Cover

 [Next]

cover
Copyright© 2000 by Microsoft Corporation


LOC Page

 [Previous] [Next]

PUBLISHED BY
Microsoft Press
A Division of Microsoft Corporation
One Microsoft Way
Redmond, Washington 98052-6399

Copyright © 2000 by Microsoft Corporation

All rights reserved. No part of the contents of this book may be reproduced or transmitted in any form or by any means without the written permission of the publisher.

Library of Congress Cataloging-in-Publication Data

Microsoft Encyclopedia of Networking / Microsoft Corporation.

        p.   cm.

    Includes index.

    ISBN 0-7356-0573-4

     1. Computer networks--Encyclopedias.    I. Microsoft Corporation.

    TK5102 .M527  2000

    004.6'03--dc21                                                           00-024947

Printed and bound in the United States of America.

1 2 3 4 5 6 7 8 9 WCWC 5 4 3 2 1 0

Distributed in Canada by Penguin Books Canada Limited.

A CIP catalogue record for this book is available from the British Library.

Microsoft Press books are available through booksellers and distributors worldwide. For further information about international editions, contact your local Microsoft Corporation office or contact Microsoft Press International directly at fax (425) 936-7329. Visit our Web site at mspress.microsoft.com. Send comments to mspinput@microsoft.com

Macintosh is a registered trademark of Apple Computer, Inc. Intel is a registered trademark of Intel Corporation. Active Channel, Active Desktop, Active Directory, Active Platform, ActiveX, Authenticode, BackOffice, DirectX, DriveSpace, FoxPro, FrontPage, IntelliMirror, IntelliSense, JScript, Microsoft, Microsoft Press, MSDN, MS-DOS, MSN, NetMeeting, NetShow, Outlook, PowerPoint, Visual Basic, Visual C++, Visual FoxPro, Visual InterDev, Visual J++, WebTV, Win32, Windows, and Windows NT are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries. Other product and company names mentioned herein may be the trademarks of their respective owners.

Unless otherwise noted, the example companies, organizations, products, people, and events depicted herein are fictitious. No association with any real company, organization, product, person, or event is intended or should be inferred.

Acquisitions Editor: Juliana Aldous

Project Editor: Maureen Williams Zimmerman

Technical Editor: Team TechEd


 [Previous] [Next]

Dedicated to Bill Gates, someone I consider to be one of history's leading innovators and the man who made it possible for ordinary people to utilize the incredible power of the PC.


Acknowledgments

It takes more than just an author to write a book—especially a book like the Microsoft Encyclopedia of Networking. So I’d like to take a moment to acknowledge various individuals who contributed their talent and expertise to making this book a success.

First, thanks to the contributing authors, who are all friends of mine and colleagues in the IT profession. Thank you for giving your valuable time and energy to help with this project. These people are

  • Anthony Bergen (B.Sc., MCSE), senior technical analyst with The North West Company

  • Changrong Li (M.Sc.), senior Firmware designer for Nortel Networks

  • John M. Nordien (M.Eng., CCNA, CNE, MCP), network consultant for Networkplace

  • Marshall Ruskin (B.Sc., MCSE), intranet architect for Department of National Defense, Canada

  • Michelle Painchaud (CPSA), business development manager for Beyond Excellence

  • Mehrab Behrouzian (MCSE, MCT), network specialist for Hadeed, Saudi Arabia

  • Sheldon Dyck (MCSE, MCT), network administrator for Communications Audit Group

  • Zhonghua Zhang (M.Sc.), software engineer for Northern Telecom Broadband Wireless Access

Next, thanks to all my editors at Microsoft Press. Thank you for your suggestions and advice, your patience and persistence, your hard work and your perseverance. Thanks especially to three key individuals:

  • Juliana Aldous, acquisitions editor, who worked with me in the initial stages of this project and helped provide momentum to get it on the road

  • Tracy Thomsic, content manager, who helped me with important planning and organizational issues once the book was starting to take shape

  • Maureen Zimmerman, project editor, who daily managed the team of technical editors, manuscript editors, and graphic artists who made this book possible

Special thanks also to Team TechEd, the technical editors at Microsoft Press who scrutinized each word of the manuscript, weeding out inaccuracies and errors, suggesting additions and corrections, and supplying their own material when my expertise was stretched to its limit, which it often was. By name these wonderful individuals are

  • Brian Johnson

  • Dail Magee Jr.

  • Donnie Cameron

  • Jean Ross

  • Jim Fuchs

  • Julia Xiao

  • Marc Young

  • Mary DeJong

  • Marzena Makuta

  • Michael Hochberg

  • Robert Lyon

  • Steve Perry

Thanks also to the manuscript editors and copy editors at Microsoft Press who turned my geek speech into human-readable English, and to the graphic artists at Microsoft Press who transformed my chicken-scrawl drawings into snazzy technical art.

And thanks to the following individuals and their companies for graciously contributing materials that have been helpful in researching various topics for this book:

  • Microsoft Corporation ( www.microsoft.com )

  • Windows NT Magazine ( www.winntmag.com )

  • Network Magazine ( www.networkmagazine.com )

  • Black Box Corporation ( www.blackbox.com )

Thanks also to Gerry and Phil at Copperfield’s Computer Books ( www.copperfields.com ), the terrific computer bookstore located in the center of North America, who have graciously let me use their huge selection of books and magazines as a library for doing research for this book.

Thanks to Orlando and Maria, the proprietors of Ciao’s Café here in Winnipeg, Canada, whose terrific espresso kept me running while writing this book. Thanks for taking such pride in your business and for providing an island of old-world civility in the midst of today’s greedy, glitzy world. Thanks also to Tony, the proprietor of North Garden Chinese Restaurant, whose top-quality dishes also kept me going throughout this project. Definitely the best Chinese food in Winnipeg!

Thanks heaps to my agent, David L. Rogelberg of Studio B Productions, Inc. ( www.studiob.com ) and his wife, Sherry, for helping me sell my initial proposal for this project and for helping me become the moderately successful author that I am today.

Thanks also to Rhonda Boresky of Escape Communications Corp. ( www.escape.ca ) for providing Internet services for my company, MTIT Enterprises ( www.mtit.com ).

Finally and most important, thanks to my wonderful wife and business partner, Ingrid, who invested many long hours in research that helped make this book a reality. You’re terrific, Schatz!


Introduction

Welcome to the Microsoft Encyclopedia of Networking, a survey of computer networking concepts, technologies, and services. This work is intended to be a comprehensive, accurate, and timely resource for students, system engineers, network administrators, IT implementers, and computing professionals from all walks of life. Before I outline its scope of coverage, however, I’ll ask a simple question that surprisingly has no easy answer: What is networking?

What Is Networking?

In the simplest sense, networking means connecting computers so that they can share files, printers, applications, and other computer-related resources. The advantages of networking computers together are pretty obvious:

  • Users can save their important files and documents on a file server, which is more secure than storing them on their workstations because a file server can be backed up in a single operation.

  • Users can share a network printer, which costs much less than having a locally attached printer for each user’s computer.

  • Users can share groupware applications running on application servers, which enables users to share documents, send messages, and collaborate directly.

  • The job of administering and securing a company’s computer resources is simplified since they are concentrated on a few centralized servers.

This definition of networking focuses on the basic goals of networking computers: increased manageability, security, efficiency, and cost-effectiveness over non-networked systems. We could also focus on the different types of networks:

  • Local area networks (LANs), which can range from a few desktop workstations in a small office/home office (SOHO) to several thousand workstations and dozens of servers deployed throughout dozens of buildings on a university campus or in an industrial park

  • Wide area networks (WANs), which might be a company’s head office linked to a few branch offices or an enterprise spanning several continents with hundreds of offices and subsidiaries

  • The Internet, the world’s largest network and the “network of networks”

We could also focus on the networking architectures in which these types of networks can be implemented:

  • Peer-to-peer networking, which might be implemented in a workgroup consisting of computers running Microsoft Windows 98 or Windows 2000 Professional

  • Server-based networking, which might be based on the domain model of Microsoft Windows NT, the domain trees and forests of Active Directory in Windows 2000, or another architecture such as Novell Directory Services (NDS) for Novell NetWare

  • Terminal-based networking, which might be the traditional host-based mainframe environment; the UNIX X Windows environment; the terminal services of Windows NT 4, Server Enterprise Edition; Windows 2000 Advanced Server; or Citrix MetaFrame

Or we could look at the networking technologies used to implement each networking architecture:

  • LAN technologies such as Ethernet, ARCNET, Token Ring, Banyan Vines, Fast Ethernet, Gigabit Ethernet, and Fiber Distributed Data Interface (FDDI)

  • WAN technologies such as Integrated Services Digital Network (ISDN), T1 leased lines, X.25, frame relay, Synchronous Optical Network (SONET), Digital Subscriber Line (DSL), and Asynchronous Transfer Mode (ATM)

  • Wireless communication technologies, including cellular systems such as Global System for Mobile Communications (GSM), Code Division Multiple Access (CDMA), Personal Communications Services (PCS), and infrared systems based on the standards developed by the Infrared Data Association (IrDA)

We could also consider the hardware devices that are used to implement these technologies:

  • LAN devices such as repeaters, concentrators, bridges, hubs, switches, routers, and Multistation Access Units (MAUs)

  • WAN devices such as modems, ISDN terminal adapters, Channel Service Units (CSUs), Data Service Units (DSUs), packet assembler/disassemblers (PADs), frame relay access devices (FRADs), multiplexers (MUXes), and inverse multiplexers (IMUXes)

  • Equipment for organizing, protecting, and troubleshooting LAN and WAN hardware, such as racks, cabinets, surge protectors, line conditioners, uninterruptible power supplies (UPS’s), KVM switches, and cable testers

  • Cabling technologies such as coaxial cabling, twinax cabling, twisted-pair cabling, fiber-optic cabling, and associated equipment such as connectors, patch panels, wall plates, and splitters

  • Unguided media technologies such as infrared communication, wireless cellular networking, and satellite networking, and their associated hardware

  • Data storage technologies such as RAID, network-attached storage (NAS), and storage area networks (SANs), and the technologies used to connect them, such as Small Computer System Interface (SCSI) and Fibre Channel

  • Technologies for securely interfacing private corporate networks with unsecured public ones, such as firewalls, proxy servers, and packet-filtering routers

  • Technologies for increasing availability and reliability of access to network resources, such as clustering, caching, load balancing, and fault-tolerant technologies

  • Network management technologies such as the Simple Network Management Protocol (SNMP) and Remote Network Monitoring (RMON)

On a more general level, networking also involves the standards and protocols that underlie the technologies and hardware mentioned, including the Open Systems Interconnection (OSI) networking model of the International Organization for Standardization (ISO); the X-series, V-series, and G-series standards of the International Telecommunication Union (ITU); Project 802 of the Institute of Electrical and Electronics Engineers (IEEE); the Requests for Comments (RFCs) of the Internet Engineering Task Force (IETF); and others from the World Wide Web Consortium (W3C), the ATM Forum, and the Gigabit Ethernet Alliance.

Other standards and protocols include the following:

  • LAN protocols such as NetBEUI, IPX/SPX, TCP/IP, and AppleTalk

  • WAN protocols such as Serial Line Internet Protocol (SLIP), Point-to-Point Protocol (PPP), Point-to-Point Tunneling Protocol (PPTP), and Layer 2 Tunneling Protocol (L2TP)

  • Protocols developed within mainframe computing environments, such as Systems Network Architecture (SNA), Advanced Program-to-Program Communications (APPC), Synchronous Data Link Control (SDLC), and High-level Data Link Control (HDLC)

  • Routing protocols such as the Routing Information Protocol (RIP), Interior Gateway Routing Protocol (IGRP), Open Shortest Path First (OSPF) Protocol, and Border Gateway Protocol (BGP)

  • Internet protocols such as the Hypertext Transfer Protocol (HTTP), File Transfer Protocol (FTP), Network News Transfer Protocol (NNTP), and the Domain Name System (DNS)

  • Electronic messaging protocols such as X.400, Simple Mail Transfer Protocol (SMTP), and Post Office Protocol version 3 (POP3)

  • Directory protocols such as X.500 and Lightweight Directory Access Protocol (LDAP)

  • Security protocols such as Password Authentication Protocol (PAP), Challenge Handshake Authentication Protocol (CHAP), X.509 digital certificates, Kerberos v5, and the various PKCS standards

  • Serial interface standards such as RS-232, RS-422/423, RS-485, V.35, and X.21

We could dig still deeper into the technologies and talk about the fundamental engineering concepts that underlie networking services and technologies, including

  • Impedance, attenuation, shielding, near-end crosstalk (NEXT), and other characteristics of cabling systems

  • Signals and how they can be multiplexed using time-division, frequency-division, statistical, and other multiplexing techniques

  • Bandwidth, throughput, latency, jabber, jitter, backbone, handshaking, hop, dead spots, dark fiber, and late collisions

  • Balanced vs. unbalanced signals, baseband vs. broadband transmission, data communications equipment (DCE) vs. data terminal equipment (DTE), circuit switching vs. packet switching, connection-oriented vs. connectionless communication, unicast vs. multicast and broadcast, point-to-point vs. multipoint links, direct sequencing vs. frequency hopping methods, and switched virtual circuit (SVC) vs. permanent virtual circuit (PVC)

We could also look at who provides networking technologies (especially WAN technologies):

  • Internet service providers (ISPs), application service providers (ASPs), integrated communications providers (ICPs), and so on

  • The central office (CO) of the local telco (through an existing local loop connection), a cable company, or a wireless networking provider

  • Local exchange carriers (LECs) or Regional Bell Operating Companies (RBOCs) through their points of presence (POPs) and Network Access Points (NAPs)

  • Telecommunications service providers that supply dedicated leased lines, circuit-switched connections, or packet-switching services

We could also look at the vendor-specific software technologies that make computer networking possible (and useful):

  • Powerful network operating systems (NOS’s) such as Windows NT and Windows 2000, Novell NetWare, various flavors of UNIX, and free operating systems such as Linux and FreeBSD

  • Specialized operating systems such as Cisco Systems’ Internetwork Operating System (IOS), which runs on Cisco routers

  • Directory systems such as the domain-based Windows NT Directory Services (NTDS) for Windows NT, Active Directory in Windows 2000, and Novell Directory Services (NDS) for Novell NetWare

  • File systems such as NTFS on Windows platforms and distributed file systems such as the Network File System (NFS) developed by Sun Microsystems

  • Programming languages and architectures for distributed computing, such as the C and Java languages, ActiveX and Jini technologies, Hypertext Markup Language (HTML) and Extensible Markup Language (XML), the Distributed Component Object Model (DCOM) and COM+, and Remote Procedure Calls (RPCs) and other forms of interprocess communication (IPC)

  • Tools and utilities for integrating technologies from different vendors in a heterogeneous networking environment, such as Gateway Services for NetWare (GSNW), Services for Macintosh, Services for UNIX on the Windows NT and Windows 2000 platforms, and Microsoft SNA Server for connectivity with mainframe systems

On a more detailed level, we could look at the tools and utilities that you can use to administer various NOS’s and their networking services and protocols, including the following:

  • Microsoft Management Console (MMC) and its administrative snap-ins in Windows 2000 or the utilities in the Administrative Tools program group in Windows NT

  • TCP/IP command-line utilities such as ping, ipconfig, traceroute, arp, netstat, nbtstat, finger, and nslookup

  • Platform-specific command-line utilities such as the Windows commands for batch administration (including the at command, which you can use with ntbackup to perform scheduled network backups of Windows NT servers)

  • Cross-platform scripting languages that can be used for system and network administration, including JavaScript, VBScript, and Perl

We could also look at applications that are network-aware, such as the Microsoft BackOffice network applications suite that includes Microsoft Exchange Server, Microsoft SQL Server, Microsoft SNA Server, and Microsoft Proxy Server. We could look at some of the terminology and technologies associated with these applications, how the software is licensed, and the GUI or command-line tools used to administer them.

As you can see, there’s more to networking than hubs and cables. In fact, the field of computer networking is almost overwhelming in its scope and complexity, and one could spend a lifetime studying only one small aspect of it. But it hasn’t always been this way. Let’s take a look at how we got to this point.

The History of Networking

Because networking is such a broad and complex field, no single event represents its point of origin. We can think of the 1960s as the early period, however, because that’s when the digital computer began to significantly affect the lives of ordinary individuals and the operations of businesses and governments. For example, during that decade the Internal Revenue Service (IRS) began to use mainframe computers to process tax returns. In this section, we’ll survey the development of networking and related communication technologies and standards from the 1960s through the 1990s.

1960s

In the 1960s, computer networking was essentially synonymous with mainframe computing and telephony services, and the distinction between local and wide area networks did not yet exist. Mainframes were typically “networked” to a series of dumb terminals with serial connections running on RS-232 or some other electrical interface. If a terminal in one city needed to connect with a mainframe in another city, a 300-baud long-haul modem would use the existing analog Public Switched Telephone Network (PSTN) to form the connection. The technology was primitive indeed, but it was an exciting time nevertheless.

The quality and reliability of the PSTN increased significantly in 1962 with the introduction of pulse code modulation (PCM), which converted analog voice signals into digital sequences of bits. DS0 (Digital Signal Zero) became the basic 64-Kbps channel, and the entire hierarchy of the digital telephone system was soon built on this foundation. Next, a device called the channel bank was introduced. It took 24 separate DS0 channels and combined them using time-division multiplexing (TDM) into a single 1.544-Mbps channel called DS1 or T1. (In Europe, 30 DS0 channels were combined to make E1.) When the backbone of the Bell system became digital, transmission characteristics improved due to higher quality and less noise. This was eventually extended all the way to local loop subscribers using ISDN. The first commercial touch-tone phone was also introduced in 1962.

The first communication satellite, Telstar, was launched in 1962. This technology did not immediately affect the networking world because of the latency of satellite links compared to undersea cable communications, but it eventually surpassed transoceanic underwater telephone cables (which were first deployed in 1965 and could carry 130 simultaneous conversations) in carrying capacity. In fact, in 1960 scientists at Bell Laboratories transmitted a communication signal coast to coast across the United States by bouncing it off the moon. Unfortunately, the moon wouldn’t sit still! By 1965, the first commercial communication satellites (such as Early Bird) were deployed.

Interestingly, in 1961 the Bell system proposed a new telecommunications service called TELPAK, which it claimed would lead to an “electronic highway” for communication, but it never pursued the idea. Could this have been a portent of the “information superhighway” of the 1990s?

The year 1969 brought an event whose full significance was not realized until more than two decades later: the development of the ARPANET packet-switching network. ARPANET was a project of the U.S. Department of Defense’s Advanced Research Projects Agency (ARPA), which became DARPA in 1972. Similar efforts were underway in France and the United Kingdom, but the U.S. project evolved into the present-day Internet. (France’s MINTEL packet-switching system, which was based on the X.25 protocol and which aimed to bring data networking into every home, did take off in 1984 when the French government started giving away MINTEL terminals; by the early 1990s, more than 20 percent of the country’s population was using it.) The original ARPANET connected computers at Stanford, the University of California at Los Angeles (UCLA), the University of California at Santa Barbara (UCSB), and the University of Utah, with the first node installed at UCLA’s Network Measurements Center. A year later, Harvard, the Massachusetts Institute of Technology (MIT), and a few other institutions were added, but few of those involved realized that this technical experiment would someday profoundly affect business and society.

1969 also saw the publication of the first RFC document. The informal RFC process evolved into the primary means of directing the evolution of the Internet. The first RFC document specified the Network Control Protocol (NCP), which became the first transport protocol of ARPANET.

That same year, Bell Laboratories developed the UNIX operating system, a multitasking, multi-user NOS that became popular in academic computing environments in the 1970s. A typical UNIX system in 1974 was a PDP-11 minicomputer with dumb terminals attached. In a configuration with 768 KB of magnetic core memory and a couple of 200-MB hard disks, the cost of such a system would have been around $40,000. (I remember working on a UNIX system in the Cyclotron lab of my university’s physics department, feeding in bits of punched tape and watching lights flash. It was awesome.)

Standards for computer networking also evolved during the 1960s. In 1962, IBM introduced the first 8-bit character encoding system, called Extended Binary-Coded Decimal Interchange Code (EBCDIC). A year later, the competing American Standard Code for Information Interchange (ASCII) was introduced. ASCII ultimately won out over EBCDIC even though EBCDIC was 8-bit while ASCII was only 7-bit. ASCII was formally standardized by the American National Standards Institute (ANSI) in 1968. ASCII was first used in serial transmission between mainframe hosts and dumb terminals in mainframe computing environments, but it was eventually extended to all areas of computer and networking technologies.

Other developments in the 1960s included the release in 1964 of IBM’s powerful System/360 mainframe computing environment, which was widely implemented in government, university, and corporate computing centers. In 1966, IBM introduced the first disk storage system, which employed 50 two-foot-wide metal platters and had a storage capacity of 5 MB. IBM created the first floppy disk in 1967. In 1969, Intel released a RAM chip that stored 1 KB of information, which at the time was an amazing feat of engineering.

1970s

While the 1960s were the decade of the mainframe, the 1970s gave rise to Ethernet, which today is by far the most popular LAN technology. Ethernet was born in 1973 in Xerox’s research lab in Palo Alto, California. (An earlier experimental network called ALOHAnet was developed in 1970 at the University of Hawaii.) The original Xerox networking system was known as X-wire and worked at 2.94 Mbps. X-wire was experimental and was not used commercially, although a number of Xerox Alto workstations for word processing were networked together in the White House using X-wire during the Carter administration. In 1979, Digital Equipment Corporation (DEC), Intel, and Xerox formed the DIX consortium and developed the specification for standard 10-Mbps Ethernet, or thicknet, which was published in 1980. This standard was revised and additional features were added in the following decade.

The conversion of the backbone of the Bell telephone system to digital circuitry continued during the 1970s and included the deployment in 1974 of the first digital data service (DDS) circuits (then called the Dataphone Digital Service). DDS formed the basis of the later deployment of ISDN and T1 lines to customer premises. AT&T installed its first digital switch in 1976.

In wide area networking, a new telecommunications service called X.25 was deployed toward the end of the decade. This system was packet-switched, in contrast to the circuit-switched PSTN, and later evolved into public X.25 networks such as GTE’s Telenet Public Packet Distribution Network (PDN), which later became Sprintnet. X.25 was widely deployed in Europe, where it still maintains a large installed base.

In 1970, the Federal Communications Commission (FCC) announced the regulation of the fledgling cable television industry. (Cable TV remained primarily a broadcast technology for delivering entertainment to residential homes until the mid-1990s, when technologies began to be developed to enable it to carry broadband Internet access services to residential subscribers.)

Despite all the technological advances, however, telecommunications services in the 1970s remained unintegrated, with voice, data, and entertainment carried on different media. Voice was carried by telephone, which was still analog at the customer premises; entertainment was broadcast using radio and television technologies; and data was usually carried over RS-232 or Binary Synchronous Communication (BSC) serial connections between dumb terminals and mainframes (or, for remote terminals, long-haul modem connections over analog telephone lines).

The 1970s were also notable for the birth of ARPANET, the precursor to the Internet, which was first deployed in 1969 and grew throughout the decade as additional hosts were added at various universities and government institutions. By 1971, the network had 19 nodes, mostly consisting of a mix of PDP-8, PDP-11, IBM S/360, DEC-10, Honeywell, and other mainframe and minicomputer systems linked together. The initial design of ARPANET called for a maximum of 265 nodes, which seemed like a distant target in the early 1970s. The initial protocol used on this network was NCP, but it was replaced in 1982 by the more powerful TCP/IP protocol suite. In 1975, the administration of ARPANET came under the authority of the Defense Communications Agency.

ARPANET protocols and technologies continued to evolve using the informal RFC process. In 1972, the Telnet protocol was defined in RFC 318, followed by FTP in 1973 (RFC 454). ARPANET became an international network in 1973 when nodes were added at the University College of London in the United Kingdom and at the Royal Radar Establishment in Norway. ARPANET even established an experimental wireless packet-switching radio service in 1977, which two years later became the Packet Radio Network (PRNET).

Meanwhile, in 1974 the first specification for the Transmission Control Protocol (TCP) was published. Progress on the TCP/IP protocols continued through several iterations until the basic TCP/IP architecture was formalized in 1978, but it wasn’t until 1983 that ARPANET started using TCP/IP as its primary networking protocol instead of NCP.

1977 saw the development of UNIX to UNIX Copy (UUCP), a protocol and tool for sending messages and transferring files on UNIX-based networks. An early version of the USENET news system using UUCP was developed in 1979. (NNTP came much later, in 1987.)

In 1979, the first commercial cellular phone system began operation in Japan. This system was analog in nature, worked in the 800-MHz and 900-MHz frequency bands, and was based on a concept developed in 1947 at Bell Laboratories.

An important standard to emerge in the 1970s was the public-key cryptography scheme developed in 1976 by Whitfield Diffie and Martin Hellman. This scheme underlies the Secure Sockets Layer (SSL) protocol developed by Netscape Communications, which is now the predominant scheme for ensuring privacy and integrity of financial and other transactions over the World Wide Web (WWW). Without this scheme, popular e-business sites such as Amazon.com would have a hard time attracting customers.

In miscellaneous developments in the 1970s, IBM researchers invented the relational database in 1970, a set of conceptual technologies that has become the foundation of today’s distributed application environments. In 1971, IBM demonstrated the first speech recognition technologies, which have since led to automated call handling systems in customer service centers. IBM developed the concept of the virtual machine in 1972 and created the first sealed disk drive (the Winchester) in 1973. IBM introduced SNA for networking in its mainframe computing environment in 1974. In 1971, Intel released its first microprocessor, a 4-bit processor called the 4004 that ran at a clock speed of 108 kHz. The online service CompuServe was launched in 1979.

The first personal computer, the Altair, went on the market as a kit in 1975. The Altair was based on the Intel 8080, an 8-bit processor, and came with 256 bytes of memory, toggle switches, and LED lights. While the Altair was basically for hobbyists, the Apple II from Apple Computer, which was introduced in 1977, was much more. A typical Apple II system, which was based on the Motorola 6502 8-bit processor, had 4 KB of RAM, a keyboard, a motherboard with expansion slots, built-in BASIC in ROM, and color graphics. The Apple II quickly became the standard desktop system in schools and other educational institutions. A physics classroom I taught in had one all the way into the early 1990s (limited budget!). However, it wasn’t until the introduction of the IBM Personal Computer (PC) in 1981 that the full potential of personal computers began to be realized, especially in businesses.

In 1975, Bill Gates and Paul Allen licensed their BASIC programming language to MITS, the manufacturer of the Altair. BASIC was the first computer language program specifically written for a personal computer. Gates and Allen coined the name “Micro-soft” for their business partnership, and they officially registered it as a trademark the following year. Microsoft went on to license BASIC to other personal computing platforms such as the Commodore PET and the TRS-80.

1980s

In the 1980s, the growth of client/server LAN architectures continued while that of mainframe computing environments declined. The advent of the IBM PC in 1981 and the standardization and cloning of this system led to an explosion of PC-based LANs in businesses and corporations around the world, especially with the release of the IBM PC AT system in 1984. The number of PCs in use grew from 2 million in 1981 to 65 million in 1991. Novell, which came on the scene in 1983, became a major player in file and print servers for LANs with its Novell NetWare NOS.

However, the biggest development in the area of LAN networking in the 1980s was the evolution and standardization of Ethernet. While the DIX consortium worked on standard Ethernet in the late 1970s, the IEEE began its Project 802 initiative, which aimed to develop a single, unified standard for all LANs. When it became clear that this was impossible, 802 was divided up into a number of working groups, with 802.3 focusing on Ethernet, 802.4 on Token Bus, and 802.5 on Token Ring technologies and standards. The work of the 802.3 group culminated in 1983 with the release of the IEEE 802.3 10Base5 Ethernet standard, which was called thicknet because it used thick coaxial cable and which was virtually identical to the work already done by DIX. In 1985, this standard was extended as 10Base2 to include thin coaxial cable, commonly called thinnet.

Throughout most of the 1980s, coaxial cable was the primary form of premise cabling in Ethernet implementations. However, a company called SynOptics Communications developed a product called LattisNet for transmitting 10-Mbps Ethernet over twisted-pair wiring using a star-wired topology connected to a central hub or repeater. This wiring was cheaper than coaxial cable and was similar to the wiring used in residential and business telephone wiring systems. LattisNet was such a commercial success that the 802.3 committee approved a new standard 10BaseT for Ethernet over twisted-pair wiring in 1990. 10BaseT soon superseded the coaxial forms of Ethernet because of its ease of installation and because it could be installed in a hierarchical star-wired topology that was a good match for the architectural topology of multistory buildings.

In other Ethernet developments, fiber-optic cabling, which was first developed in the early 1970s by Corning, found its first commercial networking application in Ethernet networking in 1984. (The technology itself was standardized as 10BaseFL in the early 1990s.) Ethernet bridges became available in 1984 from DEC and were used both to connect separate Ethernet LANs to make large networks and to reduce traffic bottlenecks on overloaded networks by splitting them into separate segments. Routers could be used for similar purposes, but bridges generally offered better price and performance during the 1980s, as well as reduced complexity. Again, market developments preceded standards as the IEEE 802.1D Bridge Standard, which was initiated in 1987, was not standardized until 1990.

The development of the Network File System (NFS) by Sun Microsystems in 1985 resulted in a proliferation of diskless UNIX workstations with built-in Ethernet interfaces that also drove the demand for Ethernet and accelerated the deployment of bridging technologies for segmenting LANs. Also around 1985, increasing numbers of UNIX machines and LANs were connected to ARPANET, which until that time had been mainly a network of mainframe and minicomputer systems. The first UNIX implementation of TCP/IP came in v4.2 of Berkeley’s BSD UNIX, from which other vendors such as Sun Microsystems quickly ported their versions of TCP/IP. Although PC-based LANs became popular in business and corporate settings during the 1980s, UNIX continued to dominate in academic and professional high-end computing environments as the mainframe environment declined.

IBM introduced its Token Ring networking technology in 1985 as an alternative LAN technology to Ethernet. IBM had submitted its technology to the IEEE in 1982 and it was standardized by the 802.5 committee in 1984. IBM soon supported the integration of Token Ring with its existing SNA networking services and protocols for IBM mainframe computing environments. The initial Token Ring specifications delivered data at 1 Mbps and 4 Mbps, but it dropped the 1-Mbps version in 1989 when it introduced a newer 16-Mbps version. Interestingly, no formal IEEE specification exists for 16-Mbps Token Ring—vendors simply adopted IBM’s technology for the product. Since then, advances in the technology have included high-speed 100-Mbps Token Ring and Token Ring switching technologies that support virtual LANs (VLANs). Nevertheless, Ethernet remains far more widely deployed than Token Ring.

Also in the field of local area networking, the American National Standards Institute (ANSI) began standardizing the specifications for Fiber Distributed Data Interface (FDDI) in 1982. FDDI was designed to be a high-speed (100 Mbps) fiber-optic networking technology for LAN backbones on campuses and industrial parks. The final FDDI specification was completed in 1988, and deployment in campus LAN backbones grew during the late 1980s and the early 1990s.

In 1983, the ISO developed an abstract seven-layer model for networking called the Open Systems Interconnection (OSI) reference model. Although some commercial networking products were developed based on OSI protocols, the standard never really took off, primarily because of the predominance of TCP/IP. Other standards from the ISO and ITU that emerged in the 1980s included the X.400 electronic messaging standards and the X.500 directory recommendations.

A major event in the telecommunications and WAN field in 1984 was the divestiture of AT&T as the result of a seven-year antitrust suit brought against AT&T by the U.S. Justice Department. AT&T’s 22 Bell operating companies were formed into seven new RBOCs. This meant the end of the Bell system, but the RBOCs soon formed Bellcore as a telecommunications research establishment to replace the defunct Bell Laboratories. The United States was divided into Local Access and Transport Areas (LATAs), with intra-LATA communication handled by local exchange carriers (the Bell Operating Companies or BOCs) and inter-LATA communication handled by inter-exchange carriers (IXCs) such as AT&T, MCI, and Sprint.

The result of the breakup for wide area networking was increased competition, which led to new technologies and lower costs. One of the first effects was the offering of T1 services to subscribers in 1984. Until then, this technology had been used only for backbone circuits for long-distance communication. New hardware devices were offered to take advantage of the increased bandwidth, especially high-speed T1 multiplexers, or muxes, that could combine voice and data into a single communication stream. 1984 also saw the development of digital Private Branch Exchange (PBX) systems by AT&T, bringing new levels of power and flexibility to corporate subscribers.

The Signaling System #7 (SS7) digital signaling system was first deployed within the PSTN in the 1980s, first in Sweden and later in the United States. SS7 made new telephony services such as caller ID, call blocking, and automatic callback available to subscribers.

The first trials of ISDN, a fully digital telephony technology that runs on existing copper local loop lines, began in Japan in 1983 and in the United States in 1987. (All major metropolitan areas in the United States have since been upgraded to make ISDN available to those who want it, but ISDN has not caught on as a WAN technology as much as it has in Europe.)

In the 1980s, fiber-optic cabling emerged as a networking and telecommunications medium. In 1988, the first fiber-optic transatlantic undersea cable was laid and increased the capacity of the transatlantic communication system manyfold.

The 1980s also saw the standardization of SONET technology, a high-speed physical layer (PHY) fiber-optic networking technology developed from time-division multiplexing (TDM) digital telephone system technologies. Before the divestiture of AT&T in 1984, local telephone companies had to interface their own TDM-based digital telephone systems with proprietary TDM schemes of long-distance carriers, and incompatibilities created many problems. This provided the impetus for creating the SONET standard, which was finalized in 1989 through a series of CCITT (anglicized as International Telegraph and Telephone Consultative Committee) standards called G.707, G.608, and G.709. By the mid-1990s, almost all long-distance telephone traffic in the United States used SONET on trunk lines as the physical interface.

The 1980s brought the first test implementations of Asynchronous Transfer Mode (ATM) high-speed cell-switching technologies, which could use SONET as the physical interface. Many concepts basic to ATM were developed in the early 1980s at the France-Telecom laboratory in Lannion, France, particularly the PRELUDE project, which demonstrated the feasibility of end-to-end ATM networks running at 62 Mbps. The 53-byte ATM cell format was standardized by the CCITT in 1988, and the new technology was given a further push with the creation of the ATM Forum in 1991. Since then, use of ATM has grown significantly in telecommunications provider networks and has become a high-speed backbone technology in many enterprise-level networks around the world. However, the vision of ATM on users’ desktops has not been realized because of the emergence of cheaper Fast Ethernet and Gigabit Ethernet LAN technologies, and because of the complexity of ATM itself.

The convergence of voice, data, and broadcast information remained a distant vision throughout the 1980s and was even set back because of the proliferation of networking technologies, the competition between cable and broadcast television, and the slow adoption of residential ISDN. New services did appear, however, especially in the area of commercial online services such as America Online (AOL), CompuServe, and Prodigy, which offered consumers e-mail, bulletin board systems (BBS’s), and other services.

A significant milestone in the development of the Internet occurred in 1982 when the networking protocol of ARPANET was switched from NCP to TCP/IP. On January 1, 1983, NCP was turned off permanently—anyone who hadn’t migrated to TCP/IP was out of luck. ARPANET, which connected several hundred systems, was split into two parts, ARPANET and MILNET.

The first international use of TCP/IP took place in 1984 at CERN, a physics research center in Geneva, Switzerland. TCP/IP was designed to provide a way of networking different computing architectures in heterogeneous networking environments. Such a protocol was badly needed because of the proliferation of vendor-specific networking architectures in the preceding decade, including “homegrown” solutions developed at many government and educational institutions. TCP/IP made it possible to connect diverse architectures such as UNIX workstations, VMS minicomputers, and CRAY supercomputers into a single operational network. TCP/IP soon superseded proprietary protocols such as Xerox Network Systems (XNS), ChaosNet, and DECnet. It has since become the de facto standard for internetworking all types of computing systems.

CERN was primarily a research center for high-energy particle physics, but it became an early European pioneer of TCP/IP and by 1990 was the largest subnetwork of the Internet in Europe. In 1989, a CERN researcher named Timothy Berners-Lee developed the Hypertext Transfer Protocol (HTTP) that formed the basis of the World Wide Web (WWW). And all of this developed as a sidebar to the real research that was being done at CERN—slamming together protons and electrons at high speeds to see what fragments appear!

Also important to the development of Internet technologies and protocols was the introduction of the Domain Name System (DNS) in 1984. At that time, ARPANET had more than 1000 nodes, and trying to remember them by their numerical IP address was a headache. NNTP was developed in 1987, and Internet Relay Chant (IRC) was developed in 1988.

Other systems paralleling ARPANET were developed in the early 1980s, including the research-oriented Computer Science NETwork (CSNET), and the Because It’s Time NETwork (BITNET), which connected IBM mainframe computers throughout the educational community and provided e-mail services. Gateways were set up in 1983 to connect CSNET to ARPANET, and BITNET was similarly connected to ARPANET. In 1989, BITNET and CSNET merged into the Corporation for Research and Educational Networking (CREN).

In 1986, the National Science Foundation NETwork (NSFNET) was created. NSFNET networked together the five national supercomputing centers using dedicated 56-Kbps lines. The connection was soon seen as inadequate and was upgraded to 1.544-Mbps T1 lines in 1988. In 1987, NSF and Merit Networks agreed to jointly manage the NSFNET, which had effectively become the backbone of the emerging Internet. By 1989, the Internet had grown to more than 100,000 hosts, and the Internet Engineering Task Force (IETF) was officially created to administer its development. In 1990, NSFNET officially replaced the aging ARPANET and the modern Internet was born, with more than 20 countries connected.

Cisco Systems was one of the first companies in the 1980s to develop and market routers for Internet Protocol (IP) internetworks, a business that today is worth billions of dollars and is a foundation of the Internet. Hewlett-Packard was Cisco’s first customer for its routers, which were originally called gateways.

In wireless telecommunications, analog cellular was implemented in Norway and Sweden in 1981. Systems were soon rolled out in France, Germany, and the United Kingdom. The first U.S. commercial cellular phone system, which was named the Advanced Mobile Phone Service (AMPS) and operated in the 800-MHz frequency band, was introduced in 1983. By 1987, the United States had more than 1 million AMPS cellular subscribers, and higher-capacity digital cellular phone technologies were being developed. The Telecommunications Industry Association (TIA) soon developed specifications and standards for digital cellular communication technologies.

A landmark event that was largely responsible for the phenomenal growth in the PC industry (and hence the growth of the client/server model and local area networking) was the release of the first version of Microsoft’s text-based, 16-bit MS-DOS operating system in 1981. Microsoft, which had become a privately held corporation with Bill Gates as president and chairman of the board and Paul Allen as executive vice president, licensed MS-DOS 1 to IBM for its PC. MS-DOS continued to evolve and grow in power and usability until its final version, MS-DOS 6.22, which was released in 1993. One year after the first version of MS-DOS was released in 1981, Microsoft had its own fully functional corporate network, the Microsoft Local Area Network (MILAN), which linked a DEC 206, two PDP-11/70s, a VAX 11/250, and a number of MC68000 machines running XENIX. This setup was typical of heterogeneous computer networks in the early 1980s.

In 1983, Microsoft unveiled its strategy to develop a new operating system called Microsoft Windows with a graphical user interface (GUI). Version 1 of Windows, which shipped in 1985, used a system of tiled windows and could work with several applications simultaneously by switching between them. Version 2 was released in 1987 and supported overlapping windows and support for expanded memory.

Microsoft launched its SQL Server relational database server software for LANs in 1988. In its current version 7, SQL Server is an enterprise-class application that competes with other major database platforms such as Oracle and DB2. IBM and Microsoft jointly released their OS/2 operating system in 1987 and released OS/2 1.1 with Presentation Manager a year later.

In miscellaneous developments, IBM researchers developed the Reduced Instruction Set Computing (RISC) processor architecture in 1980. Apple Computer introduced its Macintosh computing platform in 1984 (the successor of its Lisa system), which introduced a windows-based GUI that became the precursor to Microsoft Windows. Apple also introduced the 3.5-inch floppy disk in 1984. CD-ROM technology was developed by Sony and Philips in 1985. (Recordable CD-R technologies were developed in 1991.) IBM released its AS/400 midrange computing system in 1988, which continues to be popular to this day.

1990s

The 1990s were a busy decade in every aspect of networking, so we’ll only touch on the highlights here. Ethernet continued to dominate LAN technologies and largely eclipsed competing technologies such as Token Ring and FDDI. In 1991, Kalpana Corporation began marketing a new form of bridge called a LAN switch, which dedicated the entire bandwidth of a LAN to a single port instead of sharing it among several ports. Later called Ethernet switches or Layer 2 switches, these devices quickly found a niche in providing dedicated high-throughput links for connecting servers to network backbones.

The rapid growth of computer networks and the rise of bandwidth-hungry applications created a need for something faster than 10-Mbps Ethernet, especially on network backbones. The first full-duplex Ethernet products, offering speeds of 20 Mbps, became available in 1992. In 1995, work began on a standard for full-duplex Ethernet; it was finalized in 1997. A more important development was Grand Junction Networks’ commercial Ethernet bus, introduced in 1992, which functioned at 100 Mbps. Spurred by this commercial advance, the 802.3 group produced the 802.3u 100BaseT Fast Ethernet standard for transmission of data at 100 Mbps over both twisted-pair copper wiring and fiber-optic cabling.

Although the jump from 10-Mbps to 100-Mbps Ethernet took almost 15 years, a year after the 100BaseT Fast Ethernet standard was released work began on a 1000-Mbps version of Ethernet popularly known as Gigabit Ethernet. Fast Ethernet was beginning to be deployed at the desktop, and this was putting enormous strain on the FDDI backbones that were deployed on many commercial and university campuses. FDDI also operated at 100 Mbps (or 200 Mbps if fault tolerance was discarded in favor of carrying traffic on the redundant ring), so a single Fast Ethernet desktop connection could theoretically saturate the capacity of the entire network backbone.

ATM, a broadband cell-switching technology used primarily in WANs and in telecommunications environments, was considered as a possible successor to FDDI for backboning Ethernet networks, and LAN emulation (LANE) was developed to carry LAN traffic such as Ethernet over ATM. However, ATM is more difficult to install and maintain than Ethernet, and a number of companies saw extending Ethernet speeds to 1000 Mbps as a way to provide network backbones with much greater capacity using technology that most network administrators were already familiar with. As a result, the 802 group called 802.3z developed a Gigabit Ethernet standard called 1000BaseX, which it released in 1998. Gigabit Ethernet is now widely deployed, and work is underway on extending Ethernet technologies to 10 Gbps. A competitor of Gigabit Ethernet for high-speed collapsed backbone interconnects, called fibre channel, was conceived by an ANSI committee in 1988 and has become a viable alternative.

The 1990s have seen huge changes in the landscape of telecommunications providers and their services. “Convergence” became a major buzzword, signifying the combining of voice, data, and broadcast information into a single medium for delivery to businesses and consumers through broadband technologies such as Broadband ISDN (B-ISDN), variants of DSL, and cable modem systems. Voice over IP (VoIP) became the avowed goal of many vendors, who promised businesses huge savings by routing voice telephone traffic over IP networks. The technology works, but the bugs are still being ironed out and deployments are still slow.

The Telecommunications Act of 1996 was designed to spur competition in all aspects of the U.S. telecommunications market by allowing the RBOCs access to long-distance services. The result has been an explosion in technologies and services, with mergers and acquisitions changing the nature of the provider landscape. The legal fallout from all this is still settling.

The first public frame relay packet-switching services were offered in North America in 1992. Companies such as AT&T and Sprint installed a network of frame relay nodes across the United States in major cities, where corporate networks could connect to the service through their local telco. Frame relay began to eat significantly into the deployed base of more expensive dedicated leased lines such as the T1 or E1 lines that businesses used for their WAN solutions, resulting in lower prices for these leased lines and greater flexibility of services. In Europe, frame relay has been deployed much more slowly, primarily because of the widespread deployment of packet-switching networks such as X.25.

The cable modem was introduced in 1996, and by the end of the decade broadband residential Internet access through cable television systems had become a strong competitor with telephone-based systems such as Asymmetric Digital Subscriber Line (ADSL) and G.Lite, another variant of DSL.

In 1997, the World Trade Organization (WTO) ratified the Information Technology Agreement (ITA), which mandated that participating governments eliminate all tariffs on information technology products by the next millennium. Other WTO initiatives promise to similarly open up telecommunications markets worldwide.

The decade saw a veritable explosion in the growth of the Internet and the development of Internet technologies. As mentioned earlier, ARPANET was replaced in 1990 by NSFNET, which by then was commonly called the Internet. At the beginning of the 1990s, the Internet’s backbone consisted of 1.544-Mbps T1 lines connecting various institutions, but in 1991 the process of upgrading these lines to 44.735-Mbps T3 circuits began. By the time the Internet Society (ISOC) was chartered in 1992, the Internet had grown to an amazing 1 million hosts on almost 10,000 connected networks. In 1993, the NSF created Internet Network Information Center (InterNIC) as a governing body for DNS. In 1995, the NSF stopped sponsoring the Internet backbone and NSFNET went back to being a research and educational network. Internet traffic in the United States was routed through a series of interconnected commercial network providers.

The first commercial Internet service providers (ISPs) emerged in the early 1990s when the NSF removed its restrictions against commercial traffic on the NSFNET. Among them were Performance Systems International (PSI), UUNET, MCI, and Sprintlink. (The first public dial-up ISP was actually The World, whose URL was www.world.std.com.) In the mid-1990s, commercial online networks such as AOL, CompuServe, and Prodigy provided gateways to the Internet to subscribers. Later in the decade, Internet deployment grew exponentially, with personal Internet accounts proliferating by the tens of millions around the world, new technologies and services developing, and new paradigms evolving for the economy and business. It’s almost too early to write about these things with suitable perspective—maybe I’ll wait until the next edition.

Many Internet technologies and protocols have come and gone quickly. Archie, an FTP search engine developed in 1990, is hardly used today. The WAIS protocol for indexing, storing, and retrieving full-text documents, which was developed in 1991, has been eclipsed by Web search technologies. Gopher, which was created in 1991, grew to a worldwide collection of interconnected file systems, but most Gopher servers have been turned off. Veronica, the Gopher search tool developed in 1992, is obviously obsolete as well. Jughead later supplemented Veronica but has also become obsolete. (There was never a Betty.)

The most obvious success story among Internet protocols has been HTTP, which, together with HTML and the system of URLs for addressing, has formed the basis of the Web. Timothy Berners-Lee and his colleagues created the first Web server (whose fully qualified DNS name was info.cern.ch) and Web browser software using the NeXT computing platform that was developed by Apple pioneer Steve Jobs. This software was ported to other platforms, and by the end of the century more than 2 million registered Web servers were running.

Lynx, a text-based Web browser, was developed in 1992, and I personally know that it was still used in some rural areas with slow Internet connections as late as 1996. Mosaic, the first graphical Web browser, was developed in 1993 by Marc Andreessen for the UNIX X Windows platform while he was a student at the National Center for Supercomputing Applications (NCSA). At that time, there were only about 50 known Web servers, and HTTP traffic amounted to only about 0.1 percent of the Internet’s traffic. Andreessen left school to start Netscape Communications, which released its first version of Netscape Navigator in 1994. Microsoft Internet Explorer 2 for Windows 95 was released in 1995 and rapidly became Netscape Navigator’s main competition. In 1995, Bill Gates announced Microsoft’s wide-ranging commitment to support and enhance all aspects of Internet technologies through innovations in the Windows platform, culminating in 1998 in Internet Explorer being completely integrated into the Windows 98 operating system. Another initiative in this direction was Microsoft’s announcement in 1996 of its ActiveX technologies, a set of tools for active content such as animation and multimedia for the Internet and the PC.

In wireless telecommunications, the work of the TIA resulted in 1991 in the first standard for digital cellular communication, the TDMA Interim Standard 54 (IS-54). Digital cellular was badly needed because the analog cellular subscriber market in the United States had grown to 10 million subscribers in 1992 and 25 million subscribers in 1995. The first tests of this technology, based on Time Division Multiple Access (TDMA) technology, took place in Dallas, Texas, and in Sweden, and were a success. This standard was revised in 1994 as TDMA IS-136, which is commonly referred to as Digital Advanced Mobile Phone Service (D-AMPS).

Meanwhile, two competing digital cellular standards also appeared. The first was the CDMA IS-95 standard for CDMA cellular systems based on spread spectrum technologies, which was first proposed by QUALCOMM in the late 1980s and was standardized by the TIA as IS-95 in 1993. Standards preceded implementation, however; it wasn’t until 1996 that the first commercial CDMA cellular systems were rolled out.

The second system was the GSM standard developed in Europe. (GSM originally stood for Groupe Spéciale Mobile.) GSM was first envisioned in the 1980s as part of the movement to unify the European economy, and the final air interface was determined in 1987 by the European Telecommunications Standards Institute (ETSI). Phase 1 of GSM deployment began in Europe in 1991. Since then, GSM has become the predominant system for cellular communication in over 60 countries in Europe, Asia, Australia, Africa, and South America, with over 135 mobile networks implemented. However, GSM implementation in the United States did not begin until 1995.

In the United States, the FCC began auctioning off portions of the 1900-MHz frequency band in 1994. Thus began the development of the higher-frequency Personal Communications System (PCS) cellular phone technologies, which were first commercially deployed in the United States in 1996.

Establishment of worldwide networking and communication standards continued apace in the 1990s. For example, in 1996 the Unicode character set, a character set that can represent any language of the world in 16-bit characters, was created, and it has since been adopted by all major operating system vendors.

In client/server networking, Novell in 1994 introduced Novell NetWare 4, which included the new Novell Directory Services (NDS), then called NetWare Directory Services. NDS offered a powerful tool for managing hierarchically organized systems of network file and print resources and for managing security elements such as users and groups.

In other developments, the U.S. Air Force launched the twenty-fourth satellite of the Global Positioning System (GPS) constellation in 1994, making possible precise terrestrial positioning using handheld satellite communication systems. RealNetworks released its first software in 1995, the same year that Sun Microsystems announced the Java programming language, which has grown in a few short years to rival C/C++ in popularity for developing distributed applications. Amazon.com was launched in 1995 and has become a colossus of cyberspace retailing in a few short years. Microsoft WebTV was introduced in 1997 and is beginning to make inroads into the residential Internet market.

Finally, the 1990s were, in a very real sense, the decade of Microsoft Windows. No other technology has had as vast an impact on ordinary computer users as Windows, which brought to homes and workplaces the power of PC computing and the opportunity for client/server computer networking. Version 3 of Microsoft Windows, which was released in 1990, brought dramatic increases in performance and ease of use over earlier versions, and Windows 3.1, released in 1992, quickly became the standard desktop operating system for both corporate and home users. Windows for Workgroups 3.1 quickly followed that same year. It integrated networking and workgroup functionality directly into the Windows operating system, allowing Windows users to use the corporate computer network for sending e-mail, scheduling meetings, sharing files and printers, and performing other collaborative tasks. In fact, it was Windows for Workgroups that brought the power of computer networks from the back room to users’ desktops, allowing them to perform tasks previously only possible for network administrators.

In 1992, Microsoft released the first beta version of its new 32-bit network operating system, Windows NT. In 1993 came MS-DOS 6, as Microsoft continued to support users of text-based computing environments. That was also the year that Windows NT and Windows for Workgroups 3.11 (the final version of 16-bit Windows) were released. In 1995 came the long-awaited release of Windows 95, a fully integrated 32-bit desktop operating system designed to replace MS-DOS, Windows 3.1, and Windows for Workgroups 3.11 as the mainstream desktop operating system for personal computing. Following in 1996 was Windows NT 4, which included enhanced networking services and a new Windows 95–style user interface. Windows 95 was superseded by Windows 98, which included full integration of Web services.

And finally, at the turn of the millennium came the long-anticipated successor to Windows NT, the Windows 2000 family of operating systems, which includes Windows 2000 Professional, Windows 2000 Server, Windows 2000 Advanced Server, and the soon-to-be-released Windows 2000 Datacenter Server. Together with Windows CE and embedded Windows NT, the Windows family has grown to encompass the full range of networking technologies, from embedded devices and personal digital assistants (PDAs) to desktop and laptop computers to heavy duty servers running the most advanced, powerful, scalable, business-critical enterprise-class applications.

The Scope of This Encyclopedia

Now that you have a good idea of what networking is and how it has evolved, you can probably guess the scope of this encyclopedia. Most of the information in this encyclopedia can be grouped into three broad categories:

  • Information about networking concepts, technologies, standards, and hardware—including such things as Ethernet, Token Ring, bandwidth, latency, hubs, switches, OSI, and X.500. This is obviously the core of the encyclopedia.

  • Information about the Internet and its standards, protocols, services, architecture, and implementation—including such things as HTTP, SMTP, Web servers, Web browsers, TCP/IP, BGP, application service provider (ASP), and so on.

  • Information about Microsoft innovations and technologies, primarily those relating to the Windows NT and Windows 2000 network operating systems and BackOffice network applications. These include such things as Active Directory, Windows Clustering, Internet Information Services (IIS), NTFS permissions, and so on. Specific operating systems, applications, and networking innovations from other vendors are also covered.

Also included are numerous entries from areas that are somewhat peripheral to networking, including programming technologies such as Java and ActiveX, cryptography standards such as DES and PKCS, and Microsoft certification programs. Networking professionals are likely to encounter many of these terms in their work and reading, and they might be important to networking professionals in the coming decade.

Who This Work Is For

This work is intended both for novices pursuing the Microsoft Certified Systems Engineer (MCSE) certification and for experienced networking professionals who want to add to their knowledge of networking, the Internet, and Microsoft technologies. MCSE is the primary networking certification for Microsoft Certified Professionals (MCPs). MCSEs are qualified to plan, implement, maintain, and support information systems in a wide range of computing environments using Windows NT, Windows 2000, and BackOffice. In 1999, the number of individuals worldwide with the MCSE designation numbered 143,000.

Shipments of Windows NT Server have grown to more than 2 million a year, making Windows NT Server the world’s most popular network operating system. With this growth expected to continue with the release of Windows 2000 Server, the need for education and training of both new and existing MCSEs is great. Of course, many other professionals will find this work useful, including consultants, IT planners, system integrators, teachers, service providers, and those who market and sell Microsoft solutions, products, and services.

About the Entries

The entries in this work are, of course, in alphabetical order and range from short entries of a few lines to ones several pages long. Longer entries typically have an explanatory “How It Works” section, which elucidates key concepts. Drawings or screenshots are included in many entries to help explain key concepts. Where applicable, examples are provided under the heading “Examples.” Additional material not related to the core explanation is consigned to a “Note” section, and practical recommendations or suggestions about implementing networking technologies are listed in “Tip” sections. Cross-references to related entries are identified by the heading “See also” at the end of an entry. Links to URLs where you can find further information are listed under the heading “On the Web.”

I have made every effort to minimize technical jargon and have strived for accuracy and timeliness. However, technologies change so quickly in the networking field that a portion of the material will inevitably become outdated very soon. Microsoft Press provides updates and corrections for its books and other products on the Web at http://mspress.microsoft.com/support/.

If you have comments, question, or ideas regarding this encyclopedia, please send them to Microsoft Press via e-mail at Mspinput@microsoft.com or at the following postal address:

Microsoft Press
Attn: Microsoft Encyclopedia of Networking Editor
One Microsoft Way
Redmond, WA 98052-6399

Please note that product support is not offered through the above addresses.

I wish you well in all your networking endeavors and hope that you find this a useful and professional reference work.

Mitch Tulloch, MCT, MCSE www.mtit.com


Numbers and Symbols

>

A command-line symbol used for redirection that is supported by all versions of Microsoft Windows. Redirection allows you to direct the output of a Windows command to something other than the screen. The > symbol is generally referred to as the redirection symbol.

How It Works

Normally, Windows sends the output of a command to the screen. For example, suppose you open a command prompt on a machine running Windows 2000 Server with Windows Internet Name Service (WINS) installed on it and you type

dir c:\winnt\system32\wins
Graphic 0-1. The screen output of a command such as dir can be redirected to a text file.
Graphic 0-1. The screen output of a command such as dir can be redirected to a text file.

The typical output displayed on the screen after executing such a command might be a directory listing such as the one shown in the screen capture. With the redirection symbol, however, such a command output can be redirected to a text file or to a printer. For example, if you enter the command

dir c:\winnt\system32\wins > stuff.txt

the command creates a text file called stuff.txt and sends its output to the file. If the file stuff.txt already exists, it will be overwritten. The contents of the file will look exactly like the output on the screen shown in the illustration. You can then print out the file, send it as an e-mail attachment, or archive it for documentation purposes.

TIP

To prevent the output of a command from being displayed on the screen (for example, when running a batch file), redirect the command to nul. For example, in a logon script that synchronizes the clocks of servers with server7, use

net time \\server7 /set /yes > nul

If you want to redirect the output of a series of commands to the same file cumulatively, use the >> symbol to append redirected output to an existing file instead of overwriting it.

|

A command-line symbol used for piping that is supported by all versions of Microsoft Windows. Piping allows you to make the output of one Windows command the input for another command. The | symbol is generally referred to as the pipe symbol.

How It Works

Normally, Windows sends the output of a command to the screen. For example, suppose you open a command prompt on a machine running Windows 2000 Server and you type the command

tree c:\

The screen will display the entire directory tree of your C drive, starting with the root. Because there is more than one screen of information, the screen will scroll. To view the information more conveniently, pipe the output of the above command into the more command. The more command is a filter command that displays one screen of information at a time, waiting for you to press any key to view the next screen. You would thus type the following command

tree c:\ | more

%SystemRoot%

The directory where the core Microsoft Windows NT and Windows 2000 operating system files are stored. In a default installation of Windows NT and Windows 2000, the operating system files are located in C:\Winnt. You can specify different locations for these files when you set up Windows NT or Windows 2000.

The symbol %SystemRoot% is an environment variable that can be used in Windows commands at the command line or in batch scripts such as logon scripts. (Windows NT and Windows 2000 are case insensitive: %SYSTEMROOT%, %SystemRoot%, and %systemroot% are identical.) For example, if your current directory during a command-line session on a machine running Windows NT is

C:\Inetpub\wwwroot

and you want to change to the directory where the Windows NT operating system files are located, you can type

cd %systemroot%

3.1 kHz bearer service

A service provided by some telephone companies (telcos) for transmitting data over voice trunk lines. This service is sometimes called data-over-voice (DOV). When supporting 3.1 kHz bearer service communications, telco switches must have their trunk-line echo cancellators turned off because echo cancellation will corrupt data transmission when sent over voice lines. This service is a legacy telecommunications technology that is no longer widely implemented.

5-4-3 rule

A specification describing limitations for constructing certain kinds of Ethernet networks. The 5-4-3 rule applies specifically to Ethernet networks based on either the thinnet or thicknet cabling option.

Graphic 0-2. Five segments, four repeaters, and three populated segments.
Graphic 0-2. Five segments, four repeaters, and three populated segments.
How It Works

According to the Ethernet specifications, thinnet (or thicknet) Ethernet network segments can be joined using repeaters to form larger networks, but there are limitations on how you can do this. The maximum number of segments you can join is five. To join these segments, you need to use four repeaters because Ethernet typically uses a bus topology in which all segments are joined linearly. However, in this configuration, no more than three of the segments can actually have computers attached to them, leaving two segments that are used only for extending distances rather than hosting computers. These two unpopulated segments are called inter-repeater links. You should not violate this rule when implementing Ethernet networks; otherwise, unreliable network communications might result.

8.3 filename

The file naming convention used by the legacy MS-DOS and Microsoft Windows 3. x operating systems. 8.3 filenames use the following naming convention for file and directory names:

  • Up to eight characters can be used for the actual name of the file.

  • Up to three characters can be used for a filename extension (optional).

  • A period separates the filename from the extension (if there is one).

The reason for the file naming limitation on these platforms has to do with the way the FAT file system was designed. The file allocation table (FAT) allocates only enough space for an eight-character name followed by a three-character extension. The extension identifies the type of program that can open or run the file. For example, the file resume.doc would be identified to the operating system as a file that can be opened using Microsoft Word, since the .doc extension is registered by the operating system as the extension for Word documents.

More recent versions of Windows such as Windows 95, Windows 98, Windows NT, and Windows 2000 use long filenames (LFNs), which are more descriptive than the shorter ones.

10Base2

A type of standard for implementing Ethernet networks. 10Base2 is sometimes referred to as thinnet (or “thin coax”) because it uses thin coaxial cabling for connecting stations to form a network. 10Base2 supports a maximum bandwidth of 10 Mbps, but in actual networks, the presence of collisions reduces this to more like 4 to 6 Mbps. 10Base2 is based on the 802.3 specifications of Project 802 developed by the Institute of Electrical and Electronic Engineers (IEEE).

Graphic 0-3. A 10Base2 network.
Graphic 0-3. A 10Base2 network.
How It Works

10Base2 networks are wired together in a bus topology, in which individual stations (computers) are connected directly to one long cable. The maximum length of any particular segment of a 10Base2 network is 185 meters. If distances longer than this are required, two or more segments must be connected using repeaters. Altogether, there can be a total of five segments connected using four repeaters, as long as only three of the segments have stations attached to them. This is referred to as the 5-4-3 rule.

A 10Base2 segment should have no more than 30 stations wired to it. The minimum distance between these stations must be 0.5 meters. Stations are attached to the cable using BNC connectors, and the ends of the thinnet cabling have BNC cable connectors soldered or crimped to them.

The designation 10Base2 comes from the speed of the network (10 Mbps), the signal transmission method (baseband transmission), and the maximum segment length (185 meters, rounded off to 200 with the zeros removed).

NOTE

10Base2 networks are not implemented much anymore for two reasons. First, because their speed is limited to 10 Mbps, the networks perform poorly in today’s bandwidth-hungry, Internet-connected world. Second, 10Base2 networks have a single point of failure—the long, linear bus cable used to connect the stations. A single break or loose connection brings down the entire network, and every cable segment and station connection must be checked to determine the problem. If you are wiring an office for a small LAN with low bandwidth requirements, use 10BaseT instead. For moderate to high bandwidth requirements, try using Fast Ethernet instead.

TIP

The two ends of a 10Base2 bus must be properly terminated. If they are not, signals will bounce and network communications will be impossible.

See also
10Base5, 10BaseF, 10BaseT, Ethernet

10Base5

A type of standard for implementing Ethernet networks. 10Base5 is sometimes referred to as thicknet because it uses thick coaxial cabling for connecting stations to form a network. Another name for 10Base5 is Standard Ethernet because it was the first type of Ethernet to be implemented. 10Base5 supports a maximum bandwidth of 10 Mbps, but in actual networks, the presence of collisions reduces this to more like 4 to 6 Mbps. 10Base5 is based on the 802.3 specifications of Project 802 developed by the Institute of Electrical and Electronic Engineers (IEEE).

How It Works

10Base5 networks are wired together in a bus topology—that is, in a linear fashion using one long cable. The maximum length of any particular segment of a 10Base5 network is 500 meters, hence the 5 in 10Base5. If distances longer than this are required, two or more segments must be connected using repeaters. Altogether, there can be a total of five segments connected using four repeaters, as long as only three of the segments have stations (computers) attached to them. This is referred to as the 5-4-3 rule.

A 10Base5 segment should have no more than 100 stations wired to it. These stations are not connected directly to the thicknet cable as in 10Base2 networks. Instead, a transceiver is attached to the thicknet cable, usually using a cable-piercing connector called a vampire tap. From the transceiver, a drop cable is attached, which then connects to the network interface card (NIC) in the computer. The minimum distance between transceivers attached to the thicknet cable is 2.5 meters, and the maximum length for a drop cable is 50 meters. Thicknet cable ends have N-series connectors soldered or crimped on them for connecting segments together.

10Base5 networks were often used as backbones for large networks. In a typical configuration, transceivers on the thicknet backbone would attach to repeaters, which would join smaller thinnet segments to the thicknet backbone. In this way, a combination of 10Base5 and 10Base2 standards could support sufficient numbers of stations for a moderately large company.

NOTE

10Base5 networks are legacy networks that are no longer implemented, although some companies might choose to maintain them for cost reasons. The complexity and bandwidth limitations of 10Base5 networks render them obsolete. If you are wiring an office for a small LAN with low bandwidth requirements, use 10BaseT instead. For moderate to high bandwidth requirements, try using Fast Ethernet. If you are implementing a backbone for today’s high-speed enterprise networks, try using Gigabit Ethernet, Fiber Distributed Data Interface (FDDI), or some other advanced technology.

TIP

The two ends of a 10Base5 bus must be properly terminated. If they are not, signals will bounce and network communications will be impossible.

See also
10Base2, 10BaseF, 10BaseT, Ethernet

10BaseF

A type of standard for implementing Ethernet networks. 10BaseF is different from other 10-Mbps Ethernet technologies because it uses fiber-optic cabling instead of copper unshielded twisted-pair (UTP) cabling. 10BaseF is based on the 802.3 specifications of Project 802 developed by the Institute of Electrical and Electronic Engineers (IEEE).

How It Works

10BaseF is similar to 10BaseT in that each station is wired into a fiber-optic hub in a star topology to form the network. The maximum length of any segment of 10BaseF fiber-optic cabling is 2 kilometers. The recommended cabling type for 10BaseF networks is 62.5-micron diameter fiber-optic cabling. This cable can be terminated with either ST connectors or SMA connectors, depending on the vendor and the hub configuration. Two-strand multimode fiber-optic cabling is used, with one strand allotted for transmitting data and the other for receiving data.

The 10BaseF standard actually consists of three separate standards describing different media specifications:

  • 10BaseFB: Defines how the synchronous data transmission occurs over the fiber-optic cabling. Using 10BaseFB segments, you can cascade or link synchronous fiber-optic hubs in configurations that are longer than traditional 10BaseT Ethernet networks and contain up to 1024 stations. This standard is more expensive and is not as widely implemented as 10BaseFL.

  • 10BaseFL: Defines the characteristics of the fiber-optic link between the nodes and the hub or concentrator. 10BaseFL replaces the older standard for fiber-optic link segments, Fiber-Optic Inter-Repeater Link (FOIRL) segments, which was developed in the 1980s. 10BaseFL is the most commonly implemented version of 10BaseF.

  • 10BaseFP: Defines the implementation of a star topology that does not use repeaters. 10BaseFP stands for Fiber Passive, and its segments can be only 500 meters in length with a maximum of 33 stations connected. This standard is rarely used today.

TIP

Use 10BaseF instead of 10BaseT in environments that are electrically noisy, such as in industrial areas, near elevator shafts, or around other motors or generators.

TIP

Use fiber-optic cabling when running cables between buildings. Differences in ground potential between the ends of copper cabling can induce voltages that can damage networking equipment if the ends are not grounded properly. Fiber-optic cabling also supports faster speeds than copper UTP cabling and provides a more suitable upgrade option to Fast Ethernet and beyond.

TIP

The maximum signal loss or attenuation on a given segment should be no more than 12.5 decibels. Using too many connectors in a segment of fiber-optic cabling can cause the attenuation to exceed this figure, which can lead to signal loss.

See also
10Base2, 10Base5, 10BaseT, SC and ST connectors

10BaseT

A type of standard for implementing Ethernet networks. 10BaseT is the most popular form of 10-Mbps Ethernet, using unshielded twisted-pair (UTP) cabling for connecting stations, and using hubs to form a network. 10BaseT supports a maximum bandwidth of 10 Mbps, but in actual networks, the presence of collisions reduces this to more like 4 to 6 Mbps. 10BaseT is based on the 802.3 specifications of Project 802 developed by the Institute of Electrical and Electronic Engineers (IEEE).

Graphic 0-4. A 10BaseT network.
Graphic 0-4. A 10BaseT network.
How It Works

10BaseT networks are wired together in a star topology to a central hub. The UTP cabling used for wiring should be category 3 cabling, category 4 cabling, or category 5 cabling, terminated with RJ-45 connectors. Patch panels can be used to organize wiring and provide termination points for cables running to wall plates in work areas. Patch cables then connect each port on the patch panel to the hub. Usually, most of the wiring is hidden in a wiring cabinet and arranged on a rack for easy access.

The maximum length of any particular segment of a 10BaseT network is 100 meters. If distances longer than this are required, two or more segments must be connected using repeaters. The minimum length of a segment should be 2.5 meters. By using stackable hubs or by cascading regular hubs into a cascaded star topology, you can network large numbers of computers using 10BaseT cable. Although they support up to 1024 nodes, collision domains supporting no more than 200 or 300 nodes will yield the best performance.

NOTE

The maximum length of a 10BaseT cable segment is not a result of the specifications for round-trip communications on an Ethernet network, but rather a limitation caused by the relatively low signal strength of 10BaseT systems. With enhanced category 5 cabling, you might be able to sustain network communications effectively with cable lengths up to about 150 meters, although this is not normally recommended.

TIP

When wiring a 10BaseT network, use enhanced category 5 cabling. This will make it unnecessary to rewire your network should you decide to upgrade to Fast Ethernet.

See also
10Base2, 10Base5, 10BaseF

24 x 7

A standard for uninterrupted running of network services. A 24 x 7 network is a network whose services and resources are available 24 hours a day, seven days a week, with virtually no downtime. A further extension is the goal of 24 x 7 x 365 availability. In today’s emerging e-business economy, availability of the network and its resources and applications can make the difference between business success and failure.

A variety of technologies can be used to approach the goal of 24 x 7 availability. One of the most successful is clustering, a technology in which an application runs redundantly on multiple servers. When one of the nodes in a cluster fails, the other nodes take on the workload of the failed node so that there is no interruption in service while the failed node is being repaired or replaced. Microsoft Cluster Server (MSCS), included in Microsoft Windows NT Server, Enterprise Edition, offers clustering services for high-availability line-of-business applications.

Other technologies important to the 24 x 7 goal include fault tolerant hardware technologies. Examples are hot-swappable components, such as power supplies and hard disks that can be removed and replaced without the system having to power down or reboot. RAID 5 disk systems guard against data loss from disk failure. Cellular phones and pagers also play a role in attaining the 24 x 7 goal, as they allow businesses to keep in touch with administrators and technical support staff around the clock.

TIP

Pay your network administrators and support staff well—they deserve it in a 24 x 7 networking environment. Forget about alternative forms of compensation and shell out the big bucks. If you lose these people, they will be hard to replace!

100BaseFX

A type of standard for implementing Fast Ethernet networks. 100BaseFX is a version of Fast Ethernet that is often used for wiring campus backbones. 100BaseFX is based on 802.3u, which is an extension of the 802.3 specifications of Project 802 developed by the IEEE. 100BaseFX and a related standard, 100BaseTX, are sometimes collectively referred to as 100BaseX.

How It Works

100BaseFX networks are wired together in a star topology using fiber-optic cabling and 100-Mbps fiber-optic hubs or Ethernet switches. The maximum length of any segment of fiber-optic cabling connecting a station (computer) to a hub is 412 meters. The grade of fiber-optic cabling used is usually two-strand multimode fiber-optic cabling, with one strand carrying transmitted data and the other strand receiving data. However, you can also use two-strand single-mode fiber-optic cabling. If multimode fiber-optic cabling is used, the variety used is typically a grade with a 62.5-micron core diameter. Repeaters can be used to extend the length of cabling and for interfacing between 100BaseFX/TX and 100BaseT4 segments. The maximum allowable distances with repeaters are 2 kilometers using multimode fiber-optic cabling and 10 kilometers using single-mode fiber-optic cabling. Only one or two repeaters can be used per collision domain, depending on whether Class I or Class II repeaters are used.

TIP

When using 100BaseFX with repeaters for backbone cabling runs, Ethernet switches cannot be more than 412 meters apart when running in half-duplex mode and 2 kilometers apart when running in full-duplex mode.

See also
100BaseT4, 100BaseTX, Fast Ethernet

100BaseT

See
Fast Ethernet

100BaseT4

A type of standard for implementing Fast Ethernet networks. 100BaseT4 is based on 802.3u, which is an extension of the 802.3 specifications of Project 802 developed by the IEEE. 100BaseT4 is the most commonly used implementation of Fast Ethernet today.

Graphic 0-5. A 100BaseT4 network.
Graphic 0-5. A 100BaseT4 network.
How It Works

100BaseT4 networks are wired together in a star topology using unshielded twisted-pair (UTP) cabling and 100-Mbps hubs or Ethernet switches. The UTP cabling can be category 3 cabling, category 4 cabling, or category 5 cabling—with category 5 (cat5) cabling and enhanced category 5 cabling being the most commonly used options. 100BaseT4 uses all four pairs of wire standard UTP cabling. One pair is used for transmission and another pair for reception. The other two pairs are bidirectional and can be used to transmit or receive data. In this way, three of the four wire pairs are used at any given time to provide half-duplex transmission or reception of signals. Sharing three pairs of wires for data transfer allows 100BaseT4 to make use of lower-grade cabling installed in older buildings.

The maximum length of any segment of UTP cabling connecting a station (computer) to a hub is 100 meters. This ensures that round-trip signaling specifications are met, since violating these specifications can produce late collisions that disrupt network communications. The Electronic Industries Alliance/Telecommunications Industry Association (EIA/TIA)–recommended length of cabling between the station and the wiring closet is only 90 meters, allowing up to 10 meters more of cabling for patch cables used to connect patch panels to hubs or switches. The pinning of the RJ-45 connectors used for 100BaseT4 wiring is the same as for 10BaseT wiring.

TIP

Make sure all your cabling, connectors, and patch panels are fully cat5-compliant. Make sure that when UTP cabling is connected to patch panels, wall plates, or connectors, the wires are not untwisted more than half an inch at the termination point. 100BaseT4 most benefits companies with an older, preinstalled base of category 3 or category 4 cabling. 100BaseT4 hubs and switches are typically available in an autosensing 10/100-Mbps variety for interoperability with older 10BaseT networks and to facilitate an easy upgrade from 10BaseT to 100BaseT.

See also
100BaseFX, 100BaseTX, Fast Ethernet

100BaseTX

A type of standard for implementing Fast Ethernet networks. 100BaseTX is based on 802.3u, which is an extension of the 802.3 specifications of Project 802 developed by the IEEE. 100BaseTX and a related standard, 100BaseFX, are sometimes collectively referred to as 100BaseX.

Graphic 0-6. A 100BaseTX network.
Graphic 0-6. A 100BaseTX network.
How It Works

100BaseTX networks are wired together in a star topology using unshielded twisted-pair (UTP) cabling or shielded twisted-pair (STP) cabling and 100-Mbps hubs or Ethernet switches. If UTP cabling is used (which is the most common scenario), it must be category 5 cabling (cat5 cabling) or enhanced category 5 cabling. 100BaseTX uses two pairs of wires in twisted-pair cabling, with one pair of wires used for transmission and the other used for reception. In this fashion, with appropriate equipment, 100BaseTX is capable of supporting both the normal half-duplex Ethernet and the newer full-duplex Ethernet signaling technologies. The maximum length of any segment of UTP cabling connecting a station to a hub is 100 meters. This ensures that round-trip signaling specifications are met, since violating these specifications can produce late collisions that disrupt network communications. The Electronic Industries Alliance/Telecommunications Industry Alliance (EIA/TIA) recommends only 90 meters of cabling between the station (computer) and the wiring closet, allowing up to 10 meters more of cabling for patch cables used to connect patch panels to hubs or switches. The pinning of the RJ-45 connectors used for 100BaseTX wiring is the same as for 10BaseT wiring.

TIP

Make sure all your cabling, connectors, and patch panels are fully cat5-compliant. Make sure that when UTP cabling is connected to patch panels, wall plates, or connectors, the wires are not untwisted more than half an inch at the termination point.

See also
100BaseFX, 100BaseT4, Fast Ethernet

100BaseVG

See
100VG-AnyLan

100BaseX

See
100BaseFX, 100BaseTX

100VG-AnyLan

An alternative to Fast Ethernet that provides 100-Mbps communications based on technology developed by Hewlett-Packard. 100VG-AnyLan is based on the 802.12 specifications of Project 802 developed by the IEEE. 100VG-AnyLan is informally named 100BaseVG.

Graphic 0-7. A 100VG-AnyLan network.
Graphic 0-7. A 100VG-AnyLan network.
How It Works

100VG-AnyLan networks are wired together in a star topology using unshielded twisted-pair (UTP) cabling, shielded twisted-pair (STP) cabling, or fiber-optic cabling with supporting 100-Mbps hubs or Ethernet switches. If UTP cabling is used, it can be category 3 cabling, category 4 cabling, or category 5 cabling—with category 5 (CAT5) cabling or enhanced category 5 cabling preferred. 100BaseVG uses all four pairs of wires in UTP cabling. When using UTP category 3 cabling, category 4 cabling, or STP cabling, the maximum length of a segment is 100 meters. With UTP category 5 cabling, the maximum length of a segment is 200 meters. When using multimode fiber-optic cabling, the maximum length is 2000 meters.

100VG-AnyLan differs from Fast Ethernet by not using the traditional Carrier Sense Multiple Access with Collision Detection (CSMA/CD) method for media access used in Ethernet and Fast Ethernet networks; instead, 100VG-AnyLan uses the demand priority method for media access, which eliminates the overhead of collisions. 100VG-AnyLan uses a special coding scheme called quartet signaling, which makes it possible to transmit data over all four pairs of wires in a UTP cable simultaneously. This means that special 100VG-AnyLan hubs are required to support demand priority media access. Otherwise, the frame format, topology, and other specifications of 100VG-AnyLan are the same as for Ethernet.

NOTE

100VG-AnyLan is also being developed to support token ring networks.

1000BaseCX

A type of standard for implementing Gigabit Ethernet networks. The CX in 1000BaseCX stands for short-haul copper, and it indicates that this version of Gigabit Ethernet is intended for short cable runs over copper cabling. Gigabit Ethernet standards are defined in the 802.3z standards of Project 802 developed by the IEEE. 1000BaseCX technologies are in the beginning stages of being widely implemented in enterprise-level networks and are primarily used for collapsed backbones and high-speed interconnects within wiring closets and equipment rooms.

Graphic 0-8. A 1000BaseCX network.
Graphic 0-8. A 1000BaseCX network.
How It Works

1000BaseCX is an extension of standard Ethernet technologies to gigabit-level network speeds. 1000BaseCX is normally implemented using shielded twisted-pair (STP) cabling. Cable segments have a maximum length of only 25 meters. 1000BaseCX employs 8B/10B coding, with serial transmission rates of 1.25 Gbps. STP cabling is standard 150-ohm balanced cabling and should have a quality slightly better than IBM Type I cabling.

1000BaseCX is intended mainly for connecting high-speed hubs, Ethernet switches, and routers together in wiring closets. Common implementations for 1000BaseCX are in switch-switch and switch-server connections, with switch-server connections being the most frequently implemented use for 1000BaseCX.

1000BaseLX

A type of standard for implementing Gigabit Ethernet networks. The LX in 1000BaseLX stands for long, and it indicates that this version of Gigabit Ethernet is intended for use with long-wavelength transmissions over long cable runs of fiber-optic cabling. Gigabit Ethernet standards are defined in the 802.3z standards of Project 802 developed by the IEEE. 1000BaseLX technologies are in the beginning stages of being widely implemented in enterprise-level networks and are primarily used for long cable runs between pieces of equipment on a campus or within a building.

How It Works

1000BaseLX is an extension of standard Ethernet technologies to gigabit-level network speeds. 1000BaseLX is implemented using either single-mode fiber-optic cabling or multimode fiber-optic cabling. Cable segment lengths depend on the cable grade used, as shown in the following table.

1000BaseLX Cable Segment Lengths
Cable Grade | Maximum Segment Length
Single-mode fiber | 5000 meters
50-micron multimode fiber | 550 meters
62.5-micron multimode fiber | 440 meters

1000BaseLX is intended mainly for connecting high-speed hubs, Ethernet switches, and routers together in different wiring closets or buildings using long cabling runs. 1000BaseLX is most commonly implemented in a switch-switch configuration.

Graphic 0-9. A 1000BaseLX network.
Graphic 0-9. A 1000BaseLX network.
TIP

When you use multimode fiber-optic cabling in 1000BaseLX implementations, a condition called differential mode delay (DMD) can sometimes occur. This condition occurs only in cabling of uneven quality, and it leads to signal jitter that can disrupt network communications. To resolve this problem, newer 1000BaseLX transceivers condition the signal to distribute its power equally among all transmission modes of the cable.

1000BaseSX

A type of standard for implementing Gigabit Ethernet networks. The SX in 1000BaseSX stands for short, and it indicates that this version of Gigabit Ethernet is intended for use with short-wavelength transmissions over short cable runs of fiber-optic cabling. Gigabit Ethernet standards are defined in the 802.3z standards of Project 802 developed by the IEEE. 1000BaseSX technologies are in the beginning stages of being widely implemented in enterprise-level networks and are primarily used for shorter cable runs between pieces of equipment within a building.

How It Works

1000BaseSX is an extension of standard Ethernet technologies to gigabit-level network speeds. 1000BaseSX is implemented using only multimode fiber-optic cabling. Cable segment lengths depend on the cable grade used, as shown in the following table.

1000BaseSX Cable Segment Lengths
Cable Grade | Maximum Segment Length
50-micron multimode fiber | 500 meters
62.5-micron multimode fiber | 220 meters

1000BaseSX is intended mainly for connecting high-speed hubs, Ethernet switches, and routers together in different wiring closets or buildings using long cabling runs. 1000BaseSX is most commonly implemented in a switch-switch configuration.

TIP

When multimode fiber-optic cabling is used in 1000BaseSX implementations, a condition called differential mode delay (DMD) can sometimes occur. This condition occurs only in cabling of uneven quality, and it leads to signal jitter that can disrupt network communications. To resolve this problem, newer 1000BaseSX transceivers condition the signal to distribute its power equally among all transmission modes of the cable.

1000BaseT

A type of standard for implementing Gigabit Ethernet networks. The T in 1000BaseT identifies it as an extension of the traditional 10BaseT and 100BaseT Ethernet technologies for transmission over copper unshielded twisted-pair (UTP) cabling. Gigabit Ethernet standards are defined in the 802.3z and 802.3ab standards of Project 802 developed by the IEEE. 1000BaseT technologies are in the beginning stages of being widely implemented in enterprise-level networks. They are primarily used for short, high-speed interconnects within wiring closets and for connecting high-speed workstations to wiring closets.

Graphic 0-10. A 1000BaseT network.
Graphic 0-10. A 1000BaseT network.
How It Works

1000BaseT is an extension of standard Ethernet technologies to gigabit-level network speeds. 1000BaseT is normally implemented using the commonly installed category 5 cabling or enhanced category 5 cabling version of UTP cabling. 1000BaseT uses all four pairs of wires in standard UTP cabling, as opposed to the two pairs of wires used in 10BaseT and 100BaseT networks. Using all four pairs of UTP cabling has certain associated problems because of attenuation, crosstalk, and echoes arising from full-duplex transmission over single wires. The 802.3ab standards specify special filters for hybrid circuits used in full-duplex transmission over single wires, a special five-level pulse amplitude modulation (PAM) encoding mechanism instead of binary signals, forward error correction techniques, and pulse shaping technologies to make 1000BaseT a functional and reliable networking technology.

Cable segments for 1000BaseT have a maximum length of 100 meters. 1000BaseT is intended mainly for connecting high-speed hubs, Ethernet switches, and routers together in wiring closets; for switch-switch connections in backbones; for switch-server connections; and for horizontal cable runs to high-speed workstations.

TIP

1000BaseT is intended to provide the simplest upgrade path for legacy 10BaseT and 100BaseT Ethernet networks.

3270

The information display protocol for IBM mainframe computers. The 3270 protocol enables conversations to take place between mainframe hosts and other devices such as dumb terminals, printers, and controllers.

Microsoft SNA Server provides access to resources on mainframe computers by defining and assigning 3270 logical units. These logical units are defined within SNA Server and are configured to use an existing connection to the mainframe system that matches a logical unit resource allocated on the mainframe, usually specified within Virtual Telecommunications Access Method (VTAM). SNA Server client software is installed on client PCs to manage communications between a 3270 application and the SNA Server.


A

A+ Certification

A certification for computer service technicians that is sponsored by the Computing Technology Industry Association (CompTIA). A+ Certification certifies service technicians for competency in troubleshooting, repairing, and installing stand-alone and networked PCs. A+ is an internationally recognized certification that identifies minimum competency for entry-level computer technicians, typically those who have a minimum of six months of practical hands-on and interpersonal support experience. The Association for Services Management International (AFSMI) and a number of prominent hardware and software vendors back the A+ Certification.

A+ Certification was created by CompTIA to benefit all groups involved in the recruiting and hiring process. Specifically,

  • A+ benefits managers and recruiters by helping them identify trained, competent individuals to fill vacant positions.

  • A+ benefits job seekers by identifying skills they need to learn and develop, and by providing a recognizable career path for self-promotion and employment.

  • A+ benefits educational institutions by providing goals and objectives for developing industry-relevant technical training programs.

The A+ exam consists of two parts a core section covering general computer hardware and software that is not vendor-specific, and a module covering Microsoft operating system technologies for MS-DOS and Windows platforms.

On the Web
•
Computer Technology Industry Association’s A+ Certification page
: http://www.comptia.org/

absolute path

The hierarchical path that locates a file or folder in a file system starting from the root. The absolute path of a file enables the location of the file to be precisely specified, independent of where the user’s current directory is located.

In MS-DOS and Microsoft Windows platforms, the absolute path of a file is specified starting with a drive letter, followed by the hierarchy of directories in which the file is contained (with each directory separated by a backslash), and concluding with the exact filename. For example, on a computer running Windows 98, the absolute path to the executable for the game of Solitaire, which is typically located in the Windows directory on the C drive, would be the following:

C:\Windows\sol.exe

If the user opens a command prompt and the current directory is C:\Windows, the user can simply type sol.exe to run the Solitaire program. From any other current directory though, the user must either type the absolute path to execute the program, or specify the relative path from the current directory to the executable file.

NOTE

On UNIX platforms, path names are specified using forward rather than backward slashes, and absolute paths don’t start with a drive letter. For example, the absolute path to the file script12, located in the bin subdirectory of the usr directory, would be

/usr/bin/script12
See also
relative path, Universal Naming Convention (UNC)

Abstract Syntax Notation One (ASN.1)

An International Organization for Standardization (ISO) standard that provides a mechanism for encoding human-readable symbols into condensed binary form. Abstract Syntax Notation One (ASN.1), which is part of the X.400 and X.500 specifications, provides a standard way of formatting and encoding X.400-based e-mail messages for transmission over a network. More generally, ASN.1 is a method of specifying abstract objects that are intended for any form of serial transmission. ASN.1 is also used for defining objects in Management Information Base (MIB) files for Simple Network Management Protocol (SNMP).

How It Works

ASN.1 is similar in syntax to a programming language, and it allows the definition of different data types, data structures, arrays, classes, and other structures similar to those found in the C++ programming language. The presentation layer (layer 6) of the Open Systems Interconnection (OSI) reference model uses ASN.1 as the standard for specifying the syntax of information exchanged between applications at this layer. ASN.1 data types can be either simple or structured. An example of a definition of a simple data type and its value might be

EmployeeAddress ::= ISO646STRING        "99 Microsoft Way"

A more complex structured data type might be

EmployeeRecord ::= SET
    {
    name        [0]ISO646STRING        "Bob Smith
    title       [1]ISO646STRING        "Support Specialist"
    idNumber    [2]INTEGER             "116427"
    }

ASN.1 data structures are encoded as octets in hexadecimal notation. These structures are then transmitted over the network as binary information.

NOTE

Microsoft Exchange Server uses ASN.1 for its X.400 Connector to provide connectivity with foreign X.400 messaging systems.

acceptable use policy

A policy created by management to specify acceptable usage for corporate network services as well as the consequences of violating these standards. Acceptable use policies lately have become an important feature of corporate IT culture for a number of reasons, but mainly because of the widespread implementation of Internet access for desktop users.

Management often becomes concerned about the possibilities of employees surfing the Internet for personal use on company time, using company e-mail to send personal messages, sending spam or mail bombs, and so on. Another concern is management’s possible legal liability if employees should access illegal or pornographic material on the Internet using their corporate Internet accounts.

Even if a company doesn’t have desktop Internet access for its employees, it should still have an acceptable use policy governing access to shared network resources such as file servers and color laser printers. To be effective, an acceptable use policy needs to have the following characteristics:

  • Acceptable and unacceptable usage must be simply and clearly explained in the policy.

  • A graded series of consequences of unacceptable usage must be clearly stated in the policy.

  • The policy itself must be clearly visible in employees’ work areas.

  • Management should regularly call employees’ attention to the policy.

In addition, users should be informed if management is utilizing monitoring practices such as logging all employee Internet access or archiving all employee e-mail. Management should consult its legal department in the drafting of an acceptable use policy, and this policy should be reviewed frequently and kept up-to-date as corporate network access evolves.

access

Generally, the process of connecting to and using resources on a network. To provide a user with access to network resources, permissions must first be granted to the user. For example, if a user is granted the read permission (and only this permission) for a file on the NTFS file system, the user is said to have read-only access to the file. An important part of a network administrator’s job is to configure appropriate levels of access control—that is, to manage access to network resources such as shared files, printers, and applications so that

  • Users who need access to these resources have the appropriate level of access to them

  • Users who do not need access to the resources—as well as distrusted users or hackers—are prevented from accessing them

NOTE

In Microsoft Windows 2000, when a user or process attempts to access an object such as a file on an NTFS volume, a component of the Windows 2000 operating system called the Security Reference Monitor compares the access token attached to the process with the access control list (ACL) attached to the object. Through this comparison, the Security Reference Monitor determines whether to grant access to the user or process.

See also
access control, access control list (ACL), access token

access control

For Microsoft Windows 2000, a general term describing how administrators can secure access to objects in Active Directory. The term “access control” is also used for both the Windows 2000 and Windows NT platforms to describe how files and folders can be secured using the NTFS file system, as well as how access to shared folders, printers, and other network resources can be controlled.

How It Works

Access control can be applied to any object in Active Directory, but it is applied most often to a group or a container. Access control to directory objects is implemented primarily by assigning permissions and rights.

Permissions are assigned to an object to determine who can access that object and at what level. Permissions can be set by an administrator or by the owner of the object. The kind of permission that can be applied depends on the type of object being considered. Some of the objects to which permissions can be applied include

  • NTFS file system objects such as files, folders, and volumes

  • Local system objects such as processes and programs

  • Local or Active Directory objects such as user, group, or printer objects

The issue of inheritance is related to permissions. When permissions are assigned to a folder on an NTFS volume, they are also inherited by default by all existing child folders and files within the folder, and by any new child folders or files created later. Similarly, when permissions are assigned to a container in Active Directory, they are also inherited by default by all existing child objects within the container and by any new child objects created later.

Rights are assigned to user or group accounts to provide them with authorization to perform a specific system task, such as backing up a volume, shutting down the system, or logging on to the console interactively. Rights are most often assigned to groups rather than individual users to simplify administration. Rights can be specified at either the local or domain level.

Another aspect of access control is the issue of ownership. When a user creates an object in Active Directory or a file on an NTFS volume, he or she becomes the owner of that object or file. The owner has the right to set and modify the permissions of the object. Every object in Active Directory and every file or folder on an NTFS volume has an owner.

One additional aspect of access control is the issue of auditing. Files and folders on an NTFS volume can be audited to keep track of failures or successes in accessing them. This can be important in detecting security breaches in your network.

NOTE

When assigning permissions to objects in Active Directory, you can assign them either to the object itself (and therefore to all its attributes) or to specific attributes of the object. For example, you could allow all users to have read access to the Phone Number attribute of users in Active Directory, while granting the clerical group read/write access to that attribute so that they can modify users’ phone numbers if necessary.

See also
owner, permissions, rights

access control entry (ACE)

An entry in a discretionary access control list (DACL) or a system access control list (SACL). An access control entry (ACE) specifies the access or auditing permissions to an object in Active Directory or on a volume formatted using the NTFS file system for a particular user or group.

Graphic A-1. Access control entry (ACE).
Graphic A-1. Access control entry (ACE).
How It Works

An ACE is part of a DACL or a SACL for an object and contains information that is used to control the access attributes of that object. An ACE specifies two pieces of information:

  • The security identifier (SID) of the security principal (user, group, or computer) to which the ACE applies

  • The level of access to the object permitted for that security principal

An access mask specifying the possible permissions that can be assigned to the object is included with each ACE. An ACE can provide one of the following:

  • Discretionary access control for explicitly granting or denying access to a specific user or group (AccessAllowed and AccessDenied entries)

  • System security access control for generating security audit logs (SystemAudit entry)

See also
discretionary access control list (DACL), system access control list (SACL)

access control list (ACL)

Any mechanism for implementing access control on an operating system, file system, directory service, or other software. Access control lists (ACLs) are implemented into the basic operating system architecture of Microsoft’s Windows 2000 and Windows NT operating system platforms, and are used to control access to objects in Active Directory and files on NTFS volumes. An access control list is basically a list attached to an object specifying which security principals (users, groups, computers, and so on) are allowed to access the object and what level of access they are allowed to have. In Windows 2000, ACLs are more properly called discretionary access control lists (DACLs) because they can be configured and managed by administrators at their discretion. There is also another type of ACL in Windows called a system access control list (SACL), which is used to control the generation of audit messages when object auditing has been configured on a file system.

Access control lists are natively implemented on some UNIX operating system platforms such as Solaris (which first implemented ACLs in version 2.5.1) and are also available as third-party software for other UNIX platforms. Traditionally access control on UNIX file systems was managed using the chmod (change mode) command, but this offered only limited or coarse-grained control of file permissions and provided no flexibility for configuring unique sets of access permissions for particular users or groups. To set and display access control lists on Solaris, use the setfacl and getfacl commands. Other UNIX packages and add-ons may use different commands such as setacl and getacl.

See also
access control, discretionary access control list (DACL), system access control list (SACL)

Accessibility Options

A utility in Control Panel for most versions of Microsoft Windows that allows you to adjust the behavior of the keyboard, mouse, and display to suit the needs of individuals with impaired eyesight, hearing, or motor skills. Accessibility Options are part of Microsoft’s initiative to provide access to computer technology to all individuals, regardless of their physical impairments. Settings for Accessibility Options include the following:

  • StickyKeys:
    Makes it possible to use a key combination such as Ctrl+Alt+Delete without pressing more than one key at a time

  • FilterKeys:
    Makes it more difficult to bounce keys by telling the system to ignore brief or repeated keystrokes

  • ToggleKeys:
    Generates sounds when certain toggle keys, such as Caps Lock, are turned on

  • SoundSentry:
    Flashes a specified part of the screen when the system generates sounds

  • ShowSounds:
    Displays icons or text captions to accompany the sounds that programs generate

  • HighContrast:
    Makes reading text easier

  • MouseKeys:
    Controls the pointer using the numeric keypad

  • SerialKey:
    Enables the use of alternative input devices connected to the computer’s serial port instead of the keyboard and mouse

    Graphic A-2. Accessibility Options.
    Graphic A-2. Accessibility Options.
NOTE

Windows 98 and Windows 2000 include an additional wizard called the Accessibility Wizard that allows you to configure accessibility options on your computer. Additional accessibility utilities include Magnifier, Narrator, and On-Screen Keyboard.

Microsoft product documentation and books from Microsoft Press are available in alternative formats from Recording for the Blind and Dyslexic and Microsoft Accessibility and Disabilities Group at the following Web sites.

On the Web
•
Recording for the Blind and Dyslexic
: http://www.rfbd.org
•
Microsoft Accessibility and Disabilities Group
: http://www.microsoft.com/enable/

Accessibility Wizard

A Microsoft Windows 98 and Windows 2000 utility for configuring a computer for individuals with impaired visual or motor skills. Accessibility Wizard is an alternative to Accessibility Options for configuring computers for individuals with disabilities.

Graphic A-3. The Accessibility Wizard for Windows 98.
Graphic A-3. The Accessibility Wizard for Windows 98.
How It Works

To start the Accessibility Wizard, choose Accessories from the Start menu. Then from the Accessibility program group, choose Accessibility Wizard. Note that in Windows 98, you might have to install the Accessibility Tools to gain access to the wizard. The wizard leads the user through a series of questions concerning his or her disability and configures mouse, keyboard, and display properties to meet the particular need. This tool gives administrators the ability to configure workstations for individuals with physical impairments by leading the user through a series of screens that he or she can then respond to in real time. Using the Accessibility Wizard is generally more convenient than using the Accessibility Options property sheet to configure accessibility settings. The wizard’s final screen lists the accessibility options that have been enabled.

access mask

Defines all possible actions for a particular type of object (file, folder, and so on) for each access control entry (ACE) in a discretionary access control list (DACL) or a system access control list (SACL). The system chooses the access rights that it can grant to a thread from the possible actions listed in the access mask.

Microsoft Windows NT and Windows 2000 use access masks that support three types of access rights:

  • Specific access rights:
    These include access rights such as FILE_READ_DATA and FILE_APPEND_DATA, which provide permission to read and write data in a file. Objects can have up to 16 different specific access rights, depending on the object type.

  • Standard access rights:
    These apply to all objects and include DELETE, which grants or denies delete access to an object, and WRITE_OWNER, which grants or denies access to the owner security identifier (SID) of an object.

  • Generic access rights:
    These map to specific access rights and standard access rights. Each type of securable object maps generic access rights to its own specific and standard access rights. Generic access rights for file objects include FILE_GENERIC_READ, FILE_GENERIC_WRITE, and FILE_GENERIC_ EXECUTE. These three types are listed in Windows Explorer in Windows 2000 and in Windows NT Explorer in Windows NT as the special permissions read (R), write (W), and execute (X).

access method

See
media access control method

access mode

A mode of running a console created with the Microsoft Management Console (MMC). Different access modes are provided for MMC consoles in order to allow or restrict access to administrative functionality. This enables senior administrators to create custom consoles for junior administrators that have only the functionality needed to perform specified tasks, while preventing them from using functionality that could cause problems if not handled correctly.

How It Works

Selecting options from the Console menu configures access modes for MMC consoles. The two modes available for running consoles are

  • Author mode:
    This mode grants the user full access to all the functionality of the MMC, including adding new snap-ins, removing snap-ins, creating new console windows, and accessing the entire console tree. Only senior administrators should have this access mode.

  • User mode:
    This mode does not allow the user to add snap-ins to or remove snap-ins from the console and restricts access to some of the functionality of the MMC, depending on the options selected. For example, by selecting the Force SDI option, the MMC displays only a single console window. User mode has three submodes:

    • Full access:
      This submode allows the user to view the whole console tree but restricts the user from adding new snap-ins or changing the properties of the console.

    • Delegated access:
      This submode restricts the user so that only a portion of the console tree can be viewed.

    • SDI delegated access:
      This submode further restricts the user to a single document interface (SDI), that is, a console with only one window open. The user can open no new windows.

TIP

If an MMC console is set to user mode, you can start it in author mode by running it from the command line with the /a switch. You can also right-click on the console file (*.msc file) in Windows Explorer and use the shortcut menu to start the console in author mode. However, an administrator can also set the user’s profile settings to prevent the user from opening a console in author mode.

access point

A type of device that enables wireless stations to connect to a wired local area network (LAN). An access point therefore provides wireless stations with access to resources on a network.

Graphic A-4. Access point.
Graphic A-4. Access point.
How It Works

In typical wireless networking implementations, an access point is a device connected to a wired network, such as an Ethernet network. The access point is a transceiver, transmitting and receiving signals using either direct sequencing or frequency hopping methods in spread spectrum communication technologies. The access point provides a point of access to the wired network for mobile computers. To communicate with the access point, a mobile computer can use either a special wireless PCMCIA card or a network interface card (NIC), or it can use station adapters, which are devices that plug in to the standard 10BaseT port of the computer’s Ethernet card.

For spread spectrum communication in the 2.4 GHz range, access points typically support 1–3 Mbps communication over distances of up to about 3 kilometers. The area covered by an access point is called a cell. An access point can generally support 15 to 25 wireless stations, while still maintaining optimal data transfer rates. The access points allow wireless stations to be quickly and easily connected to a wired LAN.

See also
wireless networking

access provider

See
Internet service provider (ISP)

access token

An object generated during a successful logon by the security subsystem in Microsoft Windows NT and Windows 2000 and attached by the Winlogon process to all the user’s processes. An access token is used to uniquely identify the user’s processes in order to provide the user with appropriate access to resources on a network.

How It Works

An access token is like a card key. Your card key will provide you with access to doors that have been configured to grant you permission to open them. The list of card keys that a door will accept is analogous to an access control list (ACL).

Graphic A-5. Access token.
Graphic A-5. Access token.

When you successfully log on to Windows NT or Windows 2000, you are granted an access token, which is attached to all your user processes. Your access token contains the security identifier (SID) of your user account and every group to which you belong. When your application tries to access an object such as a file on a volume formatted with the NTFS file system, Windows NT or Windows 2000 compares the SIDs in your application’s access token to those in the access control entries (ACEs) in the object’s ACL. If it finds a match, the system grants access to that object.

See also
access control list (ACL), object in Windows NT and Windows 2000

account

A set of credentials for participating in a network. In a typical network, each user needs an account to access resources on the network, such as shared folders, printers, or applications. Accounts provide a way of identifying users on a network and are the foundation for network security. An administrator or another user with high security privileges typically creates accounts.

Accounts are generally used in server-based networks where a central computer such as a Microsoft Windows NT domain controller keeps track of each user’s account and grants or denies access to the network based on the credentials entered by the user at logon. Accounts are used less frequently in peer-to-peer networks or workgroups because the security requirements are usually much less stringent.

A Windows NT or Windows 2000 network contains three kinds of accounts:

  • User account:
    Identifies users who belong to the domain by storing their names, passwords, the groups they belong to, and the permissions they have for accessing system resources

  • Group account:
    Identifies a specific group of users and is used to assign permissions to them

  • Computer account:
    Identifies machines that belong to the domain

account domain

A type of domain in Windows NT in an enterprise containing global user accounts and global group accounts throughout. Account domains simplify account administration by centralizing administration to a single domain.

Graphic A-6. Account domain.
Graphic A-6. Account domain.
How It Works

An account domain is often a master domain too when used in a single master domain model implementation of Windows NT. The account domain contains user accounts for every user in the enterprise and is usually located at corporate headquarters. Servers and workstations at company branch offices belong to other domains called resource domains. Users at branch offices who want to log on to the network must log on to the account domain, even though their workstations are located within a resource domain. For this scenario to work, a trust relationship must be established so that each resource domain trusts the account domain. In this way, all user accounts can be centralized in the account domain, which eases account management for administrators located at headquarters.

See also
resource domain, trust relationship

account lockout

In Microsoft Windows NT and Windows 2000, a state in which a user is prevented from logging on to the network. If account lockout restrictions are set on a network, a user who fails successively to log on will be locked out of the network after a predetermined number of attempts. For example, if a user forgets the password and repeatedly attempts to log on, the domain controller assumes that unauthorized access is being attempted and shuts out the user by locking out his or her account. The account can either remain locked until an administrator unlocks it, or it can be configured to unlock after a specified period of time.

Account lockout restrictions are part of the account policy that can be set for domains. Account lockout is used to prevent unauthorized access to the network by preventing distrusted users from attempting to guess a trusted user’s password. If you set up account lockout on your network, you will probably also want to configure auditing to record failed logon attempts.

TIP

Use account lockout only for high-security networks. In a low-security environment, users can become frustrated if they lock themselves out by mistyping their password, and administrators must cope with the additional overhead and bother of unlocking these accounts.

See also
Account policy

account operator

In Microsoft Windows NT and Windows 2000, account operators are users who are assigned the responsibility of administering user and group accounts for a network. To make an individual an account operator, simply make them a member of the Account Operators group. Account operators can administer accounts only on a domain controller, not on a member server or workstation.

Account operators have the preassigned rights to log on locally to a domain controller and to shut down the system. In addition, account operators have the built-in capacity to create and manage user accounts, global group accounts, and local group accounts, as well as to keep local profiles.

TIP

Account operators should be assigned in enterprise-level networking environments only. In small to medium-sized networking environments, creating and configuring user accounts is usually the responsibility of the administrator.

Account Operators group

In Microsoft Windows NT and Windows 2000, a built-in group whose users can create, delete, and modify the properties of users, global groups, and local groups. The Account Operators group exists only on domain controllers and has an empty initial membership. The Account Operators group has the following preassigned rights:

  • Log on locally

  • Shut down the system

Additionally, members of the Account Operators group have the ability to create, delete, and modify user and group accounts. In Windows NT, members do so using User Manager for Domains. In Windows 2000, members use Active Directory Users and Computers.

NOTE

Members of the Account Operators group cannot modify the membership or rights of the following built-in groups:

  • Administrators

  • Account Operators

  • Server Operators

  • Print Operators

  • Backup Operators

See also
built-in group

Account policy

In Microsoft Windows NT, a set of rules specified for a domain using User Manager for Domains that determines the restrictions placed on passwords for users in that domain. In Windows 2000, this set of rules is specified using Active Directory Users and Computers.

To configure your account policy for a domain in Windows NT, select the domain you want to administer in User Manager for Domains, and from the menu, select Policies. Then select Accounts to open the Account Policy dialog box. You can specify restrictions for the following:

  • Maximum and minimum password age

  • Minimum password length

  • Password history

  • Account lockout trigger and duration

  • Forcible disconnection when logon hours expire

  • Logon requirement for password changes

    Graphic A-7. The Account Policy dialog box in Windows NT 4.0.
    Graphic A-7. The Account Policy dialog box in Windows NT 4.0.
NOTE

As a network administrator, not only should you avoid making your account policy too lax (for example, allowing two-letter passwords), you should also avoid making your policy unnecessarily restrictive. For example, suppose your company is a medium-security environment, but you force users to create passwords of 10 characters or more in length, you keep a password history of 10 passwords, and you set a minimum password age of seven days. Your policy might result in users writing down their list of 10 passwords and taping it under their keyboard—obviously defeating the same network security you are trying to enforce! Ultimately, the best security policy is often a posted list of rules and procedures with warnings of the consequences of breaking the rules.

TIP

In a high-security environment, you can force users to choose complex passwords containing a mixture of uppercase letters, lowercase letters, numbers, and symbols by installing Passfilt.dll from Windows NT Service Pack 2 or later.

See also
account lockout, domain in Windows NT and Windows 2000, passfilt.dll

account template

An account template is a user account in Microsoft Windows NT created with User Manager for Domains that has common group memberships and account restrictions. The administrator can copy the template and make a few modifications to easily create new accounts.

How It Works

As an example, an administrator might create an account called MarketingUserTemplate, assign it membership in the marketing global group, and set a logon hours restriction and home directory location. Next, to create new marketing user accounts in User Manager for Domains, the administrator selects the MarketingUserTemplate account, and then selects User and Copy from the menu to create a copy of the account template with the same membership and restrictions. The administrator then assigns a user name, full name, description, and password to the new account; clicks Add; and continues creating more marketing user accounts.

NOTE

Do not assign any rights and permissions to an account template because these will not be copied to the new accounts. Disable the account template so that no one can use it to log on to the network.

TIP

Add an underscore to the beginning of your account templates (for example, _MarketUserTemplate) so that these will always be visible at the top of the User Manager for Domains window.

See also
user account, User Manager for Domains

ACE

See
access control entry (ACE)

ACK

Stands for acknowledgment; any transmission from a receiving station to a transmitting station communicating that the transmitted data has been received without errors. On the other hand, if the receiving station determines that the data transmission is late or has not arrived, a NAK (negative acknowledgment) is generated to indicate to the transmitting station that the data should be sent again.

The Transmission Control Protocol (TCP) is a connection-oriented protocol that relies on acknowledgments for successful transmission of data. When a stream of TCP packets is being sent over the network, each packet contains an acknowledgment number indicating the sequence number of the next packet that the receiving station should expect to receive. TCP can use an ACK to acknowledge a series of TCP packets that have been received, rather than just a single packet. A TCP packet sent as an acknowledgment has its ACK flag set to 1 to indicate that the acknowledgment numbers of the packets received are valid.

ACL

See
access control list (ACL)

ACM

See
Association for Computing Machinery (ACM)

ACPI

See
Advanced Configuration and Power Interface (ACPI)

Active Channel Multicaster

A component of Microsoft Site Server that provides the capability of distributing channels only one time per refresh period. This results in considerable savings in bandwidth and server resources, since networks not using the Active Channel Multicaster require each client to separately pull the same channel content. For example, if a network has 10 clients, the same content would traverse the network 10 times.

How It Works

Active Channel Multicaster uses multicasting to reduce the number of connections needed to broadcast channel information. The server opens only one connection to the Web in order to retrieve the channel information. The multicast server then transmits a single copy of the channel information, directed toward an Internet Protocol (IP) multicast group. Users who have subscribed to this multicast group receive the information being transmitted directly into their Microsoft Internet Explorer browser cache. Users then view the multicast information through the standard Internet Explorer interface.

To receive Active Channel Multicaster multicasts, Internet Explorer client browsers must have the Multicast Delivery Agent (MDA) installed on the client computers. The MDA runs in the background client computer and

  • Checks the CDF file against the client browser’s subscription list to identify multicast information

  • Replaces the delivery agent for the multicast channel content

  • Supplies the user with information about multicast subscriptions

Active Channel Server

A component of Microsoft Site Server 3.0 that lets Web content developers create, manage, and deliver Channel Definition Format (CDF) files. These files specify the channel’s structure and update frequency. Users receive channels utilizing a standard Web browser such as Microsoft Internet Explorer 4.0 and later.

How It Works

Active Channel Server supports both content channels and software channels. Content channels contain a collection of theme-based Web pages or other documents. Software channels contain program files and offer users new software and software updates.

Active Channel Server uses Active Channel Agents to collect content items from a specified source and organize them into channels. These agents are scripts that can automatically update channel content items according to a specified schedule. Active Channel Agents can collect content from

  • A shared directory on the network

  • Any open database connectivity (ODBC)–compliant database such as Microsoft SQL Server

  • Indexing Service

  • Site Server Commerce databases

  • Site Server Search catalogs

  • Knowledge Manager shared knowledge briefs

Active Channel Server can also use third-party agents or custom agent scripts to gather content from other sources.

Users then configure their Web browsers to either alert them when new channel content is available or automatically download the new content. If software channels are used, software can be automatically downloaded and installed on user machines.

Active Desktop

A feature first introduced with Microsoft Internet Explorer version 4.0 that enables active content from Web sites or channels to be displayed directly on your desktop. This includes content such as graphics, HTML pages, Microsoft ActiveX controls, Java applets, and channels. For example, you could have a stock ticker applet placed directly on your desktop that updates its information continually using a live Internet connection.

Active Desktop integrates the Web and your desktop, allowing you to launch programs, switch between files, and customize your desktop using active Web content. Active Desktop makes your desktop and its folders look and work like the Web, allowing you to browse resources on your computer or local network the same way you browse for content on the World Wide Web. Information about volumes, folders, and files can be displayed as Web pages within folders, and you can move up and down the folder hierarchy using a single click instead of a double click.

Graphic A-8. Active Desktop.
Graphic A-8. Active Desktop.

Active Desktop is included with Microsoft Windows 98 and Windows 2000, and is optionally available for Windows 95 and Windows NT 4.0 by installing Internet Explorer 4.0 and the Windows Desktop Update.

How It Works

The Active Desktop is implemented as an application programming interface (API) called the IActiveDesktop interface, which is part of the Windows Shell API. This interface is designed to allow client programs to manage desktop items and wallpapers on local computers. It also provides methods for adding desktop items (with or without a user interface, allowing the user to decide whether to accept the addition), adding desktop items associated with a URL, applying changes by writing settings to the registry, and so on.

The Active Desktop consists of two layers:

  • HTML layer:
    This is the background layer that hosts active Web content items. The HTML layer has three components: a file named desktop.htm that contains HTML tags for each active Web component on the desktop, an ActiveX control that lets you move or resize components on your desktop, and any other static HTML element you want to display in the background.

  • Icon layer:
    This transparent foreground layer integrates a web-type environment with familiar Windows 95 shell features such as double-clicking, drag-and-drop, file associates, and so on.

Users can add new items to the Active Desktop on their machines by using the display utility in Control Panel (or by right-clicking a blank area of the desktop and choosing Properties from the context menu). Either specify the URL of the object you want to add to your Active Desktop, or browse to locate it on your network or on the Internet (if you are connected). Programmers can use the ActiveDesktop interface to write routines that add, remove, or modify items on the Active Desktop. You can also add items to the Active Desktop using a Channel Definition Format (CDF) file.

See also
Active Platform

Active Directory

The directory service for the Microsoft Windows 2000 network operating system. Active Directory consists of both a database and a service. Active Directory is a database of information about resources on the network, such as computers, users, shared folders, and printers. It is also a service that makes this information available to users and applications. Active Directory provides the basic features needed for an enterprise-level directory service, including an extensible information source, naming conventions for directory objects, a common set of policies, and tools for administering the service from a single point of access. Administrators can configure Active Directory to control access to network resources by users and applications.

How It Works

The basic element of Active Directory is the object. An object can represent a user, computer, printer, application, file, or another resource on the network. Active Directory objects possess attributes, which are their properties. For example, some user attributes might include first name, last name, e-mail address, and phone number. Some attributes must have mandatory values, while others can be left undefined. Attributes of a printer might include the location of the printer, the asset number of the printer for accounting purposes, the type of printer, and so on.

A special type of Active Directory object is the organizational unit (OU). An OU is a type of object that can contain other objects. An OU can either contain a specific object, such as a user or an application, or it can contain another OU. Using OUs, you can organize Active Directory into a hierarchical directory of network information based on the X.500 directory recommendations of the International Telecommunication Union (ITU). You can assign users permissions on subtrees of OUs for management and resource access purposes.

Organizational units are contained within domains, which are the basic security and organizational structure for Active Directory. Every object in Active Directory must belong to a domain. Domains usually mirror the organizational structure of your enterprise and act as a security boundary in your enterprise. For example, privileges granted in one domain are not automatically carried over to another domain. Domains can be joined into larger structures called domain trees using two-way transitive trusts, and these tree structures can be grouped into domain forests for larger enterprises.

Discretionary access control lists (DACLs) and system access control lists (SACLs) protect Active Directory objects. DACLs and SACLs specify which user or application has permission to access attributes of directory objects, and work in a similar fashion to access control lists (ACLs) that are implemented in the version of NTFS used in Windows NT 4.0. DACLs and SACLs can be used to propagate their permissions to connected directory objects. They also provide a simple way for administrators to grant access and usage rights for Active Directory to users and groups.

Active Directory has a set of rules governing which objects can be stored in the directory and which attributes these objects can possess. This set of rules is known as the schema.

Information in Active Directory is maintained for each domain on the network. Active Directory database information is stored and maintained on machines called domain controllers. This information is replicated automatically between domain controllers to ensure that every portion of the distributed directory is up-to-date. By default, the replication of updates to Active Directory occurs automatically every five minutes. Automatic replication of Active Directory information occurs only within the security boundary of a specific domain. Domain controllers in one domain do not automatically replicate with those in another domain.

Active Directory provides network administrators with centralized administration of all information about resources on the network, and it provides both users and administrators with advanced search capabilities for locating resources on the network.

NOTE

The default naming convention for objects stored in Active Directory is an Active Directory canonical name of the object. This defines the object’s position in a domain tree from left to right, starting with the object’s name and delimited by slashes. For example, the User Account MSmith in the Marketing organizational unit of the northwind.microsoft.com domain would have the Active Directory canonical name:

msmith\users\marketing\northwind.microsoft.com

Active Directory supports non-DNS naming conventions for interoperability with non-DNS environments. An example is the Lightweight Directory Access Protocol (LDAP) naming convention. An LDAP URL is composed of the name of the server with the distinguished name of the object appended to it. Other naming conventions include the following:

  • User principal name:
    This convention consists of the user’s Security Accounts Manager (SAM) account name with an object’s user principal name suffix appended to it. The user principal name suffix is the name of the domain tree or the name of the domain above the object in the domain tree.

  • Request for Comments (RFC) number 822 Name:
    This naming convention is essentially the user’s e-mail address.

  • Universal Naming Convention (UNC):
    This convention can be used for shared resources.

TIP

Before implementing Active Directory in your enterprise, you will need to gather information about the structure of your organization because Active Directory usually mirrors this structure in some fashion. A good way to proceed is to use a centralized planning approach with a team consisting of both technical and management representatives. You must develop a naming strategy, plan your domain structure, and consider how you will delegate administrative duties concerning Active Directory. When you delegate administrative control to Active Directory, do so at the OU level instead of at the individual object level. This makes it easier to control portions of the OU hierarchy within Active Directory. In particular, you probably want to delegate control to individuals responsible for creating users, groups, computers, and similar objects.

TIP

Consider the speed of the various links between your different geographical locations, and how any systems that are not interoperable with Active Directory will be integrated into your new system. You should also profile your user community to determine what sort of domain hierarchy you will be implementing. Also consider integrating your Domain Name System (DNS) zone information into Active Directory because this will store your DNS zone information in the distributed Active Directory. Plus, it will facilitate and simplify updates of zone information through replication of domain controllers.

TIP

An important planning issue is determining where to locate domain controllers and global catalog servers for your enterprise. This is because after Active Directory is installed and configured, the majority of Active Directory traffic is related to Active Directory clients querying Active Directory for information. Directory replication traffic is usually a less important consideration, unless the organization is in a constant state of flux. Placing a domain controller at each site will optimize queries but can increase replication traffic. Nevertheless, placing a domain controller at a site that has users in that domain is usually the best solution. If the domain tree is large, you should not place a global catalog server at each site because this can create a lot of replication traffic. Place global catalog servers only at large regional sites. Remember that replication of modifications made to your Active Directory might take some time to propagate throughout your enterprise. For example, if you create a new user account object, it might be a few minutes before the user can actually log on to the network using the account.

On the Web
•
Active Directory Technical Summary
: http://www.microsoft.com/ntserver/windowsnt5/techdetails/prodarch/ad_techsummary.asp

Active Directory Client

A client on a machine running Microsoft Windows 2000 that allows the computers to log on to a network by locating a domain controller and then accessing information published in Active Directory. The purpose of Active Directory Client is to enable the client machine to access information stored in Active Directory on domain controllers in the network.

NOTE

A version of Active Directory Client called the Directory Services client is available for computers running Windows 95 and Windows 98. This client allows them to log on to a Windows 2000 domain and access information published in Active Directory. The Directory Services client can be found in the \clients folder on the Windows 2000 Server compact disc. Microsoft Internet Explorer version 5.0 or later must be installed on the machine running Windows 95 or Windows 98 prior to installing the Directory Services client. A similar client will also be available for Windows NT version 4.0 machines.

Active Directory Domains and Trusts

A Microsoft Windows 2000 management console that can be used for administering domain modes and trust relationships. Active Directory Domains and Trusts provide administrators with a graphical representation of all the domain trees in a domain forest. Using the Active Directory Domains and Trusts, you can perform common administrative tasks such as

  • Creating an explicit domain trust and managing existing trust relationships between domains

  • Changing the domain mode from mixed mode to native mode

  • Adding user principal name suffixes for a forest

    Graphic A-9. Active Directory Domains and Trusts.
    Graphic A-9. Active Directory Domains and Trusts.
NOTE

To start the Active Directory Domains and Trusts, open the administrative tools shortcut named Active Directory Domains And Trusts.

TIP

You can also use the Active Directory Domains and Trusts to open Active Directory Users and Computers by right-clicking on a domain and then selecting Manage from the shortcut menu.

See also
administrative tools (Windows 2000)

Active Directory Installation Wizard

A wizard on a machine running Microsoft Windows 2000 that installs Active Directory service on a member server, turning it into a domain controller. You can use Active Directory Installation Wizard to

  • Create a new domain controller with a new domain tree

  • Create a new domain controller with a new child domain that is located under a parent domain in an existing domain tree

  • Create a replica domain controller for an existing domain

    Graphic A-10. Active Directory Installation Wizard.
    Graphic A-10. Active Directory Installation Wizard.
How It Works

You must be an administrator to run Active Directory Installation Wizard. Start the wizard by running the dcpromo utility from the command prompt, or choose the Run command from the Start menu, enter dcpromo in the Run dialog box, and then click OK. This opens the wizard’s welcome screen, where you are required to make a number of decisions concerning the following:

  • Whether to create a new domain or add a replica domain controller to an existing domain

  • If you choose to create a new domain, whether to create a new domain tree or add a child domain to an existing tree

  • If you choose to create a new domain tree, whether to create a new domain forest or add the new tree to an existing forest

Names you specify for new or existing domains, domain trees, or domain forests are based on the Domain Name System (DNS) naming system. Other steps in the wizard allow you to specify the path to the Active Directory database, the location of the SYSVOL share, and so on.

These are the results of running Active Directory Installation Wizard:

  • The machine on which the wizard is run becomes a domain controller. If it is the first domain controller in your domain, the wizard also creates a new site for that controller. If it is the first domain in your enterprise, it is also the root domain for any domain tree that will be created. You can use the wizard to create the first domain forest in your enterprise too.

  • The first domain controller is also your global catalog server.

  • Active Directory files are located in %SystemRoot%\Ntds with the associated log files.

  • The shared system volume SYSVOL, which stores scripts used for implementing group policies for your domain, is located in %SystemRoot%\Sysvol.

  • A number of default organizational units (OUs) are created, namely the Users, Builtin, Computers, and Domain Controllers.

TIP

You must make sure that DNS is already installed and configured prior to running Active Directory Installation Wizard in order to create the first domain controller for your network. A DNS name will be needed for your new domain controller, and a DNS server must be available on the network during the installation process.

Active Directory files also require an NTFS volume, which must be configured as a basic volume. Dynamic volumes cannot be used for Active Directory files. Running the wizard creates a log file in the %SystemRoot%\Debug folder that shows the results of the installation procedure.

If you are creating a new child domain, there must be an available domain controller on the existing parent domain. If you are creating a replica domain controller, there must be an available domain controller in the target domain.

Active Directory schema

Formal term for all object classes that can be stored in Active Directory and all attributes that make up these object classes. The schema defines which kinds of objects are permitted to be published in Active Directory and states their possible attributes.

How It Works

The schema consists of two types of objects:

  • Classes:
    These objects are predefined collections of attributes. For example, every user account on a network is represented in Active Directory by a User class object.

  • Attributes:
    This is the actual information stored in an object. For example, a User class object is composed of attributes such as Name, PhoneNumber, and so on.

Attributes are defined separately from classes. This allows each attribute to be defined only once and then used in many different classes. Class definitions (such as the User class) and attribute definitions (such as the Name attribute) are themselves objects within Active Directory. This means you can manage class and attribute definitions in Active Directory with the same tools you use to manage other objects (user and group accounts, computers, and so on).

The schema is located under the rootDSE object, which contains information about the directory and is located at the top of the Lightweight Directory Access Protocol (LDAP) directory naming structure. You can access this object using the LDAP URL:

LDAP://rootDSE

Active Directory of Microsoft Windows 2000 includes a default schema that defines commonly used object classes such as users, groups, computers, domains, organizational units (OUs), and security policies. Active Directory is extensible and can be modified using Active Directory Schema. Specifically, you can modify the schema by

  • Defining new object types and their attributes

  • Defining new attributes for existing object classes

  • Removing attributes from existing object classes

  • Removing existing object classes

NOTE

Existing object classes and their attributes cannot actually be deleted; they are simply marked “defunct” in Active Directory and can no longer be used.

See also
Active Directory Schema

Active Directory Schema

A Microsoft Windows 2000 administrative tool that can be used to modify Active Directory. Active Directory comes with a default schema that defines various common default object classes such as Users, Groups, Computers, and Domains—plus, it defines their attributes. Using Active Directory Schema, you can modify your organization’s schema by

  • Creating new classes and modifying existing ones

  • Creating new attributes and modifying existing ones

  • Deactivating unnecessary classes and attributes

Members of the Schema Admins group, of which the default Administrator account is automatically a member, are the only users who can make changes to the schema. A typical use for Active Directory Schema is adding new attributes to an existing User object, for example a SeniorityLevel attribute.

NOTE

Active Directory Schema is an advanced tool that should be used only by qualified administrators, as an inexperienced user could easily render your Active Directory inoperable. Before you can use this tool to modify the schema, you must add a registry setting to your machine and specify the one domain controller that can be used to modify the schema for your enterprise. This prevents unauthorized access to the schema and inconsistencies that can occur when the schema is simultaneously modified in more than one place. You must also install the snap-in for this tool in a Microsoft Management Console (MMC) console before you can use it—it is not available from the Start menu’s list of Administrative Tools.

TIP

Another way of modifying Active Directory schema is to write a script that uses Active Directory Service Interfaces (ADSI) to make calls that modify the schema. This is the best solution if you want to modify the schema for an entire enterprise or if you want to automate modifications to the schema.

See also
Active Directory schema

Active Directory Service Interfaces (ADSI)

An object-oriented programming interface to Active Directory of Microsoft Windows 2000. More generally, a set of interfaces built on the Component Object Model (COM) that lets applications work with various types of directories using a single access method. Active Directory Service Interfaces (ADSI) was formerly known as OLE DS.

How It Works

ADSI works by abstracting the capabilities of directory services from different network providers to present a single set of interfaces for managing network resources in a distributed computing network. ADSI provides a simple, open, functionally rich, and scriptable method for interfacing with any directory service, independent of the vendor. ADSI is built on the Component Object Model and consists of two types of COM objects (directory service leaf objects and directory service container objects) that clients can manipulate with interfaces. ADSI providers are used to implement these objects and their interfaces. Each object in a given namespace is identified using a unique name. For example, file system objects can be specified using their absolute path, while directory objects are usually specified using their X.500 address. However, ADSI is flexible enough to handle any naming system used by third-party vendors’ directory service implementations.

ADSI can be used by programmers and administrators to create directory-enabled applications using tools such as Microsoft Visual Basic or Microsoft Visual C++. ADSI supports the Lightweight Directory Access Protocol (LDAP) C API defined in Request for Comments (RFC) number 1823, which specifies a low-level interface for C language programming and provides support for the Messaging Application Programming Interface (MAPI) so that legacy MAPI applications will work with Active Directory.

Active Directory Sites and Services

A Microsoft Windows 2000 management console that can be used to administer Active Directory sites, domain trees, domain controllers, subnets, and intersite links. Using Active Directory Sites and Services, you can perform common administrative tasks such as

  • Creating a new site and configuring replication within the site

  • Configuring directory service (DS) objects and licensing site settings

  • Adding servers, domain controllers, intersite links, and subnets to a site

  • Moving and repairing domain controllers

  • Delegating control of a site

    Graphic A-11. Active Directory Sites and Services.
    Graphic A-11. Active Directory Sites and Services.
See also
administrative tools (Windows 2000)

Active Directory Users and Computers

A management console in Microsoft Windows 2000 that can be used for administering Active Directory objects and information published in the directory. Using Active Directory Users and Computers, you can perform common administrative tasks such as

  • Creating a new user, group, shared folder, computer, printer, or other resource

  • Creating new organizational units (OUs) for organizing directory objects

  • Moving directory objects to different organizational units

  • Deleting objects from the directory

  • Displaying and editing the properties of directory objects

  • Managing group policies and changing domain controllers

  • Finding objects within Active Directory database

NOTE

To start Active Directory Users and Computers, choose Programs from the Start menu, choose Administrative Tools, and then choose Active Directory Users And Computers.

TIP

If you want to quickly assign permissions to network resources such as file shares, printers, users, and groups in your enterprise, simply move their associated directory objects to different servers that require the same permissions to the same OU. Objects inherit permissions from their new OU and lose permissions from their old OU. However, permissions assigned directly to an object are moved together with the object.

Graphic A-12. Active Directory Users and Computers.
Graphic A-12. Active Directory Users and Computers.
See also
administrative tools (Windows 2000)

The Active Group

A consortium of software and systems vendors that is dedicated to the promotion and widespread adoption of Microsoft ActiveX technologies. The goal of The Active Group is to build on the success of ActiveX technologies and ensure that their evolution meets the needs of the broadest possible community of developers and users. Microsoft provides source code, reference specifications, and validation testing standards for ActiveX technologies to The Active Group.

The Active Group functions as an authoring group working under the auspices of The Open Group, a group dedicated to lowering the barriers of integrating new technology across the enterprise. Members of The Active Group steering committee include Adobe Systems, Computer Associates International, DEC, Hewlett-Packard Company, Microsoft Corporation, Powersoft-Sybase, Sheridan Systems, Siemens-Nixdorf Information Systems, Software AG, Videosoft, Visio, and Wall Data.

On the Web
•
The Active Group
: http://www.activex.org

active hub

A hub that has electronic circuitry to regenerate weak signals. Active hubs function as multiport repeaters, allowing computers to be networked together in a star topology. Virtually all hubs sold today are active hubs.

See also
passive hub

active partition

The partition that contains the boot files for the operating system you want to run, that is, the partition from which the computer starts up. On a computer running Microsoft Windows 2000 or Windows NT that is based on the x86 family of CPUs (an x86-based computer), the active partition must be a primary partition. In addition, on a computer running Windows 2000, the active partition must be on a basic disk.

Alpha-based computers have no active partitions; these are configured by the manufacturer-supplied configuration program.

NOTE

Depending on your platform, you can use any of the following tools to make a partition active:

  • The fdisk utility from the command prompt for MS-DOS and Windows 95 or Windows 98 platforms

  • The Disk Administrator administrative tool in Windows NT

  • The Computer Management administrative console in Windows 2000

See also
system partition

Active Platform

A set of Microsoft technologies for developing applications for the Internet. Applications developed using Active Platform technologies can be accessed and run from any client platform independent of the operating system, as long as a standard Web browser such as Microsoft Internet Explorer is installed on the client.

Active Platform is actually an umbrella term for three key Microsoft technologies:

  • Active Desktop:
    Integrates the Microsoft Windows desktop with the Internet, providing a seamless connection between local and remote applications and resources. Active Desktop is a core technology of Internet Explorer.

  • Active Server:
    The Active Platform component of Microsoft Internet Information Services (IIS) version 5 or later. Using Active Server technologies, core Windows NT services can be extended to the Internet using applications developed with Microsoft Active Server Pages (ASP) technologies.

  • Microsoft ActiveX:
    A component software technology based on the Component Object Model (COM). ActiveX allows distributed Web-based applications to be developed in any programming language and then run from within an ActiveX-enabled browser such as Internet Explorer.

active scripting

The process of using a scripting language such as Microsoft Visual Basic Scripting Edition (VBScript) or Microsoft JScript to drive Component Object Model (COM) components. Host applications such as Microsoft Internet Information Services (IIS) with Microsoft Active Server Pages (ASP) and Microsoft Internet Explorer have scripting engines for running scripts written in VBScript or JScript. Active scripting engines can be developed for other interpretive scripting languages, such as Perl, to leverage a developer’s existing knowledge of these programming platforms. Scripting engines for client software, such as Internet Explorer, are specially designed to eliminate the authoring components that are not needed in a nonauthoring host environment. This makes the client-side scripting engine lightweight, which yields better performance.

How It Works

In a typical scenario, the host application loads the script document and calls an application programming interface (API) to create a new instance of a scripting engine. The host application feeds the script to the engine and executes the script.

Active Server Pages (ASP)

An open, compile-free application environment for developing Web applications for Microsoft Internet Information Server (IIS) version 3.0 and later. Microsoft Active Server Pages (ASP) can be used to build powerful, distributed Web-based applications that combine Hypertext Markup Language (HTML), script, and Microsoft ActiveX technologies to provide dynamic Web sites. ASP combines the ease of HTML with familiar programming tools such as Microsoft Visual Basic Scripting Edition (VBScript) and Microsoft JScript, along with reusable Component Object Model (COM) components. These components can be used to build powerful, dynamic Web sites. ASP executes on the Web server, and the output returned to the Web browser is a plain HTML file.

How It Works

A page created using ASP typically contains a mixture of HTML, scripts, and other components written in any programming language. When a client requests an ASP file, the scripts in the file are processed on the server. The scripts can reference components running on either the local server or any other accessible server, and can perform actions such as accessing a database, sending e-mail, or processing information in another fashion. The result is then returned by the server to the client as a standard HTML file and displayed in the usual way.

For example, when requested, the following ASP file will return the current time and browser type to the requesting client:

<HTML>
<HEAD><TITLE>Sample Web Page</TITLE></HEAD>
<BODY>
The time right now is <% = now %>
Your browser type is <% =Request.ServerVariables("http_user_agent")
%>
</BODY>
</HTML>

You can use ASP to develop Web content that is customized for user preferences and demographics and that uses Microsoft ActiveX Data Objects (ADO) and open database connectivity (ODBC) to provide access to multiple data sources. ASP provides a browser-neutral approach to the design of Web applications where all of the application logic resides on the server.

ASP on IIS version 4.0 integrates with Microsoft Transaction Server (MTS), allowing ASP-based Web applications to take advantage of Transaction Server’s process isolation, scalability, and transaction programming model.

NOTE

Unlike the stateless Hypertext Transfer Protocol (HTTP), ASP is a session-based technology. When a user connects to an ASP file on a Web server, a session object is created. After the session expires, the session object is destroyed. The default time-out for ASP applications is 20 minutes, although Outlook Web Access uses a time-out of 60 minutes.

On the Web
•
Charles Carroll’s ActiveServerPages.com
: http://www.activeserverpages.com
•
15 Seconds home page
: http://www.15seconds.com
See also
Active Platform

Active Setup

A Microsoft ActiveX engine that can be used to interactively download and install software over the Internet using a standard Web browser such as Microsoft Internet Explorer.

How It Works

Active Setup makes use of the fact that source files of the application to be installed are partitioned into segments, the traditional ACME setup cabinet files (*.cab files). Active Setup begins by downloading a small, self-extracting setup package to the browser client. This file also collects information about the client’s computer to help determine which components already exist on the system and whether the desired application is compatible with the system’s configuration. The user specifies a location from which to download the desired application and the types of components to be installed. The application’s *.cab files are then downloaded as needed, after which Active Setup is completed and normal ACME setup can continue.

TIP

One advantage of Active Setup is that if the download is interrupted, it can be resumed at the interruption point rather than at the beginning.

active volume

The volume from which a computer starts up. On a computer running Microsoft Windows 2000, the active volume must be a simple volume, and it must be on a dynamic disk.

NOTE

You can upgrade the basic disk that contains the active partition to a dynamic disk, making it a simple volume that is active, but you cannot mark an existing dynamic volume as the active volume.

active window

The window that has the focus on a Microsoft Windows desktop. The active window is the window belonging to the application in which the user is currently working. If several windows are open on a user’s desktop, only one of these windows can be the active window. A unique color on the active window’s title bar distinguishes it from other windows. If the user enters commands or text using the keyboard, these commands or text will be routed to the program displaying the active window. To make a window the active window on the desktop, simply click on it using the mouse, or cycle through the windows on the desktop using Alt+Tab.

TIP

You can capture a bitmap image of the active window to the clipboard by pressing Alt+PrintScreen. Then open Paint, paste the contents of the clipboard into the program, and save it as a *.bmp image.

ActiveX

An umbrella term for Microsoft technology for building and using software components. Microsoft ActiveX is built on the Component Object Model (COM) and Distributed Component Object Model (DCOM) technologies, which enable software components to interact across a network.

The term “ActiveX” was first coined at the Internet Professional Developers Conference (Internet PDC) in 1996 and was based on the conference slogan “Activate the Internet.” ActiveX does not replace OLE but broadens and enlarges it to include the Internet and intranet technologies. ActiveX is supported by most Microsoft development and productivity applications, including Visual Basic, Visual C++, and Office.

On the Web
•
Microsoft COM home page
: http://www.microsoft.com/com
See also
Component Object Model (COM), OLE

ActiveX component

See
COM component

ActiveX controls

Compiled, reusable software components based on Microsoft’s Component Object Model (COM). ActiveX controls, formerly called OLE controls, can be combined as prefabricated components to aid developers in building new applications.

How It Works

ActiveX controls can draw themselves in their own windows, respond to events such as mouse clicks, and be managed through properties and methods. An ActiveX control cannot run as a stand-alone program but must be loaded into a control container such as Microsoft Visual Basic or Microsoft Internet Explorer. ActiveX controls typically provide a user interface and are generally designed to run on the client.

ActiveX controls are often used to provide dynamic features for Web pages—for example, a stock ticker control that adds a live stock ticker to a Web page, an advanced user interface navigation tool, and an animation control that adds animation functionality to a page.

ActiveX controls can be embedded into a Hypertext Markup Language (HTML) page by using the HTML <OBJECT> tag. If a user tries to access such a page using a Web browser and the embedded ActiveX control is not installed on his or her system, the control can be automatically downloaded by using the URL specified in the CODEBASE attribute of the <OBJECT> tag. Once the ActiveX control is downloaded and installed on the user’s system, the browser will continue to use the cached control until an updated version becomes available on the server.

Here is an example of a typical <OBJECT> tag that includes a CODEBASE attribute:

<OBJECT ID="BoomButton" WIDTH=225
HEIGHT=35
CLASSID="clsid:56F1BF40-B2D0-11d0-A6D6-00AA00A70FC2"
CODEBASE="http://example.microsoft.com/AControl.cab#Version=1,0,0,1">
</OBJECT>
NOTE

A malicious ActiveX control can potentially damage software or data on a user’s computer. To help users determine whether an ActiveX control is safe to install, Microsoft has developed a code-signing technology called Authenticode, which identifies the creator of a control using a digital signature issued by a well-known security authority such as VeriSign Inc.

ActiveX Data Objects (ADO)

A data access interface used to communicate with OLE DB–compliant data sources. ActiveX Data Objects (ADO) is a high-level object-based interface to OLE DB. OLE DB is a low-level complex interface to the data source. Using ADO and OLE DB, a client application can connect to a variety of data sources using the same programming model. These data sources include relational databases, hierarchical databases, indexed sequential access method (ISAM) databases, and virtually any other kind of data source for which an open database connectivity (ODBC) driver exists. In order to communicate with these unique data sources, ADO and OLE DB employ components called OLE DB providers, which are designed for specific data sources. If a native OLE DB provider is not available for a data source, but an ODBC driver is available, it should be possible to access the data source using the ODBC driver and an OLE DB provider designed to communicate with ODBC drivers.

ADO is supported in a variety of environments. For example, ADO could be used in Microsoft Visual C++ and Microsoft Visual Basic to access data in an OLE DB data source, such as Microsoft SQL Server. ADO can also be used in conjunction with Microsoft Internet Information Services (IIS) to create Microsoft Active Server Pages (ASP) applications that access data sources.

NOTE

In a Web-based environment, ADO is basically a server-based solution for data access. All data operations, such as changes to database records and filtering, must take place on the server. The client can then receive the data but cannot easily manipulate it. For applications in which the client must be able to manipulate the data being accessed, use remote data binding with Remote Data Service (RDS) instead. RDS is a technology that enables the user to manipulate data on the client and have any changes automatically made on the server. Allowing data to be manipulated on the client makes Web applications faster and more responsive.

TIP

ADO communicates with a database through a networking library. Choosing the right networking library can significantly improve data access performance. For example, if Microsoft SQL Server is running on the same machine as IIS, using named pipes can provide better performance than using the TCP/IP networking library.

adapter

Generally, a device for connecting two different types of electronic hardware without losing functionality. In networking, a cable adapter has two different connectors that provide data transmission back and forth. Cable adapters come in many varieties, and they are specified by the two connector types and whether the connectors are male or female (for example, DB9 female to DB25 male adapter). Cable adapters are a necessary part of the network administrator’s toolkit because of the large number of connectivity options provided by networking equipment vendors.

The term “adapter” is also used in a number of different contexts in networking, including the following examples:

  • Network interface cards (NICs) are sometimes called network adapter cards because they provide connectivity between computers and network cabling.

  • Cigarette lighter adapters can be used to power cellular phones or laptops from an automobile battery.

  • Digital phone adapters allow analog modems to be connected directly to Private Branch Exchange (PBX) phone outlets without damage.

  • ST-SC adapters provide connectivity between fiber-optic connectors of differing types.

Adaptive Differential Pulse-Code Modulation (ADPCM)

A technique for converting analog sound, such as speech, into binary digital information by frequently sampling the sound and expressing its modulation in binary form. Adaptive Differential Pulse-Code Modulation (ADPCM) codecs convert analog signals into digital information by quantizing the differences between the actual analog signal and a predicted signal. The result is that analog signals encoded into files using ADPCM have a smaller size than many other formats. ADPCM enables speech information to be compressed into small files for storage and transmission.

Personal Communications Services (PCS) cellular telephony systems use a 32-Kbps ADPCM coding system to provide the same quality of voice communication that is available in wired telephone networks. This standard was developed by the International Telecommunication Union (ITU) and is known as G.721.

ADC

See
analog-to-digital converter (ADC)

Add New Hardware

A Control Panel utility in Microsoft Windows 95 and Windows 98 that is used to install new peripheral hardware on your machine. On machines running Windows 98 that are fully Plug and Play compliant, you can either plug the device into the computer while it is running (for hot-pluggable devices) or you can turn off the machine, install the card, turn on the machine, and have Windows 98 automatically enumerate the new device and begin the installation procedure. The Add New Hardware Wizard generally needs to be run only for legacy devices that are not fully Plug and Play compliant.

Graphic A-13. A screen from the Add New Hardware Wizard in Windows 98.
Graphic A-13. A screen from the Add New Hardware Wizard in Windows 98.
How It Works

To install a device using the Add New Hardware Wizard in Windows 98, start the wizard and let Windows 98 look for Plug and Play devices. If the device is a legacy device, let Windows 98 search it. If Windows 98 cannot find the device, you must identify it from a list of devices by selecting a device class, choosing the manufacturer and model, and specifying the location of the appropriate driver for the device.

NOTE

In Windows 2000 this hardware utility has been enhanced and is called Add/Remove Hardware.

TIP

Make sure your hardware device is attached to your machine and turned on before running the Add New Hardware Wizard!

Add Printer

A wizard in Microsoft Windows 95, Windows 98, Windows NT, and Windows 2000 that is used to install a printer on your machine.

How It Works

The Add Printer wizard can be used to install both locally attached printers (such as one connected to an LPT port on your computer) and a network printer (such as one connected to a print server or a printer with its own network card). To install a locally connected printer, simply specify the manufacturer and model number of the printer and load the appropriate printer driver. To install a network printer, you need to specify the Universal Naming Convention (UNC) path to the network printer, which must first be shared on the network. After the printer has been installed, its property sheet can be opened to allow further settings to be configured. The installation of a printer ends with the optional printing of a test page to verify that the installation was successful.

NOTE

In Windows 2000, you can publish a printer in Active Directory to configure the properties of a printer.

Add/Remove Programs

A Control Panel utility in Microsoft Windows 95, Windows 98, Windows NT, and Windows 2000 that lets you install and remove applications from your system. Using this utility you can

  • Configure your Windows operating system by installing or removing optional Windows components.

  • Install programs from floppy disk, CD-ROM, or network share point. For Windows 2000, you can also install programs from Microsoft over the Internet.

  • Uninstall programs and their registry settings for previously installed programs.

  • Create a startup disk for troubleshooting purposes (Windows 95 and Windows 98 only).

NOTE

The Windows 2000 version of this utility is more advanced and has a different interface than earlier versions (see the screen capture).

Graphic A-14. A utility in Windows 2000.
Graphic A-14. A utility in Windows 2000.
TIP

If you are short on disk space, use Add/Remove Programs to remove seldom-used components of Windows from your hard drive.

address book view

A virtual container in Microsoft Exchange that lets Microsoft Exchange Server administrators group recipients according to common attributes. These containers are created automatically when you establish the defining attributes for the address book view.

How It Works

For example, using the Exchange Administrator program, you could create an address book view called By Department and use the Department attribute of the recipients in your Exchange organization to automatically generate various address book view containers called Sales, Marketing, Management, and so on. Each address book view container will contain only those recipients that belong to a specific department. For instance, when users access the global address list using Microsoft Outlook, these containers will be visible in their address books, along with their recipients. This allows users to more quickly address e-mail to recipients in a particular department instead of scrolling down the entire global address list.

You can also create multilevel address book views. For example, you could create a first level of virtual containers sorted by Country, followed by a second level sorted by State.

TIP

If you use the Exchange Administrator program to move a recipient from one address book view to another, the recipient takes on the defining attributes of the new address book view.

address record

Also called an A record, a type of resource record in the Domain Name System (DNS) that maps the name of a host computer or other network device to an IP address. Address records enable resolvers to query a DNS server on the network in order to resolve a host name or fully qualified domain name (FQDN) of a machine into its IP address so that network communication with the machine can be established. Address records are one of the most commonly used types of resource records stored in DNS zone files. A large part of the administrative work of a DNS administrator is creating and maintaining accurate address records for hosts on the network. The syntax for the address record is specified in Request for Comments (RFC) number 1035.

Example

An address record for the host named SERVER12 located in the northwind.microsoft.com Internet domain and having the IP address 172.16.8.55 would be

server12.northwind.microsoft.com    IN    A   172.16.8.55

Here IN identifies the record as belonging to the Internet class, and A identifies that it is an address record.

Address Resolution Protocol (ARP)

A TCP/IP network layer protocol responsible for resolving IP addresses into MAC addresses. Address Resolution Protocol (ARP) is defined in Request for Comments (RFC) number 826.

How It Works

When a TCP/IP-aware application tries to access another TCP/IP host using its IP address, the destination host’s IP address must first be resolved into a MAC address so that the frame can be addressed and placed on the wire and then be recognized by the destination host’s network interface card (NIC). This is because network interface cards operate at the physical layer (layer 1) and data-link layer (layer 2) of the Open Systems Interconnection (OSI) reference model and must use physical addresses (such as MAC addresses) instead of logical addresses (such as IP addresses) for network communication.

Graphic A-15. Address Resolution Protocol (ARP).
Graphic A-15. Address Resolution Protocol (ARP).

ARP broadcasts an ARP Request packet that effectively says, “Who has the following IP address?” This broadcast requests the MAC address of the destination host. The destination host then responds with an ARP Reply packet containing its own MAC address. The requesting host next temporarily stores the IP-to-MAC-address mapping in its local ARP cache in case this is required again within a short interval of time.

NOTE

If the destination host is on a remote network, ARP obtains the MAC address of the local router interface that connects the local network to the remote network.

See also
arp command

address space

Information that indicates which address types and subtypes can be handled by connectors and gateways for Microsoft Exchange Server. This information is used to determine how messages are routed. Each time a new connector or gateway is installed, a new address space must be created for that connector or gateway. For example, if a message were being routed through the Internet Mail Service to the address someone@microsoft.com, the address type would be SMTP and the address space would be microsoft.com. Other address types include MS Mail and X.400.

Each address space can be assigned a cost value, which is used for optimizing outbound message routing. The lower the cost value of an address space, the less it will be used by the connector. If two address spaces have the same cost value, each route will be given roughly equal priority in the routing process.

ADMD

See
Administrative Management Domain (ADMD)

ADMIN$

A special administrative share created during installation on computers running Microsoft Windows NT and Windows 2000 and used for remote administration of the computer. The path of this share is always the path to the %SystemRoot% directory (usually C:\Winnt). The Administrators group is assigned full control permissions on the ADMIN$ share on a Windows NT system. This allows administrators to access the share and remotely administer the system without needing to know where the system files are stored. Only the Administrators group has access to the ADMIN$ share.

administrative alert

A dialog box that displays on Microsoft Windows NT to notify selected users and computers of problems or warnings. Alerts are generated by the Windows NT Alerter service. Administrative alerts can be displayed when problems with security, access, sessions, directory replication, and printing occur, or when a server is shut down by an uninterruptible power supply (UPS) device.

You can configure which specific users or computers will receive administrative alerts by using Server Manager.

TIP

If you configured alerts to be sent to a specific computer but they are not being received, check your alert configuration in Server Manager. You might have misspelled the name of that particular computer—Server Manager does not validate computer names.

Administrative Management Domain (ADMD)

In X.400 messaging, a message-handling system (MHS) that is managed by a registered private agency. Administrative Management Domains (ADMDs) are usually large public telecommunications carriers such as MCI WorldCom and AT&T. This is in contrast to a Private Management Domain (PRMD), which represents a message-handling system managed by a private corporation. In the X.400 world, PRMDs cannot communicate directly with each other; instead, they must communicate through ADMDs. All the ADMDs in the world therefore form a kind of messaging backbone for global X.400 communication.

NOTE

The ADMD is the second field in a typical X.400 originator/recipient (O/R) address and is located right after the country field.

See also
X.400

administrative share

A share created during setup by Microsoft Windows NT or Windows 2000 for system purposes and remote administration. These shares usually end in the “$” character, which makes them hidden shares. You cannot modify the permissions on these shares and you cannot remove the shares.

Here are some examples of administrative shares:

  • C$, D$, and so on:
    The shares used by administrators to connect to the root of each volume on a network server and perform remote administration such as creating and deleting files and folders

  • ADMIN$:
    The share name for the %SystemRoot% folder, used by the system during remote administration

  • IPC$:
    A share used by interprocess communication (IPC) resources for sharing the named pipe interface, which allows applications running on different computers to communicate over the network

  • PRINT$:
    A share used to support shared printers

  • REPL$:
    A share used by the Directory Replicator Service that allows directory trees to be exported

  • NETLOGON:
    A share used by the NetLogon service that enables the processing of domain requests

See also
share

administrative tools (Windows 2000)

A Microsoft Windows 2000 program group containing tools for administering a network based on Windows 2000. These tools are implemented as preconfigured snap-ins for the Microsoft Management Console (MMC) and are commonly referred to as consoles. Each administrative tool corresponds to an MMC console with a particular snap-in installed. The set of available tools for a particular machine running Windows 2000 depends on how that machine was installed and configured. Commonly installed tools for Windows 2000 Server, which can be used for both local and remote administration, can include

  • Component Services

  • Computer Management

  • Configure Your Server

  • Data Sources (ODBC)

  • Distributed File System

  • Event Viewer

  • Internet Services Manager

  • Licensing

  • Local Security Policy

  • Performance

  • Routing and Remote Access

  • Server Extensions Administrator

  • Services

  • Telnet Server Administration

NOTE

Internet Services Manager (HTML) is implemented as an HTML tool that can be run from within a standard Web browser such as Microsoft Internet Explorer.

TIP

As an administrator, you can create your own administrative tools by opening a blank MMC console and installing the various snap-ins you need. When you save this tool, it will automatically be saved in the Administrative Tools program group.

administrative tools (Windows NT)

A Microsoft Windows NT program group containing tools for administering a Windows NT–based network. The basic set of tools for Windows NT Server 4.0 consists of the following:

  • Administrative Wizards

  • Backup

  • Disk Administrator

  • Event Viewer

  • License Manager

  • Migration Tool for NetWare

  • Network Client Administrator

  • Performance Monitor

  • Remote Access Admin

  • Server Manager

  • System Policy Editor

  • User Manager for Domains

  • Windows NT Diagnostics

The number of tools, which can be extended by installing additional Windows NT services using the Network utility in Control Panel, includes the following tools:

  • DHCP Manager

  • DNS Manager

  • File Manager

  • Network Monitor

  • WINS Manager

NOTE

A subset of these administrative tools can be installed on Windows NT Workstation 4.0, and a smaller subset can be installed on Windows 95 or Windows 98. The files required to install the client-based network administrative tools on Windows NT Workstation 4.0 and Windows 95 or Windows 98 are available in the \Clients\Srvtools directory on the Windows NT Server 4.0 compact disc.

administrative wizards

A Microsoft Windows NT administrative tool that consists of a number of wizards designed to facilitate common administrative tasks, namely

  • Creating new user accounts

  • Creating new groups and modifying the membership of groups

  • Configuring permissions for accessing files and folders

  • Installing local printers or connecting to network printers

  • Installing new programs or removing existing ones

  • Installing a modem

  • Creating disk sets for installing network client software

  • Managing license compliance

See also
administrative tools (Windows NT)

administrator

Generally, a person who has full rights and permissions to all resources on a network. The administrator is usually responsible for installing, managing, and controlling servers and networking components. Administrators can also modify the properties of user accounts and the membership of groups, create and manage security printers, install printers, share resources, and assign permissions to those resources.

In Microsoft Windows NT and Windows 2000, the Administrator account is a built-in account whose password is defined during installation. In Windows NT, the administrator account is a member of the Domain Admins group and the Administrators group on the domain controller on which it is defined, and it has full rights and permissions on all user-accessible system resources. In Windows 2000, the administrator account is a member of the built-in Administrators group.

NOTE

On a Windows NT domain controller, the Administrator account is a global user account, while on a Windows NT member server or workstation, the Administrator account is a separate local account.

TIP

You can rename the default Administrator account, but you cannot delete it. If you rename the account, make sure you remember what the new name is!

See also
Administrators group

Administrators group

In Microsoft Windows NT, a built-in group existing on all servers and workstations, whose initial membership consists of the Domain Admins group (on domain controllers only) and the Administrator user account (on all computers running Windows NT). In Windows 2000, a built-in group with similar membership.

The Administrators group has full rights on all user-accessible processes on a computer running Windows NT or Windows 2000. For example, on a Windows NT domain controller, the Administrators group has the right to

  • Log on locally

  • Access the computer over the network

  • Take ownership of files

  • Change the system time

  • Configure auditing and manage the security log

  • Shut down the system

  • Back up and restore files and directories

  • Force shutdown from a remote system

  • Load new device drivers

  • Add computers to the domain in Windows NT and Windows 2000

See also
built-in group

ADO

See
ActiveX Data Objects (ADO)

ADPCM

See
Adaptive Differential Pulse-Code Modulation (ADPCM)

ADSI

See
Active Directory Service Interfaces (ADSI)

ADSL

See
Asymmetric Digital Subscriber Line (ADSL)

Advanced Configuration and Power Interface (ACPI)

An open industry specification that enables software designers to integrate features for power management throughout a computer system, including the hardware, operating system, and application software. Advanced Configuration and Power Interface (ACPI) is supported by Microsoft Windows 2000 and enables the operating system to handle all the power-management resources for computer subsystems and peripherals. ACPI works with subsystems and peripherals for a wide range of mobile, desktop, and server platforms. ACPI is also the foundation for the OnNow industry initiative that enables computers to start at the touch of the keyboard.

NOTE

ACPI support can be enabled for Windows 98 by running Setup using the following command-line switch:

setup /p j

Running Setup in this mode adds the ACPIOption string value with a value data of 1 to the Windows 98 registry and causes hardware devices to be queried for ACPI support during setup. Note that Windows 98 does not support all ACPI features, for example Passive Cooling Mode.

On the Web
•
ACPI home page
: http://www.teleport.com/~acpi
•
Microsoft OnNow and Power Management
: http://www.microsoft.com/hwdev/onnow.htm

Advanced Infrared (AIr)

A connectivity technology for high-speed, low-cost infrared (IR) networking developed by IBM. IBM is the first vendor to release products based on the Advanced Infrared (AIr) standard and is working with the Infrared Data Association (IrDA) to standardize the technology.

How It Works

AIr allows ad hoc multipoint wireless peer-to-peer connections to be formed simultaneously between multiple wireless information appliances such as Personal Digital Assistants (PDAs), cellular phones, laptops, and digital cameras. The devices must be within 8 meters of each other to reliably communicate without interference. AIr ports can receive signals within a 120-degree cone, which means that the ports need not be precisely aimed at each other to achieve reliable transmission. AIr currently supports data throughput of up to 4 Mbps for direct line-of-sight communication, but it can interoperate with the existing slower IrDA 1.1 standard, and it supports the Very Fast Infrared (VFIR) standard currently under development.

See also
Infrared Data Association (IrDA), infrared transmission

Advanced Mobile Phone Service (AMPS)

The standard analog cellular phone service used in North and South America. Advanced Mobile Phone Service (AMPS), which was introduced by AT&T in the early 1980s, was the first generation of cellular phone technology and is widely deployed throughout the United States.

How It Works

AMPS uses frequencies in the 800-MHz to 900-MHz range of the radio spectrum. It modulates a 3-kHz voice channel onto 30-kHz FM carrier signals using Frequency Division Multiple Access (FDMA) to create a series of 30-kHz channels. Separate channels are used for base station to mobile transmission (forward channels) and mobile station to base transmission (backward channels). The resulting allocation of bandwidth for each channel results in a maximum of approximately 800 simultaneous phone conversations per operator.

Because the population of most cities would suggest that 800 simultaneous phone conversations is far from enough, the idea was developed to partition the coverage of cities into a number of small areas called “cells.” Each base station uses a limited-power transmitter with a directional antenna to provide coverage for a small geographical cell (from which the term “cellular communication” arose). A typical cell ranges from .5 kilometer to 20 kilometers in size, depending on whether the coverage is in a densely populated urban area or a sparsely populated rural one. Mobile users’ phones also have limited transmission power, meaning that communication is usually limited to the immediate cell the user is in. As a user moves from one cell to another, the signal is smoothly picked up from the new cell. Adjacent cells use different frequencies, which prevents interference.

Handheld AMPS cellular phones have power levels generally under 0.6 watts with a range of about 5 miles from the base station, while power levels in vehicle-mounted phones reach up to 3 watts with a range of 15 miles. Base stations themselves generally have power levels up to about 1 kilowatt.

Because of the need for data transmission and security (encryption), digital cellular phone services are increasing in popularity.

On the Web
•
Universal Wireless Communication Consortium
: http://www.uwcc.org
See also
cellular phone technology, Code Division Multiple Access (CDMA), Digital Advanced Mobile Phone Service (D-AMPS), Global System for Mobile Communications (GSM), Time Division Multiple Access (TDMA)

Advanced Peer-to-Peer Networking (APPN)

A protocol developed by IBM as the second generation of Systems Network Architecture (SNA). Advanced Peer-to-Peer Networking (APPN) is an extension of SNA that was developed

  • To enable SNA traffic to flow concurrently with other protocols

  • To provide prioritization of SNA traffic

  • To allow users to establish sessions without mainframe involvement

APPN provides a mechanism for peer-to-peer networking and session establishment between any two logical units (LUs) on an SNA network. APPN provides greater distributed network control than legacy SNA by isolating the effects of single-point failures. It supports the dynamic exchange of information about network topology to facilitate connection, reconfiguration, and route selection. APPN also supports the dynamic definition and automated registration of network resources.

Advanced Program-to-Program Communications (APPC) protocol

A protocol for peer-to-peer networking in a Systems Network Architecture (SNA) environment usually associated with AS/400 host systems.

How It Works

Advanced Program-to-Program Communications (APPC) protocol relies on each device in the network communicating directly with the others. Computers depend on their own intelligence for network communication and do not need constant access to a centrally located AS/400 host. APPC supports display and other application services across an SNA network. The overall architecture for peer-oriented SNA networks is known as Advanced Peer-to-Peer Networking (APPN). Advanced Program-to-Program Communications protocol lets applications on different APPN systems communicate across a network.

APPC is used for a variety of purposes in the AS/400 environment including

  • 5250 access

  • TN5250 access

  • File transfer

Applications that use APPC to communicate are called transaction programs (TPs).

NOTE

Microsoft SNA Server provides services necessary for APPC connectivity with AS/400 systems and mainframe hosts. APPC is typically used in peer-oriented SNA networks running on AS/400 host systems, although mainframe hosts can also support it.

Advanced Streaming Format (ASF)

A method of streaming data supported by Microsoft NetShow. Advanced Streaming Format (ASF) supports video, audio, images, URLs, and scripts. ASF streams can combine different types of data, allowing you to stream presentations involving slides and audio narration.

Using the NetShow Real-Time Encoder, you can generate live ASF streams that contain audio and video. You can also use tools provided with NetShow to create and store ASF files that you can later stream. NetShow can deliver ASF streams using either multicasting or unicasting.

TIP

When multicasting an ASF stream, configure NetShow to provide a supplemental unicast source for the stream for any clients that cannot receive multicasts.

AFTP

See
APPC File Transfer Protocol (AFTP)

agent

Simple Network Management Protocol (SNMP) client software that runs on a hub, a router, or another networking component. Agents collect information about TCP/IP statistics and conditions and can supply this information when requested to an SNMP management system. Agents can also alert management systems to errors and other conditions when a trap occurs. SNMP agents are identified by the community to which they belong.

How It Works

An agent must be installed on each networking component that will be managed in an SNMP-managed network. The agent program can then perform operations such as

  • Get operations initiated by the SNMP management console for obtaining information about a specific managed object in the host Management Information Base (MIB)

  • Get-next operations initiated by the management console to continue traversing the MIB database from the point at which it was accessed by a get operation

  • Set operations initiated by the management console to set a value for a managed object (if permissions allow this)

  • Trap operations initiated by the managed host itself when an error condition occurs, such as when the computer’s disk becomes full

NOTE

Microsoft Windows NT includes an optional service called the SNMP service, which can be used to install SNMP agent software to enable management by SNMP management consoles. TCP/IP must be installed before the SNMP agent service is installed. By default, the agent listens to TCP port number 161 for SNMP messages and to port number 162 for SNMP traps.

TIP

Windows 98 also includes an SNMP agent conforming to SNMP 1.0 specifications that lets you monitor remote connections to machines running Windows 98 from an SNMP management console. This agent is implemented as a Win32 service using Windows Sockets over TCP/IP. You can install the Microsoft SNMP agent on Windows 98 using the Network utility in Control Panel.

AGLP

The mantra for administering a Microsoft Windows NT enterprise-level network: user A ccounts are organized by placing them in G lobal groups, which are then placed into L ocal groups that have appropriate P ermissions and rights assigned to them.

How It Works

In practice, these are the steps for administering a Windows NT enterprise-level network:

  1. Create global user accounts for users in the account domains or master domains.

  2. Create global groups in these domains to organize users according to function, location, or some other criteria (or use the Windows NT built-in groups if these suffice).

  3. Assign global users to their respective global groups.

  4. Determine who needs access to network resources in the resource domains.

  5. Create local groups on domain controllers and member servers within the resource domains (or use the Windows NT built-in groups if these suffice).

  6. Assign rights and permissions to each local group as desired to provide access to network resources.

  7. Finally place global groups into local groups as desired to provide users with permissions to access resources.

    Graphic A-16. AGLP.
    Graphic A-16. AGLP.
NOTE

On Windows 2000-based networks, the mantra is AGDLP since local (L) groups are referred to as domain local (DL) groups.

AIr

See
Advanced Infrared (AIr)

AIX

A version of the UNIX operating system developed by IBM for its RS/6000 platform of servers and workstations. The first version of AIX was based on the UNIX System V operating system (release 2). The current major version is AIX Version 4.3. AIX is supported by symmetric multiprocessor (SMP) systems, scalable parallel systems, and workstations. These are some of the features of AIX 4.3:

  • Concurrent support of 32-bit and 64-bit applications using 64-bit hardware

  • A Web-based management system for managing AIX using any Java 1.1–enabled browser

  • Binary compatibility with earlier version 4 .x releases

  • C2 level security certification

  • Fast Connect for high-speed PC file and print services

On the Web
•
AIX Operating Environment
: http://www.rs6000.ibm.com/software/aix_os.html

Alerter service

A Microsoft Windows NT service responsible for sending administrative alerts to users and computers. The Alerter service generates an alert when potentially dangerous conditions occur, such as when disk space is running out. You can configure which users or computers receive these alerts by using Server Manager (or by using the Server utility in Control Panel). Pop-up alert messages will appear if the administrator is logged on or is at the appropriate computer when the alert occurs. The administrator can then consult the system log for information about what caused the alert.

TIP

The Server service must be running for the Alerter service to function. The Messenger service should also be running on both the sending and receiving computers. Also, restart the Server service and Alerter service on the computer after modifying the list of users and computers to whom alert conditions on that computer should be sent.

alias

Literally, a name for a name. An alias can be a nickname that identifies a user for e-mail. A user’s alias is usually a shortened form of the user’s full name, such as the alias JSmith or JeffS for user Jeff Smith. Aliases are a convenient way of identifying users and form the user-specific portion of an e-mail address. For example, if Jeff Smith belongs to a company whose Domain Name System (DNS) domain on the Internet is northwind.microsoft.com, his e-mail address would be either JSmith@northwind.microsoft.com or, instead, JeffS@ northwind.microsoft.com, depending on which alias is selected. In Microsoft Exchange Server you can use the auto naming feature in the Exchange Administrator program to generate the alias for a new recipient.

TIP

What if both a Jeff Smith and a Jeff Smythe work at the same company? If JeffS is the alias for the first user, you could use JeffS2 for the second. It all depends on your choice of naming convention.

All Users folder

A directory on a machine running Microsoft Windows NT that is used to store desktop settings and Start menu shortcuts for applications in the Common Programs group. Shortcuts in this group are available to all users who log on locally to the machine. The All Users folder is located in the path %SystemRoot%\Profiles\All Users. If you modify the settings in this folder, any new users who log on locally to the machine will inherit the new settings in their user profile. This can be a useful way to provide standard shortcuts to people who use a particular machine.

Alpha platform

A computer platform whose processor is based on the DEC Alpha RISC architecture microprocessor. Alpha is one of two processor platforms supported by Microsoft Windows NT (the other being Intel’s x86 platform). Alpha-based systems, which are used primarily for high-performance servers and workstations, can run operating systems such as Windows NT, Digital UNIX, and OpenVMS.

The Alpha 21164 processor is specifically designed for running Windows NT desktop applications and includes a new set of motion video instructions (MVI) for high-performance multimedia applications. The superscalar design of this processor integrates a 16-KB instruction cache, an 8-KB data cache, and a 96-KB second-level cache and can issue four instructions for each clock cycle. It uses 0.35-micron CMOS-integrated circuit technology and a fully pipelined 64-bit RISC architecture to provide the highest performance for Windows NT systems. The processor is housed in a 499-pin ceramic package and generates 28 watts of heat when running at 366 MHz. It is designed to work with the AlphaPC 164LX motherboard.

On the Web
•
Digital Semiconductor Alpha Microprocessors home page
: http://www.digital.com/alphaoem/
•
The AlphaNT Source
: http://dutlbcz.lr.tudelft.nl/alphant

American National Standards Institute (ANSI)

A U.S. standards organization that facilitates and governs the development of standards in many areas, including computing and communication. The American National Standards Institute (ANSI) was founded as a private sector voluntary standards association in 1918 and is a nonprofit, private association with almost 1400 member organizations.

ANSI doesn’t create standards itself, but it oversees groups and organizations in the development of standards. ANSI is a member organization of the International Organization for Standardization (ISO) and provides the charter for the Institute of Electrical and Electronics Engineers (IEEE).

Standards that are approved by ANSI are called ANSI Standards. Examples include the ANSI C/C++ programming language standards, ANSI-89 SQL standards, and ANSI character set. There are over 13,000 standards that have been approved by ANSI to date.

On the Web
•
American National Standards Institute home page
: http://www.ansi.org

American Registry for Internet Numbers (ARIN)

A nonprofit organization that administers the registration of blocks of IP addresses to Internet service providers (ISPs) in those areas previously managed by Internet Network Information Center (InterNIC) via its designated representative Network Solutions, Inc., namely North and South America, the Caribbean, and sub-Saharan Africa. IP address blocks are usually assigned to large national ISPs who then allocate smaller blocks to regional and metropolitan ISPs, who in turn allocate IP addresses to the networks of their corporate clients and dial-up users.

NOTE

IP address registration is administered in Europe by the Reseaux IP Europeans (RIPE) and in the Asia Pacific region by the Asia Pacific Network Information Center (APNIC). Two additional Internet Protocol (IP) registries are planned for the continents of Africa and South America.

On the Web
•
ARIN home page
: http://www.arin.net

AMP

See
asymmetric multiprocessing (AMP)

AMPS

See
Advanced Mobile Phone Service (AMPS)

analog

See
analog transmission

analog modem

A modem used for asynchronous transmission of data over Plain Old Telephone Service (POTS) lines. Analog modems are still a popular component for remote communication between users and remote networks.

How It Works

The word “modem” stands for “modulator/demodulator,” which refers to the fact that modems convert digital transmission signals to analog signals and vice versa. For example, in transmission, an analog modem converts the digital signals it receives from the local computer into audible analog signals that can be carried as electrical impulses over POTS to a destination computer or network.

To transmit data over a telephone channel, the modem modulates the incoming digital signal to a frequency within the carrying range of analog phone lines (between 300 Hz and 3.3 kHz). To accomplish this, multiplexing of the digital signal from the computer with a carrier signal is performed. The resulting modulated signal is transmitted into the local loop and transmitted to the remote station where a similar modem demodulates it into a digital signal suitable for the remote computer.

However, this basic process can transmit data only at speeds of about 1200 bps. To achieve the much higher speeds of today’s modems, advanced technologies must be applied, including echo canceling, training, data compression, and special modulation algorithms such as quadrature amplitude modulation (QAM). Using these technologies, modem speeds of 56 Kbps are now common.

Bell Labs in the 1960s and 1970s originally formulated modem standards, but after the breakup of Bell Telephone, the task of developing modem standards was taken over by the International Telegraph and Telephone Consultative Committee (CCITT), which is now called the International Telecommunication Union (ITU). According to ITU specifications, modem standards are classified by a series of specifications known as the V series.

analog-to-digital converter (ADC)

Any device for changing analog signals into digital transmission—for example, recording someone singing onto a CD. The pressure waves in the air produced by the vibration of the person’s vocal chords are analog in form and continually vary in strength within a certain range of values. The recording equipment samples this continually varying information at discrete time intervals and converts it to digital form.

Analog-to-digital converters (ADCs) are used in industry to convert environmental variables (temperature, pressure, density, speed, and so on) that vary continuously over time to digital information, which can then be analyzed using computer programs. ADCs are used in analog modems to convert digital signals into audio and vice versa.

analog transmission

Transmission of signals that vary smoothly with time, as shown in the diagram. An analog signal can take on any value in a specified range of values. A simple example is alternating current (AC), which continually varies between about +110 volts and -110 volts in a sine wave fashion 60 times per second. A more complex example of an analog signal is the time-varying electrical voltage generated when a person speaks into a dynamic microphone or telephone. Analog signals such as telephone speech contain a wealth of detail but are not readily accessible to computers unless they are converted to digital form using a device such as an analog-to-digital converter (ADC). Old-fashioned vinyl records store sound information in the form of a continuously varying analog groove, but modern musical CDs store their information in digital form. Some individuals claim that they can actually tell the difference between an analog and a digital recording, and generally agree that the analog recording sounds “warmer.”

Analog signals are usually specified as a continuously varying voltage over time and can be displayed on a device known as an oscilloscope. The maximum voltage displacement of a periodic (repeating) analog signal is called its amplitude, and the shortest distance between crests of a periodic analog wave is called its wavelength.

Graphic A-17. Analog transmission.
Graphic A-17. Analog transmission.
NOTE

The local loop of the Plain Old Telephone Service (POTS) is limited to carrying sound signals in frequency range from 300 Hz to 3300 Hz (3.3 kHz). This range is suitable for voice communication, but limits the theoretical maximum speed of analog modem transmissions to about 56 Kbps.

anchor

In Hypertext Markup Language (HTML), a source or target of a hypertext link. An anchor can be either text or a graphic and is specified using the tag formation <A …>…</A>. Anchor tags are fundamental to HTML and make the hypertext concept of linked documents possible. Without anchor tags, Web pages could not be linked together. There are two types of anchor tag. The first type creates a hypertext link that refers to a document. For example, the following HTML element will display the word “contents” as a hyperlink. If the user clicks on the link, the browser will load the contents.htm page specified in this tag:

<A TARGET="_window2" HREF="http://www.northwind.microsoft.com/contents.htm">Contents</A>

The second type of anchor tag marks a portion of text as a destination for a hyperlink. You can place the following element at the end of the contents.htm page:

<A NAME="bottom">This is the end of the page</A>

To load the contents.htm page and jump directly to the bottom of the page, the user needs to click a hyperlink such as this one:

<A TARGET="_window2" HREF="http://www.northwind.microsoft.com/contents.htm#bottom">Contents</A>

announcement

Enables Microsoft NetShow clients to receive streaming multimedia information. Announcements, which are used only with Advanced Streaming Format (ASF) transmissions, are text files that have the extension .asx.

How It Works

The function of an announcement depends on whether the transmission method is multicasting or unicasting. If the transmission method is multicasting, announcements enable NetShow clients to retrieve the channel file containing channel information. If the transmission method is unicasting, announcements supply the client with information on how to connect to the NetShow server.

TIP

Once created, an announcement can be distributed to clients by several means: over the Web, through e-mail, or on a network share.

Announcement Manager

A service in Microsoft Windows 98 that automatically runs in the background when you have WebTV for Windows installed on your computer.

How It Works

Announcement Manager receives broadcast announcements from TV networks or Web sites that notify your computer about the time and address of the broadcast and which software applications must be running to receive the broadcast. When Announcement Manager receives an announcement, it directs it to the broadcast filters you have configured for your WebTV service. The broadcast filters then determine whether to ignore the broadcast or schedule its receipt.

Announcement Manager is part of the Microsoft Broadcast Architecture, a specification for receiving Web information broadcast to your computer through a TV tuner interface.

anonymous access

One of three authentication schemes for Microsoft Internet Information Services (IIS). Anonymous access allows anonymous users to gain access to Web content hosted on the IIS server by using the anonymous user account. Anonymous access is usually reserved for low-security public Web sites, where the identity of the individual visiting the site is not important. By enabling anonymous access to the site, distrusted users from the Internet can access content on the site. By contrast, private corporate intranets use a higher form of authentication, such as

  • Windows NT Challenge/Response Authentication when clients are running Microsoft Windows and are using Microsoft Internet Explorer as their browser

  • Basic Authentication when clients are running another operating system or Web browser

See also
Basic Authentication, Windows NT Challenge/Response Authentication

anonymous user

Any user who attempts to access network resources without providing a username or password. Some Microsoft Windows NT applications like Microsoft Internet Information Services (IIS) can be configured to allow anonymous users to access their resources. This allows distrusted users from unsecure networks such as the Internet to access data that is made available for the public at large.

NOTE

Access to network resources by anonymous users can be controlled by assigning permissions to a special anonymous user account. Windows NT then provides anonymous users access to resources by impersonating the user utilizing the anonymous user account.

anonymous user account

See
IUSR_ComputerName

ANSI

See
American National Standards Institute (ANSI)

ANSI C/C++

A standard published by the American National Standards Institute (ANSI) for writing C and C++ code. Programs written in ANSI C or ANSI C++ are portable to a large number of computing platforms. Most commercial C/C++ programming tools, such as Microsoft Visual C++, contain extensions to ANSI C/C++ that simplify common programming tasks considerably but restrict the portability of the resulting code to different platforms.

TIP

You can use Visual C++ to write strict ANSI C/C++ code by following these guidelines:

  • Call Win32 application programming interfaces (APIs) directly in your program instead of using the Microsoft Foundation Classes (MFC) libraries.

  • Disable the Microsoft extensions to C++ by running Visual C++ using the /Za command-line option.

  • Use the isostream and standard template libraries from the ANSI Standard C++ library and the appropriate #include statements in your code.

ANSI character set

An 8-bit character set used by Microsoft Windows 95 and Windows 98 that lets you represent up to 256 characters (numbered 0 through 255). The ASCII (American Standard Code for Information Exchange) character set is a subset of the ANSI (American National Standards Institute) character set with characters numbered 32 through 126, each representing a displayable character. Some ANSI character codes cannot be displayed by Windows 95 or Windows 98 applications and are generally displayed as solid blocks on the output device.

ANSI uses a single byte to represent a character, in contrast to the Unicode standard supported by Windows NT, which uses 2 bytes to represent a character. For example, the ANSI character “A” would be represented in hexadecimal notation by the single byte 41h. The 256-character limit of ANSI supports only a few international characters, such as accented French and German vowels, but the 65,536-character limit of Unicode supports virtually every alphabet in the world. For example, the Unicode character “A” would be represented in hexadecimal notation by the two-byte string {41h, 00h}. The following table shows which Windows environments support ANSI and Unicode for character encoding.

Windows Environments and Character Encoding
ANSI | Unicode
16-bit Windows object libraries | 32-bit Windows object libraries
Windows 95 and Windows 98 API | Windows NT API
 | Automation in Windows 95, Windows 98, and Windows NT

answer file

A text file that can be used to perform an unattended installation of Microsoft Windows NT and Windows 2000.

How It Works

In the answer file, you specify in advance the answers to the user prompts that occur during a normal installation. This can include specifications such as what keyboard layout to use, whether the computer should join a domain or belong to a workgroup, what network protocols should be installed, and so on. The answer file is invoked using the /u switch when running the winnt or winnt32 setup utility. Answer files can be customized for individual machines by using Uniqueness Database Files (UDFs). The UDFs can be used to specify computer-specific parameters such as the computer name.

TIP

For Windows NT, a sample answer file unattend.txt is located in the \I386 folder on the Windows NT CD. You can customize this file using Microsoft Notepad or another text editor to suit your needs.

In Windows 2000, the answer file should be named sysprep.inf and must reside in the Sysprep folder, located in the root of the drive on which you are installing Windows 2000. Setup ignores the answer files named differently or located elsewhere.

AOP

See
Association of Online Professionals (AOP)

API

See
application programming interface (API)

APPC

See
Advanced Program-to-Program Communications (APPC) protocol

APPC File Transfer Protocol (AFTP)

A protocol that provides file transfer capabilities for the Advanced Program-to-Program Communications (APPC) protocol. APPC File Transfer Protocol (AFTP) servers are the APPC equivalent of File Transfer Protocol (FTP) servers in the TCP/IP world.

Microsoft SNA Server can be used to establish AFTP connections to AS/400 or mainframe computers running the APPC applications suite. Users can then utilize standard FTP client software to transfer files between the SNA server and the AS/400 or mainframe host. The optional AFTP service must first be installed on the SNA server. The installation can be configured so that the SNA server performs the function of an FTP-to-AFTP gateway. This will enable standard FTP clients to transfer files to and from the mainframe host.

Apple Open Transport

An Apple networking technology for transport-independent networking that is part of the networking and communication subsystem of the Macintosh operating system. Apple Open Transport is designed to make it easy to set up and configure networking on the Macintosh computer and to increase the performance of file, print, and other networking services on a MacOS server. Open Transport provides a consistent interface for configuring network services across supported protocols and a uniform set of application programming interfaces (APIs) for accessing networking and communication services on the Macintosh. Open Transport enables protocols to be loaded and unloaded on demand, provides a networking naming scheme plus consistent network services over the TCP/IP and AppleTalk protocols, and includes support for TCP/IP services such as Dynamic Host Configuration Protocol (DHCP) and Domain Name System (DNS). Open Transport also provides consistent API access to serial communication on the Macintosh, while third-party support is available for PPP, NCP/IPX, SMB/TCP/NetBIOS, DECnet, LAT, and X.25.

The Open Transport/AppleTalk protocol stack supports both the dynamic self-addressing of traditional AppleTalk clients and newer manually assigned static addressing. The Open Transport/TCP/IP protocol stack supports DHCP, bootstrap protocol (BOOTP), both local hosts files and DNS, Internet Protocol (IP) multicasting, both Ethernet Version 2.0 and IEEE 802.3 framing, TCP wildcard source port assignments, PPP connectivity, IP multihoming, and almost unlimited simultaneous TCP connections (limited only by installed memory and processor power).

TIP

An Apple Macintosh running Open Transport/TCP/IP can function as a DHCP client to a Microsoft Windows NT server running as a DHCP server, but not as a WINS client.

AppleShare

The file sharing protocol for AppleTalk networks. AppleShare provides these functions:

  • Enables sharing of volumes, folders, and printers

  • Provides auditing information on which resources have been accessed

  • Supports password-based control of access to shared resources

By installing Services for Macintosh on a Microsoft Windows NT server, the Windows NT server can emulate an AppleShare server so that Macintosh clients can access shared resources on the Windows NT server.

AppleShare IP

An Apple networking technology that supports native TCP/IP on the Apple Macintosh platform and provides Web, file, print, and e-mail services for departmental and workgroup-level environments. The latest version, AppleShare IP v6.1, features a single integrated administration console for local server management, remote administration using a standard Web browser, IP address filtering, Sherlock searching support, multihosting, Simple Mail Transfer Protocol (SMTP) and point of presence (POP) protocol support, shared Internet Mail Access Protocol (IMAP) folders, Domain Name System (DNS) services, and full compatibility with MacOS 8.5.

AppleShare IP client software must be installed on Macintosh client machines to enable them to access AppleShare IP services on a server over the network. AppleShare IP supports both Server Message Block (SMB) and File Transfer Protocol (FTP) protocols in addition to AppleShare file sharing, and is compatible with both Macintosh and Microsoft Windows clients.

applet

A program written using the Java programming language, which can be accessed through a Web page and downloaded to the client machine where it is run within the Web browser window. Java applets can add dynamic functionality to static Web pages provided users view these pages with a Java-enabled Web browser.

How It Works

When an applet is created, its Java statements are compiled into an intermediate pseudo-machine-code language called a bytecode. The bytecode file is stored as a class file on a Web server like Microsoft Internet Information Services (IIS), and a Web page can reference the class file using an <APPLET> tag. When a Web browser requests the page and encounters the <APPLET> tag, the bytecode in the class file is executed in a Java virtual machine on the browser.

AppleTalk

The original networking protocol for Apple Macintosh networks. AppleTalk enables users to share folders and printers for access by other network users. AppleTalk is a legacy technology that has been largely replaced by Apple Open Transport, which supports AppleTalk, TCP/IP, and other popular network protocols.

How It Works

AppleTalk is a workgroup-level networking technology that supports up to 254 network nodes per physical network. AppleTalk can run on top of the legacy LocalTalk data-link protocol, which was built into the Macintosh RS-449/RS-422 serial interface. In the more recent AppleTalk Phase II, the data-link protocols supported include EtherTalk, TokenTalk, and FDDITalk for connectivity with Ethernet, Token Ring, and Fiber Distributed Data Interface (FDDI) networks, respectively. Addresses of machines on AppleTalk networks are randomly self-assigned when the machine is first attached to the network, and then broadcast to ensure they are not already being used. This dynamic addressing feature is based on the AppleTalk Address Resolution Protocol (AARP). AppleTalk internetworks are logically partitioned into zones whose main function is to make network resources easier for users to access. A zone is a logical representation of AppleTalk network nodes that can span multiple physical networks. The mapping between zones and network numbers is maintained by the Zone Information Protocol (ZIP), which creates Zone Information Tables (ZITs) that are stored on AppleTalk routers.

AppleTalk is a suite of networking protocols that work together to provide file and print sharing services to Macintosh networks. The following illustration shows the details of the AppleTalk protocol suite.

Graphic A-18. AppleTalk.
Graphic A-18. AppleTalk.
NOTE

Apple Open Transport includes an updated version of AppleTalk with additional features such as support for manually assigned node addresses, support for multihomed and multinode systems, and other features.

application gateway

A type of firewall that provides application-level control over network traffic. Application gateways can be used to deny access to the resources of private networks to distrusted users over the Internet.

How It Works

Application gateways examine incoming packets at the application level and use proxies to create secure sessions with remote users. For example, when an external user with a Web browser tries to access the company’s internal web server, the application gateway runs a proxy application that simulates the internal web server. A session is established between the remote user and the proxy application, while a separate, independent session is established between the proxy application and the internal web server. The remote user makes a request to the proxy, the proxy acts as a go-between and obtains the information from the internal web server, and then the proxy returns the result to the remote user.

The advantage of using application gateways over packet-filtering routers is that in packet filtering, a direct network connection still exists between the remote user and the internal network resource, while an application gateway prevents the remote user from directly accessing the internal network resource. This layer of additional security comes at some cost, namely that application gateways are generally slower and require a separate proxy application for each internal network service you want to make available through the firewall.

application layer

Layer 7 of the Open Systems Interconnection (OSI) reference model, in which network-aware, user-controlled software is implemented—for example, e-mail, file transfer utilities, and terminal access. The application layer represents the window between the user and the network. Examples of protocols that run at the application layer include File Transfer Protocol (FTP), Hypertext Transfer Protocol (HTTP), telnet, and similar protocols that can be implemented as utilities the user can interface with.

Originally the OSI model consisted of two kinds of application layer services with their related protocols:

  • Common Application Service Elements (CASE):
    These enable users to initiate or terminate peer (Layer 7 to Layer 7) connections between different machines on the network, enable reliable transfer of information between them, initiate remote operations, and support recovery from failure and rollback steps.

  • Specific Application Service Elements (SASE):
    These can include file transfer, message handling, terminal access, and other services that make use of the CASE elements and protocols.

These terms have largely been replaced with the term Application Service Elements (ASE) to describe the elements of the application layer.

NOTE

In most real-world networking, such as TCP/IP networking, many of these application layer services have no meaning.

application layer proxy

Any service or server that acts as a proxy for client computer requests at the application’s protocols. For example, in Microsoft Proxy Server, the Web Proxy Service is an application layer proxy for the Hypertext Transfer Protocol (HTTP), Secure Hypertext Transfer Protocol (S-HTTP), File Transfer Protocol (FTP), and Gopher protocols. Application layer proxies provide security by hiding internal network addresses from the outside world.

Application layer proxies provide more support for the additional capabilities of each protocol than do circuit layer proxies. For example, application layer proxies can support virus scanning. Application layer proxies are also client-neutral and require no special software components or operating system on the client computer to enable the client to communicate with servers on the Internet using the proxy server.

Microsoft Proxy Server can grant users access to selected application layer protocols and can restrict access to remote Web sites by domain name, IP address, and subnet mask.

application log

A Microsoft Windows NT and Windows 2000 log that records events generated by applications running on the system. The application log can be viewed and managed using Event Viewer and can contain three types of events:

  • Error event:
    Indicated by a red stop sign and signals a serious condition, such as a failed service

  • Warning event:
    Indicated by a yellow warning sign and signals a potentially serious condition, such as low disk space

  • Information event:
    Indicated by a blue information sign and signals a noteworthy event, such as a service successfully starting up

Microsoft BackOffice applications typically log events to the application log. Administrators should review the application log regularly to ensure that applications are running properly. The following screen capture shows the application log as viewed by the Event Viewer management console for Windows 2000.

Graphic A-19. Application log.
Graphic A-19. Application log.
See also
Event Viewer, security log, system log

application programming interface (API)

A collection of programming routines and functions that an application can use to access low-level machine services. Also a set of calling conventions in a programming language that specifies how such a service is invoked through an application. Application programming interfaces (APIs) let C and assembly language routines interact with services and programming tools.

When you write applications for a high-level operating system like Microsoft Windows, you use standard Windows APIs to access standard operating system and networking services and functions. One application can then issue an API call to another application in order to execute that API function. Details of APIs are primarily of interest to developers.

Windows operating systems provide predefined sets of APIs for various purposes, such as Telephony Application Programming Interface (TAPI) for accessing functions related to making voice, data, or fax calls; Messaging Application Programming Interface (MAPI) for messaging functions; and so on.

Example

An example of an API function in Windows NT is NetServerEnum. When a computer on a network issues a net view command to obtain the list of resources or computers that can be accessed using Network Neighborhood or Windows Explorer, the client computer issues a NetServerEnum API call to the Computer Browser service.

application service provider (ASP)

A general term for a company that offers software services to business customers across a wide area network (WAN) such as the Internet, particularly services involving outsourcing of Web and e-business applications. Application service providers (ASPs) are often Internet service providers (ISPs), software vendors, or system integrators that have “repackaged” themselves to appeal to business customers.

In a broad sense, an ASP is a company that rents applications to business clients over the Web. These are typically prepackaged line-of-business applications but can also include custom software applications developed especially for the client. In contrast with simple Web hosting companies that offer their clients access to database applications and scripting tools but little else, ASPs also host the client’s business logic and data at their remote data centers and provide a full range of supporting services to the client. Another umbrella term used to describe the range of services offered by ASPs is “Websourcing.”

The ASP sector is rapidly increasing in popularity, especially among small to medium-sized businesses. The International Data Corporation (IDC) projects that this sector might grow from $150 million in 1999 to almost $2 billion by 2003. ASPs are beginning to offer everything from e-commerce applications to enterprise resource planning (ERP) services.

TIP

Use of an ASP can reduce corporate IT costs and speed deployment of e-business applications. The ASP approach is particularly attractive to newer, rapidly growing companies that have limited IT personnel and expertise. When you look for an ASP, consider its ability to provide additional capacity as your business grows. Also consider whether you are willing to trust an outside company with sensitive internal corporate data, whether you need a general contractor or a one-stop shopping solution, and how well outsourced solutions will integrate with your existing enterprise applications.

On the Web
•
ASP News Review
: http://www.aspnews.com
See also
Internet service provider (ISP)

APPN

See
Advanced Peer-to-Peer Networking (APPN)

archive attribute

An attribute of files and folders that, when marked or set by the Microsoft Windows NT Backup program, indicates that the file or folder has been backed up. Then, when the backup program is run again, if the archive bit is still set, the file is not backed up because it has not been modified. If the file is modified in the interim, the archive attribute is cleared, indicating that the file needs to be backed up again.

The archive attribute for a file can also be set or cleared manually by opening the file’s property sheet.

TIP

If you use the xcopy command to copy files using Windows 95 or Windows 98, the destination files created will always have the archive attribute set.

See also
backup, backup type

archiving

The process of long-term storage of important data for security and recovery reasons. Archived data is usually stored in a compressed format because it is required infrequently.

Some of the files that a Microsoft Windows NT administrator might consider archiving regularly include

  • Event log files for the system, security, and application logs

  • Performance monitor files for monitoring trends in memory, disk, processor, and network usage over time

  • Log files for applications such as Microsoft Internet Information Services (IIS)

TIP

When you archive event log files, you can save these files in log file format, text file format, or comma-delimited text file format. The actual binary data of an event is saved only if you archive it in event log format, but saving the information in a comma-delimited text file format allows you to import these logs into a spreadsheet program to analyze trends.

ARCNET

Acronym for Attached Resource Computer Network, an early local area network (LAN) architecture developed in 1976 by Datapoint Corporation. ARCNET predates Ethernet and uses RG/62 93-ohm coaxial cabling, RS485 twisted-pair cabling, or fiber-optic cabling to transmit data at 2.5 Mbps and a maximum of 255 nodes. A newer implementation called ARCNET Plus operates at a data rate of 20 Mbps and a maximum of 2047 nodes.

ARCNET is a baseband networking technology that is similar to standards for token-passing bus networks running over broadband cabling. ARCNET uses a token-passing bus architecture with nodes forming a logical ring but a physical bus or star pattern.

TIP

A computer running Microsoft Windows NT on an ARCNET network will have difficulty communicating with computers running Windows 95 and Windows 98 on the same network. This is because Windows NT uses Raw ARCNET, while Windows 95 and Windows 98 use Encapsulated ARCNET. The workaround solution is to install the 16-bit TCP/IP stack with Novell Open Data-link Interface (ODI) drivers on the machines running Windows 95 and Windows 98.

ARC path

Acronym for Advanced RISC Computing path. Syntax for naming partitions of a disk on a system, used in the boot.ini file of Microsoft Windows NT. The ARC path specifies the location of the partition that contains the Windows NT operating system files. In other words, the ARC path locates the system partition on the machine.

Example

A typical ARC path on an x86-based computer could be the following:

multi(0)disk(0)rdisk(0)partition(2)\WINNT="Windows NT Server Version 4.00"

In this syntax

  • Multi(0) indicates that the system is using Integrated Device Electronics (IDE), Enhanced Small Device Interface (ESDI), or Small Computer System Interface (SCSI) drives and that it relies on the computer BIOS to load system files using INT 13 BIOS calls. The number in parentheses here should always be 0.

  • Disk(0) is always zero when multi() is used; otherwise, it refers to the physical disk when scsi() is used instead of multi(). (Multi() means that Windows NT must use the system BIOS to load system files, while scsi() means that a SCSI device driver must be loaded to access the boot partition.)

  • Rdisk(0) indicates that the ordinal number for the system disk is 0. This value is usually between 0 and 3.

  • Partition(2) indicates the number of the partition where the system files are located.

A record

See
address record

ARIN

See
American Registry for Internet Numbers (ARIN)

ARP

See
Address Resolution Protocol (ARP)

ARPANET

Acronym for Advanced Research Projects Agency Network, a U.S. Department of Defense project begun in 1969 that was designed to provide high-speed network communication links between supercomputers located at different sites around the country. ARPANET was a test-bed for the development of the TCP/IP protocol suite. The first node on the ARPANET was established in 1969 at UCLA, with other nodes at Stanford and ICSB soon following. The first Request for Comments (RFC) was proposed in the same year by Steve Croker and was entitled “Host Software.”

By 1971, ARPANET had grown to over 20 hosts, including MIT, NASA, and the RAND Corporation. The first international nodes were established two years later in Norway and England. In 1983 MILNET was split off from ARPANET, and TCP/IP officially became the standard protocol for ARPANET, at which time ARPANET started to become widely known as the Internet. ARPANET continued to evolve until NSFNET was established in 1986. ARPANET formally died in 1989.

On the Web
•
The History of ARPANET: Timeline
: http://www.geocities.com/Pentagon/Quarters/4620/home.html
•
“History of ARPANET” by Michael Hauben
: http://www.dei.isep.ipp.pt/docs/arpa.html

arp command

A TCP/IP utility and Microsoft Windows NT command for viewing and modifying the local Address Resolution Protocol (ARP) cache, which contains recently resolved MAC addresses of Internet Protocol (IP) hosts on the network. When one host on a TCP/IP network wants to communicate with a second host, the first host begins by using the ARP to resolve the IP address of the second host into its associated MAC address. The MAC address is needed for communication to take place over the network.

Example

Typing arp -a displays the MAC addresses of recently resolved IP addresses. A sample display could be

Interface: 172.16.8.50
Internet Address      Physical Address      Type
172.16.8.25           00-20-af-b4-a1-4e     dynamic
172.16.8.200          00-40-95-d1-29-6c     static

One of these entries is static, meaning the Internet Protocol-to-MAC address mapping has been manually added to the ARP cache using arp –s.

NOTE

The arp command is only available if TCP/IP is installed on the machine.

AS

See
autonomous system (AS)

AS/400

Stands for Application System/400, a midrange IBM server computing platform for business computing. AS/400 uses 64-bit RISC technology, supports Systems Network Architecture (SNA), and runs the OS/400 operating system. Traditional SNA user interfaces to AS/400 systems use either text-based 5250 terminals or desktop PCs running 5250 emulation software. But IBM has released a version of OS/400 that turns the AS/400 into a Web server and allows AS/400 applications to be interfaced using TCP/IP from a standard Web browser such as Microsoft Internet Explorer.

On the Web
•
IBM’s AS/400 home page
: http://www.as400.ibm.com

ASCII

Acronym for American Standard Code for Information Interchange, a widely accepted system for coding U.S. English text using numeric values. The purpose of ASCII is to allow human readable documents to be stored and processed as binary information by computers.

How It Works

ASCII assigns a unique numeric value to each lowercase and uppercase alphabet letter, number, punctuation mark, and to certain other characters. For example, the capital letter “A” has the ASCII code 65, while a blank space has the code 32.

ASCII is a 7-bit character set that is the same as the first 128 characters (numbers 0 to 127) of the ANSI character set. The following table shows the various characters in the ASCII character set. The first 32 characters are nonprinting control characters that can be executed from the keyboard by using the Control key combined with other keys.

The ASCII Character Set
Char | Dec | Oct | Hex | Control Key Combination | Description
NUL | 0 | 0 | 0 | ^@ | Null character
SOH | 1 | 1 | 1 | ^A | Start of heading
STX | 2 | 2 | 2 | ^B | Start of text
ETX | 3 | 3 | 3 | ^C | End of text
EOT | 4 | 4 | 4 | ^D | End of transmission
ENQ | 5 | 5 | 5 | ^E | Enquiry
ACK | 6 | 6 | 6 | ^F | Acknowledge
BEL | 7 | 7 | 7 | ^G | Bell
BS | 8 | 10 | 8 | ^H | Backspace
HT | 9 | 11 | 9 | ^I | Horizontal tab
LF | 10 | 12 | a | ^J | Line feed
VT | 11 | 13 | b | ^K | Vertical tab
FF | 12 | 14 | c | ^L | Form feed
CR | 13 | 15 | d | ^M | Carriage return
SO | 14 | 16 | e | ^N | Shift out
SI | 15 | 17 | f | ^O | Shift in
DLE | 16 | 20 | 10 | ^P | Data link escape
DC1 | 17 | 21 | 11 | ^Q | Device control 1 (XON)
DC2 | 18 | 22 | 12 | ^R | Device control 2
DC3 | 19 | 23 | 13 | ^S | Device control 3 (XOFF)
DC4 | 20 | 24 | 14 | ^T | Device control 4
NAK | 21 | 25 | 15 | ^U | Negative acknowledge
SYN | 22 | 26 | 16 | ^V | Synchronous idle
ETB | 23 | 27 | 17 | ^W | End transmission block
CAN | 24 | 30 | 17 | ^X | Cancel line
EM | 25 | 31 | 19 | ^Y | End of medium
SUB | 26 | 32 | 1a | ^Z | Substitute
ESC | 27 | 33 | 1b | ^[ | Escape
FS | 28 | 34 | 1c | ^\ | File separator
GS | 29 | 35 | 1d | ^] | Group separator
RS | 30 | 36 | 1e | ^^ | Record separator
US | 31 | 37 | 1f | ^_ | Unit separator
SP | 32 | 40 | 20 |  | Space
! | 33 | 41 | 21 |  | Exclamation mark
" | 34 | 42 | 22 |  | Quotation mark
# | 35 | 43 | 23 |  | Cross hatch
$ | 36 | 44 | 24 |  | Dollar sign
% | 37 | 45 | 25 |  | Percent sign
& | 38 | 46 | 26 |  | Ampersand
‘ | 39 | 47 | 27 |  | Apostrophe
( | 40 | 50 | 28 |  | Opening parenthesis
) | 41 | 51 | 29 |  | Closing parenthesis
* | 42 | 52 | 2a |  | Asterisk
+ | 43 | 53 | 2b |  | Plus
, | 44 | 54 | 2c |  | Comma
- | 45 | 55 | 2d |  | Hyphen
. | 46 | 56 | 2e |  | Period
/ | 47 | 57 | 2f |  | Forward slash
0 | 48 | 60 | 30 |  | Zero
1 | 49 | 61 | 31 |  | One
2 | 50 | 62 | 32 |  | Two
3 | 51 | 63 | 33 |  | Three
4 | 52 | 64 | 34 |  | Four
5 | 53 | 65 | 35 |  | Five
6 | 54 | 66 | 36 |  | Six
7 | 55 | 67 | 37 |  | Seven
8 | 56 | 70 | 38 |  | Eight
9 | 57 | 71 | 39 |  | Nine
: | 58 | 72 | 3a |  | Colon
; | 59 | 73 | 3b |  | Semicolon
< | 60 | 74 | 3c |  | Less than sign
= | 61 | 75 | 3d |  | Equals sign
> | 62 | 76 | 3e |  | Greater than sign
? | 63 | 77 | 3f |  | Question mark
@ | 64 | 100 | 40 |  | At sign
A | 65 | 101 | 41 |  | Uppercase A
B | 66 | 102 | 42 |  | Uppercase B
C | 67 | 103 | 43 |  | Uppercase C
D | 68 | 104 | 44 |  | Uppercase D
E | 69 | 105 | 45 |  | Uppercase E
F | 70 | 106 | 46 |  | Uppercase F
G | 71 | 107 | 47 |  | Uppercase G
H | 72 | 110 | 48 |  | Uppercase H
I | 73 | 111 | 49 |  | Uppercase I
J | 74 | 112 | 4a |  | Uppercase J
K | 75 | 113 | 4b |  | Uppercase K
L | 76 | 114 | 4c |  | Uppercase L
M | 77 | 115 | 4d |  | Uppercase M
N | 78 | 116 | 4e |  | Uppercase N
O | 79 | 117 | 4f |  | Uppercase O
P | 80 | 120 | 50 |  | Uppercase P
Q | 81 | 121 | 51 |  | Uppercase Q
R | 82 | 122 | 52 |  | Uppercase R
S | 83 | 123 | 53 |  | Uppercase S
T | 84 | 124 | 54 |  | Uppercase T
U | 85 | 125 | 55 |  | Uppercase U
V | 86 | 126 | 56 |  | Uppercase V
W | 87 | 127 | 57 |  | Uppercase W
X | 88 | 130 | 58 |  | Uppercase X
Y | 89 | 131 | 59 |  | Uppercase Y
Z | 90 | 132 | 5a |  | Uppercase Z
[ | 91 | 133 | 5b |  | Opening square bracket
\ | 92 | 134 | 5c |  | Backslash
] | 93 | 135 | 5d |  | Closing square bracket
^ | 94 | 136 | 5e |  | Caret
_ | 95 | 137 | 5f |  | Underscore
‘ | 96 | 140 | 60 |  | Opening single quote
a | 97 | 141 | 61 |  | Lowercase a
b | 98 | 142 | 62 |  | Lowercase b
c | 99 | 143 | 63 |  | Lowercase c
d | 100 | 144 | 64 |  | Lowercase d
e | 101 | 145 | 65 |  | Lowercase e
f | 102 | 146 | 66 |  | Lowercase f
g | 103 | 147 | 67 |  | Lowercase g
h | 104 | 150 | 68 |  | Lowercase h
i | 105 | 151 | 69 |  | Lowercase i
j | 106 | 152 | 6a |  | Lowercase j
k | 107 | 153 | 6b |  | Lowercase k
l | 108 | 154 | 6c |  | Lowercase l
m | 109 | 155 | 6d |  | Lowercase m
n | 110 | 156 | 6e |  | Lowercase n
o | 111 | 157 | 6f |  | Lowercase o
p | 112 | 160 | 70 |  | Lowercase p
q | 113 | 161 | 71 |  | Lowercase q
r | 114 | 162 | 72 |  | Lowercase r
s | 115 | 163 | 73 |  | Lowercase s
t | 116 | 164 | 74 |  | Lowercase t
u | 117 | 165 | 75 |  | Lowercase u
v | 118 | 166 | 76 |  | Lowercase v
w | 119 | 167 | 77 |  | Lowercase w
x | 120 | 170 | 78 |  | Lowercase x
y | 121 | 171 | 79 |  | Lowercase y
z | 122 | 172 | 7a |  | Lowercase z
{ | 123 | 173 | 7b |  | Opening curly brace
| | 124 | 174 | 7c |  | Vertical line (pipe)
} | 125 | 175 | 7d |  | Closing curly brace
~ | 126 | 176 | 7e |  | Tilde
DEL | 127 | 177 | 7f |  | Delete
NOTE

Some people create e-mail signatures for themselves using ASCII text characters, a practice called ASCII art. If you have the time and want to become an expert at this, read the FAQ on the Web at http://non.com/news.answers/ascii-art-faq.html.

TIP

When you download files using File Transfer Protocol (FTP), you can choose whether to transfer the files as binary files or text files (ASCII files). Use only the ASCII file setting when downloading plain text files—otherwise, files will not be correctly transferred.

ASCII file

A file that contains unformatted ASCII text: only characters, numbers, punctuation, tabs, and carriage return characters. You can create and edit an ASCII file using Microsoft Notepad. If you save it with the extension .txt, it is usually referred to as a text file, but you can save it with other extensions such as .bat or .cmd for batch files, and .ini for initialization files.

ASCII files are often used for logon scripts and other batch files. Another common use is storing configuration information for operating systems and applications. Microsoft Windows 3.1 platforms used ASCII files for storing system and software configuration settings. These configuration files have the extension .ini and are referred to as INI files. More recent Windows operating systems save this information in the registry. Most versions of the UNIX operating system still store their configuration settings in ASCII files.

Because ASCII files contain unformatted text, they can be read and understood by any platform and are useful for sharing information between platforms and between applications. Shared information is often saved in a comma-delimited text file, or .csv file, with the fields separated by commas. Microsoft Exchange Server can export mailbox properties and other information in .csv files, which can then be imported into spreadsheet programs such as Microsoft Excel for manipulation and analysis.

ASD

See
Automatic Skip Driver Agent (ASD)

ASF

See
Advanced Streaming Format (ASF)

ASN.1

See
Abstract Syntax Notation One (ASN.1)

ASP

See
Active Server Pages (ASP), application service provider (ASP)

Association for Computing Machinery (ACM)

The oldest and largest educational and scientific computing society in the world. The Association for Computing Machinery (ACM) provides a forum for the exchange of information, ideas, and discoveries relating to many aspects of computing. The ACM has a worldwide membership of 80,000 computer professionals representing a wide variety of interests. The ACM also sponsors a number of special interest groups (SIGs) that bring together ACM members with shared interests. These SIGs publish technical newsletters, host conferences, and help develop standards.

One SIG of interest to networking professionals is the ACM Special Interest Group on Data Communication (SIGCOMM), which provides a forum for data communication professionals. SIGCOMM focuses on standards for network protocols and architectures. SIGCOMM publishes the ACM/IEEE Transactions on Networking Journal, sponsors conferences, and publishes a quarterly newsletter called the Computer Communication Review (CCR) in conjunction with the Institute of Electrical and Electronics Engineers (IEEE).

On the Web
•
ACM home page
: http://www.acm.org
•
SIGCOMM
: http://www.acm.org/sigcomm

Association of Online Professionals (AOP)

A nonprofit trade association serving U.S. Internet access and electronic commerce industries. The Association of Online Professionals (AOP) was founded in 1994 with a mission to promote the growth of e-commerce, online communities, and online communication. The AOP provides its members with information, service, and support. In addition, it serves as an advocate for issues of privacy, copyright, taxation, self-regulation, and e-commerce.

The AOP runs a number of special interest groups (SIGs), including the Online Services Council, Web Professionals Council, ISP Council, and Electronic Commerce Council.

On the Web
•
AOP home page
: http://www.aop.org

Asymmetric Digital Subscriber Line (ADSL)

A telco service that provides subscribers with high-speed digital telephone services. Asymmetric Digital Subscriber Line (ADSL) is a newer technology that competes with Integrated Services Digital Network (ISDN) to provide a faster alternative to analog modems for the traditional analog local loop that joins subscribers to a telco’s high-speed digital backbone networks. ADSL specifies how to implement high-speed, full-duplex transmission over the existing twisted-pair copper cabling of the Plain Old Telephone Service (POTS). ADSL can be used to simultaneously transmit voice and data over a single telephone line and can support high-speed Internet access for both homes and businesses. Should the data link go down, POTS voice service would still be available using ADSL.

Graphic A-20. Asymmetric Digital Subscriber Line (ADSL).
Graphic A-20. Asymmetric Digital Subscriber Line (ADSL).
How It Works

ADSL is a form of Digital Subscriber Line (DSL) that enhances the data-carrying capacity of the twisted-pair copper phone lines that join most homes and offices with their local telco’s switching facilities. ADSL is asymmetric, meaning the upstream and downstream transmission rates are not equal. Over regular copper phone lines, ADSL can achieve upstream speeds of up to 1.5 Mbps and downstream speeds of up to 9 Mbps, usually in a 10:1 ratio. ADSL is therefore ideal for providing high-speed Internet access to homes and businesses where download speeds are more critical than upload speeds.

ADSL uses frequency-division multiplexing (FDM) to separate voice and data into a baseband voice channel, upstream data channel, and downstream data channel. Each channel occupies a different portion of the frequency spectrum, as shown in the illustration. The baseband voice channel is split from the data channels to guarantee phone services in case the data channel fails. Data transmission rates in the upstream direction range from 9.6 to 640 Kbps, and those in the downstream direction range from 1.544 to 8 Mbps, depending on the local loop length and wire gauge of the telephone cable. (The longer the distance, the slower the speed supported.) ADSL can use any of the following modulation systems for the data channels:

  • Carrierless amplitude/phase (CAP)

  • Discrete multitone (DMT)

  • Discrete wavelet multitone (DWMT)

In a typical implementation, an ADSL modem is used to connect your computer to a standard analog POTS phone line. The ADSL modem contains a POTS splitter chip that splits the bandwidth of the phone line into a voice and a data channel. The data channel is split, using a channel separator chip, into an upstream and a downstream channel, with the downstream channel having the larger portion of bandwidth. The voice band uses frequencies up to 4 kHz, while the data channels use the higher frequencies. Carrying capacity depends on the thickness of the wire and other line conditions.

At the other end of the subscriber’s local loop is an ADSL modem at the telco central office. The telco’s modem separates voice from data using a splitter and routes voice calls through the POTS, while the data is routed to either a similar ADSL modem or a Digital Subscriber Line Access Multiplexer (DSLAM) unit. The DSLAM unit combines multiple ADSL lines into a single fiber-optic Asynchronous Transfer Mode (ATM) backbone connection to the Internet.

ADSL has numerous advantages over standard analog modem access to the Internet, including much higher data rates, instant connection, simultaneous voice/data over a single phone line, and greater security. The negative side is the higher equipment cost and limited availability of ADSL in current telco markets.

On the Web
•
ADSL Forum
: http://www.adsl.com

asymmetric multiprocessing (AMP)

An approach to distributing processing load on a multiprocessor computer (a computer with more than one CPU) in which each processor is assigned specific tasks to perform. For example, one processor might be dedicated to managing I/O requests, another to executing network requests, another to running a user application, and so on. This is in contrast to symmetric multiprocessing (SMP), in which the operating system evenly distributes the application load across multiple processors. In SMP, individual processes are not mapped to specific processors but instead are assigned to available processors by the operating system.

NOTE

Microsoft Windows NT and Windows 2000 support SMP but not asymmetric multiprocessing (AMP).

async

See
asynchronous transmission

Asynchronous Transfer Mode (ATM)

A high-speed, broadband transmission data communication technology based on packet switching, which is used by telcos, long distance carriers, and campus-wide backbone networks to carry integrated data, voice, and video information. Asynchronous Transfer Mode (ATM) can be used as the underlying technology for Fiber Distributed Data Interface (FDDI), Synchronous Optical Network (SONET), and other high-speed networks. Plus, ATM can run on any media including coax, twisted-pair, or fiber-optic.

ATM is a connection-oriented protocol that can work with either permanent virtual circuits (PVCs) or switched virtual circuits (SVCs), depending on your wide area network (WAN) traffic needs. ATM networks use bandwidth at maximum efficiency, while maintaining guaranteed quality of service (QoS) for users and applications that require it. The two main benefits of ATM are its high transmission speeds and its flexible bandwidth-on-demand capability.

How It Works

The “asynchronous” in ATM means ATM devices do not send and receive information at fixed speeds or using a timer, but instead negotiate transmission speeds based on hardware and information flow reliability. The “transfer mode” in ATM refers to the fixed-size cell structure used for packaging information. This cell-based transmission is in contrast to typical local area network (LAN) variable-length packet mechanisms, which means that ATM connections are predictable and can be managed so that no single data type or connection can monopolize the transmission path.

ATM technology originated in broadband ISDN (B-ISDN) technology and works primarily at layer 2 of the Open Systems Interconnection (OSI) reference model. ATM connects devices over a WAN using virtual channels (VCs) and virtual paths (VPs). Virtual channels consist of one or more physical ATM links connected in a series for transmitting data between remote stations. A VC exists only while data is being transmitted on it, and all cells in a given ATM transmission follow the same VC to ensure reliable data transmission. A virtual path is a collection of VCs having the same source and destination points that can be used to pool traffic being transmitted to a given destination.

ATM is a connection-oriented technology that requires the establishment of a specific network path between two points before data can be transported between them. Typically a subscriber would lease a T1 or T3 line to connect their customer premises equipment (CPE) to the telecommunication carrier’s ATM network, but frame relay or SONET can also be used to connect a site to an ATM network. The kind of CPE needed varies with the access method employed—for example, Channel Service Unit (CSU) for T1 line, frame relay access device (FRAD) or router for frame relay, and so on. Large corporate networks using an ATM backbone might use a switch-to-switch connection to the carrier’s network instead of CPE.

ATM uses fixed-size packets called “cells.” Each 53-byte ATM cell contains 48 bytes of data payload and 5 bytes of control and routing information in the header. The header provides addressing information for switching the packet to its destination. The payload section carries the actual information, which can be data, voice, or video. The payload is properly called the user information field. The reason for choosing 48 bytes as the payload size is to compromise between the optimal cell sizes for carrying voice information (32 bytes) and data information (64 bytes). The fixed size of an ATM cell makes ATM traffic simple and predictable, and makes it possible for ATM to operate at high speeds. Typical ATM speeds vary with transmission media and can include

  • 25 Mbps over unshielded twisted-pair (UTP) category 5 cabling

  • 155 Mbps over either UTP or fiber-optic cabling

  • 622 Mbps and 4.8 Gbps over fiber-optic cabling only

ATM also includes a mechanism for allocating bandwidth dynamically; that is, bandwidth is allocated only in required amounts and the required direction. As a result, when an ATM link is idle, it utilizes no bandwidth, which can result in considerable cost savings depending on the needs of your network.

ATM optimizes performance through different classes of service, which can be allocated through QoS settings. This is different from frame relay, which is a classless service. The four classes of ATM services that subscribers can specify depending on their needs are

  • Constant Bit Rate (CBR):
    This service level is suitable for applications that are sensitive to cell delay and cell loss, must have continual availability, and do not require much bandwidth (for example, voice traffic).

  • Variable Bit Rate/Realtime (VBR-RT):
    This level is suitable for applications that are sensitive to cell delay and cell loss and require a large amount of bandwidth (for example, videoconferencing).

  • Variable Bit Rate/Non-Realtime (VBR-NRT):
    This level is suitable for applications that require a large amount of bandwidth but can tolerate some cell delay and cell loss (for example, video playback).

  • Unspecified Bit Rate (UBR) or Available Bit Rate (ABR):
    This level is suitable for network services that do not have special bandwidth or cell latency/loss needs (for example, file transfer or e-mail).

ATM provides the following advantages:

  • High-speed, fast-switched integrated data, voice, and video communication that is not bound by the physical or architectural design constraints of traditional LAN networking technologies.

  • A standards-based solution formalized by the International Telecommunication Union (ITU) that allows ATM to easily replace existing telephony network infrastructures. ATM provides a global telephony standard, and over 70 percent of U.S. telcos have migrated their internal networks to ATM.

  • Interoperability with standard LAN/WAN technologies. ATM networks can be interconnected with Ethernet and token ring LANs using LAN emulation (LANE) services to provide TCP/IP over ATM.

  • QoS technologies that enable a single network connection to reliably carry voice, data, and video simultaneously and manage bandwidth on a per-connection basis depending on the priority of the service required.

Microsoft Windows 2000 supports direct connectivity to ATM networks with up to four ATM adapters in a single computer.

On the Web
•
ATM Forum
: http://www.atmforum.com
See also
telecommunications services

asynchronous transmission

A mode of serial transmission for modems and other telecommunication devices in which the data is transmitted as a continuous stream of bytes separated by start and stop bits. This is in contrast to synchronous transmission in which some timer or clocking mechanism is used to ensure a steady flow of data between the devices.

How It Works

In asynchronous communication, only about 80 percent of the transmitted bits actually contain data, while the other 20 percent contain signaling information in the form of start and stop bits. Each data frame starts with a start bit and ends with a stop bit, with data bits in between. When the receiving station receives a start bit, it knows that pure data will follow. When a stop bit is received, it knows the data frame has ended and waits for the next one.

Asynchronous transmission is essentially character-based with additional bits between characters to enable synchronization and error correction. An optional parity bit for error checking can be located immediately before the stop bit in each frame. With parity correction, an 8-bit character requires 3 bits of control information (start, stop, and parity bits), which means an actual overhead of 3/8 or 38 percent.

Asynchronous communication is not synchronized by a timer mechanism or clock, and asynchronous devices are not bound to send or receive information at an exact transmission rate. Instead, the sender and receiver negotiate transmission speeds based on hardware limitations and the need to maintain a reliable flow of information. Asynchronous transmission is mainly suitable for low-speed transmission, but speeds can be increased by using data compression.

See also
synchronous transmission

at command

A Microsoft Windows NT and Windows 2000 command that can be used to schedule the execution of commands, batch files, and executables. For example, you could use the at command to schedule a backup to occur at a specific time of the day on certain days of the week. You can also use the at command to view commands that have already been scheduled and to delete a scheduled command.

Example

at 02:00 /every:Su runback.bat runs the batch file runback.bat every Sunday at 2 A.M.

NOTE

The at command requires that Windows NT Schedule service is running on the machine. You must be a member of the Administrators group to use the at command. For Windows 2000, you can schedule tasks using the Scheduled Tasks folder within My Computer.

TIP

The Windows NT Server Resource Kit includes a GUI version of the at command that is easier to use than the command-line version and has essentially the same functionality.

ATM

See
Asynchronous Transfer Mode (ATM)

attenuation

The loss of signal strength with long distances when signals travel along cabling. Attenuation values for actual cables are measured in units of decibels (dB)—a standard measurement value used in communication for expressing the ratio of two values of voltage, power, or some other signal-related quantity. For example, a drop of 3 dB corresponds to a decrease in signal strength of 50 percent or 2:1, while a drop of 6 dB corresponds to a decrease of 75 percent or 4:1. Attenuation values for cabling media are expressed in units of decibels per 1000 feet, which express the amount of attenuation in decibels for a standard 1000-foot length of cabling composed of that media.

Copper cabling has much greater attenuation than fiber-optic cabling; therefore, copper is suitable only for relatively short cable runs. Typical attenuation values for copper category 5 cabling vary with frequency and are shown in the table that follows. Attenuation for lower-grade cable is slightly higher.

Attenuation Values for Copper Category 5 Cabling
Signal Frequency | Attenuation
4 MHz | 13 dB/1000 feet
10 MHz | 20 dB/1000 feet
20 MHz | 28 dB/1000 feet
100 MHz | 67 dB/1000 feet
TIP

Attenuation is caused by signal absorption, connector loss, and coupling loss. To minimize attenuation, use high-grade cabling such as enhanced category 5 cabling. Also try to minimize the number of connector devices or couplers, ensuring that these are high-grade components as well. When a signal attenuates a large amount, the receiving device might not be able to detect it or might misinterpret it, therefore causing errors.

Graphic A-21. Attenuation.
Graphic A-21. Attenuation.

attenuation to crosstalk ratio (ACR)

The ratio of the received strength of a signal on a pair of wires to the amount of crosstalk between the wires. The higher the attenuation to crosstalk ratio (ACR) for a given cable, the less chance of signal errors. ACR is calculated as the difference between the attenuation value and the near-end crosstalk value at a specific frequency. This is because both attenuation and crosstalk are usually expressed in units of decibels for cabling media. The decibel scale is logarithmic in nature, which means that a difference in decibel values corresponds to a ratio of actual signal voltage or power levels.

For copper category 5 cabling, the ACR value is typically about 10 dB, at a frequency up to about 100 MHz. This value decreases slightly with increasing frequency until crosstalk and attenuation values converge, at which point transmission becomes error prone and the cabling ineffective for communication.

attrib command

A Microsoft Windows command that can be used to display and modify the attributes of files and directories. You can use the attrib command to display and modify the archive, system, hidden, and read-only attributes that can be assigned to files and directories. For example, if you need to manually modify the boot.ini file on a machine running Windows NT, you can use the attrib command to remove its read-only, hidden, and system attributes.

Example

attrib –r –h –s boot.ini removes the read-only, hidden, and system attributes from the boot.ini file, allowing you to manually edit the file.

attribute marker

A type of marker that can be set or cleared for files stored on the file allocation table (FAT) or NTFS file system. Attributes indicate whether a file is

  • Read-only, meaning that it cannot be modified

  • Hidden, meaning that the file will not appear when its parent directory is listed at the command line

  • System, meaning that the file is a critical operating system file and should not be moved or modified

  • Archived, meaning that the file has been backed up

NOTE

The above attributes can be set or cleared for files on both FAT and NTFS partitions. In addition, files on an NTFS volume can be marked as compressed. NTFS uses a number of other extended attributes internally. The term “attribute” can also refer generally to other file system information, such as time stamps, file size, link counts, and so on.

TIP

To view or modify the attributes of a file, open the file’s property sheet and check or clear the appropriate check box. You can also use the attrib command to modify some attributes of a file.

attribute property

A property of an object in Active Directory. Attributes are the actual information stored in an object. For example, a user class object is composed of attributes, such as a First Name attribute for a user account object.

Attributes define the actual characteristics of objects in Active Directory. Every class of objects has its own defining set of attributes. Different objects within this class are distinguished by the values of their attributes. Some attributes, such as the First Name attribute for a user account object, must have a value assigned to them when they are created. Other attributes, such as Phone Number, can optionally be left unvalued.

Each attribute in Active Directory is defined only once and can be used for many different object classes. All objects of the same type have the same set of attributes. Different objects of the same type are distinguished by different attribute values. It is therefore the values of the attributes of a particular object that make that object unique in Active Directory.

Attributes are defined in a special portion of Active Directory. An attribute definition includes

  • The syntax (type of information) of the attribute, such as integer, date, or string

  • Whether the attribute is single-valued or multivalued

Each syntax type is specified by an object identifier, which is a globally unique identifier (GUID) issued by the International Organization for Standardization (ISO). The allowable syntax types for attributes of objects in Active Directory are shown in this table.

Allowable Syntax Types for Object Attributes
Syntax | Object Identifier | Description
Undefined | 2.5.5.0 | Not a legal syntax
Distinguished name | 2.5.5.1 | The fully qualified name of an object in the directory
Object identifier | 2.5.5.2 | Identifies an object
Case-sensitive string | 2.5.5.3 | Differentiates uppercase and lowercase
Case-insensitive string | 2.5.5.4 | Does not differentiate uppercase and lowercase
Print case string | 2.5.5.5 | Printable string
Numeric string | 2.5.5.6 | A sequence of digits
OR name | 2.5.5.7 | An x400 e-mail address
Boolean | 2.5.5.8 | TRUE or FALSE
Integer | 2.5.5.9 | A 32-bit number
Octet string | 2.5.5.10 | A string of bytes
Time | 2.5.5.11 | The number of seconds elapsed since 1/1/1970
Unicode | 2.5.5.12 | Wide string
Address | 2.5.5.13 | Internal
Distname-address | 2.5.5.14 | Internal
NT security descriptor | 2.5.5.15 66 | Windows NT Security Descriptor
Large integer | 2.5.5.16 | A 64-bit number
Security identifier (SID) | 2.5.5.17 4 | SID
See also
Active Directory schema

auditing

The process of tracking and monitoring actions is performed on servers. Auditing is an important component of a general security policy for a corporate network. Auditing can be used to detect attempts at unauthorized access to network resources and to track the usage of shared resources. Auditing creates a record of which files have been accessed, who has logged on to the network, who has attempted to use a shared resource, and so on. Specifically, auditing records information in the security log about

  • What action was performed

  • Who performed the action

  • When the action occurred

  • Whether the action succeeded or failed

How It Works

In Microsoft Windows NT, auditing must first be enabled by configuring an Audit policy for the domain being audited. If you are auditing access to files and other objects, you must specifically enable auditing on the files and objects you want to audit by using the Security tab on the file or object’s property sheet.

Windows NT records two kinds of auditing information in the security log:

  • Success audits:
    Symbolized by keys and are usually used to track resource usage for capacity and resource planning

  • Failure audits:
    Symbolized by padlocks and are usually used to monitor network resources for unauthorized access attempts

See also
Audit policy, Event Viewer, security log

Audit policy

A policy established on a domain in Microsoft Windows NT and Windows 2000 to specify which kinds of security events are recorded in the security log.

How It Works

An Audit policy can be configured using the Policies menu in User Manager for Domains. When an Audit policy is configured on a domain controller using this tool, the policy affects the security logs for all domain controllers in that domain. If the Audit policy is configured on a member server or workstation, it is valid only for that machine. The following table shows the different kinds of events that can be audited by establishing an Audit policy. You can view the results of establishing your Audit policy by using Event Viewer.

Events That Can Be Audited
Type of Event | Description
Logon and logoff | Users logging on and off and forming network connections
File and object access | Users accessing a file, folder, or printer on a network
Use of user rights | A right has been exercised—for example, backing up files and directories
User and group management | An account has been modified, created, or deleted
Security policy changes | A change has been made to an Audit policy, a trust relationship, or user rights
Restart, shutdown, and system | The system has been shut down or restarted, or system security has changed
Process tracking | A process has been started or stopped, or some related activity has occurred

These are the requirements for establishing an Audit policy in Windows NT:

  • The user must be a member of the Administrators local group on the domain controllers or on the member server to be audited.

  • Server Operators can view and archive security logs, but only administrators can enable auditing.

  • File auditing can take place only on volumes formatted using the NTFS file system.

NOTE

To configure an Audit policy in Windows 2000, use the Computer Management administrative tool, open the System Tools folder, and select the Group Policy Editor.

TIP

Be careful when enabling auditing for File and Object Access or Process Tracking, as logging these events can generate a large amount of overhead on your system. To audit access to a file, folder, or printer, first enable File and Object Access auditing in your Audit policy, and then access the Security tab on the object’s property sheet.

See also
auditing, Event Viewer, security log

AUI connector

Acronym for Attachment Unit Interface connector, a standard 15-pin connector device for thicknet or 10Base5 cabling. The AUI connector on the free end of the drop cable attaches to the DB15 connector on the network interface card (NIC). The NIC has an AUI port connector for connecting the drop cable. The other end of the drop cable typically connects to a transceiver. The transceiver is then joined to the thicknet cabling using a vampire tap that pierces the cable jacket and insulation to make a connection.

Authenticated Users group

A new built-in group for Microsoft Windows NT or Windows 2000 that is created when Windows NT 4.0 Service Pack 3 or later is applied. The Authenticated Users group is similar to the built-in Everyone group, except that anonymous logon users are never members of the Authenticated Users group. The built-in security identifier (SID) for this group is S-1-5-11. The Authenticated Users group can be used to provide additional security when running Microsoft Internet Information Services (IIS) because the anonymous user account has the ability to enumerate share names and list domain usernames. Using the Authenticated Users group can restrict this ability for the anonymous user account. You should generally use the Authenticated Users group instead of the Everyone group if you want to carefully control anonymous access to your network resources.

NOTE

In Windows NT, some editing of the registry is required to implement this new feature. For information, see Microsoft TechNet and the Readme file for Service Pack 3. In Windows 2000, the Authenticated Users group is one of the built-in system groups.

authentication

The process of validating users’ credentials to allow them access to resources on a network. On a Microsoft Windows NT or Windows 2000 network, authentication can be handled in one of two ways:

  • Logging on to a member server or workstation:
    Authentication is performed by the member server or workstation itself using its local Security Accounts Manager (SAM) database.

  • Logging on to a domain in Windows NT and Windows 2000:
    Authentication is performed by a domain controller on the network.

Authentication can be further classified according to how the credentials are passed over the network and includes the following methods:

  • Anonymous access:
    This method is supported by Microsoft Internet Information Services (IIS) and allows anonymous users on the Internet access to Web content on your server.

  • Basic Authentication:
    This method transmits passwords as clear text and is often used in UNIX networks and for File Transfer Protocol (FTP) services.

  • Windows NT Challenge/Response Authentication:
    This is the standard secure authentication method for Windows NT domain controllers.

  • Kerberos v5 Security Protocol:
    This is the standard secure authentication method for Windows 2000 domain controllers.

See also
logon

authentication provider

In Internet Connection Services for Microsoft Remote Access Service (RAS), a database for providing authentication, access, and accounting information for the users in a given realm. An authentication provider is a server that is used by Internet Authentication Service (IAS) to map a Remote Authentication Dial-In User Service (RADIUS) authentication request to a database containing user credentials. The authentication provider can verify or deny whether the individual exists in the database and return this information to the IAS server. Choices for authentication providers are

  • A Microsoft Window NT or Windows 2000 domain controller

  • A Local Users file on the IAS server

  • An open database connectivity (ODBC)–compliant database

  • A Microsoft Commercial Internet System (MCIS) membership database

Authenticode

A Microsoft security technology that certifies the identity of the publisher of software to ensure the software has not been tampered with.

How It Works

An Internet software publisher first obtains a digital certificate from a certificate authority (CA) and uses Authenticode signing tools to digitally sign his or her application. When a user tries to download the application from the Internet, client-side Authenticode software in Microsoft Internet Explorer and Microsoft Windows 98 displays the publisher’s certificate information to help the user make a more informed decision about whether to install the software on his or her machine.

Authenticode can be used to sign Microsoft ActiveX controls, .cab files, Java applets, or any other executable files.

NOTE

The Windows 98 implementation of Authenticode enables you to check online certificate revocation.

Authorized Academic Training Program (AATP)

A program offered by Microsoft to secondary and post-secondary educational institutions. Approved schools are provided with tools by Microsoft to facilitate courseware delivery that prepares students for Microsoft Certified Professional (MCP) certifications. The Authorized Academic Training Program (AATP) gives schools a powerful advantage in the competitive technical education market. AATP enables schools to serve their communities by educating future employees to fill demands for technically certified computer professionals.

There is no fee for joining the AATP program. Some of the benefits of joining the program include

  • A 100-user software license received upon purchase of a Microsoft product—provided the product is the subject of a course being taught that uses Microsoft Official Curriculum or Microsoft Approved Study Guides. Note that these licenses are for student and instructor use in the classroom only.

  • Special academic pricing on Microsoft Official Curriculum and Microsoft Approved Study Guides.

  • Online course outlines, evaluation tools, curriculum materials, certification fact sheets, and preparatory exams.

  • Access to the private AATP Internet site.

On the Web
•
Microsoft AATP Welcome Page
: http://www.microsoft.com/aatp

auto-application

An application that can be automatically started on the user’s computer by Microsoft Connection Manager (CM) after a connection is established. Auto-applications automatically launch and close upon the start and end of a connection. This lets administrators configure services to trigger when users open their e-mail or Web browser. Auto-applications can be specified using a wizard that allows you to specify the name of the application, command-line switches or parameters, and other information. An auto-application must be a complete program file; it cannot require other files to work, and it cannot be a self-extracting executable.

autochk.exe

A Microsoft Windows NT utility executed each time the computer reboots. Autochk.exe checks whether any volumes are dirty (for example, if the system was shut down due to a power failure). If autochk.exe finds a dirty volume, it runs chkdsk /f to attempt to repair it.

NOTE

Large volumes can take a long time for chkdsk to run. You can prevent autochk from checking specific volumes by using the utility chkntfs.exe found on Windows NT Service Pack 2 and later.

AutoComplete

A feature of Microsoft Internet Explorer version 4.0 and later that attempts to complete a partial Uniform Resource Locator (URL) entered into the Address field of the browser. When you begin to enter a URL, the AutoComplete function checks the browser’s history folder for any URLs that match your partial URL and displays the closest match to what you have entered. This saves users from having to retype long URLs when attempting to revisit a site. This can be viewed as both an accessibility feature and a way to avoid time-wasting mistakes. If the URL that AutoComplete suggests for you is incorrect, just keep typing your URL. AutoComplete is based on the same IntelliSense technology that is implemented in certain features of Microsoft Office, such as the AutoFill feature in Microsoft Excel.

TIP

If you clear your history folder, AutoComplete will not be able to function because it uses URLs stored in that folder. The longer you leave your history folder unemptied, the larger its contents become and the more effectively AutoComplete operates.

autodial

A feature of Microsoft Windows 2000 and Windows NT that maps network resources to phonebook entries. When a user or application tries to access a network resource, Network and Dial-up Connections in Windows 2000 (Dial-Up Network in Windows NT) automatically tries to establish a connection to the resource. To configure autodial in Windows 2000, go to Control Panel in My Computer, and then open Network and Dial-up Connections. Choose Dial-up Preferences from the Advanced menu. On the Autodial tab, select the check box next to the location where you want to enable autodial, and then click OK. To configure AutoDial in Windows NT, use the User Preferences dialog box for your phonebook entry.

NOTE

Certain actions will not trigger AutoDial for Windows NT. These include

  • Pinging an IP address. (Pinging a fully qualified domain name, however, will cause AutoDial to engage.)

  • Using both a dial-up and a local area network (LAN) connection. (AutoDial engages only after an attempt to connect over the LAN has failed.)

autoexec.bat

A batch file used by the MS-DOS and Microsoft Windows 3.1 operating systems. Autoexec.bat runs immediately after the commands in the config.sys file are executed and can contain any commands that you want carried out when you start your system. These might include commands to clear the screen of startup messages, to start terminate-and-stay-resident (TSR) programs such as virus checkers, or to define a printer port. Autoexec.bat is typically located in the C:\ directory. Autoexec.bat can also include Path, Prompt, and Set statements for defining the system path and environment variables.

Windows 95 and Windows 98 also include an autoexec.bat file, but it is present only for backward compatibility of running Windows 3.1 applications under Windows 95 or Windows 98.

NOTE

If an autoexec.bat file exists in the boot partition on a machine running Windows NT, it will be parsed at startup. Any environment variables that are defined in the file will be set, and any path specification will be appended to the default system path whenever the system is started.

autoexec.nt

A batch file in %SystemRoot%\System32 on machines running Microsoft Windows NT that is used to provide a startup environment when MS-DOS applications are run using the default.pif file. You can configure autoexec.nt the same way you would configure autoexec.bat for running MS-DOS applications on Windows NT. The corresponding file config.nt performs the same function as config.sys. Once autoexec.nt and config.nt are configured, an MS-DOS application that is started in a new command window will use these files to configure the application’s environment. You can optionally create custom startup files for specific applications that cannot use your generic autoexec.nt and config.nt files.

TIP

If you make any changes to autoexec.nt or config.nt, you must first log off and then log on again for the changes to take effect on the system.

automatic logon

A logon process whereby the user gains access to the network through user credentials previously stored in the registry. Automatic logon can be enabled on a machine running Microsoft Windows NT by editing the registry. Use registry editor (regedit.exe) to open the following key

HKEY_LOCAL_MACHINE
    \Software
        \Microsoft
            \Windows NT
                \CurrentVersion
                    \Winlogon

and modify or create the following REG_SZ type values:

  • DefaultDomainName

  • DefaultUserName

  • DefaultPassword

  • AutoAdminLogon

Set AutoAdminLogon equal to 1 to enable automatic logon.

NOTE

The automatic logon process can be bypassed by holding down the Shift key upon startup or logoff.

TIP

Use extreme care when making changes to the registry, as improper use of Registry Editor can make your system unbootable.

See also
interactive logon

Automatic Skip Driver Agent (ASD)

A Microsoft Windows 98 built-in utility that allows you to bypass troublesome devices so that Windows 98 can successfully boot.

How It Works

The Automatic Skip Driver Agent (ASD) identifies device failures that caused Windows 98 to stop responding on previous attempts to boot the system and marks these devices so that the boot process skips them on subsequent boot attempts. Once you have finished troubleshooting a device problem, you can use ASD to enable the device to see whether the device has begun to function properly. If the device fails again, ASD will again disable it. Disabled devices can be viewed and reenabled by running ASD again from the command line with the command asd.exe or from the System Information utility in the System Tools program group. Device Manager shows disabled devices with a yellow exclamation point.

During startup, Windows 98 tries to load device drivers for installed hardware. ASD keeps track of device driver failures by identifying which devices cannot be enumerated during startup. If attempts to load the device driver for a device fail two times, ASD disables the device so that Windows 98 can start properly.

Automatic System Recovery (ASR)

A feature of Microsoft Windows 2000 that allows you to restore your system in the event of hard disk failure or corruption of system files. Automatic System Recovery (ASR) is designed to replace the emergency repair disk (ERD) of Windows NT as the main tool for restoring systems after boot failures. ASR integrates the processes of repair, backup, and restore into a single recovery solution in the event of a disaster.

How It Works

To use ASR, you must first configure it by running the Disaster Recovery Preparation Wizard, which is part of the Windows 2000 Backup utility. The resulting ASR disk contains configuration information that will be critical if you need to recover your system as a result of system volume damage or corruption. If you need to reinstall the system software, the ASR disk enables you to bring the system to the same configuration it had before the disaster.

To perform ASR on an x86-based computer, you will need the three setup disks and the tape backup created by running the Disaster Recovery Preparation Wizard. After Setup Disk 3 finishes running, you will be presented with several options—select the Recover option to use the ASR disk to recover your system.

TIP

Always run the Automatic System Recovery Wizard immediately before and after you make any changes to your system configuration using the Disk Management tool. If you do this, you will be able to return your system to the stable configuration that existed prior to your change.

Automatic Version Synchronization (AVS)

A feature of the Microsoft Internet Explorer Administration Kit (IEAK). Automatic Version Synchronization (AVS) runs each time the IEAK administrator runs the IEAK Wizard and checks Microsoft’s Web site for updates to Microsoft Internet Explorer. These updates are automatically downloaded and can be distributed by the administrator to users throughout the enterprise.

Automation

A Microsoft technology that enables applications to expose their functionality to other applications. Automation, formerly known as OLE Automation, is based on the Component Object Model (COM) and allows run time binding of components. Automation is used exclusively by scripting languages, such as Microsoft Visual Basic for Applications (VBA), Microsoft Visual Basic Scripting Edition (VBScript), and Microsoft JScript, to access COM components that support Automation. The advantage of Automation is that it allows various languages to access COM components at run time. The drawbacks to Automation are that it is slow and that compile-time data type checking cannot be performed.

An application that exposes its functionality through Automation is called an Automation server. An application that communicates with the server through Automation is called an Automation controller or Automation client.

How It Works

An Automation server is a COM component that typically implements the IDispatch interface. An Automation controller is a client that communicates with the Automation server, typically using IDispatch. IDispatch is a COM interface that allows a client to indirectly access all of the exposed methods and properties of the component. Therefore, IDispatch enables a client to discover and access all the various methods and properties of a component at run time through a single interface.

NOTE

In the past, Automation required communication using the IDispatch interface. Now the term Automation is more generic and refers to the programmability of an application or component.

See also
Automation controller, Automation server

Automation client

See
Automation controller

Automation controller

A client that accesses the functionality of an Automation server. Automation is a way for one application to manipulate the exposed objects (properties and methods) of another application. Automation controllers are client applications that can manipulate the exposed objects of another application called an Automation server. Examples of Automation controllers include Microsoft Word, Microsoft Excel, and Microsoft Visual Basic.

There are two kinds of Automation clients:

  • Clients that have static information about the properties and methods of the Automation server bound to them at compile time.

  • Clients that dynamically obtain information about the properties and methods of the Automation server at run time. These clients do this by querying the IDispatch interface of the Automation server.

See also
Automation, Automation server

Automation server

A Component Object Model (COM) component that exposes its functionality to other applications. An Automation server typically implements the IDispatch interface.

Here’s an example of an Automation server: a word processing program that can expose its spell-checking functions so that Automation controllers can access them. This allows the functionality of one program (the Automation server) to be used by other programs (the Automation clients or controllers).

See also
Automation, Automation controller

auto naming

A feature of Microsoft Exchange Server that enables administrators to configure how e-mail aliases and other information are automatically generated when mailboxes are created. For example, using auto naming, you could automatically generate any of the following e-mail aliases for Jeff Smith’s mailbox:

  • JSmith

  • JeffS

  • JS

You could also devise some other custom naming scheme. These e-mail aliases then would be combined with the Domain Name System (DNS) domain name of the Exchange organization to form the user’s standard e-mail address. For example, if the domain name of the company is northwind.microsoft.com, JSmith would be combined with it to form the e-mail address JSmith@northwind.microsoft.com.

autonomous system (AS)

A portion of a large internetwork that is under a given administrative authority. Autonomous systems can be under the authority of a particular corporation or institution, or they can be defined by the uniform use of a particular routing protocol such as Open Shortest Path First (OSPF). Autonomous systems are part of the routing infrastructure of a large internetwork and can be subdivided into routing domains.

The Internet is the prime example of a large internetwork divided into different autonomous systems (such as CERFnet, SprintLink, and AlterNet). These autonomous systems are connected with backbone routers that use the Border Gateway Protocol (BGP) for communication among them. Each autonomous system is represented by a 16-bit integer assigned by Internet Network Information Center (InterNIC), which is used by BGP to avoid routing loops and implement policy-based routing on the Internet backbone. There are three types of autonomous systems:

  • Stub AS:
    This AS is connected to only one other AS. A corporate network that is connected to an AS is considered to have the same AS number as the AS it is connected to.

  • Transit AS:
    This AS is connected to more than one other AS and can be used for transit traffic between autonomous systems. They are usually administered by large Internet service providers (ISPs).

  • Multihomed AS:
    This AS is connected to more than one other AS but does not let transit traffic from another AS pass through itself. An example might be a corporate network with several Internet connections to different ISPs.

See also
routing

autosensing

Technology in which a device can determine the characteristics of an attached device and configure itself accordingly. For example, a port on an autosensing 10/100-Mbps Ethernet switch can automatically detect whether the attached station has a 10-Mbps or 100-Mbps network interface card (NIC). This is a useful feature that allows a combination of 10BaseT and Fast Ethernet connections in a single local area network (LAN). Often during migration and system upgrades you’ll find a combination of slower, legacy networking equipment and faster, more modern devices. These devices might need to coexist together for months or years, depending on the budget available for upgrades. Using autosensing hubs and switches makes this coexistence cheap and simple, and allows a full upgrade to the faster configuration later—without purchasing additional equipment.

availability

The degree to which network resources operate without interruptions resulting from scheduled maintenance or unexpected failure. Microsoft Cluster Server (MSCS) is a tool for ensuring continuous uninterrupted 24 x 7 x 365 availability of network resources. Availability has become an important issue in the modern Internet economy in which online electronic businesses are made or broken on the basis of reliable, fault-tolerant technologies. MSCS provides the basic platform for building high-availability e-business and electronic commerce applications that can compete in today’s world. MSCS can automatically detect when an application or server fails and restart it on the surviving cluster node in moments. Users connected to the server will experience only a brief pause in service.

AVS

See
Automatic Version Synchronization (AVS)

AWG

Acronym for American Wire Gauge, a specification for the diameter of conducting wires. The higher the AWG number, the thinner the wire. Category 5 cabling is usually AWG 24 wire (0.020 inch or 0.511 millimeter in diameter), while thicknet generally uses AWG 12 wire (0.080 inch or 2.050 millimeters in diameter). The following table shows some of the various AWG gauges for different diameters of wires. Note also that the thinner the wire, the higher its electrical resistance and hence the shorter the transmission distance (because resistance varies inversely with thickness).

AWG Gauges for Various Diameters of Wires
AWG Gauge | Diameter (inches) | Diameter (millimeters)
12 | 0.080 | 2.050
14 | 0.064 | 1.630
16 | 0.051 | 1.290
18 | 0.040 | 1.020
20 | 0.032 | 0.813
22 | 0.025 | 0.643
24 | 0.020 | 0.511
30 | 0.010 | 0.254

AXFR request

A type of Domain Name System (DNS) request in which a secondary DNS server requests the update of information from a master DNS server. An AXFR request always results in a full zone transfer. This can take time and use considerable network bandwidth if the zone files are large. An alternative to AXFR is the incremental zone transfer protocol described in Request for Comments (RFC) number 1995. Incremental zone transfers use an IXFR request and transfer only those portions of the zone file that have been changed. Incremental zone transfers are supported by the DNS service running on Microsoft Windows 2000.


B

backbone

The part of your network that ties different departmental networks into a single whole. The backbone carries the bulk of the network traffic and must be designed accordingly.

Graphic B-1. Two types of backbone: distributed and collapsed.
Graphic B-1. Two types of backbone: distributed and collapsed.
How It Works

Backbones are primarily used in medium to large-sized networks, such as those occupying a building or a group of buildings on a campus. These backbones generally fall into two basic categories:

  • Distributed backbone:
    Refers to using cabling to join different departmental networks in a bus topology or mesh topology. This cabling is referred to as backbone cabling, and it connects the hubs, switches, or routers of each network into a single whole. In a typical scenario, each floor or building might have a local area network (LAN) and wiring closet containing, among other things, a main hub or router. Backbone cabling is then run between floors or buildings, connecting the main hub or router for each department into a bus-style network (see illustration).

  • Collapsed backbone:
    Refers to using cabling to directly join each departmental network’s main hub or router using backbone cabling to a central hub, switch, or router in a star topology (see illustration). The central unit is often referred to as the collapsed backbone, although this term properly describes the entire configuration. The central unit can be located in the building’s main equipment room or, in a campus scenario, in the IS department’s building.

Distributed backbones generally have a greater degree of fault tolerance than collapsed ones, because the collapsed backbone unit forms a single point of failure. However, collapsed backbones usually have better traffic flow than distributed backbones because of the underlying star topology. Collapsed backbones generally offer better performance because of the reduced number of hops that traffic must make when passing between departmental LANs. Collapsed backbones are also easier to manage because they bring all the backbone switching and routing equipment into a single room or building. Collapsed backbones are used frequently for connecting departmental LANs within a single building, but less often for connecting building LANs across a campus network because of the increased distances and cabling costs.

Backbone cabling should have the highest bandwidth of any cabling in your network, since backbones are used to join together hubs, switches, and routers, linking departmental LANs or subnetworks into building-wide or campus-wide internetworks. In buildings, backbone cabling often refers to the vertical cabling running through the rises or elevator shafts that connects the hubs and switches in each floor’s wiring closet. Depending on performance requirements, anticipated growth, and cost, any of the following might be suitable for backbone cabling:

  • Cat5 UTP cable

  • Type 1A STP cable

  • Thinnet coaxial cabling

  • Multimode fiber-optic cabling

  • Single-mode fiber-optic cabling

NOTE

The term “backbone” is also used to refer to the collection of networking components (cabling, hubs, switches, and routers) that form the supporting network into which workgroup and departmental LANs are connected and joined together. A mesh topology is often used for network backbones to provide fault tolerance for critical high-speed data paths.

TIP

You should put considerable thought and planning into the design and implementation of your network’s backbone, as the overall performance of networking services is largely dependent on the bandwidth and reliability of the backbone. Design your backbone with network expansion in mind. Planning for growth is especially important if the cable reinstallation cost is high. Fiber-optic cabling is preferred for most network backbones because of its high bandwidth, security, and resistance to electromagnetic interference.

See also
collapsed backbone

backbone router

A router that is used to connect autonomous systems in a large internetwork such as the Internet.

Graphic B-2. Backbone router.
Graphic B-2. Backbone router.
How It Works

Autonomous systems are large portions of an internetwork that fall under the administration of a single authority. In an autonomous system, routers exchange information with each other using routing protocols called Interior Gateway Protocols (IGPs), such as the Routing Information Protocol (RIP) and the Open Shortest Path First (OSPF) Protocol. Backbone routers are then used to connect the various autonomous systems into a single internetwork. Backbone routers also exchange information using Exterior Gateway Protocols (EGPs), such as the Border Gateway Protocol (BGP).

Backbone routers must have high performance and reliability because they are typically used to aggregate and route traffic from dozens or hundreds of physical local area network (LAN) segments and to maintain routing information for thousands of machines. Backbone routers can cost from $10,000 to $100,000 each, or more. They come with dedicated operating systems, such as Cisco Systems’ Internetwork Operating System (IOS).

See also
routing

backboning

The process that enables the transmission of messages between similar messaging systems by making use of a different type of intermediate messaging system. For example, Microsoft Exchange Server can use an existing public or private backbone messaging system to implement an Exchange Server–based messaging system. Exchange Server can also be used for linking other mail systems such as legacy Microsoft Mail networks.

Graphic B-3. Backboning.
Graphic B-3. Backboning.
How It Works

A simple backboning example is the connecting of two or more Lotus cc:Mail postoffices using an Exchange Server organization as the messaging backbone. By installing the cc:Mail Connector on Exchange Server, messaging connectivity can be established with connected cc:Mail postoffices. Messages can then be routed from one postoffice through the Exchange organization to other postoffices on the network.

Another example of backboning is the connecting of different sites in an Exchange Server organization using a public or private messaging network. Here are two possible scenarios:

  • Using Simple Mail Transfer Protocol (SMTP) hosts on the Internet to connect Exchange sites. To do this, the Internet Mail Service can be installed on appropriate Exchange servers.

  • Using a public or private X.400 messaging system for connecting Exchange sites using the X.400 Connector.

NOTE

The term “backboning” is sometimes used to describe the core messaging paths set up for a large Exchange organization, regardless of whether messaging systems other than Exchange are involved.

TIP

When using a public messaging backbone (or a private one owned by a different company) for connecting your Exchange sites, you should consider the following:

  • Installing and configuring appropriate messaging connectors on suitable messaging bridgehead servers

  • Establishing and maintaining directory replication between Exchange sites

  • Handling background traffic from other users of the backbone

  • Tuning messaging performance to optimize use of the backbone

  • Implementing a suitable topology for the messaging backbone

For very large Exchange organizations, use a hub and spoke topology instead of a mesh topology. Hub and spoke topologies have less redundancy and fault tolerance, but mesh topologies have routing tables that grow exponentially with the number of sites involved. Mesh topologies for large organizations can lead to routing tables that are so large they degrade the performance of the message transfer agents, even on high-performance servers.

background program

Any program that runs while the user performs another task on the system—for example, a spreadsheet (background program) that calculates data while the user types a letter using a word processor (foreground program).

Operating systems usually assign fewer CPU resources to background programs than to foreground ones. In Microsoft Windows NT, the System utility in Control Panel allows you to boost the performance of the foreground application over any background applications running. Setting the performance boost to None gives both foreground and background applications equal processor time, while setting it to Maximum gives foreground applications greater priority.

In Windows 2000, the System utility in Control Panel offers you one of the following options for optimizing performance:

  • Applications:
    Provides more CPU resources to the foreground program and allocates short, variable quanta to running applications

  • Background Services:
    Divides CPU resources equally among the foreground program and any running background programs and allocates long, fixed-length quanta to applications

TIP

Select None for a performance boost on Windows NT servers. This will optimize the performance of the server for servicing network requests. Select Maximum on Windows NT workstations to optimize responsiveness for user applications.

BackOffice

See
Microsoft BackOffice

backup

A copy of important data. Performing regular backups is one of the main components of a company’s disaster recovery policy, and the importance of doing so cannot be stressed enough. Various occurrences can lead to data loss on a corporate network:

  • Disk failures caused by hardware failure, power outages, or improper use

  • Network problems leading to lost packets that are not acknowledged because of router congestion or other situations

  • Virus infection, resulting in corrupted files

  • Sabotage by hackers or disgruntled employees, resulting in erased data

  • Theft of hardware from the premises

To guard against these occurrences—or rather, to prepare for them, since they are, to a certain extent, inevitable—establish a disaster recovery policy that includes a reliable backup plan. In today’s business world, where data is the lifeblood of the enterprise, a comprehensive plan is essential. The following steps are recommended when creating such a plan:

  • Decide what kind of backup storage devices to use. Options range from small digital audio tape (DAT) drive units capable of backing up several gigabytes of data, to large automated tape libraries capable of handling terabytes of centralized data storage. Other backup options include optical storage libraries and removable disks such as Iomega’s Zip drive disks or Imation SuperDisk disks.

  • Decide whether to back up servers with dedicated, locally connected storage devices or over the network to centralized backup libraries. Network backup systems suffer from a single point of failure (the network itself) but are simpler to administer than a multitude of individual backup units.

  • Decide whether individual users’ workstations should also be backed up. A more cost-effective option is to educate users to always save their work on a network share located on a server that is regularly backed up.

  • Decide how to secure the storage of backup tapes and other media. Will duplicate copies be stored both on site (for easy access if a restore is needed) and off site (in case the company’s building burns down)? Make sure the storage facilities are climate controlled and secure.

  • Decide what kind of backup strategy to employ. A backup strategy is a combination of a backup schedule and various backup types, including normal, copy, incremental, differential, and daily copy backup types. Also consider whether you will verify all tapes immediately after each backup is performed.

  • Assign various aspects of the backup procedure to the responsible party. One option some companies now use is to back up data over the Internet to a third-party backup service provider that stores and maintains the backed-up data. This method involves issues of trust and of the Internet connection as a point of failure.

  • Test backups periodically to ensure that they are actually readable. Nothing is worse than thinking you have a backup when in fact it is unreadable.

To enable administrators to perform regular backups, Microsoft includes backup utilities with all versions of Microsoft Windows, such as the Backup tool in Windows 2000.

See also
backup strategy, backup type, tape backup, Windows Backup

Backup

See
Microsoft Backup, Windows Backup

backup agent

A service that can be installed on a server or workstation to allow files and folders on the computer to be backed up remotely over the network to a tape backup unit or another form of backup storage media. Instead of installing a tape backup unit on each server and backing it up locally, you can use a backup agent to back up multiple servers on the network, centrally. Centralized tape backup libraries are expensive but simpler to administer than a multitude of individual tape drives.

How It Works

Microsoft Windows 95 and Windows 98 include two backup agents that allow centralized, network backup of users’ workstations:

  • Backup Exec Agent from Seagate (now Veritas)

  • ARCServe Agent from Cheyenne

To use either of these agents, you must install the agent on each computer you want to back up, and your system administrator must purchase and install the corresponding server-based network backup software from the same company and install it on the server to which a tape drive is attached. Once this is done, your administrator uses the server-based backup software to schedule frequency of backups, and the users of the computers being backed up can specify which files to back up by configuring the Properties of the installed backup agent on their computers.

backup browser

A computer running Microsoft Windows NT involved in supporting the functions of the Computer Browser service.

How It Works

A backup browser is a machine that obtains a copy of the browse list from the master browser. The browse list contains information about which shared resources are available to client machines on the network and about which domains are on the network. Backup browsers automatically contact the master browser every 12 minutes to request a copy of the browse list. If the contact is successful, the master browser issues the list to the backup browser. If the backup browser cannot contact the master browser, it starts a browser election to force a new master browser to be selected.

Once the backup browser has the browse list, it caches the list and distributes it to any client that requests it. To request the browse list from a backup browser, a client calls the NetServerEnum application programming interface (API) on the backup browser.

NOTE

There will be one backup browser for every 32 systems in a given domain or workgroup on the network. The Computer Browser service determines the number of backup browsers necessary to ensure that clients can have efficient access to network resources.

Graphic B-4. Backup browser.
Graphic B-4. Backup browser.
See also
Computer Browser service, domain master browser, master browser, potential browser

backup catalog

A representation of the results of performing a backup of servers on a network. Backup software such as the Microsoft Windows NT administrative tool Windows NT Backup and Backup in Windows 2000 create catalogs so that backed up files are documented and can be found when performing a restore. Windows NT Backup stores its catalogs on the backup storage media themselves. These catalogs are then loaded into memory when the program is run. Catalogs can also be saved to disk and can be printed for documentation purposes.

Example

On the Windows NT platform, the administrative tool Windows NT Backup creates two different types of backup catalogs:

  • Tape catalog:
    Lists the details of all backup sets that have been stored on the tape. If a backup operation spans several tapes, the tape catalog is located on the last tape of the series, because it is created at the end of the backup operation.

  • Backup set catalog:
    Lists the details of files and folders included in a specific backup set. A backup set catalog is saved at the end of each backup set on the tape. This catalog is used by the Windows NT Backup program to store a summary of the file and directory information for the backup set, the number of tapes in the backup set, and the date on which the backup was performed.

TIP

If a backup operation spans several tapes and the last tape is missing or damaged, the tape catalog will not be available. However, you can still obtain a complete list of the various backup sets on the tapes by running Windows NT Backup from the command line using the ntbackup command with the /missingtape switch.

See also
backup set

backup domain controller (BDC)

A Microsoft Windows NT domain controller containing a read-only copy of the master domain directory database located on the primary domain controller (PDC). A Windows NT domain can have zero or more backup domain controllers (BDCs) for load balancing and redundancy. The BDCs periodically undergo directory synchronization in a Windows NT domain by retrieving a copy of the directory database from the PDC. A BDC can perform logon validation and authentication like a PDC, but it cannot manage accounts—for example, it cannot change user passwords.

Graphic B-5. Backup domain controller (BDC).
Graphic B-5. Backup domain controller (BDC).
NOTE

The placement of BDCs in wide area networks (WANs) that are based on Windows NT is an important issue. In a master domain model scenario, user accounts are centralized in a master domain located at company headquarters, while users and shared network resources are distributed in resource domains located at branch offices in different locations. The users in this scenario must log on to the master domain in order to access resources in the enterprise. There are two ways of facilitating this:

  • Locate all BDCs belonging to the master domain at headquarters. Unfortunately, when users at the branch offices want to log on, they will have to use the relatively slow WAN link to do so. The additional logon traffic can cause congestion on the WAN link, particularly at certain times of the day.

  • Locate one or more BDCs belonging to the master domain at each branch office (resource domain). This will facilitate logons by users located at branch offices, since they can log on to one of these BDCs locally instead of being validated over the relatively slow WAN link by a domain controller at headquarters. However, directory replication traffic between the BDCs located at the branch offices and the PDC at headquarters can cause congestion over the WAN links. To make directory synchronization more efficient over the WAN link, registry parameters such as ReplicationGovernor and ChangeLogSize can be adjusted, and batch files can be scheduled using the at command to configure different replication rates at different times of the day.

TIP

Every Windows NT network should have at least one BDC for fault tolerance. If the PDC fails, the BDC can be promoted to take its place. One BDC can support approximately 2000 users on a network, but many factors can affect this figure.

See also
domain controller, primary domain controller (PDC)

Backup Operator

In Microsoft Windows NT, users who are assigned the responsibility to back up and restore servers on a network. To make an individual a Backup Operator, simply make him or her a member of the Backup Operators group. Backup Operators can exist on Windows NT domain controllers, on member servers, and on workstations. In Windows 2000, Backup Operators are members who have a similar function and belong to the built-in group called the Backup Operators built-in group.

Backup Operators have the preassigned right to log on locally to a computer and to back up and restore files and directories on the system. Backup Operators also have the right to shut down the system. Backup Operators do not need permissions assigned to them in order to back up a particular file or directory—they have a broad system right to do so.

TIP

Backup Operators should be assigned only in enterprise-level networking environments. In small to medium-sized networking environments, backing up and restoring servers is often the responsibility of the administrator.

See also
Backup Operators built-in group

Backup Operators built-in group

In Microsoft Windows NT, a built-in group existing on all Windows NT–based servers and workstations whose members have the right to back up and restore files on the computer regardless of the permissions protecting those files. In Windows 2000, a built-in group existing on all Windows 2000–based servers and workstations. The Backup Operators built-in group is a local group with the following preassigned rights:

  • Log on locally

  • Back up files and directories

  • Restore files and directories

  • Shut down the system

TIP

If you want a user to be able to back up files and directories on any domain controller in a domain, place the user in the Backup Operators group on any domain controller. Since all domain controllers share the same directory database, the user will be a member of the Backup Operators built-in group for all domain controllers. However, if you want a user to be able to back up a member server, place the user in the Backup Operators built-in group that is a local group on that particular member server.

See also
built-in group, built-in local group

backup set

A collection of files and folders on a backup tape that were saved in a single Microsoft Windows NT Backup operation. (Windows 2000 Backup can back up files to other media types, such as hard disks.)

You have several options for creating backup sets:

  • Multiple backup sets can be saved on a single backup tape by appending each new set to the last one.

  • A backup set can span multiple tapes if you have a large quantity of information to back up.

  • Tapes can be overwritten so that a new backup set replaces the old.

    Graphic B-6. Backup set.
    Graphic B-6. Backup set.

Windows NT Backup creates a backup set catalog for each backup set. This catalog lists the various files and directories that have been backed up, and it can be used for restoring individual files or directories, or printed for documentation purposes. The backup set catalog is saved at the end of each backup set on the tape. A backup set map at the end of the tape locates all backup sets on the tape.

NOTE

A copy of the local system’s registry can also be included in the backup set for a Windows NT system. Backup sets are described with friendly names up to 32 characters long.

See also
backup catalog

backup site controller (BSC)

A Microsoft Message Queue (MSMQ) Server that contains a read-only copy of the primary site controller (PSC) or primary enterprise controller (PEC) database. MSMQ sites do not require backup site controllers (BSCs), but at least one backup site controller should be installed in each MSMQ site for load balancing and failure recovery. A PSC or PEC must be installed before you can install any backup site controllers. The BSC also functions as an MSMQ Routing Server. In this capacity, the BSC provides intermediate store-and-forward message queuing services and dynamic routing. BSCs must be installed on computers running Microsoft Windows NT Server, Enterprise Edition.

backup strategy

A plan for performing backups to ensure against data loss. Backup strategies should take the following into account:

  • The various backup types that can be performed

  • The need to archive tapes for long-term data security

  • The time needed to perform backups and restores

  • The cost of tapes

  • The cost of losing data

There is no one right way to implement a backup strategy for resources on a network of computers. To select the best backup strategy for your network, you must consider each of the items in the preceding list and balance them against each other. Your strategy should be simple, efficient, and reliable. The following table shows some examples of backup strategies.

Possible Backup Strategies
Backup Strategy | Advantages | Disadvantages
Normal backups Monday through Friday. | Most secure—every tape contains all backed up files | Longest time to back up
Normal backup Monday; differential backups Tuesday through Friday. | Less time to restore | More time to back up
Normal backup Monday; incremental backups Tuesday through Friday. | Less time to back up | More time to restore
Use a separate tape for each weekday, and archive Monday’s full backup tape weekly or monthly. | Less chance of data loss | Higher cost, since more tapes are needed
Use the same tape for each weekday, and archive the tape each week or month. | Cheaper—only one tape required per week or month | Greater chance of data loss, since using only one tape
See also
backup, backup type

backup type

A particular method for performing a backup of files and directories. Each type of backup has a different function in an overall backup plan. Most network backup software (such as Microsoft Windows NT Backup and Windows 2000 Backup) supports five backup methods:

  • Normal backup:
    Backs up everything that is selected to be backed up. Normal backups are the fastest and easiest to restore. Normal backups are sometimes referred to as “full backups.” Use a normal backup when you want to ensure that all your critical system and data files are backed up in a single operation. If your backup cycle consists only of normal backups and you need to perform a restore, you need to use only the most recent normal backup to do so.

  • Copy backup:
    Primarily used to produce an additional copy of a backup—for example, a copy to send to the accounting department for monthly archiving and reporting. While a copy backup backs up the same files as a normal backup, there is a difference between the two operations. Performing a normal backup clears the archive bit on each backed up file and marks them as having been backed up. A copy backup, however, does not modify the archive bit on the files backed up. In other words, you can perform a copy backup at any time in a backup cycle without interrupting the cycle in any way—the copy backup is distinct from the backup cycle and is not required when a restore is performed from the cycle’s set of tapes.

  • Incremental backup:
    Backs up only files that have been created or modified since the last normal or incremental backup. Files that are backed up in an incremental backup have their archive attributes cleared to indicate that they have been backed up. Using a combination of normal and incremental backups takes less time and uses less storage space than performing only normal backups. However, if you need to perform a restore, you typically need to use the normal backup plus every incremental backup from the current backup cycle to do so.

  • Differential backup:
    Copies those files that have been created or changed since the last normal or incremental backup. Files that are backed up by a differential backup do not have their archive attributes cleared, which means that these files will be backed up again in any succeeding differential backups. Differential backups are cumulative with regard to changes—that is, each differential backup in a given backup cycle contains all the files from the last differential backup, plus any files that have been modified since the last differential backup. Thus, if you need to perform a restore, you will typically need to use only the normal backup and the most recent differential backup from the current backup cycle to do so.

  • Daily copy backup:
    Copies all files that have been modified on the day the daily copy backup is performed. This method is sometimes used to make a copy of all files a user worked on in a day so that he or she can take them home to work on. Like a copy backup, the daily copy backup does not modify the archive bit of the files backed up; therefore, the daily copy backup does not interrupt the backup cycle in any way.

NOTE

Different types of backup operations have different effects on the archive attributes of the files and directories they back up. A backup operation marks the archive attribute by clearing it to indicate that the file has been backed up. If the file is later modified in some way, its archive attribute is set (unmarked). This next table shows what each type of backup operation does to the archive attribute:

Effects of Backup Operations on the Archive Attribute
Backup Type | Archive Attribute
Normal | Cleared
Copy | No effect
Incremental | Cleared
Differential | No effect
Daily copy | No effect
See also
backup, backup strategy

Backup Wizard

A wizard that is part of the Backup tool in Windows 2000 that can be used to perform a backup. The Backup Wizard starts by letting you choose among the following:

  • Backing up all files on the computer on which it is running.

  • Backing up files and folders that you specify. These files and folders can be either on the local computer or on any shared location on the network.

  • Backing up Active Directory and the registry on the computer on which the wizard is running. Active Directory can be backed up only on a domain controller.

The wizard then leads you through the process of specifying a backup location and other advanced backup options, such as verification, compression, and remote storage. You can also schedule a backup job to run unattended at a later time when users have stopped working and all files are closed.

NOTE

The Microsoft Backup tool for Windows 98 also includes a Backup Wizard with similar capabilities.

balanced line

An electrical cable consisting of pairs of conductors that have identical electrical characteristics with respect to each other and with respect to ground. The typical example in computer networking is the twisted-pair cabling used in 10BaseT Ethernet networks.

How It Works

In a balanced line, both of the two wires are carrying current at any given instant. However, at any particular moment, the directions of the current in the wires are opposite each other. This condition is also described by saying that the currents in the wires are 180 degrees out of phase with each other at any given moment. Both wires have voltages that are above ground potential, but the potentials of the wires are different with respect to ground, resulting in a flow of current. The wire pair is twisted in order to ensure that the electromagnetic radiation produced by both wires is effectively canceled out, reducing the overall electromagnetic interference (EMI) produced by the wires and reducing their sensitivity to induced currents from external sources of EMI.

TIP

A balun can be used to connect a balanced line to an unbalanced line.

See also
balun, unbalanced line

balun

Stands for bal anced un balanced. A device used to connect balanced lines and unbalanced lines. Balanced and unbalanced lines have different electrical characteristics. A balun matches these characteristics by providing impedance transformation between the two different lines. Baluns can be used for various types of connections between different wiring systems:

Graphic B-7. Balun.
Graphic B-7. Balun.

  • Twisted-pair cabling to coaxial cabling:
    Typically used for connecting 10BaseT networks with 3270 equipment running on coax or twinax networks

  • Twisted-pair cabling to token ring cabling:
    Used for matching token ring Type 1 cabling to standard unshielded twisted-pair (UTP) cabling to connect 10BaseT or faster hubs or adapters with RJ-45 ports into a token ring network

  • Asynchronous Transfer Mode (ATM) cabling to token ring cabling:
    Used for connecting token ring networks to high-speed ATM hubs in campus backbone networks

See also
balanced line, unbalanced line

bandwidth

In general, the difference between the highest and lowest frequencies in a given range of frequencies for an analog signal. For example, if the lowest and highest frequencies a telephone line can carry are 300 Hz and 3300 Hz, the telephone line can accommodate a bandwidth of 3300 – 300 = 3000 Hz, or 3 kHz.

In computer networking with digital signals, bandwidth is the capacity of a communication channel for carrying signals. The greater the bandwidth, the more data can be transferred in a given time. Bandwidth is sometimes referred to as “throughput,” and for digital communication, it is usually measured in bits per second (bps) or a multiple thereof (Kbps, Mbps, Gbps, and so on).

NOTE

For fiber-optic cabling, the bandwidth is usually expressed in units of MHz-km. For example, a cable rated at 500 MHz-km could carry 500 Mbps of data a distance of 1 kilometer, 250 Mbps of data a distance of 2 kilometers, 100 Mbps of data a distance of 5 kilometers, and so on.

Bandwidth Allocation Protocol (BAP)

A multilink remote access protocol supported by Microsoft Windows 2000 that dynamically controls how bandwidth can be allocated for multilink connections using the Point-to-Point Protocol (PPP). Bandwidth Allocation Protocol (BAP) makes multilink connections more efficient by allocating lines only as required, thus eliminating wasted bandwidth. This is especially useful if the telecommunications carrier being used for the PPP connection charges by the amount of bandwidth being utilized by the customer.

BAP allows the administrator to configure the PPP server to specify which particular Multilink PPP (MPPP) lines can be added or dropped. The administrator also specifies which bandwidth thresholds must be crossed before additional lines are added or existing ones are dropped. BAP is especially useful over Integrated Services Digital Network (ISDN) connections, because these dial-up services can almost instantly add or drop lines.

BAP is provided in Windows 2000 as an additional enhancement to the Routing and Remote Access Service (RRAS) of Windows NT 4.0. BAP is defined in Request for Comments (RFC) number 2125.

bandwidth on demand

Any telecommunications technology that provides both a permanent, dedicated connection and the capability of quickly increasing bandwidth when needed by users. Many telecommunications devices incorporate bandwidth-on-demand features of various types. For example, some Integrated Services Digital Network (ISDN) devices used for Basic Rate Interface ISDN (BRI-ISDN) can be configured to use the second ISDN B channel only when the utilization of the first channel exceeds a certain threshold. If this threshold is exceeded for a specified period of time, the second B channel automatically opens up to facilitate and speed data transfer. Once the data rate has dropped below the threshold, the second B channel shuts down until it is needed again. The ISDN technology for accomplishing this combining of channels is called bonding. Many Asynchronous Transfer Mode (ATM) products also support various bandwidth-on-demand features.

Bandwidth-on-demand technologies are typically used in bursty networking situations in which high transmission speeds and capacities are required for transporting video, voice, and data on common networking circuits. Bandwidth-on-demand configurations often involve a mix of leased-line services and circuit-switched telecommunications services, and they can save users money by opening additional circuits only on an as-needed basis. Networks that make use of bandwidth on demand can be designed to supply additional bandwidth under conditions such as

  • Exceeding a specified threshold of network traffic

  • Scheduling for expected peak periods of the day

  • Failover in case the permanent link goes down

bandwidth throttling

Generally, any networking technology that controls the amount of network bandwidth used by servers, applications, or network communication paths. In the context of Microsoft Internet Information Services (IIS), for example, bandwidth throttling is a technique for controlling the amount of network bandwidth used by individual Web sites hosted on the server. Bandwidth throttling can be used to prevent hits on a popular site from overwhelming the server and preventing other sites hosted on the server from being accessed by clients.

For example, if five Web sites are being hosted on a single machine running IIS but one of them is extremely popular, the other sites might get starved for bandwidth and users might have difficulty connecting to them. In order to rectify this situation, a specific maximum bandwidth level can be allocated to the popular site with the Internet Services Manager snap-in used for administering IIS using the Microsoft Management Console (MMC). If this maximum bandwidth is exceeded, no further connections to that site are allowed until the bandwidth utilization level drops below the threshold. This allows the unallocated bandwidth to be shared among the remaining less popular sites so that users can connect to them.

Banyan VINES

Stands for Banyan Virtual Integrated Network Service, a network operating system (NOS) for building enterprise-level networks. VINES was originally based on a proprietary family of protocols that was derived from the Xerox Network Systems (XNS) protocol. VINES uses a client/server distributed networking architecture for allowing clients to access network resources on servers over the network. VINES includes such features as

  • Basic file and print sharing

  • A distributed directory service called StreetTalk for managing networks

  • Support for the TCP/IP protocol

  • Graphical administration tools

  • Support for Simple Network Management Protocol (SNMP) management

VINES includes clients for MS-DOS, OS/2, Microsoft Windows, and Macintosh platforms as well as optional applications for integrating Windows NT, AppleTalk, Novell, and UNIX networks into existing VINES-based networks.

How It Works

VINES is built on a client/server model in which clients can make requests for services from servers on the network. The VINES protocol stack consists of five basic layers that map to the seven-layer Open Systems Interconnection (OSI) reference model as follows:

  • Physical and data-link layers:
    VINES can operate over Ethernet, token ring, X.25, and other types of networking architectures.

  • Network layer:
    The main protocol here is the VINES Internetwork Protocol (VIP), which is similar in function to the Internet Protocol (IP) of the TCP/IP protocol suite. VIP encapsulates data and addresses it using a 48-bit address that contains a 32-bit network number and a 16-bit host number. Dynamic address assignment and address resolution are performed using VINES servers, which are referred to as service nodes. VINES clients obtain their addresses dynamically from the nearest server on the network. Multihomed servers function as routers, and routing tables are maintained by periodic announcements from clients and servers. Other network layer protocols include an Address Resolution Protocol (ARP), an Internet Control Protocol (ICP), and a Routing Table Protocol (RTP).

  • Transport layer:
    For reliable delivery of data using acknowledgments and sequence numbers, VINES uses its Reliable Message Service. Another service, the Unreliable Datagram Service, supports only best-effort delivery of packets. Finally the Data Stream Service can be used to transmit large amounts of data using virtual circuits with flow-control mechanisms.

  • Session and presentation layers:
    VINES implements the standard remote procedure call (RPC) mechanism for enabling communication between VINES client and server components on different stations on the network.

  • Application layer:
    VINES supports standard file and print services, directory services (StreetTalk), and a number of other application layer services and protocols.

TIP

When connecting Windows 95 or Windows 98 clients to a VINES-based network, use the 32-bit client for Windows that comes with VINES instead of the 16-bit VINES client included with Windows 95 and Windows 98.

On the Web
•
Banyan home page
: http://www.banyan.com

BAP

See
Bandwidth Allocation Protocol (BAP)

baseband transmission

A signaling technology that sends digital signals over a single frequency as discrete electrical pulses. The entire bandwidth of a baseband system carries only one data signal and is generally less than the amount of bandwidth available on a broadband transmission system. The baseband signal is bidirectional so that a baseband system can both transmit and receive signals simultaneously. Baseband signals can be regenerated using repeaters in order to travel longer distances before weakening and becoming unusable because of attenuation. Baseband transmission technologies do not use modulation, but they can use time-division multiplexing (TDM) to accommodate multiple channels over a single baseband transmission line.

Common local area network (LAN) networking technologies such as Ethernet use baseband transmission technology. All stations on a baseband network share the same transmission medium, and they use the entire bandwidth of that medium for transmission. As a result, only one device on a baseband network can transmit at a given instant, resulting in the need for a media access control method to handle contention.

See also
broadband transmission

baseline

A set of data that indicates normal usage of monitored network resources. The Microsoft Windows NT administrative tool Performance Monitor and the Microsoft Windows 2000 snap-in called System Monitor can be used to collect data for the present performance of your network to establish a baseline. Then, if you upgrade hardware or add new users, the performance of the network can be measured again and compared with the baseline to determine trends, identify bottlenecks, and measure capacity.

How It Works

Creating a baseline for server and network activity begins with the process of identifying which server and network resources should be systematically measured. Generally, you always want to measure at least the following four resources: memory, processor, disk, and network subsystems. Using Performance Monitor or System Monitor, you should collect data for the objects shown in the table.

Resources and Corresponding Performance Objects to Monitor Performance
Resource | Objects to Collect
Memory | Memory, cache
Processor | Processor, system, server work queues
Disk | Logical disk, physical disk
Network | Server, network interface, network segment

These performance objects should be regularly captured for a period of time in order to collect the data needed to establish the baseline. Generally, you should append each log file collected to a master log file using relogging. Focus on periods of peak server and network activity, and collect at least a week of measurements to establish your baseline.

TIP

If you want to collect disk subsystem data, first enable disk objects using the diskperf command. Make sure you use a computer that is not being monitored to create your measurement baseline log files so that the activity of the computer doing the monitoring will not affect the data being collected.

Basic Authentication

Also called “Clear-Text Authentication,” an authentication method that passes a user’s credentials over a network of computers in an unencrypted form. Basic Authentication is not a secure authentication scheme, since anyone who can intercept network traffic and read it using a protocol analyzer can obtain the user’s credentials.

Basic Authentication is one of three authentication schemes available on Microsoft Internet Information Services (IIS). Basic Authentication is often used in a UNIX environment for authenticating remote HTTP users. Basic Authentication is discussed in Request for Comments (RFC) numbers 1945, 2068, and 2069.

NOTE

Basic Authentication encodes a user’s credentials using a well-known public encoding algorithm known as uuencoding. Because the algorithm is well known, it is easy to decode uuencoded text.

TIP

Enable Basic Authentication on IIS to restrict access when you have clients that do not support Microsoft Windows NT Challenge/Response Authentication, or to support authentication through a firewall or proxy server. Note that for Basic Authentication to work on IIS, the users being authenticated must have the right to Log On Locally to the IIS server. Make sure that you use the NTFS file system to secure files on your system. To make Basic Authentication more secure, implement the Secure Sockets Layer (SSL) protocol.

See also
anonymous access, Windows NT Challenge/Response Authentication

basic disk

In Microsoft Windows 2000, a physical disk that can contain primary partitions, extended partitions, and logical drives. Basic disks can be accessed by MS-DOS and legacy Windows platforms. Basic disks can also contain volumes created using Windows NT version 4.0 or earlier, such as spanned volumes (volume sets), striped volumes (stripe sets), mirrored volumes (mirror sets), and RAID-5 volumes (stripe sets with parity).

Basic disks are the default type of disk in Windows 2000. All disks are basic disks unless you convert them to dynamic disks. Basic disks can have two kinds of partitions:

  • Primary partitions:
    Basic disks support up to four primary partitions, only one of which can be marked as active.

  • Extended partitions:
    Basic disks support only one extended partition, which can be further subdivided into logical drives or logical volumes.

NOTE

You can create only basic volumes on basic disks. You cannot create new simple, spanned, striped, mirrored, or RAID-5 volumes on basic disks.

See also
dynamic disk

Basic Rate Interface ISDN (BRI-ISDN)

A standard form of communication on Integrated Services Digital Network (ISDN) communication systems. Basic Rate Interface ISDN (BRI-ISDN) connections consist of two B channels and one D channel. The B channels carry the voice or data between the customer premises and the telco’s central office (CO), while the D channel is used for establishing connections and signaling. BRI-ISDN is often referred to as 2B+D because of the channels that it uses.

The bandwidth of each B channel is 64 Kbps, so the total bandwidth of BRI-ISDN is twice that, 128 Kbps. This bandwidth can be used as two separate communication links of 64 Kbps each, or it can be combined using bonding into a single 128-Kbps communication link. The bandwidth of the D channel is 16 Kbps.

BRI-ISDN connections at customer premises can be connected directly to a switch at the telco’s central office, an ISDN call controller that is linked to the CO, an ISDN Private Branch Exchange (PBX), or some other signaling and communication equipment.

See also
Integrated Services Digital Network (ISDN), Primary Rate Interface ISDN (PRI-ISDN)

basic volume

A type of volume in Microsoft Windows 2000. A basic volume can be created only on a basic disk and can be

  • A primary partition, extended partition, or logical drive that was created using the Disk Management portion of the Computer Management tool

  • A volume set, mirror set, stripe set, or stripe set with parity that was created using Windows NT version 4.0 or earlier

See also
dynamic volume

batch commands

A special set of commands that are generally found only in batch files and enable special actions such as conditional processing. Any command supported by an operating system can be included in a batch file, but the commands listed in the table that follows are generally found only in batch files. These commands are all supported by Microsoft Windows 2000, while earlier versions of Windows might support only a subset of them.

Batch File Commands
Command | Description
call | Calls one batch program from another while allowing the calling program to continue running
echo | Toggles command-echoing on or off
endlocal | Restores environment variables set by a setlocal command
for | Used to run a specified command for each file in a set of files
goto | Jumps to a specific line that is labeled in a batch file
if | Used to perform conditional processing of commands
pause | Suspends processing of the batch file and waits for the user to respond
rem | Used to insert remarks (comments) in a batch file for documentation purposes
setlocal | Initiates localization of environment variables in a batch file
shift | Used to change the position of replaceable parameters in a batch file

batch file

Also called a batch program, an ASCII file with the extension .bat or .cmd containing a series of commands. These commands are executed sequentially when the batch file is invoked at the command prompt or in a logon script. Batch files are used primarily to simplify the execution of routine or repetitive administrative tasks such as mapping drives, synchronizing system clocks, or performing backups.

Batch files trace their origin to MS-DOS (the autoexec.bat file is the most well-known example), but they are still used by administrators for logon and installation scripts in Microsoft Windows NT and Windows 2000 and for other administrative purposes. With the advent of the Windows Script Host (WSH)—which is included in Windows 98, Windows 2000, and the Windows NT Option Pack and which allows administrative scripts to be written in higher-level scripting languages such as Microsoft Visual Basic Scripting Edition (VBScript) and JavaScript—the old batch file paradigm might finally be about to disappear.

Example

If you want to control the rate at which directory information is replicated between a backup domain controller (BDC) and a primary domain controller (PDC) on a Windows NT–based network, you can create a batch file that will change the value of the ReplicationGovernor parameter on the BDC. First create a script that has the full path to this parameter in the registry along with the value you want to assign to it, and then create the following simple batch file:

regini <Script_Name>
net stop netlogon
net start netlogon

Two different scripts and batch files can be created for different times of the day, and the at command can be used to schedule the execution of each batch file at the appropriate time. This illustration is especially useful if directory replication must occur over a slow WAN link, and it can be used to ensure that most replication traffic occurs during off hours.

B channel

Stands for bearer channel, a circuit-switched channel for carrying voice or data in Integrated Services Digital Network (ISDN) services. These channels are called bearer channels because they “bear,” or carry, the actual information being communicated between the customer premises and the telco’s central office (CO). B channels are standard, bidirectional, digital telephone channels that can carry digital information at a rate of 64 Kbps. Users with greater bandwidth needs can combine several B channels into larger data-carrying pipes. The two most common configurations are

  • 2B+D:
    Combines two B channels to form a single data pipe with a total bandwidth of 128 Kbps

  • 23B+D:
    Combines 23 B channels to form a high-speed data pipe equivalent to a T1 line with a total bandwidth of 1.438 Mbps

NOTE

B channels carry voice or data only, not signaling information. D channels carry information for establishment and control of ISDN connections.

See also
Integrated Services Digital Network (ISDN)

bcp utility

A command-line tool for Microsoft SQL Server that can be used to export and import data between SQL Server and other database servers or files. The format of the foreign data source is specified by the administrator. The bcp (“bulk copy program”) utility is typically used for such purposes as

  • Transferring data between mainframe databases and SQL Server

  • Transferring large quantities of data to or from computers running SQL Server

  • Importing or exporting data in ASCII format

How It Works

The bcp utility uses a two-step process for transferring data—the data is transferred first to a file, and then to the server. The different transfer modes available to the bcp utility include

  • Native mode:
    Used for transferring data between computers running SQL Server

  • Character mode:
    Generates tab-delimited text files for importing into spreadsheets or other database management systems

  • Format file:
    Used to transfer specific columns of data

TIP

An advantage of using the bcp utility is the capability of using it in a batch file for automating transfer of data between different platforms.

BDC

See
backup domain controller (BDC)

beaconing

A technique used on token-passing networks for monitoring the status of the token-passing process. Beaconing is used in token ring and Fiber Distributed Data Interface (FDDI) networks to ensure that token passing is functioning properly.

How It Works

On a token-passing network such as FDDI, every station is responsible for monitoring the status of the token-passing process. If a station detects that a fault has occurred, it starts placing beacons onto the ring. When the next station on the ring detects a beacon, it in turn starts placing beacons on the ring, and the first station stops transmitting them. This process will continue until the station immediately upstream of the fault location is the only station sending beacons. This allows administrators to quickly locate the fault and repair it. Once the fault is fixed, the station emitting the beacon detects its own beacon returning to it after traveling around the ring, and the station stops beaconing.

BeOS

A computer operating system developed by Be, Inc., a company that was founded in 1990 by Jean-Louis Gassée, a former president of Apple’s product division. BeOS is a preemptive multitasking operating system with symmetric multiprocessing (SMP) support and an object-oriented set of application programming interfaces (APIs) optimized for real-time digital multimedia and communication functions. Because of this, BeOS is sometimes called a “media OS” to emphasize its multimedia capabilities. BeOS runs on Intel-based platforms and certain PowerPC-based hardware, and it includes basic TCP/IP support and services. On a PowerPC, you can even run the MacOS as a shell within the BeOS desktop interface.

On the Web
•
The Be, Inc., home page
: http://www.be.com

BGP

See
Border Gateway Protocol (BGP)

BIND

Stands for Berkeley Internet Name Domain, a popular software tool for administering and maintaining the Domain Name System (DNS) on UNIX platforms. BIND was originally written for BSD UNIX and is currently maintained by the Internet Software Consortium. Because most versions of UNIX include some port of BIND, it is the most popular DNS server used by Internet service providers (ISPs) for administering and maintaining the DNS for the Internet. The DNS server services on Microsoft Windows NT and Windows 2000 are RFC-compliant implementations of DNS and are compatible with BIND.

On the Web
•
Internet Software Consortium home page
: http://www.isc.org

bindery

In Novell’s NetWare version 3. x and earlier networking operating systems, the database containing network security information (users, groups, rights, and so on) for a particular server. Each NetWare 3. x server has its own bindery for controlling access to that server’s file and print resources. In version 4. x and later, the bindery is replaced by the Novell Directory Services (NDS), although 4. x servers are also capable of running in bindery emulation mode.

Microsoft’s optional service called Gateway Services for NetWare (GSNW) for the Windows NT Server and Windows 2000 Server platforms can be used to implement gateways to resources located on NetWare file and print servers that are using bindery security. This allows Windows users to access volumes, directories, and print queues on NetWare servers without requiring NetWare client software to be installed on them. Client Services for NetWare (CSNW) can also be installed on client machines running Windows NT Workstation or Windows 2000 Professional to enable them to directly access bindery-based NetWare 2. x , 3. x , or 4. x servers that are running in bindery emulation mode.

binding

A mechanism for linking together network interface card (NIC) drivers, network protocols (such as TCP/IP), and networking services (such as Workstation service). Microsoft Windows operating systems allow you to optimize network communication by selectively enabling, disabling, and modifying the order of the bindings between different networking components. Windows NT supports network driver interface specification (NDIS) 4.0, which allows multiple protocols to be independently bound to multiple network interface cards, while Windows 2000 supports the newer NDIS 5.0 specification with enhanced functionality.

How It Works

To configure bindings for Windows NT, Windows 95, or Windows 98, use the Network utility in Control Panel. To configure bindings in Windows 2000, choose Advanced Settings from the Advanced menu of the Network And Dial-Up Connections window, which is also accessed from Control Panel. Bindings can be easily enabled, disabled, or reordered and can also be displayed in different ways, depending on the version of Windows involved. For example, in Windows NT bindings can be displayed as

  • Connections from services to protocols and then to adapters

  • Connections from protocols to services

  • Connections from adapters to protocols and then to services

In Windows 95 and Windows 98, bindings are shown in one list and cannot be reordered. In Windows 2000, bindings are displayed as a single hierarchical list and can be reordered.

TIP

To optimize network performance, disable any unnecessary bindings on your workstations.

Graphic B-8. The Bindings tab shows connections between the network cards, protocols, and services on a particular computer.
Graphic B-8. The Bindings tab shows connections between the network cards, protocols, and services on a particular computer.

B-ISDN

See also
broadband ISDN (B-ISDN)

bits per second (bps)

A unit used for measuring the speed of transmission of data on a network of computers—that is, the amount of information sent or received in a given amount of time. A bit is a single unit of digital information, represented by either a 1 or a 0. The total number of bits per second (bps) that can be transmitted over a network link represents the bandwidth of that link. Because most network communication takes place at thousands or millions of bits per second, the following related units are commonly used:

  • Kbps = kilobits per second (103 bps)

  • Mbps = megabits per second (106 bps)

  • Gbps = gigabits per second (109 bps)

black hole

In an internetwork, a black hole is a router that goes down and whose absence from the network is not detected by other routers. Packets that are forwarded to the black hole are dropped; they never reach their destination, and they give no indication to the stations sending them that this is the case—therefore, the data is lost.

Normally, a router will issue an “ICMP Destination Unreachable” message when it cannot forward a packet. However, with a black hole, these messages are not generated, so the user doesn’t know that data is being permanently lost.

If static routing is being used, a black hole persists until the affected router is brought back on line or until other static routers have their routing tables reconfigured to take the downed router into account. If dynamic routing is used, other routers soon detect the presence of the black hole and adjust their routing tables accordingly to favor other paths.

blue screen

In Microsoft Windows platforms, a blue screen on a user’s monitor indicates that something has gone seriously wrong with the system. In Windows 2000, this screen is usually called a Stop screen, and it contains complex information that qualified support technicians can use to diagnose the problem. A reboot might get the system going again, but the blue screen might reappear if the problem is not resolved. The problem causing the blue screen to appear can be either hardware-related or software-related, but the blue screen itself is generated by the operating system in response to the underlying problem.

In Windows 95 and Windows 98, the blue-colored screen normally appears when parity errors or memory violations occur. The Windows 98 blue screen requests that you either shut down the offending application or restart your system using Ctrl+Alt+Delete.

TIP

Parity errors can indicate that your system RAM has mismatched single inline memory modules (SIMMs) on your motherboard—for example, RAM with different speeds or a mix of parity and nonparity RAM. Also, systems from some manufacturers require special proprietary RAM in order to function. You should consult the documentation from your computer’s manufacturer or your RAM’s manufacturer to ensure that you have the correct type of RAM in each slot.

Bluetooth

An open specification for short-range wireless transmission of voice and data that is currently under development. Bluetooth provides a simple, low-cost method of linking Personal Digital Assistants (PDAs), cellular phones, laptops, and other information appliances. Bluetooth can be used for bridging data networks, connecting peripherals to devices, and forming ad hoc connections between groups of information appliances. Bluetooth is the initiative of a consortium called the Bluetooth Special Interest Group (SIG), whose original members include industry leaders Ericsson, IBM, Intel, Nokia, and Toshiba. More than 850 vendors support it.

How It Works

Bluetooth supports transmission of voice and data over 2.4-GHz radio frequencies, which is the unlicensed Industrial-Scientific-Medical (ISM) band, using a frequency-hopping scheme with a maximum of 1600 hops per second, resulting in a new frequency being used to transmit each packet. This scheme allows for smooth operation—in spite of fading due to reflecting obstacles or excessive distance, and in spite of noise due to electromagnetic interference (EMI), such as that generated by microwave ovens. In addition, Bluetooth uses short packets and fast acknowledgments to increase reliability and employs forward error correction to reduce the effects of random noise.

The range of transmission for Bluetooth is typically between 0.1 and 10 meters but can be as much as 100 meters using higher transmission power. The system’s automatic power adaptation adjusts transmission power to the minimum needed for reliable transmission in any given situation, which reduces the chance of eavesdropping. Bluetooth also includes encryption and authentication mechanisms. The entire Bluetooth technology is implemented in a single 9-millimeter-by-9-millimeter chip.

Bluetooth data transmission normally takes place over an asynchronous channel that provides 721 Kbps in the forward direction and 57.6 Kbps in the return direction, but synchronous data transmission at 432.6 Kbps in both directions is also supported. Time-division duplexing (TDD) is employed to alternate transmission between the two directions and thus provide full-duplex communication. Each TDD slot normally carries one packet, but packets can be spread across up to five slots. Signaling is baseband and uses a binary FM scheme. Channels can be routed by using a combination of circuit switching and packet switching.

Bluetooth voice transmission can use up to three concurrent synchronous 64-Kbps voice-only channels or one channel that simultaneously supports both asynchronous data and synchronous voice transmission. The voice channels use the continuous variable-slope delta modulation coding scheme.

Bluetooth supports concurrent connections among up to eight devices, forming what is called a piconet. Each device is temporarily assigned a unique 3-bit MAC address for the duration of the connection. A master/slave relationship exists between one device and all other devices for the duration of the connection for the purpose of establishing clocking and the hopping sequence. In all other respects, the devices operate as peers during a connection. Unconnected devices are in standby mode and listen for connection attempts every 1.28 seconds on each of 32 preassigned hopping frequencies. Link setup and authentication is performed using the Link Manager Protocol (LMP), which uses the link controller services built into the chip. Connections between devices can be either point-to-point or point-to-multipoint, and piconets can be joined, with each piconet having a different hopping sequence.

On the Web
•
Bluetooth SIG home page
: http://www.bluetooth.com

See also
wireless networking

BNC connector

A series of connectors used for connecting thinnet coaxial cabling to various networking components. BNC connectors use a twist-and-lock mechanism that provides a secure connection between network cabling and components. BNC connectors are typically used on 10Base2 Ethernet networks. The different types of BNC connectors include the following:

  • BNC cable connector:
    Soldered or crimped to the ends of a thinnet cable

  • BNC T-connector:
    Used to connect a network interface card (NIC) to a thinnet cable segment

  • BNC barrel connector:
    Used to connect two pieces of thinnet cable

  • BNC terminator:
    Provides a 50-ohm termination for the free end of a thinnet cable

See also
connector (device), terminator

B-node

A NetBIOS name resolution method in which broadcast messages are used for name registration and resolution. B-node is one of the NetBIOS name resolutions supported by Microsoft Windows NT and Windows 2000.

How It Works

Name resolution is the process of converting the name of a host on the network into a network address (such as an IP address). Name resolution must be performed in order to establish communication over a network in Windows. B-node is one of four basic methods supported by Windows for resolving NetBIOS host names—that is, computer names—into IP addresses.

If a computer running Windows is configured as a B-node machine, it always uses broadcasts to resolve names of other hosts on the network. For example, if a B-node machine wants to communicate with another machine with the NetBIOS name SERVER7 (for example, if it wants to connect to a shared resource on SERVER7), the B-node machine broadcasts a packet containing a NetBIOS name query request. If SERVER7 receives the packet, it responds by returning a frame containing its IP address. If SERVER7 is off line or fails to return a response, the B-node client will be unable to establish a connection with SERVER7.

As a name resolution method, B-node is flawed in two ways:

  • Since broadcast packets are used, B-node consumes network bandwidth and can degrade overall network communication in a busy network.

  • Since routers are usually configured to not forward broadcast packets, B-node clients can resolve only the NetBIOS names of hosts on the client’s local subnet.

A better approach to NetBIOS name resolution on Windows networks is to configure clients as H-node machines and use a WINS server. H-node is a NetBIOS name resolution method that combines B-node and P-node.

See also
H-node, M-node, NetBIOS name resolution, P-node

bonding

In Integrated Services Digital Network (ISDN) and T-series transmission technologies, a way of combining multiple DS0 channels from different circuits into a single, faster data transmission channel. Bonding involves inverse multiplexing and techniques for resolving timing differences among the different circuits.

Bonding is used in Basic Rate Interface ISDN (BRI-ISDN) for combining the two 64-Kbps B channels into a single 128-Kbps data transmission channel. Several different bonding protocols can be implemented for BRI-ISDN services, a common one being Multilink PPP (MPPP) for asynchronous bonding.

NOTE

Bonding must be supported by the ISDN devices at both ends of the ISDN link. Typically, one of the B channels is designated as responsible for initiating the bonding process.

TIP

Many ISDN terminal adapters can override bonding when the user wants to place a regular Plain Old Telephone Service (POTS) phone call. For example, you might be using ISDN for high-speed Internet access with both B channels bonded to give you 128-Kbps (or 14-kilobytes/second) access. Then, if you suddenly pick up a phone connected to the terminal adapter’s POTS jack, bonding stops and the second B channel is freed up for the phone call. Once the call is complete, bonding will resume.

boot

A term used to refer to the process of starting a computer, as in the phrase, “Please boot the computer.” The term “boot” also refers specifically to the series of steps by which a computer locates and loads the operating system once the power is turned on. This series of steps is usually referred to as the boot sequence, and it is dependent on both the type of operating system installed on the machine and the type of hardware platform (for example, x86 platform or Alpha platform).

The term “warm boot” refers to resetting the system or rebooting using Ctrl+Alt+Delete. The power to the system is not interrupted during a warm boot, but the boot process starts again from the beginning using the system BIOS.

The term “cold boot” refers to shutting down a computer and actually turning off the power source, and then turning it back on. Cold boots are sometimes necessary after installing or configuring some legacy hardware devices to ensure that the devices are properly initialized. For example, sometimes if you change the configuration parameters of an internal modem, you need to cold boot your system for these changes to take effect.

See also
boot files, boot sequence

boot files

Files needed to boot an operating system on a computer. Each operating system has its own set of boot files needed to locate, load, and initialize the operating system during the boot sequence. For example, the MS-DOS and Microsoft Windows 3.x platforms use the hidden files io.sys and msdos.sys and the file command.com. Configuration information stored in the text files config.sys and autoexec.bat is also used during the process. On Windows 95 and Windows 98 platforms, the files used are io.sys, msdos.sys, and win.com, with the files config.sys and autoexec.bat used optionally to support legacy hardware.

The files needed to boot the Windows NT and Windows 2000 operating systems vary depending on whether the x86 platform or the Alpha platform is used. For example, for Windows NT on the x86 platform, the boot files include the following:

  • boot.ini

  • bootsect.dos

  • hal.dll

  • ntdetect.com

  • ntbootdd.sys

  • ntldr

  • ntoskrnl.exe

The boot sequence also uses various device drivers and the system hive.

See also
boot sequence

boot.ini

A hidden, read-only text file on the root of the system partition of Microsoft Windows NT and Windows 2000 that is used to create the boot loader menu. For example, a typical boot.ini file for a default Windows NT installation might look like this:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINNT
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Windows NT Server Version 4.00"
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Windows NT Server Version 4.00
  [VGA mode]" /basevideo /sos

A close correspondence can be seen between the appearance of the boot.ini file and the boot loader menu, which the ntldr program creates during the Windows NT boot sequence.

NOTE

You can safely modify some of the settings in this file using the System utility in Control Panel. If you need to edit the file directly, use the attrib command to first remove its read-only, system, and hidden attributes and then modify the file using a text editor such as Microsoft Notepad. Do this carefully, as an error in the boot.ini file can prevent the system from booting.

See also
boot files

boot loader menu

A menu that appears when you boot a computer with the Microsoft Windows NT operating system installed. The boot loader menu appears during the boot loader phase of Windows NT startup, and it is displayed by the Windows NT loader program called ntldr. The boot loader menu allows you to

  • Select the particular operating system you want to run on a dual-boot system

  • Boot Windows NT using optional boot-time switches for troubleshooting reasons

There are always two boot loader menu entries for each copy of the Windows NT operating system installed on a computer—for example, “Windows NT Server Version 4.0” and “Windows NT Server 4.0 [VGA mode]”.

Use the VGA mode option if you have changed your video display driver settings and cannot access the desktop after a normal boot. Once you have booted in VGA mode, reconfigure your video driver.

TIP

The boot loader menu is created by the boot.ini file, which can be edited using a text editor such as Microsoft Notepad, but this should be done with care. A safer way of modifying boot.ini is to use the System utility in Control Panel.

BOOTP

See
bootstrap protocol (BOOTP)

boot partition

The partition of a disk on which Microsoft Windows NT or Windows 2000 installs core operating system files. These operating system files are stored in the %SystemRoot% and %SystemRoot%\system32 directories on the boot partition. The choice of boot partition is made during installation of Windows NT and cannot be changed afterward. An important consideration when installing Windows NT is designation of a boot partition that has sufficient free space to contain the operating system files together with all the optional and future components.

The boot partition can be the same as or different from the system partition, which is the partition containing the hardware-specific files for the particular hardware platform Windows NT is installed on (x86 platform or Alpha platform).

See also
system partition

bootsect.dos

A hidden, read-only file on the root of the system partition of Microsoft Windows NT that is used during the boot sequence. The bootsect.dos file is included to support dual-boot installations where another operating system is installed with Windows NT. When the boot loader menu appears, the user selects the operating system he or she wants to boot. If a non–Windows NT operating system is selected, the ntldr program immediately loads bootsect.dos and turns control of the boot process over to it. Bootsect.dos contains the location of the partition boot sector that existed on the partition prior to the installation of Windows NT. Thus, bootsect.dos enables the system to locate and load the alternate operating system. Bootsect.dos is not loaded during a normal boot of the Windows NT operating system.

See also
boot files

boot sequence

The series of steps that occurs when an operating system boots on a machine. Each operating system has its own particular boot sequence and uses its own specific set of boot files. Knowledge of the boot sequence for a particular operating system can aid in troubleshooting problems booting a machine on which that operating system is installed. For example, from messages displayed during the boot process, a technician can often determine whether a particular boot file is missing or corrupt.

The following table is a high-level illustration of the boot sequence for the Microsoft Windows NT operating system installed on an x86 platform. This boot sequence is divided into four phases, and different activities occur in each phase. For a successful boot of the system to occur, all four phases must be completed successfully.

The Four Phases of a Windows NT Boot Sequence
Phase | Name | Description
0 | Initial phase | Power-on self test (POST); locate and load ntldr
1 | Boot loader phase | Black screen: hardware detection, boot loader menu, last known good option, load ntoskrnl.exe or ntkrnlmp.exe
2 | Kernel phase | Blue screen: kernel initialization, create hardware hive and Clone control set, initialize devices, start services
3 | Logon phase | Begin Logon dialog box
See also
boot files

bootstrap protocol (BOOTP)

A TCP/IP protocol and service that allows diskless workstations to obtain their IP address, other TCP/IP configuration information, and their boot image file from a bootstrap protocol (BOOTP) server. The network interface card (NIC) on these diskless workstations contains a programmable read-only memory (PROM) chip containing code necessary to initialize the client.

How It Works

When a BOOTP client is started, it has no IP address, so it broadcasts a message containing its MAC address onto the network. This message is called a “BOOTP request,” and it is picked up by the BOOTP server, which replies to the client with the following information that the client needs:

  • The client’s IP address, subnet mask, and default gateway address

  • The IP address and host name of the BOOTP server

  • The IP address of the server that has the boot image, which the client needs to load its operating system

When the client receives this information from the BOOTP server, it configures and initializes its TCP/IP protocol stack, and then connects to the server on which the boot image is shared. The client loads the boot image and uses this information to load and start its operating system.

The Dynamic Host Configuration Protocol (DHCP) was developed as an extension of BOOTP. BOOTP is defined in Request for Comments (RFC) 951 and 1084.

NOTE

The term “bootstrap protocol” (or “boot protocol”) comes from the idea of lifting yourself up by your own bootstraps—something that is obviously difficult to do. In other words, how does a client machine start up when it initially has neither an IP address nor an operating system? BOOTP makes this difficult task possible.

TIP

Microsoft Windows NT supports DHCP but not BOOTP. Windows NT Service Pack 3 and later provides some support for BOOTP clients, as does Microsoft Windows 2000. See the readme.txt file for Service Pack 3 for more details.

boot volume

In Microsoft Windows 2000, the volume that has the Windows 2000 operating system files. The boot volume can be the same as or different from the system volume, and it can be formatted in either NTFS or file allocation table (FAT).

Border Gateway Protocol (BGP)

A standard TCP/IP protocol based on the distance vector routing algorithm that enables groups of routers to share their routing information in an efficient manner. Border Gateway Protocol (BGP) version 4 is used to connect backbone routers on the Internet and is implemented by many Internet service providers (ISPs). BGP has largely superseded the earlier Exterior Gateway Protocol (EGP).

How It Works

BGP works by listening to traffic being routed and inferring information concerning the reachability of neighboring networks. BGP supports policy-based routing, which enables network traffic to be routed differently according to its cost, importance, or security needs. BGP divides an internetwork into groups of routers (called autonomous systems) that have trusted routes between them. This limits the size of the routing table in order to optimize reliability and performance on large internetworks such as the Internet.

The first update of a router’s BGP routing table includes all known routes on the network, while succeeding updates are only incremental. BGP also supports classless interdomain routing (CIDR). BGP is defined in Request for Comments (RFC) 1771 through 1774.

On the Web
•
Border Gateway Protocol (Cisco)
: http://www.cisco.com/univercd/cc/td/doc /cisintwk/ito_doc/bgp.htm
•
Using BGP for Interdomain Routing (Cisco)
: http://www.cisco.com/univercd/cc/td/doc/cisintwk/ics/icsbgp4.htm
•
BGP FAQ
: http://info.connect.com.au/docs/routing/general/multi-faq.shtml

bottleneck

A bottleneck is a situation that occurs when network servers and components are unable to meet demand. The bottleneck is the particular network component or server subsystem that is causing the problem.

For example, if users on a Microsoft Windows NT or Windows 2000–based network are complaining that it takes too long to log on in the morning, the bottleneck and its potential resolution might be

  • Not enough domain controllers to handle logon requests (The solution: add more domain controllers)

  • The domain controller does not have enough memory to process large numbers of simultaneous logons (The solution: add more RAM)

  • Network bandwidth is saturated in the morning with directory replication traffic (The solution: reschedule directory replication or upgrade to 100-Mbps Ethernet)

The primary tool for analyzing and resolving network bottlenecks is the Windows NT administrative tool Performance Monitor (or the Performance snap-in tool for Windows 2000). To learn about how to identify and correct bottlenecks using Performance Monitor, consider taking the Microsoft Official Curriculum (MOC) course MS 689, “Supporting Microsoft Windows NT Server 4.0—Enterprise Technologies.”

bounce

An effect that happens to signals on a bus topology network when the ends of the bus are improperly terminated or unterminated. A signal that is placed on a bus that is unterminated will continue to reflect from the end of the bus until that signal is attenuated by the impedance of the cable. Another situation that can cause signals to bounce is a break in the cable, which essentially creates two unterminated ends for the two segments. The effect of signal bounce on baseband networks such as Ethernet is serious, since the transceivers on the network interface cards (NICs) attached to the bus interpret the problem as a collision and stop transmitting. This collision occurs because the signal is colliding with its own reflection. Once the proper termination is applied to the bus, network communication can resume.

bps

See
bits per second (bps)

breakout box

A troubleshooting tool used to determine the wiring of an RS-232 interface on a networking device or computer. A breakout box can be inserted between two RS-232 devices to determine which wires are active. Breakout boxes are useful in troubleshooting RS-232 connection problems resulting from a manufacturer’s device not using standard pinning.

Breakout boxes are specific examples of a more general category of network testing equipment called “status monitors.” Status monitors are available for testing a variety of serial interfaces, including RS-232, RS-449, V.35, and X.21. They generally come with a variety of connectors and are quick and easy to use for isolating problems with serial transmission connections in networking, telecommunications, and industrial settings.

bridge

A networking component used either to extend or to segment networks. Bridges work at the OSI data-link layer. They can be used both to join dissimilar media such as unshielded twisted-pair (UTP) cabling and fiber-optic cabling, and to join different network architectures such as Token Ring and Ethernet. Bridges regenerate signals but do not perform any protocol conversion, so the same networking protocol (such as TCP/IP) must be running on both network segments connected to the bridge. Bridges can also support Simple Network Management Protocol (SNMP), and they can have other diagnostic features.

Graphic B-9. The three basic types of bridge.
Graphic B-9. The three basic types of bridge.

Bridges come in three basic types:

  • Local bridges:
    Directly connect local area networks (LANs)

  • Remote bridges:
    Can be used to create a wide area network (WAN) link between LANs

  • Wireless bridges:
    Can be used to join LANs or connect remote stations to LANs

How It Works

Bridges operate by sensing the source MAC addresses of the transmitting nodes on the network and automatically building an internal routing table. This table is used to determine which connected segment to route packets to, and it provides the filtering capability that bridges are known for. If the bridge knows which segment a packet is intended for, it forwards the packet directly to that segment. If the bridge doesn’t recognize the packet’s destination address, it forwards the packet to all connected segments except the one it originated on. And if the destination address is in the same segment as the source address, the bridge drops the packet. Bridges also forward broadcast packets to all segments except the originating one.

TIP

Use bridges to reduce network congestion and improve performance by segmenting busy Ethernet networks into smaller collision domains. Bridges can also be used to connect segments more efficiently than repeaters and to join dissimilar networks such as Ethernet and token ring. Remote bridges can be used to create WAN links.

A poorly placed bridge can actually worsen network performance. For example, if you use a bridge to divide users who belong to the same department and frequently communicate with each other over the network, this might actually slow down communication among users by creating a bottleneck. It is better to use bridges to join separate departmental LANs together on which intradepartmental traffic is greater than interdepartmental traffic.

When using bridges to connect networks, make sure that only one path leads to any destination node on the network; otherwise, frames could become locked in loops and circle the network endlessly, causing a network storm.

See also
remote bridge, wireless networking

bridgehead server

A computer running Microsoft Exchange Server that acts as an endpoint of a connector joining two Exchange sites. A bridgehead server is responsible for routing messages through that connector. There are two different types of bridgehead servers in an Exchange organization, although a single server often functions in both roles:

  • Messaging bridgehead servers:
    Used to route recipient messages from one site to another

  • Directory replication bridgehead servers:
    Used to route directory replication messages from one site to another

TIP

Pass-through traffic consists of messages that originate in one site and are destined for another site, but in order to reach their destination site, must pass through one or more additional sites. You can reduce the effects of pass-through traffic by using dedicated messaging bridgehead servers—that is, bridgehead servers that have no mailboxes or public folders homed on them. You can also have traffic enter a site by one server and leave it by another. If you have a large number of sites, you might want to configure a given site to use a different bridgehead server to connect to each remote site for load balancing of messaging traffic. Also, you can schedule directory replication traffic to occur at slow periods during each day.

Briefcase

A feature of Microsoft Windows 95, Windows 98, Windows NT 4.0, and Windows 2000 that is typically used to enable mobile users to copy and synchronize files between a desktop and a portable computer so that they can easily copy and work on files at home or on the road without creating version conflicts.

Using Briefcase is simple. Create a Briefcase icon by right-clicking the desktop, choosing New from the context menu, and then choosing Briefcase. Then drag the files you want into the Briefcase folder and copy it to your laptop computer. After you modify the copies of the files in your laptop’s Briefcase folder, connect your laptop to your desktop computer and the newer versions will be copied over the old. If the original files on the desktop computer were modified while you were away, you will be prompted to specify which modified version is the correct one for each file. (Briefcase cannot merge changes in files.)

BRI-ISDN

See
Basic Rate Interface ISDN (BRI-ISDN)

broadband ISDN (B-ISDN)

The broadband transmission counterpart of Integrated Services Digital Network (ISDN). Broadband ISDN (B-ISDN) encompasses a set of International Telecommunication Union (ITU) standards and services designed to provide an integrated digital network for audio, video, and data transmission. Instead of using the copper media used in ordinary ISDN, broadband ISDN uses fiber-optic and radio media. Broadband ISDN is designed to use the cell-switching transport technology of Asynchronous Transfer Mode (ATM) together with the underlying physical transport mechanisms of Synchronous Optical Network (SONET). Broadband ISDN standards and technologies are an emerging option for high-speed networking that promises the capabilities of high-speed digital connectivity for homes and businesses.

broadband transmission

A signaling technology that sends signals simultaneously over a range of different frequencies as electromagnetic waves. The bandwidth of a broadband system can usually carry multiple, simultaneous data signals. These signals are unidirectional—traveling in only one direction at a time—so a broadband system can generally either transmit or receive but cannot do both simultaneously. Broadband signals can be regenerated using amplifiers in order to travel longer distances before becoming attenuated.

How It Works

Broadband transmissions are divided into multiple bands or channels by multiplexers using a multiplexing scheme such as frequency-division multiplexing (FDM). Each channel has a carrier frequency that is modulated to carry the signal from a given source. At the receiving station, multiplexers separate the various signals. Guard bands are used to prevent interference among channels.

Broadband transmission is typically used for environments in which video, audio, and data need to be transmitted simultaneously. Cable television systems are based on broadband transmission technologies. Other examples of broadband services include T-carrier services, Asynchronous Transfer Mode (ATM), and variants of Digital Subscriber Line (DSL).

See also
baseband transmission

broadcast

A communication method for sending information to all components on a network of computers simultaneously.

How It Works

Broadcasts take place when broadcast packets (or broadcast frames) are sent over the network. These packets contain a special address that instructs every station on the network to accept and process the packet. Broadcasts are typically used for announcements by network services, for resolving names into addresses, and for other similar functions. Broadcasts are usually not an efficient use of network bandwidth, since only one or a few network stations might actually be interested in the information being broadcast. For this reason, directed packets are used for most network communication, which involves targeting a packet directly for the intended station. (All other stations ignore the directed packet.) An alternative is multicasting, which involves a form of limited broadcast to a select group of hosts.

Certain network conditions, such as certain types of device failure, can cause broadcast storms that can bring down a network.

See also
broadcast frame, broadcast packet

broadcast frame

In Ethernet networks, a frame that has a hexadecimal MAC address of FF-FF-FF-FF-FF-FF. This hexadecimal address is equivalent to 48 binary “ones.” The meaning of this address in Ethernet is simply that this frame is intended to be received and processed by every node on the network of computers. Broadcast frames are generated when certain network services need to make announcements to other hosts on the network. Too many broadcast frames on a network can degrade communication between nodes on the network.

NOTE

Most routers are not configured to forward broadcast frames to other subnets in an internetwork; therefore, broadcast frames used as announcements are limited in scope to the local subnet on which the broadcasting host is located.

See also
broadcast

broadcast packet

In TCP/IP, an Internet Protocol (IP) packet with the IP address 255.255.255.255. In binary notation, this represents a series of 32 binary “ones.” A broadcast packet is sent over the network of computers and picked up by all hosts on the local subnet. Broadcast packets can also be forwarded to other subnets if routers are configured to forward IP broadcasts, though this is not usually the case.

See also
broadcast, directed packet

broadcast storm

A network condition in which so many broadcasts are occurring (for example, for address verification purposes) that normal communication is disrupted.

How It Works

Broadcast storms commonly occur on Ethernet networks where baseband transmission technologies allow only one station to transmit at a time. The presence of broadcast storms often indicates that a networking component is malfunctioning and is continually sending out broadcast messages. A typical situation might be a failed transceiver on a network interface card (NIC) that is continually sending out a stream of binary “ones.” During a broadcast storm, the wire is continually busy and no other station is able to transmit information over the network—so broadcast storms essentially bring down the network. Since routers often are not configured to forward broadcast frames between subnets, broadcast storms usually are confined to a single subnet. Broadcast storms might also indicate that the bandwidth of your network is nearly saturated and needs to be upgraded.

See also
broadcast

brouter

Any network device having the capabilities of both a bridge and a router. Usually, a brouter will act as a router for one protocol (for example, TCP/IP) and a bridge for all other protocols (for example, IPX/SPX). Brouters are not common in networks. Network services often send their announcements over every protocol on the network, which generates additional traffic and makes it generally disadvantageous to run more than one protocol on a single network. The solution adopted by most implementers today is to use a single protocol for all network communication on the main portion of the network, with gateways connecting to segments running other protocols. The protocol of choice for most internetworking today is TCP/IP.

browse list

The list of available shared network resources collected and distributed by the Computer Browser service on a Microsoft Windows NT or Windows 2000 network. The browse list contains all available domains and servers on the network. This list is distributed to clients who try to connect to shared resources on the network so that they can locate and connect to these resources. Essentially, when you are using Network Neighborhood, you are looking at the browse list for your network. The browse list is maintained by the master browser computer, but clients that need it obtain it from backup browsers on the network.

NOTE

If a server or domain is not heard from by the master browser after three announcement periods (amounting to approximately 45 minutes), the server or domain is removed from the browse list.

See also
Computer Browser service

browser election

In Microsoft Windows NT or Windows 2000, the process of selecting a new master browser from a network’s potential browsers. If a client machine is not able to locate a master browser on the network in Windows NT or Windows 2000, it initiates an election to select a new master browser. Elections are a way of ensuring that a master browser is always available on the network, as the absence of a master browser means that clients will be unable to locate and access network resources such as shared files and folders.

How It Works

If a client machine cannot locate a master browser on the network, it broadcasts an election datagram. When a machine that is a potential browser receives this datagram, it examines the election criteria in the datagram. If its election criteria are better than those of the datagram’s sender, the potential browser broadcasts its own election datagram and an election is declared to be in progress. The election criteria for becoming a master browser are a combination of factors, including the machine’s operating system, version, role, and so on. Eventually, one potential browser wins out (has superior election criteria) over other machines on the network, and the election ends.

NOTE

Elections also occur when domain controllers are restarted.

See also
Computer Browser service

browsing

On a Microsoft Windows NT or Windows 2000 network, the process of locating network resources using Windows Explorer, Network Neighborhood, or another utility. Browsing is made possible by the Computer Browser service, which keeps track of all shared resources on a Windows NT network and communicates this information to clients when they need to access a resource. The Computer Browser services are at the core of the ability to locate shared file and printer resources on a network.

In relationship to the Internet, the term “browsing” refers to the process of using a Web browser such as Microsoft Internet Explorer to view and download Web pages from the Internet. The origin of the term probably stems from the idea of reading magazines, in which you pick up one magazine and skim through its contents, then go to another magazine, and so on. On the Internet, it is even easier. You don’t have to “pick up” anything; you simply keep clicking the links.

BSC

See
backup site controller (BSC)

BSD UNIX

Stands for Berkeley Software Distribution UNIX, a version of UNIX that originated many common UNIX features such as the vi editor, C shell, and TCP/IP networking. BSD UNIX was developed in the 1970s at the University of California at Berkeley, which licensed the UNIX operating system from AT&T and then made a number of modifications and enhancements. BSD UNIX is one of the most popular versions of UNIX in use today, the other being UNIX System V and its variants. BSD UNIX formed the basis of the SunOS from Sun Microsystems. Sun later combined features of both BSD and System V into their popular Solaris operating system. Another variant of BSD is the FreeBSD operating system.

built-in account

In Microsoft Windows NT and Windows 2000, a type of user account that is created during installation. All computers running Windows NT or Windows 2000 have two built-in user accounts:

  • The Administrator account:
    Used to provide administrative access to all features of the operating system

  • The Guest account:
    Intended to provide occasional users with access to network resources

Depending on whether the computer is a domain controller, a member server, or a workstation, built-in accounts will be either local user accounts or global user accounts. A built-in account on a domain controller is a global user account that exists everywhere within the domain. Users can log on to any machine in the domain using such an account, which provides administrators with the capability of administering a Windows NT–based or Windows 2000–based network from anywhere on the network. On a member server or workstation, the Administrator and Guest accounts are local user accounts and exist only on those machines.

TIP

Rename the Administrator built-in user account to make it more secure.

See also
built-in group

built-in global group

Global groups in Microsoft Windows NT that are created during installation to organize common groups of users for administrative purposes. These built-in global groups are created within the Security Accounts Manager (SAM) database of the primary domain controller (PDC). Three built-in global groups exist:

  • Domain Admins:
    Initially, this group contains only the Administrator account that was created during setup. Only people with administrative responsibilities should be assigned to this group.

  • Domain Guests:
    This group contains the Guest account and is designed for organizing temporary users of network resources and granting them access.

  • Domain Users:
    When a new user account is created, it is automatically added to this group. The function of this group is to collect all ordinary users for the purpose of assigning them permissions to resources on the network.

NOTE

Windows 2000 includes a fourth type of built-in global group called Enterprise Admins, which contains users who are assigned administrative rights over the entire network. The Enterprise Admins global group should be added to the Administrators domain local group in each domain of your network. By default, the Administrator account is a member of the Enterprise Admins group.

See also
built-in local group

built-in group

In Microsoft Windows NT and Windows 2000, a type of group created during installation to simplify the delegation and assignment of common administrative tasks. Built-in groups have preassigned sets of user rights, and some also have preassigned members.

Windows NT contains three kinds of built-in groups:

  • Built-in local groups:
    These are used to assign predefined sets of rights and permissions to users and groups of users, and they exist on all computers running Windows NT.

  • Built-in global groups:
    These groups are used to automatically organize users into common groups for administrative purposes, and they exist only on Windows NT domain controllers.

  • System groups:
    These are used by the operating system to automatically group users for system purposes, and they exist on all computers running Windows NT.

In Windows 2000, the built-in groups are similar in function, except that a fourth type, called a domain local group, is also available. Built-in groups in Windows 2000 are also administered differently using different tools. Also, system groups in Windows 2000 are referred to as built-in identities.

NOTE

You cannot rename or delete a built-in group, and you cannot change the membership of a system group.

See also
built-in global group, built-in local group

built-in identities

A Microsoft Windows 2000 term used to refer to what were known in Windows NT as system groups. Built-in identities can represent different subsets of users in different situations, and they do not have a specific membership that can be modified by administrators. However, you can assign built-in identities rights and permissions for accessing resources or performing system tasks. Examples of built-in identities include

  • Everyone:
    Represents all users who can be or are on the network, whether from trusted or distrusted domains.

  • Network:
    Represents all users who can access or are accessing network resources over the network. It does not include users logged on locally to a machine and accessing those resources locally.

  • Interactive:
    Represents all users who can be or are currently logged on locally to a computer to access local resources on it. It does not include users who can access or are accessing network resources over the network.

built-in local group

A Microsoft Windows NT local group created during installation that has preassigned rights and permissions. Built-in local groups are used to simplify the administrative task of assigning users and groups rights to perform system tasks and permissions to access network resources. There are nine different built-in local groups on computers running Windows NT:

  • Users:
    Contains the Domain Users global group and is used to assign rights and permissions to all ordinary users.

  • Administrators:
    Contains the Domain Admins global group and the Administrator account created during setup.

  • Guests:
    Contains the Domain Guests global group.

  • Power Users:
    Members have the right to share folders and printers.

  • Replicator:
    This group is used exclusively by the Directory Replicator Service.

  • Backup Operators:
    Members have the right to back up and restore servers.

  • Account Operators:
    Members have the right to administer accounts.

  • Server Operators:
    Members have the right to administer servers.

  • Print Operators:
    Members have the right to administer printers.

The following table shows which of these groups exist within the domain directory database on Windows NT domain controllers and which exist within the local directory database on Windows NT member servers and workstations:

Built-In Local Groups of Windows NT
Built-In Local Group | Windows NT Domain Controller | Windows NT Member Server | Windows NT Workstation
Users | Y | Y | Y
Administrators | Y | Y | Y
Guests | Y | Y | Y
Power Users | N | Y | Y
Replicator | Y | Y | Y
Backup Operators | Y | Y | Y
Account Operators | Y | N | N
Server Operators | Y | N | N
Print Operators | Y | N | N
NOTE

On Windows 2000 networks, there are only six built-in local groups, and these exist only on member servers or workstations. The six built-in local groups for Windows 2000 are Users, Administrators, Guests, Power Users, Replicator, and Backup Operators.

Windows 2000 also has built-in groups called “built-in domain local groups.” These groups are designed to provide users with permissions and rights on domain controllers and Active Directory. The seven built-in domain local groups in Windows 2000 are Users, Administrators, Guests, Backup Operators, Account Operators, Server Operators, and Print Operators.

See also
built-in global group

built-in user account

See
built-in account

burst

A condition in which network activity rises suddenly for a short period of time. A burst is a transient elevation in network activity, and a network on which a lot of bursts occur is said to be “bursty.” Bursty networks have different bandwidth requirements than networks on which the traffic is steady, and they need to be designed accordingly. For example, a network on which large video files are frequently transmitted tends to be bursty in its traffic flow. A good first step in accommodating bursty conditions is to use Ethernet switches instead of hubs for concentrating your network connections.

TIP

Bursts can be indicative of a sudden increase in demand for network resources, or they can indicate hardware or software problems. Some networking components are capable of briefly sending data at speeds greater than normal transmission speeds; this is referred to as “operating in burst mode.”

bus

Generally, a cable or wires connecting devices in a linear fashion. Examples include

  • System bus on a motherboard, providing a path along which data can flow

  • Small Computer System Interface (SCSI) bus used for chaining SCSI devices together

  • Thinnet or thicknet cabling connecting computers, hubs, or other networking components in a bus topology

See also
terminator

business logic

A term used in writing applications for Microsoft Transaction Server (MTS) using reusable COM+ components that refers to a combination of logon verifications, policies, database lookups, validation edits, and other processes that constitute how business is done in the enterprise. The business logic of an application specifies how the programming logic of the component reflects the actual way the enterprise does business. Business logic enables consistent and logical processing of business data.

A representation of a real-world component of the enterprise’s business is called a “business object.” Examples of business objects include customers, orders, products, invoices, and anything else that can be encapsulated in an application’s business logic and manipulated by its users.

bus topology

A networking topology that connects networking components along a single cable or that uses a series of cable segments that are connected linearly. A network that uses a bus topology is referred to as a “bus network.” Bus networks were the original form of Ethernet networks, using the 10Base5 cabling standard. Bus topology is used for

  • Small workgroup local area networks (LANs) whose computers are connected using a thinnet cable

  • Trunk cables connecting hubs or switches of departmental LANs to form a larger LAN

  • Backboning, by joining switches and routers to form campus-wide networks

    Graphic B-10. Bus topology.
    Graphic B-10. Bus topology.

Bus topology is the cheapest way of connecting computers to form a workgroup or departmental LAN, but it has the disadvantage that a single loose connection or cable break can bring down the entire LAN.

NOTE

A hub or concentrator on an Ethernet network is really a collapsed bus topology. Physically, the network appears to be wired in a star topology, but internally the hub contains a collapsed bus, creating a configuration called a star-wired bus. However, in this case, a failure in one of the cables does not affect the remaining network.

TIP

Communication problems on bus networks might indicate that the bus ends are improperly terminated. A break in the cable will produce a similar result, since the ends of the break are not terminated. Use a cable tester to determine the nature and location of the problem.

See also
mesh topology, ring topology, star topology


C

C++

An object-oriented programming language based on the earlier C language that is used for developing applications, including Win32 applications for Microsoft Windows platforms. The standard form of C++ is called ANSI C++ and is defined by the American National Standards Institute (ANSI).

C++ is an important language for developing tools and applications for high-speed networking because it is a compiled language whose object code runs extremely fast. For example, a form handler written for a Hypertext Markup Language (HTML) form that runs on a UNIX Apache Web server will run much faster if it is written in a compiled language such as C or C++ than if it is written in an interpretive language such as Perl or Microsoft Visual Basic, Scripting Edition (VBScript). High-performance Internet Server API (ISAPI) applications and dynamic-link libraries (DLLs) written for Internet Information Services (IIS) generally perform best when written in C++. Powerful distributed Web-based applications for the Internet can be developed using a combination of Active Server Pages (ASP) scripts in VBScript or JScript, with Microsoft ActiveX components and ISAPI DLLs written in C++ using Microsoft Visual C++.

C++ programs for Windows network operating system platforms can be developed using a variety of tools:

  • Traditional C++ development tools using editors, compilers, and debuggers support low-level application programming interface (API) access, Microsoft Foundation Classes (MFC), software development kits (SDKs), and other supporting elements.

  • Rapid application development (RAD) tools provide integrated development environments (IDEs) that focus on providing developers with ease-of-use features.

  • Component deployment tools take a component-based approach to generating and reusing C++ code for building distributed and multitier applications.

Visual C++ combines the best features of these various classes of tools. It is an excellent choice for developing large-scale distributed networking applications based on the C++ language and Microsoft’s own specific extensions to ANSI C++ that are designed for the Win32 platform.

C2

A security standard for computer systems established by the National Computer Security Center (NCSC), a U.S. government agency responsible for evaluating the security of software products. The C2 security standard is defined in the Trusted Computer Systems Evaluation Criteria manual (or Orange Book) published by the NCSC.

The NCSC rated Microsoft’s Windows NT 3.5 (with Service Pack 3) C2-compliant. The C2 designation assures that the base operating system satisfies a number of important security criteria. This designation also represents an independent, unbiased evaluation of the security of the system architecture with regard to the government’s operating and implementation standards.

A C2 rating does not indicate that a system is free of security bugs; instead, this rating certifies that the underlying architecture of the computer system is suitable for high-security environments in specific networking configurations. It is incorrect to say that Windows NT is C2-certified or runs in C2 mode. Only a complete computer system (including hardware) can be rated C2. A rating of C2 means that in a particular implementation, in a particular networking environment and configuration, using specific hardware and software, a computer network using a Windows NT operating system can apply for and might receive C2 certification.

How It Works

According to the Orange Book, in a C-level system, the security policy must be based on what is known as Discretionary Access Control (DAC), which essentially means that users of the system can own objects (files, directories, and so on) and can control access to these objects by other users. A user who establishes control over an object is responsible for granting or denying all access rights to that object. In other words, the owner of an object grants or denies users access to the object at his or her discretion. This is in contrast to a B-level system, in which Mandatory Access Control (MAC) specifies that all objects have security levels that are defined independent of the object’s owner.

On the Web
•
NCSC home page
: http://www.radium.ncsc.mil

CA

See
certificate authority (CA)

cabinet

An enclosure with a built-in rack for holding and organizing patch panels, switches, hubs, routers, servers, and any other networking equipment within a wiring closet.

How It Works

Cabinets can be wall-mounted or freestanding, come in various heights, and are usually standardized for 19-inch-wide shelving and paneling. They generally come in 83-inch and 48-inch heights, although many vendors offer custom-designed cabinets. The reason for standardizing the width to 19 inches (18.31 inches to be precise) is that hubs, switches, routers, and other networking devices are produced in this width so that they can be organized in racks and cabinets designed for this purpose. Cabinets come with a variety of accessories for organizing cables, power strips, and so on. Because heat can accumulate in cabinets, they usually include vented walls and have an exhaust fan on top. A cabinet will often have a locking front panel made of clear plastic so that status lights on equipment are easily visible. Shelves can be fixed, mounted, or sliding to enable easy access to the sides and backs of equipment.

Graphic C-1. Cabinet.
Graphic C-1. Cabinet.
TIP

When should you choose a cabinet instead of a rack? Choose a cabinet for equipment that is exposed to user traffic, and then you can lock equipment away when the room itself is not locked. Cabinets are also best for expensive networking equipment that you don’t want anyone but authorized administrators to touch. Cabinets with filter fans installed can protect equipment in environments where dust is a problem. Use filler panels to enclose areas of the cabinet that are not occupied by equipment.

See also
premise cabling, rack

cabinet files

Files with the extension .cab that store compressed files, usually for distributing software. Cabinet files can contain multiple files in a compressed state, or a single compressed file can be spread over several cabinet files. During installation of software, the setup program decompresses the cabinet files and copies the resulting files to the user’s system.

Cabinet files can be digitally signed using a Microsoft technology called Authenticode. This allows setup files to be downloaded safely over untrusted networks such as the Internet. Cabinet files are compressed using a compression algorithm called MSZIP, which is based on the Lempel-Ziv algorithm.

NOTE

Cabinet files in Microsoft Windows 95 were located in the Win95 directory on the source CD, and most were represented as a series of large files named Win95_1.cab, Win95_2.cab, and so on. Windows 98 uses a different naming convention and names many of its smaller cabinet files by function rather than by the order in which they are used during setup. Naming by function makes the extraction of files easier, which in turn makes the setup process smoother.

TIP

In Windows 95, if you want to extract specific operating system files from a cabinet file (for example, to replace a missing or corrupt file), you have to use the command-line utility called extract. Using Windows 98, you can simply double-click on a cabinet file using Windows Explorer to view its contents in a new window, double-click on the specific file you want to extract, and specify the destination folder to send it to. You can also use the System File Checker tool to extract files without knowing which specific cabinet file they are located in.

cable modem

A device that allows your computer to access the Internet through dedicated broadband transmission networking services by means of your home cable TV (CATV) connection.

How It Works

There are generally two types of cable modem services:

  • One-way cable modems are used by unidirectional cable services. Most cable TV services are designed to carry information in one direction only—from the broadcaster to the customer premises. With one-way cable modems, the customer uses a regular telephone modem to send information to the cable company but uses the cable TV system with cable mode to receive signals from the company. The telephone modem handles all upstream communication, while the cable modem handles all downstream communication. One-way cable modems are typically cards installed inside a subscriber’s computer.

  • Two-way cable modems require that the broadcasting cable company has converted its cabling and repeater infrastructure for bidirectional communication. Two-way cable modems are typically external devices connected to a network interface card (NIC) that is installed in the subscriber’s computer. The cable modem is used for both upstream and downstream communication in this configuration. Most cable companies currently have initiatives under way to make such a conversion, but it requires a large capital investment. Therefore, it will be several years before these systems become widely available.

Cable modems modulate and demodulate analog signals like regular modems, but for transmission over broadband video services instead of telephone voice services. A cable modem can be internal or external, and can interface with the coaxial cable connection at the user’s end and the Cable Modem Termination System (CMTS) at the head office of the cable provider.

In a one-way cable modem implementation, the CMTS uses separate subsystems for upstream and downstream connections that terminate at a router. The downstream subsystem is designed for converting incoming Internet Protocol (IP) traffic into radio frequency broadband signals that are broadcast using a broadband network hub (BNH) over cable TV wiring to local groups of connected subscribers. The upstream subsystem usually consists of banks of ordinary telephone modems to allow for easy expansion of services to additional subscribers. The router is used to route network traffic between clients and local content servers hosted by the cable provider, and to the Internet.

Graphic C-2. A one-way cable modem service.
Graphic C-2. A one-way cable modem service.

Cable modem and Asymmetric Digital Subscriber Line (ADSL) are two competing technologies for bringing high-speed broadband Internet services to homes and businesses. Cable modems offer downstream speeds comparable to T1 lines, but competing technologies, lack of standards, and implementation costs are hindering widespread deployment and use of this technology.

NOTE

All subscribers in a one-way cable modem local service area are essentially on a local area network (LAN) and, if they have a packet sniffer, they can see each other. If you are using a one-way cable modem with the Microsoft Windows 98 operating system on your computer, you should disable file and print sharing so that other users in your local service area cannot see your system or access resources on it.

TIP

If you have a one-way cable modem installed on a computer running Windows 98 and it is not working properly, you might have IP Auto-Configuration Addressing enabled, causing an addressing problem that prevents packets from being routed successfully to your machine. Also try checking with your cable service provider to determine whether you have correctly configured the line-in frequency, line-out phone number, and proxy server address.

On the Web
•
Cablemodems.com
: http://www.cablemodem.com
•
IEEE 802.14 Cable-TV Protocol Working Group
: http://www.com21.com/pages/ieee-802.14.html

cable run

A length of installed cable connecting two network components that are not in immediate proximity to one another. Laying cable runs is the main work of installing premise cabling in a customer premises. Types of cable runs include

  • Horizontal cable:
    Runs through building plenums (the space between the floor and the ceiling) and false ceilings, connecting wiring closets together and connecting patch panels to wall plates

  • Vertical cable:
    Runs through vertical building rises, connecting wiring closets on each floor with the building’s main equipment room

Different grades of cabling must be used for different runs to ensure compliance with building codes and safety standards. Examples include PVC (polyvinyl chloride) cabling and plenum cabling. The EIA/TIA wiring standards specify guidelines for using cable types and grades.

NOTE

Cables connecting computers to patch panels (drop cables) and connecting patch panels with hubs and switches (patch cables) are generally not referred to as cable runs because they are not permanently installed and are usually quite short. The term “cable run” generally applies to cables that run from the patch panels in a wiring closet to other parts of the building.

TIP

When installing horizontal or vertical cable runs, use the highest grade that your budget will allow in order to accommodate future upgrades of your network’s speed and bandwidth. Use the enhanced category 5 cabling—which is a variety of unshielded twisted-pair (UTP) cabling—for all copper cabling installations. If you can, install parallel vertical runs of fiber-optic cabling with copper cabling in vertical rises to allow for future expansion of your network backbone. Installing two cables at once saves costs later, even if you need only the copper cabling now.

See also
cabling, premise cabling

cable tester

A device for measuring the integrity and transmission characteristics of cabling. Cable testers perform various functions to test network cabling for compliance with cabling standards developed by bodies such as the Telecommunications Industry Association (TIA), the International Organization for Standardization (ISO), and the International Electrotechnical Commission (IEC). Cable testers are useful to local area network (LAN) administrators, cable installers, and field service providers for testing and certifying cabling installations as compliant with these standards.

Graphic C-3. Cable tester.
Graphic C-3. Cable tester.
How It Works

Cable testers come in a variety of forms, ranging from handheld to briefcase size. They are generally divided between those used for testing fiber-optic cabling and those used for testing copper cabling. Different testers have different capabilities, but their general function is to measure various electrical characteristics across different ranges of frequencies. Testers will typically measure some or all of the following parameters at various frequencies from 100 MHz to 350 MHz and beyond:

  • Attenuation, which is the decibel decrease in signal strength as a signal propagates through a physical medium

  • Impedance, which is the resistance to the flow of alternating current

  • Noise, indicated by the floor values for randomly generated electrical signals

  • Near-end crosstalk (NEXT), which is a decibel measurement of crosstalk taken at the end where a signal is injected

  • Attenuation to crosstalk ratio (ACR), which is the decibel difference between NEXT and attenuation values

  • PowerSum NEXT, which measures the crosstalk between a single pair of wires and all other pairs in the cable

  • The distance to a short or unterminated cable end, used for link-testing the continuity of circuits

TIP

Look for cable testers that can perform comprehensive and programmable sets of autotests for a variety of cable types. A good cable tester can tell you at the push of a button whether installed wiring can support different kinds of networking architectures—such as coax, 10BaseT, 100BaseT, 100BaseVG, and token ring. Cable testers should be able to store measurements taken so that they can be analyzed separately afterward. The most accurate types of cable testers for unshielded twisted-pair (UTP) cabling are those that can test and certify category 5 cabling to Level II TSB-67 compliance. An all-in-one cable tester is an invaluable tool and a good investment for the network administrator. It can make up for its cost in higher network availability.

Use a fiber-optic tester and an optoelectronic light source to test both ends of a new spool of fiber-optic cabling before beginning an installation with this cable. A good fiber-optic cable test should give you not only a pass/fail analysis of an installed cabling setup, but also quantitative values of the optical link capabilities of your wiring configuration.

See also
cabling

cabling

Wires made of either copper or glass that are used to connect computers and other network components to enable them to communicate, thus forming a network of computers. Laying cables is the foundation for both creating local area networks (LANs) and connecting LANs into wide area networks (WANs). Network administrators are usually involved only in the planning and laying of LAN cabling, since WAN cabling is the responsibility of telecommunications carriers.

How It Works

There are two basic types of cabling used in LAN networking environments:

  • Copper cabling, which consists of insulated copper conductors that transmit signals using electrical voltages and currents. Copper cabling can be either coaxial cabling (such as thinnet or thicknet) that is used mainly in industrial environments, or the more commonly employed twisted-pair cabling. Twisted-pair cabling comes as either unshielded twisted-pair (UTP) cabling (commonly used in Ethernet or Fast Ethernet environments) or the less common shielded twisted-pair (STP) cabling (employed for token ring networks and sometimes for Gigabit Ethernet installations). Copper cabling is mainly used for shorter cable runs such as horizontal cable runs between wiring closets and wall plates in work areas, for patch cables, and for equipment interconnects.

  • Fiber-optic cabling, which is made of glass strands that transmit signals as light waves or pulses. Fiber-optic cabling can be either single-mode, which is used for the longest cable runs, or multimode, which has a much higher carrying capacity. Fiber-optic cabling is generally used for backbone cable runs such as vertical rises in buildings and building-to-building interconnects on a campus, for high-speed interconnects between networking devices in a wiring closet, and for connections to high-speed servers and workstations.

NOTE

The Telecommunications Industry Association (TIA) and Electronic Industries Alliance (EIA) have defined a series of standards on proper layout and organization of premise cabling called the EIA/TIA wiring standards. Cabling installed in a building must meet all legal requirements, including federal and local building regulations. Do not attempt to wire a building unless you are fully familiar with the required regulations. The EIA/TIA-568A Commercial Building Telecommunication Cabling Standard specifies standards for each of the following:

  • Establishing wiring closets on each floor of the building to contain rack-mounted equipment such as hubs, switches, and patch panels

  • Running vertical backbone plenum cabling through building risers and building plenums, for connecting wiring closets to the main equipment room

  • Running horizontal PVC (polyvinyl chloride) cabling for each floor through false ceilings

  • Connecting the patch panels in the wiring closet to wall plates in computer work areas

Specialized cables—such as serial, parallel, or SCSI cables—are used to connect peripherals, and therefore do not serve the same purpose as the cables just discussed. Serial cables and other special purpose cables are generally very short and are not permanently installed. Cabling for a LAN must be installed according to the standards described in the previous list. Not all networks use physical cabling. Wireless networks can use infrared, microwave, radio, or some other form of electromagnetic radiation to allow networking components to communicate with each other.

TIP

Choosing the right kind of cabling at the beginning of an installation can save considerable expense when networking equipment is later upgraded for higher transmission speeds.

See also
copper cabling, fiber-optic cabling, premise cabling

CA certificate

A digital certificate, also called a root certificate, that can be used to verify the identity of a certificate authority (CA). The CA certificate contains the identification information and public key for the certificate authority it identifies. A certificate authority that is part of a hierarchical public key infrastructure (PKI) receives its CA certificate from the CA directly above it in the hierarchy. A root CA at the top of a PKI hierarchy must self-sign its own certificate, in effect certifying itself.

How It Works

The CA certificate plays an important part in the workings of the Secure Sockets Layer (SSL) protocol. The public key of the CA, contained in the CA certificate, is used to validate all other digital certificates that have been issued by that CA for entities (individuals, systems, companies, and organizations). When an entity such as a Web browser (perhaps Microsoft Internet Explorer) or a Web server (perhaps Internet Information Services) requests a digital certificate from a CA, the CA certificate identifies the CA that issues the certificate.

This CA certificate is downloaded from a shared storage location at the certificate authority and installed onto the Web server or browser. Later, when the Web browser tries to access the Web server using the SSL protocol, the Web browser uses the CA certificate to validate the Web server’s certificate. Similarly, the server can use the CA certificate to validate the browser client’s certificate, if it has one.

NOTE

The digital CA certificate for a certificate authority must be kept in a location that is readily available for all servers and clients that will access it and install it on their Web browser or Web server. From this location, Web servers and Web clients that need to use the SSL protocol must obtain and install the CA certificate in their certificate stores. On Microsoft Certificate Server this location is the default Web location http://Server Name/certsrv, where Server Name is the name of the Microsoft Windows NT server on which Microsoft Certificate Server is installed.

TIP

Internet Explorer comes with the CA certificates of a number of certificate authorities preinstalled. These root certificates enable Internet Explorer to be used for SSL authentication, sending secure e-mail, and so on. If you want to use the services of a CA that does not have its CA root certificate installed in Internet Explorer, you can visit that CA’s Web site to find instructions on how to obtain their root certificate. Administrators can also use the Internet Explorer Administration Kit (IEAK) for importing and installing root certificates on Web browsers prior to installation on client machines.

See also
client certificate, server certificate

cache server

A server used to speed corporate access to Web content on the Internet by caching the Web pages that users most frequently request.

How It Works

Cache servers reduce network traffic and speed up access to frequently requested content by caching that content. Pages are held in the cache until they expire. If a user requests a page that has recently been cached, the page will be retrieved from the cache server instead of from the Internet. The cache server thus stores the content closer to the users who need it, reducing overall WAN link traffic and congestion. This saves valuable bandwidth on the wide area network (WAN) connection between the company’s network and its Internet service provider (ISP).

Many firewalls and proxy servers include some form of content caching. While firewalls and proxy servers are mainly concerned with securing access between a private corporate network and an untrusted public network such as the Internet, including cache server functionality in these products enhances their overall performance.

Graphic C-4. Cache server.
Graphic C-4. Cache server.
NOTE

Dedicated cache servers are also starting to be used in high-traffic situations within the Internet backbone itself to reduce congestion of the backbone. Content caching servers can be located at ISPs and Network Access Points (NAPs) for improving the performance and responsiveness of the Internet.

TIP

Microsoft Proxy Server is both a firewall and a content caching server that provides private corporate networks with secure and efficient access to resources on the Internet. Proxy Server integrates firewall and proxy server capability with content caching to provide improvements of up to 50 percent in content access speeds.

caching

Any mechanism for storing frequently needed information in accessible memory so that it can be quickly retrieved. Caching technologies are used in various ways by operating systems, applications, and network devices to improve performance by providing temporary storage of information that needs to be quickly accessed. Many Microsoft networking technologies support various kinds of caching, for example

  • The file system cache for the Microsoft Windows NT operating system, which speeds up file access from hard disk drives

  • Offline Files in Windows 2000, which allows users to browse network file system content when disconnected from the network

  • Domain Name System (DNS) cache for caching recently resolved host names on a name server, which speeds up the resolution of host names for the DNS on the Internet

  • Address Resolution Protocol (ARP) cache on a host connected to an IP internetwork, which is used for caching IP addresses that have recently been resolved into MAC addresses, thus speeding up network communications between hosts

  • Microsoft Proxy Server, which allows Web content obtained from the Internet to be cached locally for faster access and reduction of WAN link congestion

  • Caching of ODBC connections for improved access to Microsoft SQL Server databases for Active Server Pages (ASP) applications written for Internet Information Services (IIS)

Caching Array Routing Protocol (CARP)

A protocol developed by Microsoft and implemented in Microsoft Proxy Server that allows multiple proxy servers to be arrayed as a single logical cache for distributed content caching.

How It Works

Caching Array Routing Protocol (CARP) is implemented as a series of algorithms that are applied on top of Hypertext Transfer Protocol (HTTP). CARP allows a Web browser or downstream proxy server to determine exactly where in the proxy array the information for a requested Uniform Resource Locator (URL) is stored.

CARP enables proxy servers to be tracked through an array membership list that is automatically updated using a Time to Live (TTL) countdown function. This function regularly checks for active proxy servers in the array. CARP uses hash functions and combines the hash value of each requested URL with each proxy server. The URL/proxy server hash with the highest value becomes the owner of the information cached. This results in a deterministic location for all cached information in the array, which enables a Web browser or downstream proxy server to know exactly where a requested URL is locally stored, or where it will be located once it has been cached. The hash functions result in cached information being statistically distributed (load balanced) across the array. Using hashing means that massive location tables for cached information need not be maintained—the Web browser simply runs the same hashing function on the object to locate where it is cached.

CARP provides two main benefits:

  • It saves network bandwidth by avoiding the query messaging between proxy servers that occurs with conventional Internet Cache Protocol (ICP) networks.

  • It eliminates the duplication of content that occurs when proxy servers are grouped in arrays, resulting in faster response times and more efficient use of server resources.

caching-only name server

A name server in the Domain Name System (DNS) that can resolve name lookup requests but does not maintain its own local DNS database or zone file of resource records.

How It Works

Caching-only name servers do not have their own DNS databases. Instead, they resolve name lookup requests from resolvers by making iterative queries to other name servers. Once the responses to these queries are received, they are cached by the caching-only name server, in case another resolver issues the same request within a short period of time.

A caching-only name server is not authoritative for any particular DNS domain. It can look up names that are inside or outside its own zone.

NOTE

Caching-only name servers aren’t the only kind of name server that performs caching of resolved queries. For example, primary name servers also cache name lookups that they perform. This caching generally improves the response of the primary name server to name lookup requests from resolvers. Caching-only name servers are distinguished by the fact that they perform only one function: issuing iterative queries to other name servers and then caching the results.

TIP

Caching-only name servers provide support for primary and secondary name servers in environments where name lookup traffic is heavy. Using caching-only name servers where possible also reduces the overhead of zone transfers between name servers on a network.

See also
Domain Name System (DNS), name server

caching service provider (CSP)

A company that maintains caching servers that speed the transfer of information across the Internet’s infrastructure and offers managed access to these servers for a fee.

How It Works

Many companies think that if they host their Web site at an Internet service provider (ISP) or at a major Web hosting company, the site will always be accessible from anywhere on the Internet, but this is not necessarily true. Traffic congestion can cause access to a Web server to be slow and unreliable from various parts of the Internet at various times of the day, and equipment failures (such as routes going down at Internet peering points) can make a server completely inaccessible to certain portions of the Internet until the problem is fixed. (“Peering” means two ISPs or other providers passing traffic between each others’ customers.)

One solution is to mirror (replicate) your Web server at various points around the globe so that a copy of your site is relatively close to any location on the Internet. For companies with a global presence, this is a fairly simple solution to implement, but most companies do not have the presence or the resources to implement global mirroring. A better solution might be to use the services of a caching service provider (CSP), which maintains cached copies of your Web site at various points in the Internet’s infrastructure and provides tools for managing and load balancing the content to handle traffic spikes that occur at certain times of the day or year.

CSPs maintain data centers around the world with caching server farms that have high-speed connections to the Internet’s backbone. These caching servers are usually designed to cache Web content and often support features such as content management and proxying. Caching servers can also be used within the corporate network to speed access to large, distributed corporate intranets.

See also
caching

cacls command

A Microsoft Windows command for displaying and modifying the access control list (ACL) of a file or folder on an NTFS volume in Windows NT and Windows 2000. The cacls command can be used for viewing and modifying the ACL of a file and is an alternative to opening the property sheet of the file using Windows Explorer. Cacls gives you more granular control over the ACL of the file than Windows Explorer, but it displays the information in a more complex fashion.

Example

The command cacls C:\pub displays the ACL of the folder C:\pub on an NTFS partition of a machine running Windows NT or Windows 2000. Typical output might be

c:\pub BUILTIN\Administrators:F
      BUILTIN\Administrators:(OI)(CI)(IO)F
      Everyone:C
      Everyone:(OI)(CI)(IO)C
      BUILTIN\Administrators:F
      CREATOR OWNER:(OI)(CI)(IO)F
      BUILTIN\Server Operators:C
      BUILTIN\Server Operators:(OI)(CI)(IO)C
      NT AUTHORITY\SYSTEM:F
      NT AUTHORITY\SYSTEM:(OI)(CI)(IO)F

For the full syntax of this command, type cacls/? at the command prompt.

TIP

Cacls can be used with the redirection symbol to save the details of an ACL in a file. The output of the command can also be redirected to a printer for a hard copy of its details.

CAL

See
client access license (CAL)

callback

An optional feature supported by the Remote Access Service (RAS) on Microsoft Windows NT servers and the Routing and Remote Access feature of Windows 2000 servers. Callback provides an extra layer of security for users dialing in to a remote access server. When callback is configured, the client software dials in to a remote access server and has the user’s credentials authenticated. The remote access server then disconnects the client and calls the client back at a prespecified phone number. Callback might be configured

  • To ensure that the user matches his or her credentials by verifying the telephone location

  • For accounting reasons; for example, to charge the phone bill to the remote access server instead of the client

NOTE

In Windows 2000, the phone number specified for callback is called the Caller ID number.

TIP

Windows NT remote access servers configured for callback will call the dial-in client back after a preconfigured time interval of 12 seconds. This callback interval can be modified by editing the registry. See Microsoft TechNet information on callback for more details.

Graphic C-5. Callback.
Graphic C-5. Callback.
See also
Remote Access Service (RAS)

Callback Control Protocol (CBCP)

A protocol that is part of Microsoft’s implementation of the Point-to-Point Protocol (PPP). The Callback Control Protocol (CBCP) makes it possible for a PPP server to call back the remote dial-in client to complete initiation of a PPP dial-up session. Callback is a useful security feature for ensuring that dial-in clients are authentic.

How It Works

The CBCP is used during the third phase of establishing a PPP connection. After the PPP link is established using the Link Control Protocol (LCP) and the user’s credentials are authenticated using Microsoft Challenge Handshake Authentication Protocol (MS-CHAP) or some other authentication protocol supported by the client, the network access server (NAS) at the PPP service provider can optionally initiate a PPP callback control phase, provided that callback is configured on the server. The NAS and the PPP clients both disconnect from the PPP link, and the NAS calls the client back using the specified callback phone number. If the client responds, the link is reestablished; no further authentication is needed, and compatible network protocols are negotiated so that data transmission can begin.

CBCP is supported by the Remote Access Service (RAS) for Microsoft Windows NT.

TIP

Use CBCP as an extra layer of remote access security to secure corporate networks based on Windows NT. If Windows 95 or Windows 98 clients have trouble connecting to Windows NT remote access servers when CBCP is configured on the servers, try checking the ppplog.txt file on the Windows 95 or Windows 98 clients.

CAP

See
carrierless amplitude and phase modulation (CAP)

capture

A collection of frames gathered from network traffic. You can use packet-sniffing software such as Network Monitor (which is included in Microsoft Systems Management Server and in a simplified form in Microsoft Windows NT and Windows 2000) for capturing all kinds of traffic on the network. This captured traffic is displayed in the capture window as a variety of statistics and details about the nature of the traffic. Additional windows can display details about individual packets that have been captured.

Capturing network traffic is a common troubleshooting technique on enterprise-level networks. Captures can show whether services such as Dynamic Host Configuration Protocol (DHCP), Windows Internet Name Service (WINS), Domain Name System (DNS), and other common network services are performing properly. Captures can also isolate servers that are generating excessive network traffic because of failed hardware. Captures can even be used to detect unauthorized traffic initiated by malicious hackers and disgruntled employees, and to profile network traffic for planning purposes.

See also
capture window, Network Monitor

capture window

In Microsoft Network Monitor, the window that displays the statistics about the frames being captured on a network. The capture window displays four kinds of real-time statistics concerning the traffic that an administrator captures using Network Monitor:

  • Graph statistics:
    A graphical representation of current network activity that shows the percent of network utilization, frames captured per second, bytes captured per second, and broadcasts or multicasts captured per second

  • Session statistics:
    Information about current sessions between computers on the network, showing which hosts have sent packets to each other

  • Station statistics:
    Information about various stations involved in sending or receiving packets, showing how many of each type of packet they have sent or received

  • Total statistics:
    Summary statistics about network activity since the capture began, showing the number of frames, bytes, frames dropped, and so on during the capture

    Graphic C-6. Capture window.
    Graphic C-6. Capture window.
TIP

You can toggle these various window panes on and off during a capture to focus on statistics of interest.

See also
Network Monitor

CARP

See
Caching Array Routing Protocol (CARP)

carrier for telephone or telecommunications

A telephone or telecommunications company that provides different kinds of telecommunication services to its users or subscribers. A carrier is a provider of any kind of telecommunication service that can make use of the customer premises telephone connections. These services include voice transmission, data transmission over analog modems, Integrated Services Digital Network (ISDN), Asymmetric Digital Subscriber Line (ADSL), frame relay, and anything else the carrier’s equipment supports. There are two kinds of carriers:

  • A local exchange carrier (LEC) is a local telephone company that provides access to both local and long-distance telephone services through the local loop connecting the telco’s central office (CO) with the customer premises. In the United States, LECs are either local phone companies or Regional Bell Operating Companies (RBOCs).

  • An inter-exchange carrier (IXC) is a company that provides long-distance services only. IXCs own their own telecommunication facilities and provide long-distance services between LECs located in different toll-free areas. Examples include AT&T, MCIWorldCom, and Sprint.

See also
telecommunications services

carrierless amplitude and phase modulation (CAP)

A line coding scheme in which data is modulated using a single carrier frequency for transmission over a phone line. The transmission is considered “carrierless” because the carrier is suppressed before transmission and is reconstructed at the receiver. Carrierless amplitude and phase modulation (CAP) is algorithmically similar to the quadrature amplitude modulation (QAM) line coding scheme, which encodes bits as discrete phase and amplitude changes but has different transmission characteristics.

TIP

Some competitive local exchange carriers (CLECs) deploy Asymmetric Digital Subscriber Line (ADSL) using CAP as the encoding method, but results of some independent tests suggest that CAP-encoded ADSL lines might cause spectral interference with proximate T1 lines and Integrated Services Digital Network (ISDN) circuits, resulting in bit errors that can reduce throughput. However, these tests might be misleading because of the limited number of ADSL circuits currently deployed by CLECs. Check with your carrier before signing up for ADSL services to get the latest information about this issue.

Such interference is not a problem with Symmetric Digital Subscriber Line (SDSL) technologies, which use the 2B1Q encoding scheme. Furthermore, ADSL deployed by incumbent local exchange carriers (ILECs) uses discrete multitone (DMT) technology, which doesn’t produce the same degree of spectral interference as CAP. Competitive local exchange carriers generally do not use DMT for ADSL because they must deal with the copper local loop, which effectively supports DMT only about half the time but can support CAP about 85 percent of the time. Furthermore, DMT has been adopted as the standard for ADSL by both the American National Standards Institute (ANSI) and the International Telecommunication Union (ITU).

Carrier Sense Multiple Access with Collision Avoidance (CSMA/CA)

A type of media access control method for placing signals on baseband transmission networks. Since baseband networks can carry only one data signal at a time, there must be some way of controlling which station has access to the media at any given time. Carrier Sense Multiple Access with Collision Avoidance (CSMA/CA) is one such control method.

How It Works

In networking technologies that use CSMA/CA as their access method, stations announce their intention to transmit before they actually transmit their data onto the network media. Each station “listens” constantly to the wire for these announcements, and if it hears one, it avoids transmitting its own data. In other words, on a CSMA/CA network, stations try to avoid collisions with signals generated from other stations. The extra signaling generated by CSMA/CA makes it a slower access method than the Carrier Sense Multiple Access with Collision Detection (CSMA/CD) method used in Ethernet networking.

NOTE

CSMA/CA is the standard access method for AppleTalk networks based on LocalTalk. LocalTalk is a legacy network media technology that specifies the proprietary cabling components of the original AppleTalk networking architecture. LocalTalk uses a bus topology or tree topology that supports up to 32 stations on a network.

See also
media access control method

Carrier Sense Multiple Access with Collision Detection (CSMA/CD)

A type of media access control method for placing signals on baseband transmission networks. Since baseband networks can carry only one data signal at a time, there must be some way of controlling which station has access to the media at any given time. Carrier Sense Multiple Access with Collision Detection (CSMA/CD) is one such control method.

How It Works

In networking technologies that use CSMA/CD as their access method, a station first “listens” to the network media to make sure there is no signal already present from another station before it tries to place its own signal on the media. If a carrier signal is detected on the media, which indicates that a station is currently transmitting a signal, no other station can initiate a transmission until the carrier stops. If no carrier is detected, any station can transmit a signal.

If two stations listen to the wire and detect no carrier signal, they may both decide to send signals simultaneously. If this happens, a collision occurs between the two signals generated. Next, both stations detect the collision and stop transmitting their signals immediately, sending out a jamming signal that informs all other stations on the network that a collision has occurred and that they should not transmit. Meanwhile, the two stations whose signals created the collision cease transmitting and wait random intervals of time (usually a few milliseconds) before attempting to retransmit.

CSMA/CD is known as a contention method because computers contend for the chance to transmit data onto the network media. CSMA/CD is the standard access method for Ethernet networks. This method has two main drawbacks:

  • Only a relatively small number of computers can exist within any one collision domain. More computers will produce more collisions and slow overall network traffic.

  • CSMA/CD is not reliable beyond a distance of 1.5 miles (2500 meters) because of signal attenuation.

NOTE

The designation CSMA/CD derives from the following:

  • CS means that stations first s ense a c arrier present on the media before transmitting their own signals.

  • MA means that m ultiple stations can a ccess the network media.

  • CD means that if a c ollision is d etected because of multiple simultaneous transmission of signals, the stations that are transmitting signals stop, and then retransmit a short time later.

See also
media access control method

carrier signal

An alternating electromagnetic signal with a steady frequency upon which information is superimposed by some form of modulation. The specific frequency at which the carrier signal runs is called the carrier frequency and is measured in hertz (Hz). The modulation of the carrier signal enables information such as voice or data traffic to be integrated into the carrier signal. The carrier signal thus “carries” the voice or data information using modulation technologies.

The type of modulation used in digital communication systems depends upon whether the underlying carrier signal is analog or digital. For example, in digital radio or microwave communication, some form of digital-analog modulation, such as frequency-shift keying (FSK), is used to impose the digital (binary) information on the analog carrier wave. On the other hand, in Ethernet networking, a digital-digital encoding scheme called Manchester coding is used to enable the digital signal to carry binary 1s and 0s.

NOTE

In Ethernet networks, the carrier signal plays an important role in the media access control method that Ethernet uses, namely the Carrier Sense Multiple Access with Collision Detection (CSMA/CD) method.

cascaded star topology

See
star topology

cascading style sheets (CSS)

A standard from the World Wide Web Consortium (W3C) that gives Web developers more control over how the pages of a Web site will look when displayed on a Web browser. The cascading style sheets (CSS) standard gives Web developers control over design elements such as fonts and font sizes, and allows two-dimensional overlapping and exact positioning of page elements. The CSS standard also makes it easier to globally change the style and appearance of a Web site.

How It Works

Traditionally, Hypertext Markup Language (HTML) was designed for logical communication of linked information without much regard for its style or format, and was not designed to provide a high degree of control over how that information is laid out on a page. Using CSS, a Web developer can control the appearance of an entire Web site, or a portion of it, using a single HTML page called a style sheet. These style sheets define the functions of different HTML tags on your site’s Web pages and allow you to make global changes to your site’s style by changing a single entry on a style sheet. Web pages then link to style sheets using a <LINK> tag.

For example, you can use a style sheet to define the <H1> tag as representing green, 18-point, Arial font text, and you can then apply this style to the entire site or a portion of it. Cascading style sheets involve the operation of several levels of style sheets that provide control over how an element on an HTML document is placed. CSS applies these settings in the following order:

  • The STYLE attribute in the object’s tag

  • The STYLE element between the <TITLE> and <BODY> tags that specifies the style sheet to be used

  • The settings of the browser accessing the page and its default style sheet

On the Web
•
W3C standard for CSS 2
: http://www.w3c.org/Style

CAT5 cabling

See
category 5 cabling

catalog

The top-level organizational structure in Microsoft Index Server, containing the master index and other persistent indexes. The Index Server catalog is located by default in the directory %systemdrive%\inetpub\catalog.wci, but this can be overridden during installation. Index Server is included in the Microsoft Windows NT Option Pack (and the Windows 2000 Server CD) and is usually installed along with Internet Information Server (IIS) in Windows NT 4.0 or Internet Information Services in Windows 2000 to support the indexing of Web content for IIS.

If you are hosting more than one virtual server on an IIS machine, and these virtual servers represent different companies, you might want to create multiple catalogs for Index Server, one for each virtual server. Each catalog will then be used for indexing a specific virtual server, and queries based on a catalog will return only results for content on the associated virtual server.

NOTE

An Index Server query can span only one catalog at a time, so don’t create multiple catalogs unless you want to completely separate the indexing of their documents—for example, if you are hosting Web sites for multiple companies on your server.

TIP

The maximum size of the index for Index Server is 40 percent of the size of the documents being indexed (the corpus), so it is important when installing Index Server to locate the catalog on a drive with sufficient free space. For example, if you will be indexing 10 GB of documents, you will need about 4 GB of space for locating your catalog.

category 1 cabling

The lowest grade of unshielded twisted-pair (UTP) cabling. Category 1 cabling was designed to support analog voice communication only. Category 1 cabling was used prior to 1983 for wiring installations of analog telephone systems, otherwise known as the Plain Old Telephone Service (POTS). The electrical characteristics of category 1 cabling make it unsuitable for networking purposes, and it is never installed as premise wiring. Instead, all premise wiring must use either category 3 cabling, category 4 cabling, or category 5 cabling, with category 5 or enhanced category 5 cabling preferred for all new installations.

See also
cabling, premise cabling

category 2 cabling

The second-lowest grade of unshielded twisted-pair (UTP) cabling. Category 2 cabling was designed to support digital voice and data communication. Category 2 cabling was capable of data transmissions up to 4 Mbps. It was used primarily in the installation of premise wiring for legacy Token Ring networks from IBM. The electrical characteristics of category 2 cabling make it unsuitable for most networking purposes today, thus it is no longer installed as premise wiring. Instead, all premise wiring today must use only category 3 cabling, category 4 cabling, or category 5 cabling, with category 5 or enhanced category 5 cabling preferred for all new installations.

See also
cabling, premise cabling

category 3 cabling

The third-lowest grade of unshielded twisted-pair (UTP) cabling. Category 3 cabling was designed to support digital voice and data communication at speeds up to 10 Mbps. It uses 24-gauge copper wires in a configuration of four twisted-pairs enclosed in a protective insulating sheath. Category 3 cabling is the lowest grade of UTP cabling that can support standard 10BaseT types of Ethernet networks and was often used for legacy 4-Mbps Token Ring installations.

Category 3 cabling still has an installed base in older buildings where it is often cheaper to use the existing cabling than to upgrade to newer grades. Installing higher-grade cabling for backbone cabling in vertical rises and elevator shafts can extend the life of work areas that still use category 3 cabling. However, if greater speeds are required at users’ workstations, the best solution is to rewire the work areas using category 5 cabling or enhanced category 5 cabling.

NOTE

The following table summarizes the electrical characteristics of category 3 cabling at different frequencies, which correspond to different data transmission speeds. Note that attenuation increases with frequency, while near-end crosstalk (NEXT) decreases.

Category 3 Cabling Characteristics
Characteristic | Value at 10 MHz | Value at 16 MHz
Attenuation | 27 decibels/1000 feet | 36 decibels/1000 feet
NEXT | 26 decibels/1000 feet | 23 decibels/1000 feet
Resistance | 28.6 ohms/1000 feet | 28.6 ohms/1000 feet
Impedance | 100 ohms (± 15%) | 100 ohms (± 15%)
Capacitance | 18 pF/feet | 18 pF/feet
See also
cabling, premise cabling

category 4 cabling

The second-highest grade of unshielded twisted-pair (UTP) cabling. Category 4 cabling was designed to support digital voice and data communication at speeds up to 16 Mbps. It uses 22-gauge or 24-gauge copper wires in a configuration of four twisted-pairs enclosed in a protective insulating sheath. Category 4 cabling can support standard 10BaseT types of Ethernet networks. It was also commonly used in older 16-Mbps Token Ring installations.

Category 4 cabling still has an installed base in older buildings where it is often cheaper to use the existing cabling than to upgrade to newer grades. Installing higher-grade cabling for backbone cabling in vertical rises and elevator shafts can extend the life of work areas that still use category 4 cabling. However, if greater speeds are required at users’ workstations, the best solution is to rewire the work areas using category 5 cabling or enhanced category 5 cabling.

NOTE

The following table summarizes the electrical characteristics of category 4 cabling at different frequencies, which correspond to different data transmission speeds. Note that attenuation increases with frequency, while near-end crosstalk (NEXT) decreases.

Category 4 Cabling Characteristics
Characteristic | Value at 10 MHz | Value at 20 MHz
Attenuation | 20 decibels/1000 feet | 31 decibels/1000 feet
NEXT | 41 decibels/1000 feet | 36 decibels/1000 feet
Resistance | 28.6 ohms/1000 feet | 28.6 ohms/1000 feet
Impedance | 100 ohms (± 15%) | 100 ohms (± 15%)
Capacitance | 18 pF/feet | 18 pF/feet
See also
cabling, premise cabling

category 5 cabling

The highest and most commonly used grade of unshielded twisted-pair (UTP) cabling in networking today. Category 5 cabling was designed to support digital voice and data communication at speeds up to 100 Mbps. It uses 22-gauge or 24-gauge copper wires in a configuration of four twisted-pairs enclosed in a protective insulating sheath. Category 5 cabling is the standard grade of UTP cabling for networks such as

  • The standard 10BaseT variety of Ethernet

  • Fast Ethernet networks of the 100BaseTX variety

Category 5 cabling is always recommended for new installations of premise cabling and for upgrading existing premise wiring for higher-speed networks, because of its superior electrical characteristics. It is the highest grade of UTP cabling currently recognized by the Electronic Industries Alliance (EIA) and Telecommunications Industry Association (TIA), although proposals there have made for higher category 6 and category 7 grades. Many vendors offer an enhanced category 5 cabling grade with electrical characteristics exceeding those of standard category 5. Enhanced category 5 cabling supports data transmission up to frequencies of 350 MHz, and new standards are under development to allow even higher data transmission frequencies.

NOTE

The following table summarizes the electrical characteristics of category 5 cabling at different frequencies, which correspond to different data transmission speeds. Note that attenuation increases with frequency, while near-end crosstalk (NEXT) decreases.

Category 5 Cabling Characteristics
Characteristic | Value at 10 MHz | Value at 100 MHz
Attenuation | 20 decibels/1000 feet | 67 decibels/1000 feet
NEXT | 47 decibels/1000 feet | 32 decibels/1000 feet
Resistance | 28.6 ohms/1000 feet | 28.6 ohms/1000 feet
Impedance | 100 ohms (± 15%) | 100 ohms (± 15%)
Capacitance | 18 pF/ft. | 18 pF/ft.
TIP

Category 5 cabling is usually referred to simply as “CAT5.” UTP cables using CAT5 should be no more than 90 meters in length for typical Ethernet and Fast Ethernet installations, and patch cords should be no longer than 10 meters.

See also
cabling, enhanced category 5 cabling, premise cabling

CBCP

See
Callback Control Protocol (CBCP)

CDDI

See
Copper Distributed Data Interface (CDDI)

CDE

See
Common Desktop Environment (CDE)

CDF

See
Channel Definition Format (CDF)

CDF file

Text files used for creating Active Channels, Active Desktop items, and channel screen savers for managed webcasting of content to users’ desktops. CDF files are based on the Channel Definition Format (CDF) standard. CDF files provide a mechanism for allowing users to select the content they want to download from a Web site, and they let administrators schedule content for delivery to users’ desktops.

How It Works

CDF files are used to convert existing Web sites into Active Channels without the need to change the existing site in any way. You simply create a CDF file using a text editor such as Microsoft Notepad and include it in your site. This will allow the content of the site to be webcast to users’ browsers. The CDF file must be saved with the extension .cdf, and a link on your site should point to this file so that users can subscribe to the channel.

A typical CDF file defines a channel hierarchy for the different Web sites making up the Active Channel. This channel hierarchy contains a table of contents for webcasting the content and consists of a top-level channel, subchannels, and actual content items (Web pages). The simplest format for a CDF file is a list of Uniform Resource Locators (URLs) that point to specific Web pages in the site. More advanced CDF files can contain information such as

  • A map of the hierarchical structure of the URLs in the Web site

  • Logical groupings of different content items within a site that can differ from the observable link structure of the site itself

  • The title of each referenced Web page and a brief abstract of its contents

  • Information controlling the scheduling of content updates

The syntax of advanced CDF file items is based on the Extensible Markup Language (XML), an open specification that provides extensibility to standard Hypertext Markup Language (HTML) files. More than one CDF file can be created for a site, allowing users to subscribe to information in different fashions. For example, a news site can have separate CDF files for news, sports, and weather subscriptions.

NOTE

For specific information on the syntax of CDF files and how to create them, refer to the Microsoft Internet Client SDK.

TIP

Channels in Active Channel enable personalized delivery of Web content using Web applications designed for Internet Information Server (IIS) for Windows NT (Internet Information Services for Windows 2000). Active Server Pages (ASP) can be used for dynamically generating personalized CDF files for users. Cookies can also be used for dynamically generating customized CDF files for users. These CDF files can be customized on the basis of preferences that a user specifies on an HTML form prior to subscribing to the channel.

See also
Channel Definition Format (CDF)

CD file system (CDFS)

A file system designed for Microsoft Windows 95 that supports the reading of compact discs. A CD file system (CDFS) provides the same kind of file and directory management for CD-ROM devices that the file allocation table (FAT) or NTFS file systems do for hard disks. CDFS is also implemented on the Windows 98, Windows NT, and Windows 2000 platforms.

How It Works

On Windows 95 and Windows 98, CDFS uses a 32-bit protected-mode driver that supports the ISO 9660 CD file system standards. This 32-bit driver replaces the 16-bit real-mode MSCDEX driver that was used in the legacy 16-bit Windows and MS-DOS operating system platforms. In Windows 95 and Windows 98, the file system driver that supports CDFS is called cdfs.vxd, while in Windows NT and Windows 2000, it is called cdfs.sys. CDFS is optimized for reading compact discs that have a standard data block size of 2048 bytes (2 KB). The implementation of CDFS includes a dynamic, protected-mode cache pool for caching CD-ROM data to improve read performance. This allows CDFS to read ahead to ensure that playback of multimedia content from CDs is smooth and seamless.

NOTE

CDFS on Windows NT, Windows 2000, Windows 95 OSR2, and Windows 98 includes a number of enhancements over the original version of CDFS for Windows 95, such as

  • CD-XA support for optimized reading of MPEG video CDs having larger block sizes of 2352 bytes.

  • Auto-Run, which allows applications on CDs to start immediately when the CD is inserted into the drive. To do this, the operating system reads the autorun.inf file that is stored in the root of the directory structure on the CD.

TIP

Using Services for Macintosh, you can create a Macintosh-accessible volume on a CDFS volume by following the same steps you would use to make an NTFS volume accessible to Macintosh clients. Of course, the CDFS volume has one difference: it is read-only.

CDFS

See
CD file system (CDFS)

CDMA

See
Code Division Multiple Access (CDMA)

CDMA2000

A proposed hardware upgrade for the existing Code Division Multiple Access (CDMA) cellular telephone system. CDMA2000 was developed by the Telecommunications Industry Association (TIA) and is part of the International Mobile Telecommunications-2000 (IMT-2000) initiative of the International Telecommunication Union (ITU). CDMA2000 boosts the bandwidth of existing CDMA cellular systems to 2 Mbps. Another common name for this system is 3G 3X.

The existing interim standard for CDMA is IS-95a, commonly called CDMAone (the brand name used by the vendor consortium called the CDMA Development Group). This standard has approximately 30 million users in the United States and Asia and competes with Time Division Multiple Access (TDMA) systems such as the Global System for Mobile Communications (GSM), with 150 million users worldwide; Digital Advanced Mobile Phone Service (D-AMPS), with 15 million users in the United States; and Personal Digital Cellular (PDC), with 45 million users in Japan. Since the CDMA upgrade includes only a small portion of the overall wireless communication market, the IMT-2000 initiative also includes proposed upgrades to TDMA systems. A competing upgrade for TDMA systems is General Packet Radio Service (GPRS), which is closer to implementation than CDMA2000 and might therefore win more support than CDMA2000.

NOTE

The term “3G 1X” is used to describe a CDMA2000 system that uses the existing IS-94a base stations. This configuration limits transmission speeds to 144 Kbps. The CDMA Development Group promotes its implementation of the ANSI IS-95c standard as an alternative upgrade path from CDMAone. This implementation is commonly known as high data rate (HDR) and involves a hardware upgrade that gives users up to 10 aggregated 14.4-Kbps channels, but few vendors support this proposal because of the IMT-2000 initiative.

On the Web
•
CDMA Development Group
: http://www.cdg.org
See also
cellular phone technology, Code Division Multiple Access (CDMA)

CDO

See
Collaboration Data Objects (CDO)

CDPD

See
Cellular Digital Packet Data (CDPD)

CDSL

Stands for Consumer DSL, a broadband transmission technology based on Digital Subscriber Line (DSL) technology. CDSL was developed by Rockwell and is a slower technology than the more common DSL variant called Asymmetric Digital Subscriber Line (ADSL). CDSL provides data rates of about 1 Mbps downstream (about 128 Kbps upstream) to the customer premises over standard Plain Old Telephone Service (POTS) local loop wiring.

However, CDSL has the advantage of not requiring installation of a splitter at the customer premises. CDSL can operate only at distances of up to 18,000 feet from the telco’s central office (CO).

See also
Digital Subscriber Line (DSL)

cell in ATM

A 53-byte packet of data, the standard packet size used by Asynchronous Transfer Mode (ATM) communication technologies. Cells are to ATM technologies what frames are to Ethernet networking. In other words, they form the smallest element of data for transmission over the network.

Graphic C-7. Cell in ATM.
Graphic C-7. Cell in ATM.
How It Works

ATM cells are standardized at a fixed-length size of 53 bytes to enable faster switching than is possible on networks using variable-packet sizes (such as Ethernet). It is much easier to design a device to quickly switch a fixed-length packet than to design a device to switch a variable-length packet. (Switching a fixed-length packet is easier because the device knows in advance the exact length of the packet and can anticipate the exact moment at which the last portion of the packet will be received. With variable-length packets, the device must examine each packet for length information.) Using fixed-length cells also makes it possible to control and allocate ATM bandwidth more effectively, making support for different quality of service (QoS) levels for ATM possible.

The functions of information stored in the 5-byte header of an ATM cell include the following:

  • Providing information about the physical layer transmission method being used

  • Providing flow control to enable a steady flow of cell traffic and to reduce cell jitter

  • Specifying virtual path or channel identification numbers so that multiplexed cells belonging to the same ATM connection can be distinguished from cells belonging to other ATM connections, and so that cells can be switched to their intended destination

  • Specifying the nature of the payload contained in the cell—that is, whether it contains actual user data or ATM cell-management information

  • Specifying the priority of the cell to determine whether the cell can be dropped in congested traffic conditions

  • Providing error checking by means of an 8-bit field containing cyclical redundancy check (CRC) information for the header itself

There are two kinds of header formats used in ATM cells:

  • User-Network Interface (UNI) format:
    Used for communication between end nodes and an ATM network

  • Network-Node Interface (NNI) format:
    Used within the ATM network itself after the cell has been multiplexed for transmission over its virtual path

NOTE

Why a 48-byte data payload for ATM cells? This is the result of a trade-off between larger 64-byte payloads that contain more data but take longer to package and unpackage—and are therefore not suitable for real-time transmissions such as voice or multimedia—and shorter 32-byte payloads that provide better real-time transmission but are inefficient for larger amounts of data. By compromising at a 48-byte payload size, ATM has good transmission capabilities for both voice and data communication, providing efficient packet transfer with low latency.

cell in wireless communication

In wireless communication technologies, the geographical region that is covered by a transmission facility. The term “cell” is most often used in reference to cellular phone technology, but it can also be used in reference to the coverage areas for transmission of cordless telephones, satellite transmissions, wireless local area networks (LANs), packet radio, and paging technologies.

How It Works

Cells range in size from a few dozen meters to thousands of kilometers in diameter, depending on the technology being used, the power of the transmission station, and the terrain topography. The following table summarizes typical cell size ranges for different wireless communication technologies. These figures are only approximate because wireless technologies are constantly evolving.

Satellite-based systems have by far the largest cell sizes and are rapidly increasing in popularity. Cellular phone technologies in rural areas typically use cells with a radius of 10 to 50 kilometers, while cells in urban areas range in size from 1 to 10 kilometers. For highly dense urban areas, cell sizes as small as 100 meters can be used, especially in high-tier Personal Communications Devices (PCD) cellular technologies.

Cell Radius Measures by Technology
Wireless Technology | Cell Radius
Wireless LANs | 10 to 100 meters
Cellular telephone | 0.1 to 50 kilometers
PCD | 0.1 to 1 kilometer
Satellite-based | 1000 kilometers or more
NOTE

When a mobile caller using a cell phone passes from one cell to another, the cellular phone system transfers the call to the system servicing the adjacent cell, a process called roaming.

See also
cellular phone technology, wireless networking

Cellular Digital Packet Data (CDPD)

A specification for overlaying digital data transmissions on the existing circuit-switched analog cellular phone service. This phone service is called the Advanced Mobile Phone Service (AMPS). Cellular Digital Packet Data (CDPD) was developed by IBM (along with a consortium of Regional Bell Operating Companies) and other organizations to leverage the existing installed base of AMPS cellular equipment in the United States to provide low-cost, packet-switched data services. CDPD was first offered in 1994 by Bell Atlantic Mobile.

How It Works

CDPD makes use of idle times between calls in cellular phone network channels for interleaving packets of digital data. In other words, CDPD makes use of the “bursty” nature of typical voice transmission on the AMPS cellular system. Voice communication has gaps or pauses where packet data can be inserted and transmitted without interfering with the communication taking place between customers.

Although CDPD supports data transmission rates of 19.2 Kbps and higher, actual data throughput is usually around 9.6 Kbps. This is because of the large overhead added by CDPD to each data block transmitted. This overhead is designed to ensure that communications are reliable and to maintain synchronization between the modems at each end of the transmission. In addition, a color code is added to every data block to detect interference resulting from transmissions on the same channel from neighboring cell sites.

CDPD uses the Reed-Solomon forward-error-correcting code to encode each block or burst of data sent, and includes built-in RC4 encryption to ensure security and privacy of the transmitted data. CDPD is also based on the industry standard Internet Protocol (IP), allowing data to be transmitted to and from the Internet.

A typical implementation of CDPD consists of three components:

  • Mobile-End System (M-ES):
    A user device such as a laptop equipped with a cellular modem. This system communicates in full-duplex mode with a Mobile Data Base Station (MDBS) using the Digital Sense Multiple Access protocol, which prevents collisions of data streams from multiple Mobile-End Systems.

  • Mobile Data Base Station (MDBS):
    A telco device for receiving and transmitting CDPD data.

  • Mobile Data Intermediate System (MDIS):
    Provides the central control for a CDPD network.

CDPD is typically used to provide wireless access to public packet-switched networks such as the Internet so that mobile users can access their e-mail and other services. Multiple users can share the same channel; the user’s modem determines which packets are destined for the user’s machine. CDPD also supports IP multicasting and is an open standard based on the Open Systems Interconnection (OSI) reference model for networking.

On the Web
•
CDPD Forum
: http://www.cdpd.org
See also
cellular phone technology, wireless networking

cellular phone technology

A general term for a series of different technologies that enable cell-based wireless communication. A variety of different cellular phone technologies have evolved in recent years through the efforts of different vendors and standards organizations. This evolution is expected to continue as technologies mature and develop.

How It Works

The first generation of cellular phone systems were analog, with the Advanced Mobile Phone Service (AMPS) achieving widespread implementation in the United States in the 1980s. Analog cellular phone systems use frequency modulation for voice transmission and frequency-shift keying (FSK) for transmission of signaling information. Channel access is provided by the Frequency Division Multiple Access (FDMA) media access method.

Digital cellular technologies developed in the 1990s, and different competing systems have evolved, including

  • Time Division Multiple Access digital cellular, which uses Time Division Multiple Access (TDMA) as its media access method. TDMA supports both analog and digital transmission in a dual-mode configuration.

  • Code Division Multiple Access digital cellular, which uses Code Division Multiple Access (CDMA) as its media access method. CDMA is more complex than TDMA, but it is more efficient in its utilization of the frequency spectrum.

  • Global System for Mobile Communications (GSM), a popular digital cellular phone technology used in Europe and parts of Asia. GSM uses Time Division Multiple Access (TDMA) as its media access method.

  • Personal Communications Services (PCS), a set of multitier technologies that evolved from cordless telephony technologies. PCS systems use smaller cell sizes than other cellular technologies.

Graphic C-8. Cellular phone technology.
Graphic C-8. Cellular phone technology.

Common to all cellular phone technologies is the concept of the cell in wireless communication. Cellular technologies divide their geographical coverage zone into a series of smaller areas called cells that are each serviced by a transmission station. These stations are implemented in a distributed fashion to provide an overlapping series of cells that ensure all portions of a geographical region are serviced. Channels are then allocated to cells in such a way that no two adjacent cells use the same group of channels. Repeating patterns of cells are then used to optimize coverage while maintaining the maximum number of available channels per cell. For example, if you travel in a certain direction, every third cell might utilize the same set of frequencies.

When a mobile client is in one of the cells, he or she can receive and transmit information to the station servicing that cell. When the client moves to a different cell during a conversation, the new cell’s station seamlessly assumes communication with the client. One of the advantages of this system over the use of a single high-powered transmission station is that the client equipment (cell phone) itself does not need to be very powerful, which saves on size and cost.

Other aspects of designing a cellular phone technology include

  • Choice of modulation techniques

  • Signal-encoding methods

  • Error-detection and error-correction methods

  • Security-coding methods

  • Multiplexing methods for creating different channels from available bandwidth

NOTE

With the advent of cellular modems for mobile users, knowledge of cellular phone technologies is becoming an important aspect of wide area network (WAN) connectivity for the networking professional.

central office (CO)

The main switching facility for a telco, providing access to the Plain Old Telephone Service (POTS), leased lines, and circuit-switched services that the telco offers to customers. The central office (CO) contains the switching equipment that connects telephone subscribers to both local and long-distance phone services. Subscribers are connected to their local CO through a segment of wiring called the local loop. In countries other than the United States, a CO is often referred to as a public exchange.

How It Works

A typical CO looks like a fortress built to withstand an earthquake or any other natural disaster. Building standards for COs are high because of the importance of the communications infrastructure to a nation’s economic health and safety. Banks of batteries and diesel generators provide backup power in case of blackouts so that phone communication will not be disrupted.

Multitudes of twisted-pair copper telephone lines from customer premises usually enter the building through the underground cable vault. These twisted-pair lines are grouped into bundles of thousands of lines, forming large cables 3 to 4 inches in diameter. The cables have grounding mesh to provide a drain for unwanted electrical surges and tough PVC (polyvinyl chloride) insulating jackets that are pressurized to prevent water from seeping in at cable junctions. Steel racks organize these cables as they enter the cable vault.

From the vault, the cables snake their way to the main cross-connect grid. It is in these steel-frame grids that all the individual twisted-pairs fan out and connect through feeders to the main switching equipment. The importance of the feeders is that they allow any incoming twisted-pair line to connect to virtually any switching bank. This makes it possible for customers to move to a different part of the city and maintain their old telephone number at their new location. It also allows for redundancy: if a switch fails, a CO technician can rewire the feeder blocks quickly and easily. The main switches are then used to route calls to other local subscribers or to a long-distance telecommunications carrier such as AT&T or MCI WorldCom.

Centrex

An acronym for Central Office Exchange Service, a business telephone service provided by local telcos. By using a Centrex instead of a Private Branch Exchange (PBX), a business can eliminate the necessity of having its own dedicated switching facilities at its customer premises. Centrex also eliminates the need for customers to upgrade to expensive new telephones, since existing telephone lines and touch tone phones can be used with it. This frees the customer from the need to invest in the cost and management of customer premises equipment (CPE).

How It Works

Centrex services partition the switching capabilities of the telco’s central office (CO) equipment and allow a portion of these capabilities to be dedicated to a particular customer. In essence, the business customer is leasing dedicated switching facilities at the CO to enable a large number of employee telephones to be routed through a few telephone lines. All routing of calls to individual employee telephones takes place using the Centrex. Configuration changes can be performed at the CO instead of requiring technicians to visit the customer premises. This can save the cost of installing a local PBX at the customer premises.

Centrex can handle advanced communication features such as internal call handling, inbound and outbound call handling, and multiparty calling. Each individual connected can have customized calling features just as they can with a PBX. Maintenance is entirely the responsibility of the telco central office, which provides around-the-clock support.

NOTE

Some carriers such as Pacific Bell also offer Integrated Services Digital Network (ISDN) as a Centrex service in addition to standard business ISDN lines.

certificate

See
digital certificate

Certificate Administration Log Utility

A Web-based tool for administering Microsoft Certificate Server, which is included with the Microsoft Windows NT Option Pack and, as Certificate Services, with Windows 2000. The Certificate Administration Log Utility allows administrators to manage digital certificates and certificate revocation lists (CRLs) stored in the server log. Management of digital certificates and revocation lists is an essential component of a public key infrastructure (PKI). Certificate server administrators can use this tool to

  • View a list of all or filtered subsets of issued or revoked certificates, in either list or form view

  • View the details of individual certificates stored in the log

  • Revoke a certificate that is no longer considered secure

See also
Certificate Administration Queue Utility, certificate authority (CA), Microsoft Certificate Server

Certificate Administration Queue Utility

A Web-based tool for administering Microsoft Certificate Server, which is included with the Microsoft Windows NT Option Pack (and with Windows 2000 as Certificate Services). The Certificate Administration Queue Utility is used to display and manage the server queue. The server queue contains the PKCS #10 requests submitted to Microsoft Certificate Server for issuing standard X.509 format digital certificates. Issuing and managing digital certificates is an essential part of a public key infrastructure (PKI) for secure networking based on public key cryptography methods.

How It Works

For example, suppose you want to obtain and install a certificate for a Web site or virtual server on an Internet Information Server (IIS) version 4 server. Using the Key Manager component of Internet Services Manager, you first create a new key pair along with a certificate request file. The certificate request file is then enrolled using the certificate server administration Web page. The Certificate Administration Queue Utility can be used by the certificate server administrator to display details of the submitted certificate request—such as its serial number, when it was submitted, and the current disposition of the request. Using this tool, you can view a list of all or filtered subsets of received certificate requests, or view the details of individual certificate requests.

See also
Certificate Administration Log Utility, certificate authority (CA), Microsoft Certificate Server

certificate authority (CA)

Any entity (individual, department, company, or organization) that issues digital certificates to verify the identity of users, applications, or organizations. Before issuing a digital certificate to someone, the certificate authority (CA) must verify the user’s identity according to a strictly established policy, which can involve face-to-face communication, examination of a driver’s license with photograph, or another method of establishing a user’s identity. Once the user’s identity has been verified, the certificate is issued to the user. This certificate can then be presented by the user as a “digital driver’s license” to identify himself or herself during network transactions.

How It Works

CAs can be trusted third parties such as the private companies VeriSign, Inc., CyberTrust, and Nortel; or they can be established within your own organization using Microsoft Certificate Server. CAs can be stand-alone authorities with their own self-signed certificates (that is, they validate their own identity as a root CA), or they can be part of a hierarchy in which each CA is certified by the trusted CA above it (up to a root CA, which must always be self-certified).

For digital certificates to work as an identification scheme, both client and server programs must trust the CA. In other words, when a client program presents a certificate to a server program, the server program must be able to validate that the certificate was issued by a valid and trusted CA. Certificate authorities also maintain a certificate revocation list (CRL) of revoked certificates. Certificates issued by CAs expire after a specified period of time.

Certificate authorities are necessary for the functioning of a public key infrastructure (PKI), which is essential to the widespread acceptance and success of any public key cryptography system. Microsoft Windows 2000 can use standard X.509 digital certificates to authenticate connections across unsecured networks such as the Internet and to provide single sign-on using smart card authentication systems.

NOTE

Microsoft Certificate Server, a component of the Windows NT Option Pack (and of Windows 2000, as Certificate Services), is a tool that can be used for issuing, managing, and revoking digital certificates within your enterprise, without the need for third-party CAs.

On the Web
•
VeriSign, Inc.
: http://www.verisign.com
•
CyberTrust
: http://www.cybertrust.gte.com
•
Nortel
: http://www.nortelnetworks.com
See also
Microsoft Certificate Server, public key infrastructure (PKI)

Certificate Manager

A snap-in tool for Microsoft Management Console (MMC) in Microsoft Windows 2000 that allows issuing and managing digital certificates for public key cryptography. Certificate Manager can perform functions such as

  • Adding or removing certificate templates to allow different types of certificates to be issued

  • Revoking certificates and publishing a certificate revocation list (CRL)

  • Backing up and restoring the certificate information database

  • Starting and stopping Certificate Services

Certificate Manager can be used to either store issued certificates locally or publish them to Windows 2000 Active Directory. Publishing certificates to Active Directory enables users and groups with appropriate permissions to access certificates as needed.

certificate mapping

A feature of Internet Information Server (IIS) version 4 that allows mapping between user accounts and digital certificates. This is useful when an organization issues client certificates to users. Client certificates are digital certificates that verify the identity of client software (Web browsers) belonging to users. Client certificates are often used in situations in which mobile clients using laptops require secure access to a corporate intranet site.

How It Works

Before users can be granted remote access to the corporate intranet, they must be authenticated by the Web server they are connecting to. IIS supports four kinds of Web authentication mechanisms:

  • Anonymous access:
    Allows anonymous users access to Web sites—such as public sites on the Internet.

  • Basic Authentication:
    Passes a user’s credentials over the network as clear text. Although this mechanism is not very secure, it has the advantage of being able to work through a firewall or a proxy server.

  • Windows NT Challenge/Response Authentication (called Integrated Windows Authentication in Windows 2000):
    A secure authentication method that does not actually pass the user’s credentials over the network but uses a cryptographic exchange instead. The only Web browser that supports this authentication method is Microsoft Internet Explorer. This method cannot work through a firewall or a proxy server.

  • Certificate mapping:
    Uses the Secure Sockets Layer (SSL) protocol to authenticate users by examining the contents of their client certificate in order to log them on to the network without requiring them to enter their credentials.

Client certificates provide verification of identity, while certificate mapping associates a user’s account with the user’s client certificate and permits the user to log on to the network. The user typically utilizes a Web browser with SSL protocol to connect to a secure company Web site. The company Web server checks the Web browser’s client certificate. If the certificate is valid, the user is automatically logged on using his or her user account without ever having to enter credentials, and can access whatever intranet resources for which the account has permissions.

NOTE

Certificate mapping is also supported by Active Directory in the Windows 2000 operating system. The Active Directory Users and Computers administrative tool can be used for this purpose.

TIP

IIS allows two kinds of client certificate mappings:

  • One-to-one mappings between user accounts and client certificates on the user’s browser. This type of mapping is typically used to allow users secure access to corporate intranet resources; for example, to view or modify their employee information.

  • One-to-many mappings of several client certificates to a single user account. One-to-many mappings have the advantage of permitting administrators to allow a single certificate (issued by a specific organization to a particular user account) to be used to grant all users access to the corporate intranet. For example, an agency that provides your company with temps can assign the same client certificate to all temps who share one user account on your company’s network.

certificate request

A file containing an entity’s identification information and public key that is submitted to a certificate authority (CA) in order to obtain a digital certificate. A certificate request file is a text file encoded using Base64 encoding. This text file is generated by an application in response to the entity’s request for a key pair and digital certificate. The entity here refers to the individual, system, company, or organization requesting the certificate. The certificate request is then submitted to a CA to obtain a digital certificate for the entity.

The Key Manager utility in Internet Services Manager (the utility used to manage Internet Information Services) can be used to generate a key pair and a standard PKCS #10 format certificate request file. The certificate request file is a simple text file that can be viewed with Microsoft Notepad. If this file is submitted to a public certificate authority, such as VeriSign, Inc., or to the company’s own certificate authority, such as Microsoft Certificate Server, a standard X.509 format digital certificate will be granted in return.

See also
Microsoft Certificate Server

certificate revocation list (CRL)

A list, maintained by a certificate authority (CA), of digital certificates that have been issued and then later revoked. A certificate revocation list (CRL) is similar to lists of revoked credit card numbers that credit card companies used to give to vendors. The certificate authority makes the CRL publicly available so that users can determine the validity of any digital certificate presented to them.

Creating and maintaining a CRL is an essential ingredient in running a public key infrastructure (PKI) to support public key cryptography systems. Microsoft Certificate Server includes a Web-based utility called the Certificate Administration Log Utility that can be used to revoke certificates and maintain a CRL.

See also
public key cryptography, public key infrastructure (PKI)

Certificate Services

See
Microsoft Certificate Server

Certified Technical Education Center (CTEC)

An education-delivery company such as a school or training center that is qualified by Microsoft for the delivery of Microsoft Official Curriculum (MOC) courseware. Certified Technical Education Centers (CTECs) are one of Microsoft’s main channels for training on Microsoft products and technologies. CTECs can deliver training in a variety of forms, including instructor-led, self-paced, customized, and online training. CTECs are one of the ways that Microsoft contributes to solutions addressing the shortage of skilled IT professionals worldwide.

Network professionals who want to become familiar with Microsoft operating systems, applications, and development platforms can take MOC courses offered by CTECs at various locations around the world. Microsoft CTECs are also a source for the best in self-paced training materials on Microsoft products and services.

On the Web
•
Microsoft CTEC home page
: http://www.microsoft.com/ctec

CGI

See
Common Gateway Interface (CGI)

Challenge Handshake Authentication Protocol (CHAP)

An encrypted authentication scheme in which the unencrypted password is not transmitted over the network. Challenge Handshake Authentication Protocol (CHAP) is one of several authentication schemes used by the Point-to-Point Protocol (PPP), a serial transmission protocol for wide area network (WAN) connections. Other authentication schemes supported by PPP include Password Authentication Protocol (PAP), Shiva Password Authentication Protocol (SPAP), and Microsoft Challenge Handshake Authentication Protocol (MS-CHAP). PAP is a widely implemented authentication protocol, but CHAP is more secure than PAP because CHAP encrypts the transmitted password, while PAP does not. SPAP and MS-CHAP are vendor-specific implementations.

How It Works

A typical CHAP session during the PPP authentication process works something like this:

  1. A client connects to a network access server (NAS) and requests authentication.

  2. The server challenges the client by sending a session ID and an arbitrary string.

  3. The client uses the MD5 one-way hashing algorithm and sends the server the username, along with an encrypted form of the server’s challenge, session ID, and client password.

  4. A session is established between the client and the server.

To guard against replay attacks, the challenge string is chosen arbitrarily for each authentication attempt. To protect against remote client impersonation, CHAP sends repeated, random interval challenges to the client to maintain the session.

NOTE

CHAP is supported by the Remote Access Service (RAS) on Microsoft Windows NT and the Routing and Remote Access feature of Windows 2000 as a way to allow non-Microsoft clients to dial in and receive authentication for a RAS session, and to allow Microsoft RAS clients to connect to any industry-standard PPP server.

channel bank

A type of telecommunications equipment that allows multiple analog signals to be transmitted over a single digital connection. Channel banks are typically located at the telco’s central office (CO) and support the digital switching functions of the Public Switched Telephone Network (PSTN).

How It Works

A channel bank interfaces with the wires of the local loop connection that carry the phone signals from the customer premises to the telco’s CO. The channel bank combines the analog signals using a technique called multiplexing, which allows multiple signals to be combined for transmission over a single line. The channel bank also includes circuits for converting the analog signals to digital signals using pulse code modulation (PCM) techniques. The resulting digital signal format conforms to the standard 64-Kbps DS0 (Digital Signal Zero) format. The signals can then be routed through the digital switching backbone of the PSTN as necessary.

NOTE

Channel bank equipment can also be installed at customer premises for larger enterprises.

channel bar

A component of Microsoft Internet Explorer version 4 that displays the available user-subscribed Active Channels. Active Channels provide a way of webcasting information to subscribers using Microsoft’s Channel Definition Format (CDF) technology.

How It Works

When Internet Explorer is first installed on a user’s machine, a selection of preloaded channels is stored in the channel bar according to the country preference the user specified during installation. These channels are stored by default in C:\Windows\Favorites\Channels on a computer running Microsoft Windows 95 or Windows 98 and in C:\Winnt\Profiles\<user> \Favorites\Channels on a computer running Windows NT. When a user subscribes to a channel, a small red gleam appears next to the icon representing the channel. This gleam indicates that new content has been downloaded and is available for browsing.

NOTE

Administrators who plan to deliver and install Internet Explorer on users’ machines can use the Internet Explorer Administration Kit (IEAK) to customize the users’ set of startup channels. Administrators can thus use the channel bar to deliver important information to users through the company’s intranet site.

See also
Channel Definition Format (CDF)

Channel Definition Format (CDF)

An open standard created by Microsoft for Microsoft Internet Explorer version 4 (and proposed as a standard to the World Wide Web Consortium) that defines a “smart pull” technology for webcasting information to users’ desktops. Based on the Extensible Markup Language (XML), Channel Definition Format (CDF) lets administrators create Active Channels for delivery of content through the users’ Web browser, and Active Desktop elements and channel screen savers for delivery directly to the users’ desktops. Channel content can be personalized, and delivery can be scheduled according to users’ needs and preferences. Using CDF also reduces server load and allows delivery of just the needed content, instead of requiring users to download large quantities of unnecessary content.

How It Works

Let’s consider the delivery of Web content to the user’s browser using Active Channels. A Web site can be made into an Active Channel through the addition of a CDF file. The CDF file is a simple text file that is formatted using XML. It forms a kind of table of contents of the logical subset of the Web site that comprises the Active Channel. A link is then created to the CDF file on the Web site. The user clicks the link to subscribe to the Active Channel and download the CDF file. The Active Channel then appears on the channel bar on the user’s desktop. The content for the channel is downloaded to a cache on the user’s system. Channel updates are accomplished by scheduled Web crawls, using either the publisher’s predefined schedule or a user’s customized one. Users can also receive updates to channels by e-mail.

Some of the advantages of using CDF for the distribution of Web information to users include

  • Simplicity:
    Turning an existing Web site into a channel merely involves creating a CDF file with a text editor and creating a hyperlink to this file.

  • Structure:
    CDF describes how to logically group information in a hierarchical structure, independent of the content format.

  • Personalization:
    Standard Hypertext Transfer Protocol (HTTP) cookies can be used to deliver personalized information to users.

  • Administrator control:
    The administrator can control how much of the site can be downloaded by users.

  • User control:
    The user can use CDF to specify which portions of a site to download to his or her browser, instead of pulling a lot of content off the site and hoping that it contains the needed information.

NOTE

CDF is not true webcasting in the sense of Internet Protocol (IP) multicasting because it is a “pull” technology. True webcasting is supported by Microsoft NetShow for delivery of content using IP multicasting.

channel in Active Channel

The delivery method in Active Channel, a technology for Microsoft Internet Explorer that allows Web content to be “webcast” to users. Channels deliver content to users’ Web browsers. The content is displayed as ordinary Web pages and can be viewed off line. Channels are delivered to users by way of Microsoft’s Channel Definition Format (CDF) technology. Channels can contain Hypertext Markup Language (HTML); Microsoft ActiveX controls; Microsoft Visual Basic Scripting Edition (VBScript); Java applets; and other dynamic Web elements. The channels that a user has subscribed to are listed as part of his or her channel bar.

See also
Channel Definition Format (CDF)

channel in Microsoft NetShow

In Microsoft NetShow, a mechanism that supplies clients with information needed to receive and render Advanced Streaming Format (ASF) streams. The channel specifies the multicast address and port number the clients should listen to in order to receive the stream. The channel also specifies the data types and formats in the stream, enabling the client to correctly render the stream. NetShow saves channel information as files with the extension .nsc. A NetShow channel is analogous to a television channel or a radio frequency: if a NetShow client is tuned to a channel at the right time, the client receives streaming information sent by the NetShow server.

NetShow channels also support additional features such as

  • Roll over to unicast:
    If clients cannot receive a multicast, you can configure the channel so that they automatically receive a unicast of the same program.

  • Stream distribution:
    On corporate TCP/IP networks whose routers do not support multicasting, one NetShow server can distribute a stream to other NetShow servers that are each located on separate local area network (LAN) segments. These secondary servers can then multicast to clients on their own LAN segment.

NOTE

NetShow supports channels only when using ASF streams.

channel screen saver

A form of screen saver supported by Microsoft Internet Explorer version 4. Channel screen savers are Hypertext Markup Language (HTML) pages that can include such dynamic elements as Microsoft ActiveX controls; Microsoft Visual Basic Scripting Edition (VBScript); Java applets; and so on. Channel screen savers are delivered to users through Web sites using Microsoft’s Channel Definition Format (CDF). If multiple channel screen savers have been downloaded to the user’s desktop, the user’s system cycles through by default, displaying a new one every 30 seconds.

When a channel screen saver is being displayed, the user can still use the mouse to interact with objects on the screen without causing the screen saver to disappear. For example, if the channel screen saver contains a hyperlink, the user can click the hyperlink to open a new Web browser window, which causes the screen saver to disappear. If a user clicks on a section of the screen saver that is not a hyperlink, the screen saver closes, revealing the items on the user’s desktop.

See also
Channel Definition Format (CDF)

Channel Service Unit (CSU)

A digital communication device that is used to connect a digital line to a digital device. Channel Service Units (CSUs) can be used to link local area networks (LANs) into a wide area network (WAN) using telecommunications carrier services such as

  • Digital data service (DDS)

  • T-carrier services such as a T1 line

  • Frame relay links

How It Works

The CSU is used to terminate the end of the digital telecommunications line located at the customer premises. It terminates on the customer premises end with a data terminal equipment (DTE) device such as a router, switch, multiplexer (MUX), or dedicated server. The connection to a DTE is typically an RS-232 or a V.35 serial transmission interface. The service provider interface of the CSU must connect to a Data Service Unit (DSU), which is a data communications equipment (DCE) device responsible for converting signals into a format suitable for transmission over the digital communications line, and for creating and maintaining the connection.

Graphic C-9. Channel Service Unit (CSU).
Graphic C-9. Channel Service Unit (CSU).

Typically, the telecommunications service provider will lease the CSU to the customer, having preconfigured it for the type of communications to be supported. CSUs typically include remote diagnostic capabilities, such as remote loop testing and even Simple Network Management Protocol (SNMP) features that allow the unit to be monitored by the service provider.

NOTE

Currently, CSUs are usually combined with DSUs to create a single device called a CSU/DSU (Channel Service Unit/Data Service Unit). Dedicated stand-alone CSUs are typically used only for interfacing with installed customer premises telecommunications equipment that contains integrated DSUs. This installed equipment could be a channel bank, Private Branch Exchange (PBX), T1 multiplexer, or some other device.

See also
Channel Service Unit/Data Service Unit (CSU/DSU)

Channel Service Unit/Data Service Unit (CSU/DSU)

A digital communications device that combines the functions of both a Channel Service Unit (CSU) and a Data Service Unit (DSU). These devices lie between the telephone company network and the customer network at the demarcation point and are the local interfaces between the data terminal equipment (DTE) at the customer premises and the telco’s digital communications line (such as a T1 line).

How It Works

CSU/DSUs essentially function as the digital counterpart to analog modems. They are typically external units that look similar to an external modem, but they can also come in sizes that can be mounted in a rack. Unlike analog modems, CSU/DSUs do not perform signal conversion because the signal at both ends is already digital. CSU/DSUs package digital data into a format suitable for the particular digital transmission line they are servicing, and buffer and rate-adapt digital signals going to and from the telephone company network. CSU/DSUs ensure that data frames are properly formed and timed for the telephone company network and provide a protective barrier to electrical disturbances that can harm customer premises equipment (CPE).

Graphic C-10. Channel Service Unit/Data Service Unit (CSU/DSU).
Graphic C-10. Channel Service Unit/Data Service Unit (CSU/DSU).

Digital lines usually terminate at customer premises with four-wire connections having various connector types, including RJ-45, four-screw terminal blocks, and M-block connectors (used for V.35 interfaces). The four-wire connection is joined to the appropriate connector on the CSU/DSU. The CSU/DSU typically adjusts itself to the line speed of the digital data service (DDS) line using an autosensing feature. The customer’s CSU/DSU then connects directly to the customer’s router, and from there connects to the customer’s network.

At the other end of the DDS line at the central office (CO), the telco has a similar CSU that interfaces with a multiplexer to feed into the carrier’s backbone network.

TIP

When purchasing CSU/DSUs, consider first the traffic requirements of your wide area network (WAN) link and make sure they support the full range of data rates for the DDS lines you plan to use (56 K, 64 K, or T1 speed).

CHAP

See
Challenge Handshake Authentication Protocol (CHAP)

Chat

An accessory in Microsoft Windows NT and Windows 2000 (winchat.exe) for communicating with text in real time with other users on the network. Chat is an interactive tool that displays each character as it receives it. Chat supports text-based communication over a Windows network only, and is not intended as a tool for Internet Relay Chat (IRC).

Graphic C-11. The version in Windows NT.
Graphic C-11. The version in Windows NT.

The generic term “chat” describes any system that supports text-based communication over a network for logged-in users. Such a system typically includes a display that shows text as another user types it.

How It Works

Chat consists of a window with two panes, one for the message you type and one for messages you receive. A user dials another user by specifying the name of the other user’s computer. A chat window then opens on the receiver’s computer. Once the receiver answers, the text that one user types in the left or upper pane immediately appears in the right or lower pane on the other user’s chat window.

NOTE

The Windows NT and Windows 2000 Chat utility requires that the Network Dynamic Data Exchange (DDE) service and related services be running on the participating computers. In Windows NT, use the Services applet in Control Panel, and in Windows 2000, use the Services item in Computer Management to set the startup configuration of this service.

Check Disk

In Microsoft Windows NT and Windows 2000, a built-in utility for checking for errors on a hard disk volume. To access this utility, open the Properties dialog box of the volume you want in Windows Explorer or My Computer, select the Tools tab, and click the Check Now button. This displays the Check Disk dialog box, which has two options:

  • Automatically correct any file system errors that are found.

  • Scan the disk volume for bad sectors and repair those found.

Graphic C-12. The utility in Windows NT.
Graphic C-12. The utility in Windows NT.
NOTE

All files must be closed on the volume for Check Disk to attempt to correct errors. If files are open, you will be prompted to schedule Check Disk to run at the next system restart. If Check Disk is run on an NTFS volume, bad clusters will automatically be replaced and all file transactions will be logged.

child domain

A domain in a domain tree in Microsoft Windows 2000 whose Domain Name System (DNS) name is a subdomain of a parent domain. For example, if the name of the parent or company domain is microsoft.com, some typical names of child domains might include dev.microsoft.com, marketing.microsoft.com, and support.microsoft.com.

NOTE

New child domains can be created using the Active Directory Installation Wizard. A child domain must be created in an existing domain tree, since creating a new tree automatically creates a new parent domain. A two-way transitive trust exists between a parent domain and its child domains.

See also
Active Directory, domain tree

chkdsk command

A utility used in Microsoft Windows for locating, reporting, and correcting file system errors on disks. There are versions of chkdsk for all Windows platforms as well as for MS-DOS. The versions for Windows NT and Windows 2000 can be used on both file allocation table (FAT) and NTFS volumes. The syntax for the command can be displayed by typing chkdsk/? at the command prompt.

Example

Typing chkdsk c: tells the computer to check the C drive. Note that using the /f switch will force chkdsk to attempt to repair file system errors. The chkdsk command will attempt to lock the disk first, but if the errors are associated with open files, chkdsk will be scheduled to run at the next reboot.

NOTE

The chkntfs command is a different command that is included in Windows NT 4 (Service Pack 2 or later) and Windows 2000. It allows administrators to exclude specific volumes from having chkdsk /f performed on them by the autochk.exe program after an unexpected reboot.

TIP

Running chkdsk /f can result in data loss if chkdsk cannot repair the volume. Either back up your volumes before running chkdsk, or use scandisk instead.

CIDR

See
classless interdomain routing (CIDR)

CIFS

See
Common Internet File System (CIFS)

CIM

See
Common Information Model (CIM)

circuit

A path between two points over which an electrical signal can pass. In telecommunications, a circuit is a path over which voice, data, or other analog or digital signals can pass. A physical circuit is a collection of wires or cables that are connected with switches or other devices; it can be thought of as a straight line between the two endpoints.

For an electrical signal to actually flow between two points in a circuit, the circuit must be closed—that is, there must be a return path for the current. Two basic types of circuits are used in serial transmission for telecommunications technologies:

  • Balanced circuits, such as those based on the RS-422 interface, use a separate signal path and return path, with two separate wires.

  • Unbalanced circuits, such as those based on the RS-232 interface, use a single signal path, adding ground to complete the circuit.

Balanced circuits typically support higher data transmission rates because they are less susceptible to noise caused by electromagnetic interference (EMI) than unbalanced circuits.

Graphic C-13. Circuit.
Graphic C-13. Circuit.
NOTE

A typical serial interface such as RS-232 includes specifications for a number of different types of circuits, including data circuits, control circuits, timing circuits, secondary circuits, and ground connections.

See also
circuit-switched services, virtual circuit

circuit layer proxy

Any service or server that provides proxy services using a specially installed component on the client computer to form a circuit between the proxy server and the client computer. Circuit layer proxies support a wider variety of protocols than application layer proxies.

Microsoft Proxy Server version 2 is a product that combines firewall and proxy server functions and has two Microsoft Windows NT services for providing circuit-level proxy functions:

  • The Winsock Proxy Service enables Windows Sockets clients such as Microsoft NetShow Player, RealAudio, and Internet Relay Chat (IRC) to function as if they are directly connected to the Internet. The Winsock Proxy Service provides Windows NT Challenge/Response Authentication with clients, regardless of whether the clients support it, and supports Windows Sockets version 1.1–compatible applications on computers running Windows. The Winsock Proxy Service can control access by port number, protocol, and user or group. Ports can be enabled or disabled for specific users or groups, and the list of users that can initiate outbound connections on a given port can differ from the list of users that can listen for inbound connections on that port.

  • The SOCKS Proxy Service includes support for the SOCKS 4.3a protocol. The SOCKS Proxy Service provides support for Macintosh-based and UNIX-based client computers, while the Winsock Proxy Service supports only Windows-based computers. SOCKS uses Transmission Control Protocol (TCP) and can be used to control access to the Telnet, File Transfer Protocol (FTP), Gopher, and Hypertext Transfer Protocol (HTTP) protocols. The SOCKS Proxy Service does not support RealAudio, streaming video, or NetShow clients.

See also
application layer proxy

circuit-level gateway

A type of firewall that provides session-level control over network traffic. Similar in operation to packet filtering routers, circuit-level gateways operate at a higher layer of the Open Systems Interconnection (OSI) reference model protocol stack.

How It Works

Circuit-level gateways are host-based and reside on individual clients and servers inside the network, rather than on a dedicated machine as they do with other types of firewalls. Circuit-level gateways examine incoming Internet Protocol (IP) packets at the session level—Transmission Control Protocol (TCP) or User Datagram Protocol (UDP)—and act as relays by handing off incoming packets to other hosts. Circuit-level gateways are rarely used as a stand-alone firewall solution; instead, they are typically used in combination with application layer proxy services and packet filtering features in dedicated firewall applications.

Microsoft Proxy Server combines the features of packet filtering, circuit-level gateways, and application layer proxy to provide a full firewall solution for protecting your corporate network. Proxy Server supports both the SOCKS protocol, which provides nontransparent circuit-level gateway security, and the Winsock Proxy, which provides transparent circuit-level gateway security.

See also
firewall, proxy server

circuit-switched services

A telecommunications service provided to businesses by telcos and long-distance carriers. “Circuit-switched services” is an umbrella term describing any service that provides switched connections between a consumer and a provider. The telephone system is an example of a circuit-switched service. Circuit-switched services are temporary circuits only, and can be compared with leased lines, which use dedicated switches.

How It Works

With circuit-switched services, a new switched circuit must be established each time one local area network (LAN) attempts to connect to a remote LAN. Different switches can be used for each attempt, depending on availability and traffic, so the quality of services can vary between connections. Your LAN is connected through bridges, routers, modems, and terminal adapters to the telco’s central office (CO), which sets up switches on demand to connect you to your destination LAN. When you disconnect the wide area network (WAN) link, the switches are freed up for other purposes.

Graphic C-14. Circuit-switched services.
Graphic C-14. Circuit-switched services.

One advantage of circuit-switched services is that they are generally less expensive than leased lines. This is because switches are not dedicated to your network like leased lines are, and can therefore be used for other purposes when you are not using them. The cost for circuit-switched services is usually based on usage.

Another advantage of circuit-switched services is that you are not restricted to a single destination as you are with leased lines; you can dial up any destination that supports services similar to yours. However, dial-up or connection times vary with the technology used. For example, analog modems might take 10 to 20 seconds to establish a connection, while an Integrated Services Digital Network (ISDN) terminal adapter might take only 1 to 2 seconds. This latency interval tends to make circuit-switched lines unsuitable for dedicated services, such as those used for connecting company Web servers to the Internet.

Another disadvantage of circuit-switched services is that the quality can differ substantially between connections, because each circuit is a temporary connection that can exist along different paths, switches, and communication devices.

TIP

Circuit-switched services are often used as backup lines for more expensive leased lines. For example, if your more expensive T1 line fails, you can switch to a dial-up ISDN line (if it comes from a different provider). You should monitor your network usage with circuit-switched services because when a certain usage level is reached, leased lines become economically preferable.

See also
leased line, packet-switching services

circular logging

A feature of Microsoft Exchange Server whereby transaction logs can be overwritten when full. Circular logging lowers disk space usage but reduces the chances of successfully recovering from a system crash.

How It Works

Exchange Server databases, such as the directory database and information store, maintain special log files called transaction log files. These log files improve the performance and fault tolerance of the databases, and help track and maintain changes made to them. Transactions are immediately written both to the log files and to memory, and only afterward to the database files. Transaction logs are normally kept on a different drive from the database files to ensure fault tolerance in case of a disaster that causes data loss, such as a crashed disk or a power failure.

When circular logging is enabled, only a few transaction log files are maintained, and these are overwritten when they become full. This prevents log files from continually building up, which saves disk space. However, circular logging has the disadvantage of allowing you to perform only full backups, rather than incremental or differential ones, because you can restore information only up to the last full backup.

TIP

Do not use circular logging if data recoverability is of high importance to your mail system, which is almost always the case with e-mail. Circular logging is enabled by default. You should always disable it and ensure that you have enough free disk space to hold the transaction files. The only reasons you might want to enable circular logging would be if you run low on disk space or if your server is being used for noncritical data only, such as a public news server.

class

More precisely called “object class,” a logical grouping of objects within Active Directory in Microsoft Windows 2000. Objects are organized within Active Directory by their classes. Examples of object classes can include users, groups, computers, domains, and organizational units (OUs). Each class of objects has its own defining properties or attributes, as laid out in the Active Directory schema. Grouping objects logically into classes makes it easier to find and access these resources on the network.

TIP

Active Directory comes with predefined object classes. You can create additional classes or modify existing ones using the Active Directory Schema.

See also
Active Directory, object in Active Directory

classic desktop

A way of displaying the desktop and its contents that was first used in Microsoft Windows 95. The classic desktop presents users with a graphical user interface (GUI) that allows icons, shortcuts, files, and folders to be placed on it. These desktop items provide a simple way for users to launch and access frequently used programs and network resources. The Start menu provides another tool for launching programs and accessing resources. The taskbar displays the programs currently running and the windows-to-network resources that are open.

The choice of GUI for users’ client computers can make a big difference in employee productivity. The following are two factors involved in determining whether network administrators should maintain the classic desktop or upgrade to the newer Active Desktop included with Microsoft Internet Explorer beginning with version 4:

  • The cost of introducing users to the new desktop paradigm

  • The necessity for tight integration among the desktop, the corporate network, and the Internet

Graphic C-15. Classic desktop.
Graphic C-15. Classic desktop.

classless interdomain routing (CIDR)

A routing system used by routers and gateways on the backbone of the Internet for routing packets. Classless interdomain routing (CIDR) is a more efficient routing mechanism than the original method of segregating network IP addresses into classes named class A, class B, and class C. The reason for CIDR is that while class A networks support large numbers of network nodes, there are not enough class A network IDs to go around. Similarly, while many class C network IDs are available, many companies require more than the 254 IP addresses available on a class C network, but not nearly as many as the 65,534 IP addresses available on a class B network.

CIDR replaces the old class method of allocating 8, 16, or 24 bits to the network ID, and instead allows any number of contiguous bits in the IP address to be allocated as the network ID. For example, if a company needs a few thousand IP addresses for its network, it can allocate 11 or 12 bits of the address for the network ID instead of 8 bits for a class C (which wouldn’t work because you would need to use several class C networks) or 16 bits for class B (which is wasteful).

How It Works

CIDR assigns a numerical prefix to each IP address. For example, a typical destination IP address using CIDR might be 177.67.5.44/13. The prefix 13 indicates that the first 13 bits of the IP address identify the network, while the remaining 32 - 13 = 19 bits identify the host. The prefix helps to identify the Internet destination gateway or group of gateways to which the packet will be forwarded. Prefixes vary in size, with longer prefixes indicating more specific destinations. Routers use the longest possible prefix in their routing tables when determining how to forward each packet. CIDR enables packets to be sent to groups of networks instead of to individual networks, which considerably simplifies the complex routing tables of the Internet’s backbone routers.

NOTE

CIDR is not used extensively in private networks because most networks are hidden behind firewalls and can use any arbitrary block of IP addresses, such as the 10.x.y.z block allocated by Internet Network Information Center (InterNIC) for general, private use. Instead, CIDR comes into its own on the Internet backbone to facilitate routing. CIDR is defined in Request for Comments (RFC) 1519.

See also
Border Gateway Protocol (BGP)

clear-text

The process of sending data over a network in an unencrypted form. By using a packet sniffer or software such as Network Monitor, anyone who can capture clear-text packets can read the information within them. Clear-text authentication methods are sometimes the best choice in a heterogeneous network environment where users running different operating system platforms need to access resources on network servers. For example, UNIX clients that need to access an Internet Information Services (IIS) machine using a Web browser will need to be authenticated using a clear-text method called Basic Authentication.

NOTE

Basic Authentication is usually described as clear-text authentication, but in actuality, Basic Authentication weakly encrypts data using the well-known uuencoding algorithm. This algorithm is in the public domain and can easily be decrypted by knowledgeable users.

The standard AppleTalk protocol uses clear-text authentication for allowing Macintosh clients to access shared folders on Macintosh file servers using AppleShare.

client

A workstation or computer, usually belonging to a single user, as opposed to a server, which is shared by many users. Planning the hardware, software, configuration, deployment, and maintenance of clients is as important to the network administrator as the other server-related activities.

Choice of a client operating system depends on various considerations. For example, in determining whether to install Microsoft Windows 98 or Windows NT Workstation on client computers, users should consider the following:

  • Both client operating systems, in conjunction with Microsoft Internet Explorer versions 4 and later, offer the same desktop configuration options, similar utilities, and similar support for features such as user profiles, hardware profiles, and system policies.

  • Windows NT Workstation will provide client machines with better performance, greater reliability, and more robust security, but it has higher hardware requirements than Windows 98.

  • Windows 98 supports a broader range of devices and legacy software applications, and includes power-management support—making it a better solution for mobile users.

NOTE

In configuring clients to operate on a network, appropriate software must be installed on each client to allow it to access servers on the network. For example, to access Windows NT and Windows 2000 servers, client machines require Microsoft client software such as Client for Microsoft Networks. To access Novell NetWare servers, client machines require NetWare-compatible clients, such as Client for NetWare Networks.

client access license (CAL)

A license that grants a client machine access to a Microsoft BackOffice product running on a network of computers. Every client computer on a network, regardless of whether it is running a Microsoft or non-Microsoft operating system, requires a client access license (CAL) if it will be accessing any of the following Microsoft Windows NT or Windows 2000 services:

  • File services, for accessing shared files and folders on a server

  • Print services, for accessing shared network printers

  • Remote Access Service (RAS) or Routing and Remote Access Service (RRAS)

  • File and Print Services for NetWare (FPNW)

  • File and Print Services for Macintosh (FSM)

  • Microsoft Transaction Server (MTS) and Microsoft Message Queue (MSMQ) Server access

  • Windows NT Terminal Server functionality

Client access licenses can operate in one of two modes:

  • Per Server licensing, which is based on concurrency of access to network resources

  • Per Seat licensing, which is the more commonly implemented solution and is supported by all BackOffice applications

See also
licensing mode

client certificate

A digital certificate obtained for a client application (such as a Web browser) that can be used by the client to digitally sign data it transmits. Client certificates can be used to enable client machine authentication for the purpose of secure communication over the Internet using the Secure Sockets Layer (SSL) protocol.

How It Works

A client obtains a certificate from a certificate authority (CA) by submitting a certificate request file. The CA responds by issuing a client certificate, which contains the client’s identification information in encrypted form, along with the client’s public key. The client certificate must then be installed on the client’s Web browser. Microsoft Internet Explorer can import client certificates into the browser’s certificate store using the Personal button on the Content tab of the Internet Options dialog box. Administrators can also use the Internet Explorer Administration Kit (IEAK) for preconfiguring client certificates prior to installation on user computers.

Graphic C-16. Importing a client certificate in the Internet Explorer Properties dialog box.
Graphic C-16. Importing a client certificate in the Internet Explorer Properties dialog box.

In SSL communication, a Web server can validate the identity of a client using the certificate installed on the client. With Internet Information Server (IIS) version 4, client certificates can be mapped to Microsoft Windows NT user accounts by way of a process called certificate mapping. (Windows 2000 supports a similar feature in its Internet Information Services.) Certificate mapping makes it easier for administrators to control access to content located on the Web server.

TIP

Use client certificates when it is important for servers to validate the identity of clients—for example, when your enterprise includes mobile users with laptops who need to remotely and securely access the company’s intranet server using Internet Explorer.

See also
public key cryptography

Client for Microsoft Networks

A Microsoft Windows 95, Windows 98, and Windows 2000 networking component that makes it possible to access file and print services on Windows 95, Windows 98, Windows NT, Windows 2000, Windows for Workgroups, and LAN Manager dedicated servers and peer servers. Client for Microsoft Networks works with any combination of NetBEUI, IPX/SPX-Compatible Protocol, and TCP/IP protocols. Client for Microsoft Networks cannot be used for accessing non-Microsoft servers such as Novell NetWare servers. You must install Client for NetWare Networks to access these servers. Windows 95 and Windows 98 allow you to install more than one client at a time to access different kinds of servers on the network.

How It Works

Use the Network utility in Control Panel to install Client for Microsoft Networks on a computer running Windows 95 or Windows 98. Then use the property sheet of Client for Microsoft Networks to configure the computer to either participate in a workgroup or log on to a Windows NT or Windows 2000 domain.

NOTE

In Windows NT, the equivalent component is called the Workstation service, but in Windows 2000, the component is Client for Microsoft Networks, as in Windows 95 and Windows 98.

Client for NetWare Networks

A Microsoft Windows 95, Windows 98, and Windows 2000 networking component that makes it possible to access file and print services on Novell NetWare servers. Client for NetWare Networks requires that the IPX/SPX-Compatible Protocol be installed. Client for NetWare Networks cannot be used for accessing Microsoft servers such as Windows NT Server and Windows 2000. You must install Client for Microsoft Networks to access these servers. Windows 95 and Windows 98 allow you to install more than one client at a time to access different kinds of servers on the network.

How It Works

Use the Network utility in Control Panel to install Client for NetWare Networks on a computer running Windows 95 or Windows 98. Then use the property sheet of Client for NetWare Networks to configure the preferred NetWare server, to select the first drive letter to use for mapping network drives from NetWare command-line utilities, and to enable processing of logon scripts on the preferred server.

NOTE

Client for NetWare Networks can connect to NetWare 3 and earlier servers, or NetWare 4 servers running in bindery emulation mode. If you want to use Client for NetWare Networks to connect to a NetWare 4 server running Novell Directory Services (NDS), you must also install Service for NetWare Directory Services on the Windows 95 or Windows 98 client. This service is available with Windows 95 OSR2 or Service Pack 1 for Windows 95, and is included with Windows 98.

TIP

Before installing Client for NetWare Networks on a computer running Windows 95 or Windows 98, make sure you remove any real-mode NetWare requestor software running on the machine, such as NETX or VLM.

client installation point

A shared directory on a network file server to which users on your network can connect to install client software locally on their client computers. Creating a client installation is the first step in preparing to install software over the network.

How It Works

To create a client installation point, create a directory on a server and share the folder with full permissions for administrators and read-only permissions for ordinary users. Either copy the installation files for the software from the CD to the shared directory, or run the setup program using a special switch to copy the files so that they can be used for network installation—for example, to uncompress the cabinet files on the CD. Users can then connect to the shared directory, run the setup program, and complete the installation process.

client/server application

A distributed application consisting of a server portion (back end), where most of the processing and storage is performed, and a client portion (front end) that provides a user interface.

How It Works

In the client/server model, an application is split into a front-end client component and a back-end server component. The front-end client part of the application runs on a workstation and receives data that is input by the user. The client component prepares the data for the server by preprocessing it in some fashion, and then sends the processed information to the server, usually in the form of a request for some service. The back-end server component receives the client’s request, processes it, and returns information to the client. The client receives the information returned from the server and presents it to the user by way of its user interface.

An example of a client/server application is a Web application that is designed for Internet Information Services (IIS) using a combination of server-side Active Server Pages (ASP) programming and client-side scripting. The ASP scripts run on the Web server, while the client-side scripts run on the client Web browser.

Client Services for NetWare (CSNW)

A service that can be installed on Microsoft Windows NT Workstation computers to enable them to directly connect to file and print resources on Novell NetWare servers. In other words, Client Services for NetWare (CSNW) is Microsoft’s version of the NetWare redirector for Windows NT. Microsoft Windows 2000 Professional also has a similar service with the same name.

How It Works

CSNW is a full-featured, 32-bit client for NetWare networks that can be installed on Windows NT Workstation by using the Services tab of the Network utility in Control Panel (or on Windows 2000 Professional by using the Network and Dial-up Connections utility in Control Panel). If you are connecting to a NetWare 3.12 or earlier server, you must specify a preferred NetWare server for access to its bindery. If you are connecting to NetWare 4, specify the Novell Directory Services (NDS) tree and default context. CSNW supports browsing NDS trees, but does not support administration of NDS trees.

Additional options are included for printing and login script support. CSNW requires installation of the NWLink IPX/SPX-Compatible Transport protocol, but if it is not installed already, it will be added automatically when you install CSNW on a machine.

NOTE

CSNW supports connections to servers running version 2, 3, or 4 of NetWare, including both bindery emulation and NDS on NetWare 4. CSNW includes support for

  • NetWare Core Protocol (NCP)

  • Large Internet Protocol (LIP)

  • Long filenames (LFNs)

Graphic C-17. Client Services for NetWare (CSNW).
Graphic C-17. Client Services for NetWare (CSNW).
TIP

On a machine running Windows NT Server or Windows 2000 Server, NetWare connectivity is provided by Gateway Services for NetWare (GSNW). Use CSNW to provide your Windows NT Workstation clients with dedicated access to Novell NetWare servers; use GSNW only to provide occasional access to NetWare servers from Windows NT Workstation or Windows 2000 Professional clients.

cloud

In networking, any part of the network whose data transmission paths are unpredictable and vary from session to session.

Clouds are often used in networking diagrams to represent packet-switching services. In these services, a packet sent from one node to another follows an unpredictable path, since at any given moment different routers or other devices can be used to forward the packet toward its destination. The Internet is an example of a packet-switching cloud for TCP/IP networking, since data sent between two points can travel over many possible paths. This is why the Internet is graphically represented as a cloud in drawings of wide area networks (WANs). Other examples of packet-switching services include frame relay and X.25 networks.

Circuit-switched services are often represented as clouds as well. In circuit-switched services, communication switches at various telco and carrier central offices (COs) and switching facilities are temporarily used for establishing circuits between two communicating nodes. Each time communication is terminated and reestablished, different sets of switches can be used.

Graphic C-18. Cloud.
Graphic C-18. Cloud.

cluster

A configuration of two nodes in Microsoft Cluster Server (MSCS). When network clients try to access shared resources or applications on clusters, the cluster appears to the clients as a single server. MSCS is included with Microsoft Windows NT Server, Enterprise Edition. (For a similar feature in Windows 2000, see Windows Clustering.)

How It Works

Each node in a cluster is a completely independent computer system that must be running Windows NT Server, Enterprise Edition. These nodes are connected by a shared storage bus such as an external Small Computer System Interface (SCSI) disk subsystem. Network resources such as applications and shared information can be hosted on only one node at a time, but MSCS supports failover, which allows the resource to be shifted to the other node if one of the nodes in a cluster fails. Failover is controlled by the Cluster service, which runs on both nodes.

Graphic C-19. Cluster.
Graphic C-19. Cluster.

Some of the different models for configuring a cluster on MSCS include

  • High availability with static load balancing, in which both nodes make their resources available to network users as virtual servers and either node can take on the work of the other should failover be initiated. This configuration is typically used for file-sharing or print-sharing purposes.

  • High availability with hot-spare support, in which the primary node is active and provides resources to network users, while the secondary node is inactive and is used only as a dedicated backup node. This configuration is typically used for mission-critical Web services.

Cluster Administrator

A GUI-based tool used for managing any cluster on the network. A copy of Cluster Administrator is automatically installed on both nodes in the cluster when you install Microsoft Cluster Server (MSCS), but Cluster Administrator can also be installed and run from any remote computer running Microsoft Windows NT with Service Pack 3 or later. (On Windows 2000 Advanced Server, Cluster Administrator is provided as a snap-in for the Microsoft Management Console.)

Cluster Administrator can perform actions such as

  • Specifying which applications run on each node of the cluster

  • Managing services, file shares, and directory replication

  • Configuring policies for failover and failback

  • Configuring which node currently runs each application

  • Taking nodes off line for maintenance

TIP

You can also administer various aspects of MSCS by typing cluster.exe from the command prompt. This might be useful, for example, if you had to use a secondary dial-up modem connection to manage a cluster. Another use might be to create a batch file for automated administration of MSCS, and schedule the batch file using the Windows NT at command. Cluster.exe can be used only on a computer with MSCS installed or a Windows NT Workstation with Service Pack 3 that has Cluster Administrator installed.

cluster-aware application

In Microsoft Cluster Server (MSCS) or Windows Clustering, any client application that can run on a node of a cluster and can be managed as a cluster resource. Cluster-aware applications can be written to access the services of MSCS by using its cluster application programming interface (API). Cluster-aware applications also implement the extension dynamic-link libraries (DLLs) of Cluster Administrator, which allow them to be managed using Cluster Administrator. These features allow developers to write high-scalability applications that can perform dynamic load balancing across the different nodes in a cluster.

A cluster-aware application is one that is aware of the fact that it is running on a cluster and can make use of the scalability, load balancing, and failover aspects of clustering to provide high availability for mission-critical business environments. Cluster-aware applications include database applications such as Microsoft SQL Server, messaging applications such as Microsoft Exchange Server, and Web applications for running on Web servers such as Internet Information Services (IIS).

clustering

Any technology that enables two or more servers to appear to clients as a single system. Clustering provides failover protection for mission-critical applications running on servers. Microsoft Cluster Server (MSCS) is a two-node clustering solution included in Microsoft Windows NT Server, Enterprise Edition.

Clustering technologies are often used for high-availability Web servers such as Internet Information Services (IIS) to sustain around-the-clock uptime.

How It Works

A cluster consists of two or more nodes connected to a shared file system. Each of the nodes is a fully functional computing platform, and the shared file system consists of a hard disk system or RAID-5 array connected to each node using a fast Small Computer System Interface (SCSI) bus or fibre channel connection. The result is a cluster of computer systems that acts and functions as if it were a single system. This provides fast, uninterrupted service for high-demand environments with minimal downtime.

Clustering solutions fall into three different categories:

  • Active/active clustering:
    This type of clustering makes the most efficient use of system resources because there are no redundant nodes: all nodes run active processes. If one node of a cluster fails, other nodes take on the workload of the failed cluster. The latency for failover in this scenario is typically 15 to 150 seconds, depending on the hardware/software configuration. This is the kind of clustering supported by MSCS.

  • Active/standby clustering:
    Nodes are paired within a cluster, with one node designated to take over should another node fail. If an active node fails, a standby node assumes its workload. Latency for failover is also 15 to 150 seconds.

  • Fault-tolerant clustering:
    Nodes are paired within a cluster, and all nodes perform all tasks simultaneously. This is an expensive solution from a hardware point of view, but latency for failover is reduced to a second or less.

Cluster service

A Microsoft Windows NT service in Microsoft Cluster Server (MSCS) that controls cluster activity, communication between cluster servers, and failover operations. (Windows Clustering in Windows 2000 also includes a Cluster service.) The Cluster service controls all aspects of cluster operation and manages the MSCS configuration database. Each node in a cluster runs its own instance of the Cluster service.

The Cluster service handles the following functions:

  • Configuration and management of clustering service objects (nodes, networks, resources, groups, and so on)

  • Coordination between all instances of the service running on the cluster

  • Failover operations

  • Event notification

The Cluster service provides three benefits:

  • High availability:
    If one node of a cluster fails, the other node starts providing services, making mission-critical applications continually available to clients. This process is called failover.

  • Scalability:
    Using clustering technology, less powerful computer systems can be enhanced when grouped into clusters.

  • Manageability:
    Since both nodes of a cluster are managed as a single system, administrative tasks are made easier.

See also
Windows Clustering

CM

See
Microsoft Connection Manager (CM)

CMAK

See
Connection Manager Administration Kit (CMAK)

CMP cabling

See
plenum cabling

CN

See
connected network (CN)

CNAME record

Stands for Canonical Name record, a Domain Name System (DNS) resource record in a DNS server’s database or zone file. A CNAME record is used to map an alias to the canonical name (true name) of a server. The CNAME record lets you use more than one name to refer to a single host on the network. If a name server is queried by a resolver to look up a host and the queried name is an alias in a CNAME record, the name server replaces the alias name with the canonical name of the host being looked up, and then looks up the address of the canonical name.

Example

Here is an address record for the host named server12 in the Microsoft.com Internet domain. This record has the IP address 172.16.8.5, followed by a CNAME record indicating that the name bobby (or the fully qualified domain name bobby.Microsoft.com) is an alias for the same host:

server12.Microsoft.com    IN    A    172.16.8.55
bobby                     IN    CNAME        server12

CO

See
central office (CO)

coax

See
coaxial cabling

coaxial cabling

A form of network cabling used primarily in older Ethernet networks and in electrically noisy industrial environments. The name “coax” comes from its two-conductor construction in which the conductors run concentrically with each other along the axis of the cable. Coaxial cabling has been largely replaced by twisted-pair cabling for local area network (LAN) installations within buildings, and by fiber-optic cabling for high-speed network backbones.

Graphic C-20. Coaxial cabling.
Graphic C-20. Coaxial cabling.
How It Works

Coaxial cabling generally consists of a solid copper core for carrying the signal, covered with successive layers of inner insulation, aluminum foil, a copper braided mesh, and outer protective insulation. A solid conductor provides better conductivity than a stranded one, but is less flexible and more difficult to install. The insulation is usually PVC (polyvinyl chloride) or a non-stick coating; the aluminum foil and copper mesh provide shielding for the inner copper core. The mesh also provides the point of grounding for the cable to complete the circuit.

Coaxial cabling comes in various types and grades. The most common are

  • Thicknet cabling, which is an older form of cabling used for legacy 10Base5 Ethernet backbone installations. This cabling is generally yellow and is referred to as RG-8 or N-series cabling. Strictly speaking, only cabling labeled as IEEE 802.3 cabling is true thicknet cabling.

  • Thinnet coaxial cabling, which is used in 10Base2 networks for small Ethernet installations. This grade of coaxial cabling is generally designated as RG-58A/U cabling, which has a stranded conductor and a 53-ohm impedance. This kind of cabling uses BNC connectors for connecting to other networking components, and must have terminators at free ends to prevent signal bounce.

  • ARCNET cabling, which uses thin coaxial cabling called RG-62 cabling with an impedance of 93 ohms.

  • RG-59 cabling, which is used for cable television (CATV) connections.

In addition, a number of special types of coaxial cabling are sometimes used for certain networking purposes. An example is twinax cabling, which consists of two conductors first enclosed in their own insulation and then enclosed in a single copper mesh and insulating jacket. Twinax is used in legacy IBM networks for connecting AS/400 systems to 5250 terminals. Other more exotic varieties include triax, quadrax, and ribbon types of coaxial cables.

TIP

Coaxial cabling is often used in heavy industrial environments where motors and generators produce a lot of electromagnetic interference (EMI), and where more expensive fiber-optic cabling is unnecessary because of the slow data rates needed. Coaxial cabling is also used frequently in IBM mainframe and minicomputer environments. A device called a splitter can be used to fork one coaxial cable into two—for example, when connecting two 3270 terminals to one IBM mainframe system. A splitter is used at either end of the connection so that the signals for both terminals can be sent over a single coaxial cable. Coax multiplexers can be used to connect eight or more terminals to a single controller.

codec

Short for compressor/decompressor, an encoding algorithm used for recording digital audio or video. A codec compresses transmitted data at the sending end and decompresses it at the receiving end.

Microsoft NetShow uses different codecs to provide streaming multimedia information over a TCP/IP network such as the Internet. NetShow provides a number of different codecs for different purposes. You can select a codec to give you the audio or image quality and image size that you want for your transmission.

Code Division Multiple Access (CDMA)

A digital cellular phone technology that uses spread spectrum wireless networking technologies. Code Division Multiple Access (CDMA) can be used to refer both to a type of digital cellular phone system and to the specific media access method used by this kind of cellular system. CDMA was developed by Qualcomm in 1993, and it was adopted and ratified by the Telecommunications Industry Association (TIA) as part of their Interim Standard 95.

How It Works

CDMA uses the spread spectrum wireless networking technology—first developed for military communication systems in the 1940s because it spreads its transmission over a large bandwidth, making it difficult to jam. Instead of dividing the available radio spectrum into a series of discrete channels using the older Time Division Multiple Access (TDMA) media access method, a CDMA channel occupies the entire available frequency band. The disadvantage is that CDMA is more complex to implement than TDMA digital cellular technologies.

The spread spectrum approach assigns a special digital code sequence to each user, and all users share the same broad portion of the radio frequency spectrum. Users thus share time and frequency resources on the available bandwidth, and their individual communications are channeled using these codes. The code tag then identifies the conversation to the transmission station. All users in a cell that are transmitting at the same time are thus employing the same frequency band for their transmission.

CDMA combines voice and data into a single digital transmission at 9.6 Kbps, although speeds up to 19.2 Kbps per channel are possible by using error detection and correction techniques.

NOTE

Without knowledge of a conversation’s code tag, eavesdropping on CDMA conversations is difficult, making CDMA a more secure cellular phone technology than the Advanced Mobile Phone Service (AMPS) still used widely in the United States. CDMA also has a much higher call capacity than AMPS and is comparable to the Global System for Mobile Communications (GSM) standard for cellular communication used in Europe.

On the Web
•
CDMA Development Group
: http://www.cdg.org
See also
cellular phone technology

code-operated switch

A switch with a combination of input and output ports, the connections between which can be remotely reconfigured by commands entered into a computer. Code-operated switches are useful in environments where remote switching is needed for file-sharing or monitoring purposes. For example, you could use an RS-232 serial code-operated switch to remotely switch between pieces of data terminal equipment (DTE), such as servers or routers for running diagnostics from a remote console.

Graphic C-21. Code-operated switch.
Graphic C-21. Code-operated switch.
How It Works

Internal dual inline package (DIP) switches are usually used to configure the code-operated switch so that a different arming character can be used to trigger each connected device. The code-operated switch then examines the incoming data stream for these special text-string codes in order to determine to which device it should route data. An example might be the remote switching between printers. A remote computer could send an embedded switching character to specify which printer connected to the code-operated switch should be used for printing the data.

A remote user can connect to the company network using a modem that interfaces with a code-operated switch, and then use the switch to control a variety of serial-controlled devices in an industrial environment, such as a group of laboratory instruments. Code-operated switches are available from different vendors in configurations supporting up to 64 different serial devices from one remote connection.

Besides embedding switching characters in the data stream, embedded control characters can also be used to directly control the code-operated switch.

See also
switch

cold boot

Restarting the computer by turning the power switch off and then on, or by shutting down the computer, turning it off, and then turning it on again. If you perform the first type of rebooting, open files will not be properly closed and data can be lost. However, this method ensures that memory is cleared and devices are properly reset. An example might be when you reconfigure the settings of a legacy modem using the modem utility in Control Panel. You might find that you must cold boot your machine in order for the new configuration settings to fully take effect.

See also
boot

Collaboration Data Objects (CDO)

A Microsoft object library that provides messaging capability for applications written in Microsoft Visual Basic, Microsoft Visual C++, and Win32 Virtual Machine for Java. Collaboration Data Objects (CDO) provides distributed Web applications with a standard way to quickly and easily create, send, post, receive, read, and manipulate messages using interfaces based on standard Internet protocols such as Simple Mail Transfer Protocol (SMTP), Network News Transfer Protocol (NNTP), and Multipurpose Internet Mail Extensions (MIME). CDO 2 is included with Internet Information Server (IIS) version 4 and with the Microsoft Windows 2000 operating system platforms to support the built-in SMTP and NNTP services.

CDO 2 does not support mailboxes, but it does support protocol events to enable programmers to write routines that respond to incoming messages and process outgoing messages. For security reasons, CDO cannot be accessed by scripts running on Microsoft Internet Explorer.

collapsed backbone

A networking methodology in which the backbone and switching components are combined into a single device. In a traditional network, local area networks (LANs) are multipoint connections connected using a backbone cable. For example, in a building, a fiber-optic backbone might run from floor to floor and connect with a hub in a wiring closet on each floor. In contrast, collapsed backbones make use of centralized switches, which provide virtual point-to-point connections for LAN connections; these switches are located in one place.

Therefore, instead of having a hub for each floor located in that floor’s wiring closet, a set of stackable Ethernet switches would be located in the wiring closet of a single floor, with individual cables running from this closet to stations in work areas on every floor.

The advantages of using a collapsed backbone are that they eliminate the costs of backbone cabling installation, they require fewer devices, their equipment administration is more centralized, and they offer higher available bandwidth for each station. The disadvantages are that collapsed backbones generally are not feasible for use in more than one building, they require more cabling, they use more expensive devices, and they have a more limited distance capability.

See also
backbone

collision domain

A Carrier Sense Multiple Access with Collision Detection (CSMA/CD) network where a collision will occur if two computers attempt to transmit signals at the same time. The larger the collision domain of an Ethernet network, the more computers present and the higher the probability of collisions occurring and negatively affecting network performance.

NOTE

If two hubs are connected directly to a third hub, the resulting local area network (LAN) is still only a single collision domain, since only hub connections are used between segments of the network. But if the two hubs are directly connected to an Ethernet switch, you have two collision domains because the switch enables the two networks to function independently. Bridges and routers can also segment Ethernet networks into smaller collision domains.

collision in computer networking

In computer networking, a condition that occurs when two or more computers on a network try to transmit signals at the same time. Handling collisions is one of the main functions of a networking access method. For example, in Ethernet networks, collisions often occur when two or more stations attempt to place frames on the wire at the same time. To handle this situation, Ethernet makes use of the access method called Carrier Sense Multiple Access with Collision Detection (CSMA/CD) so that each station takes turns accessing the wire.

How It Works

When a station begins transmitting a signal and detects a collision, the station stops transmitting and issues a jam signal to tell the other station that a collision has occurred. Both stations then stop transmitting and wait a random interval of time before retransmitting their signals. The amount of time the stations wait before retransmitting increases with the number of collisions occurring on the network.

collision in Windows 2000

In Microsoft Windows 2000, a condition that can occur during the replication of information in Active Directory. Because Active Directory uses a multimaster replication system, it is possible for multiple changes to be made simultaneously to the same object within Active Directory by users accessing different domain controllers.

How It Works

To minimize collisions, Active Directory records and replicates all updates to directory objects only at the property or attribute level. This allows different properties of the same object to be simultaneously modified without the worry of a collision occurring. However, if two users modify the same property of an object simultaneously, a collision occurs. Using the time stamps and property version numbers for the property that was changed, Active Directory determines which update to the property has the later time stamp and uses this information to update itself.

COM

See
Component Object Model (COM)

COM+

An extension of Microsoft’s Component Object Model (COM) that builds on COM’s integrated services and features in key areas, including

  • Dynamic load balancing, which distributes client requests across multiple equivalent COM components

  • In-memory database (IMDB), which provides quicker data access to applications by lowering overhead

  • Publish and subscribe services, which provide an event mechanism enabling multiple clients to subscribe to published events and send notification to subscribers when events are fired

  • Queued components, which let clients invoke methods on COM components using an asynchronous model for increased reliability over poor network connections and in disconnected usage scenarios

  • Integration of Microsoft Transaction Server (MTS) into COM, which supports attribute-based programming, improvements in transactions, security and administration services, and improved interoperability with other transaction environments through support for the Transaction Internet Protocol (TIP)

COM component

A compiled software component that is based on Microsoft’s Component Object Model (COM) technology. COM components generally refer to the physical files that contain the classes that define COM objects. COM components also include additional code, such as code to register the component in the registry and code for loading the component.

COM components can be written in many languages using tools such as Microsoft Visual Basic, Microsoft Visual J++, Microsoft Visual C++, and Microsoft Visual FoxPro. COM components can be run on an application server, a Web server, a Microsoft Transaction Server (MTS), or a client. COM components can be stand-alone applications or reusable software components, and they make the development of Web applications comparable to the development of system applications.

How It Works

COM components interact with each other and with user applications in a client/server fashion. The client therefore uses the functionality of the server component by creating instances of classes that the server component provides and calling their properties and methods.

COM components can be designed to run in three different modes:

  • In-process:
    The component executes in the calling application’s process space.

  • Local:
    The component executes in its own process space.

  • Remote:
    The component executes in a process space on another machine.

An in-process COM component has the extension .ocx or .dll, while an out-of-process COM component (one running outside the calling application process) has the extension .exe. COM components can run on another machine in a manner transparent to the calling application by using the Distributed Component Object Model (DCOM).

TIP

When developing applications based on COM components, use in-process components to optimize the speed of object access, but use out-of-process components to maximize thread safety.

NOTE

COM components that support Automation can be called by scripting languages such as Microsoft Visual Basic Scripting Edition (VBScript) or Microsoft JScript.

Graphic C-22. In-process, local, and remote COM components.
Graphic C-22. In-process, local, and remote COM components.
See also
Automation, COM object, Component Object Model (COM)

command

A method by which actions can be performed on a computer running Microsoft Windows by typing text into a command prompt window. The commands that are available depend on which version of Windows is used.

Examples of commands common to most Windows platforms include the attrib command, cacls command, copy command, dir command, and diskcopy command. In addition to these Windows commands, some special commands are available only when certain networking services or protocols are installed. For example, if TCP/IP is installed on a computer running Windows, a number of TCP/IP commands are available, including the arp command, ping, tracert, and nbtstat.

Commands are useful for administering different aspects of a system or network using a command-line interface, such as a telnet connection or a command prompt. Commands are also often used in writing batch files that can perform a group of operations on a system or network service. You can run such a batch file directly, or you can schedule its operation for a predetermined time.

Finally, many Windows programs can be started in different ways from the command prompt using optional switches. For example, Windows Explorer can be run by typing explorer.exe from the command prompt. These programs are normally run using a graphical user interface (GUI), are started by desktop shortcuts, and are not usually referred to as commands.

command interpreter

A text-based interface to a computer operating system. Users type text commands into the command interpreter in order to execute various routines and manage system and networking resources. Traditional UNIX systems make heavy use of the command interpreter, and MS-DOS, the legacy Microsoft operating system, used a command interpreter to process text-based commands to control operating system processes.

On systems based on Microsoft Windows, users can still open a command prompt to issue various text-based commands for controlling different aspects of the system, but these commands represent only a subset of the full functionality of the GUI-based administration tools available on Windows platforms.

The command interpreter is sometimes referred to as the operating system shell, especially on UNIX platforms. Entering a command into the command interpreter is referred to as “working at the command line.”

command line

See
command prompt

command prompt

A Microsoft Windows application that allows Windows commands to be entered and executed. The command prompt provides a command-line interface for running certain operating system tasks, configuring networking services, and even accessing resources and applications over the network. Much administration can be performed from the command prompt, although the command prompt provides a more complex and less intuitive interface than the usual desktop graphical user interface (GUI) of Windows operating systems. However, administrators who have spent significant time working in UNIX networking environments might find the command prompt a more familiar paradigm for administering a Windows-based network.

Graphic C-23. Command prompt.
Graphic C-23. Command prompt.
NOTE

In Windows NT and Windows 2000, the command prompt application is cmd.exe, located in the %SystemRoot%\system32 folder. In Windows 95 and Windows 98, it is called the MS-DOS prompt, has the executable filename command.com, and is in the \Windows folder. The Windows NT version can be configured using the Console utility in Control Panel.

commercial service provider (CSP)

Internet service providers (ISPs), online service providers, telephone and cable network operators, and other companies that provide software services such as community access to mail, news, chat, and conferencing services. By utilizing these services of a CSP, customers don’t have to acquire licenses for the software the CSP provides.

Common Desktop Environment (CDE)

A graphical user interface (GUI) developed by IBM, Sun Microsystems, and Hewlett-Packard for open systems on UNIX platforms. Common Desktop Environment (CDE) is a paradigm that is widely used in the UNIX industry. CDE is based on various industry standards including the X Window System (X11) release 5, X/OPEN, OSF/Motif 1.2, and others.

CDE is designed to provide users with a simple and consistent desktop interface that includes

  • Standard windows-management features

  • File-system browsing tools supporting multiple views

  • Customizable user interface–management tools for changing backdrops, mouse and keyboard settings, and screen savers

  • Extensive and easily accessed online help features

  • Multiple workspaces for increasing available desktop area

Common Gateway Interface (CGI)

A standard mechanism for communication between Web servers and server-side gateway programs that was developed in the UNIX networking environment. These gateway programs are written either in a compiled language such as C or in an interpreted language such as Perl. Common Gateway Interface (CGI) allows Web servers to run scripts or programs on the server and send the output to the client Web browser.

How It Works

When a Web client such as Microsoft Internet Explorer submits a form or otherwise passes information to a Web server using CGI, the Web server receives the information from the client and passes it to the gateway program for processing. The gateway program then returns the result of the processing to the server, which returns it to the Web browser as an HTML page.

CGI applications are often used as form handlers for Web forms, and are executed using a <FORM> tag embedded in the form document, as in the following:

<FORM METHOD=POST ACTION=
"http://www.northwind.microsoft.com/cgi-bin/results.pl">

In this example, the Perl script results.pl in the cgi-bin directory functions as the form handler for processing the information submitted using the form.

NOTE

CGI was developed for UNIX-based systems and is supported by most Web servers, including Internet Information Services (IIS). Microsoft Internet Server API (ISAPI) is a set of server extensions for IIS that functions similar to those of CGI but uses fewer resources. The main difference is that with CGI the system creates a unique process for every CGI request, while ISAPI extensions do not require separate processes. This makes ISAPI applications generally more responsive than CGI applications.

Common Information Model (CIM)

An emerging standard from the Distributed Management Task Force (DMTF), formerly named the Desktop Management Task Force, for an extensible, object-oriented schema for managing information collected from computers, networking devices, protocols, and applications.

How It Works

The Common Information Model (CIM) defines a set of schema for describing information collected for network and systems management purposes. The type of information that can be described by CIM can include

  • Static information, such as the capacity of a hard drive on a desktop computer or the applications installed on a server

  • Dynamic information, such as the current bandwidth being used on a port on a switch or router

Information that is collected can be shared between systems on a peer-to-peer basis. This information sharing allows network devices to not only be managed from a centralized management console but also to talk to one another to resolve problems as they arise.

CIM is based on an object-oriented programming model, in which inheritance causes subclasses to acquire characteristics from their parent classes. CIM is extensible and allows vendors to define the features of their products using inherited subclasses. The fact that these subclasses are inherited from standard parent classes ensures that data collected from different vendors’ systems will be compatible with the CIM standard.

CIM consists of two parts: a language definition specifying the constructs and methods that can be used to model network and system resources, and a set of schema that describes how specific types of resources will be represented.

CIM allows three kinds of schema:

  • Core schema, which define general areas of network and system management

  • Common schema, which define specific areas of management

  • Extension schema, which define the management of vendor-specific technologies

CIM is similar to the Simple Network Management Protocol (SNMP) and Desktop Management Interface (DMI) standards. However, unlike SNMP and DMI, CIM has the ability to manage the widest possible range of hardware and software systems. CIM also shows the relationships between the different hardware and software components of an enterprise network more completely, making it easier to troubleshoot complex distributed systems and applications.

TIP

Microsoft Systems Management Server (SMS) 2.0 is capable of collecting CIM data from managed systems and exporting this data to other enterprise management applications, such as NetView from Tivoli Systems and Unicenter from Computer Associates.

See also
Web-Based Enterprise Management (WBEM)

Common Internet File System (CIFS)

A public version of the Server Message Block (SMB) file-sharing protocol that has been tuned for use over the Internet. Common Internet File System (CIFS) is a remote file system access protocol that enables groups of users to collaborate and share documents over the Internet or within corporate intranets.

CIFS is an open, cross-platform technology that is based on the native file-sharing protocols of Microsoft Windows platforms. It is supported by other platforms such as UNIX. CIFS is viewed as a possible replacement for both the File Transfer Protocol (FTP) and the Network File System (NFS) file system protocols. CIFS supports encrypted passwords and Unicode filenames; it can be used to mount a remote file system as a directory or drive on the local machine. CIFS also includes features not supported by NFS, including write-ahead and native support for locks.

NOTE

Microsoft’s Distributed file system (Dfs) is covered as part of the CIFS specification. CIFS has been submitted to the Internet Engineering Task Force (IETF) by Microsoft. CIFS client and server software is available for the Windows NT operating system platform.

Common Object Request Broker Architecture (CORBA)

A component architecture developed by the Object Management Group and its member companies that specifies technologies for creating, distributing, and managing component programming objects over a network. Common Object Request Broker Architecture (CORBA) is designed to provide interoperability between applications in heterogeneous distributed environments.

NOTE

CORBA is not supported by Microsoft, which instead has developed its own distributed object management architecture called Distributed Component Object Model, or DCOM.

How It Works

In a CORBA environment, programs request services through an object request broker (ORB), which allows components of distributed applications to find each other and communicate without knowing where applications are located on the network or what kind of interface they use. ORBs are the middleware that enable client and server programs to establish sessions with each other, independent of their location on the network or their programming interface.

The process of a client invoking a call to an application programming interface (API) on a server object is transparent. The client issues the call, which is intercepted by the ORB. The ORB takes the call and is responsible for locating a server object that is able to implement the request. Once it has located such an object, the ORB invokes the object’s method and passes it any parameters submitted by the client. The results are then returned to the client. ORBs communicate among themselves using the General Inter-ORB Protocol (GIOP) or the Internet Inter-ORB Protocol (IIOP) so that any ORB can fulfill any client request on the network.

On the Web
•
Object Management Group
: http://www.omg.org

community

A group of hosts managed by Simple Network Management Protocol (SNMP) running SNMP agents. Communities provide a simple way of partitioning and securing a network for SNMP management. SNMP agents and management systems use community names as the mechanism for authenticating SNMP messages. All SNMP agents belonging to the same community share the same community name, which functions as a kind of shared password for those agents so that they can be recognized by the SNMP management program and other agents. SNMP messages sent by SNMP management systems to a specific community are accepted only by hosts configured to belong to that community. If an SNMP agent program receives an SNMP message with a community name that it is not configured to recognize, it typically drops the message and sends a trap message to the SNMP management program indicating that a message was not authenticated on that machine.

NOTE

An agent can be a member of one or more communities. By default, all agents belong to the public community. If all community names including public names are removed from an SNMP-managed host, the host will accept all SNMP messages sent to it.

COM object

An instance of a class that is based on Microsoft’s Component Object Model (COM) technology. A COM object encapsulates functionality, which is accessed through COM interfaces. Every COM object supports at least two interfaces, IUnknown and one or more interfaces that implement the functionality of the COM object.

Graphic C-24. A client accessing a COM object.
Graphic C-24. A client accessing a COM object.
See also
COM component, Component Object Model (COM)

compact command

A Microsoft Windows NT and Windows 2000 command used to compress or uncompress files and folders on an NTFS volume. The compact command can be used to display the compression status of a file or directory, or to change that status. If a compression action is interrupted, resulting in a partially compressed file that is unreadable, you can use the compact command with the /f switch to force the full compression of the file. The command supports multiple filenames and wildcards.

Example

compact /c /s compresses all files in the current directory and its subdirectories. For the full syntax of this command, type compact/? at the command prompt.

comp command

A Microsoft Windows command for performing a bytewise comparison of the contents of different files. The comp command is typically used for byte-by-byte comparison of text files, or for a comparison of the contents of two directories.

Example

To compare C:\file1.txt and C:\file2.txt and show the differences between them as characters, type the following:

comp C:\file1.txt C:\file2.txt /a

You can also use wildcards to specify multiple files. For the full syntax of this command, type comp/? at the command prompt.

complete trust model

A domain model in Microsoft Windows NT in which every domain trusts every other domain with two-way trusts. The complete trust model is rarely implemented in Windows NT–based networks unless the motivation for using Windows NT is being driven from the bottom up. For example, if a number of individual departments start implementing domains, the company might soon find itself implementing the complete trust model in order to make administration of these domains more efficient. This model also might be used in a situation in which two companies using Windows NT merge into a single company. Because of the large number of trusts in a complete trust model, there are additional security concerns about who is able to administer what. The following table outlines the pros and cons of using this domain model.

Advantages and Disadvantages of Using the Complete Trust Model
Advantages | Disadvantages
Scalable to any number of user accounts. | Complex to set up and administer.
Suitable for merging companies or organizations with no central MIS department. | Multiple local groups must be created in each resource domain.
NOTE

When you upgrade a Windows NT network based on the complete trust model to a Windows 2000 network, you can maintain the relative independence of each domain by migrating each domain to be the root domain of a domain tree. Each domain tree would have a single domain, namely the root domain. Two-way transitive trusts can then be established between the trees to form a domain forest.

Graphic C-25. Shown for Windows NT.
Graphic C-25. Shown for Windows NT.
See also
multiple master domain model, single domain model, single master domain model

Component Object Model (COM)

As defined by Microsoft, the Component Object Model (COM) is an object-based software architecture that allows applications to be built from binary software components. COM is the foundation for various Microsoft technologies including OLE, ActiveX, Distributed COM (DCOM), COM+, and Microsoft Transaction Server (MTS).

COM is not a programming language, rather it is a specification. The goal of COM is to allow applications to be built using components. These COM components can be created by different vendors, at different times, and using different programming languages. Also, the COM components can run on different machines or different operating systems.

The following concepts are fundamental to the way COM works:

  • COM Interfaces:
    A group of related functions implemented by the COM class. COM interfaces are the mechanisms by which COM objects expose their functionality to applications and other components. An interface is a table of pointers to functions that are implemented by the object. The table represents the interface, and the functions to which the table points represent the methods of that interface. COM objects can expose multiple interfaces. Each interface has its own unique interface ID (IID).

  • IUnknown:
    This is the basic COM interface on which all other interfaces are based; it provides reference counting and interface querying mechanisms. IUnknown allows navigation to all other interfaces exposed by the object.

  • Reference counting:
    This is a mechanism by which an interface determines it is no longer being used and is therefore free to remove itself. IUnknown uses the methods AddRef and Release to implement reference counting.

  • QueryInterface:
    This is the IUnknown method used to query an object for a given interface.

  • Aggregation:
    This is a technique by which one object can make use of another.

  • Marshaling:
    This mechanism lets objects be used across thread, process, and network boundaries, thus providing location independence.

On the Web
•
Microsoft COM home page
: http://www.microsoft.com/com
See also
ActiveX component, COM component, COM object, Distributed Component Object Model (DCOM), Microsoft Transaction Server (MTS), OLE

Component Services

See
Microsoft Transaction Server (MTS)

Compression Agent

A Microsoft Windows 98 system tool for selectively compressing files using settings that you specify. Compression Agent allows you to save disk space by archiving less frequently accessed files. Using Compression Agent, you can improve the performance of access to compressed drives by modifying the level of compression used. Specifically, you can decide whether you want the selected files to be compressed and whether standard, HiPack, or UltraPack compression format should be used. UltraPack compression is available in Compression Agent but not in the DriveSpace 3 utility, and is normally used only for archiving files that are not frequently accessed. Compression Agent can either be started manually, or scheduled using Task Scheduler or the Maintenance Wizard. Compression Agent can also be run from the command prompt using the cmpagent command.

NOTE

You can use Compression Agent only on drives that have been compressed using DriveSpace 3.

CompTIA

See
Computing Technology Industry Association (CompTIA)

computer account

An account in the Security Accounts Manager (SAM) database of a Microsoft Windows NT domain controller (or in Active Directory of Windows 2000) that signifies that a particular computer is a part of a Windows NT or Windows 2000 domain. Windows NT and Windows 2000 domain controllers can store three types of accounts: user accounts, group accounts, and computer accounts.

How It Works

Computer accounts are used by Windows NT and Windows 2000 to determine whether a particular system that a user is employing to attempt to log on to the network is part of the domain. When the NetLogon service running on a client computer connects to the NetLogon service on a domain controller in order to authenticate a user, the NetLogon services challenge each other to determine whether they both have valid computer accounts. This allows a secure communication channel to be established for logon purposes.

In order for a Windows NT server or workstation to join a domain, the machine must have a computer account created for it in the SAM database. There are two ways to create this account:

  • Use Server Manager in Windows NT or Active Directory Users and Computers in Windows 2000 to create a computer account for the machine, and then have the machine join the domain.

  • Use an administrator account to create a computer account while installing Windows NT or Windows 2000 on the server or workstation.

On Windows NT, make sure there are no open sessions with the domain’s Primary Domain Controller (PDC) before having a machine join a domain.

NOTE

Machines running Windows 95 and Windows 98 can participate in domain authentication, but they do not have computer accounts in the domain directory database. This is why the logon box for a Windows 95 or Windows 98 machine has a hard-coded domain name and can log on to only one domain. The logon box for a Windows NT machine, however, has a drop-down list that lets you select which domain you want to log on to, provided there are suitable trust relationships established between domains on the network.

TIP

If you reinstall Windows NT or Windows 2000 on a machine, you must delete the old computer account and create a new computer account, even if the machine has the same name as before.

Computer Browser service

A service in Microsoft Windows NT and Windows 2000 responsible for enabling the browsing of network resources using Network Neighborhood and Windows Explorer. A Computer Browser service simplifies the user task of locating and accessing network resources by eliminating the need for users to remember Universal Naming Convention (UNC) paths or other network syntax, and by eliminating the need for all computers on the network to maintain their own list of all available network resources.

Graphic C-26. Computer Browser service.
Graphic C-26. Computer Browser service.
How It Works

The Computer Browser service maintains a distributed series of lists called browse lists that contain information about shared resources available on the network. Different computers on the network have different roles. These computers include the following:

  • Domain master browser:
    Collects and maintains the master browse list for the domain, and synchronizes this list with other domain master browsers in different domains. In a Windows NT network, the domain master browser must be the Primary Domain Controller (PDC).

  • Master browser:
    Collects and maintains the master browse list for the domain and distributes this list to backup browsers in the domain. This can be a computer running Windows 2000, Windows NT, Windows 95, Windows 98, or Windows for Workgroups.

  • Backup browser:
    Maintains copies of the browse list received from the master browsers and distributes this list to any network client requesting a network resource. This can be a computer running Windows 2000, Windows NT, Windows 95, Windows 98, or Windows for Workgroups.

  • Potential browser:
    Any computer on the network configured so that it can assume the role of a master browser or backup browser if required. This can be a computer running Windows 2000, Windows NT, Windows 95, Windows 98, or Windows for Workgroups.

  • Nonbrowser:
    Any computer that cannot be a browser but can share resources with the network.

When a client tries to access a shared resource on the network, such as a shared folder on a file server, it first contacts the master browser for a list of backup browsers. Then it contacts a backup browser for a copy of the browse list. Once the client has the browse list, it contacts the file server for a list of shares, and then connects to the desired share.

NOTE

The Workstation service and Server service must be started for the Computer Browser service to function.

TIP

The Computer Browser service uses broadcast packets. To browse on a TCP/IP internetwork consisting of multiple subnets separated by routers that do not forward broadcast, implement Windows Internet Name Service (WINS) on the network, with the domain master browser configured as a WINS client (not a WINS server). This configuration will ensure that the domain master browser will have a browse list with the resources on all subnets in the internetwork, including those spanned by other Windows NT domains.

You can also modify the MaintainServerList entry in the Windows NT registry to enable or disable a Windows NT machine as a backup browser or potential master browser, and the IsDomainMaster entry to force a machine to become the domain master browser. Both of these registry entries are found under HKEY_LOCAL_MACHINE\SYSTEM\ControlSetxxx \Services\Browser\Parameters.

See also
browse list, browser election, browsing

Computer Management

A Microsoft Windows 2000 Server management console that provides a single integrated desktop tool for managing local and remote machines. Computer Management combines a number of administrative utilities from Windows NT with additional Windows 2000 tools to provide an easy way of viewing and managing properties of any computer running Windows 2000 on the network. Using Computer Management, an administrator can perform the following actions on local and remote machines:

  • Create and manage shares

  • Display a list of connected users

  • Manage services such as Dynamic Host Configuration Protocol (DHCP) and Domain Name System (DNS)

  • Start and stop system services

  • Configure properties of storage devices

  • Monitor system events and application errors

  • Display device settings and add new device drivers

    Graphic C-27. Computer Management.
    Graphic C-27. Computer Management.
TIP

To use Computer Management for modifying administrative settings, you must be a member of the Administrators group.

computer name

For computers running Microsoft Windows, a name that identifies a computer on the network. Computer names can be up to 15 characters in length. In Windows NT, Windows 95, and Windows 98, you specify a computer’s name using the Network utility in Control Panel. (In Windows 2000, use the Network Identification tab of the System utility in Control Panel.) The computer must be restarted if its name is changed. This name is used by services that perform NetBIOS name resolution on the network, such as the Windows Internet Name Service (WINS). Computer names provide a friendly way of accessing network resources without having to remember complex numerical addresses such as IP addresses.

NOTE

A hidden sixteenth character is appended to the computer name to form the NetBIOS name for NetBIOS-aware networking services on the machine. Each NetBIOS-aware service has a different NetBIOS name, some of which are based on the name of the computer and others of which are based on the name of the domain in which the computer resides.

TIP

Give friendly names, derived from some common source such as “A Midsummer Night’s Dream,” to groups of computers offering related services. For example, you could call your servers Puck, Oberon, and so on. This makes it easy to remember that these computers all belong to the same group.

computer-telephony integration (CTI)

A general term describing the integration of computer and telephone technologies. By joining computer systems with switched telephone services, users can access advanced functions such as automatic incoming call routing, call display, and power dialing. For example, a computer can use computer-telephony integration (CTI) to issue commands to a telephone switch to control call routing of calls.

CTI applications generally fall into one of two categories:

  • Call-control applications:
    Allow computers to dial numbers, establish conference calls, and so on. The computer essentially replaces the touch-tone telephone keypad.

  • Media-processing applications:
    Deal with more complex issues, such as voice recognition, speech synthesis, and converting fax messages to e-mail. These applications pursue the goal of completely integrated unified messaging in which voice, fax, e-mail, and video conferencing features are combined.

CTI is made possible on Microsoft Windows platforms by operating system application programming interfaces (APIs) such as Microsoft’s Telephony Application Programming Interface (TAPI). The range of products and technologies that support CTI continues to evolve. Cross-platform, vendor-neutral standards have not yet been established.

Computing Technology Industry Association (CompTIA)

A computer industry trade association formed in 1982. The Computing Technology Industry Association (CompTIA) currently has more than 7500 members. CompTIA membership includes resellers, VARs, distributors, manufacturers, and training companies in the United States and Canada. The goals of CompTIA are to foster professional competence and business ethics among its members and throughout the computer industry. CompTIA provides its members with educational opportunities, a professional network, and a forum for the development of ethical, professional, and business standards in the computing industry. A number of committees meet to consider issues such as software licensing and electronic warranty forms.

On the Web
•
CompTIA home page
: http://www.comptia.org

COMTI

See
COM Transaction Integrator (COMTI)

COM Transaction Integrator (COMTI)

A component of Microsoft SNA Server version 4 that provides client applications with access to two popular mainframe transaction processing (TP) environments, Customer Information Control System (CICS) and Information Management System (IMS).

How It Works

COM Transaction Integrator (COMTI) works in conjunction with Microsoft Transaction Server (MTS), making CICS and IMS programs appear as MTS components that can be used with other MTS components to build distributed applications. COMTI includes both a Microsoft Windows NT Server run-time environment and a development tool called Component Builder, which can import mainframe COBOL code and automatically generate an object compatible with MTS. This lets developers program in the visual, object-oriented environments they are accustomed to, allowing them access to host transactions without needing to learn the intricacies of SNA.

concurrency

A term referring to the simultaneous access to a network resource by more than one client. Concurrency is an important issue in the licensing of a server operating system or application. For example, the Per Server licensing mode for Microsoft Windows NT Server is based on concurrency. If you purchase 10 client access licenses (CALs) for your Windows NT Server, a maximum of 10 concurrent connections can legally be formed with that server for accessing network resources.

NOTE

Some products, such as Microsoft Outlook 98, do not support concurrent access. In other words, you cannot install a central copy of Outlook 98 on a server and have thin clients run this program from the centralized location. Instead, you must install one copy of Outlook 98 on each client that needs to run it.

config.sys

A text file used by MS-DOS and 16-bit versions of Microsoft Windows that is used to configure computer hardware at startup. The config.sys file is used to configure a machine’s memory, keyboard, mouse, printer, and other peripherals. The config.sys file is an ASCII file that can be edited with any text editor. A typical config.sys file includes commands such as device, lastdrive, and dos. Device commands are used to load device drivers for different hardware, such as the extended memory driver himem.sys. Lastdrive specifies the highest available drive letter. Dos allows you to load MS-DOS into the high memory area and to give programs access to the upper memory area.

After the config.sys file’s commands are executed, the autoexec.bat file is executed. Windows 95 and Windows 98 also include a config.sys file, but it is present only for backward compatibility with 16-bit Windows applications running under Windows 95 or Windows 98.

NOTE

If a config.sys file exists in the boot partition on a computer running Windows NT, it will be parsed at startup.

connected network (CN)

In Microsoft Message Queue (MSMQ) Server terminology, a name for a collection of computers in which any two computers can directly communicate. Computers in the same connected network must be running the same network protocol. A connected network (CN) is essentially a label describing how MSMQ servers are related in an enterprise. CNs are logical groupings of computers that can communicate directly using MSMQ messages. When you install an MSMQ server, you specify a connected network for each network address on the server.

TIP

When you specify connected networks for your MSMQ enterprise, it’s a good idea to use meaningful labels so that administrators can easily select a connected network from a list when they need to override the default connected network settings.

connection

A link between two computers for the purpose of exchanging information. An example would be a Microsoft Windows NT Workstation, Windows 95, or Windows 98 client computer accessing a shared folder or printer on a Windows 2000 server. The term “connection” is also used to describe the establishment of communication over a WAN link, as in using a dial-up connection over a modem.

NOTE

When a client computer tries to connect to a server, the success or failure of the attempt can depend upon whether

  • The server has shared the resource that the client wants to connect to

  • The client has been properly authenticated or has permission to access the resource

  • The client is properly licensed to connect to the server, and free licenses are available

TIP

When a Windows NT Workstation client receives the message “No more connections can be made at this remote computer at this time because there are already as many connections as the computer can accept,” or a Windows 95 or Windows 98 client receives the message “This request is not accepted by the network, try again later,” it means the client is being denied a connection to the Windows NT server. Possible reasons might include the following:

  • The User Limit setting (on the Sharing tab of the folder’s property sheet) has been exceeded.

  • Your network uses Per Server licensing, and all licenses are currently allocated to connected users.

See also
client access license (CAL), license

connectionless protocol

Any transport layer protocol that relies on broadcast packets instead of directed packets. Connectionless protocols cannot guarantee delivery of packets. Instead, reliability of packets is handled by the application itself or some higher layer of the protocol stack.

An example of a connectionless protocol is the User Datagram Protocol (UDP), which is part of the TCP/IP protocol suite. UDP provides connectionless services for delivering small packets of information commonly called datagrams. Connectionless protocols can only offer “best-effort” delivery and cannot guarantee that packets will arrive in the correct order or even at all. In Microsoft Windows NT, connectionless protocols such as UDP are used in services such as the NetBIOS name service and the Simple Network Management Protocol (SNMP) service.

See also
connection-oriented protocol

Connection Manager Administration Kit (CMAK)

A wizard-based tool for creating custom connectivity solutions, and a component of Internet Connection Services for Microsoft Remote Access Service (RAS). The Connection Manager Administration Kit (CMAK) is used to customize the Microsoft Connection Manager (CM) client component. Internet service providers (ISPs) can use this tool to customize dial-up installation packages for their customers. Customization features include

  • Animated logon screen, which can include a custom logo

  • Desktop icons

  • The language the dialer displays to the customer

  • Support numbers and help files

  • Various connect actions that the dialer performs when dialing, such as shutting down applications or downloading files

connection-oriented protocol

Any transport layer protocol that establishes a connection in order to reliably send packets over the network. Connection-oriented protocols guarantee delivery of packets by making use of acknowledgments and retransmission of data. Connection-oriented protocols are used primarily for reliable delivery of large packets of data, as opposed to the unreliable connectionless protocols that are used to deliver small datagrams.

An example of a connection-oriented protocol is the Transmission Control Protocol (TCP), which is part of the TCP/IP protocol suite. The TCP protocol uses a TCP three-way handshake to establish a connection between two hosts on a network. During session establishment, the hosts negotiate the TCP window size, segment size, and other information needed to ensure reliable and efficient communication. A TCP connection is terminated using a similar handshake procedure.

See also
connectionless protocol

Connection Point Services (CPS)

A component of Internet Connection Services for Microsoft Remote Access Service (RAS) that provides users with a central location for managing and distributing network access numbers. Connection Point Services (CPS) will automatically check a subscriber’s phone book and download updates if required. CPS can also be used to merge a corporate phone book of network access numbers with phone books from an Internet service provider (ISP).

CPS has two components:

  • Phone Book Service:
    Downloads a phone book by comparing the phone book on the subscriber’s computer with those in the CPS database. This ensures that subscribers always have an up-to-date directory of network access numbers.

  • Phone Book Administrator:
    Creates new phone books or edits existing ones. You can create and maintain multiple phone books, both public and private, and post phone book information to the Phone Book Service.

connection pooling

A technique for optimizing Active Server Pages (ASP) applications running on Internet Information Server (IIS) version 4. Connection pooling allows more efficient implementation when connecting ASP front-end applications to a back-end database.

How It Works

Connection pooling involves the pooling of open database connectivity (ODBC) connections to reduce the frequency at which ODBC connections need to be opened and closed on heavily accessed servers. Connection pooling improves ASP performance for ODBC-enabled Web applications and provides a graceful way to manage connection timeouts.

To use ODBC connection pooling on IIS, perform the following steps:

  1. Configure the database driver using ODBC in Control Panel.

  2. Enable connection pooling in the Microsoft Windows NT registry.

  3. Open individual connections in your Microsoft ActiveX Data Objects (ADO) code right before data access is needed for an ASP page, and release connections as soon as the data has been accessed.

Once connection pooling is enabled, the ODBC driver will check the connection pool for idle connections it can reuse before creating a new connection in response to an ODBC request. When connections are released, they are returned to the connection pool instead of being closed.

TIP

You can control the amount of time an idle connection remains in the pool using the CPTimeout registry setting, which by default is set to 60 seconds.

connectivity server

A computer running Microsoft Exchange Server that is dedicated for routing messages to other sites and foreign mail systems using Exchange connectors. Large companies often require servers that are dedicated to message routing because of the high volume of message traffic they experience. In a typical high-volume site configuration, one server might be optimized as a home server for users’ mailboxes, another server for dedicated public-folder replica hosting, and a third for providing dedicated messaging connectivity with other sites and foreign messaging systems. A connectivity server can have one or more connectors installed on it to provide connectivity with Exchange sites, Simple Mail Transfer Protocol (SMTP) hosts, X.400 messaging systems, or Microsoft Mail postoffices. The more connectors you have on a server, the greater its hardware requirements become.

TIP

Run the Performance Optimizer wizard once you have installed your connectors on the Exchange server. This will allow your server to take maximum advantage of its particular hardware configuration.

connector (device)

A device that terminates a segment of cabling or provides a point of entry for networking devices such as computers, hubs, and routers. Connectors can be distinguished according to their physical appearance and mating properties, such as jacks and plugs (male connectors) or sockets and ports (female connectors). They can also be distinguished by their different pinning configurations, such as DB9 and DB15 connectors, which have 9 and 15 pins, respectively. In addition, connectors are distinguished by the kind of electrical interfaces they support. Examples of different types of connectors include

  • Connectors for serial interfaces, such as RS-232 and V.35

  • Ethernet connectors, such as RJ-45 and BNC connectors

  • Fiber-optic cabling connectors, such as SC and ST connectors

There are literally dozens of types of connectors used in networking, and the networking professional needs to be familiar with many of them. The illustration shows some of the common connector types used in different aspects of networking and telecommunications.

Graphic C-28. Common networking and telecommunications connectors.
Graphic C-28. Common networking and telecommunications connectors.

Connector for Lotus cc:Mail

A component of Microsoft Exchange Server that enables message transfer and directory synchronization between Exchange Server and Lotus cc:Mail systems. Lotus cc:Mail uses a shared-file messaging architecture similar to that of Microsoft Mail. The Connector for Lotus cc:Mail is implemented as a Microsoft Windows NT service on Exchange Server and supports

  • Message transfer between Exchange Server and cc:Mail messaging systems

  • Synchronization of directory information between Exchange Server and cc:Mail servers

The Connector for Lotus cc:Mail can be used to provide connectivity with database versions 6 or 8 cc:Mail postoffices.

NOTE

Only one Connector for Lotus cc:Mail can be installed on a given computer running Exchange Server, and that connector can connect to only one cc:Mail postoffice. However, multiple computers running Exchange Server can each have a cc:Mail connector installed in order to connect to multiple postoffices throughout a cc:Mail messaging system. The Lotus cc:Mail programs export.exe and import.exe must be installed on the computer running Exchange Server for connectivity to be established.

Connector for Lotus Notes

A component of Microsoft Exchange Server that enables message transfers and directory synchronization between Exchange Server and Lotus Notes systems. The Connector for Lotus Notes allows either single or multiple Lotus Notes servers to be accessed from a single machine running Exchange Server. The Connector for Lotus Notes is implemented as a Microsoft Windows NT service on Exchange Server and supports

  • Message transfer between Exchange Server and Lotus Notes

  • Synchronization of directory information between Exchange Server and Lotus Notes

The Connector for Lotus Notes also converts message content to Rich Text Format (RTF) and converts OLE objects on Exchange Server to Lotus Doclinks objects.

NOTE

The Connector for Lotus Notes supports Lotus Notes 3.x and Lotus Notes/Domino 4.x.

TIP

Be sure to install the Lotus Notes client on the computer running Exchange Server prior to attempting to install the Connector for Lotus Notes on the machine. The connector needs this client to successfully log on to the Lotus Notes mail server. If you have trouble establishing connectivity, check that the connector has a valid Lotus Notes ID and that this ID has the appropriate permissions needed to access the databases on the machine running Lotus Notes.

connector in Microsoft Exchange Server

A component of Microsoft Exchange Server used to connect Exchange sites or to connect an Exchange organization to foreign mail systems. Connectors are components of Exchange that can be used to route messages over a messaging system. Connectors are implemented on Exchange as Microsoft Windows NT services, and can be stopped and started using the Services utility in Control Panel.

Various types of connectors can be installed on Exchange, including the following:

  • Site Connector:
    Used for establishing high-speed messaging links between different sites in an Exchange organization

  • X.400 Connector:
    Used for establishing connectivity with a foreign X.400 messaging system such as those found in different parts of Europe

  • Dynamic RAS Connector:
    Used for establishing dial-up connectivity between sites in an Exchange organization

  • Internet Mail Service:
    Used for establishing connectivity with the Internet’s Simple Mail Transfer Protocol (SMTP) messaging system

  • Microsoft Mail Connector:
    Used for establishing messaging connectivity with legacy Microsoft Mail networks

  • Connector for Lotus cc:Mail:
    Used for establishing connectivity with a foreign cc:Mail system

  • Connector for Lotus Note:
    Used for establishing connectivity with a Lotus Notes network

For more information on each of these connectors, refer to their individual entries in this work.

container in Microsoft Exchange Server

An element in the Microsoft Exchange Server directory hierarchy that can contain other objects, including containers and leaf objects. Exchange Administrator provides a hierarchical view of the resources on a computer running Exchange Server. At the root of the Exchange Server hierarchy is the organization container, which is normally named after the company itself. Beneath this container are a number of other containers, including

  • Address book views, which contains various address lists optimized for client use.

  • Folders, which contains both public folders and system folders.

  • Global Address List, which is a sequential list of all recipients in the organization.

  • Site containers, which are containers for individual Exchange Server sites. These site containers contain a hierarchy of containers and leaf objects for specific Exchange Server sites you have created.

See also
Exchange Administrator

container in Microsoft Management Console (MMC)

In Microsoft Management Console (MMC), any node in a console tree to which other nodes can be added. The usual icon for a container in MMC is the folder icon. The highest-level container in a console is the console root node. Beneath this node in the hierarchy are the top-level nodes for individual snap-ins that have been installed. Administrators who are creating new MMC consoles can create additional containers (folders) for organizing their console trees as desired.

container in Windows 2000

In Microsoft Windows 2000, an object in Active Directory that can contain other objects. Examples of containers include organizational units (OUs), domains, and local networks. Domains are the core containers for organizing the structure of Active Directory. The other kinds of objects in Active Directory are leaf objects, which cannot contain other objects.

Objects created in a container inherit the discretionary access control list (DACL) of the container itself. In other words, a child object obtains its permissions from its parent object by inheritance.

NOTE

Groups are not containers; they are security principals.

container in Windows NT

In Microsoft Windows NT, an NTFS file system object (such as a directory) that can contain other objects (such as files). Objects created in a container inherit the access control list (ACL) of the container itself. In other words, a child object obtains its permissions from its parent object by inheritance. For example, if a directory on an NTFS volume has read permission assigned to the Everyone group, any new file that you create or save in the directory will inherit the same permission. Using containers therefore simplifies the assignment of permissions to objects in the file system.

Content Advisor

A feature of Microsoft Internet Explorer that allows you to control user access to Web sites based on the content ratings of the sites. The Internet provides individuals with access to a wide variety of information, but some of this information might be unsuitable for certain viewers. For example, parents are often concerned about their children being exposed to violent or sexually explicit material on the Internet.

Content Advisor lets you control the kind of Internet content that can be accessed using Internet Explorer. This is a useful feature in corporate networks that have high-speed connectivity to the Internet, since it can be used to discourage improper use of Web browsers on employee machines, thus helping to implement a company’s acceptable use policy for the Internet. With Content Advisor, you can specify ratings settings to indicate acceptable levels of content to view with regard to sex, nudity, violence, and offensive language, and you can password-protect these settings.

NOTE

Content Advisor functions properly only with Web sites that are rated.

Content Analyzer

A tool included with Microsoft Site Server and Microsoft Site Server Express that lets Web server administrators perform content analysis and link management of Web sites. Content Analyzer can visually display the structure and integrity of a site in the form of a diagram called a Web map. Web maps allow administrators to visually examine the structure of a site and quickly identify problems, such as loops and broken links. Web maps display various Web content items using different icons and can use a variety of colors to convey different kinds of information. You can also use Content Analyzer to search Web maps for various kinds of information using predefined Quick Searches. Once you find an item of interest on a Web map, you can open your Web page editing tool directly from the Web map. You can also export Web map information into a database or spreadsheet file for further analysis.

Content Analyzer can also generate predefined site reports you can use to identify broken links and analyze the structure of Web sites. These site reports can be generated in Hypertext Markup Language (HTML) format for easy reading and evaluation, and can identify changes to the content of a site, broken links, and other information.

content caching

A function of a proxy server such as Microsoft Proxy Server. Content caching allows a proxy server to cache the results of a client request. The next time a client requests the same content, it is retrieved from the cache to improve performance. Content remains in the cache for a predetermined period of time, or until the cache becomes full and old content is moved to allow new content to be cached.

Microsoft Proxy Server makes use of distributed caching, which lets content caching take place closer to users and allows caching activity to be load-balanced across several Proxy Servers for scalability and fault tolerance. For example, within corporate intranets, caching can be moved toward the branch office and workgroup levels of the organization. For Internet service providers (ISPs), caching can be moved toward regional points of presence (POPs). Distributed caching is particularly effective for solving network bandwidth problems associated with Internet push technologies.

Microsoft Proxy Server’s distributed caching can be implemented in two ways:

  • Array-based caching:
    In this approach, an array or group of proxy servers works together and is administered as a single, logical entity. A cache array provides load balancing, fault tolerance, scalability, and ease of administration. Cache arrays can provide a higher cache hit rate than an individual proxy server because of the larger size of the virtual cache.

  • Hierarchical caching:
    In this approach, you arrange proxy servers in a hierarchy by branch office or department. Requests from clients are then forwarded up the hierarchy until the requested object is found in a proxy server’s cache.

content filter

A component of Microsoft Index Server that can read a specific document format and turn it into a stream of text characters. Content filters are an essential part of the indexing process on Index Server because they determine which types of documents can be read and indexed. Index Server includes content filters for popular file formats such as

  • ASCII text

  • Hypertext Markup Language (HTML) pages

  • Microsoft Word documents

  • Microsoft Excel spreadsheets

In addition, many third-party companies have produced content filters for their own document formats, allowing these documents to be indexed by Index Server when their content filters have been installed. Content filters also handle the presence of embedded objects in documents and recognize when a language shift occurs in a multilingual document.

contention

A condition that occurs when two or more stations on a network try to access the network media simultaneously. In other words, the stations are contending for control of the media.

There are different ways of resolving contention issues on a network. One way is to use a single station as the master or primary station that controls all communication on the network. Other devices on the network function as slave, or secondary, stations. The entire system is known as a master-slave system. The master station normally functions in transmit mode, while the slave stations operate in receive mode. The master station tells individual slave stations when they should switch to transmit mode in order to transmit information over the network. This kind of scenario is used in networks based on IBM’s Systems Network Architecture (SNA).

In Ethernet networks, the Carrier Sense Multiple Access with Collision Detection (CSMA/CD) method is used to resolve contention on the network by allowing collisions to occur, and then resolving them successfully.

content rating

A mechanism for preventing users of Microsoft Internet Explorer from viewing Web sites that contain objectionable language, violence, nudity, or sexually explicit content. These ratings are configured on the Web server on a site-by-site basis. Ratings for each category have been established at four levels of acceptable use. The Webmaster who creates the site can then include information about the levels of objectionable language, violence, nudity, or sexually explicit content present on their site. Content ratings are defined by the Recreational Software Advisory Council (RSAC). The user can configure his or her browser to a specified accessibility level for each type of content by using the Content Advisor feature of Internet Explorer.

On the Web
•
RSAC home page
: http://www.rsac.org

control message

A command sent from one Usenet host to another. Control messages are defined in the Network News Transfer Protocol (NNTP) specifications. Control messages can be issued by Usenet hosts to perform actions such as

  • Creating a new newsgroup on the host

  • Deleting a newsgroup

  • Canceling messages that have already been posted

TIP

Control messages are simple text commands. You can troubleshoot a Usenet host by using telnet to connect to port 119 and manually typing various control messages and examining their results.

Control Panel

A Microsoft Windows feature consisting of a number of utilities for configuring hardware devices and operating system services.

Graphic C-29. Windows 2000 Control Panel.
Graphic C-29. Windows 2000 Control Panel.

The following table shows some of the more common Control Panel utilities in Windows 95, Windows 98, Windows NT, and Windows 2000 and briefly describes their function. Note that some utilities are named differently in the various Windows versions, such as 32-bit ODBC for Windows NT and ODBC (32 bit) for Windows 95 or 98; these utilities are listed separately here. Note also that some Control Panel utilities are present only when additional Windows components have been installed. For example, the GSNW utility is present only when Gateway Services for NetWare has been installed. Finally, installing additional third-party software can add new utilities to Control Panel associated with that software.

Common Control Panel Utilities
Control Panel Utility | Function | Windows 95 and 98 | Windows NT | Windows 2000
32-bit ODBC | Database connectivity |  | x | x
Accessibility Options | Help for visually or motor-impaired individuals | x |  | x
Add New Hardware | Hardware installation wizard | x |  |
Add/Remove Hardware | Hardware installation wizard |  |  | x
Add/Remove Programs | Installs new software or Windows components | x | x | x
Administrative Tools | Shortcut to Administrative Tools program group |  |  | x
Console | Command prompt window |  | x |
Date/Time | Date, time, time zone | x | x | x
Desktop Themes | Configures appearance of desktop | x |  |
Devices | Startup profiles for hardware devices |  | x |
Dial-Up Monitor | Monitors RAS connections |  | x |
Display | Screen and desktop settings | x | x | x
Folder Options | Enables Active Desktop and determines how folders are displayed |  |  | x
Fonts | Installs new fonts | x | x | x
Game Controllers | Configures joysticks | x |  | x
GSNW | Gateway Services for NetWare |  | x | x
Internet | Internet Explorer options | x | x |
Internet Options | Internet Explorer options |  |  | x
Keyboard | Style and response rate | x | x | x
Licensing | Changes licensing mode and configures replication |  | x | x
MacFile | Services for Macintosh |  | x |
Mail | Messaging profiles | x | x | x
Message Queuing | Configuration options for Microsoft Message Queue Server |  |  | x
Modems | Modem settings | x | x |
Mouse | Mouse settings | x | x | x
Multimedia | Audio/video settings | x | x |
Network | Networking clients, services, protocols, and adapters | x | x |
Network and Dial-up Connections | Creates and configures network connections |  |  | x
ODBC (32-bit) | Database connectivity | x |  |
Passwords | Configures passwords, enables remote administration, and enables user profiles | x |  |
PC Card | Settings for PCMCIA cards | x | x | x
Phone and Modem | Modem and TAPI location settings |  |  | x
Ports | COM port settings |  | x |
Power Management | Advanced power management settings | x |  | x
Power Options | Advanced power management settings |  |  | x
Printers | Adds printer wizard and manages printers | x | x | x
Regional Options | Currency and other settings for countries |  |  | x
Regional Settings | Currency and other settings for countries | x | x |
Scanners and Cameras | Configures these devices |  |  | x
Scheduled Tasks | Schedule system management tasks |  |  | x
SCSI Adapters | SCSI device settings |  | x |
Server | Server role |  | x |
Services | Starting and stopping services |  | x |
Sounds | System sounds | x | x |
Sounds and Multimedia | Audio/visual hardware/software and system sounds |  |  | x
System | Boot, file system, profiles, devices, environment, network identification, and so on (depending on the version of Windows) | x | x | x
Tape Devices | Tape drive settings |  | x |
Telephony | TAPI location settings | x | x |
UPS | Uninterruptible Power Supply settings |  | x |
Users | User profiles | x |  |

control set

Refers to a set of registry keys in Microsoft Windows NT and Windows 2000 that contains configuration information used for system startup. Control sets define certain aspects of the Windows NT boot process to allow Windows NT to boot up successfully. Up to four control set subkeys are located under the HKEY_LOCAL_MACHINE\SYSTEM registry key, including the following:

  • ControlSet001, ControlSet002, and so on, which represent backup copies of control sets that successfully started the system.

  • CurrentControlSet, which refers to the control set that was used to successfully boot the system under its current configuration. The key here is a pointer to one of the ControlSet00x registry keys.

NOTE

The Select registry key under HKEY_LOCAL_MACHINES\SYSTEM identifies which of the control set keys corresponds to the current, default, failed, and Last Known Good configurations. If the current control set can’t start the system, you can press the Spacebar when indicated during the boot process to select the last known good configuration, which is the last control set that worked for sure.

convert command

A Microsoft Windows NT and Windows 2000 command that can be used to convert a file allocation table (FAT) volume to an NTFS file system without loss of data on the volume. This conversion is one-way—you cannot convert an NTFS volume to a FAT volume using this command. The convert command cannot be used to convert the current drive. If you attempt to convert the system partition, convert is unable to lock the drive and instead schedules conversion to occur at the next reboot.

Example

convert d: /fs:ntfs converts D drive to NTFS.

For the full syntax of this command, type convert/? at the command prompt.

TIP

Always back up a FAT volume prior to converting it to NTFS.

cookie

In Internet technologies, a cookie is a text file that a Web server saves on a client machine during a Hypertext Transfer Protocol (HTTP) session. Cookies are used to record information about the client’s usage patterns, including the date and time the client visited the site, which pages were accessed, Web browser preferences, and so on. Cookies use the storage system of the client for saving this information instead of storing it on the server. Since the vast number of clients might visit the site only once, it would be inefficient to dedicate a large portion of server storage to tracking anonymous clients that might never return. Furthermore, client preferences (such as IP address) might change between sessions, especially for dial-up clients, so servers would have no way of recognizing clients if cookie information were saved on the server. Cookies therefore provide a way for the server to recognize that the client previously visited the site and record what the client did during previous visits, allowing the server to customize the HTTP session to meet the needs of the client (or the needs of the advertisers of the site!).

Cookies are harmless text files and cannot be used to transmit a virus to the client. Cookies are simply passive holders of information; they cannot be used to “get” any information off your computer (such as your e-mail address). Nevertheless, most Web browsers, such as Microsoft Internet Explorer, have an optional setting that allows users to reject cookies. However, rejecting cookies can result in poorer browsing experiences on sites that are cookie-dependent. You can also delete any cookies on a computer running Microsoft Windows by deleting the contents of the cookies subdirectory within the user profile directory on your hard drive. (Don’t delete the directory itself, however.)

copper cabling

One of the two basic types of physical cabling media (the other being glass, or fiber-optic cabling). Copper cabling is cheap and flexible, but it is susceptible to electromagnetic interference (EMI), has limited range because of attenuation, and generates electromagnetic radiation that can be intercepted by nearby equipment.

The types of copper cabling commonly used in networking include

  • Twisted-pair cabling, such as unshielded twisted-pair (UTP) cabling and shielded twisted-pair (STP) cabling

  • Coaxial cabling, such as thinnet and thicknet

For more information on these types of copper cabling, refer to their individual entries in this work.

TIP

UTP cabling of category 5 grade is the most commonly used copper cabling in networking environments today. Category 5 cabling (CAT5 cabling) comes in either solid core or stranded cabling. Solid core cabling is stiffer, but it has better conductivity and less attenuation, and it is simpler to terminate than stranded cabling. Stranded cabling is more flexible and easier to work with than solid cabling, and it is more resistant to breaking or fracturing. Use solid core UTP cabling for fixed horizontal cable runs, cross-connects, and backbone cabling; use stranded UTP cabling for locations where equipment is frequently moved, for short cable runs between computers and wall plates, or as patch cables in the wiring closet.

Copper Distributed Data Interface (CDDI)

Essentially, the use of Fiber Distributed Data Interface (FDDI) over copper cabling as an alternative to using fiber-optic cabling. Copper Distributed Data Interface (CDDI) can send data over unshielded twisted-pair (UTP) cabling at 100 Mbps, but cable lengths are limited to about 100 meters. The architecture and operation are similar to FDDI, but CDDI is not as commonly implemented as FDDI.

TIP

If cost is an issue, CDDI offers an alternative to FDDI. CDDI still provides a 100-Mbps network with redundancy, but at reduced cost because copper cabling is cheaper than fiber-optic cabling. Note that CDDI does not provide the security that FDDI does: copper cabling can be tapped, while fiber-optic cabling cannot.

See also
Fiber Distributed Data Interface (FDDI)

copy backup

A backup type in which all the selected files and folders are backed up, but the archive attribute is not marked for each file and folder. Copies do not interrupt the normal backup schedule because they do not change the state of the archive bit on files being backed up. Copy backups are typically used to produce additional copies of backup tapes. Copy backups might be used for

  • Archiving information in a different location

  • Generating tapes of month-end financials, which can then be given to the accounting department

  • Providing branch offices with copies of information on file servers

See also
backup, backup type

copy command

A Microsoft Windows command you can use to copy a file or group of files to a new location. The copy command can be used to copy files between volumes or within a volume to different directories. This provides a quick way of backing up files from the command prompt. The copy command can also be used to combine and move files.

Example

copy /v /y C:\myfile.txt D:\stuff\myfile2.txt

This command copies the file myfile.txt on the root of C to the folder \stuff on D and gives it the name myfile2.txt. The /v switch verifies that the copy was successful, and the /y switch suppresses the user prompt for confirmation of the action before performing it. For the full syntax of this command, type copy/? at the command prompt.

copying files

Making a replica of a file. On Microsoft Windows platforms, files can be copied using a graphical user interface (GUI) tool such as Windows Explorer or from the command prompt using the copy command.

NOTE

Some inheritance issues are associated with copying files on Windows NT and Windows 2000 platforms that use the NTFS file system. Specifically, copying a file within or between different NTFS volumes causes the file to inherit the permissions of the folder into which it is copied. For example, if a file on the NTFS drive C has read permission for everyone and it is copied to a directory on the NTFS drive D, which has change permission for everyone, the copy of the file inherits the change permission from the directory it is moved to.

See also
moving files

CORBA

See
Common Object Request Broker Architecture (CORBA)

counter

An aspect of an object in Performance Monitor for which usage statistics can be collected. Performance Monitor, a Microsoft Windows NT administrative tool for monitoring system resources, can be used to collect status information about various objects. (In Windows 2000, System Monitor in the Performance console is used to perform the monitoring task.) For example, if the object Processor is being studied, the Performance Monitor collects information on all counters that belong to this object. This includes counters such as

  • % User Time:
    The percentage of the time the processor is in user mode executing a nonidle thread

  • % Privileged Time:
    The percentage of the time the processor is in kernel mode executing a nonidle thread

  • Interrupts/sec:
    The number of device interrupts a processor receives per second

If the machine is a multiprocessor system, each instance of each counter can be monitored. Performance Monitor counters are usually one of two types:

  • Instantaneous counters, which display the most recent value of a measurement—for example, Processor: % Processor Time

  • Average counters, which display the average of the last two measured values—for example, LogicalDisk: Avg. Disk Bytes/Read

country code

A two-letter code identifying top-level domains for countries in the Domain Name System (DNS). Country codes are a way of geographically identifying a domain name as belonging to a particular country. They are an alternative to the more commonly used organizational codes such as .com, .org, .net, and so on. This table lists the various country codes for the DNS system.

Country Codes
Code | Country | Code | Country
AD | Andorra | BS | Bahamas
AE | United Arab Emirates | BT | Bhutan
AF | Afghanistan | BV | Bouvet Island
AG | Antigua and Barbuda | BW | Botswana
AI | Anguilla | BY | Belarus
AL | Albania | BZ | Belize
AM | Armenia | CA | Canada
AN | Netherlands Antilles | CC | Cocos (Keeling Islands)
AO | Angola | CF | Central African Republic
AQ | Antarctica | CG | Congo
AR | Argentina | CH | Switzerland
AS | American Samoa | CI | Cote D’Ivoire (Ivory Coast)
AT | Austria | CK | Cook Islands
AU | Australia | CL | Chile
AW | Aruba | CM | Cameroon
AZ | Azerbaijan | CN | China
BA | Bosnia and Herzegovina | CO | Colombia
BB | Barbados | CR | Costa Rica
BD | Bangladesh | CU | Cuba
BE | Belgium | CV | Cape Verde
BF | Burkina Faso | CX | Christmas Island
BG | Bulgaria | CY | Cyprus
BH | Bahrain | CZ | Czech Republic
BI | Burundi | DE | Germany
BJ | Benin | DJ | Djibouti
BM | Bermuda | DK | Denmark
BN | Brunei Darussalam | DM | Dominica
BO | Bolivia | DO | Dominican Republic
BR | Brazil | DZ | Algeria
EC | Ecuador | GY | Guyana
EE | Estonia | HK | Hong Kong
EG | Egypt | HM | Heard and McDonald Islands
EH | Western Sahara | HN | Honduras
ER | Eritrea | HR | Croatia (Hrvatska)
ES | Spain | HT | Haiti
ET | Ethiopia | HU | Hungary
FI | Finland | ID | Indonesia
FJ | Fiji | IE | Ireland
FK | Falkland Islands (Malvinas) | IL | Israel
FM | Micronesia | IN | India
FO | Faroe Islands | IO | British Indian Ocean Territory
FR | France | IQ | Iraq
FX | France (Metropolitan) | IR | Iran
GA | Gabon | IS | Iceland
GD | Grenada | IT | Italy
GE | Georgia | JM | Jamaica
GF | French Guiana | JO | Jordan
GH | Ghana | JP | Japan
GI | Gibraltar | KE | Kenya
GL | Greenland | KG | Kyrgyzstan
GM | Gambia | KH | Cambodia
GN | Guinea | KI | Kiribati
GP | Guadeloupe | KM | Comoros
GQ | Equatorial Guinea | KN | Saint Kitts and Nevis
GR | Greece | KP | Korea (North)
GS | South Georgia and South Sandwich Islands | KR | Korea (South)
GT | Guatemala | KW | Kuwait
GU | Guam | KY | Cayman Islands
GW | Guinea-Bissau | KZ | Kazakhstan
LA | Laos | MZ | Mozambique
LB | Lebanon | NA | Namibia
LC | Saint Lucia | NC | New Caledonia
LI | Liechtenstein | NE | Niger
LK | Sri Lanka | NF | Norfolk Island
LR | Liberia | NG | Nigeria
LS | Lesotho | NI | Nicaragua
LT | Lithuania | NL | Netherlands
LU | Luxembourg | NO | Norway
LV | Latvia | NP | Nepal
LY | Libya | NR | Nauru
MA | Morocco | NU | Niue
MC | Monaco | NZ | New Zealand
MD | Moldova | OM | Oman
MG | Madagascar | PA | Panama
MH | Marshall Islands | PE | Peru
MK | Macedonia | PF | French Polynesia
ML | Mali | PG | Papua New Guinea
MM | Myanmar | PH | Philippines
MN | Mongolia | PK | Pakistan
MO | Macau | PL | Poland
MP | Northern Mariana Islands | PM | St. Pierre and Miquelon
MQ | Martinique | PN | Pitcairn
MR | Mauritania | PR | Puerto Rico
MS | Montserrat | PT | Portugal
MT | Malta | PW | Palau
MU | Mauritius | PY | Paraguay
MV | Maldives | QA | Qatar
MW | Malawi | RE | Reunion
MX | Mexico | RO | Romania
MY | Malaysia | RU | Russian Federation
RW | Rwanda | TP | East Timor
SA | Saudi Arabia | TR | Turkey
SB | Solomon Islands | TT | Trinidad and Tobago
SC | Seychelles | TV | Tuvalu
SD | Sudan | TW | Taiwan
SE | Sweden | TZ | Tanzania
SG | Singapore | UA | Ukraine
SH | St. Helena | UG | Uganda
SI | Slovenia | UK | United Kingdom
SJ | Svalbard and Jan Mayen Islands | UM | US Minor Outlying Islands
SK | Slovak Republic | US | United States
SL | Sierra Leone | UY | Uruguay
SM | San Marino | UZ | Uzbekistan
SN | Senegal | VA | Vatican City State
SO | Somalia | VC | Saint Vincent and The Grenadines
SR | Suriname | VE | Venezuela
ST | Sao Tome and Principe | VG | Virgin Islands (British)
SV | El Salvador | VI | Virgin Islands (US)
SY | Syria | VN | Viet Nam
SZ | Swaziland | VU | Vanuatu
TC | Turks and Caicos Islands | WF | Wallis and Futuna Islands
TD | Chad | WS | Samoa
TF | French Southern Territories | YE | Yemen
TG | Togo | YT | Mayotte
TH | Thailand | YU | Yugoslavia
TJ | Tajikistan | ZA | South Africa
TK | Tokelau | ZM | Zambia
TM | Turkmenistan | ZR | Zaire
TN | Tunisia | ZW | Zimbabwe
TO | Tonga |  |

coupler

A small device for connecting two cables to make a longer cable, sometimes called an inline coupler. Inline couplers do not provide any amplification or signal boost, and can cause attenuation and signal degradation unless they are of high quality. One example would be a small box that accepts two category 5 (CAT5) cables with RJ-45 connectors and links them to form a longer cable. Another example would be the BNC barrel connector for joining two lengths of thinnet cabling. A third example would be a coupler with two RJ-11 connectors for joining two phone lines.

The term “coupler” is also used to refer to modular connectors that can snap into customizable patch panels to allow different kinds of cabling to be mixed in one patch panel.

Graphic C-30. A category 5 UTP (unshielded twisted-pair) coupler.
Graphic C-30. A category 5 UTP (unshielded twisted-pair) coupler.

CPE

See
customer premises equipment (CPE)

CPS

See
Connection Point Services (CPS)

CRC

See
cyclical redundancy check (CRC)

Creator Owner

A Microsoft Windows NT and Windows 2000 system group existing on all Windows NT and Windows 2000 servers and workstations that is used as a security context for running services and operating system functions. The membership of the Creator Owner system group cannot be modified directly. The Creator Owner system group includes only the user who created or took ownership of a network resource, and is functionally equivalent to that user’s primary group. The Creator Owner system group has full permissions on the resource, but the rights of the Creator Owner system group cannot be modified. Whoever creates a file system object or print job becomes the Creator Owner of that object or job.

See also
built-in group, special identity

credentials

Required for users who want to log on to a network and access its resources. Credentials, which are formed by combining a user’s username and password, identify users so that they can be authenticated by the network security provider. Credentials for access to one network do not guarantee access to another network.

In networks based on Microsoft Windows NT and Windows 2000, computers called domain controllers are responsible for authentication of user’s credentials. In addition, trust relationships can be established between Windows NT domains to allow user’s credentials to be authenticated from anywhere in the enterprise. Windows NT and Windows 2000 support single-user logon, which allows a user to use a single set of credentials for accessing resources anywhere on a network.

crimper

A cabling installation tool used for attaching connectors to cabling. Crimpers are used to terminate cables by applying appropriate pressure to contacts within a connector so that it remains physically attached to the cable without soldering. A crimper is an essential component of a network administrator’s toolkit. Crimpers can include built-in strippers for removing the outer insulation from a cable. They can include a set of dies for crimping different kinds of connectors, or they can be specialized for a single type of termination. Crimpers are most often used for terminating category 5 unshielded twisted-pair (UTP) cabling with RJ-45 connectors. A good crimper should be made of heavy-duty metal and be able to cut, strip, and terminate a cable easily.

Graphic C-31. A crimper with connector set.
Graphic C-31. A crimper with connector set.

CRL

See
certificate revocation list (CRL)

crossover cable

Twisted-pair cabling with the send and receive pairs of wires crossed. Crossover cables are primarily used for connecting hubs to each other. In addition, a small, two-station local area network (LAN) can be established by connecting two computers together with 10BaseT network interface cards (NICs) and a crossover cable. This configuration is often utilized when one computer is used to test the networking functions of another, since it allows the computer being tested to be isolated from the network. The illustration shows the pinning configuration of a crossover cable.

Graphic C-32. Crossover cable.
Graphic C-32. Crossover cable.

crosstalk

A form of interference in which signals in one cable induce electromagnetic interference (EMI) in an adjacent cable. The twisting in twisted-pair cabling reduces the amount of crosstalk that occurs, and crosstalk can be further reduced by shielding cables or physically separating them. Crosstalk is a feature of copper cables only—fiber-optic cables do not experience crosstalk.

The ability of a cable to reject crosstalk in Ethernet networks is usually measured using a scale called near-end crosstalk (NEXT). NEXT is expressed in decibels (dB), and the higher the NEXT rating of a cable, the greater its ability to reject crosstalk. A more complex scale called Power Sum NEXT (PS NEXT) is used to quantify crosstalk in high-speed Asynchronous Transfer Mode (ATM) and Gigabit Ethernet networks.

TIP

Crosstalk can be a problem for unshielded twisted-pair (UTP) cabling. To minimize crosstalk, make sure that

  • You don’t untwist or sharply bend the UTP cabling

  • The cable ends connected to a patch panel or wall plate are untwisted no more than half an inch

CryptoAPI

A core component of the latest versions of Microsoft Windows that provides application programming interfaces (APIs) for cryptographic security services that provide secure channels and code signing for communication between applications. CryptoAPI provides a set of standard Win32 libraries for managing cryptographic functions using a single consistent interface independent of the underlying cryptographic algorithms and ciphers. CryptoAPI interfaces with modules called cryptographic service providers (CSPs), such as the Microsoft RSA Base Cryptographic Provider, to provide cryptography functions such as hashing, data encryption and decryption, key generation and exchange, digital signature issuance and verification, and so forth.

CryptoAPI is natively supported by the latest versions of Windows NT, Windows 98, and Windows 2000. Microsoft Internet Explorer version 4 provides CryptoAPI support for Windows 95. The current version of CryptoAPI is version 2.

Cryptographic Message Syntax Standard (PKCS-7)

A standard that defines the general syntax for data that includes cryptographic features such as digital signatures, encryption, and certificate chains. Cryptographic Message Syntax Standard (PKCS-7) specifies the format in which the data is signed and encrypted, and the types of encryption algorithms used.

Data encrypted according to the PKCS-7 standard can have multiple digital certificates attached, including certificate revocation lists (CRLs). Certificates include information concerning the issuer and serial number of the public key of the signer so that the recipient can decrypt the message.

cryptographic service provider (CSP)

See
CryptoAPI

cryptography

In networking and telecommunications, the process of securely transmitting data over a network in such a way that if the data is intercepted, it cannot be read by unauthorized users.

How It Works

Cryptography involves two complementary processes:

  • Encryption is the process of taking data and modifying it so that it cannot be read by untrusted users.

  • Decryption is the process of taking encrypted data and rendering it readable for trusted users.

Encryption and decryption are performed using algorithms and keys. An algorithm, a series of mathematical steps that scrambles data, is the underlying mathematical process behind encryption. There are a variety of cryptographic algorithms that have been developed based on different mathematical processes.

Some algorithms result in stronger encryption than others—the stronger the algorithm, the more difficult the encrypted data is to crack. For example, Network and Dial-up Connections in Microsoft Windows 2000 supports standard 40-bit RAS RC4 encryption, but if you are located in the United States or Canada, you can get a stronger 128-bit version. Similar versions are offered for Windows NT.

Encryption algorithms involve mathematical values called keys. Earlier cryptography systems were secret key encryption systems in which only the hosts involved in transmitting and receiving the encrypted transmission knew the key. This key had to somehow be transported securely to anyone needing to decrypt a message. This was the main disadvantage with secret key cryptosystems.

Most cryptography today involves a process called public key encryption, which uses two different keys:

  • A public key that is distributed to any user (or to any client program) requesting it

  • A private key that is known only to the owner (or the owner’s client program)

To send an encrypted message, the sender uses his or her private key to encrypt the data, and the recipient uses the sender’s public key to decrypt it. Similarly, the recipient can return a response to the original sender by using the sender’s public key to encrypt the response, and the original sender uses his or her private key to decrypt it.

See also
digital certificate, public key cryptography

Crystal Reports

A third-party reporting tool created by Seagate Software and included with some Microsoft products, such as Microsoft Systems Management Server (SMS). Crystal Reports is a useful tool for network administrators that can be used for creating reports from various kinds of databases. Crystal Reports uses open database connectivity (ODBC) to extract data from an ODBC-compliant database such as Microsoft SQL Server. Crystal Reports includes a number of predefined report templates for quickly generating reports. A designer tool can be used for creating custom reports, and reports can be displayed in a variety of formats to facilitate communication and analysis of information.

CSMA/CA

See
Carrier Sense Multiple Access with Collision Avoidance (CSMA/CA)

CSMA/CD

See
Carrier Sense Multiple Access with Collision Detection (CSMA/CD)

CSNW

See
Client Services for NetWare (CSNW)

CSP

See
caching service provider (CSP), commercial service provider (CSP), CryptoAPI

CSS

See
cascading style sheets (CSS)

CSU

See
Channel Service Unit (CSU)

CSU/DSU

See
Channel Service Unit/Data Service Unit (CSU/DSU)

.csv file

A text file having the extension .csv, which contains fields of data separated by commas and a carriage return/linefeed at the end of each record. The extension .csv stands for comma-separated values.

These files are often used as a standard format for importing and exporting information between applications. For example, in Microsoft Exchange Server you can modify the properties of a group of mailboxes by exporting the properties of the mailboxes to a .csv file, opening this file as a spreadsheet in Microsoft Excel, modifying the properties using string functions and search/replace, exporting the information back into another .csv file, and then importing the modified file back into Exchange. Many applications can export log files or other information as .csv files. These files can then be imported into a spreadsheet or database program where they can be subjected to further inspection and analysis. Graphics and charts can also be generated from the imported information.

CTEC

See
Certified Technical Education Center (CTEC)

CTI

See
computer-telephony integration (CTI)

Ctrl+Alt+Delete

Holding down the Control, Alt, and Delete keys simultaneously. This action produces the following results (depending upon the operating system being used):

  • MS-DOS:
    Restarts the computer.

  • 16-bit Microsoft Windows, Windows 95, and Windows 98:
    Shows running tasks and allows you to terminate a task. A second Ctrl+Alt+Delete will restart the computer.

  • Windows NT:
    Brings up the Windows NT Security dialog box.

  • Windows 2000:
    Brings up the Windows Security dialog box.

See also
secure attention sequence (SAS)

custom authentication

Any user-created method for authentication of clients on a network. Internet Information Services (IIS) lets you create custom authentication schemes to control access to Web content. These can be implemented using several different technologies, including Active Server Pages (ASP), Internet Server API (ISAPI) authentication filters, or Common Gateway Interface (CGI) applications. For example, using any of these technologies, you can create an authentication scheme to

  • Perform a search of a client’s credentials in a custom user database

  • Examine a client’s digital certificate to determine whether to allow access

  • Use cookies or some other mechanism to establish whether the client should be authenticated

customer premises

A general term referring to your local company’s networking environment. This term is typically used by various types of service providers who provide leased or contractual services to help you implement and support your network. For example, a cabling company would install cabling at your customer premises and call this installation premise wiring. A telecommunications company might send a representative to a customer premises in order to install a CSU/DSU (Channel Service Unit/Data Service Unit) or other device in the wiring closet to enable wide area network (WAN) communication. Typically, your company is responsible for the physical security of such installed equipment, but the actual configuration and monitoring of the equipment takes place at the telco’s central office (CO).

customer premises equipment (CPE)

In telecommunications terminology, any telecommunications equipment sold or leased by the carrier to the customer that is installed at the customer’s location. Customer premises equipment (CPE) is typically installed to originate, route, or terminate telecommunications between the customer premises and the central office (CO) of the carrier or telco from which the service is leased. Some examples of customer premises equipment include telephones, modems, CSU/DSUs (Channel Service Unit/Data Service Units), Private Branch Exchanges (PBXs), and so on. Generally the telecommunications service provider is responsible for the configuration and monitoring of the CPE. For example, when installing a CSU/DSU as a termination for a T1 line, the configuration of the CSU/DSU is likely to have been done previously by the service provider. Simple Network Management Protocol (SNMP) monitoring features and loopback monitoring techniques enable the service provider to determine, from its central office, whether the remotely installed equipment is functioning correctly.

custom recipient

A recipient in Microsoft Exchange Server that doesn’t reside in the Exchange organization. When creating a custom recipient, you specify the e-mail address of the remote user first, and then configure the properties of the recipient. An example of a custom recipient is the Simple Mail Transfer Protocol (SMTP) address of a user on the Internet.

Custom recipients are often created on Exchange servers to place frequently used foreign addresses in the global address book so that users don’t have to specify the recipient’s e-mail address manually or maintain their own personal address books. Custom recipients can be used for various other purposes in Exchange, such as to enable a user’s Internet mail to be forwarded to his or her Exchange mailbox.

cyclical redundancy check (CRC)

A number mathematically calculated for a packet by its source computer, and then recalculated by the destination computer. If the original and recalculated versions at the destination computer differ, the packet is corrupt and needs to be resent or ignored.

The mathematical procedure for performing a CRC is specified by the International Telecommunication Union (ITU) and involves applying a 16-bit polynomial to the data being transmitted by the packet for packets of 4 KB of data or less, or a 32-bit polynomial for packets larger than 4 KB. The results of this calculation are appended to the packet as a trailer. The receiving station applies the same polynomial to the data and compares the results to the trailer appended to the packet. Implementations of Ethernet use 32-bit polynomials to calculate their CRC.


D

DACL

See
discretionary access control list (DACL)

daemon

A program associated with the UNIX operating system that runs in the background and performs some task without instigation from the user. An example of a daemon is the telnet daemon, which runs continuously in the background, waiting for a connection request from a telnet client. The telnet daemon facilitates the remote connection and makes it possible for the user to control the machine. Another example is the HTTPd daemon for the Apache Web server, which waits for Hypertext Transfer Protocol (HTTP) requests from Web browser clients and fulfills them.

A third example of a daemon is the nfsd daemon, which supports the remote file access aspect of the Network File System (NFS) in a UNIX environment. The nfsd daemon runs in the background on UNIX servers, waiting for remote procedure calls (RPCs) from NFS clients.

Daemons typically use RPCs for communication with clients. Because NFS is implemented as daemon processes at the user level instead of at the kernel level, NFS is thread-safe for execution, allowing multiple NFS processes to run as independent threads of execution.

NOTE

The Microsoft equivalent of “daemon” is “service.” For example, the Workstation service of Microsoft Windows NT would be known in UNIX as a daemon instead of a service.

Graphic D-1. The nfsd daemon.
Graphic D-1. The nfsd daemon.

daily copy backup

A backup type in which only files and folders that have changed on that day are backed up but the archive attribute is not marked for each file and folder. A daily copy backup is not a common type of backup operation. It is typically used only if a user wants to take home copies of the files he or she has been working on during the day. Few administrators would be willing to schedule and run the system backup software just to make copies of these files, so users taking advantage of this backup type usually have a locally attached backup device along with a similar device attached to their systems at home. Daily copy backups are likely to be performed on media such as Iomega Zip or Jaz disks rather than on tape.

NOTE

Daily copy backups are supported by the Microsoft Windows NT and Windows 2000 Backup utility.

See also
backup, backup type

D-AMPS

See
Digital Advanced Mobile Phone Service (D-AMPS)

DAO

See
Data Access Objects (DAO)

DAP

See
Directory Access Protocol (DAP)

dark fiber

Any fiber-optic cabling or fiber device such as a repeater that is installed but not currently in use. Since no light is being transmitted through the cabling, it is called “dark.” The term “dark fiber” is not generally used to refer to a problem in the fiber-optic cabling system; it simply means that the fiber media and components are waiting to be used.

However, various problems can occur in a fiber-optic cabling system that can cause it to remain dark once the system is turned on. These can include the following:

  • Microfractures in the glass core or cladding caused by improper installation techniques, such as excessive bending or stretching of a segment of cable

  • Improper terminations for the fiber or loose connectors

  • Malfunctioning repeaters

Before dark fiber is activated, the system is usually tested using an optical time domain reflectometer (which measures and analyzes a fiber link) and other measuring devices to determine whether the system has integrity, and to measure its bandwidth and attenuation parameters.

See also
fiber-optic cabling

Data Access Objects (DAO)

A Microsoft technology that enables you to use a programming language to access and manipulate data stored in both local and remote databases. Data Access Objects (DAO) lets you access and manage databases, along with their structure and objects, by providing a framework called an “object model” that uses code to create and manipulate different kinds of databases.

DAO supports two different interfaces, which are known as workspaces:

  • The ODBCDirect workspace, in which you can access database servers such as Microsoft SQL Server through open database connectivity (ODBC). This workspace lets you execute queries or stored procedures against a database server, perform batch updates, and execute asynchronous queries. ODBCDirect makes it possible for you to take advantage of Remote Data Objects (RDO) technology in your DAO code.

  • The Microsoft Jet workspace, in which you can access databases based on Jet technology or on installable indexed sequential access method (ISAM) data sources in other formats such as Paradox, dBase, and Btrieve. You use this workspace to access a single database, such as a .mdb database from Microsoft Access, or to join together data originating from several different database formats.

DAO and RDO are both available now, but these technologies are being superseded by Microsoft ActiveX Data Objects (ADO) and Remote Data Service (RDS). All these components can be found in the Microsoft Data Access Software Development Kit.

data alarm

A device for alerting network administrators to network problems. Some vendors use the term “data alarm” to describe a device that senses network problems associated with the flow of data.

These devices typically monitor serial lines such as RS-232 connections for the presence or absence of certain signals. For example, you can monitor the connection between a print server and its attached printer or between an access server and a modem or a Channel Service Unit/Data Service Unit (CSU/DSU).

A data alarm can be a simple device that monitors one serial line for the presence or absence of data. If the data flow stops, a flashing LED or audible alarm signals the problem to the administrator. More complex data alarms can support multiple serial lines or other serial interfaces such as RS-449 and V.35, can have programmable functions and menu-driven commands, and can monitor other devices, such as Time to Live (TTL) devices. These more complex devices can be configured to dial a remote station when a problem arises and to generate a report of the condition or even activate an alphanumeric pager.

Graphic D-2. Data alarm.
Graphic D-2. Data alarm.

database

A file used to store records of information, with each record containing multiple data fields. The most popular type of database is the relational database, in which the records are stored in tables that are related to each other using primary and foreign keys. A primary key is the field in each record that uniquely defines the record. (For example, a part number might be used as the primary key in a table that holds the price of each item a company sells.) A foreign key is a field in another table that matches the first table’s primary key, creating a relationship between the two. An application for creating and managing relational databases is called a relational database management system (RDBMS).

How It Works

Records are like the rows of a table. Each record is a collection of information about some physical system or logical object. Field names are like the column names of a table. Each field name represents a property or attribute of the system or object. Databases are widely used by businesses for storing information about inventory, orders, shipping, accounting, and so forth.

Microsoft SQL Server is Microsoft’s enterprise-level RDBMS. SQL Server databases are stored on devices. Each computer running SQL Server has four system databases plus one or more user databases installed on it. The system databases are as follows:

  • The master database, which is used for tracking system-wide information.

  • The tempdb database, which is used for temporary working storage and sort operations.

  • The model database, which is a template for creating new databases.

  • The msdb database, which is used to store system data and transaction logs and to support the SQL Server Agent service and its scheduling information. The msdb database is stored on two devices, the Msdbdata system device and the Msdblog system device.

NOTE

The term “database” can have different meanings for different vendors. In Oracle products, for example, “database” refers to the entire Oracle DBMS environment. In SQL Server, databases provide a logical separation of data, applications, and security mechanisms, while in Oracle this separation is achieved using “tablespaces.”

Database Maintenance Plan Wizard

A wizard included with Microsoft SQL Server version 6.0 and later that lets you configure and schedule core maintenance actions for databases. You can schedule actions such as

  • Backups of databases and their transaction logs

  • Updates of optimizer information

  • Checks for damaged data

  • Redistribution of data and free space to make the database more efficient

You can use the wizard to schedule maintenance tasks at daily or weekly intervals. You run the Database Maintenance Plan Wizard from the toolbar of the SQL Server Enterprise Manager administrative tool. You can delete or disable scheduled maintenance tasks if they are no longer required.

Database Manager

See
Systems Management Server Database Manager

database owner (DBO)

In Microsoft SQL Server, the user account that created the database and is responsible for managing administrative tasks related to a SQL Server database. Each SQL Server database is considered a self-contained administrative domain and is assigned a database owner (DBO) who is responsible for managing the permissions for the database and performing tasks such as backing up and restoring the database’s information.

Essentially, the DBO can do anything within the database. By default, the SA (system administrator) account is also a DBO account for any database on a computer running SQL Server. The database owner has full permissions inside a database that it owns.

TIP

To avoid the complexity of managing separate DBO accounts for each SQL Server database, you might want to perform all administration tasks—both server-wide and specific to the database—using only the SA account.

data communications equipment (DCE)

Any device that supports data transmission over a serial telecommunications link. Typically, data communications equipment (DCE) refers to modems, Channel Service Unit/Data Service Units (CSU/DSUs), multiplexers, and similar devices. The purpose of a DCE is to provide termination for the telecommunications link and an interface for connecting data terminal equipment (DTE) to the link.

The term “DCE” specifically refers to serial transmission, which generally occurs over links such as a local loop Plain Old Telephone Service (POTS) connection, an Integrated Services Digital Network (ISDN) line, or a T1 line. An example of a DCE is an analog modem, which provides a connection between a computer (the DTE) and the local loop POTS phone line (the serial transmission line). A DCE accepts a stream of serial data from a DTE and converts it to a form that is suitable for the particular transmission line medium being used. The DCE also works in reverse, converting data from the transmission line to a form the DTE can use.

Data Encryption Standard (DES)

A U.S. government standard for encrypting information. In 1972, the National Bureau of Standards called for proposals for an encryption standard. IBM responded with an algorithm called Lucifer, which was accepted, renamed Data Encryption Algorithm (DEA), and then further developed by the National Security Agency (NSA) and the National Bureau of Standards. In 1977, DEA was adopted as the Data Encryption Standard (DES). It is now the official encryption standard of the Department of Defense. DES is the name of the Federal Information Processing Standard FIPS 46-1, which explains the operation of the Data Encryption Algorithm.

How It Works

DES is a symmetric encryption scheme in which both the sender and the receiver need to know the secret key in order to communicate securely. DES is based on a 56-bit key (actually a 64-bit key with 8 parity bits stripped off) that allows for approximately 7.2 x 1016 possible keys. When a message is to be encrypted using DES, one of the available keys is chosen and applied in 16 rounds of permutations and substitutions to each 64-bit block of data in the message.

The large number of keys makes DES fairly secure, but in 1997 a DES key was cracked using the idle processing cycles of 14,000 computers cooperating over the Internet.

A more secure variant of DES, Triple DES, encrypts each message using three different 56-bit keys in succession. Triple DES thus extends the DES key to 168 bits in length.

NOTE

The U.S. government controls the export of encryption standards and technology. A new encryption standard called Advanced Encryption Standard (AES) is expected to replace DES soon because DES is no longer considered secure enough for some government purposes.

datagram

A term sometimes used as a synonym for “packet,” but most often meaning a packet that is sent across a network using connectionless services, where the delivery doesn’t depend on the maintenance of specific connections between computers. Networking protocol suites such as TCP/IP generally support both connection-oriented and connectionless delivery services. In TCP/IP, the Transmission Control Protocol (TCP) is responsible for providing connection-oriented services that guarantee delivery of Internet Protocol (IP) packets. In contrast, the User Datagram Protocol (UDP) handles connectionless services that guarantee only “best-effort” delivery of datagrams. For networking services that use connectionless datagrams, higher-layer protocols must ensure delivery. Datagrams are generally small packets sent over the network to perform functions such as announcements.

data integrity

The correctness and consistency of data stored in a database. Maintaining integrity is essential, because a database is only useful if its contents can be retrieved and manipulated as expected. For example, without data integrity, data could be input into the system and then be inaccessible. Data integrity must be enforced on the database server. The following items are among those that should be verified:

  • Individual field contents during insertion, updating, or deletion of data

  • The values of one field relative to another (especially for primary keys) and of data in one table relative to another (especially for foreign keys)

  • Successful completion of database transactions

Database systems employ many features to ensure data integrity. For example, Microsoft SQL Server 7 makes use of data types, constraints, rules, defaults, declarative referential integrity (DRI), stored procedures, and triggers. All these play a role in keeping the integrity of the database intact.

data isolator

A general term for a type of network device that protects serial equipment from voltage surges. If two pieces of data terminal equipment (DTE) are connected by a long serial line, voltage differences with respect to ground between the devices can cause surges over the line that can damage the devices. This can be a problem in a mainframe environment when you connect terminals to asynchronous mainframe hosts using long RS-232 cables. The problem is especially troublesome when the cabling has to run outdoors between buildings or when nearby generators or other equipment induce voltages.

Graphic D-3. Data isolator.
Graphic D-3. Data isolator.

The solution to these problems is to insert a data isolator between the mainframe host and the terminal. This isolator provides electrical isolation between the two devices, somewhat like an opto isolator for fiber-optic cabling. Data isolators typically use transformers to electrically isolate the two connected circuits from voltage surges. Data isolators can support high data transfer speeds, and they come with a variety of interfaces, such as RS-232, RS-422, and Time to Live (TTL) connections.

data line protector

A device that provides surge protection for network cables carrying data. Data line protectors prevent voltage spikes and surges from damaging costly hubs, switches, routers, and other devices. They are essentially surge protectors that are placed inline between stations on the network and concentrating hubs or other devices in the wiring closet. Data line protectors are available from different vendors for virtually every kind of networking connection, including RJ-45 connections for Ethernet networks, RJ-11 connections for telephone lines, and RS-232 connections for serial lines.

You connect a data line protector directly to one of the two connected devices, and then you attach the ground wire to a good ground connection so that there will be a path for voltage surges to flow down. For Ethernet networks using unshielded twisted-pair (UTP) cabling, data line protectors are available with multiple ports that are attached directly to the hub or the switch. Additional 10BaseT surge protectors can also be installed directly on the stations on the network for more protection.

Graphic D-4. Data line protector.
Graphic D-4. Data line protector.
NOTE

Most newer hubs, switches, routers, and other networking devices include built-in data line protection circuitry, which eliminates the need for additional data line protectors.

Data Link Control (DLC)

Generally, the services that the data-link layer of the Open Systems Interconnection (OSI) reference model provides to adjacent layers of the OSI protocol stack. Specifically, a Data Link Control (DLC) is a specialized network protocol that is used primarily for two purposes:

  • To provide connectivity with IBM mainframe or AS/400 environments, such as Systems Network Architecture (SNA), which are configured to run DLC. DLC complements SNA because SNA operates only at higher levels of the OSI model.

  • To provide connectivity for network print devices (such as certain Hewlett Packard printers that have their own network cards and are connected directly to the network).

DLC is not used as a network protocol in the usual sense of enabling communication among computers on the network. It is not used by the redirector in the Microsoft Windows NT and Windows 2000 operating systems and so cannot be used for session-level communication over a network. DLC is not routable; it is designed only to give devices direct access to the data-link layer. DLC is supported by most Windows operating systems, including Windows 95, Windows 98, Windows NT, and Windows 2000. Windows 95 OSR2 includes both a 16-bit and a 32-bit version of DLC.

TIP

To use DLC on Windows NT or Windows 2000 to connect to a Hewlett-Packard network print device, perform the following steps:

  1. Connect the printer to the network, and run the self-test routine to obtain the MAC address of the printer. Also think of a friendly name for the printer.

  2. Install the DLC protocol on the Windows NT or Windows 2000 server that will be used as a print server for the network print device. (Use the Network utility or the Windows 2000 Network and Dial-up Connections utility in Control Panel.)

  3. Run the Add Printer Wizard on the print server, choosing My Computer, Add Port, Hewlett Packard Network Port, and New Port. Enter the friendly name for the printer and select its MAC address from the list (or type it if the print device is offline). In Windows 2000, run the Add Printer Wizard, then right-click on the printer in the Printers folder and choose Properties. In the Property sheet for the printer, click the Ports tab, click Add Port, select Hewlett Packard Network Port, and then click New Port. Enter the friendly name for the printer and select its MAC address from the list (or type it if the print device is offline).

data-link layer

Layer 2 of the Open Systems Interconnection (OSI) reference model, which converts frames of data into raw bits for the physical layer and is responsible for framing, flow control, error correction, and retransmission of frames. MAC addresses are used at this layer, and bridges and network interface cards (NICs) operate at this layer.

The data-link layer establishes and maintains the data link for the network layer above it. It ensures that data is transferred reliably between two stations on the network. A number of protocols can be implemented at this layer depending on whether you are establishing local area network (LAN) or wide area network (WAN) connections between stations. Data-link protocols are responsible for functions such as addressing, frame delimiting and sequencing, error detection and recovery, and flow control.

For LANs, the Project 802 standards of the Institute of Electrical and Electronics Engineers (IEEE) separate the data-link layer into two sublayers:

  • The logical link control (LLC) layer, the upper of the two layers, which is responsible for flow control, error correction, and resequencing functions for connection-oriented communication, but which also supports connectionless communication

  • The media access control (MAC) layer, the lower of the two layers, which is responsible for providing a method for stations to gain access to the medium

Graphic D-5. Data-link layer.
Graphic D-5. Data-link layer.

Examples of data-link protocols for local area networking include the following:

  • IEEE 802.3, which provides the Carrier Sense Multiple Access with Collision Detection (CSMA/CD) access method for baseband Ethernet networks

  • IEEE 802.5, which provides the token-passing access method for baseband token ring implementations

For WANs, data-link layer protocols encapsulate LAN traffic into frames suitable for transmission over WAN links. Common data-link encapsulation methods for WAN transmission include the following:

  • Point-to-point technologies such as Point-to-Point Protocol (PPP) and High-level Data Link Control (HDLC) protocol

  • Multipoint technologies such as frame relay, Asynchronous Transfer Mode (ATM), Switched Multimegabit Data Services (SMDS), and X.25

Data Provider

A tool that simplifies data access to different kinds of data sources such as relational databases. Also known as the OLE DB Provider for AS/400 and VSAM, Data Provider is included with Microsoft SNA Server version 4. It gives Web applications written with Microsoft Active Server Pages (ASP) technology the ability to access record-level mainframe AS/400 and VSAM file systems.

Using Data Provider, you can write applications that access legacy file data on mainframes and minicomputers running Systems Network Architecture (SNA). You can also directly access AS/400 file structures and VSAM data sets using the IBM DDM protocol native to many IBM host systems without needing to install additional Microsoft software on the host system. You can also integrate unstructured legacy file data on host systems with data stored in a Microsoft Windows NT or Windows 2000 networking environment.

Data Service Unit (DSU)

A digital communication device that works with a Channel Service Unit (CSU) to connect a local area network (LAN) to an external communication carrier service or a wide area network (WAN) link (such as a T1 line). Data Service Units (DSUs) provide a modem-like interface between data terminal equipment (DTE) such as a router and the CSU connected to the digital service line. DSUs also serve to electrically isolate the telco’s digital telecommunication line from the networking equipment at the customer premises.

Graphic D-6. Data Service Unit (DSU).
Graphic D-6. Data Service Unit (DSU).

For example, in T1 transmission technologies, the DSU converts network data frames that are received from the router’s RS-232, RS-449, or V.35 serial transmission interface into the standard DSX framing format, encoding scheme, and voltages of the T1 line. The DSU also converts the unipolar networking signal into a bipolar signal suitable for transmission over the digital line. The DSU is also responsible for handling signal regeneration and for controlling timing errors for transmission over the T1 line. DSUs usually provide other functions such as line conditioning of the T1 line, as well as remote diagnostic capabilities such as Simple Network Management Protocol (SNMP), which allows the telco central office (CO) to monitor the state of the line at the customer premises.

NOTE

DSUs are usually integrated with CSUs to create a single device called a CSU/DSU (Channel Service Unit/Data Service Unit). If these devices are separate, the telco usually supplies and configures the CSU, while the customer supplies the DSU. If the devices are combined, the telco usually supplies, configures, and maintains the CSU/DSU for the customer premises.

TIP

The DSUs (or CSU/DSUs) at either end of a digital data transmission line should be from the same manufacturer. If they are not, they might not communicate with each other correctly because different vendors employ different multiplexing and diagnostic technologies that are often incompatible with those of other vendors.

See also
Channel Service Unit/Data Service Unit (CSU/DSU)

data source name (DSN)

A unique name used to create a data connection to a database using open database connectivity (ODBC). The data source name (DSN) is used by applications that need to access or manage data in the database. All ODBC connections require that a DSN be configured to support the connection. When a client application wants to access an ODBC-compliant database, it references the database using the DSN.

Graphic D-7. Data source name (DSN).
Graphic D-7. Data source name (DSN).

You can configure a DSN for an ODBC-compliant database using the Microsoft Windows NT ODBC or the Windows 2000 Administrative Tools\Data Sources (ODBC) utility in Control Panel. You can create three kinds of DSNs:

  • A user DSN, which is visible only to the user who creates it and can be used only on the current machine.

  • A system DSN, which is visible to all users on the machine and is also accessible to Windows NT and Windows 2000 services. A system DSN is stored in the registry.

  • A file DSN, which can be shared by users who have the same ODBC drivers installed. A file DSN is stored in a file.

TIP

When you design Web applications that use Microsoft ActiveX Data Objects (ADO) for accessing database information, be sure to use either a file DSN or a system DSN because ADO does not work with user DSNs.

data tap

A type of networking device that you can use to monitor the flow of data in serial lines. Data taps provide an easy way to connect monitoring equipment such as data scopes to serial interfaces such as RS-232.

These serial connections are used for a variety of networking purposes, including connecting data terminal equipment (DTE) such as servers and routers to data communications equipment (DCE) such as modems and CSU/DSUs (Channel Service Unit/Data Service Units) for implementing wide area networks (WANs); connecting dumb terminals to asynchronous mainframe hosts; and connecting servers to plotters and other serial devices. Data taps generally display network traffic in binary, hexadecimal, or character format and are used for troubleshooting various kinds of network connections.

A data tap is essentially a three-way connector in which the third connector interfaces with the test equipment. For RS-232 serial lines, data taps come in a variety of configurations, with mixtures of male and female DB-9 and DB-25 connectors.

Graphic D-8. Data tap.
Graphic D-8. Data tap.

data terminal equipment (DTE)

Any device that is a source of data transmission over a serial telecommunications link. Typically, data terminal equipment (DTE) can be a computer, a terminal, a router, an access server, or some similar device. The earliest form of DTE was the teletype machine.

Graphic D-9. Data terminal equipment (DTE).
Graphic D-9. Data terminal equipment (DTE).

The term “DTE” specifically refers to a device that uses serial transmission such as the transmissions involving the serial port of a computer. Most serial interface devices contain a chip called a universal asynchronous receiver-transmitter (UART) that can translate the synchronous parallel data transmission that occurs within the computer’s system bus into an asynchronous serial transmission for communication through the serial port. The UART also performs other functions in a DTE:

  • Error detection, to ensure that data arrives at its destination uncorrupted

  • Clocking, to ensure that data is sent at the correct rate in order to be received at its destination

To connect a DTE to a telecommunications link, you use data communications equipment (DCE). The DCE provides termination for the telecommunications link and an interface for connecting the DTE to the link. An example of a DCE for connecting a DTE to the local loop Plain Old Telephone Service (POTS) connection is a modem.

See also
data communications equipment (DCE)

DAWS

See
Digital Advanced Wireless System (DAWS)

DB connector

Any connector used for connecting data terminal equipment (DTE). The letters “DB” stand for “data bus” and are followed by a number that indicates the number of lines or pins in the connector. DB connectors were formerly called D-series connectors. DB connectors can be used for either serial or parallel connections between devices. Common members of the DB family include the following:

  • DB-9, a 9-pin serial connector for connecting modems, serial printers, mouse devices, and so on

  • DB-15, a 15-pin connector for connecting such devices as Macintosh monitors and network interface cards (NICs) for 10Base5 drop cables

  • DB-25, a 25-pin connector for connecting Macintosh Small Computer System Interface (SCSI) devices, modems, serial printers, parallel cables, switch boxes, and so on

  • DB-37, a 37-pin connector for connecting such devices as routers and Channel Service Units (CSUs)

  • DB-60, a 60-pin connector for connecting such devices as Cisco routers

See also
connector (device)

DBO

See
database owner (DBO)

DCE

See
data communications equipment (DCE)

D channel

A circuit-switched channel in Integrated Services Digital Network (ISDN) technologies that carries signaling information between the customer premises termination and the central office (CO) of the telecommunications service provider or telco. The letter “D” stands for “data” or “delta.”

How It Works

The D channel is used to signal the telco CO when connections need to be created or terminated. The D channel forms the “D” part of a 2B+D Basic Rate Interface ISDN (BRI-ISDN) line and carries signaling information at a rate of 16 Kbps. On a 23B+D Primary Rate Interface ISDN (PRI-ISDN) line, the D channel carries signaling information at the faster rate of 64 Kbps.

D channel communication uses a completely separate out-of-band communication network called the Signaling System 7 (SS7) network, as shown in the illustration. This telco network is dedicated solely to servicing system functions that are overhead as far as voice or data communication is concerned. The SS7 network on which D channel communication takes place makes possible the low latency of dial-up ISDN connections, which are typically 1 or 2 seconds (compared to a latency of 15 to 30 seconds for analog phone connections).

Graphic D-10. D channel.
Graphic D-10. D channel.
NOTE

In ISDN voice communication, D channels are also used to activate special calling features such as line call forwarding and caller ID.

See also
B channel, Integrated Services Digital Network (ISDN)

DCOM

See
Distributed Component Object Model (DCOM)

DCOM Configuration Tool

A Microsoft Windows NT, Windows 98, and Windows 2000 utility used to configure 32-bit Windows applications for Distributed Component Object Model (DCOM) communication between components of distributed applications on a network.

How It Works

You can use the DCOM Configuration Tool to configure DCOM applications to run across computers on a network. Computers can be configured to operate as DCOM clients (making calls to DCOM servers), DCOM servers, or both. Using this tool, you can configure the locations of components of distributed applications and the security settings for those components.

Graphic D-11. DCOM Configuration Tool.
Graphic D-11. DCOM Configuration Tool.

To use the tool to configure a distributed application, you must specify the security and location properties of both the calling client application and the responding server application. For the client application, you specify the location of the server application that will be called by the client. For the server application, you select a user account that will have permission to start the application and the user accounts that will run it.

NOTE

Before you can use the DCOM Configuration Tool on Windows 98, you must be sure that user-level security is being used.

TIP

To start the tool, choose Run from the Start menu, and then type dcomcnfg.

See also
Distributed Component Object Model (DCOM)

DDS

See
digital data service (DDS)

dead spot

In wireless networking, a location within the coverage area where a signal is not received. Dead spots are typically caused by physical barriers (such as buildings or concrete structures) that absorb or reflect radio or microwave frequencies. The receiving station must relocate or the barrier must be moved if the station is to receive a signal. Dead spots can also be caused by high levels of electromagnetic interference (EMI) from heavy machinery (such as motors and generators) or broad-spectrum sources of radiation (such as microwave ovens). In these cases, too, the solution is to relocate the receiver or eliminate the source of interference.

See also
wireless networking

decibel

A mathematical way of representing power ratios, such as signal loss within a circuit or a portion of a network’s cabling system. A decibel is the ratio of two values that measure signal strength, such as voltage, current, or power. This ratio is expressed logarithmically using base 10 logarithms. In mathematical terms, this means that the decibel (dB) is defined as follows, where P1 and P2 are the power (signal strength) measurements:

dB = 10 log10 (P1/P2)

Decibels are used in network cabling systems for measuring signal losses. In addition, quantities such as attenuation and near-end crosstalk (NEXT) for fiber-optic cabling are expressed in units that contain decibels. In this scenario, P1 is the strength of the signal when it enters the cabling system, and P2 is its strength at some later point, after it has traversed segments of cable, repeaters, connectors, and other cabling system components. The following table shows signal strength ratios expressed both as ratios and as decibels for conversion purposes.

Signal Strength Ratios
Signal Strength Ratio (P1:P2) | Decibels (dB)
1:1 (no signal loss) | 0 dB
2:1 (50 percent signal loss) | -3 dB
4:1 (75 percent signal loss) | -6 dB
10:1 (90 percent signal loss) | -10 dB
100:1 (99 percent signal loss) | -20 dB
1000:1 (99.9 percent signal loss) | -30 dB
Example

The category 5 cabling version of unshielded twisted-pair (UTP) cabling has an attenuation rating of 30 dB/1000 feet. This means that after traveling 1000 feet along a UTP cable, the electrical strength of the signal typically diminishes by 99.9 percent and is only 0.1 percent of its original strength at the far end of the cable.

See also
cabling, fiber-optic cabling, unshielded twisted-pair (UTP) cabling

DECnet

A protocol suite developed by Digital Equipment Corporation (DEC). DECnet was originally designed in 1975 to allow PDP-11 minicomputers to communicate with each other.

DECnet conforms to the Digital Network Architecture (DNA) developed by DEC, which maps to the seven-layer Open Systems Interconnection (OSI) reference model for networking protocols. DECnet is essentially a peer-to-peer networking protocol for all DEC networking environments. DECnet supports various media and link-layer technologies, including Ethernet, Token Ring, and Fiber Distributed Data Interface (FDDI). The current release of DECnet is called Phase V.

Graphic D-12. DECnet.
Graphic D-12. DECnet.

dedicated line

Any telecommunications line that is continuously available for the subscriber with little or no latency. Dedicated lines are also referred to as “leased lines.” Businesses often lease dedicated lines from telcos so that they can have continuous, uninterrupted communication with branch offices and with the Internet. The opposite of a dedicated line is a dial-up line, which costs less because it is used intermittently and requires fewer telco resources. However, dial-up lines suffer from the delaying effects of latency as well as less available bandwidth. Dial-up lines are generally local loop Plain Old Telephone Service (POTS) connections that use modems and provide backup services for more expensive leased lines.

Dedicated lines are allocated to the subscriber’s private domain, while dial-up lines are shared with all other subscribers in the Public Switched Telephone Network (PSTN) domain. Dedicated lines can be either point-to-point or multipoint communication paths.

The main advantages of dedicated lines are:

  • They involve minimal connection delays and minimal latency for establishing communication.

  • They provide a consistent level of service.

  • They are always available without any busy signals.

The main disadvantage of dedicated lines is that they cost more than dial-up lines.

See also
dial-up line

default gateway

A device on a TCP/IP internetwork that can forward Internet Protocol (IP) packets to another network, usually a router. In an internetwork, a given subnet might have several router interfaces that connect it to other, remote subnets. One of these router interfaces is usually selected as the default gateway of the local subnet. When a host on the network wants to send a packet to a destination subnet, it consults its internal routing table to determine whether it knows which router to forward the packet to in order to have it reach the destination subnet. If the routing table does not contain any routing information about the destination subnet, the packet is forwarded to the default gateway (one of the routers with an interface on the local subnet). The host assumes that the default gateway knows what to do with any packets that the host itself does not know how to forward.

Graphic D-13. Default gateway.
Graphic D-13. Default gateway.

When configuring a client machine on a TCP/IP internetwork, the client must know the IP address of the default gateway for its network. On Microsoft Windows NT, Windows 95, and Windows 98 clients, you configure this information on the TCP/IP property sheet for the client. The property to configure is called the Default Gateway Address. In Windows 2000, you can have a default gateway assigned automatically using Dynamic Host Configuration Protocol (DHCP).

Defense Messaging System (DMS)

A program established by the U.S. Undersecretary of Defense (Acquisition) to develop an integrated, global messaging system for transferring classified and unclassified data. The Defense Messaging System (DMS) will replace the existing Automatic Digital Network (AUTODIN) system currently in use by the U.S. Department of Defense.

Microsoft Exchange DMS, a version of Microsoft Exchange Server, complies with the DMS specification. It is suited for government agencies that are required to use DMS-compliant products and for companies that do defense business with the U.S. government. Exchange DMS technology can be purchased only through Lockheed Martin Federal Systems.

delegation

A feature supported by Active Directory in Microsoft Windows 2000. Delegation is part of the security framework of Active Directory. Along with other features such as the discretionary access control list (DACL), inheritance, and trust relationships, it enables Active Directory to be administered securely, protected from unauthorized access.

Delegation is the process of assigning permissions and rights to an object, container, or subtree of containers or organizational units (OUs) within Active Directory. These permissions and rights can be assigned for the following purposes:

  • Delegating management of a portion of Active Directory to a user or group of users by assigning permissions or rights to a portion of Active Directory

  • Protecting a portion of Active Directory from unauthorized access by denying permissions or rights to a portion of Active Directory

Using delegation, the network administrator can distribute the job of managing an Active Directory enterprise-level implementation among a group of individuals, each with the appropriate permissions and rights to manage her or his portion of the directory. For example, a user can be granted permissions and rights on the Users container so that he or she can create new users or modify the attributes of existing ones. In this fashion, the network administrator can be relieved of the tiresome duty of creating and configuring new user accounts by delegating the job to a junior administrator. Delegation is designed to relieve the network administrator of the burden of managing the entire Active Directory and is an important security management feature in Windows 2000.

NOTE

The Delegation of Control Wizard, which is part of the Active Directory Users and Computers administrative tool, can be used to delegate administration of portions of Active Directory to other administrators and users.

TIP

Always delegate administrative control at the level of organizational units, not at the level of individual objects. This allows you to better manage access to Active Directory because OUs are used to organize objects in the directory. One good idea is to delegate authority to those who are responsible for creating users, groups, computers, and other objects that commonly change in an enterprise.

Always assign permissions to groups instead of to individual users. Groups can be nested within one another and, together with inheritance of permissions, they provide a powerful tool for organizing the administration of Active Directory.

See also
Active Directory

Delegation of Control Wizard

A wizard that you can run using the Active Directory Users and Computers administrative tool for networks in Microsoft Windows 2000. The Delegation of Control Wizard facilitates delegating control of different portions of Active Directory to other administrators and users. The wizard simplifies the process by allowing only the administrator to assign permissions at the level of organizational units (OUs). Assigning permissions to OUs rather than to particular directory objects ultimately simplifies the Active Directory administrator’s work.

How It Works

To start the wizard, open the Active Directory Users and Computers tool, select the OU you want to delegate control for, and choose Delegate Control from the Action menu. Specify the users or groups to whom you want to delegate control, the subset of object types in the OU for which this should take place, and the kinds of permissions you want to assign.

See also
Active Directory, delegation

demand priority

A media access control method for 100VG-AnyLan networks. 100VG-AnyLan is a high-speed form of Ethernet based on the IEEE standard 802.12 developed by Hewlett Packard. Demand priority is the method by which stations on a 100VG-AnyLan network gain access to the wire for transmitting data.

How It Works

A 100VG-AnyLan network based on the demand priority access method consists of end nodes (stations), repeaters (hubs), switches, routers, bridges, and other networking devices. A typical 100VG-AnyLan network consists of a number of stations plugged into a cascading star topology of repeaters (hubs). Because of timing, a maximum of five levels of cascading of the physical wiring is permitted. Hubs are connected using uplink ports. Each hub is aware only of the stations directly connected to it and any hubs that are uplinked from it.

The key feature of the demand priority access method, as shown on the illustration, is that the 100VG-AnyLan hubs control which computers are allowed to transmit signals on the network at any given moment.

Hubs can be thought of as servers and end nodes as computers (clients). With demand priority, a client (a computer with a 100VG-AnyLan network interface card installed in it) must first request access to the network media (cabling) before transmitting data. The server (hub) processes this request and decides whether to allow the client access to the media. If the hub decides to grant the client access to the wire, it sends the client a signal informing it of this decision. The client then takes over control of the media and transmits its data.

Graphic D-14. Demand priority.
Graphic D-14. Demand priority.

Demand priority is considered a contention method, but it operates differently from the Carrier Sense Multiple Access with Collision Detection (CSMA/CD) access method used in Ethernet networks. Cables in a 100VG-AnyLan network are capable of transmitting and receiving data at the same time using all four pairs of twisted-pair cabling in a quartet signaling method. Each pair of wires in a twisted-pair cable transmits and receives data at 25 MHz, for a total bandwidth of 100 MHz. All contention on the network occurs at the hub. If two computers attempt to transmit signals at the same time, the hubs can either choose between the two signals based on priority or alternate between them if the priorities are equal. The hubs can do this because demand priority provides mechanisms for prioritizing transmission of different data types. Computers in demand priority networks can simultaneously transmit and receive data, and they do not need to listen to the network because the hubs control access to the wire.

See also
100VG-AnyLan, media access control method

denial of service attack

A form of attack conducted against a system or network that occurs when a malicious user consumes so many resources that none are left for others. The resources attacked might include processors, disk space, memory, modems, telephone lines, and so on. A hacker might launch a denial of service attack using software that automates attempted access to shared resources on a network exposed through the Internet.

How It Works

Denial of service attacks are often launched by hackers who want to bring down a Web server on the Internet. A common example of an attack is the SYN attack, a protocol-level attack that is intended to render the Web server’s networking services unavailable. SYN flooding is a type of attack in which Transmission Control Protocol (TCP) connection request packets (SYN packets) are sent in large numbers to a Web server. These packets use a false or “spoofed” source IP address to hide the attacker. SYN packets are used to place the TCP ports in the SYN _RECEIVED, or “half-open,” state on the Web server and then do nothing with them until they time out. If enough of these ports are half-opened, the server cannot service requests from normal clients until the unused ports expire. Unfortunately, it takes time for the half-opened ports to time out because, when a SYN packet is received, the server generates a SYN-ACK packet to acknowledge the request and then waits for a final ACK from the requester before fully opening the port for a communication session. (This is called a TCP three-way handshake.) However, that final ACK is not received because the source address in the SYN packet was spoofed. The SYN-ACK packet is thus retransmitted several times at increasingly longer time intervals until, after a total time of 189 seconds (in the implementation of TCP/IP on Microsoft Windows platforms), the server finally gives up and closes the half-open port. For that time period, the requested port is unavailable to perform any other services.

TIP

If users try to connect to your Web server and receive error messages such as “The connection has been reset by the remote host,” a SYN attack might be under way on your machine. (When the maximum number of TCP ports are in use [open or half-open] on a machine, the machine usually responds to any further connection attempts with a reset.)

To determine whether such an attack is in progress, type netstat -n -p tcp at the command prompt to see whether there are a large number of ports in the half-open SYN_RECEIVED state. If so, try using a network protocol analyzer such as Network Monitor to further examine the situation. You might need to contact your Internet service provider (ISP) to investigate the problem more closely.

If your server is under a heavy SYN attack, one fix you can try on Windows NT platforms running Microsoft Internet Information Server (IIS) is to decrease the default timeout for terminating half-open TCP connections. Open the TcpMaxConnectResponseRetransmissions parameter in the registry and set it to 3, 2, or even 1 to reduce the timeout to 45, 21, or 9 seconds, respectively. However, if you set this parameter too low, legitimate connections might experience timeouts. Windows 2000 and Windows NT 4 Service Pack 3 have corrected this problem. A fix is available for Windows NT version 3.51 from Microsoft.

dense wavelength division multiplexing (DWDM)

A technology for achieving extremely high data rates over fiber-optic cabling. Also known as wave division multiplexing (WDM), dense wavelength division multiplexing (DWDM) will likely replace time-division multiplexing (TDM) as the standard transmission method for high-speed fiber-optic backbones in the next few years.

Graphic D-15. Dense wavelength division multiplexing (DWDM).
Graphic D-15. Dense wavelength division multiplexing (DWDM).
How It Works

DWDM modulates multiple data channels into optical signals that have different frequencies and then multiplexes these signals into a single stream of light that is sent over a fiber-optic cable. Each optical signal has its own frequency, so up to 80 data streams can be transmitted simultaneously over the fiber using only eight different light wavelengths. In addition, each data stream can employ its own transmission format or protocol. This means that, using DWDM, you can combine Synchronous Optical Network (SONET), Asynchronous Transfer Mode (ATM), TCP/IP, and other transmissions and send them simultaneously over a single fiber. At the other end, a multiplexer demultiplexes the signals and distributes them to their various data channels.

Devices that support DWDM are more costly because the laser light sources for generating signals over fiber must be highly stable.

See also
time-division multiplexing (TDM)

DES

See
Data Encryption Standard (DES)

desktop

The ever-present background of the graphical user interface (GUI) for Microsoft Windows 95, Windows 98, Windows NT version 4, and Windows 2000 systems. The desktop is the user’s on-screen work area; its various icons and menus are arranged as if on top of a physical desk. Users can place items on the desktop, drag them around, move them into folders, and start and stop tasks using simple mouse actions such as clicking, double-clicking, dragging, and right-clicking.

With the Active Desktop of Windows 98 (or on Windows 95 or Windows NT 4 with Microsoft Internet Explorer version 4 installed and the Desktop Update feature selected), Web browser functions also appear on the desktop. Users can browse local and network file system objects along with content on the Internet using a familiar Web browser paradigm. Active Web content can be placed directly on the desktop and updated automatically.

See also
Active Directory

Desktop Management Interface (DMI)

A standard for managing desktop systems developed by the Desktop Management Task Force (DMTF). Using the Desktop Management Interface (DMI), information can be automatically collected from system components such as network interface cards (NICs), hard disks, video cards, operating systems, and applications that are compliant with the DMI standard. DMI was designed to be operating system–independent and protocol-independent and was designed for use on local systems that do not have a network installed. DMI can be mapped to Simple Network Management Protocol (SNMP). Note that DMI itself does not specify a protocol for managing systems over the network; instead, it must use an existing network management protocol such as SNMP to send and receive information over the network.

How It Works

DMI is similar in design to SNMP. Each component to be managed must have a Management Information Format (MIF) file that specifies the location of the component, name of vendor and model, firmware revision number, interrupt request line (IRQ), I/O port address, and so on. MIF files are formatted as structured ASCII flat-file databases; the Desktop Management Task Force has defined several standard MIFs including the Desktop System MIF file, the Adapter Card MIF file, and the Printer MIF file.

DMI service layer software running on the desktop collects information from DMI-enabled components and stores this information in the appropriate MIF file. The service layer thus acts as an intermediary between the DMI-enabled components and the DMI management application, and it coordinates shared access to the various MIFs installed on the desktop system. DMI management applications can then query the service layer on the desktop to obtain the various system components and applications from these MIF files. The service layer allows the management layer to interact with the MIFs by using commands such as

  • Get, which obtains information from a MIF

  • Event, which alerts the management application when certain events occur

  • Set, which modifies the contents of a MIF

One advantage of DMI over SNMP is that DMI management applications can access MIF files even when they have no prior information about them.

DMI management applications include Intel’s LANDesk and Microsoft Systems Management Server (SMS). SMS uses standard DMI 4.5 MIF files to expose inventory data for systems it manages and then stores this information in a Microsoft SQL Server database.

NOTE

The newer Web-Based Enterprise Management (WBEM) initiative from the DMTF proposes the Common Information Model (CIM) as a common abstraction layer for unifying the various existing data providers for system and network management, including DMI and SNMP. Microsoft has implemented WBEM into the Windows 2000 operating system as the Windows Management Instrumentation (WMI).

destination address

The address to which a frame or packet of data is sent over a network. The destination address is used by hosts on the network to determine whether the packet or frame is intended for them or for other hosts. The destination address is also used by routers to determine how to forward the packet or frame through an internetwork. The destination address can be one of the following:

  • The physical address, such as the MAC address of an Ethernet frame

  • The logical address, such as the IP address of an IP packet

Destination addresses can be either specific or general. Specific addresses point to a specific host on the network. A general address points the packet or frame to all hosts on the network or multicasts it to a specific multicast group of hosts on the network.

NOTE

The other kind of address in a packet or frame is the source address. This is the address of the host from which the packet originates (unless the source address is being spoofed).

TIP

You can see the destination address of a packet or frame by using a network sniffer device such as Network Monitor, a tool included with Microsoft Systems Management Server (SMS). Network Monitor displays destination addresses in both ASCII and hexadecimal form.

See also
source address

device

Generally, any hardware component that can be driven by software.

In Microsoft Windows 2000, you can work with devices using the Device Manager, which you access through the System utility in Control Panel. In Windows NT, you can view, stop, and start devices using the Devices utility in Control Panel.

In Microsoft SQL Server version 6, a device is a file used to store SQL Server databases. Multiple SQL Server databases can be stored on a single device, and a single database can span multiple devices.

The master system device contains four databases:

  • The master system database, which is used for tracking system-wide information

  • The tempdb system database, which is used for temporary storage purposes

  • The model system database, which is a template for generating new databases

  • The pubs sample database, which is used in the examples in the SQL Server documentation

Device Manager

A Microsoft Windows 95 and Windows 98 troubleshooting tool that is part of the System utility in Control Panel. Device Manager is used for managing peripheral devices and their associated system resources.

You can use Device Manager to do the following:

  • View the name and manufacturer of a device

  • Identify devices that are disabled (displaying a red X) or in a problem state (displaying an exclamation point)

  • Display and modify the interrupt request line (IRQ), I/O port, and other resources for a device

  • Load a new driver for a device

  • Disable conflicting plug and play devices in order to free their resources

Graphic D-16. Device Manager.
Graphic D-16. Device Manager.
NOTE

Windows 2000 also has a Device Manager tool that graphically displays the hardware installed on the computer and allows you to configure that hardware. You can start it by clicking the Device Manager button on the Hardware tab in Control Panel’s System utility.

Dfs

See
Distributed file system (Dfs)

DHCP

See
Dynamic Host Configuration Protocol (DHCP)

DHCP client

A host on a TCP/IP internetwork that is capable of having its IP address information dynamically assigned using Dynamic Host Configuration Protocol (DHCP). The term “DHCP client” can also describe the software component on a computer that is capable of interacting with a DHCP server to lease an IP address.

Microsoft Windows comes with DHCP client software that you can configure when you install the TCP/IP protocol suite. This software allows a machine to immediately take its place in TCP/IP internetworks using DHCP. Other operating systems might require that the DHCP client software be installed and configured separately.

Microsoft operating systems that can function as DHCP clients include the following:

  • Windows 2000

  • Windows NT

  • Windows 98

  • Windows 95

  • Windows for Workgroups with the Microsoft TCP/IP-32 add-on installed

  • Network Client 3 for MS-DOS

  • LAN Manager 2.2c

NOTE

On machines running Windows 2000, the DHCP client is DNS-aware and uses dynamic update for registering addresses, which allows the IP address and fully qualified domain name (FQDN) of client machines to be assigned and supported together.

TIP

Windows NT, Windows 95, and Windows 98 clients can release and renew their IP address leases using the ipconfig command. This command can also be useful for resolving IP address conflicts or for troubleshooting DHCP clients and servers.

See also
DHCP server, Dynamic Host Configuration Protocol (DHCP)

DHCP client reservation

A process for configuring a Dynamic Host Configuration Protocol (DHCP) server so that a particular host on the network always leases the same IP address. You can create a client reservation on a DHCP server if you want the server to always assign the same IP address to a specific machine on the network. You might do this to assign IP addresses to servers on the network because the IP addresses of servers should not change. (If they do, client machines might have difficulty connecting with them.) An alternative and more common way to assign a client reservation to a server is to manually assign a static IP address to the server.

How It Works

On Microsoft Windows 2000–based networks you can create DHCP client reservations using the DHCP console, while in Windows NT you use DHCP Manager. Enter the MAC address as the client’s unique identifier. When the client with that address contacts the DHCP server to request an IP address, the server leases the reserved address to the client.

See also
DHCP console, DHCP Manager

DHCP Client service

The service in Microsoft Windows 2000 and Windows NT that implements the client component of the Dynamic Host Configuration Protocol (DHCP) on workstations and servers. You can use the DHCP client service to obtain IP addresses and other TCP/IP configuration information from a DHCP server (such as a Windows 2000 or Windows NT server running the DHCP Server service).

Microsoft Windows includes support for DHCP and provides client software that lets you manage a machine’s IP address over a network. This software runs as a service under Windows 2000 and Windows NT. DHCP simplifies the administration and management of IP addresses for machines on a TCP/IP network.

See also
DHCP Server service, Dynamic Host Configuration Protocol (DHCP)

DHCP console

A Microsoft Windows 2000 administrative tool for managing the DHCP Server service on Windows 2000 Server. The DHCP console is the main tool used for managing and configuring all aspects of the Dynamic Host Configuration Protocol (DHCP) on a Windows 2000–based network and is implemented as a snap-in for the Microsoft Management Console (MMC).

You can use the DHCP console for the following standard DHCP administration tasks:

  • Creating a scope of IP addresses to lease to DHCP clients

  • Creating a set of scope options, which are passed on to clients

  • Configuring the lease duration for IP addresses leased to clients

  • Viewing and terminating active leases on a network

  • Creating reservations for servers that need specific IP addresses

  • Monitoring DHCP statistics

Graphic D-17. The DHCP console for Windows 2000 Server.
Graphic D-17. The DHCP console for Windows 2000 Server.

The DHCP console also includes the following advanced features, which are new to Windows 2000:

  • Automatic detection of rogue DHCP servers on the network

  • Automatic self-assignment of temporary IP addresses to clients if a lease cannot be obtained from a DHCP server

  • New DHCP options for multicast groups (class D IP addresses), superscopes for grouping together DHCP scopes for management purposes, and other vendor-specific functions

  • Integration of DHCP and Domain Name System (DNS), allowing clients to use dynamic update to update their host names to IP address mappings in DNS server zone files

See also
Dynamic Host Configuration Protocol (DHCP)

DHCP lease

The duration for which a DHCP server loans an IP address to a DHCP client. You can configure the lease duration using the Microsoft Windows NT administrative tool DHCP Manager or the Windows 2000 console snap-in.

TIP

If your TCP/IP network configuration doesn’t change often or if you have more than enough IP addresses in your assigned IP address pool, you can increase the DHCP lease considerably beyond its default value of three days. However, if your network configuration changes frequently or if you have a limited pool of IP addresses that is almost used up, keep the reservation period short—perhaps one day. The reason is that if the pool of available IP addresses is used up, machines that are added or moved might be unable to obtain an IP address from a DHCP server and thus will be unable to participate in network communication.

See also
DHCP console, DHCP Manager

DHCP Manager

A Microsoft Windows NT administrative tool for managing the DHCP Server service on Windows NT Server. DHCP Manager is the main tool used for managing and configuring all aspects of the Dynamic Host Configuration Protocol (DHCP) on a Windows NT–based network. DHCP Manager is installed on a machine running Windows NT Server by using the Network utility in Control Panel to add the Microsoft DHCP Server service to the machine.

Graphic D-18. Administrative tool for Windows NT Server 4.0.
Graphic D-18. Administrative tool for Windows NT Server 4.0.

You can use DHCP Manager for the following tasks:

  • Creating a scope of IP addresses to lease to DHCP clients

  • Creating a set of scope options, which are passed on to clients

  • Configuring the lease duration for IP addresses leased to clients

  • Viewing and terminating active leases on a network

  • Creating reservations for servers that need specific IP addresses

See also
Dynamic Host Configuration Protocol (DHCP)

DHCP options

Additional IP address settings that a DHCP server passes to DHCP clients. When a DHCP client requests an IP address from a DHCP server, the server sends the client at least an IP address and a subnet mask value. Additional information can be sent to clients if you configure various DHCP options. You can assign these options globally to all DHCP clients, to clients belonging to a particular scope, or to an individual host on the network.

You can configure a number of different DHCP options using the Microsoft Windows NT administrative tool DHCP Manager and the Windows 2000 snap-in DHCP console, but the options listed in the following table are the ones most commonly used by Microsoft DHCP clients. In Windows NT–based networks options 3, 6, 44, and 46 are the most commonly used, while in Windows 2000–based networks options 3, 6, and 15 are commonly used.

DHCP Options
Number | Option | What It Configures
003 | Router | Default gateway IP address
006 | DNS Servers | IP addresses of DNS servers
015 | DNS Domain Name | Parent domain of associated DNS servers
044 | NetBIOS over TCP/IP Name Server | IP addresses of Windows Internet Name Service (WINS) server
046 | NetBIOS over TCP/IP Node Type | Method of NetBIOS name resolution to be used by the client
047 | NetBIOS over TCP/IP Scope | Restricts NetBIOS clients to communication with clients that have the same scope ID
See also
DHCP console, DHCP Manager

DHCP relay agent

A TCP/IP host that is configured to allow a single DHCP server to lease IP address information to DHCP clients on multiple subnets. DHCP relay agents make it unnecessary to maintain a separate DHCP server on every subnet in an internetwork. You can configure Microsoft Windows NT and Windows 2000 servers to operate as DHCP relay agents.

How It Works

The DHCP relay agent is a machine with the DHCP Relay Agent service installed and configured to forward DHCP requests to a DHCP server on a different subnet (as shown in the illustration). The process happens as follows:

  1. A DHCP client on the subnet where the DHCP relay agent is configured broadcasts a request for a lease from a DHCP server.

  2. Since there is no DHCP server on the client’s subnet, the DHCP relay agent picks up the client’s request and forwards it directly to the DHCP server on another subnet.

  3. The DHCP server responds to the request by offering a lease directly to the client.

    Graphic D-19. DHCP relay agent.
    Graphic D-19. DHCP relay agent.
TIP

To configure a machine running Windows NT Server as a DHCP relay agent, you must do two things:

  1. Install the DHCP Relay Agent service using the Services tab of the Network utility in Control Panel.

  2. Configure the DHCP server that the agent will pass requests to. Do this on the DHCP Relay tab of the Microsoft TCP/IP Properties sheet of the TCP/IP protocol.

TIP

To configure a Windows 2000 server as a DHCP relay agent, follow these steps:

  1. Open the Routing and Remote Access console from the Administrative Tools program group.

  2. Expand the server node to display General beneath IP Routing in the console tree.

  3. Right-click General, and select New Routing Protocol from the context menu.

  4. Specify DHCP Relay Agent in the New Routing Protocol dialog box, and click OK.

  5. Open the property sheet for DHCP Relay Agent under IP Routing in the console tree, specify the IP address of the DHCP server to which lease requests should be relayed, and click OK.

  6. Right-click DHCP Relay Agent in the console tree, and select New Interface to specify a router interface on which relay will be enabled.

See also
Dynamic Host Configuration Protocol (DHCP)

DHCP scope

A range of IP addresses that a DHCP server can lease out to DHCP clients. You configure the DHCP scope using the Microsoft Windows NT administrative tool DHCP Manager or the Windows 2000 snap-in DHCP console. The IP addresses are leased for a specific Time to Live (TTL), usually three days. Information about scopes and leased IP addresses is stored in the DHCP database on the DHCP server. The values for IP address scopes created on DHCP servers must be taken from the available pool of IP addresses allocated to the network. Errors in configuring the DHCP scope are a common reason for problems in establishing communication on TCP/IP networks.

TIP

If non-DHCP clients have static IP addresses that fall within the range of the server’s DHCP scope, these static IP addresses must be excluded from the scope. Otherwise, two hosts might end up with the same IP address, one assigned statically and the other assigned dynamically, resulting in neither host being able to communicate on the network.

See also
DHCP console, DHCP Manager

DHCP server

A server that dynamically allocates IP addresses to client machines using the Dynamic Host Configuration Protocol (DHCP). DHCP servers perform the server-side operation of the DHCP protocol. The DHCP server is responsible for answering requests from DHCP clients and leasing IP addresses to these clients.

DHCP servers should have static IP addresses. A DHCP server gives DHCP clients at least two pieces of TCP/IP configuration information: the client’s IP address and the subnet mask. Additional TCP/IP settings can be passed to the client as DHCP options.

NOTE

To have Microsoft Windows 2000 Server function as a DHCP server, install the DHCP Server service and manage it using the DHCP console snap-in for the Microsoft Management Console (MMC). To have Windows NT Server function as a DHCP server, install the DHCP Server service and configure it using the administrative tool DHCP Manager. Note that a DHCP server should generally not be a DHCP client—that is, it should have a static IP address.

TIP

If hosts on a TCP/IP network are randomly losing connectivity with the network one by one, the DHCP server might be down and unable to renew leases for IP addresses obtained by the clients. Without a valid IP address leased to them, DHCP clients cannot communicate over the network.

See also
DHCP client, DHCP Server service, Dynamic Host Configuration Protocol (DHCP)

DHCP Server service

The service in Microsoft Windows 2000 and Windows NT that implements the server component of the Dynamic Host Configuration Protocol (DHCP) on Windows 2000 Server or Windows NT Server. The DHCP Server service is an optional networking component that can be installed on

  • Windows NT Server by using the Network utility in Control Panel, selecting the Services tab, and adding the Microsoft DHCP Server service. When this service is installed on a machine running Windows NT Server, the administrative tool DHCP Manager is also installed.

  • Windows 2000 Server by using the Add/Remove Programs utility in Control Panel, selecting Add/Remove Windows Components, and selecting Dynamic Host Configuration Protocol (DHCP) from Networking Services. When this service is installed on a machine running Windows 2000 Server, the DHCP console administrative tool is implemented as a snap-in for the Microsoft Management Console (MMC).

NOTE

The DHCP Server service should generally be installed only on a machine that has a manually assigned static IP address.

See also
Dynamic Host Configuration Protocol (DHCP)

dial-up line

Any telecommunications link that is serviced by a modem. Dial-up lines are ordinary phone lines used for voice communication, while dedicated or leased lines are digital lines with dedicated circuits. Dial-up lines are generally much less expensive to use, but they have less available bandwidth.

Companies often use dial-up lines for occasional, low-bandwidth usage (such as remote access networking) or as a backup for more costly dedicated lines. Dial-up lines are shared with all subscribers in the Public Switched Telephone Network (PSTN) domain, while dedicated or leased lines are allocated solely to the subscriber’s private telecommunications domain.

See also
dedicated line

Dial-Up Networking

See
Network and Dial-up Connections

Dial-Up Networking Monitor

A Microsoft Windows NT utility accessed through Control Panel that shows status information for an active dial-up networking session. Dial-Up Networking Monitor is one of the tools included in Windows NT when Remote Access Service (RAS) is installed on the machine.

Dial-Up Networking Monitor shows the following information:

  • The condition of the selected RAS device

  • Device and connection statistics in bytes and frames in and out

  • Accumulated device errors and overruns

  • The networks and users your devices are connected to

  • Preferences for status icons and sounds

Graphic D-20. Dial-Up Networking Monitor.
Graphic D-20. Dial-Up Networking Monitor.
See also
Network and Dial-up Connections

DID

See
direct inward dialing (DID)

differential backup

A backup type in which only files and folders that have changed since the last normal backup are backed up. Unlike an incremental backup, a differential backup does not clear the archive attribute for each file and folder. You can use differential backups in conjunction with normal backups to simplify and speed up the backup process. If a normal backup is done on a particular day of the week, differential backups can be performed on the remaining days of the week to back up the files that have changed since the first day of the backup schedule. Differential backups are faster than normal backups and use less tape or other storage media.

NOTE

Differential backups are cumulative (unlike incremental backups), so when you need to do a restore, you need only the normal backup and the most recent differential backup. Differential backups take longer to complete than incremental backups, but they are faster to restore data from.

See also
backup type, incremental backup

digital

See
digital transmission

Digital Advanced Mobile Phone Service (D-AMPS)

The digital version of the Advanced Mobile Phone Service (AMPS), the standard analog cellular phone technology common throughout North America and around the world. Digital Advanced Mobile Phone Service (D-AMPS) cellular systems, which have been used since 1992, build on the large installed base of AMPS cellular network installations. D-AMPS is cheaper and easier to implement than Code Division Multiple Access (CDMA) cellular technologies, but its transmissions are not as secure.

How It Works

D-AMPS uses the same 800 to 900–MHz frequency bands and 30-kHz carrier spacing that AMPS uses, although a dual-band 800/1900 MHz system has also been implemented. D-AMPS differs from AMPS technology by using Time Division Multiple Access (TDMA) technology as its media access technique. TDMA splits each 30 kHz–wide AMPS channel into three additional channels. This triples the number of cellular phone channels available under AMPS. D-AMPS is an easier upgrade path from AMPS than Global System for Mobile Communications (GSM), which also uses TDMA technology but in an incompatible format.

See also
Advanced Mobile Phone Service (AMPS)

Digital Advanced Wireless System (DAWS)

A proposed standard for a multimegabit packet-switching radio network from the European Telecommunications Standards Institute (ETSI). The Digital Advanced Wireless System (DAWS) will be compatible with the existing packet radio system called the Terrestrial Trunked Radio (Tetra), which enables terminals to communicate directly with each other in regions without cellular coverage.

DAWS is being developed in response to the rapid deployment of Global System for Mobile Communications (GSM) wireless cellular communication systems and the increasing demand for high-speed wireless mobile data services in response to the phenomenal growth of the Internet in recent years. The ultimate goal of the DAWS effort is to provide mobile wireless Asynchronous Transfer Mode (ATM) data communication services with full-terminal mobility over wide areas of roaming. ATM has been selected by ETSI as the technology of choice for the backbone of the future envisaged European Information Infrastructure (EII).

DAWS will be designed to support applications that require data rates in excess of the 2-Mbps rate supported by the International Mobile Telecommunications-2000 (IMT-2000) standards, with eventual planned support for full ATM rates of 155 Mbps envisioned. Examples include wireless networking, Internet browsing, video conferencing, file transfer, and Voice over IP (VoIP).

See also
Terrestrial Trunked Radio (Tetra)

digital certificate

A technology for verifying the identity of the user or service you are communicating with. Digital certificates are issued by certificate authorities (CAs), which are public or private organizations that manage a public key infrastructure (PKI). The main function of a digital certificate is to associate a specific user with his or her public/private key pair.

Digital certificates are the networking equivalent of driver’s licenses, and they go hand in hand with encryption to ensure that communication is secure. Digital certificates verify the authenticity of the holder, and they can also indicate the holder’s privileges and roles within secure communication. They can be used like driver’s licenses for identification purposes or like bank cards (together with a password) to perform financial transactions in e-commerce and online banking. Digital certificates enable various rights, permissions, and limitations to be applied to their holders for various kinds of trusted communication purposes such as purchasing, government banking, benefits, and voting rights.

How It Works

A digital certificate consists of data that definitively identifies an entity (an individual, a system, a company, or an organization). Digital certificates are issued by and digitally signed with the digital signature of the CA (once the CA has verified the identity of the applying entity). In addition to identification data, the digital certificate contains a serial number, a copy of the certificate holder’s public key, the identity and digital signature of the issuing CA, and an expiration date. The CA also maintains a copy of the user’s public key in its centralized certificate storage facility.

Digital certificates are formatted according to an International Organization for Standardization (ISO) standard called X.509 v3. The X.509 standard specifies that a digital certificate must contain the following information fields:

  • Version number

  • Certificate serial number

  • Signature algorithm ID used

  • Name of certificate issuer

  • Validity period (for certificate expiration)

  • Subject name (name of certificate owner)

  • Public key information for subject

  • Unique identifier of certificate issuer

  • Unique identifier of subject

  • Extensions

  • Digital signature for all the above fields

Digital certificates and public key cryptography are used in the popular Secure Sockets Layer (SSL) protocol, which provides secure transactions over the Internet. Several types of digital certificates are involved in this process, including

  • CA certificate, which identifies the certificate authority, such as those based on Microsoft Certificate Server, and is used by Web browsers and Web servers to validate client and server certificates

  • Server certificate, which identifies a Web server such as Microsoft Internet Information Services (IIS)

  • Client certificate, which identifies a Web browser such as Microsoft Internet Explorer

NOTE

A digital certificate is not the same as a digital signature. A digital certificate is a file that certifies the owner’s identity, contains the owner’s public key, and can be used to support encrypted communication. The purpose of a digital certificate is to certify that the user has the right to use the public/private key pair that has been issued by the CA. A digital signature, on the other hand, contains identity information along with the message or document itself (which has been hashed using the private key of the sender), and it confirms the identity of the sender and ensures that the content of the message has not been modified in transit.

In other words, to send an encrypted transmission, a user signs the message with a digital signature. But in order to be able to do this at all, the user must first be issued a key pair and its associated digital certificate.

See also
digital signature

digital data service (DDS)

A family of leased line data communication technologies that provides a dedicated synchronous transmission connection at speeds of 56 Kbps. Digital data service (DDS) is only one example of a type of digital line; others include Integrated Services Digital Network (ISDN) and T1. DDS can be used in either multipoint or point-to-point communications and requires dedicated digital lines. DDS lines can also be used to connect buildings on a campus, usually with a maximum distance of about 3 miles.

How It Works

“DDS” was originally a trademark for an AT&T all-digital service running at 56 Kbps, but the term has evolved into a general descriptor for a variety of digital services offered by different carriers under various names. DDS is usually available in both a dial-up version called switched 56 and a dedicated leased line service for continuous connections. The dial-up version can serve as a backup for the dedicated version.

Typically, DDS uses four wires to support digital transmission speeds of 56 Kbps, but it is actually a 64-Kbps circuit that uses 8 Kbps for sending signaling information. Some vendors provide a variant of DDS with a data transmission rate of a full 64 Kbps.

To use DDS services for wide area network (WAN) connectivity, route packets from your local area network (LAN) through a bridge or a router, which is connected by means of a V.35 or RS-232 serial interface to a CSU/DSU (Channel Service Unit/Data Service Unit). The CSU/DSU is connected to the four-wire termination of the DDS line by means of an M-block connector, a screw terminal block, or some other connection mechanism. The Channel Service Unit (CSU) converts the data signal into a bipolar signal suitable for transmission over the telecommunications link. The DDS lines themselves use four wires and support speeds of 64 Kbps, but 8 Kbps of bandwidth is usually reserved for signaling, so the actual data throughput is usually only 56 Kbps.

Graphic D-21. Digital data service (DDS).
Graphic D-21. Digital data service (DDS).

DDS lines are dedicated lines with negligible connection establishment latency; they are always “on” and never “busy.”

See also
telecommunications services

digital line

An umbrella term for various kinds of digital telecommunications services. The distinguishing feature of a digital line is that it is digital from end to end and does not employ any kind of analog modem technologies. As a result, digital lines have higher traffic-carrying capacities, less noise, and better error-handling features than analog lines. The term “digital line” can refer to circuits based on the following:

  • Digital data service (DDS)

  • Integrated Services Digital Network (ISDN)

  • T-carrier services such as T1 lines, fractional T1, and T3

  • Switched 56 services

digital modem

Any type of modem used for synchronous transmission of data over circuit-switched digital lines. One example of a digital modem is an ISDN terminal adapter. Digital modems are not used for changing analog signals into digital signals because they operate on end-to-end digital services. Instead, they use advanced digital modulation techniques for changing data frames from a network into a format suitable for transmission over a digital line such as an Integrated Services Digital Network (ISDN) line. They are basically data framing devices, rather than signal modulators.

digital nervous system

A paradigm for electronic connectivity between businesses that enables them to create efficient, integrated systems that are easy to use and manage. The digital nervous system can be viewed as the next evolutionary phase of the Information Age.

The idea of this business paradigm is that businesses connect to each other in a way that is similar to the organization of a living organism. Digital information—whether it is text, graphics, audio, or video—flows between businesses much like electrical impulses flow between parts of the body. A stimulus of information entering one business that is generated by another business produces a response. The greater the complexity and the more interconnected the nervous system, the higher the organism—and the same applies to business. Greater interflow of digital information can lead to the evolution of new forms of doing business. The Internet and its related paradigms “intranet” and “extranet” serve as examples of this evolution. These concepts grew naturally—almost organically—from the complex interconnectedness fostered by advances in software and networking.

On the Web
•
Microsoft Digital Nervous System home page
: http://www.microsoft.com/dns

Digital Signal Zero

See
DS0

digital signature

An electronic signature that you can use to sign a document being transmitted by electronic means such as e-mail. Digital signatures validate the identity of the sender and ensure that the document they are attached to has not been altered by unauthorized parties during the transmission.

How It Works

Digital signatures are based on public key cryptography systems. In order for digital signatures to work, the sender must have both a digital certificate and a key pair issued by a certificate authority (CA) such as VeriSign, Inc. A digital signature for a particular document is created using a mathematical hash of the document, which is then encrypted using the sender’s private key. The resulting signature is attached to the document and transmitted. The receiver performs the same hash on the received document using the sender’s public key. If the two hashes match, it means that the message has been transmitted without corruption by the identified sender. Note that the particular content of a digital signature depends on the document being transmitted; it is different for each document sent.

See also
digital certificate

Digital Subscriber Line (DSL)

A telecommunications technology for providing high-speed transmission to subscribers over the existing copper wire twisted-pair local loop between the customer premises and the telco’s central office (CO). The Digital Subscriber Line (DSL) technology was designed to provide high-speed data and video-on-demand services to subscribers at speeds much faster than Integrated Services Digital Network (ISDN). The essential advantage of using DSL is that it allows much faster data transmission rates over existing copper local loop telephone lines than traditional modems.

DSL standards are still evolving, and implementation is not yet widespread in most locations. In addition, DSL is competing with cable modem technologies to replace ISDN for high-speed Internet access.

How It Works

DSL is not a specific digital line technology but rather a form of digital modem technology that defines the signaling processes for high-speed, end-to-end digital transmission over the existing copper twisted-pair wiring of the local loop. DSL accomplishes this by using advanced signal processing and digital modulation techniques. However, with DSL, the digital signals are not converted to analog or vice versa; instead, the signals remain digital for the complete communication path from the customer premises to the telco’s CO.

Usually, a DSL modem and a signal splitter are installed at the customer premises to separate voice and data signals. DSL modems can use a variety of modulation methods, including carrierless amplitude and phase modulation (CAP) or discrete multitone (DMT) technology modulation, depending on the vendor’s implementation. At the telco’s CO, a Digital Subscriber Line Access Multiplexer (DSLAM) connects subscribers to a high-speed Asynchronous Transfer Mode (ATM) backbone.

DSL actually represents a family of related services commonly referred to as “xDSL,” which includes the following:

  • Asymmetric Digital Subscriber Line (ADSL), which allocates line bandwidth asymmetrically with downstream (CO to customer premises) data rates of up to 9 Mbps and upstream rates of up to 640 Kbps, depending on the implementation

  • High-bit-rate Digital Subscriber Line (HDSL), which supports high-speed, full-duplex communication up to T1 or E2 speeds over multiple twisted-pair lines

  • Symmetric Digital Subscriber Line (SDSL), which supports standard telephone communication and T1 or E1 data communication over a single twisted-pair line

  • Very High-rate Digital Subscriber Line (VDSL), which supports downstream speeds of up to 52 Mbps over short distances

Depending on the type of xDSL technology used, signal modulation by the DSL modem might use CAP, DMT, or some other modulation process. (CAP is currently the most popular implementation.)

digital transmission

Transmission of signals that vary discretely with time between two values of some physical quantity, one value representing the binary number 0 and the other representing 1. With copper cabling, the variable quantity is typically the voltage or the electrical potential. With fiber-optic cabling or wireless communication, variation in intensity or some other physical quantity is used. Digital signals use discrete values for the transmission of binary information over a communication medium such as a network cable or a telecommunications link. On a serial transmission line, a digital signal is transmitted 1 bit at a time.

The opposite of digital transmission is analog transmission, in which information is transmitted as a continuously varying quantity. An analog signal might be converted to a digital signal using an analog-to-digital converter (ADC) and vice versa using a digital-to-analog converter (DAC). ADCs use a method called “quantization” to convert a varying AC voltage to a stepped digital one.

Graphic D-22. Digital transmission.
Graphic D-22. Digital transmission.

direct burial fiber-optic cabling

A cable consisting of multiple fiber-optic cables bundled together and enclosed in a protective sheath. Direct burial fiber-optic cabling is designed to be buried in trenches and contains a gel filling that protects the individual fibers from temperature and moisture variations. A strip of strengthening material runs axially down the cable to prevent excessive bending, which can fracture the individual fibers. Direct burial cabling can have steel-armor construction with heavy waterproof polyethylene jackets and can contain either multimode or single-mode fiber-optic strands.

Graphic D-23. Direct burial fiber-optic cabling.
Graphic D-23. Direct burial fiber-optic cabling.
TIP

Direct burial cabling is more cost-effective than single-fiber cabling for long outdoor cable runs between buildings or across a campus because it allows for future bandwidth upgrades.

See also
fiber-optic cabling

Direct Cable Connection

A Microsoft Windows 95 and Windows 98 tool that enables file transfers between two computers running Windows 95 and/or Windows 98 using a serial null-modem cable or a standard parallel cable. You can use Direct Cable Connection to establish a temporary network connection for the purpose of transferring files between machines.

How It Works

One computer must be designated as the host (the server) and the other as the guest (the client). The desired resources must be shared on the host computer, and Dial-Up Networking must be installed on the guest computer.

TIP

The host computer can also act as a router that allows the guest computer to access resources on other computers on the host computer’s network.

directed frame

A frame that is being sent by one station to a specific destination station on the network. On an Ethernet network, a directed frame is one that uses the hexadecimal MAC address of a specific target machine on the network as its destination address. The directed frame is picked up by the target machine and is ignored by all other machines on the network.

Directed frames are used for most network communication because they are the most efficient type of frame for communication. However, some services, such as network announcements, require that all stations on the network receive a frame. To send a frame to all stations on the network, you use a broadcast frame instead of a directed frame.

See also
broadcast frame

directed packet

An Internet Protocol (IP) packet that is being sent by one host on a TCP/IP network to a specific destination host on the network. A directed packet contains the IP address of a specific target host on the network as its destination address. The directed packet is picked up by the target host and is ignored by all other hosts on the network.

Directed packets are used for most network communication on a TCP/IP network because they are the most efficient method for communication. However, some services, such as network announcements, require that all hosts on the network receive a packet. To send a packet to all stations on the network, you use a broadcast packet instead of a directed packet.

See also
broadcast packet

direct inward dialing (DID)

A service provided by a local exchange carrier (LEC) to a corporate client. Direct inward dialing (DID) uses a Private Branch Exchange (PBX) that allows outside callers to directly dial individuals within the company.

How It Works

The LEC allocates a block of phone numbers to the company, usually differing only in the last two, three, or four digits. For example, a company with 50 employees who each need a separate phone number could be assigned the numbers 555-1201 through 555-1250. Outside callers could dial the employees directly using these numbers, which are routed through perhaps only eight trunk lines that service the PBX, supporting a maximum of eight simultaneous calls. Inbound calls are routed by the PBX to the appropriate extension.

directory

See
Active Directory, directory database, directory service

Directory Access Protocol (DAP)

A protocol for accessing information in a directory service based on the X.500 recommendations. The Directory Access Protocol (DAP) specifies how an X.500 Directory User Agent (DUA) communicates with a Directory System Agent (DSA) to issue a query. Using DAP, users can view, modify, delete, and search for information stored in the X.500 directory if they have suitable access permissions.

DAP is a complex protocol with a lot of overhead, which makes it generally unsuitable for implementations in a Microsoft Windows environment. A simpler version called Lightweight Directory Access Protocol (LDAP) is growing in popularity and can be used to access and update directory information in X.500 directories. LDAP is more suitable than DAP for implementation on the Internet and has mostly superseded DAP as an access protocol for X.500-based directories (which are now often called LDAP directories).

directory database

The central store of account and security information on a network. In Microsoft Windows NT and Windows 2000, the directory database resides on the domain controllers, which manage all security-related aspects of the network. In Windows NT, the directory database is generally called the Security Accounts Manager (SAM) database. In Windows 2000, the directory database is the database component of Active Directory.

The SAM database in Windows NT stores information about users, groups, and computers that participate in the domain. It also stores security policy information such as password expiration policies and audit policies. The SAM database stores its information in a privileged area of the registry.

NOTE

The practical upper limit for a SAM database is 40 MB, which corresponds to approximately 26,000 user and computer accounts. If an enterprise has more than 26,000 users, the Windows NT directory database can be partitioned (split) into two or more portions and trust relationships can be configured according to a multiple master domain model.

directory export

The process of exporting information from a directory service. Microsoft Exchange Server supports the exporting of information about recipients stored in its directory database. This information can be exported to a comma-delimited text file (.csv file), edited, and then imported into another system.

For example, you can import recipient information into a spreadsheet to print it out. Or you can export the information into a spreadsheet, use spreadsheet functions to mass-modify certain fields, and then use directory import for reimporting the modified account information back into Exchange. Using directory export/import is in fact the usual method in Exchange for modifying the properties of a large number of recipients at one time.

Graphic D-24. Directory export.
Graphic D-24. Directory export.
See also
directory import

directory hierarchy

The hierarchy of all containers and leaf objects in a Microsoft Exchange Server directory, which is displayed and configured using the Exchange Administrator program. This hierarchy is based on the directory recommendations given by X.500.

Graphic D-25. Directory hierarchy.
Graphic D-25. Directory hierarchy.
How It Works

The Exchange directory hierarchy begins at a root object called the Organization container, and then branches down into sites, servers, connectors, recipients, and other objects. To configure any object in the directory hierarchy, you use its property sheet.

Objects in the directory hierarchy of Exchange come in two types:

  • Containers, which can contain other directory objects. Containers usually also have configurable properties.

  • Leaf objects, which are end nodes in the directory tree and whose properties can be configured using their property sheets.

directory import

The process of importing information into a directory service. The information to be imported must be in a format that the importing system can understand, usually a delimited text file such as a .csv file. Microsoft Exchange Server allows recipient information to be imported into its directory database and allows recipients exported from other mail systems to be imported into Exchange. For example, you can use the Exchange Migration Wizard to extract mailbox information from a foreign mail system into a .csv file. You can then import this information into a spreadsheet program such as Microsoft Excel, modify it as needed, and import it into Exchange to create new mailboxes in your organization for users of the foreign mail system who are migrating to Exchange.

See also
directory export

directory replication in Microsoft Exchange Server

The replication of Microsoft Exchange Server directory information between Exchange servers within an Exchange organization. The Exchange directory database contains information about the various recipients in the organization and configuration information for all components of Exchange. Directory replication is a process that copies this information between Exchange servers so that all Exchange servers in an Exchange organization have easy access to this critical information.

How It Works

Directory replication in an Exchange organization gives each Exchange server a complete, up-to-date copy of all directory information for the entire organization. Directory replication occurs differently depending on whether Exchange servers are in the same site.

Within an Exchange site, intrasite replication of directory information takes place automatically and uses remote procedure calls (RPCs) between servers. You cannot configure this operation. Replication takes place approximately five minutes after a change is made to the directory. The server in which the change was made notifies other directories one at a time, and the other servers send the first server RPC messages requesting updates to the directory.

Between Exchange sites, intersite replication requires that you first establish messaging connectivity between sites using a connector such as the Site Connector. Then you must install and configure the Directory Replication Connector. Replication of directory changes takes place using standard e-mail messages communicated between the Exchange directory services on each machine. One server in each site is designated as a bridgehead server for requesting directory updates from the other site. You can schedule intersite directory replication to occur at off hours in busy networks or more frequently in networks in which frequent changes to recipients are made.

directory replication in Windows 2000

The process of replicating updates to Active Directory on different domain controllers in the network. Directory replication ensures that users have access to resources on the network by ensuring that information about users, groups, computers, file shares, printers, and other directory objects is current on all domain controllers in the network.

How It Works

Directory replication of Active Directory on a Microsoft Windows 2000–based network takes place in two ways, depending on whether the participating domain controllers are in the same site.

Within a site, intrasite replication between domain controllers uses remote procedure calls (RPCs) by means of a dynamically allocated port number. This replication takes place automatically every five minutes. Domain controllers within a site exchange update information in a ring fashion, from one domain controller to another. This ring topology is established by a periodically running process called the Knowledge Consistency Checker (KCC) and ensures a minimum of two replication paths between each pair of domain controllers and a maximum replication hop count of three hops to support efficient replication and fault tolerance.

Between sites, intersite replication can use RPCs if the local area network (LAN) or wide area network (WAN) connection supports them or some other method such as Simple Mail Transfer Protocol (SMTP) e-mail messages. Intersite replication uses a compressed format for more efficient use of slow WAN links and is easier to schedule and manage than intrasite replication.

TIP

To take advantage of the greater flexibility of intersite replication and to use it instead of intrasite replication, configure your domain controllers to belong to more than one physical site.

directory replication in Windows NT

The replication of a tree of folders from one server to another using the Directory Replicator Service. You can use directory replication to create and manage identical directory structures on different Microsoft Windows NT servers and workstations. When a change is made to the master directory structure, such as modification of a file or addition of a directory, that change is replicated to the other computers.

One use for directory replication is to provide a means for load balancing file system information across several servers. This allows more clients to efficiently access the data stored in the replicated directory structure because identical data is stored on different machines. For example, you might replicate a database of customer information across several servers in your network to provide easier access. You can also use directory replication to copy logon scripts from a primary domain controller (PDC) to a set of backup domain controllers (BDCs). You can configure replication to occur between different computers in a domain or from one domain to another.

How It Works

The export server is the computer that contains the master copy of the directory tree to be replicated. This export server must be a machine running Windows NT Server. The computers that will replicate with the export server are called import servers. Import servers can be machines running Windows NT Server, Windows NT Workstation, or LAN Manager Server.

Prior to configuring directory replication, you must create a new user account as a security context within which the replicator service will run. This account should have a password that never expires and should be a member of the Replicator, Domain Users, and Backup Operators groups. The account should be accessible from both export and import machines. Use the Services utility in Control Panel to configure the Directory Replicator Service to start automatically upon system startup and to use your new account for logging on.

Server Manager is the administrative tool used for configuring replication in Windows NT. You can configure replication to occur either immediately after a change is made to the directory structure or after a stabilization period. When configuring replication, you select one of the following options:

  • Replicate the entire subtree of directories and files beneath a specific directory on the export server.

  • Replicate only specific files contained in the subtree by applying locks to its directories and files to prevent them from being exported.

By default, the export directory in which the master copy of the replicated data is contained is located in the following path:

%SystemRoot%\system32\repl\export

The default path to which the directory structure is imported on the import server follows:

%SystemRoot%\system32\repl\import
NOTE

Do not use directory replication as a substitute for a regular program of tape backups. The Directory Replicator Service can create a lot of network traffic and should not be used for backing up data across a network. If the data you are replicating contains large files that change frequently, replication traffic can cause network congestion unless you watch it carefully. Be especially careful when you replicate directory structures over slower WAN links to avoid congestion that interferes with other essential forms of traffic such as logon traffic.

TIP

The Directory Replicator Service on Windows NT can export only one directory tree from a given export server. It is a good idea to leave the default export location as it is and move the directory structure and information you want to replicate to this default export location. This allows you to also replicate logon scripts because by default these are located on a PDC in the location

%SystemRoot%\system32\repl\export\scripts

and on a BDC in the location

%SystemRoot%\system32\repl\import

Since these script directories are located within the default export and import paths, they can be replicated along with other data.

Directory Replicator Service

A Microsoft Windows NT and Windows 2000 service for replicating files and folders over the network. The Directory Replicator Service simplifies the task of updating key network configuration files needed by all users, such as system policies and logon scripts. You can also use directory replication to load balance between multiple servers when a large number of users need access to specific files or folders.

Graphic D-26. Directory Replicator Service.
Graphic D-26. Directory Replicator Service.
How It Works

The Directory Replicator Service replicates files from an export computer to an import computer. The export computer must be running the Windows NT Server operating system, but the import computer can run Windows NT Server, Windows NT Workstation, or LAN Manager for OS/2 servers.

The files and folders to be replicated must be placed in subdirectories of the REPL$ administrative share located at %SystemRoot%\system32\repl\export. (The export folder is shared when the Directory Replicator Service is started using the Services utility in Control Panel.) These subdirectories are automatically exported to the %SystemRoot%\system32\repl\import directory on the import computer.

Use the Windows NT administrative tool Server Manager to configure directory replication.

directory service

A tool for locating, managing, and organizing network resources, which can include volumes, folders, files, printers, users, groups, and other objects. A directory service is a core component of a network operating system (NOS) and functions much like the yellow pages of a phone book. For example, if you look up “printers,” you’ll find a list of available printers and information for accessing them. However, for a directory service to function like a network yellow pages, it must be combined with a complementary entity, the directory database.

The directory database is the hierarchical database structure that contains the actual information about the various resources on the network. In other words, you need a directory database, which contains the directory information, and a directory service, which allows you to search for and locate information stored in the directory. For simplicity, however, the terms “directory” and “directory service” are often used to refer to the combination of directory and directory service.

Examples of directory services produced by different vendors and standards bodies include the following:

  • Windows NT Directory Services (NTDS) for Windows NT

  • Active Directory for Windows 2000

  • Novell Directory Services (NDS) for Novell NetWare version 4.x

  • X.500, an International Organization for Standardization/International Electrotechnical Commission (ISO/IEC) standard for directory services

An enterprise-level directory service (a service suitable for an enterprise-level network with thousands of users that is spread over a large geographical area) has the following essential characteristics:

  • It is scalable so that it can grow to accommodate information and provide services as the enterprise itself grows.

  • It is extensible with a schema that can be modified by adding new classes, objects, and attributes.

  • It provides simple ways of finding directory objects that are based on industry standards such as X.500, Lightweight Directory Access Protocol (LDAP), and Domain Name System (DNS).

  • It can be administered from a single point on the network.

Active Directory for Windows 2000 satisfies all these conditions.

See also
Active Directory, directory database

directory service log

A log that contains events written by Active Directory on machines running Microsoft Windows 2000. The directory service log exists only on domain controllers because these are the only computers that have copies of Active Directory. The directory service log contains events such as informational, warning, and error events concerning operations that have been performed on or by Active Directory. These events reveal the state of Active Directory and can be used for diagnostic and troubleshooting purposes.

Information in the directory service log can be displayed using Event Viewer, a Windows 2000 administrative tool that runs as a snap-in for the Microsoft Management Console (MMC). Event Viewer for Windows 2000 supports a number of different kinds of logs in addition to the three supported in the Windows NT version of Event Viewer, namely the system log, security log, and application log. The actual types of event logs available in Windows 2000 Event Viewer depend on which optional networking components are installed on the machine.

Directory Service Manager for NetWare (DSMN)

An add-on utility for Microsoft Windows NT Server. Directory Service Manager for NetWare (DSMN) enables Windows NT domain controllers to manage account information on NetWare 2.x , 3.x , and 4.x servers. It does this by copying NetWare account information to the primary domain controller (PDC) and then propagating changes back to the bindery on the NetWare servers. DSMN also synchronizes accounts across all NetWare servers, allowing users to access any NetWare server using a single logon username. DSMN does not come with Windows NT but can be ordered separately from your Microsoft value-added reseller (VAR).

NOTE

DSMN supports NetWare 4.x servers only when they are running in bindery emulation mode, not in Novell Directory Services (NDS) mode.

Directory Service Markup Language (DSML)

A proposed specification based on XML (Extensible Markup Language) that will enable directory systems to share information. The Directory Service Markup Language (DSML) schema for XML provides mechanisms for accessing information in directories even if the format of the data is unknown. The DSML working group is open; it includes IBM, Novell, and Oracle and is supported by other directory vendors, including Microsoft. A related initiative is the Directory Interoperability Forum (DIF), whose aim is to establish a standard that will enable use of the Lightweight Directory Access Protocol (LDAP) for performing data queries across multiple directories. DSML and DIF are separate initiatives, but they might eventually merge or be subsumed within a wider objective.

On the Web
•
DSML working group
: http://www.dsml.org

directory synchronization in a Windows NT domain

The process whereby the domain directory databases of backup domain controllers (BDCs) in a Microsoft Windows NT domain are synchronized with the master directory database on the primary domain controller (PDC). Accurate and reliable directory synchronization is the foundation for effective operation of Windows NT Directory Services (NTDS).

TIP

If directory synchronization must be performed over slow WAN links, you can adjust some registry parameters to make directory synchronization more efficient and prevent it from consuming excessive bandwidth. For more information, see the Microsoft Official Curriculum (MOC) course MS 689: Microsoft Windows NT Server 4.0 Enterprise Technologies.

See also
domain controller

directory synchronization in Microsoft Mail

The process by which information stored in Microsoft Mail 3.x mail systems is replicated between postoffices. There is only one directory server postoffice in a Microsoft Mail 3. x mail system; other postoffices that participate in directory synchronization are called requestor postoffices. Requestor postoffices send their address list updates to the directory server postoffice, which then sends cumulative changes back to the requestor postoffice. Directory synchronization also ensures that the global address list is updated.

directory synchronization process

Any process used for exchanging directory information between directory services implemented by different vendors or on different platforms. For example, the exchange of directory information between Active Directory in Microsoft Windows 2000 and Novell Directory Services (NDS) in Novell NetWare takes place using directory synchronization. Directory synchronization is different from directory replication, which always takes place between directory services from the same vendor or on the same platform. For example, domain controllers in a Windows 2000–based network maintain Active Directory by exchanging directory updates using directory replication.

NOTE

Microsoft provides special directory synchronization agents that support the exchange of directory information between Active Directory and NDS. It also provides an agent for synchronizing Microsoft Exchange Server directory services with Active Directory. The Microsoft Exchange directory service is based on the Lightweight Directory Access Protocol (LDAP).

direct sequencing

One of two popular spread spectrum transmission technologies for wireless networking, the other being frequency hopping. Direct sequencing can be used for both wireless local area network (LAN) connections and as part of a cellular telephone technology.

How It Works

Direct sequencing systems transmit data 1 bit at a time instead of packaging data into multibit packets, as in frequency hopping. Each bit of data is transmitted simultaneously over a range of frequencies in the 902 to 928–MHz frequency band. Spreading the data over multiple frequencies reduces signal loss due to noise and interference.

In direct sequencing, the transmitter feeds each bit of the data stream into a signal spreader that multiplies the input, creating a wideband signal. The wideband signal is then amplified and broadcast by using an antenna.

Graphic D-27. Direct sequencing.
Graphic D-27. Direct sequencing.

Direct sequencing has a faster theoretical maximum data transmission rate than frequency hopping, but in practice the two methods provide similar throughput for wireless transmission of data because of protocol overhead in typical wireless communication systems.

See also
spread spectrum, wireless networking

discretionary access control list (DACL)

In Microsoft Windows 2000, an internal list attached to an object in Active Directory that specifies which users and groups can access the object and what kinds of operations they can perform on the object. In Windows 2000 and Windows NT, an internal list attached to a file or folder on a volume formatted using the NTFS that has a similar function.

How It Works

In Windows 2000, each object in Active Directory or a local NTFS volume has an attribute called Security Descriptor that stores information about

  • The object’s owner (the security identifier or the owner) and the groups to which the owner belongs.

  • The discretionary access control list (DACL) of the object, which lists the security principals (users, groups, and computers) that have access to the object and their level of access.

  • The system access control list (SACL), which lists the security principals that should trigger audit events when accessing the list.

The DACL for an object specifies the list of users and groups that are authorized to access the object and also what levels of access they have. The kinds of access that can be assigned to an object depend on the type of object under consideration. For example, a file object can have read access assigned to a user but a printer object cannot. (You can’t read a printer!)

The DACL for an object consists of a list of access control entries (ACEs). A given ACE applies to a class of objects, an object, or an attribute of an object. Each ACE specifies the security identifier (SID) of the security principal to which the ACE applies, as well as the level of access to the object permitted for the security principal. For example, a user or group might have permission to modify all or some of the attributes of the object, or might not even have permission to be aware of the object’s existence. In common parlance, DACLs are sometimes simply referred to as access control lists or ACLs, though this is not strictly correct.

NOTE

The owner of an object always has permission to modify its DACL by granting permissions to other users and groups.

See also
access control, access control entry (ACE), access control list (ACL), system access control list (SACL)

Disk Administrator

A Microsoft Windows NT administrative tool used for managing hard drives.

You can use Disk Administrator to

  • Create, delete, and format partitions, volume sets, and stripe sets

  • Mark partitions as active

  • Assign drive letters and volume labels

  • Create mirror sets and stripe sets with parity

NOTE

In Windows 2000, the Disk Administrator tool is part of the Storage tools within the Computer Management tool.

Graphic D-28. Disk Administrator.
Graphic D-28. Disk Administrator.

Disk Cleanup

A utility included with Microsoft Windows 98 that helps you reclaim space on your hard drive by deleting files you no longer need. You can use Disk Cleanup to select the types of files to uninstall and to inspect and remove files in the Recycle Bin, temporary files, Internet cache files, and unneeded Microsoft ActiveX components. You can also use Disk Cleanup to remove optional Windows components that you no longer need, remove programs that you installed, and convert a FAT16 partition to FAT32.

NOTE

You can configure Disk Cleanup to automatically run when your disk is low on space.

Graphic D-29. Disk Cleanup.
Graphic D-29. Disk Cleanup.

Disk Defragmenter

A utility included with Microsoft Windows 95, Windows 98, and Windows 2000 that can rearrange files on a hard drive to free up contiguous disk space and improve performance. The screen capture shows the Windows 95 and Windows 98 Disk Defragmenter at work.

How It Works

Disk Defragmenter examines a drive for fragmented files, which are files whose data is scattered over different parts of the drive. Fragmentation occurs as files are deleted and created on a drive. Fragmentation slows down read/write disk operations. Disk Defragmenter moves the pieces of fragmented files to a single, contiguous location on the drive. This allows the files to be accessed more efficiently.

Graphic D-30. Disk Defragmenter.
Graphic D-30. Disk Defragmenter.

On machines running Windows 2000, you can use Disk Defragmenter to defragment FAT16, FAT32, and NTFS volumes.

NOTE

Disk Defragmenter does not move files that have both hidden and system attributes or mounted compressed volume files.

TIP

The Disk Defragmenter tool for Windows 2000 runs as a snap-in for Microsoft Management Console (MMC).

disk duplexing

A fault tolerant disk technology supported by Microsoft Windows NT Server. Disk duplexing is essentially the same as disk mirroring, except that a separate disk drive controller is used for each mirrored drive to provide additional fault tolerance. This provides two levels of fault tolerance:

  • If one drive fails, the other contains a mirrored copy of the data.

  • If one controller fails, the other controller continues to function.

You can establish disk duplexing on Windows NT systems at the partition level. In terms of system recovery and management, there is no difference between disk mirroring and disk duplexing.

diskperf command

A Microsoft Windows NT and Windows 2000 command for starting and stopping disk performance counters for Performance Monitor (System Monitor in Windows 2000). Counters for the objects Logical Disk (partition) and Physical Disk (drive) are disabled by default because a performance hit of a few percent can occur if they are enabled. You must run the diskperf command prior to monitoring disk activity with Performance Monitor. On some disk subsystems, enabling these counters might produce a small decrease in system performance, so you should disable them when monitoring of the system is completed. You must reboot the system after running diskperf.

Example

diskperf –n sets the system to not use any disk performance counters.

For the full syntax of this command, type diskperf /? on the command line.

disk quotas

A feature of Microsoft Windows 2000 that administrators can use to track and control disk usage on a per-user basis for each NTFS file system volume that the user stores data on.

Depending on how disk quotas are configured, when a user exceeds the specified disk limit, one of two things can occur:

  • An event is logged to the system log.

  • Disk access is blocked and an event is logged. The user is presented with an “insufficient disk space” error.

How It Works

Support for disk quotas is built into the new version of NTFS on Windows 2000. Disk quotas are tracked independently for each NTFS volume even if several volumes are on the same physical disk. For purposes of managing disk quotas for users, disk space usage is based on file and folder ownership. Windows 2000 ignores compression when it calculates how much disk space a user is utilizing. Whatever is unallocated in a user’s disk quota is reported as free space for applications that allow the user to access disk space.

You use the Quota tab on the property sheet for an NTFS volume to enable disk quotas, set quota limits, and specify what happens when users exceed their quotas. To configure disk quotas for users, you essentially specify two values:

  • Quota limit:
    How much disk space the user is allowed to use

  • Quota threshold:
    The conditions under which an event should be logged to indicate that the user is nearing his or her quota limit

For example, if the quota limit for a user is set to 10 MB while the quota threshold is specified as 8 MB, an event is logged when the user stores more than 8 MB of data on the volume, and the user is prevented from storing more than 10 MB of data on the volume.

To view the status of disk quotas on an NTFS volume for which this feature has been enabled, open the volume’s property sheet and examine the traffic light icon. The light is

  • Red if quotas are disabled

  • Yellow if the NTFS file system is recalculating the status of quota compliance

  • Green if quotas are enabled

NOTE

Disk quotas are specified on a per-volume basis. That is, disk usage is tracked independently for different volumes.

Graphic D-31. Disk quotas.
Graphic D-31. Disk quotas.
TIP

If you want to track disk usage by user but don’t want to deny users access to a volume, you can enable disk quotas but specify that users can exceed their disk quota limit. Note also that enabling disk quotas incurs slight overhead in file system performance.

To use disk quotas on an NTFS volume, enable this feature when the volume is created and before any users have access to it. Begin by setting more restrictive settings for all users, and then relax these settings for users who need more disk space or work with large files.

disk status

In the Disk Management portion of the Computer Management tool of Microsoft Windows 2000, information about whether the disk is healthy or has a problem. The Status column can show the status indicators given in the following table. The letter “B” indicates that the status indicator can apply to basic disks, and “D” indicates dynamic disks.

Disk Status
Disk Status | Description/Prescription
Online (BD) | The disk is accessible. There are no problems.
Online—Errors (D) | I/O errors detected. Try reactivating the disk to see whether the errors are transient.
Offline (D) | The disk is not accessible and might be corrupted, disconnected, or powered down. Try reactivating the disk, and check the cables and the controller.
Foreign (D) | The disk has been moved to this machine from another computer running Windows 2000. You must import the foreign disk before you can use it.
Unreadable (BD) | The disk is not accessible and might be corrupted, have I/O errors, or hardware failure. Try rescanning the disk or rebooting the system to see whether it recovers.
Unrecognized | The disk type is unknown, and the disk is probably from a different operating system, such as UNIX.
No Media | The drive is either a CD-ROM drive or some type of removable drive and has no media in it.

distance vector routing algorithm

Also called the Bellman-Ford algorithm, a routing algorithm in which every router maintains a database with one entry for each possible destination on the network. The Routing Information Protocol (RIP), which is supported by Microsoft Windows NT and Windows 2000, is one example of a dynamic routing protocol that uses the distance vector routing algorithm.

How It Works

When this algorithm is used by a routing protocol, each router advertises its routing table to its adjacent neighbors. Each advertisement contains the following information about each route in that routing table:

  • The hop count for the route (the distance)

  • The direction in which the route is located (the vector)

These advertisements are performed independently by all routers (that is, no synchronization exists between advertisements made by different routers). In addition, routers receiving advertisements do not generate acknowledgments, which reduces the overhead of routing protocol traffic.

Routers select the route with the lowest cost to each possible destination and add this to their own routing tables. These neighbors propagate the information to their neighbors hop by hop until information from all routers has spread throughout the entire internetwork.

Distance vector routing protocols (that is, protocols based on the distance vector routing algorithm) are simpler to understand and easier to configure than link state routing algorithm protocols. The main disadvantage of the distance vector routing algorithm is that changes are propagated very slowly throughout a large internetwork because all routing tables must be recalculated. This is called the Slow Convergence Problem. Other disadvantages are that routing tables can become extremely large, making distance vector routing protocols unsuitable for large internetworks, and that route advertising generates a large amount of traffic overhead.

The following table shows correspondence between routable network protocols and distance vector routing protocols.

Correspondence Between Protocols
Network Protocol | Distance Vector Routing Protocol
IP | RIP or Interior Gateway Routing Protocol (IGRP)
IPX | RIP
AppleTalk | RTMP
NOTE

Windows NT Server version 4 supports RIP version 1 for Internet Protocol (IP), RIP for Internetwork Packet Exchange (IPX), and Routing Table Maintenance Protocol (RTMP) for AppleTalk. Windows NT Server version 4 with Microsoft’s Routing and Remote Access Service (RRAS) installed supports RIP version 2 for IP.

See also
link state routing algorithm

distinguished name

The native address format for recipients in Microsoft Exchange Server. Also, one of the addressing formats for objects within Active Directory in Microsoft Windows 2000. Distinguished names are part of the X.500 directory specifications and are used for locating and accessing objects using the Lightweight Directory Access Protocol (LDAP).

How It Works

In Active Directory for Windows 2000, every object in the directory has a unique name. Three kinds of names can be used to define a specific object in Active Directory:

  • A distinguished name, which specifies the complete path to the object through the hierarchy of containers

  • A relative distinguished name (RDN), which is the portion of the name that is an attribute of the object itself

  • A user principal name (UPN), which is the name used when a user logs on to the network

For example, consider a user object within Active Directory. A user object is an example of a leaf object because it cannot contain other objects. User objects such as Jeff Smith are identified using common names (CNs). A container is a directory object that can contain other objects. In Active Directory, containers are referred to as organizational units (OUs) because they are used to organize other objects into hierarchies of containers. For example, the user Jeff Smith would typically be contained within the Users container. At the top of the container hierarchy are the containers that represent different components of the domain itself. These components are called domain components (DCs). For example, if user Jeff Smith exists in the microsoft.com domain, the distinguished name for this user is represented by the path

DC=com,DC=microsoft,OU=Users,CN=Jeff Smith

In Microsoft Exchange Server, distinguished names are used to identify recipients. Exchange automatically creates a distinguished name for every recipient object in its directory database, including objects such as mailboxes, distribution lists, and public folders. For example, if a user Jeff Smith has a mailbox named JeffS located on an Exchange server in Redmond at the organization Microsoft, the distinguished name for this user would be represented internally as

O=Microsoft,OU=Redmond,CN=Recipients,CN=JeffS

The Message Transfer Agent (MTA) uses a recipient’s distinguished name to determine how to route messages to that recipient within an Exchange organization.

TIP

Exchange Server also automatically generates X.400 addresses for every object in the directory. Don’t delete these addresses, even if you have no X.400 Connectors installed in your sites, because if Exchange Server cannot use a recipient’s distinguished name for any reason, it uses the recipient’s X.400 address for message routing.

distributed application

An application consisting of two or more parts that run on different machines but act together seamlessly. In the simplest scenario, the user interface part runs on a client machine, while the processor-intensive or storage-intensive part runs on a server. This type of distributed application is called a client/server application. Examples include the following:

  • Microsoft Exchange Server (back end) as a mail server with users running Microsoft Outlook (front end) on their client machines

  • Microsoft Access (front end) as an interface for accessing database information stored in Microsoft SQL Server (back end)

  • A Web application written using Active Server Pages (ASP) for Internet Information Services (IIS) (back end) that is accessed from a client machine running Microsoft Internet Explorer (front end)

NOTE

Microsoft Windows operating systems use interprocess communication (IPC) to enable seamless communication between the client and server parts of distributed applications.

Distributed Component Object Model (DCOM)

A technology for component-based development of software that is network-aware. Using Distributed Component Object Model (DCOM), developers can create network-aware applications using Component Object Model (COM) components. DCOM works under various network transports, including TCP/IP.

How It Works

DCOM is a client/server protocol that provides distributed network services to COM, allowing DCOM-enabled software components to communicate over a network in a similar fashion to the method by which COM components communicate among themselves on a single machine. DCOM client objects make requests for services from DCOM server objects on different machines on the network using a standard set of interfaces.

Graphic D-32. Distributed Component Object Model (DCOM).
Graphic D-32. Distributed Component Object Model (DCOM).

The client object cannot call the server object directly. Instead, the operating system intercepts the DCOM request and uses interprocess communication mechanisms such as remote procedure calls (RPCs) to provide a transparent communication mechanism between the client and server objects. The COM run time provides the necessary object-oriented services to the client and server objects. The COM run time also uses the security provider and RPCs to create network frames that conform to the DCOM standard.

In Microsoft Windows NT and Windows 2000, DCOM requests are sent using RPCs. Windows NT and Windows 2000 use security features such as permissions to enable software components to securely and reliably communicate over the network.

DCOM was formerly known as “Network OLE.”

See also
Component Object Model (COM)

Distributed file system (Dfs)

A separately available add-on for the Microsoft Windows NT operating system and a component of the Windows 2000 operating system. The Distributed file system (Dfs) allows file servers and network shares to be logically organized into a single Dfs directory tree. This simplifies management of network resources and makes it easier for users to locate and access network resources. From the user’s perspective, the Dfs makes it appear that there is only one server containing a hierarchical tree of resources, while in fact these resources might be distributed across multiple servers in different locations.

The Dfs simplifies directory browsing, offers search tools that simplify locating network resources, and offers administrative tools for building and managing Dfs directory trees. It also eliminates the need for Windows 95, Windows 98, or Windows NT Workstation clients to form multiple persistent network connections, because users require only one persistent connection to the directory tree.

How It Works

In the Windows 2000 implementation, you first open the Dfs snap-in for Microsoft Management Console (MMC) to create a Dfs root node. You can then create Dfs child nodes under the root node. Each child represents a shared folder that can be located anywhere on the network. When users want to access a resource on the network, they navigate through the Dfs tree and do not need to know the particular server the resource is located on. Users must have Dfs client software installed on their machines. Dfs client software is included with Windows 2000, Windows NT, and Windows 98. An optional Dfs client can be downloaded for Windows 95 from the Microsoft Web site.

You can configure Dfs to operate in two ways:

  • Stand-alone Dfs stores the description of the Dfs file system topology on a single computer. If that computer fails, the entire Dfs system goes down, although users can still access resources the traditional way using mapped network drives or Universal Naming Convention (UNC) paths if they know which servers these resources are stored on and the names of the shares.

  • Fault tolerant Dfs stores the Dfs topology information in Active Directory on Windows 2000 domain controllers. This configuration is better for fault tolerance and file replication.

TIP

If a server containing Dfs shares fails, you can simply move the files to another machine, create new shares, and map the existing Dfs child nodes to the new shares. Your users won’t even know that anything has changed. If you assign a user permission to access a shared folder, that person automatically has permission to access it through the Dfs tree as well.

distribution box

A fixed or free-standing miniature patch panel in an enclosure. Typically, horizontal cable runs are connected to the punchdown blocks within the distribution box, and drop cables are plugged into the RJ-45 ports of the box. You can thus use distribution boxes to provide central cabling points away from walls. Stations can then be plugged and unplugged from an accessible location in the work area instead of from the back of the workstations (after you bend down and crawl behind the machine) or from the land drops in the wall (which are often hidden behind desks or other obstacles).

TIP

Use distribution boxes for classrooms and work areas in which computers frequently need to be moved around and rearranged.

distribution group

One of two types of groups within Active Directory in Microsoft Windows 2000. The other type is security groups. While security groups can be listed in discretionary access control lists (DACLs) for controlling access to resources or sending e-mail to users, distribution groups can be used only for e-mail purposes. By sending e-mail to a distribution group, you send e-mail to every member of that group.

Distribution groups can be converted to security groups and vice versa as long as the domain is in native mode. You cannot perform conversion if the domain is in mixed mode.

distribution list

A grouping of recipients in Microsoft Exchange Server that you can use to send a single message to multiple users simultaneously. When a message is sent to a distribution list, it is sent to all recipients on the list. Distribution lists provide a convenient way of performing mass mailings to users. For example, a marketing department might create several hundred custom recipients for regular customers outside the Exchange organization. These custom recipients can then be included as members within a single distribution list. When the department wants to send e-mail to its customers announcing new products or services, the e-mail can be sent to the distribution list. A computer running Exchange Server (configured to expand distribution lists) makes sure that each custom recipient receives a copy of the message.

distribution server

Generally, any server that contains the source files for a software product and that is used to perform remote installations. For example, if you want to perform remote installations of Microsoft Windows NT Workstation on client machines, you can copy the I386 and Drvlib folders from the CD onto a folder called NTWKS on your file server, and then share this folder.

TIP

When you copy files from the CD to a folder on the server, use the xcopy command or, if you are using Windows Explorer, be sure to first choose Options from the View menu and select Show All Files. Otherwise, some hidden files will not be copied, and installation will fail.

DLC

See
Data Link Control (DLC)

DLL

See
dynamic-link library (DLL)

DMI

See
Desktop Management Interface (DMI)

DMS

See
Defense Messaging System (DMS)

DN

See
distinguished name

DNA

See
Microsoft Windows Distributed interNet Applications (DNA) Architecture

DNS

See
Domain Name System (DNS)

DNS client

A client machine configured to send name resolution queries to a DNS server. A DNS client is also called a resolver. When a client needs to resolve a remote host’s name into its IP address, it sends a request to the DNS server, which returns the IP address of the remote host. DNS client software, which is built into most machines that have TCP/IP installed, enables the machines to issue DNS queries to name servers. For example, on Microsoft Windows platforms, the DNS client software makes possible the use of DNS names for browsing the Internet using Microsoft Internet Explorer.

TIP

In Windows operating systems, you must configure the IP address of the DNS server in the client’s TCP/IP property sheet in order for the DNS client software to work properly. With dial-up networking connections to the Internet, this information can be communicated to the client machine during negotiation of the Point-to-Point Protocol (PPP) connection with the Internet service provider (ISP).

DNS console

A snap-in for the Microsoft Management Console (MMC) in Microsoft Windows 2000 that enables administrators to manage Windows 2000 Servers running as DNS servers. You can use the DNS console to

  • Create and maintain the DNS database of host name to IP address mappings

  • Create and manage zones of authority

  • Create start of authority (SOA), name server (NS), address (A), CNAME, and other resource records in the DNS database

  • View DNS server statistics

  • Control how zones are stored and replicated between DNS servers

  • Configure how DNS servers will process DNS queries and handle dynamic updates

  • Configure security for specific zones and resource records

    Graphic D-33. DNS console.
    Graphic D-33. DNS console.
TIP

Windows 2000 Server includes a new command-line utility, dnscmd, which can be used for managing certain aspects of DNS servers. This utility can be run from the command prompt or scripted into batch files to automate certain aspects of DNS administration. To use this command you must install the Windows 2000 Support Tools from the \Support\Tools folder on the Windows 2000 product CD. Type dnscmd /? to see the syntax for this command.

See also
DNS server, Domain Name System (DNS)

DNS database

The collection of database files, or zone files, and associated files that contain resource records for a domain. These files are stored on a name server. DNS database files are typically flat-file database files in the form of simple ASCII files.

On a Microsoft Windows NT server with the Microsoft DNS Service installed, these database files are located in the \System32\DNS directory. The DNS database files in this directory are

  • The zone file, which has the extension .dns and contains the resource records that the DNS server manages

  • The reverse lookup file, which resolves IP addresses into host names

  • The cache file, which has the names and IP addresses of the root name servers for DNS

  • The boot file, which is used for startup configuration of the DNS server and is needed only for resolving the names of hosts that are located outside the zones for which the DNS server is authoritative

On a Windows 2000 DNS server, DNS database information can be either stored in the preceding standard text files or integrated into Active Directory, depending on how DNS is installed and configured on the machine. Using Active Directory for storing DNS database information has the benefits of Active Directory’s enhanced security features and multimaster replication, providing faster and more efficient replication of DNS zone information than using standard DNS text files.

See also
Domain Name System (DNS)

DNS Manager

A Microsoft Windows NT administrative tool for managing the Microsoft DNS Service on a Windows NT server. You can use DNS Manager to

  • Create and maintain the DNS database of host name to IP address mappings

  • Create and manage zones of authority

  • Create start of authority (SOA), name server (NS), address (A), CNAME, and other resource records in the DNS database

  • View DNS server statistics

See also
DNS server, Domain Name System (DNS)

DNS namespace

All domains and subdomains within the Domain Name System (DNS). DNS uses a namespace that is hierarchical in structure and is stored as a distributed database on servers called name servers. The term “namespace” can have two meanings:

  • The abstract space of fully qualified domain names (FQDNs) that are used to identify hosts on the Internet or on a private corporate TCP/IP internetwork

  • The physical space of DNS database files (zone files) that exist on name servers and that actually define or contain the abstract DNS namespace

Active Directory in Microsoft Windows 2000 requires that a DNS namespace be configured in a domain-based implementation of Windows 2000 in an enterprise.

See also
Domain Name System (DNS)

DNS query

One of three methods of requesting that name servers handle name lookups. DNS queries can occur between resolvers and name servers, and between name servers and other name servers. Queries can be answered by the queried name server from its local DNS database, from previously cached query results, or from a referral to another name server. The three basic kinds of DNS queries are recursive queries, iterative queries, and inverse queries.

For more information on these types of DNS queries, see their respective entries in this work.

See also
Domain Name System (DNS), host name resolution

DNS server

A server that is used to resolve host names or fully qualified domain names (FQDNs) into IP addresses on a TCP/IP network. A DNS server, which is also called a name server, accomplishes this by accepting DNS queries from DNS clients and by performing DNS queries among other DNS servers, depending on how the servers have been configured.

Microsoft Windows 2000 Server can function as a DNS server and is managed using an administrative tool, DNS console, which is a snap-in for the Microsoft Management Console (MMC). Windows NT Server can also function as a DNS server and is managed using an administrative tool, DNS Manager. Windows 2000 DNS servers include additional capabilities not supported by their Windows NT counterparts, such as dynamic update, which allows DNS servers to update their DNS database files automatically using Dynamic Host Configuration Protocol (DHCP).

Another feature of Windows 2000 is tight integration of DNS and Active Directory. For example, when a Windows 2000 client needs to locate a Windows 2000 domain controller, the NetLogon service uses the DNS server’s support for the SRV (service) resource record to allow registration of domain controllers in the local DNS namespace.

TIP

DNS servers can provide a simple means of load balancing connections to heavily used file or application servers such as Internet Information Services (IIS). The method is called Round Robin DNS, and it works as its name implies. Say you have three Web servers hosting identical content and you want to load balance incoming Hypertext Transfer Protocol (HTTP) requests across these servers. You can create three A records in the DNS zone file, each with the same host name but different IP addresses, one IP address for each Web server, as shown in this example:

www.northwind.microsoft.com        172.16.8.33
www.northwind.microsoft.com        172.16.8.34
www.northwind.microsoft.com        172.16.8.35

When a DNS client requests resolution of the name www.northwind.microsoft.com into its IP address, the DNS server returns all three IP addresses (.33, .34, .35), and the client chooses the first address (.33) and sends the HTTP request to the Web server associated with this address. The next time the DNS server receives the same name resolution request, it rotates the IP addresses in round-robin fashion (.34, .35, .33) and returns them to the client. The client picks the first address, which is now .34. This way, each DNS name resolution returns a different IP address and the load is balanced between the Web servers.

The drawback to using Round Robin DNS is that if a server fails, DNS will continue to return the address of the failed server.

See also
DNS Manager, Domain Name System (DNS)

DNS zone

See
zone

Domain Admins

A built-in group on Microsoft Windows NT and Windows 2000 networks. The Domain Admins group simplifies administration of users on the network. It is a global group and does not have any preassigned system rights. The initial membership of the group is the sole user account called Administrator. Other user accounts that are added to this group gain rights and privileges equivalent to those of the Administrator account and can perform actions similar to those of the Administrator account. All network administrators in a given domain should be members of this group.

NOTE

On Windows 2000–based networks, the Domain Admins group is created by default in the Users organizational unit (OU) within Active Directory.

See also
built-in group

domain blocking

A security technology introduced with Microsoft Internet Information Server version 4. Domain blocking allows Internet Information Server administrators to grant or deny access to content on the server based on a client’s IP address, subnet, or Internet domain name. This is a useful security feature for protecting machines running Internet Information Server from repeated attack by hackers. Domain blocking can be applied at various levels, including the following:

  • All virtual servers on the machine (master level)

  • A specific virtual server

  • A specific virtual directory

  • A specific file

domain controller

A Microsoft Windows NT or Windows 2000 server that manages the domain security policy. Users and computers that need to obtain access to network resources within the domain must be authenticated by a domain controller in the domain. Windows NT domain controllers are the foundation of Windows NT Directory Services (NTDS), while Windows 2000 domain controllers are based on Active Directory.

In a Windows NT–based network, the domain controllers form a hierarchy. There are two types of Windows NT domain controller:

  • The primary domain controller (PDC), which contains a writable master copy of the domain directory database. A domain can have only one PDC, which is at the top of the domain controller hierarchy. All changes to directory information (such as user accounts or passwords) must be made on the PDC.

  • The backup domain controller (BDC), which contains read-only replicas of the domain directory database stored on the PDC. There can be zero or more BDCs per domain. BDCs provide redundancy and load balancing for the domain. Periodically, the BDCs in a domain undergo directory synchronization with the PDC to ensure that the BDCs contain an accurate copy of the domain directory database. This replication ensures the proper functioning of the NTDS.

A Windows 2000 domain controller is any Windows 2000 server with the optional Active Directory service installed. Windows 2000 domain controllers contain a complete, writable copy of the Active Directory information for the domain in which they are installed. Run the Active Directory Installation Wizard to promote any Windows 2000 member server to the role of a domain controller. A domain controller manages information in the Active Directory database and enables users to log on to the domain, be authenticated for accessing resources in the domain, and search the directory for information about users and network resources. A Windows 2000 domain controller contains a writable copy of the domain directory database.

Unlike in a Windows NT–based network, where domain controllers are in a hierarchy, all domain controllers in a Windows 2000–based network are equal, and changes to the domain directory database can be made at any domain controller. Replication of directory information between Windows 2000 domain controllers follows a multimaster model. In this configuration, each domain controller acts as a peer to all other domain controllers. In other words, there are no primary or backup domain controllers in Windows 2000, only domain controllers.

In a pure Windows 2000 networking environment, all domain controllers can be configured to run in native mode. If you have a mix of Windows NT 4 and Windows 2000 domain controllers, the Windows 2000 domain controllers must be configured to run in mixed mode.

NOTE

If you need to move a Windows NT domain controller to a new domain, you must reinstall Windows NT. Domain controllers cannot migrate from one domain to another because when you create a domain, a unique security identifier (SID) is created to identify the domain, and domain controllers have this SID hard-coded into their domain directory database.

You can use the administrative tool Active Directory Users and Computers to convert a Windows 2000 domain controller from mixed mode to native mode. However, domain controllers running in native mode cannot be changed to mixed mode. If you create a new domain controller for an existing Windows 2000 domain, this new domain controller is referred to as a replica domain controller. Replica domain controllers are typically created to provide fault tolerance and better support for users who access resources over the network.

TIP

To upgrade a Windows NT–based network to Windows 2000, upgrade the PDC first. This allows the domain to immediately join a domain tree, and administrators can administer the domain using the administrative tools of Windows 2000 and create and configure objects in Active Directory.

An important issue regarding domain controllers in Windows 2000–based networks is where to place them. After an administrator implements Active Directory and populates its initial information, most Active Directory–related traffic will come from users querying for network resources. The key to optimizing user queries is in how you locate the domain controllers and the global catalog servers on your network. Placing a domain controller at each physical site optimizes query traffic but increases replication traffic between sites. Nevertheless, the best configuration is usually to place at least one domain controller at each site with a significant number of users and computers.

See also
Active Directory, domain modes

domain forest

In Microsoft Windows 2000, a logical structure formed by combining two or more domain trees.

How It Works

Forests provide a way of administering enterprise networks for a company whose subsidiaries each manage their own network users and resources. For example, a company called CarPoint might have a domain tree with the root domain carpoint.com, while a subsidiary company called Expedia might have a domain tree with the root domain expedia.com. Note that these two companies do not share a contiguous portion of the DNS namespace; this is typical of trees in a forest. The two companies might want to administer their own users and resources but make those resources available to each other’s users. They can combine the two domain trees into a forest by establishing a two-way transitive trust between the root domains of the two trees.

Graphic D-34. Domain forest.
Graphic D-34. Domain forest.

All trees in a forest must share a common directory schema and global catalog. The global catalog holds information about all objects in all domains of the forest and acts as an index of all users and resources for all domains in the forest. By searching the global catalog, a user in one domain can locate resources anywhere in the forest. The global catalog contains only a subset of the attributes of each object. This ensures fast searches for users trying to locate network resources.

Domain Guests

A built-in group on Microsoft Windows NT and Windows 2000 networks. The Domain Guests group simplifies administration of users on the network. It is a global group and does not have any preassigned system rights. The initial membership of the Domain Guests group is the sole user account called Guest. Other user accounts that are added to this group gain the rights and privileges equivalent to those of the Guest account and can perform actions similar to those of the Guest account. Domain Guests are typically users who are given occasional, temporary access to network resources.

NOTE

On Windows 2000–based networks, the Domain Guests group is created by default in the Users organizational unit (OU) within Active Directory. Normally, the only member of this group is the Guest account, but on a Windows NT server with Internet Information Services (IIS) installed, additional guest accounts are created for use by IIS.

See also
built-in group

domain in DNS

A grouping of TCP/IP hosts in the hierarchical Domain Name System (DNS). Domains are the building blocks of DNS. A domain consists of a group of nodes in the DNS namespace. Domains are organized hierarchically in the DNS namespace, with the topmost domain called the root domain.

DNS domains can be classified as one of the following:

  • A parent domain, which contains other domains. An example of a parent domain is microsoft.com.

  • A child domain, or subdomain, which is contained within a parent domain. Examples of child domains in the microsoft.com parent domain are northwind.microsoft.com and marketing.microsoft.com.

NOTE

Domain names can include only the characters a–z, A–Z, and 0–9, the dash (-), and the period. A name that completely identifies a host in the DNS namespace is called a fully qualified domain name (FQDN).

See also
Domain Name System (DNS)

domain in Windows NT and Windows 2000

A network security model for grouping computers together. Computers on a network based on Microsoft Windows NT or Windows 2000 that are in the same domain share a common directory database of security information such as user accounts, passwords, and password policies. Domain-based networks have the following features:

  • Centralized administration:
    The entire network can be administered from a single location.

  • Single-user logon:
    Users need only one user account to access any workstation on the network.

  • Universal resource access:
    Users can access any network resource for which they have the appropriate permissions.

    Graphic D-35. This shows a Windows 2000 domain.
    Graphic D-35. This shows a Windows 2000 domain.
How It Works

Typically, the following computers are members of the domain:

  • Domain controllers, which maintain the database of directory information for the domain. On Windows NT servers, this database is called the Security Accounts Manager (SAM) database, while in Windows 2000 domains, this information is stored in Active Directory. Domain controllers periodically exchange directory information using directory replication so that the information in any given domain controller is kept up to date. (If the information stored in a domain controller is out of date, users might have trouble logging on with that particular domain controller or finding recently shared resources on the network.)

  • Member servers, which are stand-alone servers typically used for file and print services, Web services, or running applications such as Microsoft SQL Server. Member servers cannot authenticate users like domain controllers can.

  • Workstations or client computers, which participate in the security policies of the domain and are members of the domain, but are used as desktop machines for users instead of as network servers.

A Windows NT or Windows 2000 network can be installed as either a domain or a workgroup. The domain model is preferable because it allows computers to share a common security policy and a common domain directory database. Machines running Windows 98 and legacy Windows machines can also participate in domain security on Windows NT and Windows 2000 networks but are not considered full members of the domain because they have no computer accounts within the domain directory database.

A Windows NT domain requires only one primary domain controller (PDC) and can have a number of backup domain controllers (BDCs). By creating a PDC, you create a new domain. Windows NT member servers and workstations can join a domain. Other systems, such as computers running Windows 95 and Windows 98, can participate in a domain but are not considered members of the domain because they have no computer accounts in the domain directory database.

Windows 2000 domains use peer domain controllers, which are all equal in status. In Windows 2000, domains are core entities within Active Directory and act as a boundary for network security and for the replication of directory information over the network. If you establish a security policy in one domain, the settings, rights, and discretionary access control lists (DACLs) of that policy are limited to that domain. Domains are also the fundamental containers for all network objects within them. Domains contain users, groups, computers, and other directory objects. These objects can be grouped together using a hierarchy of organizational units (OUs).

NOTE

Domains can span geographical boundaries and networks; an enterprise can have branches in several continents with all machines belonging to a single domain. Alternatively, a single network or location can have multiple domains installed, with or without trust relationships between them.

NOTE

To change the name of a domain in Windows NT, you first change it on the PDC and then on the other machines in the domain. However, this can affect other software installed on the servers.

See also
Active Directory, domain controller, trust relationship, workgroup

domain local group

A type of group in a Microsoft Windows 2000–based network. Windows 2000 uses groups to organize users or computer objects for administrative purposes. Groups can have different scopes, or levels of functionality. The scope of a group can be a single domain, a group of domains connected by trust relationships, or the entire network.

Domain local groups are Windows 2000 groups whose scope is restricted to the specific domain in which they are defined. Domain local groups are used to provide users with access to network resources and to assign permissions to control access to these resources. Domain local groups have open membership, which means that you can add members from any domain to them.

To use a domain local group, you first determine which users have similar job responsibilities in your enterprise. Then you identify a common set of network resources in a domain that these users might need to access. Next, you create a domain local group for the users and assign the group appropriate permissions to the network resources. This procedure is called A-G-DL-P (access, group, domain local, permissions), which is a variation of the AGLP administration paradigm used in Windows NT–based networks.

TIP

If network resources within a domain are used only within the domain, you can group users in the domain using domain local groups. If your scope of resource usage is several domains linked by trust relationships, use global groups instead. If your network is a pure Windows 2000–based network and your domain controllers are running in native mode, you can use universal groups as well.

See also
global group, universal group

domain master browser

One of the roles of machines running Microsoft Windows NT and Windows 2000 in supporting the computer browser service on a Windows NT–based or Windows 2000–based network. The domain master browser is a computer running Windows NT or Windows 2000 that collects the master list of domain resources on the network. It then distributes this list to master browsers on each subnet. If the domain has only one subnet, the domain master browser is also the master browser for that subnet.

NOTE

A Windows NT domain has only one domain master browser, which is always the primary domain controller (PDC).

See also
Computer Browser service

domain model

A model for building an enterprise-level network using Microsoft Windows NT or Windows 2000 domains. Windows NT and Windows 2000 can be scaled for implementation in enterprise-level businesses that support thousands of users and cover geographically diverse regions. Choosing a correct domain model for implementing your Windows NT or Windows 2000 network can greatly simplify administration of your network. Some domain models are more suitable for smaller implementations, while others are better for larger networks.

Four main domain models can be implemented in a Windows NT network:

  • The single domain model, which keeps all machines in the network in a single domain and is usually implemented in smaller companies

  • The single master domain model, which separates resource domains from a master or accounts domain and is suitable for companies with a hierarchical organizational structure

  • The multiple master domain model, which uses multiple accounts or master domains and is suitable for large organizations that span different countries or continents

  • The complete trust model, which is used by very decentralized organizations or during the transition period when two companies merge

Because of its two-way transitive trusts between domains, Windows 2000 is capable of building more flexible domain structures. In addition to the single domain model, domains can be linked hierarchically in domain trees, and domain trees can be joined in domain forests. For more information on Windows 2000 domain models, see Microsoft Official Curriculum (MOC) course number 1561, Designing a Microsoft Windows 2000 Directory Services Infrastructure.

See also
trust relationship

domain modes

A mode of operation for domain controllers in Microsoft Windows 2000–based networks. Windows 2000 domain controllers are computers that contain a writable copy of Active Directory. You can convert a Windows 2000–based server to a domain controller by running the Active Directory Installation Wizard on that machine. You can run Windows 2000 domain controllers in either of two modes:

  • Mixed mode, which provides backward compatibility with Windows NT domain controllers (downlevel domain controllers). This mode supports networks with a mixture of Windows 2000 and Windows NT domain controllers and allows them to interoperate. Multimaster replication cannot be used in mixed mode environments.

  • Native mode, which interoperates only with other Windows 2000 domain controllers. Native mode should be used when there are no downlevel domain controllers on the network and the entire network has been upgraded to Windows 2000.

NOTE

By default, Active Directory is installed on a Windows 2000 server in mixed mode. You can change a domain controller from mixed mode to native mode, but not vice versa. Use the administrative tool Active Directory Users and Computers to perform the change.

domain name

A name for a domain within the Domain Name System (DNS), usually registered with the Internet Network Information Center (InterNIC)—for example, the microsoft.com domain owned by Microsoft Corporation.

Owning a domain name is essential in today’s business world, as the dot-com enterprise becomes the standard model for business. A company’s domain name typically reflects the company’s trademark name or logo. Because company names can be registered at the state or federal level, companies in different states or countries might want to register identical domain names. Unfortunately, the DNS was not established with consideration of these trademark issues, and the courtroom has become a common arena for resolving domain name ownership disputes.

See also
fully qualified domain name (FQDN)

Domain Name System (DNS)

A hierarchical system for identifying hosts on the Internet or on a private, corporate TCP/IP internetwork. The Domain Name System (DNS) provides

  • A method for identifying hosts with friendly names instead of IP addresses

  • A distributed mechanism for storing and maintaining lists of names and IP addresses of hosts

  • A method for locating hosts by resolving their names into their associated IP addresses so that network communication can be initiated with the host

How It Works

The DNS namespace is hierarchical in structure, beginning with the root domain, which branches to top-level domains, then second-level domains, and so on to the individual host name.

For example, the fully qualified domain name (FQDN) barney.northwind.microsoft.com can be broken down as follows:

  • Host name: barney

  • Third-level domain: northwind (stands for Northwind Traders Ltd., a fictitious Microsoft subsidiary)

  • Second-level domain: microsoft (Microsoft Corporation)

  • Top-level domain: com (commercial domain)

The root domain has a null label and is not expressed in the FQDN.

Graphic D-36. Domain Name System (DNS).
Graphic D-36. Domain Name System (DNS).

The DNS is implemented as a distributed database using name servers located at various points on the Internet. Clients called resolvers can perform name lookups by contacting these name servers, which resolve host names into IP addresses. In Microsoft Windows NT and UNIX BIND name servers, the DNS database of host name to IP address mappings must be created manually by entering resource records for each host that needs to be resolved. In Windows 2000, the new dynamic update can be used to register host names automatically, and zone information can be stored and replicated using Active Directory.

Each name server on the Internet is responsible for a subset of the DNS namespace known as a zone of authority. Each zone of authority can consist of one or more domains and subdomains. The most important name servers on the Internet are the dozen or so root name servers, which are responsible for maintaining the infrastructure of the domain name system. These root name servers are maintained mostly by the Internet Network Information Center (InterNIC) and by U.S. military agencies (because the Internet evolved from the ARPANET project of the U.S. Defense Department in the 1970s).

A name server can function in one of four roles in the DNS:

  • Primary name server, which contains the master copy of the zone file for the zones it has authority over

  • Secondary name server, which obtains its zone files using a zone transfer from a master name server

  • Master name server, which can provide zone information to secondary name servers

  • Caching-only name server, which does not contain any zone information

NOTE

Although DNS is used mainly for the Internet, large private TCP/IP internetworks can also use DNS internally with their own name servers. The main advantage of doing this is that host names are friendlier than IP addresses. On smaller TCP/IP networks, hosts files can be used instead of DNS, while on Windows NT–based networks, Windows Internet Naming Service (WINS) is often used for NetBIOS name resolution. Windows NT Server has an installable service called the Microsoft DNS Service, which allows Windows NT servers to function as name servers called DNS servers.

The DNS is also an essential part of Active Directory in Windows 2000. Active Directory uses the DNS to resolve domain names into IP addresses. However, it can also use non-DNS naming conventions to locate objects in the directory. These other naming conventions include

  • The Lightweight Directory Access Protocol (LDAP) naming convention of distinguished names and relative distinguished names (RDNs). This includes LDAP Uniform Resource Locators (URLs).

  • User principal names for identifying users and groups.

  • Security Accounts Manager (SAM) account names for user accounts.

  • Universal Naming Convention (UNC) paths for shared network resources.

See also
host name resolution

domain tree

A hierarchical grouping of Microsoft Windows 2000 domains created by adding one or more child domains to an existing parent domain. Domain trees are used to make a domain’s network resources globally available to users in other domains.

How It Works

In a domain tree, all domains share their resources and security information to act as a single administrative unit. A user who logs on anywhere in a domain tree can access file, printer, and other shared resources anywhere in the tree if he or she has appropriate permissions. A domain tree has only one Active Directory, but each domain controller in a tree maintains only the portion of Active Directory that represents the objects in that particular domain.

Domains in a domain tree are joined using two-way transitive trusts. These trusts enable each domain in the tree to trust the authority of every other domain in the tree for user authentication. This means that when a domain joins a domain tree, it automatically trusts every domain in the tree.

For child domains to be part of a domain tree, they must share a contiguous namespace with the parent domain. The namespace of a Windows 2000 domain is based on the Domain Name System (DNS) naming scheme. For example, in the illustration, the child domains northwind.carpoint.com and adventure.carpoint.com share the same namespace as the parent domain carpoint.com. In this example, carpoint.com is also the name of the root domain—the highest-level parent domain in the tree. The root domain must be created first in a tree.

Graphic D-37. Domain tree.
Graphic D-37. Domain tree.

All domains in a domain tree have their directory information combined into a single directory: Active Directory. Each domain provides a portion of its directory information to an index on the domain controllers. By searching this index, users can locate and access shared resources, applications, and even users anywhere in the domain tree.

NOTE

Two or more domain trees that do not share a contiguous namespace can be combined into a domain forest.

See also
domain forest

domain user account

One of three types of user accounts available on a Microsoft Windows 2000–based network. User accounts enable users to log on to domains or computers and access any resources in the domain for which they have appropriate permissions. This is in contrast to local user accounts, which are used only for logging on to a specific machine (such as a member server) and accessing resources on that machine.

Domain user accounts are created in Active Directory and stored in organizational units (OUs). Domain user account information is replicated to all domain controllers in a domain using directory replication. This replication enables the user to quickly and easily log on from any part of the domain.

You create domain user accounts using the administrative tool called Active Directory Users and Computers, a snap-in for the Microsoft Management Console (MMC). You can create domain user accounts in the default Users OU or in any other OU that you have created in Active Directory.

NOTE

Windows 2000 also includes a number of built-in accounts that simplify the task of administering users on a network. The two built-in user accounts are the Administrator and Guest accounts.

Domain Users

A built-in group on Microsoft Windows NT and Windows 2000 networks. The Domain Users group simplifies administration of users on the network. It is a global group and does not have any preassigned system rights. Its initial membership is empty until ordinary network users are created for the domain. User accounts that are added to this group gain the rights and privileges that are assigned to ordinary users in the network, such as the right to log on over the network. All ordinary users on the network should be members of this group.

NOTE

On Windows 2000–based networks, the Domain Users group is created by default in the Users organizational unit (OU) within Active Directory.

See also
built-in group

DOS

See
MS-DOS

down

The state of a network when some or all network communications are disrupted. Common reasons for networks being down include

  • Loose connectors on cables

  • Breaks or shorts in cables

  • Failed networking components

Indications that the network might be down include

  • Users complain that they can’t log on to the network or access certain network resources.

  • Alarm systems in Simple Network Management Protocol (SNMP) management software start sending administrative alerts or e-mail to administrators.

  • The uninterruptible power supply (UPS) unit in the wiring closet generates its annoying high-pitched tone.

drain wire

An uninsulated wire included in shielded cabling that runs the length of some coaxial cabling or shielded twisted-pair (STP) cabling. The drain wire makes contact with the foil sleeve or mesh along the wire. The externally exposed portion of the drain wire should be connected to a secure ground connection. This ensures that the wire is properly grounded and that the shielding in the wire operates effectively. It also helps to maintain the two ends of the wire at the same voltage with respect to ground. If voltage differences form between the ends of a network cable, they can lead to a sudden voltage surge or discharge that can damage attached networking devices.

DriveSpace

A Microsoft Windows 95 and Windows 98 utility for compressing file allocation table (FAT) volumes. You can use DriveSpace to free up disk space for users on workstations or for network shares on servers. DriveSpace uses disk compression techniques to pack more information onto a disk than is normally possible with uncompressed files.

How It Works

DriveSpace creates a read-only, hidden system file called a compressed volume file (CVF). This file, typically called drvspace.000, contains all the files and folders on the original uncompressed volume. A driver called drvspace.bin in the root of the active partition is used at boot time to mount the compressed drive.

Windows 95 OSR2 (OEM Service Release 2) and Windows 98 have an enhanced version of DriveSpace called DriveSpace3 that supports CVFs of up to 2 GB in size. To compress a drive, type drvspace at the command prompt. In the DriveSpace 3 dialog box shown on the screen, highlight the volume you want to compress. You have several ways to compress data with DriveSpace 3.

Graphic D-38. Disk Compression Settings dialog box.
Graphic D-38. Disk Compression Settings dialog box.

drop

Another name for a wall plate. For example, a network administrator might say, “This room has 24 drops, and 6 are still available.” This means that there are 24 wall plate connections on the walls of the room, and 18 of them have drop cables attached to them to connect them to computers in the room. The other end of the drops usually terminates at a patch panel in the wiring closet. Another name for a drop is a “LAN Drop.”

drop cable

In standard Ethernet networks, a cable connecting a computer’s network interface card (NIC) to a transceiver attached to a thicknet cable. A drop cable is also called a “transceiver cable.”

More generally, a drop cable is any short cable connecting a computer’s NIC to a wall plate. Drop cables allow computers to be easily disconnected and reconnected from the network so that you can move them around in the room. Drop cables are generally needed because horizontal cabling connecting patch panels in wiring closets terminates at wall plates in the work areas, but computers in the work areas are distributed throughout the entire room. In a more permanent networking configuration, wall plates might be located on floors and very short drop cables might be used to connect the computers to the network.

Dr. Watson

A Microsoft Windows utility that intercepts software faults and provides the user with information on which software faulted and why.

In earlier versions of Windows, this information was terse and cryptic, but it was greatly expanded and reorganized in the version of Dr. Watson included with Windows 98, as shown in the screen capture. However, this information is usually not helpful to the person running the software. Dr. Watson is primarily of interest to the providers of the software to determine what caused the software to crash. A piece of software that frequently generates Dr. Watson messages can be considered buggy, and you should contact your software vendor for a fix or a replacement.

Graphic D-39. Watson.
Graphic D-39. Watson.

DS0

Stands for Digital Signal Zero, a standard digital transmission rate for digital telecommunications. DS0 defines a transmission rate of 64 Kbps and can carry either a single voice channel or data.

Telecommunication carriers transmit digital signals in multiples of DS0 called DS1, DS2, and so on. These multiples differ depending on whether you are dealing with the T-carrier system of North America or the E-carrier system of Europe and other continents. The following table lists the common DS-series transmission rates and their T-series or E-series equivalents (when defined). For example, you can see that a T1 data transmission is equivalent to 24 DS0 transmissions multiplexed together and can transmit data at a rate of 1.544 Mbps.

DS-Series Transmission Rates
DS Type | Multiple of DS0 | Data Rate | T-Series | E-Series
DS0 | 1 | 64 Kbps | N/A | N/A
DS1 | 24 | 1.544 Mbps | T1 | N/A
N/A | 32 | 2.048 Mbps | N/A | E1
DS1C | 48 | 3.152 Mbps | N/A | N/A
DS2 | 96 | 6.312 Mbps | T2 | N/A
N/A | 128 | 8.448 Mbps | N/A | E2
N/A | 512 | 34.368 Mbps | N/A | E3
DS3 | 672 | 44.736 Mbps | T3 | N/A
N/A | 2048 | 139.264 Mbps | N/A | E4
DS4 | 4032 | 274.176 Mbps | N/A | N/A
N/A | 8192 | 565.148 Mbps | N/A | E5

DSL

See
Digital Subscriber Line (DSL)

DSML

See
Directory Service Markup Language (DSML)

DSMN

See
Directory Service Manager for NetWare (DSMN)

DSN

See
data source name (DSN)

DSU

See
Data Service Unit (DSU)

DTE

See
data terminal equipment (DTE)

DTMF

See
Dual Tone Multiple Frequency (DTMF)

dual boot

A computer that can boot one of several operating systems by means of a startup menu. An example is a machine on which Windows 98 and then Windows NT has been installed. The user can utilize the Windows NT boot loader menu to choose which operating system to run at startup.

Windows NT supports dual booting with other operating systems, but this is neither recommended nor supported by Microsoft. Dual boot systems are typically used in hobbyist and test networks in which a variety of operating systems are used to test different networking functions, or when the number of available machines is fewer than needed to perform the tasks.

NOTE

The Windows NT boot loader menu can include up to 10 operating systems.

Dual Tone Multiple Frequency (DTMF)

The audio signaling method used by Touch-Tone phones. Microsoft’s Telephony Application Programming Interface (TAPI) can recognize and interpret Dual Tone Multiple Frequency (DTMF) signals, allowing Microsoft Windows–based applications to integrate with telephony. Some networking vendors also supply hardware devices called DTMF/ASCII converters, which convert DTMF tones directly into different ASCII characters, which can then be fed as input into a program that routes telephone calls accordingly.

How It Works

Each DTMF signal generated by pressing a key on a Touch-Tone phone generates two simultaneous audible tones of different frequencies, as shown in the following table. DTMF was developed by AT&T; the term Touch-Tone was originally an AT&T trademark.

Frequencies of DTMF Signals
 | 697 Hz | 770 Hz | 852 Hz | 941 Hz
1209 Hz | 1 | 4 | 7 | *
1336 Hz | 2 | 5 | 8 | 0
1477 Hz | 3 | 6 | 9 | #

duplex

A telecommunications term referring to bidirectional communication. In full-duplex communication, both stations send and receive at the same time, and usually two communication channels are required. However, you can also achieve full-duplex communication using a multiplexing technique whereby signals traveling in different directions are placed into different time slots. The disadvantage of this technique is that it cuts the overall possible transmission speed by half.

In half-duplex communication, only one station can transmit at any given time while the other station receives the transmission. The opposite of duplex communication is simplex communication, which can occur only in one direction.

DWDM

See
dense wavelength division multiplexing (DWDM)

dynamic disk

In Microsoft Windows 2000, a new kind of disk management technology for hard disks. Dynamic disks are different from basic disks, which are disk systems that function similarly to earlier versions of Windows and are also supported by Windows 2000. You create and manage dynamic disks using the Disk Management portion of the Computer Management administrative tool.

How It Works

Dynamic disks use a Windows 2000–based disk management technology called dynamic storage, which creates a single partition for the entire physical disk. This dynamic disk can then be divided into a number of dynamic volumes, each consisting of one dynamic disk or portions of one or more dynamic disks. In other words, dynamic volumes can span several dynamic disks or several portions of a single dynamic disk. Dynamic disks cannot contain the partitions and logical drives that can be created on basic disks. You can create dynamic disks only on Windows 2000 machines; they cannot be accessed locally by MS-DOS and legacy Windows operating systems in a dual-boot configuration.

The main advantage of using dynamic disks is that you can resize and reconfigure them without rebooting the system. You can thus create and delete simple volumes, spanned volumes, striped volumes, mirrored volumes, and RAID-5 volumes on machines running Windows 2000 without needing to reboot the machine.

NOTE

You can use Disk Management to revert a dynamic disk to a basic disk, but you must first remove all volumes from the dynamic disk. Once the disk is reverted, you can create only partitions and logical drives on it.

See also
basic disk

Dynamic Host Configuration Protocol (DHCP)

A standard Internet protocol that enables the dynamic configuration of hosts on an Internet Protocol (IP) internetwork. Dynamic Host Configuration Protocol (DHCP) is an extension of the bootstrap protocol (BOOTP).

How It Works

DHCP is a client-server protocol that uses DHCP servers and DHCP clients. A DHCP server is a machine that runs a service that can lease out IP addresses and other TCP/IP information to any client that requests them. For example, on Microsoft Windows NT or Windows 2000 servers you can install the Microsoft DHCP Server service to perform this function. The DHCP server typically has a pool of IP addresses that it is allowed to distribute to clients, and these clients lease an IP address from the pool for a specific period of time, usually several days. Once the lease is ready to expire, the client contacts the server to arrange for renewal.

DHCP clients are client machines that run special DHCP client software enabling them to communicate with DHCP servers. All versions of Windows include DHCP client software, which is installed when the TCP/IP protocol stack is installed on the machine.

DHCP clients obtain a DHCP lease for an IP address, a subnet mask, and various DHCP options from DHCP servers in a four-step process:

  1. DHCPDISCOVER:
    The client broadcasts a request for a DHCP server.

  2. DHCPOFFER:
    DHCP servers on the network offer an address to the client.

  3. DHCPREQUEST:
    The client broadcasts a request to lease an address from one of the offering DHCP servers.

  4. DHCPACK:
    The DHCP server that the client responds to acknowledges the client, assigns it any configured DHCP options, and updates its DHCP database. The client then initializes and binds its TCP/IP protocol stack and can begin network communication.

Graphic D-40. Dynamic Host Configuration Protocol (DHCP).
Graphic D-40. Dynamic Host Configuration Protocol (DHCP).

DHCP lease renewal consists only of steps 3 and 4, and renewal requests are made when 50 percent of the DHCP lease time has expired.

TIP

When you implement DHCP on a network, you should consider the following:

  • DHCP servers do not share their database of leased IP addresses, so if your network has more than one DHCP server, be sure that their DHCP scopes do not overlap.

  • Assign DHCP options to the DHCP server if clients need them.

  • Assign static IP addresses to non-DHCP clients, and exclude these addresses from the scope on the DHCP server if necessary.

  • Assign static IP addresses to all servers on your network or assign them DHCP client reservations on the DHCP server to ensure that they always lease the same IP address.

  • Configure DHCP relay agents if one DHCP server must serve hosts on several subnets.

Dynamic HTML

A proposed World Wide Web Consortium (W3C) standard developed by Microsoft for creating interactive multimedia Web content. You can use Dynamic HTML to make Web pages look and behave more like typical desktop applications. Dynamic HTML supports features such as

  • Document Object Model (DOM), a standard whereby every element of a Web page is exposed for scripting. Each element on a Hypertext Markup Language (HTML) page can function as an object that can be modified using scripts and other programs. For example, Dynamic HTML can make the appearance of an object on a Web page change during an onmouseover or onclick event.

  • Cascading style sheet (CSS) positioning, which allows HTML content developers to control the style and layout of objects on a Web page using style sheets. These style sheets can then be cascaded to define different levels of precedence.

  • Dynamic Content and Dynamic Styles, which HTML content developers can use to dynamically change the content or style of every HTML element on a Web page based on mouse events or other forms of user interaction.

  • Data Binding, which integrates data with HTML elements. For example, table rows can be automatically generated from data records and data-bound fields.

dynamic-link library (DLL)

A file containing executable routines that can be loaded on demand by an application. Dynamic-link libraries (DLLs) offer the advantage of providing standard services for many different calling applications, and they simplify and modularize application development by providing component-based services. DLLs are loaded into RAM only when needed by the calling application, which reduces the memory requirements of large applications. DLLs are files that have the extension .dll.

dynamic packet filtering

A feature of Microsoft Proxy Server version 2 that enables Proxy Server to do the following:

  • Determine dynamically whether to accept a packet from the Internet while minimizing the number of exposed ports in both directions and the length of time the port is open to the Internet

  • By default, drop all packets on an external interface

How It Works

Dynamic packet filtering involves two Proxy Server components:

  • The Packet Filter Driver, which talks directly to the external network interface

  • The Packet Filter Manager, which provides the high-level interface for interaction between Proxy Server services and the driver

In a typical scenario, a client with the Winsock Proxy client might attempt to connect to an Internet server using Telnet. The Winsock Proxy client intercepts the Telnet connection request and remotes the request to the Winsock Proxy server, which verifies that the client has proper Microsoft Windows NT permissions to use Telnet to access servers on the Internet and opens a local socket. The Winsock Proxy server then informs the Packet Filter Manager that an outbound connection request from the socket to a remote Telnet service has been approved, and the Packet Filter Manager orders the Packet Filter Driver to open the socket and the Winsock Proxy server to start a Telnet session on behalf of the client. When the Winsock Proxy determines that the client has closed the Telnet session, it tells the Packet Filter Manager to close the socket and thus blocks any further packets from the remote system.

Dynamic RAS Connector

A connector in Microsoft Exchange Server. You can use the Dynamic RAS Connector when a permanent network connection between two Exchange sites is unavailable. The Dynamic RAS Connector uses the Microsoft Windows NT Remote Access Service (RAS) to connect two sites.

The Dynamic RAS Connector is typically used in an Exchange implementation in one of the following ways:

  • To provide a backup messaging connectivity path between two remote Exchange sites in case their dedicated connection goes down. For example, two sites might have a T1 line connecting them and use Site Connector to establish messaging between them. If the T1 line goes down, the Dynamic RAS Connector can kick in and use a modem to provide temporary messaging services between the sites.

  • As an option for connecting low-traffic branch office sites to the main headquarters site of an Exchange organization.

dynamic routing

A routing mechanism handled by a routing protocol, such as Routing Information Protocol (RIP) or Open Shortest Path First (OSPF) Protocol, that dynamically exchanges routing information among routers on an internetwork. Routers that use this method are called dynamic routers.

How It Works

For a dynamic router to function, a routing protocol must be installed on each router in the internetwork. The routing table of one router is manually seeded with routing information for the first hop, and then the routing protocol takes over and dynamically builds the routing table for each router. Routers periodically exchange their routing information so that if the internetwork is reconfigured or a router goes down, the routing tables of each router are modified accordingly. Hosts on a network need only be configured so that their default gateway address matches the IP address of the local router interface.

Dynamic routers are much simpler to administer than static routers, but they are sometimes less secure because routing protocol information can be spoofed. If the network is reconfigured or a router goes down, it takes time for this information to propagate between the various routers on the network. Routing protocols also create additional network traffic, and different routing protocols offer their own advantages and disadvantages.

NOTE

You can configure a multihomed Microsoft Windows NT server as a dynamic RIP router by selecting Enable IP Forwarding on the Routing tab of the TCP/IP property sheet, and then using the Services tab of the Network property sheet to add the RIP for Internet Protocol (IP) service to the server. Another example of a dynamic router is a multihomed computer running Windows NT Server and Microsoft’s Routing and Remote Access Service (RRAS) with either RIP or OSPF configured.

TIP

Dynamic routers cannot exchange information with static routers. To configure static and dynamic routers to work together on the same internetwork, you must add manual routes to the routing tables of both types of routers.

See also
router, routing table, static routing

dynamic update

A variation of the Domain Name System (DNS) defined in Request for Comments (RFC) 2136 and supported by Active Directory in Microsoft Windows 2000. The dynamic update protocol provides support for dynamic updates of zone file information between domain controllers. Instead of using primary and secondary zones, Active Directory reuses zones.

How It Works

Dynamic update lies at the heart of Active Directory because domain names in Windows 2000 are also DNS names. For example, northwind.microsoft.com can be both a legal DNS name and the name of a Windows 2000 domain.

Ordinary DNS must be administered manually. Administrators must perform all changes to the DNS database or zone files manually. Zone files are propagated between DNS servers by zone transfers, which occur periodically.

Dynamic update lets computers running Windows 2000 with dynamically assigned IP addresses register both their host name and IP address information in the DNS database when they initialize on the network. Dynamic update can thus integrate the DNS and Dynamic Host Configuration Protocol (DHCP) services. Dynamic update also supports new types of server-to-server messages that allow individual resource records or sets of records to be added or deleted in a server’s zone.

When DNS is integrated with Active Directory for dynamic update, administrators must enable and manage the following zones:

  • The DNS root zone

  • DNS forward lookup zones

  • DNS reverse lookup zones

Dynamic update is similar to ordinary DNS in that zone update operations occur using primary or master servers only. Dynamic update, however, allows primary servers to receive updates initialed by a specified list of “authorized servers,” which can include secondary zone servers, domain controllers, and other servers that perform name registration services, such as Windows Internet Name Service (WINS) or DHCP servers.

NOTE

You can use the DNS Manager snap-in for the Microsoft Management Console (MMC) to enable Active Directory integration on an existing DNS server. The zone file information will be written into Active Directory.

dynamic volume

In Microsoft Windows 2000, any volume created using the Disk Management portion of the Computer Management administrative tool. You can create dynamic volumes only on dynamic disks. Types of dynamic volumes include the following:

  • Simple volumes

  • Spanned volumes

  • Striped volumes

  • Mirrored volumes

  • RAID-5 volumes

See also
basic volume


E

E-carrier

The digital telecommunications services backbone system of Europe, a format standardized by the International Telecommunication Union (ITU). E-carrier services were developed in the 1970s and became widely available in the 1980s. E-carrier services can be used for wide area network (WAN) connections, for high-speed Internet connections, for private videoconferencing services, and for public frame relay services. E-carrier services are generally available wherever the parallel T-carrier services are not.

E-carrier transmissions are graded E1, E2, and so on in order of increasing transmission speeds. These different service grades are multiples of the basic DS0 data transmission rate, similar to the T-carrier system of North American telecommunications carriers.

The E-carrier service rates are specified by the organization CEPT (Conférence Européenne des Administration des Postes et des Télécommunications, or European Conference of Postal and Telecommunications Administrations). The most popular of these services, E1, is also the slowest. E1 transmits data at speeds of up to 2.048 Mbps over two pairs of twisted wires. It consists of 31 separate 64-Kbps DS0 channels multiplexed together, each of which can carry either a voice conversation or a stream of data. E1 is sometimes referred to as 2-Meg.

Graphic E-1. E-carrier.
Graphic E-1. E-carrier.

The E-series transmission rates are shown in the table included in the article on DS0 elsewhere in this work. E-carrier lines use 8 bits per channel for encoding signals and do not rob bits for control signals as T-carrier lines do.

NOTE

If the E1 service entering your customer premises needs to connect directly to a different building, you have two solutions. First, you could have the service provider extend the E1 line to the other building, thus moving the demarcation point (termination point) of the line. This could be costly, however. A simpler solution might be to connect the E1 line to a fiber-optic line driver, lay down a fiber-optic cable from the line driver to a similar driver in the other building, and then connect the remote line driver to your E1 equipment.

edbutil

A command-line tool for versions 4.0 and 5.0 of Microsoft Exchange Server. Edbutil can be used to defragment, repair, and check the integrity of the following Exchange Server databases:

  • Directory database (dir.edb)

  • Private information store database (priv.edb)

  • Public information store database (pub.edb)

Edbutil works at the Joint Engine Technology (Jet) level and attempts to find and repair inconsistencies. It can also be used to defragment these databases, resulting in a database size reduction.

NOTE

In Exchange Server version 5.5, the edbutil utility has been replaced by the newer tool eseutil.

TIP

Use this utility with caution, and make sure that you have backed up the information store and directory databases first! Microsoft recommends using this utility only when troubleshooting Exchange Server problems in consultation with Microsoft Technical Support.

EDGE

See
Enhanced Data Rates for Global Evolution (EDGE)

edge router

A device in an Asynchronous Transfer Mode (ATM) network that routes data between an ATM backbone network and local area networks (LANs). Edge routers can be used to translate Ethernet or Token Ring data for transmission over ATM backbones. This allows ATM to be used as a backbone for connecting multiple LANs into a metropolitan area network (MAN) or wide area network (WAN). An alternative and more commonly used configuration is to connect LAN networking equipment directly to ATM backbone switches, which provide points of contact with an ATM provider’s backbone network. An edge router can function as an ATM switch and provide routing capabilities for LAN networking protocols—all in one hybrid device.

Graphic E-2. Edge router.
Graphic E-2. Edge router.

EDI

See
electronic data interchange (EDI)

effective permissions

In Microsoft Windows NT and Windows 2000, the cumulative permissions a user has for accessing a resource based on his or her individual permissions, group permissions, and group membership. The effective permissions a user experiences trying to access a file or folder depend on the various permissions granted to the user expressly or by virtue of their membership in a particular group. When a permissions conflict exists between one group and another, or between the user and a group, rules are applied that resolve the issue.

How It Works

In networks based on Windows NT or Windows 2000, calculation of effective permissions can be determined using three simple rules:

First, if a user belongs to two (or more) groups, and these two groups have different NTFS standard file permissions on a given file, the user’s ability to access the file both locally and over the network is determined as follows:

  • The effective NTFS permission is the least restrictive (most permissive) NTFS standard permission. For example,

    read (NTFS) + change (NTFS) = change (NTFS)

  • The exception to this is that the no-access permission overrides all other permissions. For example,

    read (NTFS) + no access (NTFS) = no access (NTFS)

Second, if a user belongs to two (or more) groups, and these two groups have different shared folder permissions on a given shared folder, the user’s ability to access the shared folder over the network is determined as follows:

  • The effective shared folder permission is the least restrictive (most permissive) shared folder permission. For example,

    read (shared folder) + change (shared folder) = change (shared folder)

  • The exception to this is that the no-access permission overrides all other permissions. For example,

    read (shared folder) + no access (shared folder) = no access (shared folder)

Third, when a user attempts to access a folder or file over a network that has both NTFS permissions (the first example) and shared folder permissions (the second example) configured on it, the effective permission is the most restrictive (least permissive) permission. For example,

read (NTFS) + change (shared folder) = read (combined)

See also
NTFS permissions (Windows 2000), NTFS permissions (Windows NT), shared folder permissions

EFS

See
Encrypting File System (EFS)

EGP

See
Exterior Gateway Protocol (EGP)

EIA

See
Electronic Industries Alliance (EIA)

EIA/TIA wiring standards

Standards for commercial and telecommunications wiring developed by the Electronic Industries Alliance (EIA) and Telecommunications Industry Association (TIA). These standards are also supported by the American National Standards Institute (ANSI). The EIA/TIA wiring standards actually consist of a group of standards covering different aspects of premise cabling and other wiring practices. These standards include the following:

  • EIA/TIA 570:
    Residential/Light Commercial Wiring Standard

  • EIA/TIA 568A:
    Commercial Building Telecommunications Cabling Standard

  • EIA/TIA 569:
    Commercial Building Standard for Telecommunications Pathways and Spaces

  • EIA/TIA 606:
    Design Guideline for Administration of Telecommunications Infrastructure in Commercial Buildings

  • EIA/TIA 607:
    Commercial Building Grounding and Bonding Requirements for Telecommunications

For more information, see the Web sites for the EIA and TIA listed in this entry.

TIP

When installing wiring for your network, be sure to follow the EIA/TIA standards, both for legal reasons and to ensure that your network will function as expected. Be sure also to follow any local or state building codes.

On the Web
•
Electronic Industries Alliance (EIA)
: http://www.eia.org
•
Telecommunications Industry Association (TIA)
: http://www.tiaonline.org

election

See
browser election

electromagnetic interference (EMI)

Electrical noise induced in cabling by the presence of nearby electrical equipment such as motors, air conditioners, fluorescent lights, and power lines. Electromagnetic interference (EMI) can interfere with the transmission of signals.

EMI is only a problem with copper cabling. It’s caused when the changing electromagnetic fields generated by one cable induce extraneous currents or interference in adjacent or nearby cables. EMI in copper cabling can be reduced to acceptable levels by

  • Avoiding bunching of unshielded cabling

  • Keeping all cabling away from power cords and transformers

  • Using shielded twisted-pair (STP) cabling instead of unshielded twisted-pair (UTP) cabling

  • Enclosing cabling in external mesh or wire shielding

  • Properly grounding electrical equipment and external shielding

  • Taking care not to excessively untwist the terminating ends of twisted-pair cabling

EMI can be a greater concern in heavy industrial settings where high voltages and equipment, such as motors and generators, produce high levels of electrical noise. Using coaxial cabling in these settings affords greater resistance to the effects of EMI than using twisted-pair cabling. Fiber-optic cabling is an even better solution in heavy industrial settings because it is wholly resistant to EMI. (Changing electromagnetic fields have no effect on the light waves traveling along a glass fiber.)

electronic data interchange (EDI)

A standard format developed by the Data Interchange Standards Association (DISA) in which companies can exchange business data and financial transactions. Electronic data interchange (EDI) is defined in the American National Standards Institute (ANSI) standard called X.12.

How It Works

The basic unit of an EDI transmission is the message, which consists of a transaction set with a header and footer attached. A transaction set is roughly equivalent to a typical business form, such as a purchase order, and consists of a number of data segments, each containing various fields delimited by some character. These fields represent individual elements of the business transaction, such as company name, account number, quantity, and so on; they are formatted according to a standard code. This code is implemented as a map between your business application’s data fields and the type of EDI standard that is appropriate for the transaction being performed.

EDI data can originate from any computing level, from mainframe to local area network (LAN) server. Systems communicate through EDI translation software that formats the data into standard EDI encoding and exchange information—either through a direct dedicated link between business partners or through an external third-party value-added network (VAN) service provider that acts as a clearinghouse for EDI transactions. If a VAN is used, as it normally is, the VAN processes EDI messages and routes them to the appropriate electronic mailbox for the destination business partner, who can then retrieve the EDI messages from the mailbox and process the transactions using business applications.

On the Web
•
Data Interchange Standards Association (DISA) home page
: http://www.disa.org

Electronic Industries Alliance (EIA)

The main trade organization representing the U.S. high-tech community. The Electronic Industries Alliance (EIA) was founded in 1924 as the Radio Manufacturers Association. It plays an important role in enabling U.S. electronics producers to be competitive by developing technical standards, hosting trade shows and seminars, performing market analysis, and facilitating relations with the government. The EIA represents a broad spectrum of U.S. electronics manufacturing interests.

The EIA is organized along the lines of specific electronic products and markets, with each sector, group, or division having its own board of directors and its own agenda for enhancing competitiveness. Major divisions include the components, consumer electronics, electronic information, industrial electronics, government, and telecommunications divisions.

An important computer networking function of the EIA is the series of standards for residential and commercial network cabling that are collectively known as the EIA/TIA wiring standards. Individuals and companies installing cabling for computer networks must follow these standards in order to comply with government legal and safety requirements.

On the Web
•
Electronic Industries Alliance (EIA) home page
: http://www.eia.org

e-mail

Stands for electronic mail; any system for sending and receiving messages over a network. E-mail originated in the early 1970s with ARPANET and is now the primary method of business communication today.

Many vendors and organizations have developed electronic messaging standards and formats, including the IBM mainframe host-based PROFS and SNADS messaging systems, Microsoft Mail, Lotus cc:Mail, and Novell GroupWise. The two most popular messaging formats used today are the Internet Simple Mail Transfer Protocol (SMTP) and X.400 mail systems.

X.400 is a popular messaging format that is used throughout much of Europe, but SMTP mail, which was developed in the United States as part of the ARPANET project, enjoys worldwide popularity and acceptance. Both systems are based on a client/server architecture, with messaging clients sending e-mail to mail servers that act as message transfer agents by routing messages through a backbone of mail servers to their final destination. Microsoft Exchange Server is Microsoft’s premiere e-mail messaging server software, and combined with the Microsoft Outlook client, it makes a full-featured messaging and collaboration system. Microsoft Exchange Server supports interoperability with most existing messaging systems, including SMTP, X.400, Microsoft Mail, and Lotus cc:Mail.

e-mail address

Any of several types of addresses that ensure an e-mail message reaches its intended recipient. An e-mail address must contain sufficient information so that the message can be routed to its specific recipient. There are various kinds of e-mail address formats depending on the e-mail system in use. Address formats typically include at least two parts:

  • A user portion, which indicates the name or alias of the user to whom the mail is directed

  • A routing portion, which indicates the information needed to route the message to the particular mail system on which the user has his or her mailbox

The following table shows some examples of e-mail address formats.

E-Mail Address Formats
Type of Address | Example
SMTP (Internet) | BobS@Northwind.Microsoft.com
Microsoft Mail | Northwind/MICROSOFT/BOBS
Lotus cc:Mail | BobS at Northwind
X.400 | C=US;a=SPRINT;p=Microsoft;o=Northwind;s=BobS

emergency repair disk (ERD)

A recovery tool for repairing missing or corrupt files or restoring the registry on a Microsoft Windows NT or Windows 2000 system. Having a current copy of the emergency repair disk for each server on your network is an important part of preparing for disaster recovery.

How It Works

An emergency repair disk (ERD) contains compressed versions of registry hive, default user profile, setup.log, and other system configuration files. An ERD can be created any time using the rdisk utility, and should always be created after installing new services or software or upgrading hardware or device drivers on a system.

An ERD cannot be used to boot a computer running Windows NT or Windows 2000. To perform a system recovery of a machine running Windows NT using an ERD, boot your system using the three boot floppies and select the Repair option from the appropriate menu. Then select the specific repair options you want to perform, namely

  • Inspect Registry Files:
    Prompts to replace each registry file

  • Inspect Boot Sector:
    Restores Windows NT boot sector

  • Inspect Startup Environment:
    Restores the boot.ini file to allow access to Windows NT

  • Verify Windows NT System Files:
    Replaces missing or corrupt operating system files

To perform a system recovery on a machine running Windows 2000, try booting to Safe Mode first by pressing the F8 function key during startup. If this fails or if the system cannot be repaired, boot the system using the four boot floppies, select the Repair option by pressing the R key when prompted, and then either use the ERD to attempt a repair or press C to open the Recovery Console. The Recovery Console is a powerful command-line interface to the operating system, designed for use by advanced administrators only.

TIP

If you can’t find your three Windows NT boot floppies, you can create a new set by running the command winnt32/ox from the Windows NT compact disc on a working computer running Windows NT. To create the four Windows 2000 boot floppies, insert the Windows 2000 compact disc and a blank floppy into any machine running MS-DOS or Windows, click Start, select Run, and enter the following path into the Run box:

<cdrom_drive>\bootdisk\makeboot a:

emergency startup disk

A startup disk created during a Microsoft Windows 95 or Windows 98 setup that can be used to troubleshoot Windows 95 and Windows 98 boot problems. Having a current copy of the emergency startup disk for each machine running Windows 95 or Windows 98 on your network helps with disaster recovery if these machines fail to boot properly.

The emergency startup disk contains files necessary to load a command-line version of Windows 95 or Windows 98, plus other useful system-recovery utilities, including a real-mode registry editor. When you insert an emergency startup disk into your computer and reboot, the computer starts from the disk instead of from your hard drive.

TIP

You should create a new emergency startup disk whenever you make a configuration change to a machine running Windows 95 or Windows 98—for example, when you install new hardware or update device drivers.

EMI

See
electromagnetic interference (EMI)

encapsulation

Generally, a process by which a lower-layer protocol receives data from a higher-layer protocol and then places the data into the data portion of its frame. Thus, encapsulation is the process of enclosing one type of packet using another type of packet. Encapsulation at the lowest levels of the Open Systems Interconnection (OSI) reference model is sometimes referred to as framing. Examples of encapsulation include the following:

  • An Ethernet frame that encapsulates an Internet Protocol (IP) packet, which itself encapsulates a Transmission Control Protocol (TCP) packet, which then encapsulates the actual data being transmitted over the network

  • An Ethernet frame encapsulated in an Asynchronous Transfer Mode (ATM) frame for transmission over an ATM backbone

The data-link layer (layer 2) of the OSI model for networking is responsible for encapsulation or framing of data for transmission over the physical medium. In local area network (LAN) technologies, this is usually Carrier Sense Multiple Access with Collision Detection (CSMA/CD) for Ethernet networks. For wide area network (WAN) technologies, the data-link protocols used depend on whether the communications are point-to-point or multipoint:

  • For point-to-point communications, possible WAN data-link protocols include Point-to-Point Protocol (PPP) and High-level Data Link Control (HDLC) protocol.

  • For multipoint communications, possible WAN data-link protocols include frame relay, ATM, Switched Multimegabit Data Services (SMDS), and X.25.

Encrypting File System (EFS)

A Microsoft Windows 2000 core technology for storing encrypted NTFS files on disk; designed to protect data on NTFS volumes from local access by unauthorized users.

How It Works

Encrypting File System (EFS) is a public key cryptography scheme based on the Data Encryption Standard (DES) that runs as a Windows 2000 system service and is transparent to the user. EFS is simple to use and automatically generates an encryption key pair for the user who is logged on if one does not already exist. The user’s private key, stored in Active Directory, is used for decrypting encrypted files and folders.

Each time EFS encrypts a file or folder, it generates a random encryption key. EFS encrypts this encryption key using the user’s public key. EFS stores encryption keys in the nonpaged pool of memory.

To access an encrypted NTFS file, the user must meet one of the following criteria:

  • Have the private key for the file (in other words, the file was originally encrypted by that user)

  • Have permission to share the encrypted file

  • Be a registered recovery agent

You can encrypt or decrypt a file or folder on an NTFS volume with the Advanced button on the General page of that file or folder’s property sheet. You can also enable or disable encryption from the command prompt using the cipher command.

NOTE

EFS does not work on FAT volumes.

TIP

If you are working with applications that create temporary files, you might want to enable encryption at the folder level instead of the file level in order to guard against unauthorized access to your temporary files. With folder-level encryption, all files in the folder are encrypted.

encryption

The process of rendering a message (or data) unusable to all but the intended recipients, who have the ability to decrypt it. Cryptography is the science of creating workable procedures for encrypting and decrypting messages. The goal is to ensure that a message intercepted by a distrusted user cannot be decrypted in a feasible amount of time.

How It Works

Although there are many different approaches to encryption, the two most common are

  • Symmetric key encryption:
    This method uses a secret key known only to the sender and recipient of a message (and perhaps to others that they trust). The secret key is used both to encrypt the message when it is sent and to decrypt it when it is received. The actual encryption process involves mathematically combining (hashing or transforming) the message and the key in some complex fashion that is virtually impossible to undo unless the recipient also has the key. Symmetric key encryption is very secure, but suffers from one problem—if you want to send a message to someone who does not have your key, you must also find a way to securely give them a copy of the key. This difficulty makes symmetric key encryption generally unworkable for electronic communication over a network or telecommunications service, except where only the original sender and recipient will need the key. For example, symmetric key encryption works in cellular phone communication when only the subscriber and the service provider need a copy of the user’s key.

  • Public key encryption:
    This method is now commonly used in many computer networking and telecommunications systems for transmitting sensitive information using the Secure Sockets Layer (SSL) protocol—for example, sending credit card numbers over the Internet. SSL establishes a secure communications session over the Internet by using public key encryption, which provides every participating user with a public key and a private key. Users are the only ones aware of their private keys, while their public keys are generally available to anyone who wants them. Remember that if a message is encrypted with a user’s public key, it can be decrypted only with the same user’s private key, and vice versa.

For example, if user A wanted to send an encrypted message to user B, it would typically work like this:

  1. User A requests user B’s public key or obtains this key from a certificate authority (CA) that both users trust.

  2. User A encrypts his message using user B’s public key and sends the encrypted message to user B.

  3. User B receives the encrypted message from user A and decrypts it with user B’s private key.

    Graphic E-3. The public key encryption method.
    Graphic E-3. The public key encryption method.
NOTE

The preceding approach outlines the steps used for encrypting and decrypting the actual message being transmitted during a secure communication session. A different approach, called a digital signature, is used to confirm the authenticity of the sender and the integrity of the message. Digital signatures are encrypted in a reverse fashion to the message itself. Specifically, if user A wants to send his digital signature to user B, then

  1. User A creates a hash of his message using a hashing algorithm. This hash forms the basis of the digital signature, which user A then encrypts using his own private key.

  2. User A appends the encrypted digital signature and his own public key to the message, which is then encrypted using user B’s public key.

  3. User B receives the message and attachments, decrypts its contents using her own private key, and uses user A’s public key to decrypt the digital signature that user A attached to the message. User B then generates a hash of the received message and compares this to the digital signature that user A sent. If the two are identical, it is unlikely that the message has been tampered with in transit.

See also
public key cryptography

encryption algorithm

A mathematical procedure for encrypting data. Encryption algorithms form the basis by which encryption can take place and are fundamental to cryptography.

How It Works

Encryption algorithms generally use some kind of mathematical key (chosen from a large set of available keys) to transform plaintext (the data being encrypted) into ciphertext (the resulting encrypted data). An encryption algorithm must be reversible so that the recipient can use another mathematical key to decrypt the data in order to read it. A good encryption algorithm is difficult to decrypt if you don’t know the decrypting key. It might take massively parallel computers centuries (or aeons) of intense computing, trying all possible keys, to decrypt a typical message without knowing the specific decryption key.

Encryption algorithms typically perform their encryption process on multibyte segments of data instead of on one byte at a time. Such an algorithm is referred to as a block cipher. For example, the Data Encryption Standard (DES) algorithm, a 56-bit key algorithm used for many years by the U.S. government, encrypts data 8 bytes at a time.

End-User License Agreement (EULA)

A type of contract between a computer software publisher and the purchaser of the software that outlines the various rights granted to the purchaser for the legal use of the software. The End-User License Agreement (EULA) for a software product is usually found on a separate piece of paper accompanying the product, inside the front cover of the user manual, or on screen prior to installing the software. You should read and become familiar with the terms of your EULA for the software you purchase. Failure to follow the terms of the EULA might open you or your company to prosecution for software piracy.

TIP

You can access the EULA for Microsoft Windows 98 by opening the text file license.txt. It is located in the \Windows folder. In Windows 2000, the file is called eula.txt and is located in the \System32 folder.

On the Web
•
Microsoft antipiracy site
: http://www.microsoft.com/piracy

enhanced category 5 cabling

Sometimes referred to as CAT5E, an informal cabling standard that some cable manufacturers use to refer to category 5 cabling that is capable of supporting transmission speeds faster that 100 Mbps. At present, there is no official standard for unshielded twisted-pair (UTP) cabling above category 5, although category 6 and category 7 specifications have been proposed. In other words, there is no standard or specification that has been agreed upon for defining category 6 or higher UTP cabling, although steps are being made to develop one.

How It Works

Enhanced category 5 cabling has certain electrical characteristics that make it the recommended type of cabling for most new networking installations. Supporting frequencies up to 350 MHz or higher, it is typically 4-pair solid conductor 24-gauge UTP cabling that has a low capacitance in the range of 13 to 14 pF/ft, as compared with regular category 5 cabling that has a capacitance of around 17 pF/ft. Its impedance is 100 ohms, the same as for regular category 5 cable. CAT5E cabling is suitable for Fast Ethernet installations, Integrated Services Digital Network (ISDN) wiring, 155-Mbps Asynchronous Transfer Mode (ATM) networks, and other present and proposed high-speed networking solutions such as 1000BaseT.

TIP

If you plan to use enhanced category 5 cabling in your network, you should make sure that all your other wiring components match these specifications. This means purchasing and installing enhanced category 5 patch panels, wall plates, and other components. Also, be sure to strictly follow wiring guidelines because improper installation of enhanced category 5 cabling will result in loss of potential bandwidth. The real key to operating a successful high-speed UTP wiring system is careful installation.

Enhanced Data Rates for Global Evolution (EDGE)

A proposed upgrade to the hardware for the General Packet Radio Service (GPRS) packet-switched wireless mobile data service. Enhanced Data Rates for Global Evolution (EDGE) is designed to provide mobile users with wireless roaming data services of up to 400 Kbps.

EDGE can be deployed by many Global System for Mobile Communications (GSM) providers as an upgrade for existing GSM systems within the GSM Phase 2+ initiative, which is planned for the years 2000–2001. GSM networks do not require new network elements to implement EDGE, although some hardware and software upgrades will be required. EDGE uses a different modulation technique called phase-shift keying that allows it to provide higher data rates than existing GSM systems over reduced areas of coverage.

EDGE can be deployed on both circuit-switched and packet-switched cellular services. In North America, EDGE can be deployed by Time Division Multiple Access (TDMA) cellular providers under the IS-136 standard. Initial test deployments are planned for the year 2000.

See also
General Packet Radio Service (GPRS)

enterprise

A large company, geographically distributed with a large number of users. In this context, an enterprise-level network of computers refers to the network belonging to an enterprise; that is, a network that typically consists of thousands of computers distributed across several geographically remote locations and connected by WAN links.

Enterprise-level networks generally use the TCP/IP protocol and are divided into a number of smaller networks called subnets, which are joined using routers. Enterprise-level networks are often heterogeneous networks consisting of different protocols and operating systems such as Microsoft Windows NT and Windows 2000, Novell NetWare, and varieties of UNIX, all interoperating to various degrees. Enterprise-level networks can include legacy mainframe and minicomputer systems as well.

This mixture of systems and protocols can make it challenging to administer and manage an enterprise-level network and offers a good argument for upgrading legacy systems to newer, standardized ones. Companies can save considerable costs in the long run by upgrading their networks to secure, reliable, scalable network operating systems such as Windows NT and Windows 2000. The initial cost of upgrades and training are quickly recouped through lower maintenance and administration costs, the result of migrating an enterprise’s heterogeneous combination of systems and protocols to a homogeneous network consisting of computers running Windows NT or Windows 2000, and running TCP/IP.

Enterprise Admins

A built-in group for the Microsoft Windows 2000 operating system platform. Enterprise Admins is one of four predefined global groups that Windows 2000 creates by default to help administrators organize users in their network. The other three groups are Domain Users, Domain Guests, and Domain Admins. While Domain Admins are those users who can perform administrative tasks on any computer belonging to the domain, the Enterprise Admins group is intended to have an even larger scope. Enterprise Admins need to be able to perform administrative tasks on any computer in the enterprise. A Windows 2000–based enterprise can consist of a number of domains interconnected in a domain tree, or even several domain trees connected into a domain forest. Enterprise Admins can administer the entire network for the enterprise. Just as with the Domain Admins group, the Enterprise Admins group has one initial member: the Administrator user account that belongs to the local domain.

enterprise resource planning (ERP)

A general term describing the entirety of the business functions of an enterprise. Enterprise resource planning (ERP) includes tasks such as planning, purchasing, tracking orders, supplying customers, managing inventory, servicing customer requests, producing financial reports, and bookkeeping.

ERP software is modular software designed to integrate these various business functions and simplify their management. ERP software typically consists of an integrated suite of tools for performing standard line-of-business functions such as payroll, accounting, inventory management, and order entry. ERP software is used in transportation and automotive businesses, industrial environments, and other large industrial settings. ERP software lets these large businesses manage diverse business resources across the enterprise in order to plan more effectively for growth and expansion.

Because most business data is stored in databases, ERP software usually depends on the database-management program used. Microsoft SQL Server forms a robust and scalable foundation on which to build ERP software.

enterprise server

A designated server running Microsoft Windows NT or Windows 2000 in an enterprise, which is used as a central repository for software licensing information regarding Windows NT, Windows 2000, or Microsoft BackOffice. An enterprise server is typically a primary domain controller (PDC) but can also be a stand-alone server that is not part of any domain in the enterprise. All PDCs in the enterprise replicate their licensing information with the enterprise server, so the enterprise server contains a master database of this information. If there is only one domain in the enterprise, the PDC for that domain is the master licensing server. If there are several domains, each domain’s PDC keeps track of licenses for that domain, and all PDCs then replicate their licensing information to the specifically designated enterprise server. Stand-alone member servers that are not part of any domain also need to replicate their licensing information with the enterprise server.

NOTE

You can have more than one enterprise server in your enterprise, but it is simplest to have only one because enterprise servers cannot replicate with each other.

See also
License Manager

environmental subsystems

Components of the Microsoft Windows NT or Windows 2000 operating system that support the running of applications from different operating system architectures. Environmental subsystems provide the necessary “environment” in which these applications can run. They are an essential part of the Windows NT operating system that enables cross-platform support for applications written for different operating systems. Windows NT and Windows 2000 include the following environmental subsystems:

  • Win32 subsystem for running 32-bit Windows applications

  • OS/2 subsystem for running OS/2 1.X character-based applications (does not support the OS/2 Presentation Manager GUI or Warp versions)

  • POSIX subsystem for running POSIX.1-compliant applications

NOTE

MS-DOS-based applications run on Windows NT in the context of a Win32 application called a Virtual DOS Machine (VDM) that emulates an MS-DOS environment.

environment variables

String variables containing information that an operating system uses to control services and applications. The PATH and TEMP variables used in the autoexec.bat file in MS-DOS were early examples of environment variables. Microsoft Windows NT and Windows 2000 offer a more extensive selection. For example, environment variables for Windows NT include the following:

  • System (predefined) environment variables such as USERNAME, USERDOMAIN, WINDIR, and HOMEPATH. These variables are set on the system no matter who logs on and cannot be changed by any user. They specify particular parameters pertaining to the system itself, such as the location of the operating system files. They can be used in logon scripts because they are always present when any user logs on.

    • Graphic E-4. Environment variables of Windows NT.
    Graphic E-4. Environment variables of Windows NT.

  • User (user-defined) environment variables, such as the path to application files. User environment variables take precedence over system environment variables when the two conflict.

  • Autoexec.bat environment variables, such as those used in path statements.

You can view and specify environment variables in Windows NT and Windows 2000 by using the System utility in Control Panel. Environment variables may be used in logon scripts by enclosing them within percent symbols; for example, %USERNAME% contains the currently logged on user name.

NOTE

The System utility in Control Panel shows only a portion of the system environment variables defined on a system running Windows NT or Windows 2000.

ERD

See
emergency repair disk (ERD)

ERP

See
enterprise resource planning (ERP)

eseutil

A command-line tool for version 5.5 of Microsoft Exchange Server. Eseutil can be used to defragment, repair, and check the integrity of the following Exchange Server databases:

  • Directory database (dir.edb)

  • Private information store database (priv.edb)

  • Public information store database (pub.edb)

Eseutil works at the Joint Engine Technology (Jet) level and attempts to find and repair inconsistencies. You can also use eseutil to defragment these databases, resulting in a database size reduction.

NOTE

Eseutil replaces the earlier utility edbutil that was used with Exchange Server versions 4 and 5.

TIP

Use this utility with caution, and make sure that you have backed up the information store and directory databases first! Microsoft recommends using this utility only when troubleshooting Exchange Server problems in consultation with Microsoft Technical Support.

ESMTP

Stands for SMTP Service Extensions, an extension to the Simple Mail Transfer Protocol (SMTP) protocol that lets receiving SMTP hosts inform sending hosts of the extensions that it supports. ESMTP requires no modification of the SMTP configuration of either the client or the mail server.

How It Works

Instead of beginning the session with the helo command, the receiving host issues the ehlo command. If the sending host accepts this command, the receiving host then sends it a list of SMTP extensions it supports. The sending host then knows which SMTP extensions it can use to communicate with the receiving host.

NOTE

The Internet Mail Service for Microsoft Exchange Server version 5.5 supports ESMTP. The ESMTP standard is defined in Request for Comments (RFC) number 1869.

Ethernet

The most popular network architecture for local area networks (LANs). Ethernet was originally developed by Xerox in the 1970s and was proposed as a standard by Xerox, Digital Equipment Corporation (DEC), and Intel in 1980. A separate standardization process for Ethernet technologies was established in 1985 in the Institute of Electrical and Electronics Engineers (IEEE) 802.3 standard known as Project 802. The IEEE standard was then adopted by the International Organization for Standardization (ISO), making it a worldwide standard for networking. Because of its simplicity and reliability, Ethernet is by far the most popular networking architecture used today. It is available in three different speeds:

  • 10 Mbps, which is simply called Ethernet

  • 100 Mbps, which is called Fast Ethernet

  • 1000 Mbps or 1 Gbps, which is an emerging standard called Gigabit Ethernet

How It Works

Ethernet specifications define the functions that occur at the physical layer and data-link layer of the Open Systems Interconnection (OSI) reference model, and package data into frames for transmission on the wire. Ethernet is a baseband networking technology that sends its signals serially one bit at a time. It operates in half-duplex mode, in which a station can either transmit or receive, but cannot do both simultaneously.

Ethernet uses the Carrier Sense Multiple Access with Collision Detection (CSMA/CD) media access control method for determining which station can transmit at any given time over the shared medium. In an Ethernet network, each station (computer) listens to the network and transmits data only if no other stations are currently using the network. If the wire is free of signals, any station that wants to can contend (try to take control of) the network in order to transmit a signal. Ethernet networks are thus based on the concept of contention and operate on a first-come, first-served basis, rather than relying on a master station that controls when other stations can transmit. If two stations try to transmit data at the same time, a collision occurs, and both stations stop transmitting. They wait a random interval of time (measured in milliseconds) and then try again.

The more stations on an Ethernet network, the higher the number of collisions, and the worse the performance of the network. Typical performance of a 10-Mbps Ethernet network with around 100 stations will support a bandwidth of only about 40 to 60 percent of the expected value of 10 Mbps. One way of solving the problem of collisions is to use Ethernet switches to segment your Ethernet network into smaller collision domains.

Ethernet stations transmit their data over the wire in packages called frames. An Ethernet frame has a minimum size of 64 bytes and a maximum size of 1518 bytes. A total of 18 bytes are used for information such as source and destination addresses, network protocol being used, and other frame overhead. Thus, the maximum payload size (amount of data carried) for an Ethernet frame is 1500 bytes. There are four different Ethernet encapsulation methods by which Ethernet packages data into a frame:

  • Ethernet II (used for TCP/IP)

  • Ethernet 802.3 (called Raw 802.3 in Novell networking, and used for connectivity with NetWare 3.11 and earlier)

  • Ethernet 802.2 (also called Ethernet 802.3/802.2 without SNAP [subnetwork access protocol], and used for connectivity with NetWare 3.12 and later)

  • Ethernet SNAP (also called Ethernet 802.3/802.2 with SNAP, and created for compatibility with Macintosh and TCP/IP systems)

Ethernet can use virtually any physical networking topology and cabling system (medium). Although a star topology (stations wired in a star-like fashion to a central hub) is often used from the physical point of view, all Ethernet networks are logical bus topology networks at heart. One station places a signal on the bus, and that signal travels to every other station on the bus.

Ethernet is available in three different speeds and can be further differentiated by media and other considerations, as shown in the following table.

Ethernet Speeds, Types, Standards, and Specs
Speed | Type of Ethernet | IEEE Standards | IEEE Specs
10 Mbps | Ethernet | 10Base2 10Base5 10BaseF 10BaseT | 802.3
100 Mbps | Fast Ethernet | 100BaseFX 100BaseT 100BaseT4 100BaseTX | 802.3u
1000 Mbps or 1 Gbps | Gigabit Ethernet | 1000BaseCX 1000BaseLX 1000BaseSX 1000BaseT | 802.3z
NOTE

Ethernet media specifications such as 10BaseT look strange and obscure, but can be easily interpreted. For example, 10BaseT means 10 -Mbps baseband transmission over twisted-pair cabling media.

A new type of Ethernet technology that solves the problems of collisions and has twice the bandwidth of traditional Ethernet is called full-duplex Ethernet. Full-duplex Ethernet uses two pairs of wires with Ethernet switches to allow stations to simultaneously send and receive data without collisions. On a 10BaseT wired network, each full-duplex Ethernet station would have a transmission bandwidth of 20 Mbps.

Graphic E-5. The Ethernet II frame format.
Graphic E-5. The Ethernet II frame format.
TIP

The various Ethernet framing formats are incompatible with each other, so if you have a heterogeneous Ethernet network, you need to specify the correct frame type in order for machines running Microsoft Windows NT to see your Novell NetWare servers. Windows NT allows you to select Auto Detect from the Frame Type drop-down list on the NWLink IPX/SPX-Compatible Transport protocol configuration property sheet if you don’t know what frame type your NetWare servers are using. (In Windows 2000, select the check box next to Auto Frame Type Detection in the NWLink IPX/SPX/NetBIOS-Compatible Transport protocol configuration property sheet.) You might also need to configure your routers for the proper frame type. Older Cisco routers running Internetwork Operating System (IOS) version 10 or earlier do not support Ethernet 802.3/802.2 with SNAP.

The following table shows some troubleshooting tips for Ethernet media problems.

Troubleshooting Tips for Ethernet Media Problems
Problem | Suggestion
No link integrity | Check that you have not mismatched 10BaseT and 100BaseT (or 100BaseTX and 100BaseT4) cables, hubs, or network interface cards; make sure no crossover cables are used for station-to-hub cable connections.
Too much noise | Check for damaged cables; make sure you are using category 5 (CAT5) cabling (or enhanced category 5 cabling for 100BaseT) and that all your cabling interface components (patch panels, wall plates, terminal blocks, and so on) are CAT5 certified.
Too many collisions (greater than 0.1 percent of total frames on the network) | Check for unterminated cables using a time-domain reflectometer; use a protocol analyzer to look for a jabbering transceiver (a network interface card that is continually broadcasting); and make sure you don’t have any cables exceeding the maximum specified length.
On the Web
•
Charles Spurgeon’s Ethernet Web site
: http://www.ots.utexas.edu/ethernet
See also
10Base2, 10Base5, 10BaseT, 100BaseT, Fast Ethernet, Gigabit Ethernet

Ethernet address

See
MAC address

Ethernet switch

Sometimes simply called a switch (when referring to Ethernet networking hardware), a networking component used to connect workgroup hubs to form a larger network or to connect stations that have high bandwidth needs. Ethernet switches provide superior performance to hubs but are more expensive.

How It Works

In a hub, which basically functions as a multiport repeater, a packet entering one port is regenerated and passed to every other port. As a result, if you try to connect several workgroup local area networks (LANs) by uplinking their hubs to a main hub, the new larger network remains a single collision domain. With the increased number of nodes on the network, more collisions will occur, and network traffic congestion can result. If a 10-Mbps Ethernet hub has 10 ports, each port effectively gets one-tenth of the total bandwidth, or 1 Mbps.

A solution to this congestion problem is to use an Ethernet switch in place of the main hub. When a signal enters a port of the Ethernet switch, the switch looks at the destination address of the frame and internally establishes a logical connection with the port connected to the destination node. Other ports on the switch have no part in the connection. The result is that each port on the switch corresponds to an individual collision domain, and network congestion is avoided. Thus, if a 10-Mbps Ethernet switch has 10 ports, each port effectively gets the entire bandwidth of 10 Mbps—to the frame, the switch’s port appears to provide a dedicated connection to the destination node. Ethernet switches are capable of establishing multiple internal logical connections simultaneously, while routers generally process packets on a first-come, first-served basis (although this distinction is blurring in newer hardware).

There are two main types of Ethernet switches:

  • Layer-2 switches operate at the data-link layer (or layer 2) of the Open Systems Interconnection (OSI) reference model and are based on bridging technologies. They establish logical connections between ports based on MAC addresses. Use layer-2 switches for segmenting your existing network into smaller collision domains to improve performance.

  • Layer-3 switches operate at the OSI network layer (or layer 3) and are based on routing technologies. They establish logical connections between ports based on network addresses. Use these for connecting different networks into an internetwork. Layer-3 switches are sometimes called routing switches or multilayer switches.

Some manufacturers also refer to their newest switches as layer-4 switches, but these are essentially an enhanced form of layer-3 switch that takes into account some higher-level protocol information in routing traffic.

The actual mechanism by which switching occurs divides Ethernet switches into two general device classes:

  • Store-and-forward switches buffer whole incoming frames, perform error checking, and switch the packet to the correct port according to the internal address table of the switch. This is similar to how bridges work, but this mechanism suffers from high latency (delay) as the frame is processed.

  • Cut-through switches read only the source and destination addresses of an incoming packet, check the address table, and switch the packet to the correct port. Error checking is not performed—which speeds up performance but results in bad packets being processed rather than dropped. This kind of switching has extremely low latency but can cause problems by forwarding jabbers throughout the network.

Ethernet switches are also distinguished in other ways, such as by the number of ports they have, whether they operate in half-duplex or full-duplex mode, their transmission speed (for example, 10 Mbps, 10/100 Mbps, or 100/1000 Mbps), ports for connectivity with high-speed Fiber Distributed Data Interface (FDDI) backbones, and so on. Advanced features can include Simple Network Management Protocol (SNMP), out-of-band management (OBM), and custom packet filtering.

Although Ethernet switches relieve traffic congestion by segmenting collision domains, they do have some disadvantages:

  • They are generally several times more expensive than hubs of the same speed.

  • Networks involving switches are more difficult to monitor and troubleshoot.

Here is a good rule of thumb for deciding whether to incorporate switches into your existing network: switches can improve your network’s performance if the current network utilization level is higher than 35 percent or if collisions are running at more than 10 percent. For starters, replace your main hub in a cascading hub topology network with an Ethernet switch and connect servers that are heavily utilized directly to the switch (see diagram).

Graphic E-6. Ethernet switch.
Graphic E-6. Ethernet switch.
TIP

If users in a department have high bandwidth needs, such as those running CAD or multimedia applications, consider replacing their workgroup hub with an Ethernet switch, or if the number of users is small, connect their stations directly to the main Ethernet switch.

Another use for Ethernet switches is to connect 100-Mbps Ethernet “islands” to an existing 10-Mbps Ethernet LAN. Simply use a 10/100-Mbps Ethernet switch with two ports to connect them.

You can also connect two LANs several kilometers apart by using two Ethernet switches, both having one 100BaseT port and one 100BaseFX port. Connect the switches to the LANs, and then connect a fiber-optic cable between the FX ports.

When purchasing Ethernet switches, make sure they have RMON agents built into each port, as this will considerably ease remote network troubleshooting.

EULA

See
End-User License Agreement (EULA)

events

Types of occurrences that are logged by the Event Log service of Microsoft Windows NT or Windows 2000 and can be viewed using the administrative tool called Event Viewer. There are five basic types of events:

  • Errors:
    These events represent some significant problem that can lead to loss of data or functionality in the operating system, such as failure of a service to start upon reboot. The corresponding symbol in the system or application log is a red stop sign.

  • Warnings:
    These events indicate some impending problem such as low remaining disk space. The corresponding symbol in the system or application log is an exclamation point superimposed on a yellow circle.

  • Information:
    These events indicate that some significant system operation has successfully occurred; for example, a service has successfully started. The corresponding symbol in the system or application log is an information sign—that is, the letter “i” superimposed on a blue circle.

  • Successes:
    These events are recorded only in the security log and represent auditing information concerning the successful completion of attempts to access secured resources, such as when a user successfully logs on to the network.

  • Failures:
    These events are recorded only in the security log and represent auditing information concerning failed attempts to access secured resources, such as when a user attempts to access a shared folder and fails.

Event Viewer

A Microsoft Windows NT administrative tool used to monitor events on a server. Events are significant actions that take place on a server and include the following:

  • A process has been completed, such as the defragmentation of a database.

  • A service has been started, stopped, or paused.

  • A service has issued an unexpected response to a client.

  • A service was unable to start.

  • A memory violation has occurred, resulting in an application being terminated.

Event Viewer records events in three different logs:

  • System log:
    Records warnings, errors, and information events about Windows NT services and devices

  • Security log:
    Records success and failure events for objects being audited

  • Application log:
    Records warnings, errors, and information events about applications running on the server

The system and application logs should be monitored regularly for signs of problems with devices, services, or applications running on the server. When a problem occurs, Event Viewer is the first place you should check. If auditing is configured on the server, you can monitor the security log for signs of attempted unauthorized access (failure audits) or for an indication of resource usage (success audits).

Graphic E-7. Event Viewer.
Graphic E-7. Event Viewer.
NOTE

In Windows 2000, Event Viewer is implemented as a snap-in for Microsoft Management Console (MMC) and appears as one of the administrative tools in Control Panel. The Windows 2000 Server version of Event Viewer includes additional logs such as the directory service log, the DNS server log, and the file replication service log. Windows 2000 Event Viewer is extensible, with additional logs present when new network services are installed on the machine.

TIP

Select View, and then select Filter Events to filter out unwanted events when the Event Viewer logs are large.

Everyone group

A system group existing on all Microsoft Windows NT and Windows 2000 servers and workstations. The Everyone group includes all local and remote users who have access to any computer running Windows NT on which the Everyone group is defined. This includes users from untrusted domains and non–Windows NT networks. By default, the Everyone system group has the sole preassigned system right “Access this computer from network.” Additional rights can be granted to this group if desired. You cannot modify the membership of system groups such as the Everyone group directly.

NOTE

The Everyone group is one of seven built-in system groups that are defined on networks based on the Windows 2000 operating system.

TIP

When you share a folder on a server running Windows NT, full control permission is initially assigned to the Everyone group. It is a good idea to remove this group and assign appropriate permissions to other groups, such as Administrators and Users.

Be careful about assigning additional permissions to the Everyone group. If you allow users who do not have valid user accounts to access the network using the Guest account, they will gain any permissions and rights that you have assigned to the Everyone group.

See also
built-in group, special identity

Exchange Administrator

The primary tool for managing the sites, servers, services, and recipients in a Microsoft Exchange organization. The Exchange Administrator program can be installed on a computer running Microsoft Exchange Server during setup, or as a stand-alone administrative tool on a server or workstation running Microsoft Windows NT or Windows 2000, provided that the machine can establish a remote procedure call (RPC) connection with all Exchange servers it wants to administer.

The Exchange Administrator program provides a view of the Exchange directory hierarchy for the organization. Using the menus, toolbars, and property sheets for directory objects, administrators can configure all aspects of their Exchange sites, services, connectors, gateways, recipients, and other Exchange components. Exchange Administrator provides a two-pane view similar to Windows Explorer, including

  • Container pane (left):
    Displays all container objects in the organization’s directory hierarchy.

  • Contents pane (right):
    Shows the contents of the currently selected container in the container pane. The contents of a container can be leaf objects, other containers, or both.

    Graphic E-8. Exchange Administrator.
    Graphic E-8. Exchange Administrator.

Exchange directory service

One of the four core components of Microsoft Exchange Server. The Exchange directory service is responsible for maintaining the Exchange directory database of information concerning the organization’s sites, servers, services, and recipients. This directory is based on the X.500 directory recommendations of the International Telecommunication Union (ITU) and is essentially a Lightweight Directory Access Protocol (LDAP)–compliant directory.

To synchronize the information among all servers, the directory service also replicates the directory information among all Exchange Server computers in an Exchange organization through directory replication. This replication takes place automatically every five minutes among Exchange servers in the same site and when the administrator has scheduled it to occur between different sites. The Exchange directory service is implemented as a Microsoft Windows NT service and can be stopped, started, or paused like any other service. Errors that occur in the directory service are written to the application log on the Exchange server.

NOTE

The directory service agent for Windows 2000 can integrate information maintained by the Exchange directory service with Active Directory in Windows 2000.

Exchange event service

A Microsoft Windows NT service running on Microsoft Exchange Server version 5.5 computers. This service can be configured using Microsoft Outlook to monitor for occurrence of specific events in public folders. These events include timing events, message postings, and message deletions. The event service notifies users of specific actions that occur on public folders. This allows developers to write custom workflow applications that perform specific actions when a specific event occurs in a public folder. Developers can write scripts using the Exchange Scripting Agent to trigger responses to messages being posted in both public folders and users’ mailboxes.

TIP

When writing mailbox agents that use the event service, use high-level programming languages such as C or C++. If you write mailbox agents using an interpreted language such as Microsoft Visual Basic, Scripting Edition (VBScript), Exchange Server will slow to the speed of the interpreter whenever the script is called by a message being posted to the mailbox. This can cause a significant drop in performance.

Exchange permissions

Sets of rights assigned to users or groups to control access to directory objects in the organization of Microsoft Exchange Server. These rights are grouped into common roles, which are then assigned to users and groups.

Exchange permissions can be assigned to any object in the Exchange directory hierarchy and are inherited by other objects below that object, provided they are in the same context.

The following table shows the individual rights that can be granted to users and groups to control access to directory objects. Note that not all of these rights are available for any given directory object.

TIP

If you don’t see the Permissions property page for an Exchange directory object, use Options from the Tools menu of the Exchange Administrator program to make it visible. (The screen capture illustrates the property sheet for the Toronto site in an Exchange organization.)

Graphic E-9. Exchange permissions.
Graphic E-9. Exchange permissions.
Individual Rights
Right | Type of Permission Granted
Add Child | Create objects within a container.
Modify User Attributes | Modify user-level attributes of an object.
Modify Admin Attributes | Modify administrator-level attributes of an object.
Modify Permissions | Modify the permissions on the existing object.
Delete | Delete the object.
Logon | Access the directory database (needed by Exchange service account).
Replication | Replicate directory information with other servers (needed by Exchange service account).
Mailbox Owner | Read and delete messages in the mailbox.
Search | View the contents of the container.
Send As | Send a message using the sender’s return address.

Exchange Scripting Agent

A tool for Microsoft Exchange Server that allows server-side scripts to be written that execute actions when specific events or conditions occur in public folders. These events include timing events, message postings, and message deletions. For example, an action could be triggered in response to generation of an Out-of-Office (OOF) message. Another example of such an event is the automatic generation of a reminder message when a user doesn’t read his or her e-mail for a specified number of days. A form that is submitted to a public folder could be validated by a script that determines whether it satisfies some specific criteria, such as a minimum order quantity. Scripts can be written in Microsoft Visual Basic, Scripting Edition (VBScript) or JScript using the Exchange Scripting Agent.

Exchange Server

See
Microsoft Exchange Server

executive

See
Windows NT executive

expand command

A Microsoft Windows NT and Windows 2000 command that can be used to uncompress files from the distribution files on the Windows NT compact disc. Use this command to perform a system recovery when a missing or corrupt Windows NT operating system file is preventing your system from booting. Expand is an MS-DOS–based utility.

Example

expand d:\i386\sol.ex_ c:\winnt\system32 installs Solitaire the hard way—off the Windows NT compact disc.

NOTE

The Windows NT Resource Kit includes a Windows NT–based expansion utility called expndw32.exe that can be accessed from the File Tools program group in the Start menu.

For the full syntax of this command, type expand /? at the command line.

export server

A Microsoft Windows NT or Windows 2000 server that exports directories and files to other computers using the Directory Replicator Service in Windows NT and Windows 2000. The export server contains the master copy of the directory tree that is being copied to the import servers by the Directory Replicator Service.

In Windows NT, configure your export server using the Replication button on Server Manager, which is accessed either from the Server icon in Control Panel or from the Start menu’s list of administrative tools. You must specify the following:

  • The particular directory tree to be exported. The default tree is

    %SystemRoot%\System32\Repl\Export

  • The domains or computer names to which you want to export the tree

  • Selected subdirectories that you do not want to replicate by applying locks to them (optional)

In Windows 2000, the directory replication functionality is integrated into Active Directory.

TIP

In Windows NT, if you add any domain or computer names to the To list box for directory replication, you are no longer automatically replicating to the local domain and must specify the name of the local domain (if desired).

See also
Directory Replicator Service

extended partition

A physical disk partition on which a series of logical drives can be created. You can create an extended partition on a disk to overcome the limitation of having only four partitions per disk.

Information about the various partitions on a disk is stored in a structure called the partition table. The partition table is 64 bytes in size and is located on cylinder 0, head 0, sector 1 of your hard drive, in the same sector as the Master Boot Record. The partition table has the same format no matter what operating system is used on the disk. Up to four partitions can be created on a disk, but only one partition can be extended per disk. In Microsoft Windows NT, you can create an extended partition using Disk Administrator. For earlier Windows platforms, use the fdisk utility.

NOTE

In Windows 2000, extended partitions can be created only on basic disks.

See also
partition of a disk

extender

A general name for a class of networking devices that extend the distances over which stations (computers) can typically be connected to concentrators such as hubs and switches.

An example is a 10BaseT extender for Ethernet networks. In 10BaseT networks, stations should be located no more than 100 meters from a hub, but by using an extender, you could increase this to about 183 meters. A 10BaseT extender can thus be used for connecting a remote station, such as a station located in a nearby building, to the network. Extenders are essentially a simplified form of bridge designed to support only a few remote stations. They need to be installed in pairs, one at the remote location and one at the main network. Some extenders can be used to carry network data over installed phone lines, connecting remote stations without installing additional network cabling.

Graphic E-10. Extender.
Graphic E-10. Extender.

Extenders are also available for increasing the maximum connection distance for other data transmission technologies such as the Small Computer System Interface (SCSI) bus. A normal SCSI bus is limited to about 6 meters, but a fiber-optic SCSI extender can increase this distance to a kilometer or more using duplex fiber-optic cable. You can use parallel extenders for directly connecting to printers located in a different building. You can use serial extenders to connect computers to remote RS-232 serial test equipment located in laboratories in different buildings.

extension cable

A cable used to extend a length of cabling. Extension cables come in all types with various connector devices and can be used to extend serial lines, parallel lines, network cables, power cables, and so on.

TIP

Extending a cable using an extension cable is not always a good idea because the additional interface introduced by the connection usually results in some signal loss. Furthermore, extending network cables can cause problems if the new, longer cable exceeds the maximum length of the specifications for that type of network. For example, extending unshielded twisted-pair (UTP) cabling beyond 100 meters in a 10BaseT Ethernet network can result in unreliable communication between hosts on the network.

Exterior Gateway Protocol (EGP)

A type of routing protocol used to distribute routing information between different autonomous systems in large internetworks based on the TCP/IP protocol. The Internet is one example of an Exterior Gateway Protocol (EGP). EGPs specify how networks within an autonomous system are advertised to routers outside the given autonomous system. EGPs thus facilitate the exchange of inter-autonomous-system routing information between different autonomous systems, independent of whether these autonomous systems employ the same Interior Gateway Protocols (IGPs) within their networks.

The EGP was the original routing protocol developed for communicating routing information between autonomous systems on the Internet. It is no longer used because of its poor support for multipath networking environments, and the Border Gateway Protocol (BGP) has replaced it. The term “Exterior Gateway Protocol” now refers both to the particular protocol itself and to the class of protocols it describes.

See also
autonomous system (AS)

extract command

The Windows Cabinet Extraction tool for Microsoft Windows 95 and Windows 98 that is used to extract files and lists of files from Windows cabinet files. These cabinet files are found on the Windows CD. The extract command lets you extract one or more files from the cabinet files—for example, if a system file becomes corrupt and you want to replace it rather than rerun Setup.

Example

To display the contents of the cabinet file Win95_02.cab, type extract /d win95_02.cab at the command prompt.

extranet

In its simplest form, a private TCP/IP network that securely shares information using Hypertext Transfer Protocol (HTTP) and other Internet protocols with business partners such as vendors, suppliers, and wholesale customers. An extranet is thus a corporate intranet that is exposed over the Internet to certain specific groups that need access to it. Extranets built in this fashion follow the client/server paradigm, with Web servers such as Microsoft Internet Information Services (IIS) functioning as the server, and Web browsers such as Microsoft Internet Explorer functioning as the client. Other extranet models exist, however, such as a peer-to-peer business connection for electronic data interchange (EDI).

Extranets are a powerful tool because they let businesses share resources on their own private networks over the Internet with suppliers, vendors, business partners, or customers. Extranets are typically used for supporting real-time supply chains, for enabling business partners to work together, or to share information such as catalogs with customers. The power of the extranet is that it leverages the existing technology of the Internet to increase the power, flexibility, and competitiveness of businesses utilizing well-known and easily used tools such as Web servers and Web browsers. Extranets also save companies money by allowing them to establish business-to-business connectivity over the Internet instead of using expensive, dedicated leased lines. Extranets can also save money by reducing phone and fax costs.

How It Works

Peer-to-peer extranets between business partners typically use virtual private networks (VPNs) to establish secure, encrypted communication over the unsecured public Internet for the transmission of sensitive business information, such as EDI between partners, or between headquarters and branch offices. These extranets act as dedicated gateways between business partners and generally do not allow private access to individual users. Peer-to-peer extranets can use Internet Protocol Security (IPSec) with a public key infrastructure (PKI) to provide IP-based authentication and encrypted transmission of information.

Client/server extranets have different requirements, as individual users need to be authenticated before receiving secure, encrypted access to company resources. Instead of authenticating on the basis of IP addresses as in peer-to-peer extranets, users must be authenticated using user accounts or digital certificates mapped to accounts. Client/server extranets might support HTTP access only or might allow other client/server applications to run. Encryption for HTTP access is performed using the Secure Sockets Layer (SSL) protocol.


F

failback

In clustering technology, the action of moving resources back to a node (a computer in a cluster) that has failed. This is sometimes known as “rebalancing the workload.”

How It Works

Suppose you have a cluster that has two nodes, each containing different resources. If Node A experiences failure, failover occurs and the workload of Node A (its set of resources) is transferred to Node B. When Node A reboots, it checks with Node B to see which resources are running on Node B and discovers that some of these cluster groups would “prefer” to reside on Node A. At this point failback occurs, and the preferred groups are moved from Node B back to Node A. Failback might be configured to occur immediately or at a scheduled time if access to resources is low.

In Microsoft Windows NT 4 Enterprise Edition, Microsoft Cluster Server (MSCS) sets up and controls clustering. In Windows 2000 Advanced Server, the Cluster service makes these functions available.

See also
failover

failover

Any technology that allows one device to take over for a similar device that has failed. An example of a system that takes advantage of failover technology is clustering. Failover is also often used to ensure that a break in a communication line doesn’t cause a break in communication between networked systems.

How It Works

Suppose you have a cluster that has two nodes, each containing different resources. If Node B experiences failure, failover occurs and the workload of Node B (its set of resources) is transferred to Node A. In Microsoft’s clustering services (Microsoft Cluster Server for Microsoft Windows NT 4 Enterprise Edition and the Cluster service for Windows 2000 Advanced Server), the cluster resources (network applications, data files, and other tools installed on the nodes of the cluster) provide services to clients on the network. A resource can be hosted on only one node at any given time, but by using the Cluster Administrator program you can configure the resource to fail over to the second node if the first node fails. This causes the resource and its operation to move from one node to the other if a failure of one node occurs.

Failover is initiated automatically by the Cluster service when a failure is detected on one of the nodes. This process can take up to 10 seconds to initiate. Failover is transparent to the users if they are accessing cluster resources using stateless protocols such as Hypertext Transfer Protocol (HTTP), and does not require any special client software to be installed on users’ machines. If a client is connected using a tool such as Windows Explorer, it will be notified that the connection is unavailable. The user should abort, retry, or cancel the connection attempt. (To connect to the resource on the failover node, retry the connection attempt.) For other Cluster service applications, users might have to log on again to the resource.

Graphic F-1. Failover.
Graphic F-1. Failover.
NOTE

Microsoft’s clustering services support failover at the level of virtual servers, which means items such as Web sites, print queues, file shares, and applications can be protected from system failure.

fallback switch

A class of switches used to provide failover support for critical network communication lines. Fallback switches are an essential component of a fault tolerant network system with resources that must have a high availability.

How It Works

For network resources that require high availability, resources can be connected to your network using two circuits:

  • A primary line that normally provides access to the resource

  • A secondary line to which the fallback switch reroutes the moment the primary line fails

An example of a resource requiring high availability is a high-speed T1 line that is used by remote clients for accessing a corporate intranet. If the primary T1 line goes down, there must be a backup line that provides instant, transparent failover support for clients. The solution is to use two T1 lines connected to a fallback switch by a serial interface such as RS-232 or V.35. The fallback switch detects a failure the moment the primary line goes down and can perform a remedial action such as

  • Automatically switching over to the backup line

  • Sounding an audible alarm to notify administrators

  • Generating an alert to a Simple Network Management Protocol (SNMP) management console

TIP

Fallback switches can also be used to provide fault tolerance for a high-speed backbone for Fast Ethernet, Fiber Distributed Data Interface (FDDI), or Asynchronous Transfer Mode (ATM) networking. For example, you can use fallback switches to run two multimode fiber-optic cables between a pair of Ethernet switches, instead of having only one cable connecting them. If one fiber-optic cable goes dark, the fallback switch immediately detects the problem and switches over to the backup cable.

Fallback switches that can be managed using SNMP management consoles are very useful. For example, you could use a remote SNMP terminal to cause a fallback switch to change from a primary to a secondary line if you need to take the primary line down for maintenance. Ganged fallback switches can be used to control multiple serial or local area network (LAN) devices simultaneously. For example, you could schedule a ganged switch to switch over from a set of primary Web servers to a backup Web server every night during a period of low traffic while maintenance or backups are performed on the primary servers. Be sure to use a fallback switch with some form of password protection on its SNMP management functions.

Graphic F-2. Fallback switch.
Graphic F-2. Fallback switch.

FAQ

See
frequently asked questions (FAQ)

Fast Ethernet

An Ethernet standard for 100-Mbps data transmission. Defined by the IEEE 802.3u specification, Fast Ethernet is used for departmental backbones, connections to high-speed servers, and connections to workstations running bandwidth-intensive software such as CAD or multimedia applications.

How It Works

Fast Ethernet uses the same Carrier Sense Multiple Access with Collision Detection (CSMA/CD) media access control mechanism as traditional 10-Mbps Ethernet networks. Fast Ethernet implementations are collectively known as 100BaseT technologies. They are generally wired in a star topology using special Fast Ethernet hubs and switches. Fast Ethernet can be implemented in three different transmission schemes or cabling options:

  • 100BaseTX:
    The most popular Fast Ethernet implementation. 100BaseTX uses two pairs of wires in category 5 cabling; that is, the same cabling as the popular but lower-speed 10BaseT variety of Ethernet.

  • 100BaseFX:
    A duplex multimode fiber-optic cable with ST connectors used mainly for backbone wiring.

  • 100BaseT4:
    Uses four pairs of wires and enables Fast Ethernet to be used over category 3 cabling or higher.

Graphic F-3. Fast Ethernet island connected to legacy 10BaseT network.
Graphic F-3. Fast Ethernet island connected to legacy 10BaseT network.

The Fast Ethernet specification includes mechanisms for auto-negotiation of frame speed for the media, enabling vendors to supply dual 10/100-Mbps networking devices for smoothly incorporating Fast Ethernet into legacy 10BaseT networks.

Upgrading to Fast Ethernet is probably the easiest and cheapest way of upgrading your network to meet increasing bandwidth needs. Advantages of upgrading 10-Mbps Ethernet networks to Fast Ethernet include the following:

  • Fast Ethernet integrates easily into existing 10-Mbps Ethernet networks without requiring reinvestment in new network-management and troubleshooting software.

  • Fast Ethernet can carry voice, data, and video at 100 Mbps, which is 10 times faster than traditional 10-Mbps Ethernet.

  • Fast Ethernet can operate over the same installed media used for a traditional 10-Mbps Ethernet network.

  • The network can be migrated slowly to Fast Ethernet by using autosensing 10/100 hubs and network interface cards (NICs).

NOTE

Repeaters (hubs) for Fast Ethernet networks come in two varieties:

  • Class I repeaters:
    Perform internal signal translation that introduces slight propagation delays but allows different types of Fast Ethernet media, such as 100BaseTX and 100BaseFX, to be connected together. You can use only one Class I repeater per Fast Ethernet segment.

  • Class II repeaters:
    Take incoming signals and repeat them immediately (without translation) to all outgoing ports, thus minimizing port latency. Class II repeaters require that all ports connect to the same media, such as 100BaseTX. You can use up to two Class II repeaters per Fast Ethernet segment.

An alternative to Fast Ethernet is 100BaseVG (also called 100VG-AnyLan). This IEEE 802.12 specification defines 100-Mbps transmission using a demand-priority media access control technology that Hewlett-Packard originally developed for transporting both Ethernet and Token Ring frames.

TIP

End-to-end node distances on Fast Ethernet segments should be no more than 205 meters depending on the class of repeaters and cabling being used. Also, nodes cannot be more than 100 meters from a hub or repeater with 100BaseTX, or 412 meters with 100BaseFX.

100-Mbps Ethernet switches can be used for segmenting your network to reduce bottlenecks caused by users trying to access key servers on the network. Simply connect each local area network (LAN) 10/100 hub to the Ethernet switch, and connect the servers directly to the switch.

See also
Ethernet, Gigabit Ethernet

FAT

See
file allocation table (FAT)

FAT32

An enhanced version of file allocation table (FAT), supported by Microsoft Windows 95 OSR2, Windows 98, and Windows 2000. FAT32 theoretically supports drives of up to 2 terabytes (2048 GB) in size, although for Windows 2000 the actual size limit is 32 GB. If the installation partition is smaller than 2 GB, it will automatically be formatted using FAT. If the installation partition size is equal to or greater than 2 GB, it will automatically be formatted as FAT32.

FAT32 uses a smaller cluster size than FAT so is more efficient at utilizing disk space on large volumes (those greater than 512 MB in size) than FAT. The savings in disk space using FAT32 instead of FAT for large volumes is typically 20 to 30 percent. The following two tables show the difference in cluster sizes between the original FAT and FAT32.

FAT Cluster Sizes
Drive Size | FAT Cluster Size
0 MB–32 MB | 512 bytes
33 MB–64 MB | 1 KB
65 MB–128 MB | 2 KB
129 MB–256 MB | 4 KB
257 MB–512 MB | 8 KB
513 MB–1024 MB | 16 KB
1025 MB–2048 MB | 32 KB
FAT32 Cluster Sizes
Drive Size | FAT32 Cluster Size
260 MB–8 GB | 4 KB
9 GB–16 GB | 8 KB
17 GB–32 GB | 16 KB
More than 32 GB | 32 KB
NOTE

Using FAT32 (or FAT) with the Windows 2000 operating system platform is not recommended because it does not offer the security features that are provided by the NTFS file system. FAT32 also does not support disk compression. The only time you would use FAT32 with Windows 2000 is in a dual-boot situation, which Microsoft does not recommend. Note that in a dual-boot system, FAT32 volumes cannot be accessed by any operating systems other than Windows 95 OSR2, Windows 98, or Windows 2000. For dual-boot with Windows 95, Windows 98, or Windows NT, drive C must be a FAT partition.

TIP

Remember, a client that connects over the network to a shared folder in Windows 2000 can access files in that folder regardless of whether the folder is stored on an NTFS, FAT, or FAT32 volume—provided the client has the appropriate permissions to do so.

FAT32 conversion utility

A utility included with Microsoft Windows 98 that allows users to convert existing file allocation table (FAT) volumes to FAT32 volumes without reformatting. FAT32 conversion utility can increase the performance of the disk storage system when larger partitions and drives (those larger than 512 MB) are used.

This utility can be run by choosing Programs, Accessories, System Tools, and Drive Converter (FAT32) from the Start menu. The utility provides a graphical user interface (GUI) for converting FAT16 volumes to FAT32. Running the conversion utility prompts you to select a drive letter to convert, after which the system restarts in MS-DOS mode. The system is then checked using scandisk, and the drive is converted.

TIP

At the completion of the conversion, Disk Defragmenter is configured to run upon the next reboot of the system. Do not interrupt the defragmentation process, because performance of the converted volume will likely be poor if the volume is not completely defragmented.

FAT volume

A partition on a physical disk formatted using the file allocation table (FAT) file system. FAT volumes can be used to share folders for users to access over the network, but they lack the advanced security control and auditing features of NTFS volumes. The maximum file partition size is 4 GB in Microsoft Windows NT and 2 GB in MS-DOS, Windows 3.x, Windows 95, and Windows 98.

TIP

Be sure to regularly defragment heavily used FAT volumes because the FAT file system can easily become fragmented when files are deleted and created. Use FAT volumes instead of NTFS volumes when you want to dual-boot Windows NT or Windows 2000 systems with earlier MS-DOS, Windows 3.x, Windows 95, or Windows 98 systems.

See also
NTFS file system

fault tolerance

Any mechanism or technology that allows a computer or operating system to recover from a failure. In fault tolerant systems, the data remains available when one component of the system fails. Here are some examples of fault tolerant systems:

  • Transactional log files that protect the Microsoft Windows registry and allow recovery of hives

  • RAID 5 disk systems that protect against data loss

  • Uninterruptible power supply (UPS) to protect the system against primary power failure

TIP

Just because your system is fault tolerant doesn’t mean you are fully prepared for disaster. You still need to perform regular backups of important data. For example, a RAID 5 disk system will protect against data loss if one disk drive fails, but not if two or more drives fail simultaneously.

fault tolerant boot disk

A boot disk for a Microsoft Windows NT server whose system partition or boot partition is mirrored. The fault tolerant boot disk can be used to boot the system in the event that one member of the mirror set fails. If you plan to use disk mirroring in your system, you need to create a fault tolerant boot disk. Disk mirroring is the only form of fault tolerance that Windows NT and Windows 2000 support for the critical system and boot partitions.

How It Works

A fault tolerant boot disk should be formatted using a computer running Windows NT. This disk consists of a floppy disk containing the following files in its root directory:

  • Ntldr

  • Ntdetect.com

  • Ntbootdd.sys (for SCSI disks with BIOS disabled)

  • Bootsect.dos (on dual-boot systems only)

  • Boot.ini

In addition, the boot.ini file must be modified so that its ARC paths point to the mirrored copy of the system partition.

TIP

Test your fault tolerant boot disk by using it to boot your system from the shadow drive and making sure you can log on. Be sure to disable the primary drive of the mirror pair to perform the test. Also, if you change the system’s disk configuration using Disk Administrator, be sure to update the boot.ini file on the floppy.

Make sure that the primary and shadow drives of your mirrored pair are identical in make, model, and firmware revisions so that you can recover from a broken mirror set. However, this is not necessary if you have a valid fault tolerant boot disk.

Fax Service

A service in Microsoft Windows 2000 that lets you administer fax devices on both a local machine and over the network. Besides allowing users to send and receive faxes both locally and over the network, Fax Service includes extensive document archiving and logging options for billing and troubleshooting purposes.

How It Works

Fax Service is integrated as a snap-in within the Microsoft Management Console (MMC). Prior to configuring a fax device, choose Programs, Administrative Tools, and Computer Management from the Start menu. In Computer Management, open the Services And Applications folder and click on Services. Then right-click on Fax Service in the right pane of Computer Management and choose Start from the context menu to start the Fax Service. To configure a fax device, access its property sheet. Then configure its Transmitting Station Identifier (TSID), which identifies the location that transmits the fax, and the Receiving Station Identifier (CSID), which identifies the line that receives the fax. The TSID and CSID are usually the telephone number of the fax line. TSID and CSID are required on all faxes in some locales.

FCC

See
Federal Communications Commission (FCC)

FDDI

See
Fiber Distributed Data Interface (FDDI)

FDDI token passing

The token-passing access method for Fiber Distributed Data Interface (FDDI) networking. FDDI uses a ring topology and uses token passing for placing frames on the ring.

How It Works

The token-passing method used by FDDI is generally similar to the token-passing definition outlined in the IEEE 802.5 specification for token ring networks. However, in an FDDI ring, each host holds the token for a predetermined amount of time and can transmit as many frames as it can produce during this time. When the time interval expires, the host must release the token for the next host on the ring to use. This differs from the IEEE 802.5 specification in that many frames from each host can exist on the ring at the same time, instead of only one frame per host, as is the case in token ring networks. This allows FDDI networks to support higher data traffic rates than token ring networks and makes FDDI more suitable for network backbones.

See also
Fiber Distributed Data Interface (FDDI), Token Ring

FDM

See
frequency-division multiplexing (FDM)

FDMA

See
Frequency Division Multiple Access (FDMA)

Federal Communications Commission (FCC)

A government agency overseeing all aspects of telecommunications. Among other responsibilities, the Federal Communications Commission (FCC) licenses portions of the electromagnetic spectrum for communication technologies such as cellular phones and wireless networking. For example, in 1994 the FCC auctioned off portions of the 1900-MHz radio wave section of the electromagnetic spectrum to enable companies to deploy Personal Communications Services (PCS) technologies for cellular communication. FCC auctions are intended to increase the number of cellular phone providers in the United States, foster growth and competition in the telecommunications industry, and raise money for the U.S. government treasury.

One role of the FCC is to implement communication legislation passed by Congress. The Telecommunications Act of 1996 represents the first major overhaul of the laws regarding telecommunications in more than 60 years. The FCC is tasked with enforcing this legislation, which is designed to open up competition in the telecommunications arena to foster innovation and economic progress.

On the Web
•
FCC home page
: http://www.fcc.gov

Fiber Distributed Data Interface (FDDI)

A high-speed network technology, conforming to the Open Systems Interconnection (OSI) reference model for networking and the American National Standards Institute (ANSI) standard X3T9, which runs at 100 Mbps over fiber-optic cabling; often used for network backbones in a local area network (LAN) or metropolitan area network (MAN).

How It Works

Fiber Distributed Data Interface (FDDI) is usually implemented as a dual token-passing ring within a ring topology (for campus networks) or star topology (within a building). The dual ring consists of a primary and secondary ring. The primary ring carries data. The counter-rotating secondary ring can carry data in the opposite direction, but is more commonly reserved as a backup in case the primary ring goes down. This provides FDDI with the degree of fault tolerance necessary for network backbones. In the event of a failure on the primary ring, FDDI automatically reconfigures itself to use the secondary ring as shown in the illustration. Faults can be located and repaired using a fault isolation technique called beaconing. However, the secondary ring can also be configured for carrying data, extending the maximum potential bandwidth to 200 Mbps.

Stations connect to one (or both) rings using a media interface connector (MIC). Its two fiber ports can be either male or female, depending on the implementation. There are two different FDDI implementations, depending on whether stations are attached to one or both rings:

  • Single-attached stations (Class B stations):
    Connect to either the primary or secondary ring using M ports. Single-attached FDDI uses only the primary ring and is not as commonly deployed for network backbones as dual-attached FDDI. Single-attached stations are used primarily to connect Ethernet LANs or individual servers to FDDI backbones.

  • Dual-attached stations (Class A stations):
    Connect to both rings. The A port is the point at which the primary ring enters and the secondary ring leaves; the B port is the reverse. M ports provide attachment points for single-attached stations. Dual-attached FDDI uses both rings, with the secondary ring serving as a backup for the primary. Dual-attached FDDI is used primarily for network backbones that require fault tolerance. Single-attached stations can be connected to dual-attached FDDI backbones using a dual-attached device called a concentrator or multiplexer.

Graphic F-4. Fiber Distributed Data Interface (FDDI).
Graphic F-4. Fiber Distributed Data Interface (FDDI).

FDDI uses a timed token-passing technology similar to that of token ring networks as defined in the IEEE 802.5 standard. FDDI stations generate a token that controls the sequence in which other stations will gain access to the wire. The token passes around the ring, moving from one node to the next. When a station wants to transmit information, it captures the token, transmits as many frames of information as it wants (within the specified access period), and then releases the token. This feature of transmitting multiple data frames per token capture is known as a capacity allocation scheme, in contrast to the priority mechanism used in the IEEE 802.5 token ring standard. Every node on the ring checks the frames. The recipient station then reads the information from the frames, and when the frames return to the originating station, they are stripped from the ring.

There can be up to 500 stations on a dual-ring FDDI network. The maximum circumference for an FDDI ring is 100 kilometers (or 200 kilometers for both rings combined), and there must be a repeater every 2 kilometers or less. Bridges or routers are used to connect the FDDI backbone network to Ethernet or token ring departmental LANs. For these reasons, FDDI is not often used as a wide area network (WAN) solution, but is more often implemented in campus-wide networks as a network backbone.

NOTE

FDDI frames encapsulate LAN traffic for transmission of LAN packets over FDDI backbones. The maximum frame size for an FDDI frame is 4500 bytes. FDDI implementations use one of three possible framing formats:

  • FDDI-raw:
    Supported by Cisco routers running Internetwork Operating System (IOS) versions 11.1 .x and later, and by some third-party vendors

  • FDDI with LLC:
    Supported by IOS versions 10.0 and earlier

  • FDDI with LLC and SNAP:
    Default format for encapsulating Internetwork Packet Exchange (IPX) packets on FDDI

FDDI implemented over copper cabling instead of fiber-optic cabling is called Copper Distributed Data Interface (CDDI).

TIP

FDDI makes a great network backbone for an Ethernet or Token Ring network. Put your servers directly on the FDDI ring to increase server performance. When bridging between Ethernet LANs and FDDI backbones, be aware that there are two different types of bridges:

  • Encapsulating bridges:
    Encapsulate Ethernet frames into FDDI frames

  • Translating bridges:
    Translate source and distention MAC addresses into FDDI addresses

These two FDDI bridging technologies can cause incompatibilities. For example, while Cisco FDDI bridges can generally interoperate with translating bridges from other vendors, their encapsulation method is proprietary and usually won’t work with encapsulating bridges from other vendors. Both types of bridging methods are commonly used in FDDI networks.

The following table shows some troubleshooting tips for FDDI networks.

FDDI Troubleshooting
Problem | Suggestions
FDDI ring is not functioning. | Check the status of the router’s FDDI interface, making sure the interface and line protocol are up. Try pinging a remote router. Check the physical connections of the cable; use an optical time domain reflectometer to test for problems.
Signal is degraded. | Check whether the upstream FDDI neighbor has failed and the bypass switch has been activated.
See also
fiber-optic cabling

fiber exhaust

A term referring to the potential saturation of the fiber-optic backbone of the Internet due to the exponentially increasing demand for Internet services. As high-speed residential Internet access using cable modems and Asymmetric Digital Subscriber Line (ADSL) technology becomes available, more and more of the Internet bandwidth will be used up. Another factor contributing to fiber exhaust is the move toward high-bandwidth services such as IP telephony and video multicasting technologies on the Internet. Strategies telecommunications carriers use to avoid fiber exhaust include the following:

  • Creating additional high-speed, fiber-optic backbone lines for the Internet by laying down more fiber

  • Using dense wavelength division multiplexing (DWDM) technologies to enable existing fiber backbones to carry additional traffic

  • Upgrading existing time-division multiplexing (TDM) fiber backbones to higher bit rates

fiber-optic cabling

A glass cabling media that sends network signals using light. Fiber-optic cabling has higher bandwidth capacity than copper cabling, and is used mainly for high-speed network Asynchronous Transfer Mode (ATM) or Fiber Distributed Data Interface (FDDI) backbones, long cable runs, and connections to high-performance workstations.

How It Works

Fiber-optic cabling consists of a signal-carrying glass core of 5 to 100 microns in diameter (a sheet of paper is about 25 microns thick and a human hair about 75 microns thick), surrounded by a layer of pure silica called cladding, which prevents light from escaping. Surrounding the cladding are protective layers of acrylic plastic coating, Kevlar fibers for additional strength, and a PVC (polyvinyl chloride) jacket (usually colored a distinctive orange). Network components use LED or laser diodes to convert electrical signals into light pulses for transmission on fiber-optic cables. An optical detector is used to convert the light pulses back into electrical signals.

Graphic F-5. Fiber-optic cabling.
Graphic F-5. Fiber-optic cabling.

There are two types of fiber-optic cabling:

  • Single-mode fiber-optic cabling:
    Has a narrow core (5 or 10 microns in diameter) and allows only one signal to be sent or received at a time over very long distances (up to 50 times farther than multimode fiber-optic cabling). Single-mode fiber-optic cabling uses laser-emitting diodes to introduce signals into the fiber and can transmit only one signal (light beam) at a time. Signal transmission is clear for approximately 30 miles (50 kilometers) before dispersion will distort signals, which means that single-mode fiber is ideal for long cable runs.

  • Multimode fiber-optic cabling:
    Has a thicker core (50, 62.5, or 100 microns in diameter) and has sufficient bandwidth to allow multiple signals to be simultaneously transmitted or received; each signal follows a different path or mode through the fiber. Light-emitting diodes are used instead of laser-emitting diodes to introduce signals into multimode fiber. Signal transmission is clear for approximately 3000 feet, but longer cable runs can distort signals through modal dispersion. There are two types of multimode fiber:

    • Step-index multimode fiber:
      The less costly variety of multimode fiber, it uses a wide core with a uniform index of refraction, causing the light beams to reflect in mirror fashion off the inside surface of the core by the process of total internal reflection. Because light can take many different paths down the cable and each path takes a different amount of time, signal distortion can result when step-index fiber is used for long cable runs. Use this type only for short cable runs.

    • Graded-index multimode fiber:
      The more expensive type of multimode fiber, it uses a core made of multiple concentric layers of glass, each having a lower index of refraction than the layer it contains. In graded-index fiber, light beams follow curved paths and all rays reach the end of the fiber simultaneously, reducing the signal distortion that occurs in step-index fiber when long cable runs are used.

Connectors for fiber-optic cabling come in several varieties, including SC, ST, and SMA connectors. ST connectors have a wider installed base, but SC connectors are more versatile and are becoming more popular. SMA connectors do not conform to EIA/TIA wiring standards.

Fiber-optic cabling has several advantages over copper cabling, including the following:

  • Data transmission rates of up to 100 Gbps and higher.

  • Low attenuation, allowing signals to be sent over distances measured in kilometers.

  • Less than 10 percent the weight of copper cabling.

  • Immunity to crosstalk and noise caused by electromagnetic interference (EMI).

  • Prevention of ground loops by electronically isolating transmitting and receiving stations.

  • Greater signal security because signals cannot be picked up by electromagnetic induction as they can from copper cabling. The fiber would have to be tapped (physically opened) in order to eavesdrop on the transmission.

Graphic F-6. Connecting two LANs using fiber-optic cabling.
Graphic F-6. Connecting two LANs using fiber-optic cabling.

Fiber-optic cabling is often used for campus-wide backbones, long cabling runs between buildings, and local area network (LAN) connections to heavily used servers or high-speed workstations. Fiber is used also in heavy industrial environments where machinery can cause high levels of EMI. Fiber is not used extensively at the LAN level yet because it is more expensive and more difficult to install than copper cabling. Long-distance telecommunications carriers such as Sprint and MCI use fiber-optic cabling exclusively for their country-wide telecommunications lines.

Different styles of fiber-optic cabling exist, depending on the intended use. Examples include the following:

  • Duplex multimode cable:
    With 62.5-micron core and 125-micron cladding, this is the most common general purpose cable type for most networking environments that require fiber-optic cabling. You can separate the two cables for termination purposes just as you can with an appliance power cord.

  • Breakout style cable:
    This style of cabling contains multiple individual simplex fibers that are stranded around a central strengthening member. It is used for work-area connections and does not require patch panels.

  • Distribution style cable:
    This style of cabling contains multiple individual simplex color-coded fibers that are stranded around a central strengthening member. It is often used in backbone applications that require multiple fiber connections.

  • Steel-reinforced cable:
    This type of cabling uses a corrugated steel inner tube for protecting cable that needs to be buried or run outdoors.

NOTE

Line drivers for fiber-optic cabling are available for synchronous or asynchronous transmission as well as for single-mode or multimode fiber, allowing you to extend or interconnect LANs in either point-to-point or multipoint configurations.

TIP

Remember that the bandwidth of a fiber-optic cable depends on the distance as well as the frequency. Bandwidth is usually expressed in frequency distance form, for example in MHz-km. In other words, a 500-MHz-km fiber-optic cable can transmit a signal a distance of 5 kilometers at a frequency of 100 MHz (5 x 100 = 500), or a distance of 50 kilometers at a frequency of 10 MHz (50 x 10 = 500). In other words, there is an inverse relationship between frequency and distance for transmission over fiber-optic cables.

Be careful not to unduly stress fiber-optic cabling during installation. The maximum acceptable bend radius is usually 20 times the diameter of the cable. Use an optical time domain reflectometer (OTDR) to test for faults after installation. Loss of signal, or attenuation, in fiber-optic cables can be caused by absorption (no medium is completely transparent to light), cable microbending (especially in single-mode fiber if it is not installed correctly), connector loss because of poor splicing or poorly installed or misaligned connectors, or coupling loss at the transmitter or receiver.

For safety, never look down a fiber-optic cable connected to your network because the invisible laser light can injure the retina of your eye. When splicing connectors onto fiber, be careful to avoid getting shards of glass in your eyes or on your hands—use double-sided tape to clean the connection and remove loose shards. Wear protective eyewear.

Fiber-optic cabling is available for purchase in bulk for those who want the challenge of terminating it themselves, but most customers buy standard or custom preterminated cables from suppliers. These cables can be simplex or duplex; they can be single-mode or multimode (multimode is most common); and they can be terminated with ST-ST, ST-SC, SC-SC, or SMA connectors.

See also
SC and ST connectors, time domain reflectometry (TDR)

Fibre Channel

A high-speed fiber-optic cabling technology for connecting computer devices. Although Fibre Channel is viewed as the future replacement for the Small Computer System Interface (SCSI) standard for connecting servers to external data storage units such as external hardware RAID arrays, it can also be used as a transport for high-speed data and video transmission over networks.

An enterprise-level data storage environment can benefit from Fibre Channel because the traditional SCSI interface has become a bottleneck in high-speed server operations. Fibre Channel eliminates the limitations of bandwidth, distance, and scalability that are related to the SCSI standard and is becoming the industry standard for enterprise-level storage solutions involving RAID arrays and storage area networks.

How It Works

Fibre Channel, defined in the American National Standards Institute (ANSI) standard X3.230-1994, can handle data transmission rates from 266 Mbps to more than 4 Gbps over distances as great as 10 kilometers, with typical speeds of 1.06 Gbps in common configurations. You can implement Fibre Channel over both fiber-optic and copper media.

Fibre Channel systems typically connect hosts using host bus adapters to special hubs, adapters, switches, and storage units. Fibre Channel connections can be simple, point-to-point connections with intelligent communication between devices.

Fibre Channel uses a control protocol that is isolated from the data transmissions and uses point-to-point connections, switched topologies, and arbitrated loops to provide high performance and scalability.

A typical Fibre Channel implementation might use a stackable hub or switch to connect a server or mainframe host to an external Fibre Channel RAID storage system having 100-Mbps redundant loops and hot-swappable disks. Servers can also use SCSI over Fibre Channel for connecting to legacy storage systems. Fibre Channel can also carry TCP/IP and video traffic for server-to-server connections and high speed workstation connections in CAD/CAE or multimedia environments.

Graphic F-7. An example of its usage.
Graphic F-7. An example of its usage.

Fibre Channel competes with other high-speed networking technologies, such as Gigabit Ethernet and Asynchronous Transfer Mode (ATM). Fibre Channel’s strengths include its protocol-independent transport service (in contrast to Gigabit Ethernet’s frame format, which extends from the desktop to the network backbone) and its guaranteed delivery service (included in Class 4 Fibre Channel, which makes it competitive with ATM’s Quality of Service features). Also, Gigabit Ethernet is limited to general networking transport solutions and ATM is limited to networking and video transport, while Fibre Channel can carry network and video traffic, connect to storage devices, and be used in clustering technology.

On the Web
•
Fibre Channel Industry Association
: http://www.fibrechannel.com

file

Information assigned a name and stored on a disk or some other media. Files are the primary unit of information stored on disk systems. Examples of files include

  • Executable files (programs)

  • Data files (documents, databases)

  • Web pages (HTML files)

Files are generally stored in a file system, which provides a hierarchical way of saving, locating, and accessing information.

file allocation table (FAT)

Specifically, a table maintained on a hard disk by MS-DOS and Microsoft Windows operating systems that acts as a table of contents, showing where directories and files are stored on the disk. By extension, the acronym FAT is also used to refer to the file system itself for MS-DOS and Windows platforms. In other words, when we refer to the FAT file system, we simply call it the FAT. The FAT is widely supported by all Windows platforms and can be installed on partitions of up to 2 GB in size on Windows 95 and Windows 98, and on partitions of up to 4 GB on Windows NT and Windows 2000. The FAT is often used in dual-boot scenarios, or when the security and reliability of the NTFS file system is not required.

How It Works

The FAT file system is based on the FAT, a structure that maps the locations of the clusters in which files and folders are stored on the disk. The FAT records the location of each cluster that makes up a given file and the sequence in which it is stored. This is necessary because files are usually not stored in a contiguous location on a hard disk because of the presence of disk fragmentation caused by the creation and deletion of files on the disk. For each file on a FAT volume, the FAT contains the entry point for the allocation unit in which the first segment of the file is stored, followed by a series of links called the allocation chain. The allocation chain indicates where succeeding segments of the file are located and is then terminated by an end-of-file (EOF) marker.

Two copies of the FAT are kept in fixed locations on the disk to provide redundancy. A disk formatted with the FAT file system is said to be a FAT volume. The sizes of the individual clusters in which file information is stored on a FAT volume depend on the size of the partition or logical drive formatted using FAT, as shown in the following table. For compatibility reasons, these cluster sizes are the same whether the FAT volume is on an MS-DOS or Windows platform. In the table, you’ll see that on small FAT partitions (under 15 MB in size) a special 12-bit FAT file system is used instead of the usual 16-bit FAT.

FAT Information for Different Volume Sizes
Drive Size | FAT Type | Sectors/Cluster | Cluster Size
0 MB–15 MB | 12-bit | 8 | 4 K
16 MB–127 MB | 16-bit | 4 | 2 K
128 MB–255 MB | 16-bit | 8 | 4 K
256 MB–511 MB | 16-bit | 16 | 8 K
512 MB–1023 MB | 16-bit | 32 | 16 K
1024 MB–2047 MB | 16-bit | 64 | 32 K
2048 MB–4095 MB | 16-bit | 128 | 64 K

Different versions of Windows support different file systems. The original release of Windows 95 supports only FAT, while Windows 95 OSR2 and Windows 98 support FAT and FAT32. FAT32 is a newer 32-bit version of FAT that was first included with the OSR2 release of Windows 95. The original version of FAT is 16-bit and is sometimes referred to as FAT16. Windows NT supports both FAT and NTFS, but not FAT32. Windows 2000 supports FAT, FAT32, and NTFS. Possible advantages of using FAT volumes with Windows NT and Windows 2000 include the following:

  • Multiboot capability:
    If you need to dual boot between Windows 95 or Windows 98 and Windows NT, use FAT instead of NTFS because Windows 95 and Windows 98 cannot read or recognize NTFS volumes.

  • Efficiency on small partitions:
    FAT requires less overhead than NTFS and is more efficient on smaller volumes (those under 400 MB in size).

NOTE

The root directory on a FAT volume has a fixed size and can contain only a limited number of entries.

See also
FAT32, file system, NTFS file system

File and Printer Sharing for Microsoft Networks

A Microsoft Windows 95 and Windows 98 networking component that allows computers running Windows 95 and Windows 98 to share folders and printers so that other clients can access them. File and Printer Sharing for Microsoft Networks uses the Server Message Block (SMB) file sharing protocol, and is compatible with clients such as

  • Computers running Windows 95 and Windows 98 that have Client for Microsoft Networks installed

  • Windows NT

  • Windows for Workgroups

  • LAN Manager

Use the Network utility in Control Panel to install Client for Microsoft Networks on a computer running Windows 95 or Windows 98.

NOTE

You cannot install File and Printer Sharing for Microsoft Networks if File and Printer Sharing for NetWare Networks is already installed.

File and Printer Sharing for NetWare Networks

A Microsoft Windows 95 and Windows 98 networking component that allows computers running Windows 95 and Windows 98 to share folders and printers so that they can be accessed by Novell NetWare clients and by computers running Windows 95 or Windows 98 with Client for NetWare Networks.

Use the Network utility in Control Panel to install File and Printer Sharing for NetWare Networks on a computer running Windows 95 or Windows 98.

NOTE

Installing File and Printer Sharing for NetWare Networks automatically installs the NWLink IPX/SPX-Compatible Transport protocol and Client for NetWare Networks, if these have not already been installed. A bindery-based NetWare server must also be available as a network security provider because File and Printer Sharing for NetWare Networks does not support NetWare servers running Novell Directory Services (NDS).

You cannot install File and Printer Sharing for NetWare Networks if File and Printer Sharing for Microsoft Networks is already installed.

File and Print Services for Macintosh (FSM)

The Microsoft Windows 2000 counterpart to Services for Macintosh on machines running Windows NT. File and Print Services for Macintosh (FSM) lets PC and Apple Macintosh clients share files and printers. With FSM on a server running Windows 2000, Macintosh client machines need nothing more than the Macintosh operating system software installed to access resources on the server.

How It Works

FSM integrates the following three services:

  • File Services for Macintosh:
    Also called MacFile, this service lets Macintosh clients access files stored on the server running Windows 2000. Use MacFile to specify a directory on an NTFS volume as a Macintosh-accessible volume.

  • Print Services for Macintosh:
    This service lets Macintosh clients print to printers connected to the server running Windows 2000 and spools print jobs for AppleTalk printers such as the LaserWriter.

  • AppleTalk protocol:
    This service can be installed on the server running Windows 2000 to enable it to function as an AppleTalk router.

Once FSM is installed on your server, you can make directories available as Macintosh volumes by using the Shared Folders node in the System Tools folder of the Computer Management tool.

NOTE

You can install an optional authentication module for Macintosh clients so that they can securely log on to Windows 2000–based servers running FSM.

File and Print Services for NetWare (FPNW)

A Microsoft Windows NT and Windows 2000 add-on utility that enables a server running Windows NT or Windows 2000 to

  • Allow NetWare client machines to access resources on a server running Microsoft Windows NT

  • Share directories and printers on a server running Windows NT so that NetWare clients can access them

  • Manage NetWare printers from a server running Windows NT, making these printers also available to Microsoft clients

How It Works

File and Print Services for NetWare (FPNW) accomplishes these functions by mimicking the functionality of a NetWare 3.12 file and print server, and providing file and print services directly to NetWare and compatible client computers. A server running Windows NT or Windows 2000 using FPNW appears to NetWare client machines as if it were really a NetWare server, and clients can access volumes, files, and printers just as they would on a NetWare server. Accounts for NetWare client users are stored in the Security Accounts Manager (SAM) database, instead of requiring maintenance in a separate NetWare server. The FPNW server supports both the Server Message Block (SMB) protocol for Windows client connections and the NetWare Core Protocol (NCP) for NetWare client connections. FPNW requires that the NWLink IPX/SPX-Compatible Transport protocol be installed on the server.

Graphic F-8. File and Print Services for NetWare (FPNW).
Graphic F-8. File and Print Services for NetWare (FPNW).

FPNW supports NetWare functions such as user-account creation, remote administration, secure logins, and print queue management. However, it does not support NetWare functions such as user disk volume restrictions or inherited rights masks.

NOTE

FPNW is not included with Windows NT or Windows 2000, but you can obtain it as a separate utility from your Microsoft value-added reseller (VAR). FPNW can be installed only on server machines, not on workstations. The directory that will be used as a NetWare SYS volume should be on an NTFS partition.

file extension

A string appended to a filename, consisting of a period followed by three alphanumeric characters. File extensions usually identify the application that can open or run them. For example, text files end with the extension .txt and are opened with Microsoft Notepad. Other common file extensions include the following:

  • .doc for Microsoft Word documents

  • .exe for executable files

  • .htm for Web pages created in Hypertext Markup Language (HTML)

  • .gif for GIF 87/89 format images, commonly used on the Internet

TIP

Associations between different file extensions and the programs used to open them are stored in the registry. Sometimes you might need to modify or remove a registered file extension. For example, if two different applications save files using the same file extension, you can easily modify file extensions in Microsoft Windows 95, Windows 98, or Windows NT by using Windows Explorer. Just select Options from the View menu to open the Options dialog box, and select the File Types dialog box. Create, remove, or edit file extensions as desired. Be aware that using this tool might negatively affect the ability of applications on your system to function, so modify extensions with care. In Windows 2000, you can do the same by selecting Folder Options from the Tools menu.

Graphic F-9. File extension.
Graphic F-9. File extension.
See also
8.3 filename, long filename (LFN)

File Manager

A key Microsoft Windows 3.1 utility that provides a graphical way of managing files and directories. You can use File Manager to copy files, start programs, print documents, and maintain disks. Since File Manager is a network-aware utility, you can also use it both to share folders and to map network drives to shared folders on other systems on the network. This capability is useful, for example, in a Windows for Workgroups network in which one machine is used as a server for the other machines.

Graphic F-10. File Manager.
Graphic F-10. File Manager.
NOTE

File Manager is also included with Windows 95 and Windows 98 for users who prefer it to the newer Windows Explorer utility. To run File Manager in Windows 95 or Windows 98, click Start, click Run, and type winfile.

file permissions (Windows 2000)

File permissions for NTFS volumes on computers running Microsoft Windows 2000. For information on file permissions on Windows NT versions 4 and earlier, refer to the entry on NTFS standard file permissions in this work.

How It Works

File permissions govern access to files on an NTFS volume, while folder permissions govern access to folders on an NTFS volume. There are five standard file permissions on NTFS volumes for computers running Windows 2000: full control, modify, read & execute, read, and write. For any given file on an NTFS volume, each of these file permissions can be allowed or denied for a specific user or group by using the Security tab of the file’s property sheet in Windows Explorer (see the illustration).

Each of these five standard file permissions is made up of a subset of the individual or special file permissions that are available on NTFS volumes on machines running Windows 2000. The following table lists the various special file permissions and how they are combined to form the five different standard file permissions.

NOTE

If a group is granted full control folder permission on a folder, any member of the group can delete any files in that folder regardless of the file permissions.

Graphic F-11. File permissions (Windows 2000).
Graphic F-11. File permissions (Windows 2000).
Special File Permissions
Special Permissions | Full Control | Modify | Read & Execute | Read | Write
Execute file | x | x | x |  |
Read data | x | x | x | x |
Read attributes | x | x | x | x |
Read extended attributes | x | x | x | x |
Create files/write data | x | x |  |  | x
Append data | x | x |  |  | x
Write attributes | x | x |  |  | x
Write extended attributes | x | x |  |  | x
Delete subfolders and files | x |  |  |  |
Delete | x | x |  |  |
Read permissions | x | x | x | x | x
Change permissions | x |  |  |  |
Take ownership | x |  |  |  |
Synchronize | x | x | x | x | x
See also
folder permissions (Windows 2000)

file system

Any technology for organizing, storing, and locating data on a system or network. The file system for a computing platform defines the method by which the operating system stores, locates, and accesses files on its hard disk subsystem.

How It Works

File systems usually have a hierarchical structure consisting of a series of nested directories for storing files. Each directory can contain files, other subdirectories, or both. The top of the file system is called the root, and the various directories are its branches. The file system thus forms a tree.

Graphic F-12. A hierarchical file system.
Graphic F-12. A hierarchical file system.

File systems include conventions for the type and the maximum number of characters that can be used to name a file. A file can be located in the file system by specifying its absolute path—that is, its path starting from the root and traversing through the directory structure until the file is reached. Using graphical user interface (GUI) or command-line tools, files can be located, copied, moved, and deleted. Microsoft Windows Explorer is an example of a GUI tool that shows the hierarchical structure of the file system on a Windows-based machine. File systems can incorporate technologies for marking files with attributes such as hidden and read-only. Some file systems allow you to compress files, and some allow you to specify file system quotas for users.

File systems can generally be classified into two types, depending on where the stored resources are located:

  • Local file systems:
    These systems are part of the operating system and manage locally attached storage devices such as disk drives and removable drives. Portions of local file systems can be shared to allow users on the network to access specific files, but users generally need to know the name or location of the share in order to access it.

  • Distributed file systems:
    These systems are used to combine shared portions of local file systems on many different machines into a single network-wide hierarchical file system. Distributed file systems allow shared network resources located all over the network to appear as though they are located on a single “superserver,” and simplify the process of users locating and accessing shared network resources.

Examples of common file systems include the following:

  • The file allocation table (FAT) file system for MS-DOS-based and Windows-based computers

  • The NTFS file system for Windows NT and Windows 2000

  • The Distributed file system (Dfs) for Windows NT and Windows 2000

  • The standard hierarchical UNIX file system

  • Sun’s distributed Network File System (NFS) for UNIX platforms

File-Transfer Access and Management (FTAM)

The Open Systems Interconnection (OSI) reference model counterpart of the Internet standard File Transfer Protocol (FTP). The File-Transfer Access and Management (FTAM) protocol is an OSI application layer (layer 7) protocol that specifies a standard mechanism for access and management of a distributed network file system. FTAM enables users to

  • Access file stores both locally and remotely, making FTAM a distributed file access protocol more similar to Gopher in this regard than to FTP

  • Integrate management of both local and remote file stores, including the ability to manipulate both files and their attributes

  • Access file stores on different kinds of machines that have different types of file systems

  • Transfer files both synchronously and asynchronously

The FTAM model defines the architecture of a hierarchical virtual file store in terms of file structure, file attributes, and the kinds of operations that can be performed on files and their attributes. The FTAM standard does not specify the actual user interface for file access and management, simply the underlying architecture of the system. Vendors are left free to create their own user interfaces to FTAM file systems or use existing interfaces for their vendor-specific file systems. Some third-party vendors have developed FTAM-based products for Microsoft Windows NT and other operating systems, but like many aspects of the OSI model, FTAM has not caught on the way Internet protocols such as FTP have, mainly because of its complexity.

File Transfer Protocol (FTP)

An Internet standard application-level TCP/IP protocol that can be used for transferring files between hosts on a TCP/IP internetwork.

How It Works

File Transfer Protocol (FTP) is one of the earliest Internet protocols, and is still used for uploading and downloading files between clients and servers. An FTP client is an application that can issue FTP commands to an FTP server, while an FTP server is a service or daemon running on a server that responds to FTP commands from a client. FTP commands can be used to change directories, change transfer modes between binary and ASCII, upload files, and download files.

Graphic F-13. File Transfer Protocol (FTP).
Graphic F-13. File Transfer Protocol (FTP).

FTP uses Transmission Control Protocol (TCP) for reliable network communication by establishing a session before initiating data transfer. TCP port number 21 on the FTP server listens for connection attempts from an FTP client and is used as a control port for establishing a connection between the client and server, for allowing the client to send an FTP command to the server, and for returning the server’s response to the command. Once a control connection has been established, the server opens port number 20 to form a new connection with the client for transferring the actual data during uploads and downloads.

NOTE

Internet Information Services (IIS) supports virtual servers and virtual directories using FTP.

TIP

You can view the status of open ports on IIS using the netstat command. If an FTP client has trouble accessing information on IIS, try changing the directory listing style for the FTP service on IIS. FTP supports only Basic Authentication or anonymous access for authentication schemes and does not support the more secure Microsoft Windows NT Challenge/Response Authentication method.

See also
Internet Information Services (IIS)

Find

A dialog box in Microsoft Windows 2000 that lets you locate objects in Active Directory. The Find dialog box allows you to query the global catalog server for objects such as users, groups, computers, shared folders, printers, and other objects in Active Directory.

How It Works

To use the Find dialog box, open a console with the snap-in for Active Directory Users and Computers installed, right-click on a container or organizational unit, and select Find from the shortcut menu. Then specify what kinds of objects you want to search for within Active Directory, such as

  • Users, contacts, and groups

  • Computers

  • Printers

  • Shared folders

  • Directory folders

  • Routers

  • Custom search

Next specify whether you want to search the entire Active Directory, a particular domain, or a particular organizational unit. Finally, specify the query parameters associated with the type of object you are looking for. For example, if you are looking for users, contacts, or groups, you can specify the name of the object, its description, or specific attributes of the object such as home phone or e-mail address.

NOTE

If you are performing a search based on an attribute of an object, you must specify a value for this attribute.

Graphic F-14. Find.
Graphic F-14. Find.

finger

A TCP/IP utility for viewing information about a user on a system running the finger service. If you “finger” a user’s e-mail address, the result returned to you includes the user’s username, full name, whether and how long the user has been logged on, and other information depending on the configuration of the finger service you are querying.

NOTE

Microsoft’s implementation of TCP/IP on Windows NT has finger client software but no finger service. In other words, you can run the finger client on a machine running Windows NT that is connected to the Internet in order to obtain results from a UNIX server at an Internet service provider (ISP) running the finger daemon. In this situation, if the ISP makes its finger daemon publicly available on the Internet, it is commonly referred to as a finger gateway.

Example

Typing the command finger jsmith@s12.microsoft.com displays information about user Jeff Smith on a server called s12.microsoft.com.

FIPS

See
National Institute of Standards and Technology (NIST)

firewall

Any system or device that allows safe network traffic to pass while restricting or denying unsafe traffic. Firewalls are usually dedicated machines running at the gateway point between your local network and the outside world, and are used to control who has access to your private corporate network from the outside—for example, over the Internet. More generally, a firewall is any system that controls communication between two networks. In today’s networking environment in which corporate networks are connected to the Internet—inviting hackers to attempt unauthorized access to valuable business information—a corporate firewall is essential.

How It Works

In its simplest form, a firewall is essentially a kind of router or computer with two network interface cards that filters incoming network packets. This device is often called a packet-filtering router. By comparing the source addresses of these packets with an access list specifying the firewall’s security policy, the router determines whether to forward the packets to their intended destinations or stop them. The firewall can simply examine the IP address or domain name from which the packet was sent and determine whether to allow or deny the traffic. However, packet-filtering routers cannot be used to grant or deny access to networks on the basis of a user’s credentials.

Graphic F-15. Firewall.
Graphic F-15. Firewall.

Packet-filtering routers can also be configured to block certain kinds of traffic while permitting others. Usually this is done by disabling or enabling different TCP/IP ports on the firewall system. For example, port 25 is usually left open to permit Simple Mail Transfer Protocol (SMTP) mail to travel between the private corporate network and the Internet, while other ports (such as port 23 for Telnet) might be disabled to prevent Internet users from accessing other services on corporate network servers. The difficulty with this approach is that the size of the access list for the firewall can become huge if a large number of domains or ports are blocked and a large number of exceptions are configured. Some ports are randomly assigned to certain services (such as remote procedure call services) on startup; it is more difficult to configure firewalls to control access to these ports.

The simple firewall just described is sometimes called a network-level firewall because it operates at the lower levels of the Open Systems Interconnection (OSI) reference model for networking. Network-level firewalls are transparent to users and use routing technology to determine which packets are allowed to pass and which will be denied access to the private network. Network-level firewalls implemented solely on stand-alone routers are called packet-filtering routers or screening routers.

Another type of firewall is a circuit-level gateway, which is usually a component of a proxy server. Circuit-level gateways essentially operate at a higher level of the OSI model protocol stack than network-level firewalls do. With a circuit-level firewall, connections with the private network are hidden from the remote user. The remote user connects with the firewall, and the firewall forms a separate connection with the network resource being accessed after changing the IP address of the packets being transmitted in either direction through the firewall. The result is a sort of virtual circuit between the remote user and the network resource. This is a safer configuration than a packet-filtering router because the external user never sees the IP address of the internal network in the packets he or she receives, only the IP address of the firewall. A popular protocol for circuit-level gateways is the SOCKS v5 protocol.

Another more advanced type of firewall is the application-level firewall (or application gateway), which is also usually a component of a proxy server. Application gateways do not allow any packets to pass directly between the two networks they connect. Instead, proxy applications running on the firewall computer forward requests to services on the private network, and then forward responses to the originators on the unsecured public network. Application gateways generally authenticate the credentials of a user before allowing access to the network, and they use auditing and logging mechanisms as part of their security policy. Application gateways generally require some configuration on the part of users to enable their client machines to function properly, but they are more atomic in their configurability than network-level firewalls. For example, if a File Transfer Protocol (FTP) proxy is configured on an application gateway, it can be configured to allow some FTP commands but deny others. You could also configure an SMTP proxy on an application gateway that would accept mail from the outside (without revealing internal e-mail addresses), and then forward the mail to the internal mail server. However, because of the additional processing overhead, application gateways have greater hardware requirements and are generally slower than network-level firewalls.

NOTE

Microsoft Proxy Server includes the functions of network-level firewalls, circuit-level firewalls, and application gateways, enabling businesses to protect their sensitive corporate networks from attack over the Internet.

TIP

The best way to begin configuring a packet-filtering firewall is to block all packets at first and then start allowing access to the internal network on a case-by-case basis. Make sure that internal network addresses do not cross the firewall to the outside world and do not store sensitive data on the machine running the firewall software itself. Treat your firewall machine as expendable—the worst possibility should be a hacker’s damage to the firewall; this would simply leave your private network securely disconnected from the outside world. You can disable all unnecessary network services on your firewall machine to protect the firewall itself from attack.

If you are concerned only about controlling outgoing access from your network, and in addition your users do not need to be able to remotely access your network over the Internet, a packet-filtering router or circuit-level gateway type of firewall is probably sufficient. For users who frequently need to remotely access your network, however, an application gateway is generally best.

FireWire

Also known as the IEEE 1394 High Performance Serial Bus, a serial transmission specification proposed by Apple for connecting high-speed peripherals to computers at speeds of up to 393 Mbps. FireWire supports hot-swapping of peripherals with up to 63 peripherals connected to a single IEEE 1394 bus. In addition, up to 1023 IEEE 1394 buses can be interconnected to form a vast array of peripherals using FireWire. FireWire features simple plug-in connectors using thin serial cables that can be hot-plugged without interfering with your system’s operation. FireWire connectors are based on the Nintendo Game Boy connector.

How It Works

FireWire as defined in IEEE 1394 uses 64-bit device addresses. FireWire cables use two twisted-pair wires for data transmission and two wires for power. FireWire includes two different serial interfaces:

  • A backplane interface:
    Runs at speeds between 12.5 and 50 Mbps for bus connections within a computer system

  • A point-to-point interface:
    Runs at speeds of 98.304 Mbps (S100 specification), 196.608 Mbps (S200), and 393.216 Mbps (S400) for connecting devices to computers using serial cables

The topology of a typical FireWire implementation can be complex, but it is typically a hierarchical or tree topology consisting of various IEEE 1394 components. More complex topologies, including several computers sharing portions of the peripheral network, are also possible. The illustration shows how you can use FireWire. The four types of components you can use in a FireWire implementation are

  • Devices:
    Typically have 3 ports but can have up to 27 ports and can be daisy-chained up to 16 devices

  • Splitters:
    Provide extra IEEE 1394 ports if needed to accommodate the number and arrangement of devices used

  • Repeaters:
    Overcome distance limitations in IEEE 1394 cables

  • Bridges:
    Isolate traffic within a specific portion of an IEEE 1394 bus

FireWire connections have a maximum distance of 4.5 meters, but up to 16 components can be daisy-chained to a maximum distance of 72 meters without using repeaters.

Graphic F-16. FireWire.
Graphic F-16. FireWire.

FireWire is supported by the Microsoft Windows 98 and Windows 2000 operating systems, along with the universal serial bus (USB) specification.

NOTE

Windows 98 resets the FireWire bus and assigns new physical addresses to IEEE 1394 devices when

  • Devices are added or removed from the bus

  • The system is rebooted

On the Web
•
1394 Trade Association
: http://www.1394ta.org

flapping

A problem condition that can occur with dynamic routers on large internetworks. When a router is flapping (called a “flapping router”), it broadcasts routing table updates that alternate between two different routes to a host. For example, the flapping router might indicate during the first broadcast that route A is the best route to a given host, indicate during the second broadcast that route B is the best route, indicate during the following broadcast that route A is best, and so on. Flapping routers thus generate unnecessary routing traffic over the network. This generally happens when a router is unnecessarily configured to load-balance between paths with equal hop counts. To determine whether a router is flapping, use a network packet sniffer.

flow control

The mechanism by which a modem controls the rate at which it receives data from another modem. You can also use flow control to describe data rate control mechanisms between other devices, such as computers and attached printers, or between CSU/DSUs (Channel Service Unit/Data Service Units) and routers. Flow control is sometimes equated with handshaking, but the term “handshaking” specifically refers to flow control negotiations that take place at the beginning of a communication session, while the term “flow control” also can apply to data transmission management during an active communication session. In general modem technologies, two basic types of flow control exist:

  • Hardware flow control:
    Also known as RTS/CTS (Request To Send/Clear To Send) control, this method uses special dedicated pinning on cables to leave flow control to the modem itself. In other words, a separate hard-wired signal link (wire) that does not carry data is used to enable one modem to send stop and start messages to the other modem by raising or lowering voltage levels on this wire. Hardware flow control is used with high-speed modems that can compress data and is usually the default setting for Microsoft Windows-based software, such as HyperTerminal, that uses modems.

  • Software flow control:
    Also known as XON/XOFF control, this method uses special data characters (usually Ctrl+S to stop transmission, and Ctrl+Q to resume) sent within the data stream itself to enable a local modem to signal a remote modem to stop transmitting data so that the local modem can catch up.

    Software flow control is slower and less reliable than hardware flow control because a user, program, or line noise might inadvertently generate a stop signal for the remote modem. In addition, software flow control is used only for transmitting ASCII text information, not for binary data files, because the binary data might contain the Ctrl+S stop character and cause the remote modem to stop transmitting data.

    Graphic F-17. Flow control.
    Graphic F-17. Flow control.

folder permissions (Windows 2000)

File permissions for NTFS volumes on computers running Microsoft Windows 2000. For information on folder permissions on machines running Windows NT versions 4 and earlier, refer to the entry on NTFS standard folder permissions in this work.

How It Works

Folder permissions govern access to folders on an NTFS volume, while file permissions govern access to files on an NTFS volume. NTFS volumes for computers running Windows 2000 have six standard folder permissions: full control, modify, read & execute, list folder contents, read, and write.

For any given folder on an NTFS volume, each of these folder permissions can be allowed or denied for a specific user or group by using the Security tab of the folder’s property sheet in Windows Explorer (see the illustration).

Each of these six standard folder permissions is made up of a subset of the individual or special permissions that are available on NTFS volumes on machines running Windows 2000. The following table lists the various special permissions and how they are combined to form the six different folder permissions.

Graphic F-18. Folder permissions (Windows 2000).
Graphic F-18. Folder permissions (Windows 2000).
Special Folder Permissions
Special Permissions | Full Control | Modify | Read & Execute | List Folder Contents | Read | Write
Traverse folder | x | x | x | x |  |
List folder | x | x | x | x | x |
Read attributes | x | x | x | x | x |
Read extended attributes | x | x | x | x | x |
Create files | x | x |  |  |  | x
Create folders | x | x |  |  |  | x
Write attributes | x | x |  |  |  | x
Write extended attributes | x | x |  |  |  | x
Delete subfolders and files | x |  |  |  |  |
Delete | x | x |  |  |  |
Read permissions | x | x | x | x | x |
Change permissions | x |  |  |  |  |
Take ownership | x |  |  |  |  |
NOTE

The list folder contents and the read & execute folder permissions have the same special permissions. However, read & execute permission is inherited by both files and folders, while list folder contents permission is inherited only by folders.

See also
file permissions (Windows 2000)

foreign host

In a Microsoft TCP/IP implementation, any host that uses a non-Microsoft operating system. Examples of foreign hosts are OS/2 workstations, Solaris servers, and VMS mainframes.

Connectivity with foreign hosts for the purpose of transferring files with the host requires

  • A common networking protocol, such as TCP/IP or Internetwork Packet Exchange (IPX)

  • A common file-sharing protocol, such as Server Message Block (SMB) or Network File System (NFS)

foreign mail system

A mail system that belongs to a different company than your own and that might also be of a different type. An example could be a public X.400 messaging system in Europe or the Internet’s Simple Mail Transfer Protocol (SMTP) mail system. The term “foreign mail system” usually refers to a mail system other than Microsoft Exchange Server. You can establish connectivity between an Exchange organization and a foreign mail system by installing and configuring an appropriate connector on an Exchange server in your organization. Examples include

  • Using the Internet Mail Service to connect an Exchange organization to the SMTP mail system on the Internet

  • Using the X.400 Connector to connect an Exchange organization to a public X.400 messaging network such as those common in Europe

forest

See
domain forest

form (Exchange)

In Microsoft Exchange Server messaging systems, a graphical interface for users to enter or display messages. Forms can be created for uniformly posting information to public folders using Microsoft Outlook. For example, an order form could be created for posting orders to a public folder for processing. The Exchange Scripting Agent can then be used to create triggers that process the form when certain input conditions exist.

form (HTML)

In Hypertext Markup Language (HTML), a form is a portion of a Web page that presents a series of fields for the Web browser user to complete, along with a Submit button to send the data to the Web server for processing. Forms are often used in Web sites for guest books, registration, and similar purposes. If you create an HTML form you must create a corresponding form handler—an application that accepts the data from the form and processes it accordingly. Form handlers are typically written in Perl and implemented as Common Gateway Interface (CGI) scripts on UNIX Web server platforms such as Apache. On Internet Information Services (IIS), form handlers can be Internet Server API (ISAPI) applications written in C or Active Server Pages (ASP) scripts written in Microsoft Visual Basic, Scripting Edition (VBScript).

format command

A command common to all Microsoft operating systems that can be used to install a file system on a partition. After a drive has been partitioned as desired, each partition must be formatted before files can be stored on the partition. Note that formatting a partition causes all data previously stored on it to be lost.

Example

In Microsoft Windows 95 and Windows 98, format /d: /u performs an unconditional (irreversible) format of drive D.

NOTE

You can use the graphical user interface (GUI) tool Disk Administrator in Windows NT and the Disk Management utility in Windows 2000 to format a disk volume. Disk Management is found in the Storage folder of the Computer Management tool in Windows 2000.

forwarder

A name server configured to perform iterative queries with other name servers on the Internet. Forwarders are useful for reducing name resolution traffic and speeding Domain Name System (DNS) name queries for large private TCP/IP internetworks that are connected to the Internet. They are also used to resolve name queries when a firewall between your network and the Internet prevents clients in your network from directly querying name servers located at your Internet service provider (ISP) or elsewhere on the Internet. In this case, a typical location for the forwarder is on the bastion host. (The “bastion host” is the host running the proxy server or application layer gateway application.)

How It Works

If one of your name servers is configured as a forwarder, all off-site queries for resolving DNS names are first sent to the forwarder. The forwarder then performs an iterative query with an off-site name server located at your ISP to resolve the query. The results of the query are cached by the forwarder. This caching of name query results by the forwarder speeds later name query requests and reduces traffic between your network and the ISP.

Graphic F-19. Forwarder.
Graphic F-19. Forwarder.
See also
DNS query, Domain Name System (DNS)

FPNW

See
File and Print Services for NetWare (FPNW)

FQDN

See
fully qualified domain name (FQDN)

fractional T1

A type of Internet connection. A fractional T1 line is a T1 line, leased by a T-carrier service provider to a customer, that carries only a fraction of the regular T1 bandwidth of 1.544 Mbps. Regular T1 lines consist of 24 DS0 channels multiplexed together, while fractional T1 lines consists of fewer than 24 channels. Fractional T1 lines typically consist of a combination of nailed-up channels and switched channels. The technology of fractional T-carrier services is the same as that of regular T-carrier services; the extra channels are simply unused. Customers might want to lease fractional T1 services when they don’t require the entire bandwidth (or cost) of a regular T1 line.

FRAD

See
frame relay access device (FRAD)

frame

A segment of data on a network or telecommunications link, generally consisting of a header with preamble (start of frame flag), destination and source addresses, data payload, and usually some form of error-checking information. Frames are assembled and generated by the data-link layer and physical layer of the Open Systems Interconnection (OSI) reference model. This assembly process is called “framing.” In other words, packets from the network layer are encapsulated by the data-link layer into frames. Data segments generated by higher layers of the OSI model are generally referred to as packets, but the term “packet” is also sometimes used to include frames.

The format in which data frames are constructed depends on the particular data-link layer protocol being used. Thus, we can speak of Ethernet frames, Integrated Services Digital Network (ISDN) frames, X.25 frames, frame relay frames, and so on. Each particular local area network (LAN) or wide area network (WAN) data-link protocol has its own method of framing data for transmission over the network or telecommunications line. Frames can be fixed-length or variable-length, and have addressing information for multipoint connections or no addressing information for point-to-point connections. They can also have error correction, as in X.25, or no error correction, as in frame relay.

frame relay

A packet-switching technology offered as a telecommunications service by telcos and long-distance carriers, used primarily for WAN links. Frame relay can be used to encapsulate local area network (LAN) traffic such as Ethernet frames for transmission over digital data transmission lines for wide area networks (WANs), and can connect multiple LANs to form a multipoint WAN. Frame relay technology was originally an offshoot of Integrated Services Digital Network (ISDN) digital communication technology.

How It Works

Frame relay technology is a packet-switching service that is similar in operation to, and considered the replacement for, the older X.25 packet-switching technology—but it provides higher performance and has a greater efficiency because it is a more streamlined protocol. For example, while X.25 includes error-correction functions, frame relay leaves error correction up to the station endpoints in order to speed up WAN communications. When errors do occur, frame relay drops the offending frame and retransmits the data. Frame relay also does not support the hop-by-hop flow control functions that X.25 supports, which further streamlines frame relay operation.

As in other packet-switching networks, frame relay operates by breaking network data into “packets” and tagging each packet with a destination address. Each packet is then relayed through the switching nodes that make up the packet-switching network. The packets are reassembled into the correct order at their destination. Frame relay is a protocol-independent service that uses special frame relay devices for encapsulating network data into variable-length packets called frames using the data-link layer protocol called High-level Data Link Control (HDLC). Frame relay links can have unpredictable latency for forming connections because frame relay networks have no prioritization scheme.

Instead of relaying each packet individually through the frame relay network, frame relay uses virtual circuits that act as temporary paths through the network. These virtual circuits can be either switched virtual circuits (SVCs) that are set up and torn down on a call-by-call basis, or permanent virtual circuits (PVCs) that are established in advance. PVCs are preferred because they provide a more reliable grade of service for the customer. PVCs provide dedicated point-to-point connections between local and remote customer premises through a frame relay cloud. By establishing multiple PVCs, you can run multiple logical WAN links over a single physical frame relay connection. PVCs are managed using the Local Management Interface (LMI) protocol, which provides features for verifying link integrity and managing the status of PVCs.

PVCs function in a way similar to private leased lines and provide the customer with a level of service that is agreed upon, called the Committed Information Rate (CIR). The CIR, a negotiated level of service you purchase from the carrier, specifies your maximum transmission speed over the frame relay network. Speeds typically range from 56 Kbps to T3 speeds and higher, depending on your requirements. CIR acts as a kind of bandwidth throttling mechanism that facilitates the use of shared frame relay circuits by different users. Some service providers allow temporary bursts of traffic to exceed the CIR, but any traffic above the Committed Information Burst Rate (CIBR) is dropped and requires retransmission.

Frame relay runs over T1 and fractional T1 carriers with transmission speeds ranging from 56 Kbps to 1.544 Mbps or higher. Since frame relay is independent of network protocols such as TCP/IP and IPX/SPX-Compatible Protocol, it has more flexibility than X.25.

Frame relay implementations usually follow one of two networking topologies:

  • Fully meshed topology:
    In this implementation, each frame relay device is connected to every other device using PVCs to form a multipoint WAN. When an update is transmitted to one device, it is seen by every other device as well. The advantage of this configuration is that the entire frame relay network can be treated as a single data-link connection.

  • Partially meshed topology:
    This implementation uses a star or hub-and-spoke topology in which frame relay devices are not connected to every other device in the frame relay cloud. Network designers should be careful when adopting this configuration to prevent split-horizon problems.

To connect a network to a telco Frame Relay Bearer Service (FRBS), use a special bridge, router, or CSU/DSU (Channel Service Unit/Data Service Unit) device called a frame relay access device (FRAD). The FRAD connects your customer premises to an Edge Switch (ES) on your provider’s frame relay cloud (the collection of all frame relay circuits belonging to your provider). See the illustration for an example.

Frame relay technology is more popular in North America than slower packet-switching technologies such as X.25, while in Europe, X.25 has traditionally been a more popular solution. Frame relay services were first offered in 1992 by AT&T, Sprint, and other carriers, which have installed frame relay points of presence (POPs) for connections to the central office (CO) of local telcos in major metropolitan locations around the United States.

NOTE

An important consideration in frame relay communication is a set of extensions to the frame relay encapsulating protocols called the LMI, developed by Cisco, DEC, and others. Frame relay routers from Cisco use a “Cisco LMI” while many other vendors use the “ANSI LMI,” which can create incompatibilities.

TIP

Bursts of traffic above the CIR are typically short (less than two seconds in duration) and are generally possible only during off-peak utilization times. When access to the service provider’s frame relay network is heavy, your maximum bandwidth will be your CIR.

Graphic F-20. A frame relay WAN link.
Graphic F-20. A frame relay WAN link.

Some possible strategies for troubleshooting frame relay links in different kinds of situations appear in the following table.

Troubleshooting Frame Relay Links
Problem | Suggestions
Frame relay link is down (connections fail) | Check cabling and connections, make sure you are using a data terminal equipment (DTE) cable, try connecting the cable to a different port, or try a different cable. Make sure you are using IETF encapsulating if mixing frame relay devices from different vendors.
Cannot ping remote router | Check the status of PVC; contact carrier if this is down. Check the router’s access list, disable access list, and retry. Make sure you are using IETF encapsulating if mixing frame relay devices from different vendors. Check the configuration of the frame relay address map.
Cannot ping device on remote network | Try pinging local router’s frame relay address; check that a default gateway is specified. Check for split horizon conditions in a hub-and-spoke frame relay implementation.
On the Web
•
Frame Relay Forum
: http://www.frforum.com

frame relay access device (FRAD)

Sometimes called a frame relay assembler/disassembler, a telecommunications device that enables a customer site to be connected to a frame relay service.

How It Works

The frame relay access device (FRAD) is a device that receives network packets from the customer’s network and encapsulates them into a format acceptable for transmission over frame relay circuits. A local FRAD accepts packets from a bridge, router, or other device; buffers them; frames them; and transmits them over a frame relay link to a remote FRAD that performs the process in reverse. Special bridges and routers can include built-in FRAD circuitry for directly connecting customer networks to a frame relay service.

The FRAD also includes technology for statistically multiplexing large numbers of virtual circuits (logical data streams) over a single physical communication link. This enables the FRAD to provide the customer with greater flexibility in bandwidth use, in contrast to time-division multiplexing (TDM) techniques, which ensure a full level of service for each data stream, even when they carry no data. For example, if two data streams are multiplexed using TDM, frames from the two streams will alternate to form the single serial data link. If one of these streams has no data, empty frames will still be sent, resulting in a poor utilization of bandwidth. In statistical multiplexing, the multiplexed data stream contains only frames from data streams that are carrying data, and the higher the data transmission rate of a stream, the greater the number of frames that are multiplexed into the serial data link.

TIP

Some bridges and routers, such as many of those from Cisco, have built-in FRAD technology and need to be connected only to a CSU/DSU (Channel Service Unit/Data Service Unit) through a V.35 or other serial transmission cable to provide customers with an all-in-one frame relay access solution for wide area networking. Use a bridge if you want an easy way to connect a branch office using frame relay. Use a router if you want to control traffic flow or reroute failed connections.

See also
frame relay

frame relay cloud

The totality of frame relay circuits within a telecommunication carrier’s frame relay network. This frame relay network is commonly known as a Frame Relay Bearer Service (FRBS). Typically, a frame relay cloud is a collection of packet-switching devices owned by the carrier and used as a shared public network for backboning wide area network (WAN) traffic for private customers. Frame relay clouds can also consist of frame relay circuits owned by private networking consortiums. The frame relay network is described as a “cloud” because of the large number of interconnections between the various edge switches, usually forming a fully connected mesh topology. In frame relay services, each frame of information contains the routing information needed to enable the frame to be routed to its destination through the cloud.

See also
 frame relay

frame type

Specifies the data format for frames when using the NWLink protocol on machines running Microsoft Windows NT or Windows 2000. Two machines on a network using NWLink or IPX/SPX-Compatible Protocol must be using the same frame type to communicate. NWLink on Windows NT and Windows 2000 can listen to IPX/SPX traffic on the network and automatically configure itself to use the network frame type, which is usually

  • 802.3 for NetWare 2.2 through 3.11

  • 802.2 for NetWare 3.12 and later

The following table shows the frame types supported by NWLink.

Frame Types Supported by NWLink
Network Topology | Frame Types Supported
 | Ethernet II | 802.2 | 802.3 | SNAP | 802.5
Ethernet | x | x | x | x |
Token Ring |  |  |  | x | x
FDDI |  | x |  | x |
NOTE

The NWLink property sheet on Windows NT and Windows 2000 Server allows you to configure NWLink to use multiple frame types if needed. NWLink on Windows NT and Windows 2000 Server is configured by default to be automatically detected when NWLink is first loaded. But if multiple frame types are detected, including 802.2, the 802.2 frame type will be selected by default. NWLink on Windows NT Workstation and Windows 2000 Professional can be configured for multiple frame types only by editing the registry.

See also
NWLink IPX/SPX-Compatible Transport

Frequency Division Multiple Access (FDMA)

The signal multiplexing technology used in the Advanced Mobile Phone Service (AMPS) analog version of cellular phone technology. Frequency Division Multiple Access (FDMA) is one of three methods used for allocating channels to users over the shared wireless communications medium in cellular phone communication; the others are Time Division Multiple Access (TDMA) and Code Division Multiple Access (CDMA).

How It Works

FDMA is implemented at the media access control (MAC) layer of the data-link layer in the Open Systems Interconnection (OSI) reference model for networking protocol stacks. FDMA is based on the frequency-division multiplexing (FDM) technique used in wireless networking. In FDMA, the user is assigned a specific frequency band in the electromagnetic spectrum, and during a call that user is the only one who has the right to access the specific band. In the AMPS cellular phone system, these frequency bands are allocated from the electromagnetic spectrum as follows:

  • Transmission by mobile station:
    824 MHz to 849 MHz

  • Transmission by base station:
    869 MHz to 894 MHz

Two different frequency bands are used to allow full-duplex communication between base and mobile stations. Both of these bands are then divided into discrete channels that are 30 kHz wide in bandwidth.

Graphic F-21. Frequency Division Multiple Access (FDMA).
Graphic F-21. Frequency Division Multiple Access (FDMA).
NOTE

One way to understand FDMA is to imagine different people in the same room communicating in voices with different pitches, some high and some low; they would all be able to talk simultaneously and (more or less) understand one another. This is similar to the way FDMA works. FDMA is used by traditional AM and FM radio bands to allow broadcast by individual stations.

See also
Code Division Multiple Access (CDMA), Time Division Multiple Access (TDMA)

frequency-division multiplexing (FDM)

A signal transmission technology in which multiple signals can simultaneously be transmitted over the same line or channel. Frequency-division multiplexing (FDM) can be used in both wired and wireless networking for transmitting large amounts of data at high speeds. FDM is the simplest and oldest form of multiplexing in wireless networking technology.

How It Works

Frequency division multiplexing involves simultaneously transmitting multiple signals on different frequencies. These different frequencies, called channels, share non-overlapping portions of the total frequency band being used. Signals from different data sources are fed into a multiplexer that modulates each signal and transmits them at different frequencies. These signals are then transmitted over the wire or through wireless communication and are separated at the destination into individual data signals using a demultiplexer.

See also
dense wavelength division multiplexing (DWDM), multiplexing, time-division multiplexing (TDM)

frequency hopping

A spread-spectrum transmission technology for wireless networking. Spread-spectrum wireless technologies trade throughput for increased reliability, and were originally developed by the U.S. military to provide communication that could not easily be jammed.

How It Works

Frequency hopping transmitters take the incoming data stream and segment it into multibit packets. These packets are then transmitted sequentially in a pseudo-random manner over the various frequency channels within the spread-spectrum band being used. In other words, the frequency of the carrier signal keeps hopping around. Synchronization between the master transmitter and slave devices is achieved by modulating the center or carrier frequency of the communication band according to a preset algorithm. Both the mobile and the base station know the modulation algorithm, which enables them to keep in communication with each other. For increased security, the modulation algorithm can be dynamically modified.

Graphic F-22. Frequency hopping.
Graphic F-22. Frequency hopping.

frequently asked questions (FAQ)

A list of commonly asked questions and their answers, developed for beginners in a given subject to reduce the amount of customer technical support required. Frequently asked questions (FAQs) are often available for computer products and services on company and organization Web sites on the Internet. They are also available for many different Usenet newsgroups. Some Microsoft software documentation also includes FAQs to provide quick answers to commonly asked questions about the software. To ease your customer support requirements, create a simple and highly usable FAQ for your clients.

FSM

See
File and Print Services for Macintosh (FSM)

FTAM

See
File-Transfer Access and Management (FTAM)

FTP

See
File Transfer Protocol (FTP)

FTP service

A Microsoft Windows NT service on servers running Microsoft Internet Information Server, or a Windows 2000 service on servers running Internet Information Services (IIS). The FTP service supports the Internet standard File Transfer Protocol (FTP), and allows users to upload and download files between FTP clients and FTP servers such as IIS.

FTP supports only user-level authentication. In other words, FTP servers such as IIS that are running the FTP service support only anonymous authentication or Basic Authentication. When an FTP client attempts to connect to an FTP server configured to use Basic Authentication, the user’s name and password are transmitted as clear text over the network, which is insecure. The best way to secure FTP services is to enable anonymous authentication on all FTP servers, which requires users to log on with the username “anonymous.” (They can enter anything for the password, but the FTP server’s welcome message usually requests that they politely use their e-mail address as their password for logging purposes.) You should configure the FTP service on IIS to allow only anonymous logons to prevent users from passing their credentials over the network. Then simply avoid storing critical information on your FTP servers, and use them for access to public information only.

You will probably also want to configure your FTP servers to allow only downloads and prohibit all uploads. If your corporate users must upload files remotely using FTP, you can create an FTP drop box for them. An FTP drop box is a folder on an NTFS volume, configured as a virtual directory that has write permission on it but no read permission. In other words, users can upload files to the directory but cannot read what has already been uploaded.

FTP utility

A TCP/IP utility for copying files to and from remote hosts on machines running Microsoft Windows 95, Windows 98, Windows NT, and Windows 2000. The remote host must be running the FTP service and authenticate the client before the client can transfer files. The FTP utility provides a command-line interface only for uploading and downloading files to FTP servers. Various shareware GUI-based FTP clients are available on the Internet.

How It Works

The FTP command starts an interactive session in which a series of FTP-specific commands can be used to list directories, upload and download files, change between binary and ASCII mode, and so on.

The FTP command is a command-line FTP client and must interact with the FTP service running on the remote host. Microsoft’s implementation of the FTP service is part of Internet Information Services (IIS).

full backup

See
normal backup

full-duplex

A mode of communication in which data is simultaneously transmitted and received between stations. Full-duplex communication is twice as fast as half-duplex communication, and typically uses two separate pairs of wires (or two channels for wireless networking) for supporting simultaneous transmission and reception by a host. An alternative arrangement is to use some multiplexing technique, such as time-division multiplexing (TDM), to interleave transmission and reception on a single channel. This does not produce true full-duplex communication, but to an ordinary user it might appear to do so if the interleaving process is fast enough.

Graphic F-23. Full-duplex.
Graphic F-23. Full-duplex.

Examples of full-duplex communication include cellular telephone technologies and full-duplex Ethernet. Examples of half-duplex communication are walkie-talkies, CB radios, and standard Ethernet networks. Examples of simplex communication technology include satellite broadcasting and cable TV broadcasting.

full-duplex Ethernet

An emerging type of Ethernet that supports full-duplex communication between stations on the network. Full-duplex Ethernet lets stations send and receive data simultaneously, thus giving it twice the maximum throughput of traditional forms of Ethernet.

How It Works

Full-duplex Ethernet uses two lines for sending and receiving data simultaneously. It is used in point-to-point connections between stations and requires that lines be concentrated using Ethernet switches instead of hubs or repeaters. Using switches and point-to-point connections means that full-duplex Ethernet avoids the collisions that can degrade the performance of standard half-duplex Ethernet. A full-duplex connection on a 100BaseT network would thus have a theoretical maximum speed of 200 Mbps, but in reality full-duplex Ethernet tends to achieve only a 20 to 60 percent higher throughput than standard Ethernet.

NOTE

Full-duplex Ethernet does not use the traditional Carrier Sense Multiple Access with Collision Detection (CSMA/CD) media access control method of traditional Ethernet since collisions cannot occur on a full-duplex, point-to-point link between two stations. Because of this, the distance limitations between two stations in full-duplex Ethernet depend only on the strength of the transceivers with respect to the medium used. Thus station-to-station distances for full-duplex Ethernet connections can be much greater than for traditional Ethernet networks. For 100-Mbps full-duplex links, this is generally around 2 kilometers over fiber-optic cabling.

TIP

Use 20-Mbps full-duplex Ethernet to connect two 10BaseT Ethernet networks over duplex single-mode fiber-optic cabling at distances of up to 15 kilometers. To do this, use a pair of half-to-full duplex converters at either end of the fiber-optic line. These converters should always be used in pairs, and they typically have an attachment unit interface (AUI) port that accepts the fiber-optic transceiver.

Graphic F-24. Full-duplex Ethernet.
Graphic F-24. Full-duplex Ethernet.

fully qualified domain name (FQDN)

In the Domain Name System (DNS), a dotted name that fully identifies a TCP/IP host on the Internet. A fully qualified domain name (FQDN) of a host consists of its host name dotted together with its domain name and any names of subdomains in which the host resides. FQDNs are used in Uniform Resource Locators (URLs) for accessing Web pages on the Internet and provide an absolute path through the DNS namespace to the target host on which the Web page resides. They are also sometimes called absolute domain names.

Example

For the FQDN server7.microsoft.com, the TCP/IP host name is server7 and its domain is microsoft.com.

Fusion

An annual business symposium for the business experts and managers in the Microsoft Certified Solution Provider (MCSP) worldwide community. The general purpose of Microsoft Fusion is to enable solution providers to

  • Share information on the latest Microsoft products, technologies, and sales strategies from experts in the field

  • Share their experiences and tips with other industry experts and peers

  • Discover new methods for growing a business by capitalizing on Microsoft technologies and resources

On the Web
•
Microsoft Fusion home page
: http://events.microsoft.com/events/fusion


G

G.703

An encoding standard developed by the International Telecommunication Union (ITU) for interfacing data communications equipment (DCE) with digital high-speed synchronous communication services. G.703 is not used in North America but is widely used in Europe, and it covers specifications for digital transmission from rates of 64 Kbps to 2.048 Mbps. Private Branch Exchange (PBX) systems often use 64-Kbps leased lines utilizing the G.703 standard, as do E-carrier services such as E1 communication links. Some U.S. vendors sell converters for connecting synchronous V.35, RS-449, or X.21 interfaces to G.703 in order to sell their switching equipment in Europe.

Graphic G-1. G.703.
Graphic G-1. G.703.
NOTE

G.703 has been updated to include support for U.S. standard T-carrier service speeds, such as T1 transmission at 1.544 Mbps.

GAL

See
Global Address List (GAL)

gateway

A term for a broad category of network components that allow communication between different networking architectures and different protocols. Gateways generally operate at the higher levels of the Open Systems Interconnection (OSI) reference model for networking. They are commonly used to provide connectivity between two different protocol stacks that might be running on different systems. Examples include the following:

  • E-mail gateways—for example, a gateway that receives Simple Mail Transfer Protocol (SMTP) e-mail, translates it into a standard X.400 format, and forwards it to its destination

  • Gateway Service for NetWare (GSNW), which enables a machine running Microsoft Windows NT Server or Windows 2000 Server to be a gateway for Windows clients so that they can access file and print resources on a NetWare server

  • Gateways between a Systems Network Architecture (SNA) host and computers on a TCP/IP network, such as the one provided by Microsoft SNA Server

  • A packet assembler/disassembler (PAD) that provides connectivity between a local area network (LAN) and an X.25 packet-switching network

A gateway is usually a dedicated device or a set of services running on a dedicated computer. Gateways are essentially devices that direct network traffic in some fashion and translate that information.

Gateway Service for NetWare (GSNW)

A service for servers running Microsoft Windows 2000 and Windows NT (called Gateway Services for NetWare in Windows NT) that can be installed on these servers to enable them to directly access file and print resources on Novell NetWare servers. Gateway Service for NetWare (GSNW) can also enable a Windows-based server to act as a gateway for other Microsoft clients, such as Windows for Workgroups, Windows 95, Windows 98, Windows NT Workstation, or Windows 2000 Professional, allowing them to access the resources on the NetWare server.

GSNW can connect to NetWare 2.x , 3.x , or 4 .x servers. The 4.x servers can run either bindery emulation or Novell Directory Services (NDS). Using GSNW, Microsoft clients can access the resources on the NetWare server by connecting to a share on the server running Windows NT or Windows 2000. The process is totally transparent to users—to the client, the resource appears to be located on the Windows-based server.

How It Works

A server that has GSNW installed also must have the NWLink protocol loaded. This protocol, which is an IPX/SPX-Compatible Transport, makes it possible for the Windows server to communicate with the NetWare server. If it is not already installed, NWLink will install automatically on the server when you install GSNW.

To prepare the NetWare server for the gateway, you must create a group and a user account as follows:

  • Create a group called Ntgateway on the NetWare server, and give it the necessary rights for accessing the resources you want to make available on the server.

  • Create a user account on the NetWare server, and give it the necessary rights for accessing the resources you want to make available on the server. Make this user account a member of the Ntgateway group.

GSNW will use this user account for creating a connection to the NetWare server. The connection will appear on the server running Windows NT or Windows 2000 as a redirected drive that can be shared, as if it were a resource located on the Windows-based server. Windows clients can then connect to the shared resource by browsing Network Neighborhood, by mapping a drive using Windows Explorer, or by using the net use command.

From the perspective of the Windows clients on the network, the shared resources they access appear to reside on the Windows-based server. In actuality, the GSNW service on the server is performing protocol conversion between the Server Message Block (SMB) protocol, which the Windows clients understand, and the NetWare Core Protocol (NCP), which the NetWare file server uses.

Graphic G-2. Gateway Service for NetWare (GSNW).
Graphic G-2. Gateway Service for NetWare (GSNW).

After GSNW is installed, the first time you log on to the server for connectivity to a NetWare 4.x server using NDS, you are prompted to specify a default tree and context for connecting to the NetWare server. If the NetWare server is running in bindery-emulation mode or is an earlier 2.x or 3.x server, you must specify a preferred server when you log on. You can also configure these settings using the GSNW utility in Control Panel.

TIP

Because GSNW must process all requests directed through the gateway and perform protocol conversion between SMB and NCP, access is slower than if the clients actually had NetWare client software installed and could directly access the NetWare server. You should use GSNW only for occasional or temporary access to NetWare servers by Windows clients. Install Client Services for NetWare (CSNW) on machines running Windows 95 or Windows 98 for better performance.

See also
Client Services for NetWare (CSNW), File and Print Services for NetWare (FPNW), NetWare protocols

gender changer

A type of adapter with two connectors of the same type and gender, making it possible to change the gender of the connector to which it is joined from male (with pins) to female (with sockets) or vice versa.

This allows two male or two female cable ends to be joined. Gender changers come in a wide variety of types and are specified by connector type and gender. An example is a V.35 to V.35 male/male gender changer, which can be used to connect two V.35 serial cables (or one cable and a CSU/DSU) that terminate with female connectors

Graphic G-3. Examples of V.35 gender changers.
Graphic G-3. Examples of V.35 gender changers.
TIP

Some gender changers can also act as adapters for different data interfaces. For example, a V.35 to RS-232 male/male gender changer can be used to connect a V.35 connection on a CSU/DSU (Channel Service Unit/Data Service Unit) to a router, using an RS-232 serial cable. Be sure that the pinning for such a gender changer is suitable for the type of equipment you want to connect because different pinnings might exist when different serial interfaces are connected.

General Packet Radio Service (GPRS)

An upgrade to the Time Division Multiple Access (TDMA) cellular phone system. General Packet Radio Service (GPRS) uses packet switching instead of the existing circuit-switching technologies of TDMA systems to provide more efficient use of available bandwidth. GPRS provides subscribers with up to eight separate 14.4-Kbps communication channels. In theory, GPRS has a maximum data transmission rate of 171.2 Kbps, but in practice the maximum rate is only about 44 Kbps downstream and 22 Kbps upstream because of the overhead of combining channels and the power limitations on the subscriber end. Implementation of GPRS requires that existing TDMA hardware be upgraded accordingly.

Some limited trials of GPRS began in 1999, with widespread trials set to begin in the summer of 2000. A number of European and Asian countries are piloting GPRS systems and have an edge over the United States in the arena of wireless communication systems running at more than 20 Kbps.

With its higher data rates, GPRS makes possible the kinds of wireless applications and services that have simply not been feasible on the existing Global System for Mobile Communications (GSM) circuit-switched data services, which are limited to 9.6 Kbps, or by using the existing Short Message Service (SMS), which is limited to a maximum of 160 characters of transmitted information. Possible uses for GPRS include services such as wireless mobile Web browsing, discussion groups, chat services, mobile commerce, and home automation through wireless remote control.

NOTE

It is probable that GPRS upgrades will be easiest for carriers whose networks operate in the 1800-MHz or 1900-MHz frequency bands, because they usually have sufficient unused capacity to implement channel aggregation without having to upgrade their bearer equipment. Upgrading to GPRS is more expensive for carriers operating in the 800-MHz or 900-MHz bands because of the near-full capacity of those bands.

Another cost involved in the GPRS upgrade process is that of replacing the circuit-switched core network connecting existing base stations with an IP-based backbone network for interfacing between the wireless system and the Internet. You create an interface between a GPRS network and an Internet Protocol (IP) network by using a gateway GPRS support node (GGSN). You can also use GGSNs to connect GPRS networks with legacy X.25 packet-switching networks.

GPRS might have a short implementation lifetime if the International Mobile Telecommunications-2000 (IMT-2000) initiative from the International Telecommunication Union (ITU) gathers steam, because IMT-2000 upgrades will support data throughput speeds of up to 2 Mbps—much greater than what GPRS can provide.

See also
Time Division Multiple Access (TDMA)

Gigabit Ethernet

A type of Ethernet that allows the transmission of data at 1 Gbps (or 1000 Mbps) over both fiber-optic cabling and copper twisted-pair cabling. Gigabit Ethernet competes with Fiber Distributed Data Interface (FDDI) and Asynchronous Transfer Mode (ATM) technologies as an alternative for high-speed network backbones. Gigabit Ethernet is defined in the IEEE 802.3z and 802.3ab specifications.

Graphic G-4. Gigabit Ethernet.
Graphic G-4. Gigabit Ethernet.
How It Works

Gigabit Ethernet supports a modified Carrier Sense Multiple Access with Collision Detection (CSMA/CD) media access method similar to those supported by previous versions of 10-Mbps Ethernet and 100-Mbps Fast Ethernet. Modifications to CSMA/CD for Gigabit Ethernet include extending the length of the carrier and slot times to pack out all frames to a minimum carrier length of 512 bytes. From the point of view of the MAC (media access control) interface, the minimum packet size still appears as 64 bytes. These modifications are performed to maintain a 200-meter-diameter topology for Gigabit Ethernet networks when a shared-media topology is used in half-duplex communications. The modifications can affect the performance of traffic involving smaller packets, but this is accommodated for by building a packet-bursting feature into Gigabit Ethernet that allows a station to take temporary control of the wire to send out a number of small packets. Note that these changes to CSMA/CD occur only during half-duplex communication. When using switched full-duplex connections, these changes do not apply.

Because CSMA/CD is used, Gigabit Ethernet can be viewed as a relatively easy upgrade path for network administrators familiar with 10BaseT and Fast Ethernet technologies. Gigabit Ethernet uses the same standard 802.3 framing structure of standard Ethernet, with frames between 64 and 1514 bytes in length. In standard half-duplex mode, Gigabit Ethernet supports speeds of 1 Gbps using CSMA/CD, but full-duplex versions support speeds of 2 Gbps for high-speed network backbones.

Gigabit Ethernet can be implemented in four different cabling or physical layer (PHY) options:

  • 1000BaseCX:
    Uses 150-ohm balanced twinax cabling or shielded twisted-pair (STP) cabling over a maximum distance of 25 meters. This version is used primarily for connecting switches and routers in wiring closets. It uses Fibre Channel–based 8B/10B coding at a serial line rate of 1.25 Gbps.

  • 1000BaseLX:
    Uses long wavelength transmissions over single-mode fiber-optic cabling. This version is used mainly for long cable runs of up to 5 kilometers.

  • 1000BaseSX:
    Uses short wavelength transmissions over multimode fiber-optic cabling. This version is used mainly for short cable runs of up to 300 meters (over 50-micron fiber) and up to 550 meters (over 62.5-micron fiber).

  • 1000BaseT:
    Uses twisted-pair category 5 cabling (four pairs of wires) over a maximum distance of 100 meters (maximum network diameter of 200 meters) and is intended mainly for connecting high-speed workstations to concentrators in nearby wiring closets.

Gigabit Ethernet networks can function as shared-media half-duplex networks using 1000-Mbps hubs, but they are usually implemented as switched full-duplex networks using 1000-Mbps Ethernet switches. Engineers currently envision two main uses for Gigabit Ethernet in corporate networking environments:

  • High-speed switch-switch connections for network backbones. Typically you might connect several 100/1000-Mbps switches to provide Fast Ethernet islands joined by Gigabit Ethernet backbones. An alternative would be to connect several 10/100 switches to one 100/1000 switch.

  • High-speed server-switch connections for server farms connected to server backbones. This configuration can provide users with 1-Gbps access to application or file servers.

Gigabit Ethernet might eventually be used for direct connections to high-speed user workstations, but at present this is a costly scenario to implement, and most applications can achieve sufficient bandwidth using only Fast Ethernet.

NOTE

Gigabit Ethernet is defined by the IEEE 802.3z specification. The Gigabit Ethernet Alliance is an open forum for promoting cooperation and standards in industry implementations of Gigabit Ethernet. Gigabit Ethernet standards were developed only recently and are now beginning to be widely implemented in high-speed networks.

TIP

Upgrading a Fast Ethernet backbone switch to a Gigabit Ethernet 100/1000-Mbps switch is straightforward and will enable you to connect high-speed server farms using Gigabit Ethernet network interface cards (NICs). Benefits include increased throughput and performance, more network segments, more bandwidth per segment, and a greater number of nodes per segment.

On the Web
•
Gigabit Ethernet Alliance
: http://www.gigabit-ethernet.org

G.Lite

A variation of Asymmetric Digital Subscriber Line (ADSL) that is targeted for home Internet access. G.Lite typically has a downstream rate of up to 1.5 Mbps and an upstream rate of up to 384 Kbps, depending on the implementation. G.Lite is also called DSL Lite or Universal ADSL. The International Telecommunication Union (ITU) has endorsed the term “G.Lite” as a standard.

How It Works

G.Lite is sometimes referred to as “splitterless ADSL” because a voice-data splitter is not required at the customer premises to split the voice and data signals being carried over the line. This is different from normal ADSL, which uses a Plain Old Telephone Service (POTS) splitter at both the customer premises and the telco’s central office (CO) to separate the voice and DSL bands for transmission over the phone line to prevent them from causing interference with each other. Instead, the customer’s computer simply connects to a G.Lite ADSL modem and from the modem to the phone line. No rewiring of the customer premises is required, because G.Lite uses the installed local loop connection to the customer premises. Customers can make phone calls or send faxes while connected to the Internet over their G.Lite connection. G.Lite connections are “always on”; in other words, once you turn your computer on, the connection is active and you can send or receive e-mail without having to dial up a connection. Because of the elimination of the need to install splitters, G.Lite services should be less expensive for customers than ordinary ADSL services and should become widespread in the near future.

NOTE

The quality of an ADSL connection to your home can suffer if you have a large number of RJ-11 phone jacks installed. This is because each phone jack acts as a bridged tap that is run off the main phone line as a parallel connection. Signals traveling along your phone line can reflect off these jacks and affect the overall reliability of your ADSL connection.

Also, the farther your home is from the telco CO, the less bandwidth might be available for your ADSL connection.

Global Address List (GAL)

A list of all recipients in a Microsoft Exchange Server organization. The Exchange directory service maintains the Global Address List (GAL) in the Exchange directory database. The GAL typically contains

  • Mailboxes

  • Custom recipients

  • Distribution lists

The GAL can be accessed by

  • The Exchange Administrator program

  • Microsoft-based messaging clients using Messaging Application Programming Interface (MAPI), such as Microsoft Outlook

  • Lightweight Directory Access Protocol (LDAP) clients using TCP/IP, such as Microsoft Outlook Express

  • Hypertext Transfer Protocol (HTTP) clients such as Web browsers using Outlook Web Access

NOTE

Public folders are the only form of Exchange recipient not contained within the GAL.

global.asa

A file used in Active Server Pages (ASP) applications running on Microsoft Internet Information Server or Internet Information Services that contains information global to all pages in the application. Global.asa does not generate content visible to the client Web browser—any Hypertext Markup Language (HTML) in the global.asa file is ignored by the server. The global.asa file can contain object declarations using <OBJECT> tags, type library declarations for COM components that your application uses, and application and session events. You can have only one global.asa file per ASP application.

TIP

If your global.asa file generates an error, you should ensure that any object declarations within the file have application-level or session-level scope, that any script in the file is enclosed within <SCRIPT> tags, and that any <OBJECT> tags are placed outside of <SCRIPT> tags.

global catalog

A Microsoft Windows 2000 service and store that contains a partial replica of Active Directory information from all domains in your enterprise forest. The global catalog enables users to easily locate objects in any domain with maximum speed and minimum network traffic. In effect, the global catalog acts as a kind of index for looking up objects stored in Active Directory anywhere on your network. You can search the global catalog for Active Directory objects by using the Find dialog box in Active Directory Users and Computers.

How It Works

The global catalog resides on a selected group of the domain controllers in your Windows 2000 enterprise called global catalog servers. The administrative tool Active Directory Sites and Services is used to specify which domain controllers will host the global catalog—that is, which will be configured as global catalog servers. The global catalog is automatically created the first time you run the Active Directory Installation Wizard, and it is installed on the first domain controller in your root domain by default. The directory replication process controlled by Active Directory creates and maintains the contents of each global catalog server.

Every directory object in the entire enterprise is represented in the global catalog, but only a subset of the properties of each object is stored in the catalog. The properties represented are those most likely to be used as search attributes, such as the user’s first or last name. However, administrators can specify storing additional object attributes in the catalog if desired. Having the global catalog store only a subset of an object’s attributes in Active Directory improves the response time for performing search queries on Active Directory.

NOTE

You can modify which attributes are represented for objects in the global catalog by editing the schema of Active Directory, but you must do so with care. The global catalog also includes the access permissions for directory objects, so if you search for an object and it doesn’t show up, you probably do not have permission to access the object.

TIP

In a geographically distributed enterprise, each physical site should have at least one domain controller to speed network traffic. Most Active Directory–related traffic is the result of queries on Active Directory, so the domain controller for small sites should also be configured as a global catalog server. This will reduce traffic over WAN links to other sites by allowing the global catalog server to locally resolve queries for information on directory objects from other domains.

See also
global catalog server

global catalog server

A Microsoft Windows 2000 domain controller that stores a copy of the global catalog. Administrators and users can utilize global catalog servers on a Windows 2000–based network to locate objects that are stored in Active Directory. Information stored on global catalog servers is updated each time Active Directory undergoes directory replication.

TIP

You must locate your global catalog servers appropriately so that queries on Active Directory perform effectively. Ideally, you should have at least one global catalog server at each site within the enterprise. However, in a multidomain environment, the replication traffic generated by maintaining these servers can be a burden on overall network traffic, especially if slow WAN links are involved. Consider placing your global catalog servers as follows:

  • Place several global catalog servers in each major site where large numbers of users and resources can be found.

  • Place a global catalog server at each small site where there are significant numbers of users and resources or where the wide area network (WAN) connection to major sites is slow.

See also
global catalog

global group

A group that exists only in the Security Accounts Manager (SAM) database on a Microsoft Windows NT–based network. Global groups are created on domain controllers and are used within an enterprise-level Windows NT network to organize users by function (for example, Accountants global group), location (for example, Third-Floor global group), or some other criteria, to simplify account administration. Global groups contrast local groups, whose primary function is to provide users with permissions for accessing network resources and rights for performing system tasks. Note that global groups can contain only global user accounts from their own domain. They cannot contain global user accounts from other domains, and they cannot contain other groups.

NOTE

Global groups are a little different in Windows 2000. Global groups can contain only members from the domain in which they are created, and they can be granted permissions on resources in any domain in the current forest. Users from one forest cannot be members of groups from another forest, and groups from one forest cannot be granted permissions on resources in another forest.

If the Windows 2000 domain is in native mode, global groups can contain both user accounts and global groups from the same domain; however, in mixed mode, global groups can contain only user accounts.

See also
AGLP, built-in global group, built-in group, group, local group

global load balancer

A hardware-based or software-based solution that can direct requests for Web content to multiple geographical locations where the content is stored. For example, if an electronic business has several data centers around the world, it can use global load balancers to direct Web customers’ traffic to centers that can provide the fastest response time for each customer’s location. If a data center goes down as a result of a power outage or some other condition, traffic to that site can be transparently redirected to other sites. The overall effect of implementing global load balancers in an e-business enterprise is an increase in reliability and performance from the customer’s point of view.

How It Works

Global load balancers essentially act as intelligent Domain Name System (DNS) name servers, performing name lookups for Uniform Resource Locators (URLs) and directing requests to the most appropriate IP addresses. The following five criteria are typically used to determine which address to forward a request to. (Not all global load balancers support all five criteria.)

  • Proximity of the site to the client, usually measured in router hops and established by using the Border Gateway Protocol (BGP), Internet Control Message Protocol (ICMP), or User Datagram Protocol (UDP)

  • Latency (the overall response time of the site), which is usually determined by pinging the site and calculating the delay

  • Server load (how busy the site is and how much capacity the server has for responding to clients)

  • Server health (whether the site is up and what its CPU and connection load are)

  • Packet loss (the average quality of the Transmission Control Protocol connection to the site), which is established by using ping

Of course, the DNS standard itself has built-in load balancing in the form of round-robin DNS. If multiple IP addresses are mapped to the same domain name, clients requesting the domain are directed to each IP address in a round-robin fashion. However, this rudimentary load-balancing scheme does not take into account such factors as which IP address belongs to the nearest host, the relative capability of the hosts to respond to requests, the availability of hosts, and so on. This is where global load balancers come in—they take over the role of authoritative name server for a company’s domain.

Global load balancers come in three varieties:

  • Layer 4 switches or routers with built-in support for global load balancing. Many Layer 4 switches and routers support some form of local load balancing, and software upgrades might be available that add such support. These switches tend to perform faster than appliances or software because they use hardware for packet forwarding and use software for routing purposes only. However, they also tend to be the most expensive solution.

  • Network appliances, which are essentially self-contained, stripped-down servers running global load-balancing software on top of operating systems optimized for this particular function.

  • Software that can run on standard servers running Microsoft Windows 2000, Windows NT, or UNIX that enables the servers to function as global load balancers. If you use this solution, be sure that your server is dedicated to running this software and does not run any other applications.

Global load balancers talk only to the local DNS server configured for the client, not to the client itself. This works well, except when mobile users travel to other cities and use their laptops to try to access the site. In this situation, if the client is still using a preconfigured DNS server at the home location, the global load balancer thinks that the client is still there as well. Also, once a DNS-based global load balancer has directed a client to the appropriate site or server, it is no longer involved in the client’s session and cannot tell whether the server goes down or whether some problem occurs with the connection.

For this reason, some global load balancers also use Hypertext Transfer Protocol (HTTP) redirects to masquerade as the target site and redirect HTTP requests to different servers. The client actually talks to the load balancer itself, and performance is faster than using DNS because fewer Transmission Control Protocol (TCP) connections are required. If the client’s connection to the server is interrupted, the global load balancer can redirect the client to a different server with minimal interruption. The downside of using HTTP redirects is that they work only with HTTP and not with other Internet protocols, such as File Transfer Protocol (FTP) or Network News Transfer Protocol (NNTP), or with streaming multimedia. This can be a limitation if your e-business delivers this type of content to the customer.

Other mechanisms can be used to perform global load balancing, including cookie-based and proprietary schemes. Windows NT 4, Enterprise Edition, provides a load-balancing service called Windows NT Load Balancing Service (WLBS). This IP load-balancing service employs a fully distributed clustering design that is ideal for creating highly available and scalable IP-based services such as Web, virtual private networking (VPN), streaming media, and proxy services.

globally unique identifier (GUID)

A 128-bit value based on time and space that can be used to uniquely identify an item. Globally unique identifiers (GUIDs) are used in the Component Object Model (COM) to uniquely identify classes and interfaces so that naming conflicts will not occur. A GUID is virtually guaranteed to be unique across all systems at any time. You can generate GUIDs using the console-based uuidgen utility or using the Microsoft Windows–based guidgen utility in Microsoft Visual C++.

In Windows 2000, each object, object class, or object attribute in Active Directory is assigned a unique GUID when it is created. The GUID of an entity in Active Directory never changes, even if the entity itself is renamed or moved to another location. The GUID acts as a kind of permanent name for the entity within the directory to ensure that it can be positively identified when needed.

TIP

Microsoft BackOffice products such as Microsoft Exchange Server and Microsoft SQL Server also use GUIDs to uniquely tag objects. For example, the information store in Exchange Server has a base GUID that is used to generate individual GUIDs for all messages, attachments, and folder contents kept in the store. If you restore the information store from a backup, you need to run the command isinteg -patch before restarting the information store to change the base GUID. Running this patch ensures that new objects created in the information store do not accidentally end up with GUIDs that are identical to those of objects already existing in the information store. This could cause inconsistencies in the information store database.

Global System for Mobile Communications (GSM)

A digital cellular phone technology popular in Europe, Asia, and other parts of the world. Global System for Mobile Communications (GSM) supports voice, data, Group 3 fax, and paging services for both vehicle-mounted and handheld mobile use. In addition, its speech quality equals that of the analog Advanced Mobile Phone Service (AMPS) and can interface with packet-switched networks.

How It Works

The GSM Phase 1 implementation uses a combination of Frequency Division Multiple Access (FDMA) and Time Division Multiple Access (TDMA) media access control methods to provide full-duplex communication over two frequency bands within the 862-to-960-MHz World Association of Radio Communications (WARC) portion of the electromagnetic spectrum. These two frequency bands are

  • The 890-to-915-MHz band for mobile-to-base (uplink) communication

  • The 935-to-960-MHz band for base-to-mobile (downlink) communication

Carrier signals are spaced 200 kHz apart within these bands to provide 124 pairs of superchannels based on frequency-division multiplexing (FDM), each of which is then subdivided into eight traffic channels using time-division multiplexing (TDM). Each channel carries voice communication at 13 Kbps (or 9.6 Kbps for data transmission). GSM thus provides 992 full-duplex channels for voice communication. Power classes for GSM mobile units range from 0.8 through 2.0 watts transmission power for handsets to 8 through 20 watts for vehicle-mounted units. Approximately half of a GSM transmission consists of overhead for signaling, such as synchronization and error handling. Such high overhead is typical in cellular phone systems, and is necessary—not so much because of external interference of buildings and other structures, but because of internal interference due to crosstalk between channels and across cell boundaries.

GSM is a secure system that uses key-based encryption for authentication and, optionally, for data transfer. The diagram shows the process that occurs when a mobile user wants to place a call. When the user dials a number, the mobile unit connects with the base station requesting authorization. The base station generates a random number and transmits it to the mobile unit, which then combines the random number with the owner’s secret key stored in the phone’s standard Subscriber Identity Module (SIM) card by using a ciphering algorithm called A3. The result of this process is transmitted to the base station. Meanwhile, the base station, which has the private keys for all its subscribers stored in a database, follows the same steps, using the A3 algorithm to combine the generated random number with the caller’s private key. The result is compared with the result transmitted by the user. If the two results agree, the user is logged on to the system.

Graphic G-5. The authentication process for GSM.
Graphic G-5. The authentication process for GSM.

GSM Phase 1 supports call forwarding, global roaming, call barring, and other features. GSM Phase 2 adds additional features such as the following:

  • Short message service for sending and receiving short text messages using phones

  • Call holding, call waiting, and caller ID

  • Multiparty calling supporting up to five parties per call

  • Mobile fax and data services

GSM Phase 2+ (just being implemented at the time of this writing) includes support for data transmission at 64 Kbps and higher, packet radio, virtual private networks, enhancements to the SIM card, higher spectral efficiency, integration with satellite links, and even GSM services in the local loop.

NOTE

GSM has a counterpart service called Digital Communication Service (DCS) that works in essentially the same way as GSM, except at a higher 1.8-GHz frequency band. DCS provides a total of 2992 channels for voice communication. One advantage DCS has over GSM is that it uses much lower power levels for mobile units, ranging from 0.25 to 1.0 watts transmission power.

The SIM card is a small device about the size of a stamp that is issued when a user subscribes to the GSM service. It contains the user’s phone number, private key, billing information, and other information. When users visit a locale at which the GSM system is different, they can simply remove the SIM card from their phone and install it in a rented phone that can function in that locale.

Encryption of messages is similar to the encrypted authentication process, except that each transmitted frame is encrypted using a different random number. This makes encrypted GSM messages extremely difficult to crack, so much so that some countries prohibit GSM providers from encrypting user messages!

See also
Advanced Mobile Phone Service (AMPS), Code Division Multiple Access (CDMA), Time Division Multiple Access (TDMA)

global user account

A type of user account in Microsoft Windows NT that has a domain-wide scope. (These accounts are called domain user accounts in Windows 2000.) In Windows NT, global user accounts are created using User Manager for Domains and are stored in the directory database on Windows NT domain controllers. In Windows 2000, domain user accounts are managed through the Active Directory Users and Computers snap-in. Global accounts allow users to take full advantage of the Windows NT Directory Services (NTDS). Users who have global accounts can access resources anywhere in the domain, provided they have appropriate permissions for those resources.

NOTE

User Manager for Domains creates global accounts by default. The other type of user account in Windows, the local user account, exists only within the directory database of the machine on which it is created. Use only global accounts for users when implementing Windows NT domains as your security model.

See also
local user account

Gopher

An Internet protocol used for distributed storage of documents.

How It Works

Gopher is similar to another Internet protocol, File Transfer Protocol (FTP), because it remotely accesses files over a TCP/IP internetwork such as the Internet. But while an FTP site exists on only one server and there can be many different FTP sites, there is really only one distributed Gopher file system. The Gopher file system is a single collection of all Gopher servers in the world (although private Gopher subnetworks also exist).

Graphic G-6. Gopher.
Graphic G-6. Gopher.

Each Gopher server can act as the root of the hierarchical distributed file system. To access a file or document, a person using a Gopher client (a standard Web browser such as Microsoft Internet Explorer will do) types the Uniform Resource Locator (URL) of an accessible Gopher server. For example, gopher://gopher.tc.umn.edu takes the user to a Gopher server for the University of Minnesota (where Gopher originated). The Gopher file system is presented as a series of folders, each of which can contain

  • More folders

  • Individual documents

  • Links to other Gopher servers (displayed as folders)

Users then work their way down the “gopher hole” (to use the metaphor) until they locate the document they want, and then they display or download it. They can also use a search tool developed at the University of Nevada called Veronica (Very Easy Rodent-Oriented Netwide Index to Computerized Archives) to perform keyword searches to locate documents on the worldwide Gopher network.

NOTE

Gopher was popular in the late 1980s as a mechanism for storing and disseminating information, especially for libraries and universities, but it has fallen out of favor because of the rising popularity of the World Wide Web (WWW). Not many Gopher servers still work, and most of them are not regularly updated with new information.

GPRS

See
General Packet Radio Service (GPRS)

grep

Stands for global regular expression print, a command in the UNIX operating system. Grep lets you search a file or multiple files for a specific pattern or string of characters and, if desired, replace it with a different string. The output of grep is a display of each line of the file that contains the desired character string. You can use wildcards and other meta-characters to perform complex search and replace operations with grep. Grep is useful for searching for specific entries in text files such as log files, UNIX system error logs, or C program code files.

Example

Typing grep 'a[b-f]' log.txt searches the text file called log.txt for any lines that contain the character a immediately followed by b , c , d , e , or f.

NOTE

Shareware versions of the grep utility are available from third-party vendors for Microsoft Windows platforms. Grep can also be combined with other UNIX commands in scripts that can perform more complex search functions. For example, you can pipe the output of a verbose command into grep to display a more selective form of output.

ground loop

A condition created when two or more parts of a network are grounded at separate points, causing a voltage difference between connected networking components. These voltage differences typically occur because of nonuniformities in the electrical characteristics of the grounding at different locations.

How It Works

For example, consider two computers that are located some distance apart and are connected by coaxial cabling. Each device is also connected to the earth by the ground wire of its AC power cable, but the two devices are plugged into different power outlets. These power outlets are connected to different parts of your building’s electrical distribution system, and these different parts are under different loads (have different currents being drawn from them by different configurations of devices). Thus they provide slightly different voltages. You might also find slight differences in the ground potential at the two locations. These voltage differences can cause currents to be induced through the shielding of the network cabling, and these currents can be large because of the cable’s low resistance. Large pulses of current can occur when other devices on the power circuits are switched on or off abruptly. This situation can be potentially damaging to sensitive networking components and might cause them to reset or lock up.

Ground loops can be prevented by

  • Using nonconducting fiber-optic cabling instead of copper cabling, especially for longer cable runs

  • Utilizing opto isolators or isolation transformers to break electrical connections between networking components

TIP

Ground loops are especially problematic with serial connections such as RS-232 because cables using this interface have a second signal ground path between the devices. Ground loops can also be a problem with shielded cabling such as shielded twisted-pair (STP) cabling or coaxial cabling. These loops will occur if the cable’s shielding is grounded by a direct connection to the chassis of the devices, because this provides a second ground path between the devices in addition to that produced by the ground portion of the AC power connection. The resulting current loops can build up until they are potentially damaging to the connected equipment. To prevent such damage, the shielding in a shielded cable should be grounded only at one end of its connection. Finally, when grounding a metal rack or cabinet that houses networking equipment, you should ground it using the same AC power cable ground connection that you used for the equipment itself. Note that ground loops are not a significant problem with unshielded twisted-pair (UTP) cabling because the wiring is transformer-isolated in the hub and network interface card (NIC) connections.

group

A collection of user accounts. Groups simplify the task of network administration by allowing administrators to group similar user accounts together in order to grant them the same rights and permissions.

The scope of a group is the portion of the network where the group can be granted rights and permissions. For example, a group whose scope is global can be granted permissions to resources in its own domain and to resources in trusting domains. On the other hand, a group whose scope is local can be granted permissions to resources only on the machine where it was created.

On Microsoft Windows NT–based networks, groups are created using User Manager for Domains. Windows NT groups have two levels of scope:

  • Global groups:
    A global group can be granted permissions to resources in its own domain and to resources in trusting domains. A global group can contain user accounts only from its own domain. Global groups are created on Windows NT domain controllers and exist in the domain directory database.

  • Local groups:
    A local group created with Windows NT Workstation can be granted permissions only to resources on the machine where it was created. A local group created with Windows NT Server (on a domain controller) can be granted permissions only to resources on the domain controllers of its own domain. A local group can contain user accounts and global groups both from its own domain and from trusted domains. Network administrators of enterprise-level Windows NT networks can use a resource-access strategy called AGLP (Accounts are organized by placing them in Global groups, which are then placed in Local groups that have appropriate Permissions and rights assigned to them) to plan and implement local groups in their network.

The situation in Windows 2000 is a little different. First, you create Windows 2000 groups using Active Directory Users and Computers. Groups are stored as group objects within Active Directory. Also, there are two types of groups in Windows 2000–based networks:

  • Security groups:
    Can contain members and can be granted permissions in order to control user access to network resources. Windows 2000 security groups are similar in function to the Windows NT groups just described. However, in Windows 2000, these groups have three different levels of scope, rather than two. Also, security groups in Windows 2000 can contain users, other groups, and even computers.

  • Distribution groups:
    Used for nonsecurity functions such as grouping users together to send e-mail. Unlike security groups, these groups cannot be used to control user access to network resources.

These two types of groups are stored in Active Directory. There are three levels of scope for security groups in Windows 2000–based networks:

  • Universal groups:
    Can contain members from any domain and can be granted permissions to resources in any domain in the current domain forest. Universal groups can contain user accounts, global groups, and universal groups from any domain in the current forest. Note that you can create universal groups only when the domain is in native mode, and not in mixed mode.

  • Global groups:
    Can contain members only from their own domain, but can be granted permissions to resources in any trusting domain. When the domain is in native mode, global groups can contain user accounts and global groups from the same domain. When the domain is in mixed mode, these groups can contain only user accounts.

  • Domain local groups:
    Can contain members from any domain, but can be granted permissions only to resources in their own domain. However, unlike the local groups of Windows NT, a domain local group can be granted permissions to resources on all servers (both the domain controllers and member servers) in its domain. When the domain is in mixed mode, domain local groups can contain user accounts and global groups from any domain in the forest. When the domain is in native mode, they can also contain domain local groups from their own domain and universal groups from any domain in the forest.

NOTE

Users can belong to multiple groups at the same time. A group does not actually contain its member user accounts; it is merely a list of user accounts. Nesting of groups (adding groups to other groups) is allowed, with certain restrictions. For example, in Windows NT a local group can contain global groups (but not other local groups) as members, while a global group can contain only users as members, not other global or local groups.

Graphic G-7. Nesting of groups in Windows NT and in Windows 2000.
Graphic G-7. Nesting of groups in Windows NT and in Windows 2000.

With Windows 2000, the nesting of groups is more complicated, as shown in the diagram. Furthermore, you can nest groups inside groups to any level, although nesting to one level is the recommended practice for effective administration.

Note that on Windows 2000–based networks, universal groups are available only when your domain controllers are running in native mode, not when they are running in mixed mode. Also, repeated nesting of groups is allowed only in native mode.

On member servers and computers running Windows 2000 Professional, you can also create a fourth type of group called a local group, one that exists only within the local security database of the machine on which it is created. Local groups in Windows 2000 are similar to local groups in Windows NT. They can contain user accounts that are local to the machine, and user accounts and global groups from their own domain. A local group can be granted permissions only to resources on the machine where it was created. You use Local Users and Groups, a snap-in for Microsoft Management Console (MMC), to create local groups on a machine.

TIP

On high-speed Windows 2000 networks, using only universal groups simplifies network administration. But if you have slower WAN links within your enterprise, using global and domain local groups can reduce the size of the global catalog at each site and significantly reduce the wide area network (WAN) traffic required to keep the global catalog current. Using global and domain local groups further reduces WAN traffic by reducing the size of users’ security tokens.

If your Windows 2000 network has only a single domain, use global groups and domain local groups for granting permissions to network resources. Create global groups according to function, add users to the global groups, create domain local groups according to groups of common resources, assign permissions to the domain local groups, and finally, place the global groups in the appropriate domain local groups. If you have a domain tree, use global and universal groups instead in a similar administrative approach.

In Windows 2000, you can change the scope of a group if desired. For example,

  • Global groups that are not members of other global groups can be converted to universal groups.

  • Domain local groups that do not contain other domain local groups can be converted to universal groups. Do this if you want to enable users in other domains to access resources that have been made accessible to the domain local group under consideration.

group account

See
group

group policy

A group of settings that are applied to a subset of Active Directory objects in Microsoft Windows 2000. Group policies are created and assigned using Group Policy, a snap-in for the Microsoft Management Console (MMC). Group policies are typically used to simultaneously configure the desktop working environments of a group of users, but they have many other uses as well. Group policies can be used to

  • Manage applications—for example, by configuring policies to allow users to install applications published in Active Directory, or to automatically install or upgrade applications on their machines

  • Redirect folders from the Documents and Settings folder on a user’s local machine to a share on the network

  • Assign scripts for startup, shutdown, logon, and logoff events

  • Manage security—for example, to control users’ access to files and folders, control user logon rights, and configure account lockout restrictions

  • Manage software—for example, to configure user profiles such as desktop settings, Start menu, and other common settings

Group policies can be assigned to domains, sites, or organizational units (OUs). To create and configure a group policy, use Group Policy to create a new Group Policy object (GPO). Group policies are applied to users when they log on and to computers when they boot up. If two policies apply to a user or computer, and they do not conflict, they are applied in a cumulative fashion. Users are subject to group policies that apply to them as users and to group policies that apply to the computer at which they are working.

NOTE

Every Windows 2000 domain has a default group policy that applies to all users and computers in the domain. Computers that are moved to a different domain lose the GPO of their original domain and have the GPO of their new domain applied to them. The default GPO for a domain is the only GPO on which you can configure password restrictions, lockout restrictions, Kerberos, the Encrypting File System (EFS), and Internet Protocol (IP) security settings.

NOTE

Group policies set for machines running Windows 2000 do not apply to downlevel Windows NT, Windows 95, or Windows 98 clients.

TIP

A typical use for group policies is to enforce a written company policy across all users in a specific site or domain.

Group Policy

An administrative tool in Microsoft Windows 2000 that is used for configuring group policies; that is, user and computer settings for groups of users and computers. Group Policy is the successor to the Windows NT administrative tool called System Policy Editor.

How It Works

System Policy Editor for Windows NT stores system policy information in an ntconfig.pol file that modifies a portion of the Windows NT registry. Group Policy stores its settings in an Active Directory object called a Group Policy object (GPO) that contains the collection of settings for a group of users or computers created using Group Policy. A GPO is normally associated with a selected site, domain, or organizational unit (OU) object in Active Directory. Group policy information is also stored in a folder structure called the Group Policy Template on the SYSVOL volume on domain controllers. Group policies can also be configured for computers that are not domain members. Group Policy can be used to specify the following:

  • Scripts that should be run at startup, shutdown, logon, or logoff

  • Files to be placed on users’ computers

  • Software registry settings to customize users’ desktops, configure applications, and control services (similar to System Policy Editor)

  • Audit policies for auditing account logons, account management, directory service access, object access, and other functions

In addition, by using the Security Settings extension, you can configure users’ security settings, and by using the Software Installation extension, you can publish, update, or repair applications on user’s computers.

To configure a group policy for a specific site in Active Directory, open the administrative tool called Active Directory Sites and Services, select the specific site you want to configure, click the Action button on the toolbar, choose Properties from the drop-down menu, and select the Group Policy tab. Alternatively, you can install the Group Policy snap-in in a new Microsoft Management Console (MMC) (see screen capture).

NOTE

To configure a group policy for a directory object in Active Directory, you need access to a domain controller, read and write permissions on SYSVOL, and modify permissions on the selected directory object.

Group Policy for Windows 2000 cannot be used to configure group policies for downlevel Windows NT, Windows 95, or Windows 98 clients. Use System Policy Editor instead.

Graphic G-8. Group Policy.
Graphic G-8. Group Policy.

GSM

See
Global System for Mobile Communications (GSM)

GSNW

See
Gateway Service for NetWare (GSNW)

Guest account

In Microsoft Windows NT, a built-in account with a null password created during installation. The Guest user account is a member of the Domain Guests global group on the domain controller or member server on which it is defined.

The Guest account is intended for occasional users who need temporary access to resources on the network. It is disabled by default and can be enabled using User Manager for Domains. The Guest account is also created by default on machines running Windows 2000 during installation.

NOTE

On a Windows NT domain controller, the Guest account is a global user account; a member server or Windows NT workstation has a separate Guest local user account. To control guest access to your network, you can assign these Guest accounts one, both, or neither of the following rights:

  • Access this computer from the network.

  • Log on locally.

TIP

Do not enable the Guest account unless you are sure you will need it; unless you are sure that all your shared resources have correct permissions assigned to them, enabling the Guest account could pose a security risk.

See also
Guests group

Guests group

A Microsoft Windows NT built-in group existing on all Windows NT–based servers and workstations. The Guests group is a local group whose initial membership is the built-in Guest user account. If a member server or workstation joins a domain, the global group called Domain Guests is added to the local Guests group.

The Guests group has no preassigned rights or permissions on Windows NT domain controllers and has a single right, Log On Locally, on the Windows NT member server or workstation on which it exists. You can assign any network resource permissions to this group in order to grant temporary or guest users the access they require.

NOTE

Members of the Guests group do not have the right to make permanent changes to their desktop settings. The Guests group is also a built-in local group on machines running Windows 2000 that are not part of a domain.

See also
built-in group

GUID

See
globally unique identifier (GUID)


H

H.323

A recent standard for audio and video conferencing established by the International Telecommunication Union (ITU). H.323 is a comprehensive standard for multimedia communication among computers, terminals, network devices, and network services running on connectionless networks that do not support intrinsic quality of service (QoS) functions, such as Internet Protocol–based networks and the Internet. This standard is widely accepted by manufacturers of Voice over IP (VoIP) and Internet phone software and devices. Any hardware or software system that supports the H.323 standard can communicate with any other H.323 system. H.323 is designed to make multimedia communication over the Internet as standardized as telephone communication. For example, with telephone communication you can purchase telephone equipment from any vendor and plug it into your phone system, and the equipment works. The idea is to make Internet communication appliances just as easy to use.

How It Works

H.323 defines a protocol stack that performs functions related to establishing and maintaining real-time multimedia communication that involve transmission of audio, video, and data. H.323 does not represent one standard, but rather an umbrella of other ITU standards. The H.323 protocol stack includes more than two dozen G-level, H-level, and T-level protocols from the ITU. H.323 is designed to run over Internet Protocol (IP) and includes specifications for the following components:

  • H.323 Conference Manager, which manages the establishment of multimedia conferencing connections

  • The H.245 protocol, which controls communication with data terminal equipment (DTE)

  • The H.225 protocol, which performs synchronization and framing mechanisms for multimedia data streams

  • The T.120 protocol, which provides support for real-time, multipoint data communication

H.323 also specifies standard codecs for audio (G.723) and for video (H.263) that enable H.323 products to send and receive voice and video images. Specifically, H.323 defines standards for data codecs for audio transmission rates of 14.4 Kbps or faster and video transmission rates of 28.8 Kbps or faster. H.323 recognizes the T.120 protocol for data conferencing and provides a set of standards-based conferencing features for audio and video conferencing.

H.323 gateway

A service that allows you to connect an H.323-based communication system on the Internet to a telephony system. You can use H.323 gateways to connect corporate networks to telephony systems for supporting integrated audio and video conferencing. For example, you can use an H.323 gateway to place a Microsoft NetMeeting call to someone’s telephone. The Uniform Resource Locator (URL) format for doing so is “callto:<address>”, in which <address> is the fully qualified domain name (FQDN), IP address, or e-mail address of the person you are calling. You can use this URL as a link on a Web page or enter it directly in the address box of your Web browser.

Graphic H-1. H.323 gateway.
Graphic H-1. H.323 gateway.

NetMeeting does not include any H.323 gateway software, but it will support third-party gateways when they become available.

hacking

Any attempt to compromise a network’s security. Hackers are generally curious programmers who enjoy getting into the nuts and bolts of how computer systems (usually UNIX and Microsoft Windows NT) and networks (usually TCP/IP) work. Hackers usually guard their identity carefully and use purely technological means to try to break into a system.

Hackers generally find sufficient satisfaction with the mere act of defeating a network’s security system, and they pride themselves on not damaging or taking advantage of the data stored in the systems they hack. This unwritten “hacker’s code” distinguishes hacking from cracking, which is the attempt to steal revenue from software publishers by removing software protection functions such as expiration dates and installation codes, and from phreaking, a more destructive activity that usually involves both technological hacking and some form of deception through personal contact with the target organization with the aim to defraud.

NOTE

The term “hack” is also used to refer to any temporary or inelegant solution to a networking problem, as in, “I hooked in the old hub as a repeater just as a temporary solution—I know it’s a hack, but it should do fine until we can buy something better.”

On the Web
•
Microsoft Security home page
: http://www.microsoft.com/security

HAL

See
hardware abstraction layer (HAL)

half-duplex

A mode of communication in which data can be transmitted or received, but cannot be transmitted and received simultaneously. The simplest example is a walkie-talkie: You have to press a button to talk and release the button to listen. When two people use walkie-talkies to communicate, at any given moment, only one of them can talk while the other listens. If both try to talk simultaneously, a collision occurs and neither hears what the other says.

Communication through traditional Ethernet networks is another example of half-duplex communication. When one station on an Ethernet transmits, the other stations detect the carrier signal and listen instead of transmitting. If two stations transmit signals simultaneously, a collision occurs and both stations stop transmitting and wait random intervals of time before retransmitting.

In contrast, full-duplex communication enables stations to transmit and receive signals simultaneously, with the advantage of providing twice the bandwidth of equivalent half-duplex technologies. However, full-duplex requires two communication channels to achieve these results—one to transmit and one to receive signals.

A third mode of communication is called simplex, which involves transmission in one direction only, with one station transmitting signals and the other receiving them.

See also
full-duplex, simplex

HAN

See
home area network (HAN)

Handheld Device Markup Language (HDML)

A markup language loosely modeled on Hypertext Markup Language (HTML) that is optimized for wireless Internet access by handheld information appliances such as Personal Digital Assistants (PDAs), pagers, and cellular phones. These devices have limited size displays and require that hypertext information be formatted accordingly. Handheld Device Markup Language (HDML) is currently used by wireless carriers such as AT&T, Ameritech, and Bell Atlantic. Its current version is HDML 2.0.

How It Works

HDML is for devices with displays of 4 lines by 20 characters or smaller. It is not intended as a means of delivering standard Web content to these devices—a standard HTML page simply could not be reformatted to fit on such a device. Instead, HDML provides a new way to deliver information to handheld wireless devices by using wireless Internet Protocol (IP) instead of traditional circuit-switched cellular communication systems. HDML is thus not a subset or scaled-down version of HTML but a new markup language specifically designed for these devices. Another reason not to use scaled-down HTML for these devices is that HTML requires a user interface that allows actions such as clicking links, which is not available for handheld devices.

HDML uses its own navigation model, which is based on the filing card metaphor. Cards are grouped into “activities,” which facilitate the development of HDML-based applications. The user can enter information and share it among cards using variables, and the user can parameterize cards so that a family of cards differing only in the value of a variable can be stored more efficiently in the limited-size cache of these devices. You can use variables to create forms for entering information in HDML applications. HDML currently does not support scripting, branching, or conditional statements.

HDML is likely to be used to deliver a broad range of time-sensitive information to handheld wireless devices, including appointments, weather information, stock quotes, white pages lookups, inventory lookups, and catalog-pricing lookups. Scripts can be developed to extract this kind of information from the databases in which it resides and format it into HDML cards, in much the same way that Perl can be used to write scripts to access database information stored on UNIX servers, or that Active Server Pages (ASP) can be used to build Web-based applications that connect to Structured Query Language (SQL) databases.

handshaking

The process that establishes communication between two networking devices. For example, when two computers first connect with each other through modems, the handshaking process determines which protocols, speeds, compression, and error-correction schemes will be used during the communication session. Handshaking is necessary at the start of each session because typically the modems differ in their vendor, model, or hardware/software configuration. The handshake ensures that communication is possible despite these differences.

The term “handshaking” arises from the analogy of two people meeting to conduct business. They first shake hands to greet each other, announcing their name, title, and intentions. They might also “size each other up” to determine the other person’s capacities and capabilities.

How It Works

During the handshaking process, both modems send the other a series of control signals and respond to each other’s signals. Handshaking is also referred to as “flow control” because the process establishes the ground rules for managing the flow of data between the two devices. Some of the parameters that the modems need to negotiate are

  • The maximum transmission speed, taking into consideration the speed of both modems and the quality of the transmission

  • The length of the line delay to apply echo cancellation

  • The communication protocol

Modern modems transmit the control signals in full-duplex mode over the RS-232 interface that connects them to the computers.

See also
flow control

hardware abstraction layer (HAL)

A thin layer of software at the base of the Microsoft Windows NT and Windows 2000 operating systems that offers a uniform interface between the underlying hardware and the higher layers of the operating system, hiding hardware differences from those higher layers. In other words, the hardware abstraction layer (HAL) hides hardware differences from the operating system so that uniform code can be used for all hardware. All hardware looks the same to the operating system because it “sees” the hardware through the filtered glasses of the HAL.

How It Works

The HAL is located at the base of the Executive Services, and it encapsulates most hardware-specific functions that are performed by the operating system. If another portion of the operating system wants to access a hardware device, it must refer its request to the HAL. The HAL handles communication between the kernel of the operating system and the hardware.

NOTE

The HAL is implemented in Windows as a file called hal.dll. If a hardware vendor needs to protect proprietary technology, the company can develop a custom implementation of the HAL. This means that different processor configurations might use different HAL drivers.

hardware address

See
MAC address

Hardware Compatibility List (HCL)

A list of hardware that is compatible with a Microsoft Windows operating system product. The list includes computer systems as well as individual hardware components such as video cards, motherboards, and sound cards.

When in doubt, you should consult the Hardware Compatibility List (HCL) before installing an operating system on a nonstandard or customized machine. Using components not included on the HCL can lead to installation failures or system instabilities. Microsoft has determined that drivers for hardware devices listed on the HCL are compatible with that version of Windows; Microsoft supports only these drivers.

If you use drivers for devices that are not on the HCL, you might not be entitled to Microsoft product support for your system configuration. If you must use non-HCL devices, contact the manufacturer of the device to see whether a supported driver exists for the particular Windows operating system you are using. If you contact Microsoft Product Support about a problem and the support engineer determines that a hardware device in your system is not on the HCL, you likely will incur a charge for the call even if the problem cannot be resolved.

TIP

You can usually find the HCL for a particular Windows operating system on its distribution CD. (The file might be called hcl.txt.) A more up-to-date version of the HCL for all Windows operating system platforms is available on the Web at the HCL site listed in the On the Web section of this entry.

On the Web
•
Microsoft Product Support Services
: http://www.microsoft.com/support
•
Microsoft HCL site
: http://www.microsoft.com/hwtest/hcl

hardware profile

Information about the configuration of devices and services that are used to boot an operating system into a certain configuration. A hardware profile tells the operating system which devices are present when the computer boots.

You can create several different hardware profiles on Microsoft Windows operating systems and select the one you want to use at boot time. For example, if Windows 98 is installed on a laptop computer, you can create two hardware profiles for that computer:

  • A profile for when the computer is docked and connected to the network. (The profile will contain configuration information for the network adapter.)

  • A profile for when the computer is undocked and used in the field. (The profile will contain no configuration information about networking.)

When the laptop is booted, you select the appropriate hardware profile from a menu generated by the operating system.

TIP

Hardware profiles are usually not necessary for plug and play laptops running Windows 98. These computers can recognize when new hardware becomes available (for example, by docking) and automatically configure themselves.

hashing algorithm

A mathematical procedure that takes information contained in files and scrambles it to create a fixed-length string of numbers and characters called a hash. A good hashing algorithm has the following characteristic: if you apply a hashing algorithm to some data and then change only a few bits in the data and apply the algorithm again, the two resulting hashes will differ in almost every bit.

Hashing algorithms are used extensively in cryptography for encrypting keys or messages. Examples of popular cryptographic hashing algorithms include MD2, MD4, MD5, and SHA-1. Message Digest 5 (MD5) uses a 128-bit hash, and Secure Hash Algorithm (SHA) uses a 60-bit hash. The more bits in a hash, the greater the security of the encryption process.

Hashing is also used in some database technology for creating indexes of items in a database. Hashes of database objects are generally smaller than the objects themselves, so they can be indexed and searched more quickly. You can generate unique hashes of fixed length for each database record, creating a hash table that you can use for quick searches for records.

H channel

A designation for groups of channels on Basic Rate Interface ISDN (BRI-ISDN) services. H channel standards are defined by the International Telecommunication Union (ITU) and are composed of different combinations of Integrated Services Digital Network (ISDN) B channels. The most common configurations are as follows:

  • H0 channel, which consists of six B channels multiplexed to provide a data transmission speed of 384 Kbps. This service is sometimes called switched 384 or ISDN H0.

  • H11 channel, which consists of 24 B channels to provide 1536 Kbps of bandwidth. This is sometimes called ISDN H11 or switched 1536.

  • H12 channel, which consists of 30 B channels to provide 1920 Kbps of bandwidth. This is sometimes called ISDN H12 or switched 1920.

HCL

See
Hardware Compatibility List (HCL)

HDLC

See
High-level Data Link Control (HDLC)

HDML

See
Handheld Device Markup Language (HDML)

HDSL

See
High-bit-rate Digital Subscriber Line (HDSL)

header

The initial portion of a packet or a frame. The header contains control information such as addressing, routing, and protocol version. The format of this information depends on the protocol being used. For example, an Internet Protocol (IP) header contains information about the version of the IP protocol, the length of the header, the type of service used, the packet’s Time to Live (TTL), the source and destination address, and so on. Headers are used to control the flow of packets through the network or over the communication link.

The end of a frame sometimes has a smaller structure called a footer or trailer, but this usually contains only error-checking information. Control information is always placed in the header because this is the first portion of the packet or frame that is read by a networking device such as a switch or a router.

heartbeat

In Microsoft Cluster Server (MSCS) in Windows NT Server, Enterprise Edition, a message that the Cluster service running on one node regularly sends to the Cluster service on the other node to detect a failure. Nodes in a cluster communicate status information with each other using the Cluster service, a Microsoft Windows NT service on Cluster Server. These messages appear as network traffic between the two nodes in the cluster on the dedicated network connection between the nodes, which is called the private network of the cluster. If the heartbeat is lost over the private connection, Cluster Server reverts to a public network connection for its heartbeat and other Cluster service traffic. You can configure the polling interval for the heartbeat using Cluster Administrator.

Help

Any of several systems of online help for Microsoft products. The type of help features available depend on the nature of the product, the date of release, and the context in which it is invoked. Examples of help functions include the following:

  • Help Topics:
    Choose Help from the Start menu in Microsoft Windows NT, Windows 2000, Windows 98, or Windows 95 to open a Help Topics window with three tabs: Contents (to browse the help database using a hierarchical set of book icons), Index (to type the topic you want help on and then display the appropriate entry), and Find (named Search in Windows 98 and Windows 2000, to conduct a full-text keyword search of the help database). Windows 2000 includes a fourth tab, Favorites, that lets you save links to Help topics.

  • What’s This?:
    To find information about a setting in a dialog box or property sheet, right-click the item and choose What’s This? from the context menu, or click the question mark button at the top right of the dialog box.

  • F1 key:
    To get context-sensitive help at any point, press the F1 function key.

  • Browser-based help:
    New Microsoft products such as Windows NT Option Pack provide access to their help database through a standard browser application such as Microsoft Internet Explorer 4.

  • Books Online:
    Many Microsoft products have additional user manuals in an online format that you can access from the Start menu.

helper server

In Microsoft Systems Management Server (SMS), a server used to manage the load on the SMS site server. You move some of the SMS components—such as the Scheduler, Despooler, Inventory Processor, and Inventory Data Loader—from the site server to one or more helper servers. A helper server must be a Microsoft Windows NT Server as well as an SMS logon server for the site.

TIP

If your site server is heavily loaded, move the SMS components to a helper server. You can use Performance Monitor to determine which components should be moved from your site server.

heterogeneous network

A network that uses multiple network architectures and operating systems. An example of a heterogeneous network at the hardware level is a combination of Ethernet and Token Ring local area networks (LANs) connected with a Fiber Distributed Data Interface (FDDI) backbone. An example at the network operating system (NOS) level is a server room in which some machines are running Microsoft Windows NT, others are running UNIX, and still others are running Novell NetWare. An example at the application level is a messaging system that includes Microsoft Exchange Server, Novell GroupWise, UNIX Sendmail, and IBM PROFS mail systems.

Heterogeneous networks are generally more complex to administer than homogeneous networks. Most networks are heterogeneous because they evolve over a period of time. Most startup companies cannot afford to buy a completely homogeneous, state-of-the-art network platform, and even if they could, it would soon become out of date. One advantage of deliberately maintaining a heterogeneous network is that customers can use any product they choose instead of being locked into a single vendor’s system. Networking and operating system choices can be made on a “best-served” basis instead of an “only buy from us” approach.

See also
homogeneous network

hidden share

In Microsoft Windows operating systems, a share with a dollar sign ($) appended to the share name. Hidden shares are accessible on the network using Universal Naming Convention (UNC) paths or mapped network drives, but only if the user knows that they are present and knows their exact name. These shares do not show up in Network Neighborhood or Windows Explorer, or when you use the net view command; users are unaware of their presence unless they are specifically informed.

It is a good idea not to acquaint ordinary users with hidden shares, because they might create such shares on their workstations if appropriate file and print services are installed. This can lead to secret, uncontrolled publishing of information within the company, which is usually against company policy.

Windows NT and Windows 2000 also create certain hidden shares during the installation process that the operating system uses for specific purposes. These hidden shares are called administrative shares; permissions on them should not be modified.

High-bit-rate Digital Subscriber Line (HDSL)

A modulation technology similar to Asymmetric Digital Subscriber Line (ADSL) that uses a group of existing copper twisted-pair subscriber telephone lines to transmit data at T1 or E1 speeds. High-bit-rate Digital Subscriber Line (HDSL) was the earliest version of Digital Subscriber Line (DSL) to be widely implemented; it is often used as a low-cost alternative to dedicated T1 links for wide area networks (WANs) and for building-to-building communication in a campuswide network.

How It Works

HDSL was designed as an alternative to T-carrier services such as T1 lines. HDSL essentially operates in the same way as ADSL except that it is always symmetrical—that is, its upstream and downstream speeds are the same. This generally means that the maximum bandwidth for HDSL transmissions is less than for ADSL. HDSL comes in various formats, including the following:

  • 668-Kbps full-duplex transmission over a single unconditioned, unshielded copper twisted-pair phone line.

  • 1.544-Mbps full-duplex transmission (T1 speed) over unconditioned, unshielded twisted-pair cables. This is the most common configuration and is called Dual-Duplex HDSL. It uses twisted-pair phone lines with two pairs of wires (four wires) within the line, with full-duplex 784-Kbps transmission taking place over each pair of wires.

  • 2.048-Mbps full-duplex transmission (E1 speed) over three unconditioned twisted-pair lines.

HDSL can carry both voice and data over a single communication link. The maximum distance for HDSL transmission is generally 3700 meters when running over unconditioned copper twisted-pair wiring; some vendors claim that their devices support twice this distance. This maximum distance from the telco’s central office (CO) is sometimes called the Carrier Service Area (CSA). HDSL is typically used for connecting bridges, routers, and telephone equipment such as Private Branch Exchanges (PBXs) over a campus using HDSL line drivers with built-in CSU/DSU (Channel Service Unit/Data Service Unit) functionality. It can also be used for private data networks, connections between points of presence (POPs), and other services. It is not widely implemented at the customer premises level, which uses the more popular ADSL or G.Lite for providing customers with high-speed Internet access.

Graphic H-2. High-bit-rate Digital Subscriber Line (HDSL).
Graphic H-2. High-bit-rate Digital Subscriber Line (HDSL).
TIP

You can use HDSL to connect campus networks and phone equipment at T1 speeds without the need for costly fiber-optic cabling. HDSL line drivers or line terminals generally support a variety of data interfaces, including V.35, G.703, and 10BaseT connections. They are configurable for N x 64 Kbps transmission speeds and sometimes include bridge or router functionality for framing of High-level Data Link Control (HDLC), Point-to-Point Protocol (PPP), Internet Protocol (IP), and other protocols. They can be used for LAN-LAN connections and for connecting local area networks (LANs) to frame relay networks or the Internet.

HDSL is easier to maintain and provision than conventional T-carrier span designs because HDSL requires a repeater only at both ends of the line, not every 1800 meters (6000 feet), as required by conventional T1 lines.

See also
Asymmetric Digital Subscriber Line (ADSL), Digital Subscriber Line (DSL)

High-level Data Link Control (HDLC)

A standard synchronous communication protocol at the data-link layer (layer 2) of the Open Systems Interconnection (OSI) reference model that is used for wide area network (WAN) synchronous serial connections over leased lines. High-level Data Link Control (HDLC) was derived from Synchronous Data Link Control (SDLC) and was developed by the International Organization for Standardization (ISO) for point-to-point communication. It was later adapted by the International Telecommunication Union (ITU) for X.25 Link Access protocol.

How It Works

HDLC defines a method for encapsulating or formatting data into frames for synchronous transmission over synchronous serial WAN links to remote sites. HDLC is a bit-stream protocol (bit streams are not broken into individual characters) that uses a 32-bit checksum for error correction and supports full-duplex communication. HDLC frames consist of a flag byte followed by address and control information, data bits, and a CRC byte. A control field at the start of a frame is used for establishing and terminating data link connections.

An HDLC link consists of a primary station and a secondary station, with the primary station issuing the commands and the secondary station issuing the responses. Like another layer 2 WAN protocol called Point-to-Point Protocol (PPP), HDLC is used mainly for point-to-point communication, in contrast to other layer 2 WAN protocols such as Asynchronous Transfer Mode (ATM), frame relay, and X.25, which are used for both point-to-point and point-to-multipoint communication. Because HDLC is used mainly in point-to-point communication, it does not need to have addressing implemented at the data-link layer because the local and remote stations are connected directly. In this configuration, either one station is the primary and the other the secondary (unbalanced point-to-point link) or both stations function in a primary/secondary capacity (balanced point-to-point link). You can also use HDLC in a more complex configuration in which one primary links to several secondaries (unbalanced multipoint configuration).

HDLC is commonly used in leased-line connections in which the WAN link’s endpoints are terminated with CSU/DSUs (Channel Service Unit/Data Service Units) connected to Cisco routers running Internetwork Operating System (IOS). Routers and access servers from other vendors often use PPP instead of HDLC.

NOTE

HDLC was developed by the ISO as an offshoot of the SDLC protocol, which IBM developed in the 1970s as part of its Systems Network Architecture (SNA) mainframe computing environment.

Graphic H-3. High-level Data Link Control (HDLC).
Graphic H-3. High-level Data Link Control (HDLC).

High Performance File System (HPFS)

A disk file system designed for version 1.2 of the Microsoft/IBM OS/2 operating system as a successor to the file allocation table (FAT) file system used by MS-DOS. High Performance File System (HPFS) is supported by Microsoft Windows NT version 3.51 but not by Windows NT 4 or the Windows 2000 operating systems, which use the more advanced NTFS file system.

How It Works

HPFS was designed to function as an Installable File System (IFS), which is implemented as a dynamic-link library (DLL) that hooks into the file system component of the operating system kernel. You configure HPFS through an IFS= line in the config.sys file. The CD file system (CDFS) was also designed to support IFS. HPFS improves on the performance of the FAT file system for MS-DOS in the following ways:

  • It locates file directory and allocation information in close physical proximity to the files themselves on the hard disk. (The FAT file system locates the root directory and allocation information on the outermost cylinders of the drive.)

  • It has a more robust and efficient file system tree structure than FAT, so you can locate directories more quickly.

  • It has multiple asynchronous read/write threads.

  • It uses sector-based allocation instead of the more space-wasting, cluster-based allocation used by FAT.

  • It uses large file cache sizes and lazy-writes.

Other features of HPFS that were considered advanced at the time of its development included the following:

  • Long filenames—up to 254 characters in length. These long filenames are case preserving but not case sensitive. MS-DOS applications can still access HPFS volumes either over the network to an OS/2 LAN Manager server or from inside an MS-DOS compatibility box on an OS/2 workstation.

  • Extended attributes—a series of name/value pairs associated with each directory or file. These extended attributes can be 64 KB in size and support advanced kinds of search queries, such as by file type, version number, subject, or comments.

  • Support for extended character sets.

  • Maximum 64-GB drive size. (The practical limit is 16 GB, however.)

High Speed Circuit Switched Data (HSCSD)

An upgrade to the existing Time Division Multiple Access (TDMA) cellular phone system. High Speed Circuit Switched Data (HSCSD) provides subscribers with up to four separate 14.4-Kbps communication channels that can be bundled together to provide greater bandwidth for data transmission. However, the overhead that is required by this bundling results in bandwidth of only 28.8 Kbps instead of the theoretical 57.6 Kbps. Unlike General Packet Radio Service (GPRS), which requires that existing TDMA hardware be upgraded, HSCSD is a software-only upgrade.

Some operators of Global System for Mobile Communications (GSM) cellular networks have upgraded their systems to HSCSD. However, competition from GPRS, which will be ready for deployment in the year 2000, could slow the growth and adoption of HSCSD technologies and eventually overshadow them.

See also
Time Division Multiple Access (TDMA)

History

A folder in Microsoft Internet Explorer that contains shortcuts to Web pages that you have recently browsed. The History folder makes it simple to return to sites that you have recently visited but have not designated as favorites. By clicking the History button on the Internet Explorer toolbar, you can view the contents of the History folder and revisit any of the links. You can configure how many days items should be kept in the folder, and you can delete the files manually if desired. Using the offline browsing feature of Internet Explorer, you can browse the History folder while you are disconnected from the Internet.

hive

A physical file containing part of the registry in Microsoft Windows NT and Windows 2000. This is opposed to a subtree, which is a logical section of the registry. The term “hive” is loosely connected with the idea of the cellular structure of a beehive.

How It Works

Hives consist of a discrete collection of keys and subkeys that have a root at the top of the registry. Five of these hives are located in the folder %SystemRoot%\system32\config; the sixth hive (ntuser.dat), which contains user profile information, is stored on machines running Windows NT in the folder %SystemRoot%\Profiles\username. On machines running Windows 2000, it is stored in the folder

  • %SystemRoot%\Documents and Settings\username if this is a new Windows 2000 installation or an upgrade from Windows 95 or Windows 98

  • %SystemRoot%\Profiles\username if this is an upgrade from Windows NT to Windows 2000

Each hive has an associated transactional .log file that logs all modifications made to the registry and provides fault tolerance. Each hive file also has a .sav file, which is a backup copy of the hive file. The functions of the hives and the logical key they map to are indicated in the following table.

Windows NT Hives
Hive | Key | Function
Default | HKEY_USERS\.DEFAULT | Contains the default system profile used when the logon screen is displayed.
SAM | HKEY_LOCAL_MACHINE \SAM | Contains information for the Security Account Manager (SAM). This hive cannot be viewed with the registry editor and must be accessed using specific application programming interfaces (APIs).
Security | HKEY_LOCAL_MACHINE \SECURITY | Contains the computer’s security policy information. This hive also cannot be viewed with the registry editor and must be accessed using specific APIs.
Software | HKEY_LOCAL_MACHINE \SOFTWARE | Contains global configuration information for installed software.
System | HKEY_LOCAL_MACHINE \SYSTEM and HKEY_CURRENT_CONFIG | Contains configuration information for installed hardware devices and services.
Ntuser.dat | HKEY_CURRENT_USER | Contains user-specific configuration settings for the user who is currently logged on interactively.

H-node

A NetBIOS name resolution method used for name registration and resolution. H-node is one of the types of NetBIOS over TCP/IP nodes defined in Request for Comments (RFC) numbers 1001 and 1002, and is supported by computers running Microsoft Windows NT and Windows 2000.

How It Works

Name resolution is the process of converting the name of a host on the network into a network address, such as an IP address. Name resolution must be performed to establish communication over a network. H-node is one of four basic methods supported by Windows NT and Windows 2000 for resolving NetBIOS host names (that is, computer names) into IP addresses.

If a computer running Windows NT or Windows 2000 is configured as an H-node machine, it first tries to use a NetBIOS name server to resolve names of other hosts on the network; this is the way a P-node machine functions. A server running Windows NT or Windows 2000 with the Windows Internet Name Service (WINS) configured on it is the typical example of a NetBIOS name server. If name resolution fails this way (for example, if all WINS servers are down), an H-node machine tries to use broadcasts to resolve the names of the hosts; this is the way a B-node machine functions. H-node is thus a combination of P-node and B-node (in that order), which explains the origin of the term “H-node” because here, “H” stands for “hybrid.”

If there is no WINS server on a network, machines running Windows NT or Windows 2000 automatically configure themselves as B-nodes. If there is at least one WINS server on the network, however, the systems default to H-node.

See also
B-node, M-node, NetBIOS name resolution, P-node

home area network (HAN)

A network of several computers at a user’s home. With the rapid growth in the PC market, almost 15 percent of homes in the United States that have one PC have at least one additional PC. As a result, ordinary PC users are becoming interested in networking their home PCs to use them for purposes such as

  • Dedicating one PC to the role of a file server

  • Sharing a printer among multiples PCs

  • Installing a home Web server connected to the Internet by means of a cable modem

  • Playing network games with family and friends

  • Using networked PCs to prepare for certifications such as Microsoft Certified Systems Engineer (MCSE)

Popular technologies for deploying home area networks (HANs) include the following:

  • 10BaseT and 10Base2 networking kits (available from most computer vendors), which provide 10-Mbps throughput.

  • AC port interface cards that enable the use of standard AC wall outlets for transmitting information between computers in different rooms using installed AC wiring. These ports typically achieve only 1-Mbps throughput, but this will probably be extended to 5 or 10 Mbps.

  • Wireless networking transceivers and hubs that have limited distance and capabilities and operate in the unlicensed Industrial-Scientific-Medical (ISM) frequency range.

  • Infrared (IR) networking peripherals that allow PCs in the same room to communicate with one another.

home folder

Also called home directory, a user’s private folder for storing personal files. Home folders for users are usually centrally located on a network server for the following reasons:

  • To ensure that their contents are backed up regularly

  • To make home folders available from any computer on the network

  • To make home folders available from any client operating system

Graphic H-4. Use this Computer Management dialog box to specify a home folder in Windows 2000.
Graphic H-4. Use this Computer Management dialog box to specify a home folder in Windows 2000.
How It Works

Microsoft Windows NT Server does not have a default location for home folders. To create a network share for users’ home folders on a Windows NT–based network, follow these steps:

  • Use Windows Explorer on a server to create and share a folder called Users on a volume formatted using the NTFS file system of the server on which users’ home folders will be stored. The home folders will all be located in the Users share.

  • Remove the default Full Control access for Everyone and assign Full Control to Users. This restricts access to the shared folder to domain users.

  • Use the Profiles button on the User Properties dialog box in User Manager for Domains, and specify the location of each user’s home directory using the format \\SERVER_NAME\users\%username%. The expression %username% is an environment variable that will be replaced with the account name for each user. A subfolder within the Users share will be created for each user; this subfolder will be the user’s home folder, and its name will be the same as the user’s account name. Each user will have Full Control access on his or her home folder; no other user, including Administrator, will have permissions on the folder.

NOTE

Home folders are not part of the user profile of roaming users, so they must be specified as described in this entry. In Windows 2000, use Computer Management to assign home folder locations. Open the property sheet for the user and specify the location of the user’s home folder on the Profile tab (see the screen capture on the previous page).

home server

In Microsoft Exchange Server, the Exchange server on which a user’s mailbox content resides. A home server must have a private information store to contain mailbox contents, but it does not need to have a public information store. You can have many home servers in an Exchange organization.

You should dedicate specific servers as home servers in sites that have large numbers of users as well as to limit the number of home servers to streamline and simplify backup operations. Mailboxes can be moved between servers so that a user’s home server can be changed.

homogeneous network

A network that uses a single network architecture and operating system. An example is an Ethernet local area network (LAN) in which all machines are running Microsoft Windows 2000 Server. Another example is an enterprise-level messaging system based solely on Microsoft Exchange Server. Homogeneous networks are the simplest networks to administer, but most corporate networks are heterogeneous networks for the following reasons:

  • Budgets are limited, so it is not always possible to upgrade an older heterogeneous network into a newer homogeneous one unless the ultimate cost savings can be justified to management.

  • Products continually evolve, so what might be a state-of-the-art network operating system today will be a second-class system tomorrow.

  • Management and user expectations and needs evolve, so upgrading a second-class system might not be as appropriate as replacing it entirely with something newer.

  • Decision making involves politics, and different groups might press for purchasing software that they are more comfortable with instead of making prudent long-term decisions.

See also
heterogeneous network

hood

Sometimes called a boot, the protective enclosure at the ends of cabling that houses the pins. The hood protects the contacts between the cable’s wires and the pins in the enclosed connector. The term “hood” is usually applied to serial cables for serial transmission interfaces such as RS-232 and V.35. The RJ-45 termination of unshielded twisted-pair (UTP) cabling and the SC termination of fiber-optic cabling are simply called connectors or jacks.

Hoods are generally made of metal or plastic. Metal hoods are used on shielded cabling to provide shielding against electromagnetic interference (EMI) at the cable ends. Removable metal hoods are also used for running cable through tight spaces, such as conduits, or for repinning connections. Plastic hoods, which are less expensive, are used primarily on unshielded cabling. Molded plastic hoods are also used to provide durable, tamper-proof housings for pins.

Graphic H-5. Hood.
Graphic H-5. Hood.

hop

The logical distance between networks based on the number of routers that must be traversed by packets sent between them. For example, in TCP/IP internetworking, the number of hops between two hosts would be the number of routers that an Internet Protocol (IP) packet would have to pass through in order to reach its destination.

The following illustration shows a network path that is 3 hops long. As the packet travels from source to destination, the header of the packet maintains information about the “hop count” (the number of hops traversed). This information is stored as a Time to Live (TTL) parameter within each packet that typically starts with a value of 128 and is decremented by 1 at each router (that is, after each hop). If router congestion delays the packet at a router, the TTL might be decremented by more than 1 to indicate this. If the TTL is decremented to 0 before the packet reaches its ultimate destination, the next router drops the packet and retransmission is required from the source host.

Graphic H-6. Hop.
Graphic H-6. Hop.

Hop counts are used by dynamic routers to determine the best route for forwarding data across a large internetwork. The route that has the smallest total number of hops is generally the best route for sending the data.

TIP

Use the tracert command in Microsoft Windows NT or Windows 2000 to watch the hop count decrease as an IP packet traverses an internetwork toward its destination.

horizontal cabling

In premise cabling, any cabling that is used to connect a floor’s wiring closet to wall plates in the work areas to provide local area network (LAN) drops for connecting users’ computers to the network.

How It Works

Horizontal cabling is most easily installed during construction or renovation of the building because proper installation might require opening false ceilings or walls. If this is not feasible, installing external cable trays and conduits might be the best solution, because loose cables on the floor pose a hazard and should be avoided at all costs.

Horizontal cabling is usually installed in a star topology that connects each work area to the wiring closet, as shown in the illustration. Four-pair 100-ohm unshielded twisted-pair (UTP) cabling (category 5 cabling or enhanced category 5 cabling) is usually recommended for new installations because it supports both voice and high-speed data transmission. To comply with EIA/TIA wiring standards, individual cables should be limited to 90 meters in length between the wall plate in the work area and the patch panels in the wiring closet. Patch cords for connecting the patch panel to hubs and switches in the wiring closet should be no longer than 7 meters total distance (with a maximum of two patch cords per line, each of which does not exceed 6 meters in length). Cables connecting users’ computers to wall plates should be limited to 3 meters in length.

TIP

Avoid installing cables near motors, generators, transformers, or power lines in order to minimize electromagnetic interference (EMI). Keep cables away from photocopying machines and elevators because these machines generate a lot of EMI.

If you anticipate increased bandwidth needs in the near future, use multimode fiber-optic cabling instead of UTP cabling for horizontal cabling.

You probably want to install two four-pair UTP cables in each work area, one for voice and the other for data transmission. Be sure to use the right kind of wall plates (RJ-11 for voice and RJ-45 for data).

Graphic H-7. Horizontal cabling.
Graphic H-7. Horizontal cabling.

host

Any device on a TCP/IP network that has an IP address. Examples include servers, workstations, network-interface print devices, and routers. The terms “node” and “host” are often used interchangeably in this regard.

Sometimes the term “host” means a device on a TCP/IP network that can both receive data and initiate contact with other devices. For example, a computer configured as a Simple Mail Transfer Protocol (SMTP) host receives e-mail messages and forwards them to their destination.

NOTE

In mainframe computing environments, a host is a mainframe computer that is accessed by users through remote terminals.

Host Data Replicator

A Microsoft database replication tool that copies data from legacy DB2 database tables on an IBM mainframe to Microsoft SQL Server database tables. The Host Data Replicator can copy data either on demand or according to a predefined schedule.

The Host Data Replicator consists of a data replicator service implemented as a service in Microsoft Windows NT and Windows 2000 plus an administrative tool called the Data Replication Manager. The Host Data Replicator performs the replication by taking a snapshot of the entire source table. It then either copies the entire snapshot to the target database table, overwriting any records in the existing target table, or appends the information to the target table, depending on how it is configured. The Host Data Replicator can also replicate SQL Server tables back to a DB2 database.

The Host Data Replicator is supported by Microsoft SNA Server version 3 and later and Microsoft SQL Server version 6.5 and later.

host header names

A feature of Hypertext Transfer Protocol (HTTP) version 1.1 supported by IIS that lets multiple Web sites hosted on an IIS 4 or IIS 5 Web server share the same IP address. Web browsers such as Microsoft Internet Explorer support host header names and can access these Web sites seamlessly.

How It Works

To configure multiple virtual servers (Web sites) on an IIS server to share one IP address and use host header names for client access to them, perform the following steps:

  1. Open the property sheet for each virtual server in Internet Services Manager.

  2. Select the Web Site tab and specify the IP address and port number (usually port 80), or select All Unassigned if your server has only one IP address.

  3. Click the Advanced button, select the identity you want to use from the Multiple Identities For This Web Site list, and add a host header name. Note that each identity can have only one host header name, but each virtual server can have multiple identities.

  4. Register the host header name with your Domain Name System (DNS) server or Internet service provider (ISP).

Once the IIS server and DNS name resolution environment are configured properly, a Web browser that supports host header names, such as Internet Explorer 4 and later, can use these names to access different virtual servers that have the same IP address and port number and are located on the same machine running IIS. The browser makes an HTTP 1.1–compliant GET request, which contains in its header the host header name being requested.

NOTE

Web browsers that support host header names include Internet Explorer 3 and later or Netscape Navigator 3 and later.

TIP

IIS 4 and later support host header names on older browsers by implementing a mechanism based on cookies. For very old browsers that don’t support cookies, a tool in the IIS Resource Kit called the Cookie Munger enables these browsers to access such sites on IIS 4.

Do not create host header names for the Default Web Site, because this might affect other services installed on the server that expect the Default Web Site to have no host header names.

host ID

The portion of an IP address that uniquely identifies a host on a given TCP/IP network. You find the host ID by logically NANDing the binary form of the IP address with the binary form of the subnet mask for the network. The other part of an IP address is the network ID, which specifies the network to which the host belongs.

For example, if a host has an IP address of 172.16.8.55 on a network with a subnet mask of 255.255.0.0 (the default subnet mask), the host ID is 0.0.8.55 or simply 8.55. The host ID uniquely identifies the host, but only within the boundary of the network ID for the network on which the host is installed.

See also
network ID

host name

An alias given to a computer on a TCP/IP network to identify it on the network. Host names are a friendlier way of identifying TCP/IP hosts than IP addresses, and host names can be resolved into IP addresses by host name resolution using a DNS server or hosts files. Host names can include the characters a–z, A–Z, 0–9, period, and dash (-). To ensure full compatibility with the Domain Name System (DNS), do not use any other special characters in host names.

TIP

To find out the host name of a computer running Windows NT or Windows 2000, type hostname at the command prompt.

See also
host name resolution

host name resolution

The process by which a host determines the IP address of another host given its host name or fully qualified domain name (FQDN) on a TCP/IP network.

How It Works

Suppose you go to the command prompt of a machine running 32-bit Microsoft Windows NT and type ping followed by a host name or FQDN of another host on the network. The host name or FQDN of the target host must first be resolved into its IP address before the TCP/IP utility ping can occur. This process is called host name resolution.

A number of different methods can be used to perform host name resolution. The following table shows the order in which these are attempted on a Microsoft network. The methods are tried in succession until the host name is resolved into its IP address or until name resolution finally fails. Some methods will not be available—for example, if there is no DNS server or NetBIOS Name Server (NBNS) on the network.

Host Name Resolution Methods in the Order Applied
Host Name Resolution Methods | Comments
Check whether the target host is the local host. | The local host knows its own host name!
Check local hosts file. | This check is performed only if a hosts file has been configured.
Contact DNS server. | This check is performed only if the DNS tab of the TCP/IP property sheet has a DNS server specified on it. The local host tries again at intervals of 5, 10, 20, 40, 5, 10, and 20 seconds.
Check local NetBIOS name cache. (Unique to Microsoft networks.) | The cache contains recently resolved NetBIOS names. (On Microsoft networks, NetBIOS names and host names are usually the same.)
Contact NBNS. (Unique to Microsoft networks.) | This check is performed if NBNS has been configured by creating a Windows Internet Name Service (WINS) record within the DNS database. On a Microsoft network, this is usually a WINS server. The local host tries three times to contact the WINS server and then tries secondary WINS server three times if configured.
Perform local broadcast. (Unique to Microsoft networks.) | Local host broadcasts a NetBIOS name query request packet three times.
Check local lmhosts file. (Unique to Microsoft networks.) | This check is performed if an lmhosts file has been configured.

If all methods fail, an error message states that the computer could not be found on the network.

NOTE

There is a separate series of steps for attempting to resolve NetBIOS names on a network that uses WINS. For more information, see the entry on NetBIOS name resolution elsewhere in this work.

See also
Domain Name System (DNS), host name

host record

See
address record

host routing

The routing process that occurs when a host (computer) on a network forwards a packet to a destination host on the network. This is different from router routing, which is what happens when a router receives a packet that needs to be forwarded to a destination host.

How It Works

Host routing essentially involves a simple decision: Should the packet be forwarded directly to its destination host, or should it be forwarded to a router? The host makes this decision by comparing the packet’s destination address with entries in its internal routing table.

The host must first obtain the internetwork address of the destination host using some form of name resolution. For example, in order for a host to forward a packet to a remote host called northwind.Microsoft.com, it could first use the Domain Name System (DNS) to obtain the IP address of the remote host. The host then compares this address with entries in its internal routing table to determine whether the destination has a local or remote network address. If the address is a local network address, the host forwards the packet directly to its destination using the physical layer or physical address of the remote host. This process is known as direct delivery. On TCP/IP networks, the physical address of a host is its MAC address, which is obtained by using the Address Resolution Protocol (ARP).

If, however, the host determines that the destination host has a remote network address (that is, the destination host is on a different network than the sending host), the host forwards the packet to a nearby router after first obtaining the physical address of the near-side interface of the router. This process is known as indirect delivery. It is the responsibility of the router to ensure that the packet is forwarded toward its destination, although in a typical internetwork the destination might be several hops away, in which case the router’s responsibility extends only to the next hop on the path.

See also
router, routing

hosts file

A text file that provides a local method for resolution of fully qualified domain names (FQDNs) into their respective IP addresses on a TCP/IP network. Hosts files are an alternative to DNS servers for name resolution on TCP/IP networks. They are used mainly on small networks or when maintaining a DNS server is impractical.

How It Works

You can locate the hosts file using the following paths:

  • Microsoft Windows NT or Windows 2000:
    %SystemRoot%\system32\ drivers\etc\Hosts

  • Microsoft Windows 95 or Windows 98:
    \%WinDir%\Hosts.sam

Each line in the hosts file contains the IP address of a TCP/IP host followed by the FQDN of the host, followed by an optional comment prefixed with a pound sign (#).

NOTE

Hosts files should contain mappings for hosts on both local and remote networks. Mappings can consist of an IP address and one or more host names (aliases). If you are using hosts files to resolve host names on a network, each computer on the network should have a hosts file.

TIP

Place the host names that need to be most frequently resolved near the top of the hosts file, because the file is parsed linearly from the beginning.

See also
lmhosts file, networks file, protocol file, services file

hot

An adjective referring to actions that can be performed on systems or hardware devices while the power for the device is still turned on or while the device still has a live network connection or telecommunications link. “Hot” technologies are used in

  • Fault tolerant disk drive systems such as RAID systems

  • Redundant power supply systems

  • Modular Ethernet switches and routers

  • Redundant high-speed data communication links

Examples of disk storage systems that use “hot” technologies include the following:

  • Hot-rebuild system:
    A drive subsystem that can automatically rebuild its original drive configuration after drive failure

  • Hot-spare system:
    A drive subsystem that has additional unused drives that can be called into action when drive failure occurs

  • Hot-swap system:
    A drive subsystem in which drives are mounted on trays and can be removed and replaced without shutting down the system

TIP

When you buy a hardware RAID unit, be sure that it has hot-rebuild, hot-spare, and hot-swap capabilities.

HPFS

See
High Performance File System (HPFS)

HSCSD

See
High Speed Circuit Switched Data (HSCSD)

HTML

See
Hypertext Markup Language (HTML)

HTMLA

See
HTML-based administration (HTMLA)

HTML-based administration (HTMLA)

A technique for remotely administering servers using a standard Web browser such as Microsoft Internet Explorer as the client-side administrative interface. Microsoft Internet Information Services (IIS) supports HTML-based administration (HTMLA) from any Web browser that supports frames and JScript. HTMLA is based on Microsoft’s Component Object Model (COM) and Distributed Component Object Model (DCOM) architectures. The purpose of HTMLA is to simplify remote management of network resources and services by requiring that only client machines used for remote administration run a standard Web browser. Most of today’s networking products are moving toward HTMLA.

HTML Extension (HTX)

A text file with the extension .htx that is used by Microsoft Index Server (Indexing Service in Windows 2000). An HTML Extension (HTX) file is used to format the result set issued by Index Server in response to a catalog search query. These catalog search queries are issued using an Internet Data Query (IDQ) file. HTX files are also used by the Internet Database Connector (IDC) to format the result set of a database query.

The .htx file formats the result set of a query into a Hypertext Markup Language (HTML) page that the user who issued the query can read and understand. The .htx file acts as a template for formatting the result set and consists of HTML statements with additional tags and specific read-only variables such as

  • CiMatchedRecordCount, which contains the number of records that match the query

  • CiRecordsPerPage, which indicates the number of records on the next page

  • CiContainsFirstRecord, which is 1 if the page contains the first record of query results and 0 otherwise

HTTP

See
Hypertext Transfer Protocol (HTTP)

HTTP Keep-Alives

An enhanced version of HTTP persistent connections supported by Microsoft Internet Information Server (IIS). HTTP Keep-Alives allow a client Web browser to keep connections open with the Web server instead of closing them after the request has been answered and reopening them for each new Hypertext Transfer Protocol (HTTP) request, which consumes system resources. For this feature to work, however, both the client Web browser and the Web server must support HTTP Keep-Alives. Web browsers that support this feature include Microsoft Internet Explorer version 2 and later and Netscape Navigator 2 and later.

NOTE

HTTP Keep-Alives are enabled by default. They are not the same as TCP Keep-Alives, which are periodic packets sent between machines to determine whether an idle connection is still active.

HTTPS

A protocol developed by Netscape for secure transmission of Web content over the Internet. HTTPS is another name for Netscape’s implementation of the Secure Sockets Layer (SSL) protocol that functions as a subprotocol to the application layer (layer 7) protocol, Hypertext Transfer Protocol (HTTP).

HTTPS is based on the public key cryptography system and allows information transmitted over the Internet to be encrypted for greater security. To run HTTPS on a Web server, you must install a digital certificate on the server. Web browsers will then connect to the server by providing a Uniform Resource Locator (URL) that begins with the prefix https:// rather than http://. The designation “HTTPS” comes from the combination of “HTTP” and “secure.”

NOTE

HTTPS uses the TCP well-known port number 443 instead of port 80, which is used by HTTP. HTTPS is not the same as Secure Hypertext Transfer Protocol (S-HTTP).

HTTP status codes

Three-digit codes that Web servers return in response to Hypertext Transfer Protocol (HTTP) requests sent by Web browsers. They are also known as HTTP error codes because most of them signify some sort of error condition.

The HTTP status code is one of the first pieces of information returned by a Web server in response to a request from a Web browser, and it informs the browser of the status of the request. Status codes are usually displayed by Web browsers instead of the desired Web page when the server cannot satisfy the browser’s request for some reason. Status codes are grouped into categories by their first digit, as shown in the following table.

HTTP Status Codes by Category
Status Code | Category | Description
2 xx | Success | The action was completed.
3 xx | Redirection | Further action must be taken to fulfill the request.
4 xx | Client error | The request could not be accepted because of client error.
5 xx | Server error | The request could not be accepted because of server error.

Some common status codes in HTTP sessions that are fairly self-explanatory include the following:

  • 200 OK (not seen by the client)

  • 400 Bad Request

  • 401 Unauthorized

  • 403 Forbidden

  • 404 File Not Found

  • 500 Internal Server Error

NOTE

Microsoft Internet Information Server (IIS) version 4 allows administrators to create customized HTTP status code pages that can be considerably more informative to users than status codes such as “Forbidden.”

HTX

See
HTML Extension (HTX)

hub

Also called a repeater hub, the basic networking component used in traditional 10-Mbps Ethernet networks to connect network stations to form a local area network (LAN). Hubs can be used for

  • Connecting about a dozen computers to form a workgroup or departmental LAN

  • Connecting other hubs in a cascaded star topology to form a larger LAN of up to roughly a hundred computers

How It Works

Hubs are the foundation of traditional 10BaseT Ethernet networks. The hub receives signals from each station and repeats the signals to all other stations connected to the hub. In active hubs (which all of today’s hubs are), the signal received from one port is regenerated (amplified) and retransmitted to the other ports on the hub. Hubs thus perform the function of a repeater and are sometimes called multiport repeaters. From a logical cabling point of view, stations wired into a hub form a star topology.

Hubs generally have RJ-45 ports for unshielded twisted-pair (UTP) cabling, and they range in size from 4 to 24 or more ports for connecting stations to the hub, plus one or more uplink ports for connecting the hub to other hubs in a cascaded star topology. Hubs generally have various light-emitting diode (LED) indicator lights to indicate the status of each port, link status, collisions, and so on. Hubs with several different types of LAN connectors such as RJ-45, BNC, and AUI are commonly called combo hubs.

There are numerous types of hubs for various specialized uses. These include the following:

  • Minihubs, which have only 4 to 8 ports and are used for quick or temporary LAN extensions. Minihubs can be as small as a cigarette packet.

  • Workgroup hubs, which are the basic building blocks of small workgroup LANs. These typically have 8 or 16 ports on them, plus a BNC or an AUI port to provide more connectivity options within existing 10Base2 or 10Base5 networks. A hub is generally termed a workgroup hub if it supports up to 50 stations, a departmental hub if it supports up to 250 stations, and an enterprise hub if it supports more than 250 stations. Stackable hubs can be used to provide these various capabilities.

  • Stackable hubs, which are modular in design and can be mounted in racks and cabinets within the wiring closet and can be connected using special ribbon or DB-50 cables. Stackable hubs are available in configurations of 8, 16, and 24 ports and can be stacked to effectively form a single hub with 48, 72, 144, or more ports. Stackable hubs take less space and are easier to manage than regular workgroup hubs. Most stackable hubs also have an uplink switch that can be used to convert one of the ports into an additional uplink port, allowing you to connect another hub directly to the port.

  • Intelligent hubs, which can be remotely managed and monitored using Simple Network Management Protocol (SNMP). Special connectors on the back of advanced hubs might provide features such as an RS-232 serial interface for connecting to an SNMP management console. Such hubs are sometimes called manageable hubs.

  • Dual-speed hubs, which have autosensing ports that support combinations of both 100-Mbps Fast Ethernet connections and 10-Mbps traditional Ethernet connections. Each port senses the speed of the attached station and configures itself to function appropriately. Advanced dual-speed hubs might contain internal Ethernet switch circuitry that segments the 10-Mbps and 100-Mbps connections into separate collision domains and forwards data between the domains to improve overall performance. These advanced hubs are sometimes called master hubs, and only one of these is required in a mixed 10/100-Mbps LAN. Dual-speed hubs are typically stackable hubs with 8 or 16 ports that can be stacked to support a total of 32 or 48 ports. They are useful in situations in which you are gradually migrating from 10BaseT to 100BaseT.

  • Fast hubs, which have 100-Mbps ports only for forming 100BaseTX Fast Ethernet LANs. They are usually stackable hubs with advanced SNMP management functions, and they might have built-in Ethernet switching functions. They might also allow you to mix 100BaseTX and 100BaseT4 hubs in a stack that supports up to 144 stations, and they might include fiber-optic ports for connecting to a high-speed fiber-optic backbone.

  • Modular hubs, which are more expensive hubs that provide a backplane or chassis in which cards can be inserted to create custom hub configurations. They are more common in Token Ring or Fiber Distributed Data Interface (FDDI) environments.

You can also combine the features of these various types of hubs to form fast stackable hubs, manageable dual-speed hubs, and so on.

Graphic H-8. Stackable hubs and a diagram of hubs at work.
Graphic H-8. Stackable hubs and a diagram of hubs at work.
NOTE

A device called a wiring concentrator or Multistation Access Unit (MAU) is similar to a hub but is used in Token Ring networks.

TIP

Until recently, hubs have formed the foundation of most workgroup or departmental-sized networks, but Ethernet switches, which offer superior performance, are gaining popularity in today’s high-speed multimedia environments as their price continues to fall.

HyperTerminal

A communication utility included in Microsoft Windows 95, Windows 98, Windows NT, and Windows 2000 that provides terminal access to remote computers using a modem. You can use HyperTerminal to send and receive files between your computer and a remote computer over a modem and to connect to remote computer bulletin board systems. If you want to access files and printers on a remote computer running Windows over a modem, use Dial-Up Networking instead of HyperTerminal. (With Windows 2000, use Network and Dial-up Connections.)

TIP

Network administrators can also use HyperTerminal to remotely connect to routers, switches, and other devices that support VT100 terminal emulation, and enter text commands for configuring the device.

Hypertext Markup Language (HTML)

A formatting or markup language used to create documents for the World Wide Web (WWW).

How It Works

Hypertext Markup Language (HTML) in its simplest form uses tags to format ASCII text documents by indicating text that should be displayed as boldface, italic, bulleted, hyperlinked, centered, and so on. These tags usually come in pairs, can be nested, can contain additional attributes, and are used to “mark up” the text. For example, the text “Save 50%” can be displayed on Web browsers in boldface by marking it up using the <STRONG> tag (which means “turn on the bold style”) and the </STRONG> tag (which means “turn off the bold style”). The resulting HTML would look like this:

<STRONG>Save 50%</STRONG>

HTML pages are saved as files with the extension .htm or .html in the appropriate directory on a Web server such as Microsoft Internet Information Services (IIS). When a Web browser such as Microsoft Internet Explorer downloads an HTML page from a Web server, it interprets the tags and displays the document with the appropriate formatting.

HTML has gone through several versions since it was created in the early 1990s. At the time of this writing, the most current version is HTML 4. The original HTML did not provide much control over how documents were formatted—that is, how objects such as text and graphics were laid out on a page. Its original set of tags was quite limited and was intended primarily for linking documents using hyperlinks to form hypertext. As the Web grew in popularity, however, first Netscape and then Microsoft introduced their own proprietary HTML tags to provide Web developers with more control over document formatting, thus increasing the pace at which the World Wide Web Consortium (W3C) developed the HTML standard. HTML 4 includes standards for creating cascading style sheets, which provides powerful formatting capabilities for precise placement of objects on a Web page.

On the Web
•
“A Beginner’s Guide to HTML” from the National Center for Supercomputing Applications (NCSA)
: http://www.ncsa.uiuc.edu/General/Internet/WWW/HTMLPrimerAll.html
•
“HTML 4.0 Specification” from the W3C
: http://www.w3c.org/TR/REC-html40

Hypertext Transfer Protocol (HTTP)

A standard Internet protocol that specifies the client/server interaction processes between Web browsers such as Microsoft Internet Explorer and Web servers such as Microsoft Internet Information Services (IIS).

How It Works

The original Hypertext Transfer Protocol (HTTP) 1.0 protocol is a stateless protocol whereby a Web browser forms a connection with a Web server, downloads the appropriate file, and then terminates the connection. The browser usually requests a file using an HTTP GET method request on TCP port 80, which consists of a series of HTTP request headers that define the transaction method (GET, POST, HEAD, and so on) and indicates to the server the capabilities of the client. The server responds with a series of HTTP response headers that indicate whether the transaction is successful, the type of data being sent, the type of server, and finally the requested data.

IIS 4 supports a new version of this protocol called HTTP 1.1, which has new features that make it more efficient. These new features include the following:

  • Persistent connections:
    An HTTP 1.1 server can keep TCP connections open after a file has been transferred, eliminating the need for a connection to be opened and closed each time a file is transferred, as is the case with HTTP 1.0.

  • Pipelining:
    This is a process whereby an HTTP 1.1 client can send multiple Internet Protocol (IP) packets to the server without waiting for the server to respond to each packet.

  • Buffering:
    This process allows several HTTP requests by the client to be buffered into a single packet and sent to the server, which results in faster transfer times because fewer and larger packets are used.

  • Host headers:
    This feature enables an HTTP 1.1–compliant Web server to host multiple Web sites using a single IP address.

  • Http put and http delete commands:
    These commands enable Web browsers to upload and delete files from Web servers using HTTP.

NOTE

If you want to use the HTTP 1.1 features of Microsoft Internet Information Server 4, your clients must be running an HTTP 1.1–compliant browser such as Microsoft Internet Explorer 4.

NOTE

Don’t confuse HTTP with HTML! HTTP is the protocol through which Web servers communicate with Web browsers. It is a control language for passing commands between clients and servers. HTML is Hypertext Markup Language, the language for constructing Web pages (the actual content passed from Web servers to Web clients in an HTTP request).

TIP

You can view the HTTP headers in HTTP requests and responses by using the full version of Network Monitor, a tool included with Microsoft Systems Management Server (SMS). Set your capture filter to capture HTTP protocol packets, and then connect to the Internet and browse some Web sites to generate HTTP traffic.

On the Web
•
World Wide Web Consortium (W3C)
: http://www.w3.org


I

I2O

See
Intelligent Input/Output (I2O)

IAB

See
Internet Architecture Board (IAB)

IANA

See
Internet Assigned Numbers Authority (IANA)

IAS

See
Internet Authentication Service (IAS)

ICA

See
Independent Computing Architecture (ICA)

ICANN

See
Internet Corporation for Assigned Names and Numbers (ICANN)

ICMP

See
Internet Control Message Protocol (ICMP)

ICP

See
integrated communications provider (ICP), Internet Cache Protocol (ICP)

ICQ

A program that enables users to locate other ICQ users on the Internet and communicate with them in real time. ICQ, which homophonically stands for “I seek you,” lets you search for users currently online on ICQ networks and alerts you when friends go online. You can use ICQ to send real-time messages to other users, have group chat sessions, send e-mail, transfer files and URLs, play games, and so on. ICQ can even function as a universal platform for launching any peer-to-peer application, such as Microsoft NetMeeting.

How It Works

When you install ICQ and begin the registration process, you are connected to an ICQ server that belongs to a network of such servers distributed across the Internet. During registration, you are given a unique number called an ICQ#, which identifies you to all other users on the ICQ network. You use your ICQ# to register your presence with the ICQ network when you go online and start ICQ, and to allow other ICQ users to recognize when you are online so that they can contact you. You can specify a list of ICQ friends, and an ICQ server will alert you when any of these friends go online.

On the Web
•
ICQ Inc.
: http://www.icq.com

IDC

See
Internet Database Connector (IDC)

IDQ

See
Internet Data Query (IDQ)

IE

See
Microsoft Internet Explorer

IEAK

See
Internet Explorer Administration Kit (IEAK)

IEEE

See
Institute of Electrical and Electronics Engineers (IEEE)

IEEE 488

An Institute of Electrical and Electronics Engineers (IEEE) standard for a parallel interface developed by Hewlett-Packard that is used for connecting computers to measurement sensors and test equipment for automatic data acquisition in a laboratory or industrial setting. Examples of such equipment include signal generators, frequency counters, voltmeters, and temperature sensors.

How It Works

IEEE 488, also known as the General-Purpose Interface Bus (GPIB), provides high-speed parallel communication using a 24-pin connector. An IEEE 488 cable generally has eight single wires for data transfer, eight twisted-pairs for interface handshaking and management, and a drain (ground) wire, all enclosed in an insulating protective jacket. This configuration provides eight bidirectional channels for transmitting 1 byte (8 bits) of information at a time, at a maximum bus speed of 1 Mbps using tristate drivers. You can chain together up to 15 devices for a total length of 20 meters, with no more than three connectors stacked and no more than 2 meters between adjacent devices. The master device acts as a controller that determines which device can transmit data over the bus at any given time, while the other devices are placed in standby mode. Only one device can transmit signals on the bus at any given time, but multiple devices can receive those signals.

TIP

If your industrial environment is dusty or has high levels of electromagnetic interference (EMI) from motors, generators, or other heavy equipment, you can obtain special shielding covers to protect your IEEE 488 connectors. You can use switchboxes to alternate several industrial sensors on a single IEEE 488 cable.

IEEE 802 standards

See
Project 802

IEEE 1284

An Institute of Electrical and Electronics Engineers (IEEE) standard for high-speed bidirectional parallel communication. IEEE 1284 defines the high-speed printer interface called the Enhanced Parallel Port (EPP), which is compatible with the Centronics port used for connecting parallel port printers to computers. IEEE 1284 enables bidirectional communication between computers and attached printers. It also enables computers to spool jobs to printers at more than 10 times the speed of a traditional parallel port interface.

How It Works

To make bidirectional printing work using IEEE 1284, you need the following:

  • A print device that supports bidirectional printing.

  • A printer driver that supports bidirectional printing.

  • A correctly configured parallel port on the connected computer (print server). For example, if the parallel port is configured as AT-compatible, change it to PS/2 mode.

  • An IEEE 1284–compliant cable.

For example, Microsoft Windows 98 can detect plug and play print devices by communicating with them. The bidirectional communication allows the print device to return information to the computer that queried it for hardware information. This information can include IEEE 1284 device ID values, printer memory, installed fonts, and other information that the printer driver on the server can use to install and configure the printer. Bidirectional communication also allows the print device to send status messages (such as an “out of paper” message) to the server.

IEEE 1284 specifies two electrical interfaces:

  • Level I interface, which functions at a lower speed and provides only reverse-mode capabilities

  • Level II interface, which functions at a higher speed and provides bidirectional communication

The connectors for the IEEE 1284 interface also come in several types:

  • Type A connectors, which are standard 25-pin DB25 connectors

  • Type B connectors, which are 36-pin centerline Champ connectors with bale locks to hold the cable in place for physical security

  • Type C connectors, which are 36-pin centerline miniconnectors with clips for physical security

TIP

An IEEE 1284 cable typically has “IEEE 1284” printed on its insulating jacket. IEEE 1284 cables are commonly used for connecting laser printers, scanners, tape drives, and portable storage devices (such as Iomega Zip drives) to a computer; these cables have a DB25 male connector on one end and a Centronics 36 male connector on the other. You can obtain cables for converting the IEEE 1284 parallel interface to the universal serial bus (USB) interface to connect print devices with a Centronics connector to a computer with a USB connector. Special signal-powered IEEE 1284 cables can allow printers to be located up to 100 feet from the connected computer and still maintain reliable communication. Adapters are available for connecting 36-pin and DB25 connectors.

IEEE 1394

See
FireWire

IETF

See
Internet Engineering Task Force (IETF)

IGMP

See
Internet Group Management Protocol (IGMP)

IGP

See
Interior Gateway Protocol (IGP)

IIS

See
Internet Information Services (IIS)

IIS Object Cache

A cache maintained by Internet Information Services (IIS) that stores file objects that are frequently requested by the World Wide Web (WWW), File Transfer Protocol (FTP), and Simple Mail Transfer Protocol (SMTP) services and by Active Server Pages (ASP) applications. The IIS Object Cache contains handles for open file objects, directory listings, and other frequently used file system objects. The cache runs within the main inetinfo.exe process and provides improved performance for IIS services and ASP applications.

TIP

For performance reasons, you should keep the IIS Object Cache in the working set of the IIS process in RAM. Be sure that you have sufficient RAM to do this. If you don’t have enough RAM, the IIS Object Cache will be paged to disk and performance will be impaired. You can observe the performance of the cache by using Performance Monitor. Look for counters relating to cache hits and cache misses for each IIS service.

ILS

See
Internet Locator Service (ILS)

IMAP4

See
Internet Mail Access Protocol version 4 (IMAP4)

impedance

In physics, the measure of resistance to the flow of electric current. Impedance to signal flow within a transmission line has three components: a resistive component, a capacitative component, and an inductive component. The value for each component varies with the frequency of the current, which means that the overall impedance of a transmission line also varies with frequency. A perfect transmission would have an impedance that does not change with frequency.

Characteristic impedance is the measure of resistance of a transmission line (such as a cable) calculated with the assumption that the cable is of infinite length. It is represented by the symbol Z0 . Each type of network cabling has its own characteristic impedance. Twisted-pair cabling can have a relatively constant impedance by virtue of its design and dimensional characteristics. The EIA/TIA wiring standards, specifically EIA/TIA 568-A (Commercial Building Telecommunications Cabling Standard), mandate that category 5 cabling should have an impedance of 100 ohms, plus or minus 15 percent, up to a frequency of 100 MHz. It is important that cabling meet these standards because networking equipment, such as hubs, switches, and routers, is designed to match this impedance value. If wiring with a different impedance is used with such equipment, reflections of signals can occur that can distort signals, create signal loss, and degrade network communications—or even render them impossible.

NOTE

Impedance is an issue only with copper cabling and is not a relevant physical characteristic for fiber-optic cabling.

impersonation

Generally, a mechanism for supporting client/server communication. In Microsoft Windows NT and Windows 2000, impersonation is a method that a server uses to determine whether a client has sufficient rights to access a resource.

How It Works

Impersonation involves temporarily altering the security context of the server so that it matches that of the client. When the client attempts a connection to a resource on the server, it tells the server the impersonation level that the server can use to service the client’s request. The client can offer four impersonation levels:

  • Anonymous:
    The server does not receive any information about the security context of the client.

  • Identification:
    The server can authenticate the client but cannot use the security context of the client for performing access checks.

  • Impersonation:
    The server can both authenticate the client and use the client’s security context to perform access checks.

  • Delegation:
    The server authenticates the client and passes the client’s security context to a remote server on the client’s behalf. Delegation is not supported by the NTLM authentication method of Windows NT Server, but delegation is supported by the Kerberos authentication method of Windows 2000.

An example of impersonation occurs when anonymous access is enabled on a Web site hosted on Internet Information Services (IIS). Anonymous access uses the IUSR_ComputerName anonymous account on the IIS server, which is part of the Guests local group. If an IIS machine receives a Hypertext Transfer Protocol (HTTP) request from a remote Web browser, IIS impersonates the IUSR_ComputerName account so that it can allow the remote client to access the requested files or run the requested application. This prevents access to system files on the IIS machine by the remote client.

import computer

A computer running Microsoft Windows 2000 Server, Windows 2000 Professional, or Windows NT, to which directories and files are imported from a Windows NT–based server that is running the Directory Replicator Service. The import server contains a replica of the directory tree that is received from an export server by the Directory Replicator Service.

You configure an import server using the Replication button in Server Manager, which you access from the Server icon in Control Panel or from the Start menu’s list of administrative tools. To do this, you must specify the following:

  • The location to which you want to import the exported directory tree. The default tree is %SystemRoot%\System32\Repl\Import.

  • The domains or computer names from which you want to import the tree.

See also
Directory Replicator Service

IMT-2000

See
International Mobile Telecommunications-2000 (IMT-2000)

IMUX

See
inverse multiplexer (IMUX)

in-addr.arpa

A special domain in the Domain Name System (DNS) that is used for inverse queries. Using the in-addr.arpa domain, a resolver can submit a request to a name server to resolve an IP address into its corresponding fully qualified domain name (FQDN).

How It Works

The in-addr.arpa domain contains nodes whose names are based on IP addresses with octets in the reverse order. For example, a host with the IP address 172.16.8.44 would be represented in the in-addr.arpa domain by 44.8.16.172.in-addr.arpa. Resource records for the in-addr.arpa domain are called pointer (PTR) records and are contained within a type of zone file called a reverse lookup file.

See also
DNS namespace, DNS query, Domain Name System (DNS)

in-band signaling

Generally, any signaling transmission that takes place within a range of frequencies that are normally used only for data transmission. Instead of using separate control and data channels, control information is transmitted using a portion of the data channel. If a separate control channel is used, the service is called out-of-band signaling.

For example, in-band signaling is used in switched 56 services, in which a 64-Kbps digital communication link has 8 Kbps set aside for control signaling. This is sometimes referred to as “robbed-bit signaling” because the 8-Kbps bandwidth is “robbed” from the data channel for handling control functions such as wide area network (WAN) link synchronization. T1 lines that use switched channels also use in-band signaling techniques.

Graphic I-1. Comparison with out-of-band signaling.
Graphic I-1. Comparison with out-of-band signaling.

Inbox Repair Tool

A tool included with Microsoft Exchange Server that you can use to check and repair problems with personal folders and offline storage files in a messaging system that uses Microsoft Windows messaging clients (such as Microsoft Outlook). The Inbox Repair Tool is installed on clients that have Outlook installed. It is also included on the Windows 98 CD as the utility scanpst.exe.

How It Works

When you run the Inbox Repair Tool, it analyzes the .pst file’s directory structure and item headers and tries to recover all the folders and all the items in those folders. If it finds any errors, it attempts to recover the damaged items. It also creates a log file of the actions it has performed, which you can examine later for further information. The tool creates a new set of empty Outlook folders along with a Lost And Found folder that contains any folders and items it recovered from the .pst file. You can then create a new .pst file and drag the recovered folders and items to your new Personal Folders entry in your Outlook profile.

incremental backup

A backup type in which only selected files and folders that have changed since the last normal backup are backed up and the archive attribute is marked for each file and folder. You can use incremental backups in conjunction with normal backups to simplify and speed up the backup process. If you do a normal backup on one particular day of the week, you can perform incremental backups on the remaining days to back up only the files that have changed during each day of the backup schedule. Incremental backups are faster than normal backups and use less tape.

NOTE

Incremental backups are not cumulative, as differential backups are, so when you need to perform a restore, you need the normal backup and all incremental backups since the normal backup was done. Incremental backups are faster to perform but take longer to restore from.

See also
backup type, differential backup

incremental zone transfer

A method of updating zone information in newer implementations of the Domain Name System (DNS).

How It Works

Incremental zone transfer is a more efficient method of propagating zone updates than the earlier standard DNS method of transferring the entire zone file using the AXFR request. Incremental zone transfer is defined in Request for Comments (RFC) 1995 and uses the IXFR request to transfer only the minimal information needed to keep the DNS servers within a given zone of authority in synchronization.

In incremental zone transfer, every primary or master DNS server maintains a full copy of the up-to-date zone file plus an additional version history that records any changes to resource records that occurred during recent updates of the zone file. When a secondary DNS server makes an IXFR request to a primary or master DNS server, the master server compares the zone version number of the secondary server’s zone to its own current version number. The zone version number is the serial number stored in the start of authority (SOA) record of the DNS server. If the master server has a newer version number and incremental zone transfers are supported, the master server sends to the secondary server only those changes to resource records that have occurred in the time interval between the two version numbers. If the version numbers of the master and secondary servers match, no zone transfer takes place. And if incremental zone transfer is not supported, the normal full zone transfer takes place instead.

NOTE

Incremental zone transfers are supported as part of the dynamic update features of Microsoft Windows 2000.

Independent Computing Architecture (ICA)

A general-purpose presentation services protocol for Microsoft Windows operating system platforms. The Independent Computing Architecture (ICA) protocol was developed by Citrix for Citrix Winframe to run on Windows NT Server, and is implemented in Windows NT Server, Terminal Server Edition. ICA lets the user interface of an application run with minimal consumption of resources on a client device while the actual application logic executes on an ICA-enabled server. In this respect, ICA is similar to the X Windows protocol for UNIX platforms. The only data transferred between the server and the client device over the network are the user interface, keystrokes, and mouse movements. This results in minimal resource requirements for the client, allowing the use of a “thin client.” ICA also provides location independence because it runs the Windows NT Server operating system and application program at a centralized location while displaying the user interface on any supporting client.

The ICA protocol runs over most industry-standard networking protocols, such as TCP/IP, NetBEUI, IPX/SPX, and Point-to-Point Protocol (PPP). It also runs over transport protocols such as Integrated Services Digital Network (ISDN), frame relay, and Asynchronous Transfer Mode (ATM). Users can access standard Windows applications running on a remote ICA-based server over dial-up, local area network (LAN), wide area network (WAN), or Internet connections. Applications can be launched from Web pages or from Windows desktops, making the ICA protocol a platform-independent solution.

index

A database object in relational databases that enables efficient and rapid access to data in the rows of a database table using key values. Indexes are created on columns in a Microsoft SQL Server database and provide a way to logically order rows in a database table. Because databases without indexes take much longer to query, planning and implementing indexes is an essential part of database design.

Indexes can also be used to enforce the uniqueness of rows in a database table by building the index on a key value.

TIP

Although using indexes generally speeds queries, it is not a good idea to have an index for every column because building the index takes time and requires additional disk space, plus modifying the contents of the database causes modifications to the index. You should only create indexes for the following:

  • Primary and foreign keys

  • Data on which you frequently issue search queries

  • Columns that are often retrieved in a sorted order or are used in joins

See also
Index Tuning Wizard

Indexing Service

An optional component of the Microsoft Windows 2000 Server operating system platform that enables the indexing of contents and properties of documents on Internet or intranet sites hosted using Internet Information Services (IIS). On the earlier Windows NT Server platform, this component was called Index Server and was included as part of the Windows NT Option Pack. The features of the Indexing Service include the following:

  • Support for indexing of multiple IIS servers, Windows NT and Windows 2000 file servers, and Novell NetWare file servers

  • Extensible support for multiple file formats, including ASCII text, Hypertext Markup Language (HTML), Microsoft Word, Microsoft Excel, Microsoft PowerPoint, and third-party file formats that use content filters

  • Multiple-language support for both indexing and querying, including language shifts within a document

  • Support for indexing newsgroup content on an IIS 4 server running the NNTP Service

  • Zero-maintenance design, including automatic reindexing and error detection and recovery

How It Works

Indexing Service (which runs as the Content Index service in Windows NT) automatically indexes new documents as you add them to your Web sites on IIS. It begins by scanning the new documents and using content filters to generate a stream of text from them. Then it enlists word breakers to divide the text stream into words, after which the normalizer removes noise words and punctuation. It compiles the resulting words into word lists, which it merges into persistent indexes. Finally, it conducts a master merge to create a master index, which it stores in an Indexing Service catalog. The master index is the most efficient way to store indexing information.

Administrators can use the Indexing Service snap-in for the Microsoft Management Console (MMC) to view the status of the indexing process and to configure catalogs. Although the entire indexing process runs automatically, administrators can use the MMC to force a scan or a merge if necessary.

You can create and configure an HTML query form to issue queries against Indexing Service catalogs by using one of the following:

  • Internet Data Query (IDQ) files and HTML Extension (HTX) files

  • Active Server Pages (ASP) scripting

  • SQL queries that use Microsoft ActiveX Data Objects (ADO)

Index Tuning Wizard

A wizard in Microsoft SQL Server version 7 that you can use to select and create an optimal set of indexes and statistics for a database. The Index Tuning Wizard lets you optimize your database’s indexes even if you do not understand the structure of the database or the internal workings of SQL Server.

How It Works

The wizard uses a workload to build a recommended optimal set of indexes for your database. A workload is a SQL script or a trace created using SQL Server Profiler. It contains SQL batch or remote procedure call (RPC) event classes and data columns called Event, Class, and Text. The workload profiles the normal activity of your database and allows the wizard to analyze it to determine which index configuration will optimize performance of your database. The result of running the wizard is a set of Structured Query Language (SQL) statements that you can use to create new indexes and remove existing ones. You can implement these recommendations immediately, save them to a SQL script for later use, or schedule their execution as a SQL Server job.

The wizard can recommend the best set of indexes to use for a given workload, recommend how you can tune your database for a small group of problem queries, and let you analyze the effects of proposed alterations, such as distributing queries among different tables.

NOTE

If you don’t have enough data in your database tables or if your existing set of indexes is optimal, the Index Tuning Wizard cannot produce a recommendation for you.

information store

One of the four core components of Microsoft Exchange Server. The information store consists of two databases that store Exchange messaging content:

  • The public information store, which stores content for public folders hosted on the server

  • The private information store, which stores users’ mail folders, messages, and attachments for users whose home directories are on the server

The information store is implemented as a Microsoft Windows NT service or a Microsoft Windows 2000 service and can be accessed by

  • Messaging clients based on Microsoft Messaging Application Programming Interface (MAPI), such as Microsoft Outlook

  • Post Office Protocol version 3 (POP3) clients, such as Microsoft Outlook Express

  • Network News Transfer Protocol (NNTP) clients, such as Outlook Express

The information store stores its message content using the Exchange message database encoding format (MDBEF). MAPI clients can access this format directly, but non-MAPI clients require conversion of MDBEF format information to their own messaging format—such as Simple Mail Transfer Protocol (SMTP) or X.400.

TIP

An Exchange Server can have a private information store, a public information store, or a private and a public information store. This provision for creation or deletion of information stores allows you to load-balance demand on servers by creating dedicated messaging or dedicated public folder servers in your sites.

Infrared Data Association (IrDA)

An international consortium of hardware and software manufacturers that creates and promotes interoperable solutions for infrared (IR) data networking for computer networks, communication, and other networking applications. The Infrared Data Association (IrDA), which was formed in 1993, has over 150 members from hardware, software, and communication sectors. It has developed and agreed on standard formats for communication between computers and infrared devices to ensure interoperability between different systems, platforms, and devices. The IrDA also schedules meetings, conferences, and other events relating to infrared networking technologies. IrDA standards include the IrDA Data and IrDA Control infrared communication standards.

On the Web
•
IrDA home page
: http://www.irda.org
See also
infrared transmission, IrDA Control, IrDA Data

Infrared Monitor

A Microsoft Windows 98 utility for managing a computer’s connectivity to devices that use infrared (IR) communication technology. To activate Infrared Monitor on your system, use the Infrared utility in Control Panel or the icon in the system tray of the taskbar when you use an infrared device. You can use Infrared Monitor for the following tasks:

  • Determining which infrared devices are within the range of your system

  • Determining which infrared devices are currently in communication with your system and the status of those communications

  • Reporting on the status of infrared activity and all connected infrared devices

  • Enabling or disabling infrared services on a serial port

  • Configuring the maximum transmission speed to tune performance

  • Configuring sounds for signaling different infrared device status situations

TIP

By limiting the maximum transmission speed for infrared communication, you might be able to improve communication between your system and its infrared-enabled peripherals. Try a connection speed of 19.2 Kbps and gradually work upward.

See also
Infrared Data Association (IrDA), infrared transmission

infrared transmission

The transmission of data or voice information over infrared (IR) light. Infrared data transmission is often used to connect laptops or Personal Digital Assistants (PDAs) to peripherals (such as printers) or to desktop computers for synchronizing work files. The most popular computer industry standard for infrared transmission is the IrDA Data standard developed by the Infrared Data Association (IrDA).

How It Works

IR is light that is beyond the red end of the visible spectrum. Wavelengths in the range of 770 to 1400 nanometers are called the near infrared region of the electromagnetic spectrum, while longer wavelengths are called the far infrared. An IR transducer consists of a driver and an IR emitter that can both transmit and receive infrared transmissions. The transducer is connected to an encoder/decoder that interfaces with the computer or peripheral’s universal asynchronous receiver-transmitter (UART) for asynchronous serial transmission between the devices.

IrDA devices that use the IrDA Data protocol suite initiate a connection using the discovery functions of the Infrared Link Management Protocol (IrLMP) and establish the primary and secondary stations using the Infrared Link Access Protocol (IrLAP). The secondary station then adjusts its data speed to match the primary station and establishes a serial communication link.

TIP

Remember that IrDA devices have severe distance limitations and require a direct line of sight between them in order to communicate, and that outdoor communication can be adversely affected by fog and other bad weather.

inheritance

A feature in the security framework of Microsoft Windows NT and Windows 2000 that allows the access control entry (ACE) for an object whose security settings are being configured to be propagated to other objects that are beneath it in the file system or directory hierarchy. In Windows NT, inheritance is used in the NTFS file system for propagating the permissions assigned to a folder to the files and folders within that folder. In Windows 2000, inheritance also applies to Active Directory and allows permissions assigned to a container or an organizational unit (OU) within Active Directory to be propagated further down the directory tree. Inheritance also appears in other directory-based systems such as Microsoft Exchange Server, in which Exchange administrative permissions assigned to a container in the Exchange directory that is based on the Lightweight Directory Access Protocol (LDAP) can be applied to leaf objects and other containers within that container.

Inheritance simplifies the administration of hierarchical file systems and directories by allowing administrators to configure ACEs globally and then modify them on an exception basis, rather than configure ACEs individually for each object in the system.

See also
delegation, discretionary access control list (DACL), permissions

INI files

A series of initialization files used in Microsoft Windows 3.1 and Windows for Workgroups that store configuration information about hardware, devices, and services on the computer. These text files, which have the extension .ini, include

  • WIN.INI, which stores information about the desktop environment, fonts, and printers, as well as other settings

  • SYSTEM.INI, which stores boot settings and information specific to running in Standard and 386 Enhanced modes

  • CONTROL.INI, which maintains the Windows color schemes

  • PROGMAN.INI, which stores information about program groups

  • WINFILE.INI, which stores status information for File Manager

In addition, individual applications often create their own INI files during installation to store application-specific settings.

NOTE

Instead of using INI files, Windows 95, Windows 98, Windows NT, and Windows 2000 store all configuration settings in the registry. Most of these files are also included in these operating systems to provide backward compatibility for running 16-bit Windows programs, because such programs were designed to save their settings in INI files and cannot access the registry.

instance

A particular occurrence of a Microsoft Windows NT Performance Monitor (System Monitor in Windows 2000) counter. For example, if the %Privileged Time counter is being monitored for the Processor object on a symmetric multiprocessing (SMP) machine with four processors, individual instances of that counter are instances 0, 1, 2, and 3. By using instances, you can monitor the performance of processes, threads, and devices on a per-instance basis for detailed understanding of their resource use on a machine. Individual instances of a given counter can be displayed in the usual way using charts and graphs.

instant messaging

An Internet technology for sending short messages to other users who are online. The concept of instant messaging started in early networked UNIX environments; users who were logged on could use commands such as talk, write, and finger to determine who else was logged on and to send them messages. However, the term “instant messaging” now generally applies to a technology popularized by America Online (AOL) and supported by Microsoft and other companies.

How It Works

AOL users can send instant messages to other AOL users online by using client software called AOL Instant Messenger (AIM). To use AIM, a user signs on at an AOL central server, indicating that he or she is online and can receive instant messages from other users. The central server records the user’s IP address for that session. (The user’s IP address is assigned by Dynamic Host Configuration Protocol [DHCP] and can vary from session to session.) Other users can then send instant messages to that user via the server. The user’s AIM client sends the server a copy of the user’s “buddy list” (a list of other users that he or she frequently exchanges messages with), and the server responds by telling the user which buddies are currently online and can receive messages. The user can select a buddy from the list and submit a message to the server, which forwards the message to the buddy.

Graphic I-2. The instant messaging system used by AOL.
Graphic I-2. The instant messaging system used by AOL.
NOTE

Microsoft has an instant messaging client called MSN Messenger Service. An Internet Engineering Task Force (IETF) working group is developing a standard for an Instant Messaging and Presence Protocol (IMPP) to make sure that instant messaging offerings from different vendors are fully compatible with each other. Microsoft plans to ensure that its instant messaging clients and servers support IMPP.

Institute of Electrical and Electronics Engineers (IEEE)

A worldwide nonprofit association of technical professionals that promotes the development of standards and acts as a catalyst for new technology in all aspects of the engineering industry, including computer networking, telecommunications, electric power, aerospace, and consumer electronics. The Institute of Electrical and Electronics Engineers (IEEE) has more than 330,000 individual members in 150 countries. Its activities include standards committees, technical publishing, and conferences.

A major contribution of the IEEE in the field of computer networking is Project 802, a collection of standards for local area network (LAN) architectures, protocols, and technologies. These standards continue to evolve under the auspices of various IEEE working groups and committees.

On the Web
•
IEEE home page
: http://www.ieee.org

integrated communications provider (ICP)

A telecommunications service provider that offers one-stop shopping for voice and data telecommunications through a single integrated architecture. Use of an integrated communications provider (ICP) can save companies a considerable amount of money compared to leasing the services separately from Regional Bell Operating Companies (RBOCs), competitive local exchange carriers (CLECs), or incumbent local exchange carriers (ILECs).

How It Works

The main difference between an ICP and a traditional carrier service provider is that an ICP generally installs a single, all-in-one integrated access device (IAD) at the customer premises that enables voice and data traffic to be serviced over a single line. This provides for easier management than using multiple lines with different technologies and devices. The IAD connects to the provider by using an Asynchronous Transfer Mode (ATM) connection over a single T1 line or Digital Subscriber Line (DSL) circuit at the local loop. (About 80 percent of the customer cost for ICP services is for the ICP’s rental of local loop access from an RBOC). At the provider end, many ICPs are building their own integrated ATM backbone networks so that they can better control the services they offer.

TIP

While the cost of using an ICP might be less than that of using an RBOC or a CLEC, the ICP might not offer some services, such as toll-free long distance and DSL services. You should also be sure that you understand how the various services are billed before you sign a contract.

Some ICPs use time-division multiplexing (TDM) to allow a single T1 line to carry voice, data, and video over 24 DS0 (Digital Signal Zero) channels. In this scenario, you might be paying for bandwidth that you are not using, because TDM dedicates slots of bandwidth to services whether or not data is being carried in these slots. You can generally get better value from ICPs that use ATM circuits between the subscriber and provider because ATM can use statistical multiplexing, which allocates bandwidth dynamically between voice and data. However, the disadvantage of the ATM approach is that if the line goes down, all voice and data transmission is interrupted, while with the TDM approach, customers might still have access to analog phone lines if such lines are used.

Graphic I-3. Integrated communications provider (ICP).
Graphic I-3. Integrated communications provider (ICP).

Integrated Services Digital Network (ISDN)

A digital communication service provided by telcos. Integrated Services Digital Network (ISDN) is an all-digital dial-up (on-demand) service that can simultaneously carry high-quality voice, data, and video transmissions over existing Plain Old Telephone Service (POTS) telephone wires of the subscriber’s local loop connection at speeds of 128 Kbps or higher. Even higher speeds can be reached using data compression.

How It Works

ISDN is supplied to the customer premises over standard POTS 4-wire twisted-pair wiring and uses time-division multiplexing (TDM) to send three channels of data (two B channels and one D channel) over a single communication line (two copper wires). Up to eight data terminal devices (such as computers, telephones, and fax machines) can be connected to a single ISDN line. You can set up different data rates based on your local telephone company’s services.

ISDN has its own framing or encapsulation format called V.120, which is the international standard for synchronous ISDN data stream framing. ISDN frames are 48 bits long and are transmitted at 4000 frames per second. Each ISDN frame contains two 8-bit slots for the B1 channel and two 8-bit slots for the B2 channel, which alternate with each other and with one 1-bit D channel slot after each B channel slot. Each B channel thus provides a data transfer rate of 2 x 8 bits x 4000 Hz = 64 Kbps, while the D channel has a bandwidth of 4 x 1 bits x 4000 Hz = 16 Kbps. The remainder of the frame is used for line balancing, echo detection, activation, and padding.

The two basic types of channels in an ISDN service are

  • B (bearer) channels, which are used for carrying either voice or data. The data transmission can be either packet-switched (such as X.25) or circuit-switched (telco) services. Each B channel in an ISDN service is completely separate, but you can use a protocol called Bandwidth On Demand Interoperability Group (bonding) to dynamically join the two B channels in a typical Basic Rate Interface ISDN (BRI-ISDN) service using inverse multiplexing to produce a single 128-Kbps data channel.

  • D (delta) channels, which are control channels for setting up connections and for other signaling purposes. For example, ISDN voice communication uses D channels to implement call forwarding and call display services. The D channel uses a completely separate telco communication network called the Signaling System 7, or SS7. This out-of-band telco network is used exclusively for system overhead signaling for ISDN and digital data service (DDS) services, and it makes possible the low latency of ISDN dial-up connections. For example, it takes only 1 to 2 seconds for an ISDN dial-up connection to be established, compared to 15 to 45 seconds for a typical analog modem. D channels can also be used to connect to an X.25 network.

The two most common ISDN interfaces or service types available from local carriers are

  • Basic Rate Interface (BRI), which consists of two 64-Kbps B channels and one 16-Kbps D channel. BRI is also referred to as 2B+D service. This is the most common configuration and provides up to 128 Kbps data throughput in dial-up connections to a switch or ISDN Private Branch Exchange (PBX) at the telco’s central office (CO).

  • Primary Rate Interface (PRI), which consists of twenty-three 64-Kbps B channels and one 64-Kbps D channel. PRI is also referred to as 23B+D service and is analogous to T1 services in carrying capacity.

ISDN lines terminate at the customer premises using an RJ-45 connector in a configuration called a U interface, which is usually connected to a Network Termination Unit (NTU). The NTU can then directly connect to special ISDN phones or network interface cards (NICs) in computers using the standard ISDN S/T interface. Alternatively, the U interface on the ISDN line can be connected directly to an ISDN terminal adapter, which interfaces the ISDN line with non-ISDN computer equipment and POTS telephones or fax machines. ISDN terminal adapters are sometimes called ISDN modems, but they are not really modems because ISDN is an end-to-end digital communication service.

Graphic G-4. Integrated Services Digital Network (ISDN).
Graphic G-4. Integrated Services Digital Network (ISDN).
NOTE

You can use the ISDN Configuration Wizard in Microsoft Windows 98 to configure your ISDN hardware. Some telcos provide only 56-Kbps B channels instead of 64 Kbps for ISDN, and ISDN is not always available in rural areas. ISDN charges usually include both monthly fees and usage charges per minute, although usage charges are sometimes waived.

TIP

Plug your ISDN network termination device into an uninterruptible power supply (UPS) so that you can use the phone during a power failure and so that your wide area network (WAN) link doesn’t go down. If you have a large company and expect a lot of local telephone calls within your organization, you can sometimes obtain a Centrex ISDN service in which local calls have no usage charges. The Windows NT, Windows 2000, Windows 98, and Windows 95 operating systems have built-in support for ISDN.

Tips for Troubleshooting ISDN
Problem | Suggestions
ISDN router or terminal adapter fails to dial | Check the cabling, the line signal, and the dialer map on the router.
Dial fails to go through on a BRI line | Be sure that you are using a straight-through RJ-45 cable. Check other cables, make sure the speed is set correctly to 56 or 64 Kbps as necessary, verify the phone number and service profile identifier (SPID) assigned by the service provider, and check the router hardware.
Dial fails to go through on a PRI line | Be sure that you are using a straight-through DB15 cable and that the speed is set correctly to 56 or 64 Kbps as necessary. Check the dialer map on the router, the phone number of the remote PRI, and the status lights and framing on the Channel Service Unit (CSU). Power-cycle the CSU.
Dial is successful but cannot ping the remote router | Check the Point-to-Point Protocol (PPP) configuration (if used). Check the routing table and add a static route if necessary. Check that the dialer map has the correct remote router specified, and have the telco check the remote router configuration.

Integrated Windows Authentication

See
Windows NT Challenge/Response Authentication

Intel-based platform

See
x86 platform

intelligent hub

A hub that is enabled for remote monitoring and management through Simple Network Management Protocol (SNMP). An intelligent hub contains Management Information Base (MIB) information that specifies which conditions can be monitored and which functions can be managed. These functions can include the following:

  • Setting alerts on problem conditions such as excessive collisions

  • Isolating and disconnecting problem computers

  • Providing network statistics to remote management consoles

Intelligent hubs are usually managed using in-band signaling methods, but they usually offer out-of-band management functions as well, such as being managed by a remote Telnet connection. Some stackable hubs have separate SNMP modules that you can purchase and install to provide manageability.

See also
hub

Intelligent Input/Output (I2O)

A hardware architecture developed by a consortium led by Intel that improves the input/output (I/O) performance of systems by relieving the central processing unit (CPU) of interrupt-intensive I/O tasks. Intelligent Input/Output (I2O) also provides a way of standardizing I/O device drivers across different operating systems and hardware platforms.

How It Works

I 2O makes use of a separate I2O processor such as the Intel i960 series of processors. This enables the CPU to offload interrupts received from peripherals to the I2O processor for handling. This scheme can improve the performance of servers by as much as 30 percent.

I2O also standardizes device drivers by dividing them into two components:

  • A Hardware Device Module (HDM), which directly interfaces with the peripheral being managed

  • An Operating System Service Module (OSM), which interfaces with the operating system on the machine

In addition, an intermediate layer between the HDM and OSM provides independence between them by providing standard communication mechanisms that allow any HDM for any peripheral to interoperate with any OSM for any operating system.

NOTE

The Windows 2000 operating system supports I2O.

On the Web
•
I2O Special Interest Group (SIG) home page
: http://www.i2osig.org

IntelliMirror

A set of management technologies native to Microsoft Windows 2000 that simplifies the task of configuring and maintaining applications, settings, and data at the client and server level. IntelliMirror provides a distributed replication service that lets clients and servers “intelligently mirror” and share information stored on local and distributed file systems. IntelliMirror mirrors the workstation environment on the network server so that the environment can be easily managed. IntelliMirror also offers full roaming support by allowing a user to log on to any client machine and access his or her software, settings, and data. IntelliMirror is designed to simplify network administration and eliminate the need for administrators to “visit” desktop clients to upgrade operating systems and applications.

IntelliMirror uses Remote Installation Services to enable authorized clients to download fully configured operating systems, applications, and data from remote servers, thus performing unattended installations on the clients. IntelliMirror technologies will significantly reduce the total cost of ownership (TCO) of PC-based networks.

Interactive

A built-in identity in Microsoft Windows 2000 and Windows NT that includes any user who has successfully logged on to the local server console. The operating system uses this group to enable the user who is logged on locally to access resources on the computer. The name “Interactive” stems from the idea that the user who belongs to this group is “interacting” with the local computer through the console.

As with all system groups, administrators cannot directly modify membership in the Interactive group or the rights of the Interactive group.

See also
built-in identities

interactive logon

A logon process whereby the user gains access to the network by entering a username and password in response to a dialog box on the local console. This is in contrast to a remote logon, which occurs when a user who is already logged on locally tries to make a network connection to a remote computer—for example, using the net use command at the command prompt. Interactive logons are supported by all versions of Microsoft Windows.

In a Windows 2000 or Windows NT network, the information that the user must specify during an interactive logon depends on the network’s security model, as described in the following table. After successfully logging on interactively, the user is granted an access token that is assigned to the initial process created for him or her.

Required Logon Information for Security Models
Security Model | What the User Must Specify
Workgroup | Username and password
Domain | Username and password
Domain with a trust relationship trusting other domains | Username, password, and domain
NOTE

When trust relationships are configured between Windows 2000 and Windows NT domains, the interactive logon dialog box allows the user to select a logon domain—that is, the domain in which the user’s user account is located. In contrast, the Windows 95 and Windows 98 logon domains are hard-coded using Client for Microsoft Networks and offer only one domain to choose from at logon time.

See also
automatic logon

inter-exchange carrier (IXC)

A telco that mainly provides long-distance communication services. Inter-exchange carriers (IXCs) own or share the various high-bandwidth, fiber-optic trunk lines that cross the country and provide high-speed switched digital services for voice, data, and video communication. About 90 percent of the U.S. long-distance communication market is controlled by the IXCs AT&T, MCI WorldCom, and Sprint.

Local telephone service to subscribers is primarily the domain of local exchange carriers (LECs) such as the Regional Bell Operating Companies (RBOCs). However, the Telecommunications Act of 1996 has opened up the market so that LECs can compete in long-distance markets by leasing services from IXCs, and IXCs can compete in local markets by leasing local loop connections from LECs. Some companies have also gained access to each other’s services by merging. Other emerging competitors for IXCs are cable television companies, who have customer premises installations in most U.S. residences and who are upgrading their networks for bidirectional communication.

interface

In networking and communication, a standard or mechanism for transferring data from one device to another. An interface specifies the nature of the boundary between two devices and determines the procedures and protocols that make it possible for the devices to exchange data.

Graphic I-5. An example of an interface between DTE and DCE devices.
Graphic I-5. An example of an interface between DTE and DCE devices.

The two main types of networking and communication interfaces are as follows:

  • Serial interfaces, which transfer data one bit at a time. The most common serial interface is the RS-232 interface.

  • Parallel interfaces, which transfer data several bits at a time, usually one or more bytes at a time. The most common parallel interface is the one used for connecting printers to computers, which uses a female DB-25 or 36-pin Centronics connector.

The following table shows some common examples of serial interfaces used in networking. Serial interfaces are commonly used for connecting data terminal equipment (DTE), such as computers or routers, to data communications equipment (DCE), such as modems or CSU/DSUs (Channel Service Unit/Data Service Units).

Serial Interfaces for Networking
Serial Interface | Description
RS-232 | A common interface for communication over unbalanced lines. Uses DB-9 or DB-25 connectors.
RS-422/485 | For communication over balanced lines. More suitable than RS-232 for environments with significant electromagnetic interference (EMI) or with DB-9 or DB-37 connectors.
V.35 | A high-speed serial interface for data transmission at 48 Kbps. Combines balanced lines with unbalanced lines and is used in Integrated Services Digital Network (ISDN) and frame relay connections. Uses a 24-pin block connector.
X.21 | A high-speed serial interface that uses the International Telecommunication Union (ITU) standard for connecting DCE and DTE for synchronous communication. Uses a DB-15 connector.
NOTE

The type of interface a device uses is related to the kind of connector or cable used to connect to the device, but not in a one-to-one fashion. For example, you could say that a device has an RS-232 serial interface, but it is incorrect to say that you use an RS-232 connector or an RS-232 cable to connect to that device. RS-232 specifies the interface, but several cabling options can support it, such as a cable terminated with a DB-9 or a DB-25 male connector.

The term “interface” is also used in routing terminology, in which it describes the connection between a router and an attached network.

See also
connector (device)

interface card

Any card that you plug into the motherboard of a computer to support connectivity between the main system bus and the external serial or parallel bus. Computers usually come with installed serial/parallel interface cards for connecting modems, printers, and other devices to your system, but in certain situations you might want to purchase a separate interface card. These situations include

  • When you have an older computer whose serial interface card cannot support the newer fast 56-Kbps V.90 modems or whose parallel interface card cannot support IEEE 1284 bidirectional print devices such as the newer Hewlett Packard LaserJet print devices

  • When you need a different serial interface such as RS-422/485 to connect your machine to special networking or industrial measurement equipment

Many different kinds of interface cards are available, including the following:

  • RS-232 high-speed serial input/output (I/O) cards with 16550 universal asynchronous receiver-transmitter (UART) chips for connecting to high-speed modems and Integrated Services Digital Network (ISDN) terminal adapters. These cards can be either Industry Standard Architecture (ISA) or Peripheral Component Interconnect (PCI) bus cards and can support transfer speeds of up to 460.8 Kbps—much higher than the 115.2-Kbps rate supported by standard RS-232 interfaces.

  • Enhanced Capabilities Port (ECP)/Enhanced Parallel Port (EPP) high-speed parallel I/O cards that support up to 2.5-Mbps transfer speeds.

  • RS-422/485 interface cards for connecting to industrial sensor and measuring equipment. These cards can support up to 31 separate devices that can be located up to 4000 feet from the computer. Data transfer speeds are up to 460.8 Kbps.

interface converter

Any device that converts one hardware interface to another. These devices are generally stand-alone, powered devices for midline use or rack-mounted devices for use in wiring closets. There are interface converters for serial and parallel interfaces, asynchronous and synchronous communication, half-duplex and full-duplex communication, single-node and host converters, copper and fiber-optic converters, AC-powered or interface-powered devices, and so on. Examples of interface converters include the following:

Graphic I-6. A network that uses an interface converter to convert between RS-232 and V.35.
Graphic I-6. A network that uses an interface converter to convert between RS-232 and V.35.

  • RS-232 to RS-422 serial interface converters for directly connecting the RS-232 serial interface of a computer to an RS-422 programmable logic controller for synchronous data transmission. If handshaking is required, you should use an RS-232 to RS-422/449 serial interface converter instead.

  • RS-232 to RS-422/485 serial interface converters that allow RS-422/485 data collection equipment or industrial measurement devices to be connected to a computer using its built-in RS-232 serial interface. Alternatively, you can install an interface card in the computer to allow it to connect directly with the RS-422/485 device.

  • RS-232 to V.35 serial interface converters for connecting RS-232 devices to V.35 lines.

  • V.35 to G.703 or X.21 serial interface connectors for use in Europe.

  • Small Computer System Interface (SCSI) to parallel converter for connecting SCSI peripherals to an Enhanced Capabilities Port (ECP)/Enhanced Parallel Port (EPP) parallel port.

interference

See
electromagnetic interference (EMI)

Interior Gateway Protocol (IGP)

A type of routing protocol used for distributing routing information within autonomous systems in large internetworks based on the TCP/IP protocol (such as the Internet).

How It Works

Interior Gateway Protocols (IGPs) specify how routers within an autonomous system (AS) exchange routing information with other routers within the same autonomous system. This is in contrast to Exterior Gateway Protocols (EGPs), which facilitate the exchange of routing information between different autonomous systems.

Examples of IGPs for TCP/IP internetworks include the following:

  • Routing Information Protocol (RIP) for Internet Protocol (IP), which is based on the distance-vector algorithm. RIP is a popular protocol for small to medium-sized internetworks.

  • Open Shortest Path First (OSPF) Protocol, which is based on the link-state algorithm. OSPF is used mainly on medium to large-sized internetworks.

  • Interior Gateway Routing Protocol (IGRP), a distance-vector protocol developed by Cisco Systems.

Graphic I-7. A network using IGP to route information within an autonomous system and EGP to route information between autonomous systems.
Graphic I-7. A network using IGP to route information within an autonomous system and EGP to route information between autonomous systems.
NOTE

Microsoft Windows NT version 4 with the Routing and Remote Access Service (RRAS) installed and Windows 2000 with Routing and Remote Access installed support RIP for IP and for OSPF.

intermediary device

Any networking device positioned between a Remote Access Service (RAS) server and a RAS client. Intermediary devices are third-party devices for performing security-related tasks such as authentication, encryption, and other functions. RAS on Microsoft Windows NT Server and on Windows 2000 Server supports intermediary devices.

How It Works

An intermediary device such as a security host can be positioned between a RAS server and its modem pool. Clients connecting to the modem pool must be authenticated by the security host before they can establish a connection with the RAS server. The security host thus provides an extra layer of security for remote access to the network. The security host might prompt the user for credentials, or the user might be required to use a security card to gain access to the network.

Graphic I-8. A security host as an intermediary device between a RAS server and a client.
Graphic I-8. A security host as an intermediary device between a RAS server and a client.
TIP

Once you have configured RAS on Windows NT Server to work with intermediary devices such as third-party security hosts, you must then configure the client to work with the device. You can typically do this by activating terminal mode on the client so that it can respond to the special prompts issued by the device.

International Mobile Telecommunications-2000 (IMT-2000)

An initiative of the International Telecommunication Union (ITU) to create a global standard for wireless data networks. The goal of International Mobile Telecommunications-2000 (IMT-2000) is to support data transmission rates of up to 2 Mbps for fixed stations and 384 Kbps for mobile stations. Note that the “2000” in the term “International Mobile Telecommunications-2000” refers to the transmission speed (approximately 2000 Kbps), not the deployment date (which might be several years beyond the year 2000).

IMT-2000 consists of several sets of standards, including the following:

  • CDMA2000:
    A proposed hardware upgrade to the existing Code Division Multiple Access (CDMA) cellular phone systems used in the United States and in some parts of Asia

  • W-CDMA:
    A proposed upgrade to Global System for Mobile Communications (GSM) networks that provides an alternative air interface to CDMA2000 for upgraded CDMA systems in Europe and Japan

  • Universal Mobile Telecommunications System (UMTS):
    A standard for 3G (third-generation) wireless networks proposed by the European Telecommunications Standards Institute (ETSI)

  • Universal Wireless Communications (UWC-136):
    A standard for 3G wireless networks proposed by the Telecommunications Industry Association (TIA)

Because of the fundamental inoperability between the two major types of cellular communication technologies—Time Division Multiple Access (TDMA) and CDMA—the ITU hopes that this initiative will unify wireless mobile communication worldwide by upgrading both TDMA and CDMA systems to a single global standard. However, the IMT-2000 initiative will not immediately result in a single worldwide air interface for wireless communication.

The upgrade for CDMA bearers will be simpler and will move them directly from the current IS-95a standard called CDMAone (the brand name used by the vendor consortium called the CDMA Development Group for existing data transmission at 16 Kbps) to the proposed CDMA2000. The upgrade for TDMA bearers can take several different paths—for example, from TDMA to General Packet Radio Service (GPRS) to Enhanced Data Rates for Global Evolution (EDGE) to UMTS. Some industry watchers predict that GPRS and IMT-2000 will be widely adopted worldwide in the next five years, which will give Europe and Asia an edge in high-speed wireless data communication over the United States, where as many as five competing systems might be deployed widely.

NOTE

3G wireless communication systems are those that provide transmission quality similar to Integrated Services Digital Network (ISDN) phone systems. First-generation systems are the analog cellular phone systems such as the Advanced Mobile Phone Service (AMPS) in North America, and second-generation systems are widely used digital cellular phone systems such as the Digital Advanced Mobile Phone Service (D-AMPS), CDMA systems, TDMA systems, and GSM.

On the Web
•
IMT-2000 home page
: http://www.itu.int/imt/
See also
CDMA2000, Universal Mobile Telecommunications System (UMTS), Universal Wireless Communications (UWC-136)

International Organization for Standardization (ISO)

A nongovernmental organization based in Geneva, Switzerland, that has representatives from about 130 countries and is responsible for developing a variety of international standards in science and engineering. The International Organization for Standardization (ISO), established in 1947, runs almost 3000 different working groups and committees covering a broad range of standards issues. The ISO’s goals are to develop cooperation in scientific, technological, intellectual, and economic activities and to facilitate the international exchange of goods and services. The ISO includes member agencies in more than 30 countries. These member agencies include the American National Standards Institute (ANSI) and the European Computer Manufacturers Association (ECMA).

ISO standards include the following:

  • Open Systems Interconnection (OSI) reference model for networking

  • ISO/IEC SQL-92 standard for the transact-SQL language

  • ISO codes for photographic film speeds

  • ISO 9000 framework for business-management and quality-assurance standards

  • ISO 216 international standard paper sizes

  • Standards for telephone and bank cards

  • ISO international country codes and currency codes

TIP

If you plan to modify the schema of Active Directory for Microsoft Windows 2000 and create new classes or attributes, you must obtain a unique object identifier for your enterprise to ensure that your new classes and attributes do not conflict with those defined by other directory services. This is especially important in a heterogeneous networking environment with multiple interoperating directory services such as Active Directory, Novell Directory Services (NDS), an X.500-based directory service, or Simple Network Management Protocol (SNMP). You can contact the ISO to receive an object identifier for your organization and then subdivide your object identifier space as you desire and assign object identifiers to your new classes and attributes.

International Telecommunication Union (ITU)

An international organization headquartered in Geneva, Switzerland, that coordinates global telecommunications networks and services with governments and the private sector. Known until 1993 as the International Telegraph and Telephone Consultative Committee (CCITT), the International Telecommunication Union (ITU) is responsible for a number of important international networking and communication standards, including the following X series and V series standards:

  • X.25 packet-switching network standard

  • V.90 56-Kbps modem standard

  • X.400 message-handling system (MHS) standard

  • X.435 standard for electronic data interchange (EDI) over X.400

  • X.500 directory service recommendations

  • X.509 digital certificate and authentication standard

The ITU also hosts important study groups, meetings, and conferences and is a leading publisher of information on telecommunications technology and standards. The section of the ITU that is concerned with developing international standards for telecommunications is called the ITU Telecommunications Standardization Sector, or ITU-T.

On the Web
•
ITU home page
: http://www.itu.int

Internet

The global TCP/IP public internetwork that originated in the ARPANET project of the U.S. Department of Defense in the 1970s. The original purpose of ARPANET was to create a wide area network (WAN) that would allow researchers at various defense and civilian research agencies to communicate with each other and to collaborate on projects. When ARPANET grew larger and an increasing number of civilian agencies such as universities and networking companies wanted access to it, administration of the network (now called the Internet) was given to the National Science Foundation (NSF) and then to Internet Network Information Center (InterNIC).

The backbone networks that make up the Internet are owned and managed by private companies, including MCI WorldCom and Sprint. These companies often share physical lines and often lease lines from Regional Bell Operating Companies (RBOCs). Backbone lines on the Internet are linked at points called Network Access Points (NAPs), where Internet service providers (ISPs) can exchange traffic. Examples of NAPs include MCI WorldCom’s “MAE West” NAP in San Jose, California, and the company’s “MAE East” NAP in Washington, D.C. An ISP leases a point of presence (POP) connection to a backbone’s network in order to supply individual users and companies with Internet services. See the Web link in this entry for topological and descriptive views of the architecture of the Internet.

The Internet is not owned by any one group; it is a collection of networks and gateways that run a common TCP/IP protocol and that all evolved from ARPANET. Nevertheless, various administrative bodies oversee various aspects of the Internet. These groups include the following:

  • Internet Society (ISOC), which coordinates a number of other bodies and gives advice and direction to them.

  • Internet Architecture Board (IAB), which is responsible to the ISOC and oversees the architecture of the Internet.

  • Internet Engineering Task Force (IETF), which is responsible to the IAB and develops Internet protocols that define the TCP/IP protocol suite, the Domain Name System (DNS), and so on.

  • Internet Assigned Numbers Authority (IANA), which is soon to be replaced by the Internet Corporation for Assigned Names and Numbers (ICANN). IANA is responsible for coordinating the registration of DNS names and assigning IP addresses.

Although a large number of Internet protocols currently support applications for users of the Internet, these services are constantly evolving, and many are rapidly disappearing as new services emerge. By far the most popular business uses of the Internet are the World Wide Web (WWW) and e-mail. Usenet newsgroups and Internet Relay Chat (IRC) are also popular.

On the Web
•
Atlas of Cyberspaces
: http://www.cybergeography.org/atlas/atlas.html

Internet2

A project of the University Corporation for Advanced Internet Development (UCAID) to develop a high-speed network for research and collaboration and for developing innovative applications for education. Internet2 is supported by more than 150 universities in the United States.

The Internet2 project is designed to create a leading-edge network for developing and testing new Internet applications for researchers. Its members consist of a collection of national, regional, and campus organizations whose networks are linked by new technologies and common research goals. Internet2 is not a successor to the present Internet, but rather new technologies to be used as part of the Internet. Internet2 is being developed by a consortium of institutions working to improve on existing Internet technologies. The knowledge and new technologies developed using Internet2 will be made available to the broader Internet community as they emerge.

Some of the potential benefits of new Internet technologies include advances in areas such as telemedicine, digital libraries, and virtual laboratories. Internet2 will also provide researchers with a test bed for developing new networking technologies, such as the following:

  • Broadband networking

  • Quality of service (QoS) networking technologies

  • IPv6, the new 128-bit version of the Internet protocol

  • Multicasting technologies

NOTE

Other groups are working toward similar goals in cooperation with Internet2. Examples include the federally led NGI (Next Generation Internet) initiative, the National Science Foundation’s High Performance Connections program, and the MCI WorldCom vBNS network service.

On the Web
•
Internet2 home page
: http://www.internet2.edu

Internet Architecture Board (IAB)

A technical advisory group for the Internet Society (ISOC). The Internet Architecture Board (IAB) oversees the evolution of Internet protocols and standards. It was established in 1983 and currently consists of 13 voting members, 6 of whom are nominated by the Internet Engineering Task Force (IETF) and approved by the ISOC. IAB members are part-time volunteers who provide the IETF community with advice and support. The IAB’s functions include the following:

  • Overseeing the evolution of protocols for the architecture of the Internet

  • Overseeing the process for developing Internet standards and for managing and publishing the Request for Comments (RFC) series of standards documents

  • Providing guidance to the ISOC on technical and procedural matters relating to the Internet

  • Selecting and appointing the chair of the IETF and candidates for the Internet Engineering Steering Group (IESG) and the Internet Assigned Numbers Authority (IANA)

On the Web
•
IAB home page
: http://www.iab.org

Internet Assigned Numbers Authority (IANA)

A U.S. government–funded organization that coordinates the assignment of unique Internet protocol parameters such as the IP address space and the Domain Name System (DNS). The Internet Assigned Numbers Authority (IANA) also delegates authority to other organizations and companies to grant users unique IP address blocks and register domain names. IANA is the ultimate authority for managing the root name servers that maintain the central database of information for the DNS. IANA also controls the assignment of TCP/IP protocol identifiers and numbers for autonomous systems on the Internet.

IANA operates under the auspices of the Internet Society (ISOC). It is also considered part of the Internet Architecture Board (IAB). IANA delegates the responsibilities for managing IP and DNS space to three regional bodies:

  • The American Registry for Internet Numbers (ARIN), which manages North America, South America, and sub-Saharan Africa

  • Réeseaux IP Européens (RIPE), which manages Europe and North Africa

  • The Asia Pacific Network Information Center (APNIC), which manages Asia and Australia

A new international nonprofit organization called the Internet Corporation for Assigned Names and Numbers (ICANN) will eventually take over the responsibilities of IANA because of the increasingly international and commercial nature of the Internet. ICANN will open up the registration and management of the DNS to commercial companies.

NOTE

Actual registration of IP addresses and DNS names is performed by network information centers, of which there are currently four in the United States:

  • Internet Network Information Center (InterNIC), which has exclusive authority over registering .com, .org, .net, .gov, and .edu top-level domains

  • The U.S. Domain Registration Service, which administers the .us top-level domain

  • The U.S. Department of Defense Network Information Center, which manages the .mil top-level domain

  • The .int top-level domain registry in Marina del Ray, California

On the Web
•
IANA home page
: http://www.iana.org

Internet Authentication Service (IAS)

A service included with Internet Connection Services for Microsoft Remote Access Service (RAS) that ships with Microsoft Windows NT 4.0 Option Pack and Microsoft Windows 2000. The Internet Authentication Service (IAS) provides authentication and authorization services for remote users who connect to their corporate network. System administrators can also use IAS to monitor connection usage for corporate accounting and billing purposes. IAS can record each authentication request and response, client logon time, client logoff time, and connection speed. This information can be stored and transferred to a database.

Graphic I-9. Internet Authentication Service (IAS).
Graphic I-9. Internet Authentication Service (IAS).
How It Works

IAS uses the Remote Authentication Dial-In User Service (RADIUS) protocol, which allows a network access server (NAS) to forward requests for authentication over the Internet. In a typical implementation, a remote user dials in to a NAS at the user’s Internet service provider (ISP) using the Point-to-Point Protocol (PPP). The NAS receives the authentication request packets from the remote user, packages them into RADIUS packets, and forwards them to an IAS server on the private corporate network. The IAS server maintains the actual database of users who are allowed to log on to the company network remotely or uses the Security Accounts Manager (SAM) database on a corporate domain controller. Communication between the NAS and IAS servers involves a unique password called a “shared secret,” which secures the exchange of information between them and guarantees its integrity. If the user is authenticated by the IAS server, a packet is sent to the NAS to indicate this, and the NAS allows the user to establish a remote connection to the private corporate network.

IAS supports the Password Authentication Protocol (PAP), Challenge Handshake Authentication Protocol (CHAP), and Microsoft Challenge Handshake Authentication Protocol (MS-CHAP) methods for authentication through PPP.

Internet Cache Protocol (ICP)

A protocol developed in 1995 to allow arrays of proxy servers to communicate and work together over a network. Internet Cache Protocol (ICP) lets individual proxy servers query neighboring proxy servers to try to locate cached copies of requested objects. If these queries fail, the object is requested from the Internet. ICP has some inherent drawbacks:

  • ICP arrays use queries to determine the location of cached information, a process that generates additional network traffic.

  • ICP arrays have negative scalability—the more proxy servers in the array, the more query traffic is generated.

  • ICP arrays tend to become highly redundant, with each cache containing similar information (the URLs of the most frequently visited sites).

Microsoft’s solution to these problems is the Caching Array Routing Protocol (CARP), which it developed for Microsoft Proxy Server version 2.

Internet Connection Services for Microsoft Remote Access Service (RAS)

A Microsoft Windows NT Option Pack add-on for Windows NT that corporations and Internet service providers (ISPs) can use to build comprehensive Internet access solutions such as dial-up virtual private networks (VPNs). Internet Connection Services for Microsoft Remote Access Service (RAS) can provide subscribers with seamless connections, global dial-up, and secure communication over the Internet to private networks. Internet Connection Services for RAS consists of three components:

  • Connection Manager Administration Kit (CMAK), which is used to configure Microsoft Connection Manager (CM)

  • Connection Point Services (CPS), which administrators can use to centrally manage network access phone book distribution

  • Internet Authentication Service (IAS), which allows users to be authenticated by the Windows NT Security Accounts Manager (SAM) database using the Remote Authentication Dial-In User Service (RADIUS) protocol

Using Internet Connection Services for RAS, you can

  • Provide secure remote access to a corporate private network using a Windows NT–based server that has Point-to-Point Tunneling Protocol (PPTP) enabled

  • Provide a seamless connection experience for users connecting to the Internet or a VPN

  • Provide global dial-up networking services

  • Administer access to network access servers from a central location using RADIUS

Internet Connection Wizard

A wizard included with Microsoft Windows and Microsoft Internet Explorer that makes it easy for users to connect their computers to the Internet. If you do not yet have an account with an Internet service provider (ISP), you can use the Internet Connection Wizard to select an ISP, sign up, and configure your computer for a new Internet account via modem. If you already have an account, the wizard can help you configure your account so that you can connect through a modem or a local area network (LAN).

Graphic I-10. Internet Connection Wizard.
Graphic I-10. Internet Connection Wizard.

For Internet Explorer 5.0, the Internet Connection Wizard is by default located in the Communications program group. From the Start menu choose Accessories, Communications, and then Internet Connection Wizard.

Internet Control Message Protocol (ICMP)

A TCP/IP network layer protocol used by routers and TCP/IP hosts for building and maintaining routing tables, adjusting data flow rates, and reporting errors and control messages for TCP/IP network communication. Internet Control Message Protocol (ICMP) is defined in Request for Comments (RFC) 792.

How It Works

ICMP uses connectionless Internet Protocol (IP) datagrams of various types for communicating control messages between hosts and routers on a TCP/IP network. The more common ICMP packets include the following:

  • Echo Reply (ICMP type 0):
    The ping command uses this packet type to test TCP/IP connectivity.

  • Destination Unreachable (ICMP type 3):
    Indicates that the destination network, host, or port cannot be reached.

  • Source Quench (ICMP type 4):
    Routers send this packet type when they cannot process IP traffic as fast as it is sent. A Source Quench message essentially means, “Slow down!” A Microsoft Windows NT or Windows 2000 host can respond to a Source Quench message by slowing down its rate of data transmission.

  • Redirect Message (ICMP type 5):
    Used to redirect the host to a different network path. This message essentially tells the router to override the entry in its internal routing table for this packet.

  • Echo Request (ICMP type 8):
    The ping command uses this packet type to test TCP/IP connectivity.

  • Time Exceeded (ICMP type 11):
    Indicates that the Time to Live (TTL) has been exceeded because of too many hops. The tracert command uses this message to test a series of routers between the local and remote hosts.

NOTE

When a multihomed machine running Windows NT is used as a router, it does not send Source Quench messages to the transmitting hosts if data is being received too quickly. Instead, it simply discards packets that can’t be buffered and processed.

TIP

ICMP redirects can modify a router’s routing table, so sometimes hackers try to subvert routers by issuing forged ICMP redirects in order to perform a denial of service attack. ICMP redirects are usually sent by routers only if all the following conditions occur:

  • The router is configured to generate ICMP redirects.

  • The incoming router interface for the packet is the same as the outgoing router interface.

  • The subnet of the source IP address is identical to the next-hop IP address.

  • The IP datagram is not source routed.

Internet Corporation for Assigned Names and Numbers (ICANN)

A nonprofit corporation that will take over the functions of the Internet Assigned Numbers Authority (IANA) and some other Internet-management organizations. The Internet Corporation for Assigned Names and Numbers (ICANN) will be responsible for such functions as

  • Allocating portions of the IP address space

  • Managing the Domain Name System (DNS), including developing new top-level domains and managing root name servers

  • Assigning Internet Protocol (IP) parameters

Until now, the U.S. company Network Solutions has exclusively managed the registration of domain names and has maintained the DNS database. ICANN will open up the process and allow competition in the DNS registration arena by creating guidelines for determining the following:

  • Who can function as a domain name registry

  • Policies on fees and privacy rights for domain name registries

  • How disputes will be resolved between domain name registries

  • What new top-level domain names will be allowed

On the Web
•
ICANN home page
: http://www.icann.org
•
ICANNWatch
: http://www.icannwatch.com

Internet Database Connector (IDC)

A Microsoft technology for linking database content to Web pages that predates the development of Microsoft Active Server Pages (ASP) technology. The Internet Database Connector (IDC) is typically used on Internet Information Services (IIS) to allow clients to use Web browsers to access data stored in a Microsoft SQL Server database.

How It Works

The IDC is a legacy solution for enabling Web browsers to access, read, and modify information in databases, but it is still viable for small environments with limited requirements. The IDC provides excellent performance using open database connectivity (ODBC) versions 3 and later.

The IDC itself is implemented on IIS as an Internet Server API (ISAPI) dynamic-link library (DLL) called Httpodbc.dll that uses ODBC to gain access to SQL databases. To use IDC, you must create the following:

  • A query file (.idc file) that specifies the data source name (DSN) of the SQL database to be connected to, the username and password that the client Web browser should use to connect and log on to the database, the template file to be used for formatting the results, the particular Structured Query Language (SQL) statements to be executed in the query, and so on.

  • A template or HTML Extension (HTX) file (.htx file) that specifies the Hypertext Markup Language (HTML) format in which database queries are to be returned to the client and that in effect creates the HTML results page from the result set of the SQL query that is performed.

TIP

Be sure that you have the DSN of the SQL database being accessed by the Internet Database Connector configured in ODBC as a System DSN, because the Internet Database Connector typically runs not as a user but as part of the operating system. Be sure that execute permissions are configured on the virtual directory where the .idc file is stored on IIS.

Internet Data Query (IDQ)

A text file with the extension .idq that defines the basic parameters for a Microsoft Index Server query. These parameters include the scope of the query and its restrictions (the words being searched for). The Internet Data Query (IDQ) file is the handler for the Hypertext Markup Language (HTML) query form used to issue the query. The result set generated by the IDQ file is formatted into HTML using an HTML Extension (HTX) file (.htx file) and returned to the user. Developing a query or search page for a Web site that can use Index Server involves creating three files:

  • The HTML form that presents the search page to the user

  • The IDQ form handler that executes the query

  • The HTX file that formats the results returned to the user

TIP

Although you can use Active Server Pages (ASP) scripting to issue and format Index Server queries, IDQ/HTX files offer better performance.

See also
HTML Extension (HTX)

Internet Engineering Task Force (IETF)

An international community of networking engineers, network administrators, researchers, and vendors whose goal is to ensure the smooth operation and evolution of the Internet. The Internet Engineering Task Force (IETF) receives its charter from the Internet Society (ISOC), and its daily operations are overseen by the Internet Architecture Board (IAB).

The work of the IETF is performed by a number of working groups who are dedicated to such aspects of the Internet as routing, operations and management, transport, security, applications, and user services. These working groups interact primarily through mailing lists and are managed by area directors who belong to the Internet Engineering Steering Group (IESG). Some working groups develop extensions and newer versions of familiar protocols such as Hypertext Transfer Protocol (HTTP), Lightweight Directory Access Protocol (LDAP), Network News Transfer Protocol (NNTP), Point-to-Point Protocol (PPP), and Simple Network Management Protocol (SNMP). Others develop new protocols such as the Common Indexing Protocol, Internet Open Trading Protocol, and the Internet Printing Protocol.

The working groups produce documents called Internet Drafts, which have a life span of six months, after which they must be deleted, updated, or established as a Request for Comments (RFC) document.

On the Web
•
IETF home page
: http://www.ietf.org

Internet Explorer

See
Microsoft Internet Explorer

Internet Explorer Administration Kit (IEAK)

A tool for preconfiguring and customizing Microsoft Internet Explorer version 4 and deploying it throughout an enterprise. The main component of the Internet Explorer Administration Kit (IEAK) is the IEAK Configuration Wizard, which is used to download, configure, and package Internet Explorer 4 components for distribution to users in the enterprise. Some of the features of the kit include

  • Automatic Version Synchronization (AVS) for notifying administrators when software updates for Internet Explorer 4 become available. Administrators can download these updates and distribute them to users.

  • Profile Manager for centrally managing user desktop settings after deployment of Internet Explorer 4.

  • Wizard-based configuration for determining which portions of Internet Explorer 4 will be deployed and how they will be configured.

The IEAK also supports deployment methods such as Microsoft Systems Management Server (SMS), e-mail, Web sites, floppy disks, and CDs.

How It Works

You first decide how you want to distribute your custom package for Internet Explorer: CD, floppy disks, or an Internet Uniform Resource Locator (URL) for users to download the package. You use the IEAK Configuration Wizard to build custom packages that include Internet Explorer, its related components, and up to 10 other custom components.

Once you create your package, you can distribute it using the appropriate method for the type of package: locate it on an Internet or file server, or give users copies of CDs or floppy disks. Users can then run the Setup program to install Internet Explorer and the additional components on their systems. You can also use the IEAK Configuration Wizard to do the following:

  • Create silent installation packages that don’t allow users to change the configuration settings you have specified.

  • Create branded packages that customize users’ browsers using a company-specific logo, title bar text, toolbar background bitmap image, or channel title bar for Internet Explorer.

  • Create packages with preconfigured browser settings such as a Start page, Search page, Support page, default favorites, welcome page, desktop wallpaper, Active Channels, and proxy settings.

Internet Group Management Protocol (IGMP)

A TCP/IP network layer protocol used for informing routers of the availability of multicast groups on the network.

How It Works

In a multicasting environment, Internet Group Management Protocol (IGMP) is used to exchange information on the status of membership in multicast groups between routers on the network. In other words, once a router becomes aware that there are hosts on a locally attached network that are members of a particular multicast group, it advertises this information to other routers on the internetwork so that multicast messages are forwarded to the appropriate routers.

To join a multicast group, a host must report its request for membership to nearby routers. These routers periodically poll the hosts in their locally attached networks to check on their membership status. When a host first joins a multicast group, it sends an IGMP message called a Host Membership Report that is directed to the multicast address 244.0.0.1 containing the multicast address that identifies the group it wants to join. Routers connected to that host’s local network then advertise to other routers throughout the internetwork that the particular network has hosts belonging to that multicast group. The routers poll the hosts regularly by sending Host Membership Query messages to determine whether any of them are still members of that group. If no hosts on the network belong to that group any longer, the router stops advertising the information to other routers on the internetwork so that multicast messages directed to that group are no longer forwarded to it.

NOTE

IGMP is used in Microsoft Windows NT and Windows 2000 only when the Windows Internet Naming Service (WINS) is installed. At startup, a WINS server sends IGMP packets to the multicast address 224.0.1.24 to seek out possible WINS replication partners on the network.

Internet guest account

See
IUSR_ComputerName

Internet Information Services (IIS)

The service integrated into the Microsoft Windows 2000 Server operating system platform that provides support for application-layer Internet protocols. In the earlier Windows NT Server platform, IIS stood for “Internet Information Server” and was an optional component of Windows NT Server. Internet Information Services (IIS) is also the foundational component for a wide variety of Microsoft Internet and intranet solution platforms, including Microsoft Site Server, Microsoft Commercial Internet System (MCIS), and other Microsoft BackOffice products.

IIS has evolved since it was first released for Windows NT 3.51 into its current version 5.0 for the Windows 2000 platform. The highest version available for the Windows NT platform is version 4.01, which was included as part of the Windows NT Option Pack. Both IIS versions 4.01 and 5.0 support the following features:

  • Fully integrated with Windows NT security and the version of NTFS used in Windows NT

  • Full support for version 1.1 of Hypertext Transfer Protocol (HTTP)

  • Support for File Transfer Protocol (FTP)

  • Limited support for Simple Mail Transfer Protocol (SMTP)

  • Support for Network News Transfer Protocol (NNTP)

  • Support for advanced security using the Secure Sockets Layer (SSL) and related protocols

  • Provides a platform for deploying scalable Web server applications using Active Server Pages (ASP); Internet Server API (ISAPI); Common Gateway Interface (CGI); Microsoft Visual Basic, Scripting Edition (VBScript); JScript; and other installable scripting languages such as Perl

  • Allows Web applications to be run as isolated processes in separate memory spaces to prevent one application crash from affecting other applications

  • Integrates with Microsoft Transaction Server (MTS) and Microsoft Message Queue (MSMQ) Server for deploying transaction-based Web applications

  • Can be managed using the Microsoft Management Console (MMC), through a standard Web browser such as Microsoft Internet Explorer, or by running administrative scripts using the Windows Scripting Host (WSH)

  • Includes domain blocking for allowing/granting access on the basis of IP address or domain

  • Allows IIS activity to be logged in various formats including IIS, World Wide Web Consortium (W3C), National Computer Security Association (NCSA), and open database connectivity (ODBC) logging

  • Allows Web site operators to be assigned for limited administration of each Web site

  • Bandwidth throttling to prevent one Web site from monopolizing a server’s available bandwidth

NOTE

IIS 4 offers only Microsoft Personal Web Server (PWS) for Windows NT Workstation, Windows 95, or Windows 98.

Internet Locator Service (ILS)

A Lightweight Directory Access Protocol (LDAP) directory service running on a server that lets users of Microsoft NetMeeting locate and contact other NetMeeting users to conference and collaborate over the Internet or over a private TCP/IP internetwork. The Internet Locator Service (ILS) replaces the earlier User Locator Service (ULS) technology.

How It Works

Microsoft Commercial Internet System (MCIS) has an ILS service that functions as a memory-resident database for storing dynamic directory information about NetMeeting users. This information, which includes a user’s name, company, and IP address, is stored in an Active Directory Global Catalog and can be accessed by any LDAP client, such as NetMeeting. Clients periodically refresh the information in the ILS database. Users can access the ILS using LDAP to place a call to other NetMeeting users and to determine which NetMeeting users are currently logged on to the ILS. Using Active Server Pages (ASP), you can design a customizable Web interface that displays who is currently online and allows users to search for other users and initiate NetMeeting sessions with them.

Internet Mail Access Protocol version 4 (IMAP4)

An Internet standard protocol for storing and retrieving messages from Simple Mail Transfer Protocol (SMTP) hosts. Internet Mail Access Protocol version 4 (IMAP4) provides functions similar to Post Office Protocol version 3 (POP3), with additional features as described in this entry.

How It Works

SMTP provides the underlying message transport mechanism for sending e-mail over the Internet, but it does not provide any facility for storing and retrieving messages. SMTP hosts must be continuously connected to one another, but most users do not have a dedicated connection to the Internet.

IMAP4 provides mechanisms for storing messages received by SMTP in a receptacle called a mailbox. An IMAP4 server stores messages received by each user until the user connects to download and read them using an IMAP4 client such as Microsoft Outlook 2000 or Microsoft Outlook Express.

IMAP4 includes a number of features that are not supported by POP3. Specifically, IMAP4 allows users to

  • Access multiple folders, including public folders

  • Create hierarchies of folders for storing messages

  • Leave messages on the server after reading them so that they can access the messages again from another location

  • Search a mailbox for a specific message to download

  • Flag messages as read

  • Selectively download portions of messages or attachments only

  • Review the headers of messages before downloading them

To retrieve a message from an IMAP4 server, an IMAP4 client first establishes a Transmission Control Protocol (TCP) session using TCP port 143. The client then identifies itself to the server and issues a series of IMAP4 commands:

  • LIST:
    Retrieves a list of folders in the client’s mailbox

  • SELECT:
    Selects a particular folder to access its messages

  • FETCH:
    Retrieves individual messages

  • LOGOUT:
    Ends the IMAP4 session

NOTE

IMAP4 is supported by Microsoft Exchange Server. Because IMAP4 clients can allow read messages to remain on the IMAP4 server, IMAP4 is especially useful for mobile users who dial up and access their mail from multiple locations. The downside is that IMAP4 servers require more resources than POP3 servers because users tend to leave large numbers of messages on the server.

TIP

To troubleshoot problems with remote IMAP4 servers, use Telnet to connect to port 143. Then try issuing various IMAP4 commands such as the ones described in this entry and examine the results.

Internet Mail Service

A component of Microsoft Exchange Server that enables Exchange to send and receive Simple Mail Transfer Protocol (SMTP) mail to foreign SMTP mail systems such as the Internet. Post Office Protocol version 3 (POP3) clients can use Internet Mail Service to send and receive e-mail.

Internet Mail Service can use the SMTP backbone of the Internet for connecting Exchange sites. Many sites have existing Internet connections that can be used for this purpose. One advantage of Internet Mail Service over Site Connector is that you can schedule Internet Mail Service to route messages at different times or intervals. One disadvantage is that this routing can produce a bottleneck because all messaging traffic flows through one server in each site.

Internet Network Information Center (InterNIC)

A cooperative venture between Network Solutions, Inc. (NSI) and the U.S. government. Network Solutions is the agency currently responsible for coordinating registration of domain names within the Domain Name System (DNS). Internet Network Information Center (InterNIC) is responsible for registering and maintaining the top-level domains .com, .edu, .net, .gov, and .org. InterNIC itself is a registered service mark of the U.S. Department of Commerce. InterNIC acts as both a registry that maintains a database of top-level domain information and a registrar that provides name registration services and other value-added services.

A new nonprofit agency called Internet Corporation for Assigned Names and Numbers (ICANN) will soon open up the registration and management of the DNS to companies other than NSI.

On the Web
•
InterNIC home page
: http://www.internic.net

Internet News Service

A component of Microsoft Exchange Server that enables Exchange users to access Usenet newsgroups as public folder content and make public folder content available as Usenet newsgroups. The Internet News Service governs newsgroup messaging between Exchange servers and Usenet hosts and enables Network News Transfer Protocol (NNTP) clients to download lists of newsgroups and read or post messages. It can also be used as a method for replicating public folder content between Exchange organizations.

TIP

If you plan to host Usenet newsgroups, be sure that you have adequate disk space to accommodate the large daily feed.

Internet Protocol (IP)

A TCP/IP network layer protocol for addressing and routing packets of data between hosts on a TCP/IP network. Internet Protocol (IP) is a connectionless protocol that provides best-effort delivery using packet-switching services.

How It Works

IP does not guarantee delivery of data. The responsibility for guaranteeing delivery and sending acknowledgments lies with the higher transport-level protocol Transmission Control Protocol (TCP).

The structure of an IP packet is shown in the following diagram. Some of the more important header fields include

  • Source IP address:
    The IP address of the host transmitting the packet.

  • Destination IP address:
    The IP address of the host to which the packet is being sent, a multicast group address, or the broadcast IP address 255.255.255.255.

  • Header checksum:
    A mathematical computation used for verifying that the packet was received intact.

  • Time to Live (TTL):
    The number of router hops that the packet can make before being discarded.

  • Fragment offset:
    The position of the fragment if the original IP packet has been fragmented (for example, by a router). This information enables the original packet to be reconstructed.

IP packets are routed in the following fashion:

  • If IP determines that the destination IP address is a local address, it transmits the packet directly to the destination host.

  • If IP determines that the destination IP address is a remote address, it examines the local routing table for a route to the destination host. If a route is found, it is used; if no route is found, IP forwards the packet to the default gateway. In either case, the packet destined for a remote address is usually sent to a router.

  • At the router, the TTL is decreased by 1 or more (depending on network congestion), and the packet might be fragmented into smaller packets if necessary. The router then determines whether to forward the packet to one of the router’s local network interfaces or to another router. This process repeats until the packet arrives at the destination host or has its TTL decremented to 0 (zero) and is discarded by a router.

    Graphic I-11. The structure of an IP packet.
    Graphic I-11. The structure of an IP packet.

Internet protocols

A term that generally refers to application-layer TCP/IP protocols commonly used over the Internet. The following table shows many of the standard Internet protocols in use today. Some of these protocols, such as Gopher, are rapidly waning in popularity. To access a protocol such as Hypertext Transfer Protocol (HTTP) with a Web browser such as Microsoft Internet Explorer, you would use a Uniform Resource Locator (URL) beginning with http://.

Standard Internet Protocols
Protocol | Protocol Name | Description
http | Hypertext Transfer Protocol | Used for Web pages that contain text, graphics, sound, and other digital information stored on a Web server on the World Wide Web
ftp | File Transfer Protocol | Transfers files between two computers over the Internet
gopher | Gopher protocol | Displays information stored on a network of Gopher servers
wais | WAIS protocol | Used for accessing a Wide Area Information Servers database
file | File protocol | Opens a file on a local hard disk or a network share
https | Secure Hypertext Transfer Protocol | Establishes an encrypted HTTP connection using the Secure Sockets Layer (SSL) protocol
mailto | MailTo protocol | Starts a Simple Mail Transfer Protocol (SMTP) e-mail program to send a message to the specified Internet e-mail address
news | News protocol | Opens a Network News Transfer Protocol (NNTP) newsreader and the specified Usenet newsgroup
nntp | Network News Transfer Protocol | Performs the same function as the News protocol
mid | Musical Instrument Digital Interface (MIDI) protocol | Plays MIDI sequencer files if the computer has a sound card
telnet | Telnet protocol | Starts a Telnet terminal emulation program
rlogin | Rlogin protocol | Starts an Rlogin terminal emulation program
tn3270 | TN3270 protocol | Starts a TN3270 terminal emulation program
pnm | RealAudio protocol | Plays RealAudio streaming audio from a RealAudio server
mms | Microsoft Media Server (MMS) protocol | Plays .asf streams from a Microsoft NetShow server

Internet Protocol Security (IPSec)

A protocol for negotiating and controlling the security of transmissions over a TCP/IP internetwork. Internet Protocol Security (IPSec) defines standards for data encryption and data integrity at the level of Internet Protocol (IP) datagrams and can be used to encrypt transmission of data and ensure that the data originated from the sender and was not modified in transit. IPSec encrypts data at the IP level and uses tunneling to securely send information over the Internet and between intranets. IPSec is an emerging Internet Engineering Task Force (IETF) standard and is implemented in the Microsoft Windows 2000 operating system.

How It Works

IPSec is implemented at the transport layer of the Open Systems Interconnection (OSI) reference model and protects IP and higher protocols using security policies that can be configured to meet the needs of securing users, sites, applications, or the enterprise in general. IPSec essentially resides as an additional layer under the TCP/IP protocol stack and is controlled by security policies installed on each machine and by an encryption scheme negotiated between the sender and the receiver. These security policies consist of a collection of filters with associated behaviors. When the IP address, port number, and protocol of an IP packet match a particular filter, the corresponding behavior is applied to the packet.

In Windows 2000, these security policies are created and assigned at the domain level or for individual hosts using the IPSec Management snap-in for the Microsoft Management Console (MMC). IPSec policies consist of rules that specify the security requirements for different forms of communication. These rules are used to initiate and control secure communication based on the nature of the IP traffic, the source of the traffic, and its destination. These rules specify authentication and negotiation methods, tunneling attributes, and connection types.

To establish a security association (secure communication session) between two computers, a protocol framework called ISAKMP/Oakley is used. ISAKMP/Oakley includes a set of cryptographic algorithms but is also extensible to support user-defined encryption algorithms. During the negotiation process, agreement is reached on the authentication and security methods to be used, and a shared key is generated for data encryption. IPSec supports two different kinds of security associations:

  • Authentication Header (AH) protocol:
    Provides user authentication and protection from replay attacks and supports data authentication and integrity functions. AH enables the recipient to be sure of the identity of the sender and that the data has not been modified during transmission. AH does not provide any encryption of the data itself. AH information is embedded in the IP packet’s header and can be used alone or with the Encapsulating Security Payload (ESP) protocol.

  • Encapsulating Security Payload (ESP) protocol:
    Encapsulates and encrypts user data to provide full data confidentiality. ESP also includes optional authentication and protections from replay attacks and can be used either by itself or with AH. ESP information is also embedded in the IP packet’s header.

Devices and software configured to support IPSec can use either public key encryption using keys supplied by certificate authorities (CAs) or preshared keys for private encryption.

Internet Relay Chat (IRC)

A technology for using the Internet to send real-time, text-based messages. Internet Relay Chat (IRC) is defined in Request for Comments (RFC) 1459.

How It Works

IRC is a client/server technology in which users employ IRC client software to connect to an IRC server or hub. Clients can then connect to an existing chat group (also called chat room or channel) and type messages to other users currently in that group. Chat groups are identified using a pound sign (#) prefix. Messages are transmitted in real time and can appear character by character on the recipients’ client software if the person sending the message types slowly enough.

Depending on how the chat server is configured, users might be able to create their own chat rooms and hold private discussions. Some chat servers require that you register once to obtain a unique nickname, while others allow you to select a nickname for the current session only. Some Web sites also offer Web-based interfaces to their chat servers.

Microsoft Exchange Server version 5.5 includes an IRC-based chat server that you can use to set up public or private IRC sites.

On the Web
•
IRC.NET
: http://www.irc.net

Internet Research Task Force (IRTF)

An umbrella organization for several long-term research groups that focus on standards for Internet protocols, architecture, applications, and technologies. Internet Research Task Force (IRTF) research groups include

  • The End-to-End (E2E) group, which is concerned with end-to-end services and protocols implemented in hosts

  • The Information Infrastructure Architecture group, which works to articulate a common information infrastructure for the Internet to support greater interoperability between applications

  • The Internet Resource Directory group, which develops models for resource description on the Internet, including mechanisms for querying, indexing, and retrieval

  • The Network Management group, which is concerned with issues relating to the management of the Internet from the perspectives of high-level management domains and customer-oriented services

  • The Services Management group, which is concerned with the convergence of networking technologies relating to the Internet

The IRTF is overseen by the Internet Architecture Board (IAB).

On the Web
•
IRTF home page
: http://www.irtf.org

Internet Server API (ISAPI)

A Microsoft set of standard application programming interfaces (APIs) for developing extensions to Internet Information Services (IIS). Internet Server API (ISAPI) provides developers with a powerful way to extend the functionality of IIS to provide better performance than Active Server Pages (ASP) or the Common Gateway Interface (CGI) and to provide low-level access to all Microsoft Win32 API functions. Of course, since ISAPI dynamic-link libraries (DLLs) are generally written in a high-level programming language such as C or C++, they are usually more difficult to develop than ASP-based or CGI-based solutions and might not scale as well.

There are two kinds of ISAPI DLLs, which have different uses on IIS:

  • ISAPI extensions:
    Run-time DLLs that can run either in process or out of process on IIS. ISAPI extensions provide extended functionality to IIS.

  • ISAPI filters:
    Used to preprocess packets of data before they enter or leave the IIS main process. An example of an ISAPI filter is the Secure Sockets Layer (SSL) protocol component on IIS 4.

TIP

You can create ISAPI extensions easily using the ISAPI Extension Wizard in Microsoft Visual C++.

Internet service provider (ISP)

A company that provides individual users and businesses with connectivity to the Internet. Internet service providers (ISPs) also provide clients with access to Internet services such as Web hosting, Simple Mail Transfer Protocol (SMTP) mail, Usenet newsgroups, Internet Relay Chat (IRC), and downloadable Internet software.

ISPs come in various shapes and sizes, from volunteer-run freenets to local, regional, and national service providers such as America Online. Many smaller ISPs, especially those that originated in a university environment, still use freely available software such as Linux, Apache’s Web server, and Sendmail for providing services to customers. Larger ISPs often use a heterogeneous network in which Internet Information Services (IIS) and Microsoft Exchange Server play an essential role by providing core Web and mail services, as well as support for advanced Web and e-commerce applications for business and corporate clients.

Internet services

Any of a number of technologies for making information accessible to users over the Internet. Each Internet service is defined by a protocol, such as Hypertext Transfer Protocol (HTTP), and is enabled using client/server applications, such as Web browsers and Web servers. Internet protocols are defined in the Request for Comments (RFC) documents published by the Internet Engineering Task Force (IETF).

Internet services include Telnet, File Transfer Protocol (FTP), Gopher, Wide Area Information Server (WAIS), Archie, Veronica, Simple Mail Transfer Protocol (SMTP), Network News Transfer Protocol (NNTP), and Internet Relay Chat (IRC). Some of these services have remained popular (such as NNTP), while others have faded in popularity (such as Gopher). The most popular Internet service by far is the relatively new World Wide Web (WWW), which is based on HTTP.

Internet Services Manager

The main administrative tool for Internet Information Services (IIS) on Microsoft Windows 2000 platforms. This tool is called Internet Service Manager in Windows NT. Internet Service Manager is implemented as a separate application in IIS versions 3.0 and earlier, but with IIS 4.0, it is implemented as a snap-in for the Microsoft Management Console (MMC). In IIS 5.0 on the Windows 2000 platform, this snap-in is simply called Internet Information Services, and its shortcut in the Administrative Tools program group is called Internet Services Manager.

Using Internet Services Manager, you can

  • Create and delete virtual servers (Web sites) and virtual directories

  • Configure the properties of virtual servers, virtual directories, and individual files

  • Create and configure File Transfer Protocol (FTP) sites

  • Configure the Simple Mail Transfer Protocol (SMTP) and Network News Transfer Protocol (NNTP) services

  • Configure security settings and levels

  • Start, stop, and pause virtual servers

Internet Society (ISOC)

A professional society founded in 1992 that provides leadership for the development and evolution of the Internet. The Internet Society (ISOC) comprises over 150 individual organizations, including government agencies and private companies, and is an umbrella organization for other Internet groups, including the Internet Engineering Task Force (IETF) and the Internet Architecture Board (IAB).

The ISOC has more than 6000 individual members in more than 100 countries. It is governed by a board of trustees elected from its membership. The ISOC hosts conferences and issues publications related to the development and management of the Internet. The ISOC has taken the lead in promoting the formation of a nonprofit constituency for the new Internet Corporation for Assigned Names and Numbers (ICANN), which oversees the Internet Domain Name System (DNS). The ISOC essentially functions as a legal umbrella for the standardization processes managed by the IETF and the IAB.

On the Web
•
ISOC home page
: http://www.isoc.org

internetwork

A network, usually TCP/IP, consisting of multiple networks joined by routers. More generally, an internetwork is any network consisting of smaller networks joined in any fashion using bridges, switches, routers, and other devices. For example, an Internet Protocol (IP) internetwork could consist of a mix of Microsoft Windows NT or Windows 2000 and UNIX machines distributed over different subnets, connected with standard IP routers from Cisco Systems or another vendor. An Internetwork Packet Exchange (IPX) internetwork could be a set of networks using Novell NetWare clients and servers running IPX that are connected using IPX-enabled routers.

Internetworking is the process of planning, implementing, and maintaining an internetwork. For IP internetworks, this involves such tasks as

  • Determining which IP address classes and network IDs to use

  • Dividing the internetwork into different subnets using a custom subnet mask

  • Managing host IP address information using the Dynamic Host Configuration Protocol (DHCP)

  • Configuring dynamic routers for efficient exchange of routing information

  • Acquiring tools and skills for troubleshooting internetwork problems

Internetwork Operating System (IOS)

An operating system developed by Cisco Systems for its line of routers and access servers to provide a standard way to configure these devices.

How It Works

The Internetwork Operating System (IOS) is usually stored as a system image within a router’s flash memory. The startup configuration file called startup-config is stored in nonvolatile RAM, and the actual operating configuration of the router (its routing tables, queues, and so on) are stored in ordinary RAM. Cisco routers can typically run in three different operating environments:

  • ROM monitor:
    Also called the bootstrap program, this environment is accessed through the console port. The ROM monitor initiates the bootstrap process and can be used to run diagnostics, recover lost passwords, and recover from system failures.

  • Boot ROM:
    This environment is used mainly to upgrade to new versions of IOS by loading a new image of IOS into flash memory.

  • Cisco IOS:
    This is the normal operating environment, in which you can enter commands to configure and troubleshoot the operation of your router. For example, you can enter the show version command to determine which version of IOS your router is running.

The normal IOS operating environment itself can run in four different modes:

  • User EXEC mode:
    This mode is enabled by default when you connect to a router using a command-line console (for example, using a Telnet connection). Using EXEC, the IOS system command interpreter, you can type commands using a command-line interface. User EXEC mode supports a subset of IOS commands for performing basic actions such as configuring terminal settings, running tests, and displaying configuration information.

  • Privileged EXEC mode:
    This mode lets you do everything you can do in User EXEC mode and more, including running the setup command to enter configuration information, running the configure command to modify configuration information, and running the debug command to display event messages. Enter Privileged EXEC mode by typing the enable command.

  • Configuration mode:
    This mode lets you configure your router’s settings. You enter this mode by typing the configure terminal command.

  • Setup mode:
    This mode is used to create new configuration files that enable features such as addressing, routing, and security.

NOTE

Although IOS was originally designed as a monolithic, “router-centric” operating system, it has evolved into a modular operating system composed of different subsystems that can easily be upgraded and that support complex distributed networking functions.

TIP

You can quickly tell which command mode of IOS you are running by looking at your command prompt. The following table shows the various IOS command modes.

Privileged EXEC mode should always be password protected because it lets you reconfigure key operating system parameters. Don’t run the debug command when you are connected to the network unless absolutely necessary because this increases the load on the processor. Type a question mark (?) at a prompt to determine which commands are available in the currently enabled IOS mode.

IOS Command Modes
Prompt | IOS Mode
Router> | User EXEC
Router# | Privileged EXEC
Router(config)# | Configuration
(A series of dialog box prompts) | Setup
On the Web
•
Cisco IOS Software
: http://www.cisco.com/warp/public/732/index.html

Internetwork Packet Exchange (IPX)

A Novell NetWare protocol used for routing packets from one network node to another throughout an internetwork. Internetwork Packet Exchange (IPX) is a network layer protocol and provides connectionless datagram services for Ethernet, Token Ring, and other common data-link layer protocols. IPX is the commonly used local area network (LAN) protocol on legacy NetWare-based LANs but has recently been replaced with TCP/IP for NetWare 5.x.

How It Works

IPX packets use 32-bit (4-byte) network numbers to uniquely identify each data link (connected network) in an IPX internetwork. The administrator of each network assigns these network numbers, which must be unique for each connected network; all nodes on a connected network must have the same network number. Nodes discover their network number by communicating with routers attached to the local network. Routers use these network numbers to route IPX packets from one network to another within an internetwork. IPX is thus a routable protocol. The structure of an IPX packet is shown in the following diagram.

IPX also uses 48-bit (6-byte) addresses for each node within a given network. An entire IPX network address is thus 4 + 6 = 10 bytes long. IPX packets are assigned a 16-bit (2-byte) socket number to identify the networking service they are communicating with—for example, Network Control Protocol (NCP), Service Advertising Protocol (SAP), or Routing Information Protocol (RIP). Thus, the following 12-byte triple completely identifies the networking service that a packet is communicating for:

{network number, node address, socket number}

When an IPX client is booted on a NetWare internetwork using IPX-enabled routers, the client broadcasts a Get Nearest Server (GSN) request message to its locally connected network in order to locate the nearest NetWare server. If a NetWare server can’t be located on the connected network, the router informs the client of the nearest available server based on the cost of the connection. The router is familiar with this information because NetWare servers using IPX periodically notify the network of their presence using SAP, which allows IPX routers to construct server tables based on SAP numbers.

Graphic I-12. The structure of an IPX packet.
Graphic I-12. The structure of an IPX packet.

IPX is a connectionless protocol that works at the network layer of the Open Systems Interconnection (OSI) reference model, and IPX packets are connectionless datagrams. To function within connected networks, IPX works with a transport layer protocol called the Sequenced Packet Exchange (SPX) protocol. SPX is responsible for generating acknowledgments for IPX packets received over the network to ensure that no packets were lost during transport.

TIP

On Ethernet networks, NetWare clients and servers can communicate with each other using IPX only if they use compatible frame types (encapsulation formats). The terminology used to describe these frame types depends on whether you’re discussing Novell NetWare clients and servers or IPX-enabled routers from Cisco Systems. The following table illustrates these differences.

Ethernet_II is the default frame type for NetWare version 3.x and earlier, while NetWare 4.x uses the Ethernet_802.2 frame type.

Frame Type Terminology
Common Terminology | Novell Terminology | Cisco Terminology
Ethernet | Ethernet_II | arpa
raw | Ethernet_802.3 | novell-ether
802.3 | Ethernet_802.2 | sap
snap | Ethernet_SNAP | snap

InterNIC

See
Internet Network Information Center (InterNIC)

interprocess communication (IPC)

A mechanism for establishing a connection between processes, running on two computers or on a single multitasking computer, to allow data to flow between those processes. Interprocess communication (IPC) mechanisms are commonly used in client/server environments and are supported to various degrees by the different Microsoft Windows operating systems.

How It Works

A networked IPC generally consists of the following two components:

  • An application programming interface (API) that defines the standard set of functions that can be called when software tries to use an IPC.

  • A protocol that specifies the format in which the information is transmitted using the IPC. When IPCs are passed over the network, the format specified is the format of the packet or frame transmitted between the computers.

The following table lists some IPC mechanisms and the platforms that support them.

IPC Mechanisms Supported on Windows Platforms
Process | Windows NT | Windows 95 | Windows 98 | Windows 2000
Named pipes | x | x | x | x
Mailslots | x | x | x | x
NetBIOS | x | x | x | x
Windows Sockets | x | x | x | x
Remote procedure call (RPC) | x | x | x | x
Network Dynamic Data Exchange (NetDDE) | x | x | x | x
Distributed Component Object Model (DCOM) | x |  | x | x

intranet

A private TCP/IP internetwork within an organization that uses Internet technologies such as Web servers and Web browsers for sharing information and collaborating. Intranets can be used to publish company policies and newsletters, provide sales and marketing staff with product information, provide technical support and tutorials, and just about anything else you can think of that fits within the standard Web server/Web browser environment.

Internet Information Services (IIS), with its support for Active Server Pages (ASP), is an ideal platform for building intranet applications that can be accessed using a standard Web browser such as Microsoft Internet Explorer.

inverse multiplexer (IMUX)

Also called an IMUX, a device that can perform inverse multiplexing of digital telecommunication channels. A typical IMUX might be capable of inverse multiplexing together four Basic Rate Interface ISDN (BRI-ISDN) lines, two T1 lines, or four T1 lines to provide a throughput of 512 Kbps or 5.888 Mbps, respectively. This saves the expense of having to purchase or lease equipment to individually terminate each Integrated Services Digital Network (ISDN) or T1 line, and it provides an efficient way to increase wide area network (WAN) speed for high-bandwidth uses such as videoconferencing, T1 backup, or large file transfers. IMUXes can include built-in CSU/DSU (Channel Service Unit/Data Service Unit) functionality, they have a 34-pin built-in V.35 LAN (data) interface, and they have an RJ-45 or DB25 connector for the line interface. They often feature load-sharing functions so that if one ISDN or T1 line goes down, no delays occur. IMUXes usually include diagnostic and loopback functions for both local and remote troubleshooting.

inverse multiplexing

A networking and telecommunications technique of combining the bandwidths of a number of digital lines into a single virtual pathway for high-speed communication. Inverse multiplexing is the opposite of multiplexing, which combines data transmissions from multiple pieces of data terminal equipment (DTE) into a single digital communication channel.

How It Works

You can connect a device called an inverse multiplexer, or IMUX, to the termination of several leased digital lines to create a single virtual connection with a bandwidth equal to the sum of the bandwidths of the individual lines. Inverse multiplexing can be used to aggregate the bandwidth of digital data service (DDS), switched 56, Integrated Services Digital Network (ISDN), or T1 and higher T-carrier services into a single high-bandwidth DTE interface. You can then connect this DTE interface to customer premises equipment such as routers or CSU/DSUs (Channel Service Unit/Data Service Units), which are connected to the customer’s network.

Graphic I-13. Inverse multiplexing.
Graphic I-13. Inverse multiplexing.

Inverse multiplexing requires an IMUX at both the customer premises and the telco central office (CO). When several ISDN subchannels are multiplexed into a single high-speed channel, a connection is initiated when the customer’s IMUX dials a number to establish a connection with the CO IMUX. Once a single ISDN subchannel is established, the customer IMUX dials the remaining numbers and establishes the additional ISDN subchannels. Once all the subchannels are up, a protocol called Bandwidth On Demand Interoperability Group (bonding) establishes synchronization between the two stations using a handshaking mechanism to resolve any delays between the subchannels. These delays are primarily the result of the different circuit-switched communication subchannels having physical paths of different lengths, even though they have the same two endpoints. The bonding protocols also ensure that data sent over each subchannel arrives at its destination in the correct order.

The main advantage of inverse multiplexing is that it is often less expensive to lease several low-speed digital lines and inverse multiplex them together than to lease a single high-speed digital line with the same aggregate bandwidth. Inverse multiplexing is also useful in areas where high-speed digital services such as T1 are not readily available.

See also
multiplexing

inverse query

A Domain Name System (DNS) query in which a resolver contacts a name server to perform a reverse name lookup, requesting a host name for a given IP address. An inverse query is the opposite of the usual DNS query—that is, given a host’s fully qualified domain name (FQDN), it determines the host’s IP address.

Because of the hierarchical structure of the namespace of the DNS, inverse queries normally have to search all domains to resolve the IP address. To circumvent this, a special domain called in-addr.arpa exists for reverse name lookups. The nodes in this domain are named after the IP addresses of hosts but with the octets in reverse order to facilitate searching. However, inverse queries can take place only on the name server queried and cannot be forwarded to another name server. Because individual name servers manage only a small portion of the entire DNS namespace, there is no guarantee that a given inverse query issued against a specific name server will meet with a successful response.

NOTE

Most names used on Internet servers are configured for reverse name lookups to avoid the extra overhead required. However, if you need to use the DNS troubleshooting utility nslookup, you should configure the in-addr.arpa domain on name servers to support inverse queries. Otherwise, there is no need to configure this inverse domain.

See also
iterative query, recursive query

I/O Manager

A component of Microsoft Windows NT executive running in kernel mode that is responsible for all Windows NT input/output functions. The I/O Manager integrates various networking components, including the following:

  • File system drivers

  • Networking protocols

  • Network adapter card drivers

How It Works

The I/O Manager is modular or layered in design. It consists of the three networking component layers listed in this entry separated by two boundary layers, the Transport Driver Interface (TDI) layer and the network driver interface specification (NDIS) layer. The I/O Manager receives a request for shared network resources and determines whether the requested resource is local or remote. If the request is for a remote resource, it is forwarded to the appropriate redirector.

Graphic I-14. I/O Manager.
Graphic I-14. I/O Manager.
See also
kernel mode, network driver interface specification (NDIS), Transport Driver Interface (TDI), Windows NT executive

IOS

See
Internetwork Operating System (IOS)

IP

See
Internet Protocol (IP)

IP address

A 32-bit logical address for a host on a TCP/IP network. Each host on a TCP/IP network needs a unique IP address for communication to take place reliably on the network.

How It Works

IP addresses are usually expressed in four-octet, dotted-decimal form—w.x.y.z—in which each octet ranges in value from 0 to 255 (with some restrictions). The IP address of a host is partitioned by the network’s subnet mask into two parts, a network ID and a host ID.

IP addresses belong to certain classes according to their first octet, as defined in the following table. The actual distinguishing feature of each class is the pattern of high-order bits in the first octet, but it is easier to remember these classes by their first octet decimal numbers.

IP Address Classes
IP Address Class | Possible First Octet | Used For
Class A | 1–126 | Very large networks
Class B | 128–191 | Medium to large networks
Class C | 192–223 | Small networks
Class D | 224–239 | Multicasting
Class E | 240–255 | Reserved (experimental)

IP addresses whose first octet is 127 represent the loopback address and are used for troubleshooting purposes only, not for naming hosts.

NOTE

Networks that are directly connected to the Internet must have their IP addresses assigned by the Internet Network Information Center (InterNIC) or some other authority. Businesses usually obtain these addresses through their local Internet service provider (ISP). However, firewall and proxy server combinations, which are popular on today’s networks, hide a network’s IP addresses from other hosts on the Internet. These private networks can use any IP addresses they choose, although InterNIC recommends the following IP address blocks for private networks:

  • Class A networks:
    10.x.y.z

  • Class B networks:
    172.16.y.z through 172.31.y.z

  • Class C networks:
    192.168.0.z through 192.16.255.z

TIP

Note the following considerations for valid IP addressing:

  • The network ID cannot be 127.

  • The network ID and host ID cannot both be 255.

  • The network ID and host ID cannot both be 0.

  • The host ID must be unique for a given network ID.

See also
subnetting

IPC

See
interprocess communication (IPC)

ipconfig

A TCP/IP utility that displays the current TCP/IP configuration settings for each network interface card (NIC) on a Microsoft Windows NT or Windows 2000 system. The ipconfig command is often one of the first commands you use to check the status of the connection when you experience communication problems on a TCP/IP network.

How It Works

When you type ipconfig at a command prompt, the following information is displayed for each NIC:

  • IP address

  • Subnet mask

  • Default gateway

You can display additional information, including the host name, physical address, and Dynamic Host Configuration Protocol (DHCP), Windows Internet Name Service (WINS), and Domain Name System (DNS) configuration, using ipconfig /all.

You can release and renew IP addresses obtained by DHCP using ipconfig /release and ipconfig /renew.

IPng

See
IPv6

IPSec

See
Internet Protocol Security (IPSec)

IP telephony

An umbrella term for technologies that allow the transmission of voice and video over TCP/IP internetworks instead of the traditional Public Switched Telephone Network (PSTN). Many vendors have produced platforms and software for IP telephony, but the technology is still in its growth stage and standards are not yet clearly established.

The advantage of IP telephony is that it allows voice communication to be closely integrated with data transmission over corporate networks and allows long-distance communication to be established over the Internet instead of through private long-distance carriers such as Sprint and MCI WorldCom. The primary difficulty with IP telephony is that the existing Internet Protocol (IP) internetwork is connectionless and suffers from latency that can cause annoying glitches (pauses) in voice and video transmission over IP packets. This happens because TCP/IP was not originally designed as a connection-oriented service capable of specific levels of quality of service (QoS), whereas the PSTN, with its circuit-switched connections, provides just that.

See also
H.323, Voice over IP (VoIP)

IPv4

The current 32-bit IP addressing scheme used on TCP/IP networks worldwide. Because the number of hosts connecting to the Internet has skyrocketed in recent years, unique IP addresses are gradually running out. A new scheme called IPv6 has been proposed and is currently under review by the Internet community. However, with most corporate networks now hiding their networks behind firewalls, the pressure to move to IPv6 has lessened because companies can choose any network ID they want for their private network. The only assigned IP addresses they require from their Internet service provider (ISP) are for the public interfaces on their firewall machines. At this point, IPv4 seems to be firmly entrenched in the networking world for at least the next few years.

See also
Internet Protocol (IP)

IPv6

A proposed new IP addressing scheme for TCP/IP networks to replace the current IPv4 scheme. Proposed features of IPv6 include the following:

  • 128-bit IP addresses to solve the problem of the available IP address pool being depleted

  • A simplified header format to reduce network overhead and improve performance

  • Support for preallocation of network resources to enable time-dependent services such as voice and video to receive guaranteed bandwidth and quality of service (QoS)

  • Extensibility to account for future growth and evolution of Internet technologies and standards

IPv6 is also sometimes referred to as IPng, which stands for “IP Next Generation.” A network called the 6Bone was set up in 1995 as a testbed for IPv6 and to investigate how the Internet can be migrated from IPv4 to IPv6.

NOTE

IPv6 is currently a draft Internet Engineering Task Force (IETF) standard, Request for Comments (RFC) 2460. Many vendors, including Microsoft, are currently exploring ways to integrate IPv6 into their network products.

IPX

See
Internetwork Packet Exchange (IPX)

ipxroute

A Microsoft Windows NT and Windows 2000 utility for viewing and modifying Internetwork Packet Exchange (IPX) routing table information when NWLink IPX/SPX-Compatible Transport is installed on machines running Windows NT and Windows 2000. You can use ipxroute to display the current IPX settings, such as frame type, IPX network numbers, and internal network number. You can also use it to display the IPX routing table, Service Advertising Protocol (SAP) table, and IPX routing statistics.

Example

The Ipxroute Table command shows the IPX routing table, while Ipxroute Config shows binding information for IPX, such as the IPX network number.

IPX/SPX-Compatible Protocol

Microsoft’s version of the Novell NetWare IPX/SPX (Internetwork Packet Exchange/Sequenced Packet Exchange) protocol for Microsoft Windows 95, Windows 98, and Windows 2000. Using IPX/SPX and Client for NetWare Networks, clients running Windows 95 and Windows 98 can access shared resources on NetWare servers directly, as long as they have appropriate permissions and rights. Under Windows 2000 this protocol is part of NWLink. IPX/SPX-Compatible Protocol can also be used to access Windows NT or Windows 2000 servers running File and Printer Sharing for NetWare Networks. IPX/SPX-Compatible Protocol supports the 32-bit Windows Sockets 1.1 and NetBIOS over Internetwork Packet Exchange (IPX) programming interfaces.

NOTE

Although the Windows 95 and Windows 98 user interfaces allow you to configure multiple bindings for IPX/SPX-Compatible Protocol to multiple network interface cards (NICs), only the first binding is actually used. You cannot use IPX/SPX-Compatible Protocol for connecting to NetWare over an ARCNET network; you must install real-mode IPX drivers instead.

TIP

IPX/SPX-Compatible Protocol is set by default to autodetect the frame type used on a NetWare network. If no frame type is detected, the default 802.2 type is used. If multiple frame types are detected, the predominant one is selected.

IRC

See
Internet Relay Chat (IRC)

IrDA

See
Infrared Data Association (IrDA)

IrDA Control

A standard developed in 1998 by the Infrared Data Association (IrDA) for communication over IR light between in-room cordless peripheral devices and a host computer. Peripherals such as keyboards, joysticks, mouse devices, and other pointing devices can use IrDA Control for communicating with their host computer. IrDA Control is implemented using a suite of protocols that include the following:

  • IrDA Control PHY (physical layer), which provides for data transmission that is bidirectional and error-correcting, over IR light at speeds of up to 75 Kbps over distances of up to 5 meters.

  • IrDA Control MAC (media access control), which enables host devices to communicate with multiple IrDA Control peripherals and up to eight peripherals simultaneously. IrDA Control MAC offers a fast response time by using a polling interval of 13.8 meters and supports the dynamic assignment and reuse of addresses assigned to peripheral devices.

  • IrDA Control LLC (logical link control), which ensures proper sequencing of data and handles retransmissions when errors occur.

See also
Infrared Data Association (IrDA)

IrDA Data

A standard developed by the Infrared Data Association (IrDA) in 1994 for two-way point-to-point communication over IR light at speeds of up to 4 Mbps. IrDA Data is used for communication between palm computers, digital cameras, cellular phones, and other devices. It is implemented using a suite of protocols, including the ones listed.

  • IrDA Data PHY (physical layer), which provides low-level continuous bidirectional error-correcting operation from 9600 bps up to 4 Mbps over distances of at least 1 meter. Specifically, asynchronous serial transmission is supported between 9600 bps and 115.2 Kbps, synchronous serial transmission at 1.152 Mbps, and synchronous communication at 4 Mbps.

  • IrDA Data Infrared Link Access Protocol (IrLAP), a serial link protocol adapted by the IrDA for infrared serial communication from the High-level Data Link Control (HDLC) protocol. IrLAP provides a single serial connection between two IrDA devices and manages the device-to-device discovery, connection, and reliable data transfer functions.

  • IrDA Data Infrared Link Management Protocol (IrLMP), which is used for link control and multiplexing of IrDA devices. IrLMP allows multiple IrDA devices to communicate over a single infrared link and provides for protocol and service discovery through the Information Access Service (IAS).

In addition to the three mandatory IrDA Data protocols described, a number of optional protocols are available that support flow control, port emulation, object exchange services, image exchange, interfacing with telephony devices, and infrared wireless access to local area networks (LANs).

See also
Infrared Data Association (IrDA)

IRTF

See
Internet Research Task Force (IRTF)

ISAPI

See
Internet Server API (ISAPI)

ISAPI extension

A dynamic-link library (DLL) that runs in the same address space as the Web server running Internet Information Services (IIS) and can access all available resources on the Web server. ISAPI extensions (sometimes called ISAPI Server extensions) can run in process or out of process on IIS. These extensions are generally loaded on demand the first time a user requests them and remain in memory until the service is stopped. You can use ISAPI extensions wherever you might use Common Gateway Interface (CGI) applications, such as for a form handler for Hypertext Markup Language (HTML) forms. An ISAPI extension is generally called in a manner similar to calling a CGI application. For example, the Uniform Resource Locator (URL) shown below invokes the extension TEST.DLL on the Web site www.northwind.microsoft.com and passes it the parameters Value1 and Value2:

http://www.northwind.microsoft.com/isapie/TEST.DLL?Value1&Value2

ISAPI filter

A dynamic-link library (DLL) that is loaded into Internet Information Services (IIS) when it starts and that remains in memory until it stops. ISAPI filters provide Web servers such as IIS with the ability to preprocess or postprocess information sent between the client and server, and they have no equivalent in the Common Gateway Interface (CGI) scheme. ISAPI filters receive special filter event notifications and respond based on these notifications. You use ISAPI filters for such tasks as custom authentication, encryption, and compression schemes or for updating logging statistics on the Web server. ISAPI filters are generally called for every Uniform Resource Locator (URL) that the Web server processes instead of being explicitly invoked by a URL, as are ISAPI extensions.

Custom ISAPI filters can be designed by third-party developers for such tasks as

  • Custom authentication

  • Data encryption

  • Data compression

  • Filtering

  • Traffic analysis

ISDN

See
Integrated Services Digital Network (ISDN)

ISDN fallback adapter

A device that allows you to back up digital data service (DDS) lines using a dial-up Integrated Services Digital Network (ISDN) line. If the DDS line experiences failure, the fallback adapter automatically kicks in the ISDN line to maintain wide area network (WAN) connectivity. Fallback adapters typically have built-in ISDN terminal adapter functionality and can sometimes provide backup support for multiple DDS lines. The fallback and restore settings are configurable using a built-in or serial-connected terminal interface. To use a fallback adapter, you connect it to the ISDN line with the RJ-45 connector and to the local area network (LAN) bridge or router and the DDS CSU/DSUs (Channel Service Unit/Data Service Units) using the V.35 or RS-232 serial interfaces.

Graphic I-15. ISDN fallback adapter.
Graphic I-15. ISDN fallback adapter.

ISDN router

A router with built-in hardware for connecting directly to Integrated Services Digital Network (ISDN) lines. ISDN routers—also called ISDN access routers because they provide direct connectivity to a wide area network (WAN) connection—are a popular way of providing SOHOs (Small Office/Home Offices) with 128-Kbps dial-up ISDN connectivity to the Internet or to a remote private corporate network through the industry-standard Point-to-Point Protocol (PPP). They typically support up to 10 users in a small workgroup Ethernet local area network (LAN) and might provide some firewall, network address translation (NAT), or Dynamic Host Configuration Protocol (DHCP) support.

ISDN routers include RJ-11 jacks for connecting several analog phones, fax machines, or other devices for simultaneous voice/fax/data connectivity. Built-in data compression can increase the effective bandwidth by a factor of 5 or higher. Some ISDN routers include built-in hubs for quick connectivity. Many are manageable using a remote Telnet connection or through Simple Network Management Protocol (SNMP).

ISDN terminal adapter

A device used at the customer premises to terminate a dial-up Integrated Services Digital Network (ISDN) line and connect it to a computer or a local area network (LAN). You use a terminal adapter when you do not have dedicated ISDN telephone or computing equipment. Terminal adapters are sometimes called ISDN modems.

How It Works

A terminal adapter connects using an RJ-45 connector to the U interface of the ISDN line at the customer premises and provides electrical termination for this line. The other interface on the terminal adapter is typically an RS-232, RS-366, RS-530, or V.35 serial interface such as DB25, or a 34-pin connector for connecting the terminal adapter to a bridge, router, or computer at the customer premises. Terminal adapters can include several RJ-11 connectors for connecting an analog telephone or a fax machine so that you can transfer data, talk on the telephone, and fax documents simultaneously over one ISDN line. Some newer terminal adapters have an S/T interface for connecting to an S/T videoconferencing unit.

Graphic I-16. ISDN terminal adapter.
Graphic I-16. ISDN terminal adapter.

ISDN terminal adapters can be stand-alone AC powered devices or interface cards that you install on your computer. They can provide 128-Kbps throughput using the Bandwidth On Demand Interoperability Group (bonding) protocol for high-speed Internet and wide area network (WAN) connectivity, with higher effective data transfer rates using built-in data compression. Terminal adapters do not provide an “always on” network connection, but their latency time interval for establishing an ISDN connection is typically small (1 to 3 seconds). You can usually also configure an idle timer for dropping idle connections to save costs.

TIP

If you need more speed than ISDN but can’t afford to upgrade to T1 lines, try using an inverse multiplexer to combine several ISDN lines into one high-speed data pipe.

When you buy ISDN terminal adapters, be sure that they support the ISDN standard used by your telco. Such standards can include the National ISDN-1, ISDN-2, and ISDN-3 standards for AT&T, Northern Telecom, and Siemens. An ISDN terminal adapter with automatic service profile identifier (SPID) detection generally works with most ISDN installations.

isinteg

A command-line utility in Microsoft Exchange Server for checking the consistency of the information store databases at a higher level than the eseutil utility does. The isinteg utility checks for problems relating to referential integrity of the information store databases that are preventing the information store services from starting or are preventing users from accessing their stored messages. Such a situation can arise after the information store is restored from an offline backup. You can run isinteg (which stands for the Information Store Integrity Checker) in two different modes:

  • Test mode, which allows you to search the information store databases for errors in tables, unreferenced objects, and incorrect reference counts. Select the Fix option in Test mode to repair any errors the utility finds.

  • Patch mode, which is for repairing an information store that will not start after being restored from an offline backup.

NOTE

The isinteg utility is located in the Exchsrvr\Bin directory on an Exchange server. You should not use isinteg as part of your regular Exchange server maintenance plan—it is intended only for troubleshooting use, especially in consultation with Microsoft Product Support Services.

TIP

Always back up your information store databases before running this utility!

ISO

See
International Organization for Standardization (ISO)

ISOC

See
Internet Society (ISOC)

ISP

See
Internet service provider (ISP)

ISQL

A command-line version of the Microsoft SQL Server GUI-based tool ISQL/w. The ISQL utility provides a query interface for running transact-SQL queries against SQL Server and lets administrators perform system-management tasks from servers or workstations using system-stored procedures and scripts.

NOTE

In version 7 of SQL Server, the ISQL utility does not support some version 7 features because it essentially runs with version 6.5 functionality. For example, you cannot use ISQL on version 7 to retrieve Unicode ntext data. For full support of SQL Server 7 features, use the new OSQL utility.

TIP

Use ISQL when you want to create a script for automating administrative tasks.

ISQL/w

A graphical user interface (GUI) tool in Microsoft SQL Server that lets you directly enter transact-SQL statements and system-stored procedures into SQL Server for administering the system and querying databases. ISQL/w can be used to graphically analyze transact-SQL queries.

NOTE

ISQL/w is a SQL Server 6.5 tool that is provided with SQL Server 7 for backward compatibility. With version 7, you can use the SQL Server Query Analyzer tool instead, which is integrated into the Microsoft Management Console (MMC).

iterative query

A DNS query in which a name server contacts a second name server to perform a name lookup.

How It Works

In a typical Internet name lookup (for example, www.alpine.expedia.com), a resolver sends a recursive query to a locally accessible name server such as a name server maintained by your local Internet service provider (ISP). If the local name server cannot resolve the name because it is outside of its zone of authority and it is configured as a forwarder, the server performs an iterative query to a root name server, which responds with the IP address of a name server whose zone of authority includes the desired top-level domain (.com). The local name server then performs an iterative query with this top-level name server, which responds with the IP address of a second-level name server whose zone of authority includes the desired second-level domain (expedia.com). The local name server contacts this second-level name server and resolves the fully qualified domain name (FQDN) into its IP address or returns an error if the query cannot be resolved.

See also
inverse query, recursive query

ITU

See
International Telecommunication Union (ITU)

IUSR_ComputerName

A Microsoft Windows NT user account created when Internet Information Services (IIS) is installed. The IUSR_ComputerName account, in which ComputerName is the NetBIOS name of the Windows NT or Windows 2000 server on which IIS is installed, is also known as the anonymous account because it is designed to allow anonymous access to World Wide Web (WWW) and File Transfer Protocol (FTP) sites on IIS.

How It Works

The IUSR_ComputerName account is given a randomly assigned password and is made a member of the Guests local group. The account is also granted the sole system right “log on locally” so that when users on the Internet try to anonymously access a WWW or FTP site on IIS, they are authenticated as if they had logged on locally to the system console (instead of being authenticated as normal network users). This secures the computer against unauthorized network access. Once a user is authenticated as an anonymous user, he or she transparently uses the IUSR_ComputerName account to gain access to files on the WWW or FTP sites of interest.

NOTE

The IUSR_ComputerName account is automatically included in the built-in Guests local group on the server on which IIS is installed, so be sure to review the permissions and rights that you have granted to the Guests group.

TIP

You can change the password of the IUSR_ComputerName account using User Manager for Domains, but if you do so you should use Internet Services Manager to ensure that this password is synchronized with the password specified for the account in the IIS property sheets. Select the Enable Automatic Password Synchronization setting in Internet Services Manager to ensure this.

IXC

See
inter-exchange carrier (IXC)


J

jabber

Random, malformed frames of data that are sent continuously by failed circuitry in a networking component. A network interface card (NIC) or other device that is jabbering generates a continuous stream of unwanted signals that can disrupt communication between other devices on the network. This is especially common on Ethernet networks, in which each device must compete for use of the line using the Carrier Sense Multiple Access with Collision Detection (CSMA/CD) contention protocol. When a NIC jabbers on an Ethernet network, all network communication might cease until the offending NIC is replaced. Other causes of jabbering on a network include a faulty NIC, loose cabling, or a poorly grounded cable (for shielded cabling).

The term “jabber” is also used in the Institute of Electrical and Electronic Engineers (IEEE) 802.3 specification for any frame of data that exceeds the maximum frame length for that specification. For Ethernet networks, the maximum frame length is 1518 bytes (18 bytes of overhead and 1500 bytes of payload). A frame longer than 1518 bytes is often called a “jabber frame.” Another name for jabbering is “long packet error.”

Jabbering can also occur in Fast Ethernet networks, in which a combination of 100BaseT4 and 100BaseTX cabling schemes are employed in one network. The continuously generated idle stream signal of the TX network can appear to the T4 network as jabber and can bring down the entire network. This should not be a problem if all network devices implement autonegotiation in an IEEE-compliant fashion. In addition, Fast Ethernet repeaters generally implement jabber control by automatically disconnecting any port that transmits information in streams longer than 40 Kb.

NOTE

A frame shorter than 64 bytes on an Ethernet network is called a “runt frame.”

jack

A receptacle into which you can insert a connector or plug to form a connection. An example is a category 5 (CAT5) jack, which can be attached to twisted-pair cabling and which accepts an RJ-45 connector. Jacks are usually built into networking devices such as hubs and switches, but in some modular expandable devices jacks can be inserted and removed to support different kinds of connectors. Patch panels and wall plates are other examples of items that can be modular and can be configured by inserting different kinds of jacks into them. This modularity allows flexibility for networks that must be reconfigured frequently, such as classroom computer networks.

Graphic J-1. Jack.
Graphic J-1. Jack.

jacket

The outer covering of cabling that protects it from physical damage. The jacket of a cable protects the wiring from various kinds of damage, including

  • Damage caused by exposure to sun, heat, moisture, dust, and chemicals

  • Damage caused by contact with sharp edges of walls, furniture, or plenum ducts; by mechanical vibrations; or by mechanical stresses introduced during the cable installation process

The jacket is usually made of an insulating material, although its primary purpose is not insulation. (This function is provided by the insulation of individual wires within the jacket.) Common materials used for cable jackets include the following:

  • Polyvinyl chloride (PVC):
    This is the most common material used for cable jackets. PVC is a tough, fire-resistant material formed from resins and plastics that can withstand a wide range of temperatures. PVC cables are typically used in vertical rises, but they should not be used in plenums because PVC gives off toxic fumes when burned.

  • Kynar plastic (polyvinylidene fluoride):
    This material has good fire-retardant qualities, which makes it suitable for installation in plenums, but it is several times more costly than polyvinyl chloride.

  • Flamarrest:
    This chloride compound has high fire retardance and is suitable for plenum installations.

  • Neoprene:
    This dark-colored plastic is resistant to moisture and doesn’t degrade in sunlight. It’s a good choice for use in outdoor cable runs.

  • Polyethylene:
    This soft, moisture-resistant plastic has poor fire retardance and is suitable only for outdoor cable runs.

See also
cabling

jam signal

A signal sent by a device on an Ethernet network to indicate that a collision has occurred on the network. Collisions occur on Ethernet networks because access to media (usually a cable) is based on contention—that is, on a first-come, first-served basis. If two stations attempt to take control of the medium at the same time and begin transmitting, both stations will detect each other’s signal and realize that a collision has occurred. The two stations then issue a jam signal, which notifies all other stations on the network of the collision. They all must wait a short period of time before attempting to transmit again. The length of time is random for each station so that the retransmissions won’t cause more collisions. The jam signal sent by one transmitting station must start with a 62-bit pattern of alternating 0s and 1s, followed by a 32-bit sequence that provides a dummy checksum value for the other transmitting station. This 32-bit sequence cannot be equal to the cyclical redundancy check (CRC) value for the frame preceding the jam.

Java

An object-oriented programming language developed by Sun Microsystems. Java is syntactically related to the C and C++ programming languages but is simpler, has libraries that are tuned for the Internet environment, and is designed to be portable across different operating systems and platforms. Java code can be reused and extended through inheritance, which simplifies the development process.

You can use Java to develop full-fledged distributed applications and application suites, but much of its appeal comes from its ability to create applications called “applets” that can be downloaded from Web servers by standard Web browsers and then executed on the client browser. These applets can add various interactive features to Web sites to enhance the user’s experience and provide features such as rotating ad banners or animated stock tickers.

How It Works

After you write an application (or applet) in Java, a Java compiler takes your source code (which is usually saved with the extension .java) and compiles it into something called bytecode. Bytecode is not true machine code—it is a set of generic instructions that are not specific to any particular hardware platform or operating system. Bytecode files generally have the extension .class and are referred to as class files. Here is a simple example of a Java application called HelloThere.java:

Class HelloThere {
  Public static void main (String args[]) {
    System.out.println("Hello there");
  }
}

The HelloThere.java program defines a new class called HelloThere and contains only one method: main(). When this program is compiled into the class file HelloThere.class and then run, it displays the text “Hello there” on the screen (the standard output device).

To run the application (class file), you must have a bytecode interpreter called a Java Virtual Machine (JVM) on the system. The JVM reads the bytecode of your application and executes it by converting each bytecode instruction into a machine-native instruction or set of instructions. This translation process takes place regardless of whether the particular piece of bytecode has been previously executed. If the application is an applet, the Web browser that accesses it must have a JVM installed in it. The use of a bytecode interpreter instead of a “true” compiler, which generates platform-specific machine code, means that applications written in Java are often slower than those written in C or C++, but the ease of development and portability of code offset these disadvantages in most cases. To obtain additional functionality, you can link native code to Java applications.

The JVM has special security features built into it to ensure that any malicious Java applet downloaded from the Internet cannot perform any harmful actions on the user’s system. In this sense, you can consider the JVM running in the Web browser a “sandbox” that allows the applet to safely “play around” (execute) while preventing access to certain items, such as the client machine’s file system.

An alternative to the JVM is a just-in-time (JIT) Java compiler that dynamically compiles segments of Java bytecode into equivalent segments of platform-specific executable machine code at run time. JIT compilers offer better performance than the JVM for running Java applications, especially in applications in which segments of code run multiple times (for example, in loops).

NOTE

Other components of the Java platform include the following:

  • JavaBeans, the Java component architecture for developing Java applications. JavaBeans can be self-contained applications or portions of Java applications. You can use them as building blocks for creating more complex programs.

  • Java Foundation Classes (JFC), which are building blocks for creating interfaces for Java applications.

  • Java Database Connectivity (JDBC), which provides standard application programming interfaces (APIs) for connecting SQL (Structured Query Language) databases to Java applications.

  • JavaOS, an operating system designed to natively run Java programs.

On the Web
•
Sun Microsystems Java home page
: http://java.sun.com
•
Microsoft technologies for Java
: http://www.microsoft.com/java

Java Database Connectivity (JDBC)

A standard Structured Query Language (SQL) data access interface developed by Sun Microsystems that allows Java applications to access databases. Java Database Connectivity (JDBC) is based on open database connectivity (ODBC) and is used with the Java programming language. The JDBC application programming interface (API) is a standard component of Java 2.0 Platform.

How It Works

The JDBC API specifies a set of Java classes that represent database connections, SQL queries and their result sets, and other objects associated with accessing databases. Multiple drivers for JDBC exist that allow access to different database formats, and the JDBC drivers themselves can be implemented either within applets or as native methods on the operating system. JDBC also supports drivers that act as a bridge between ODBC and JDBC. This type of driver translates JDBC function calls into native ODBC calls, but this bridge cannot be run by untrusted applets within a Web browser environment.

See also
Java

JavaScript

A cross-platform, object-based scripting language that is similar to C but simpler in syntax. JavaScript was developed by Netscape Communications and built into the Netscape Navigator Web browser version 2.0 and later. JavaScript enables Web developers to produce Web pages with dynamic functionality such as animated graphics, browser detection, cookies, scrolling text, form handlers, and authentication without having to write or invoke Common Gateway Interface (CGI) applications. JavaScript can be used to develop both client and server applications, but it is usually run on the client Web browser.

How It Works

JavaScript scripts are placed in standard Hypertext Markup Language (HTML) files using special tags. Here is a simple example:

<HTML>
<HEAD><TITLE>Javascript Test</TITLE></HEAD>
<BODY>
<H1>Knock Knock</H1>
<SCRIPT LANGUAGE="JavaScript">
alert("Who's there?");
</SCRIPT>
</BODY>
</HTML>

The <SCRIPT> and </SCRIPT> tags identify and contain the actual JavaScript script. When this page is loaded into a Web browser such as Netscape Navigator version 3.0, the browser reads the script and interprets it, causing an alert dialog box to be displayed with the message “JavaScript Alert: Who’s there?” and an OK button that closes the dialog box when clicked.

NOTE

JavaScript is not the same as Java, which is an object-oriented programming language. A syntactically similar scripting language called JScript is supported on Microsoft Internet Explorer.

See also
Java, JScript

JBOD

Stands for “just a bunch of disks” and refers to any unstructured high-capacity disk-storage system. JBODs do not have the fault tolerance features of RAID disk systems. They are used for simple applications that require a large disk capacity. A JBOD has no specified format—anything will do, including a collection of daisy-chained external Small Computer System Interface (SCSI) disk drives, removable Jaz drives, optical drives, or a mixture of different types of disk drives. JBODs are difficult to manage and usually arise as a result of poor network planning as a company expands and upgrades its services. If you have a JBOD on your network, it is a good idea to migrate as much of your data as possible to a RAID-5 disk system, either an external hardware RAID-5 unit or a Microsoft Windows NT server with RAID-5 implemented in software.

JDBC

See
Java Database Connectivity (JDBC)

Jet

A Microsoft database engine technology developed in 1992 and included in a variety of Microsoft products, including Microsoft Access and Microsoft Visual Basic. Jet is not available as a separate product.

Jet, which stands for Joint Engine Technology, is an advanced 32-bit multithreaded database engine that uses transaction logs to track and maintain information and provide fault tolerance. The Jet database engine has its own processors for performing client-based processing of queries and for generating result sets. Jet databases can be accessed using Data Access Objects (DAO) and open database connectivity (ODBC). DAO provides the Component Object Model (COM) interface for accessing indexed sequential access method (ISAM) databases such as Microsoft FoxPro, dBASE, or Paradox through Jet. Native Jet database files usually have the extension .mdb. Jet is used by the directory and information store database services of Microsoft Exchange Server.

NOTE

Jet databases are best accessed through DAO (rather than ODBC) because they expose only a limited amount of functionality to ODBC drivers. Jet cannot use ODBC to build queries that use server-side cursors, and it has limited capability for stored procedures and multiple result sets.

jetpack

A Microsoft Windows NT utility installed with the Dynamic Host Configuration Protocol (DHCP) and Windows Internet Naming Service (WINS) services that you use to manually compact the DHCP or WINS database on a server running Windows NT. Compacting a database usually improves its performance. These two databases should be compacted automatically, but jetpack gives administrators the option of manually compacting the databases when needed.

Example

To compact the DHCP database, you use the following procedure at the command prompt:

cd \%SystemRoot%\system32\dhcp
net stop dhcpserver
jetpack dhcp.mdb tmp.mdb
net start dhcpserver

In this example, tmp.mdb is a temporary database that is used during the compaction process. Jetpack copies the database information to tmp.mdb as it compacts it, deletes the original database, and renames tmp.mdb to replace the deleted database.

Don’t use temp.mdb as the name of the temporary database instead of tmp.mdb as shown in the example; if you do, an error will result. Before you run jetpack, be sure that there is no file named temp.mdb in the DHCP or WINS database directory.

TIP

The DHCP or WINS database should be compacted if it approaches 30 MB in size.

Jini

A networking technology developed by Sun Microsystems that enables devices that run the Java Virtual Machine (JVM) to quickly form network connections between each other as needed for communication. You can plug together Jini devices to form an instant federation or community of devices without needing to install software or configure the devices. Each device in a Jini community can provide various kinds of services to other devices in the community. Jini technology is based on the Java programming language and defines protocols for dynamic discovery, joining, lookup, leasing, and transaction processes between devices. Sun hopes to implement Jini technology in everyday devices such as televisions, telephones, and pagers to increase the level of connectivity of these devices and to provide new functions for them.

On the Web
•
Sun Microsystems Jini home page
: http://www.sun.com/jini

jitter

Distortion in transmission that occurs when a signal drifts from its reference position. Jitter can be caused by variations in the timing or the phase of the signal in an analog or digital transmission line. Jitter typically results in a loss of data because of synchronization problems between the transmitting stations, especially in high-speed transmissions.

Jitter is inherent in all forms of communication because of the finite response time of electrical circuitry to the rise and fall of signal voltages. An ideal digital signal would have instantaneous rises and falls in voltages and would appear as a square wave on an oscilloscope. The actual output of a digital signaling device has finite rise and fall times and appears rounded when displayed on the oscilloscope, which can result in phase variation that causes loss of synchronization between communicating devices. The goal in designing a transmission device is to ensure that the jitter remains within a range that is too small to cause appreciable data loss.

job

In Microsoft Systems Management Server (SMS), a set of instructions about system actions to be performed, such as managing the distribution, installation, and removal of software from computers in the network. Using the Systems Management Server Administrator program, you can create, modify, cancel, and delete jobs.

How It Works

All jobs are stored in the SMS database using Microsoft SQL Server. Before you create a job, you must create a package, and you might also need to create machine groups, site groups, or queries depending on whether you want to use these tools to limit which computers receive the package. For example, if you want to create a job that will distribute Microsoft FrontPage to all computers in your development sites that have sufficient disk space, you first run a query to find all computers (from your development sites) with sufficient disk space. Then you create a package for FrontPage and a site group that represents your target systems. Finally, you create the job.

After you create a job, SMS monitors the database and starts the job at the scheduled time. SMS sends the package and job actions to the targeted systems, where they are carried out. As a job is carried out, its status is reported back to the server in the site where the job was created.

You can create three kinds of jobs using SMS:

  • Run Command On Workstation jobs

  • Share Package On Server jobs

  • Remove Package From Server jobs

join

A database operation that allows you to retrieve and modify data from more than one table at a time using a single Structured Query Language (SQL) SELECT statement. You can use the Microsoft Query tool for Microsoft SQL Server to graphically create joins for transact-SQL queries that join two or more tables or join a table to itself. Joins are a necessity because a single table might not provide all the information you want to retrieve about a specific database entity. By connecting tables using joins, you can retrieve information that resides in more than one table in a single operation.

You can create three kinds of joins:

  • Inner joins:
    Connect two tables to form a result set that contains only the matching rows that satisfy the join condition. Inner joins can be equijoins or natural joins.

  • Cross or unrestricted joins:
    Produce a result set that contains all combinations of all rows from the tables that are joined. A cross join between a table of 5 rows and another table of 4 rows creates a result set of 20 rows.

  • Outer joins:
    Maintain information that does not match the join condition. For example, a left outer join contains at least all rows from the first table.

NOTE

There are two kinds of syntax for creating joins, ANSI join syntax and SQL Server join syntax. You can use only one of these types of syntax in a given SELECT statement.

Joint Engine Technology (Jet)

See
Jet

JScript

An interpreted object-based scripting language supported by Microsoft Internet Explorer, Internet Information Services (IIS), and the Windows Scripting Host (WSH). Microsoft JScript version 5.0 is the first fully compliant implementation of the ECMA-262 specification for cross-platform, vendor-neutral scripting languages.

JScript enables Web developers to produce dynamic content for Web pages that can incorporate Microsoft ActiveX controls and Java applets. JScript cannot be used for developing stand-alone applications and has limited file input/output (I/O) features. It is a loosely typed language, which means that you don’t have to declare a variable’s data type before you use the variable.

How It Works

Scripts written in JScript are embedded directly into Hypertext Markup Language (HTML) using <SCRIPT> tags, and the HTML files are stored on the Web server. When a Web browser such as Internet Explorer 4 accesses the page, it downloads and executes the script locally on the client machine. Internet Explorer can do this because it has a built-in scripting engine that can understand and interpret scripts written in JScript and Microsoft Visual Basic, Scripting Edition (VBScript).

The following is a simple example of a script written in JScript. The script is embedded in an HTML page between the <SCRIPT> and </SCRIPT> tags and displays a confirm message box when the user opens the file using Internet Explorer. When the user makes a selection, the remaining portion of the page loads.

<HTML>
<BODY>
<H1>Welcome to our restaurant!</H1>
<HR>
<SCRIPT>
var testing=window.confirm("Click OK for food, Cancel for drink.");
if (testing) {
    window.alert("Hot dog");
} else window.alert("Beer");
</SCRIPT>
<H1>Thanks for coming!</H1>
</BODY>
</HTML>
Graphic J-2. A dialog box created using JScript.
Graphic J-2. A dialog box created using JScript.
NOTE

JScript 3 and JavaScript 1.2 are syntactically similar but have some differences. JScript 3 complies fully with the ECMA-262 specification, while JavaScript 1.2 does not. JScript also includes additional features not included in the ECMA-262 standard.

On the Web
•
Microsoft Windows Script Technologies home page
: http://msdn.microsoft.com/scripting/default.htm
•
ECMA-262 specification
: http://www.ecma.ch/stand/ecma-262.htm


K

KCC

See
Knowledge Consistency Checker (KCC)

keepalives

A feature of Hypertext Transfer Protocol (HTTP) version 1.1 that minimizes the number of connections that Web browsers need to make to access content on Web servers. Keepalives, which are also known as persistent connections, are supported by both Microsoft Internet Information Services (IIS) and Microsoft Internet Explorer.

How It Works

When a Web browser that supports keepalives (such as Internet Explorer 4) makes an HTTP GET request to a Web server that supports keepalives (such as IIS 4), the Web browser includes a new “Connection:Keep-Alive” header in the list of HTTP headers that it sends to the Web server in the request. The Web server responds by giving the client the file it requested (usually an HTML page or an image file). After the server sends the file to the client, instead of closing the TCP/IP socket it keeps the socket open for a period of time in case the client wants to download additional files. A typical Web page might include a dozen images, and normally up to four sockets are kept open for transferring files between the client and the server.

NOTE

The term “keepalives” also refers to special packets used to keep a TCP connection open on a TCP/IP internetwork.

TIP

Keepalives do not work unless they are supported by both the Web browser and the Web server.

Kerberos v5 security protocol

A method of securely authenticating users’ requests for access to services on a network. It was developed by the Massachusetts Institute of Technology (MIT), which based it on the Data Encryption Standard (DES). Kerberos is the primary security protocol for Microsoft Windows 2000 domains and is used by domain controllers to verify the identity of the user and the integrity of data during a session. Kerberos has also been implemented on several UNIX platforms including OpenBSD.

How It Works

Kerberos uses a ticket-based method for granting a user access to a network service. When a Kerberos-enabled client wants to request a network service (such as network logon) from a Kerberos-enabled server, the client must first contact an authentication server (AS) to receive a ticket and an encryption key. The encryption key, called the session key, is used to unlock communication between the client and the server and thereby authenticate that communication. The initial ticket, often called the ticket-granting ticket (TGT), contains a copy of the session key and an identity, which is a randomly generated number. The AS passes the TGT and the identity back to the client, which stores the ticket in its ticket cache. When the client wants to access a particular service, it sends the ticket to a ticket-granting server (TGS). (The TGS and AS are usually the same machine.) The TGS gives the client a ticket that securely identifies the client to the service it is requesting. Finally, the client presents the ticket to the network service it is trying to access and is granted access to the resource as many times as desired until the ticket expires. When the client sends a ticket, the ticket is always accompanied by an authenticator message that is encrypted with the session key. This authenticator includes a time stamp, which is used to ensure that the ticket is legitimate.

Graphic K-1. The protocol defines the steps a client must take to gain access to network services or resources.
Graphic K-1. The protocol defines the steps a client must take to gain access to network services or resources.

In the Windows 2000 implementation of Kerberos, each domain controller has the Kerberos v5 services running on it, and a Kerberos client is built into each server and workstation running Windows 2000. The Kerberos services maintain encrypted user passwords and identities in Active Directory. When a user logs on to a domain controller, the initial Kerberos authentication enables the user to access available resources anywhere in the enterprise because authentication credentials issued by the Kerberos services of one domain are accepted by all domains within a domain tree or a domain forest.

The Kerberos service issues an initial ticket for the logon domain when a user logs on to a Windows 2000 workstation. Any server running Windows 2000 can then validate the client’s ticket without having to contact the domain Kerberos service. It can do this because servers running Windows 2000 share the encryption key that the Kerberos service uses to encrypt tickets. This encryption key is called the server key.

If a Windows 2000 client in one domain requests access to a resource in a remote domain that is part of the same domain tree or forest, the Kerberos service in the local domain issues a referral ticket that the client presents to the Kerberos service in the remote domain. The Kerberos service in the remote domain then issues an initial ticket that is valid for its own domain and identifies the domain. Using this ticket, the client can then access resources in the remote domain.

The implementation of Kerberos in Windows 2000 is an industry-standard version that is compliant with Request for Comments (RFC) 1510.

Some of the benefits of Kerberos authentication include the following:

  • Two-way transitive trusts between domains

  • Mutual authentication of both client and server during an authentication session

  • Delegated authentication for multitier client/server interactions

On the Web
•
RFC 1510
: http://www.ietf.org/rfc/rfc1510.txt

kernel

The core services within an operating system. The term “kernel” is most often used in a UNIX environment and is contrasted with the term shell, which describes the outer portion of the operating system that is exposed to the user and provides a user interface for entering commands and receiving output. (In Microsoft Windows operating systems, the shell is the desktop.)

The kernel generally interfaces with other components of the operating system through system calls, which provide a standard interface to kernel functions. In many operating systems, the kernel is primarily responsible for scheduling processes and threads and for handling interrupts from devices. The kernel also typically manages input/output (I/O) operations and memory management.

How It Works

In Windows NT and Windows 2000, the kernel (called ntoskernl.exe and commonly referred to as the microkernel) is located in the \Winnt\System32 directory and runs in nonpageable memory (which means that it is always resident in memory). The kernel is responsible for thread scheduling and dispatching threads to processors on a symmetric multiprocessing (SMP) platform. The kernel code itself is not preemptive—that is, no other thread or process can preempt the kernel’s operations. Each thread is assigned a priority level from 0 to 31, as follows:

  • Levels 0 through 15 indicate dynamic priority and are assigned to application and user threads.

  • Levels 16 through 31 indicate real-time priority and are assigned only to key operating system threads.

The kernel adjusts priority levels for threads to ensure that no thread is starved and that each receives proper attention, with threads having a higher priority level getting the greater share of processor resources.

The kernel does its job by managing two classes of objects:

  • Control objects, which control the operation of the kernel and include processes, interrupts, asynchronous procedure calls, and profiles

  • Dispatcher objects, which manage thread dispatching and synchronization and include events, threads, timers, semaphores, mutants, and mutexes

The Windows NT kernel communicates with the hardware abstraction layer (HAL) to interact with hardware and communicates with the Windows NT executive and its components for higher-level operating system functions. The kernel loads when the screen turns blue during the boot process.

NOTE

In Windows 95 and Windows 98, the kernel file is kernel32.dll, and it is located in the \Windows\System directory. If the kernel is corrupt or missing, you can expand the file from the distribution CD and replace the damaged or missing file on your hard drive (as long as you can access that drive in a way that doesn’t involve this file, such as through MS-DOS).

kernel mode

A privileged mode of operation in which processes can execute within the Microsoft Windows NT and Windows 2000 operating systems. Processes running in kernel mode can access system memory and hardware. Kernel mode processes include components of the operating system that directly manage resources on the computer, such as the following:

  • Windows NT executive, which contains operating system modules that manage objects, processes, security, memory, and devices

  • The kernel, which manages core operating system services

  • The hardware abstraction layer (HAL), which isolates operating system code from hardware differences

    Graphic K-2. Kernel mode of the Windows NT and Windows 2000 architectures. (User mode is shown in light gray.)
    Graphic K-2. Kernel mode of the Windows NT and Windows 2000 architectures. (User mode is shown in light gray.)
See also
user mode

keyboard emulator

A device that can be plugged into the keyboard port of a server to emulate the presence of a connected keyboard. When a power outage causes the server to reboot, the server detects the presence of a keyboard and the reboot is allowed to occur. This is important when administrators are off site when servers need to be rebooted, because computers normally do not boot unless a keyboard is attached.

A keyboard emulator is used as a security device when the presence of an attached keyboard is not desirable, such as when the servers are in an unlocked room or can be tampered with in some other fashion. By removing the keyboard and installing a keyboard emulator, you can prevent unauthorized users from attempting a local logon to a server.

key in a relational database

A column (attribute) or group of columns (attributes) used to uniquely identify records in a table of a relational database such as those created and managed by Microsoft SQL Server. There are two main types of database keys:

  • Primary keys, which uniquely identify the rows of a table. Each row has a unique value in the primary key column or columns. Each table in a relational database should have one and only one primary key, and primary keys cannot allow nulls (NN), duplicates (ND), or no changes (NC).

  • Foreign keys, which are columns or groups of columns within a table that match the primary key of a different table. Foreign keys are used to define relationships between tables and to enforce referential integrity in a database by ensuring that each value in the foreign key column is actually a valid entry in the primary key column of another table.

NOTE

A column in a database table can be both a primary key for its own table and a foreign key for a different table.

key in cryptography

A mathematical entity used in cryptography for the encryption of messages and for signing messages with digital signatures. In secret key (or symmetric key) cryptography, both the sender and the recipient use the same key for encrypting and decrypting messages. Public key cryptography uses a key pair that consists of the private and public keys of the sender. The degree of security of a key depends on the type of mathematical algorithm used with the cryptosystem and the length of the key. Most cryptography algorithms make use of transformations using prime numbers and congruency. Key lengths range from 40 bits for the RC2 and RC4 cryptography algorithms to 512 bits for RSA public key systems. You obtain keys from certificate authorities (CAs) by submitting a key request file, such as one generated by the Key Manager component of Internet Information Services (IIS).

See also
public key cryptography

key in Microsoft Windows registry

A registry item that can contain subkeys and values. Keys are used for organizing the registry into a hierarchical structure and for naming and identifying collections of registry values.

Keys are thus analogous to directories in a file system as displayed using Microsoft Windows Explorer, and keys are in fact displayed by the Registry Editor as folders. The screen capture shows the Control key being displayed, which contains value entries (in the right pane) and subkeys (the series of items under it in the left pane). The Control key itself is a subkey of the CurrentControlSet key.

Graphic K-3. The Control key in the Windows NT and Windows 2000 RegistryEditor (regedt32.exe).
Graphic K-3. The Control key in the Windows NT and Windows 2000 RegistryEditor (regedt32.exe).

Key Management Server (KMS)

A component of Microsoft Exchange Server version 5.5 that provides encryption and digital signature services for secure messaging. Key Management Server (KMS) enables you to send secure mail using Secure/Multipurpose Internet Mail Extensions (S/MIME) algorithms such as DES, 3DES, RC2-40, RC2-64, and RC2-128, and monitors all security functions for Microsoft Exchange. KMS is implemented as a Microsoft Windows NT service and requires that Microsoft Certificate Server be installed on a machine in your enterprise to issue user certificates. KMS uses Certificate Server for generating digital certificates and key pairs. Once KMS is installed and configured in an Exchange organization, security can be administered using two objects in the Exchange directory hierarchy displayed in the Exchange Administrator tool:

  • Certificate authority (CA), a directory object for configuring security for users

  • Site Encryption, a directory object for configuring security for sites

TIP

Only one KMS can be installed in an Exchange organization. Service Pack 1 and later for Exchange Server 5.5 includes additional enhancements and fixes for KMS, so it’s recommended that you install the service pack before using KMS.

Key Manager

A component of Internet Information Server version 4 and earlier that generates certificate requests and key pairs for enabling the Secure Sockets Layer (SSL) protocol. You can use Key Manager to do the following:

  • Create a certificate request file and send it to Microsoft Certificate Server to obtain a digital certificate

  • Install a server certificate on a virtual server, thus enabling the virtual server for SSL

  • Generate a key pair for the public key cryptography used in SSL

How It Works

To use Key Manager to obtain a digital certificate from a certificate authority (CA), start Key Manager from the toolbar of Internet Services Manager. Then choose Create New Key from the Key menu. The key request file that is generated is a text file that you can e-mail to a third-party CA such as VeriSign or send directly over the network to Certificate Server if you have it configured as your CA.

NOTE

In Internet Information Services (IIS) 5, Key Manager has been replaced with Certificate Manager.

key pair

The public and private keys generated for an entity (individual, system, company, or organization) in a public key cryptography system. Such systems always generate keys in pairs. The private key belongs to the user alone and is kept secret. The public key is available to anyone who requests it. If a message is encrypted with the private key, it can be decrypted using the public key, and vice versa. This is possible because the private and public keys have a specific mathematical relationship.

NOTE

You can use the Certificate Manager component of Internet Information Services (IIS) to generate a key request file. You can then submit the file to a server running Microsoft Certificate Server or to a public certificate authority (CA) such as VeriSign to obtain a key pair and a digital certificate. Once the key pair has been issued to a user, the user can encrypt messages and sign the messages with digital signatures.

See also
public key cryptography

KMS

See
Key Management Server (KMS)

Knowledge Consistency Checker (KCC)

A utility built into the Exchange directory service of Microsoft Exchange Server that ensures consistency within the directory database. The Knowledge Consistency Checker (KCC) automatically checks for directory consistency throughout an Exchange site every three hours, or whenever you modify the directory, to ensure that the directory database is consistent throughout your Exchange organization. If the directories do not match, the KCC initiates directory replication to correct the inconsistencies. The KCC is also involved in replicating directory information between sites.

You can force the KCC manually using the Directory Service object in the Exchange directory hierarchy. This causes all the directories in your Exchange organization to be checked for consistency with one another. You might want to force the KCC to run if you have added new servers to other sites and want to update this information in the directory of your own site, or if you suspect that errors have occurred during directory replication.

NOTE

Active Directory in Microsoft Windows 2000 uses a similar KCC tool for controlling directory replication between domain controllers within a site. The Active Directory KCC logically links a site’s domain controllers to a ring topology, which defines the paths that directory updates use to travel from one domain controller to another. The KCC does this by creating connection objects that represent a unidirectional path from one domain controller to another. These connection objects are located in the NTDS Settings folder, which is in the Active Directory Sites and Services administrative tool. Administrators can also create additional intrasite or intersite connection objects for controlling directory replication, but it is often better to let the KCC do this automatically to ensure better performance.

The ring topology generated by the KCC ensures a minimum of two replication paths between domain controllers so that if one domain controller is down, replication can continue. In this topology, a directory replication update travels from one domain controller to any other domain controller in the same site in three or fewer “hops.” When a domain controller is added to or removed from a site, the KCC generates a new topology.

TIP

Don’t confuse the KCC of the Directory Service object with the DS/IS Consistency Adjuster of the Server object! Running the DS/IS Consistency Adjuster carelessly can yield unexpected results such as rehomed public folders.

Knowledge Manager

A component of Microsoft Site Server that makes it easy for visitors to your site to find information and receive updates when information is added or changed. Knowledge Manager enables users to

  • Search for information by entering a word or a phrase.

  • Browse predefined categories of information (similar to Yahoo! categories).

  • View personal knowledge briefs, which are summaries of information on a specific topic that consist of Uniform Resource Locators (URLs) or saved searches. Users can set up their own personal briefs (called My Briefs) or subscribe to briefs created by experts in the organization. They can receive updates by e-mail, from a briefing channel, or by revisiting the Web page.

  • Create Shared Briefs for sharing information with colleagues.

  • View the Channel Center, which lists available channels.

KVM switch

Stands for Keyboard-Video-Mouse switch, an electronic switch that allows one or more keyboards, video monitors, and pointing devices to control a number of computers. You can use KVM switches to cut costs and prevent equipment clutter in server rooms. Cheaper KVMs sometimes use pushbuttons for selecting computers, but more sophisticated KVMs allow you to select a computer by using a keyboard shortcut or by selecting from an on-screen context menu. The menu might also include some form of password protection for each computer and a master password that grants access to all computers attached to the switch. KVMs can support two, four, or eight computers, and some KVMs can be daisy-chained to support many more computers.

Another use for a KVM arises when your servers are in a special “clean room” or secured location and you want to control them from a different room. In this case, the KVM switch must include a built-in video extender, which amplifies the video signal so that the monitor can be connected to the computer using a cable that is 500 feet or longer. In this configuration, you must use two video extenders, one at the server and one at the remote monitor station. Video extenders can often be connected using a single interconnect line of category 5 cabling.

Graphic K-4. KVM switch.
Graphic K-4. KVM switch.

Other, similar types of switches include the following:

  • KV (Keyboard-Video) switch

  • KVMM (Keyboard-Video-Mouse-Monitor) switch


L

L2F

See
Layer 2 Forwarding (L2F)

L2TP

See
Layer 2 Tunneling Protocol (L2TP)

LADC

See
Local Area Data Channel (LADC)

LAN

See
local area network (LAN)

LANE

See
LAN emulation (LANE)

LAN emulation (LANE)

An Asynchronous Transfer Mode (ATM) technology that enables local area network (LAN) traffic such as Ethernet frames to be carried over an ATM network. LAN emulation (LANE) lets you use ATM as a backbone for connecting LANs.

How It Works

Ethernet and ATM technologies are difficult to connect because ATM is a connection-oriented technology and Ethernet is a broadcast-based connectionless technology. Also, Ethernet frames and ATM cells are different in format and addressing.

For an ATM network to act as a backbone for connecting Ethernet LANs, it must support MAC-to-ATM address mapping. LANE converts variable-length Ethernet frames into fixed-length ATM cells for transmission over the ATM backbone. LANE services run on one or more network servers and map ATM endpoint addresses to non-ATM endpoint Ethernet MAC addresses. These services enable users on ATM networks to transparently access resources on Ethernet networks and vice versa. LANE clients run on bridges, routers, or servers and must reside on each end station of the emulated LAN. Each client has both a MAC address and an ATM address, which is a 20-byte network service access point (NSAP) address. A bridge or router connects the ATM network to the Ethernet network.

When a user on an ATM network wants to access a resource on the Ethernet LAN, the client sends an address resolution message (ARM) to the LANE server, which forwards the message to a bridge or router connected to the Ethernet network. If the bridge or router knows the destination MAC address, it acts as a proxy and forwards the message to the destination client; if it doesn’t know the destination MAC address, it relays the message to the broadcast unknown server (BUS), a LANE service that broadcasts the message to all stations on the Ethernet LAN.

NOTE

LANE can also be used for connecting Token Ring networks using an ATM backbone.

See also
Asynchronous Transfer Mode (ATM), MAC address

LAN-host integration

The integration of LAN-based networks using protocols such as IPX/SPX or TCP/IP with SNA-based host systems such as IBM mainframes and AS/400 systems.

How It Works

Systems Network Architecture (SNA) networks originally developed separately from local area networks (LANs). As a result, both types of network have their own PC adapters, cabling, and protocols. LANs are built primarily around Ethernet using NetBEUI, IPX/SPX, or TCP/IP protocols, and they are connected into wide area networks (WANs) using routers and bridges. LANs and WANs support only non-SNA protocols.

As a result, many large companies have developed a two-tier network, consisting of a traditional LAN-based Ethernet network and an entirely separate SNA host-based network. However, because of the cost of maintaining separate networks, many have merged their SNA-only networks with non-SNA networks.

Early attempts at LAN-host integration involved directly connecting PC computers to IBM host systems using SNA hardware adapters and SNA protocols across a dedicated SNA network. Each PC was connected to a local IBM control unit such as an IBM 3174 or IBM 5294 using coaxial or twinax cabling. Standards were developed to allow SNA and non-SNA protocols to share the same network, but networking engineers soon found that mixing SNA and TCP/IP was like mixing oil and water, especially with regard to WAN connections, in which Data Link Control (DLC) timeouts and other difficulties made network management complex.

One solution is to install a TCP/IP protocol stack directly on the mainframe host, but this often results in degradation of host performance and additional challenges in terms of IP address administration.

Another solution is the LAN-to-SNA gateway. The gateway computer lets desktop PCs access applications and data on the mainframe host using traditional LAN protocols. TCP/IP is used to connect the desktop PC and the SNA gateway, while SNA is used to connect the SNA gateway and the mainframe host. This LAN-to-SNA gateway solution has become the de facto standard for providing host access to LAN-based PCs. An example of an SNA gateway application is Microsoft SNA Server, which provides LAN-to-SNA gateway services over a variety of network protocols that include NetBEUI, TCP/IP, IPX/SPX, Banyan VINES, and AppleTalk.

LanmanServer

See
Server service

LanmanWorkstation

See
Workstation service

LAN security switch

A type of manual switch that can be used to physically disconnect two or more local area network (LAN) segments. LAN security switches create a physical break in a circuit, preventing the flow of data between the connected segments. LAN security switches are available for both copper cabling and fiber-optic cabling. A fiber-optic LAN security switch has a small mirror inside that rotates when you manually flip a switch or rotate a dial to open or close the connection. You cannot operate LAN security switches remotely using electronic means; they must be operated manually.

LAN security switches are typically used in high-security networking environments that must meet the highest government or military security standards. For example, a network supervisor can use a LAN switch at the end of the day to physically disconnect a portion of the network that includes servers that store sensitive data, thus preventing users from accessing the servers during off hours. This is generally more convenient and safer than going into the server room and unplugging connectors from a hub.

Graphic L-1. LAN security switch.
Graphic L-1. LAN security switch.

LAN segment

A physical portion of a local area network (LAN) that is separated from other portions by bridges or routers. LANs are often “segmented” using bridges in order to improve network performance. Bridges are smart devices that build MAC-level routing tables that forward network traffic on the basis of the destination MAC address of each frame. If the destination address of a frame is a machine in the local LAN segment, bridges attached to that segment will not allow the frame to pass; this reduces unneeded network traffic in other segments attached to the bridge.

TIP

Segmentation improves performance of Ethernet networks by reducing the number of stations in each segment of the LAN that must compete with each other for access to the network. Bridges are generally used for segmenting smaller LANs because they are cheaper and require no special configuration. You place a bridge between your department or workgroup hub and the main network backbone to improve traffic on your local segment.

Graphic L-2. LAN segment.
Graphic L-2. LAN segment.

Last Known Good configuration

The current configuration information for drivers and services when a user successfully logs on to a Microsoft Windows 2000 or Windows NT system. This information is copied to the LastKnownGood control set in the registry and can be used to recover your system if you cannot log on again (for example, if you add or upgrade a driver that is incorrect for your hardware configuration).

How It Works

If you modify your system and are unable to log on again, you can restart your system, press F8 in Windows 2000 or Spacebar in Windows NT, and follow the prompts to reset the Windows configuration.

LAT

See
Local Address Table (LAT)

late collision

A collision on an Ethernet network that is detected late in the transmission of the packet. Late collisions can result from defective Ethernet transceivers, from having too many repeaters between stations, or from exceeding Ethernet specifications for maximum node-to-node distances.

How It Works

Signals on a cable do not travel instantaneously from point to point. Instead, they travel at a fixed speed, which is near the speed of light on copper cabling. If segments of an Ethernet network are too long, collisions can occur that are not detected by the stations on the network. This can result in lost or corrupted data. Collisions are natural on an Ethernet network, and they occur when two stations transmit their signals simultaneously or almost simultaneously. When the stations detect the collision (the concurrent signal from the other transmitting stations), they stop their transmission and wait a random time interval before attempting a retransmission. But the Ethernet standard specifies that if a station on the network is able to transmit 64 bytes or more before another signal is detected, the first station is considered to be “in control” of the wire and can continue to transmit the remainder of its frame, while the second station must stop transmitting and wait.

If the distance between two transmitting stations exceeds the particular Ethernet specification, the stations might not become aware soon enough that another station already has control of the wire. The resulting collision of signals results in a data packet that is more than 64 bytes in length, which is allowable but which contains cyclical redundancy check (CRC) errors, resulting in unreliable communication.

latency

The delay that occurs when a packet or signal is transmitted from one part of a network to another. A network with high latency can experience unpredictable delays. These delays usually do not affect data transmission appreciably since network protocols such as Internet Protocol (IP) are connectionless, but they have a serious impact on transmissions such as streaming audio and video because the human ear and eye can easily detect latency in these forms of transmission. The term “latency” can also refer to the delay in forming a connection, such as the 15 to 30 seconds required to establish a modem connection.

Intrinsic latency in a transmission is caused by the finite transmission speed of the electrical signals through the wires (or the light signals through the fiber-optic cabling). Intrinsic latency cannot be eliminated but is usually quite small. Much greater latency is usually introduced into a network by gateway devices such as routers and bridges, which process packets and perform protocol conversion. The latency for a bridge is thus the time delay between the moment when the packet enters one port of the bridge and the moment when it leaves another port—usually a fraction of a millisecond.

Layer 2 Forwarding (L2F)

A media-independent tunneling protocol developed by Cisco Systems. The Layer 2 Forwarding (L2F) protocol tunnels data-link layer frames in such protocols as Point-to-Point Protocol (PPP) or Serial Line Internet Protocol (SLIP), making it possible to create virtual private networks (VPNs) over a public network such as the Internet. On the server side, L2F can be used with such features as user authentication through Remote Authentication Dial-In User Service (RADIUS), dynamic allocation of addresses, and quality of service (QoS). L2F is implemented in Cisco routers through Cisco’s Internetwork Operating System (IOS).

How It Works

When using PPP with L2F, for example, PPP provides the connection between a dial-up client and the network access server (NAS) that receives the call. A PPP connection initiated by a client terminates at a NAS located at a PPP service provider, usually an Internet service provider (ISP). L2F allows the termination point of the connection to be extended beyond the NAS to a remote destination node, so the client’s connection appears to be directly to the remote node instead of to the NAS. The function of the NAS in L2F is simply to project or forward PPP frames from the client to the remote node. This remote node is called a home gateway in Cisco networking terminology.

NOTE

L2F has been largely superseded by the newer Layer 2 Tunneling Protocol (L2TP), an Internet Engineering Task Force (IETF) standard protocol that provides a vendor-neutral tunneling solution. L2TP is an extension of the PPP protocol that supports the best features of the Point-to-Point Tunneling Protocol (PPTP) and the L2F protocol.

See also
Layer 2 Tunneling Protocol (L2TP)

Layer 2 switch

A form of Ethernet switch that switches packets by looking at their physical addresses (MAC addresses). These switches operate at the data-link layer (or layer 2) of the Open Systems Interconnection (OSI) reference model. They essentially perform a bridging function between LAN segments because they forward frames based on their destination address without any concern for the network protocol being used. Thus, Layer 2 switches are essentially multiport bridges that operate near wire speed and have extremely low latency.

How It Works

Layer 2 switches can be installed transparently into networks. They do not interfere with communication between hosts and routers. Once installed, a Layer 2 switch learns about its connected hosts and networks by examining the source addresses of frames it receives. It builds a cache (database) of these MAC addresses and the ports on the switch to which they are mapped.

When a frame arrives at a port of the switch, the switch examines its destination MAC address and then forwards the frame to the port to which the destination host is connected. If the frame’s source address is unfamiliar, the switch sends the frame to all its other ports except the one through which the frame entered.

Layer 2 switches are often used to create virtual LANs (VLANs), in which the logical segmenting of the network differs from its physical segmentation. Using Layer 2 switches is functionally equivalent to flattening a network into a number of smaller switching domains.

TIP

Use Layer 2 switches for segmenting your Ethernet network into smaller collision domains to improve network performance. Layer 2 switches are generally used in combination with routers to create larger networks. Layer 2 switches are used for creating LAN segments, while the routers provide higher-level functions such as providing wide area access or protocol translation. An alternative is to use a Layer 3 switch, which combines the functionality of an Ethernet switch and a router in one package.

See also
Ethernet switch

Layer 2 Tunneling Protocol (L2TP)

An Internet Engineering Task Force (IETF) standard tunneling protocol that is used to encapsulate Point-to-Point Protocol (PPP) frames for transmission over TCP/IP, X.25, frame relay, or Asynchronous Transfer Mode (ATM) networks. You can use Layer 2 Tunneling Protocol (L2TP) to create virtual private networks (VPNs) over public networks such as the Internet. Because L2TP is an IETF standard, it provides the interoperability between different VPN vendors that protocols such as Microsoft’s Point-to-Point Tunneling Protocol (PPTP) and Cisco’s Layer 2 Forwarding (L2F) protocol do not, although L2TP essentially combines the best features of these two protocols and is an extension of them. The driving forces behind the development of L2TP include Microsoft and Cisco Systems; L2TP is supported on many Cisco Systems platforms and by the Microsoft Windows 2000 operating system.

How It Works

PPP provides the connection over which L2TP tunnels packets. The tunnel can be initiated by either the dial-up client at the customer premises or by the network access server (NAS) located at the L2TP service provider, typically an Internet service provider (ISP). When the client initiates a connection to the NAS, the NAS is referred to as an L2TP access concentrator (LAC). The LAC forwards its L2TP traffic to the remote node, which is referred to as an L2TP network server (LNS); the NAS performs the server-side function of PPP termination and acts as the receiver of incoming connections. However, if the NAS initiates the L2TP tunnel with the customer premises, the client PC acts as the LNS.

L2TP supports several of the authentication options supported by PPP, including Password Authentication Protocol (PAP), Challenge Handshake Authentication Protocol (CHAP), and Microsoft Challenge Handshake Authentication Protocol (MS-CHAP). You can use L2TP to authenticate the endpoints of a tunnel to provide additional security, and you can implement it with Internet Protocol Security (IPSec) to provide a secure, encrypted VPN solution.

Some of the differences between L2TP and L2F include the following:

  • L2F has no defined client.

  • L2F functions in compulsory tunnels only, while L2TP can use voluntary tunnels.

  • L2TP provides additional features such as flow control and AVP hiding.

L2TP differs from PPTP in the following ways:

  • PPTP tunnels only over an IP internetwork such as the Internet, while L2TP can use a wider variety of tunnel media.

  • PPTP supports only one tunnel between two endpoints, while L2TP supports multiple tunnels between two points, each with its own quality of service (QoS).

  • L2TP headers are compressed and are only 4 bytes, while PPTP has 6-byte headers.

L2TP can be implemented wherever PPTP or L2F is used. A VPN constructed using L2TP can be initiated in two ways:

  • The client can initiate the tunnel in a similar fashion to PPTP tunnels. For example, Windows 2000 clients can initiate L2TP tunnels and connect with routers that support L2TP, such as Cisco routers.

  • A NAS can initiate the tunnel, enabling telcos and ISPs to provide corporate customers with complete VPN solutions.

NOTE

When Multilink PPP (MPPP) is used, the PPP links from the customer premises must terminate at the same NAS at the service provider. L2TP has the advantage of supporting multilink configurations in which each link terminates at a different NAS at the provider for more flexibility.

Layer 3 switch

An Ethernet switch that switches packets by looking at both their network address (for example, their IP or IPX address) and their physical address (for example, their MAC address). This type of switch operates at both the network layer (layer 3) and the data-link layer (layer 2) of the Open Systems Interconnection (OSI) reference model. A Layer 3 switch combines the speed of an Ethernet switch with some of the capabilities of a router for building advanced, high-speed Ethernet networks.

How It Works

Layer 3 switches perform on two levels: layer 2 and layer 3. Their layer 3 switching functionality can take one of two forms:

  • Packet-by-Packet Layer 3 (PPL3) switches:
    These switches look into every packet to determine its logical layer 3 destination address (such as its destination IP address). PPL3 switches essentially function as high-speed routers with the routing functionality built into its hardware instead of software. Like routers, besides forwarding a packet to its destination, these switches perform other functions that a standard router performs, such as using the packet’s checksum to verify its integrity, updating the packet’s Time to Live (TTL) information after each hop, and processing any option information in the packet’s header. PPL3 switches typically communicate with each other using a routing protocol such as Routing Information Protocol (RIP) or Open Shortest Path First (OSPF) Protocol so that they become aware of the overall topology of the network.

  • Cut-through switches:
    These switches look into only the first packet of a series of packets to determine its logical layer 3 destination address (such as the destination IP address), and then switch the remainder of packets in the series using the layer 2 address (MAC address). This leads to higher data throughput rates.

In addition to performing layer 3 switching functions (routing functions), Layer 3 switches perform the functions of Layer 2 switches (bridging functions) at each switch interface. You can group switching interfaces in various ways to allocate bandwidth and contain broadcasts, which makes Layer 3 switches a powerful, scalable technology for building high-speed Ethernet backbone networks.

TIP

You can deploy a Layer 3 switch in your network anywhere a traditional router is used. The following table shows some of the differences between a traditional router and a Layer 3 switch.

Traditional Router vs. Layer 3 Switch
Feature | Router | Layer 3 Switch
Local area network (LAN) protocols supported | IP, IPX, AppleTalk | IP, IPX, AppleTalk
Packet-forwarding method | Software-based | Hardware-based
Throughput | Lower | Higher
Definition of subnet | Per port | Per layer 2 switching domain
Support for policy-based routing | Less | More
Relationship with bridges | Peer | Layered
Cost | Higher | Lower
See also
Ethernet switch

Layer 4 switch

Essentially, a Layer 3 switch that is capable of examining layer 4 of each packet that it switches. In TCP/IP networking, this is equivalent to examining the Transmission Control Protocol (TCP) layer information in the packet. Vendors tout Layer 4 switches as being able to use TCP information for prioritizing traffic by application. For example, to prioritize Hypertext Transfer Protocol (HTTP) traffic, a Layer 4 switch would give priority to packets whose layer 4 (TCP) information includes TCP port number 80, the standard port number for HTTP communication.

Some vendors foresee higher-layer switches that examine layer 5, 6, or 7 information to provide more control over prioritizing application traffic, but this might be just vendor hype.

LCP

See
Link Control Protocol (LCP)

LDAP

See
Lightweight Directory Access Protocol (LDAP)

leaf object

An element in the directory hierarchy that is the endpoint of a branch and cannot contain other objects in the way that containers can. An example of a leaf object is a mailbox in the directory of Microsoft Exchange Server, which is found within the Recipients container. You can view and manage objects in the Exchange directory hierarchy using the Exchange Administrator tool.

The term “leaf object” can also describe an endpoint of a branch in Active Directory of Microsoft Windows 2000. Leaf objects (or terminal objects) are found in containers such as organizational units (OUs) and cannot contain other directory objects. You can view and manage objects in Active Directory using Microsoft Management Console (MMC) by installing snap-ins such as Active Directory Users and Computers and Active Directory Sites and Services.

See also
Exchange Administrator, Microsoft Exchange Server

leased line

Also called a dedicated line, a telecommunications service provided to businesses by telcos and long distance carriers that provides a permanent direct connection between two geographically separate local area networks (LANs). Leased lines are dedicated circuits that the telco reserves for the exclusive use of the customer. They are permanently available, always active, and secure, and they have a consistent quality of service (QoS) and a flat monthly fee. However, they are very expensive compared to dial-up lines, and businesses rarely use their full bandwidth capabilities except in short bursts.

Leased lines are a form of point-to-point connection. Your LAN is connected by bridges, routers, modems, and terminal adapters to the telco’s central office (CO), which sets up dedicated switches to connect you to the destination LAN. The presence of dedicated switches is what makes leased lines so expensive. You would use a leased line to connect a Microsoft Exchange server to the Internet, for example. Since the leased line is always on, there is no connection delay when users try to access the server for their e-mail.

Leased lines are available in 56 Kbps, T1, T3, and higher speeds. They are used mainly for connecting customer premises to the telco CO. The charge for a leased line is based on both bandwidth and distance; leased lines are usually leased for a base monthly cost, and sometimes incur an extra monthly charge proportional to the traffic carried on the line.

Graphic L-3. Leased line.
Graphic L-3. Leased line.
NOTE

The opposite of a leased or dedicated line is a dial-up line or switched line.

See also
circuit-switched services, packet-switching services

LEC

See
local exchange carrier (LEC)

LFN

See
long filename (LFN)

license

A legal authorization to use software in a given networking scenario. Merely purchasing Microsoft Windows NT, Windows 2000, or any other Microsoft BackOffice software does not legally authorize you to use this software in a given networking scenario; you must also have the appropriate license. You generally obtain a server license for each server and a client access license (CAL) for each client that accesses the server.

In the BackOffice licensing model, each server and client computer is licensed separately. Each BackOffice server requires a server license. The server license is included when you purchase the particular BackOffice product, and it grants you the right to run that product on a particular computer. Each client connection to a BackOffice server requires a CAL, a legal document that grants a client machine the right to access the services provided by a BackOffice server. CALs are generally not included when you buy your BackOffice software and must be purchased separately. Every client machine, no matter what its operating system (Windows, Macintosh, UNIX, and so on), must have a CAL to access either basic Windows NT or Windows 2000 networking services such as file and print services, services for Macintosh, services for NetWare, or Remote Access Service (RAS) or to access any BackOffice application, such as Microsoft Exchange Server.

See also
client access license (CAL), License Manager, Per Seat licensing, Per Server licensing

License Logging Service

The Microsoft Windows NT service that creates and maintains the database of licensing information for License Manager and generates noncompliance events in the application log.

TIP

If your licensing database information becomes corrupt, you can delete and re-create it by doing the following:

  1. Stop the License Logging Service using the Services applet in Control Panel.

  2. Delete the licensing database files cpl.cfg, llsuser.lls, and llsmap.lls in the %SystemRoot%\system32 directory.

  3. Restart the License Logging Service.

  4. Add your licenses again using License Manager.

See also
client access license (CAL), license

License Manager

A Microsoft Windows NT administrative tool used to manage licenses for Microsoft BackOffice products on a network. You can use License Manager to do the following:

  • Add or delete client access licenses (CALs) for BackOffice products

  • Create license groups

  • Display licensing information

  • Change licensing from Per Server to Per Seat (one-time conversion)

License Manager can manage licensing on a local machine or over a network.

Graphic L-4. License Manager.
Graphic L-4. License Manager.
NOTE

To configure replication of a server’s licensing information to an enterprise server, use the Licensing tool in Control Panel.

See also
client access license (CAL), license

licensing mode

One of two types of client access license (CAL) for Microsoft Windows NT and Microsoft BackOffice. The two licensing modes are Per Server licensing and Per Seat licensing.

TIP

If you are denied a network connection to a server running Windows NT or BackOffice application running on a server because you have exceeded your licensing requirements, you might be able to free up existing connections without having to buy more licenses. Here are a few points to consider:

  • If you connect to the same server from two different client machines while logged on with the same username, you use up two licenses if you are running in Per Server mode.

  • IPX connections to basic file and print services on Windows NT take 15 minutes or more to time out when you disconnect.

  • Internet applications such as Microsoft Internet Explorer, File Transfer Protocol (FTP), and Telnet do not use up licenses.

  • NetDDE applications such as Clipboard Viewer do not use up licenses.

Lightweight Directory Access Protocol (LDAP)

An Internet protocol for accessing and updating information in an X.500-compliant directory. Users who run Lightweight Directory Access Protocol (LDAP) clients can connect to an X.500 directory service and add, delete, modify, or search for information if they have the appropriate access rights to the directory. For example, a user can use an LDAP client to search a network directory for individuals, users, companies, or other information stored in the directory. LDAP is designed to run over TCP/IP and can access information in both X.500-based directories and many non-X.500-based directories. The current version of LDAP is LDAPv3.

How It Works

LDAP was designed by researchers at the University of Michigan to be an easier, more streamlined version of the standard X.500 Directory Access Protocol (DAP), which requires a full Open Systems Interconnection (OSI) protocol stack to run. LDAP consists of only 16 commands—8 requests and 8 responses. These commands enable users to access, read, modify, and delete information in the directory if they have the appropriate permissions. Objects are referenced using their distinguished names, as in an X.500-based directory.

A directory that is designed specifically for LDAP clients is called an LDAP directory, but this is essentially the same as the X.500 directory structure. An LDAP directory is a distributed directory; portions of the directory can be stored on different directory servers in the network. These directory servers periodically synchronize with each other to keep their information up to date. The root of an LDAP directory branches into countries, then organizations, then organizational units (departments, sections, and so on), and finally into leaf objects, which can include people, servers, printers, and other network objects.

Microsoft Exchange Server stores its directory information in an X.500-style directory. Microsoft Outlook Express is a simple LDAP client that can be used to access personal information about recipients in an Exchange organization.

NOTE

Directory services that are not fully X.500-compliant but can be accessed and managed using LDAP are sometimes called LDAP directory services. An example of an LDAP directory is Active Directory in Microsoft Windows 2000.

Objects within an LDAP directory are identified by their distinguished names, the standard namespace for X.500 directories. Distinguished names are also sometimes referred to as the LDAP Standard Naming Convention.

An LDAP Uniform Resource Locator (URL) is another naming convention that can be used to allow LDAP clients to access objects in an LDAP directory. An LDAP URL is formed by appending the distinguished name of the directory object to the fully qualified domain name (FQDN) of the server containing the LDAP directory. For example, if Active Directory is installed on the server Server7.Microsoft.com, and the distinguished name of the object being referenced in Active Directory is

DC=com,DC=Microsoft,OU=Users,CN=Jeff Smith

the LDAP URL for referencing this object using an LDAP client is

LDAP://Server7.Microsoft.com/CN=Jeff Smith/OU=Users/DC=Microsoft/DC=com
See also
Active Directory, distinguished name, X.500

line booster

A device that can regenerate or boost the signal strength in serial and parallel transmission so that you can use longer cables. Line boosters typically work with the RS-232 interface and can be used to increase the allowable distance between computers and peripherals (such as printers), usually doubling the distance from 15 meters to 30 meters for serial transmission and from 6 meters to 12 meters for parallel transmission. Line boosters are needed in some networking environments because the signal strength in a serial transmission line decreases with the length of the cable being used.

TIP

Line boosters must be installed at the midway point between the computer and the peripheral, not at one end of the connection.

Graphic L-5. Line booster.
Graphic L-5. Line booster.

line coding

A method of placing digital signals on a wire. Line coding specifies the relationship between the binary information in a data bitstream and the square-wave voltage variations on the wire that represent this information electrically.

For example, Integrated Services Digital Network (ISDN) technologies use several different line coding schemes. The U interface, which is located at the ISDN line termination point at the customer premises where a two-wire metallic cable terminates with an RJ-11 jack, uses the 2 binary, 1 quaternary (2B1Q) line coding scheme for Basic Rate Interface ISDN (BRI-ISDN) and the Bipolar with 8 Zero Substitution (B8ZS) scheme for Primary Rate Interface ISDN (PRI-ISDN) in the United States. European ISDN uses 4 binary, 3 ternary (4B3T) for BRI-ISDN and High Density Bipolar 3 (HDB3) for PRI-ISDN.

In the 2B1Q line coding scheme, a block of two binary bits can represent four different values: 00, 01, 10, and 11. These four values are mapped to one quaternary value, which is encoded using four different voltages. The first bit represents a positive or negative voltage, and the second bit represents either 1-volt or 3-volt line potential. The following table shows the four possible combinations.

Graphic L-6. Line coding.
Graphic L-6. Line coding.
Binary Data and Corresponding Voltage Level for 2B1Q Line Coding
Binary Data Represented | Voltage of Electrical Pulse
00 | -3
01 | -1
10 | +3
11 | +1

The result of using 2B1Q line coding for BRI-ISDN is that a single electrical pulse represents 2 binary bits instead of 1 binary bit. This effectively doubles the possible bandwidth of the communication channel, as shown in the illustration.

NOTE

The term “line coding” sometimes refers to signal modulation technologies used in Digital Subscriber Line (DSL) technologies.

line conditioner

Any device that is used to prevent undesirable electrical signals from damaging computer, networking, or telecommunication equipment and to guard against data loss due to electrical noise, sags, and surges. Sometimes called a line shaper, a line conditioner can also ensure that the parameters of the signal remain within specifications for the medium or interface being used, even over excessively long or noisy transmission lines. By maintaining signal integrity, line conditioners can allow communication devices to function at higher throughput rates.

How It Works

Line conditioners contain circuitry that enables them to filter out noise caused by electromagnetic interference (EMI) and other sources. They also contain isolation transformers that electrically isolate the circuitry from unwanted DC voltages, impedance-matching circuitry for reducing unwanted signal reflections, and surge suppressors to guard against high-voltage surges (6000 volts or more) caused by lightning strikes and power failures. Line conditioners can also correct sags (drops) in voltages caused by momentary brownouts, but they are not meant to replace or supply power during a power loss. They often include fault indicators and audible alarms.

You can use line conditioners in the following places:

  • In power supplies and in uninterruptible power supply (UPS) systems (power conditioners) to protect computers and networking devices from AC surges coming through power lines.

  • In local area networks (LANs) to protect hubs, routers, and other networking equipment from EMI and unwanted noise coming through the networking cables, and to maintain the integrity of network data signals.

  • In offices to protect modems, telephones, fax machines, and other equipment by filtering out electrical surges in phone lines and to reduce noise so that the devices can operate at their nominal throughput speeds.

  • In WAN links for protecting CSU/DSUs (Channel Service Unit/Data Service Units) and access servers connected to Integrated Services Digital Network (ISDN), T1, and other copper telecommunication lines against EMI surges. T1 lines must have line conditioners at regular intervals to ensure the integrity of the signal transmitted over the line.

TIP

Line conditioners can often improve analog modem transmission speeds, enabling high-speed modems to function at their maximum transmission speeds over noisy telephone lines in the local loop.

line driver

A device that can use installed twisted-pair phone lines or leased lines to connect terminals to servers in different parts of a building or in different buildings. A line driver is essentially a combination of a signal converter and an amplifier for digital signals. The signal converter performs line conditioning, and the amplifier increases the signal strength. Also called a “short-haul” device, a line driver allows a signal produced by a serial transmission device using an interface such as RS-232 to be carried over a longer distance than the interface standard allows, which for RS-232 is only 15 meters.

How It Works

Line drivers are always used in pairs. One line driver is placed at the local site and is connected to the terminal, while the other is located at the remote site and is connected to the server. Line drivers are typically used to extend the maximum distance of serial communication protocols such as RS-232, V.35, X.21, and G.703 and can provide either synchronous or asynchronous communication in various vendor implementations. Considerations for line driver type include full-duplex or half-duplex communication, 2-wire or 4-wire cabling options, and various kinds of connectors. The most common type of line driver uses an RS-232 serial interface for synchronous transmission of data over installed 4-wire telephone cabling. These line drivers can extend the maximum distance of RS-232 serial transmission from 15 meters to several kilometers.

For intrabuilding connections using line drivers, copper unshielded twisted-pair cabling or the installed telephone lines are typically used. For interbuilding connections, fiber-optic cabling is preferred.

NOTE

Line drivers are available for almost every kind of communication mode, from 19.2-Kbps RS-232 serial line drivers over 6 kilometers to 2-Mbps single-mode fiber-optic line drivers over 18 kilometers. Line drivers for parallel connections can extend parallel transmission of data from about 6 meters to several kilometers. Line drivers are also used in implementation of T1 lines.

Graphic L-7. Line driver.
Graphic L-7. Line driver.
TIP

When you use line drivers, your maximum bandwidth and transmission distance are inversely related—that is, the longer the line, the less bandwidth you have.

For connecting data terminal equipment (DTE) such as two computers, you should use a modem eliminator instead.

line filter

A device used to suppress noise in a transmission line or cable, caused by electromagnetic interference (EMI). EMI is produced by nearby power lines, motors, generators, and other sources. EMI can introduce noise into a transmission line or cable that can degrade the quality of a signal or even make communication impossible. By inserting a line filter at the appropriate point, you can suppress the noise and potentially improve transmission speeds.

Line filters might be needed in homes or small businesses that use modems to connect to the Internet through a dial-up connection over the local loop. High-speed V.90 modems sometimes have difficulty attaining their top data transfer speeds because of ambient line noise caused by nearby sources of EMI. By placing a line filter at the customer premises between the modem and the Plain Old Telephone Service (POTS) connection, you can filter out noise, which could improve modem speeds.

Graphic L-8. Line filter.
Graphic L-8. Line filter.
TIP

Before installing a line filter, you should use a radio frequency (RF) spectral analyzer to determine the general frequency of the source of EMI so that you can choose an appropriate line filter. Line filters typically filter out one of the following frequency ranges: low frequency (LF), high frequency (HF), very high frequency (VHF), or ultra high frequency (UHF) signals.

Line Printer Daemon (LPD)

A general TCP/IP daemon on UNIX networks that is used for receiving and spooling print jobs on a print server. The Line Printer Daemon (LPD) print server might be connected directly to the print device, or it might be a network print device that supports LPD. UNIX clients send their jobs to the printer by using the Line Printer Remote (LPR) utility; you can use another utility called Line Printer Queue (LPQ) to check the status of print jobs spooled on the server.

Microsoft Windows NT Server has an optional LPD service that you can install on the machine by installing the Microsoft TCP/IP Printing service, which enables computers running UNIX to send print jobs to the computer running Windows NT by using LPR. Computers running Windows NT can also use the LPR command to send print jobs to a Windows NT server running LPD. The Microsoft TCP/IP Printing service thus provides Microsoft Windows/UNIX printing interoperability for heterogeneous network environments.

Windows 2000 Server uses Microsoft Print Services for UNIX, which provides both LPD and LPR services through two Windows 2000 services:

  • LPDSVC:
    Runs on the Windows 2000 print server and receives print jobs from native LPR utilities running on UNIX workstations.

  • LPRMON:
    Runs on the Windows 2000 print server and forwards print jobs to native LPD processes running on UNIX computers with attached printers.

TIP

The startup configuration for the LPD service on Windows 2000 is set to Manual by default and should be changed to Automatic if this feature is used.

Graphic L-9. Line Printer Daemon (LPD).
Graphic L-9. Line Printer Daemon (LPD).

Line Printer Queue (LPQ)

A general TCP/IP utility on UNIX networks that is used for querying the status of the print queue on a print server. The UNIX print server runs a daemon called the Line Printer Daemon (LPD), and the client printing the job uses a utility called the Line Printer Remote (LPR). You can use the lpq command on a server running Microsoft Windows NT that has the Microsoft TCP/IP Printing service installed (or a server running Windows 2000 that has Microsoft Print Services for UNIX installed) to display the status of the print queue on a UNIX LPD server, a Windows NT–based server running the LPD service, or a Windows 2000–based server running the LPDSVC service.

The lpq command displays a list of files on the server that are waiting to be printed. You can also use this command to check the print queue on a UNIX print server; this is one way that Windows NT and Windows 2000 provide interoperability between the UNIX and Windows environments.

Example

Enter the command lpq -S Server7 -P Laser12 to display the status of the print queue Laser12 on a Windows NT–based server named Server7 that is running the LPD service.

Line Printer Remote (LPR)

A general TCP/IP utility on UNIX networks that is used to send print jobs from clients to print servers. A print server is a UNIX machine running the Line Printer Daemon (LPD) process. In Microsoft Windows NT–based or Windows 2000–based networks that use TCP/IP, you use the lpr command to send print jobs to a UNIX LPD server, a Windows NT–based server running the LPD service, or a Windows 2000–based server running the LPDSVC service.

For example, to configure a computer running Windows NT for Line Printer Remote (LPR) printing to a UNIX LPD print server, use the Network utility in Control Panel to install the optional service called Microsoft TCP/IP Printing on your machine. Then use the Add New Printer Wizard to create a new printer, adding a new LPR port that maps to the IP address or fully qualified domain name (FQDN) of the UNIX host running the LPD service and attached to the print device or the stand-alone network print device.

Example

Enter the command lpr -S Server7 -P Laser12 readme.txt to print the readme.txt file using the print queue Laser12 on the Windows NT–based server named Server7, which is running the LPD service.

NOTE

The file to be printed using the lpr command must be a text file or a file specially formatted for the printer being used (for example, a PostScript file for a PostScript printer).

line sharer

A device that allows many devices to share the same line. Examples of line sharers include the following:

  • Host line sharers:
    Allow multiple terminals or other data terminal equipment (DTE) to be connected to an asynchronous mainframe host over a single, shared serial transmission line using V.35 adapters and cable. You can use host line sharers primarily to broadcast data to the DTEs. Data transmitted by the DTEs can also be buffered in the line sharer until the line is free and the data can be sent to the host. Host line sharers typically use either RS-232 or V.35 serial interface connections.

  • PSTN line sharers:
    Allow multiple Public Switched Telephone Network (PSTN) devices, such as phones, fax machines, and modems, to share one or more phone lines by using RJ11 connectors and adapters. You can often program PSTN line sharers to switch between devices based on calling tones, so that you can remotely control data collection equipment over modems in industrial environments. A small line sharer might let you connect four phones or other devices to two shared phone lines for a small office/home office (SOHO). Other line sharers connect large numbers of phones to a relatively small number of phone lines on a first-come, first-served basis in modem-pooling environments.

    • Graphic L-10. Three varieties of line sharer.
    Graphic L-10. Three varieties of line sharer.

  • Internet line sharers:
    Typically stand-alone devices that together with RS-232 modem adapters allow several PCs to share one modem for dial-up connection to the Internet. Internet line sharers typically use one IP address to allow multiple users to browse the Internet simultaneously.

Link Control Protocol (LCP)

A subprotocol within the Point-to-Point Protocol (PPP) protocol suite that is responsible for link management.

How It Works

Link Control Protocol (LCP) operates at the data-link layer (layer 2) of the Open Systems Interconnection (OSI) reference model for networking and is considered a data-link layer protocol. During establishment of a PPP communication session, LCP establishes the link, configures PPP options, and tests the quality of the line connection between the PPP client and PPP server. LCP automatically handles encapsulation format options and varies packet sizes over PPP communication links.

LCP also negotiates the type of authentication protocol used to establish the PPP session. Different authentication protocols are supported for satisfying the security needs of different environments. LCP can negotiate the following authentication protocols:

  • Password Authentication Protocol (PAP):
    Transmits passwords in clear text using a two-way handshake

  • Shiva PAP (SPAP):
    A vendor-specific implementation of PAP

  • Challenge Handshake Authentication Protocol (CHAP):
    Passes a password hash using a three-way handshake and is more secure than PAP or SPAP

  • Microsoft Challenge Handshake Authentication Protocol (MS-CHAP):
    Microsoft’s implementation of CHAP, which is more secure than regular CHAP

See also
Point-to-Point Protocol (PPP)

Link Monitor

A component of Microsoft Exchange Server that verifies the state of a connection between Exchange servers and foreign mail systems. Link Monitors determine whether the messaging link to another mail system is functioning correctly. You should configure Link Monitors for all your connections to remote mail systems from your Exchange organization.

How It Works

The system attendant service sends test messages between the Exchange servers and the foreign mail system at every polling interval and measures the round-trip messaging time.

Link Monitor messages are simply ordinary e-mail messages that the system attendant sends automatically at regular intervals. When a messaging link fails, the Link Monitor can perform a series of escalating actions that can include sending an alert, sending an e-mail notification, or activating a pager.

Graphic L-11. Monitoring a link.
Graphic L-11. Monitoring a link.

link state routing algorithm

A routing method used by dynamic routers in which every router maintains a database of its individual autonomous system (AS) topology. The Open Shortest Path First (OSPF) routing protocol uses the link state routing algorithm to allow OSPF routers to exchange routing information with each other.

How It Works

An AS or routing domain is a group of networks that use the same routing protocol and are under common administration. All routers in an AS have identical link state databases, which contain information about each router’s local state. Routers distribute their local state by using link state advertisements (LSAs), which contain information about neighbors and route costs. From these LSAs, each router builds a hierarchical tree containing least-cost paths to other networks, with the router itself as the root of the tree. Least-cost paths are determined by preassigned factors such as the number of hops between routers, the speeds of the network links connecting them, and traffic flow patterns.

The link state routing algorithm used by the OSPF protocol offers the following advantages over the distance vector routing algorithm used by the Routing Information Protocol (RIP):

  • RIP routers exchange their entire routing table on a periodic basis, adding to overall network traffic, while OSPF routers exchange only routing table updates.

  • RIP routers use only the single metric hop count to create their routing tables, while OSPF routers can also use link speeds and traffic patterns to establish cost values for routing traffic.

On the other hand, OSPF requires considerably more processing on the part of the router, making it more expensive to implement. OSPF is also more complex to configure than RIP.

See also
distance vector routing algorithm

Linux

An operating system derived from the UNIX family of operating systems that is POSIX-compliant and freely distributed through many sites on the Internet. Linux was developed in 1991 by a student from Finland named Linus Torvalds, who still controls the development of the Linux operating system kernel. However, numerous individuals have made important contributions over the years to the operating system. A typical Linux distribution includes the Linux kernel and supporting files, the GNU C/C++ compiler, the Xfree86 version of the X Windows graphical interface, the Apache web server, and other tools and utilities, plus source code for everything. Linux is supported by a network of thousands of users and developers who continue to improve its functionality and performance.

Linux is a good starting point for students interested in learning the UNIX operating system. It has also found a niche in some companies for specific server-based solutions such as Web servers and mail gateways, but some corporations are reluctant to utilize free software such as Linux in their mission-critical operations, because there is no single company responsible for its development and support. Recently, companies such as Red Hat have sought to enhance the usability of Linux in the corporate environment by providing technical support along with easy-to-install Linux distribution.

On the Web
•
Linux Online
: http://www.linux.org
•
Red Hat Software home page
: http://www.redhat.com

list server

A program that maintains an e-mail mailing list and allows messages to be distributed to its members. For example, a company or organization might set up a list server to run mailing lists for discussing marketing issues, asking and receiving answers from technical support, announcing new products and services, or disseminating tips and tricks for using software.

How It Works

Common list server programs include Listserv and Majordomo. Listserv was originally developed for the BITNET/EARN network. Users must first subscribe to a mailing list using a special e-mail command, although many lists also have Web interfaces for subscribing, unsubscribing, posting messages, and receiving help. Once users subscribe to a list, they receive a copy of every message posted to the list, and every message they post is distributed to all members of the list.

NOTE

Microsoft maintains a number of popular mailing lists relating to various Microsoft products and services. The URL for subscribing to these lists appears at the end of this entry.

TIP

Don’t subscribe to too many mailing lists at once, because the e-mail traffic might fill your mailbox!

On the Web
•
Search The List of Lists
: http://catalog.com/vivian/interest-group-search.html

LLC layer

See
logical link control (LLC) layer

lmhosts file

A text file that provides a local method for name resolution of remote NetBIOS names into their respective IP addresses on a TCP/IP network. Using lmhosts files is an alternative to using WINS servers for name resolution on Microsoft Windows–based networks. Using a WINS server is generally preferable because it reduces administrative overhead.

How It Works

You can find the lmhosts file in the %SystemRoot%\system32\drivers\etc directory in Windows NT and Windows 2000 and in the \Windows directory in Windows 95 and Windows 98.

Each line in the lmhosts file contains the IP address of a NetBIOS computer on the network, followed by the NetBIOS name of the computer. The computer name can be followed by optional prefixes that identify domains and domain controllers and allow entries to be loaded into the NetBIOS name cache at startup. Comments are prefixed with the pound sign (#). Here is an example taken from the sample lmhosts file included with Windows 95:

102.54.94.97  rhino     #PRE #DOM:networking
#net group's DC
102.54.94.123 popular   #PRE      #source server
102.54.94.117 localsrv  #PRE      #needed for the include
NOTE

The lmhosts file contains mappings for hosts on remote networks only. Mappings are not required for hosts on local networks because these can be resolved using broadcasts. If you are using lmhosts files to resolve NetBIOS names on a network, each computer on the network should have an lmhosts file.

TIP

Place the NetBIOS names that need to be resolved most frequently near the top of the lmhosts file, because the file is parsed linearly from the beginning.

See also
hosts file, networks file, protocol file, services file

load balancing

Providing access to resources on a group of servers in such a way that the workload of serving clients is shared among the servers. Numerous vendors supply hardware and software-based load balancing solutions for enterprise networking. Microsoft in particular implements various forms of load balancing in its products, including the following:

  • Microsoft Cluster Server (or Windows Clustering in Windows 2000):
    Provides static load balancing for high availability of shared resources. Each node in a cluster shares its own resources or applications, and if failover occurs, the nodes still running can assume the services of the other nodes. This leads to load balancing and high performance.

  • Microsoft Proxy Server version 2:
    Provides load balancing of Winsock Proxy (WSP) client connections across several proxy servers by specifying the servers’ IP addresses in the mspclnt.ini file, which is copied from the server to the client when the WSP client is set up. This file enables clients to randomly select which proxy server to use each time they issue a proxy request.

  • Microsoft DNS Service in Windows NT Server:
    Supports round-robin DNS service. If you list several IP addresses for the same host name in a DNS zone file, clients connecting to the DNS server to resolve the host name receive the IP addresses in round-robin fashion. This is a simple form of load balancing.

  • Microsoft SNA Server version 4:
    Provides load balancing and fault tolerance for connectivity with AS/400 systems.

Various network devices can also implement load balancing. For example, routers use load balancing when routing tables indicate that two or more routes to a destination have the same cost. This use of routers allows you to use different LAN segments more effectively, resulting in greater availability of overall network bandwidth.

local address

The address that a computer on a TCP/IP network uses to access another computer on the same subnet of the network. For example, consider a TCP/IP network with the following subnet scheme:

  • Network ID = 202.55.0.0

  • Subnet Mask = 255.255.240.0

Using this scheme, there are 14 possible subnets for the network:

  • Subnet 1 has hosts 202.55.16.1 through 202.55.31.254.

  • Subnet 2 has hosts 202.55.32.1 through 202.55.47.254.

  • Subnet 3 has hosts 202.55.48.1 through 202.55.63.254.

  • Subnet 14 has hosts 202.55.224.1 through 202.55.239.254.

Now consider the following three hosts on the network:

  • Host A = 202.55.38.147

  • Host B = 202.55.44.12

  • Host C = 202.55.59.6

From the point of view of Host A, which is located on Subnet 2:

  • Host B is located on the local subnet (Subnet 2), so Host B’s address is local to Host A.

  • Host C is located on a remote subnet (Subnet 3), so Host C’s address is remote to Host A.

Local Address Table (LAT)

A component of Microsoft Proxy Server created during the setup process that contains information about your company’s private network. The Local Address Table (LAT) is a text file that specifies the ranges of IP addresses that are used in your private (local) network. IP addresses that are external to your private network are excluded from the LAT. The LAT is used by Proxy Server clients to determine whether they should attempt to contact a host directly or make a proxy request through Proxy Server.

How It Works

The LAT consists of a series of IP address pairs that define either a range of IP addresses or a single IP address. Addresses can be added to the LAT either automatically from the Microsoft Windows NT internal routing tables (which occurs when Proxy Server is first set up) or manually, by entering IP address pairs.

The LAT is contained in a file named msplat.txt and is stored with a client setup program on the proxy server in C:\Mspclnt. This directory is automatically shared; clients can connect to this share to run the client setup program, which configures the client computer to function as a client of the Winsock Proxy (WSP) service. The client setup program attempts to configure the client computer’s Web browser as a client of the Web Proxy service. The client setup program also copies the LAT file to the client. Proxy Server is responsible for ensuring that the client always has the most current version of the LAT.

The LAT is used each time a Windows Sockets application on the client tries to establish a connection to an IP address to determine whether the IP address is on the private network or on an external network. Connections to internal networks are made directly, while connections to remote addresses use the WSP service on Proxy Server.

NOTE

During Proxy Server setup, the LAT is automatically generated from the internal Windows NT routing tables, but these generated addresses might not completely define your private network. You should therefore review the generated list of IP addresses and add any needed IP address pairs until all addresses of your internal network are defined. You should also remove any IP address pairs that define external addresses.

Local Area Data Channel (LADC)

A telco service for transmitting data using line drivers. Local Area Data Channel (LADC), also called telco restricted lines, conforms to the Bell 43401 standard published by AT&T. The LADC standard specifies “dc continuity,” which basically means that metallic (copper) conductors (usually the unshielded twisted-pair cabling used for phone lines) must be used. LADC lines must also be unloaded—that is, without terminators, loading coils, or protection circuitry that can add to the inductance of the line and thus distort signals. LADC lines are available to distances of 5 kilometers from the telco’s central office (CO); the longer the distance, the lower the bandwidth supported.

local area network (LAN)

A group of computers located in the same room, on the same floor, or in the same building that are connected to form a single network. Local area networks (LANs) allow users to share storage devices, printers, applications, data, and other network resources. They are limited to a specific geographical area, usually less than 2 kilometers in diameter. They might use a dedicated backbone to connect multiple subnetworks, but they do not use any telecommunication carrier circuits or leased lines except to connect with other LANs to form a wide area network (WAN).

How It Works

Before you can link computers into a LAN, you must install a network-aware operating system on them to enable them to share resources. The choice of operating system depends on whether the network will be a peer-to-peer network or a server-based network. Microsoft Windows 98 is a good choice for peer-to-peer workgroup LANs, while Windows NT and Windows 2000 offer the security and scalability needed to support a server-based network.

Next, you choose a networking architecture. (The vast majority of LANs use Ethernet.) Then you must install a suitable network interface card (NIC) in an available slot on the motherboard of each node (computer) in the network. You must also install a software driver to control the card’s functions. You use cabling to join the NICs in order to enable the computers to communicate with each other. The most common type of cabling used in LANs is unshielded twisted-pair (UTP) cabling. The cabling is installed in some kind of topology or layout, the most popular of which is the cascaded star topology used in the 10BaseT version of Ethernet. You then choose a protocol to enable the nodes on the network to speak a common “language"; the most popular protocol is TCP/IP, especially for Internet connectivity, although for small stand-alone workgroup LANs that use Windows 95 or Windows 98, NetBEUI is still popular.

See also
wide area network (WAN)

local exchange carrier (LEC)

A telco in the United States that provides local telephone and telecommunication services to businesses and individuals. “Local exchange” refers to a telco’s central office (CO), and “carrier” refers to a company that “carries” telephone and data traffic for customers. In other words, your local exchange carrier (LEC) is simply the company that sends you a telephone bill for local phone calls. An LEC owns the local loop cabling between its CO and its subscribers’ premises, which are confined to a geographical area known as the local access and transport area (LATA). Any calls that take place within a given LATA are considered local calls and are billed accordingly.

The largest LECs came into existence with the breakup of AT&T in the early 1980s, which led to the formation of several independent Regional Bell Operating Companies (RBOCs), but there are also a number of smaller independent LECs in the United States, especially in rural areas that were never part of the Bell system. LECs connect their communication networks using inter-exchange carriers (IXCs), which are long-distance carriers such as Sprint, AT&T, and MCI WorldCom.

The Telecommunications Act of 1996 changed the landscape of the telephone system in the United States by allowing LECs to compete in the deregulated long-distance market and by allowing IXCs to provide services directly to customer premises through mergers, acquisitions, and new technologies. Before 1996, each LEC was also an incumbent local exchange carrier (ILEC) that was the sole provider of telephone services to subscribers in its geographical region. The Telecommunications Act allowed companies to become competitive local exchange carriers (CLECs) that could compete with ILECs in their area by leasing or purchasing services from the ILECs or installing their own systems. LECs have an advantage in that they already own a right-of-access to customer premises, while IXCs have an advantage in that they are larger, more highly capitalized companies that can afford to invest heavily in new technologies and services or even acquire LECs directly.

See also
inter-exchange carrier (IXC)

local group

In Microsoft Windows NT–based networks, a type of group that exists only on the local computer on which it is created. On a Windows NT member server or workstation, local groups reside in the local security database on the computer. A local group created on a domain controller, however, exists on all domain controllers in the domain because domain controllers in the same domain share the same security database.

Local groups are used within an enterprise-level Windows NT network to provide users with permissions for accessing network resources and rights for performing system tasks. You generally create local groups for specific groups of resources on the network and assign these local groups suitable permissions on the resources. A collection of global user accounts can be made into a global group. Global groups are placed into local groups to give users access to resources on the network. This process is referred to as AGLP. Note that local groups can contain global user accounts and global groups from any trusted domain, but they cannot contain other local groups.

A Windows 2000–based network can have both local groups and domain local groups. Local groups are for computers running Windows 2000 that are not part of a domain, and they exist only within the local security database of the computer on which they were created. Local groups are used for granting users who are interactively logged on to a computer running Windows 2000 access to resources on that computer. Local groups can contain only local user accounts from the same machine. Domain local groups, however, have a domain-wide scope and provide users with access to resources located anywhere in a domain. You create local groups on a stand-alone machine running Windows 2000 by using the tool Local Users and Groups, which is implemented as a snap-in for Microsoft Management Console (MMC).

TIP

You should use local groups only on stand-alone Windows 2000 servers and workstations that are not part of a domain.

See also
AGLP, built-in group, global group, group

localhost

See
loopback address

local loop

The portion of the telephone system that connects your home or office to the nearest central office (CO) of your local telco. The wiring used in the local loop is usually unshielded twisted-pair (UTP) cabling, the transmission method is analog transmission, and the maximum distance from the telco’s CO to the subscriber’s customer premises is about 5 kilometers.

Graphic L-12. Local loop.
Graphic L-12. Local loop.
NOTE

In many urban and commercial areas, the local loop is being upgraded to Integrated Services Digital Network (ISDN), which uses the same wiring but provides all-digital communication for better voice and data connections. Asymmetric Digital Subscriber Line (ADSL) is another technology that is becoming popular, especially for high-speed residential Internet access.

local network

The network consisting of all computers with the same network number. For example, on a TCP/IP internetwork, a user’s local network consists of all the computers that have the same network ID number, such as 208.16.8.0. Each computer on the local network has a different host ID to identify it among other hosts on the local network. Examples of host IDs for the network 208.16.8.0 could be .25 for 208.16.8.25, .26 for 208.16.8.26, and so on.

The term “local network” can also describe hosts that are on the same TCP/IP subnet in a large internetwork or hosts that are on the same physical LAN segment, such as all the hosts connected to the same hub in an Ethernet network. The term is vague, so you must determine its meaning from the context in which it is used.

Local Procedure Call Facility (LPC Facility)

A component of the Microsoft Windows NT executive running in kernel mode that is responsible for message passing. In the Windows NT operating system, applications and their supporting environmental subsystems function in a client/server relationship even though both are located on the same machine. The Local Procedure Call Facility (LPC Facility) provides the mechanism for client and server components to send messages to each other. The LPC Facility functions in essentially the same way that remote procedure calls (RPCs) do, except with RPCs the client and server components are located on different machines.

When an application on a computer running Windows NT needs to call an application programming interface (API) function on an environmental subsystem such as the Win32 subsystem, the client uses a placeholder called a stub, which is located in a dynamic-link library (DLL). The stub is used to package and send the parameters being passed to the server subsystem process that implements the call, which unpackages them and executes the called function. The LPC Facility then waits for a response to be issued back. From the application’s point of view, however, the whole process appears to take place locally within the DLL. The application is unaware that the DLL has forwarded the call to another API using the LPC Facility.

Local Security Authority (LSA)

The central component of the security subsystem in the Microsoft Windows NT operating system. The Local Security Authority (LSA) is responsible for managing interactive logons to the system. When a user attempts to log on locally to the system by entering a username and password in the logon dialog box, the logon process invokes the LSA, which passes the user’s credentials to the Security Accounts Manager (SAM), which manages the account information stored in the local SAM database. The SAM compares the user’s credentials with the account information in the SAM database to determine whether the user is authorized to access the system. If it finds the user account information in the SAM database, the SAM authenticates the user by creating a logon session and returning the security identifier (SID) of the user and the SIDs of global groups of which the user is a member to the LSA. The LSA then grants the user an access token that contains the user’s individual and group SIDs and their rights; these enable the user to access resources for which he or she has permissions.

The LSA is also responsible for other security-related functions, including the following:

  • Managing the local security policy on the computer, such as maximum number of logon attempts allowed and account lockout settings

  • Managing the audit policy on the computer and logging any events generated by the Security Reference Monitor

NOTE

In Windows 2000, Active Directory is functionally located within the LSA in the form of a module called the Directory Service module.

local security database

The database of user and group accounts on a server or workstation running Microsoft Windows NT installed as part of a workgroup. In the workgroup security model, each computer running Windows NT is responsible for authenticating users who try to log on locally (interactively) to a particular machine. Each computer in a workgroup maintains its own independent local user and group accounts in its local security database. This is in contrast to a domain security model, in which the security database for all computers in the domain is kept on special machines called domain controllers. The local security database also contains the local security policy for the machine, which governs such things as password expiration and account lockout settings. The local security database is also called the SAM database because it is managed by the Security Accounts Manager (SAM), a component of the Windows NT security subsystem on the local machine.

NOTE

If a machine running Windows 2000 is installed in a workgroup, the database of account information stored on that machine is also called the local security database.

See also
Security Account Manager (SAM) database, security subsystem

local user account

In Microsoft Windows NT–based networks, a user account that resides in the local security database of a particular Windows NT member server or workstation. When a user has a local account on a computer, the user can log on to the computer interactively.

In a Windows NT–based network based on the workgroup security model, all user accounts are local user accounts and are created using the administrative tool called User Manager, the version of User Manager for Domains that is installed on stand-alone Windows NT member servers and workstations. In a Windows NT–based network that is based on the domain security model, new user accounts created using User Manager for Domains are by default global user accounts that are valid everywhere in the domain and are stored in the Security Accounts Manager (SAM) database on domain controllers. However, in a domain you can also create a local account with User Manager for Domains by clicking the Account button in the New User dialog box and specifying Local Account as the Account Type. This is generally not recommended because local user accounts are not valid throughout the domain and are valid only for logging on interactively to the computer on which they are created.

In a Windows 2000–based network, a local user account is one of three types of user accounts, the others being domain user accounts and built-in accounts. Local user accounts enable users to log on interactively to stand-alone Windows 2000 servers or client computers in a workgroup and access system resources on the machine for which they have suitable permissions. Domain user accounts allow users to log on to a domain and access resources anywhere in the domain. Local user accounts are created using the Local Users and Groups tool, which is implemented as a snap-in for Microsoft Management Console (MMC). Local user accounts are stored in the local security database on the machine on which they are created, while domain user accounts are created in Active Directory and stored in organizational units (OUs).

See also
built-in account, domain user account, global user account

local user profile

A user profile stored locally on a computer running Microsoft Windows NT. A local profile is created for a user the first time the user successfully logs on to his or her computer. If the user does not have a preconfigured roaming user profile at the time of the first logon, Windows NT copies the default user profile to the new local user profile folder.

Local profiles are created for all users who interactively log on to computers running Windows NT so that they can access their own personal settings on that machine. Each user who logs on to a machine thus has his or her own local profile stored on the machine. Local profiles are stored in the folder %SystemRoot%\Profiles.

Each user’s profile is stored in a subfolder that is named after the username of the user and contains the user’s personal settings. The personal settings include both the appearance of the desktop and Start menu and the user’s network connections (such as mapped drives). Even if users have a roaming profile that allows them to log on from any machine in the network and obtain their personal settings, each machine also stores a local copy of their profiles in case the network is down when they try to log on.

Graphic L-13. Local user profile.
Graphic L-13. Local user profile.
NOTE

Windows 2000, Windows 95, and Windows 98 also support local user profiles. In Windows 2000, local user profiles are stored in the Documents and Settings folder.

See also
roaming user profile, user profile

Local Users and Groups

A Microsoft Windows 2000 administrative tool available on member servers running Windows 2000 Server and client computers running Windows 2000 Professional that you can use to create and manage local user accounts and local groups on the machine. Local Users and Groups is implemented as a snap-in for Microsoft Management Console (MMC), like other Windows 2000 administrative tools.

You can use Local Users and Groups only if a workgroup security model is being used for your network. In a workgroup, each computer manages its own security and maintains its own local security database of account information. If your network uses a domain security model, all user accounts for the domain are stored in Active Directory, which contains a distributed domain directory database maintained by domain controllers on your network. You cannot install Local Users and Groups on domain controllers; on these machines, you should use Active Directory Users and Computers for creating domain user accounts.

See also
Active Directory Users and Computers

locking

A mechanism in Microsoft SQL Server that protects a database against data loss when users simultaneously attempt to modify the same database object. Locking synchronizes users’ access to the database and prevents concurrent data manipulation problems to ensure that data remains consistent and query results are correct.

How It Works

Locking provides concurrency in a multiuser environment—that is, it enables multiple clients to simultaneously access and modify a database without the danger of the data becoming corrupted. If one user locks a portion of the database to view or modify data, that data cannot be accessed or modified by any other user until the first user’s updates have been committed.

SQL Server version 7 uses multigranular locking, in which each database resource is locked at a level appropriate for that kind of resource. The following table shows the various database resources that can be locked in SQL Server 7, in order of decreasing granularity. This range of granularity allows a balance between concurrency (the ability of multiple clients to simultaneously access a database) and performance (speed). For example, highly granular locking such as row-level locking allows more concurrency (different users can simultaneously modify different rows in the same database table), but this increases system overhead because the server must manage more locks.

Database Resources That SQL Server 7 Can Lock
Locked Resource | Description
DB | Locks the entire database
Table | Locks an entire database table, including its data and indexes
Extent | Locks a contiguous group of eight data pages or eight index pages
Page | Locks individual 8-KB data pages or index pages
Key | Locks a row within an index
RID (row identifier) | Locks individual rows in a table

SQL Server uses a number of resource lock modes that specify how different database resources can be accessed by concurrent transactions. These include the following:

  • Shared locks:
    Allow concurrent transactions to read data—for example, by using transact-SQL SELECT statements. Shared locks allow concurrent reads but lock the resource against modification until the reads are completed. After the data is read, the lock is removed unless a repeatable read is being performed.

  • Exclusive locks:
    Lock data so that it can be modified—for example, by using INSERT, DELETE, or UPDATE statements. No other reads or modifications can be performed on the resource while it is exclusively locked.

Other locking modes include update locks, bulk update locks, and intent locks.

Lock Workstation

A security option for locking a workstation so that only the user who locked it or an administrator can unlock it by pressing Ctrl+Alt+Delete and entering the valid password. If you plan to leave a computer running Microsoft Windows NT or Windows 2000 temporarily and you want to prevent unauthorized access to its console but want to avoid shutting down the system, press Ctrl+Alt+Delete. Then, in the Security dialog box, click the Lock Workstation button on Windows NT, or click the Lock Computer button on Windows 2000.

Network administrators should encourage all users in the enterprise to use Lock Workstation because an unlocked workstation is vulnerable to tampering and can be used to steal or destroy valuable company information. It is easier to lock a workstation than to log off because it takes less time. Locking a workstation also allows the user to continue running applications in the background. Note that you can lock only computers running Windows NT and Windows 2000; this feature is not supported by Windows 95 and Windows 98.

log

Any file that contains records corresponding to application or operating system events or conditions, usually arranged sequentially by time. Log files are usually delimited text files (such as .csv files) in which each line represents a transaction or logged event, with individual data fields separated by delimiting characters such as commas. Delimited text files can be imported into spreadsheet programs such as Microsoft Excel, database programs such as Microsoft Access, and report and analysis tools such as Crystal Reports for further analysis and graphical display of trends and usage patterns. “Relogging” is the process of taking a log file and sampling it at larger time intervals to reduce the size of the file for archiving purposes while maintaining the overall trend of data within the log.

Numerous processes within the Microsoft Windows operating systems and the Microsoft BackOffice applications maintain logs. Some log functions include the following:

  • Keeping track of transactions performed on an information store or database (as in Microsoft SQL Server or Microsoft Exchange Server)

  • Monitoring server or network performance over time when Performance Monitor is used on a Windows NT–based or Windows 2000–based network

  • Recording details of visitors to Web sites when you use Internet Information Services (IIS)

  • Recording the details of modem commands or Point-to-Point Protocol (PPP) transmissions when you use Network and Dial-up Connections to connect to an Internet service provider (ISP)

logical link control (LLC) layer

One of the two sublayers into which the data-link layer of the Open Systems Interconnection (OSI) reference model is subdivided for data-link protocols used on local area networks (LANs). The logical link control (LLC) layer is part of the IEEE Project 802 specifications. The LLC protocol is based on the earlier High-level Data Link Control (HDLC) protocol. “LLC” sometimes refers to the IEEE 802.2 protocol itself, which is the most common LAN protocol implemented at the LLC layer.

How It Works

For LAN data-link protocols such as Ethernet, the data-link layer is divided into an upper layer called the logical link control (LLC) layer and a lower layer called the media access control (MAC) layer. The MAC layer coordinates access to the physical layer according to a media access control method, which for Ethernet is the Carrier Sense Multiple Access with Collision Detection (CSMA/CD) scheme. The MAC layer thus provides services to the LLC layer so that protocol data units can be transferred to the medium without any concern about the broadcast, framing, addressing, or error-detection schemes used. The LLC uses the MAC services to provide two types of data-link operations to the network layer above it: LLC1 for connectionless and LLC2 for connection-oriented data-link communication services (known as Type 1 and Type 2, respectively). These LLC services are grouped into two classes:

  • Class 1 services:
    Connectionless services used by applications that do not require error detection or flow control.

  • Class 2 services:
    Either connectionless (Type 1) or balanced-mode connection-oriented (Type 2) data transfer services. The LLC provides the error detection and recovery, flow control, and resequencing services needed for connection-oriented data transfer.

See also
Open Systems Interconnection (OSI) reference model

logoff

The process by which users notify a network’s security authority (such as a Microsoft Windows NT domain controller) that they are terminating their session on the network. Users should always log off their computers when they are finished for the day to prevent unauthorized access to the network through their computers by others who might use the building at night.

If you find that users do not log off their computers, try configuring logon hours restrictions on your domain controllers to forcibly disconnect users after work hours. You can also check whether your password policy is too strict, which might encourage users to stay logged on to avoid having to reenter a complex password each time they return to their station.

TIP

In Windows NT and Windows 2000, if you are leaving your desk for only a short time, you can lock your workstation by using Ctrl+Alt+Delete instead of logging off. It’s faster, and it allows applications such as your e-mail program to continue running.

logon

The process by which a user’s credentials are verified by a network security authority so that the user can be granted access to the machine. Logons can be one of two types:

  • Interactive logons:
    Occur when users sit at the console of the computer they want to access and enter their credentials in the logon dialog box.

  • Remote logons:
    Occur when a user has already logged on interactively to a machine but wants to establish a network connection with a remote computer. For example, if the user tries to map a drive letter to a shared folder on the remote computer, a remote logon must take place during the process so that the remote computer can be sure that the user has the right to perform the action.

When a user attempts an interactive logon to a machine, the user’s credentials are verified by a security authority, which can be one of the following:

  • The local machine itself, such as a computer running Microsoft Windows NT or Windows 2000 that is configured as part of a workgroup. In the workgroup security model, each machine maintains its own separate list of valid user accounts in its local security database. When a user performs an interactive logon to a stand-alone machine running Windows NT or Windows 2000 that is not part of a domain, the machine itself validates the user’s credentials.

  • A designated machine or group of machines on the network. For example, in a Windows NT–based network that is based on the domain security model, special machines called domain controllers store and maintain the list of valid user accounts for all users on the network in the domain directory database or Security Account Manager (SAM) database. These domain controllers are used for validating attempts by users logging on to computers in the domain. When the user attempts to log on interactively to the local machine that is part of a domain, the local machine forwards the user’s credentials to a domain controller on the network by using a mechanism called pass-through authentication, and the domain controller authenticates the user’s credentials and informs the user’s local machine that it should allow the user access to the network.

NOTE

In a Windows 2000–based network that uses the domain security model, the directory database is the database component of Active Directory. A successful logon to a machine running Windows NT or Windows 2000 results in an access token being granted to the user, which enables the user to access shared resources on the network for which he or she has suitable permissions.

logon hours

The hours during which a user has access to the network. In Microsoft Windows NT, administrators use User Manager for Domains to establish logon hours and other restrictions for each user account. In Windows 2000, administrators use Active Directory Users and Computers, which is implemented as a snap-in for Microsoft Management Console (MMC). Logon hours can be applied on either a permit or deny basis.

Graphic L-14. Logon hours.
Graphic L-14. Logon hours.
NOTE

When a user’s logon hours expire, the user can continue to work on the workstation but cannot access any network resources except the resources that are already open, such as the shares that the user is accessing. In Windows NT, you can disconnect users from all network resources when their hours expire by choosing Policies from the User Manager for Domains menu bar, selecting Account, and then selecting Forcibly Disconnect Remote Users From The Server When Logon Hours Expire at the bottom of the Account Policy dialog box.

TIP

For security reasons, you might want to restrict logon hours for ordinary users to company working hours. This reduces the chance of accounts being used for unauthorized access during off hours.

logon script

A batch file that automatically runs every time a user logs on to a network. A typical logon script might contain a series of net.exe commands that synchronize the clock of the client computer with a particular server, ensure that mapped network drives are available, restore printer connections, and perform other actions to configure the user’s work environment.

Logon scripts are primarily intended for non–Microsoft Windows and legacy Windows clients that are part of a Windows NT–based or Windows 2000–based network. This is because Windows NT Workstation and Windows 2000 Professional make use of user profiles instead for configuring the user’s desktop, network, and printer connections.

Example

The following simple script runs when a Windows client logs on to a Windows NT Primary Domain Controller. The script synchronizes the workstation’s clock with the server, maps the drive letter K to a share on the server, and then exits.

net time \\pdc /set /yes >nul
net use k: \\pdc\home
exit

long filename (LFN)

Names of files in Microsoft Windows NT, Windows 95, Windows 98, and Windows 2000, which can be up to 260 characters long and can include letters, numbers, and selected special characters. An 8.3 alias is automatically generated so that MS-DOS and 16-bit Windows-based applications can access the files.

How It Works

The NTFS file system has native support for long filenames, while Windows 95 and Windows 98 use multiple file allocation table (FAT) entries to hold a single long filename, marking these entries with the following unique set of attributes:

  • Read-only

  • System

  • Hidden

  • Volume label

Windows 95, Windows 98, Windows NT, and Windows 2000 similarly generate MS-DOS 8.3 aliases by using the first six characters (excluding spaces) from the long filename, followed by a tilde and a number, plus a three-character extension using the first three characters after the final period. All characters in the filename and extension are translated to uppercase. The following table shows some long filenames and their MS-DOS aliases.

Long Filenames and Corresponding MS-DOS Aliases
Long Filename | MS-DOS 8.3 Alias
This is my document.doc | THISIS~1.DOC
This is my other document.doc | THISIS~2.DOC
This was a text document.text | THISWA~1.TEX
See also
8.3 filename

loopback

A testing procedure in telecommunications in which a test signal is sent from a service provider’s central office (CO) to the customer premises and is returned or echoed by the customer premises equipment (CPE) back to the service provider. Loopback tests are used to check line integrity and the proper functioning of customer premises equipment and to diagnose and troubleshoot communication problems. Loopback tests can be performed by wide area network (WAN) access devices such as CSU/DSUs (Channel Service Unit/Data Service Units) and routers to place calls to themselves over a WAN to test the integrity of the WAN link. If the loopback signal fails to return, the WAN link is down and must be repaired. If the loopback signal returns, the device compares the original signal with the returned one; any discrepancies found can be used to troubleshoot communication problems.

Graphic L-15. Loopback.
Graphic L-15. Loopback.

For example, if you are a subscriber using an Integrated Services Digital Network (ISDN) line to connect to your service provider, you can usually perform a loopback test yourself. If the Service Profile Identifiers (SPIDs) and ISDN directory numbers have been configured for your ISDN interface, a loopback test will determine

  • Whether you can connect with your provider’s ISDN exchange. If not, you might have a cable or interface problem.

  • Whether your ISDN numbers are correctly assigned.

  • Whether you have caller ID or other advanced ISDN services on your line.

Another type of loopback test is the local loopback test, which a WAN access device uses to test networking connectivity with locally attached network devices. You can also implement a local loopback test by having network application software place a call to the WAN access equipment and having the equipment return an echo to the application.

loopback address

In TCP/IP networking, the special IP address 127.0.0.1. The loopback address is used to route outgoing IP packets to the TCP/IP protocol stack bound to the network interface card (NIC) and back to the source application without actually placing the packets on the network.

To test whether TCP/IP is installed correctly on a machine running Microsoft Windows, type ping 127.0.0.1 at the command prompt. You can also type the command ping localhost to achieve the same result, or you can even ping any other legal IP address with the form 127.x.y.z. If this test produces an error, your NIC is incorrectly configured or your TCP/IP stack is corrupt. Try removing and reinstalling TCP/IP on your machine. If that fails, try reinstalling the driver for your NIC or replacing the NIC.

LPC Facility

See
Local Procedure Call Facility (LPC Facility)

LPD

See
Line Printer Daemon (LPD)

LPQ

See
Line Printer Queue (LPQ)

LPR

See
Line Printer Remote (LPR)

LSA

See
Local Security Authority (LSA)


M

MAC address

A unique 6-byte (48-bit) address that is usually permanently burned into a network interface card (NIC) or other physical-layer networking device and that uniquely identifies the device on an Ethernet-based network. A MAC address is also known as an Ethernet address, hardware address, physical address, or PHY address.

How It Works

MAC addresses can be hard-coded into circuitry or stored in read-only memory (ROM), and they can be configured using vendor-supplied software. The uniqueness of MAC addresses is ensured by the Institute of Electrical and Electronics Engineers (IEEE), which assigns networking device vendors specific blocks of MAC addresses for the devices they produce. The first 3 bytes (24 bits) represent the manufacturer of the card, and the last 3 bytes (24 bits) identify the particular card from that manufacturer. Each group of 3 bytes can be represented by 6 hexadecimal digits, forming a 12-digit hexadecimal number representing the entire MAC address. Examples of manufacturer 6-digit numbers include the following:

  • 00000C (Cisco)

  • 00001D (Cabletron)

  • 0004AC (IBM [PCMCIA Ethernet adapter])

  • 0020AF (3Com)

  • 00C0A8 (GVC)

  • 080007 (Apple)

  • 080009 (Hewlett-Packard)

Each frame on an IP-based local area network (LAN) contains a source MAC address and destination MAC address in its header. These addresses are added to the frame by the media access control (MAC) layer of the protocol stack. Every device and port that connects to an Ethernet LAN requires a MAC address. These MAC addresses are used by devices such as bridges and Layer 2 switches for building routing tables to direct traffic through the network. Bridges gather MAC addresses by examining the source MAC address of every frame of network traffic they receive. They then use these source addresses for building their internal routing tables, which they use to forward frames only to the segment that has the station with that particular destination MAC address. This process reduces network congestion by avoiding the need for bridges to forward broadcasts.

NOTE

Some NICs come with a software utility that you can use to change the MAC address of the card. Changing the address is not a good idea! If you accidentally configure two network cards on your network to have the same MAC address, address conflict problems will result and the computers will not be able to communicate on the network. However, some NICs, such as Token Ring cards, actually require you to assign a unique MAC address to them before they will work.

TIP

To determine the MAC address of your computer’s NIC, use the following commands:

  • From the Microsoft Windows NT or Windows 2000 command prompt: ipconfig /all

  • From the Windows 95 or Windows 98 Run dialog box: winipcfg

machine group

In Microsoft Systems Management Server (SMS), an alias for a collection of computers. Machine groups are used to specify the targets and distribution servers for SMS jobs such as Run Command On Workstation and Share Package On Server.

TIP

You generally use machine groups when you want to specify exactly the computers for a job, such as when you want to distribute licensed software to clients. Machine groups are used this way because their membership is static. Machine groups contain only the computers that you add to them. This is unlike the Sites window, which contains all the computers that belong to the selected site.

Macintosh

A personal computing platform released in 1984 by Apple Computer. The Apple Macintosh introduced a number of user interface innovations to the popular personal computer market. These innovations, originally developed at the Stanford Research Institute and the Xerox Palo Alto Research Center (Xerox PARC) in the 1970s, included a graphical user interface (GUI) with mouse-clickable program icons and resizable windows. The Macintosh originally used the 680x0 series of microprocessors from Motorola and now uses the PowerPC processor developed by Apple, IBM, and Motorola.

The Macintosh operating system was originally called System. Now it is known as MacOS. While it holds a much smaller market share than Microsoft Windows, the Macintosh has a niche in the desktop publishing and graphics industry and among some groups of university professionals.

Macintosh computers and Intel-based computers can be part of the same network. For example, Services for Macintosh allows servers running Windows NT to support Macintosh client machines by emulating an AppleShare server, and it allows servers running Windows NT to provide Macintosh clients with file and print sharing service and AppleTalk routing capability. A similar set of components including File Server for Macintosh, Print Server for Macintosh, and the AppleTalk protocol, which together are referred to as AppleTalk network integration, can be used on machines running the Windows 2000 platform to enable Macintosh computers to interoperate with PC networks based on the Windows 2000 operating system. AppleShare is a file-sharing protocol that is a part of AppleTalk, a suite of networking protocols developed by Apple for its Macintosh computing platform.

On the Web
•
Apple home page
: http://www.apple.com
See also
Apple Open Transport, AppleShare, AppleShare IP, AppleTalk

MAC layer

See
media access control (MAC) layer

mailbox

In Microsoft Exchange Server, a receptacle for messages sent by other users. Mailboxes are the most common type of Exchange recipient and are usually associated with the Microsoft Windows NT or Windows 2000 account of a user in the company’s network. Mailboxes store the user’s folders, messages, and attachments in the private information store on an Exchange server. The mailbox content for each user in an organization using Exchange exists on only one server in the organization, which is called the user’s home server.

TIP

To change the properties of a large group of mailboxes simultaneously, choose Directory Export from the Exchange Administrator (or its command-line equivalent) to export the properties of the mailboxes to a .csv text file. Edit the file to change the properties using the Replace feature of your text editor, and then choose Directory Import from the menu to import the properties back into the Exchange directory.

If you need to create a large number of similar mailboxes, first create a mailbox template, and then choose Duplicate from the Exchange Administrator.

mail client

Any client software that provides users with an interface for creating, sending, receiving, viewing, and storing e-mail messages. Examples of Microsoft mail clients include Microsoft Outlook and Microsoft Outlook Express. To function in a client/server mail system, mail clients require a mail server such as Microsoft Exchange Server that acts as a message-routing facility to forward outgoing messages to their destination and as a postoffice where incoming messages can be stored and retrieved by clients.

Other popular mail clients include the following:

  • Eudora, developed by QUALCOMM, which is available in a full professional version and a shareware version

  • Netscape Messenger, which is part of the Netscape Communicator suite of Internet tools

  • Pine and Elm, which are command-line mail clients used in UNIX environments

mailslot

An interprocess communication (IPC) mechanism in Microsoft Windows operating systems that provides connectionless, datagram-based one-to-one or one-to-many communication between processes on different computers. Mailslots are similar to named pipes, which also provide communication between two processes. However, the communication through a named pipe is one-to-one and two-way, while the communication through a mailslot can be one-to-many and is only one-way. Mailslots are implemented as file system drivers, and therefore

  • Are opened by requests made from the redirector

  • Take full advantage of the features of file system drivers, such as security and validation

Mailslots were originally developed for Microsoft OS/2 LAN Manager and have been maintained in Windows for backward compatibility. They are usually used for broadcast purposes, such as service announcements.

Mailslots are used in the Computer Browser service on Windows NT and in the WinPopUp messaging tool in Windows 95 and Windows 98, among other places.

mail system

Any set of applications used to support e-mail messaging between a group of users in an organization or between users in different organizations. Mail systems include both client software (for composing, sending, receiving, and viewing messages) and server software (for storing and transporting messages).

How It Works

Mail systems come in two general types:

  • Shared-file mail systems:
    The client software initiates and maintains all messaging activity. The server is a passive file server (usually called a postoffice). The client regularly polls the server for new messages, and if messages are found, the client downloads and displays them. An example of a shared-file mail system is Microsoft Mail. Advantages of such mail systems include low server-end requirements and simple maintenance. Disadvantages include limited security, high processing load for the client, and poor scalability.

  • Client/server mail systems:
    The client makes requests to the server, and the server processes the requests, either receiving mail from the client or sending mail to the client. The client and the server share the processing of messages. An example of a client/server mail system is Microsoft Exchange Server, which uses remote procedure calls (RPCs) for communication between clients and servers. Advantages of client/server mail systems include lower network traffic, scalability, and security. The main disadvantage is that they require more powerful servers than shared-file mail systems do.

NOTE

Mail systems are also distinguished by their address formats. Each mail system uses one or more address formats. These can be industry-standard formats such as the Simple Mail Transfer Protocol (SMTP) or X.400 standard Originator/Recipient (O/R) format, or they can be proprietary address formats such as the Microsoft Mail version 3 or Lotus cc:Mail format. Exchange Server supports most popular industry-standard and proprietary address formats. The following table lists some of the address formats supported by Exchange.

Address Formats Supported by Exchange
Address Format | Example
SMTP | mitch@northwind.microsoft.com
X.400 O/R | C=US;a=Sprint;p=microsoft;o=northwind;s=Tulloch;g=Mitch;
Microsoft Mail | microsoft/northwind/mitch
cc:Mail | Tulloch, Mitch at northwind
TIP

Exchange Server can offer an all-in-one mail system solution because it can provide messaging connectivity with legacy mail systems such as Microsoft Mail and foreign mail systems such as Lotus cc:Mail, Internet SMTP mail, and X.400 messaging systems. This connectivity is provided by connectors such as the X.400 Connector and Internet Mail Service. You can thus use Exchange as a messaging backbone system in a heterogeneous mail system environment. Exchange Server also includes the Microsoft Exchange Migration Wizard, which you can use to migrate users and mailboxes from legacy and foreign mail systems to an Exchange-based system. This migration can simplify administration and reduce costs.

mainframe

A general term for a high-level, typically large computer that is capable of performing demanding computational tasks. Vendors of mainframes include IBM, Unisys, and Hitachi Data Systems. Mainframe computers were historically operated as centralized computing systems to which dumb terminals were attached through local network connections and remote dial-up connections. Users entered text-based commands into these terminals, and the terminal forwarded the commands to the mainframe, where all the processing was performed. The results of the processing were returned to the terminal and displayed. Modern mainframes offer terminal communication but also support connections to “smart terminals”—desktop computers that are connected to the mainframe but also have their own computing power.

Much of the computing performed in the government, financial, and industrial sectors still uses mainframes for such functions as database processing, transactions, accounting, and payroll. To access data stored on a mainframe, distributed-computing systems such as Microsoft Windows 2000 can use a Microsoft BackOffice product called Microsoft SNA Server. Internet Information Services (IIS) can also use components of SNA Server and Active Server Pages (ASP) technology to build distributed Web-based applications that provide browser-based access to mainframe data.

IBM’s line of mainframes has evolved to the point that its System/390 mainframe platform can be used for distributed client/server computing and Web-based computing. A modern mainframe can thus be considered a very big server that can easily be integrated with Windows 2000 or other servers into local area networks (LANs) or wide area networks (WANs).

On the Web
•
IBM S/390 home page
: http://www.s390.ibm.com

Maintenance Wizard

A wizard in Microsoft Windows 98 that lets you schedule disk maintenance utilities to ensure optimum performance for your applications. Administrators can use the Maintenance Wizard on Windows 98–based networks to configure workstation maintenance schedules and processes.

Graphic M-1. This wizard is part of Windows 98.
Graphic M-1. This wizard is part of Windows 98.
How It Works

Use the Maintenance Wizard to set the schedule for system tools to check your hard disks for problems and free up additional space on your disks. You start the wizard by choosing Accessories from the Start menu and then choosing the System Tools and Maintenance Wizard from the submenus. When you run the wizard, you specify the following:

  • When the maintenance tasks should be scheduled to run

  • Whether to defragment your hard disks by using Disk Defragmenter

  • Whether to check your hard disks by using Scandisk

  • Whether to free up additional space by using Disk Cleanup to delete temporary files and other unnecessary files

makepipe

A command-line tool for Microsoft SQL Server that you use to verify that named pipes are functioning correctly between the client and the server. You use makepipe with readpipe, another command-line tool, to verify the integrity of named pipes. The process is similar to the way that the ping utility is used to test connectivity with a TCP/IP host.

How It Works

If you have trouble connecting with your server running SQL Server over the network, you can use makepipe and readpipe to determine whether named pipes connectivity is the problem. You first start makepipe at a command prompt on the server you want to test. It creates a pipe and then waits for a client to connect. Then you run the readpipe utility from a workstation and try to connect with the server. When testing is complete, you use Ctrl+Break on the server to stop makepipe.

MAN

See
metropolitan area network (MAN)

Management console

See
MMC console

Management Information Base (MIB)

A hierarchical database that defines the information that an SNMP management system can request from an agent using Simple Network Management Protocol (SNMP).

How It Works

A Management Information Base (MIB) is a collection of manageable network objects. These objects are a logical representation of physical networking components that are SNMP-enabled (such as computers, hubs, routers, switches, and networking software). MIBs contain information about the configuration of these networking components, such as the version of the software running on the component, the IP address or port number, and the amount of available disk space for storage. MIBs function as a kind of directory containing the logical names of the network resources and their configuration parameters that are managed by SNMP.

Because every MIB is a member of the MIB hierarchy, you can uniquely identify a MIB for each network component. The name is represented using a standard dotted naming system. For example, the root of the LAN Manager MIB II in the following diagram would be represented by one of the following:

  • iso.org.dod.internet.private.enterprises.lanmanager

  • 1.3.6.1.4.1.77

    Graphic M-2. The tree structure of a MIB.
    Graphic M-2. The tree structure of a MIB.

This tree-link MIB structure contains branches both for public networking standard objects and proprietary private vendors’ implementations of networking objects. Vendors can apply to the Internet Assigned Numbers Authority (IANA) to have specific MIB numbers reserved for their products. For example, the LAN Manager MIB II has over 90 objects that SNMP management systems can use to obtain information about users who are logged on, sessions, shares, and so on.

You can use SNMP commands to retrieve the value of a MIB object or, in some cases, to change the value.

NOTE

Microsoft’s implementation of SNMP in Windows NT and Windows 2000 includes the following MIBs, among others:

  • Internet MIB II:
    Objects for configuration analysis of TCP/IP networks

  • LAN Manager MIB II:
    Objects relating to sessions, shares, and users of LAN Manager–related software, including Windows NT and Windows 2000

  • DHCP MIB:
    Objects for monitoring Dynamic Host Configuration Protocol (DHCP) statistics in Windows NT and Windows 2000

  • WINS MIB:
    Objects for monitoring Windows Internet Name Service (WINS) statistics in Windows NT and Windows 2000

MIB extensions exist for any SNMP-manageable device, including networking hardware and software from Apple, Cisco, Novell, and others.

On the Web
•
WWW SNMP MIB Browser
: http://www.ibr.cs.tu-bs.de/cgi-bin/sbrowser.cgi
See also
Simple Network Management Protocol (SNMP)

Management Information Format (MIF)

A standard format for describing hardware and software desktop computer components that you use in conjunction with Desktop Management Interface (DMI) to manage networked PCs. The Management Information Format (MIF) and DMI were defined by the Distributed Management Task Force (DMTF), an organization composed of industry leaders whose aim is to lead the development, adoption, and unification of standards for managing systems.

How It Works

The MIF database on a system contains a collection of MIF files that provides information about the various hardware and software components stored on the system. A program called a DMI Service Provider that runs locally and is resident on the computer being managed collects and manages the information from MIF files. MIF files are text files that are supplied with each manageable hardware or software component installed on the system and that contain information about the attributes of that component. You can retrieve and display the information in the MIF database using a management interface (MI) utility.

NOTE

Microsoft Systems Management Server (SMS) uses six types of MIF files for collecting and storing information in the SMS database:

  • Personal Computer (.mif)

  • SMSEvent (.emf)

  • UserGroup (.umf)

  • JobDetails (.jmf)

  • PackageLocation (.pmf)

  • Custom architecture (.mif)

SMS can also use MIF files to add information to the SMS database about objects such as routers with custom architectures.

Manchester coding

The line coding technology used in standard Ethernet networks and specified in the IEEE 802.3 standard. Manchester coding is the process by which digital information in a binary bit stream is converted into electrical signals for transmission.

How It Works

Simple Manchester coding uses a two-state transition of line voltage to represent one bit of information. In other words, two baud (voltage changes) are used for one bit (piece of information). A binary 0 is represented by a transition from higher to lower voltage in the time set for transmitting one bit (that is, one “bit time”). A binary 1 is represented by a transition from lower to higher. For Ethernet networks, the high voltage is typically +0.85 volts and the low is typically -0.85 volts, making each voltage transition equal to 1.7 volts.

Manchester coding has the advantage of enabling data to be transmitted without the need for an extra clocking signal. This is possible because voltage transitions take place in the middle of each bit transmission interval, which establishes a timing pattern. The mid-interval voltage changes thus allow the sending and receiving stations to maintain proper synchronization with each other in order to ensure the integrity of the transmission. Because of the extra transition per bit that is used for clocking purposes, Manchester coding is only 50 percent efficient—for example, a 20-MHz bandwidth is required to produce a 10-Mbps data transmission rate.

Another version, called differential Manchester coding, represents binary 0 by a voltage transition at the start of the bit-interval, and binary 1 by no transition at the start of the bit-interval. In both cases, a transition takes place in the middle of the interval for synchronization purposes. Differential Manchester encoding is used for IEEE 802.5 token ring networking.

Graphic M-3. Simple Manchester coding for Ethernet.
Graphic M-3. Simple Manchester coding for Ethernet.

mandatory user profile

A user profile in a network based on Microsoft Windows NT or Windows 2000 that is stored on a network share on a server and that the user cannot modify. Because a mandatory user profile is on a server, users can access their personal desktop settings from any machine on the network. Mandatory user profiles are configured as read-only so that users cannot permanently change their desktop settings. They can reconfigure their desktop for the duration of the current logon session, but once they log off their changes are lost.

Mandatory user profiles are typically configured by administrators who want to prevent users from modifying their desktops so that they can reduce the time they spend troubleshooting modifications or enforcing uniformity because of company policies. Mandatory profiles can also be used for several users who require the same desktop configuration. The administrator can create a mandatory profile and use it for the entire group of users. Changing the mandatory user profile once affects all users assigned that profile. This simplifies the administrator’s job when desktops require upgrading or additional applications.

How It Works

To change a roaming user profile into a mandatory one, locate the user’s profile folder on the server and simply change ntuser.dat to ntuser.man. This makes the user profile read-only from the perspective of any client machine.

NOTE

Windows 95 and Windows 98 also support mandatory user profiles in conjunction with networks based on Windows NT or Windows 2000.

See also
local user profile, roaming user profile, user profile

manual switch

Any manually operated (nonelectronic) switch used for switching between network devices. Manual switches are cheaper than powered electronic switches and are available in a variety of configurations for different uses. They generally have rotary switches on the front and connectors on the back. The connectors can be DB9, DB15, RJ-11, RJ-45, or other connectors such as V.35, BNC, or Centronics. Examples of manual switches include the following:

  • Stand-alone manual switches:
    These are generally small boxes with a rotary switch on the front and a set of connectors on the back. They can be used for switching connections between printers, monitors, keyboards, and other devices.

  • Rack-mounted manual switches:
    These are standard 19-inch-wide rack-mounted boxes, typically with a number of rotary switches on the front and connectors on the back. These are used more rarely and essentially combine a number of stand-alone switches into a single rack-mounted box.

  • Many-to-one switches:
    These allow several users to share one device or allow one user to access different devices. For example, a user can use a many-to-one switch to manually switch between a color laser printer and a black-and-white printer. Or an administrator can manually switch a server from a primary 10BaseT Ethernet network to a secondary network. These switches are typically either two-to-one or four-to-one switches.

  • X switches:
    These allow several users to share several devices in different configurations. These switches are typically two-to-two switches.

  • Dual switches:
    These allow you to switch two connectors at once.

    Graphic M-4. Two manual switch configurations: with a many-to-one switch and with an X switch.
    Graphic M-4. Two manual switch configurations: with a many-to-one switch and with an X switch.
NOTE

Manual switches are often used in high-security environments in which a user can access a device only by physically switching to it. Some manual switches include key locks that control access.

See also
switch

MAPI

See
Messaging Application Programming Interface (MAPI)

mapped network drive

A shared folder on a network that has been associated with an available drive letter on a local PC. The result is that the shared folder behaves like a local drive on the PC.

How It Works

In Microsoft Windows NT, Windows 2000, Windows 98, and Windows 95, you can use one of the following procedures to map a network drive:

  • Right-click on My Computer or Network Neighborhood on the desktop and choose Map Network Drive from the shortcut menu. Select an available drive letter, enter the Universal Naming Convention (UNC) path to the shared folder, and specify credentials to gain access to the shared folder.

  • Click the Map Network Drive button on the toolbar in Windows Explorer and continue as described in the first procedure.

  • From a command prompt, use the Net Use command.

TIP

At times, it might be preferable to access a shared folder on a network by using the run command instead of mapping a drive because the run command does not require you to use an available drive letter. Choose Run from the Start menu, and then type the UNC path to the network share.

master browser

A machine running Microsoft Windows NT or Windows 2000 that is involved in supporting the functions of the Computer Browser service. The master browser for a domain is usually the primary domain controller (PDC) for that domain.

How It Works

The master browser collects and maintains a list of available servers that have shared network resources in its domain. This list, known as the browse list, is created when individual servers announce their presence on the network by sending a server announcement to the master browser.

The master browser also collects and maintains a list of all Windows NT and Windows 2000 domains on the network. If the domain of a master browser spans several subnets, the master browser maintains only the browse list for its own subnet and one master browser will exist for each subnet in the domain.

Backup browsers obtain a copy of the browse list from the master browser. Backup browsers automatically contact the master browser every 15 minutes to request a copy of both the browse list and a list of domains on the network. The backup browser caches this list and distributes it to any client on the network that requests it.

See also
Computer Browser service

master database

In Microsoft SQL Server, the database that stores the system-level configuration information about the server running SQL Server and about each database on the server. This information includes system tables, transaction logs, system configuration settings, login accounts, and database location and initialization information.

The master database is one of four system databases on every server running SQL Server. The others are as follows:

  • The msdb database:
    Used by the SQL Server Agent for job scheduling and recording purposes.

  • The model database:
    Used as a template for creating new user databases when the CREATE DATABASE statement is run.

  • The tempdb database:
    Stores all temporary tables, work tables, and temporary stored procedures generated during operation of the server running SQL Server. The contents of tempdb are lost when connections with the server are terminated or the system is shut down, and the database is re-created upon system startup to provide a clean work area.

NOTE

In SQL Server version 7, all databases, including the four system databases, are separate files in the \MSSQL\Data directory on the server. Each database consists of a database (.mdf) file and a corresponding log (.ldf) file. This differs from SQL Server 6.5, in which the master and model databases and the first 2 MB of the tempdb database exist as a single file called the master device.

TIP

Be sure to always have a recent backup copy of the master database for recovery from system failure on a server running SQL Server. Don’t bother backing up the tempdb database, but for improved system performance you can prevent tempdb from automatically growing to meet system needs by increasing its default size to its maximum anticipated size.

master domain

A trusted domain in Microsoft Windows NT–based networks that contains accounts for all users in an enterprise. Master domains are used in enterprise-level implementations of Windows NT to allow user accounts to be centralized and managed in one domain.

How It Works

The master domain is typically found at company headquarters, while resource domains are implemented at branch offices. A trust relationship is established between the resource domains and the master domains, in which each resource domain trusts the master domain. Users who log on to their computers at headquarters automatically log on to the master domain to validate their credentials. Users at branch offices can log on to either their local resource domain or the trusted master domain, but they must choose the master domain because all user account information resides there. In a wide area network (WAN), one or more backup domain controllers (BDCs) belonging to the master domain are installed at each branch office to facilitate local logons and to prevent logon traffic from being routed over slow WAN links to headquarters.

TIP

Many companies use the Windows NT master domain model to administer users and groups in master domains and resources in second-tier (or resource) domains. Because the majority of reasons to use the Windows NT master domain model disappear when domains are migrated to Active Directory in Windows 2000 and a domain tree is established, these companies might choose to dissolve existing second-tier domains into organizational units (OUs) in the master domains.

See also
resource domain

master index

The end product of the indexing process in Microsoft Indexing Service. The process first creates word lists, which are merged into shadow indexes and then become one master index. Unlike word lists, which reside in volatile memory, the shadow indexes and the master index are persistent indexes that are stored on disk.

The process by which shadow indexes are combined into a master index is called a master merge. A master merge combines multiple shadow indexes with any old master index to create a new master index. The new master index is the most efficient form for the index of a corpus of documents being indexed by the Indexing Service. The master index stores the indexing data in a highly compressed format in a structure called the catalog. The compressed nature of the master index provides the most efficient data structure for storing information and for issuing queries against the corpus, but the process of generating a master index is resource intensive and is generally performed by the Indexing Service when load on the server is low. However, the administrator can also force a merge to update the master index after new documents are added to the corpus being indexed.

master name server

In the Domain Name System (DNS), a name server that has authority over a given zone of authority. Master name servers provide read-only copies of their DNS database to secondary name servers. A secondary name server must obtain and update its resource records from a master name server. The process by which these records are obtained and updated between name servers is called a zone transfer.

NOTE

A master name server can itself be either a primary name server or a secondary name server. If it is a secondary name server, the master name server must obtain its own resource records from another master name server. If it is a primary name server, it contains the master copy of the resource records for its zone of authority.

TIP

When you configure zone transfers between name servers, be sure that the start of authority (SOA) record for the secondary name server is correctly configured with the name of the master name server from which it will obtain its resource records. No configuration is required with the master name server itself.

See also
caching-only name server, primary name server, secondary name server

master station

A general term for any network device that controls the operation of other network devices. For example, in a point-to-point connection between an IBM controller and a 3270 terminal, the controller is the master station while the terminal is a slave station. Or, in a multipoint circuit, one of the devices might function as a master station while all the rest are slaves. Typically, the master station polls all the slave stations regularly and in order, to determine whether a slave wants to initiate communication with the master. (This is in contrast to a peer multipoint circuit such as in an Ethernet network, in which each station can contend for control of the media.) Another scenario might involve a token-passing network in which one of the devices might function as a master station and be responsible for detecting and replacing lost tokens.

matrix switch

An electronic switch with multiple input and output ports that can be controlled from a keypad or some other front-panel switching facility. You can use matrix switches to allow multiple stations to share a group of peripherals such as printers, modems, Small Computer System Interface (SCSI) devices, or other serial or parallel devices. The term “matrix switch” comes from the mathematical structure called a matrix, which is a two-dimensional structure with N rows and M columns representing N times M values. Likewise, a matrix switch with N input ports and M output ports has N times M switching possibilities. Typical configurations for matrix switches include 4 x 4 and 4 x 8.

Code-operated matrix switches can be operated by character codes embedded in the data stream sent from user workstations.

Graphic M-5. Matrix switch.
Graphic M-5. Matrix switch.
NOTE

The term “matrix switching” also describes the switching technology at the center of an Asynchronous Transfer Mode (ATM) network that functions by supplying needed bandwidth for end-to-end sessions. ATM matrix switching avoids contention by end stations on the network.

See also
switch

MAU

See
Multistation Access Unit (MAU)

MBone

Stands for multicast backbone, an experimental portion of the Internet that is used to test multicasting technology.

How It Works

The MBone platform was established in 1992 to test and develop technology and software for multicasting audio and video information over the Internet. It consists of a portion of the Internet with specially configured routers that support routing of multicast Internet Protocol (IP) packets. These MBone routers can forward IP packets through nonmulticast routers using tunneling technologies that encapsulate multicast IP packets into unicast packets that the routers can understand. MBone IP addresses used for multicasting of audio and video information have been allocated by the Internet Assigned Numbers Authority (IANA) as those in the range 224.2.y.z, which is a subset of the class D group of IP addresses ranging from 224.0.0.0 to 239.255.255.255.

On the Web
•
MBone Information Web
: http://www.mbone.com
•
Map of the MBone
: http://www.cs.berkeley.edu/~elan/mbone.html

MBS

See
Mobile Broadband System (MBS)

MCDBA

See
Microsoft Certified Database Administrator (MCDBA)

MCIS

See
Microsoft Commercial Internet System (MCIS)

MCP

See
Microsoft Certified Professional (MCP)

MCSD

See
Microsoft Certified Solution Developer (MCSD)

MCSE

See
Microsoft Certified Systems Engineer (MCSE)

MCSP

See
Microsoft Certified Solution Provider (MCSP)

MCT

See
Microsoft Certified Trainer (MCT)

MDA

See
media-dependent adapter (MDA)

MDAC

See
Microsoft Data Access Components (MDAC)

MDHCP

See
multicast DHCP (MDHCP)

media

A classification of cabling according to its physical construction and transmission characteristics. A cable is referred to as “the medium” over which signals can travel in a network. Examples of media include the following:

  • Coaxial cabling

  • Twisted-pair cabling

  • Fiber-optic cabling

The term “media” can also refer to a combination of cabling and topology used for different types of Ethernet networks. Thus, for example, 10BaseT refers to a star topology using unshielded twisted-pair (UTP) cabling, while 10Base2 refers to a bus topology using thinnet cabling. You can loosely refer to these examples as 10BaseT and 10Base2 Ethernet media.

NOTE

Wireless networking uses electromagnetic waves, which are, strictly speaking, not media at all. Wireless networking can be said to use “unguided media.”

See also
coaxial cabling, fiber-optic cabling, twisted-pair cabling

media access control (MAC) layer

One of the two sublayers into which the data-link layer (layer 2) of the Open Systems Interconnection (OSI) reference model is subdivided based on the specifications of IEEE Project 802. The other sublayer is the logical link control (LLC) layer. The MAC layer interfaces with the physical layer below it and provides access to and direct communication with the network interface card (NIC).

How It Works

Essentially, the MAC layer determines which computer on the network is allowed to use the media at any given moment. The MAC layer is thus responsible for implementing the media access control method for the particular network architecture, such as Ethernet or Token Ring. The MAC layer is also responsible for making sure that data is delivered without errors.

The MAC layer receives framed data from the LLC layer immediately above it, which is media independent, and reframes the data, adding a source and destination physical address or MAC address to the frame for transmission on the medium.

media access control method

A way to allow computers to transmit signals over network cabling, while ensuring that only one computer transmits at a time. If two computers simultaneously place signals on the wire, a collision can occur and data might be corrupted unless a method is used to resolve the collision gracefully. Media access control methods act like traffic lights by permitting the smooth flow of traffic on a network, and they prevent or deal with collisions. Media access control methods are implemented at the data-link layer of the Open Systems Interconnection (OSI) reference model.

Four main media access control methods are used in networking:

  • Carrier Sense Multiple Access with Collision Detection (CSMA/CD), which is used in Ethernet networking

  • Carrier Sense Multiple Access with Collision Avoidance (CSMA/CA), which is used in AppleTalk networking

  • Token passing, which is used in Token Ring and Fiber Distributed Data Interface (FDDI) networking

  • Demand priority, which is used in 100BaseVG networking

See also
Carrier Sense Multiple Access with Collision Avoidance (CSMA/CA), Carrier Sense Multiple Access with Collision Detection (CSMA/CD), demand priority

media converter

A device that connects two different networking media for Ethernet networks, such as thinnet cabling and unshielded twisted-pair (UTP) cabling. Each Ethernet standard provides specifications for the media used—for example, 10Base2 and 10Base5 use different media types. A media converter allows these different types to be transparently joined.

Media converters can be simple, stand-alone two-port small boxes for connecting two wires of different media types, rack-mounted units with 8 or 16 preconfigured ports, or modular units, which allow the greatest range of configuration options. Media converters come in many types, with many different kinds of connectors. Some media converters are similar to bridges in their functionality.

Media converters can be used for various functions, including the following:

  • Connecting two different wiring systems, such as 100BaseTX and 100BaseFX, without adding to the repeater count for your network

  • Connecting two 10BaseT or 100BaseTX networks in different buildings using fiber-optic cabling runs as long as 15 kilometers

  • Connecting a 100Base2 thinnet Ethernet segment to an RJ-45 port on a 10/100-Mbps hub

  • Integrating a mix of cabling including UTP cabling, thinnet, thicknet, and fiber-optic cabling

    Graphic M-6. Media converter.
    Graphic M-6. Media converter.
TIP

Media converters can be valuable if you have a large existing thicknet or thinnet Ethernet local area network (LAN) and you want to take advantage of new, fast Ethernet switching technology. Instead of rewiring your entire LAN to UTP (which is the standard cabling type for Ethernet switches), you can use some of your existing cabling by connecting your coaxial cabling to a media converter and then connecting the media converter to the Ethernet switch using UTP patch cables.

media-dependent adapter (MDA)

A module that can be inserted into a modular Ethernet switch to provide connectivity between different media types. Modular Ethernet switches typically have two to four media-dependent adapter (MDA) slots on the front panel, where you can easily insert and remove MDAs for providing various media connectivity configurations.

Graphic M-7. Media-dependent adapter (MDA).
Graphic M-7. Media-dependent adapter (MDA).

Typical MDAs might provide

  • Eight 10BaseT ports

  • Two 100BaseTX or 100BaseFX ports

  • A Fiber Distributed Data Interface (FDDI) double-ring connection

By selecting and inserting different MDAs into a modular switch, you can quickly reconfigure complex Ethernet networks. Bridging between the different types of media is performed internally by the chassis circuitry inside the switch.

member server

A server running Microsoft Windows NT or Windows 2000 that is not a domain controller. A member server does not contain a copy of the domain directory database or Security Account Manager (SAM) database; it has its own local security database. Member servers can participate in domain security, which allows files and other resources on the member server to be shared and permissions to be assigned to different domain users and groups. However, you cannot use member servers to authenticate user credentials, as you can with domain controllers.

Member servers are usually used for dedicated network purposes such as the following:

  • File and print servers

  • Application servers

  • Database servers

  • Web servers

NOTE

On Windows 2000–based networks, a member server is a server that stores Active Directory information and is not a domain controller. However, in Windows 2000 you can change a member server to a domain controller by using the Active Directory Installation Wizard.

See also
domain controller

memory.dmp

A file produced when you configure a recovery setting using the System utility of Control Panel in Microsoft Windows NT and Windows 2000. The memory.dmp file consists of the contents of the pagefile when a Stop screen was generated because of operating system failure. Microsoft support technicians can analyze this file to determine the cause of the failure.

TIP

To save memory.dmp, the pagefile must be at least 1 MB larger than the amount of RAM in the system and must also reside on the system partition. There must also be sufficient free space for memory.dmp to be saved on the system partition. If you encounter a Stop screen and contact Microsoft product support, and the support technician requests that you send the memory.dmp file, you can compress the file using Pkzip or Winzip before sending the file to Microsoft by means of File Transfer Protocol (FTP). You can also back up the file to tape or write it to a CD and e-mail it. A third option is to use a utility called dumpexam.exe to extract essential information from the file into a much smaller memory.txt file for analysis by Microsoft technical support.

merge

Part of the indexing process in Microsoft Indexing Service. Merges combine word lists into persistent indexes and ultimately into a master index. A merge can be one of several types:

  • Shadow merge:
    Combines word lists into persistent indexes called shadow indexes in order to free server resources and increase the performance of Indexing Service queries

  • Annealing merge:
    Combines shadow indexes into fewer shadow indexes and takes place when the server is idle and necessary server resources are available

  • Master merge:
    Combines shadow indexes with an old master index (if present) to create a new master index

mesh topology

A network topology in which additional networking components are used to provided redundant data paths. This topology provides fault tolerance—if a wire, hub, switch, or other component fails, data can travel along an alternate path. A diagram of a mesh network might resemble a portion of a fishing net. A mesh topology is most often used in large backbone networks in which failure of a single switch or router can result in a large portion of the network going down. Mesh networks can use the following topologies:

  • Full mesh topology:
    Provides a direct link between each pair of nodes (routers) on the backbone network. Full mesh topologies provide the highest level of fault tolerance but increase the computational strain on dynamic routers for calculating their routing tables. A full mesh network with N routers would have N factorial paths (1 x 2 x 3 x … x N) to calculate.

  • Partial mesh topology:
    Includes some redundant data paths to provide some level of fault tolerance. This is the more usual implementation in large internetworks.

    Graphic M-8. Typical mesh topology of networks connected by routers.
    Graphic M-8. Typical mesh topology of networks connected by routers.
See also
bus topology, ring topology, star topology

message

A communication sent by one user to another user by means of an e-mail system such as the Simple Mail Transfer Protocol (SMTP) mail system that is used over the Internet. In networking in general, a message is any grouping of information at the application layer (layer 7) of the Open Systems Interconnection (OSI) reference model that is exchanged between applications for various purposes. These layer-7 messages can contain control information or report errors, or can support the running of a network-aware application in some other fashion.

In Microsoft Message Queue (MSMQ) Server terminology, a message is a unit of information or data that is sent between two computers. An MSMQ message can contain either text or binary data. MSMQ applications communicate with each other using MSMQ messages.

message digest (MD) algorithms

A group of hashing algorithms used in cryptography and developed by Rivest. The term “message digest” refers to a short string or hash value of fixed length that is computed from the longer variable-length message being hashed by the algorithm. The important message digest (MD) algorithms include MD2, MD4, and MD5, all of which produce a 128-bit hash value. The MD algorithms are commonly used to generate a digital signature from a message.

MD2 was developed in 1989 for 8-bit encoders. It pads the message to be encoded until it is a multiple of 16 bytes in length, appends a 16-byte checksum, and computes the hash.

MD4 was developed in 1990 for 32-bit encoders. It pads the message to be encoded until it is 56 bytes short of being a multiple of 512 bytes, appends an 8-byte message length value, and iteratively hashes the message in three rounds. MD4 can be broken fairly easily in a dedicated cryptographic attempt. It is implemented in the Microsoft Challenge Handshake Authentication Protocol (MS-CHAP) supported by the Remote Access Service (RAS) on Microsoft Windows NT.

MD5 was developed in 1991 for 32-bit encoders and is an extension of MD4. It uses four rounds of hashing instead of three. It is fairly difficult to crack. Windows NT RAS Client supports MD5-CHAP for connecting to third-party Point-to-Point Protocol (PPP) servers supporting MD5 authentication, but Windows NT RAS Server does not. However, Service Pack 3 for Windows NT provides limited support for MD5-CHAP PPP authentication.

NOTE

MD5 is also used in Simple Network Management Protocol (SNMP) version 2 for authenticating the origin of SNMP messages and verifying their integrity. Another hashing algorithm used in generating digital signatures is the secure hash algorithm (SHA) developed by the Network Information System (NIS).

Message Tracking Center

A tool included with Microsoft Exchange Server for tracking the flow of messages through an Exchange e-mail system. You can use the Message Tracking Center to identify and diagnose messaging problems such as slow or stopped connections and slow network segments or wide area network (WAN) links.

You can also use the Message Tracking Center to locate a specific message—for example, to track an unauthorized message and remove it from the system.

TIP

To use the Message Tracking Center, message tracking must first be enabled on one or more of the following Exchange components:

  • Message Transfer Agent (MTA)

  • Information Store

  • Internet Mail Service

  • Microsoft Mail Connector

When message tracking is enabled, log files are generated by the System Attendant on each server. The Message Tracking Center then interprets and analyzes these logs.

Message Transfer Agent (MTA)

One of the four core components of Microsoft Exchange Server. The Message Transfer Agent (MTA) routes messages between servers, sites, and foreign mail systems. It is implemented as a Microsoft Windows NT service on an Exchange server. The MTA is responsible only for delivering messages from one Exchange server to a different server. It is not responsible for delivering messages between users whose mailboxes are located on the same Exchange server.

NOTE

The term “message transfer agent” is also used more generally to describe any mail system software that can move messages from one message store location to another. For example, the External program for the legacy Microsoft Mail version 3 could move messages from one Microsoft Mail postoffice to another. MTAs also form a core component of any X.400 messaging system.

Messaging Application Programming Interface (MAPI)

A Microsoft technology that allows developers to use the Microsoft Windows messaging subsystem for writing messaging applications.

How It Works

Messaging Application Programming Interface (MAPI) provides a generic programming interface for making Windows applications mail-enabled and standardizes how messages are handled by messaging applications. MAPI also provides a general messaging subsystem built into the Windows operating system that can function with any message transport mechanism. The messaging subsystem is thus similar to the printing subsystem that allows Windows to interface with any kind of print device and perform standard printing functions.

MAPI is a kind of middleman between the messaging application running on the computer and the underlying messaging services. The client interface for accessing these services through MAPI is the same whether the services are LAN-based messaging services, e-mail services, fax services, or any other messaging service. MAPI allows standard function calls to access general messaging functions such as sending, receiving, and reading messages in a uniform fashion regardless of the messaging subsystem used. MAPI provides two sets of interfaces: the client-side application programming interfaces (APIs) called by the messaging application, and the service-provider interfaces that the Windows messaging subsystem uses to connect with different messaging-handling systems.

Microsoft Outlook is an example of a MAPI-enabled client. Microsoft Exchange Server is Microsoft’s MAPI-enabled mail server.

Messenger service

A Microsoft Windows NT and Windows 2000 service that sends and receives pop-up messages. These messages can be generated by the Alerter service, which generates Windows NT alerts when conditions warrant it. Or, an administrator can generate pop-up messages in one of the following ways:

  • In Server Manager, choosing Send Message from the Computer menu to send a message to all users currently connected to the selected server

  • Using the Net Send command at the Windows NT command prompt

NOTE

For a message to be received on Windows NT Workstation or Windows 2000 Professional, the Messenger service must be started on the workstation. For a message to be received on a computer running Windows 95 or Windows 98, winpopup.exe must be running.

metabase

A hierarchical, memory-resident database that is used to store configuration settings for Internet Information Services (IIS). Prior to Microsoft Internet Information Server version 4, this information was stored in the Microsoft Windows NT registry. The metabase is more flexible and expandable than the registry and provides better performance.

The metabase is stored in the file metabase.bin in the \WINNT\system32\inetsrv directory on a machine running IIS.

NOTE

Some settings for IIS 4 are still stored in the registry for backward compatibility with older versions of IIS.

TIP

The Microsoft Internet Information Server Resource Kit includes a number of administrative scripts that you can use to back up and restore the metabase.

metropolitan area network (MAN)

A term that can mean several things in different contexts:

  • Multiple local area networks (LANs) that are connected on a campus or industrial complex using a high-speed backbone.

  • Multiple networks that are connected within the same city to form a citywide network for a specific government or industry.

  • Any network bigger than a LAN but smaller than a wide area network (WAN).

  • A Distributed Queue Dual Bus architecture network based on the IEEE 802.6 standard of Project 802. This is the formal definition of a metropolitan area network (MAN), but it is essentially obsolete.

TIP

Fiber Distributed Data Interface (FDDI) is a good network technology for building a metropolitan area network (MAN).

MFC

See
Microsoft Foundation Classes (MFC)

MIB

See
Management Information Base (MIB)

microkernel

See
kernel

Microsoft BackOffice

A comprehensive and integrated family of server products for intranets, corporate networks, and the Internet. Microsoft BackOffice is available in two different integrated product suites—BackOffice Server and BackOffice Small Business Server—and also as a series of separately available products, which are listed in the following table.

Other Microsoft BackOffice Products
Application | Description
Microsoft SNA Server 4 | Used to integrate mainframe and AS/400 applications, data, and security with PC local area network (LAN), wide area network (WAN), and Internet/intranet environments
Microsoft Host Data Replicator | Provides bidirectional snapshot replication of data between Microsoft SQL Server and multiplatform DB2 databases by means of SNA Server
Microsoft Proxy Server 2 | Offers firewall security functions and high-performance Web caching in one product
Microsoft Systems Management Server (SMS) 1.2 | A multisite management system that provides integrated desktop management for customers with medium to large Microsoft Windows–based environments
Microsoft SQL Server 7 | A scalable, high-performance database-management system designed for distributed client/server computing that includes built-in data replication, management tools, integration with the Internet and intranets, and an open system architecture
SQL Server 7, Enterprise Edition | A high-performance database-management system designed for large, high-availability database applications and distributed, mission-critical database applications
Microsoft Exchange Server 5.5 | A messaging and collaboration server for businesses of all sizes that fully supports Internet protocols
Exchange Server 5.5, Enterprise Edition | Adds unlimited message storage and other enhancements to Exchange Server
Microsoft Site Server 2 | A comprehensive Web site environment for creating, deploying, and managing intranet sites using Windows NT and Internet Information Services (IIS)
Site Server 2, Enterprise Edition | Adds features for the advanced management of commerce-enabled Web sites to Site Server
On the Web
•
Microsoft BackOffice products
: http://www.microsoft.com/backoffice

Microsoft BackOffice Server

An integrated suite of server applications that are optimized for the Microsoft Windows NT operating system. Microsoft BackOffice Server lets organizations easily develop, deploy, and administer powerful intranet and line-of-business applications. It provides integration, cohesion, and ease of use along with scalability, interoperability, availability, and manageability. BackOffice Server is also the easiest and most cost-effective way to license and use the BackOffice family of products through client access licenses (CALs).

The advanced features of BackOffice Server version 4.5 include the following:

  • Support for all major Internet protocols

  • Messaging and collaboration services

  • Database services

  • Systems management services

  • Proxy and firewall services

  • Web site content publishing, management, and analysis services

  • Mainframe host integration services

  • Microsoft Management Console (MMC)

  • Cross-suite reporting with Seagate Crystal Info version 5

  • Intranet starter site with sample applications

  • Integrated, scenario-based setup

  • Web-based administration tools

  • Development tools

BackOffice Server version 4.5 includes the following applications to provide core networking, file and print, communication, Web, and application services:

  • Windows NT 4

  • Internet Information Server 4

  • Microsoft Index Server 2

  • Microsoft Certificate Server

  • Microsoft Transaction Server (MTS) 2

  • Microsoft Message Queue (MSMQ) Server

  • Microsoft Internet Connection Services for Remote Access Service (RAS)

  • Microsoft FrontPage

  • Microsoft Exchange Server 5.5 and Microsoft Outlook

  • Microsoft Proxy Server 2

  • Microsoft SNA Server 4

  • Microsoft SQL Server 7

  • Microsoft Site Server 3 (free coupon included)

  • Microsoft Systems Management Server (SMS) 1.2

  • Seagate Software Crystal Info 5 (five-user)

On the Web
•
Microsoft BackOffice Server
: http://www.microsoft.com/backofficeserver

Microsoft BackOffice Small Business Server

A complete, integrated solution for businesses with 25 or fewer PCs. Microsoft BackOffice Small Business Server includes file, print, and application services; communication services; and Internet connection services.

Small Business Server integrates these applications from the BackOffice family of products:

  • Microsoft Windows NT

  • Microsoft Exchange Server

  • Microsoft SQL Server

  • Internet Information Services

  • Microsoft Proxy Server

Small Business Server also extends this BackOffice functionality by including the following:

  • Microsoft Fax Service

  • Microsoft Modem Sharing Server

  • Internet connectivity for small businesses

Small Business Server is easy to set up and manage, and it can grow with a business’s needs. It includes the following features:

  • Unified, integrated administration through the Small Business Server Console

  • Simple, wizard-based installation and configuration (from creating users to installing printers and establishing Internet connectivity)

  • Easy setup and configuration of client computers using the Set Up Computer Wizard

  • Extensive online help and troubleshooting tips for the administrator and users

  • An easy upgrade path to BackOffice Server when a business grows beyond 25 computers

  • Support for e-mail, the Internet, and fax

  • Scheduling and collaboration features through the Microsoft Outlook desktop information manager and Exchange Server

On the Web
•
Microsoft BackOffice Small Business Server
: http://www.microsoft.com/backofficesmallbiz

Microsoft Backup

A tool included with Microsoft Windows 98 that lets you back up files from your hard drive to tape, floppy disks, or another computer on the network. Microsoft Backup is derived from backup software produced by Seagate Software.

How It Works

You start Backup using System Tools in the Accessories program group. The tool opens with a wizard that lets you choose from the following options:

  • Create a new backup job

  • Open an existing backup job

  • Restore from a previous backup job

If you are creating a new backup job, you use the wizard-based graphical interface to specify the volumes, folders, and files to be backed up, whether to back up all selected files or only those that are new or have changed since the last backup, the location to which you want to back up your files (a device or network location), and options for verifying and compressing backups. A report of the success or failure of the backup process is also created.

Graphic M-9. Microsoft Backup.
Graphic M-9. Microsoft Backup.

Microsoft Certificate Server

A Microsoft BackOffice application for issuing and managing standard X.509 digital certificates. Microsoft Certificate Server, which is included with the Microsoft Windows NT Option Pack, and Microsoft Certificate Services, which is included in Windows 2000, enable network administrators to act as a certificate authority to issue, renew, manage, and revoke digital certificates for their enterprise without having to use the services of third-party certificate authorities. Certificate Server is designed for networks that use Web-based applications and tools and require the security and reliability of the Secure Sockets Layer (SSL) protocol, Secure/Multipurpose Internet Mail Extensions (S/MIME), and Microsoft Authenticode software signing.

How It Works

Certificate Services give network administrators full control over certificate policies and procedures, the format and content of certificates, and certificate management. It logs all certificate transactions, allowing administrators to track and audit certificate issuance, renewal, and revocation.

Certificate Server receives PKCS #10 certificate requests generated by other applications such as Key Manager from Internet Information Server (IIS) version 4. These certificate requests are submitted on behalf of an entity (individual, system, company, or organization) and include the entity’s identification information and public key. The Certificate Server administrator verifies the identity of the entity that issued the request and issues an X.509 digital certificate in PKCS #7 format to the entity if all appropriate criteria have been met.

Certificate Server runs as a Windows NT service. It is administered using a standard Web browser. You use Web-based tools to manage the two Certificate Server databases: Server Queue, which keeps a record of all certificate requests that have been received, and Server Log, which keeps copies of all certificates that have been issued.

Certificate Server is policy independent and can receive certificate requests through any transport medium, including Hypertext Transfer Protocol (HTTP), remote procedure calls (RPCs), floppy disks, and custom transport mechanisms. Certificate Server uses Microsoft CryptoAPI to ensure the security and privacy of confidential information.

See also
Certificate Administration Log Utility, Certificate Administration Queue Utility

Microsoft Certified Database Administrator (MCDBA)

A Microsoft certification for individuals who have demonstrated expertise in administering and implementing databases using Microsoft SQL Server. Users who achieve this certification have demonstrated ability in performing tasks such as

  • Installing and configuring SQL Server

  • Planning and designing SQL databases

  • Creating, configuring, managing, maintaining, optimizing, monitoring, and troubleshooting databases

  • Using transact-SQL for creating data services

The Microsoft Certified Database Administrator credential is broken into two separate tracks. To achieve the Microsoft Certified Database Administrator (MCDBA) designation in Windows NT 4, candidates must pass four core exams relating to Microsoft Windows NT Server and SQL Server 7, plus one elective exam. The Windows 2000 track requires 3 core exams plus one elective.

On the Web
•
MCDBA program info
: http://www.microsoft.com/mcp/mktg/mcdba.htm

Microsoft Certified Professional (MCP)

A Microsoft certification for individuals who have demonstrated in-depth knowledge of a specific Microsoft Windows operating system, Microsoft BackOffice product, or Microsoft application development tool. Employers can use the Microsoft Certified Professional (MCP) designation to screen candidates for technical positions, and current employees can be encouraged to achieve this designation as part of their career advancement path.

You become an MCP by passing an exam associated with the specific software tool. The exams are administered by independent organizations such as Sylvan Prometric and Virtual University Enterprises, which together have over 1400 testing centers worldwide. Passing any one Microsoft exam (except Exam 70-058, Networking Essentials) earns you the MCP designation. You can earn further designations on the system engineer, developer, and Internet tracks by passing a set of core and optional exams. These designations include Microsoft Certified Systems Engineer (MCSE), Microsoft Certified Solution Developer (MCSD), Microsoft Certified Database Administrator (MCDBA), and Microsoft Certified Trainer (MCT).

Other certifications require mastering combinations of skills. Examples include Microsoft Certified Systems Engineer + Internet, Microsoft Certified Professional + Site Building, and Microsoft Certified Professional + Internet.

On the Web
•
MCP home page
: http://www.microsoft.com/mcp
•
MCP program information
: http://www.microsoft.com/mcp/mktg/cert.htm

Microsoft Certified Solution Developer (MCSD)

A Microsoft certification for individuals who have demonstrated in-depth knowledge of Microsoft tools for designing and developing solutions for business, such as Microsoft Visual Studio. Microsoft Certified Solution Developer (MCSD) is the premier designation for individuals who design and build custom solutions for Microsoft Windows operating system platforms. To become an MCSD, you must pass three core exams—Desktop Application Development, Distributed Application Development, and Solution Architecture—and one elective exam.

The benefits of MCSD designation include industry recognition, a subscription to the Microsoft Developer Network (MSDN), and access to technical and product information.

On the Web
•
MCSD program information
: http://www.microsoft.com/mcp/mktg/mcsd.htm

Microsoft Certified Solution Provider (MCSP)

A business that is enrolled in a Microsoft program that helps businesses provide customers with Microsoft networking, system integration, application development, and training solutions. Microsoft Certified Solution Providers (MCSPs) have expertise in Microsoft products and services as well as third-party products and technologies.

Benefits of belonging to the MCSP program include early access to new Microsoft products, Microsoft business development tools, technical information, and membership in a worldwide network of MCSPs. An alternative channel for organizations who cannot meet the MCSP program requirements is the Microsoft Direct Access (MSDA) program.

On the Web
•
MCSP Public home page
: http://www.microsoft.com/mcsp

Microsoft Certified Systems Engineer (MCSE)

A Microsoft certification for individuals who have demonstrated in-depth knowledge of Microsoft Windows NT and Microsoft BackOffice networking products. A Microsoft Certified Systems Engineer (MCSE) can perform various functions within an IS department, work as a consultant or systems integrator, or function in numerous other technical capacities. MCSEs are often employed as support technicians, network analysts, or operating systems experts. The MCSE designation is Microsoft’s premier designation for individuals who are skilled in planning, installing, configuring, optimizing, maintaining, and troubleshooting Windows operating systems and BackOffice server products.

To earn the certification, you must pass four operating systems exams and two elective exams. Benefits of the MCSE designation include industry recognition, a subscription to the Microsoft TechNet Technical Information Network, and access to technical and product information.

On the Web
•
MCSE program information
: http://www.microsoft.com/mcp/mktg/mcse.htm

Microsoft Certified Technical Education Center

See
Certified Technical Education Center (CTEC)

Microsoft Certified Trainer (MCT)

An instructor certified technically by Microsoft who provides training in Microsoft products and services. Microsoft Certified Trainers (MCTs) must use the Microsoft Official Curriculum (MOC) and must deliver training at authorized Microsoft training locations such as Certified Technical Education Centers (CTECs) and Authorized Academic Training Program (AATP) institutions. MCT is Microsoft’s premier designation for individuals who are skilled in imparting practical knowledge of Microsoft products.

MCTs must demonstrate their training skills and technical competency on a course-by-course basis by passing the relevant exam and fulfilling other requirements.

On the Web
•
MCT program information
: http://www.microsoft.com/mcp/certstep/mct.htm

Microsoft Challenge Handshake Authentication Protocol (MS-CHAP)

An encrypted authentication scheme used in wide area network (WAN) communication. Microsoft Challenge Handshake Authentication Protocol (MS-CHAP) is supported by the Point-to-Point Protocol (PPP) used by the Remote Access Service (RAS) of Microsoft Windows NT, and the Point-to-Point Tunneling Protocol (PPTP) used by the Routing and Remote Access Service (RRAS) of Windows NT Service Pack 4 and later and by Windows 2000 and Windows 98.

How It Works

MS-CHAP is similar to the Challenge Handshake Authentication Protocol (CHAP) that encrypts password information before transmitting it over a PPP link using the industry-standard MD5 one-way encryption method. MS-CHAP is Microsoft’s version of CHAP; it differs from CHAP in the following ways:

  • The MS-CHAP challenge response packet is in a format designed specifically for Windows platforms.

  • MS-CHAP does not require the use of plaintext or reversibly encrypted passwords the way CHAP does. Instead, the RAS server uses the MD4 hash of the password for validating the challenge response.

Both the client and the authenticating server generate independent initial keys for data encryption. For example, to establish a PPP session between a Windows NT RAS server and a Windows dial-up networking client, the client first requests authentication from the RAS server. The RAS server then sends the client a challenge consisting of a session identifier and an arbitrary string of characters called the challenge string. The client returns a response to the server that consists of the username plus a one-way encryption of the password, session identifier, and challenge string. The RAS server examines the response and determines whether to authenticate the client.

NOTE

The original Windows NT RAS service supports MS-CHAP version 1, while Windows NT and Windows 2000 RRAS support MS-CHAP version 2. Version 2 of MS-CHAP supports mutual (two-way) authentication to verify the identity of both sides of a PPP or PPTP connection, and separate cryptographic keys for transmitted and received data that are based on the user’s password and the arbitrary challenge string. This two-way authentication is more secure than version 1 because the same user will have different keys generated for each PPP or PPTP session. LAN Manager encoding of password changes and challenge responses is also no longer supported in version 2.

Microsoft Cluster Server (MSCS)

The clustering-solution software included with Microsoft Windows NT Server, Enterprise Edition. Microsoft Cluster Server (MSCS) supports clusters of two servers that are running Windows NT Server, Enterprise Edition. It provides network administrators with a scalable, centralized solution for networks that require high availability of resources. When network clients try to connect to shared resources on MSCS, they do so in the same way that they connect to any other network server. Users can thus learn to work with clusters without requiring additional training.

Clustering also provides static load balancing—that is, the distribution of processes across servers. This is different from fault tolerance, which provides error-free, nonstop availability of resources, usually through a backup of the primary system that remains idle until a failure occurs. In a cluster, the redundant systems are active, not passive.

How It Works

With MSCS, when one server (node) in a cluster fails or is taken offline, the other server takes over the failed server’s operations. Clients accessing resources on MSCS experience little or no interruption in their work because MSCS automatically moves the resource functions from one cluster node to the other.

MSCS nodes in a cluster are connected using a network, which typically is a Small Computer System Interface (SCSI) bus. MSCS provides users with a single, virtual image of the cluster. If one node in the cluster fails, the applications on the failed node are made available on the other node. Client access to network applications continues with little or no interruption. In most cases, if the interruption is detected in 5 seconds, services will be available again in 30 seconds or less, depending on how long it takes to restart the application.

For example, suppose one node in a cluster runs Internet Information Services (IIS) to service Web clients, while the other node runs a Microsoft SQL Server database. If the first node fails, the resource (IIS) fails over to the second node, which now responds to both Web and SQL requests from clients.

MSCS has two components:

  • Clustering software that enables nodes in a cluster to exchange specific types of messages and manage the transfer of resource operations as needed. This software includes the Cluster Service and the Resource Monitor.

  • Cluster Administrator, a GUI-based application for managing a cluster.

NOTE

In MSCS, a resource (such as a network application or shared resource) can be hosted on only one node at a time. If you configure the resource to fail over, the operation of the resource moves from the failed node to the working node in response to a failure. Related or dependent resources can also be organized into resource groups, which can also run on only one node at a time. If a resource group has an IP address and network name assigned to it, the group’s resources appear to network clients as individual servers called virtual servers. Users can access applications or services on a virtual server exactly as they would if the application or service resided on a physical server.

TIP

MSCS clusters can work with only one interconnect, but two interconnects are strongly recommended to eliminate a single point of failure for the cluster.

NOTE

For information on clustering in Windows 2000, see the entry Windows Clustering elsewhere in this work.

On the Web
•
Microsoft Cluster Server overview
: http://www.microsoft.com/ntserver/ntserverenterprise/exec/overview/Clustering.asp

Microsoft Commercial Internet System (MCIS)

A comprehensive, integrated, commercial-grade Internet server suite aimed at commercial service providers (CSPs). Microsoft Commercial Internet System (MCIS) includes integrated applications in four areas:

  • Membership services:
    The MCIS Membership System integrates with other MCIS services to enable CSPs to manage and deploy Internet services for a community of members. CSPs can authenticate users, authorize access to various services, and customize services to meet the needs of their membership.

  • Community services:
    MCIS includes a commercial-grade Internet standards–based mail system called MCIS Mail that can scale to millions of users. MCIS Mail blocks unsolicited mail (spam) by not relaying Simple Mail Transfer Protocol (SMTP) mail. MCIS also includes an Internet standards–based Network News Transfer Protocol (NNTP) news service called MCIS News for hosting electronic discussion groups and community bulletin boards. MCIS News can support tens of thousands of concurrent users and provides public, read-only, moderated, or authenticated newsgroups. MCIS also includes conferencing services through MCIS Chat for text-based real-time collaboration. This is the IRC-based Chat service included with Microsoft Exchange Server version 5.5. It can be used along with the Microsoft NetMeeting conferencing software client to engage in real-time conferencing.

  • Hosting services:
    MCIS includes Microsoft Site Server, Commerce Edition, a suite of Internet server applications for building e-commerce Web sites. Site Server, Commerce Edition, lets your customers publish content, personalize delivery of information, analyze site usage, and build full-featured commerce-enabled business solutions.

  • Network access services:
    Through Internet Connection Services for Microsoft Remote Access Service (RAS), CSPs can deploy and manage virtual private networks (VPNs) and roaming services for their customers. Wizards simplify the process of customizing and preconfiguring dialers, which can be branded with a CSP’s icons and logos. Dialers automatically configure client machines for Internet access. Phone books can be centrally managed to provide users with the most current network access numbers.

On the Web
•
MCIS home page
: http://www.microsoft.com/mcis

Microsoft Connection Manager (CM)

A client dialer for connecting to network resources on public networks or secure private networks over the Internet. Microsoft Connection Manager (CM) resides on top of Network and Dial-up Connections and simplifies network access. It is available for Microsoft Windows 95, Windows 98, Windows NT, and Windows 2000 and can be customized using the Connection Manager Administration Kit (CMAK).

Using the Connection Manager dialer, an employee or subscriber can establish a connection to the Internet or to a private company network. Connections can also be customized. For example, the dialer can automatically toggle Point-to-Point Tunneling Protocol (PPTP) on or off based on the network access phone number selected. By dialing an Internet service provider (ISP) phone number and enabling PPTP, employees can have transparent access to their corporate network through an encrypted tunnel over the Internet.

Connection Manager resides on the client machine and is used for connecting to points of presence (POPs) for Internet access provided by the company or ISP. Connection Manager’s features include the following:

  • Wizard-based administration

  • POP and RAS phone books

  • Automatic disconnect and redial

  • Multiple custom service profiles

Microsoft Data Access Components (MDAC)

A set of technologies that provide access to information in a variety of sources. Developers can use these components in client/server and Web-based situations. Microsoft Data Access Components (MDAC) includes the following:

  • ActiveX Data Objects (ADO), a simplified interface to OLE DB

  • OLE DB, a low-level interface to multiple types of data sources including relational databases, ISAM, spreadsheets, and delimited text files

  • Open database connectivity (ODBC), a standard interface to relational data sources

Microsoft Developer Network (MSDN)

A Microsoft program that provides developers with tools, information, training, and events to help them develop products for Microsoft Windows platforms. MSDN Online, the Web site for developers of Windows-based software, regularly features news, general information, and in-depth technical articles and interviews. Membership in MSDN Online is free upon registration and includes access to the MSDN Library Online, a vast collection of content and downloadable sample code. Developers can also pay to subscribe to the MSDN Library, which provides regular CDs containing product documentation, code samples, technical articles, and more. The benefits of paid subscriptions to the Microsoft Developer Network (MSDN) vary with the level of subscription chosen, with the most expensive subscriptions including copies of Microsoft operating systems, Microsoft development kits, Microsoft BackOffice applications, Microsoft Visual Studio development suites, and other software.

TIP

You can receive MSDN information by subscribing to the MSDN Flash e-mail newsletter, a semi-monthly newsletter with news, event listings, and important announcements.

On the Web
•
MSDN Online home page
: http://msdn.microsoft.com

Microsoft Direct Access (MSDA)

A program that provides consultants and resellers of Microsoft products and services with free online technical support, local Direct Access Quarterly Briefing events, a weekly e-mail newsletter, technical training opportunities, and Not For Resale (NFR) versions of Microsoft software. The Microsoft Direct Access (MSDA) Web site offers information on various new Microsoft products, sales and marketing tips, technical support newsgroups, and other valuable information.

On the Web
•
MSDA home page
: http://www.microsoft.com/directaccess

Microsoft DNS Service

Also called the Microsoft DNS Server service, an optional service on Microsoft Windows NT Server that implements the Domain Name System (DNS) on a server running Windows NT, allowing that server to function as a DNS server or name server. The Microsoft DNS Service for Windows NT is a fully BIND-compliant implementation of DNS and is an optional component that you can install on a Windows NT server using the Network utility in Control Panel. It includes a GUI-based tool called DNS Manager that you can use to create and administer resource records on all DNS servers on the network.

Windows 2000 includes an enhanced version of the Microsoft DNS Service that includes the following additional functionality:

  • Integration with Active Directory. You can store resource records in Active Directory and replicate them more easily. Using a special resource record called an SRV record, you can integrate downlevel Windows NT–based servers with Microsoft DNS Service installed with Active Directory. The SRV record is defined in Request for Comments (RFC) 2052.

  • Support for the DNS dynamic update protocol, a protocol based on RFC 2136 that enables hosts to register their DNS name dynamically with the name server. Hosts can also be required to be authenticated for purposes of dynamic name registration, as defined in RFC 2137.

  • Integration with Dynamic Host Configuration Protocol (DHCP), which allows the Windows 2000 DHCP service to automatically register the DNS name of clients.

  • Support for the incremental zone transfer method specified in RFC 1995, which allows DNS servers to transfer only zone updates to each other instead of having to transfer entire zone files.

  • Support for the Unicode character set.

TIP

You must install Service Pack 4 on Windows NT Server to be able to create SRV records manually. If you are integrating your Windows 2000–based DNS servers with non-Microsoft name servers that do not support SRV records (such as BIND 4 name servers), you must either upgrade the non-Microsoft name server to a version that supports SRV records or designate your new Windows 2000 domain as a new DNS subdomain.

See also
DNS Manager, DNS server

Microsoft Exchange Server

Microsoft’s client/server messaging system for Windows NT and Windows 2000. Exchange Server 5.5 supports all key industry messaging standards, including the following:

  • X.400

  • Internet standards (SMTP, POP3, IMAP4, LDAP, HTTP, NNTP, SSL, MIME, and S/MIME)

  • Messaging Application Programming Interface (MAPI)

Exchange clients are available for all the popular operating systems, including the following:

  • MS-DOS, Windows 3.x , Windows 95, Windows 98, Windows NT, and Windows 2000

  • Apple Macintosh

  • UNIX

  • OS/2

The popular client Microsoft Outlook complements Exchange Server by providing users with a full desktop information-management tool for managing messages, appointments, tasks, and contacts.

Exchange Server is designed for mission-critical enterprise-level messaging solutions and includes such features as

  • Intelligent message rerouting

  • Transaction-based directory services

  • Fault-tolerant message store

  • Built-in server and link monitoring tools

  • Connectors and gateways for connectivity with foreign mail systems

Exchange Server can coexist with most popular mail systems and can be used for messaging connectivity with the following:

  • Microsoft Mail

  • Internet mail (SMTP)

  • X.400

  • Lotus cc:Mail

  • IBM PROFS and SNADS

How It Works

A company’s Exchange organization is divided into sites, each of which has one or more Exchange servers. Site connectors provide connectivity between permanently connected sites, and you can use other connectors to establish messaging connectivity with foreign mail systems and over dial-up Remote Access Service (RAS) connections. Exchange Server offers public folders for document sharing and management, and address book views provide users with custom lists of recipients. An entire Exchange organization can be managed from a single workstation running the Exchange Administrator program. Clients can access their mailboxes from standard clients such as Outlook or standard Web browsers such as Microsoft Internet Explorer using the Outlook Web Access feature.

The core components of Exchange Server and other messaging components are implemented as Windows NT services. The four core components of Exchange Server are as follows:

  • Exchange directory service

  • Exchange Message Transfer Agent service

  • Exchange Information Store service

  • Exchange System Attendant service

NOTE

Exchange Server 4 natively supported the SMTP, MIME, MAPI, X.400, and X.500 messaging standards. Exchange Server 5.0 supported additional Internet standards such as POP3 for mailbox access, SMTP for Internet mail, NNTP for Usenet newsgroups, LDAP for X.500 directory access, HTTP and HTML for Web browser access, and SSL for secure authentication and encryption. Exchange Server 5.5 has added support for Microsoft Cluster Server, IMAP4, S/MIME, Key Management, Virtual Organizations, and unlimited message store size.

On the Web
•
Microsoft Exchange home page
: http://www.microsoft.com/exchange
See also
Exchange directory service, information store, Message Transfer Agent (MTA), System Attendant

Microsoft Fax Service

A component of Microsoft BackOffice Small Business Server that provides fax services to clients over the network. You can use Microsoft Fax Service to send and receive faxes over any Class 1 fax modem on the Small Business Server Recommended Hardware List. The fax client software is installed on client machines using the Set Up Computer Wizard. Users can fax both documents and e-mail messages using Fax Service.

How It Works

Fax Service creates shared fax printers on Small Business Server. You can add a fax printer to your Printers folder the same way that you add any other shared network printer. You can print documents using the fax printer or address e-mail messages to fax recipients. Small Business Server then dials the recipient and sends the fax.

When incoming faxes arrive, you can have Fax Service print them, save them in a shared folder, or route them to a user’s mailbox.

Microsoft Foundation Classes (MFC)

A set of classes, global functions, global variables, and macros developed by Microsoft that provides a framework for developing applications for Microsoft Windows platforms.

How It Works

The Microsoft Foundation Classes (MFC) are an object-oriented interface to the Windows application programming interface (API). MFC encapsulates much of the Windows API by providing classes that represent key Windows objects, such as windows, controls, dialog boxes, brushes, and fonts. Programmers can develop Windows-based applications by using a combination of C++ code and MFC instead of calling Windows API functions directly. Many MFC class member functions actually call the encapsulated Windows API functions. Note that you cannot call MFC class member functions directly—you have to instantiate the class first.

Most of the MFC classes are derived by inheritance from the root class named CObject. CObject provides support for serializing data and obtaining run-time class information, although you don’t need to derive new classes from CObject if you don’t need these capabilities. Other classes in MFC include the following:

  • MFC application architecture classes, which supply common functionality to most applications and create the framework for an application. The AppWizard uses these classes to create new applications.

  • Windows, dialog, and control classes for creating and managing windows.

  • Drawing and printing classes for encapsulating device contexts for graphical output and creating drawing tools such as brushes, palettes, and bitmaps.

  • Data type, array, list, and map classes for handling data of various types.

  • File and database classes for storing and retrieving files in databases or on disks. These include classes for file I/O, Data Access Objects (DAO), and open database connectivity (ODBC).

  • Internet and networking classes for exchanging information between computers and over the Internet. These include classes for Windows Sockets and Internet Server API (ISAPI).

  • OLE classes for creating compound documents and OLE objects, using Automation, creating ActiveX controls, and so on.

  • Debugging and exception classes for error handling and debugging applications.

Microsoft FrontPage

Microsoft’s Web site–management and content-development tool, which is part of the Microsoft Office family of productivity tools. Microsoft FrontPage 2000 includes a number of different views for developing, maintaining, and troubleshooting Web site content, including the following:

  • Page view:
    Allows users to display their content in normal (WYSIWYG) format, work directly in HTML, or preview their content as it will appear in a browser

  • Folders view:
    Displays the Web pages, graphics, and other files that are in the various folders making up a site

  • Reports view:
    Lets users run predefined reports that list slow pages, find unlinked or recently modified files, locate broken hyperlinks, and so on

  • Navigation view:
    Lets users create navigation bars and view the overall structure of their site

  • Hyperlinks view:
    Graphically displays the status of links

  • Tasks view:
    Lets users view and assign tasks in environments where groups of developers are collaborating on creating a site

FrontPage works with Web servers that have FrontPage Server Extensions installed on them, such as Internet Information Services (IIS) of Microsoft Windows 2000 Server. These server extensions enable FrontPage users to easily create and update dynamic Web content on local intranet or remote Internet Web servers.

On the Web
•
Microsoft FrontPage home page
: http://www.microsoft.com/frontpage

Microsoft Index Server

See
Indexing Service

Microsoft Internet Explorer

Microsoft’s Web browser and integrated suite of client-side Internet software, which integrates tightly into the Microsoft Windows operating system and is included with current versions of Windows as an essential operating system component. Microsoft Internet Explorer includes such components as

  • Internet Explorer Web browser

  • Microsoft Outlook Express

  • Microsoft NetMeeting

  • Microsoft FrontPage Express

  • Microsoft Chat

  • Web Publishing Wizard

  • Connection Wizard

Internet Explorer’s Web browser includes

  • Support for the latest Internet protocols, including Hypertext Markup Language (HTML) 4; Microsoft Visual Basic, Scripting Edition (VBScript); Jscript; ActiveX; Java; and Dynamic HTML

  • Split-screen Search, History, Channel, and Favorites Explorer bars that can be toggled on and off

  • Security zones for dividing intranets and the Internet into safe and unsafe regions with their own security settings

  • Authenticode 2 code-signing technology that enables users to check the digital certificate of downloaded code before installing it on their system

  • Offline browsing, which enables users to access Web content in their History or Subscribed Content folders when they are not connected to the Internet

  • Scheduled, unattended dial-up for obtaining Web content from subscribed sites to view offline later

  • Autocompletion of Uniform Resource Locators (URLs) typed into the address bar using Microsoft IntelliSense technology

  • Dynamic HTML behaviors that allow Dynamic HTML functionality to be extended through hosted components

  • Development enhancements that allow users to set the properties of items based on the value of an expression

  • Enhancements to tables that allow users to create fixed-layout tables and collapsible borders

  • Accessibility enhancements

On the Web
•
Microsoft Internet Explorer home page
: http://www.microsoft.com/windows/ie

Microsoft Internet Information Server (IIS)

See
Internet Information Services (IIS)

Microsoft Magnifier

A utility in Microsoft Windows 98 and Windows 2000 for visually impaired persons that presents a split screen, with one portion showing a magnified view of the selected part of the other portion. Users can control the size and position of the magnification window and the level of magnification, invert the screen colors, use the high-contrast color mode, and track the focus of the mouse pointer or cursor on the screen. You can configure Microsoft Magnifier using the Accessibility Wizard.

Graphic M-10. Microsoft Magnifier.
Graphic M-10. Microsoft Magnifier.

Microsoft Mail

The precursor to the Microsoft Exchange Server messaging system. Version 3 of Microsoft Mail provides LAN-based electronic mail to users of MS-DOS, Microsoft Windows 3.x , Windows NT, and LAN Manager.

How It Works

Microsoft Mail is a shared-file mail system. The central message store, called the postoffice, consists of inbox and outbox directories on a file server. The postoffice includes information for each user such as user ID, password, preferences, message folders, and the actual mail messages and attachments received by the user.

The External program acts as a Message Transfer Agent (MTA) for moving mail using the store-and-forward method. The MTA reads a message from one message store, reads the routing information to find out its intended destination, and connects with the destination message store to write the message to it. This is a scheduled event and does not occur continuously, so messages can take some time to be delivered.

Microsoft Mail is managed using the Administrator program. This program manages the postoffice, directory synchronization, gateways, and users.

Microsoft Mail Connector

A component of Microsoft Exchange Server that enables interoperability between Exchange Server and Microsoft Mail version 3 for PC networks and for AppleTalk networks. This connector allows Exchange to coexist with legacy Microsoft Mail networks while an upgrade to these networks is under consideration. The Microsoft Mail Connector is implemented as a Microsoft Windows NT service on an Exchange server.

TIP

If you are implementing connectivity between Exchange and Microsoft Mail on a local area network (LAN), the Microsoft Mail Connector is sufficient to connect to Microsoft Mail postoffices to transfer messages. If you are using a modem or an X.25 connection, you must install the Microsoft Mail External program on the remote Microsoft Mail postoffice server.

Microsoft Management Console (MMC)

A tool first included with Microsoft Windows NT Option Pack that provides an integrated management framework for all administrative tools. Microsoft Management Console (MMC) is now the standard administrative interface for managing the Microsoft Windows 2000 operating system and applications. In Windows 2000 and future releases of Microsoft BackOffice applications, all administrative tools will be implemented in the form of snap-ins for MMC.

How It Works

By itself, MMC does not provide any network or server management capability. Instead, it provides a common environment in which snap-ins can run. A snap-in is a component that provides some network or server management capability for administrators.

When a suitable set of snap-ins has been installed, the MMC configuration can be saved as a tool or an .msc file. You can use this file to delegate levels of management capability to other administrators, and you can place it on a network share or deliver it by e-mail.

The MMC user interface presents a hierarchical view of your network resources in a two-pane view similar to that of Windows Explorer. The left pane (the Scope pane) shows a hierarchical view of the administrative namespace of manageable nodes (network objects), while the right pane (Results pane) shows the contents, services, or configuration items of the selected node in the Scope pane. You perform management tasks by using the menu or toolbars, opening property sheets for nodes, and accessing Web pages in the Results pane.

MMC offers the following features:

  • Customization:
    Administrators can create an MMC tool that contains the exact functionality they need.

  • Integration:
    MMC integrates all management capability into a single common framework, making it easier to learn and perform network administration.

  • Flexibility:
    Third-party companies can create their own snap-ins to further extend the capabilities of MMC.

On the Web
•
Windows NT Management Services
: http://www.microsoft.com/ntserver/management

Microsoft Message Queue (MSMQ) Server

A Microsoft product included with the Microsoft Windows NT Option Pack and Windows NT Server, Enterprise Edition, that provides store-and-forward messaging services for Microsoft Transaction Server (MTS). Microsoft Message Queue (MSMQ) Server acts as a resource manager for MTS by allowing the components of distributed Web applications to asynchronously communicate with each other.

MSMQ supports such features as

  • Connectionless messaging:
    The sessionless store-and-forward message queuing methodology means that components of distributed applications do not have to establish sessions or even use the same networking protocol in order to share information.

  • Guaranteed delivery:
    Messages are logged to a disk-based queue to provide guaranteed delivery.

  • Network traffic prioritization:
    High-priority messaging traffic preempts low priority traffic, which guarantees proper response times for critical applications.

  • Support for transactions:
    You can bind multiple MSMQ-related actions into a single transaction, make sure that messages are delivered in order and no more than once, and confirm that messages reached their destination or were retrieved successfully from the destination message queue.

  • Routing:
    MSMQ’s smart routing is based on the network’s physical topology, session concentration, and transport connectivity.

  • Security:
    MSMQ supports access control through Windows NT security and digital signatures and supports auditing through the Windows NT application log. Encryption and authentication are supported using public key encryption and digital certificates.

  • Heterogeneous system support:
    MSMQ applications can be implemented over disparate hardware platforms.

How It Works

MSMQ is a store-and-forward service that lets applications running at different times communicate across heterogeneous networks, even when the systems are temporarily offline. Applications send messages to MSMQ, which queues messages to ensure that they eventually reach their intended destinations. MSMQ guarantees message delivery and provides fast and efficient routing, integrated security, and priority-based messaging.

Computers running MSMQ operate within an MSMQ Enterprise, which is divided into MSMQ sites that are connected with site links. MSMQ applications communicate using messages, which are simply units of information or data that are sent between computers and can contain text or binary data. Acknowledgments can be used to confirm whether messages reached or were retrieved from their destination queues. The MSMQ queues, which store and forward messages, include administration, system, dead letter, transactional dead letter, and report queues.

MSMQ uses four types of servers to control message queuing, each of which must be installed on computers running Windows NT Server, Enterprise Edition:

  • primary enterprise controller (PEC)

  • primary site controller (PSC)

  • backup site controller (BSC)

  • MSMQ Routing Server

MSMQ supports dependent clients, independent clients, and servers. Independent clients and servers run the MSMQ service and can communicate asynchronously with each other, while dependent clients use synchronous communication. Some MSMQ servers have a copy of the MSMQ Information Store (MQIS) database, which is a distributed database that stores information about the MSMQ enterprise, computers, and queues.

NOTE

On the Windows 2000 platform, this component is known as Message Queuing, and is sometimes referred to as MSMQ 2.0. Message Queuing is compatible with MSMQ 1.0 for Windows NT, and some of the changes with the new version include the following:

  • MSMQ sites are now integrated into Windows 2000 sites.

  • MQIS is now integrated into Active Directory.

  • PECs, PSCs, and BSCs are now called Message Queuing servers and run on Windows 2000 domain controllers.

  • MSMQ Routing Servers are now called Message Queuing servers with routing.

  • MSMQ site links are now called routing links.

  • MSMQ Explorer is integrated into the Microsoft Management Console (MMC) as an administrative snap-in.

On the Web
•
Overview of MSMQ
: http://www.microsoft.com/ntserver/appservice/exec/overview/MSMQ_Overview.asp

Microsoft Modem Sharing Server

A component of Microsoft BackOffice Small Business Server that enables users to connect to remote networks, online bulletin board systems, and the Internet. Microsoft Modem Sharing Server lets you pool modems installed on your server to provide users with greater bandwidth. Users connect to and use this pool in the same way that they use locally connected modems. This sharing of modems decreases hardware costs because individual users do not require locally attached modems.

When users need access to a remote network or an online service, they simply run the modem sharing application. The application uses a Component Object Model (COM) port that is connected over the network to a modem pool on your server running Small Business Server. An available modem from the modem pool dials the remote network or online service. If more than one modem is in the modem pool, your server automatically uses the next available modem in the pool.

Microsoft NetMeeting

An application included with Microsoft Internet Explorer version 4 that offers real-time communication over the Internet using audio and video conferencing capabilities. Microsoft NetMeeting uses Internet Locator Service (ILS) to locate other NetMeeting users who can be invited to participate in conferencing and collaboration.

NetMeeting includes the following features:

  • Support for T.120 and H.323 standards.

  • Audio and video conferencing capabilities.

  • Text-based chat windows.

  • Binary file transfers between users.

  • Multipoint data conferencing for sharing Microsoft Windows-based programs with multiple remote users in real time. Others can see what you are doing with a program, and they can remotely take control of the application.

  • Whiteboard for sharing graphics and real-time drawings.

  • Integration with Microsoft Outlook Express so that users can send e-mail to the people they can’t reach for an actual conference.

On the Web
•
Microsoft NetMeeting home page
: http://www.microsoft.com/netmeeting

Microsoft NetShow

A client/server networked streaming multimedia system for bringing rich broadcasting features to the Web. Using Microsoft NetShow Player, the client software, users can watch and listen to live or recorded broadcasts from NetShow servers without having to wait for downloads to complete. NetShow Player, which is included with Microsoft Internet Explorer, forwards audio or video files to the browser for display within a browser window or frame.

NetShow supports various delivery formats, including the following:

  • Audio, illustrated audio, and video-on-demand

  • Synchronized audio and video

  • Live Internet Protocol (IP) multicast audio, video, and file transfer

NetShow has the following four components:

  • Microsoft NetShow Server:
    For transmitting audio, video, and files to Microsoft Windows clients by using unicasting or multicasting.

  • NetShow Administrator:
    For configuring and monitoring NetShow servers and managing NetShow channels, programs, and streams.

  • NetShow clients:
    For receiving and rendering streams transmitted by NetShow servers. NetShow Player is an example.

  • NetShow content and conversion tools:
    For converting live audio and video to Advanced Streaming Format (the ASF Real-Time Encoder, for example) and for assembling, synchronizing, and compressing audio and video files into a single .asf file (the ASF Editor, for example). Conversion tools are also included for converting .mov, .avi, and .wav files to .asf format.

On the Web
•
Windows Media Technologies
: http://www.microsoft.com/windows/windowsmedia

Microsoft NetShow Server

The server site of the Microsoft NetShow client/server streaming media delivery system. NetShow Server is implemented as a series of Microsoft Windows NT services that can deliver streaming audio, video, and other files over TCP/IP networks (such as the Internet) to NetShow Player clients.

How It Works

NetShow Server can deliver streaming media content in two ways:

  • Unicasting:
    NetShow Server sends a separate copy of the data to any client that requests it. Unicasting involves computers establishing a two-way, point-to-point connection. The advantage of unicasting streaming media content is that the client can communicate with the server that supplies the multimedia stream. For example, the client can request that the server pause the stream. The disadvantage is that each client requires a separate stream, which can rapidly use up available bandwidth.

  • Multicasting:
    NetShow Server sends a single copy of the data to all clients that request it. Multicasting involves a server sending a single copy of the data stream over the network to multiple clients. The advantage of multicasting streaming data is that only one copy of the data is sent over the network, which uses much less bandwidth than unicasting. The disadvantage is that multicasting is connectionless, so clients have no control over the streams they receive.

NetShow Server can deliver content either live or on demand. Live content is delivered in conjunction with the NetShow Real-Time Encoder, which compresses the audio/video feed in real time before passing it to NetShow Server for delivery.

NOTE

The client side of the NetShow client/server streaming media delivery system, NetShow Player, can receive streaming media content from NetShow Server and display it for users.

TIP

You cannot use multicasting unless the routers on your network support multicasting. Unlike broadcasts, routers can control where multicasts travel on a network. If clients are behind a firewall, you can configure NetShow channels to offer clients unicasts instead of multicasts.

Microsoft Office User Specialist (MOUS)

A Microsoft certification for individuals who have demonstrated in-depth knowledge of the Microsoft Office suite of office productivity tools. Employers can use Microsoft Office User Specialist (MOUS) certification to screen candidates and can offer MOUS training to current employees. The MOUS program provides two levels of certification: Microsoft Office Proficient Specialist, for general knowledge of Office products, and Microsoft Office Expert Specialist, for advanced knowledge of Office products.

On the Web
•
MOUS home page
: http://www.mous.net

Microsoft Official Curriculum (MOC)

Courseware developed by Microsoft product groups to train network administrators, support staff, and system integrators in the use of Microsoft products. Microsoft Official Curriculum (MOC) courseware has been created for Microsoft BackOffice, Microsoft Office, and all Microsoft developer products. The curriculum generally includes training on planning for, implementing, installing, configuring, managing, optimizing, monitoring, and troubleshooting Microsoft products. MOC comes in both instructor-led formats and as self-paced training kits, and can be used to prepare for Microsoft Certified Professional (MCP) certification exams.

On the Web
•
MOC program information
: http://www.microsoft.com/train_cert/train/moc.htm

Microsoft Open License Program (MOLP)

A Microsoft software licensing program for small to mid-sized businesses with 5 to 1000 PCs on their network. Microsoft Open License Program (MOLP) provides flexible volume licensing that reduces costs associated with purchasing, upgrading, and maintaining Microsoft software. MOLP is a two-year agreement that facilitates compliance with licensing and simplifies the tracking and management of licenses.

How It Works

MOLP has three license pools based on product area:

  • Applications:
    Includes Microsoft Office, Microsoft FrontPage, Microsoft Visual Basic, and so on

  • Systems:
    Includes Microsoft Windows 95, Windows 98, Windows NT Workstation, and so on

  • Servers:
    Includes Windows NT Server, Microsoft BackOffice Server, Microsoft Exchange, Microsoft SQL Server, and so on

License pools are managed separately. Points are assigned to each deployment of a product. The number of points you accumulate in each pool determines the discount you receive for licenses in that pool over the two-year program. More points mean greater discounts, and the bigger the initial licensing purchase, the bigger the discount over the two-year period. Generally, one point equals one license. For example, one deployment of Windows NT is 15 points, while one deployment of Office is 2 points.

License types include the following:

  • Standard:
    No previous version of the software is on the machine.

  • Version upgrade (VUP):
    You purchase licenses to upgrade software.

  • Competitive upgrade (CUP):
    You purchase licenses to upgrade a competitor’s software to Microsoft’s version.

  • Product upgrade (PUP):
    You purchase licenses for upgrades such as Office 97 Standard to Office 97 Professional.

MOLP delivers client access licenses (CALs) through a secure Web site. This Web site also maintains the client’s database of licensing information.

On the Web
•
Microsoft licensing information
: http://www.microsoft.com/licensing

Microsoft Outlook

Microsoft’s mail client and full-featured desktop information-management application. Microsoft Outlook, which is part of the Microsoft Office suite, lets users manage their messages, appointments, contacts, tasks, and activities. It also integrates with other Office applications at the front end and with Microsoft Exchange at the back end to enable users to collaborate using e-mail, calendar, contact lists, task lists, journals, and notes. Outlook is a full MAPI client and interoperates with all e-mail systems that support Messaging Application Programming Interface (MAPI). Outlook can be run as a stand-alone application or as part of the Office suite.

Outlook’s advanced features include the following:

  • Support for MAPI, Post Office Protocol version 3 (POP3), Internet Mail Access Protocol version 4 (IMAP4), and Hypertext Transfer Protocol (HTTP)

  • A common user interface with other Office components

  • AutoNameCheck, message tracking, message recall, embedded hyperlinks, and other e-mail enhancements

  • Enhancements to calendar and scheduling functions to facilitate processing of meeting requests, tracking attendees, and configuring the duration of appointments

  • Simplified tracking of “to do” lists using task requests, task tracking, status reports, and task categorizations

  • Custom Outlook forms for creating custom collaboration applications

On the Web
•
Microsoft Outlook
: http://www.microsoft.com/outlook

Microsoft Outlook Express

An Internet mail and news client included with Microsoft Internet Explorer version 4. Microsoft Outlook Express replaces the older Microsoft Internet Mail and News client included with Internet Explorer 3.

Outlook Express includes the following features:

  • A customizable three-pane view that shows folders, messages, and message content

  • WYSIWYG editing of Hypertext Markup Language (HTML) messages

  • Support for Internet standard protocols, including Simple Mail Transfer Protocol (SMTP), Post Office Protocol version 3 (POP3), Internet Mail Access Protocol version 4 (IMAP4), Lightweight Directory Access Protocol (LDAP), and Network News Transfer Protocol (NNTP)

  • Support for multiple Internet service provider (ISP) accounts so that users can receive mail from multiple e-mail accounts and download all messages into the same Inbox

  • Integration with Internet Explorer security zones

  • Automatic name resolution (matching address book entries to a typed username)

  • Stationery templates for adding a personal touch to messages

  • Enhanced Inbox rules for filtering incoming mail

Microsoft Personal Web Server (PWS)

A workgroup-level Web server that is installed instead of the full Internet Information Server (IIS) version 4 when IIS is installed on a machine running Microsoft Windows NT Workstation, Windows 95, or Windows 98. Microsoft Personal Web Server (PWS) is suitable for personal publishing, hosting local area network (LAN) intranet sites, development and testing, and performing remote administration of IIS.

When PWS is installed on Windows NT Workstation, it supports all the features of IIS on Windows NT except the following:

  • Index Server

  • Hosting of multiple Web sites

  • ODBC logging

  • Domain blocking

  • Process isolation

How It Works

PWS has two components, a Web or Hypertext Transfer Protocol (HTTP) server and a File Transfer Protocol (FTP) server, which work independently.

You can run a Web server, an FTP server, or both. PWS creates the \Inetpub\ Wwwroot folder for your home page and for the files that you want to make available through FTP. You can create a subdirectory structure under this directory.

NOTE

When PWS is installed on Windows 95 and Windows 98, it lacks the NTFS security features. Be sure you don’t accidentally place sensitive data on your site.

Graphic M-11. You can manage PWS through Personal Web Manager.
Graphic M-11. You can manage PWS through Personal Web Manager.

Microsoft Proxy Server

A firewall and content-caching server that provides a secure gateway to the Internet with high response time. Microsoft Proxy Server, a part of the Microsoft BackOffice family of products, was the first firewall product to include high-performance content caching and the first content-caching server to provide firewall support.

Proxy Server includes the following features:

  • Firewall support through application layer proxy, circuit layer proxy, and dynamic packet filtering.

  • Real-time alerting and logging features that enable administrators to detect and track attacks on their networks.

  • Array-based and hierarchical content caching, including support for Caching Array Routing Protocol (CARP).

  • Support for reverse proxying, which causes Proxy Server to impersonate a Web server to outside users and enables it to fulfill requests for Web content from its cache and forward requests to the real Web server only when needed. Reverse proxying is supported only for Hypertext Transfer Protocol (HTTP).

  • Support for reverse hosting, which lets any server sitting behind Proxy Server publish to the Internet by having Proxy Server simulate virtual roots on a Web server and then redirect requests to a Web server. Reverse hosting is supported only for HTTP.

  • Support for server proxying, which allows Proxy Server to listen for incoming packets that are destined for computers on the secured network behind the Proxy Server and then forward these packets as appropriate to other servers. Server proxying is a circuit-layer service and works with a wide variety of application layer protocols.

  • Integration with Microsoft Windows NT administrative tools.

  • HTML-based administration and command-line management using scripting.

  • Support for SOCKS v4.3 support, HTTP 1.1, File Transfer Protocol (FTP) caching, and Secure Sockets Layer (SSL) tunneling.

  • Installable third-party components for virus scanning, JavaScript and ActiveX filtering, and site blocking.

How It Works

Proxy Server provides three basic types of proxy services: Web Proxy, Winsock Proxy, and SOCKS Proxy. These can all work together with dynamic packet filtering. The following table compares these proxy services.

Features of Microsoft Proxy Server
Item | Web Proxy | Winsock Proxy | SOCKS Proxy
Security layer (type of proxy) | Application layer | Circuit layer | Circuit layer
Protocols supported | HTTP, FTP, Gopher, HTTPS | Many | Many
Client support | Any CERN-based browser | Windows | Many
Special client software needed | No | Yes (included) | Yes (included)
Cacheable content | Yes | No | No
Dynamic packet filter support | Yes | Yes | Yes
On the Web
•
Microsoft Proxy Server
: http://www.microsoft.com/proxy

Microsoft RAS Protocol

A legacy Remote Access Service (RAS) protocol developed by Microsoft for Windows for Workgroups 3.11 and Windows NT 3.1 and supported by later versions of Windows for backward compatibility. Microsoft RAS Protocol enables legacy Windows RAS clients to dial in and connect to Windows for Workgroups or Windows NT RAS servers using the NetBEUI protocol. Once the RAS client establishes a connection, the RAS server acts as a NetBIOS gateway so that the client can access servers on the network using NetBEUI, NetBIOS over IPX, or NetBIOS over TCP/IP. Windows 3.1 does not support the Point-to-Point Protocol (PPP), but Windows NT 3.5 does. You need RAS Protocol only if you are connecting to a Windows NT RAS server from legacy Windows for Workgroups or Windows NT 3.1 clients.

Microsoft Sales Specialist

A certification for Microsoft channel partners who have demonstrated in-depth knowledge of Microsoft platforms, applications, solutions, and technologies. The Microsoft Sales Specialist program helps the certified individual to identify business opportunities and gain the skills to take advantage of them. Individuals who pass a skills assessment exam to earn the Sales Specialist designation gain access to a secure, dedicated Web site that provides tools, information, and strategies for maximizing their sales potential.

The program is targeted at managers, sales representatives, and marketing representatives, including Microsoft Certified Solution Providers (MCSPs), value-added resellers (VARs), and resellers and distributors of Microsoft products and services. The program includes training courses on 32-bit Microsoft Windows platforms, Microsoft BackOffice products, and Microsoft licensing programs.

On the Web
•
Microsoft Sales Specialist program information
: http://www.microsoft.com/salesspecialist

Microsoft Schedule+

A personal scheduling tool that was the precursor to the Calendar component of Microsoft Outlook. Microsoft Schedule+, which works with Microsoft Mail version 3 mail systems, helps users keep track of appointments, create “to do” lists, send meeting invitations and view invitees’ available times, and configure reminders of important events and meetings. Users can use Schedule+ while they are connected to the postoffice or while working offline. To use the group scheduling features of Schedule+, you need access to a Microsoft Mail server. Schedule+ can also be used as a stand-alone calendar program.

Microsoft Schedule+ Free/Busy Connector

A component of Microsoft Exchange Server that enables users to share free and busy time information in order to book meetings and appointments by using the calendar component of Microsoft Outlook or the older Microsoft Schedule+. The Microsoft Schedule+ Free/Busy Connector is implemented as a Microsoft Windows NT service on Exchange Server. It can exchange free/busy system information with legacy Microsoft Mail servers so that Exchange and Microsoft Mail messaging systems can coexist.

Microsoft Script Debugger

A component of Internet Information Server (IIS) version 4 that enables easy debugging of Active Server Pages (ASP) applications, regardless of the script language they are written in. You can use Microsoft Script Debugger to debug both client-side and server-side scripts written using Microsoft Visual Basic, Scripting Edition (VBScript); Jscript; REXX; or Perl. You can perform the following tasks:

  • View the source code of the script being debugged and execute the script line by line.

  • Set breakpoints, view and modify variables and property values, and view the stack.

  • Switch between different execution scripts.

NOTE

You can debug only scripts that are running on the local Web server, not on a remote server.

TIP

Do not use Script Debugger on a production system because it interrupts the execution of the script if an error occurs. Copy your scripts to a test system and debug them from there.

Microsoft Seminar Online

A Microsoft Web site that provides seminars over the Internet to users of Microsoft products and services. Seminar Online offers technical content from experts in Microsoft technologies, which users can receive on demand based on their needs and personal interests. Users can view seminars at any time and in any order. Seminars change frequently and provide practical and timely content on the latest Microsoft technologies. Selected seminars are also included in Microsoft TechNet subscriptions as CD compilations for easy viewing. There is no charge to view seminars, but you must have a frames-enabled Web browser.

On the Web
•
Microsoft Seminar Online home page
: http://www.microsoft.com/seminar

Microsoft Site Server

A comprehensive Internet server for end-to-end management of enterprise-level Internet and intranet sites. Using Microsoft Site Server version 3, organizations can easily publish information to the Internet or corporate intranets by providing content authors with a structured content submission, posting, and approval process managed by site administrators and site editors. Site Server lets users search for information from diverse sources that include internal and external Web sites, network file servers, Microsoft SQL Server databases and other ODBC-compliant databases, and Microsoft Exchange Server public folders. Using Site Server, companies can deliver information to users through personalized Web pages, channels, and direct e-mail. Site Server administrators can analyze site usage to plan and troubleshoot the structure and effectiveness of their sites.

Site Server is optimized to run with Microsoft Windows NT and Internet Information Services (IIS) and can be used in heterogeneous networking environments for clients running on any platform as long as they have a standard Web browser such as Microsoft Internet Explorer. Site Server tools cover the full range of Web site development needs:

  • Publishing:
    Site Server’s comprehensive publishing solution comprising a set of tools for managing site content. Content management tools let multiple content authors submit, tag, and edit content using a drag-and-drop Web interface. Content deployment tools let site administrators place Web content on staging servers for review and then securely and easily deploy it to production Web servers.

  • Delivery:
    Site Server’s powerful search tool lets users search across Internet and intranet Web sites, files, databases, and Exchange servers. Sites can deliver personalized content to users, including personalized mailings, using the Direct Mailer tool. Active Channel Multicaster, based on multicast technology, delivers information using push technologies. Active Channel Server can be used to manage and schedule the delivery of information using channels. Users can also self-manage subscription sites.

  • Analysis:
    Site Server provides tools for analyzing Web site usage and structure, and for importing Web server log files into a database from all popular Web servers (including IIS, Netscape, Apache, Lotus Domino, and Real Audio servers). You can also import data from sources other than Web server log files using Custom Import and then generate Web site activity reports based on that data using Report Writer and its 46 predefined report styles. You can use Content Analyzer to help you visualize the structure of Web sites. The powerful searching and analysis tools of Content Analyzer let you gain insight into how a site is being used.

TIP

Before you implement Site Server, you should do the following:

  • Sketch out the hierarchy of your organization with the common names of the various departments and sections, personnel classifications, and job titles.

  • List the content types you plan to use in building your site, and plan the attributes you will use to describe each type of content.

  • Use the makecm.vbs script included with Site Server to create your content stores with their various content types, directories, and attributes.

On the Web
•
Microsoft Site Server
: http://www.microsoft.com/SiteServer
See also
Microsoft Site Server, Commerce Edition

Microsoft Site Server, Commerce Edition

An integrated Internet server built on Microsoft Site Server for Internet e-commerce. Using Microsoft Site Server, Commerce Edition, businesses can create and manage cost-effective e-commerce sites and applications, produce targeted online advertising and marketing, and participate in personalized promotion schemes. Companies can conduct business online securely using order capture, management, and routing functions. Site Server, Commerce Edition, integrates easily into existing inventory, accounting, and electronic data interchange (EDI) systems and includes tools for analyzing customer and partner usage information.

In addition to the publishing, delivery, and analysis features of Site Server, Commerce Edition, version 3 includes such e-commerce features as

  • Ad Server:
    For deploying online advertisements. Ad Server supports targeted delivery, scheduled management, and exposure limits.

  • Buy Now:
    Formats product information and order forms in various ways (including for online ads).

  • Commerce Interchange Pipeline:
    Enables interchange of structured business information using the Internet or existing EDI systems.

  • Microsoft Market:
    A sample site with reference code for intranet-based corporate purchasing applications that use authenticated requisitions, purchase order workflow and approval mechanisms, a procurement catalog schema, and multiple purchase order output types.

  • Dynamic Promotion:
    Enables development of advertising campaigns and product promotions based on the preferences and purchasing history of customers and partners.

  • Order Processing Pipeline:
    For managing orders based on specified business rules.

On the Web
•
Microsoft Site Server, Commerce Edition
: http://www.microsoft.com/SiteServer

Microsoft Site Server Express

An Internet application for analyzing and reporting on the structure and functionality of Web sites hosted using Internet Information Services (IIS). Microsoft Site Server Express, which is included in the Microsoft Windows NT Option Pack, offers a subset of the functionality included with Microsoft Site Server, including the following tools and utilities:

  • Content Analyzer:
    For visual analysis of sites in the form of a Web map

  • Usage Import:
    Imports IIS logs for generating reports using Report Writer

  • Report Writer:
    Analyzes imported IIS logs and generates reports about the users and organizations that have visited your site and about the requests made at your site

  • Posting Acceptor:
    Enables users to publish Web content to IIS using the HTTP Post method described in Request for Comments (RFC) 1867

Microsoft SNA Server

A tool for LAN-host integration (integration of SNA and non-SNA networks, personal computers and host computers, and Internet/intranet technologies with IBM AS/400 and mainframe systems). Version 4 of Microsoft SNA Server is a comprehensive gateway and application integration platform that enables organizations to embrace Internet, intranet, and client/server technologies while preserving their investment in AS/400 and mainframe systems.

SNA Server offers the following advantages:

  • You save money by preserving existing AS/400 and mainframe investments.

  • It allows you to integrate Internet, intranet, and client/server solutions with host-based systems.

  • It provides a platform for developing powerful client/server applications, including next-generation Web transaction and e-commerce solutions, that use host resources.

How It Works

In its earliest versions, SNA Server provided gateway functions for integrating TCP/IP, Internetwork Packet Exchange (IPX), NetBEUI, and Banyan VINES networks with SNA host-based environments. This provided connectivity between LAN-based client/server systems such as Microsoft BackOffice Server and host-based systems such as IBM AS/400 and mainframe computers.

In version 3 of SNA Server, this gateway functionality was extended to include facilities integration with Microsoft Windows NT applications and security. Version 4 further extends the gateway functions while enhancing SNA Server’s position as a platform for application integration. SNA Server 4 is the first SNA gateway product that combines the features of a traditional SNA gateway with middleware application capabilities.

When a LAN client attempts to communicate with an SNA network, it establishes an initial connection with an SNA server, which provides the client with the names of all SNA servers in the domain. The client then tries SNA servers randomly from these names until it locates the requested logical unit (LU). An LU is a configurable unit that specifies the type of session to be established with the mainframe or AS/400 host. The SnaBase service lets SNA servers and clients keep track of the names of SNA servers in the domain. The SNA Server is connected to the AS/400 or mainframe using a dedicated 802.2, X.25, or Synchronous Data Link Control (SDLC) link using the appropriate hardware and cabling.

SNA Server 4 includes the following new features:

  • Microsoft Management Console (MMC) support, which integrates management of SNA Server with other Windows NT tools through several SNA Server snap-ins and makes SNA Server ready for the Windows 2000 family of operating systems

  • Support for up to 30,000 simultaneous sessions per server

  • Telnet support for 3270 and 5250 applets, which gives administrators more choice for terminal emulation when accessing AS/400 or mainframe systems

  • Web Setup for Windows 95 and Windows 98 clients, a simple way to provide host connectivity through Web browsers on corporate intranets by having users download a preconfigured SNA client using a standard Web browser such as Microsoft Internet Explorer

  • COM Transaction Integrator for CICS and IMS, which provides drag-and-drop simplicity for development of three-tier client/server or Web-to-host applications by integrating CICS or IMS mainframe environments with Microsoft Transaction Server (MTS)

  • Component Builder, a tool for importing COBOL code from mainframe environments and automatically generating components for MTS

  • SNA Session-Level Compression for improved data throughput

  • VSAM File Transfer command-line utility for uploading or downloading files between mainframe VSAM data sets and Windows NT

  • OLE DB Provider for AS/400 and VSAM

On the Web
•
Microsoft SNA Server
: http://www.microsoft.com/sna

Microsoft SQL Server

A high-performance client/server relational database–management system (RDBMS) for the Microsoft Windows NT and Windows 2000 operating systems. Microsoft SQL Server is part of the Microsoft BackOffice family of server products. RDBMS’s are used in high-volume transaction-processing environments such as online order entry systems, data warehousing, decision-support applications, and e-commerce.

SQL Server includes the following features:

  • A distributed management framework for centrally managing all servers running SQL Server in an organization

  • Built-in data replication to copy information throughout an enterprise not only to SQL Server databases but also to Oracle, IBM DB2, Sybase, and other databases

  • The Web Assistant for populating a Web server with SQL data for Internet or private intranet use

  • Microsoft Distributed Transaction Coordinator for creating distributed transaction-based applications across multiple servers

  • Integration with the security features of the Windows NT platform

  • A high-performance, scalable, multithreaded parallel architecture

  • Scalable dynamic locking architecture for page-level and row-level locking

  • Data warehousing and online analytical processing (OLAP) enhancements

  • Support for OLE Automation stored procedures

  • Integration with Microsoft Exchange through the SQL Mail utility

  • Support for Windows 2000, Windows NT, Windows 98, and Windows 95

  • A query processor that supports the complex queries used in decision support, data warehousing, and OLAP applications

  • Wizards that ease tasks for administrators and programmers

  • Support for Microsoft Management Console (MMC)

  • Tools for profiling and tuning a server’s performance

  • Integration with Microsoft Proxy Server and Microsoft Office 2000

How It Works

SQL Server is a client/server database system. The server runs the SQL Server database software, which processes requests submitted by the database client software and sends the results back to the client. The SQL Executive and the SQL Server Database Engine service are examples of database services performed by SQL Server.

The SQL Server software is arranged in multiple layers. The Net-Library layer, which accepts connections from clients, hides the network connectivity details when a client communicates with a server running SQL Server. Net-Libraries use interprocess communication (IPC) mechanisms such as named pipes, remote procedure calls (RPCs), and Windows Sockets. Several Net-Libraries are included with SQL Server for both the server and the client. Net-Libraries on the server listen for client connection attempts.

A client computer runs the database client software, which is used to connect to the server running SQL Server, make requests, receive results, and display the results on the user’s screen. Examples of database client software that can connect to SQL Server include SQL Server Enterprise Manager, ISQL/w, and Microsoft Access. The database client software is also made up of multiple layers. Users interact directly with the client application, which might present a form such as an order entry form. When the user submits the form, the client software interacts with the server running SQL Server using open database connectivity (ODBC) or DB-Library application programming interfaces (APIs). The server processes the request and returns information to the client.

On the Web
•
Microsoft SQL Server
: http://www.microsoft.com/sql

Microsoft Systems Management Server (SMS)

A Microsoft BackOffice application for managing an organization’s networked computers. Microsoft Systems Management Server (SMS) lets network administrators

  • Manage their hardware and software assets

  • Distribute new software from a central location

  • Manage shared applications loaded from network servers

  • Perform network protocol analysis for planning and troubleshooting purposes

  • Perform remote troubleshooting and remotely control individual PCs

For example, you can use SMS to determine which computers need updated drivers, which have sufficient free disk space to run new applications, how many copies of Microsoft Office are installed in your organization, and so on. This simplifies maintenance and upgrading tasks for network administrators.

Using SMS, you can also manage, install, and control server-based applications from a central location. You can perform network protocol analysis to locate and resolve bottlenecks on your network. Using the administrative tools of the Microsoft Windows NT operating system, administrators have a single, consistent administrative environment for managing their network assets.

How It Works

SMS organizes a company’s network assets into hierarchical logical groupings of computers and domains called sites. Using the top site, an administrator can centrally manage the entire network. Sites can be designed so that sites without administrators can be managed by sites with administrators. This logical structure is scalable—as your company grows and your needs change, you can add additional sites and structure.

A typical SMS enterprise deployment might consist of the following tiers:

  • A central SMS machine linked to a computer running Microsoft SQL Server that hosts the corporate inventory database, which includes centralized hardware and software inventory information on all your networked computers.

  • Primary SMS servers for sharing the load of distribution to the logon servers. These are located so that the majority of network traffic generated by SMS is on local segments.

  • Local area network (LAN) servers such as Windows NT and Windows 2000 domain controllers, file and print servers, and application servers.

  • Clients such as Windows NT, Windows 2000, Windows 98, or Windows 95.

Software is distributed down the hierarchy, while inventory information is passed up the hierarchy. At each SMS site, inventory information is collected and forwarded to the site above it. Thus, the SMS database at the top site has complete inventory information for the entire network. From this top site, you can use the Systems Management Server Administrator program to query and view the inventory database for hardware, software, and configuration information about any computer on your network. Queries can be specific—for example, you can determine which computers in your network have Pentium processors or which systems have Office installed.

You can also use SMS to distribute and install software on clients and servers on your network, and you can schedule software distribution to minimize the impact on your system. The Systems Management Server Administrator program can

  • Send software from one site to another.

  • Move software to selected servers called distribution servers. Users can then access and install the software on their clients from these servers.

  • Set up and configure network applications on servers for shared use by groups of users. SMS automatically creates a program item for the network application on users’ computers.

  • Install and configure software on clients and servers.

The following are additional features of SMS 2 that make it easy to use:

  • Integrated setup with SQL Server

  • Enhanced administration using wizards, taskpads, and Microsoft Management Console (MMC)

  • Context-sensitive HTML-based help

  • A nonintrusive 32-bit agent client that is invisible to the user except when distribution packages are available

  • A status system that provides a common reporting mechanism for all components

  • Support for the Common Information Model (CIM) specification

  • Dynamic, discovery-based software inventory mechanisms

  • The Network Topology Tracing Tool, which provides a graphical display of the network routes between servers within a site, including infrastructure devices such as routers and hubs

  • Dynamic distribution lists for sending software to users automatically when they join a group

On the Web
•
Microsoft Systems Management Server
: http://www.microsoft.com/smsmgmt

Microsoft TechNet

An information resource program developed by Microsoft for IT professionals who work with Microsoft products. Microsoft TechNet is important to those who plan, deploy, maintain, support, and evaluate Microsoft business products, such as Microsoft Windows 2000 and members of the Microsoft BackOffice suite.

Graphic M-12. Microsoft TechNet.
Graphic M-12. Microsoft TechNet.
How It Works

The TechNet program includes a monthly CD subscription, a Web site, an electronic newsletter, regular technical briefings at locations around the world, and special offers. Each month a collection of CDs updates your TechNet binder to ensure that you have the latest and most accurate information on all Microsoft products and services. The subscription includes four categories of CDs:

  • Monthly issues of up-to-date technical information, which include the Technical Information, Supplementary Drivers and Patches, and full Microsoft Knowledge Base CDs. The Technical Information CD includes a large collection of manuals, resource kits, and other documentation on current versions of Microsoft products; you can either browse or search this CD to find the information you need. The Knowledge Base CD is a collection of thousands of articles written by Microsoft support professionals that answer technical questions, provide detailed how-to information, resolve bugs, list fixes, and document changes and corrections to Microsoft products.

  • The Server Utilities, Client Utilities, and Software Library Archive CDs, as well as CDs that contain utilities from various Microsoft product resource kits.

  • Service Pack CDs for all Microsoft products for which service packs are available. These service packs provide cumulative fixes and patches for bugs and known problems with Microsoft products, and can include additional enhancements to the original product version.

  • Extras, such as CDs for Microsoft Seminars Online and time-limited evaluation versions of Microsoft software.

An enhanced version of TechNet, called TechNet Plus, includes beta evaluation software for various upcoming Microsoft products.

On the Web
•
Microsoft TechNet home page
: http://www.microsoft.com/technet

Microsoft Transaction Server (MTS)

Software included in the Microsoft Windows NT Option Pack and Windows NT Server, Enterprise Edition, that provides a variety of services for component-based applications, including transaction support, security, and thread pooling. In Windows 2000 Server, this component has been merged with the Component Object Model (COM) to form COM+, and the resulting Windows 2000 services are known by the name Component Services.

How It Works

Microsoft Transaction Server (or Component Services in Windows 2000) defines a transactional programming model and supplies a run-time environment and graphical user interface (GUI) administration tool for managing transactional applications. It provides automatic support for transactions, thread management, database connection pooling, process isolation, and other features that are essential for developing multiuser applications. Portions of a distributed application running on different computers and coordinated using MTS can communicate with each other as though they were installed on a single computer.

MTS includes the following features:

  • Configurable security. Administrators can define roles and then specify the components and interfaces that clients belonging to each role can access.

  • Support for Microsoft SQL Server, Oracle, and DB2 databases as well as for resource managers such as Microsoft Message Queue (MSMQ) Server in Windows NT (or Message Queuing in Windows 2000).

  • Database connection pooling. You can reuse existing database connections instead of creating new ones, thereby improving performance and scalability.

  • Process isolation. You can separate applications into packages that each run in their own process, making applications more fault tolerant and secure against failures.

  • COM Transaction Integrator for initiating and controlling Custom Information Control System (CICS) transactions on IBM mainframe computers.

  • Support for a broad range of development tools, including Microsoft Visual C++ and Microsoft Visual Basic.

  • Component state management, which makes it easier to build applications with efficient resource sharing.

Microsoft Windows

A family of operating systems with a common graphical user interface (GUI) that lies at the core of Microsoft’s strategy to make PCs easier to use, reduce the cost of PC ownership, advance the PC platform, and integrate PCs with the Internet.

Microsoft Windows operating systems originally derived from MS-DOS, Microsoft’s watershed disk operating system for personal computers. The early 16-bit versions of Windows, Windows 3.1 and Windows for Workgroups, evolved into the 32-bit desktop operating system Windows 95, which was later upgraded to Windows 98. Meanwhile, a separate, fully 32-bit line-of-business operating system called Windows NT Advanced Server evolved into Windows NT version 3.51, which was further enhanced with additional services and a shell upgrade in Windows NT 4. These separate Windows NT and Windows 98 platforms will eventually be merged into the Windows 2000 family, which includes versions for all levels of users, from enterprise-level mission-critical servers to personal desktop computers.

Another evolutionary path has recently brought forth Windows CE, a low-footprint operating system for palm-sized PCs and embedded systems.

All versions of Windows are now fully integrated with the Internet through the Microsoft Internet Explorer suite of Internet tools and utilities. The following table lists these versions. For more information about each version of Windows, see its entry in Chapter W.

Microsoft Windows Operating Systems
Operating System | Description
Windows 98 | The easiest desktop operating system
Windows NT Workstation 4 | Powerful desktop operating system for business computing
Windows NT Server 4 with Windows NT Option Pack | Enterprise-level operating system for network communications, data, applications, and management
Windows NT Server 4, Enterprise Edition | Extends the scalability, availability, and manageability of Windows NT Server 4 with clustering and other enhancements
Windows NT Server 4, Terminal Server Edition | Delivers the Windows NT desktop to diverse platforms using terminal emulation for centralized management and lower cost
Windows 2000 Professional | The next generation of the Windows NT Workstation operating system
Windows 2000 Server, Standard Edition | The next generation of Windows NT Server, including Active Directory for enterprise-level networking
Windows 2000 Advanced Server | The next generation of Windows NT Server 4, Enterprise Edition
Windows 2000 Datacenter Server | For the highest level of enterprise server operations, with up to 32-way symmetric multiprocessing (SMP) and 64 GB of physical memory
Windows CE | A portable operating system for small mobile computing devices such as handheld PCs, “wallet” PCs, wireless communication devices, and Web TVs
On the Web
•
Microsoft Windows home page
: http://www.microsoft.com/windows

Microsoft Windows Distributed interNet Applications (DNA) Architecture

Also called Windows DNA Architecture, an application development model from Microsoft for highly adaptable business solutions that use Microsoft’s digital nervous system paradigm. The Windows DNA framework includes support for client/server PC-based computing and Web services for building a new class of distributed computing solutions for the Windows platform. It leverages the integrated services of the Windows platform and the Component Object Model (COM).

How It Works

Windows DNA services are exposed in a uniform way through COM for use by distributed applications and include these core elements:

  • Presentation services:
    Include support for Dynamic HTML (DHTML), Hypertext Markup Language (HTML), scripting, components, and the Win32 application programming interface (API)

  • Application services:
    Include Internet Information Services (IIS), message queuing services, transaction services, and COM+

  • Data services:
    Include ActiveX Data Objects (ADO) and OLE DB

  • System services:
    Include services for security, management, directory, networking, and communication

To use Windows DNA, simply follow this process:

  1. Separate your application into three logical tiers—presentation, business logic, and data.

  2. Select the Windows components and technologies for your presentation level that provide your client with a suitable interface.

  3. Write COM components to implement your business logic using the application services of Windows 2000 or Windows NT.

  4. Use ADO to access data, and use OLE DB to expose data for your third tier.

Windows DNA is a comprehensive integrated development platform that makes development of distributed applications using a language-independent process faster and easier. It is interoperable with existing enterprise applications and legacy systems.

MIF

See
Management Information Format (MIF)

MIF Form Generator

See
Systems Management Server MIF Form Generator

Migration Wizard

A tool in Microsoft Exchange Server for migrating mail users from other mail systems to Exchange.

How It Works

The Migration Wizard uses source extractors to extract directory information and messages from the system to be migrated from, and formats the information as a set of migration files. You can then import these files to the Exchange server. The wizard includes built-in source extractors for the following:

  • Microsoft Mail for PC Networks

  • Lotus cc:Mail

  • Novell GroupWise

  • Netscape Collabra

You can obtain source extractors for other mail systems from their vendors or have them custom built. You can carry out migration in a single stage if you have all the associated connectors and gateways installed on your Exchange server, or you can do it in two stages if you do not have sufficient administrative resources to perform the entire migration at once.

Graphic M-13. Migration Wizard.
Graphic M-13. Migration Wizard.

MIME

See
Multipurpose Internet Mail Extensions (MIME)

mirrored volume

In Microsoft Windows 2000, a volume created with the Disk Management tool that duplicates its data on two physical disks to provide fault tolerance—if one physical disk fails, the system continues to operate using the second disk. Mirrored volumes perform read operations more slowly than RAID-5 volumes but execute write operations more quickly. You cannot extend mirrored volumes, and you must create them on dynamic disks.

NOTE

The Windows NT equivalent of a mirrored volume is called a mirror set.

See also
dynamic volume

mirror set

A fault tolerance technology, also known as RAID 1, whereby data is written simultaneously to two disks, making one disk drive a mirror image of the other. This duplication of all disk information provides data redundancy—if one half of a mirror set fails, the system can continue to operate using the duplicate of the failed disk. Mirror sets are slower than stripe sets with parity for read operations but are faster for write operations.

Mirror sets are often used to provide fault tolerance for the Microsoft Windows NT system partition and boot partition. You can use the Windows NT administrative tool Disk Administrator to create, break, and reestablish mirror sets. In Windows 2000, the corresponding administrative tool is called Disk Management.

See also
RAID

mixed mode

A domain mode for running Microsoft Windows 2000 domain controllers that is backward compatible with domain controllers running the earlier Windows NT operating system. Domain controllers running in mixed mode use the Windows NT LAN Manager (NTLM) authentication protocol, allowing Windows 2000 Active Directory to work with downlevel Windows NT domain controllers.

Mixed mode has the following characteristics:

  • While updates to Windows NT domain controllers must be made at the primary domain controller (PDC), updates to Windows 2000 domain controllers can be made at any Windows 2000 domain controller.

  • Multimaster replication does not function between uplevel and downlevel domain controllers—downlevel Windows NT domain controllers replicate updates from the PDC to the backup domain controllers (BDCs) in the usual way.

  • You cannot nest groups as you can in a pure Windows 2000–based network. You can only add global groups to domain local groups with one level of nesting.

  • You cannot use universal groups.

If you have a pure Windows 2000–based network, you should configure your domain controllers to run in native mode. A domain running in native mode supports multimaster replication and nested groups.

TIP

Windows 2000 domain controllers install in mixed mode by default when you run the Active Directory Installation Wizard. You can use the administrative tool Active Directory Users and Computers to change your domain controllers from mixed mode to native mode. However, you cannot change domain controllers back to mixed mode. After you upgrade all your downlevel domain controllers to Windows 2000, change all domain controllers to native mode in order to take advantage of multimaster replication, nesting of groups, and universal groups in Windows 2000.

See also
domain modes

MLP

See
Multilink Point-to-Point Protocol (MPPP)

MMC

See
Microsoft Management Console (MMC)

MMC console

A file that contains customized configuration information for Microsoft Management Console (MMC) and can be used to start MMC with a specific set of snap-ins and a specific console tree. MMC consoles have the extension .msc and are saved in the My Administrative Tools folder on a machine running Microsoft Windows 2000. You create a custom MMC console (or simply console) by adding snap-ins to a blank MMC console. You can do this for several reasons:

  • To save a specific console for a specific administrative task. An administrator can thus create a custom administrative tool that is not cluttered with unnecessary functionality and provides just enough functionality to perform the task at hand.

  • To create a console for unifying a set of administrative tasks. An administrator can thus create a single console with which all common administrative tasks can be performed instead of switching between different tools for different tasks.

  • To distribute the console to junior administrators in read-only form.

How It Works

As administrator, you choose Run from the Start menu, type mmc.exe , and click OK. This opens a blank console window. Add snap-ins to this empty window to create your custom console. Then save the console in your My Administrative Tools folder. Note that each user on a computer running Windows 2000 has a separate My Administrative Tools folder for storing custom console files.

Graphic M-14. MMC console.
Graphic M-14. MMC console.
NOTE

Windows 2000 includes a number of preconfigured MMC consoles (also known as administrative tools) for performing specific administrative tasks. You access these using the Administrative Tools shortcut in the Programs group of the Start menu.

M-node

A NetBIOS name resolution method used for name registration and resolution. M-node is one of the types of NetBIOS over TCP/IP nodes defined in Request for Comments (RFC) numbers 1001 and 1002, and is supported by computers running Microsoft Windows NT.

How It Works

Name resolution is the process of converting the name of a host on the network into a network address (such as an IP address). Name resolution must be performed in order to establish communication over a network. M-node is one of four basic methods supported by Windows NT for resolving NetBIOS host names (that is, computer names) into IP addresses.

If a computer running Windows NT is configured as an M-node machine, it first tries to use broadcasts to resolve the names of the hosts, similar to a B-node machine. If name resolution fails this way (for example, if broadcasts are stopped by routers from reaching computers on other subnets), Windows NT tries to use a NetBIOS name server to resolve names of other hosts on the network, similar to a P-node machine. A Windows NT server with the Windows Internet Naming Service (WINS) configured on it is a typical example of a NetBIOS name server. The “M” in the term “M-node” stands for “mixed,” as M-node is a mixture of B-node and P-node, in that order.

See also
B-node, H-node, NetBIOS name resolution, P-node

Mobile Broadband System (MBS)

A proposed standard from the International Telecommunication Union (ITU) for a fourth-generation mobile wireless communication system. The Mobile Broadband System (MBS) is a project of the Research and Technology Development in Advanced Communications Technologies in Europe (RACE) program. It extends mobile telecommunications to include broadband communication and offers multimegabit data transmission rates of up to 155 Mbps for wireless transmission of multimedia video and audio content. The technology underlying MBS is Asynchronous Transfer Mode (ATM) networking; the standard will fully integrate MBS with the ATM-based Integrated Broadband Communications Network (IBCN) proposed for Europe. MBS is a wireless extension to broadband ISDN (B-ISDN) communication, which is still in the developmental stage.

MOC

See
Microsoft Official Curriculum (MOC)

modem

Generally, any type of data communications equipment (DCE) that enables digital data transmission over the analog Public Switched Telephone Network (PSTN). The term “modem” (which actually stands for “modulator/demodulator”) is usually reserved for analog modems, which interface, through a serial transmission connection such as the RS-232 interface, with data terminal equipment (DTE) such as computers. The modem converts the digital signal coming from the computer into an analog signal that can be carried over a Plain Old Telephone Service (POTS) line. The term “digital modem” is sometimes used for ISDN terminal adapters, but this is something of a misnomer because no signal modulation actually takes place.

Modems were developed in the 1960s by Bell Labs, which developed a series of standards called the Bell Standards. These standards defined modem technologies of up to a 9600-bps transmission speed. The Bell Standards have been superseded by the V series standards from the International Telecommunication Union (ITU), which defines standards of up to V.90 (which supports 56-Kbps downloads and 33.6-Kbps uploads).

Modems generally have two interfaces:

  • An RS-232 serial transmission interface for connecting to the DTE, usually the computer

  • An RJ-11 telephone interface for connecting to the 4-wire PSTN telephone outlet in the local loop connection

Modem types include the following:

  • Internal modems, which are installed as interface cards inside the computer and might use some of the machine’s CPU processing power for functions such as encoding and data compression.

  • External modems, which are generally more expensive and connect to the serial port on the computer using a DB9 or DB25 connector. External modems are useful when several users need to share a modem.

  • PCMCIA modems, which are credit-card-sized modems for laptop computers used by mobile workers.

  • Voice/data/fax modems, which can be used for file transfer, sending and receiving faxes, and voice mail using associated software.

See also
analog modem, digital modem, V series

modem eliminator

A device for connecting two pieces of data terminal equipment (DTE) without modems by providing timing signals and handshaking for synchronous transmission.

How It Works

Modem eliminators provide an easy way to connect two pieces of DTE without a modem. They simulate a synchronous transmission data link by generating a clocking signal. Modem eliminators provide speeds of up to 2.048 Mbps and use RS-232, RS-422/485, RS-530, V.25, or X.21 cabling.

Graphic M-15. Modem eliminator.
Graphic M-15. Modem eliminator.

Modem eliminators are similar to line drivers, but modem eliminators simply connect two pieces of DTE, while line drivers connect DTE to data communications equipment (DCE). Also, line drivers regenerate signals and thus extend the maximum possible distance, while modem eliminators do not. Finally, line drivers are used in pairs (one at each end of the line), and modem eliminators are used singly and are placed at the midpoint between the two devices being connected.

modulation

The process by which information is encoded into electrical signals for transmission over a medium. Binary information, as represented by a series of 1s and 0s, must be converted to analog or digital electrical signals for transmission. For analog transmission over voice-grade Public Switched Telephone Network (PSTN) lines, this process is usually called “modulation,” and for transmission over digital lines, the term “line coding” is often used instead.

Modulation forms the basis of the digital-to-analog converter (DAC) component of an analog modem. Modulation in modems allows digital binary information to be received from a serial interface on a computer and modulated for transmission over the voice-grade PSTN telephone network.

Graphic M-16. Different types of modulation.
Graphic M-16. Different types of modulation.

Three types of signal modulation for analog signals can be used:

  • Amplitude modulation (AM):
    Carries information by modulating the amplitude (voltage) of the carrier signal. Different amplitudes represent different information values. For example, an amplitude of 3 volts might represent a 1, while an amplitude of 1 volt represents a 0.

  • Frequency modulation (FM):
    Carries information by modulating the frequency of the carrier signal. Different frequencies represent different information values. For example, a frequency of f might represent a 1, while a frequency of 2f represents a 0. A common frequency modulation scheme in modem technologies is called frequency-shift keying (FSK), in which four frequencies within the PSTN 3-KHz line bandwidth are used for transmission and reception of binary data, as shown in the following table.

Frequencies Used in FSK Modulation
FSK Frequency | Meaning
1070 Hz | Transmitted binary 1
1270 Hz | Transmitted binary 0
2025 Hz | Received binary 0
2225 Hz | Received binary 1

  • Phase modulation (PM):
    Carries information by modulating the phase of the carrier signal. Different phases represent different information values. For example, a phase of 0° might represent a 1, while a phase of 180° represents a 0. A common implementation of phase modulation in modem technologies is called differential phase-shift keying (DPSK), in which relative phase changes instead of absolute phase values are used to represent encoded binary information. Quadrature amplitude modulation (QAM) allows the encoding of pairs of binary values as different phase values, as shown in the following table.

QAM Encoding of Binary Value Pairs
QAM Phase Value | Binary Information Represented
45° phase shift | 11
135° phase shift | 10
225° phase shift | 01
315° phase shift | 00

For modulation (line coding) over digital transmission lines, you can use various techniques, depending on the networking technology. For example,

  • Manchester coding is the standard line coding technique used for standard Ethernet networks.

  • Carrierless amplitude and phase (CAP) modulation is an older Digital Subscriber Line (DSL) line coding technology. CAP has been largely replaced by discrete multitone (DMT) modulation, which is endorsed for Asymmetric Digital Subscriber Line (ADSL) use by the American National Standards Institute (ANSI) and for DSL-Lite by the International Telecommunication Union (ITU), and includes error-correction functions that CAP does not. A newer variant is discrete wavelet multitone (DWMT) modulation, which is used for Very High-Rate Digital Subscriber Line (VDSL) implementations.

MOLP

See
Microsoft Open License Program (MOLP)

MOUS

See
Microsoft Office User Specialist (MOUS)

moving files

Changing the location of a file on a hard disk or a distributed storage system. On NTFS volumes located on machines running Microsoft Windows NT or Windows 2000, the effect of moving a file depends on whether the file is moved within a volume or to a different volume:

  • If you move a file within an NTFS volume, it retains its original permissions.

  • If you move a file between volumes, it inherits the permissions of the folder it is moved to.

NOTE

If you move an object within Active Directory on a Windows 2000–based network, the object loses any permissions that were assigned to the organizational unit (OU) in which it resided and inherits the permissions assigned to the OU to which it is moved. Also, any permissions that were explicitly assigned to the object remain in effect after the object is moved. For example, you might move an object in Active Directory if a user has changed departments and you have to move the user object from the Sales OU to the Marketing OU. Use the Active Directory Users and Computers snap-in for Microsoft Management Console (MMC) to move objects in Active Directory.

See also
copying files

MP

See
Multilink Point-to-Point Protocol (MPPP)

MPLS

See
Multiprotocol Label Switching (MPLS)

MPPP

See
Multilink Point-to-Point Protocol (MPPP)

MPR

See
multiple provider router (MPR)

MQIS

See
MSMQ Information Store (MQIS)

MSAU

See
Multistation Access Unit (MAU)

MS-CHAP

See
Microsoft Challenge Handshake Authentication Protocol (MS-CHAP)

MSCS

See
Microsoft Cluster Server (MSCS)

MSDA

See
Microsoft Direct Access (MSDA)

MSDN

See
Microsoft Developer Network (MSDN)

MS-DOS

Stands for Microsoft Disk Operating System, the venerable operating system created by Microsoft for the first IBM personal computer in 1981. MS-DOS evolved through a number of versions until its final release in 1994 as MS-DOS 6.22. The following table highlights the evolution of MS-DOS over the years.

Graphic M-17. Example of running an MS-DOS command.
Graphic M-17. Example of running an MS-DOS command.
Versions of MS-DOS
Version | Release Date | Features
1.0 | August 1981 | Designed for the IBM PC, the initial version was distributed on a single 160-KB floppy disk and ran in 8 KB of RAM.
1.1 | May 1982 | Support was added for double-sided 320-KB disks.
2.0 | March 1983 | Designed for the IBM PC/XT, this version added support for hard disks, hierarchical directories, background printing, and third-party device drivers.
2.1 | October 1983 | Designed for the short-lived IBM PCjr.
3.0 | August 1984 | Designed for the new IBM PC/AT, this version added support for 1.2-MB floppy disks and hard drives larger than 10 MB.
3.1 | March 1985 | Added support for networking and file sharing.
3.2 | January 1986 | Added support for the new 3.5-inch floppy disks.
3.3 | April 1987 | Designed for the IBM PS/2, this version added commands and support for international versions.
4.01 | February 1988 | This version added the mem command, the MS-DOS shell, and support for hard drives larger than 32 MB.
5.0 | May 1991 | For this version, the MS-DOS shell was redesigned, task-swapping was added, and more extensive help, undelete, unformat, and memory-management tools were added.
6.0 | March 1993 | Added the MemMaker utility, real-time disk compression, multiple boot configurations, and antivirus and backup utilities.
6.2 | October 1993 | Added Scandisk for low-level disk checking.
6.22 | February 1994 | Added DriveSpace disk compression.
How It Works

MS-DOS is a 16-bit operating system that runs a command-line interface. MS-DOS commands come in two types:

  • Built-in commands:
    Embedded in the MS-DOS command interpreter command.com. Examples include dir, copy, and date.

  • External commands:
    MS-DOS utilities that reside as separate files. Examples include doskey, edit, and smartdrv.

The core operating system consists of three primary files in the root of the system partition:

  • io.sys:
    Controls the boot process and contains basic I/O drivers.

  • msdos.sys:
    Operating system kernel. Applications request operating system services through msdos.sys, which translates them into actions that can be performed by io.sys and device drivers.

  • command.com:
    Command interpreter, which provides a user interface for executing MS-DOS commands.

In addition, two text files help control the boot process:

  • config.sys:
    Contains commands that configure hardware components such as memory, keyboard, mouse, and printer

  • autoexec.bat:
    Contains startup commands that configure your prompt and path and run memory-resident programs such as doskey and smartdrv

The remaining external MS-DOS commands and utilities are by default found in the directory C:\DOS.

NOTE

MS-DOS was so popular in the PC market that other vendors produced their own versions, including IBM’s PC-DOS and Novell’s DR-DOS.

You can add networking functionality to MS-DOS by using the Microsoft Network Client 3.0 for MS-DOS add-on. You can create installation disks for this software using the Network Client Administrator tool in Microsoft Windows NT.

MS-DOS mode

A mode of running Microsoft Windows 95 and Windows 98 in which MS-DOS-based applications can access hardware directly. You can use MS-DOS mode when you have to run stubborn MS-DOS programs that will not run in an MS-DOS window within Windows 95 or Windows 98.

How It Works

To switch to MS-DOS mode from Windows, choose Shutdown from the Start menu, and then choose Restart In MS-DOS Mode. The Windows graphical user interface (GUI) vanishes, leaving only an MS-DOS prompt, which allows you to run a single MS-DOS-based application. A stub of the Windows operating system remains in memory and restores the Windows GUI when you type exit at the MS-DOS prompt.

MS-DOS prompt

See
command prompt

MSMQ

See
Microsoft Message Queue (MSMQ) Server

MSMQ Enterprise

All computers in an organization that run Microsoft Message Queue (MSMQ) Server and access information from the same distributed database (the MSMQ Information Store). For security reasons, organizations should not install more than one Enterprise, although messaging between multiple MSMQ Enterprises is possible.

MSMQ Information Store (MQIS)

A distributed database for Microsoft Message Queue (MSMQ) Server that contains information about enterprise topology, enterprise settings, computer information, and queue information. MSMQ applications can query the MSMQ Information Store (MQIS) to locate queues and obtain queue properties. Copies of the MQIS are distributed among MSMQ computers in an enterprise.

NOTE

In Microsoft Windows 2000, this functionality has been moved to Active Directory.

MSMQ Routing Server

A server running Microsoft Message Queue (MSMQ) Server that supports dynamic routing and intermediate store-and-forward message queuing. MSMQ Routing Servers enable computers using different network protocols to communicate. MSMQ Routing Servers do not contain copies of the primary site controller (PSC) or primary enterprise controller (PEC) database. Before you can install any MSMQ Routing Servers in your network, you must first install a PEC.

TIP

Since every PEC, PSC, and backup site controller (BSC) functions as an MSMQ Routing Server, the number of additional MSMQ Routing Servers you need depends on your MSMQ connectivity needs, namely

  • The number of dependent and independent clients

  • The number of MSMQ sites

  • The number of connected networks (CNs)

  • The overall MSMQ message volume

Be sure to install enough MSMQ Routing Servers so that messages can reach their target queues through different servers.

MSMQ site

In Microsoft Message Queue (MSMQ) Server, a collection of computers between which communication is fast and inexpensive. MSMQ site boundaries usually follow the physical location of the computers, such as all computers within a given building. Computers in an MSMQ site need not run the same network protocol and might not be able to communicate with each other directly.

MSMQ sites are connected to other sites through site links. MSMQ messages are routed through these site links based on cost values assigned to them by administrators.

MTA

See
Message Transfer Agent (MTA)

mtacheck

A command-line troubleshooting utility included with Microsoft Exchange Server. You can use mtacheck to check data stored by the Message Transfer Agent (MTA) in data (.dat) files. These data files are related to problems with connectors that involve unprocessed messages. If mtacheck finds any problems, it tries to fix them. In a typical scenario, when an object in the MTA is damaged and blocks the messaging queue, mtacheck finds the object and removes it, placing it in a file so that you can examine it later. You can also use mtacheck to try to restart the MTA if it stops and you can’t start it using the Services utility in Control Panel.

MTS

See
Microsoft Transaction Server (MTS)

multicast DHCP (MDHCP)

An extension to the Dynamic Host Configuration Protocol (DHCP) supported by Microsoft Windows 2000 that offers dynamic assignment and configuration of Internet Protocol (IP) multicast addresses on TCP/IP networks. Multicast DHCP (MDHCP) extensions to DHCP are described in Request for Comments (RFC) 2131, which obsoletes the earlier RFC 1541.

How It Works

You normally configure DHCP servers by creating scopes. A scope contains a range of IP addresses chosen from class A, B, and C of the IP addressing scheme. These addresses are then assigned to a client who requests an IP address lease. Each client that requests an IP address from the DHCP server is assigned a unique IP address belonging to class A, B, or C.

MDHCP allows Windows 2000 DHCP servers to include class D multicast IP addresses in separate DHCP scopes. These addresses range from 224.0.0.0 through 239.255.255.255. Some class D addresses are permanently reserved for specific multicast groups, while others can be assigned as desired. MDHCP dynamically assigns these available class D addresses to clients who want to temporarily join a multicast group in order to receive a multicast transmission. The clients must support MDHCP in order to request and receive multicast addresses from the MDHCP service. Client machines running Windows 2000 support MDHCP.

MDHCP operates separately from DHCP, and a client that has an IP address from a DHCP server (or has a static IP address that has been manually assigned to it) can request from the MDHCP service an additional multicast address so that it can receive a multicast transmission over the network. A client can lease only one unicast address, but it can request and obtain multiple multicast addresses and belong to multiple multicast groups simultaneously.

NOTE

If a client does not support MDHCP, it cannot request addresses from the MDHCP service. But it can run other applications (such as Microsoft NetMeeting) in order to receive multicast transmissions over a network.

multicasting

A technique in which a single copy of data is sent over a network to a specific group of computers. Multicasting is connectionless—clients receive multicast transmissions by “tuning in” to them, a process similar to tuning in to a radio station. Multicasting is essentially a point-to-multipoint communication mechanism.

Microsoft NetShow is an example of an application that uses multicasting technology to transmit streaming audio and video over the Internet and corporate intranets. Multicasting is unidirectional communication between a NetShow server and a NetShow client.

How It Works

NetShow multicasts require two pieces of information:

  • A destination IP address and port number indicating the IP address and port to which the client should “listen” for multicasts

  • Multicast scope, which determines how widely the multicast is distributed over the network

The method used to inform the client of the destination IP address and port depends on the kind of stream being multicast. The types of streams are as follows:

  • Advanced Streaming Format (ASF):
    The destination IP address and port are specified when a channel is created using the NetShow Administrator program. An announcement tells the client how to locate the channel. The channel contains information about which IP address and port the client should listen to, the format of each stream, and the streaming information itself.

  • Real-Time Protocol (RTP) live audio streams, WAV audio streams, and streaming file transfers:
    Information about the destination IP address and port is specified for each stream in the program when you create a program using NetShow Administrator. To receive these multicasts, this information must match the IP address and port specified using the control on the client’s Web page. All the information a client needs to receive the multicast is provided when you include the audio or file transfer client OLE custom control (OCX) on a Web page.

Multicast IP addresses are class D addresses and fall in the range 224.0.0.0 through 239.255.255.255. For intranet use, addresses in the range 239.*.*.* are recommended. Port numbers can range from 1 through 65535, although ports below 1024 are reserved, as are some ports above 1024. Port numbers for RTP audio should be even numbers in the range 16384 through 32768.

In NetShow you set multicast scopes by specifying a Time to Live (TTL) value, which decrements each time packets pass through a router. NetShow default scope values are as follows:

  • Local network = 1

  • Intranet = 32

  • Internet = 128

These values can be customized to meet the needs of your network.

multihoming

The technique of using multiple network interface cards (NICs) in a single server or configuring a single NIC with multiple IP addresses. On a TCP/IP network, a multihomed machine has a separate IP address assigned to each of its interfaces. Multihoming is typically used to increase bandwidth by providing connectivity to several networks simultaneously.

Multihoming is also used when a computer is connected to both a direct local area network (LAN) connection and the Internet using a dial-up networking connection. Another use of multihoming is to allow a privileged station to connect to both a low-security LAN and a restricted high-security LAN. These kinds of multihoming are supported by Microsoft Windows 98, Windows NT, and Windows 2000.

Another use for multihoming is when a machine running Windows NT Server or Windows 2000 Server is used as a router. By installing two or more NICs in a single machine running Windows NT Server or Windows 2000 Server and enabling Routing Information Protocol (RIP) on the machine, you can have the server function as a dynamic router that can exchange routing table information with other RIP-enabled routers. Or, if you do not enable RIP on the server, it can function as a static router, in which case you would manually configure the server’s routing table from the command prompt using the route command.

Graphic M-18. A multihomed server.
Graphic M-18. A multihomed server.

Multilink Point-to-Point Protocol (MPPP)

A protocol for inverse multiplexing of Point-to-Point Protocol (PPP) communication links. Multilink Point-to-Point Protocol (MPPP) is an extension of the industry-standard PPP. MPPP can also be abbreviated as MP or MLP.

How It Works

An ordinary dial-up modem connection to the Internet through an Internet service provider (ISP) usually uses PPP as its wide area network (WAN) data-link protocol, but sometimes the 56-Kbps speed provided by V.90 modems is insufficient. MPPP allows multiple physical dial-up links to be inverse multiplexed together to form a single high-bandwidth logical PPP connection between the dial-up client and the ISP. MPPP works by ordering the data frames from the client across the multiple PPP channels and recombining them at the ISP’s termination point, and vice versa. MPPP defines protocols for splitting the data stream into PPP packets, sequencing the packets, transmitting them over separate logical data links, and then recombining them at the receiving station.

MPPP is also supported by some ISDN terminal adapters to allow two 64-Kbps Integrated Services Digital Network (ISDN) channels to be inverse multiplexed together into a single 128-Kbps channel using the bonding protocol.

More channels can be aggregated for even greater bandwidth. Microsoft Windows 98 supports MPPP for both analog modems and ISDN terminal adapters.

In the Remote Access Service (RAS) of Windows NT, MPPP is known as RAS Multilink Channel Aggregation and supports the aggregation of two or more analog modems or ISDN terminal adapters (or a combination of both). RAS Multilink Channel Aggregation was originally based on Request for Comments (RFC) 1717 and is supported by Windows NT Server and Windows NT Workstation, although it is only supported for dial-out connections on Windows NT Workstation. Multilink in the Windows 2000 Routing and Remote Access feature supports RFC 1990, which obsoletes RFC 1717.

Graphic M-19. Multilink Point-to-Point Protocol (MPPP).
Graphic M-19. Multilink Point-to-Point Protocol (MPPP).
NOTE

An extension to MPPP called Multichassis Multilink Point-to-Point Protocol (MMP), which some vendors support, allows MPPP connections to be aggregated across multiple routers and network access servers (NAS’s) in a way that is transparent to the dial-up MPPP client. In other words, the client initiates an MPPP session but is actually connected to several MMP-enabled NAS’s at the ISP instead of only one NAS as in the usual scenario. MMP enables the data stream to be split, sequenced, and recombined at several different points to provide a single logical connection between the client and the ISP.

Another extension to MPPP that some vendors support is called Multichannel PPP (MPP), which in addition to inverse multiplexing of PPP links also supports session and bandwidth management functions, including the dynamic addition or removal of channels without the need to reinitialize the link. Both the client and the server must support MPP for this to work.

TIP

To use MPPP for a dial-up connection to the Internet, your ISP’s NAS must also support this protocol. RAS Multilink Channel Aggregation for Windows 98 or Windows NT functions best if all devices are of the same type (analog or ISDN) and operate at the same speed. When a Windows dial-up client attempts a multilink connection, it first establishes the primary connection using the first installed device, and then it successively aggregates each additional device.

multimaster replication

The method by which information stored in Active Directory in Microsoft Windows 2000 is replicated between domain controllers. Windows 2000 uses multimaster replication for replicating updates made to Active Directory on one domain controller to all other domain controllers in a domain. Multimaster means that all domain controllers are “master” domain controllers—in other words, they are all peers as far as the replication process is concerned. This is different from the master/slave replication of the Security Account Manager (SAM) database between domain controllers on a Windows NT–based network, in which only the primary domain controller (PDC) has a writable copy of the SAM database, while the backup domain controllers (BDCs) have read-only copies of the database. In Windows 2000, the Active Directory directory service on every domain controller is writable, and you can make changes to Active Directory at any domain controller on the network. Once you make these changes, multimaster replication ensures that Active Directory on all other domain controllers is updated accordingly.

The advantages of the multimaster replication method supported by Windows 2000 over the PDC/BDC master/slave replication method of Windows NT include the following:

  • You can make updates to Active Directory as long as any domain controller is functioning on the network.

  • When domain controllers are distributed at all sites, you can make updates to Active Directory anywhere on the network with a local domain controller, even when wide area network (WAN) links to other sites are down.

NOTE

If an object in Active Directory has the same attribute modified almost simultaneously on two different domain controllers, a collision is said to have occurred. Collisions are resolved using timestamps as a tie-breaking mechanism.

See also
Active Directory

multimode fiber-optic cabling

A type of fiber-optic cabling that allows multiple signals to be transmitted simultaneously. Line drivers for multimode fiber-optic cabling use light-emitting diodes (LEDs) to generate the light signals that carry the data down the fiber.

How It Works

Multimode fiber, which has a glass core whose index of refraction varies with the distance from the core axis, is implemented in two main forms:

  • Step-index multimode fiber:
    The light rays reflect off the walls of the core by total internal reflection. Depending on the angle at which the rays are incident on the surface of the core, different light paths are created that can carry additional signal bandwidth. In longer cables, these paths can get out of step with each other at the far end of the fiber and degrade signal quality.

  • Graded-index multimode fiber:
    The core consists of concentric layers of material. Each successive layer has a lower index of refraction than the one that it envelops. As a result, rays of light travel along curved paths and all arrive in step with each other at the far end of the fiber.

Multimode fiber is available with different core diameters, typically 50, 62.5, and 100 microns. Multimode fiber can carry more bandwidth than single-mode fiber, but single-mode fiber can carry signals up to 50 times farther than multimode.

Multimode fiber is not recommended for long cable runs and should generally be restricted to runs of 914 meters. If this limit is exceeded, the light traveling along different paths through the fiber can produce a condition called modal dispersion, which results in parts of the signal arriving at unexpected times at the end station. This can degrade the quality of the signal or cause it to be unrecognizable.

Graphic M-20. Multimode fiber-optic cabling.
Graphic M-20. Multimode fiber-optic cabling.
TIP

Step-index fiber is cheaper than graded-index fiber and should be used only for shorter cable runs or where less bandwidth is required.

See also
fiber-optic cabling

multiple master domain model

A Microsoft Windows NT domain model in which all global users and group accounts reside in several account domains that trust one another with two-way trusts. Network resources reside in multiple resource domains that trust every account domain.

The advantages of the multiple master domain model are that it is scalable to any number of user accounts and that resource domains in this model manage their own resources. Among the disadvantages are the fact that the master domain model is complex to set up and administer, and that multiple local groups must be created in each resource domain.

Graphic M-21. Multiple master domain model.
Graphic M-21. Multiple master domain model.
NOTE

When you upgrade a Windows NT network based on the multiple master domain model to a Windows 2000 network, you can simplify your network administration considerably. Large enterprises usually use the multiple master domain model either because of limitations on the recommended number of users in a Windows NT domain (about 20,000) or because their company is spread across several geographically separate locations. Active Directory in Windows 2000 overcomes these limitations by enabling up to 10 million objects to be stored in the Active Directory database and by allowing a single domain to be divided into multiple sites with intersite directory replication traffic being scheduled for times of low wide area network (WAN) link use. The result is that a Windows NT–based network consisting of several master domains and many resource domains can be combined into a single Windows 2000 domain. You can create a hierarchy of organizational units (OUs) within Active Directory to mirror the administrative structure of the former multiple master domain model network, with suitable rights and permissions assigned to the OUs for different users and groups.

If you want to maintain the existing administrative structure of your company, you can migrate each master or resource domain to a distinct Windows 2000 domain. Each master domain becomes a root domain, and the resource domains that trusted them become child domains joined by two-way transitive trusts to their parent domain. The result is one new domain tree for each former master domain. You then establish two-way transitive trusts between the root domains of each tree, forming a domain forest. All users in your enterprise thus gain access to resources anywhere on the network.

See also
complete trust model, master domain, single domain model

multiple provider router (MPR)

A component of the Microsoft Windows NT operating system that supports the Workstation service by enabling access to shared folders and printers using standard Win32 network application programming interfaces (APIs).

How It Works

When an application tries to access a shared resource using a Universal Naming Convention (UNC) path, the request first goes to the I/O Manager, which forwards it to the Multiple UNC Provider (MUP). The MUP then queries the installed redirectors to determine which one can access the shared resource. These queries are passed to each redirector through a provider dynamic-link library (DLL) that is designed to communicate with that vendor’s redirector but presents a common programming interface to the multiple provider router (MPR). Once the appropriate redirector has been selected, the MPR forwards the request to the redirector.

Multiple UNC Provider (MUP)

A component of the Microsoft Windows NT operating system that supports the Workstation service by enabling access to shared folders and printer-sharing using Universal Naming Convention (UNC) paths.

How It Works

When an application tries to access a shared resource using a UNC path, the request first goes to the I/O Manager, which forwards it to the Multiple UNC Provider (MUP). The MUP then queries the installed redirectors to determine which one can access the shared resource. It then passes the request to the redirector.

Multiple Virtual Storage (MVS)

An operating system for legacy IBM mainframe computers that is now called the OS/390 operating system on IBM’s System/390 mainframe models. Multiple Virtual Storage (MVS) was originally developed for the System/360 series of mainframes, and it still runs on many mainframes used in government, finance, and industry for running accounting and payroll systems, large databases, and other legacy applications. MVS is mainly used to run applications written in COBOL, but it supports other languages. These languages include FORTRAN, PL/1, and CICS.

NOTE

The name “Multiple Virtual Storage” comes from the fact that MVS uses virtual memory (storage) for sharing memory among multiple applications.

multiplexer (MUX)

A telecommunications device that multiplexes several data channels from different pieces of data terminal equipment (DTE). Multiplexers (MUXes) are frequently used to combine digital lines in order to save cost by eliminating the need for extra line termination devices such as CSU/DSUs (Channel Service Unit/Data Service Units). For example, a T1 MUX might have several V.35 interfaces for accepting incoming data from bridges or routers connected to your local area networks (LANs) plus a DSX-1 interface for connecting to a channel bank or private branch exchange (PBX) system. The MUX takes the serial data input and voice input and multiplexes them together into a single data stream using an integrated CSU/DSU for direct transmission over a T1 line, allowing you to use your T1 line for voice and data combined. You can use a similar device to multiplex data and voice for transmission over a public frame relay carrier network.

MUXes are often used in mainframe environments for connecting remote terminals to async hosts without the need for individual cabling for each terminal. These types of MUXes are generally used in pairs and combine channels using time-division multiplexing (TDM). Examples include the following:

  • Fiber-optic MUXes for combining several sync or async data channels onto one duplex fiber-optic cable. A typical fiber-optic MUX might have 12 or 24 RS-232 input ports and support speeds in excess of 115.2 Kbps per channel. These MUXes are typically used in pairs to connect remote terminals to an async mainframe host across a campus environment and are often referred to as short-haul or local MUXes.

  • Twisted-pair MUXes for multiplexing several RS-232 serial channels over installed RJ-11 wiring to save costs.

  • Coax MUXes for connecting several 3270 terminals to an IBM controller in order to reduce the costs of cabling.

You can use an Ethernet MUX to take the output of several ports from a 10-Mbps Ethernet switch and transmit the time-division multiplexed signals over a single fiber-optic cable at distances up to 2 kilometers. These MUXes are also typically used in pairs.

NOTE

An inverse multiplexer, or IMUX, takes a single input data channel from a DTE such as a router and spreads it to several digital transmission lines. A demultiplexer is a MUX at the remote end of a multiplexed communication system.

TIP

Advanced T1 MUXes often offer some management functions. For example, you can configure a MUX with Simple Network Management Protocol (SNMP) to send a trap to your SNMP management console when a problem occurs. Some MUXes can also remote-dial a number using a built-in modem. A modular MUX allows you to expand your wide area network (WAN) link as your network grows by adding modules to provide additional V.35, RS-232, or RS-530 input ports.

Graphic M-22. A T1 multiplexer and a fiber-optic MUX.
Graphic M-22. A T1 multiplexer and a fiber-optic MUX.
See also
inverse multiplexing

multiplexing

In networking, the technique of combining separate communication channels from different sources into a single channel for transmission over a wide area network (WAN) link. For example, you can combine input from various pieces of data terminal equipment (DTE) using a multiplexer and transmit it over a single digital data line. The line must have a bandwidth equal to or greater than the combined bandwidth of the signals from the pieces of DTE.

Graphic M-23. Multiplexing.
Graphic M-23. Multiplexing.

A number of multiplexing methods are used in telecommunications and networking, each one suited to a different form of communication. Analog signals are often multiplexed using a technique called frequency-division multiplexing (FDM), in which the total bandwidth of the carrier is subdivided into a series of subchannels with different frequencies. Digital signals are often multiplexed using a technique called time-division multiplexing (TDM), in which multiple signals are combined into a single communication channel or bitstream by alternating them in brief time slots or intervals. Another digital multiplexing technology is statistical packet multiplexing (SPM), which is more efficient than TDM in dynamically allocating bandwidth for each multiplexed channel. A newer multiplexing technology is dense wavelength division multiplexing (DWDM), which is used in fiber-optic networks.

See also
inverse multiplexing

multipoint

See
point-to-multipoint

multiport repeater

See
hub

Multiprotocol Label Switching (MPLS)

A proposed standard from the Internet Engineering Task Force (IETF) for a switching protocol for backbone routers in large TCP/IP internetworks such as the Internet.

How It Works

Multiprotocol Label Switching (MPLS) is an outgrowth of switching protocols such as Layer 3 switching, tag switching, and Internet Protocol (IP) switching. MPLS enables routers to exchange information about the common paths taken by IP packets with different addresses. Routers can identify these paths as label-switched paths (LSPs) and enable routers to perform more efficient lookups in the relatively small label-swapping table (LST) that they maintain, instead of having to perform slower lookups in large IP address tables.

MPLS is particularly useful in the Internet infrastructure, where core routers are often connected in fully meshed topologies using permanent virtual circuits (PVCs) through Asynchronous Transfer Mode (ATM) backbones. MPLS also supports quality of service (QoS), which makes IP more suitable for sending multimedia and other streamed information.

NOTE

Label switching is also implemented in other technologies such as ATM and frame relay networks. MPLS proposes to bring the same traffic management features to IP internetworks, and MPLS-enabled routers will treat ATM and frame relay switches as peers within the label-switched IP internetwork.

Multipurpose Internet Mail Extensions (MIME)

A widely used Internet standard for encoding binary files to send them as e-mail attachments over the Internet.

How It Works

Traditional e-mail sent over the Internet using Simple Mail Transfer Protocol (SMTP) as specified by Request for Comments (RFC) 822 defines messages as consisting of a header and a body part, both of which are encoded using 7-bit ASCII text encoding. The header of an SMTP message consists of a series of field/value pairs that are structured so that the message can be delivered to its intended recipient. The body is unstructured text and contains the actual message.

Multipurpose Internet Mail Extensions (MIME) defines five additional extensions to SMTP message headers, supports multipart messages with more than two parts, and allows the encoding of 8-bit binary data such as image files so that they can be sent using SMTP. The encoding method for translating binary information used by MIME, Base64 Encoding, essentially provides a mechanism for translating nontext information into text characters.

The MIME extensions are implemented as fields within the e-mail message header. These fields define the following:

  • Content type

  • Content transfer encoding method

  • MIME version number

  • Content ID (optional)

  • Content description (optional)

NOTE

Microsoft Exchange Server uses MIME to encode messages in foreign character sets and for sending Rich Text Format (RTF) messages that include formatting such as italics and underlining.

Multistation Access Unit (MAU)

A wiring concentrator or passive hub used in Token Ring networks. Multistation Access Units (MAUs), which are the core wiring components for building Token Ring local area networks (LANs), direct network traffic from one station to the next.

How It Works

A MAU provides a physical ring topology for Token Ring traffic to follow, although the actual logical wiring topology used is a star topology with stations connected in a star pattern to a central MAU. A typical MAU might provide 8 or 16 ports for connecting stations to the ring. If a larger LAN is required, you can join MAUs to form a larger ring by connecting the ring-out connector of one MAU to the ring-in connector of another, and continue connecting until the ring-out of the last MAU in a series is connected to the ring-in of the first to complete the loop. You can connect up to 33 MAUs in this manner in a logical ring. MAUs also include circuitry that provides fault tolerance if a station fails or is disconnected from the MAU and allows Token Ring traffic to continue around the ring unaffected.

A typical MAU is a stand-alone device or a rack-mounted device that supports 8 or 16 workstations and includes one ring-out and one ring-in connector. It might support 4 Mbps or 16 Mbps or both and use either IBM data or RJ-45 lobe connectors for using IBM type 3 cabling or 100-ohm impedance shielded twisted-pair (STP) cabling. A modular MAU lets you add different connector or repeater modules for greater flexibility of network design. Stackable MAUs allow you to easily create large Token Ring LANs with up to 256 stations. Manageable MAUs include built-in Simple Network Management Protocol (SNMP) modules and might support both in-band and out-of-band management functions. Active MAUs regenerate signals at each port in order to reduce jitter and extend signaling distances beyond recommended specifications.

NOTE

The acronym “MAU” also stands for Medium Access Unit (or Media Attachment Unit) and can refer to the portion of the circuitry in a hub, Ethernet switch, or network interface card (NIC) that enables the correct form of electrical or optical connection to the particular type of media being used. The MAU (also known as the transceiver) detects the carrier and signal activity on the media, notes when collisions occur, and forwards this information to the remaining circuitry. To distinguish the two different meanings of the acronym “MAU,” the acronym “MSAU” is sometimes used to refer to a Multistation Access Unit.

Graphic M-24. Connecting several MAUs.
Graphic M-24. Connecting several MAUs.
TIP

If you need to locate your stations at distances greater than 100 meters from the MAU, you can use repeaters or a powered MAU with built-in repeaters for greater lobe distances. For larger rings, some MAUs include ring-in/out connectors for both copper cabling (RJ-45 connectors) and fiber-optic cabling (ST connectors).

A common way to bring down a Token Ring network is to connect a Token Ring station that has the wrong speed for the given network—for example, connecting a 4-Mbps station to a 16-Mbps network. This speed mismatch causes beaconing that brings down the network. A smart MAU can detect a mismatched station and lock out the station before a problem can occur.

Look for MAUs that have automatic loopback functions on their ring-in/out ports. If a break in the ring occurs between two MAUs, the break is automatically detected and traffic is routed along a preconfigured backup path.

multitasking

What an operating system does when it runs two or more programs simultaneously. From the point of view of the user, the programs appear to be executing at the same time, but from the operating system’s point of view, one of two things might be happening:

  • On a multiprocessor machine, each processor might be running a separate program simultaneously. This is true multitasking, which can only take place on machines with more than one processor and with operating systems that support multiple processors. Microsoft Windows 95 and Windows 98 are designed to run on machines with a single processor, but Windows NT supports systems with up to four processors (or eight in the Enterprise edition).

  • On a single-processor machine, the operating system time-slices between applications so that each application receives a small portion of time to run before giving this privilege to another application.

There are two basic types of multiprocessing on machines that run versions of the Windows operating system:

  • Preemptive multitasking:
    The operating system decides which thread or process is allowed to run at any specific time. Windows 95, Windows 98, and Windows NT support this form of multitasking.

  • Cooperative multitasking:
    Each application is responsible for voluntarily relinquishing control to other applications. Windows 3.x supports this form of multitasking.

Windows NT supports symmetric multiprocessing (SMP) on multiprocessor machines, whereby the Windows NT kernel lets processors share memory and assign ready threads to the next available processor. This SMP support ensures that no processor is ever idle or running a low-priority thread when a high-priority thread is waiting. Windows NT also supports soft affinity, whereby a thread tries to run on the same processor it last ran on, all things being equal. You can also use Task Manager to assign a specific process to a processor.

MUP

See
Multiple UNC Provider (MUP)

MUX

See
multiplexer (MUX)

MVS

See
Multiple Virtual Storage (MVS)

MX record

Stands for mail exchange record, a resource record in Domain Name System (DNS) databases that is used to implement mail routing. MX records specify the host that will be used to process or forward Simple Mail Transfer Protocol (SMTP) mail for a given DNS domain. MX records are required for SMTP hosts to enable SMTP mail to be exchanged over the Internet.

Example

An MX record specifying that incoming mail directed toward the microsoft.com domain should be delivered to the SMTP host mail.microsoft.com might be

microsoft.com.   IN   MX   0   mail.microsoft.com.

The number 0 is the preference value that specifies the priority of the SMTP host (which is used if more than one SMTP mail exchanger exists for a given domain).

My Computer

A desktop icon in Microsoft Windows 95, Windows 98, Windows NT, and Windows 2000 that allows users to browse local resources on their computers. The icon provides a view that is different but complementary to Windows Explorer’s view of system and network resources. My Computer gives users a simple way to view the resources on their computer. In Windows 98 with Active Desktop installed, My Computer has an optional Web interface that supports browsing.

Graphic M-25. My Computer.
Graphic M-25. My Computer.
See also
Network Neighborhood

My Documents

A desktop shortcut in Microsoft Windows 98 and Windows 2000 that gives users a convenient location for storing documents that they create. My Documents is the default location where applications such as Paint or WordPad save the files you create. The desktop icon for My Documents is a folder containing a sheet of paper. My Documents is also part of the user profile on a machine running Windows.

TIP

You can change the target folder location of the My Documents folder for a user who is logged on by right-clicking its icon and choosing Properties. For example, you can modify the My Documents folder so that it points to a network share or the user’s home folder. You should teach users to store their personal documents in the My Documents folder.

My Network Places

A desktop folder in Microsoft Windows 2000 that displays the networking connectivity of your machine. You can use My Network Places to connect to shared folders on other computers on the network. The My Network Places folder contains

  • Add Network Place:
    Starts the Add Network Place Wizard. You use the wizard to create shortcuts to network resources such as shared folders, printers, and File Transfer Protocol (FTP) sites.

  • Entire Network:
    Contains links to all computers on your network.

  • Microsoft Windows Network:
    Included in Entire Network and provides access to computers belonging to Windows 2000 and Windows NT domains and workgroups.

  • Directory:
    Included in Entire Network and provides access to information on users, groups, and computers stored in Active Directory on domain controllers.

  • Computers Near Me:
    Shows all computers in your local domain or workgroup.

  • Shortcuts to other shared network resources that you have created using the Add Network Place Wizard.

TIP

If you right-click My Network Places and choose Properties, you can open your Network Connections folder, which displays the types of connections that your computer has with local area networks (LANs) or the Internet and allows you to configure these connections.

Graphic M-26. My Network Places.
Graphic M-26. My Network Places.


N

Nagle’s algorithm

An algorithm used in implementations of TCP/IP that controls traffic congestion on a network. Nagle’s algorithm limits transmission of small datagrams and controls the size of the Transmission Control Protocol (TCP) sending window. The algorithm increases the efficiency of routers by reducing the latency of the routing process. It is also an important mechanism for enabling large internetworks such as the Internet to handle TCP/IP applications (such as Telnet applications) that communicate using large numbers of small Internet Protocol (IP) packets.

For example, consider a Telnet client communicating with a Telnet server. When a user types a single character in the Telnet client window, TCP packages the character and sends it to the server as a very small packet. It would be highly inefficient if each character typed into a Telnet window were sent as an individual packet. In fact, when the user types the next character, one of two things can happen:

  • If an acknowledgment has been received for the first packet sent, TCP packages the second character into a second small packet and sends it immediately to prevent delay.

  • If an acknowledgment has not been received for the first packet, TCP buffers the second character, then the third, and so on until the acknowledgment is received or the buffer has reached a certain size, triggering TCP to package the buffered characters and send them. This is a result of Nagle’s algorithm being implemented on the client TCP/IP protocol stack. The process of buffering the TCP send buffer is sometimes called “nagling.”

Another part of Nagle’s algorithm addresses the problem of a network system getting bogged down when a large datagram is sent over and over again because it takes too long to fill a sending window (the receiving buffer) with the data from the datagram. According to the algorithm, when a client receives a message that datagrams are being dropped because of congestion at a particular host, the client responds by temporarily acting as if the host’s window size has been reduced. This “throttles back” the amount of information sent to the host and enables the host to catch up.

NOTE

Nagle’s algorithm is defined in Request for Comments (RFC) 896. It is implemented in the TCP/IP protocol stack of the Microsoft Windows NT and Windows 2000 operating systems. Proposals have been put forth for improving this algorithm because it does not produce optimal results with certain kinds of TCP/IP interactions, such as those based on HTTP 1.1.

named pipe

An interprocess communication (IPC) mechanism that provides reliable, connection-oriented, two-way communication between processes on two computers. Named pipes are one form of client/server communication in Microsoft Windows operating systems and applications.

How It Works

A pipe is a portion of memory reserved for one process to pass information to another. Named pipes are implemented as file system drivers and therefore are opened by requests made from the redirector. They take full advantage of the features of file system drivers, such as security and validation.

Developed originally for Microsoft OS/2 LAN Manager and maintained in recent versions of Windows for backward compatibility, named pipes provide guaranteed delivery of data between computers for distributed applications in a client/server environment. They provide a reliable, one-to-one, bidirectional, connection-oriented form of communication between a client process running on one machine and a server process (service) running on a different machine.

Named pipes are used in the WinLogon process on Windows NT and in client/server applications that use Microsoft SQL Server.

NOTE

Windows 98 supports client-side named pipes communication for backward compatibility with OS/2 LAN Manager and other applications, but it does not support server-side named pipes. Named pipes consume more server-side memory than other IPC mechanisms (such as Windows Sockets) and generate a bit more network traffic.

name lookup

In the Domain Name System (DNS), the process of a resolver sending a request to a name server. The resolver sends the host name of a TCP/IP host on the internetwork, and the name server returns the host’s IP address. The name server is said to “resolve” the name of the host into its associated IP address.

The query sent by the resolver to the name server is most often a recursive query, which returns either the expected IP address or an error. This type of query makes it possible for a name server to forward the request on to other name servers if it can’t resolve the name and then return the result of that request to the resolver. If the queried name server is configured to forward requests, it can perform an iterative query, querying several name servers in succession until it resolves the name or runs out of name servers to query.

See also
Domain Name System (DNS), host name resolution

name resolution

The process of resolving the name of a computer on a network into its network address. Name resolution is an important part of network communication because the logical names of hosts on the network must be resolved into their network addresses before communication can take place.

TCP/IP networks running Microsoft Windows operating systems support two name resolution methods:

  • NetBIOS name resolution to resolve NetBIOS names into IP addresses. This is performed by using broadcasts or by querying a Windows Internet Name Service (WINS) server.

  • Host name resolution to resolve fully qualified domain names (FQDNs) into IP addresses. This is performed by using a local Hosts file or by querying a Domain Name System (DNS) server.

In addition, once the name of a host is resolved into its IP address, the TCP/IP protocol called Address Resolution Protocol (ARP) resolves the host’s IP address into its physical layer or MAC address. Once the name resolution process is complete, you can place frames on the network with appropriate destination MAC addresses so that they can be received by their destination host.

See also
host name resolution, NetBIOS name resolution

name server

A host on the Internet or on a TCP/IP internetwork that can be used to resolve host names into IP addresses. Name servers are an essential component of the Domain Name System (DNS), which provides the namespace of all hosts on the Internet or on a private TCP/IP internetwork. Because of name servers, when you want to access or reference a host on a TCP/IP network, you can use its friendly DNS name instead of its IP address, which is generally harder to remember.

How It Works

The DNS functions as a client/server-based system, with name servers forming the server part and resolvers forming the client part. Each name server has authority over a portion of the DNS namespace called a zone, which means that it should be able to resolve name lookups for hosts located within that zone. Resolvers send name lookups to name servers by passing them the name of a host. The name server performs name resolution by determining which IP address corresponds to the requested host’s name. Name servers can also query each other, so a typical name lookup from a resolver might involve several name servers.

This distributed system of name servers makes it possible to share the load of name resolution among many computers. Just imagine if one machine had to track the name of every host on the Internet!

Within a zone you can have two types of name servers, which allows for fault tolerance and a further sharing of the load:

  • Primary name servers:
    These name servers keep a local file of the information relating to their zone. This local file or DNS database contains resource records, which are mappings of host names to IP addresses for hosts in that zone. A DNS administrator must manually create and maintain the DNS database on a primary name server.

  • Secondary name servers:
    These name servers obtain their database of resource records from a master name server, which can be either a primary name server or another secondary name server. The process by which the DNS database is transferred from a master name server to a secondary name server is known as zone transfer.

The collection of all name servers on the Internet is used to manage and maintain the DNS namespace of host name to IP address mappings. Name servers can also be used on private TCP/IP internetworks to facilitate network communication.

NOTE

Microsoft’s implementation of a name server in Windows NT, the Microsoft DNS Service, is fully compliant with related Requests for Comments (RFCs) describing the implementation and working of the DNS.

Windows 2000 supports the industry’s extension to DNS with the DNS dynamic update protocol. This protocol is integrated into Active Directory on Windows 2000–based networks and enables the dynamic updating of DNS name servers.

See also
Domain Name System (DNS)

name server (NS) record

A type of Domain Name System (DNS) resource record that identifies the specific host as a name server. For each zone governing a portion of the DNS namespace, there should be one name server (NS) record for each name server in the zone. Each NS record also requires an associated address record that resolves the host name of the name server into its IP address. The syntax for the NS record is specified in Request for Comments (RFC) 1035.

Here is an example of an NS record:

microsoft.com.      IN  NS      nameserver2.microsoft.com.

In this example, the domain microsoft.com is within the zone of authority of the name server named nameserver2. IN stands for Internet, and NS stands for name server.

See also
Domain Name System (DNS)

namespace

The abstract space or collection of all possible addresses, names, or identifiers of objects on a network, internetwork, or the Internet. A namespace is “the space of all names” for a given type of network name.

A simple example of a namespace is an IP address space, which consists of the space of all possible IP addresses. This space is divided into class A, class B, and so on, which represent disjoint subgroups of the IP address space. Generally, every node on a TCP/IP network, internetwork, or the Internet must occupy a unique point in the IP address space—that is, it must have a unique IP address. This ensures that a packet directed to a particular node (such as a computer, network printer, or router interface) can be addressed with the IP address of that node. If two nodes on a network were to have the same IP address number, a packet intended for one might end up at the other. The exception is when you have a private network connected to the Internet through a firewall that uses network address translation (NAT) or some other scheme to hide the addresses of nodes in the private network from the Internet. In this case, if no direct communication is expected between nodes in the two networks (except through the firewall), nodes in the private network can be assigned arbitrary IP addresses such as 10.x.y.z.

Another common example of a namespace is the DNS namespace of the Internet. Unlike the space of IPv4 addresses just described, the DNS namespace is hierarchical in structure and arbitrarily scalable (except so far as a node in DNS namespace must generally map to some specific IP address). It also has the advantage of being a logical naming scheme, in contrast to a physical naming scheme such as IP addresses, which are bound to the particular network structure being used.

The root of the DNS namespace branches out to a relatively small number of top-level domains such as .com, .org, and .edu. Private companies can register a domain name in one of these top-level domains and then subdivide their branch of the DNS namespace as they desire. For example, a company named Carpoint Traders might register the domain name carpoint.com and then create three new subdomains under it named sales.carpoint.com, support.carpoint.com, and hq.carpoint.com. Specific servers and router interfaces exposed to the Internet might then be given specific DNS addresses to uniquely identify them in the DNS namespace. An address in the DNS namespace, called a fully qualified domain name (FQDN), maps to a unique node on the Internet. An example might be widgets.support.carpoint.com, which might map to the address 10.15.6.133. Names of domains, subdomains, and individual hosts are maintained on name servers located at various points across the Internet or within large private internetworks. If you want to locate a particular node in the DNS namespace, you query a name server. The process of locating a particular DNS node and resolving its FQDN into its associated IP address is called name resolution.

Another namespace used in Microsoft Windows NT–based and Windows 2000–based networks is the NetBIOS namespace, which is the space of all NetBIOS names (computer names) of Windows machines on the network. Unlike the hierarchical tree structure of the DNS namespace, the NetBIOS namespace is flat and is managed using the Windows Internet Name Service (WINS), which runs on WINS servers in the network. Because the NetBIOS namespace is flat, it is not as scalable as DNS. For example, say that you query a name server to resolve an FQDN such as widgets.support.carpoint.com into its associated IP address. The name server might first have to find another name server that is authoritative in the carpoint.com domain. Next, the name server must find a name server that is authoritative in the support.carpoint.com subdomain whose database contains a record for the widgets.support.carpoint.com host. Finally, the name server must resolve the information in the record into an IP address. The whole process might take only several referrals and a short inspection of a relatively small database of resource records because each name server on the Internet is authoritative over only a small portion of the DNS namespace. Once you locate the correct name server through a series of hierarchical queries, the final name lookup deals with only a small number of records. The NetBIOS namespace is different, however, because each WINS server maintains a database of records for all NetBIOS names on the network. So if you were to use WINS to manage a network the size of the Internet with its millions of hosts, each WINS server would have a flat-file database containing millions of records, which would need to be searched from top to bottom each time a query was issued against it.

Because of the flexibility and scalability of DNS and its association with the Internet, DNS is the primary naming system used by Windows 2000. Support for WINS is included only for backward compatibility with downlevel Windows NT stations and legacy Windows stations. Active Directory in Windows 2000 uses DNS as the service for name resolution (for locating users, groups, computers, shared folders, printers, and other objects on the network). The namespace of Active Directory represents a bounded area within which the DNS name of the root of Active Directory is translated to all the objects within the directory. Within Active Directory, a domain tree represents a contiguous namespace of connected objects, while a domain forest is a disjointed namespace formed from two or more domain trees. Companies with Windows 2000–based networks can use the same DNS namespace for both internal and external network connections, or they can use separate DNS names for the network from an internal or an external perspective.

See also
Domain Name System (DNS), IP address

naming context in Active Directory

A contiguous subtree or branch of Active Directory in Microsoft Windows 2000. Naming contexts are used to partition the Active Directory namespace into sections, each with its own security boundary. You use naming contexts during the process of directory replication to form the basic unit of the replication process.

Active Directory always includes at least three naming contexts:

  • Configuration:
    Contains information about sites, services, partitions, and the Active Directory schema

  • Domain naming:
    Contains information relating to directory data for the domain in which the Active Directory domain controller resides

  • Schema:
    Contains the schema information that defines the classes, objects, and attributes used in Active Directory

During multimaster replication of Active Directory, any naming context that has been updated is replicated to other domain controllers. For example, if the schema is modified on one domain controller, the schema naming context is replicated to all other domain controllers in Active Directory and also to the global catalog server. Only those portions of the naming context that have changed are actually replicated.

naming context in Exchange Server

A boundary for permissions inheritance. Microsoft Exchange Server has three levels of naming context:

  • Organization container

  • Site container

  • Configuration container

If permissions are assigned to a user or a group on the site container, those permissions are inherited by everything in the Exchange directory hierarchy beneath the site container until the configuration container is encountered. Similarly, if an object in the configuration container has permissions assigned to it, those permissions are inherited by all objects beneath it.

naming convention

A rule to ensure that users on a network have their own unique username so that they can be owners of their own resources (such as their personal folders). A simple and consistent naming convention for users on your network is an important part of network administration. Examples of naming conventions applied to the user Jeff Smith might include the following:

  • jsmith—the first letter of the user’s first name concatenated with the user’s full last name

  • jeffs—the user’s first name concatenated with the first letter of the user’s last name

Two users on a network might have the same first or last name, so your naming convention should include a rule to break ties. For example, if Jeff Smith is “jsmith,” James Smith might be “jsmith2.” You might also want to establish a rule for easily identifying temporary employees, such as “T-jsmith” or “jsmith(temp).”

NOTE

On Microsoft Windows 2000–based networks, usernames of domain user accounts must be unique within the given organizational unit (OU) in which they are created in Active Directory. Usernames can be more than 20 characters long, but only the first 20 characters are used as logon credentials.

NAP

See
Network Access Point (NAP)

NAS

See
network access server (NAS)

NAT

See
network address translation (NAT)

National Electric Code (NEC)

A series of specifications for protecting commercial and residential buildings from electrical hazards. The National Electric Code (NEC) is published by the National Fire Protection Association (NFPA), an international organization that advocates standards for fire safety and related issues. The NEC is one of hundreds of standards documents produced by the NFPA. The NEC, which is NFPA standard number 70, deals with how to properly install and maintain electrical and electronic equipment in order to minimize fire hazards. In the area of computer networking, the NEC covers the proper installation and construction of copper cabling and fiber-optic cabling, as well as issues relating to the powering of network devices, such as proper grounding.

The NEC is legally enforced in every state in the United States and in a number of other countries. Most U.S. municipalities have adopted NEC recommendations in local building codes. Testing of electrical equipment for compliance with NEC standards is performed by Underwriters Laboratories (UL).

On the Web
•
NFPA home page
: www.nfpa.org

National Institute of Standards and Technology (NIST)

A government organization that provides services and programs to help U.S. industries commercialize new technologies and compete internationally. National Institute of Standards and Technology (NIST) certification identifies technologies as meeting federal government requirements.

In the area of relational database management systems (RDBMS’s), NIST administers a test named Federal Information Processing Standard (FIPS) 127-2. FIPS 127-2 is based on the broader American National Standards Institute (ANSI) SQL92 standard, which ensures portability across heterogeneous RDBMS’s by establishing a common set of structured query language (SQL) commands. There is no higher standard for SQL database languages than FIPS 127-2.

Microsoft SQL Server 6.5 was the first RDBMS to pass the NIST version 5.1 validation tests for Entry Level FIPS 127-2. SQL Server 6.5 complies with both the ANSI SQL92 standard and the FIPS standards.

native mode

A domain mode for running Microsoft Windows 2000 domain controllers that is incompatible with domain controllers running the earlier Windows NT operating system. You can use domain controllers running in native mode only to authenticate users on a pure Windows 2000–based network. If your network contains a mixture of Windows 2000 and Windows NT computers, you should configure your Windows 2000 domain controllers to run in mixed mode so that they can interoperate with Windows NT domain controllers. If you plan to use native mode, all domain controllers must be running Windows 2000 and must be configured to run in native mode, but member servers and client workstations can run either Windows 2000 or Windows NT.

NOTE

Native mode gives you more options than mixed mode regarding types of groups. Specifically, you can use global groups, domain local groups, and universal groups, and you can nest them to any degree. Running in mixed mode means that universal groups are not available, and you can nest global groups only in domain local groups and only to one level of nesting.

TIP

Windows 2000 domain controllers install in mixed mode by default. You can use the administrative tool Active Directory Domains and Trusts to change your domain controllers from mixed mode to native mode. If you change a domain controller to native mode, you cannot change it back to mixed mode, so don’t make the change until all your domain controllers are running Windows 2000.

See also
domain modes

NBF

See
NetBEUI Frame (NBF)

NBNS

See
NetBIOS Name Server (NBNS)

nbtstat

A TCP/IP utility that displays current TCP/IP connections and statistics using NetBIOS over TCP/IP (NetBT). Nbtstat is installed on a computer running Microsoft Windows when the TCP/IP protocol stack is installed. You can run nbtstat from the command prompt to view NetBT statistics on the computer and determine the status of connections formed to the machine. You can also use nbtstat to preload #PRE entries in an Lmhosts file into the NetBIOS name cache and view the NetBIOS name and NetBIOS scope ID of a machine.

Example

nbtstat -n shows the NetBIOS names of the host that have been registered on the system; nbtstat -c displays the current contents of the NetBIOS name cache, which contains NetBIOS name to IP address mappings for other hosts on the network.

TIP

Nbtstat is useful for troubleshooting NetBIOS name resolution problems. You can run nbtstat -a < ComputerName > to obtain the local NetBIOS name table on <ComputerName> and its MAC address.

NDIS

See
network driver interface specification (NDIS)

NDS

See
Novell Directory Services (NDS)

near-end crosstalk (NEXT)

A measurement of the ability of cabling to reject crosstalk. Crosstalk is an undesirable condition in which the signals traveling through adjacent pairs of wire in twisted-pair cabling interfere with each other. Near-end crosstalk (NEXT) measures the ability of a cable to reject crosstalk between pairs of wire at the near end of the circuit. The pair causing the interference is called the “disturbing pair,” while the pair experiencing the interference is the “disturbed pair.” Channel NEXT is the NEXT value measured between one wire pair and another in the same cable; it is measured at both ends of the wire.

The NEXT value for a given cable type is typically expressed in decibels per 1000 feet and varies with the frequency of transmission. The higher the NEXT value, the greater the cable’s ability to reject crosstalk at its local connection. For example, the specifications for category 5 cabling include the minimum NEXT values shown in the following table. Note that the NEXT value generally decreases with increasing frequency, indicating increasing interference due to crosstalk at higher frequencies.

Graphic N-1. Near-end crosstalk (NEXT).
Graphic N-1. Near-end crosstalk (NEXT).

The NEXT types are as follows:

  • Pair-to-Pair NEXT:
    NEXT between adjacent pairs of wire in a twisted-pair cable. A typical four-pair (eight-wire) unshielded twisted-pair (UTP) cable has six possible values for pair-to-pair NEXT, which are then averaged. This simple measurement is not adequate, however, because every pair of wire generates crosstalk with every other pair in the cable.

  • Power Sum NEXT (PS NEXT):
    A more rigorous way of rating a cable’s crosstalk that measures the total amount of crosstalk between one wire pair and all its neighboring pairs in the same cable. PS NEXT is particularly important for cabling used in high-speed networks such as Gigabit Ethernet and Asynchronous Transfer Mode (ATM) networks.

  • Far-End Crosstalk (FEXT):
    A measurement of how the far end of one wire pair affects the near end of another pair.

Desired Data Rate and the Cable’s Minimum NEXT Value
Frequency | Minimum NEXT Value
4 MHz | 53 dB/1000 feet
10 MHz | 47 dB/1000 feet
20 MHz | 42 dB/1000 feet
1000 MHz | 32 dB/1000 feet
TIP

To minimize NEXT in installations of category 5 cabling, do not expose more than 2 inches of wire pairs at the termination point of the cable (the patch panel, wall plate, or RJ-45 connector). Also, do not untwist the wire pairs more than half an inch.

NEC

See
National Electric Code (NEC)

NetBEUI

Stands for NetBIOS Extended User Interface, a networking protocol developed by IBM and Microsoft in 1985 that is used for workgroup-size local area networks (LANs) with up to 200 stations. NetBEUI is an extension of the NetBIOS protocol.

NetBEUI was the primary protocol for LAN Manager and Windows for Workgroups. It is a fast and efficient protocol with low overhead that supports both connection-oriented communication (such as communication for mapping drives using the Net Use command and starting services remotely using the Net Start command) and connectionless communication (such as communication for sending datagrams, registering NetBIOS names, and performing NetBIOS name resolution).

NetBEUI is also self-tuning and implements flow control and error detection. It defines a framing mechanism at the transport layer and implements the LLC2 protocol of the Open Systems Interconnection (OSI) reference model for networking.

NOTE

NetBEUI is supported by all Microsoft Windows network operating systems; its implementation on Windows NT is called the NetBEUI Frame (NBF) protocol.

TIP

NetBEUI relies more heavily on broadcast packets than do the TCP/IP and NWLink IPX/SPX-Compatible Transport protocols; you should therefore use it only on smaller networks sized for workgroups. Because NetBEUI is a single-part naming scheme, it is a nonroutable protocol and is generally unsuitable for wide area networks (WANs).

NetBEUI Frame (NBF)

An enhanced implementation of the NetBEUI protocol that is available on Microsoft Windows NT operating systems. Some of the enhancements and special features of NetBEUI Frame (NBF) include the following:

  • Support for network driver interface specification (NDIS) version 3 for full 32-bit asynchronous transport layer communication using the transport driver interface (TDI) layer as a NetBIOS emulator

  • Support for automatic memory tuning through dynamic memory allocation

  • Support for dial-up clients through the Remote Access Service (RAS)

  • An extension of NetBEUI’s limit of 256 concurrent NetBIOS sessions to more than 1000 sessions

NOTE

Although NetBEUI is essentially a nonroutable protocol, NBF supports Token Ring Source Routing on IBM Token Ring networks.

See also
NetBEUI

NetBIOS

Stands for Network Basic Input/Output System, a specification created by IBM and Microsoft that allows distributed applications to access each other’s network services independent of the transport protocol used.

NetBIOS provides network input/output services to support client/server applications on a network. From an architectural viewpoint, the NetBIOS specification defines two things:

  • An interprocess communication (IPC) mechanism or application programming interface (API) that allows applications that are NetBIOS-enabled to communicate remotely over a network and request services from lower levels of the protocol stack. This is the primary and original definition of NetBIOS.

  • A protocol operating at the session and transport layers of the Open Systems Interconnection (OSI) reference model that enables functions such as session establishment and termination as well as name registration, renewal, and resolution.

NetBIOS has more overhead than other IPC mechanisms. NetBIOS can take different forms depending on the network protocol on which it is running. The following table lists some common network protocols and the form that NetBIOS takes on each.

NetBIOS Protocol Stacks
Network Protocol | Name When Combined with NetBIOS
NetBEUI | NBF (NetBEUI Frame protocol)
NWLink IPX/SPX-Compatible Transport | NWLink NetBIOS
TCP/IP | NetBT (NetBIOS over TCP/IP)
See also
NetBIOS name resolution, P-node, Windows Internet Name Service (WINS)

NetBIOS name

A 16-byte name for a networking service or function on a machine running Microsoft Windows NT. NetBIOS names are a more friendly way of identifying computers on a network than network numbers and are used by NetBIOS-enabled services and applications. NetBIOS names are used by Windows NT applications such as Windows Explorer and Network Neighborhood as well as by the Windows NT net commands.

In Windows 2000, NetLogon and other networking services now register in DNS, but legacy network command-line applications still use NetBIOS names to access these services.

How It Works

Each service that is NetBIOS-enabled requires a unique NetBIOS name to identify it on the network. This NetBIOS name consists of a name assigned to the computer during installation, which can be up to 15 characters, along with a 1-byte hexadecimal sixteenth character that identifies the type of service or function. The 15-character name can be the computer name, the domain name, or the name of the user who is logged on.

For example, the sixteenth character identifying the Windows NT Messenger service has the 1-byte hexadecimal identifier 03h. On a computer running Windows NT named SERVER12, the Messenger service would be uniquely identified on the network with the NetBIOS name SERVER12[03h]. NetBIOS names are also distinguished by whether they are

  • A unique name, which applies to a single IP address

  • A group name, which applies to a subnet group of IP addresses

  • A multihomed name, which applies to a multicast group of IP addresses

The following table shows some of the more common suffixes that constitute the hidden sixteenth character of a NetBIOS name and the networking service with which they are associated.

Common Suffixes for NetBIOS Names
Suffix (Hex) | First 15 Characters | Networking Service
00 | Computer name | Workstation service
00 | Domain name | Domain name
03 | Computer name | Messenger service
03 | User name | Messenger service
06 | Computer name | RAS Server service
20 | Computer name | File Server service
21 | Computer name | RAS Client service
1B | Domain name | Domain master browser
1C | Domain name | Domain controllers
1D | Domain name | Master browser
1E | Domain name | Browser service election
TIP

To view the NetBIOS names registered for your computer, use the nbtstat command.

NetBIOS name resolution

On TCP/IP internetworks, the process by which the NetBIOS name of a computer is resolved to its IP address. NetBIOS name resolution enables NetBIOS hosts to communicate with each other using TCP/IP. Once a host’s name has been resolved to its IP address, the address resolution protocol (ARP) can then be used to resolve the IP address into its corresponding physical layer or MAC address. Once the physical address of a host is known, frames may be placed on the wire and targeted to this address.

How It Works

When you go to the command prompt of a machine running Microsoft Windows and type a Net Use command to map a drive to a network share, you type the NetBIOS name of the target host in the command (for example, net use x: \\server7\pub ). For this command to be fulfilled, the NetBIOS name of the remote host must first be resolved into its IP address so that it can be contacted on the network. This process is called NetBIOS name resolution.

You can use a number of different methods to perform NetBIOS name resolution. The following table shows the order in which these are attempted when the hosts are H-node types. Each method is successively tried until the name is resolved into its IP address or name resolution fails. Some methods will not be available—for example, if there is no NetBIOS Name Server (NBNS) or DNS server on the network.

NetBIOS Name Resolution Methods
Method (in the Order Applied) | Comments
Check local NetBIOS name cache | The cache contains recently resolved NetBIOS names.
Contact NBNS | This method works only if NBNS is configured. The name server is usually a Windows Internet Name Service (WINS) server on a Microsoft network. The requestor tries three times to contact the name server, and then tries to contact a secondary WINS server three times (if configured with secondary servers).
Perform local broadcast | The requestor broadcasts a NetBIOS name query request packet. The requestor tries three times before giving an error.
Check local lmhosts file (Unique to Microsoft networks. If all methods fail, an error message states that the computer could not be found on the network.) | The requestor checks if an Lmhosts file exists.
Check local hosts file (Unique to Microsoft networks. If all methods fail, an error message states that the computer could not be found on the network.) | On Windows NT the requestor checks the Hosts file if Enable DNS For Windows Resolution is selected on the WINS Address tab of the TCP/IP property sheet. This option is not available for Windows 2000.
Contact DNS server (Unique to Microsoft networks. If all methods fail, an error message states that the computer could not be found on the network.) | The requestor contacts the DNS server if Enable DNS For Windows Resolution is selected on the WINS Address tab of the TCP/IP property sheet and the DNS tab has a DNS server specified on it. The requestor also tries 5, 10, 20, and 40 seconds later.
NOTE

A separate series of steps is used to resolve host names on a network that uses the Domain Name System (DNS). On IPX/SPX networks, NetBIOS over IPX (NBIPX) resolves NetBIOS names to Internetwork Packet Exchange (IPX) addresses.

See also
host name resolution, NetBIOS, NetBIOS name, NetBIOS over TCP/IP node types

NetBIOS Name Server (NBNS)

A server responsible for maintaining a list of mappings between NetBIOS computer names and network addresses for a network that uses NetBIOS as its naming service. A computer registers itself with the NetBIOS name server upon startup by providing the name server with its computer name and network address. When the computer needs to communicate with a remote machine, it queries the name server for the network address of the remote machine. Names can also be resolved by using broadcasts, but this is more wasteful of network bandwidth than use of a dedicated name server.

NOTE

On a Windows NT–based network, an enhanced form of NetBIOS name servers called Windows Internet Name Service (WINS) servers are used. WINS is a NetBIOS over TCP/IP (NetBT) mode of operation defined in Request for Comments (RFC) numbers 1001 and 1002 as p-node. WINS servers can also be used on Windows 2000–based networks, but the primary mode of name resolution for Windows 2000 is the Domain Name System (DNS).

See also
Windows Internet Name Service (WINS), WINS server

NetBIOS over TCP/IP (NetBT)

The NetBIOS session-layer protocol and application programming interfaces (APIs) running on top of the TCP/IP network protocol. NetBIOS over TCP/IP (NetBT) supports NetBIOS session and naming functions such as the discovery, resolution, and release of NetBIOS names on a TCP/IP network, which allows the NetBIOS interface and client/server protocol to be extended over wide area networks (WANs). This can be done effectively only if you manage name processes such as NetBIOS name registration centrally using the Windows Internet Name Service (WINS) on Microsoft Windows NT. Broadcast-based name registrations usually don’t work over an internetwork because routers are typically configured not to forward broadcast packets to remote subnets.

The Server, Workstation, NetLogon, Browser, and Messenger services on Windows NT interact with NetBT by using the Transport Driver Interface (TDI) networking component.

NetBIOS over TCP/IP node types

Different configurations or node types of NetBIOS over TCP/IP (NetBT) hosts. The node type determines how the NetBIOS naming functions are performed. For example, the naming functions can be performed by broadcast, by a NetBIOS Name Server (NBNS) such as a Windows Internet Name Service (WINS) server, or by both. The node type also determines the order in which the functions are performed. The following list describes the NetBIOS naming functions (name resolution, name registration, and name release):

  • NetBIOS name discovery:
    NetBT hosts that want to communicate with similar hosts must issue a NetBIOS name query request to resolve the NetBIOS name of the target server into its IP address.

  • NetBIOS name registration:
    NetBT hosts must register their NetBIOS name when they are initialized on a network to ensure that there are no duplicate names on the network. NetBIOS name registration can be done either by broadcasts or by directed packets sent to a WINS server. Either or both methods can be used in either order, depending on the NetBT node type of the host.

  • NetBIOS name release:
    NetBT hosts must release their NetBIOS names when they are shut down or when a particular NetBIOS-enabled service is stopped on the server. This enables the released name to be used by another host. NetBIOS name release can be done by broadcasts or by directed packets sent to a WINS server. Either or both methods can be used in either order, depending on the NetBT node type of the host.

The NetBIOS over TCP/IP node types are listed in the following table.

NetBIOS over TCP/IP Node Types
Node Type | Method (in the Order Applied) | Comments
B-node (broadcast) | Broadcast only | Uses NetBIOS name queries for name registration and name resolution. Typically not forwarded by routers, so limited to local subnet. Can create excessive traffic in large networks.
P-node (peer-to-peer) | NBNS only | Uses NBNS, which is a single point of failure for NetBIOS naming functions.
M-node (mixed) | Broadcast NBNS | A combination of B-node and P-node. Uses broadcast by default. If unable to resolve, uses NBNS.
H-node (hybrid) | NBNS Broadcast | A combination of P-node and B-node. Uses NBNS by default. Default node type for Microsoft clients if an NBNS is configured on the network.
Microsoft enhanced B-node | NetBIOS name cache Broadcast Lmhosts file | An enhanced broadcast that utilizes the Lmhosts file. Default node type for Microsoft clients if no NBNS is configured on the network.
TIP

You can configure the NetBIOS node type directly on a Microsoft Windows NT client by using the registry, but the preferred way is to configure DHCP scope option number 46 on the DHCP server and configure the clients as DHCP clients.

See also
NetBIOS name resolution

NetBIOS scope ID

A character string appended to a NetBIOS name of a host that identifies the host as belonging to a specific group. You can use NetBIOS scope IDs to segment the flat NetBIOS namespace into a series of subspaces. Two hosts can communicate only if they have the same NetBIOS scope ID and belong to the same subspace. The total length of a NetBIOS name plus scope ID cannot exceed 256 characters.

NOTE

The topology of NetBIOS subspaces does not have to match the physical topology of the network or the logical topology of subnets on a TCP/IP internetwork.

TIP

Using NetBIOS scope IDs is no longer recommended, especially if you are also using the Domain Name System (DNS) for naming hosts on your network. You should configure NetBIOS scope IDs only if you want to isolate a particular subset of computers on your network from the rest of the network and allow them to communicate only among themselves. (You configure a NetBIOS scope ID on a computer running Microsoft Windows NT 4 by using the WINS Address tab of the TCP/IP property sheet. In Windows 2000, you must manually modify an entry in the registry.)

If trust relationships are configured between several Windows NT domains on your network, using NetBIOS scope IDs can break the effect of these trust relationships by preventing pass-through authentication between trusted domain controllers that have different scope IDs. Furthermore, in a single-domain environment, if the scope ID of a workstation is different from that of the domain controllers, users will not be able to log on to the network at that workstation.

NetBT

See
NetBIOS over TCP/IP (NetBT)

net commands

A group of commands that can be used at the command prompt for managing certain aspects of networking on Microsoft Windows platforms. These commands are summarized in the following tables. For more information about a specific command (such as net accounts), type net accounts /? or net help accounts at the command prompt. For additional information on the net commands for Windows NT and Windows 2000, refer to Windows Help.

Net Commands for Windows NT and Windows 2000
Command | Description
Net Accounts | Update the accounts database, modify account and password settings, or display account information.
Net Computer | Add or remove computers from the domain.
Net Config | Display or change the setting for the Server or Workstation service.
Net Continue | Restart a paused Windows service.
Net File | Display a list of open shared files and file locks; this command can be used to close a shared file and remove a file lock.
Net Group | Add, modify, delete, or display global group account information in the domain directory database.
Net Help | Obtain a list of net commands or get help for a specific net command.
Net Helpmsg | Obtain further information about Windows network messages.
Net Localgroup | Add, modify, delete, or display local group account information in the local or domain directory database.
Net Name | Add, delete, or display the names or aliases that the Messenger service recognizes as representing your computer.
Net Pause | Pause a Windows service to allow users to disconnect before stopping it.
Net Print | Display and manage jobs in a print queue.
Net Send | Send a message to a user or computer over the network.
Net Session | Display the list of currently connected sessions on the local computer.
Net Share | Create, delete, or display shared resources.
Net Start | Display a list of running services or start a specific stopped service.
Net Statistics | Display statistics about the Server and Workstation services.
Net Stop | Stop a specified Windows service that is currently running.
Net Time | Synchronize the computer’s clock with that of another computer or domain, or display the time for a computer or domain.
Net Use | Connect or disconnect to shared resources or display information about connections.
Net User | Add, modify, delete, or display user account information in the local or domain directory database.
Net View | Display a list of computers in the domain or display the shared resources available on a specific computer.
Net Commands for Windows 95 and Windows 98
Command | Description
Net Config | Display current computer settings.
Net Diag | Run the Microsoft Network Diagnostic program to display diagnostic information about a computer.
Net Help | Obtain a list of net commands or get help for a specific net command or error message.
Net Init | Load protocol and network-adapter drivers without binding them to Protocol Manager.
Net Logoff | Break connections to network resources.
Net Logon | Log on to a domain.
Net Password | Change logon password.
Net Print | Display and manage jobs in a print queue.
Net Start | Start services.
Net Stop | Stop services.
Net Time | Synchronize the computer’s clock with that of another computer or workgroup, or display the time for a computer or workgroup.
Net Use | Connect or disconnect to shared resources or display information about connections.
Net Ver | Display information about workgroup redirector.
Net View | Display a list of computers in the workgroup or display the shared resources available on a specific computer.
Example

Some of the commands produce more than one screen of output at the command prompt. To prevent information from scrolling off the screen, pipe the output through More (for net help accounts | more).

Net-Library

A network interface layer that Microsoft SQL Server uses to communicate with database client software.

How It Works

Net-Libraries are specific to each type of interprocess communication (IPC) mechanism. A Net-Library can be loaded for each IPC mechanism being used—for example, one Net-Library for named pipes communication and another for TCP/IP sockets. Net-Libraries are used at both the server and client levels. This allows clients on different networks to be supported simultaneously using the built-in Microsoft Windows NT and Windows 2000 support for running multiple network protocols simultaneously on one system.

Net-Libraries on SQL Server listen for incoming connection attempts from database clients. SQL Server has a multiprotocol networking library that listens using named pipes, TCP/IP ports, and Sequenced Packet Exchange (SPX) sockets.

NOTE

Be sure to distinguish between the particular IPC mechanism and its underlying network protocol. Some IPC mechanisms (such as named pipes) can function simultaneously over multiple network protocols such as NetBEUI, NWLink IPX/SPX, and TCP/IP.

NetLogon service

A Microsoft Windows NT service that authenticates users who attempt to log on to the domain. For example, if a user attempts to log on interactively to a computer running Windows NT Workstation within the domain, the NetLogon service running on the workstation forwards the logon request to a domain controller within the domain using a process called pass-through authentication. The workstation knows how to contact the domain controller because during startup the workstation finds a domain controller through a process called discovery, after which an implicit trust relationship establishes a secure communication channel between the workstation and the domain controller.

The NetLogon service also ensures that all domain controllers within the domain are synchronized by having the primary domain controller (PDC) periodically notify groups of backup domain controllers (BDCs) that they should query the PDC for any updates to the Security Account Manager (SAM) database. The NetLogon service also enables and maintains trust relationships between domains on a multidomain deployment of Windows NT.

NetLogon Share

The administrative share for the scripts folder on Microsoft Windows NT domain controllers at %SystemRoot%\system32\repl\import\scripts. This share is used by the NetLogon service for the following purposes:

  • Storing a default user profile for users (which must be stored in a subdirectory called Default User). If a user without a local profile on his or her workstation or a server-based roaming profile logs on, the default user profile is used.

  • Storing logon scripts (for example, logon.bat).

  • Storing system policies (ntconfig.pol or config.pol files).

When a client logs on to a Windows NT domain and is authenticated, the final step in the logon process involves connecting to the NetLogon share and downloading or applying any of the items in the preceding list.

netstat

A TCP/IP utility that displays the current TCP/IP connectivity status and statistics. Netstat is available on a computer running Microsoft Windows if the TCP/IP protocol stack has been installed on that machine. You can run netstat from the command prompt to get current TCP/IP statistics and connections for the local machine. You can also view statistics on a per-protocol basis for Transmission Control Protocol (TCP), User Datagram Protocol (UDP), Internet Protocol (IP), or Internet Control Message Protocol (ICMP).

Netstat provides information on

  • IP addresses and port numbers of TCP/IP connections, including client and server connections. Either host names or IP addresses can be displayed. For example, netstat -a displays all connections and listening ports (for TCP and UDP).

  • Ethernet statistics, including bytes sent and received, directed and broadcast frames sent and received, discards, and errors.

  • The routing table for the local machine.

NetWare

A network operating system from Novell that is widely used in local area networks (LANs). NetWare was created by Novell in the early 1980s.

NetWare versions 2 and 3 were essentially used for LAN-based file and print servers running the Internetwork Packet Exchange (IPX) protocol that were administered by menu-driven MS-DOS-based utilities such as syscon, filer, fconsole, pconsole, and monitor. NetWare 4 offers a more scalable solution by providing Novell Directory Services (NDS). The hierarchical NDS allows users to locate and access shared resources anywhere on the network regardless of their physical location. NDS supports the TCP/IP protocol and the Windows-based administration tool nwadmin, which replaced most of the menu-driven MS-DOS–based administration tools for managing an entire NetWare 4–based network from a single location. NetWare 4 also supports single-network logon, in which users log on once to the NDS tree, are authenticated, and can then find and access all resources on the network for which they have appropriate permissions. Other internal system enhancements enable NetWare 4 to provide improved performance for file and print services.

NetWare 5, the latest version, includes support for native Internet Protocol (IP), Dynamic Host Configuration Protocol (DHCP), Domain Name System (DNS), and a new multiprocessing kernel with virtual memory support.

TIP

Microsoft Windows NT and Windows 2000 offer many services for interoperating with and migrating from NetWare servers and networks, including the following:

  • NWLink IPX/SPX-Compatible Transport

  • Gateway Service for NetWare (GSNW)

  • Client Services for NetWare (CSNW)

  • File and Print Services for NetWare (FPNW)

  • Migration Tool for NetWare

NetWare Directory Services

See
Novell Directory Services (NDS)

NetWare protocols

The group of protocols developed for and specific to the Novell NetWare network operating system (NOS); popularized in NetWare versions 2 and 3. Some of the networking architecture of NetWare protocols evolved from the Xerox Network Systems (XNS) created in the late 1970s. The more important NetWare protocols that figure prominently in NetWare version 3 include the following:

  • Internetwork Packet Exchange (IPX):
    A network layer (layer 3) protocol that identifies stations and the networks they reside on and can be used to route packets from one network to another on an IPX internetwork.

  • Sequenced Packet Exchange (SPX):
    A transport layer (layer 4) protocol that provides reliable, connection-oriented communication sessions between hosts on a network.

  • NetWare Core Protocol (NCP):
    An upper-layer (layers 5 and 6) protocol that services requests from applications such as the NetWare shell. NCP supports file and print services, management of network and host names, and accounting and security functions.

  • NetBIOS:
    An upper-layer protocol that provides session-layer interoperability with other NetBIOS-enabled operating systems such as LAN Manager and Microsoft Windows NT.

  • Service Advertising Protocol (SAP):
    Enables NetWare servers to advertise themselves as present on the network and allows clients to find and access resources.

NOTE

In addition to these original NetWare protocols, NetWare version 4 also supports Internet Protocol (IP) encapsulation of IPX/SPX packets, which means that IPX datagrams can be encapsulated within User Datagram Protocol (UDP) packets for transmission over TCP/IP internetworks. NetWare 5 has native support for TCP/IP.

Net Watcher

A system tool in Microsoft Windows 95 and Windows 98 for monitoring shared resources on other computers running Windows 95 and Windows 98. You must enable remote administration on the computers to be monitored using the Passwords utility in Control Panel. Net Watcher is the Windows 95 and Windows 98 equivalent of the more powerful Windows NT tool Server Manager and Windows 2000 tool Computer Management.

Net Watcher shows all current connections to a computer running Windows 95 or Windows 98, along with the names of the connected users, the files and printers that are in use, and the level of access granted. An administrator can use Net Watcher to disconnect users from shared resources, close files that are in use, create new shares, and stop sharing existing shares.

Graphic N-2. Net Watcher.
Graphic N-2. Net Watcher.
NOTE

Net Watcher cannot show hidden shares.

Network Access Point (NAP)

A point at which sections of the Internet’s high-speed backbone are connected. Internet service providers (ISPs) are connected at Network Access Points (NAPs) so that they can exchange packets.

How It Works

The backbone of the Internet actually consists of sections of high-speed fiber-optic cabling that are owned by different carriers (including AT&T, Sprint, and MCI WorldCom). NAPs are places at which these carriers interconnect their lines so that the Internet can function as a single entity. NAPs contain high-speed switching facilities for transferring traffic from one carrier’s lines to another’s.

The National Science Foundation originally established four different NAPs in Chicago, New York, San Francisco, and Washington, D.C., but with the growth of the Internet and the changing landscape of telecommunication carrier companies, more NAPs have been created. These include “MAE West” in San Jose and “MAE East” in Washington, D.C., both of which are operated by MCI WorldCom.

To lessen the traffic burden on the Internet’s backbone, major ISPs can connect their services directly to a NAP in the form of a “peering arrangement,” whereby traffic that needs to move between two ISPs connected to the same NAP can move directly from one ISP to the other instead of having to traverse the Internet’s backbone.

network access server (NAS)

A general name for a server at an Internet service provider (ISP) that a dial-up client connects to in order to establish a Point-to-Point Protocol (PPP) connection. Network access servers (NAS’s) provide dial-up entry points for PPP clients to connect to the Internet. They can also be used to tunnel through the Internet to establish a virtual private network (VPN) using the Point-to-Point Tunneling Protocol (PPTP). Another name for a NAS is a point of presence (POP) server.

The NAS is typically responsible for authenticating the dial-up client’s credentials and negotiating flow control and error correction. NAS’s can be general-purpose server computers running specialized NAS software such as Internet Connection Services for Microsoft Remote Access Service (RAS), or they can simply be routers with support for a built-in PPP connection, which are often called “access servers.”

Graphic N-3. Network access server (NAS).
Graphic N-3. Network access server (NAS).

network adapter card

See
network interface card (NIC)

network address translation (NAT)

A form of packet filtering used in firewall products that protects a network from outside intrusion by hackers. Network address translation (NAT) also eliminates the need for an organization to have a set of globally unique IP addresses, thus helping to conserve the available pool of IPv4 addresses for the Internet.

How It Works

NAT is essentially the translation of IP addresses in one network into those for a different network. NAT is usually implemented on firewalls in which one network (the private network) is hidden behind the firewall while the other network (the public network) represents distrusted users from whom the IP addresses of the private network must be hidden.

NAT replaces the internal network IP address for each Internet Protocol (IP) packet passing through the firewall with a dummy one from a fixed pool of addresses. The actual IP addresses of computers on the private network are thus hidden from users outside the firewall. All requests that pass through the firewall have their addresses translated on the way to the private network, and all responses returned to the unsecure public network have their addresses translated back on the way out of the private network.

Implementing NAT on a router or firewall essentially involves creating and configuring a NAT table containing the private/public IP address mappings. These mappings can be statically created or dynamically generated from a specified pool of IP addresses (either randomly or, more often, on a round-robin basis). A static NAT table essentially consists of a series of NAT rules that specify how IP addresses will be translated.

For example, a typical static NAT rule might be equivalent to the statement, “Translate all IP addresses belonging to the network 176.43.8.z to IP addresses in the form 145.5.133.z with the subnet mask 255.255.255.0 used for both networks.” This rule results in the address 176.43.8.1 being mapped to 145.5.133.1, 176.43.8.2 being mapped to 145.5.133.2, and so on.

A dynamic NAT rule might be used when the number of IP addresses that need to be translated is not equal to the number of NAT IP addresses that you can translate to. In this case, if all the NAT IP addresses are being used, external hosts trying to form new connections are rejected. Each time a connection is formed between the external and internal networks, a different NAT IP address is assigned to the internal host being connected to. This effectively hides the network identity of the hosts on the private network from hosts outside the firewall.

Another NAT technique that is frequently implemented on Linux machines is called masquerading. In this situation, all the IP addresses of the internal private network are hidden to outsiders, who can access only the single IP address of the interface exposed to the public network. An arbitrary number of Transmission Control Protocol (TCP) connections can be multiplexed through the single IP address by assigning each connection a different port number (chosen by default from the range 61,000 through 65,096, which allows up to 4096 simultaneous connections).

In addition to securing your private corporate network, NAT also reduces the need to get a block of unique IP addresses from your Internet service provider (ISP). Only the far side of your router or firewall server needs a unique IP address from your ISP—you can use any IP addresses within your network because your private network is securely hidden from the outside world behind your firewall. This reduces costs and helps extend the viability of the current IPv4 system by reducing the number of unique IP addresses required on the Internet. In fact, the original impetus for the development of NAT technologies was the fact that the available pool of unique IPv4 addresses was steadily running out. NAT was viewed as a temporary solution until IPv6 could be standardized and implemented, but the security advantages of using NAT in firewalls has revitalized IPv4 and made migration to IPv6 less urgent.

NAT is defined in Request for Comments (RFC) 1631.

Network and Dial-up Connections

A utility in Microsoft Windows 2000 that allows a client machine to connect to a remote access server or the Internet over a phone line or some other WAN link. (This utility is named Dial-Up Networking in Windows NT, Windows 95, and Windows 98.) In Windows 2000, you can use Network and Dial-up Connections to create

  • A dial-up connection to a Remote Access Service (RAS) server on a private network

  • A Virtual Private Network (VPN) connection over the Internet

  • A direct connection to a second computer using a serial, parallel, or infrared port

You can also use Network and Dial-up Connections to configure a stand-alone computer running Windows 2000 (one that is not part of a domain) to accept incoming connections from other computers.

NOTE

If your Windows 2000–based computer is part of a domain, use the Routing and Remote Access console to configure instead of Network and Dial-up Connections to accept incoming connections.

network architecture

An umbrella term describing the topologies, access methods, protocols, and other technologies used for networking. The following are examples of network architectures for local area networks (LANs):

  • Ethernet:
    By far the most popular network architecture for LANs. Ethernet supports speeds of 10, 100, and 1000 Mbps and is based on the contention method of media access control.

  • Token Ring:
    An architecture developed by IBM. Legacy IBM networks support speeds of 4 and 16 Mbps, although vendors are working on standards for much higher speeds.

  • AppleTalk:
    An architecture developed by Apple for its Macintosh platform that is essentially a protocol suite that can run over Ethernet, Token Ring, or Fiber Distributed Data Interface (FDDI) networks.

  • ARCNET:
    An older LAN architecture developed by Datapoint for small bus topology networks.

network client

Software that runs on a client computer and allows it to establish connectivity with services running on server computers. In Microsoft Windows 95 and Windows 98, the network client is one of several components that can be installed to provide connectivity with different kinds of networks. Without the appropriate client software, a workstation cannot access files and print resources or other resources on a network server.

Windows 95 and Windows 98 include several different network clients:

  • Client for Microsoft Networks, which allows a computer running Windows 95 or Windows 98 to participate in a Windows network and access file and print resources on Windows NT or LAN Manager servers

  • Client for NetWare Networks, which allows a computer running Windows 95 or Windows 98 to participate in a NetWare network and access file and print resources on NetWare servers

  • Clients for Novell, Banyan, and other networks

NOTE

To add or remove a network client, use the Network utility in Control Panel, select the Configuration tab, and click Add.

Network Client 3.0 for MS-DOS

An add-on for MS-DOS that allows MS-DOS-based workstations to use resources such as shared folders, printers, and applications on a Microsoft network. Using Network Client, an MS-DOS-based workstation can participate in both workgroups and Windows NT domains.

Network Client must be installed on a machine that already has MS-DOS installed on it. Network Client has limited support for TCP/IP networking functionality such as Dynamic Host Configuration Protocol (DHCP), Windows Internet Name Service (WINS), and Domain Name System (DNS).

NOTE

You can create installation disks for Network Client using the Network Client Administrator tool in Windows NT.

TIP

If you can’t remember the syntax for Network Client commands when you use the MS-DOS command prompt, type net to load and open the Network Client pop-up command interface.

Network Client cannot function as a master browser, so if you want to browse network resources using Network Client, a master browser must already be installed on the network.

Network Client Administrator

A Microsoft Windows NT administrative tool for installing client software on client machines. You can use Network Client Administrator to

  • Create network installation startup disks for booting a client machine, connecting to a distribution server, and installing a client operating system (such as Windows 95 or Microsoft Network Client 3.0 for MS-DOS). You must configure the disk for the particular network interface card (NIC) used by the client machine.

  • Create a set of installation disks to manually install Microsoft Network Client 3.0 for MS-DOS, Remote Access v1.1a for MS-DOS, TCP/IP-32 for Windows for Workgroups, or LAN Manager 2.2c on client machines.

  • Install tools for administering Windows NT–based servers on machines running Windows NT Workstation, Windows 95, and Windows 98.

  • Share the client-based network administration tools.

  • View remoteboot service information.

network driver interface specification (NDIS)

A standard or specification that simplifies the process of writing drivers for network interface cards (NICs) and enables them to interact transparently with various transport protocols. The network driver interface specification (NDIS) is also a library of routines (or “wrapper”) in Microsoft Windows NT that is implemented through the file ndis.sys, which provides a uniform programming interface between NIC drivers and network protocols. NDIS simplifies the development of drivers for NICs.

NDIS was developed jointly by Microsoft and 3Com in 1989 and has gone through a series of revisions, as shown in the following table. The most recent versions allow one NIC to be bound to many protocols (which is ideal for heterogeneous networks) or allow one protocol to run on a system with multiple NICs (which helps increase network bandwidth for heavily used servers).

NDIS Versions
Version | Platform | 16-bit or 32-bit | Features
2 | Windows for Workgroups and OS/2 | 16 | Real mode; each NIC must have its own driver.
3 | Windows NT 3.5 x | 32 | Unlimited number of NICs can be bound to an unlimited number of protocols.
3.1 | Windows 95 | 32 | A superset of NDIS 3 with plug and play functionality and support for minidrivers. Windows 95 supports up to four NICs in a computer.
4 | Windows NT 4 | 32 | Unlimited number of NICs can be bound to an unlimited number of protocols. Also allows capturing of all frames on local network segment without the need to switch the NIC to promiscuous mode.
5 | Windows 98 and Windows 2000 | 32 | Adds support for connection-oriented networks such as Integrated Services Digital Network (ISDN) or Asynchronous Transfer Mode (ATM), including support for multiple virtual circuits on one network adapter.
See also
I/O Manager

Network File System (NFS)

A client/server distributed file system developed by Sun Microsystems that has become the standard file system for various implementations of the UNIX platform. Network File System (NFS) lets users transparently store and access information on both local and remote computers on a TCP/IP internetwork.

How It Works

NFS uses remote procedure calls (RPCs) running over User Datagram Protocol (UDP) on server port 2049 for stateless communication between clients and file servers on the network. NFS clients (client machines running NFS client software) import remote file systems from NFS servers, while the NFS servers export local file systems to clients.

Machines running the NFS client can connect to NFS servers and read, modify, copy, move, or delete files on the server using RPC requests such as READ, WRITE, CREATE, and MKDIR. To the user accessing the remote file system from the client, the files appear to be stored locally on his or her system.

Before a user can access files within the directory structure on the local UNIX file system of the NFS server, the administrator must mount the portions of the local UNIX file system that will be made accessible to clients and assign appropriate user privileges.

network ID

The portion of an IP address that identifies the TCP/IP network on which a host resides. The network ID portion of an IP address uniquely identifies the host’s network on an internetwork, while the host ID portion of the IP address identifies the host within its network. Together, the host ID and network ID, which make up the entire IP address of a host, uniquely identify the host on a TCP/IP internetwork.

How It Works

The network ID is found by logically ANDing the binary form of the IP address with the binary form of the subnet mask for the network. For example, if a host has an IP address of 172.16.8.55 on a network with a subnet mask of 255.255.0.0 (the default subnet mask), the network ID of the host is 172.16.0.0, or simply 172.16.

TIP

When you assign network IDs to local area networks (LANs) connected by routers, each LAN and each WAN link must have a unique network ID.

See also
host ID

Network Information System (NIS)

A client/server directory services application developed by Sun Microsystems for UNIX. Network Information System (NIS) acts as a kind of “yellow pages” for locating resources on a TCP/IP internetwork, enabling applications or users to locate and access files and applications anywhere in the network using only a single username and password.

How It Works

NIS uses remote procedure calls (RPCs) for communication between clients and servers. NIS client programs access NIS servers to locate resources and authenticate resource access.

A newer version called NIS+ includes additional security features. NIS is often used with the Network File System (NFS).

network interface card (NIC)

An adapter card that plugs into the system bus of a computer and allows the computer to send and receive signals on a network. A network interface card (NIC) is also known as a network adapter card or simply a network card.

How It Works

NICs can be legacy components that require manual configuration of interrupt request (IRQ) and base I/O port settings, or they can be plug and play components. NICs are available for any system bus type: Industry Standard Architecture (ISA), Extended Industry Standard Architecture (EISA), Micro Channel Architecture, and Peripheral Component Interconnect (PCI). PCI cards are 32-bit and give the best performance. They are available in various speeds, such as 10 Mbps for Ethernet and 10/100 Mbps for Fast Ethernet. Other cards are available for networking technologies such as Token Ring and Fiber Distributed Data Interface (FDDI).

A computer can communicate with the NIC using several methods, including memory-mapped I/O, direct memory access (DMA), or shared memory. A parallel stream of data is sent to the card and buffered before being packaged into discrete frames for serial transmission over the network. Framing adds headers and trailers to the data, which contains addressing, clocking, and error-checking information. The frames are then converted to electrical voltage pulses that drive an electrical signal over the wire. The receiving NIC processes the signal in the reverse order into a data stream for the receiving computer. Many of these functions are built into the network firmware, while others are governed by the NIC driver software installed on the computer.

NICs can have one or more connectors for cabling to be attached, such as

  • RJ-45 connector for twisted-pair cabling (the most common type)

  • BNC connector for thinnet cabling

  • DB15 connector for connecting drop cables to thicknet cabling

network layer

Layer 3 of the Open Systems Interconnection (OSI) reference model for networking. The network layer is responsible for functions such as the following:

  • Logical addressing and routing of packets over the network

  • Establishing and releasing connections and paths between two nodes on a network

  • Transferring data, generating and confirming receipts, and resetting connections

The network layer also supplies connectionless and connection-oriented services to the transport layer above it. The network layer functions closely with the physical layer (layer 1) and data-link layer (layer 2) in most real-world network protocol implementations.

On TCP/IP-based networks, IP addresses and network numbers are used at the network layer, and IP routers perform their routing functions at this layer. An example of an OSI model network layer protocol is the X.25 packet-switching network layer protocol, which is built on the X.21 physical layer protocol.

See also
Open Systems Interconnection (OSI) reference model

Network Monitor

A Microsoft Windows 2000 and Windows NT administrative tool that functions as a software-based network packet analyzer for troubleshooting network problems. You can use Network Monitor to

  • Capture data frames from a connected network

  • Display, filter, edit, and retransmit frames on the network

  • Monitor and display protocol statistics

  • Examine individual captured frames in detail

    Graphic N-4. Network Monitor.
    Graphic N-4. Network Monitor.
NOTE

The version of Network Monitor included with Windows NT is a simplified version that lacks some of the features in the full version included with Microsoft Systems Management Server (SMS). In particular, the simplified version can perform only local capturing of data to and from the computer running Network Monitor.

Network Monitor Agent

A Microsoft Windows NT service that allows a computer to capture all traffic on the local network segment, which it can then collect centrally and display on a computer running Network Monitor. Network Monitor Agent also provides the Network Segment object for Performance Monitor. You can install Network Monitor Agent in Windows NT, and you can install a similar service in Windows 95 and Windows 98, by using the Network utility in Control Panel. (See the Admin folder on the Windows 95 or Windows 98 CD.)

NOTE

To install Network Monitor Agent in Windows NT, use the Network utility in Control Panel. Then use the Network Monitor Agent utility in Control Panel to configure, capture, and display packets to prevent unauthorized monitoring of your server. Installing Network Monitor Agent also enables the Network Segment object in Performance Monitor.

Network Neighborhood

A desktop icon in Microsoft Windows NT, Windows 95, and Windows 98 that allows users to browse shared network resources on their computers. Using Network Neighborhood, you can browse resources on the network in the same way that you use My Computer to browse the resources on your local machine. These two tools provide complementary views of system and network resources to those provided by Windows Explorer.

When you open Network Neighborhood to view the connected network, you see all the computers in your present domain or workgroup, plus an entity called Entire Network. You can open Entire Network to browse resources on all the connected networks that your computer is aware of.

TIP

If you know your network domain settings are correct and you try to browse Network Neighborhood but only the Entire Network icon is visible, and if when you double-click on the Entire Network icon you get an error message saying “Unable to browse the network,” your network cable might have come loose from its network interface card (NIC).

See also
My Computer, My Network Places

Network News Transfer Protocol (NNTP)

An Internet standard protocol that governs the interaction between Network News Transfer Protocol (NNTP) servers (news servers) and NNTP clients (news readers). NNTP is the underlying protocol on which the Usenet Internet news system is built.

How It Works

NNTP is both a client/server protocol and a server/server protocol. It offers a set of simple text commands that

  • Enable NNTP clients such as Microsoft Outlook Express and Microsoft Internet Mail and News to use TCP port number 119 to connect to an NNTP service or daemon running on an NNTP server and download a list of newsgroups, read the messages in a newsgroup, or post a new message to a newsgroup.

  • Enable NNTP servers such as Internet Information Server (IIS) 4 running the NNTP Service or Microsoft Exchange Server 5.5 running the Microsoft Exchange Internet News Service to connect to other NNTP servers on the Internet and replicate newsgroups and their content among each other. This replication process between NNTP servers (or hosts, as they are called) forms the basis of the worldwide news system called Usenet.

NNTP connections between clients and servers and between servers and servers use Transmission Control Protocol (TCP) for reliable, guaranteed packet delivery. Clients connecting to servers might require authentication before their NNTP commands are accepted.

NNTP client commands include the following:

  • LIST:
    To obtain a list of newsgroups available on the server

  • GROUP:
    To select a specific newsgroup

  • ARTICLE:
    To display a selected message

  • POST:
    To post a new message or reply to an existing one

NNTP is defined in Request for Comments (RFC) 977.

network numbers

Numbers that you must configure to ensure proper network communication when you configure the NWLink IPX/SPX-Compatible Transport protocol for Microsoft Windows NT and Windows 2000. You must configure two different network numbers to ensure proper network communication:

  • The Internetwork Packet Exchange (IPX) network number (also known as the external network number), a unique number assigned to all computers on the same network segment that are using the same NWLink frame type. In Windows 2000 Server, you configure this number by accessing the NWLink IPX/SPX/NetBIOS Compatible Transport Protocol property sheet, selecting Manual Frame Type Detection, clicking Add, and entering the number.

  • The virtual network number (also known as the internal network number), a unique number assigned to a machine that enables it to be used in a multiple network environment. This number is hexadecimal 0 by default; in Windows 2000, you can configure it by specifying it on the NWLink IPX/SPX/NetBIOS Compatible Transport Protocol property sheet.

NOTE

For the TCP/IP protocol for Windows NT and Windows 2000, the network number is usually referred to as the network ID.

TIP

To view the IPX network number of a computer running Windows NT or Windows 2000, type ipxroute config at the command prompt.

network of computers

A group of computers connected in some fashion in order to share resources. Networks with enhanced storage and server-based processing power provide users with greater functionality and security than independent or stand-alone machines.

Networks can be classified based on

  • Physical size:
    They can be classified as local area networks (LANs), metropolitan area networks (MANs), or wide area networks (WANs).

  • Topology:
    Topologies (the manner and complexity of interconnections) include the bus topology, star topology, ring topology, and mesh topology.

  • Security:
    Networks can be based on workgroups, in which all machines control their own security, or they can be based on servers (such as domain-based Microsoft Windows 2000 networks).

  • Network architecture:
    For example, networks can be classified as Ethernet, Token Ring, or Fiber Distributed Data Interface (FDDI) networks.

  • Primary protocol:
    Networks can be classified as Internet Protocol (IP) networks, Internetwork Packet Exchange (IPX) networks, Systems Network Architecture (SNA) networks, and so on.

NOTE

In TCP/IP networking, a network is a group of hosts with the same network ID. Multiple networks can be combined using routers to form an internetwork. Each network in an internetwork can be referred to as a subnetwork.

network operating system (NOS)

Also called server operating system, a computer operating system that is network-aware. Network operating systems (NOS’s) typically provide support for features such as the following:

  • File and printer sharing

  • Data security and authentication

  • Distributed applications

  • Messaging

  • Centralized administration

You can use a NOS to create local area networks (LANs) that function as either peer-to-peer networks or server-based networks, depending on your needs and budget. Examples of NOS’s include Microsoft Windows NT, Novell NetWare, and Banyan VINES. Cisco’s Internetwork Operating System (IOS) is an example of a NOS that runs not on computers but on internetworking devices such as routers.

network protocol

A protocol that operates at the network layer (layer 3) of the Open Systems Interconnection (OSI) reference model for networking. Common network protocols include the following:

  • Internet Protocol (IP):
    Part of the TCP/IP protocol suite for connectivity with the Internet

  • Internetwork Packet Exchange (IPX):
    A Novell NetWare protocol

  • NetBEUI:
    A protocol developed from NetBIOS that functions at both the network and transport layers

Microsoft 32-bit Windows operating systems are implemented in a layered fashion that allows multiple network protocols to be bound to multiple network interface cards (NICs) and allows multiple network clients and services to access these protocols. Windows computers can thus establish connectivity and interoperability with non-Microsoft operating system platforms such as UNIX and Novell NetWare.

network resources

See
resource on a network

networks file

A text file that provides a local method of resolving network names into their network IDs on a TCP/IP network. The entries in the networks file are friendly names for TCP/IP networks; they can be used in TCP/IP commands such as the route command and for TCP/IP network management.

How It Works

The networks file is at the following location on computers running Microsoft Windows:

  • Windows NT and Windows 2000: %SystemRoot%\system32\drivers\etc

  • Windows 95 and Windows 98: \Windows

Each line in the networks file contains a friendly network name for the network, followed by the IP address of the network and an optional comment prefixed with a pound sign (#). The following example is from the sample networks file included with Windows 95 and Windows 98:

loopback     127
campus       284.122.107
london       284.122.108
See also
hosts file, lmhosts file, protocol file, services file

Network system group

A special identity or system group that exists on all servers and workstations running Microsoft Windows NT and Windows 2000. The Network group includes any user who has successfully connected to a shared resource on the computer from over the network. The group enables network users to access resources on the computer, in contrast to the Interactive group, which enables locally logged-on users to access resources on the machine.

Administrators cannot modify system groups. This means that they cannot directly modify membership in the Network group or the rights of the group.

See also
built-in group

Network Termination Unit (NTU)

A device for connecting digital Integrated Services Digital Network (ISDN) customer premises equipment to ISDN lines. The Network Termination Unit (NTU) allows customer premises equipment to be connected to the switching equipment at the telco’s central office (CO).

How It Works

Digital ISDN customer premises equipment such as routers and ISDN phones usually have an ISDN S/T interface, while the ISDN termination at the customer end of the local loop usually has a U interface using an RJ-45 connector. The NTU converts the U termination of the ISDN line to one or more standard coding S/T interfaces that are suitable for connecting digital ISDN-ready phones, routers, and other devices to an ISDN line. NTUs work differently than ISDN terminal adapters, which allow you to connect analog telephones, faxes, and similar equipment to your ISDN line. NTUs typically support either point-to-point or multipoint connections over distances of up to 5.4 kilometers on 26 AWG copper twisted-pair cabling.

NOTE

Some newer ISDN-enabled devices have a built-in U interface, making an NTU unnecessary. The following table shows the differences between the Basic Rate ISDN U and S/T interfaces.

Basic Rate ISDN U Interfaces vs. Basic Rate ISDN S/T Interfaces
Property | U Interface | S/T Interface
Number of wires | 2 | 4
Connector | RJ-45 | RJ-45
Zero-to-peak voltage | 2.5 V | 0.75 V
Line coding | 2B1Q (or 4B3T in Europe) | ASI (Alternate Space Inversion)
See also
Integrated Services Digital Network (ISDN)

network utilization

The percentage of available bandwidth being used in a network. For Ethernet networks, a network utilization of 40 to 60 percent is normally the maximum; higher utilization results in more collisions and retransmissions. Another word that describes network utilization is “throughput,” which is typically measured in Mbps or MB/sec.

newsfeed

Information sent from one Usenet host to another to replicate newsgroup listings and content. Newsfeeds are an essential part of the Usenet architecture; they allow news servers all over the Internet to exchange lists of newsgroups and messages. Usenet newsfeeds come in two types:

  • Push feed:
    Initiated by the remote host. This type is usually used when the newsfeed is very large.

  • Pull feed:
    Initiated by the local host. This type gives the local host more control over what to download.

The host that provides the newsfeed is called the inbound host; the host that receives the newsfeed is called the outbound host.

NOTE

Microsoft Exchange Server supports downloading Usenet newsfeeds through the Internet News Service.

newsgroup

A collection of posted messages on a Network News Transfer Protocol (NNTP) server. Newsgroups contain postings on a particular topic, although they are often a prime target for spammers who post unsolicited advertisements. Newsgroups are defined hierarchically using a dotted notation. An example of a newsgroup is alt.books.computing, which is an “alternative” group that discusses books about computing. The dotted notation of the newsgroup name emphasizes the hierarchical structure of the Usenet system of newsgroups. For example,

  • alt is the root of the hierarchy of alternative newsgroups.

  • alt.books refers to either a newsgroup on alternative books or a collection of such newsgroups.

  • alt.books.cooking refers to either a newsgroup of alternative cookbooks or to a collection of such newsgroups.

Newsgroups can be either moderated or unmoderated. In moderated newsgroups, all messages posted to the newsgroup are first sent to the newsgroup moderator, who accepts or rejects messages depending on their relevance to the group’s focus. Unmoderated groups are generally a free-for-all, although politeness dictates that users post only messages related to the newsgroup’s focus.

TIP

When you first join a newsgroup, it’s a good idea to “lurk” in the background for a while and read the postings to understand the focus and tone of the group. Posting off the topic or at too low a level in an advanced group can lead a “newbie” to get flamed.

See also
Usenet

NEXT

See
near-end crosstalk (NEXT)

Next Generation I/O (NGIO)

A specification from the Next Generation I/O (NGIO) Forum that is designed to replace the Peripheral Component Interconnect (PCI) system bus. With today’s Pentium III processors and high-speed hard disks, the PCI bus is rapidly becoming the bottleneck that limits the performance of high-speed data center servers. The PCI bus is limited to about 500 Mbps of shared throughput. It lacks an error-detection mechanism and has relatively high latency. NGIO is intended to overcome these limitations. It uses a channel-based architecture that supports full-duplex transmission speeds of up to 2.5 Gbps.

NOTE

The NGIO Forum recently combined its efforts with a group called Future I/O, which was promoting a different standard. The combined standard will be called System I/O; its development group is headed by Intel and IBM and includes Microsoft, Sun Microsystems, Hewlett-Packard, and Dell. System I/O is expected to reach the server market in the year 2001. It will use a channel-based I/O architecture instead of a bus architecture and will use from 1 to 12 wires, each having a throughput of 2.5 Gbps. The channel-based architecture will allow different channels to carry different information to different components simultaneously, which will be a great improvement over parallel-transmission bus technologies. System I/O will also fully support hot-swapping of components.

On the Web
•
NGIO Forum
: http://www.ngioforum.org

NFS

See
Network File System (NFS)

NGIO

See
Next Generation I/O (NGIO)

NIC

See
network interface card (NIC)

NIS

See
Network Information System (NIS)

NIST

See
National Institute of Standards and Technology (NIST)

NNTP

See
Network News Transfer Protocol (NNTP)

NNTP service

A Microsoft Windows 2000 or Windows NT service that is installed on Windows 2000 Server by default and installed when Microsoft Internet Information Server (IIS) version 4 is set up on Windows NT. The NNTP service, which you manage using Microsoft Management Console (MMC), hosts Usenet-style newsgroups and allows news readers such as Microsoft Outlook Express and Microsoft Internet Mail and News to access those newsgroups and post messages to them.

Features of the NNTP service on IIS include the following:

  • Security that is based on access control lists (ACLs) and NTFS

  • Different methods of NNTP client authentication, including Basic Authentication, Anonymous Access, Challenge/Response (NTLM), Microsoft Commercial Internet System (MCIS), and Secure Sockets Layer (SSL) authentication

  • Integration with Event Viewer, Windows NT’s Performance Monitor, Windows 2000’s System Monitor, and other standard Windows NT and Windows 2000 monitoring and troubleshooting tools

  • Support for different content types, including text, HTML, GIF, JPEG, and MIME

  • Integration with Microsoft Indexing Service to enable searching of newsgroup message content

  • Management using MMC or from a Web browser

TIP

The NNTP service on IIS 4 can use virtual directories to make locating newsgroup content easier.

node

A general term for a device on a network that has a specific physical or logical address or can recognize addresses. Nodes can be computers, repeaters, bridges, or other devices on a network that can transmit, receive, or process signals. Another name for a node, especially on Ethernet networks, is a station.

Other common meanings of the term “node” include

  • A domain or subdomain in the namespace of the Domain Name System (DNS)

  • An object in the console hierarchy of Microsoft Management Console (MMC)

  • In Microsoft Cluster Server (MSCS) terminology, an independent computer system running Windows NT Server, Enterprise Edition, that is a member of a cluster

noise

Undesirable random electrical transmission on network cabling that is generated by networking components such as network interface cards (NICs) or induced in cabling by proximity to electrical equipment that generates electromagnetic interference (EMI). Noise is generated by all electrical and electronic devices, including motors, fluorescent lamps, power lines, and office equipment, and it can interfere with the transmission of signals on a network. The better the signal-to-noise ratio of an electrical transmission system, the greater the throughput of information on the system.

TIP

You can generally reduce noise by using higher-quality components, lowering the temperature of components, or using shielded cabling. Be sure to locate sensitive networking components and cabling away from heavy machinery, generators, motors, and other equipment that can generate a lot of EMI. Also be sure to terminate cables properly at patch panels and wall plates to minimize noise due to crosstalk.

See also
signal

normal backup

A backup type in which all the selected files and folders are backed up. Also known as full backup, this is the most secure way of backing up files and folders to tape. In a normal backup, the archive attribute is marked for each file and folder that is backed up. If the file is later modified, the archive attribute is cleared, indicating that the file needs to be backed up again. Normal backups are the safest form of backup but take the longest and use the most tape. They are also the easiest form of backup to perform a restore from, because you generally need only one tape to perform the restore (unless the amount of information to be backed up exceeds the capacity of the tape).

TIP

A good backup plan consists of at least one normal backup each week, with either incremental or differential backups during the rest of the week.

See also
backup, backup type

NOS

See
network operating system (NOS)

Novell Directory Services (NDS)

A distributed network directory service for managing network resources such as users, servers, and peripherals that is loosely modeled after the X.500 specification. Novell Directory Services (NDS) was originally called NetWare Directory Services.

How It Works

The foundation of NDS is the directory tree, which provides a hierarchical view of all network resources. Resources in the network can be grouped logically according to their location, function, or the structure of the company. Objects in the tree can be either containers or leaf objects, with the root container being the name of the company or organization. Containers can be considered branches and can hold leaf objects or other containers. When a user is assigned access rights to a container, these rights flow down into any subcontainers within the container. Trees, subtrees, and containers can also be renamed and merged.

You can implement NDS directories as a distributed database that is partitioned among multiple NDS servers on the network to provide fault tolerance and load balancing. As a result, no single server contains or is responsible for the entire directory. The NDS servers replicate with each other to ensure that each server contains an up-to-date version of the directory for the portion of the directory that the server is responsible for. To locate an object such as a user, a group, a shared directory, or a printer on the network, an NDS client can access the directory on any NDS server.

NOTE

NDS was originally tied to the NetWare 4 operating system, but it is now available for other platforms, including UNIX and Microsoft Windows NT.

nslookup command

A TCP/IP utility on Microsoft Windows NT and Windows 2000 for diagnosing problems with name servers at the command prompt. Nslookup is installed on a computer running Windows NT or Windows 2000 when you install the TCP/IP protocol on the machine. You can use nslookup to manually display resource records in the zone files of DNS servers. The utility can operate in either an interactive or a noninteractive mode.

You enter interactive mode by typing nslookup at the command prompt. Once in the interactive running state, you can type ls -d microsoft.com to list all the resource records for the microsoft.com domain that are stored in the DNS database of the name server being queried.

NS record

See
name server (NS) record

NTFS file system

An advanced, high-performance file system designed for use with the Microsoft Windows NT and Windows 2000 operating systems. NTFS is superior to the file allocation table (FAT) file system in many respects, providing better performance, reliability, and compatibility. NTFS includes security features for data access control and ownership privileges that make it suitable for file servers, Web servers, and application servers in the corporate networking environment. The following table shows a comparison between the features of NTFS and FAT.

NTFS Compared with FAT
Feature | NTFS | FAT
Local security | x |
File-level access permissions | x |
Automatic recoverability using lazy writes and transaction logging | x | Lazy writes only
File-level compression | x |
POSIX-compliant | x |
Supports Services for Macintosh | x |
Dual boot with Windows 95 and Windows 98 |  | x
Maximum volume size | 232 = 4 GB | 264 = 32 EB (theoretical) 241 = 2 TB (practical)
Optimal volume size | Less efficient for volumes over ~500 MB | Less efficient for volumes under ~50 MB
How It Works

Like FAT, NTFS uses the cluster as the fundamental unit of disk space allocation. The default size of the clusters for an NTFS volume depends on the size of the volume, as shown in the table. When you create a new NTFS volume by formatting a disk partition with NTFS, the master file table (MFT), which contains information concerning all the files and folders stored on the volume, is created. The MFT is located on the disk immediately after the partition boot sector, which contains the BIOS parameter block and the code that enables the operating system to find and load the startup files. After the MFT comes NTFS system files, which help implement NTFS by storing information such as the contents of the volume, volume name and version, table of attribute names and numbers, a list of transaction steps used for NTFS recoverability, the root folder, and so on. After the NTFS system files is the file area where user data can be stored. The total overhead of the MFT and NTFS system files is about 1 MB.

Graphic N-5. Structure of an NTFS volume.
Graphic N-5. Structure of an NTFS volume.
Default Cluster Sizes for NTFS
Volume Size | Sectors/Cluster | Cluster Size
512 MB or less | 1 | 512 bytes
513 KB–1024 MB | 2 | 1 KB
1025 MB–2048 MB | 4 | 2 KB
2049 MB–4096 MB | 8 | 4 KB
4097 MB–8192 MB | 16 | 8 KB
8193 MB–16384 MB | 32 | 16 KB
16385 MB–32768 MB | 64 | 32 KB
32769 MB or more | 128 | 64 KB
NOTE

NTFS on Windows 2000 includes additional features not supported by NTFS on Windows NT. These features are used to provide greater manageability and enhanced security, and to support the new Active Directory of Windows 2000. They include the following:

  • Multiple data streams:
    Allow libraries of files to be defined as alternate streams

  • Reparse points:
    Alter the way NTFS resolves path names

  • Change journal:
    Provides a persistent log of all changes made to files on the volume

  • Encryption:
    Allows data to be stored in encrypted form

  • Sparse file support:
    Allows programs to create very large files while consuming disk space only as needed

  • Disk quotas:
    Allow administrators to control how much disk space users have access to

Note that Windows NT 4.0 systems must be running Service Pack 4 or later to read basic volumes formatted using the Windows 2000 version of NTFS. Also, because of the different disk structures, Windows NT 4 disk utilities such as autochk and chkdsk will not work on Windows 2000 NTFS volumes. Because of these incompatibilities, Microsoft does not recommend dual booting between Windows NT 4 and Windows 2000.

TIP

Here are some recommendations for installing Windows NT Server on a system:

  • Partition your hard disk into at least two volumes, or use two or more separate hard drives.

  • Your C volume, which contains the operating system, should be 250 to 500 MB in size and formatted with FAT. This gives you a back door for replacing missing or corrupt system files by using an MS-DOS boot disk. If you change your mind later and want to better secure C using NTFS, you can convert a FAT volume to NTFS by using the convert command.

  • Your other volumes, which contain your application files and data files, should be formatted in NTFS. This gives the files the greater protection that NTFS provides and offers you greater control over access to data shared over the network.

For installing Windows 2000 Server on a system, Microsoft recommends using NTFS for the C partition. You should have a minimum of 1.2 GB of free space on this partition, but at least 2 GB free is recommended.

NTFS permissions (Windows 2000)

A set of permissions used in Microsoft Windows 2000 to secure folders and files located on an NTFS file system partition or volume. NTFS permissions provide security for both local and network access to the file system. They are different from shared folder permissions, which can be applied only to folders and which secure the file system for network access only, not for local access.

How It Works

NTFS permissions in Windows 2000 differ depending on whether they are applied to files or to folders. The five standard file permissions and six standard folder permissions are listed in the following tables. These standard file and folder permissions are actually composed of various groupings of the 18 different special permissions—for more information, see the entry on NTFS special permissions (Windows 2000). These groupings simplify the job of securing files and folders on NTFS file system partitions and volumes.

Standard NTFS File Permissions in Windows 2000
File Permission | User Access Granted
read | Open the file and view its permissions, attributes, and ownership
write | Modify the file, modify its attributes, and view its permissions, attributes, and ownership
read & execute | Delete the file and do everything read permission allows
modify | Delete the file and do everything read & execute and write permissions allow
full control | Take ownership, modify permissions, and do everything modify permission allows
Standard NTFS Folder Permissions in Windows 2000
Folder Permission | User Access Granted
read | View contents of folder and view its permissions, attributes, and ownership
write | Create new files and folders in the folder, modify its attributes, and view its permissions, attributes, and ownership
list folder contents | View contents of folder
read & execute | View subfolders within the folder and do everything read and list folder contents permissions allow
modify | Delete the folder and do everything read & execute and write permissions allow
full control | Take ownership, modify permissions, and do everything modify permission allows

To use these standard permissions to secure a file or folder you must be the object's owner, have full control of the object, or be a member of the Administrators system group. You must explicitly assign a permission to a file or folder for the permission to be granted. If no permission is specified for a given user or group, the user or group has no access to the file or folder. When you explicitly assign a permission you can choose to either allow or deny the permission.

When you create a file or folder on an NTFS file system volume, it inherits the permissions of its parent folder or volume. When you assign a permission to a parent folder or volume, you have the option of propagating that permission to all of its child folders and files.

The following rules apply to assigning permissions for files and folders on NTFS file system volumes:

  • If a user belongs to two or more groups and the groups have different permissions on a given folder, the user’s effective permission is the least restrictive (most permissive) of the permissions. For example, if a user has read permission on a file and a group the user belongs to has modify permission, the effective permission is modify, which is the least restrictive of the two.

  • A permission explicitly denied overrides a similar permission explicitly allowed. For example, if a user has read permission on a file and a group the user belongs to has been denied read permission, the user cannot open and read the file.

  • A permission for a file overrides a similar permission for the folder containing the file. For example, if a user has modify permission on a file and read permission on the folder containing the file, the user can open, read, edit, and save changes to the file.

NOTE

The differences between NTFS standard permissions for Windows 2000 and for Windows NT include the following:

  • Windows 2000 has six folder permissions; Windows NT has seven.

  • Windows 2000 has five file permissions; Windows NT has four.

  • In Windows 2000 you can explicitly grant or explicitly deny any standard file or folder permission. In Windows NT you can only explicitly grant a permission (but you can explicitly grant no access as a permission).

TIP

When you format a partition or volume using NTFS, the Everyone system group is automatically assigned full control permission for the root of the volume. Any new files or folders you create on the volume inherit this permission. Be aware that leaving full control for everyone might create a security risk; you should replace it with more suitable permissions such as full control for the Authenticated Users special identity.

See also
NTFS permissions (Windows NT), NTFS special permissions (Windows 2000), NTFS special permissions (Windows NT)

NTFS permissions (Windows NT)

A set of permissions used in Microsoft Windows NT to secure folders and files on an NTFS file system partition. NTFS permissions provide security for both local and network access to the file system. They are different from shared folder permissions, which can be applied only to folders and which secure the file system for network access only, not for local access.

How It Works

NTFS permissions in Windows NT differ depending on whether they are applied to files or to folders. The four standard file permissions and seven standard folder permissions are listed in the following tables. These standard file and folder permissions are actually composed of various groupings of six NTFS special permissions:

  • read (R)

  • write (W)

  • execute (X)

  • delete (D)

  • change permission (P)

  • take ownership (O)

For more information on these special permissions, see the entry on NTFS special permissions (Windows NT).

Standard NTFS File Permissions in Windows NT
File Permission | Special Permissions
full control | RWXDPO
change | RWXD
read | RX
no access | None
Standard NTFS Folder Permissions in Windows NT
Folder Permission | Special Permissions for Folders | Special Permissions for Files in a Folder
full control | RWXDPO | RWXDPO
change | RWXD | RWXD
add & read | RWX | RX
add | WX | Unspecified
read | RX | RX
list | RX | Unspecified
no access | None | None

To use these standard permissions to secure a file or folder you must be the object’s owner, have full control of the object, or be a member of the Administrators system group. You must explicitly assign a permission to a file or folder for the permission to be granted. If no permission is specified for a given user or group, the user or group has no access to the file or folder.

When you create a file or folder on an NTFS file system partition, it inherits the permissions of its parent folder or partition. When you assign a permission to a parent folder or partition, you have the option of propagating that permission to all of its child folders and files.

The following rules apply to assigning permissions for files and folders on NTFS file system volumes:

  • If a user belongs to two or more groups and the groups have different permissions in a given folder, the user’s effective permission is the least restrictive (most permissive) of the permissions. For example, if a user has read permission on a file and a group the user belongs to has change permission, the effective permission is change, which is the least restrictive of the two.

  • The no access permission overrides all other permissions. For example, if a user has read permission on a file and a group the user belongs to has no access permission, the user cannot open and read the file.

  • A permission for a file overrides a similar permission for the folder containing the file. For example, if a user has change permission on a file and read permission on the folder containing the file, the user can open, read, edit, and save changes to the file.

NOTE

For a description of the differences between NTFS standard permissions for Windows 2000 and for Windows NT, see the entry on NTFS permissions (Windows 2000).

TIP

In most cases NTFS standard permissions are sufficient for controlling access to a file or folder. If standard permissions are not sufficiently granular for your purposes, you can use NTFS special permissions.

See also
NTFS permissions (Windows 2000), NTFS special permissions (Windows 2000), NTFS special permissions (Windows NT)

NTFS special permissions (Windows 2000)

Individual permissions granted or denied when NTFS file system standard permissions are not sufficiently granular for specific security purposes. The special permissions available depend on whether you are securing files or folders. In both cases, 14 special permissions are available; 10 of these are common to the two scenarios. The following tables list the various NTFS special permissions available in Microsoft Windows 2000.

NTFS Special Permissions for Both Files and Folders in Windows 2000
Special Permission | User Access Granted
read attributes | View the attributes (including read-only, hidden, system, and archive) of the file or folder
read extended attributes | View custom attributes that can be defined by certain applications for the file or folder
write attributes | Modify the attributes of the file or folder
write extended attributes | Modify custom attributes that can be defined by certain applications for the file or folder
delete subfolders and files | Delete subfolders or files
delete | Delete the file or folder; however, even if this permission is denied on a file, you can delete it if its parent folder has been granted delete subfolders and files permission
read permissions | View the permissions on the file or folder
change permissions | Modify the permissions on the file or folder
take ownership | Take ownership of the file or folder
synchronize | Lets threads in multithreaded programs wait on the file or folder handle and synchronize with another thread that signals it
NTFS Special Permissions Only for Files in Windows 2000
Special Permission | User Access Granted
execute file | Execute the file
read data | Read the file
write data | Modify the file
append data | Append to the file (but not modify existing data)
NTFS Special Permissions for Folders in Windows 2000
Special Permission | User Access Granted
traverse folder | Drill down to other files and folders in the folder even if you have no permissions on intermediate subfolders
list folder | View the names of subfolders and files in the folder
create files | Create files in the folder
create folders | Create subfolders within the folder
How It Works

You can grant or deny special permissions by using the Advanced button on the Security tab of a file’s or folder’s property sheet. You can select different combinations of special permissions to create custom sets of permissions for special purposes. In most cases, however, it is simplest to use NTFS standard permissions for securing files and folders. If you use special permissions, Windows 2000 gives you a lot of flexibility in how you can apply them, especially if you are applying them to a folder. For example, you can apply a custom set of special permissions to

  • The selected folder only

  • The selected folder, its subfolders, and files

  • The selected folder and its subfolders only

  • The selected folder and its files only

  • Subfolders and files of the selected folder but not the folder itself

  • Subfolders of the selected folder but not the folder itself

  • Files in the selected folder but not the folder itself

To use special permissions you must be the object’s owner, have full control of the object, or be a member of the Administrators group.

NOTE

There are significant differences between NTFS special permissions for Windows 2000 and for Windows NT. The most obvious difference is that in Windows 2000 you can assign any of 14 special permissions, but in Windows NT you have 6 special permissions to choose from: read (R), write (W), execute (X), delete (D), change permission (P), and take ownership (O). The reason for this difference is that in Windows NT much of the machinery of NTFS is hidden from the user interface, while in Windows 2000 this machinery is exposed in the user interface.

See also
NTFS permissions (Windows 2000), NTFS permissions (Windows NT), NTFS special permissions (Windows NT)

NTFS special permissions (Windows NT)

Individual permissions granted or denied when NTFS file system standard permissions are not sufficiently granular for specific security purposes. The special permissions available are the same whether you are securing files or folders, with the exception that when you secure a directory you have the additional option of leaving access unspecified instead of assigning a specific set of special permissions. In both cases, six special permissions are available; these are listed in the following table.

NTFS Special Permissions in Windows NT
Special Permission | Abbreviation | User Access When Applied to Files | User Access When Applied to Folders
read | R | View file owner and permissions Read the file | View contents of the folder View folder attributes View folder owner and permissions
write | W | View file owner and permissions Modify file attributes Edit the file | Add files to the folder Add subfolders Modify folder attributes View folder owner and permissions
execute | X | View file owner and permissions Modify file attributes Run the executable file | View folder attributes Browse folder hierarchy View folder owner and permissions
delete | D | Delete the file | Delete the folder
change permission | P | Change file permissions | Change folder permissions
take ownership | O | Take ownership of the file | Take ownership of the folder
How It Works

By selecting different combinations of special permissions, you can create custom sets of permissions for special purposes. In most cases, however, NTFS standard permissions are sufficient for securing files and folders. To use special permissions you must be the object’s owner, have full control of the object, or be a member of the Administrators system group. For information on which sets of special permissions comprise the various standard permissions, see the entry on NTFS permissions (Windows NT).

NOTE

For a description of the differences between NTFS special permissions for Microsoft Windows NT and for Microsoft Windows 2000, see the entry on NTFS special permissions (Windows 2000).

See also
NTFS permissions (Windows 2000), NTFS permissions (Windows NT), NTFS special permissions (Windows 2000)

NTLM protocol

See
Windows NT Challenge/Response Authentication

NTU

See
Network Termination Unit (NTU)

NTVDM

See
NT Virtual DOS Machine (NTVDM)

NT Virtual DOS Machine (NTVDM)

A single-threaded Win32 application that simulates an MS-DOS environment on a Microsoft Windows NT system to enable the system to properly run MS-DOS and Windows 3.x applications. Each MS-DOS-based application running on Windows NT requires its own NT Virtual DOS Machine (NTVDM). As a result, if an MS-DOS-based application fails while running on Windows NT, it does not affect other MS-DOS-based applications.

How It Works

You can customize the NTVDM for an MS-DOS-based application by right-clicking on the application’s executable file and choosing Properties. The settings you can configure are similar to those available in the Windows 3.x tool PIF Editor.

null modem cable

A serial cable with cross-pinning that is used for file transfers and for other specialized communication between computers.

How It Works

Null modem cables, also known as file transfer cables, are used to directly connect two computers for transferring files between them—for example, by using the Direct Cable Connection accessory of Microsoft Windows 95 and Windows 98.

The most common form of null modem cable is based on the RS-232 serial transmission interface specifications. Pins 2 and 3 are crossed in a null modem cable to allow you to directly link two RS-232 serial ports on different computers. Other pins can also be crossed depending on the intended purpose of the cable. The most common forms of termination for these cables are DB9 and DB25 connectors.

Serial RS-232 null modem cables support distances of up to about 15 meters and can be used for any communication for which a direct DTE-to-DTE connection or DCE-to-DCE connection is required. If longer distances are needed in serial communication, you can use a line driver to amplify the signal up to several kilometers. A cable connecting two pieces of data terminal equipment (DTE) is specifically called a null modem cable, while a cable connecting two pieces of data communications equipment (DCE) is usually called a tail-circuit cable and has a different cross-pinning. You can obtain null modem cables for other serial interfaces such as V.35 and those with special types of pinning.

NOTE

Parallel data-transfer cables achieve faster data transfer rates for file transfer than serial null modem cables.

TIP

Use a shielded null modem cable to extend distances up to 30 meters without using line drivers.

NWLink

See
NWLink IPX/SPX-Compatible Transport

NWLink IPX/SPX-Compatible Transport

Commonly referred to as “NWLink,” a Windows NT networking protocol that is Microsoft’s version of IPX/SPX, the protocol used in Novell NetWare. NWLink is a 32-bit networking protocol for Windows NT. It is primarily used when

  • Microsoft clients such as Windows NT Workstation require access to NetWare file, print, and application servers. Windows NT Workstation clients can access NetWare file and print services directly using Client Services for NetWare (CSNW) or through a Windows NT–based server acting as a gateway using Gateway Service for NetWare (GSNW).

  • NetWare clients need access to Windows NT servers. NetWare clients can access file and print services on a Windows NT server by installing File and Print Services for NetWare (FPNW) on the Windows NT server.

NWLink includes the following features:

  • Compliance with Network Driver Interface Specification (NDIS) 4

  • Support for NetBIOS over NWLink (NWLink NetBIOS)

  • Support for the following IPC mechanisms: Windows Sockets, named pipes, and remote procedure calls (RPCs)

TIP

If a Windows NT server or client with NWLink installed is unable to communicate with NetWare clients or servers, check the properties of NWLink to make sure you are using the same frame type as the machines running NetWare. You must also configure network numbers when using NWLink.


O

object identifier

A globally unique identifier for an object’s class in Active Directory. An object identifier for an attribute remains unchanged even when the distinguished name of the object is modified because of system configuration changes. Object identifiers ensure that when Active Directory is integrated with other directory systems such as Novell Directory Services (NDS), X.500, or Simple Network Management Protocol (SNMP), no conflicts occur between them. Each class of object in Active Directory has a unique object identifier that is externally assigned by an issuing authority. In the United States, the issuing authority is the American National Standards Institute (ANSI). The International Organization for Standardization (ISO) maintains a list of the world’s issuing authorities. An object’s attributes also require unique object identifiers.

TIP

If you want to create new classes of objects or new attributes in Active Directory using Active Directory Schema Manager, you must obtain an object identifier for your organization. An example of an object identifier for a U.S. company is 1.2.840.105670, where 1.2.840 is assigned to U.S. companies and 105670 is the number assigned to the specific company. Once your company has an object identifier, you can extend it by appending dotted decimal portions. So if 1.2.840.105670 represents Northwind Traders, 1.2.840.105670.27 might represent the Sales division, 1.2.840.105670.33 might represent the Support division, and so on. Further levels of subdivision are also possible.

object in Active Directory

The basic element of Active Directory in Microsoft Windows 2000 that represents something on the network, such as a user, a group, a computer, an application, a printer, or a shared folder.

How It Works

Objects have attributes that define and describe them. For example, the attributes of a user object might include the user’s name, e-mail address, and phone number. All objects of the same type or class have the same set of attributes, but they are distinguished from each other by having different values for at least one of these attributes. Some attributes are required to have values (such as the First Name attribute of a user object), while other attributes can be optional (such as Telephone Number).

You can group objects by placing them into container objects (containers) such as the ones following:

  • Domains:
    The fundamental units of Active Directory that share common administration, security, and replication requirements. Domains can also be grouped into domain trees and forests to reflect the administrative structure of an enterprise.

  • Organizational units (OUs):
    Container objects that are used to organize other directory objects. OUs make possible the hierarchical structure of Active Directory, in which objects are grouped according to common functions and purposes to simplify network administration. The hierarchical grouping of objects and OUs also simplifies the process of searching Active Directory for information about network resources.

Access to an object in Active Directory is based on the object’s discretionary access control lists (DACLs), which list the users and groups authorized to access the object and their access levels. You can group objects with similar security requirements into OUs to simplify assignment of permissions to the objects and to facilitate administration and control of network resources. You can assign permissions to objects by using Active Directory Users and Computers, a snap-in for Microsoft Management Console (MMC).

Objects can be referenced by name by using

  • Distinguished names:
    Analogous to absolute paths of objects within a file system. The distinguished name of an object specifies complete information about the object’s location within Active Directory and includes the domain name, names of OUs that it belongs to, and the name of the object itself. Each object in Active Directory must have a unique distinguished name.

  • Relative distinguished names:
    Analogous to relative paths of objects in the current directory of a file system. The relative distinguished name of an object is the portion of the distinguished name that is unique to the object. Any two objects in the same OU must have unique, differing relative distinguished names.

The most common types of objects in Active Directory are as follows:

  • User account objects:
    Required for users to log on to the network.

  • Group objects:
    Collections of user accounts, computers, or other groups created for organizational purposes or for assigning permissions to shared resources.

  • Computers:
    Represent machines that belong to the domain.

  • Shared folders:
    Pointers to shared folders on a server on the network. If you create a shared folder on a computer running Windows 2000, an associated shared folder object is automatically created in Active Directory.

  • Printers:
    Pointers to printers on the network. If you create a network printer on a machine running Windows 2000, an associated printer object is automatically created in Active Directory.

  • OUs:
    Containers for organizing other objects in a hierarchical fashion.

TIP

When you use Active Directory Users and Computers to view the property sheet for an object, the Security tab, which displays the Active Directory permissions assigned to that object, is usually not visible. Choose Advanced Features from the View menu to make this tab visible.

TIP

If you have resources such as shared folders or printers on computers that are not running Windows 2000, you must manually publish information about these resources in Active Directory if you want users to be able to locate and access them through Active Directory. You do this by adding the appropriate type of object for that resource to Active Directory and having it point to where the resource is located on the network.

TIP

When you create a new Active Directory object, you usually use a wizard to specify values for the important attributes of the object. You can specify other attributes after the object is created by opening the property sheet for that object.

object in C and C++ programming

A construct containing data as well as methods (functions for manipulating the construct’s data). Object-oriented programming (OOP) focuses on objects instead of functions for manipulating separate data entities. The “blueprint” for an object is a class; a specific object is an “instance” of a class that you access using its associated methods. New classes can be derived from more general classes through a procedure called inheritance. The derived class contains all the methods and data of the original class, which can simplify programming.

object in Performance Monitor

A component or aspect of a server for which you can collect and analyze usage statistics. Examples of objects in the Microsoft Windows NT and Windows 2000 administrative tool Performance Monitor include caches, logical disks, memory, processors, and threads. When an object is monitored, data is collected for every instance of every counter for the object.

See also
Performance Monitor

object in Windows NT and Windows 2000

A system resource that can be made available to an application. Examples of objects in Microsoft Windows NT and Windows 2000 include files, printers, memory, devices, windows, threads, and processes. A file object, for example, includes the file’s name and status information, along with a collection of methods for creating, opening, closing, and deleting the object. These methods describe what actions can be performed on the object by the Object Manager, the component of the Windows NT executive that manages resources on a machine running Windows NT or Windows 2000.

object linking and embedding (OLE)

A feature that allows users to create and edit documents that contain objects created by different applications. For example, you can embed bitmap images, sound clips, spreadsheet files, and other objects in Microsoft Word documents.

The term “object linking and embedding” comes from these two types of actions for creating compound documents:

  • Linking
    adds a link in a document that points to source data stored somewhere else. Linked objects are stored in the document as a path to the original linked data, usually a separate file from the container document.

  • Embedding,
    on the other hand, adds one document directly to the other. Embedded objects are stored with the document that contains them.

See also
OLE

Object Manager

A component of Windows NT executive running in kernel mode that creates, deletes, and manages executive objects (data types that represent system resources) and manages the global namespace for the Microsoft Windows NT and Windows 2000 operating systems.

How It Works

Windows NT and Windows 2000 are considered object-based operating systems because they control access to all system objects (system resources such as files, printers, and threads). Applications running on Windows NT or Windows 2000 cannot manipulate system resources directly—they must ask Windows NT or Windows 2000 to perform the desired action on the object. This feature provides the basis for all Windows NT and Windows 2000 security, including access control, auditing, and memory protection.

All operating system resources in Windows NT and Windows 2000 are implemented as objects, which are abstract representations of the resources that the operating system can manage. The Object Manager performs actions such as creating, monitoring, and securing the object by invoking the object’s methods. The Object Manager also maintains a global hierarchical namespace of all the objects managed by Windows NT and Windows 2000.

OBM

See
out-of-band management (OBM)

OC-x

See
optical carrier (OC-x) levels

ODBC

See
open database connectivity (ODBC)

ODBC logging

A feature of Internet Information Services (IIS) that allows logs of Web site activity to be written directly to a database that is compliant with the open database connectivity (ODBC) protocol. You can analyze the record of Web site traffic stored in the database and generate reports using standard database analysis tools. This is more convenient than logging Web traffic in text files and then importing them into database tables.

TIP

The Usage Import utility of Microsoft Site Server Express supports only the IIS and NCSA log file formats, so if you want to use Usage Import and Report Writer to generate reports of your Web site traffic, don’t use ODBC logging to collect the information—use Microsoft IIS Log File Format or NCSA Common Log File Format instead.

ODI

See
Open Data-link Interface (ODI)

offline browsing

A feature of Microsoft Internet Explorer that allows users to browse cached or subscribed Web content when they are not connected to the Internet. Offline browsing is an easy way to browse Web content on a laptop when an Internet connection is not available. Users can surf their history folder to view recently accessed Uniform Resource Locators (URLs). If users click on an unsaved link, they are notified that they are working offline and are asked whether they would like to connect to the Internet to access the resource.

TIP

When you add a Web page to your Favorites list, you can specify that the page be available for offline browsing, indicate how deep you want to be able to browse the page’s links offline, and specify how you want to keep the offline content up to date. To view the site offline later, you can

  • Choose Synchronize from the Favorites menu to manually synchronize offline content

  • Choose Work Offline from the File menu to switch to offline browsing mode

  • Select the item from your Favorites list

To leave Work Offline mode, choose Work Offline from the File menu.

Offline Files in Windows 2000

A feature that lets you continue working with shared network resources after you disconnect from the network. Shared files and folders from any computer that supports SMB-based file and print sharing (such as Microsoft Windows 2000, Windows NT 4, Windows 98, and Windows 95) can be made available for offline use by Windows 2000 clients. Windows 2000 clients that are configured to use offline folders can cache the network resources in a local folder. When disconnected from the network, the client can continue working normally on the cached files. The client can then synchronize the contents of the cache with the network share when the connection is restored.

How It Works

To enable offline file support on a computer running Windows 2000, open My Computer and choose Folder Options from the Tools menu. Select the Offline Files tab and check Enable Offline Files.

Specify synchronization options, a cache size, and additional advanced options. To make a share on the network available for offline use, select the share in My Computer (where it might appear as a mapped network drive) or My Network Places (where it will appear as a network share) and choose Make Available Offline from the File menu. The contents of the network share will be copied to the local computer’s cache in a process known as synchronizing. You can specify additional synchronization settings by selecting Settings in the Synchronizing dialog box.

Graphic O-1. Synchronizing with a network share using Offline Files in Windows 2000.
Graphic O-1. Synchronizing with a network share using Offline Files in Windows 2000.

offline folders in Microsoft Outlook

A feature that allows users to copy the contents of server-based folders to their hard disks or to a network share. Offline folders have a format similar to personal folders, but they have the extension .ost instead of .pst. To copy information to offline folders, you choose Synchronize from the Tools menu on the Outlook toolbar and select the synchronization method that you want to use.

NOTE

In Microsoft Outlook, the following folders are always considered as a group; if one of them is marked for offline use, all of them are:

  • Inbox

  • Outbox

  • Deleted Items

  • Sent Items

  • Contacts

  • Journal

  • Notes

  • Tasks

OLAP

See
online analytical processing (OLAP)

OLE

A low-level object-oriented technology based on the Component Object Model (COM) that provides services to applications for creating compound documents.

How It Works

An OLE application can be one or both of the following:

  • An OLE server application, which is used to create objects that will be contained in compound documents. A server application can create OLE components that can be placed in documents created by OLE container applications.

  • An OLE container application, which is used to create the actual compound documents. A container application can create documents that can contain and display OLE components using OLE.

OLE container documents support in-place activation, which allows users to activate an embedded OLE component from within the container document. Activating the component changes the container application’s user interface to include features that allow users to directly edit the component from within the container document.

NOTE

The meaning of the term “OLE” has changed since its first usage at Microsoft. Version 1 of Object Linking and Embedding (OLE), referred to as OLE 1, was created in 1991 and was Microsoft’s first mechanism for creating compound documents. OLE 2, the second version of OLE, improved on OLE 1 and expanded the support for creating compound documents. OLE 2 was based on the model known as the Component Object Model (COM). Microsoft began to recognize that OLE 2 could be used to solve other software problems and that it could be applied to other areas of software development. Microsoft saw OLE 2 as an expandable architecture to create software and, as such, decided to drop the version number. Microsoft also reduced the name from “Object Linking and Embedding (OLE)” to just “OLE,” which had no spell-out. At that time, OLE referred to any technology based on COM. In 1996, Microsoft introduced the name “ActiveX.” Initially, the name “ActiveX” referred to COM-based technologies related to the Internet, which overlapped with OLE. Soon, OLE technologies were being referred to as “ActiveX technologies.” At that time, Microsoft decided to change the name “OLE” back to its original name, “object linking and embedding (OLE),” and once again use it to refer to technologies for creating compound documents and the linking and embedding of objects.

See also
ActiveX, Component Object Model (COM), object linking and embedding (OLE)

OLE DB

A set of open, extensible interfaces developed by Microsoft and based on OLE/COM technologies for providing applications with uniform methods of data access in diverse data sources. These data sources can include mainframe databases such as IBM’s Information Management System (IMS) and DB2; server databases such as Microsoft SQL Server and Oracle; desktop databases such as Microsoft Access, Microsoft FoxPro, and Paradox; and non-DBMS information sources such as file systems, spreadsheets, text files, and e-mail. OLE DB defines interfaces that encapsulate various types of database functionality such as record containers, query processors, and transaction coordinators. OLE DB facilitates the development of applications that combine various types of database queries from diverse sources.

How It Works

The architecture of an OLE DB system has three parts:

  • Data source:
    Can be any ODBC-compliant database, a legacy mainframe system, or another common data source.

  • OLE DB consumer:
    Represents the traditional client that needs to access data from the data source.

  • OLE DB provider:
    A set of COM components that extracts the requested data from the data source and returns it in tabular format to the OLE DB consumer. The type of provider you use depends on the type of data source the client needs to access. Providers are available for the full range of data sources including ODBC, SQL Server, Jet, Oracle, and AS/400.

Because of the standard set of interfaces used in OLE DB providers, any consumer is able to access data from any provider. Furthermore, because providers are COM objects, consumers can access them using any programming language, including C++, Microsoft Visual Basic, and Java.

Graphic O-2. The architecture of an OLE DB system.
Graphic O-2. The architecture of an OLE DB system.

As an example of a provider, the OLE DB Provider for AS/400 and VSAM enables record-level access to mainframe Virtual Storage Access Method (VSAM) files and to the AS/400 native file system. The OLE DB Provider for AS/400 and VSAM is included with Microsoft SNA Server version 4. You use the OLE DB Provider for AS/400 and VSAM to develop applications for discrete data access and for record-level access to physical and logical files on AS/400 systems, in Partitioned Data Sets (PDS’s) and Partitioned Data Set Extended (PDSE) files, and in most versions of VSAM on mainframes. Using the OLE DB Provider for AS/400 and VSAM, programmers can access mainframe VSAM or AS/400 data using Microsoft’s object-based OLE DB data access technology. Programmers can thus access source data from host systems without having to learn about Systems Network Architecture (SNA) or host applications programming. The OLE DB Provider for AS/400 and VSAM facilitates a broad range of data access, from individual records to complete files. Using ActiveX Data Objects (ADO), you can develop web-to-host integration solutions using programming languages such as Microsoft Visual Basic or scripting languages such as Microsoft Visual Basic, Scripting Edition (VBScript), and Microsoft JScript.

OLE DB for OLAP

A set of Component Object Model (COM) interfaces and objects that extends OLE DB to allow access to information stored in multidimensional information sources. OLE DB for OLAP is included in OLE DB 2.0 and leverages the OLE DB architecture to enable online analytical processing (OLAP) functions for COM-based applications.

online analytical processing (OLAP)

A technology that allows users to perform sophisticated data analysis on typically large amounts of enterprise data to gain insight on the information it contains. Examples of analysis include financial modeling, budget forecasting, production planning, and determining broad sales and distribution trends. A query issued in an online analytical processing (OLAP) system could be, “What would be the effect on sales over the next three quarters if the cost of widgets went up 5% while sales dropped 15%?” OLAP systems primarily focus on queries that ask “What if…?” In other words, OLAP systems are designed for making predictions, modeling scenarios, and supporting decision-making.

The database for an OLAP system is structured to allow for efficient retrieval of information. The database can be a data warehouse. A data warehouse is a database that contains static data on a particular subject, drawn from various sources. Queries issued against data warehouses tend to focus on queries that ask “What was…?” or “Who did…?” and are useful for analyzing past sales and growth figures. For example, “What were the total sales for the five largest subsidiaries in the first two quarters of last year?” OLAP systems and data warehouses thus constitute two complementary tools for analyzing and interpreting business data in order to make smart decisions.

An OLAP system is typically based on a multidimensional model, which allows users to easily select, explore, and view the data. An OLAP system generally provides the technology for creating and managing the databases. An OLAP system can have tools to discover relationships between data items by comparing the results of various OLAP queries.

Microsoft SQL Server version 7.0 includes a number of tools for data warehousing and online analytical processing, including Data Transformation Services (DTS) Designer and SQL Server OLAP Services. You can use DTS Designer to specify the workflow steps and transactions for combining multiple heterogeneous data sources into a data warehouse. You can then use OLAP Services to analyze the data, preaggregate data into multidimensional cubes for frequently asked queries, model data, create new views, and perform ad hoc sets of calculations.

On the Web
•
OLAP Council home page
: http://www.olapcouncil.org

OnNow

A power-management design initiative from Microsoft that combines innovation in PC hardware and software to produce a computer that is always on but appears to be off and that responds immediately when a user or application makes a request. For example, an incoming telephone call could wake the computer and start a TAPI-enabled application. OnNow is designed to make personal computers function like appliances in the sense that they respond instantly to user action instead of requiring a warm-up period or boot process. OnNow is based on the Advanced Configuration and Power Interface (ACPI) specification developed by Intel, Microsoft, and Toshiba.

Microsoft Windows 98 directs its power-management functions through the OnNow system. Instead of having the system BIOS control the power state of the system devices and peripherals, OnNow lets the operating system control it. The operating system can place various devices in a sleep state to conserve power and wake them to full power instantly when a user or application issues a request. For OnNow to function as designed, the system must have peripherals and applications that support OnNow power-management functions and the system BIOS must support ACPI.

OpenBSD

A free version of UNIX that is based on the BSD 4.4 operating system and is maintained and supported by a large community of developers. The OpenBSD project is headed by Theo de Raadt, a computer science graduate of the University of Calgary in Alberta, Canada. OpenBSD is widely viewed as one of the most secure UNIX platforms available; even its default installation is fairly hacker-proof. OpenBSD includes support for the Kerberos IV security protocol and Internet Protocol Security (IPSec). OpenBSD also supports binary emulation of most software written for other popular UNIX flavors, such as HP-UX, SunOS, Solaris (SVR4), Linux, and FreeBSD. The current release of the OpenBSD software is version 2.5.

On the Web
•
OpenBSD home page
: http://www.openbsd.org

open database connectivity (ODBC)

A Microsoft database technology that provides an application programming interface (API) that Microsoft Windows–based applications can use to access structured query language (SQL) databases (such as those created and managed with Microsoft SQL Server) over a network.

How It Works

Open database connectivity (ODBC) defines a call-level interface that lets applications access data in any database through the appropriate ODBC driver. The ODBC API allows applications to be independent of the database management systems (DBMS’s) that manage their source data.

The main components of ODBC are as follows:

  • ODBC API:
    A set of function calls, error codes, and SQL syntax that defines how data in a DBMS is accessed.

  • ODBC database drivers:
    Dynamic-link libraries (DLLs) that can process ODBC function calls for specific DBMS’s. ODBC drivers translate application calls to ODBC into calls that the specific DBMS can respond to.

  • ODBC Driver Manager:
    Loads the ODBC drivers that an application needs.

ODBC, which is based on SQL, provides interoperability by allowing an application to access different SQL DBMS’s by using a common set of code. Developers can thus build client/server database applications without having to pre-specify which DBMS’s will be used for the back end. ODBC uses database drivers to link applications to any ODBC-compliant DBMS. ODBC database drivers are available for more than 50 popular DBMS’s, including SQL Server, Microsoft Access, Microsoft FoxPro, Microsoft Excel, Paradox, dBase, and delimited text files.

With ODBC, applications are not tied to proprietary vendor APIs and can run independently of the underlying data communication protocols. Data can be sent and received in a format suitable for the application instead of being tailored for a vendor-specific DBMS.

You can configure ODBC by using the ODBC utility in Control Panel. This utility lets you define a data source name (DSN) for the database being accessed and drivers for accessing the database. To configure ODBC with this utility, you associate a DSN with an ODBC driver, which lets an application interact with a database that is located either on the local machine or on a network server.

Open Data-link Interface (ODI)

A standard developed by Novell and Apple for defining the communication mechanism between network interface card (NIC) drivers and network protocols. Open Data-link Interface (ODI) allows multiple NICs to be bound to multiple protocols, similar to the network driver interface specification (NDIS) standard. ODI is a legacy standard that was defined primarily for the Internetwork Packet Exchange (IPX) protocol on Novell NetWare 2. x and 3. x networks. Microsoft’s NWLink IPX/SPX-Compatible Transport supports ODI for backward compatibility.

Open Shortest Path First (OSPF) Protocol

A link state routing protocol that is used to exchange routing information between dynamic routers. Open Shortest Path First (OSPF) is an Interior Gateway Protocol (IGP) that is used mainly in larger TCP/IP internetworks and within autonomous systems of the Internet. OSPF is more efficient in terms of network overhead than the Routing Information Protocol (RIP), but it is considerably more complex to plan and implement in an enterprise.

How It Works

OSPF-enabled routers use the Shortest Path First (SPF) algorithm to compute the shortest path between nodes on an internetwork. They create a map (or tree) called the link state database that describes the topology or structure of the router’s specific network area. Network areas are groups of networks connected using OSPF-enabled routers that all have router interfaces for any of the networks included in the area. Areas typically have no more than about 30 or 40 routers and are connected to each other through a designated high-speed contiguous backbone area using area border routers (ABRs). OSPF areas simplify computation of link state information because the computational requirements of calculating link state information rise rapidly as the size and complexity of the network increase. With OSPF areas, each router need maintain only link state information about its own area and other areas connected to it, which improves the scalability of OSPF.

The link state information stored in the database (routing table) of each router includes cost information in addition to hop information. Administrators can configure routers in a complex mesh topology network so that specific paths are preferred over others. The SPF algorithm is used so that routing information can be quickly recalculated if routers are moved or if they go down. This feature is known as Fast Convergence. The SPF algorithm also ensures that the routing tables contain the shortest (least-cost) paths and that routing loops do not occur.

Graphic O-3. Open Shortest Path First (OSPF) Protocol.
Graphic O-3. Open Shortest Path First (OSPF) Protocol.

The link state database of routing information is updated by advertisements using multicasting if a router goes down or if the structure of the network is reconfigured, and the database is used to calculate routes for delivering data over the network. Unlike the older RIP, OSPF uses multicasting to update only routing information, not the entire routing table. And unlike RIP-enabled routers, which broadcast routing information every 30 seconds, OSPF broadcasts changes only when they occur. These features substantially reduce inter-router network traffic compared to RIP and make OSPF a more efficient protocol than RIP for large internetworks.

NOTE

Microsoft Windows NT supports OSPF through the Routing and Remote Access Service (RRAS), which can be downloaded from the Microsoft Web site. OSPF will also be supported natively by Windows 2000.

TIP

When you design an OSPF-based internetwork, you should work from the top down—that is, you should first plan your autonomous system and how it will interact with other autonomous systems, and then you should subdivide the autonomous system into areas and then into individual networks. Try to map your IP address space and subnets to this hierarchy of areas and networks and assign each area a small set of network IDs that can be summarized as a small series of routes. Be sure that areas connect to each other through your high-speed backbone area and not directly to each other. (In other words, avoid back doors.) Specify cost values that relate to the amount of traffic and hardware characteristics of each router.

Open Systems Interconnection (OSI) reference model

An architectural model for open networking systems that was developed by the International Organization for Standardization (ISO) in Europe in 1974. The Open Systems Interconnection (OSI) reference model was intended as a basis for developing universally accepted networking protocols, but this initiative essentially failed for the following reasons:

  • The standards process was relatively closed compared with the open standards process used by the Internet Engineering Task Force (IETF) to develop the TCP/IP protocol suite.

  • The model was overly complex. Some functions (such as connectionless communication) were neglected, while others (such as error correction and flow control) were repeated at several layers.

  • The growth of the Internet and TCP/IP—a simpler, real-world protocol model—pushed the OSI reference model out.

The U.S government tried to require compliance with the OSI reference model for U.S. government networking solutions in the late 1980s by implementing standards called Government Open Systems Interconnection Profiles (GOSIPs). This effort was abandoned in 1995, however, and now few real-world implementations of OSI networking protocols exist outside of Europe.

The OSI reference model is best seen as an idealized model of the logical connections that must occur in order for network communication to take place. Most protocol suites used in the real world, such as TCP/IP, DECnet, and Systems Network Architecture (SNA), map somewhat loosely to the OSI reference model. The OSI model is a good starting point for understanding how various protocols within a protocol suite function and interact.

The OSI reference model has seven logical layers, as shown in the following table.

The OSI Reference Model
Layer Number | Layer Name | Description
7 | Application layer | Interfaces user applications with network functionality, controls how applications access the network, and generates error messages. Protocols at this level include HTTP, FTP, SMTP, and NFS.
6 | Presentation layer | Translates data to be transmitted by applications into a format suitable for transport over the network. Redirector software, such as the Workstation service for Microsoft Windows NT, is located at this level. Network shells are also defined at this layer.
5 | Session layer | Defines how connections can be established, maintained, and terminated. Also performs name resolution functions.
4 | Transport layer | Sequences packets so that they can be reassembled at the destination in the proper order. Generates acknowledgments and retransmits packets. Assembles packets after they are received.
3 | Network layer | Defines logical host addresses such as IP addresses, creates packet headers, and routes packets across an internetwork using routers and Layer 3 switches. Strips the headers from the packets at the receiving end.
2 | Data-link layer | Specifies how data bits are grouped into frames, and specifies frame formats. Responsible for error correction, flow control, hardware addressing (such as MAC addresses), and how devices such as hubs, bridges, repeaters, and Layer 2 switches operate. The Project 802 specifications divide this layer into two sublayers, the logical link control (LLC) layer and the media access control (MAC) layer.
1 | Physical layer | Defines network transmission media, signaling methods, bit synchronization, architecture (such as Ethernet or Token Ring), and cabling topologies. Defines how network interface cards (NICs) interact with the media (cabling).

You can think of each layer as being logically connected to the same layer on a different computer on the network. For example, the application layer on one machine communicates with the application layer on another machine. But this communication is logical only; physical communication occurs when packets of data are sent down from the application layer of the transmitting computer, encapsulated with header information by each lower layer, and then put on the wire at the physical layer of the transmitting computer. After traveling along the wire, the packets are picked up by the physical layer of the receiving computer, passed up the seven layers while each layer strips off its associated header information, and then passed to the application layer of the receiving computer, where the receiving application can process the data.

See also
application layer, data-link layer, network layer, physical layer, presentation layer, session layer, transport layer

optical carrier (OC-x) levels

A set of signaling rates designed for transmission over Synchronous Optical Network (SONET) networks. Optical carrier (OC-x) levels also apply to Asynchronous Transfer Mode (ATM) networks. The term “optical carrier” indicates that SONET runs over fiber-optic cabling. The following table shows some of the common OC-x transmission rates.

OC-x Transmission Rates
Name | Rate
OC-1 | 51.85 Mbps
OC-3 | 155.52 Mbps
OC-12 | 622.08 Mbps
OC-24 | 1.244 Gbps
OC-48 | 2.488 Gbps
OC-192 | 9.952 Gbps
NOTE

OC-1 is roughly equivalent to T3 in the T-carrier system. It is a standard SONET Synchronous Transport Signal (STS) transmission rate of 51.85 Mbps. This data transmission rate is known as STS-1. Higher data transmission rates (OC-3, OC-12, and so on) are multiplexed STS-1 transmissions. In other words, OC-3 is three times faster than OC-1 (STS-1).

opto isolator

A device for electrically isolating networking components that are joined by long runs of copper cabling. Opto isolators prevent ground loops from damaging networking components.

How It Works

When a network component or cable transmitting a signal is connected to one port on an opto isolator, the signal is converted briefly into light and then back into an electrical signal before exiting through the other port on the opto isolator. This brief metamorphosis from electric current into light and back again breaks the electrical connection between the two ports of the device, allowing the signal (alternating current) to flow but preventing direct current from flowing along the cable.

Opto isolators are commonly used in RS-232 serial connections between mainframe hosts and terminals connected by long cables. Opto isolation is typically built into line drivers for serial communication, so separate opto isolators are not required.

Graphic O-4. Opto isolator.
Graphic O-4. Opto isolator.
See also
ground loop

Orange Book

Another name for the publication Trusted Computer Systems Evaluation Criteria (TCSEC), published by the National Computer Security Center (NCSC) of the U.S. Department of Defense. Orange Book standards are used to evaluate the security of both stand-alone and network operating systems (NOS’s). The current version of this publication dates from 1985. The Orange Book, which was named for its orange cover, is actually a part of a series of computer system security guidelines and standards that are collectively known as the Rainbow Series.

The Orange Book provides methods of assessing the security of a specific computer system, and it offers hardware and software manufacturers guidance on how to create products that can be certified as secure by the U.S. government and military.

For example, Microsoft Windows NT Server in certain configurations complies with the C2 (Controlled Access Protection) security standards outlined in the Orange Book. C2 is applied not to operating systems but to specifically tested physical computers running those operating systems. C2 is one of a family of security designations that the Orange Book applies to computer systems, which include the following:

  • D (Minimal Protection):
    For systems that were evaluated but failed.

  • C1 (Discretionary Security Protection):
    Provides separation between users and data by using access controls.

  • C2 (Controlled Access Protection):
    Adds user accountability to C1 in the form of logons, auditing, and other features.

  • B1 (Labeled Security Protection):
    Builds on C2 by including informal written security policies, data labeling, and mandatory access control.

  • B2 (Structured Protection):
    Builds on B1 by including formal written security policies, separation of critical and noncritical elements, and protection against covert entry.

  • B3 (Security Domains):
    Builds on B2 by including reference monitoring of all object access to ensure security, a designated security administrator, and system recovery procedures.

  • A1 (Verified Design):
    The same as B3, except security is verified by both testing and analysis of formal design. An A1 system is considered impenetrable to hostile attack.

organizational unit (OU)

A type of container object in Active Directory of Microsoft Windows 2000 that can contain other Active Directory objects.

How It Works

An organizational unit (OU) can contain other OUs, or it can contain specific objects, such as those listed here:

  • Users

  • Groups

  • Computers

  • File shares

  • Printers

  • Security policies

  • Applications

OUs make possible the hierarchical structure of Active Directory. Objects in the directory are grouped in tree-like structures for easier administration. OUs are displayed in Windows 2000 administrative consoles as folders, much like the folders in a file system that store individual files. OUs are logical groupings of users and resources in a domain; they simplify management of the domain by delegating administrative tasks to specific people.

OUs are often used to duplicate the organizational structure of the company within Active Directory. For example, a company might have OUs named Dev, Marketing, and Sales that represent the network resources of these three departments. OUs can also be assigned according to geographical criteria (New York, Los Angeles, and Detroit, for example) or by administrative function (Accounts, Shares, and Printers). When you run the Active Directory Installation Wizard to install Active Directory on a server running Windows 2000 (thus turning the server into a domain controller), a default hierarchy of OUs is created. This default hierarchy helps you begin administering Active Directory. It consists of the following OUs, which you can display by using Active Directory Users and Computers, a snap-in for Microsoft Management Console (MMC):

  • Builtin:
    Includes built-in security groups such as Administrators and Account Operators

  • Computers:
    Includes other computers in the domain

  • Users:
    Includes domain user objects

  • Domain Controllers:
    Includes the domain controllers in the domain

Graphic O-5. Organizational unit (OU).
Graphic O-5. Organizational unit (OU).

The hierarchical structure of OUs in Active Directory also simplifies the task of querying Active Directory for information about network resources. OUs are useful in facilitating administration of Active Directory and therefore in the administration of resources on the network itself. Administrators use OUs to organize users and resources on the network, and to delegate administrative and other rights and permissions to users and groups. The administrator has full access rights on all objects in the directory and can assign permissions to various subtrees of OUs for appropriate users and groups. For any OU, the administrator can delegate either of the following rights to specific users and groups:

  • Complete administrative control:
    Full control over all objects in the OU

  • Limited administrative control:
    The ability to modify only certain aspects of objects contained in the OU

Access to objects in Active Directory is based on discretionary access control lists (DACLs), which offer a security model similar to that used in the NTFS file system. Because objects with similar security requirements are grouped into an OU, permissions assigned to the OU are inherited by all objects in the OU. You assign permissions to OUs and other objects by using Active Directory Users and Computers.

NOTE

If several domains are connected into a domain tree, each domain can have its own specifically designed hierarchy of OUs. The structures of domains within a domain tree are independent of one another. However, an OU can contain objects only from its own domain, not from any other domain within a domain tree.

OUs are not part of the namespace of a company, which in Windows 2000 is based on the Domain Name System (DNS). In other words, you can identify a Windows 2000 domain by using a DNS name such as northwind.microsoft.com, but you cannot identify OUs within the domain by using DNS names. However, you can specify OUs by using Lightweight Directory Access Protocol (LDAP) names.

You cannot create new OUs within the four default OUs previously listed. These default OUs simply get you started in administering your network.

TIP

To create new OUs in Active Directory, select the desired parent container in Active Directory Users and Computers, and choose Organizational Unit from the New submenu of the Action menu. You can also use the console toolbar. The only information you need to specify when you create a new OU is its name.

When you create an OU, you should consider who will own and manage it and who will be responsible for the following tasks:

  • Adding objects to or deleting objects from the OU

  • Modifying the values of attributes of objects in the OU

  • Managing permissions on the OU and its objects, and delegating the permissions to others

You can create OUs for groups of users who will be assigned similar permissions to network resources. You can also create separate OUs for permanent and temporary employees. You can group shared folders and printers with similar security requirements into OUs.

You should create OUs that are stable and will not change frequently, and you should avoid making the hierarchy of OUs too complicated. In a multidomain scenario with a domain tree, it is usually a good idea to make first-level OUs the same for all domains to provide consistency for the company’s network resources. First-level OUs typically represent the following:

  • Different geographical locations, such as countries or continents, or different functional locations, such as headquarters and branch offices. This is usually the best way to define first-level OUs.

  • Different types of network resources, such as users, printers, computers, and so on. This simplifies resource administration but might lead to too many first-level OUs.

  • Different business units, such as Sales, Support, and Management. Keep it flexible and broad enough so that if your company reorganizes, you won’t have to re-create everything.

  • Projects and cost centers.

Keep the entire structure of OUs fairly shallow—no more than two or three levels—to ensure good performance when users query Active Directory. A maximum of 10 levels of OUs is recommended.

You can use OUs in place of resource domains, which are used in Windows NT to simplify and centralize administration of network resources. You can also create domain trees with separate domains for resources. You should create new domains instead of OUs if you want to implement different security policies in different locations or branches of your company or in an extremely large enterprise. Otherwise, it is simpler to create only one domain and organize resources and administrative tasks using OUs within that domain.

organization in Microsoft Exchange Server

The root or highest-level administrative unit in Microsoft Exchange Server, which is usually identified by the broadest name that can represent the enterprise’s business—the organization name cannot be changed without reinstalling all servers. An Exchange organization consists of a number of sites, each of which consists of one or more Exchange servers. Sites are connected by connectors such as a Site Connector or Dynamic RAS Connector. You can also use other connectors such as the Internet Mail Service Connector or X.400 Connector to provide messaging connectivity between your Exchange organization and a foreign mail system. Examples of such foreign mail systems include the following:

  • The collection of Simple Mail Transfer Protocol (SMTP) hosts on the Internet

  • A public or private X.400 message-handling system

  • Another Exchange organization

    Graphic O-6. Organization in Microsoft Exchange Server.
    Graphic O-6. Organization in Microsoft Exchange Server.

In the Exchange directory hierarchy, which is displayed in the Exchange Administrator program, the Organization container contains

  • Site containers

  • Address book views

  • Public and system folders

  • Global address list

OS/2

A 32-bit operating system originally developed by IBM and Microsoft as a replacement for MS-DOS. IBM later extended OS/2 to include both server and desktop versions. IBM’s current line of OS/2 software includes the OS/2 Warp Server, the OS/2 Advanced Warp Server, and the OS/2 Warp 4 client. OS/2 Warp in its various forms is a 32-bit preemptive multitasking operating system that supports application, file and print, groupware, and Web server configurations as well as desktop workstations. OS/2 Warp Server includes symmetric multiprocessing support and clustering technologies for high-availability server environments. OS/2 Warp Server supports most common networking protocols and all types of clients, including Microsoft Windows, Macintosh, and AIX clients.

On the Web
•
OS/2 Warp home page
: http://www.software.ibm.com/os/warp

OS/2 subsystem

A component of the Microsoft Windows NT operating system running in user mode that supports the running of OS/2 1. x text-based applications on Windows NT. The OS/2 subsystem is rarely used and is not compatible with the OS/2 Presentation Manager graphical user interface.

In Windows 2000, OS/2 subsystem can be used only on a local computer, and can’t be used from a Terminal Server client computer.

OSI model

See
Open Systems Interconnection (OSI) reference model

OSPF

See
Open Shortest Path First (OSPF) Protocol

OU

See
organizational unit (OU)

Outlook Web Access

A component of Microsoft Exchange Server that works with Internet Information Server (IIS) version 4 and Active Server Pages (ASP) technology to allow Exchange users to access their e-mail, address books, and public folder content using a standard Web browser such as Microsoft Internet Explorer. More generally, Microsoft Outlook Web Access allows administrators to publish Exchange services on the Web. It uses Hypertext Transfer Protocol (HTTP) on the client side and remote procedure calls (RPCs) on the server side.

out-of-band management (OBM)

A method of remotely managing the wide area network (WAN) telecommunications components of your network by using a secondary serial communication link. These devices are typically routers, switches, or Channel Service Unit/Data Service Units (CSU/DSUs) that establish and maintain WAN links to the corporate network. Devices that can be managed out-of-band usually have an RS-232 port or some other serial port for remote control of their functions.

How It Works

In a typical setup, a remote PC is connected by a modem through a phone line to a code-operated switch located at the office local area network (LAN). This switch controls networking and telecommunication devices such as routers, bridges, switches, CSUs, and even power supplies through their RS-232 serial connections. Alternatively, the modem might be connected directly to a remote modem connected to the device being managed. In either case, the result is a separate low-cost dial-up circuit connecting the administrator and the network devices that is independent of the main network connection, which is usually a more expensive T1 or other leased line. The administrator can thus access the WAN device from a remote location even when the WAN link itself is down, and can troubleshoot the problem from off-site. Out-of-band management (OBM) also allows administrators to access and configure WAN devices without disturbing the WAN link itself. In other words, OBM functions “out of the bandwidth.”

Graphic O-7. Out-of-band management (OBM).
Graphic O-7. Out-of-band management (OBM).

For example, you can use OBM functions on a power supply to remotely reboot or reset your network devices when they go down. You can use out-of-band switches to select different serial interfaces remotely over a modem by issuing simple ASCII commands to different devices. You can even use OBM to remotely configure and control devices on your network. OBM devices are a useful part of a network disaster recovery plan.

For networking devices that you can configure and troubleshoot using out-of-band connections, you usually perform management tasks by connecting to a serial port (also called the setup port or configuration port) either locally with a cable or remotely through a modem. You usually use text-based commands from a terminal emulator program such as Windows HyperTerminal, which can emulate a VT100 terminal. You can often control access using passwords for extra security.

NOTE

OBM offers an advantage over in-band management systems such as Simple Network Management Protocol (SNMP) management systems. SNMP employs the network itself for communication, so if the WAN link goes down, the remote station cannot use SNMP to determine the problem because SNMP functions only if the WAN link is working.

OBM is often used as a backup system for in-band SNMP management, when the devices have limited SNMP support, or when the cost of an SNMP management system cannot be justified. You can often manage a device in-band by using a remote Telnet client for entering the same commands that are used in OBM.

TIP

You can often use out-of-band transmission so that a device that enters a problem state calls an administrator’s pager via a modem. The administrator can then dial in to the device remotely and correct the problem. Some network devices include built-in modems and data switches for remote OBM.

out-of-band signaling

Any transmission technology in which signaling is separate from the data being transmitted. Out-of-band signaling uses one or more channels for transmitting data or voice information and one special out-of-band channel for performing signaling functions such as establishing and terminating the communication link, controlling flow, or transmitting error information. The out-of-band channel can be

  • A physically separate set of wires (such as pins 4 and 5 of an RS-232 cable, which perform flow control functions and do not carry data)

  • A multiplexed system in which bandwidth is divided into two or more channels within the same set of wires (such as Integrated Services Digital Network, in which the two B channels and one D channel are multiplexed onto the same set of wires)

The opposite of out-of-band is in-band, in which signaling information is sent over the same channel as the data transmission. Out-of-band transmission is usually considered a better choice than in-band transmission for the following reasons:

  • None of the valuable data bandwidth is used for signaling.

  • The data stream is not interrupted with signaling information.

  • The signaling information cannot be disrupted by the noise created by the data transmission.

  • Data transmission characters cannot accidentally (or purposefully) initiate control actions.

NOTE

Out-of-band circuits are often used for out-of-band management (OBM) of wide area network (WAN) devices. These are usually physically separate dial-up lines.

See also
out-of-band management (OBM)

owner

In the NTFS file system, the person ultimately responsible for the permissions assigned to a file, usually the creator of a file. By default, the owner of a file has permission to modify the object’s discretionary access control list (DACL) by granting users and groups permissions for various objects.

A file always has an owner. Ownership creates a trail of accountability for the file. The ownership of a file on an NTFS volume can be changed in two ways:

  • The user who owns the file, or any user who has full control permission on the file, can grant the NTFS take ownership permission to another user, thus allowing that user to take ownership of the file by using the file’s Security property sheet. Users can be allowed to take ownership of a file they do not own, but ownership cannot be assigned to them by other users (even the original owner or an administrator).

  • Members of the Administrators group can always take ownership of any file by using the Security property sheet. When an administrator takes ownership of a file, the Administrators group becomes the owner of the file, not the individual administrator.

In the Microsoft Windows 2000 operating system, objects in Active Directory also have owners. The user who creates an object in Active Directory becomes the object’s owner. The owner controls the permissions for the object and its attributes. Ownership of an object in Active Directory can be changed in ways similar to those for a file on an NTFS volume.


P

package

In Microsoft Systems Management Server (SMS), an object that defines software to the SMS system. Packages store information about software so that various components of the software can be identified as a group. You use SMS to install a package on client computers, share the package so that it can be run from network servers, and maintain inventory information about the package. You can create packages for all types of software, including Microsoft, third-party, and in-house applications; data files; batch files; and scripts.

How It Works

A package contains a definition of the files that make up the software, plus other configuration and identification information. You create packages using the Systems Management Server Administrator program. Packages are stored in the SMS database at your site and at all subsites. After you create a package, you must also create a job that can be used to install the package on clients or share the package on servers.

You use a package server—a type of server in an SMS implementation—to install and maintain packages. There are two kinds of package servers:

  • Source servers, which contain the original source files for software to be distributed

  • Distribution servers, which store and distribute the package files

TIP

If you want to perform software inventory, you need not explicitly create a job for this purpose. When you define the inventory properties for a package, SMS automatically creates a system job to update the SMS inventory components. This allows SMS to maintain inventory information on the package.

packet

The fundamental unit of information transmitted over a network or over a digital communication link. Packets usually contain a header with control information about the packet type, source address, and destination address. They can also contain error-checking information. Packets have a logical structure based on the protocol used, but the general structure of a packet includes a header followed by a payload (data) and an optional trailer (footer). Packets can also have different sizes and structures depending on the underlying network architecture. A packet might also be called a datagram, a frame, or a cell.

NOTE

From the perspective of the Open Systems Interconnection (OSI) reference model, the terms “packet” and “frame” have precise definitions. A packet is an electronic envelope containing information formed in one of the layers from layer 3 through layer 7 of the OSI model. A frame is an electronic envelope of information that includes the packet as well as other information from all seven layers of the OSI model.

packet assembler/disassembler (PAD)

A telecommunications device that breaks a data stream into individual packets and formats the packet headers for asynchronous transmission over an X.25 network. It also accepts packets from the network and translates them into a data stream. Packet assembler/disassemblers (PADs) are a form of data communications equipment (DCE) for connecting asynchronous data terminal equipment (DTE) such as computers and dumb terminals to the X.25 packet-switching service.

Graphic P-1. Packet assembler/disassembler (PAD).
Graphic P-1. Packet assembler/disassembler (PAD).
How It Works

When one computer on an X.25 network wants to communicate with another computer in a remote location, the first computer sends a signal to its attached PAD requesting a connection to the remote computer. The remote computer responds by either accepting the request and initiating full-duplex communication or rejecting the request. Either computer can terminate the link at any time. Note that this communication link is for data only—X.25 does not support voice transmission. Note also that PADs are DCEs, and even though they are located at the customer premises, they are considered nodes on the X.25 network.

The PAD’s function is simply to assemble data such as strings of characters into packets to transmit over the X.25 network to the remote host and to disassemble packets that are received. PADs are often used for providing remote access via dumb terminals over X.25 to mainframe or minicomputer hosts. In this scenario, the terminals require PADs but the mainframe hosts do not—they are directly connected to the X.25 network. To configure the PAD, the administrator must specify a number of PAD parameters such as echo control, data forwarding, break signals, line folding, and binary speed. The PAD parameters (usually 22 for each terminal that the PAD services) are defined by an International Telecommunication Union (ITU) protocol called X.3. Communication between terminals and PADs is governed by the protocol X.28, and communication between the PAD and the remote host is governed by X.29.

PADs come in different configurations. Some PADs support eight or more asynchronous DTE connections and have multiple DCE interfaces for maximum configurability. Typically, you connect your asynchronous hosts (computers) to the PAD using RJ-45 connectors on twisted-pair cabling. The PAD then connects to a Channel Service Unit/Data Service Unit (CSU/DSU), which interfaces with the X.25 connection using a serial interface such as RS-232 or V.35.

NOTE

The Remote Access Service (RAS) on Microsoft Windows NT and Windows 2000 supports PADs and other ways of connecting to X.25 networks, such as X.25 smart cards and special modems for dialing up X.25 carriers such as SprintNet and Infonet.

TIP

Some PADs support both X.25 and frame relay packet-switching services and can be used to ease the migration path from X.25 to frame relay.

packet filtering

The process of controlling the flow of packets based on packet attributes such as source address, destination address, type, length, and port number.

How It Works

Many routers and proxy servers use some form of packet filtering that provides firewall capabilities for protecting the network from unauthorized traffic. Administrators can create rules for filtering out unwanted packets and can arrange these rules in the most efficient order. A packet that passes all the rules is allowed through, while a packet that violates any rule is dropped.

Packet filtering can be implemented on routers and firewall devices in two ways: static filtering and dynamic filtering.

Static packet filtering provides limited security by configuring selected ports as either permanently open or permanently closed. For example, to deny outside packets access to a company intranet server on port 80 (the standard port number for the Hypertext Transfer Protocol, or HTTP) you could configure the router or firewall to block all incoming packets directed toward port 80.

Dynamic packet filtering provides enhanced security by allowing selected ports to be opened at the start of a legitimate session and then closed at the end of the session to secure the port against attempts at unauthorized access. This is particularly useful for protocols that allocate ports dynamically—for example, with the File Transfer Protocol (FTP). If you want to grant outside users secure access to an FTP server behind the firewall (within the corporate network), you need to consider the following:

  • Port 21 (the FTP control port) needs to be left permanently open so that the FTP server can “listen” for connection attempts from outside clients. A static filtering rule can accomplish this.

  • Port 20 (the FTP data port) needs to be opened only when data will be uploaded to or downloaded from the FTP server. With static filtering this port would have to be configured as permanently open, which could provide a door for hacking attempts. Dynamic filtering allows this port to be opened at the start of an FTP session and then closed at the end of the session.

  • In order to establish an FTP connection with the client, the FTP server randomly assigns two port numbers in the range 1024 through 65,535 to the client, one for the control connection and one to transfer data. Because these ports are assigned randomly, there is no way to predict which ports above 1024 must be able to be opened by the firewall. With static filtering, you would therefore have to leave all ports above 1024 permanently open if you wanted to allow FTP access through the firewall, which would be a real security risk. With dynamic filtering, however, you can configure rules on the firewall that will read the packets issued by the server, dynamically open the two randomly assigned ports to allow a session to be opened, monitor the flow of packets to ensure that no attempt is made to hijack the session by an unauthorized user, and close the randomly assigned ports when the FTP session ends.

Graphic P-2. Packet filtering.
Graphic P-2. Packet filtering.
TIP

Microsoft Proxy Server includes a number of predefined filters that you can use to configure exceptions for common protocols. You can use these to quickly configure Proxy Server for securing your network from the Internet.

Packet filtering on a typical router can cause a performance hit of about 30 percent on the router’s ability to handle network traffic. This suggests that instead of using a packet-filtering router for a firewall, you should consider installing proper firewall software such as Microsoft Proxy Server on a dedicated server. Proxy Server includes dynamic packet filtering among its security features. If packet filtering is enabled, all incoming and outgoing packets are rejected unless an exception is explicitly created that allows them to pass. Packet filters can be enabled on Proxy Server only if the machine has an external network interface, such as one connected to a distrusted network (the Internet, for example).

NOTE

Some routers and firewalls can actually ping the source address of each packet to ensure that addresses local to the company network are coming from inside the network and are not being spoofed by a hacker outside the network.

Proxy Server also supports domain filters for allowing or denying access to World Wide Web (WWW) or FTP services based on the source IP address or Domain Name System (DNS) domain name. Proxy Server can issue alerts to inform you when packets are rejected or illegal packets are detected. It will also keep a log of alerts that occur for analysis and record keeping.

packet forwarding

The process of a networking component accepting a packet and transmitting it to its destination. For example, a router receives packets from hosts on one attached network and forwards them to hosts on another attached network or to another router for further forwarding. How a packet is forwarded is based on a comparison of the packet’s destination address with the routing table stored in the router. Each act of forwarding performed by a router is called a hop across the internetwork.

packet switching

The process by which a networking or telecommunications device accepts a packet and switches it to a telecommunications device that will take it closer to its destination. Packet switching allows data to be sent over the telecommunications network in short bursts or “packets” that contain sequence numbers so that they can be reassembled at the destination. Wide area network (WAN) devices called switches route packets from one point on a packet-switched network to another. Data within the same communication session might be routed over several different paths, depending on factors such as traffic congestion and switch availability.

Packet switching is the transmission method used for most computer networks because the data transported by these networks is fundamentally bursty in character and can tolerate latency (due to lost or dropped packets). In other words, the transmission bandwidth needed varies greatly in time, from relatively low traffic because of background services such as name resolution services, to periods of high bandwidth usage during activities such as file transfer. This contrasts with voice or video communication, in which a steady stream of information must be transmitted in order to maintain transmission quality and in which latency must remain minimized to preserve intelligibility.

The Internet is the prime example of a packet-switched network based on the TCP/IP protocol suite. A series of routers located at various points on the Internet’s backbone forward each packet received on the basis of destination address until the packet reaches its ultimate destination. TCP/IP is considered a connectionless packet-switching service because Transmission Control Protocol (TCP) connections are not kept open after data transmission is complete.

X.25 public data networks are another form of packet-switching service, in which packets (or more properly, frames) formatted with the High-level Data Link Control (HDLC) protocol are routed between different X.25 end stations using packet switches maintained by X.25 service providers. Unlike TCP/IP, X.25 is considered a connection-oriented packet-switching protocol because it is possible to establish permanent virtual circuits (PVCs) that keep the logical connection open even when no data is being sent. However, X.25 can be configured for connectionless communication by using switched virtual circuits (SVCs). An X.25 packet-switched network typically has a higher and more predictable latency (about 0.6 seconds between end stations) than a TCP/IP internetwork. This is primarily because X.25 packet switches use a store-and-forward mechanism to buffer data for transmission bursts, which introduces additional latency in communication. In addition, X.25 uses error checking between each node on the transmission path, while TCP/IP uses only end-to-end error checking.

Frame relay (also called fast packet switching) is another connection-oriented packet-switching service that gives better performance than X.25. It does this by switching packets immediately instead of using the store-and-forward mechanism of X.25 networks. Frame relay also eliminates flow control and error checking to speed up transmission. This is possible because frame relay networks use modern digital telephone lines, which are intrinsically much more reliable than the older analog phone lines on which much of the X.25 public network still depends. Frame relay supports only connection-oriented PVCs for its underlying switching architecture.

Finally, Asynchronous Transfer Mode (ATM) is another packet-switching service in which small fixed-length packets called cells are switched between points on a network.

NOTE

Packet switching is different from circuit switching, in which switches are configured in a fixed state for the duration of the session so that the route the data takes is fixed. A network that is circuit-switched requires a dedicated switched communication path for each communication even if its full bandwidth is not being used. In packet switching, bandwidth can be used when available for more efficient transmission. Circuit switching is generally used in telephone systems, while packet switching is used for computer networks. Digital cellular phone services are generally also circuit-switched, but Personal Communications Services (PCS) cellular systems are gradually being migrated to packet-switched networks for greater efficiency in data transmission.

Another difference between packet switching and circuit switching is that circuits must first be established before any data is sent, and this generally involves a certain amount of setup time. During this process, the request for a circuit connection must pass through the circuit-switched network, resources must be reserved for the connection, and a signal must be returned to the initiating station when the circuit is established and data transmission can begin. Circuit-switched networks are thus useful only when the duration of the data transmission is much longer than the setup time involved in establishing the circuit. With packet switching, data can be sent at the start of transmission, which is better suited to the bursty, irregular nature of short network transmissions over a computer network or WAN link.

See also
packet-switching services

packet-switching services

Telecommunications services provided by telcos and long distance carriers that route packets of data between local area networks (LANs) in diverse geographical locations to form a wide area network (WAN). Packet-switching services are used to connect multiple LANs into a point-to-multipoint configuration, usually called a multipoint WAN.

How It Works

A customer’s local network is typically connected through routers, bridges, frame relay access devices (FRADs), or other devices to a telco’s central office (CO). These devices either have built-in technology for connecting directly to packet-switching services or use intermediary devices located at the customer premises. Packet-switching devices take network frames and “package” them into packets suitable for the type of packet-switching service being used. These services can include frame relay, X.25, Asynchronous Transfer Mode (ATM), or Switched Multimegabit Data Services (SMDS) public or private packet-switched networks. If virtual private network (VPN) technologies are used, the public Internet can also be used as a packet-switching service for multipoint WAN connections.

Graphic P-3. Packet-switching services.
Graphic P-3. Packet-switching services.

The packaging process varies with the particular service used, but it basically consists of breaking down network frames into relatively small individual packets of data and tagging the packets with the destination address of the remote node to which the packet is directed. Each end node (local network access device) connected to the cloud has a layer 2, or data-link layer, address that is known to every other end node. These addresses are used to route packet data between individual nodes on the WAN or to broadcast packets to all nodes when needed. Other information is also tagged onto the packets for error correction and other purposes, depending on the service used. The packets are usually small to lessen the load on the switching devices and to enable quick retransmission when transmission errors occur.

Packets are individually placed onto the carrier’s packet-switched network and switched from circuit to circuit until they reach their destination. Two packets forming part of the same network message might take entirely different routes to reach their destination node—it depends on the best route available at any given moment, as determined by the packet-switching services themselves. This is different from circuit-switched networks, in which all packets are sent over the same switched circuits for the duration of the connection. At the destination, the packets are reassembled into network frames and delivered to the remote network, where they are routed to their destination computers.

In networking diagrams, a public packet-switched network is typically depicted as a cloud because the details of the switches and connections are not of interest to the customer—they are the responsibility of the carrier or carriers providing the services.

Advantages of packet-switching services include the following:

  • Customers are not restricted to a single destination, as with point-to-point connections using leased lines.

  • Packets can be routed to any destination that supports similar services, so businesses are not tied to a particular carrier or telco.

  • Packet-switched networks have low latency and are suitable for hosting dedicated services such as company Web servers if the connection has sufficient bandwidth.

  • Customers usually pay monthly rates plus additional charges based on bandwidth use, which means that the primary charges are on a per-transaction basis. The less you use the service, the less you pay.

See also
circuit-switched services, leased line

PAD

See
packet assembler/disassembler (PAD)

page fault

A condition that occurs in Microsoft Windows operating systems when a process looks for application code or data in its working set and doesn’t find it, causing the Virtual Memory Manager to swap the necessary information into memory. Windows handles process information in 4-KB blocks called pages. This information can be stored as virtual memory that can be swapped from the hard disk to RAM. Pages are the basic building blocks of virtual memory in Windows and are managed by the Virtual Memory Manager.

See also
virtual memory

pagefile

See
paging file

paging file

A file on a hard disk that Microsoft Windows NT or Windows 2000 uses to store program code that is temporarily not needed to maximize the functionality of the limited RAM on most machines. The paging file, sometimes referred to as the pagefile, is managed by the Virtual Memory Manager.

NOTE

The default size for the paging file on Windows NT is equal to the amount of installed RAM plus 12 MB. The default size for the paging file on Windows 2000 is equal to 1.5 times the amount of installed RAM. The minimum allowed paging file size is 2 MB. The default location of the paging file is %SystemRoot%\pagefile.sys

TIP

During installation of Windows NT and Windows 2000, the paging file is automatically installed on the partition that has the most free space. You achieve the best performance by moving the paging file to a separate hard drive with its own controller. Use the System utility in Control Panel to configure the paging file.

See also
virtual memory

PAP

See
Password Authentication Protocol (PAP)

parallel transmission

A form of signal transmission that sends information 8 or more bits at a time over a cable. Parallel interfaces are used mainly to connect printers, hard drives, and other peripherals to computers.

How It Works

While a serial interface such as RS-232 transfers only 1 bit of data at a time, parallel interfaces typically transfer 8 bits (1 byte) of data at a time. A typical parallel interface for a computer uses a port that accepts a female DB25 connector. The parallel interface for a printer often uses a 36-pin Centronics connector.

For the DB25 connector, all 25 of the leads must be working for parallel transmission to function. In contrast, serial interfaces, which sometimes use DB25 connectors, require only three active leads to transmit data. The parallel 25-pin connector has 17 leads for carrying signals and 8 leads for grounding. Of the 17 leads, 8 are used for data bit signals, 5 for status signals, and 4 for handshaking. Typical throughput of a parallel interface is 16 KBps or 128 Kbps. Parallel communication is usually limited to cables of up to 6 meters, but devices can be used to boost signals for longer distances.

NOTE

A new type of parallel interface, conforming to the IEEE 1284 standard, supports bidirectional parallel communication at speeds of up to 1 MBps over distances of up to 10 meters. Parallel ports that support this standard are referred to as Enhanced Parallel Ports (EPPs) or Extended Capabilities Ports (ECPs).

See also
serial transmission

parent domain

A domain in a Microsoft Windows 2000 domain tree whose Domain Name System (DNS) name forms the basis of subdomains called child domains. For example, the parent domain named microsoft.com could include three child domains named dev.microsoft.com, marketing.microsoft.com, and support.microsoft.com. A two-way transitive trust exists between a parent domain and its associated child domains.

See also
Active Directory, domain tree

parity information

Redundant information associated with any block of information that provides fault tolerance. Parity information calculated from the block of data can be used to reconstruct the block of data in the event of data loss or failure.

How It Works

RAID-5 volumes stripe data and parity information across a set of physical disks in such a way that for each stripe one disk contains the parity information while the other disks contain the data being stored. Each stripe uses a different (rotating) disk for storing its parity data.

The parity information for the stripe is created using an exclusive OR (Boolean XOR) operation on the data in the stripe. As a simple example, suppose that the block of binary data 10011 is to be written to a stripe on a RAID-5 volume that comprises six physical disks. Bit “1” is written to the first disk, bit “0” to the second disk, bit “0” to the third disk, and so on. The sixth, or parity, disk in the stripe contains the parity bit:

1 XOR 0 XOR 0 XOR 1 XOR 1 = 1

If the first disk fails so that the “1” bit stored on it is lost, the missing bit can be mathematically reconstructed using the remaining data bits and the parity bit for the stripe as follows:

? XOR (0 XOR 0 XOR 1 XOR 1) = 1
? XOR 0 = 1
Therefore:  ? = 1

partition in Active Directory

A logical divider for organization information in Active Directory in Microsoft Windows 2000. Partitions divide Active Directory into separate sections and enable it to store large numbers of objects in a distributed directory over the network. They also allow Active Directory to scale millions of objects. A partition functions as a physical storage container for a portion of the directory data for an organization. Each domain’s directory information is stored in a separate partition and is identified using the distinguished name of the domain. The global catalog server can find an object in Active Directory by using the object’s distinguished name, which can be used to identify a replica of a partition that contains the object.

partition of a disk

A portion of a physical disk that functions like a completely separate physical disk. Partitions allow physical disks to function as multiple separate storage units for isolating operating systems from applications data on a single-boot system or for isolating operating systems from one another on a multiboot system.

Disks can have two types of partitions:

  • Primary partitions:
    You can install a bootable operating system along with its associated file system on primary partitions. A physical disk can have up to four primary partitions.

  • Extended partitions:
    A series of logical drives can be created on extended partitions. You can create an extended partition on a disk to overcome the limitation of four primary partitions per disk.

NOTE

You can create partitions by using the fdisk command in MS-DOS and all versions of Microsoft Windows, by using Disk Administrator in Windows NT, or by using the Disk Management tool in Windows 2000. Using the fdisk command, you can create one primary partition and one extended partition. Disk Administrator can create up to four primary partitions or three primary and one extended partition. Disk Management can create partitions only on basic disks, not on dynamic disks.

passfilt.dll

A file in Microsoft Windows NT Service Pack 3 or later that allows administrators to increase password strength. The file establishes the following rules for password creation:

  • The minimum password length is six characters.

  • The password cannot contain a username or any part of the user’s full name.

  • The password must contain characters from at least three of the following categories:

    • Uppercase letters

    • Lowercase letters

    • Numbers

    • Non-alphanumeric characters, specifically:

      . , ; : * & % !

TIP

To install passfilt.dll, first install Windows NT Service Pack 3 or later on your domain controller, which copies passfilt.dll into the %SystemRoot%\system32 directory. Then use registry editor to edit the following key:

HKEY_LOCAL_MACHINE
    System
        CurrentControlSet
            Control
                Lsa

and create or modify the following values:

  • Value:
    Notification Packages

  • Type:
    REG_MULTI_SZ

  • Data:
    passfilt.dll

See also
Account policy

passive hub

See
patch panel

passive termination

A terminator such as a resistor that absorbs signal energy and prevents signal bounce. Passive terminations are generally used in bus topology networks such as 10Base2 and 10Base5 networks of the Ethernet variety. Termination is not required in star topology networks because the central concentrator (hub) provides the termination for each signal path. Ring topology networks such as Token Ring also do not require termination points because the signal path has no beginning or end. Passive termination is also used in some forms of Small Computer System Interface (SCSI) systems for terminating a chain of SCSI devices. Active termination, which involves electronically canceling the signal incident on the end of a transmission system, is generally more expensive than passive termination but more efficient.

pass-through authentication

In Microsoft Windows NT–based networks, a method of performing authentication to a domain controller that resides in a trusted domain. Pass-through authentication enables users to log on to computers in domains in which they do not have a valid user account. Users in a multidomain Windows NT–based network can thus access resources anywhere in the enterprise for which they have suitable permissions.

How It Works

Consider the example of an enterprise consisting of three domains—two resource domains (the trusting domains) in which network resources such as shared folders or printers reside, and a master domain (the trusted domain) in which all user accounts are defined. The resource domains trust the master domain using Windows NT one-way nontransitive trusts. When a user attempts to log on to a computer in a resource domain, pass-through authentication takes place in one of two ways:

  • When the user first logs on to the computer, the domain controller in the resource domain passes the user’s credentials to the domain controller in the master domain. The user is authenticated, and the user’s security identifier (SID) and group membership are returned to the domain controller in the resource domain.

  • If the user tries to access a shared folder or printer in the other resource domain, the user’s credentials are passed to the domain controller in the master domain in order to be authenticated for resource access.

password

A secure identifier that enables a user to access a secured resource. For example, a password can be used to log on to a network and access personal files. Passwords are a part of a user’s credentials, which include, at a minimum, the username and password, and in a multidomain Microsoft Windows 2000–based or Windows NT–based enterprise also include the user’s domain. Passwords are generally known only to users themselves and possibly to members of the Administrators or Account Operators group on Windows 2000–based or Windows NT–based networks.

NOTE

If a user forgets his or her password, the user cannot log on to the network without contacting the administrator. On a Windows NT network, the administrator uses the tool User Manager for Domains to create a new password for the user. On a Windows 2000–based network, the administrator uses the Computer Management tool to create a new password for the user.

TIP

When establishing a password policy for your company, you should determine

  • Who will control passwords—the administrators or the users. Giving users control over their own passwords makes them completely responsible for their systems and personal folders. You can configure Windows NT and Windows 2000 so that the first time users log on to the network they must change their initial password to one that only they know. This is usually the best solution.

  • How complex passwords should be and how often they should be changed. If you make passwords too complex, such as random scrambles of letters, numbers, and symbols, the network might be less secure instead of more because users are likely to write down a difficult-to-remember password and tape it under their keyboard or in some other handy location. Also, if passwords must be changed frequently, users will typically make simple changes such as adding an incremental number to the end of each new password. The best policy is usually to require a password of six to eight characters that doesn’t change and to teach users to select passwords that do not include family names, addresses, postal codes, and so on. Passwords should usually be simple combinations of letters and numbers, such as “blue144” or “max13one.”

See also
Account policy, username

Password Authentication Protocol (PAP)

A clear-text authentication scheme used in Point-to-Point Protocol (PPP) connections over WAN links that is outlined in Request for Comments (RFC) 1334. Password Authentication Protocol (PAP) is not a secure form of authentication because the user’s credentials are passed over the link in unencrypted form. For this reason, Challenge Handshake Authentication Protocol (CHAP) or some other authentication protocol is preferable if the remote client supports it. If the password of a remote client using PAP has been compromised, the authentication server can be attacked using replay attacks or remote client impersonation.

How It Works

PAP uses a two-way handshake to perform authentication. Once the PPP link is established using the Link Control Protocol (LCP), the PPP client sends a username and password to the PPP server. The server uses its own authentication scheme and user database to authenticate the user, and if the authentication is successful, the server sends an acknowledgment to the client.

PAP is typically used only if the remote access server and the remote client cannot negotiate any higher form of authentication. The remote client initiates the PAP session when it attempts to connect to the PPP server or router. PAP merely identifies the client to the PPP server; the server then authenticates the client based on whatever authentication scheme and user database are implemented on the server.

TIP

You should disable PAP on the Remote Access Service (RAS) for Microsoft Windows NT to ensure that user passwords are never sent as clear text over an unsecured connection.

PASTE

See
Provider Architecture for Differentiated Services and Traffic Engineering (PASTE)

patch cable

A short cable, usually unshielded twisted-pair (UTP) cabling, that connects a port on a patch panel to a port on a hub or a switch. Patch cables are usually terminated at both ends with RJ-45 connectors. Cable vendors usually supply patch cables in fixed lengths such as 1, 3, 6, 10, 25, 50, and 100 feet, and also in custom lengths. Patch cables usually come in various colors, which can be helpful in organizing the cabling joining devices on your equipment racks and avoiding “spaghetti.” You should use patch cables that meet the requirements of the equipment you are using. Category 5 patch cables, which are certified to 100 MHz, or enhanced category 5 patch cables, which are certified to 350 MHz and higher, are generally recommended.

Graphic P-4. Patch cable.
Graphic P-4. Patch cable.
NOTE

Be sure to purchase the correct type of patch cable. For example:

  • The wiring type (pinning) of the cable should match that of your installed premise cabling. Pinning types include TSB 568A, TSB 568B, and USOC, which are described in the table.

  • Use straight-pinning or crossover cabling. Crossover cabling, which has the send and receive wire pairs switched, is used primarily for connecting hubs.

TIP

Use patch cables with molded boots to prevent kinks from forming and to prevent pins from becoming bent through rough handling. Molded boots can also reduce the amount of crosstalk in the cable and allow it to perform at higher frequencies.

TIP

Category 5 UTP patch cables should be no longer than 10 meters.

Color Codes by Cable Type
UTP Pinning Type | Pinning for Each Wire Pair
568A | Blue 4 and 5 Orange 3 and 6 Green 1 and 2 Brown 7 and 8
568B | Blue 4 and 5 Orange 1 and 2 Green 3 and 6 Brown 7 and 8
USOC | Blue 4 and 5 Orange 3 and 6 Green 2 and 7 Brown 1 and 8

patch panel

A rack-mounted panel with a series of connectors that provides a branching-out point for network cabling to leave the wiring closet and make horizontal runs to wall plates in the work areas.

Graphic P-5. Patch panel.
Graphic P-5. Patch panel.

Patch panels are usually standard 19-inch-wide panels for mounting in equipment racks in wiring closets. They typically contain between 16 and 96 ports for connecting to hubs and switches using patch cables. Patch panels themselves cannot be used to network computers; they are mainly used to organize wiring and to avoid “spaghetti.” The horizontal cables running from the wiring closet to the wall plates are usually connected to the back of the patch panel, while the patch cords connecting to the hubs and switches plug into the front of the patch panel. The back of the patch panel is a form of punchdown block—wires are not soldered but punched down using a sharp tool called a punchdown block tool.

NOTE

Another name for a patch panel is passive hub. A patch panel is a hub only in the sense that it is a physical device in which wires are concentrated, but it cannot be used to network computers. All true hubs used in networking are active hubs, which are powered devices that regenerate signals coming into one port for transmission through other ports on the hub. The term “passive hub” is an older term that is not generally used today.

In telephony applications, the termination point for twisted-pair wiring is usually called a punchdown block instead of a patch panel.

There are a few things you should be aware of when selecting patch panels:

  • Be sure that your patch panels are category 5–approved if you plan to upgrade your network.

  • Do not remove excessive amounts of cable jacket when you terminate category 5 cables to terminal blocks.

  • Purchase patch panels with built-in surge protection to protect expensive Ethernet switches.

Front-access patch panels are easiest to install in cramped conditions. You can use hinged or folding patch panels as a convenient alternative to full-size, rack-mounted patch panels. Modular patch panels allow the greatest flexibility of configuration. Use cable managers to organize and support cables connected to patch panels.

path

The route that a user or application follows to locate a file in a file system, an object in a directory, a server on a network, or some other kind of resource in a hierarchical system. A path to an object can be one of the following:

  • An absolute path, which starts from the root of the file system or directory

  • A relative path, which starts from the user’s current directory or location

Example

On a system running Microsoft Windows, the absolute path to a file is expressed using backslashes, as follows:

C:\Windows\Profiles\Administrator\User.dat

If the current directory is C:\Windows\Profiles, the relative path to the same file is as follows:

\Administrator\User.dat

To access files in shared folders on a Windows network, you can use the Universal Naming Convention (UNC) path:

\\server16\pub\readme.txt

On UNIX platforms, forward slashes are used instead of backslashes, as in this example:

/user/bin/blah.gz

To request a Web page on the Internet, you specify the page’s Uniform Resource Locator (URL), which is essentially the path to the page in the hierarchical Domain Name System (DNS):

http://www.microsoft.com/support/FAQ.htm

PBX

See
Private Branch Exchange (PBX)

PCM

See
pulse code modulation (PCM)

PCS

See
Personal Communications Services (PCS)

PDA

See
Personal Digital Assistant (PDA)

PDC

See
primary domain controller (PDC)

PEC

See
primary enterprise controller (PEC)

peer server

A computer that functions as a server for a group of users in a peer-to-peer network. For example, in a small office with only five users running Microsoft Windows 95 or Windows 98, you can set aside an additional machine running Windows 95 or Windows 98 as a peer server for storing company files.

You should use peer servers only in small networks with no great need for security. Security on peer servers is limited to share-level security, which allows only three kinds of access:

  • Read-only access based on a password

  • Full-control access based on a password

  • A combination of the above, based on two separate passwords

If security is an issue, consider using a dedicated server running Windows NT.

peer-to-peer network

A network in which the computers are managed independently of one another and have equal rights for initiating communication with each other, sharing resources, and validating users.

How It Works

A peer-to-peer network has no special server for authenticating users. Each computer manages its own security, so a separate user account might need to be created for each computer that a user needs to access. Users usually store files on their own computers and are responsible for ensuring that those files are appropriately backed up. In a peer-to-peer network, each computer typically runs both client and server software and can be used to make resources available to other users or to access shared resources on the network.

Peer-to-peer networks are simple to set up and are often ideal for small businesses that have fewer than 10 computers and that cannot afford a server-based solution. The disadvantages of peer-to-peer networks are poor security and lack of centralized file storage and backup facilities.

Microsoft Windows 98 is an ideal operating system for peer-to-peer networks. Networking is easy to set up and configure, folders and printers can be shared, user profiles allow multiple users to share one computer, and you can create an office intranet using the Microsoft Personal Web Server.

See also
server-based network

Performance

See
Performance Monitor

Performance Monitor

A Microsoft Windows NT administrative tool for monitoring the performance of Windows NT servers on a network. (In Windows 2000, this tool is called System Monitor.)

You can use Performance Monitor to

  • Capture real-time performance objects and counters

  • Log, graph, and set alert conditions for performance data

  • Identify bottlenecks and trends in resource usage

  • Observe the effect of system configuration changes

  • Establish a baseline and determine system capacity

    Graphic P-6. Performance Monitor.
    Graphic P-6. Performance Monitor.
How It Works

When you use Performance Monitor, you should collect data on the four main system resources (the memory, processor, disk, and network subsystems) in addition to resources specific to the aspect of server usage you are studying. The following table shows the recommended objects to monitor.

Recommended Objects to Monitor
System Resource | Performance Objects to Monitor
Memory | Memory, cache
Processor | Processor, system
Disk | Logical disk, physical disk
Network | Network segment, network interface, server
TIP

In Windows NT, Performance Monitor can run as a background service without user intervention. Use the monitor.exe utility from the Microsoft Windows NT Server Resource Kit, and use the Windows NT at command to schedule the service to run at appropriate times.

See also
System Monitor

Performance Optimizer

A Microsoft Exchange Server tool that automatically analyzes your hard disk subsystem and suggests where to locate various Exchange components such as the information store and transaction logs. Performance Optimizer also modifies certain registry settings to improve messaging performance.

Performance Optimizer runs when you finish setting up a new Exchange server. You should also run it whenever you change the configuration of a server’s core services—for example, if you change the configuration of the information store, Exchange directory service, or Message Transfer Agent (MTA), if you install or remove a connector or gateway, or if you add more RAM or another disk or processor.

Graphic P-7. Performance Optimizer.
Graphic P-7. Performance Optimizer.

Perl

An acronym for Practical Extraction and Reporting Language, an interpreted scripting language that is often used on UNIX platforms to develop Common Gateway Interface (CGI) programs. CGI scripts written in Perl are often used as input handlers for Hypertext Markup Language (HTML) forms because of Perl’s powerful string manipulation capabilities. However, because Perl is an interpreted scripting language, applications such as form handlers for Web pages that are written in Perl run more slowly than if they were compiled programs written in C or some other high-level programming language.

NOTE

You can use Microsoft’s Windows Script Host (WSH) to run administrative scripts written in Perl by installing a third-party ActiveX scripting engine for Perl. Administrators from UNIX backgrounds can do this to leverage their knowledge of Perl to administer Microsoft Windows NT and Windows 2000.

permanent virtual circuit (PVC)

A form of telecommunications service for wide area networks (WANs) that provides a dedicated switched circuit between two nodes in a circuit-switched network.

How It Works

The switches of a permanent virtual circuit (PVC) are set up and configured by the telco or carrier to provide a permanent, point-to-point connection between the two nodes. These circuits are called “permanent” because the telco dedicates specific resources (switches) to your company—they can’t be used by anyone else as long as you lease the service. The switches are called “virtual” because the customer does not have a physical wire connecting two networks but rather a logical connection between switches configured by the telco’s management software. In fact, the customer does not even need to know how the circuit is set up.

Graphic P-8. Permanent virtual circuit (PVC).
Graphic P-8. Permanent virtual circuit (PVC).

PVCs offer guaranteed bandwidth and extremely low latency for establishing a connection. Also, because the switching pathway is permanent, the quality of the connection does not vary with time. The result is more reliable service than switched virtual circuits (SVCs). However, PVCs are more expensive than SVCs because telco resources are dedicated to the customer and cannot be used for other purposes. Furthermore, with a PVC you pay for the bandwidth whether or not you use it; with SVCs, the amount you pay depends on how much bandwidth you use.

PVCs are best for WAN links that carry steady, high volumes of network traffic. They are commonly used in leased lines for point-to-point WAN links between two networks.

NOTE

The term “permanent virtual circuit” is also used in frame relay networking. This type of circuit is configured in a similar fashion to those used in leased line connections.

See also
switched virtual circuit (SVC), virtual circuit

permissions

Settings that you establish for a resource to control which users and groups can access the resource and what degree of access they have. Permissions are implemented at several levels in Microsoft Windows operating systems and other Microsoft BackOffice applications. Permissions are implemented in Microsoft systems using discretionary access control lists (DACLs), which are attached to the object they control.

Examples of permission types include the following:

  • Shared folder permissions:
    Can be applied to shared folders on Windows systems to control access to network shares by users

  • NTFS permissions:
    Can be applied to files and folders on NTFS volumes for both local and network control of access to the resources

  • Print permissions:
    Can be assigned to printers to control who can manage printers, manage documents, or print documents

  • Active Directory permissions:
    Can be assigned to objects within Active Directory of Windows 2000 using Active Directory Users and Computers

  • Exchange permissions:
    Can be assigned to objects in the Microsoft Exchange Server directory hierarchy to control who can administer different parts of an Exchange organization using the Exchange Administrator program

  • Public folder permissions:
    Can be assigned using Microsoft Outlook to files in public folders to control who can read, edit, or delete those files

Per Seat licensing

A licensing mode in which a client access license (CAL) is assigned to a particular client computer for a particular Microsoft BackOffice server product. A CAL allows the client to access the services of a particular BackOffice product that can be running on any server within the network. Per Seat licensing can be applied to any BackOffice product that requires CALs, such as Microsoft Windows 2000 Server, Windows NT Server, Microsoft Exchange Server, Microsoft SQL Server, Microsoft SNA Server, Microsoft Site Server, and Microsoft Systems Management Server (SMS).

Example

Consider a network that consists of three servers running Windows 2000 Server and 50 assorted client computers running Windows 2000 Professional, Windows 98, Windows for Workgroups, Mac OS, and so forth. If you purchase 50 Per Seat licenses for Windows 2000 Server, one for each client, each client computer can connect to any of the three Windows 2000 Servers.

NOTE

If you use Per Seat licensing, you must purchase a CAL for every client that accesses the BackOffice product, including non-Microsoft clients such as Macintosh and UNIX clients.

TIP

Per Seat licensing is often the preferred mode of licensing on networks with a large number of servers. On networks with only one or two servers, Per Server licensing might be a more economical option.

See also
client access license (CAL), Per Server licensing

Per Server licensing

A licensing mode in which a client access license (CAL) is assigned to a particular server computer running a particular Microsoft BackOffice server product. Each CAL allows only one connection per client computer to the particular BackOffice product. Per Server licensing can be applied to only the following BackOffice products: Microsoft Windows 2000 Server, Windows NT Server, Microsoft SQL Server, Microsoft SNA Server, and Microsoft Site Server.

Example

Consider a server computer on a network running Windows 2000 Server that has 25 Windows 2000 Server Per Server CALs. A total of 25 client computers can simultaneously connect to the Windows 2000 Server and access its services. If a twenty-sixth client tries to connect, it will be denied access and an entry will be written to the application log.

NOTE

One client computer can connect to multiple shares on the server, but this is counted as only one connection for licensing purposes.

TIP

Per Server licensing is the preferred mode of licensing on small networks. However, you must purchase licenses equal to the maximum number of simultaneous connections you anticipate on each server for a particular BackOffice product. If you are not sure whether to use Per Seat or Per Server licensing, choose Per Server licensing. As more servers are added to your network, you can perform a one-time, one-way conversion of Per Server to Per Seat licenses as required. However, you cannot convert Per Seat licenses to Per Server licenses.

See also
client access license (CAL), Per Seat licensing

persistent connection

Generally, any network connection that is opened and then is kept open in case it is needed again.

Example

The Windows Internet Name Service (WINS) for Microsoft Windows 2000 Server uses persistent connections between WINS replication partners. Windows 2000 Server WINS replication partners maintain persistent connections among themselves so that replication can be initiated at any time without the network traffic overhead associated with establishing new connections. This means that WINS databases are updated immediately and shared network resources are always available.

In the earlier version of WINS for Windows NT Server, however, replication partners had to open a new connection between each other every time WINS replication was initiated. As a result, most administrators of large networks configured WINS replication to occur at certain time intervals or after a certain number of updates to the WINS database had accumulated. Because of delays in updating WINS databases on WINS servers, clients sometimes could not access shared network resources.

persistent index

An index created by Microsoft Indexing Service. Persistent indexes are stored on disk and are more efficient and compressed than word lists, which are stored in volatile RAM. All persistent indexes are ultimately merged into a single, highly efficient persistent index called the master index. The process by which this occurs is known as a master merge.

Personal Communications Services (PCS)

A general term for digital cellular phone technologies that are used for personal wireless mobile communication. Personal Communications Services (PCS) technologies were developed in the early 1990s because the existing Advanced Mobile Phone Service (AMPS) technologies were running out of available bandwidth in the electromagnetic frequency spectrum. PCS systems are end-to-end digital in nature and are more secure than analog cellular systems. PCS networks can be used for voice, fax, and data applications such as e-mail and file transfers. PCS systems are generally circuit-switched, although some are being migrated to packet-switched networks.

Some of the standards and technologies that developed from the PCS initiatives include the following:

  • Time Division Multiple Access (TDMA) digital cellular systems based on the TDMA IS-136 standard. TDMA divides frequency bands into time slots and then multiplexes user conversations within these slots. TDMA operates in both the 800-MHz and 1900-MHz frequency bands, but only frequencies at 1900 MHz are specifically referred to as PCS, while those in the 800-MHz range are referred to as cellular.

  • Code Division Multiple Access (CDMA) digital cellular systems based on the CDMA IS-95 standard, which was developed by QUALCOMM. CDMA uses spread-spectrum transmission technologies and assigns codes to individual users transmitting within the same broad frequency spectrum. CDMA operates at both the 800-MHz and 1900-MHz frequencies, but only frequencies at 1900 MHz are specifically referred to as PCS, while those in the 800-MHz range are referred to as cellular.

  • Global System for Mobile Communications (GSM) digital cellular systems based on the GSM 1900 standard. GSM is based on TDMA technologies and divides frequency bands into time slots. GSM has the advantage of supporting roaming between Europe and North America. GSM operates in the 1900-MHz frequency range (or the 1800-MHz range in Europe).

PCS systems and services can also be classified as follows:

  • Narrowband PCS:
    Uses the 900-MHz portion of the electromagnetic spectrum, specifically the frequency bands 901–902, 930–931, and 940–941 MHz. Narrowband PCS is used for wireless telephony, wireless data transmission, voice message paging and text-based paging, and other services.

  • Broadband PCS:
    A newer technology that uses the 2-GHz portion of the electromagnetic spectrum, specifically the frequency band from 1850 to 1990 MHz, with the exception of a 20-MHz band reserved for unlicensed voice and data services. Broadband PCS with its greater bandwidth allocation is used or intended for wireless telephony, high-speed wireless data transmission, portable facsimile transmission, wireless Personal Digital Assistants (PDAs), and wireless video telephony services.

Personal Digital Assistant (PDA)

A handheld computer that is programmed for functions such as keeping track of appointments, sending and receiving e-mail, browsing the Internet, composing memos, performing spreadsheet calculations, managing contacts, banking, and viewing stock quotes.

Personal Digital Assistants (PDAs) typically have a small, grayscale liquid crystal display (LCD) with either a small keyboard or a pen-based user interface for entering data. Information can be exchanged with a desktop or laptop PC by using a docking cradle, serial port, or infrared (IR) communication port, depending on the model. A PDA’s processing power is similar to that of a 386 processor, and its memory is limited to a few megabytes (but is sometimes expandable). Many PDAs also support standard or even wireless modems for sending and receiving e-mail or accessing specialized Internet content.

Some PDAs run a proprietary operating system. For example, 3Com’s Palm Pilot runs Palm OS; about 7500 developers produce software for this platform. One of the earliest PDAs was the Apple Newton. Other PDAs run Microsoft Windows CE, a version of the Windows operating system for devices with a small screen and a nonstandard user interface. Microsoft offers Windows CE versions of many of its popular applications, including Microsoft Word, Excel, Outlook, PowerPoint, and Internet Explorer.

PDA management is becoming an increasingly important job for network administrators. It’s often a good idea to standardize the type of PDA that is used in a company to reduce the headache and overhead of administering multiple PDA-to-PC software interfaces.

personal folders

A hierarchy of folders in Microsoft Outlook and other Microsoft Windows messaging clients that users can create and modify and that stores users’ messages and attachments. Personal folders, which can be stored on the client machine or on a network share, have the extension .pst.

NOTE

In many situations, it is advantageous not to use personal folders. Using personal folders can make messages less accessible. For example, Microsoft Exchange Server stores users’ messages in the information store on the Exchange server. This allows users to access their messages from any messaging client that can access the Exchange server. If messages are moved to personal folders, those messages can be read only from clients that can access the personal folders file. It is possible to use a combination approach, in which messages that need to be accessible from different clients can be left on the server and messages that are rarely accessed can be moved to personal folders. Here are some reasons why you might want to use personal folders:

  • For backing up folders and their messages

  • For archiving old messages

  • For reducing the space taken up by messages on the server (a disk space limit for messages is typically set on the server)

  • For moving some messages to the disk of a laptop computer to work off-site

Users can password protect their personal folders, but if they forget the password they cannot reset it.

Personalization and Membership servers

Related components of Microsoft Site Server that enable Web site administrators to personalize content for site visitors and provide secure content based on site membership. Features of the Personalization and Membership servers include the following:

  • Personalized content suited to individual visitors’ needs. Site administrators can build rules governing personalized content and store user profiles in the Membership Directory.

  • Members-only areas on a site with controlled access for users. Site administrators can register users, protect and share their data, verify users’ identities, and control access to sites. User information is stored in a Lightweight Directory Access Protocol (LDAP) directory based on Microsoft SQL Server.

  • Direct mail for delivering personalized content to site visitors through scheduled e-mail based on their site usage patterns.

How It Works

Membership Authentication on the Personalization and Membership servers builds on Microsoft Windows NT security by letting administrators store user accounts and group permissions in the Site Server Membership Directory. Access to Web content is controlled by granting users and groups permissions on Web content using the same Windows Explorer method that Windows NT and Internet Information Services (IIS) administrators use.

By storing user and group accounts in the Membership Directory, you can enable sites to scale beyond the capabilities of the Windows NT Security Account Manager. In other words, instead of managing tens of thousands of accounts using the Windows NT domain model, you can use Personalization and Membership servers to manage millions of user accounts. This is particularly important if a cookie account and a user profile must be created for every user visiting the site.

Tools are also included for creating registration pages to handle creating new user accounts in the Membership Directory, adding users to groups, and upgrading cookie users to secured accounts. You can manage membership by using Microsoft Management Console (MMC) or through Web-based Administration (WebAdmin).

TIP

When you plan an implementation of Site Server, you must decide whether to use Windows NT Authentication or Membership Authentication. You cannot reverse your decision later without rebuilding the Membership Directory, which essentially means redoing all your initial implementation work. Use Windows NT Authentication for Windows NT–based intranets in which user accounts already exist for network users. Use Membership Authentication for Internet sites and for intranet sites in which Windows NT accounts do not yet exist. Membership Server is also suitable for any type of site in which users must self-register and thus create and manage their own profiles, which eases the burden on the Site Server administrator. For example, the information that intranet users create in the Membership Directory can form the basis of your corporate information directories with little administrative overhead.

Personal Web Server (PWS)

See
Microsoft Personal Web Server (PWS)

PGP

See
Pretty Good Privacy (PGP)

physical address

See
MAC address

physical layer

Layer 1 (or the PHY layer) of the Open Systems Interconnection (OSI) reference model. The physical layer is the bottom layer of the seven-layer OSI networking architecture model. It establishes the physical interface and mechanisms for placing a raw stream of bits onto the wire. It defines the voltage, current, modulation, bit synchronization, connection activation and deactivation, and various electrical characteristics for the transmission media (such as unshielded or shielded twisted-pair cabling, coaxial cabling, and fiber-optic cabling). Protocols at the PHY layer include IEEE 802.3, RS-232C, and X.21. Repeaters, transceivers, network interface cards (NICs), and cabling operate at the PHY level.

See also
Open Systems Interconnection (OSI) reference model, protocol

ping

Stands for Packet Internet Groper, a TCP/IP utility that verifies the integrity of a network connection with a host on a TCP/IP network. The ping command is one of the first commands to use to troubleshoot communication problems on a TCP/IP network.

How It Works

At the command prompt, type ping followed by either the IP address or the fully qualified domain name (if the Domain Name System is implemented) of the host for which you want to test networking connectivity. One or multiple Internet Control Message Protocol (ICMP) echo packets are sent to the host, and if connectivity is working, an equal number of echo replies are received. The replies show the packet size in bytes, response time in milliseconds, and Time to Live (TTL) of the echo reply. The TTL is decremented for each hop along the way and indicates the number of routers (hops) passed through along the network path.

The usual procedure for using ping to troubleshoot a TCP/IP network follows:

  • Verify that TCP/IP is installed and running by pinging the local loopback address using ping 127.0.0.1.

  • Ping your own IP address and host name.

  • Ping the IP address of the default gateway for your local network.

  • Ping the IP address of a host on a remote network.

If these steps produce the expected results, TCP/IP is installed and running on your network.

TIP

For advanced syntax features, simply type ping instead of ping /?.

If you can ping a host’s IP address but not its fully qualified domain name (FQDN), you probably have a name resolution problem. Check your Domain Name System (DNS) configuration and make sure that the DNS server is running, or check your Hosts file if it is implemented.

PKCS

Stands for Public Key Cryptography Standards, a set of standards developed by an industry consortium headed by RSA Laboratories and including Microsoft that specifies how a public key cryptography system should be implemented and operated. The following table shows the standards that are important to public key cryptography.

Public Key Cryptography Standards
Standard | Description
PKCS #1 | Specifies how to encrypt and sign data using RSA encryption
PKCS #2 | Now included in PKCS #1
PKCS #3 | Describes the Diffie-Hellman key exchange protocol
PKCS #4 | Now included in PKCS #1
PKCS #5 | Specifies how to encrypt data using a secret key derived from a user’s password
PKCS #6 | Specifies the syntax standard for extended certificates
PKCS #7 | Specifies the general syntax of messages that include cryptographic enhancements such as encryption and digital signatures
PKCS #8 | Specifies the format for private key information
PKCS #9 | Specifies various attribute types that are used in other PKCS standards
PKCS #10 | Specifies the syntax for requesting digital certificates
PKCS #11 | Specification for the Cryptoki application programming interface (API), which is used in smart cards
PKCS #12 | Specifies a portable format for storing and transporting certificates, private keys, and so forth
PKCS #13 | Specifies standards for elliptic curve cryptography (under development at the time of this writing)
PKCS #14 | Specifies standards for generating pseudo-random numbers (under development at the time of this writing)
PKCS #15 | Specifies the standard format for cryptographic token information (under development at the time of this writing)
On the Web
•
RSA Security home page
: http://www.rsasecurity.com
See also
PKCS #7, PKCS #12

PKCS #7

Also called the Cryptographic Message Syntax Standard, a cryptographic standard from RSA Security for the exchange of digital certificates in public key cryptography. PKCS #7 specifies the syntax of digital certificates and other encrypted information—specifically, the method by which data is encrypted and digitally signed, as well as the algorithms involved.

How It Works

You can use PKCS #7 to encrypt two types of data:

  • Base data:
    Data that has not been encrypted and contains no cryptographic enhancements such as hashes or digital signatures.

  • Enhanced data:
    Data that is encrypted or contains cryptographic enhancements or both. Enhanced content encapsulates one form of content within another.

A variety of content types are defined by the PKCS #7 standard, including the following:

  • Data:
    String of bytes or octets.

  • Signed data:
    Data along with an encrypted message digest. A message digest is the value produced when a hashing algorithm is applied to data. (The terms “digest” and “hash” are synonymous.) The message digest is used by the recipient to confirm that the original message was not tampered with during transit and to validate the identity of the sender.

  • Enveloped data:
    Encrypted data plus the public key that can decrypt the data. You use this method to keep the contents of the message secret from all but trusted recipients.

  • Signed-and-enveloped data:
    Encrypted content with its public key and doubly encrypted message digest.

  • Digested data:
    Data plus a message digest.

  • Encrypted data alone:
    The public key for decrypting the data must be transmitted by some other mechanism in this case.

When you use PKCS #7 to sign data, it usually includes the signing certificates, a list of relevant certificate revocation lists, and any other certificates in the certification path. If you use PKCS #7 to encrypt data, it usually includes references to the issuer and the serial number of the certificate that is associated with the public key that can be used to decrypt the encrypted data.

PKCS #7 supports additional features, such as the following:

  • Recursion, in which a digital envelope is enclosed in a digital envelope, which is enclosed in another digital envelope, and so on

  • Time-stamping of encrypted messages and digital signatures

  • Counter-signatures and user-defined attributes

See also
PKCS

PKCS #12

A cryptographic standard for the exchange of digital certificates in public key cryptography. PKCS #12 is an industry-standard format for the transfer, backup, and restoration of digital certificates and their associated public or private keys. PKCS #12 is the export format that is usually used to export a digital certificate with its private key, because exposing a user’s private key using a less secure method of export poses a security risk. PKCS #12 is used to export certificates to other computers, to removable media for backup purposes, or to smart cards to enable smart card authentication schemes.

See also
PKCS

PKI

See
public key infrastructure (PKI)

Plain Old Telephone Service (POTS)

The basic analog telecommunications service provided by a local telco. Plain Old Telephone Service (POTS) was the only type of telephone service until the 1970s.

How It Works

Starting from your home or customer premises, two-pair copper twisted-pair wire runs to your local telco’s central office (CO). This copper wire connection forms what is known as the local loop. The CO has switches that connect you to another local subscriber, to another CO, or to a long-distance provider, depending on whether your call is local or long distance. POTS is an inexpensive circuit-switched telecommunications service, but it supports data transfer speeds up to only 56 Kbps. It typically takes 15 to 30 seconds to establish connections for data transfer using modems.

plenum cabling

Also known as CMP cabling, a grade of cabling that is resistant to combustion and is used for horizontal cable runs in building plenums and vertical rises such as elevator shafts. A plenum is a horizontal space within a building that houses building components and allows the movement of air. False ceilings are not considered plenums. Plenum cabling is less flexible and costlier than polyvinyl chloride (PVC) cabling. The external insulating jacket of plenum cabling is usually a fluoropolymer such as Teflon FEP.

Plug and Play

A design philosophy and set of specifications for PC architectures that enables computer hardware, peripherals, device drivers, and operating systems to be easily reconfigured with minimal user understanding and intervention. Plug and Play frees users from having to manually configure devices and device drivers when they add or remove peripherals from computer systems. For example, to configure a non–Plug and Play sound card, a user typically has to manually change jumpers or dual inline package (DIP) switches on the sound card itself, a task that is often difficult for the inexperienced user. With Plug and Play, you simply plug in the device and follow a series of prompts (if any are necessary) to configure the appropriate drivers for your device.

How It Works

A true Plug and Play system consists of the following three elements:

  • A Plug and Play operating system such as Microsoft Windows 95, Windows 98, or Windows 2000.

  • A Plug and Play system BIOS that supports Advanced Power Management 1.1 (Windows 95) or Advanced Configuration for Power Management (Windows 98), automatic configuration of boot and motherboard devices, hot docking, and other features.

  • Plug and Play system buses such as PCI or universal serial bus (USB) and Plug and Play peripheral devices (internal or external) and their associated drivers. Plug and Play peripheral devices include USB, IEEE 1394, SCSI, PCMCIA, and PCI devices. ISA, EISA, and VESA devices are not fully Plug and Play. Other Plug and Play devices include IDE controllers, ECP parallel ports, and video adapters.

If a system does not support all three of these features, it is not truly Plug and Play, although it might have some limited Plug and Play support. In a completely Plug and Play system, these features work together to automatically enumerate (identify) new devices installed on or connected to the system, determine their resource requirements, establish a system configuration that can support these requirements without device conflicts, program the devices as necessary and load their device drivers, and notify the user of the changes to the system’s configuration.

The Windows 95 and Windows 98 components that work together to support Plug and Play include the following:

  • Configuration Manager:
    Manages the device configuration process by communicating with the BIOS, motherboard, and peripheral devices.

  • The hardware tree:
    Contains the current system configuration information. The hardware tree is dynamically constructed by Configuration Manager upon each reboot and uses information in the registry to configure the system’s devices. You can display information stored in the hardware tree by using the Device Manager tab of the System Properties dialog box (double-click the System icon in Control Panel).

  • Bus and port enumerators:
    Build the hardware tree by enumerating attached devices. Different enumerators are used for each type of system and peripheral bus.

  • Resource arbitrators:
    Allocate system resources such as interrupt requests (IRQs) and input/output (I/O) ports to devices and resolve conflicts between devices.

  • Setup and Device Installer:
    Creates the configuration database during initial system setup and can assist in installing non–Plug and Play devices by using the Add New Hardware Wizard.

When you add a new hardware device to a Plug and Play system, the Add New Hardware Wizard starts and installs the necessary drivers for the hardware. The wizard selects suitable hardware resources for the device, which might include an IRQ line, I/O address, direct memory access (DMA) channel, and memory range. If the system cannot properly detect the hardware, you can manually run the Add New Hardware Wizard to configure the hardware.

TIP

Be sure that the new device is attached to the computer and is turned on before you run the Add New Hardware Wizard.

P-node

A NetBIOS name resolution method used for name registration and resolution. P-node is one of the types of NetBIOS over TCP/IP nodes defined in Request for Comments (RFC) numbers 1001 and 1002, and is supported by computers running Microsoft Windows NT and Windows 2000.

How It Works

Name resolution is the process of converting the name of a host on the network into a network address (such as an IP address). Name resolution must be performed to establish communication over a network. P-node is one of four basic methods supported by Windows NT for resolving NetBIOS host names (that is, computer names) into IP addresses.

If a computer running Windows NT is configured as a P-node machine, it does not use broadcasts to resolve the names of the hosts. Instead, it tries to query a NetBIOS name server to resolve names of other hosts on the network. The advantage of doing this is that name resolution can function across large internetworks consisting of IP subnets connected with routers. Routers normally block broadcasts but will forward packets directed toward a specific name server.

A server running the Windows Internet Naming Service (WINS) is a typical example of a NetBIOS name server. If the WINS server is unavailable to the client issuing the query, the requested name cannot be resolved into its associated IP address. Furthermore, each client must be configured with the IP address of the WINS server in order for P-node name resolution to work. For this reason, M-node or H-node methods are usually preferred; they can use both broadcasts and directed traffic to resolve NetBIOS names of hosts.

See also
B-node, H-node, M-node, NetBIOS name resolution

pointer (PTR) record

A resource record in a zone file that contains a record associating an IP address with a host name in the in-addr.arpa domain. Pointer (PTR) records are used for reverse name lookups and provide host name to IP address mappings. Here is an example of a PTR record:

1.141.205.202.in-addr.arpa      IN  PTR     server9.microsoft.com.

In this PTR record, the IP address 202.205.141.1 is mapped to the host Server9 within the microsoft.com domain. Note that the IP address of the host appears in the reverse order in the in-addr.arpa domain.

NOTE

With the DNS service installed on Microsoft Windows NT or Windows 2000, you can automatically create an associated PTR record for each host when you create its host record.

See also
Domain Name System (DNS)

point of presence (POP)

The local access point for an Internet service provider (ISP). A point of presence (POP) consists of the high-speed telecommunications equipment and technologies that enable users to connect to the Internet via their ISP. The POP might include call aggregators, modem banks, routers, and high-speed Asynchronous Transfer Mode (ATM) switches. A POP has one or more unique IP addresses plus a pool of assignable IP addresses for its permanent and dial-up clients. The actual POP for an ISP might be located within the telecommunications facility of a telco or a long-distance carrier. The ISP rents or leases space in the facility to install the routers and access servers that provide Internet connectivity for clients and for the equipment that provides the ISP with a high-speed T1 or T3 connection to the Internet’s backbone.

point-to-multipoint

A form of communication that provides a path from one fixed point to a number of other points.

How It Works

A point-to-multipoint (or simply multipoint) wide area network (WAN) consists of more than two end nodes connected using a packet-switching telecommunications network. A number of layer 2, or data-link layer, protocols support multipoint WANs, including frame relay, Switched Multimegabit Data Services (SMDS), Asynchronous Transfer Mode (ATM), and X.25 packet-switched networks.

A public or private frame relay network can be used to connect multiple networks into a multipoint WAN configuration, as shown in the following diagram. Each end node is configured with a unique data-link address, which allows any node on the WAN to communicate with any other node.

NOTE

The various data-link layer protocols can also be used for point-to-point WAN connections, but other layer 2 protocols such as the Point-to-Point Protocol (PPP) are simpler to implement for point-to-point WAN communication.

Graphic P-9. Point-to-multipoint.
Graphic P-9. Point-to-multipoint.
See also
point-to-point

point-to-point

A form of communication that provides a direct path from one fixed point to another.

How It Works

A point-to-point wide area network (WAN) consists of two end nodes connected by a leased line. In a typical configuration, a router on the network is connected using a serial transmission interface such as V.35 to a Channel Service Unit (CSU) at the local customer premises. The CSU provides the interface between the router and the telco’s leased line. An identical setup is configured at the remote customer premises. Because there are only two end nodes in a point-to-point WAN link, addressing need not be provided for the end nodes at the data-link layer.

Point-to-point WAN connections typically use High-level Data Link Control (HDLC), Point-to-Point Protocol (PPP), or one of their derivatives—such as Point-to-Point Tunneling Protocol (PPTP)—as the layer 2, or data-link layer, protocol for encapsulating local network traffic into frames for transmission over the WAN link.

NOTE

The term “point-to-point” is also used more generally. For example, the configuration of a terminal connected to a minicomputer using two short-haul asynchronous modems is referred to as a point-to-point connection.

Graphic P-10. Point-to-point.
Graphic P-10. Point-to-point.
TIP

PPP is usually used in heterogeneous networking environments in which the routing and access equipment comes from different vendors, while HDLC tends to be used in homogeneous networking environments in which the routers and access equipment run only Cisco’s Internetwork Operating System (IOS) software.

See also
point-to-multipoint

Point-to-Point Protocol (PPP)

An industry standard data-link layer protocol for wide area network (WAN) transmission that was developed in the early 1990s. Point-to-Point Protocol (PPP) allows Remote Access Service (RAS) products and devices from different vendors to interoperate for WAN communication.

How It Works

PPP supports the transmission of network packets over a serial point-to-point link by specifying framing mechanisms for encapsulating network protocols such as Internet Protocol (IP), Internetwork Packet Exchange (IPX), or NetBEUI into PPP frames. PPP encapsulation is based on the High-level Data Link Control (HDLC) derived from the mainframe environment. These PPP frames can be transmitted over serial transmission lines such as Plain Old Telephone Service (POTS), Integrated Services Digital Network (ISDN), and packet-switched networks such as X.25. PPP includes an extensible Link Control Protocol (LCP) for establishing, tearing down, and testing data-link WAN connections, as well as a number of Network Control Protocols (NCPs) for establishing and configuring network communication using each network protocol. PPP also supports a number of authentication schemes, such as Password Authentication Protocol (PAP) and Challenge Handshake Authentication Protocol (CHAP).

A typical dial-up session using PPP is completely automated and requires no real-time user input. It has four stages:

  • Link establishment:
    PPP uses LCP to establish and maintain a PPP link over a serial transmission line. LCP frames are sent over the data link to test its integrity and establish the link.

  • User authentication:
    PPP uses one of several authentication protocols, including PAP, CHAP, and Microsoft Challenge Handshake Authentication Protocol (MS-CHAP).

  • Callback:
    PPP Callback Control (Microsoft’s implementation of PPP) uses Callback Control Protocol (CBCP) if it is configured.

  • Configuration:
    NCPs are used to establish network connections, perform compression and encryption, lease IP addresses using Dynamic Host Configuration Protocol (DHCP), and so on. NCP frames are sent over the link to establish a network connection between the PPP server and the remote PPP client.

NOTE

PPP is superior to the older Serial Line Internet Protocol (SLIP) in that it offers error correction and dynamic negotiation without user intervention, supports multiple network protocols simultaneously, and is faster. PPP is the basis for the Point-to-Point Tunneling Protocol (PPTP) and the Layer 2 Tunneling Protocol (L2TP), which can be used to create virtual private networks (VPNs). PPP is supported by Microsoft Windows 2000, Windows NT, Windows 95, and Windows 98 and is the default setting for Network and Dial-up Connections, RAS, and connectivity to the Internet.

TIP

If you can connect to a remote PPP server but you can’t ping the remote server, try turning off IP header compression. Windows 98 also allows you to record all PPP communication in a ppplog.txt log file for troubleshooting purposes. Open the property sheet of your dial-up networking icon, select the Server Types tab, and select the Record A Log File For This Connection option.

Point-to-Point Tunneling Protocol (PPTP)

A data-link layer protocol for wide area networks (WANs) based on the Point-to-Point Protocol (PPP) and developed by Microsoft that enables network traffic to be encapsulated and routed over an unsecured public network such as the Internet. Point-to-Point Tunneling Protocol (PPTP) allows the creation of virtual private networks (VPNs), which tunnel TCP/IP traffic through the Internet. Remote users can securely access corporate local area network (LAN) resources using the Internet instead of having to use direct modem connections over the Public Switched Telephone Network (PSTN) or dedicated leased-line connections.

How It Works

PPTP is an extension of PPP and is based on PPP negotiation, authentication, and encryption schemes. PPTP encapsulates Internet Protocol (IP), Internetwork Packet Exchange (IPX), or NetBEUI packets into PPP frames, creating a “tunnel” for secure communication across a LAN or WAN link. The PPTP tunnel is responsible for authentication and data encryption and makes it safe to transmit data over unsecured networks.

PPTP supports two types of tunneling:

  • Voluntary tunneling:
    Initiated by the PPTP client (such as Microsoft Windows 95, Windows 98, Windows NT, or Windows 2000). This type of tunneling does not require support from an Internet service provider (ISP) or network devices such as bridges.

  • Compulsory tunneling:
    Initiated by a PPTP server at an ISP. This type of tunneling must be supported by network access servers (NAS’s) or routers.

No matter which type of tunneling you use, you must use a PPTP server. Corporations can set up dedicated PPTP-enabled servers on their networks using Windows NT Server.

NOTE

Microsoft’s Remote Access Service (RAS) for Windows NT supports PPTP through both dedicated and dial-up Internet connections. To enable Windows NT Server to act as a PPTP server, click Network in Control Panel, click the Advanced button on the TCP/IP property sheet, and select Enable PPTP Filtering.

TIP

Because PPTP supports multiple network protocols, including IP, IPX, and NetBEUI, two computers can establish a tunnel over the Internet only if they are running the same network protocol. To troubleshoot PPTP over a TCP/IP connection, use ping to determine whether you are connected to your PPTP server. Also be sure that you have trusted credentials in the domain of the PPTP server, and be sure that you don’t have an active Winsock Proxy client that might be redirecting PPTP packets to a proxy server instead of to your VPN.

polyvinyl chloride (PVC) cabling

A grade of network cabling that uses polyvinyl chloride (PVC) plastic for its outer protective insulating jacket. Polyvinyl chloride cabling is cheap and flexible but gives off dangerous gases during combustion. Building codes usually require that plenum cabling be used instead of polyvinyl chloride cabling for horizontal runs from wiring closets to wall plates. Polyvinyl chloride cabling is usually used to connect wall plates to computers. Both coaxial and twisted-pair cabling are generally available in either polyvinyl chloride or plenum-grade jackets.

POP

See
point of presence (POP)

POP3

See
Post Office Protocol version 3 (POP3)

port

In TCP/IP networking, an endpoint of a logical connection between two hosts on an internetwork. Ports are identified by port numbers. A port identifies a unique process for which a server can provide a service or the client can access a service. Ports can be Transmission Control Protocol (TCP) ports or User Datagram Protocol (UDP) ports, depending on the type of service supported.

In general networking terminology, a port is a connector for attaching cables or peripherals to a computer—for example, a parallel port for connecting a printer to a computer or a serial port for connecting a serial mouse or modem to a computer. Connectors on networking components, such hubs or routers, are also sometimes called ports, although a better term for a connector on a router is a “router interface.”

portal

A Web site that provides a collection of services for Internet users, such as the following:

  • A directory of interesting or useful sites

  • A search engine for finding sites on the Internet

  • Public information services such as weather, white pages, yellow pages, maps, and stock quotes

  • Opportunities to purchase goods and services on line

  • Information and frequently asked questions (FAQ) for new users of the Internet

  • Registration services for receiving free newsletters via e-mail

  • Chat areas for discussing various topics and for building online communities

  • Games

Some of the leading Internet portals are listed below.

On the Web
•
Microsoft Network (MSN)
: http://www.msn.com
•
Yahoo!
: http://www.yahoo.com
•
America Online (AOL)
: http://www.aol.com
•
Lycos
: http://www.lycos.com
•
Netscape Netcenter
: http://www.netscape.com

port number

A 16-bit integer assigned to a port on a TCP/IP host that enables the host to communicate with another host on the network. Ports can have numbers between 0 and 65,536 and are divided into two types:

  • Well-known port numbers, which are fixed numbers between 0 and 1023 and are assigned by the Internet Assigned Numbers Authority (IANA). Some of these numbers are currently unassigned or reserved for future use.

  • Dynamically assigned port numbers, which the operating system assigns as needed when a TCP/IP application or service requests a port. These numbers are between 1024 and 65,536 and can be released and reassigned as needed.

NOTE

Transmission Control Protocol (TCP) and User Datagram Protocol (UDP) ports are different, but TCP and UDP ports use the same assigned port numbers for a given TCP/IP application or service whenever possible.

See also
well-known port numbers

POSIX

An acronym for Portable Operating System Interface for UNIX, one of several standards developed by the Institute of Electrical and Electronics Engineers (IEEE) for cross-platform implementations of UNIX. POSIX is a standard operating system interface and environment that supports portability of applications at the source code level. POSIX arose because different vendors were producing different “flavors” of UNIX; code written for one platform would not run on another platform unless it was modified appropriately. The solution was to develop a standard in which code could be portable between all UNIX flavors, so that a POSIX call in one program would work on any other POSIX-compliant system.

Because of vendor-specific enhancements most UNIX systems are not 100 percent POSIX-compliant. The POSIX.1 standard defines the portability of C language code by specifying a standard application programming interface (API). Microsoft Windows NT and Windows 2000 are fully compliant with the POSIX.1 standard, which means that the POSIX subsystem of Windows NT or Windows 2000 can run native C language code written to the POSIX.1 standard. Windows NT does not support other POSIX standards.

POSIX Standards
Standard | Description
POSIX.1 | Specifies the base system interfaces for C language programming
POSIX.2 | Specifies standards for shells and system utilities plus additional C language interfaces
POSIX.3 | Specifies methods for testing conformance to POSIX
POSIX.4 | Adds real-time extensions to POSIX.1
POSIX.5 | Extends POSIX.1 to the Ada programming language
POSIX.9 | Extends POSIX.1 to the FORTRAN77 language

POST

See
power-on self test (POST)

postoffice

The central message store in a legacy Microsoft Mail system.

How It Works

The postoffice consists of a series of message storage directories on the Microsoft Mail file server. The postoffice stores information such as user ID, password, user preferences, message folders, mail messages, and attachments. The postoffice is a passive file system; no active software runs on it. The International Telecommunication Union (ITU) refers to this component of a mail system as the “message store.”

Post Office Protocol version 3 (POP3)

An Internet standard protocol for storing and retrieving messages from Simple Mail Transfer Protocol (SMTP) hosts.

How It Works

SMTP provides the underlying transport mechanism for sending e-mail messages over the Internet, but it does not provide any facility for storing messages and retrieving them. SMTP hosts must be continuously connected to one another, but most users do not have a dedicated connection to the Internet.

Post Office Protocol version 3 (POP3) provides mechanisms for storing messages sent to each user and received by SMTP in a receptacle called a mailbox. A POP3 server stores messages for each user until the user connects to download and read them using a POP3 client such as Microsoft Outlook 98, Microsoft Outlook Express, or Microsoft Mail and News.

To retrieve a message from a POP3 server, a POP3 client establishes a Transmission Control Protocol (TCP) session using TCP port 110, identifies itself to the server, and then issues a series of POP3 commands:

  • stat:
    Asks the server for the number of messages waiting to be retrieved

  • list:
    Determines the size of each message to be retrieved

  • retr:
    Retrieves individual messages

  • Quit:
    Ends the POP3 session

NOTE

After a POP3 client reads a message in its mailbox on a POP3 server, the message is deleted. Primarily because of this, POP3 is being supplanted by Internet Mail Access Protocol version 4 (IMAP4), which offers better support for mobile users. POP3 is supported by Microsoft Exchange Server.

TIP

To troubleshoot problems with remote POP3 servers, use Telnet to connect to port 110 and examine the results as you try issuing various POP3 commands such as the ones just described.

potential browser

A computer on a Microsoft Windows NT network that can assume the role of a master browser or a backup browser if required to do so. If a new backup browser is needed, the master browser can appoint a potential browser as a backup browser. If a new master browser is needed, an election takes place to determine which potential browser should assume the role. If a computer running Windows joins a Windows NT network and its MaintainServerList parameter is set to either Auto or Enabled, it informs the master browser that it is a potential browser. The MaintainServerList parameter is configured differently depending on the version of Windows involved:

  • Windows NT uses the following registry key:

    Hkey_Local_Machine
    System
        CurrentControlSet
            Services
                Browser
                    Parameters

  • Windows 95 and Windows 98 use the Browse Master property in File and Printer Sharing for Microsoft Networks.

  • Windows 3. x uses MaintainServerList in the system.ini file.

TIP

You should disable MaintainServerList on machines running Windows 3. x , Windows 95, and Windows 98 because these operating systems are used on client machines that can occasionally be rebooted, causing spurious elections to occur.

See also
Computer Browser service

POTS

See
Plain Old Telephone Service (POTS)

power-on self test (POST)

A special set of ROM routines that run whenever a PC is booted. The power-on self test (POST) is designed to test whether system components are functioning properly before attempting to boot the operating system, and checks such things as the RAM, keyboard, and disk drives. If a problem is detected during the POST, the system typically emits a series of beeps and displays a corresponding error message giving some indication of the problem. Specific problems are indicated by different numbers of beeps, but the interpretation of these varies depending on the BIOS used.

TIP

On newer Pentium II or III systems that use the popular AMI WinBIOS, use the following table to interpret the number of beeps in order to troubleshoot the problem.

POST Beep Codes for AMI WinBIOS
Number of Beeps | Problem | Resolution
1, 2, or 3 | Memory error | Check speed and voltage of dual inline memory modules (DIMMs), try reseating DIMMs, or replace DIMMs
4 | Timer error | Replace motherboard
5 | CPU error | Try replacing CPU, or replace motherboard
6 | Gate A20 error | Try reseating keyboard controller chip, try replacing keyboard controller chip, or replace motherboard
7 | Interrupt error | Replace motherboard
8 | Video memory error | Try reseating the video RAM (VRAM), try replacing the VRAM, or replace video card
9 | BIOS ROM error | Replace BIOS ROM chip

Power Users group

A built-in group in Microsoft Windows NT and Windows 2000. The Power Users group is a local group that exists only on member servers and workstations. The initial membership of this group is empty. Generally speaking, a power user is a person who is familiar with the advanced features of a program’s user interface. In Windows NT, a power user is a user who has certain rights.

The Power Users group has preassigned rights including the following:

  • Log on locally

  • Access this computer from the network

  • Change the system time

  • Shut down the system

Power users also have the right to share and manage local disk resources and printers and to create and modify local user accounts on the local machine.

See also
built-in group

PPP

See
Point-to-Point Protocol (PPP)

PPP Multilink

A protocol for combining multiple physical WAN links into a single logical pathway to increase bandwidth. Microsoft’s Remote Access Service (RAS) for Windows NT and Window 2000 supports combining Plain Old Telephone Service (POTS) and Integrated Services Digital Network (ISDN) lines using PPP Multilink, as does Windows 98.

TIP

PPP Multilink must be enabled on both the dial-up networking client and the RAS server in order to work.

PPTP

See
Point-to-Point Tunneling Protocol (PPTP)

premise cabling

The entire wiring system in a building, including cabling, power lines, wiring closets, distribution centers, wall plates, and fixtures. Premise cabling should be installed according to the Electronic Industries Alliance and Telecommunications Industry Association (EIA/TIA) wiring standards and must comply with all state and municipal building codes and requirements.

How It Works

In computer networking, the premise wiring system is a hierarchical system based on the star topology, starting with the equipment room (main cross-connect) that houses the main telecommunications equipment for the particular building, including servers, Private Branch Exchanges (PBXs), and routers. The equipment room contains the facilities for telecommunications signals to enter and leave the building. It can be one room or several rooms on different floors, depending on the building layout and administrative considerations.

From the equipment room, a vertical backbone cable runs up the building riser or elevator shaft, connecting the equipment room with wiring closets (intermediate cross-connects) on each floor. Additional backbone cabling runs horizontally to secondary wiring closets (horizontal cross-connects) if necessary. No further cross-connects should be used; in other words, the hierarchy should be no more than three cross-connects deep.

The wiring closets contain cabinets or racks with patch panels, hubs, switches, and other equipment. Horizontal wiring runs from the patch panels through wall and ceiling spaces to wall plates and distribution boxes to form local area network (LAN) drops in the work areas where computers are set up. Patch cables or drop cables connect computers in the work area to the wall plates and distribution boxes.

See also
cabling

presentation layer

Layer 6 of the seven-layer Open Systems Interconnection (OSI) reference model. The presentation layer structures data that is passed down from the application layer into a format suitable for network transmission. This layer is responsible for data encryption, data compression, character set conversion, interpretation of graphics commands, and so on. The network redirector also functions at this layer.

NOTE

Most real-world protocol suites, such as TCP/IP, do not use separate presentation layer protocols. The presentation layer is mostly an abstraction in real-world networking.

Pretty Good Privacy (PGP)

A digital signature and encryption scheme for secure exchange of e-mail and attached documents. You can use Pretty Good Privacy (PGP) to encrypt e-mail messages so that no one but the intended recipient can read them and to digitally sign messages so that the recipient can be sure of the identity of the sender and that the message has not been tampered with during transit.

How It Works

PGP uses the RSA or Diffie-Hellman public key cryptography algorithm and supports 128-bit keys. When you send a digital signature, a hashing algorithm generates a hash from the username and other information, which is then encrypted using the sender’s private key. The hashing algorithm is MD5 when you use RSA and SHA-1 when you use Diffie-Hellman. As in a typical public key cryptography system, the recipient uses the sender’s public key to decrypt the signature and verify the sender’s identity. The sender’s public key is retrieved by the recipient from a public PGP key management server such as the one maintained by Network Associates.

PGP is popular in the Internet community but does not scale well for corporate enterprise applications because its key management facilities are implemented as a distributed “web of trust” rather than the usual hierarchical certificate authority (CA) scheme.

On the Web
•
Network Associates home page
: http://www.nai.com

PRI-ISDN

See
Primary Rate Interface ISDN (PRI-ISDN)

primary domain controller (PDC)

A Microsoft Windows NT domain controller that contains the master copy of the Security Account Manager (SAM) database. A Windows NT domain has only one PDC, which periodically undergoes directory synchronization to copy its directory database to back up domain controllers in the domain. The primary domain controller (PDC) must be the first computer installed in a domain and defines the domain.

NOTE

If a PDC needs to be taken offline for maintenance or repair or if it unexpectedly goes down, a backup domain controller (BDC) can be promoted to the role of PDC. This is necessary because BDCs contain read-only copies of the domain directory database, so user accounts cannot be modified and passwords cannot be changed unless there is a PDC on the network.

See also
backup domain controller (BDC), domain controller

primary enterprise controller (PEC)

A computer running Microsoft Message Queue (MSMQ) Server that functions as a primary site controller (PSC) for one site and contains information about the enterprise configuration and the certification keys in its MSMQ Information Store (MQIS) database. The primary enterprise controller (PEC) also functions as an MSMQ Routing Server.

Administrators can install only one PEC on an MSMQ network. You must install the PEC before you install any primary site controllers.

primary group

In Microsoft Windows NT, the global group that is specified as primary for a particular user account. Users can be members of many different global groups within their domain, but only one of these global groups can be the primary group.

Primary groups are used when users running Windows NT Services for Macintosh or POSIX applications log on to the computer. The user’s primary group is the group that the owner of a particular resource works with most.

primary name server

A name server that maintains its own local Domain Name System (DNS) database of resource records. A primary name server has a master copy of resource records for each zone over which it has authority. These records are stored locally on the name server in the form of a text file called the zone file. All changes to the resource records for a zone must be made on the primary name server.

Secondary name servers obtain their resource records from master name servers, which can be either primary name servers or other secondary name servers. The usual configuration when name servers are used within a TCP/IP internetwork for name resolution is one primary and one secondary name server, with the primary configured as the master name server for the secondary (which is sometimes called the slave name server). If Microsoft Windows NT is used for the DNS servers, the tool for configuring name servers is DNS Manager, a Windows NT administrative tool. In Windows 2000 the analogous tool is the DNS console.

See also
Domain Name System (DNS)

primary partition

A partition on which you can install a bootable operating system and its associated file system. Primary partitions cannot be subdivided into further segments, as extended partitions can. The partition table on a drive’s master boot record can contain entries for up to four primary partitions or three primary and one extended partition. Only one primary partition at a time can be the active partition (contain the currently running operating system files). In Microsoft Windows NT, the active partition is also known as the system partition. Primary partitions are used in multiboot systems to isolate the files of each operating system from one another.

See also
extended partition

Primary Rate Interface ISDN (PRI-ISDN)

A standard form of communication on Integrated Services Digital Network (ISDN) communication systems. Primary Rate Interface ISDN (PRI-ISDN) connections consist of 24 digital channels divided between 23 B channels and a single D channel. The B channels carry the voice or data between the customer premises and the telco’s central office (CO), while the D channel is used for establishing connections and signaling. PRI-ISDN is often referred to as 23B+D because of the channels that it uses.

The bandwidth of each B channel and of the single D channel is 64 Kbps, so the total bandwidth of PRI-ISDN is 1.544 Mbps, which is identical to that of a T1 circuit. By using the bonding protocol, the 23 B channels can be combined to form a single 1.472-Mbps data channel. The European version of PRI-ISDN uses 31 B channels and one D channel, providing the bandwidth of an E1 circuit.

See also
Basic Rate Interface ISDN (BRI-ISDN), Integrated Services Digital Network (ISDN)

primary ring

The main ring used in the Fiber Distributed Data Interface (FDDI), which uses a dual ring topology. The primary ring is the only ring used unless it has a fault, in which case the network reconfigures itself to use the secondary ring with the data traveling in the opposite direction. The dual ring configuration provides FDDI with fault tolerance.

TIP

Run the FDDI primary ring and secondary ring along different physical paths to make the network more redundant. An accident or disaster affecting one of the rings will not affect the other.

See also
Fiber Distributed Data Interface (FDDI), secondary ring

primary site controller (PSC)

A computer running Microsoft Message Queue (MSMQ) Server that functions as the site controller for the first MSMQ site you create. The primary site controller (PSC) maintains a database of information concerning the computers and queues in the site. Each site usually has its own PSC, and you can install only one PSC for a given site.

For load balancing and failure recovery purposes, you can install one or more backup site controllers (BSCs) in each MSMQ site. BSCs contain a read-only copy of the PSC or primary enterprise controller (PEC) database. MSMQ sites do not require BSCs, but it is usually a good idea to install one or more of them in each MSMQ site. You must install a PSC or PEC before you can install any BSCs.

printing pool

A way of connecting one printer to multiple print devices. In Microsoft Windows terminology, a print device is the physical hardware that does the printing, while a printer is a software interface on a computer that enables jobs to be sent to a print device. Normally, a printer is configured for each individual print device. Using a printing pool, you identify several print devices as a single printer to the operating system. When a client sends a print job to a printing pool, the printer sends the job to the first available print device managed by the printer. Clients can thus print jobs without having to check to see which print device is free.

Printing pools are used in networks with high printing volume and also to provide a form of fault tolerance. Printing pools also simplify the administration of large numbers of print devices. You can create printing pools on print servers running Windows NT and Windows 2000.

NOTE

The print devices in a printing pool must be the same make and model or at least be similar devices that use the same printer driver. Print devices that are pooled can be a mix of local and network interface print devices. Place pooled print devices in close physical proximity to one another so that users do not have to search for the device that printed their job.

TIP

If you don’t have identical print devices and thus cannot create a printing pool, you can take other measures to meet the needs of increased printing volume:

  • Share an existing printer that is currently not shared for network use.

  • Configure priorities between printers to enable critical documents to be printed before noncritical ones.

  • Institute company policies on how to use printers properly, and audit printer usage.

See also
printing terminology

printing terminology

In Microsoft Windows, the following are printing-related terms:

  • Print device:
    A hardware device that produces printed output, such as a LaserJet, ink-jet, or dot-matrix print device. Most people loosely refer to these devices as “printers,” but the term “printer” has a specific meaning in the Windows operating system, as described below.

  • Printer:
    A software interface installed on a Windows computer that allows users and applications to print to a print device. Microsoft uses the term “print device” to refer to the actual hardware device; “printer” refers to the software interface that controls that device. To create a printer, you use the Add Printer Wizard in the Printers folder.

  • Print server:
    A computer with which a print device is associated. A print server receives print jobs from clients and sends them to the print device.

  • Printer driver:
    A series of files that convert printing commands into machine-specific language for sending them to a print device. Each model and make of print device has its own specific printer driver.

NOTE

Print devices can be further subdivided into two types:

  • Local print device:
    A print device that is locally attached to the parallel or serial port on the print server. If a local print device is being used only on the local machine, its software interface is called a “local printer.” If a local print device is shared, clients can access it over the network and its software interface is called a “network printer” from the perspective of the clients.

  • Network-interface print device:
    A print device that has its own built-in network interface card (NIC) and can be plugged into the network anywhere that a local area network (LAN) drop is free. A network-interface print device is not connected directly to the print server; it is managed remotely by the print server.

TIP

Keep network-interface print devices on the same network or subnet as their print server to minimize the extra network traffic. Be sure that your print server has sufficient RAM for processing documents and sufficient disk space for spooling print jobs. Dedicating a computer to the role of print server is usually recommended, especially if that computer will manage several print devices.

Print Operators group

A built-in group in Microsoft Windows NT and Windows 2000. The Print Operators group is a local group on computers that run Windows NT and a domain local group on a Windows 2000 domain controller. Print operators are users who can administer network printers. The initial membership of this group is empty. The Print Operators group has the following preassigned rights:

  • Log on locally

  • Shut down the system

Print operators also have the right to set up and configure network printers.

See also
built-in group

print permissions

A set of permissions assigned to users and groups to control access to the printers on a Microsoft Windows NT print server. Suitable print permissions are an important part of network administration, especially in enterprise-level networks with different administrative levels. There are four levels of print permissions, as described in the following table.

Print Permissions
Permission | What It Allows Users to Do
no access | Cannot connect to or print to a printer
print | Connect to a printer Print a document Manage your own documents only
manage documents | Print permissions plus: Pause and restart any document Delete any document Manage job settings for all documents
full control | Manage documents permissions plus: Share a printer Change printer properties Delete a printer Change printer permissions
NOTE

On a Windows 2000 print server, the full control permission is called “manage printers.” Also, instead of using a no access permission, you permit or deny the manage printers, manage documents, or print permissions. You can, in addition, click the Advanced button on the Printer Properties property page to configure more granular customized sets of printer permissions.

TIP

In Windows 2000, you can remotely administer printers using a Web browser by accessing the Uniform Resource Locator (URL) http://Print_Server_Name/printers. Administrators can configure printer permissions and settings, check the status of printers, and create real-time reports on printer usage.

print server

A server that manages a printer on a network. The printer can be directly connected to a port on the print server (a local printer), or it can have its own built-in network interface card (NIC) and be connected directly to the network (a network printer). Clients that want to print jobs send them to the print server, which queues or spools the jobs and then sends them to the printer. Microsoft Windows NT Server is a good operating system for running a print server on your network.

Instead of dedicating a computer to managing a printer on a network, you can use a stand-alone print server device. These devices generally have a small footprint—some are even pocket-sized—and can be used to attach a printer anywhere in the network. Typically, an RJ-45 port on the device can be plugged directly into an Ethernet hub or into a wall plate in a work area, while an IEEE 1284 port on the device is connected to the printer. Stand-alone print server devices generally have built-in support for a variety of protocols (such as TCP/IP, IPX/SPX, NetBEUI, and Data Link Control) and platforms (such as Windows 2000, Novell NetWare, and UNIX) and support a wide variety of makes and models of printers.

Other features of stand-alone print server devices can include the following:

  • Support for two or four parallel printer connections

  • Support for Line Printer Daemon/Line Printer Remote (LPD/LPR) or Dynamic Host Configuration Protocol (DHCP)

  • Support for Token Ring or AppleTalk networking architectures

print sharer

Any hardware device that enables two or more computers to directly share one or more attached printers without using a network. Print sharers include the following:

  • Manual switch boxes, on which a user turns a rotary switch to select which computer controls the printer. The manual switch boxes are usually in a 2-to-1, 4-to-1, or 6-to-1 configuration. A special switch called an X-switch can allow either of two computers to print to either of two printers.

  • Electronic print-sharing switches, on which users also use knobs or toggle switches to select a computer or printer. These switches have solid-state circuitry inside that does the switching, unlike manual switch boxes, which have simple metallic contacts.

  • Port-contention or FIFO (first in, first out) switches, which automatically monitor all input ports. When a signal enters an input port from a computer, the switch automatically assigns that port to the output printer port.

  • Code-operated switches, which examine the input (computer) data ports for an ASCII string indicating which output (printer) port to switch the incoming printer data to.

  • Scanning switches, which function like port-contention switches except that they sequentially scan the input ports instead of monitoring them all continuously.

NOTE

If more than two computers need to share a printer, the best solution is to connect the computers to a local area network (LAN) and use a print server to set up a shared network printer. The print sharing devices listed previously are intended primarily for non-networked computers that must be directly connected to printers. In a small peer-to-peer networking setting, you can use a machine running Microsoft Windows 95 or Windows 98 that has File and Printer Sharing installed on it to share an attached printer with other workstations. In larger networks, Windows 2000 Server is a better choice.

TIP

Don’t use manual switch boxes with laser printers. The switching mechanism can cause voltage spikes that can seriously damage the printer.

Private Branch Exchange (PBX)

A telephone switch at the customer premises that supports multiple independent telephone extensions. Private Branch Exchanges (PBXs), which are installed by a telco, save businesses the cost of supplying an individual local loop connection for each employee because employees can share external trunk line connections. The PBX provides connectivity between the client’s private telephone system that it supports, and the telco’s public trunk lines. In Europe, a PBX is known as a Private Automatic Branch Exchange (PABX).

How It Works

PBXs were originally switch consoles controlled by human operators, who would plug and unplug patch cords to establish connections for customers. The modern electronic PBX (also known simply as a switch) is a solid-state device that essentially establishes a private switching system that mimics the functions of a telco’s much larger central office (CO) switching facility. PBXs allow businesses to have better control of their own telecommunications equipment, and they reduce costs by more effectively routing local telephone traffic.

Typically, a PBX is leased and installed in the main equipment room of a building or campus by a telco or other service provider. It handles all calls initiated and received in the building. If an outgoing call is directed to another line on the PBX, the PBX routes the call directly to its destination instead of forwarding it to the local CO. Outgoing calls directed to destinations outside the PBX are routed to the CO for handling.

A modern digital PBX can handle data, fax, and other forms of traffic in addition to voice traffic. Telephones and other devices are connected by individual circuits directly to the PBX unit, while trunk lines coming in from the outside terminate at a multitrunk channel band (MCB) unit. The MCB interfaces with the main distribution frame (MDF), which provides the individual circuits that connect the outside world to the PBX unit. The more circuits that the MDF creates from the trunk lines, the more simultaneous outgoing calls can be initiated and received by users of the PBX system. Add-ons for the PBX unit can include call management systems (CMS’s), which provide call notification and control services; call accounting services; and modem pools for remote dial-up access.

Graphic P-11. Private Branch Exchange (PBX).
Graphic P-11. Private Branch Exchange (PBX).

PBX switches come in various sizes. The smallest is a 3-by-8 switch that supports three business lines and eight extension lines. This configuration permits eight phones to be connected, but only three of them can make or receive calls at a time.

PBXs support a number of features, including the following:

  • Direct Inward Dialing (DID):
    A form of call routing that allows outside users to dial directly to any of the extensions

  • Direct Outward Dialing (DOD):
    A form of call routing that allows extensions to dial directly to any outside phone number

  • Station-to-Station Dialing (SSD):
    Allows any extension to call any other extension without using a business line

Most modern PBXs support digital phone extensions and T1 or multirate Integrated Services Digital Network (ISDN) for their telco connection. PBX boards can also be installed in servers to support computer-telephony integration (CTI). Many products and configurations are available.

NOTE

An alternative to installing a PBX at the customer premises is to lease a Centrex service from the telco’s CO. This service offers similar features to a PBX but from a remote location, and it is managed remotely by the telco.

private information store

One of the two databases in the information store on a computer running Microsoft Exchange Server. The private information store stores content for mailboxes homed on the server. It consists of a number of files stored in the \mdbdata directory on the Exchange server. These files include the following:

  • Priv.edb:
    The actual database file

  • Edbxxxx.log:
    Transaction files used to track changes to the database

  • Edb.chk:
    A checkpoint file to keep track of transactions in edbxxxx.log that are uncommitted

  • Res1.log and Res2.log:
    Reserved log files used in low disk space conditions

  • Temp.edb:
    A temporary file used for storing transactions that are in progress

process isolation

A feature of Component Services (Microsoft Transaction Server) and Internet Information Services (IIS) that allows multiple critical Web applications to be hosted on a single IIS server. Running each application as an isolated process in its own memory space leads to greater reliability because the failure of one unstable application will not affect any other running applications and cannot crash the IIS server.

Profile Manager

A component of the Internet Explorer Administration Kit (IEAK) that is used to manage users’ desktop settings remotely from a central station. Profile Manager integrates with Microsoft’s System Policy Editor and can be used to

  • Manage system policies for implementing system and user restrictions

  • Create or import .adm files, which are templates for policy files

  • Centrally maintain both 16-bit and 32-bit Microsoft Windows policies

  • Enable or disable individual restrictions

NOTE

In Windows 2000, the functionality of the Profile Manager is incorporated into the Group Policy snap-in.

Project 802

An ongoing project of the Institute of Electrical and Electronics Engineers (IEEE) for defining local area network (LAN) and wide area network (WAN) standards and technologies. The 802 specifications define the operation of the physical network components—cabling, network adapters, and connectivity devices such as hubs and switches.

Project 802 has a number of subsections, including the following:

  • 802.1:
    Internetworking standards

  • 802.2:
    The logical link control (LLC) layer of the Open Systems Interconnection (OSI) reference model data-link layer

  • 802.3:
    Ethernet (Carrier Sense Multiple Access with Collision Detection)

  • 802.4:
    Token Bus LAN

  • 802.5:
    Token Ring LAN

  • 802.6:
    Metropolitan area network (MAN)

  • 802.7:
    Broadband technologies

  • 802.8:
    Fiber-optic technologies

  • 802.9:
    Integrated voice/data networks

  • 802.10:
    Network security standards and technologies

  • 802.11:
    Wireless networking technologies and standards

  • 802.12:
    Demand priority access technologies

  • 802.14:
    Cable television access

The Project 802 standards are constantly evolving, and new subcategories are being created to standardize new networking technologies.

promiscuous mode

A mode of operation of a network interface card (NIC) in which the NIC accepts all frames on the wire, including those not specifically directed to it. A NIC operating in promiscuous mode reads every frame it receives, whether the frames are broadcast, multicast, or directed. In some networks, this can be a security problem because nodes that act “promiscuously” can be configured not only to read frames but also to store them and even retransmit them. Sensitive information can thus be intercepted on the network and retransmitted to remote stations. This problem can occur in both Ethernet and Token Ring networks when NICs are configured to act promiscuously.

NOTE

Network driver interface specification (NDIS), as of version 4, supports a capturing mode called local only, which uses fewer CPU resources than promiscuous mode but supports capturing of all frames for Microsoft Network Monitor.

property sheet

In Microsoft Windows NT, Windows 95, Windows 98, and Windows 2000, a feature for configuring system and user software settings. You can access the property sheet for an object by right-clicking the object and choosing the Properties command from the context menu. The following screen capture shows the property sheet for a file called test.txt. Property sheets contain various controls such as text boxes, check boxes, option buttons, command buttons, scrolling list boxes, drop-down list boxes, and tabs. Property sheets make Windows easy to use compared to those operating systems such as MS-DOS that use command prompt.

Graphic P-12. Property sheet.
Graphic P-12. Property sheet.

protocol

A set of rules for sending information over a network. Protocols can include rules concerning any or all of the following functions:

  • Data transmission mechanisms

  • Communication session initialization and termination

  • Addressing and routing

  • Authentication and verification

  • Encryption and compression

  • Error correction

Protocols are usually classified according to the layer they correspond to in the Open Systems Interconnection (OSI) reference model for networking. Types of protocols include the following:

  • Data-link protocols:
    Govern the framing of data, physical addressing of network nodes, and media access control methods. For local area networks (LANs), these primarily include Ethernet, Token Ring, and Fiber Distributed Data Interface (FDDI). For wide area networks (WANs), they include Point-to-Point Protocol (PPP), High-level Data Link Control (HDLC), frame relay, Asynchronous Transfer Mode (ATM), and X.25.

  • Network protocols:
    Handle link services and are responsible for addressing, routing, and error checking. Examples include NetBEUI, Internetwork Packet Exchange (IPX), NWLink, and Internet Protocol (IP).

  • Transport protocols:
    Enable the establishment of sessions and ensure reliable flow of data. Examples include NetBEUI, Sequenced Packet Exchange (SPX), NWLink, and Transmission Control Protocol (TCP).

  • Application layer protocols:
    Enable applications to access network services. Examples include Hypertext Transfer Protocol (HTTP), File Transfer Protocol (FTP), Telnet, Simple Mail Transfer Protocol (SMTP), Simple Network Management Protocol (SNMP), Network News Transfer Protocol (NNTP), X.400, X.500, Server Message Block (SMB), and Network File System (NFS).

Some protocols have been developed by specific vendors and then accepted as de facto standards by the industry, while others were initially formulated by independent standards bodies and then accepted and implemented by vendors. The most widely implemented protocols are those relating to TCP/IP and the Internet.

protocol converter

A general term for a device that enables communication between networks or transmission systems that use different protocols. Protocol converters are often used in mainframe computing environments; they enable one device to emulate the communication functions of another device. For this reason, a protocol converter is sometimes known as an emulator, and it can be either hardware-based or software-based.

How It Works

One type of protocol converter allows you to communicate asynchronously using a PC to a mainframe host over a synchronous communication link. You can thus use a PC as the front end to the host instead of using expensive synchronous terminals. The PC typically emulates a 3270 terminal for remote connections or a 5250 terminal for local connections.

For example, you can turn a PC into a 5250 terminal by installing a 5250 emulator card. Use twinax cabling to connect the port on the card directly to the AS/400 or System 390 mainframe. The 5250 emulator software running on the PC typically supports multiple concurrent 5250 sessions.

To support this synchronous/asynchronous conversion, the emulation hardware/software must perform several conversions:

  • Connect the twinax or coax synchronous connection from the host to an asynchronous RS-232 connection for the PC. For a remote connection, the converter might include X.21 or V.35 serial interfaces as well.

Graphic P-13. Protocol converter.
Graphic P-13. Protocol converter.

  • Take the Synchronous Data Link Control (SDLC) data stream from the host and convert it to an asynchronous format.

  • Perform synchronous EBCDIC to asynchronous ASCII conversion and translate standard input/output into appropriate screen/keyboard mappings.

NOTE

You can also use protocol converters to connect ASCII printers to AS/400 or System/3x mainframe hosts. A protocol converter for this purpose is sometimes called a printer emulation card.

protocol file

A text file that provides resolution of protocol names into their respective RFC-defined protocol numbers on a TCP/IP network. The entries in the protocol file are friendly names for TCP/IP protocol numbers and can be used for well-known service (WKS) records in Domain Name System (DNS) servers and other Windows Sockets applications.

How It Works

The protocol file is in the following location on computers running Microsoft Windows:

  • Windows NT and Windows 2000:
    %SystemRoot%\system32\drivers\etc\protocol

  • Windows 95 and Windows 98:
    \Windows\protocol

Each line in the protocol file contains the standard name for a protocol followed by the assigned number as defined in Request for Comments (RFC) 1060, an alias, and an optional comment prefixed with a pound sign (#). The following example comes from the sample protocol file included with Windows 95 and Windows 98:

ip       0     IP       # Internet protocol
icmp     1     ICMP     # Internet control message protocol
ggp      3     GGP      # Gateway-gateway protocol
tcp      6     TCP      # Transmission control protocol
See also
hosts file, lmhosts file, networks file, services file

protocol suite

A collection of protocols that work together as a group. Examples of protocol suites include the following:

  • NetWare’s Internetwork Packet Exchange (IPX) and Sequenced Packet Exchange (SPX) and related protocols, such as NetWare Core Protocol (NCP) and Service Advertising Protocol (SAP)

  • The Internet’s TCP/IP protocol suite, which consists of Internet Protocol (IP), Transmission Control Protocol (TCP), and related protocols such as Address Resolution Protocol (ARP), Internet Control Message Protocol (ICMP), and Hypertext Transfer Protocol (HTTP)

  • AppleTalk and its related protocols, such as AppleShare, EtherTalk, and LocalTalk

Provider Architecture for Differentiated Services and Traffic Engineering (PASTE)

A draft standard from the Internet Engineering Task Force (IETF) that defines ways that Internet service providers (ISPs) can deliver different traffic types to their clients and bill them accordingly. Provider Architecture for Differentiated Services and Traffic Engineering (PASTE) can be implemented without adding overhead to an ISP’s routers, whose tables are often burdened by the rapidly expanding address space of the Internet.

How It Works

Existing technologies such as Cisco Systems’ tag switching require that routers maintain state information for every virtual circuit they detect. PASTE eases this requirement by aggregating traffic flows that share a common path into a trunk. Routers need only maintain tables of trunks instead of tables for virtual circuits, which greatly reduces router overhead. Packets can then join or leave a trunk at any router. PASTE uses the Multiprotocol Label Switching (MPLS) protocol and the Resource Reservation Protocol (RSVP) to provide these differentiated services.

provisioning

The configuration of options on telecommunications equipment at the customer premises. For example, an analog telephone line can be provisioned with only a few options, such as caller ID and call waiting. An Integrated Services Digital Network (ISDN) line can be provisioned with many more options, and the configuration of the ISDN equipment at the customer premises must match that at the telco’s central office (CO) for communication to function properly. For example, the service profile identifier (SPID), which is a phone number with additional digits prefixed and appended to it, must be configured properly on the customer’s ISDN equipment for the telco’s ISDN switching equipment to recognize the type of equipment that is attached, recognize whether one or more devices is attached, and enable calls to be routed appropriately to the equipment.

proxy cache server

A type of proxy server that caches Web pages that users request on the Internet. You can use a proxy cache server like a regular proxy server at the border of a private corporate network in order to cache the Web pages returned from the Internet when users in the private network request them. When users request these pages again, the pages are returned instantly from the cache; a new request need not be sent over the Internet. This speeds up browsing for frequently accessed Web sites and reduces the amount of bandwidth used on the corporate Internet link.

Proxy cache servers can also be used at Internet service providers (ISPs) and at strategic locations on the Internet’s high-speed backbone to provide relief to heavily accessed Web servers and to reduce overall backbone traffic.

NOTE

Microsoft Proxy Server supports two kinds of caching for the Web proxy service:

  • Passive caching:
    Web pages that clients request are cached for later retrieval if requested.

  • Active caching:
    Proxy Server tries to anticipate which Web pages clients will request, and when the server has idle time and the network is sufficiently quiet, Proxy Server requests the pages and stores them in the cache.

proxy server

A computer that can act on the behalf of other computers to request content from the Internet or an intranet.

How It Works

Proxy servers act as secure gateways to the Internet for client computers. They are transparent to client computers—a user interacting with the Internet through a proxy server is not aware that a proxy server is handling the requests unless the user tries to access a resource that the proxy server is configured to disallow. Similarly, the Web server receiving the requests from the proxy server interprets these requests as though they came directly from client computers.

Proxy servers can be used to secure private networks connected to unsecured public networks such as the Internet. They have greater functionality than packet-filtering routers because they operate at a higher level of the protocol stack and afford greater control over monitoring and managing network access. A proxy server functioning as a security agent for a private network is generally called a firewall.

Two types of proxy servers are used in network firewall environments: circuit-level gateways and application-level gateways. Circuit-level gateways establish virtual circuits between machines on the internal private network and the proxy server on the border of the private network. The proxy server controls all connections between the internal private network and the external public network. If a client on the private network wants to access the Internet, for example, the Hypertext Transfer Protocol (HTTP) request packet generated by the client’s Web browser traverses the virtual circuit to the proxy server; the proxy server then changes the source IP address of the packet to that of the external (public) network interface of the proxy server and forwards the packet onto the Internet. When a remote HTTP server on the Internet sends a response, the proxy server routes this response back through the virtual circuit to the client that made the request.

An application-level gateway can implement security policies for analyzing packets that reach the external (public) interface of the proxy server from distrusted public networks. These security policies can examine packet addresses and other header information, permit or deny packets on the basis of their contents, and modify the address, header, or contents of packets that they monitor in order to hide key information about the internal network’s applications and services. Application-level gateways provide proxy services only for specifically configured applications and protocols such as HTTP, File Transfer Protocol (FTP), Simple Mail Transfer Protocol (SMTP), and Telnet. For each type of application for which you want to regulate access through the firewall, you must install and configure a related proxy service on the proxy server. Applications and protocols for which a proxy service is not installed cannot be accessed through the firewall.

NOTE

Instead of using a proxy server, you can provide modems for and run telephone lines directly to each user who needs Internet access, but this option is costly. You can also configure a physically separate network with several computers that have shared Internet access, but this is cumbersome for users. Advantages of using a proxy server include the following:

  • It provides a single, secure gateway to manage.

  • It can provide different types of access to the Internet as appropriate for each group of users.

  • It can monitor and track Internet usage for each user.

  • Many users can share a single high-speed Internet connection.

Microsoft Proxy Server is an example of a proxy server and firewall product that provides a secure gateway for your network to the Internet.

PSC

See
primary site controller (PSC)

P-series protocols

A group of protocols that are part of the X.400 messaging standards. Five P-series protocols relate to messaging systems that support X.400, such as Microsoft Exchange Server:

  • P1 Protocol:
    Specifies the layout of messages transferred from one Message Transfer Agent (MTA) to another. This protocol specifies that X.400 messages consist of two parts: a P1 header, which acts as an envelope and must contain a globally unique recipient address for message routing and control purposes, and a P2 message, which is the actual content of the message.

  • P2 Protocol:
    Defines the format for transmitting the content of an X.400 message. This format includes a P2 header (which is not used because the P1 header provides the necessary routing information for the message) and a P2 body, which is the actual content of the message and consists of one or more body parts of various types (such as text, images, voice, or telex).

  • P3 Protocol:
    Specifies how a user agent (UA) communicates directly with an MTA for sending or receiving a message. This protocol is not used as often as the P7 Protocol for the same reason that Post Office Protocol version 3 (POP3) is used instead of Simple Mail Transfer Protocol (SMTP) to receive Internet mail.

  • P7 Protocol:
    Specifies how a UA communicates with a message store (MS) in order to selectively retrieve messages from the store and delete unwanted messages without downloading them.

  • P22 Protocol:
    A 1988 revision of the P2 Protocol that clarifies and extends certain features of P2.

See also
X.400

PSTN

See
Public Switched Telephone Network (PSTN)

PTR

See
pointer (PTR) record

public folder

A type of recipient in Microsoft Exchange Server that can store messages and documents for sharing with other users in an Exchange organization. Public folders can contain simple messages, attachments, multimedia clips, binaries, and any other type of file. They can also contain custom forms that facilitate contributing and viewing information.

NOTE

To create public folders in an Exchange organization, you should use the client program Microsoft Outlook. Public folders created with Outlook can later be configured using the Exchange Administrator program, which you cannot use to create public folders.

public folder replica

A copy of a public folder’s contents stored on another Microsoft Exchange Server. All replicas of a public folder are equivalent—there is no master replica for a public folder.

TIP

When planning where to host public folders in your Exchange organization, consider the following:

  • The volume of information that will be stored and how much it will increase over time

  • How long information should be retained before it is deleted

  • How many users will access the information and how frequently they will access it

public information store

One of the two databases within the information store on a Microsoft Exchange Server computer. The public information store stores content for public folder replicas on the server. The public information store consists of a number of files in the \mdbdata directory on the Exchange server. These files include the following:

  • Pub.edb:
    Actual database file

  • Edbxxxxx.log:
    Contains transaction files for tracking changes to the database

  • Edb.chk:
    A checkpoint file to keep track of transactions in edbxxxxx.log that are uncommitted

  • Res1.log and Res2.log:
    Reserved log files used in low disk space conditions

  • Temp.edb:
    A temporary file used for storing transactions that are in progress

public key cryptography

Also known as asymmetric cryptography, a popular encryption method developed by Martin Hellman and Whitfield Diffie in 1976 that is used for securing transmission of data over distrusted networks such as the Internet.

How It Works

Traditional cryptography involves a private or secret key that was shared by the individuals involved in the transmission. The key is a mathematical entity that the sender can use to encrypt a message and the receiver can use to decrypt it. This traditional form of cryptography is known as secret key cryptography or symmetric cryptography. The main problem with this form of cryptography is the question of how the owner of the key can securely transmit the key. In other words, the main problem is one of key management—how to create, store, and transmit the key to those who will need it to decrypt messages sent to them.

Public key cryptography solves this problem by creating a set of two different keys for anyone needing to transmit encrypted information. A precise mathematical relationship exists between the two keys, which together are called a key pair. Both keys are produced at the same time using a mathematical algorithm such as RSA. As a result, when either one of the two keys is used to encrypt a message, the other can be used to decrypt it.

The two keys in a key pair are as follows:

  • The private key:
    Held privately by the owner of the key pair and kept secret from anyone else. The responsibility for safe storage of the private key rests entirely with the key pair owner, who has no need to transmit the private key to others.

  • The public key:
    Made available by the key pair owner to anyone who requests it. Because the public and private keys are related mathematically, in principle someone could take another person’s public key, perform complex mathematical calculations on it, and extract the corresponding private key. The solution is to use keys sufficiently long and with a sufficiently complex mathematical relationship so that it is all but impossible to extract the private key from the public one.

Once a key pair is generated for someone, that person can use it to encrypt messages and to digitally sign messages so that the recipient can be sure of the identity of the sender.

Of course, the whole public key cryptography system is ultimately founded on trust. All persons who are issued key pairs must trust the third-party authority who provided the key pairs. This trusted authority is called a certificate authority (CA). Someone who wants to obtain a key pair from a CA must contact the CA and present proof of identity. This could involve a face-to-face meeting, examination of a driver’s license with photograph, or some other method of establishing a user’s identity.

NOTE

Network administrators can use Microsoft Certificate Server, which is included in the Microsoft Windows NT 4 Option Pack, to establish their own CAs. Users can then transmit encrypted and digitally signed e-mail messages by using Microsoft Exchange Server or establish secure Web sites that use the Secure Sockets Layer (SSL) protocol with Internet Information Services (IIS).

See also
digital certificate, digital signature, encryption, Secure Sockets Layer (SSL)

public key infrastructure (PKI)

A set of services that support the use of public key cryptography in a corporate or public setting. A public key infrastructure (PKI) enables key pairs to be generated, securely stored, and securely transmitted to users so that users can send encrypted transmissions and digital signatures over distrusted public networks such as the Internet. An effective, trustworthy public key infrastructure is essential for secure e-mail and World Wide Web (WWW) transactions, e-commerce, and virtual private networks (VPNs).

How It Works

Generally, a public key infrastructure consists of the following coordinated services:

  • A trusted certificate authority (CA) that can verify user identities and issue users digital certificates and public/private key pairs. Sometimes the verification of user identities is performed by a separate registration authority (RA), but this service can also be integrated with the CA.

  • A certificate store in which users can access the public keys of other users for encrypting messages or validating digital signatures. This store is usually based on the X.500 directory recommendations.

  • A digital certificate and key management system for generating, storing, and securely transmitting certificates and key pairs to users who request them.

Public key infrastructures can have different scopes. For example, a corporate enterprise can use Microsoft Certificate Server to establish a PKI for all its users and for those of partner companies such as suppliers and wholesalers. The PKI system can then be used to secure transactions between users that are sent over the Internet. PKIs can also be established on a national or global scale to support secure e-commerce transactions over the Internet involving users and vendors who are geographically and politically separated. PKIs on this scale consist of a hierarchy of CAs managed by different governments or companies and linked to a trusted root CA (such as the U.S. government). The current leader in worldwide PKI implementation is probably VeriSign, Inc., which is both a vendor of CA software and a CA.

In order for a public key infrastructure to work, it must be implemented in a hierarchical fashion with authorities, super-authorities, and root authorities, similar to the Internet’s Domain Name System (DNS). Standards bodies and cryptography vendors such as PKIx of the Internet Engineering Task Force (IETF), Pretty Good Privacy (PGP), Simple Public Key Infrastructure (SPKI), and Public Key Cryptographic Standards (PKCS) have proposed a global public key infrastructure, but there is no universal standard that has been agreed upon for a public key infrastructure, and implementations of the existing standards are often not interoperable.

On the Web
•
VeriSign, Inc.
: http://www.verisign.com

Public Switched Telephone Network (PSTN)

The public telephone network managed by the local telco and long-distance carriers. The Public Switched Telephone Network (PSTN) consists of a digital backbone of switched circuits together with the analog local loop wiring still found in many residences. The PSTN is also known as the Plain Old Telephone Service (POTS), although that term specifically relates to the older, nondigital portion of the PSTN. The PSTN provides the most popular basis for creating wide area networks (WANs) through both leased lines and dial-up lines between local and remote networks. PSTN is often used in wide area networking because of its ubiquitous nature—local loop connections exist almost everywhere in the world.

publishing

In Active Directory of Microsoft Windows 2000, the process of making directory objects accessible to users on the network. Objects created in Active Directory are automatically published on the network. For example, when you create a new user object (information about that user, such as the user’s phone number and e-mail address) users on the network can look up that information using Active Directory.

If an object that doesn’t reside in Active Directory (such as a shared folder or shared printer) is published, Active Directory points to its location on the network. Most objects are automatically published in Active Directory if they reside on computers running Windows 2000, but you might have to manually publish the location of other objects, such as shared folders and printers on downlevel computers running Windows NT.

TIP

When you consider whether to publish an object in Active Directory, think about whether the information will be changed frequently. Published information should be relatively static. Information should be published when it will be useful to a large segment of the enterprise community. Structured information is more useful to publish than individual items such as files, which should be published instead in file systems accessed through share points. Applications can publish their connection points and application data in Active Directory.

pulse code modulation (PCM)

A common method of converting analog signals into digital signals.

How It Works

Pulse code modulation (PCM) devices receive analog signals with continually varying voltages and quantize these signals into discrete voltages sampled at regular time intervals, typically 8000 times per second, with each sample being 8 bits in size. This provides a total transmission rate of 64 Kbps, as in Integrated Services Digital Network (ISDN) digital telephone communication. The result of this quantization process is a series of discrete voltages over time. The voltage levels correspond to powers of 2 and represent a series of binary numbers so that the output of a PCM device is essentially a binary number.

A typical PCM device consists of a sample-and-hold circuit that samples the analog voltage signal and holds it long enough so that an analog-to-digital converter can convert it into digital (binary) format. A single device plus its associated software that can perform both the analog-to-digital conversion and its reverse is known as a codec or coder/decoder.

PVC

See
permanent virtual circuit (PVC)

PVC cabling

See
polyvinyl chloride (PVC) cabling

PWS

See
Microsoft Personal Web Server (PWS)


Q

QoS

See
quality of service (QoS)

QoS ACS

See
QoS Admission Control Service (QoS ACS)

QoS Admission Control Service (QoS ACS)

A Microsoft Windows 2000 service that can be used to centrally designate when, how, and by whom shared network segment resources will be used.

How It Works

QoS Admission Control Service (QoS ACS) is based on the Subnet Bandwidth Management (SBM) specification defined by the Internet Engineering Task Force (IETF). QoS ACS operates at the network layer and can service all transport protocols in the TCP/IP protocol suite, including Remote Display Protocol (RDP), User Datagram Protocol (UDP), and Transmission Control Protocol (TCP). A QoS ACS host (a server running Windows 2000 with the QoS ACS service installed and configured) uses the Resource Reservation Protocol (RSVP) as a message service for sending and receiving priority bandwidth requests.

A QoS ACS host controls the bandwidth for the subnet to which it is connected. The QoS ACS host uses multicasting to send out messages called beacons to inform clients on the subnet that it is ready to receive bandwidth allocation requests. Clients on the subnet that desire access to shared network resources (such as multimedia servers) first submit their bandwidth request to the QoS ACS server so that it can determine whether sufficient bandwidth is available to allocate to the clients. Bandwidth is then allocated based on the current state of resource and bandwidth availability on the subnet and the QoS ACS policy rights of the requesting user. These policy rights are defined in Active Directory.

A client’s request for bandwidth will be rejected if the QoS ACS host determines that the user does not have the right to reserve bandwidth on the subnetwork or the subnetwork does not have sufficient resources to support the request at that time. If the client’s request is rejected, the client must decide whether to try accessing the resource using a best-effort service level or wait until later when priority bandwidth becomes available and can be allocated to the client. If the request is approved, the QoS ACS host logically allocates the requested bandwidth and forwards the client’s resource request to the appropriate server on the network.

No configuration is required for Windows 2000 or Windows 98 clients, and non-Windows clients can request bandwidth, provided they are running suitable SBM client software.

Q-series protocols

Also called Series Q protocols, a set of protocols developed by the International Telecommunication Union (ITU) that includes the following:

  • Q.920/921:
    Specifies the User-Network Interface (UNI) data-link layer for Integrated Services Digital Network (ISDN), including the ISDN D channel’s Link Access Procedure D (LAP-D) data-link protocol.

  • Q.922A:
    Specifies the ITU encapsulation method for frame relay networks.

  • Q.931:
    Specifies mechanisms for establishing, maintaining, and tearing down ISDN connections. This includes working with connections in the LAP-D data-link protocol, which runs on the ISDN D channel.

  • Q.93B:
    The Asynchronous Transfer Mode (ATM) signaling protocol, which specifies mechanisms for establishing, maintaining, and tearing down broadband ISDN (B-ISDN) connections.

quality of service (QoS)

Generally, any networking technology that has predictable latency and data loss. More specifically, any mechanism that allows either absolute or relative performance requirements to be defined for different traffic streams carried over a network. In other words, a quality of service (QoS) network can guarantee a certain level of throughput for a specific path, connection, or type of traffic. This makes it possible to ensure that critical network applications receive priority handling.

How It Works

Networks that support QoS mechanisms can generally control both the quality of a network transmission and the availability of bandwidth to ensure this quality. These are different from ordinary networks, which guarantee only a best-effort delivery—traffic flow cannot be controlled and bandwidth cannot be reserved. If traffic congestion occurs during a period of intense network communication, QoS features can kick in to ensure that certain data streams receive preference for users and applications that need consistent data flow. For example, networks carrying real-time audio or video require a high level of QoS to ensure that reception is smooth and free of errors. (Latency in delivery of packets for a real-time multimedia stream can produce pauses and dropouts that are highly undesirable from the user’s point of view.)

You can control the following network properties in a network that supports QoS functions:

  • Throughput (total bandwidth used)

  • Latency (traffic delay)

  • Priority (among types of traffic)

  • Peak traffic, burstiness, and jitter (to smooth traffic flow)

  • Packet or cell loss and retransmission

Asynchronous Transfer Mode (ATM) is one networking technology that can deliver data at specific levels of QoS. A look at the QoS features in ATM will give you an idea of the scope of issues that QoS can address. The QoS mechanisms of ATM function in the following areas:

  • Traffic contracts:
    Specify QoS parameters for a data stream, such as peak and average bandwidth and maximum burst size. Each ATM end node in an ATM network negotiates a traffic contract with that network. QoS parameters can be defined for the end node to control the type and amount of traffic that the host can send over an ATM circuit. If an ATM switch in the circuit cannot meet these requirements, it sends a message to the transmitting host indicating that the connection is refused. Each virtual channel or virtual path that is established by an ATM end node in an ATM network has its own traffic contract.

  • Traffic shaping:
    Involves ATM devices using data queues to smooth out traffic bursts and limit the peak data rate so that the conditions of the negotiated traffic contracts are met.

  • Traffic policing:
    ATM switches enforce traffic contracts so that the agreed-upon QoS conditions of each data stream are met. If these conditions are violated, ATM switches set the cell-loss priority (CLP) bit of each offending cell, which indicates that the offending cells might be dropped when congestion occurs at the switch.

The specific QoS parameters that can be negotiated in an ATM network are called traffic parameters. They include the following:

  • Cell Delay Variation (CDV):
    The tolerance per second for cells that should not exceed the peak cell rate. CDV is specified at the network, not at the end station. Cells within the CDV are accepted.

  • Maximum Burst Size (MBS):
    The maximum number of cells per burst.

  • Peak Cell Rate (PCR):
    The maximum number of cells that can be transmitted per second based on the specified peak bandwidth per second.

  • Sustainable Cell Rate (SCR):
    The maximum number of cells that can be transmitted per second based on the specified sustainable bandwidth per second.

The implementation of QoS in ATM allows ATM networks to support four classes of QoS, each with scalable levels:

  • Constant Bit Rate (CBR):
    The traffic requires a guaranteed rate of transport and does not tolerate cell loss. The ATM end station informs the ATM network of the required QoS parameters at call setup. The network then performs admission control by reserving the necessary bandwidth or refusing the connection. The end station is responsible for complying with the agreed-upon peak data rate—if it exceeds this rate, the network drops the offending cells.

  • Variable Bit Rate (VBR):
    Similar to CBR except that it negotiates a maximum burst size and maximum sustainable rate in addition to a peak data rate.

  • Unspecified Bit Rate (UBR):
    Does not involve reserving bandwidth or establishing cell-loss ratios. UBR is commonly used in LAN emulation (IP-over-ATM networks that are typically used in campus backbones). If one cell is dropped because of congestion, the entire Internet Protocol (IP) packet to which the cell belongs must be retransmitted.

  • Available Bit Rate (ABR):
    Uses periodic polling of the ATM network to adjust the data transmission rate. ABR is also used in LAN emulation (LANE) implementations.

NOTE

The QoS features of ATM give it an advantage over competing technologies such as Fast Ethernet and frame relay, but ATM is more difficult to implement because of its more complex architecture. However, you can use ATM backbone technology to backfill QoS features into connected Fast Ethernet and frame relay network structures, albeit awkwardly. Gigabit Ethernet also includes QoS features.

In best-effort TCP/IP internetworks such as the Internet, QoS in IP data streams is difficult to achieve. The Internet Engineering Task Force (IETF) has proposed two new mechanisms for providing QoS for the Internet and for TCP/IP internetworks: integrated services and differentiated services.

Integrated services focuses on making it reasonable to use TCP/IP internetworks for a variety of services, such as audio, video, real-time data, and classical data traffic. It regulates the flow of data based on computations made by the router. It also makes use of the Resource Reservation Protocol (RSVP), which can be used to reserve circuits to maintain an even flow of data. Controlled-load service, another aspect of integrated services, ensures that priority data keeps moving even when the router reaches its capacity. Because integrated services requires new routers, it would require considerable rebuilding of the core technology of the Internet.

Differentiated services aggregates IP traffic into three classes of priority serviced by routers. This would enable ISPs to offer varying levels of priority to their customers. Differentiated services uses the DS field in the IPv4 packet header to define how the packet will be forwarded (the “per-hop behaviors” of IP traffic). This solution would mean minor changes to the Internet’s backbone routers and would leave the complexity of implementing QoS features to the edges of the network, especially the signaling methods for establishing QoS-enabled links between nodes on the network.

quartet signaling

A signaling method used in 100VG-AnyLan (100BaseVG) networks. Signals are transmitted over all four pairs of wire in voice-grade unshielded twisted-pair (UTP) cabling. Quartet signaling makes possible the transmission of data at a speed of 100 Mbps while using the same transmission frequencies that are used on standard 10BaseT networks. Quartet signaling also enables 100VG-AnyLan to leverage existing installations of category 3, 4, and 5 UTP cabling for 100-Mbps transmission.

How It Works

10BaseT Ethernet networks use only two pairs of wires in a four-pair UTP cable—one pair for transmitting data and the other pair for receiving data and for detecting collisions on the network. 100VG-AnyLan uses a demand priority method for controlling access to the media, which prevents collisions from occurring. As a result, 100VG-AnyLan can use all four pairs of wires for data transmission—hence the term “quartet signaling.” In addition, quartet signaling uses a different line coding technique than the traditional Manchester coding method used in Ethernet networks. Quartet signaling uses the 5B/6B NRZ line coding method, while Manchester coding uses a 1B/2B scheme whereby 1 bit of data is encoded using two binary symbols. The 1B/2B algorithm is reliable and simple to implement but inefficient. The 5B/6B method encodes 5 bits using six binary symbols, which allows two and a half times as much information to be transmitted per wire compared to 10BaseT Ethernet (as shown in the following table).

Calculations for Line Coding Data Rates
 | Manchester Coding | Quartet Signaling
Line coding | 1B/2B | 5B/6B
Line frequency | 20 MHz | 30 MHz
Data rate per pair | (1/2) x 20 = 10 Mbps | (5/6) x 30 = 25 Mbps
Number of pairs used | 1 | 4
Total data rate | 1 x 10 = 10 Mbps | 4 x 25 = 100 Mbps
NOTE

The 100BaseT4 form of Fast Ethernet also uses all four pairs of wire in twisted-pair cabling.

See also
100VG-AnyLan, demand priority

queue

A collection of items waiting to be processed in a specific order. Examples of queues in computer and networking technology are numerous and include the following:

  • A print queue, which consists of print jobs waiting to be sent to a print device

  • A messaging queue (on a mail server such as Microsoft Exchange Server), which consists of messages waiting to be sent

  • A backlog of packets waiting to be forwarded over a specific interface by a router

  • Information, function calls, or transactions sent by one application and forwarded to another by Microsoft Message Queue (MSMQ) Server in Microsoft Windows NT or Message Queuing in Windows 2000

  • A collection of fax messages waiting to be processed and sent by a fax server

  • A series of system messages, such as key presses and mouse clicks, sent by applications to an operating system for processing

quorum resource

A resource used in Microsoft clustering services—Microsoft Cluster Server (MSCS) for Microsoft Windows NT Server 4.0, Enterprise Edition, and Windows Clustering for Windows 2000—that guarantees that data necessary for recovery is maintained consistently among all members of a cluster. The quorum resource must be a physical disk and can be owned by only one node in a cluster. The quorum resource stores the cluster log, which is maintained by the clustering software. If a node fails and then recovers, the quorum resource is responsible for updating that node’s configuration information so that it matches all other nodes. If the nodes in a cluster cannot communicate with each other, the quorum resource determines which node can continue operating. If the node owning the quorum resource fails, another node takes ownership of the resource. Each cluster can have only one quorum resource.


R

RA

See
registration authority (RA)

rack

Also called an equipment rack, a metal frame for holding and organizing networking devices. A networking component that is designed to be mounted in a rack is said to be rack-mountable. Rack-mountable devices include hubs, routers, Ethernet switches, patch panels, and uninterruptible power supply (UPS) devices.

Racks can be wall mounted or freestanding. They come in various heights and standard widths—19 inches is by far the most common width. The width is the distance between the mounting holes for mounting equipment—the actual width of the rack is usually several inches wider. Common heights for racks are 48 and 83 inches. In EIA/TIA-compliant racks, the holes on the frame are spaced 1.75 inches apart vertically, a distance symbolized as a “U” or “unit” of rack space. If a piece of networking equipment is described as 3U, it occupies 3 x 1.75 = 5.25 inches of vertical space once it is mounted in the rack.

Graphic R-1. Rack.
Graphic R-1. Rack.

Racks offer a way to organize equipment in a wiring closet. Racks come with a variety of accessories. Cable organizers, for example, allow you to run bundled cabling down the side or back of the rack to avoid “spaghetti.” You can use sliding shelves or drawers to incorporate odd-sized equipment in racks for easy access for configuration and wiring. Vented sides and fan trays help circulate air to keep equipment from overheating. By attaching a locking plastic door, you can convert some racks into cabinets for more secure storage.

NOTE

A ladder rack is a modular rack system for supporting cable runs in walls, false floors, and false ceilings.

TIP

If your area is prone to earthquakes, you can bolt the base of your rack to the floor for greater security. Wall-mounted racks allow you to organize equipment in areas with limited floor space.

See also
cabinet, cabling

RADIUS

See
Remote Authentication Dial-In User Service (RADIUS)

RAID

Stands for redundant array of independent disks, a technology for implementing fault tolerance on a disk subsystem by using data redundancy, either using software or using a separate hardware RAID storage unit.

A number of RAID levels are defined, but Microsoft Windows NT and Windows 2000 support only three of them—RAID 0, RAID 1, and RAID 5. These are the most popular implementations of RAID. The RAID levels that are presently defined include the following:

  • RAID 0 (disk striping):
    Data is written across a disk in stripes. Stripe sets do not provide fault tolerance, but they provide fast read/write performance. Windows NT Server and Windows 2000 Server support RAID 0.

  • RAID 1 (disk mirroring):
    Data is written simultaneously to two (or more) disks, making one disk drive a mirror image of the other. Any NTFS file system partition can be mirrored, including the boot or system partition. Using mirror sets improves read performance slightly but has no effect on a single disk system for write performance. Windows NT Server and Windows 2000 Server support RAID 1.

  • RAID 2 (disk striping with error checking and correcting [ECC]):
    Information is stored on several disks.

  • RAID 3 (disk striping with parity ECC):
    Parity information is written to a single disk for error recovery.

  • RAID 4 (disk striping with large stripes):
    Entire records are written to single drives, and parity information is stored on a single disk for error recovery.

  • RAID 5 (disk striping with parity):
    Both data and parity information are written across all disks in stripes to provide full data recoverability in case any single drive fails. Disk striping with parity is an excellent way to protect data from the downtime caused by disk failures. RAID 5 requires a minimum of three disks and is supported by Windows NT Server and Windows 2000 Server.

  • RAID 6 (disk striping with two parity schemes):
    An extension of RAID 5 that has additional fault tolerance built in and is designed to protect data against multiple simultaneous failed disk drives. It is not commonly used.

  • RAID 10 (disk striping with disk mirroring):
    An expensive solution that has the same level of fault tolerance as RAID 1. It is not commonly used.

  • RAID 53 (disk striping of stripe sets):
    Consists of a stripe set (RAID 0) of individual RAID-3 disk arrays. RAID 53 has the same level of fault tolerance as RAID 3. It is very expensive and is not commonly used.

    Graphic R-2. Common RAID file types.
    Graphic R-2. Common RAID file types.
NOTE

RAID is implemented using the Windows NT Server administrative tool Disk Administrator or the Disk Management portion of the Computer Management tool in Windows 2000. RAID cannot be implemented on Windows NT Workstation or Windows 2000 Professional.

TIP

Windows NT and Windows 2000 provide a software-based RAID solution in which the operating system software enables various types of RAID functionality on the internal disk subsystem, usually a Small Computer System Interface (SCSI) disk subsystem. The other type of RAID solution is hardware-based RAID, in which stand-alone external RAID-5 disk arrays are usually attached to servers using SCSI or fiber channel connections.

TIP

When you buy a hardware RAID-5 unit, be sure that it has hot-rebuild, hot-swap, and hot-spare capabilities. These features protect business-critical data and ensure high availability.

See also
fault tolerance

RAID-5 volume

In Microsoft Windows 2000, a volume created with the Disk Management portion of the Computer Management tool that stores its data with parity information across multiple physical disks. Data is stored using striping, which places data and parity information alternately and evenly across multiple disks. The parity information in RAID 5 is not stored on a single disk—each stripe stores its parity information on a different (rotating) disk. RAID-5 volumes provide fault tolerance, but they cannot be mirrored or extended. RAID-5 volumes must be created on dynamic disks.

NOTE

The Window NT and Windows 2000 equivalent of RAID-5 volumes are stripe sets with parity.

See also
dynamic volume

RAS

See
Remote Access Service (RAS)

RBOC

See
Regional Bell Operating Company (RBOC)

rcp

A simple TCP/IP utility for copying files to or from remote hosts. Rcp uses Transmission Control Protocol (TCP) to ensure reliable delivery of data between the client and the host. Rcp can be scripted in a batch file and does not require a password. The remote host must be running the rshd service, and the user’s username must be configured in the remote host’s .rhosts file. Rcp is one of the r-commands available on all UNIX systems.

NOTE

Microsoft’s implementation of TCP/IP on Windows NT and Windows 2000 includes rcp client software but not rshd services.

rdisk

A Microsoft Windows NT utility for updating information in the %SystemRoot%\repair folder and creating an emergency repair disk (ERD). You can use the ERD to save the configuration of a server running Windows NT and to restore the server if the system files or registry become corrupted. Rdisk is not listed as a Windows NT administrative tool, but you can run it from the command prompt, from the Run command box (via the Start menu), or by creating a shortcut to the executable by using the path \Winnt\System32\rdisk.exe. When you run rdisk, you can either update the \Winnt\Repair directory or simply create an ERD. (You can create a Windows 2000 ERD from the Welcome tab of the Backup tool.)

TIP

Rdisk.exe normally doesn’t back up the default, Security Account Manager (SAM), or security hives unless you run it with the /s switch. To do this, type rdisk /s at the command prompt or in the Run command box.

RDP

See
Remote Desktop Protocol (RDP)

recipient

In Microsoft Exchange Server, any directory object that can receive messages. Recipients are generally stored in the Recipient container within the Exchange directory hierarchy. Types of recipients that you can create include the following:

  • Mailboxes:
    Usually are owned by a specific user and contain the user’s personal folders, messages, and attachments

  • Distribution lists:
    A grouping of recipients generally used to support mass mailings (such as customer support bulletins)

  • Custom recipients:
    Users on other mail systems such as the Internet’s Simple Mail Transfer Protocol (SMTP) mail system or a private X.400 messaging system

  • Public folders:
    Locations for users to post documents and share workgroup projects

  • Mailbox agents:
    Scripts or programs that can process messages

recovery

The process of repairing a downed server, usually after a disk failure. Recovering a server usually involves these steps:

  1. Replacing the failed hardware that caused the server to crash

  2. Reinstalling the base operating system and any required service packs, along with any server applications that are needed

  3. Restoring critical data and configuration files from tape backup

In Microsoft Windows NT, you can configure recovery settings on the Startup/Shutdown tab on the property sheet of the System utility in Control Panel. (To configure recovery settings in Windows 2000, open the System utility in Control Panel, click the Advanced tab, and then click the Startup And Recovery button.) You use these settings to tell the server to dump debugging information or to log an event if a Stop screen occurs.

TIP

To prepare for the possibility of a downed server, you should do the following:

  • Create and keep handy floppy disks for booting the system.

  • Create and keep handy floppy disks containing critical system configurations, such as an emergency repair disk (ERD) for Windows NT and Windows 2000 systems.

  • Document the hardware of the machine and all installed software, fixes, and patches.

  • Keep a record of any previous recovery attempts.

  • Keep handy the hardware and operating system manuals.

Recreational Software Advisory Council (RSAC)

A nonprofit organization with a content advisory system for Web sites on the Internet. The system, known as RSACi (Recreational Software Advisory Council on the Internet), allows Web site administrators to rate their sites according to degrees of potentially objectionable content. There are four types of content, each with five levels, rated from 0 to 4. The content areas are as follows:

  • Sex

  • Nudity

  • Violence

  • Offensive language

By rating their Web sites according to the RSACi system, Web site administrators can help adults protect children from content that might be objectionable. Microsoft Internet Explorer has built-in client support for the RSACi system, which is administered using a password-protection scheme.

On the Web
•
Recreational Software Advisory Council (RSAC) home page
: http://www.rsac.org

recursive query

A Domain Name System (DNS) query in which a resolver contacts a name server to perform a name lookup and the name server returns a result or an error. The name server cannot refer the client to a different name server, but it can forward the query directly to another name server if it has a forwarder configured.

How It Works

When a name lookup is performed on a name server, the resolver sends a recursive query to a nearby name server. If the name is outside the name server’s zone of authority, the name server cannot resolve the name and returns an error unless it is also configured as a forwarder. If this is the case, the nearby name server performs an iterative query on a root name server, which then responds with the IP address of a name server whose zone of authority includes the desired top-level domain. Further iterative queries are performed until the name is resolved into its IP address or an error is produced.

See also
inverse query, iterative query

redirection

A process whereby a Web server such as Internet Information Services (IIS) forwards a request for a file to a different directory, Web site, or application. Redirection enables client requests to always be fulfilled, even when content in a site is being updated or if the name of a virtual directory has been changed. For example, if you want to replace an old version of a page named old.htm with a newer version named new.htm, but you don’t want to alter the navigational structure of your site or bother users with a notice of the change, you can enter a <META> tag in the <HEAD> section of the old.htm file to redirect browsers to the new page.

For example, the following tag in the <HEAD> section of the old page causes a browser accessing that page to be redirected to the new page after viewing the old page for 3 seconds:

<META HTTP-EQUIV="REFRESH" CONTENT="3;URL=NEW.HTM">

You can place a notice on the old page such as, “This page will be redirected to its newer version in 3 seconds.”

The term “redirection” is also used in printing. For example, if you are trying to print some documents but a print device has failed, Microsoft Windows 2000 lets you redirect all outstanding jobs for the print device to another print device that uses the same printer driver as the failed device. To redirect your pending documents, follow these steps:

  1. Open the property sheet for the failed print device, and select the Ports tab.

  2. Click the Add Port button, select Local Port, select New Port, and enter the Universal Naming Convention (UNC) path for the second print device.

  3. Click OK, and then click Apply.

redirection symbol

See
> (the “greater than” symbol in the Numbers and Symbols chapter)

redirector

A networking software component installed on a client machine or workstation that allows a client to access file and print services on a network server. The redirector makes it appear to the client that the file and print resources are located on the local machine instead of elsewhere on the network.

How It Works

On a machine running Microsoft Windows NT or Windows 2000, the Workstation service is the default redirector. However, you can install multiple redirectors on a machine running Windows NT or Windows 2000 if you need connectivity to different file systems. In Windows NT and Windows 2000, the redirector is implemented in the form of a file system driver. When a client program requests a network resource, the request is handed to the I/O Manager, which calls the redirector. The redirector translates the request into Server Message Block (SMB) requests for transmission over the network to the Server service on the remote computer.

Regional Bell Operating Company (RBOC)

One of the regional telcos that was created as a result of the breakup of American Telephone and Telegraph (AT&T), or one of their successors. AT&T, which was also known as the Bell System (or “Ma Bell”), was divested in 1983 to end its monopoly control and was broken up into several dozen Bell Operating Companies (BOCs), each of which was to supply telephone services to local loop subscribers in a given geographical region. Seven Regional Bell Operating Companies (RBOCs) were also created, each consisting of two or more BOCs. The seven original RBOCs were Ameritech, Bell Atlantic, BellSouth, NYNEX, Pacific Bell, Southwestern Bell, and U S WEST. RBOCs provided local loop services to much of the United States by functioning as local exchange carriers (LECs), while AT&T was left to provide long-distance carrier services and to function as an inter-exchange carrier (IXC). In addition to the RBOCs, dozens of independent LECs serviced different areas.

The telecommunications landscape changed with the passage of the Telecommunications Act of 1996. The act allowed RBOCs and independent LECs to compete with existing IXCs for long-distance carrier business, allowed mergers, and essentially opened up the telecommunications market to all kinds of companies, including cable television companies. Of the seven original RBOCs, only five remain today.

registration authority (RA)

A company or organization that is responsible for receiving and validating requests for digital certificates and public/private key pairs. A registration authority (RA) is part of the public key infrastructure (PKI).

How It Works

The RA receives a certificate request and verifies the identity of the requestor using acceptable forms of identification, which can be communicated face to face, over the telephone, by mail or courier, or in another secure fashion that is acceptable to the RA. Identification can include a driver’s license, Social Security number, or another unique identifier for the requestor. If the RA approves the request, it contacts the certificate authority (CA) in the PKI and asks it to issue the requestor the desired digital certificate and key pair. The RA and CA are often different entities within the same company or organization.

See also
public key cryptography, public key infrastructure (PKI)

registry

A hierarchical database in which newer Microsoft Windows operating systems store their hardware and software configuration information such as user profiles, the hardware and software installed on the system, registered document types, property settings for icons, ports being used, and so on. The registry in Windows 2000, Windows NT, Windows 95, and Windows 98 replaces the INI files, such as win.ini and system.ini, that were used in the legacy Windows 3.1 and Windows for Workgroups 3.11 operating systems.

How It Works

In Windows NT and Windows 2000, the registry is logically divided into five subtrees, each containing keys and subkeys (analogous to folders and subfolders) that themselves contain values (analogous to files). Physically, the registry consists of a series of hives and their transaction files located in %SystemRoot%\system32\config.

In Windows 95 and Windows 98, the logical structure of the registry is similar to that for Windows NT and Windows 2000, but the physical format is incompatible. A sixth subtree called HKEY_DYN_DATA is created dynamically and is used for performance measuring and Plug and Play configuration. The registry consists of dynamic information stored in RAM and two files in the %Win_Root% directory: system.dat, which stores computer-specific information, and user.dat, which stores user-specific information.

TIP

The main tool you should use to modify the registry is Control Panel, which provides a number of utilities for safely configuring different aspects of the system’s hardware and installed software. If you want (or need) to dig deeper into the registry, use the registry editor, but do so carefully—a single wrong value can render your operating system unbootable.

Registry Checker

A Microsoft Windows 98 utility for troubleshooting registry problems. Registry Checker can correct certain kinds of registry problems and can back up the registry regularly.

How It Works

Registry Checker comes in two forms:

  • ScanRegW:
    A protected-mode GUI-based version that you can run from within Windows to scan the registry for corruption, optimize the format of registry files, and back up the user.dat, system.dat, win.ini, and system.ini files. ScanRegW runs automatically when you start your system; you can also use it to force a scan to back up the files. The backed up files are stored as compressed .cab files in \Windows\Sysbckup.

  • ScanReg:
    A real-mode MS-DOS-based version that is invoked when ScanRegW finds corruption in the registry and asks you to restart the computer. ScanReg runs during restart and either restores the registry to a known good backup version or, if none exists, tries to fix the corruption.

Registry Checker automatically inspects the registry upon startup and attempts to either fix the problem or restore the registry from backup. It automatically backs up the Windows 98 registry each day after a successful system startup and can maintain up to five different backup versions of the registry in compressed format. Registry Checker also improves system performance by removing information from the registry that is no longer needed and by compacting free space.

TIP

To manually start Registry Checker, open the Start menu, point to Accessories and then System Tools, and choose System Information. In the Microsoft System Information window, select Registry Checker from the Tools menu.

registry editor

A tool for editing the Microsoft Windows registry. The registry editor for Windows 95 and Windows 98 is called regedit, and the registry editor for Windows NT and Windows 2000 is called regedt32.

Regedit lets you search for, create, modify, and delete keys and values in the local registry; connect to a remote computer running Windows 95 or Windows 98; view or modify the registry; and import and export portions of the registry as text files with the extension .reg.

Regedt32 lets you search for, create, modify, and delete keys and values on the local or remote computer; save and restore keys for backup purposes; modify permissions; and configure auditing of registry access.

Graphic R-3. Registry editor.
Graphic R-3. Registry editor.
NOTE

The Windows 95 and Windows 98 registry editor regedit is included in Windows NT and Windows 2000 in the %SystemRoot% directory, but you should avoid using it for editing the registry for these operating systems because it does not support all data types in the Windows NT and Windows 2000 registries.

TIP

To avoid accidentally corrupting the registry, use the Options menu to set regedt32 to read-only mode unless you need to modify to the Windows NT or Windows 2000 registry.

To remotely modify the registry over the network on another machine running Windows 95 or Windows 98, you must have the Remote Registry service installed and user-level security enabled on the network.

If you make a mistake when you use the registry editor, your system might be rendered unbootable! Microsoft recommends against directly changing the registry if you can make the change using another method (such as using Control Panel).

relative path

The hierarchical path that locates a file or folder on a file system starting from the current directory. The relative path is different from the absolute path, which locates the file or folder starting from the root of the file system.

Example

If the current directory is C:\Windows, the relative path to the executable for the game of Solitaire, which is located in the current directory, is simply the name of the executable—sol.exe. If the current directory is C:\Windows\System, the relative path to Solitaire is ..\sol.exe.

In a UNIX file system, the syntax for relative paths is similar except that it uses forward slashes instead of backslashes to separate levels in the file system hierarchy.

NOTE

The idea of a “relative path” is also used in other naming contexts. For example, in Active Directory of Microsoft Windows 2000, you can uniquely and globally specify directory objects using the object’s distinguished name, which provides a kind of absolute path within the directory starting at the root and terminating at the desired object. For example, the object representing the user Mitch Tulloch in the domain northwind.expedia.com has this distinguished name:

DC=com,DC=expedia,DC=northwind,OU=Users,CN=Mitch Tulloch

If a search context is established as the Users container within the northwind.expedia.com domain, the relative distinguished name of the Mitch Tulloch object is simply

CN=Mitch Tulloch

This relative distinguished name uniquely identifies the desired object within the Users container in Active Directory.

See also
absolute path

remailer

Also called an anonymous remailer, an Internet site that lets you forward Simple Mail Transfer Protocol (SMTP) e-mail to recipients anonymously. You can use remailers to ensure the privacy of your e-mail address—for example, to keep recipients from adding your address to a mailing list. You can also use remailers to prevent yourself from being spammed when you voice an unpopular opinion on a mailing list or some other forum.

TIP

Yahoo! has a list of Web-based anonymous remailers.

remote access

Any networking technology that gives users access to essential network services from remote locations. Remote access to a company network can be either dial-up access through a modem or dedicated access through a leased line. Remote access typically gives remote users access to the following services on a company network:

  • File and print services

  • Client/server applications such as database applications

  • Applications for remote network administration

How It Works

There are two basic types of remote access:

  • Remote control:
    Uses a program such as pcAnywhere to take control of the console of a computer remotely. Administrators generally use this method to troubleshoot server problems remotely. However, because the remote connection is often made through a relatively slow analog modem, the bandwidth restriction often makes remote control access slow and jerky. Remote control access provides high security, saves on hardware and licensing costs, and is simple to implement on a network.

  • Remote node:
    Uses a remote access device to provide a gateway for users to access file, print, and other services on a company network from remote locations, such as from a laptop while on the road. Remote access gateway devices can be computers running remote access software and connected through multiport serial boards with 4, 8, 12, or more asynchronous communication ports that are connected to analog modem banks or ISDN terminal adapters, or they can be routers with built-in modem or Integrated Services Digital Network (ISDN) functionality. A computer that makes remote access possible is generally called a remote access server, while a router that supports remote access is generally called an access server. Remote node devices can include features such as network address translation (NAT), Dynamic Host Configuration Protocol (DHCP) support, password-based authentication, callback, and basic firewall functionality.

Graphic R-4. Remote access.
Graphic R-4. Remote access.
NOTE

Microsoft has enabled remote node remote access functionality on both its Windows NT and Windows 2000 operating system platforms to allow remote users to connect to a Windows NT–based or Windows 2000–based network. The Remote Access Service (RAS) of Windows NT provides full-featured remote node services for dial-up networking and virtual private network (VPN) functionality using the RAS and is administered using the administrative tool called Remote Access Admin. The optional Routing and Remote Access Service (RRAS) component for Windows NT 4 adds additional Internet Protocol (IP) routing functionality and is administered using its own tool called Routing and RAS Admin. On the Windows 2000 platform, both dial-up networking and VPN functionality are supported within Routing and Remote Access; they are administered by using either the netsh command-line utility or the Routing and Remote Access console.

A RAS server is often called a RAS router because it has at least one local area network (LAN) and one wide area network (WAN) interface and therefore operates as a router. The same is true of RRAS servers.

TIP

In a mixed environment of Windows NT and Windows 2000 RAS and RRAS servers, there are limitations on which tools you can use for administering the various servers:

  • The Windows 2000 Routing and Remote Access console can be used to manage many aspects of Windows NT RRAS routers, but it cannot perform certain tasks such as installing or removing RRAS, configuring RRAS properties, configuring IP–IP tunnels, and so on.

  • The Windows 2000 Routing and Remote Access console cannot be used to manage Windows NT RAS routers. Instead, when you select a Windows NT RAS server using the Windows 2000 RRAS console, the Windows NT administrative tool Remote Access Admin will automatically be opened with the Windows NT RAS server automatically selected.

  • You cannot use the Windows NT RAS administrative tool Remote Access Admin or the Windows NT RRAS administrative tool Routing and RAS Admin to administer Windows 2000 RRAS routers.

  • The netsh command-line utility for administering RRAS on Windows 2000 cannot be used with RAS or RRAS on Windows NT.

Remote Access Admin

An administrative tool in Microsoft Windows NT for managing and configuring the Remote Access Service (RAS) on servers running Windows NT. You can use this tool to

  • Connect to a RAS server to administer it

  • Stop, start, and pause RAS on the server

  • Grant permission to users to dial in to the network using RAS and specify callback settings

  • Monitor, send messages to, and disconnect active RAS users

NOTE

The corresponding tool for administering remote access on the Windows 2000 Server platform is the Routing and Remote Access console.

TIP

You can also grant a user permission to dial in to your network through RAS by using User Manager for Domains. Access the user’s properties and click the Dialin button.

Remote Access Service (RAS)

An optional Microsoft Windows NT networking service that provides remote access for remote clients. A machine running Windows NT on which Remote Access Service (RAS) is installed is called a RAS server.

How It Works

RAS allows remote clients to connect through a telephone line or other wide area network (WAN) link to the RAS server; from there RAS allows those clients to access resources on the network. Remote users can access network resources as though they were logged on to a machine directly connected to the network. To allow a user to connect remotely to the RAS server, use the administrative tool User Manager for Domains and grant the user dialin permission. You can set three forms of dialin permission:

  • No call back:
    Gives the user permission to dial in to the network using the RAS server.

  • Set by caller:
    Terminates the connection after the user dials in to the RAS server. The RAS server dials the user back at the phone number the user specifies. This function is called callback.

  • Preset to:
    Also uses callback, but the server always calls the user back using a phone number preset on the server.

RAS on Windows NT provides both dial-in and dial-out capability, supporting up to 256 simultaneous inbound connections on Windows NT Server but only one inbound connection on Windows NT Workstation. Clients that want to connect to a RAS server must have dial-up networking or a similar application installed. RAS is fully integrated into the Windows NT security model and supports encrypted authentication, auditing, callback, and intermediary hardware security hosts. Users can be restricted to access to the RAS server only, or to access through the RAS server to all resources on the network.

Windows NT RAS supports clients connecting over the following media:

  • The Public Switched Telephone Network (PSTN) using modems

  • Dedicated Integrated Services Digital Network (ISDN) lines

  • X.25 packet-switching networks

  • A null modem cable

You can establish RAS connections with Windows NT by using any common local area network (LAN) transport protocol and the following WAN protocols:

  • Point-to-Point Protocol (server-side or client-side), including Point-to-Point Tunneling Protocol (PPTP) for establishing virtual private network (VPN) connections

  • Serial Line Internet Protocol (client-side only)

NOTE

An optionally available Windows NT 4 component called Routing and Remote Access Service (RRAS) replaces the existing RAS on Windows NT and provides additional Internet Protocol (IP) routing functionality.

On Windows 2000 Server, remote access functionality is provided by Routing and Remote Access, which supports both dial-up networking and virtual private networks.

TIP

You install RAS on a Windows NT server by using the Services tab of the Network utility in Control Panel.

See also
remote access, Routing and Remote Access, Routing and Remote Access Service (RRAS)

remote administration

The practice of administering network resources from a remote location. Remote administration capability is essential in an enterprise-level wide area network (WAN) environment and for network administrators who are on the road. Networking and software vendors offer many types of solutions for remote administration, including the following:

  • Remote access devices, which allow administrators to dial in to their corporate networks from remote locations using a laptop and a modem. They can then use various software tools to administer different aspects of the network. For example, in a network based on Microsoft Windows 2000, administrators can use Microsoft Management Console (MMC) with suitable snap-ins installed to remotely administer servers running Windows 2000 from any computer running Windows 2000. They can also use remote control software such as pcAnywhere to run any administrative tool from a remote platform.

  • Programs such as Telnet, which administrators can use over remote access links to configure devices such as routers and Ethernet switches from the command prompt. Many of these devices support another form of management called out-of-band management (OBM), which allows administrators to directly dial in to the device through a modem connected to an RS-232 serial port on the device and configure the device using a program such as HyperTerminal.

  • Secure remote administration through the Internet. Microsoft Internet Information Server (IIS) on Windows NT—Internet Information Services on Windows 2000—includes a remote administration tool that is implemented as an Active Server Pages (ASP) application on the server. Using this tool, administrators can use a simple Web browser such as Microsoft Internet Explorer to remotely configure World Wide Web (WWW) and File Transfer Protocol (FTP) servers running on Windows NT Server and Windows 2000 Server.

  • Code-operated matrix switches, which are useful if remote devices need to be rebooted. A switch is connected to a device’s power supply and can be controlled from a remote location via a computer and a modem.

Remote Authentication Dial-In User Service (RADIUS)

A protocol for authentication, authorization, and accounting of remote access connections using dial-up networking and virtual private network (VPN) functionality. Remote Authentication Dial-In User Service (RADIUS) is typically implemented with the Point-to-Point Tunneling Protocol (PPTP).

How It Works

RADIUS is a client/server protocol that centralizes the profile information of dial-up users in a central database on a RADIUS server, which runs special RADIUS software. The RADIUS server is generally separate from the network access server (NAS) that actually allows the client to make a dial-up connection. An RFC-compliant RADIUS server stores all user profile information in a flat-file ASCII database that is accessible by any NAS that needs it to authenticate users. Some RADIUS servers can also use UNIX password files, Password Authentication Protocol (PAP), Challenge Handshake Authentication Protocol (CHAP), Microsoft Challenge Handshake Authentication Protocol (MS-CHAP), third-party security systems, and Network Information Services (NIS) for authenticating users. This improves the security of remote access to corporate networks through tunneling across the Internet and simplifies administration of remote users. RADIUS servers are also typically used to provide statistics for billing purposes.

In a typical session, a client dials in to a NAS at an Internet service provider (ISP) and submits its credentials, which the NAS reformats as RADIUS packets and forwards to the RADIUS server. The RADIUS server can authenticate the user directly or act as a proxy client to forward the authentication process to some other type of service or security device. Once the RADIUS server authenticates the client, it informs the NAS, which allows the client to complete its connection. All communication between the client and the RADIUS server is encrypted.

Graphic R-5. Remote Authentication Dial-In User Service (RADIUS).
Graphic R-5. Remote Authentication Dial-In User Service (RADIUS).
NOTE

RADIUS is supported by the Internet Authentication Service (IAS).

Remoteboot service

An optional Microsoft Windows NT service for starting MS-DOS, Windows 3.1, Windows 95, and Windows 98 Remoteboot clients remotely over the network. These Remoteboot clients are diskless workstations that have a network interface card (NIC) with a boot programmable read-only memory (PROM) chip that allows them to be started remotely. The client operating system and client startup configuration files reside on the Remoteboot server, not on the client.

Remoteboot gives the administrator greater control over a user’s workstation but requires greater network bandwidth to work effectively. It reduces costs by eliminating the need for local hard drives or floppy drives on workstations. You use the Remoteboot Manager administrative tool to manage the Remoteboot service on a server running Windows NT and to add diskless workstations to your network, remove them from the network, and configure them.

remote bridge

A bridge that connects two geographically separated networks by using a telecommunications service such as Plain Old Telephone Service (POTS), leased lines, or a circuit-switched service. A remote bridge has at least one local area network (LAN) port, such as an RJ-45 jack for an unshielded twisted-pair (UTP) LAN connection to a switch or a hub, and at least one serial port, such as an RS-232 port or V.35 interface. The serial port is synchronous for digital lines or asynchronous for modems. The bridge might have both synchronous and asynchronous serial ports. Remote bridges can also be enabled for Simple Network Management Protocol (SNMP) and have other diagnostic and support features such as out-of-band management (OBM) support.

Graphic R-6. Remote bridge.
Graphic R-6. Remote bridge.
TIP

To use remote bridges to connect remote LANs, connect a bridge to the main hub or switch in each LAN, and then connect the serial port on each bridge to the modem, Integrated Services Digital Network (ISDN) terminal adapter, or Channel Service Unit/Data Service Unit (CSU/DSU), depending on the type of wide area network (WAN) link used.

See also
bridge

remote client impersonation

A technique for attacking or gaining improper access to a network. Remote client impersonation takes place when a third party monitors traffic on a network by using a packet sniffer or software such as Microsoft Network Monitor, captures a connection during the user authentication process, extracts the authentication parameters (such as username, password, and domain) from the captured frames, and then takes control of the authenticated connection.

A similar hacking technique called a replay attack takes place when a third party monitors traffic on a network, captures a connection during the authentication process, and then plays back the client’s captured response to obtain a new authenticated connection.

TIP

Authentication schemes in which the user’s password is transmitted in clear text, such as the Password Authentication Protocol (PAP) supported by most Point-to-Point Protocol (PPP) services, are most susceptible to remote client impersonation and replay attacks. More secure PPP authentication schemes, such as the Challenge Handshake Authentication Protocol (CHAP) or the Microsoft version of that protocol (MS-CHAP), are preferable. CHAP guards against remote client impersonation by using the user’s password to create an encrypted hash of a challenge string instead of passing the actual password during the authentication process. It protects against replay attacks by using a different, arbitrarily selected challenge string for each authentication attempt.

TIP

To access secured resources on Internet Web sites hosted by Internet Information Services (IIS), be sure that Basic Authentication is disabled on the server and that sensitive documents are located on NTFS volumes with suitable permissions configured.

Remote Desktop Protocol (RDP)

A protocol used by Microsoft Windows NT Server, Terminal Server Edition, and by Windows 2000 Server Terminal Services that lets clients communicate with Terminal Services over a network. Remote Desktop Protocol (RDP) is based on the T.120 protocol of the International Telecommunication Union (ITU), a standard multichannel conferencing protocol that is also used in Microsoft NetMeeting conferencing software. RDP is a multichannel-capable protocol that can use separate virtual channels for carrying serial device communication and presentation data sent from the server and encrypted client mouse and keyboard data sent from the client. RDP supports up to 64,000 separate channels for data transmission and supports multipoint transmission.

NOTE

RDP is sometimes referred to as the Remote Display Protocol. It was formerly known as the T.SHARE protocol.

Remote Network Monitoring (RMON)

An extension of the Simple Network Management Protocol (SNMP) that allows detailed monitoring of network statistics for Ethernet networks. Remote Network Monitoring (RMON) is defined in Request for Comments (RFC) 1757.

RMON lets you monitor network traffic on a remote Ethernet segment from a central location on the network to detect problem conditions such as traffic congestion, dropped packets, and excessive collisions. You can use RMON to set network traffic thresholds that trigger alarms so that you can correct network problems before they occur. Embedded RMON support for Ethernet switches lets network administrators monitor switched Ethernet networks that cannot easily be monitored using traditional packet-sniffing network analyzers.

How It Works

Like SNMP, RMON is implemented as a standard Management Information Base (MIB) on RMON-enabled devices. These RMON-enabled devices include the following:

  • Stand-alone devices called dedicated RMON probes that can be temporarily or permanently installed where desired on the network

  • Existing network devices such as repeaters, bridges, hubs, routers, or Ethernet switches that have an RMON probe embedded into their circuitry

An RMON probe consists of an SNMP agent for collecting information and communicating it to an SNMP management application, and one or more RMON MIBs defining the network objects to be managed. Typically, an SNMP-manageable device such as a hub or router needs additional software installed on it only to provide RMON functionality and turn it into a probe. Other devices called hosted probes are implemented as add-on hardware modules with built-in processing power and memory.

RMON is usually implemented on only one device or interface per TCP/IP subnet. RMON agent software runs on the port of the router or switch, which monitors and collects Ethernet networking statistics for the attached subnet. These statistics relate to the physical layer (layer 1) and the data-link layer (layer 2) of the Open Systems Interconnection (OSI) reference model for networking. An SNMP management console contacts the RMON agent when it wants to collect the statistics in order to analyze them and present them to the network administrator, or network traffic conditions on the device can trigger the agent to notify the management station of an alarm condition using SNMP traps. RMON agents can also collect and store statistics for monitoring trends in network traffic.

The RMON MIB defined in RFC 1757 contains nine groups of manageable objects (RMON monitoring elements) for various aspects of Ethernet traffic monitoring, totaling 204 objects and 2 events. These groups of objects, usually referred to as the RMON1 groups, are as follows:

  • Statistics (1):
    Records statistics for Ethernet network interfaces (ports), including packets sent and received, bytes sent and received, the number of each type of packet, packets dropped, errors, and collisions

  • History (2):
    Specifies the types of data being sampled and the frequency at which data is sampled, and records the sampled data for later analysis

  • Alarm (3):
    Lets you set thresholds and sampling periods to trigger alarms when specified network conditions arise

  • Host (4):
    Records MAC addresses; the number of packets sent and received for broadcast, unicast, and multicast packets; the number of bytes sent and received; and the number of error packets for all hosts on the subnet

  • HostTopN (5):
    Lets you list hosts according to ranking parameters such as amount of traffic generated or number of errors generated

  • Matrix (6):
    Records statistics for communication between pairs of hosts, such as their source and destination addresses and the number of bytes and packets sent and received

  • Filter (7):
    Controls which kinds of packets the agent should capture, such as all packets larger than a certain size, all packets that match a specific bit mask, or logical combinations of individual expressions

  • Capture (8):
    Lets you capture packets for collecting network statistics and configure capture buffer sizes

  • Events (9):
    Lets you generate SNMP traps and log entries

NOTE

RFC 1513 extends the original RMON specification by adding a MIB group to RMON called Token Ring, which extends RMON functionality to Token Ring local area networks (LANs) by allowing sampling and collection of statistics specific to this networking environment.

RMON2, defined by RFC 2021, extends the original RMON specification with nine more MIB groups that specify the collection of statistics at the network layer (layer 3) and application layer (layer 7). Network administrators can remotely collect information about the flow of data in client/server applications in an enterprise environment. For example, with RMON2-enabled routers and switches, you can determine which workstations are accessing a specific client/server application on a specific server from a remote SNMP management console. RMON2 includes the original RMON MIB groups and extends them with an additional 268 manageable objects.

TIP

Make sure that your RMON-enabled device or probe supports at least groups 1, 2, 3, and 9 from the previous list. Probes that support only these four groups are said to support mini-RMON. Many network hardware vendors provide RMON-enabled devices that support only mini-RMON because these are generally considered the most useful RMON groups.

See also
Simple Network Management Protocol (SNMP)

remote procedure call (RPC)

A message-passing programming technology developed by Sun Microsystems and extended by the Open Software Foundation (OSF) that allows an application to execute procedures and interact with services on a remote computer on the network. Remote procedure calls (RPCs) are the preferred method of enabling client/server processing on the Microsoft Windows 2000 and Windows NT platforms, an Microsoft’s implementation of RPC functionality is compatible with that of other implementations, such as those for the IBM AIX, HP-UX, and Sun Solaris operating systems.

How It Works

You use RPCs to pass messages between components of a distributed application that are located on different computers on a network. While local procedure calls (LPCs) provide a mechanism for enabling different parts of an application located on a single computer to communicate with each other, RPCs involve communication between different computers. RPCs actually use a variety of other interprocess communication (IPC) mechanisms such as named pipes, mailslots, Windows Sockets, and NetBIOS to establish connections between the RPC client and RPC server components on different machines.

The remote procedure call service (RPC service), a component of the Windows NT executive running in kernel mode, is responsible for message-passing between the client and server components of a distributed application, usually a client/server application such as Microsoft Outlook (client part) with Microsoft Exchange Server (server part). On a Windows NT–based network, the server part of a distributed application first registers itself with the RPC Locator service. The client part of the application, which is on the local computer, can then query the RPC Locator service to determine the location of the required server part. A process called the remote procedure stub then packages the client’s function call into a suitable RPC message and sends it to the remote computer using the RPC Run Time process. At the remote machine, a process called the application stub receives the RPC message, unpackages it into a function call, and executes it, returning any resulting values to the client part in a similar fashion. From the viewpoint of the client part of the application, the server part appears to be on the same computer.

Remote Registry service

A Microsoft Windows 95 and Windows 98 service that allows the registry editor and the System Monitor tool to connect to a remote computer running Windows 95 or Windows 98 for remote administration and troubleshooting. This arrangement works only if the following conditions are met:

  • Both computers must be running the Remote Registry service. To install the Remote Registry service, use the Network utility in Control Panel and add a new service by browsing to the \Admin\Nettools\Remotreg folder (on the Windows 95 CD) or the \Tools\Reskit\Netadmin\Remotreg directory (on the Windows 98 CD).

  • Both computers must be configured for user-level security. This means that there must be a security provider on the network, such as a Windows NT domain controller.

  • Both computers must be running a common network protocol such as TCP/IP, IPX/SPX, or NetBEUI.

  • Remote administration must be enabled on the remote computer for the user of the local computer. You enable remote administration by using the Passwords utility in Control Panel.

NOTE

Granting remote administration privileges on a computer running Windows 95 or Windows 98 means that the user has full control over all shared network resources on the machine, including access to the full file system through the hidden administrative share Admin$.

repeater

A networking component that extends a network by boosting the signal so that it can travel farther along the cabling.

How It Works

Digital signals traveling on cables weaken with distance—a phenomenon known as attenuation. A repeater is a form of digital amplifier that works at the physical layer (layer 1) of the Open Systems Interconnection (OSI) reference model for networking to regenerate (amplify) the signal so that it can travel farther. Repeaters also perform other functions such as filtering out noise caused by electromagnetic interference (EMI), reshaping the signal, and correcting timing to remove signal jitter so that the signal can travel farther. Repeaters can also be used to join dissimilar media such as unshielded twisted-pair (UTP) cabling and thinnet, but they cannot be used to join dissimilar network architectures such as Ethernet and Token Ring. Repeaters are an inexpensive way to extend a network.

Repeaters can be used in Ethernet and Token Ring local area networks (LANs) to extend signal transmission to remote nodes and over long fiber-optic cabling runs to connect LANs. Repeaters can also be used in mainframe environments for boosting signals for serial transmission to remote terminals.

Other uses for repeaters include the following:

  • Joining two 16-Mbps Token Ring networks in different buildings over distances up to 3000 meters over multimode fiber-optic cabling or up to 20 kilometers over single-mode fiber

  • Increasing the lobe length between a Token Ring main ring and a remote node

  • Joining dissimilar 10Base2 and 10Base5 segments to form a single Ethernet LAN

  • Boosting signals from mainframe controllers to 3270 terminals over coaxial or UTP cabling to support distances up to 2500 meters

  • Extending the operating distance of T1 lines by placing G.703 repeaters at 2.2-kilometer intervals

  • Extending backbone fiber-optic cable runs in campuswide LANs or metropolitan area networks (MANs)

Repeaters are also used in fiber-optic networks to amplify and regenerate light signals for long-distance cable runs. Repeaters come in various types for different network architectures and data communication technologies.

NOTE

Up to two Class II Ethernet repeaters can be cascaded together to connect remote nodes that are up to 205 meters apart.

TIP

Other than increasing signal strength, repeaters do not filter network traffic in any way. In particular, they do not block broadcasts, so if you connect two Ethernet segments using a repeater, you increase the size of the collision domain, which degrades overall network performance. For this reason, bridges and routers are often preferable to repeaters.

See also
hub

replay attack

See
remote client impersonation

replica domain controller

A type of domain controller in a Microsoft Windows 2000–based network. A replica domain controller is a domain controller that has joined an existing domain. The replica domain controller gets its copy of the Active Directory database from the first domain controller in the domain. A replica domain controller is created when an existing member server in a domain is promoted to a domain controller using the Active Directory Installation Wizard.

Replica domain controllers can provide several functions in a Windows 2000–based network, including the following:

  • Improving support for network logons and access to network resources

  • Providing fault tolerance for Active Directory by supplying a backup copy of the directory database

TIP

You must have administrative privileges in the domain to promote an existing member server to a replica domain controller. At least one Domain Name System (DNS) server must also be running on the network, and at least one domain controller must be running in the target domain.

See also
Active Directory, domain controller

replication

See
directory replication in Windows 2000

Replicator

A built-in group on all servers and workstations running Microsoft Windows NT. The Replicator group is used by the Directory Replicator Service to replicate part of the file system between computers running Windows NT. The group’s membership is initially empty. When you configure the Directory Replicator Service, you must create a special user account with any name to provide a context in which the service can start up and run. You must make this account a member of the Replicator, Backup Operators, and Domain Users groups. The Replicator group must also have change permission for the Export and Import folders on the computers involved in replication and must be granted the system right called Logon As A Service using User Manager for Domains in order for replication to function properly.

See also
Directory Replicator Service

Report Writer

A tool included with Microsoft Site Server and Microsoft Site Server Express that can take Web server log files that have been imported using the Usage Import tool and generate summary or detail reports on several topics, including the following:

  • Bandwidth use due to server hits

  • Browser and operating system used by clients

  • Geographical distribution of clients

  • Hit statistics

  • Most and least frequently requested documents

Request for Comments (RFC)

A document that describes the standards, protocols, and technologies of the Internet and TCP/IP. Since 1969, about 2400 Requests for Comments (RFCs) have been published on various networking protocols, procedures, applications, and concepts.

Internet and TCP/IP standards are generated by consensus rather than by committee. Any member of the Internet Society (ISOC) can submit an RFC for consideration, although submission is usually done through the Internet Engineering Task Force (IETF). Once published, an RFC is reviewed by various technical groups and given one of five classifications:

  • Required

  • Recommended

  • Elective

  • Limited Use

  • Not Recommended

Once an RFC is classified, it is published as an Internet Draft and is discussed and tested by research and technical groups and individuals. It might eventually go through the following stages of development:

  1. Proposed standard:
    Stable, well understood, and generally considered useful

  2. Draft standard:
    Stable enough to develop implementations of the standard in applications and networking technology

  3. Internet standard:
    Technically mature, widely implemented, and significantly beneficial to the Internet community

RFCs are sequentially numbered and published by the RFC Editor at the Information Sciences Institute at the University of Southern California.

NOTE

Old RFCs are not updated, so several RFCs might relate to the same Internet protocol or technology, and some of them might be obsolete. To find the current RFC for a protocol or technology, see the Internet Architecture Board (IAB) Official Protocol Standard published quarterly by the IAB. The following table shows some of the important RFCs for commonly used Internet protocols.

Some Important RFCs for Internet Protocols
Protocol | RFC(s)
ARP | 826
DHCP | 2131, 2132
DNS | 1034, 1035
FTP | 959
HTTP-1.1 | 2068
ICMP | 792
IGMP | 1112
IMAP4 | 2060
IP | 791, 919, 922, 950
IPv6 | 1883
Kerberos | 1510
LDAPv3 | 2251
MIME | 2045, 2046, 2047, 2049
NetBIOS | 1001, 1002
NNTP | 977
OSPFv2 | 2328
POP3 | 1939
PPP | 1661, 1662
PPP-CHAP | 1994
PPP-MP | 1990
RADIUS | 2138
RMON | 1757
RSVP | 2205
SMTP | 821, 822, 974, 1869, 1870
SNMP | 1157
SNMPv2 | 1441
TCP | 793
Telnet | 854, 855
UDP | 768
On the Web
•
RFC Editor
: http://www.rfc-editor.org

reservation

An IP address that is reserved for a specific computer by a Dynamic Host Configuration Protocol (DHCP) server. The reservation contains the IP address to be leased and the MAC address of the computer it will be leased to. Reservations are often used for servers on a network, which normally should all have the same IP address. An alternative procedure is to manually assign these servers a static IP address. The advantage of using a reservation is that the IP address of the server is centrally managed in the database of the DHCP server, which means there is less chance of an address conflict.

Reservations (or static IP addresses) are always recommended for

  • Domain controllers

  • Domain Name System (DNS) and Windows Internet Name Service (WINS) servers

  • Router interfaces

  • Non-DHCP clients

TIP

To create a reservation for a computer, you must know the MAC address of its interface. On computers running Microsoft Windows NT or Windows 2000, you can enter ipconfig at the command prompt to determine this value; on computers running Windows 95 or Windows 98, you can enter winipcfg in the Run dialog box (which you access via the Start menu).

resolver

Abstractly, a client in the Domain Name System (DNS). More concretely, a resolver is software running on a TCP/IP host that enables the host to query a name server in order to resolve a host name into its associated IP address. The resolver software enables the host to formulate and send a query to the name server, interpret the response from the name server, and pass this information to the program that initially called the resolver software.

On UNIX platforms with BIND implemented, a resolver is a set of library routines that are linked to the client programs that need to use them, such as Web browsers or File Transfer Protocol (FTP) client programs. Computers running Microsoft Windows become resolvers when you install the TCP/IP protocol stack and configure the IP address of a DNS server on the DNS tab of the TCP/IP property sheet.

See also
Domain Name System (DNS), host name resolution

resource domain

In Microsoft Windows NT, a type of domain in an enterprise networking environment that includes file, print, and other resources for users throughout the enterprise. Resource domains are part of a master domain model or multiple master domain model enterprise-level implementation of Windows NT. Resource domains simplify resource administration by separating the administration of resources from the administration of user accounts.

How It Works

In a master domain model implementation of Windows NT, an account domain—or master domain—contains user accounts for every user in the enterprise and is usually located at corporate headquarters. Servers and workstations at branch offices belong to other domains called resource domains. A trust relationship is established so that each resource domain in the enterprise trusts the account domain. Users at branch offices who want to log on to the network simply log on to the account domain even though their workstations are located within resource domains. Administrators at branch offices are responsible for managing only the resources (file and print shares, Web servers, database servers, and so forth) for their own domain and are not involved in account management.

See also
account domain, trust relationship

resource for a cluster

Any physical or logical component that can provide a service to a network client and that can be taken offline and brought online by Microsoft Cluster Server (MSCS) or Windows Clustering. Resources are physical or logical entities that are managed by a node of a cluster. MSCS supports a number of types of resources, which you can manage using the Cluster Administrator program. These resource types include the following:

  • Dynamic Host Configuration Protocol (DHCP) servers

  • Distributed Transaction Coordinator

  • File shares

  • Generic applications such as database programs

  • Generic services such as Microsoft Windows NT services

  • Internet Information Services (IIS) virtual server for World Wide Web (WWW) and File Transfer Protocol (FTP)

  • IP addresses

  • Microsoft Message Queue (MSMQ) Server

  • Network names

  • Physical disks

  • Print spoolers

  • Time services

Related MSCS terminology with regard to resources includes the following:

  • Resource Group:
    An association of dependent or related resources running on one node of a cluster. Dependent resources require other resources in order to operate. All resources in a group move together between nodes during failover or failback operations.

  • Resource Monitor:
    A software component of MSCS that facilitates communication between the Cluster service and application resources.

NOTE

MSCS resources always exist in one of the following states:

  • Offline

  • Offline pending

  • Online

  • Online pending

  • Failed

resource on a network

Any files, applications, or devices on a network that users need access to. Examples of network resources include the following:

  • Shared folders and volumes:
    Contain files that users need to access. Users can be granted different levels of permissions on these shares. For example, users might be given read-only permission for shares that contain administrative documents, modify permission for shares that contain workgroup documents, and full control permission for their own personal shared folders.

  • Shared printers:
    Allow many users to print to a single print device. You can control access to the printer by using print permissions and by setting priorities and times for accessing printers.

  • Applications:
    Allow users to access back-end applications (such as databases) using front-end clients. These applications can be standard .exe executables or scripted Web server applications such as those developed using Microsoft Active Server Pages (ASP) technology.

  • Web servers:
    Allow HTML-based documents and applications to be shared and accessed from any platform by using a standard Web browser such as Microsoft Internet Explorer.

  • File Transfer Protocol (FTP) servers:
    Allow files to be shared between different operating system platforms such as UNIX and Microsoft Windows.

resource record

An individual entry in a Domain Name System (DNS) database that contains information about domain names in the DNS.

How It Works

Resource records are individual records (lines) in a text file called a zone file, which is located on a DNS server. You can edit this zone file with a simple text editor, but Microsoft Windows NT and Windows 2000 platforms offer a GUI-based administrative tool that simplifies the creation and management of resource records on a Windows NT or Windows 2000 DNS server. A typical resource record consists of a series of fields separated by spaces.

The most common type of resource record is the address record, or A record, which maps the IP address of a TCP/IP to its DNS name. Other common types of resource records include CNAME, NS, PTR, SOA, and SRV. The following table describes some important types of resource records that you can create in the standard implementation of DNS as defined by Request for Comments (RFC) 1035 and later.

Possible DNS Resource Records
Record Type | Description
A (address) | Maps the IP address to the host name
CNAME (canonical name) | Creates an alias for a host name
HINFO (host information) | Specifies information about the host, such as operating system and CPU type
MX (mail exchanger) | Indicates a Simple Mail Transfer Protocol (SMTP) host (mail forwarder)
NS (name server) | Indicates a DNS name server that is authoritative for the domain
PTR (pointer) | Points to another location in the DNS namespace
SOA (start of authority) | Indicates the name server that is authoritative for the domain
SRV (server) | Locates a host that can provide a specific network service
See also
Domain Name System (DNS)

reverse hosting

Also called virtual hosting, an extension to reverse proxying that is supported by Microsoft Proxy Server. Using reverse hosting, the proxy server simulates virtual roots on a Web server and redirects requests for a particular domain and root combination to a single Web server. This approach means that only one hole needs to be opened through the Proxy Server firewall to allow Hypertext Transfer Protocol (HTTP) requests to enter. Reverse proxying works as an application layer proxy service and supports HTTP only.

reverse name lookup

The process of a resolver querying a name server to resolve a host’s IP address into its associated fully qualified domain name (FQDN). This is the reverse of the usual host name resolution process, in which a resolver queries a name server to resolve a host name into its associated IP address. Reverse name lookups use a special domain called in-addr.arpa.

Reverse name lookups are used in a variety of circumstances. For example, when a Web browser contacts a Web server, the Web server obtains the IP address of the computer the browser is running on. The Web server software often uses a reverse lookup to try to resolve the client’s IP address into its associated FQDN, usually for purposes of logging the Hypertext Transfer Protocol (HTTP) session.

See also
name lookup

reverse proxy

A service or server that offloads Web publishing responsibilities from Web servers and allows you to securely connect a company’s internal Web servers to the Internet or to the rest of the company intranet. In reverse proxying, a proxy server is used to impersonate a Web server to the outside world. The proxy server receives client requests for Web content and fulfills these requests from its cache. It forwards client requests to the actual Web server only if it cannot serve the requests from its own cache.

Microsoft Proxy Server supports reverse proxying so that you can publish to the Internet without compromising your internal network’s security. Proxy Server uses reverse proxying to send client requests downstream to a Web server or group of Web servers that are located behind the proxy server. This configuration results in improved Web server capacity planning, protects the security of data while allowing access to the Internet, and allows Web servers to access other servers on the internal network for publishing purposes.

rexec

A TCP/IP utility that enables clients to run commands directly on remote hosts. The remote host must be running the rexec service or daemon for the execution to work. Rexec authenticates the username on the remote host before executing the command and prompts the client to enter a password. Rexec is one of the r-commands available on all UNIX systems.

NOTE

Microsoft’s implementation of TCP/IP on Windows NT and Windows 2000 includes rexec client software but no rexec service. Rexec provides functionality similar to that of rsh, except rexec uses clear-text password authentication.

TIP

You cannot use rexec to run interactive commands such as vi or emacs. Instead, use Telnet to run interactive commands on a remote host. Note also that rexec forwards the user’s password as clear text, which can pose a security risk in some environments.

RFC

See
Request for Comments (RFC)

RG

Stands for Radio Guide, a U.S. Army specification for grades of transmission lines. RG specifications refer to forms of coaxial cable used in networking, as in the following examples:

  • RG-8:
    Also known as N series cable, which is a coaxial cable with an impedance of 52 ohms. RG-8 looks like thicknet Ethernet cabling but is actually a lower grade and does not perform as well. True thicknet cabling is labeled as IEEE 802.3 cabling, has a diameter of 3/8 inches, and is yellow or orange.

  • RG-58:
    Often called thinnet, which is a form of coaxial cabling with an impedance of 50 ohms and a diameter of 3/16 inches used in 10Base2 Ethernet networking. Subdesignations of this standard include RG-58 /U, which has a solid copper core, and RG-58 A/U, which has a stranded copper core.

  • RG-59:
    Another name for CATV or cable television cabling, which is a form of coaxial cabling with an impedance of 75 ohms.

  • RG-62:
    A form of coaxial cabling with an impedance of 93 ohms that is used in ARCNET networks.

rights

Also known as system rights, the system tasks that a user can perform on a Microsoft Windows NT workstation, on a server running Windows 2000 or Windows NT, or on a domain. These tasks include changing a server’s clock, rebooting the machine, logging on to the local console, and performing a backup. A system administrator can view and modify Windows NT rights by using the Policies menu in User Manager for Domains. Windows NT built-in groups have predefined sets of rights assigned to them. The following table lists the basic Windows NT rights and the users and groups that have them by default.

Windows NT Rights
Right | Users and Groups Who Have the Right by Default
Access this computer from the network | Administrators Everyone
Add workstations to the domain | Administrators
Back up files and directories | Administrators Backup Operators Server Operators
Change the system time | Administrators Server Operators
Force shutdown from a remote system | Administrators Server Operators
Load and unload device drivers | Administrators
Log on locally | Administrators Account Operators Backup Operators Print Operators Server Operators
Manage the auditing and security log | Administrators
Restore files and directories | Administrators Backup Operators Server Operators
Shut down the system | Administrators Account Operators Backup Operators Print Operators Server Operators
Take ownership of files and other objects | Administrators
NOTE

In Microsoft Exchange Server, rights are individual permissions that can be assigned to users and groups to control their level of access to objects in the Exchange directory hierarchy.

See also
Exchange permissions, permissions

ring topology

A networking topology in which network stations are connected along a single path whose ends are joined to form a circle. The circle might be logical only; the physical arrangement of the cabling might be starlike, with a hub or concentrator at the center. A ring network is based on a ring topology.

The ring topology is commonly used in the following kinds of networks:

  • Token ring networks:
    The ring of a token ring network is concentrated inside a device called a Multistation Access Unit (MAU).

  • Fiber Distributed Data Interface (FDDI) networks:
    The ring in this case is both a physical and logical ring and usually runs around a campus or collection of buildings to form a high-speed backbone network.

Graphic R-7. Ring topology.
Graphic R-7. Ring topology.
See also
bus topology, mesh topology, star bus topology, star topology

RIP

See
Routing Information Protocol (RIP)

RIPE

See
American Registry for Internet Numbers (ARIN)

RJ connectors

A family of push-and-click connectors for twisted-pair wiring in telephone and network wiring. RJ stands for Registered Jack. RJ types define both a jack or receptacle (female) and a plug (male) type of connector. The most common types of RJ connectors are as follows:

  • RJ-11 connector:
    A 4-wire or 6-wire telephone-type connector that connects telephones to wall plates. RJ-11 supports up to six wires, but usually only four are used with the two-pair twisted-pair cabling commonly found in telephone cabling.

  • RJ-45 connector:
    An 8-wire telephone-type connector used with twisted-pair cabling for connecting computers, wall plates, patch panels, and other networking components. RJ-45 is the standard type of connector for both unshielded twisted-pair (UTP) and shielded twisted-pair (STP) cabling in star-topology Ethernet networks such as 10BaseT and 100BaseT4. RJ-45 is defined in International Organization for Standardization (ISO) standard 8877.

  • RJ-48 connector:
    An 8-wire telephone-type connector used with twisted-pair cabling for connecting T1 and 56-KB digital data service (DDS) lines. RJ-48 uses the same jack as RJ-45 but uses a different pinning, with one pair of wires to transmit signals, one pair to receive signals, one pair for drain, and one unused pair (reserved for future use). RJ-48 connectors come in three varieties: RJ-48C and RJ-48X for connecting T1 lines, and RJ-48S for connecting 56-KB DDS lines.

NOTE

The diagram shows RJ-11 and RJ-45/48 connectors, which are used to terminate both ends of UTP cabling. Pins are labeled 1 through 4 or 1 through 6 for 4-wire and 6-wire RJ-11, and 1 through 8 for 8-wire (four-pair) RJ-45/48. Cables can be straight-pinned or cross-pinned, depending on their use. For example, a straight-pinned RJ-45-terminated UTP cable is used to connect a computer to a 10BaseT hub, while a cross-pinned cable or crossover cable is used to connect two computers directly or to connect two hubs.

Graphic R-8. RJ connectors.
Graphic R-8. RJ connectors.

The following table shows the pinning for these various cables, with the colored wires coded as follows:

  • Y = yellow

  • G = green

  • R = red

  • W = white

  • S = silver

  • OR = orange

  • BL = blue

  • BK = black

  • BN = brown

If these colors are combined in striped cables, the coloring is coded OR/W for orange/white or orange with white striping, and so on. RJ-11 and RJ-45 cables generally use solid-color wires, while RJ-48 cables are usually striped. Note that RJ-45 has two types of cross-pinning: 568A/B and USOC. If the pinning of a wire is listed as Y (1–4), it means that the yellow wire is connected to pin 1 at one end and to pin 4 at the other.

Types of Cable Pinning
Connector/Cable | Pinning
RJ-11 straight (4-wire) | Y (1-1), G (2-2), R (3-3), BL (4-4)
RJ-11 crossed (4-wire) | Y (1-4), G (2-3), R (3-2), BL (4-1)
RJ-11 straight (6-wire) | BL (1-1), Y (2-2), G (3-3), R (4-4), BK (5-5), W (6-6)
RJ-11 crossed (6-wire) | BL (1-6), Y (2-5), G (3-4), R (4-3), BK (5-2), W (6-1)
RJ-45 straight (8-wire) | BL (1-1), OR (2-2), BK (3-3), R (4-4), G (5-5), Y (6-6), BN (7-7), S (8-8)
RJ-45 USOC crossed (8-wire) | BL (1-8), OR (2-7), BK (3-6), R (4-5), G (5-4), Y (6-3), BN (7-2), S (8-1)
RJ-45 568A/B crossed (8-wire) | BL (1-3), OR (2-6), BK (3-1), R (4-5), G (5-4), Y (6-2), BN (7-8), S (8-7)
RJ-48C straight (8-wire) | OR/W (1-1), W/OR (2-2), (3-3) unused, BL/W (4-4), W/BL (5-5), (6-6) unused, BL drain (7-7), OR drain (8-8)
RJ-48C crossed (8-wire) | OR/W (1-4), W/OR (2-5), (3-3) unused, BL/W (4-1), W/BL (5-2), (6-6) unused, BL drain (7-7), OR drain (8-8)

RMON

See
Remote Network Monitoring (RMON)

RMON2

See
Remote Network Monitoring (RMON)

roaming user profile

A Microsoft Windows NT or Windows 2000 user profile that is stored on a network server so that the user can access personal desktop settings from any machine on the network. Roaming user profiles are generally created for users by the system administrator. A roaming profile that cannot be modified by the user is called a mandatory user profile. If the server on which the profile is stored is unavailable when the user logs on to the network, the locally cached copy of the profile stored on his or her workstation will be used instead.

How It Works

There is no default location for roaming profiles on a Windows NT–based or Windows 2000–based network. They can be stored either on domain controllers or on member servers. To create a network share for users’ roaming profiles, create and share a folder called Profiles on one of the servers. Then proceed as follows:

  • In Windows NT, open User Manager for Domains, open the property sheet for the user, and click the Profiles button. Then specify the profile path as follows: \\SERVER_NAME\Profiles\%username%. This creates a subfolder within the Profiles share with the name of the user and for which the user has full control permission. When the user logs on to and logs off of a workstation for the first time, the user’s local profile is copied to his or her personal profile folder.

  • In Windows 2000, open Active Directory Users and Computers, open the property sheet for the user, and select the Profile tab. Then follow the procedure described for Windows NT.

NOTE

Windows 95 and Windows 98 also support roaming user profiles, but Windows NT user profiles are not compatible with Windows 95 and Windows 98 user profiles. If a user has a Windows NT roaming profile configured, that user’s desktop settings are available from computers running Windows NT Workstation but not from machines running Windows 95 and Windows 98.

See also
local user profile, mandatory user profile, user profile

roles

In Microsoft Exchange Server, groups of Exchange rights that can be assigned to users and groups to control their level of access to objects in the Exchange directory hierarchy. Exchange has a number of predefined roles for assigning common sets of permissions to users and groups, as shown in the following table.

Exchange Rights
Right | Role
 | Admin | Permissions Admin | Service Account Admin | View Only Admin | User | Send As | Search
Add child | x | x | x |  |  |  |
Modify user attributes | x | x | x |  | x |  | x
Modify admin attributes | x | x | x |  |  |  |
Delete | x | x | x |  |  |  |
Logon | x | x | x | x |  |  |
Modify permission |  | x | x |  |  |  |
Replication |  |  | x |  |  |  |
Mailbox owner |  |  | x |  | x |  |
Send as |  |  | x |  | x | x |
Search |  |  |  |  |  |  | x

Administrators can also create custom roles to grant special types of access to the directory.

See also
Exchange permissions

root

The base of a hierarchical file system. The root directory contains the tree of directories and files that make up the file system. The symbol used to represent this directory depends on whether the file system is on a Microsoft Windows platform or a UNIX platform. Windows designates the root with a backslash (\), and UNIX uses a forward slash (/). The root directory is the first element in the absolute path of a file or directory on the file system.

NOTE

The term “root” can also refer to the user with the highest level of administrative rights, especially on a UNIX system. Other names for this user are SuperUser (UNIX), Supervisor (NetWare), and Administrator (Windows NT).

The term “root” can also refer to the highest-level entity in a directory system structure. For example, the root of Active Directory in Windows 2000 is the RootDSE object.

root certificate

A digital certificate that attests to the identity of a certificate authority (CA). A root certificate is signed by the CA itself (self-signed) or by a higher authority in a hierarchy of CAs in a public key infrastructure (PKI). Every CA requires a root certificate so that it can be “trusted” by entities that request digital certificates from it. If a client trusts the root certificate of a CA, it automatically trusts any other certificates that are issued by that CA. Root certificates thus form one of the foundations of public key cryptography.

Microsoft Certificate Server, which is included with Microsoft Windows NT Option Pack, and Certificate Services in Windows 2000 can self-sign a root certificate during the installation process or create a certificate request file that can be used to request a certificate from a higher CA.

root domain

A domain in a domain tree of a Microsoft Windows 2000–based network that is the highest-level parent domain in the tree. All other domains in the tree derive their Domain Name System (DNS) name from the root domain and form a contiguous namespace with the root domain. An example of a root domain name for a company called Expedia might be expedia.com. The root domain is the first domain you create when you implement Active Directory in an enterprise. All other domains you create derive their DNS name from the root domain.

TIP

You should select a root domain name before you implement Active Directory on your Windows 2000–based network. The name should be easily recognized by users in the outside world, and you should make sure that it is legally acceptable and does not violate existing trademarks or duplicate registered company names. Root domain names should be static and not subject to change.

If you plan to connect your network directly to the Internet, you should register your root domain name with the Internet Network Information Center (InterNIC) or some other domain name registration authority. You can use separate external and internal root domain names in your enterprise network if you want to separate network resources that will be accessible to outside users on the Internet from those intended for internal company use only. You should register both the internal and external root domain names to prevent future naming conflicts. You should also use a firewall to protect the private domain from the Internet.

Graphic R-9. Root domain.
Graphic R-9. Root domain.
See also
Active Directory, domain tree

RootDSE

The object that resides at the top of the directory hierarchy in Active Directory in Microsoft Windows 2000. RootDSE is the root of the logical namespace for Active Directory and is the top of the search tree for accessing Active Directory using the Lightweight Directory Access Protocol (LDAP). The RootDSE object is specified in Request for Comments (RFC) 1777.

How It Works

The RootDSE object is located in the Directory System Agent (DSA) within the directory service module ntdsa.dll, which is part of the security subsystem in Windows 2000. The RootDSE object is a container object and has a Configuration container that is used to store configuration information for the enterprise network. The Configuration container contains the various naming contexts for Active Directory. (A naming context is a contiguous subtree of Active Directory and forms a unit of information for replication purposes.) These naming contexts include the following:

  • Partitions naming context:
    Identifies the partitions of the enterprise network

  • Schema naming context:
    Contains all types of classes and attributes for objects stored in Active Directory

  • Services naming context:
    Acts as a central storage place for network-wide configuration information

  • Sites naming context:
    Stores information about the sites, domain controllers, and replication topologies used throughout the enterprise

TIP

You can view the RootDSE object by using the Active Directory Object Browser. Choose Run from the Start menu, type adsvw to start the Object Browser, and then enter the following LDAP Uniform Resource Locator (URL):

LDAP://RootDSE

routable protocol

Also called a routed protocol, a network protocol that supports routing of packets on an internetwork using their logical network layer (layer 3) addresses. The most commonly used routable network protocols are as follows:

  • The TCP/IP suite used on the Internet

  • Novell’s IPX/SPX (or Microsoft’s equivalent NWLink IPX/SPX-Compatible Transport)

  • The legacy Xerox Network Systems (XNS)

  • Digital’s DECnet

  • Apple Computer’s AppleTalk suite

  • Banyan VINES

  • The Open Systems Interconnection (OSI) suite

Common network protocols that are not routable include the following:

  • NetBEUI

  • Data Link Control (DLC)

route

Generally, a specific path along which packets can be forwarded on an internetwork by a router. Specifically, a TCP/IP utility for viewing and modifying the internal routing table on a computer running Microsoft Windows 2000, Windows NT, Windows 98, or Windows 95. This internal routing table contains routing information that determines how the computer delivers packets to local and remote hosts on the network. If a multihomed server running Windows 2000 or Windows NT is used, you can use the route command to configure the routing table for static routing. (In Windows 2000, you can also use Routing and Remote Access to configure static routing.)

Example

Typing route print at the command prompt displays the routing table of the local computer. Typing route add 172.16.25.0 mask 255.255.255.0 172.16.10.1 metric 2 adds a new route to the routing table, specifies that any packets destined for the network with network ID 172.16.25.0 should be forwarded to the router interface 172.16.10.1 in the local network, and specifies that packets sent along this route will traverse two hops on the network.

router

A networking device that is used to extend or segment networks by forwarding packets from one logical network to another. Routers are most often used in large internetworks that use the TCP/IP protocol suite and for connecting TCP/IP hosts and local area networks (LANs) to the Internet using dedicated leased lines.

How It Works

Routers work at the network layer (layer 3) of the Open Systems Interconnection (OSI) reference model for networking to move packets between networks using their logical addresses (which, in the case of TCP/IP, are the IP addresses of destination hosts on the network). Because routers operate at a higher OSI level than bridges do, they have better packet-routing and filtering capabilities and greater processing power, which results in routers costing more than bridges.

Routers contain internal tables of information called routing tables that keep track of all known network addresses and possible paths throughout the internetwork, along with the cost of reaching each network. Routers route packets based on the available paths and their costs, thus taking advantage of redundant paths that can exist in a mesh topology network. Because routers use destination network addresses of packets, they work only if the configured network protocol is a routable protocol such as TCP/IP or IPX/SPX. This is different from bridges, which are protocol independent.

Graphic R-10. Typical uses for routers.
Graphic R-10. Typical uses for routers.

Routers are classified as one of the following:

  • Static routers:
    These must have their routing tables configured manually with all network addresses and paths in the internetwork.

  • Dynamic routers:
    These automatically create their routing tables by listening to network traffic. (The first route must be configured manually, however.)

Routers are used to segment large networks and join LANs to wide area networks (WANs), and they form the basis of the public packet-switched TCP/IP network known as the Internet. Routers can be so complex that Cisco Systems, the major vendor of enterprise-level routers, has an operating system for routers called Internetwork Operating System (IOS) that is devoted solely to managing routers.

NOTE

Routers generally block broadcast traffic and can thus prevent broadcast storms from slowing down the flow of traffic in a network. Routers can also be used to join dissimilar media such as unshielded twisted-pair (UTP) cabling and fiber-optic cabling, and different network architectures such as Token Ring and Ethernet.

TIP

Routers often provide basic firewall functions by filtering out packets based on their source or destination network address. Such a device is known as a packet-filtering router.

TIP

To use a router to connect a LAN to the Internet over a high-speed T1 line, connect a router to the main hub or switch in the LAN, and then connect the serial port on the router to a Channel Service Unit/Data Service Unit (CSU/DSU), which connects to a dedicated T1 line. Your telco will provide Internet access through the T1 line.

Routers are similar to bridges in that they both forward packets and can be used to either segment or join networks. However, routers also use network layer (layer 3) addresses such as IP addresses to forward packets, while bridges use layer 2 (or MAC) addresses. When should you use a bridge and when should you use a router? You should use bridges to connect network segments that run the same network protocol—for example, to connect an Internet Protocol (IP) segment to an IP segment. You must also use bridges when you run nonroutable network protocols such as NetBEUI on your network. On the other hand, you should use routers to connect network segments that run different network protocols—for example, to connect an IP segment to an Internetwork Packet Exchange (IPX) segment. And generally speaking, routers are more intelligent than bridges and improve network bandwidth by not forwarding broadcast packets to other networks. Finally, when you use TCP/IP to connect to the Internet, use routers unless you absolutely need to use a bridge.

See also
routing

routing

The process of selecting a path through an internetwork over which to transmit packets to a destination host or hosts and then having devices called routers forward the packets to those hosts. For routing to occur, a routable protocol such as TCP/IP or IPX/SPX must be used.

How It Works

Routing takes place at the network layer (layer 3) of the Open Systems Interconnection (OSI) reference model. On a TCP/IP internetwork, this means that routing involves delivering packets to destination IP addresses on the internetwork.

The first and main part of the routing process consists of determining the path over which packets will travel from the sending, or original, host to the receiving, or destination, host. The second part of the process involves having routers switch packets from one successive segment, or “hop,” of the path to the next until the packets arrive at their destination.

Routers are devices that join subnets, which are separate and distinct networks that make up an internetwork. The routers maintain internal tables called routing tables, which contain information describing the potential paths that data can take to travel through the internetwork. Between any two subnets on the internetwork, there can be more than one path or route by which packets can travel. The routing information stored in the routing tables describes the metric or cost value for each possible route between different subnets. When packets need to be sent to a host or hosts on another network, they are forwarded to a router that is connected to the local network, which then checks its routing tables to determine which path the packets should take. Packets are usually sent along the path with the lowest cost value or metric. If two paths to the same destination have the same metric, packets can be load-balanced between the two routes.

The value of the metric for a specific path depends on several factors. For example, the metric might be proportional to the number of routers that the packet stream must be switched through (the number of hops traversed) in order to reach the end of the path. The metric might also depend on other factors such as the delay or latency of packets when they are processed by each router, the amount of traffic congestion (load) at the router, available bandwidth, and the relative reliability of the routers. Network administrators can manually specify metrics for each path and enter them into routing tables by using static routers, or they can use dynamic routers, which use a routing algorithm to automatically calculate metrics for each possible path. Dynamic routers automatically calculate metrics by communicating with each other using special protocols called routing protocols. Examples of routing protocols include Routing Information Protocol (RIP) and Open Shortest Path First (OSPF) Protocol.

Once the routing table of a router has been configured (or once the tables of all dynamic routers have “converged” and stabilized), the router carries out its switching function. This switching function is essentially independent of the particular routing protocol being used. It works like this: If a host on the local network needs to send a packet to a host on a remote network, it checks its own internal routing table to determine which router to contact and then uses Address Resolution Protocol (ARP) to obtain the MAC address of the local router interface that connects the local network to the remote network. The host then sends the packet directly to the local router interface. The network layer header of the packet contains the logical network address (the IP address on a TCP/IP internetwork) of the destination host that the packet needs to be delivered to. The router receives the packet, inspects the network-layer destination address in the packet’s header, and compares the address to the route information stored in the router’s internal routing table in order to determine what to do with the packet. If the router cannot determine what to do with the packet, it simply drops the packet. Otherwise, it forwards the packet to another router, which forwards it again until the packet finally reaches its destination network. As the packet is switched from router to router, its network layer destination address remains the same, but its MAC address keeps changing to that of the next router interface along the path.

NOTE

Although routing is normally considered the exclusive job of routers, routing actually occurs in two places on a network such as a TCP/IP internetwork:

  • At the host itself (host routing). Each host on the internetwork normally maintains its own internal routing table. This table is used to determine whether to send a packet to the local network, to a specific router interface, or to the default gateway address.

  • At the routers that connect the various subnets (router routing).

Routing in a network can suffer from a number of problems. One problem is the existence of routing loops, which occur when a packet passes through the same router more than once on a given trip. The result is that the packet loops until its lifetime decreases to zero and a router discards it. The originating host usually never knows that the packet was dropped and did not reach its destination. Routing loops occur most often in networks that use incorrectly configured static routers. Routing algorithms for dynamic routers can usually detect loops and reconfigure routing tables to eliminate them.

Another problem is convergence. In a large internetwork using dynamic routers, it might take some time for a change in one router’s tables to propagate to all other routers in the internetwork. In the meantime, temporary routing loops can occur and less efficient network paths might be chosen, resulting in more traffic congestion.

TIP

To view the internal routing table of a computer running Microsoft Windows 2000 or Windows NT, type route print at the command prompt.

See also
router

routing algorithm

A mathematical procedure that a dynamic router uses to calculate entries for its routing table.

How It Works

Routing algorithms are implemented as software running within the internal CPU of a router. They are implemented as a routing protocol because they involve procedures and protocols that allow routers to exchange information with one another in order to calculate the metrics of various paths or routes through an internetwork. Routing algorithms base their work off the values contained in a combination of variables. These values can be determined dynamically by inspecting header information in packets directed toward the router, or they can be manually specified by network administrators. The routing algorithm then processes the values of these variables to generate the internal routing table for the router. The variables are generally known as routing metrics and can include the following:

  • Hops:
    The number of intermediate routers between a given network and the local router

  • Latency:
    The time delay in processing a packet through the router or over a given route

  • Congestion:
    The length of the packet queue at the incoming port of the router

  • Load:
    The processor use at the router or the number of packets per second that it is currently processing

  • Bandwidth:
    The available capacity of a route to support network traffic; decreases as network traffic increases

  • Reliability:
    The relative amount of downtime that a particular router might experience because of malfunctions

  • Maximum Transmission Unit (MTU):
    The largest packet size that the router can forward without needing to fragment the packet

Routing algorithms are usually implemented as a combination of dynamic (real-time calculated) and static (specified by the network administrator) factors. Algorithms are usually implemented in a distributed fashion, with each router independently calculating its own routing tables, and in the case of dynamic routers, exchanging routing information with each other as well. This provides a degree of fault tolerance for the routing network: If one router goes down, all other routers can reconfigure their routing tables to route traffic around the failed router. When the failed router is restored, the routing tables are recalculated. Some routing algorithms support forwarding packets over several paths to a given destination (when such multiple paths exist). They can thus better manage network traffic by load balancing packets accordingly.

One major distinction between routing algorithms involves the space within which they operate. In a flat routing space, all routers are peers, while in a hierarchical routing space, different routing domains, areas, or autonomous systems are connected using a backbone routing network. The advantage of a hierarchical routing space is that it reduces the amount of intercommunication traffic that must take place between routers in order for them to calculate their routing tables. For example, routers that forward traffic only within their own routing table do not need to exchange routing information with routers in other domains. The downside, of course, is that a hierarchical system is much more difficult to implement and maintain than a flat routing space.

From a mathematical point of view, routing algorithms come in two common types: link state routing algorithms and distance vector routing algorithms. A link state routing algorithm is a hierarchical routing space algorithm that forms the basis of the Open Shortest Path First (OSPF) Protocol, while a distance vector routing algorithm is a flat routing space algorithm that forms the basis of the Routing Information Protocol (RIP). From a network administrator’s perspective, the differences between these algorithms are as follows:

  • A routing protocol based on the distance vector routing algorithm is simpler to implement than one based on the link state routing algorithm. Link state algorithms require more processing power, and routers that implement it are generally more costly.

  • Routing loops are less likely to occur when the link state algorithm is used.

  • The two algorithms offer a trade-off with respect to network traffic between routers. Specifically, routers using the distance vector algorithm periodically send their entire routing table to other routers, but only to routers one hop away, while the link state algorithm floods the entire internetwork with information from each router, but only updated information is sent when needed.

See also
routing, routing protocol

Routing and Remote Access

An integrated component of Microsoft Windows 2000 that provides both remote access and routing capabilities. Routing and Remote Access supports both dial-up and virtual private network (VPN) remote access clients, and supports routing of Internet Protocol (IP), Internetwork Packet Exchange (IPX), and AppleTalk. Using this component, a server running Windows 2000 Server can function as a Remote Access Service (RAS) server, a VPN server, or even a branch-office router. Routing and Remote Access is also the name of the Microsoft Management Console (MMC) snap-in that is used to manage these services in Windows 2000.

How It Works

The Routing and Remote Access snap-in is used to configure the server side of remote access on servers running Windows 2000 and to configure routing on servers running Windows 2000 with multiple local area network (LAN) or wide area network (WAN) interfaces.

When you use the snap-in to install and configure remote access you create a remote access server that provides these two types of connectivity: dial-up networking and virtual private networking.

  • Dial-up remote access is typically used by mobile or home users who need to dial in to corporate networks—for example, to access a corporate intranet, e-mail server, database server, or other network resource. Windows 2000 supports dial-up connections using providers such as analog telephone lines, ISDN, and X.25.

  • VPN connections emulate point-to-point connections by encrypting and encapsulating traffic and securely routing (tunneling) it between the VPN client and VPN server. Windows 2000 supports the Point-to-Point Tunneling Protocol (PPTP) and Layer 2 Tunneling Protocol (L2TP) for creating virtual private networks. VPNs are typically used for mobile users and home users to securely connect to corporate networks over an unsecure connection such as the Internet.

Some of the new remote access features supported by Windows 2000 include the following:

  • Integration of remote access functionality with Active Directory

  • Policy-based administration for more flexible administration of remote access privileges for users and groups

  • A new version of Microsoft Challenge Handshake Authentication Protocol (version 2) that strengthens the security of the remote access connection negotiation process

  • Support for the L2TP for creating VPNs

  • The Extensible Authentication Protocol (EAP), which lets you use smart cards and other technologies for remote access authentication

  • The Bandwidth Allocation Protocol (BAP), which increases the efficiency of Multilink PPP (MPPP) connections

Routing and Remote Access in Windows 2000 provides powerful industry-standard routing capabilities that can turn a computer running Windows 2000 Server into a full-featured, enterprise-class router for both LAN and WAN internetworks. A computer running Windows 2000 Server that has the Routing and Remote Access service installed and configured on it is usually referred to as a Windows 2000 router. Supported features include the following:

  • Multiprotocol support for unicast routing that includes IP, IPX, and AppleTalk protocols

  • Standard IP routing protocols, such as the Routing Information Protocol (RIP) versions 1 and 2 and the Open Shortest Path First (OSPF) Protocol

  • Support for routing multicast IP traffic

  • IP network address translation (NAT) functionality for connecting home or small office/home office (SOHO) networks to the Internet

  • Packet-filtering capability for both IP and IPX

  • Demand-dial routing for automatic initiation of dial-up WAN connections

  • VPN functionality using both PPTP and L2TP

  • Support for IP-in-IP tunneling

NOTE

The client side of remote access on Windows 2000 Professional clients is configured using the Network Connection Wizard, which provides a step-by-step method for creating and configuring basic inbound and outbound connections.

Routing and Remote Access Service (RRAS)

An add-on for Microsoft Windows NT Server version 4 with Service Pack 3 or later that provides additional support for TCP/IP internetworking, including the following:

  • Routing Information Protocol (RIP) for Internet Protocol (IP) versions 1 and 2, which allows a multihomed server running Windows NT to be used as a dynamic RIP router for small to medium-sized IP internetworks.

  • Open Shortest Path First (OSPF) Protocol, which allows a multihomed server running Windows NT to be used as a router for large IP internetworks in autonomous systems.

  • IP packet filtering, which allows a multihomed server running Windows NT to be used as a packet-filtering router. Both input and output filters can be configured for each TCP/IP interface and can be configured based on the contents of key header fields in IP, Transmission Control Protocol (TCP), User Datagram Protocol (UDP), and Internet Control Message Protocol (ICMP) packets.

  • ICMP router discovery, which supports automatic discovery of default routers by hosts using ICMP router advertisement messages.

  • Dynamic Host Configuration Protocol (DHCP) relay agent support for enabling DHCP clients and DHCP servers to reside on different networks.

NOTE

Routing and Remote Access Service (RRAS) replaces the existing Remote Access Service (RAS) on Windows NT 4 and fully supports the existing capabilities of RAS. For information on RRAS for Windows 2000, see the entry on Routing and Remote Access elsewhere in this chapter.

Routing Information Protocol (RIP)

A routing protocol that is used to exchange routing information between dynamic routers on Internet Protocol (IP) or Internetwork Packet Exchange (IPX) internetworks. Routing Information Protocol (RIP) was designed in 1980 to be used with the Xerox Network Systems (XNS) protocol suite but is most commonly used today in small to mid-sized TCP/IP internetworks. RIP first became popular as a result of its inclusion in release 4.2 of the Berkeley BSD UNIX platform. It is supported by Microsoft Windows NT Server and Microsoft Windows 2000 Server and has been adapted to the AppleTalk networking system as the Routing Table Maintenance Protocol (RTMP).

How It Works

RIP is based on the distance vector routing algorithm, one of several common routing algorithms that routers use to dynamically calculate the cost or metric of each possible path through an internetwork. RIP has been implemented for both TCP/IP and IPX/SPX internetworks as RIP for IP and RIP for IPX, respectively. RIP is designed for intradomain routing (routing within a flat routing space or routing domain).

Routing tables in RIP-enabled routers are calculated on the basis of the number of hops to the destination network. RIP routers do not use other routing metrics such as load, bandwidth, latency, or Maximum Transmission Unit (MTU) in calculating routing costs. The routing table of a RIP router contains the cost in hops of every path to every destination network in the internetwork.

RIP-enabled routers on a TCP/IP internetwork broadcast their complete routing tables every 30 seconds over User Datagram Protocol (UDP) port 520 using RIP advertisements. You might assume that this adds a lot of overhead to network traffic, but this information is broadcast information and is thus propagated only throughout the local network and received only by routers that have a routing interface to the local network. RIP does not support multipath routing. If a routing table has multiple routes for a single network ID, RIP stores the route with the lowest metric (number of hops to destination).

When a RIP router is first turned on, it announces its presence using a General RIP Request message so that neighboring RIP routers can send it advertisements of their routing tables. These RIP advertisements from neighboring RIP routers allow the router to build its own routing tables. In addition, the new RIP router announces to its neighbors all network IDs of locally attached networks so that they can update their routing tables with this information.

RIP supports a maximum metric of 15; networks that are more than 15 hops away are unreachable using RIP. This limits RIP implementation to small and mid-sized internetworks. RIP metrics are independent of TCP/IP Time to Live (TTL) values, so if two networks are separated by more than 15 routers on a RIP-enabled internetwork, packets sent between them are dropped even if their TTL values have not decremented to zero. If you try to send a packet to a network more than 15 hops away, a RIP router returns an Internet Control Message Protocol (ICMP) Destination Unreachable message.

RIP is a well-supported industry standard routing protocol. Its main disadvantage is that the routing table of a RIP-enabled router can be quite large because it contains all possible routes to all possible networks. RIP advertisement packets are only 512 bytes in length and can contain a maximum of 25 different routing table entries, so a large routing table with hundreds of entries means that dozens of RIP packets are broadcast every 30 seconds. This can result in a lot of extra broadcast traffic on the local subnet. RIP is therefore not suitable for large internetworks or for networks with many slow wide area network (WAN) links. RIP announcements are not synchronized over the internetwork and are sent without expectation of acknowledgments. This can lead to convergence problems and routing loops.

In addition, routing entries in a RIP routing table time out 3 minutes after the last RIP announcement is received, so if a RIP router goes down, it takes time for this information to propagate throughout the internetwork, a problem known as slow convergence. This 3-minute timeout value exists so that information about routers that unexpectedly fail or go down can be propagated throughout the internetwork. If neighboring routers do not hear from a RIP router within 3 minutes, networks that are locally attached to the missing router are assigned a hop count of 16, making them unreachable.

NOTE

Microsoft Windows NT supports RIP for both TCP/IP (RIP for IP) and NWLink IPX/SPX-Compatible Transport (RIP for IPX). There are two versions of RIP:

  • RIP version 1:
    Defined in Request for Comments (RFC) 1058.

  • RIP version 2:
    Defined in RFC 1723. RIP version 2 extends RIP by supporting full backward compatibility with RIP version 1. It allows optional multicasting of routing table information to the multicast address of 224.0.0.9, the inclusion of subnet mask values in RIP announcements, and simple password protection to prevent rogue RIP routers from hijacking network traffic.

A RIP-enabled router that can receive RIP broadcasts but cannot send them is called a Silent RIP Router.

TIP

Another disadvantage of RIP is that it cannot take into account real-time network parameters such as congestion, latency, or router load when the RIP router determines whether to forward a packet along a specific route. Use the Open Shortest Path First (OSPF) Protocol if you want to dynamically take into account such real-time network parameters, but be aware that implementing OSPF is fairly complex and might require you to upgrade your existing routers.

If your RIP-enabled internetwork includes slower WAN links as well as fast local area network (LAN) links between networks, you can assign the WAN links hop values that are greater than 1 to compensate for their slower speed. For example, you can assign a T1 link between two networks a hop count of 3 or 4. However, the total hop count between any two networks must still be less than or equal to 15, and such a configuration makes sense only if the topology of the network is a complex mesh involving both fast LAN and slow WAN links.

RIP routers should be turned off properly so that they can advertise the fact that they are being turned off to their neighboring routers. This notification, called a triggered update, declares all locally attached networks to the router as having a hop count of 16, making them unreachable. These triggered changes then propagate throughout the internetwork.

See also
routing, routing algorithm

routing interface

In general, the port at which a router connects to a given network. For a given network, the port on the router that is directly connected to the network is called a local router interface, while any port on the router that is connected to a different network is called a remote router interface. Each interface of a router has a unique MAC address, just like a network interface card (NIC) in a computer.

In the Routing and Remote Access Service (RRAS) of Microsoft Windows 2000, a router interface is a physical or logical interface over which packets are forwarded. These packets can be unicast packets of Internet Protocol (IP), Internetwork Packet Exchange (IPX), or AppleTalk, or multicast packets of IP. Routing interfaces in Windows 2000 RRAS can be

  • Physical local area network (LAN) interfaces such as Ethernet or Token Ring connections. Some wide area network (WAN) interfaces such as frame relay adapters are logically represented by RRAS as LAN interfaces.

  • Demand-dial interfaces that represent logical connections such as dial-up modem or dedicated virtual private network (VPN) point-to-point connections. These can be either on-demand or persistent connections.

  • IP-in-IP tunnel interfaces, which represent a tunneled point-to-point connection.

NOTE

If only one router is connected to a network, the local router interface is the default gateway for all hosts on that network. Windows 2000 and Windows NT support configuring additional gateways by using the Advanced button on the TCP/IP property sheet.

routing metric

A variable or factor that a dynamic router can use to calculate its routing table to determine which path or route the router should use to forward a packet.

How It Works

Routing metrics enable routers to make intelligent decisions about how to forward packets to ensure that

  • Packets are delivered efficiently and quickly

  • Congestion does not occur over links between networks

  • Packets are not lost by being dropped by overloaded or dead routers

The simplest metric used by routers to calculate routing table entries is the number of hops to a given destination network. For example, this metric is used by the Routing Information Protocol (RIP), which allows dynamic routers to communicate with each other to share routing information and synchronize the entries of their routing tables. If you need more control over the paths that packets take, you can use protocols such as Open Shortest Path First (OSPF) Protocol and Interior Gateway Protocol (IGP), which can use a number of other metrics, including real-time metrics that routers determine dynamically, such as the following:

  • Load:
    Generally, the number of packets being processed per second by the router or its CPU utilization. If the load on a router becomes high, the router can advise other routers to recalculate routing tables in order to divert traffic around it.

  • Latency:
    The time interval needed to route a packet through the router or over a specific path through the internetwork. Latency can be increased by delays due to such factors as port congestion on the router, heavy router load, bandwidth utilization of links between networks, and physical distance between networks.

Other routing metrics are manually entered into the router configuration by network administrators who have a knowledge of the physical layout and performance of the network. Such metrics can include the following:

  • Bandwidth:
    The total capacity of each network link to carry traffic between different networks in the internetwork.

  • Reliability:
    The relative amount of anticipated downtime for a given link between two networks.

  • Cost:
    A parameter roughly proportional to the actual cost in dollars of using each network link. Some wide area network (WAN) links might have more latency but cost much less.

  • Maximum Transmission Unit (MTU):
    The largest size of packet that the router can forward without segmenting the packet into subpackets. Segmentation of network traffic by routers adds additional latency to network communication.

See also
routing

routing protocol

A protocol that enables the exchange of routing tables between routers in an internetwork. Routing protocols are the software implementation of specific routing algorithms, which are mathematical procedures for determining the cost of various paths or routes through an internetwork so that traffic can be routed most efficiently.

Routing protocols are generally implemented in medium to large-sized TCP/IP internetworks to simplify the administration of routing tables. Common routing protocols include the following:

  • Routing Information Protocol (RIP):
    Based on the distance vector routing algorithm and used in small to medium-sized internetworks. RIP is an intradomain routing protocol that can function only within a given routing domain. Microsoft Windows NT Server and Microsoft Windows 2000 Server support RIP; a multihomed machine running Windows NT or Windows 2000 can be used as a RIP router.

  • Interior Gateway Protocol (IGP):
    Based on the distance vector routing algorithm and used in medium-sized to large-sized internetworks. IGP is an intradomain routing protocol that can function only within a given routing domain. IGP uses a number of metrics to determine routing cost, including load, bandwidth, latency, reliability, and Maximum Transmission Unit (MTU). The router determines some of these factors dynamically as it inspects incoming traffic, while others are specified by the network administrator. IGP supports multipath routing for load balancing and fault tolerance.

  • Open Shortest Path First (OSPF) Protocol:
    Based on the link state routing algorithm and used in medium-sized to large-sized internetworks. OSPF is an intradomain routing protocol that can function only within a given routing domain. OSPF is also a hierarchical routing protocol that can be used within a single autonomous system. OSPF evolved from the earlier Open Systems Interconnection (OSI) reference model routing protocol called intermediate-system-to-intermediate-system (IS–IS). OSPF supports multipath routing and uses one or more routing metrics, including bandwidth, reliability, load, latency, and MTU. If OSPF uses more than one metric, it also supports type-of-service (TOS) requests for differentiating traffic.

  • Exterior Gateway Protocol (EGP):
    An interdomain routing protocol for routing between different routing domains that are connected by a routing backbone such as the Internet. EGP was specifically designed in 1984 as the protocol for communication between the core or backbone routers of the Internet. EGP does not use routing metrics—it simply keeps track of which networks are currently reachable through a given router.

  • Border Gateway Protocol (BGP):
    Another interdomain routing protocol created specifically to enable the core or backbone routers of the Internet to communicate with each other. BGP is superior to EGP because it can detect routing loops and use routing metrics.

  • NetWare Link Services Protocol (NLSP):
    Used in Novell NetWare 4.x as part of its Multi-Protocol Router (MPR). NLSP is based on a combination of OSPF routing and Novell’s Service Advertising Protocol (SAP) functions and is also based on the link state routing algorithm.

  • Routing Table Maintenance Protocol (RTMP):
    Used in AppleTalk networks and based on the distance vector routing algorithm. RTMP is derived from RIP.

NOTE

Dynamic routers talk to each other using routing protocols and are essentially self-configuring (except for the first one installed in an internetwork). Static routers do not talk to each other and must be configured independently.

TIP

Remember that a routing protocol is different from a routable protocol. A routing protocol is used by routers to communicate with each other. A routable protocol, on the other hand, is a network protocol such as TCP/IP or IPX/SPX that can be routed between networks within an internetwork.

See also
routing, routing algorithm

routing table

An internal table that a computer or router uses to determine which router interface to send packets to, based on their destination network addresses. Microsoft Windows platforms automatically build their own routing tables, which are used to determine whether to forward specific packets to

  • The local network segment

  • A near-side router interface

  • The default gateway for the segment

To view the internal TCP/IP routing table on a computer running Windows 2000, Windows NT, Windows 98, or Windows 95, type route print at the command prompt.

A typical routing table looks like the following:

Active Routes:
Network Address   Netmask     Gateway Address     Interface  Metric
127.0.0.0       255.0.0.0        127.0.0.1        127.0.0.1    1
172.16.8.0      255.255.255.0    172.16.8.50      172.16.8.50  1
172.16.8.50     255.255.255.255  127.0.0.1        127.0.0.1    1
172.16.255.255  255.255.255.255  172.16.8.50      172.16.8.50  1
224.0.0.0       224.0.0.0        172.16.8.50      172.16.8.50  1
255.255.255.255 255.255.255.255  172.16.8.50      172.16.8.50  1

This computer has a single network interface card (NIC) with the address 172.16.8.50. The columns of this table are as follows:

  • Network Address:
    A destination network address on the network

  • Netmask:
    The portion of the network address that must match in order for that route to be used

  • Gateway Address:
    Where the packet needs to be forwarded (a local NIC or a local router interface)

  • Interface:
    The address of the NIC through which the packet should be sent

  • Metric:
    The number of hops to the destination network

NOTE

In Microsoft Exchange Server, the routing table is the internal table that defines how messages can be routed to other sites in the Exchange organization and to foreign mail systems through installed connectors and gateways. This routing table is generally known as the Gateway Address Routing Table (GWART).

RPC

See
remote procedure call (RPC)

RPC Ping

A client/server utility included with Microsoft Exchange Server for testing for remote procedure call (RPC) connectivity between two locations on a network. The server portion of RPC Ping runs on an Exchange server and responds to requests from the RPC Ping client. RPC connectivity is essential between all Exchange servers in the same site.

TIP

If an RPC-based mail client such as Microsoft Outlook cannot connect to an Exchange server in its site, perform the following tests:

  1. Check network connectivity between the client and the server to try to map a network drive to a shared folder on the server by typing the Net Use command at the command prompt on the client. If this fails, you might have a hardware failure such as a failed network interface card (NIC), a loose cable, or a configuration problem with your networking protocol (such as an erroneous IP address).

  2. If network connectivity is successful, you might have a problem with the RPC binding order on the client. Try modifying this binding order in the registry.

  3. If the client still cannot connect to the server, run the server-side component of RPC Ping on the server to test which protocols RPC can bind with and which protocols can be accepted by the client. This server-side component of RPC Ping is called Rpings. Run the client-side component of RPC Ping (Rpingc32 on computers running Windows 2000, Windows NT, Windows 98, and Windows 95) to test RPC connectivity with the Exchange server. If Rpingc32 works for a specific protocol, rearrange the RPC binding order on the client so that this protocol is first.

RRAS

See
Routing and Remote Access Service (RRAS)

RS-232

More properly known as RS-232C, a widely implemented serial transmission interface developed by the Electronic Industries Alliance (EIA) that is used for connecting data terminal equipment (DTE) such as computers or terminals to data communications equipment (DCE) such as modems, packet assembler/disassemblers (PADs), or serial printers. The RS-232 specification uses unbalanced lines to provide full-duplex serial communication using baseband transmission. RS-232 provides a typical data rate of 19.2 Kbps over a maximum distance of 15 meters, but the maximum data transfer rate is 115.2 Kbps. Up to two devices can be connected using RS-232. Devices cannot be daisy-chained together using RS-232. (Use RS-422/423 instead.)

RS-232 specifies the types of wires and connectors, the pinning of the connectors and the function of each wire, the voltage levels and their meanings, and control procedures such as handshaking. RS-232 cables (cables designed to use the RS-232 serial interface specification) are typically 25-wire unshielded twisted-pair (UTP) cables with DB25 type connectors or 9-wire cables with DB9 connectors. The pin assignments are shown in the following table. Note that only pins 1 through 8 and pin 20 are required for most basic RS-232 functions, which means that 9-pin DB9 connectors can be used on RS-232 serial cables for most applications.

Pin Assignments of RS-232
Pin Number | Function
1 | Equipment ground (for protection)
2 | DTE transmit data
3 | DTE receive data
4 | Request-to-send (RTS), controlled by the DTE
5 | Clear-to-send (CTS), controlled by the DCE
6 | Data-set-ready (DSR), controlled by the DTE
7 | Signal ground (common return path)
8 | Carrier-detect (CD)
9 | + Voltage
10 | - Voltage
11 | Not used
12 | Secondary received line signal indicator
13 | Secondary CTS
14 | Secondary DTE transmit data
15 | DCE transmitter signal timing
16 | Secondary DTE receive data
17 | Receiver signal timing
18 | Local loopback
19 | Secondary RTS
20 | Data-terminal-ready (DTR), controlled by the DTE
21 | Signal quality detector
22 | Ring indicator
23 | Data signal rate selector
24 | DTE transmitter signal timing
25 | Test mode
NOTE

In a PC, RS-232 is typically implemented in a universal asynchronous receiver-transmitter (UART) chip, which converts the internal parallel bus signal to a serial bit stream and vice versa, enabling communication between your system bus and serial devices.

RS-232 is compatible with the V.24 and V.28 standards from the International Telecommunication Union (ITU).

TIP

You can use RS-232 with a null modem cable to connect two pieces of DTE (for example, to transfer files). If you are having trouble with an RS-232 connection, be sure that you’re using a regular cable for DTE–DCE communication or a null modem cable for DTE–DTE communication—they look the same but are incompatible.

Although the maximum speed of RS-232 is 115.2 Kbps, older PCs support rates of up to only 56 or 64 Kbps. Newer PCs have a 16550 UART chip that supports serial throughput rates of up to 460.8 Kbps.

See also
FireWire

RS-422

A high-speed full-duplex serial interface that uses balanced lines and has more immunity from noise than the RS-232 interface. (An unbalanced version called RS-423 is less frequently implemented.) RS-422 is used in industrial environments with a lot of electromagnetic interference (EMI) or where more than two serial devices need to be chained together. It is typically used for high-speed synchronous communication between data terminal equipment (DTE) and multiple daisy-chained data communications equipment (DCE).

RS-422 was originally designed to supersede RS-232, but they now coexist. RS-422 typically transmits data at rates of 230 Kbps, but the speed can be increased to around 1 Mbps. The maximum distance for an RS-422 connection is typically 300 meters. RS-422 cables typically have 25 wires and use DB37 or DB9 connectors.

NOTE

Related Electronic Industries Alliance (EIA) standards include the following:

  • RS-449:
    Specifies the pinning for RS-422 when DB37 connectors are used.

  • RS-485:
    Expands RS-422 to include balanced multipoint serial communication using tristate drivers.

  • RS-530:
    Specifies the pinning for RS-422 when DB25 connectors are used. Note that RS-530 cables look like RS-232 cables but are not compatible with them.

RS-422 and RS-423 are compatible with the International Telecommunication Union (ITU) V.11 and V.10 standards, respectively.

RSAC

See
Recreational Software Advisory Council (RSAC)

rsh

A TCP/IP utility that enables clients to run commands directly on remote hosts without having to log on to the remote host. The remote host must be running the rsh service or daemon for this to work. Rexec, another TCP/IP utility that enables clients to run commands directly on remote hosts, does not prompt the client to enter a password upon connecting. Note, however, that rsh users must have their computer name and username configured in the remote host’s .rhosts file in order to use this command. Rsh is one of the UNIX r-commands that are available on all UNIX systems.

NOTE

Microsoft’s implementation of TCP/IP on Windows NT and Windows 2000 contains rsh client software but no rsh service. Rsh provides functionality similar to that of rexec, except rexec uses clear-text password authentication.

TIP

If a user on a computer running Windows NT or Windows 2000 is logged on to a Windows NT or Windows 2000 domain and tries to use rsh to run a command on a remote UNIX server that is running the rsh daemon, the domain controller must be available in order to resolve the username of the user, which is required by the rsh client.

run command box

A command box in Microsoft Windows 2000, Windows NT, Windows 95, and Windows 98, in which you can

  • Type the absolute path of an executable file on the local computer (for example, C:\winnt\.system32\sol.exe) and run the application associated with it

  • Type the name of an executable file on the local computer that is located on the system path (for example, sol.exe) and run the application associated with it

  • Type the absolute path of a volume or folder on the local computer (for example, the path C: or C:\winnt) and open it in a window

  • Type the absolute path of a file on the local computer (for example, C:\winnt\system32\readme.wri) and open it using its associated application

  • Type the UNC path of a network share (for example, \\server9\pub) and open it in a window

  • Type the UNC path of a network application (for example, \\server9\C$\winnt\notepad.exe) and run it locally

    Graphic R-11. Run command box.
    Graphic R-11. Run command box.


S

SA

The System Administrator login ID for administering a computer running Microsoft SQL Server version 6 and configured for standard security. The SA account is the main administrator for the SQL Server environment and can be used to

  • Install new computers running SQL Server

  • Create new devices and databases

  • Configure servers and clients running SQL Server

  • Grant permissions to SQL Server users

  • Monitor disk space, memory, and connections

  • Back up and restore SQL Server databases

  • Move data in and out of SQL Server databases

  • Manage data replication

  • Schedule unattended operations

The SA account can access any application or database on the SQL Server system. If the server running SQL Server is configured for standard security, a password should be assigned to the SA by using the SQL Server Enterprise Manager. There are no restrictions on what the SA can do in SQL Server.

TIP

Anyone who has SA access to a server running SQL Server can also use the xp_cmdshell command to run almost any Microsoft Windows NT or Windows 2000 shell commands and change the configuration of your Windows-based server. So be careful who you grant SA access to.

TIP

In SQL Server 7, user accounts that are members of the Sysadmin fixed server role have the rights and privileges of the SA account. The SA account is provided in SQL Server 7 only for backward compatibility with earlier versions of SQL Server. Although SA can be used as a kind of back door to the system if you’re having problems with other administrator accounts, it should not be used for general-purpose administration of the server running SQL Server.

See also
SQL Security Manager

SACL

See
system access control list (SACL)

safe mode

A mode of starting Microsoft Windows 95, Windows 98, and Windows 2000 that bypasses startup files and runs a basic set of files and drivers including mouse, keyboard, video, mass storage, and basic system services. Safe mode is used for troubleshooting Windows 95, Windows 98, and Windows 2000 when your system fails to boot properly—for example, due to a corrupt device driver or after you make an erroneous change to the registry. Safe mode bypasses the system startup files to allow you to start with a “clean” configuration.

To access safe mode while booting Windows 95 and Windows 98, press the F5 key when the screen shows the message “Starting Windows 95…” or “Starting Windows 98…” You can also start safe mode from the command prompt by typing win /d:m. You can also press F6 to access safe mode with networking support. When you are in safe mode, you are informed of this by text displayed in all four corners of the screen.

To access safe mode while booting Windows 2000, press the F8 key when you see the message “Please select the operating system to start.” You will then be presented with a list of options that includes three safe mode options: standard, networking-enabled, and safe mode with command prompt. Use the arrow keys to navigate the list. Press the Enter key to make your selection.

Graphic S-1. Safe mode.
Graphic S-1. Safe mode.

SAM database

See
Security Account Manager (SAM) database

SAN

See
storage area network (SAN)

SAP

See
Service Advertising Protocol (SAP)

SAS

See
secure attention sequence (SAS)

SATAN

See
Security Administrator Tool for Analyzing Networks (SATAN)

scan

Part of the indexing process used by the Microsoft Indexing Service, an optional component of Microsoft Windows 2000 Server. In Microsoft Windows NT, scanning is made available through Microsoft Index Server. Scanning is the process of inventorying virtual directories on the server that have been configured for indexing to determine whether any new documents have been added that need to be indexed.

How It Works

Scanning can take two forms:

  • Full scans:
    Scan all documents located in the directory

  • Incremental scans:
    Scan only the documents that have been modified since the last scan

If either type of scan finds documents that need to be indexed, the documents are passed to content filters that extract indexing information to form volatile indexes called word lists. This process is called filtering.

Various conditions can trigger a scan of a virtual directory:

  • When a new virtual directory is created and marked for indexing, a full scan is made of the directory.

  • When the NTFS file system determines that a document has been added to a directory marked for indexing, an incremental scan is made of the directory.

  • If documents in a virtual directory are physically located on a non-Windows server such as a NetWare server, Indexing Service periodically polls the server for changes to the contents of the directory; if changes are detected, an incremental scan is triggered.

  • When the system reboots or when the Content Index Service is restarted, incremental scans are initiated for all directories marked to be indexed.

  • You can manually initiate a full scan of a directory by using the Indexing Service snap-in for Microsoft Management Console (MMC).

scandisk

A utility for locating, reporting, and correcting file system errors (such as lost file fragments and cross-linked files) on disks. Scandisk was originally included in version 6.2 of the MS-DOS operating system, but there are also versions for Microsoft Windows 95 and Windows 98. Scandisk is generally preferable to chkdsk because it has better error recovery features and can perform a more exhaustive surface scan if needed.

Two versions of scandisk are included with Windows 95 and Windows 98:

  • Scandisk.exe:
    The real-mode MS-DOS version, which runs at boot time if the computer was not properly shut down. This version is included on the emergency startup disk and can also be used to repair compressed volume files.

  • Scandskw.exe:
    The Windows version, which can repair long filename corruption and can be run in the background by using the /n switch.

TIP

It is a good idea to run scandisk regularly on your system because it is easier to prevent data loss due to hard drive problems than to fix it afterwards. Scandisk creates a log called scandisk.log, which you can view to find out what problems were found and what corrective actions were performed.

SC and ST connectors

Connector types that are generally used for connecting fiber-optic cabling to networking devices. Both are recognized by the Electronic Industries Alliance/Telecommunications Industry Association (EIA/TIA) 568A standard.

SC stands for subscriber connector and is a standard-duplex fiber-optic connector with a square molded plastic body and push-pull locking features. SC connectors are typically used in data communication, CATV, and telephony environments.

ST stands for straight tip, a high-performance fiber-optic connector with round ceramic ferrules and bayonet locking features. ST connectors are more common than SC connectors.

You can generally use SC and ST connectors with either single-mode or multimode fiber-optic cabling. Coupling receptacles for these connectors come in either panel-mount or free-handing designs. For narrow space installations, you can get 90-degree boot versions instead of straight versions. SC and ST connectors come in both simplex and duplex form.

Graphic S-2. SC and ST connectors.
Graphic S-2. SC and ST connectors.
NOTE

A third type of fiber-optic connector is the SMA connector, which has a threaded-nut locking feature. Subtypes include SMA905 and SMA906 connectors.

TIP

The best fiber-optic connectors are military-grade connectors. These connectors satisfy the MIL-C-83522 (ST) specifications and are corrosion-proof; have isolated relief boots to reduce cable strain; and are heat, shock, vibration, fungus, and salt-spray resistant.

See also
fiber-optic cabling

Schedule service

A service in Microsoft Windows NT 4 that allows batch scripts to be scheduled and executed using the at command. The Schedule service provides the security context in which the at command can execute the batch files. If you configure the Schedule service to start up using a particular account as a security context, be sure that account is part of the Backup Operators group because the at command is typically used for scheduling backups.

In Microsoft Windows 2000, the Schedule service has been replaced by the Task Scheduler service.

TIP

You must start the Schedule service before using the at command. You can start the service by using the Services utility in Control Panel or by using the Net Start Schedule command at the command prompt. The Schedule service is dependent on the Workstation and Server services.

schema

A set of rules for Active Directory in Microsoft Windows 2000 that defines which objects can be contained in the directory and what attributes those objects can have. The schema can be considered a formal definition of Active Directory.

Active Directory comes with a default schema that is sufficient in most instances and that defines common network objects in the directory such as users, groups, domains, and computers. You can modify the schema by using the Active Directory Schema, a snap-in for Microsoft Management Console (MMC). The schema is extensible in that new object classes and attribute types can be added to it. Members of the Schema Admins group have the necessary rights for modifying and extending the schema. The built-in Administrator account is included in this group. You can make the following types of modifications to the schema:

  • Create new classes and attributes

  • Modify existing classes and attributes

  • Deactivate existing classes and attributes

NOTE

Key attributes within the Active Directory schema that are prefixed with “System-” cannot be modified. This ensures consistency of the schema.

The schema is actually stored in Active Directory itself in a container under the RootDSE object.

TIP

If you modify the schema, you should wait five minutes for the modifications to be written to the system, whereupon the changes are updated in Active Directory and replicated to all domain controllers. Therefore, if you modify the schema, you should wait until the changes have replicated throughout your entire enterprise before you create new objects that use these modifications.

As a safety measure, domain controllers by default have read-only permissions on the schema. If you want to write changes to the schema, you must first modify a registry setting on the domain controller on which you plan to make modifications. (Make modifications to the schema from only one domain controller at a time.) The Schema Manager MMC snap-in offers a check box that you can use to set or clear the key. To modify the registry manually, you add the parameter Schema Update Allowed with data type REG_DWORD and a nonzero value to the following registry key:

HKEY_LOCAL_MACHINE
     \System
          \CurrentControlSet
               \Services
                    \NTDS
                         \Parameters

scope

See
DHCP scope

SCSI

See
Small Computer System Interface (SCSI)

SDLC

See
Synchronous Data Link Control (SDLC)

SDSL

See
Symmetric Digital Subscriber Line (SDSL)

secondary name server

A name server that downloads its Domain Name System (DNS) database of resource records from a master name server. The master name server can be either a primary name server or another secondary name server. Primary name servers get their resource records from local files called zone files. Secondary name servers do not maintain local zone files—they obtain their resource files over the network from master name servers via a zone transfer, which occurs when a secondary name server polls a master name server and determines that there are updates to the DNS database that need to be downloaded. This means that the DNS administrator has to maintain only a single set of DNS resource records (on the primary name server), which simplifies DNS administration.

Secondary name servers are used in the DNS to provide redundancy and load balancing for name resolution. On BIND implementations of DNS, secondary name servers are often referred to as slave name servers.

NOTE

A name server can be a primary name server for one zone and a secondary name server for a different zone. In other words, name servers are defined as primary or secondary on a per-zone basis.

TIP

On a corporate TCP/IP internetwork that uses DNS as its name resolution method, it is a good idea to have at least two name servers—a primary master name server, and a secondary name server for backup. Otherwise, if the primary goes down, users won’t be able to resolve server names on the network and therefore won’t be able to find and access any network resources.

BIND makes it possible for slave name servers to keep backup copies of zone files in case the master name server goes down. It is generally a good practice to keep such backup copies. You can also implement a list of up to 10 master name servers that can be tried successively by each slave name server in a very large DNS implementation. BIND v8 includes a feature whereby the primary notifies the slave when changes have been made to the primary’s DNS database. This notification process causes BIND v8 name servers to be more up to date with each other than with the polling procedure of earlier BIND implementations.

See also
name server

secondary ring

One of the two rings used in Fiber Distributed Data Interface (FDDI) networks to interconnect stations on the network. FDDI is a dual-ring topology networking architecture based on a token-passing access method. The secondary ring usually sits dark (unused), except when a fault occurs on the primary ring, in which case the network reconfigures itself to make use of the secondary ring to wrap around the fault. Because the data travels on the secondary ring in the opposite direction that it was traveling on the primary ring, when it’s put to use, the secondary ring reroutes data back the way it came, thus avoiding the problem spot. The dual-ring configuration provides FDDI with a degree of fault tolerance—if a computer or cable on the primary ring goes down, the secondary ring is put to use, working in conjunction with the portion of the primary ring that isn’t broken. This feature is known as a self-healing capability and is performed when the stations on both sides of the link concentrator reconfigure themselves when a failure occurs in the link (due to a cable break, a loose connector, or some device failure).

NOTE

The FDDI specification allows the length of the two rings to reach up to 200 kilometers, with up to 1000 attached stations. However, since the secondary ring is usually used for redundancy purposes, a maximum of 500 stations is allowed on an FDDI network. Repeaters are needed every 2 kilometers around the rings.

TIP

Run the FDDI primary ring and secondary ring along different physical paths to make your FDDI network even more redundant. If an accident or disaster affects one of the rings, it might not affect the other.

See also
Fiber Distributed Data Interface (FDDI), primary ring

secure attention sequence (SAS)

The Ctrl+Alt+Delete keystroke combination in Microsoft Windows NT and Windows 2000, which displays the Windows Security dialog box. (Note that in Windows NT the dialog box is called Windows NT Security.) Users can press this key combination to do the following:

  • Log on to or log off of a Windows workstation

  • Lock the console or unlock a locked workstation

  • Change their passwords

  • Invoke Task Manager

  • Shut down, log off, or restart their systems

TIP

The secure attention sequence (SAS) offers protection against Trojan horse programs that masquerade as common system applications. For example, it is impossible to write a Trojan horse program that presents the user with a phony Windows Security dialog box in an attempt to steal a user’s credentials, because this program cannot be activated by the SAS. The most that a hacker can do is write a Trojan horse program that displays a Windows Security dialog box at random times while the user is already logged on. To guard against such an event, you should educate users to always use the SAS keystroke sequence even if the computer they are using already displays what appears to be the Windows Security dialog box.

The SAS also kills any logon scripts that are running and can be used to terminate scripts that have stopped responding.

Secure Hypertext Transfer Protocol (S-HTTP)

An Internet protocol for encryption of Hypertext Transfer Protocol (HTTP) traffic. Secure Hypertext Transfer Protocol (S-HTTP) is an application-level protocol that extends the HTTP protocol by adding encryption to Web pages. It also provides mechanisms for authentication and signatures of messages. S-HTTP provides broad support for implementing different types of cryptographic algorithms and key management systems. Although S-HTTP systems can make use of digital certificates and public keys, messages can also be encrypted on a per-transaction basis using symmetric session keys. S-HTTP was proposed as a draft standard in 1996 and is still under development.

NOTE

S-HTTP is not as widely implemented as Secure Sockets Layer (SSL), which is independent of protocol and works with HTTP, Simple Mail Transfer Protocol (SMTP), Network News Transfer Protocol (NNTP), and other Internet protocols.

S-HTTP is also the name given to World Wide Web (WWW) server software that implements the S-HTTP protocol. This software was developed by Enterprise Integrations Technologies (EIT), the National Center for Supercomputing Applications (NCSA), and RSA Security.

Secure/Multipurpose Internet Mail Extensions (S/MIME)

A protocol for the secure exchange of e-mail and attached documents originally developed by RSA Security. Secure/Multipurpose Internet Mail Extensions (S/MIME) adds security to Internet e-mail based on the Simple Mail Transfer Protocol (SMTP) method and adds support for digital signatures and encryption to SMTP mail to support authentication of the sender and privacy of the communication. Note that because HTTP messages can transport MIME data, they can also use S/MIME.

How It Works

S/MIME is an extension of the widely implemented Multipurpose Internet Mail Extensions (MIME) encoding standard, which defines how the body portion of an SMTP message is structured and formatted. S/MIME uses the RSA public key cryptography algorithm along with the Data Encryption Standard (DES) or Rivest-Shamir-Adleman (RSA) encryption algorithm. In an S/MIME message, the MIME body section consists of a message in PKCS #7 format that contains an encrypted form of the MIME body parts. The MIME content type for the encrypted data is application/pkcs7-mime.

NOTE

S/MIME is gaining in popularity in the enterprise because its key management facilities are implemented as a hierarchical public key infrastructure (PKI) scheme. Version 2 of S/MIME has gained some support and is defined by Request for Comments (RFC) 2311 through 2315. An Internet Engineering Task Force (IETF) working group is currently working on version 3, which is expected to become an Internet standard when it is completed.

On the Web
•
IETF S/MIME Working Group
: http://www.imc.org/ietf-smime

Secure Sockets Layer (SSL)

A handshaking protocol for communication over the Internet that provides secure authentication and data encryption. Secure Sockets Layer (SSL) was developed by Netscape Communications for the secure transmission of information over the Internet.

How It Works

SSL works between the application and transport layers on a TCP/IP host to provide encryption of data for data security and encryption of user credentials for secure authentication. SSL uses the Rivest-Shamir-Adleman (RSA) public key cryptography method and is dependent on the implementation of digital certificates and a supporting public key infrastructure (PKI). Both the client and the server must support SSL. Because SSL is application independent, it can be used to encrypt data transmission for many application-layer Internet protocols, including Hypertext Transfer Protocol (HTTP), Simple Mail Transfer Protocol (SMTP), and Network News Transfer Protocol (NNTP).

An SSL handshake begins when an SSL-enabled client requests a connection with an SSL-enabled server. The server sends the client its digital certificate and public key. The client and server then negotiate a mutually acceptable level of encryption (usually 40-bit, 56-bit, or 128-bit strength, depending on legal restrictions and availability). The client then generates a session key, encrypts it with the server’s public key, and sends the encrypted session key to the server, which decrypts the session key using its private key. From that point on, the session key is used to encrypt all data exchanged between the client and server, providing secure, private communication.

TIP

A Web site that uses SSL has a Uniform Resource Locator (URL) that begins with https:// instead of http://.

Security Account Manager (SAM) database

The database of user and group account information stored on a domain controller in a Microsoft Windows NT–based network. The Security Account Manager (SAM) database is also known as the domain directory database, or sometimes simply the directory database.

The SAM database occupies a portion of the Windows NT registry. All user accounts, group accounts, and resource definitions such as shares and printers have their security principals defined in the SAM database. Because the entire SAM database must reside in a domain controller’s RAM, it cannot exceed about 40 MB in Windows NT, which works out to about 40,000 user accounts, or 26,000 users and Windows NT workstations combined. (The following table lists the size of common objects in a SAM database.)

The master copy of the SAM database is stored on the primary domain controller (PDC). Periodic directory synchronization ensures that backup domain controllers (BDCs) have an accurate replica of this master database, so BDCs can also be used for logons and for pass-through authentication of users attempting to access network resources.

Object Sizes in a SAM Database
Object | Size in SAM Database
User account | 1.0 KB
Computer account | 0.5 KB
Global group account | 0.5 KB plus 12 bytes per user
Local group account | 0.5 KB plus 36 bytes per user
NOTE

In Microsoft Windows 2000, the functions of the SAM database have been migrated to the more powerful and scalable Active Directory.

Security Administrator Tool for Analyzing Networks (SATAN)

A free tool developed by Dan Farmer and Wietse Venema in 1995 for remotely analyzing the security of networks. Security Administrator Tool for Analyzing Networks (SATAN) consists of a variety of routines that probe a network for security holes in a similar way that hackers do. SATAN tests the vulnerabilities of TCP/IP hosts using common TCP/IP protocols, such as File Transfer Protocol (FTP), Network File System (NFS), and Network Information System (NIS), and analyzes how the host responds to requests based on these protocols. The results are stored in a database and can be displayed using a Web browser.

SATAN runs on machines running UNIX and needs the Perl interpreter to operate. Typically, SATAN identifies weaknesses in the setup and configuration of network software; network administrators can use it to check the configuration of their network software. SATAN can also identify the network services that are running and provide information about the types of hardware and software and the topology of the network.

TIP

Because SATAN is free and can be downloaded from numerous places on the Internet, it can be used both by network administrators and by hackers. If you are concerned about the possible misuse of SATAN against your network, you can obtain various types of free anti-SATAN software on the Internet that alert you to a SATAN attack so that you can take remedial action.

security descriptor

A unique header for an object stored in Active Directory of Microsoft Windows 2000. Security descriptors contain security identifiers (SIDs), which are discretionary access control lists (DACLs) or system access control lists (SACLs) that specify the access permissions for the object. Specifically, the security descriptor for an object contains the following:

  • The owner SID:
    Identifies the security principal (the owner of the object)

  • The group SID:
    Used only by Services for Macintosh and the POSIX subsystem

  • The DACL:
    Contains the access permissions and rights for the object and its attributes, along with the SIDs of the security principals who can access the object

  • The SACL:
    Contains system-wide security policies such as the auditing policy

security group

One of two types of groups in Microsoft Windows 2000 that are created and stored in Active Directory; the other is distribution groups. Security groups are used for grouping accounts and for controlling access to resources, much in the same way that global groups and local groups are used in Microsoft Windows NT–based networks. (In other words, all groups in Windows NT are security groups.) Security groups are security principals that can contain other security principals such as user, group, and computer objects from Active Directory.

Security groups come in three types:

  • Domain local groups:
    Provide users with permissions to access resources; used only within the specific domain in which they are created

  • Global groups:
    Logically group users for administrative purposes and have visibility in the current domain and trusted domains

  • Universal groups:
    Similar to global groups but reduce global catalog replication traffic when they are used

See also
distribution group

security identifier (SID)

An internal number in the Security Account Manager (SAM) database of a domain controller in Microsoft Windows NT or Windows 2000 that uniquely identifies a user, group, or computer account within a domain. Security identifiers (SIDs) are used internally by Windows NT and Windows 2000 to provide user accounts with access to network resources.

How It Works

SIDs are guaranteed to be unique because they are created using a combination of user information, domain information, and time and date of account creation. The general format of a SID is a series of decimal numbers separated by dashes in the following form:

S-1-X-Y1-Y2-…

X is the value of the identifier authority, and Y1, Y2, and so on are values of subauthorities. The prefix S-1 means “SID revision 1.”

NOTE

Changing the name of a user, computer, or domain does not change the underlying SID for that account. Administrators cannot modify the SID for an account in Windows NT, and there is generally no need to know the SID assigned to a particular account. SIDs are primarily intended to be used internally by the operating system to ensure that accounts are uniquely identified to the system.

security log

A Microsoft Windows NT and Windows 2000 log that records auditing events. You can view and manage the security log by using the administrative tool Event Viewer. Entries in the security log are either success entries, which are identified by a key symbol, or failure entries, which are identified by a padlock symbol.

You can view additional details by opening the property sheet for the particular event. You can also select events by filtering the security log. You can export the security log as a .csv file and import it into a spreadsheet or database program for further analysis.

TIP

In a high-security environment, you can enable a registry parameter named CrashOnAuditFail, which causes the system to display a Stop screen when the security log is full. This prevents unaudited system access on your server. When you restart the system, you must archive the current contents of the security log before continuing. See the Microsoft Windows NT Server Resource Kit or the Microsoft Windows 2000 Server Resource Kit (both from Microsoft Press) for more information.

See also
application log, system log

security principal

An object in Active Directory of Microsoft Windows 2000 that can be assigned permissions and rights.

How It Works

Three types of security principals are used in Windows 2000 networks:

  • User objects:
    Represent individual user accounts

  • Group objects:
    Can be used to group other security principals for assigning permissions and to ease administration

  • Computer objects:
    Represent individual computers running Windows 2000 on the network

Security principals are uniquely identified by security identifiers (SIDs), which provide a unique, internal, alphanumeric identifier for the security principal.

security provider

A server or device on a network that authenticates users trying to log on or access network resources. In a Microsoft Windows NT–based or Windows 2000–based network, special servers called domain controllers act as security providers and handle tasks such as user logons and control of resource access. If all domain controllers are temporarily offline, users can still log on to their local computers and use local computer resources but cannot be authenticated for accessing resources elsewhere on the network.

Microsoft Windows 95 and Windows 98 can operate as stand-alone computing environments or as part of a Windows NT or Windows 2000 domain. If files on a computer running Windows 95 or Windows 98 will be shared by users on a Windows NT–based or Windows 2000–based network, be sure that you have configured Windows 95 or Windows 98 networking to use user-level security instead of the more common share-level security used in workgroup environments.

Security Reference Monitor

A component of the Microsoft Windows NT executive running in kernel mode that acts like a security watchdog, enforcing security when applications try to access system resources. The Security Reference Monitor decides whether a given process should be granted access rights to an object. It does this by comparing the access token attached to the process to the discretionary access control list (DACL) attached to the object that the process is trying to access. It compares the security identifiers (SIDs) in the DACL entry by entry to the SIDs in the access token to see what level of access the process should be granted. If any of the DACL SIDs denies the request access, the process is denied access to the object. The Security Reference Monitor also ensures that auditing takes place if auditing is configured in the local security policy.

security subsystem

The component of the Microsoft Windows NT and Windows 2000 operating systems that validates logons and authenticates access to network resources. Portions of the security subsystem run in kernel mode and portions run in user mode, as shown in the following diagram. The components that work together to provide security in Windows NT and Windows 2000 include the following:

  • Local Security Authority (LSA):
    Checks to see whether users have permission to access the system itself. The LSA manages the local security policy, generates access tokens, supports interactive logons, and manages auditing.

  • Logon processes:
    Display the Windows NT and Windows 2000 Security dialog boxes, in which a user can log on to the system interactively. Windows NT and Windows 2000 also include remote logon processes for pass-through authentication by remote users who want to access network resources.

  • Security Account Manager (SAM) database:
    The database in the registry that contains the user and group account credentials. The LSA uses the SAM database to determine whether to allow a user to log on to the network.

  • Security Reference Monitor:
    Checks to see whether users have permission to access a particular object, such as a file on an NTFS volume. The Security Reference Monitor enforces the access validation functions of the LSA and generates audit messages (if this feature is enabled).

    Graphic S-3. Security subsystem.
    Graphic S-3. Security subsystem.

security zone

A feature of Microsoft Internet Explorer that allows users to designate which intranets and portions of the Internet are trusted or distrusted. The more trusted a zone is, the broader the permissions it grants for executing scripts, Microsoft ActiveX controls, and Java applets, and for executing other potentially hazardous actions. Security settings for a zone can be high, medium, low, or custom.

Here are the zones you can configure and their default security settings:

  • Internet zone (medium):
    For sites on the Internet that are considered unsafe and for which access is restricted

  • Local intranet zone (medium):
    For internal sites that are connected to the local network

  • Trusted sites zone (low):
    For Internet sites that are considered safe for unrestricted access

  • Restricted sites zone (high):
    For sites on the Internet that have not been determined either safe or unsafe and are thus considered extremely dangerous

A fifth zone, which is defined as trusted but which cannot be configured, is the My Computer zone, which consists of the local system’s resources.

Graphic S-4. The Security tab in the Internet Options dialog box.
Graphic S-4. The Security tab in the Internet Options dialog box.

segmentation

The process of dividing a large network into smaller, connected networks. Segmentation improves the performance of Ethernet networks by reducing the size of collision domains. Because stations on an Ethernet network use contention to try to use the networking media, fewer stations in a given network segment means less contention and better network performance. Bridges or routers are generally used to segment an Ethernet network into smaller collision domains.

The term “segmentation” also refers to the process by which routers break down oversized frames into smaller portions that are sequenced, forwarded, and then reassembled at the receiving station. Segmentation is usually a sign that the network is misconfigured because segmentation eats valuable CPU cycles on routers and produces greater latency in network communication.

separator page

A page that is printed between print jobs. In the old days, separator pages indicated when one print job finished and the next one began. In Microsoft Windows NT and Windows 2000, separator pages can have two functions:

  • Separating printed output in a multiuser environment so that users can more easily retrieve their print jobs

  • Switching a print device between different print modes (if the device has this capability)—for example, switching between Printer Control Language (PCL) mode and Postscript mode

Windows NT and Windows 2000 include three separator pages, which are located in the \Winnt\System32 directory:

  • Pcl.sep:
    Switches the printing mode to PCL printing, typically for printers made by Hewlett-Packard. A separator page is also printed.

  • Pscript.sep:
    Switches the printing mode to Postscript for supported printers. No separator page is printed.

  • Sysprint.sep:
    Functions like pscript.sep but also prints a separator page.

Windows 2000 includes a fourth separator page, sysprtj.sep, which is similar to sysprint.sep.

You can use Notepad to edit any default separator page file to create a custom separator file. You can add new lines by using printer escape codes such as those shown in the following table.

Escape Codes for Custom Separator Pages
Code | Function
@D | Prints the date that the job was submitted. (Use Regional Settings in Control Panel to specify the format.)
@E | Ejects the page. (Use at the end of a separator page.)
@Fpathname | Prints the contents of the file specified by “pathname” without performing any processing of the file.
@Hnn | Sends escape code nn to the printer (device-specific functionality).
@I | Prints the job number.
@L | Prints the following characters as is until the next escape code is encountered.
@N | Prints the name of the user who submitted the job.
@T | Prints the time that the job was submitted.
@n | Skips n lines.
@0 | Skips to the next line.
TIP

If a printer can auto-switch between printing modes (by identifying the type of the rendered file sent to it), you do not need to specify a separator page.

serial interface

See
serial transmission

Serial Line Internet Protocol (SLIP)

An industry standard protocol developed in 1984 for UNIX environments that supports TCP/IP networking over serial transmission lines. These serial lines are typically dial-up connections using a modem. Serial Line Internet Protocol (SLIP) can provide TCP/IP hosts with dial-up access to the Internet by using SLIP servers located at Internet service providers (ISPs).

NOTE

SLIP is an older serial line protocol that doesn’t support automatic negotiation of network configurations. It has been largely replaced by the Point-to-Point Protocol (PPP) for the following reasons:

  • SLIP supports only TCP/IP, while PPP is a multiprotocol encapsulation protocol that can also support Internetwork Packet Exchange (IPX) and AppleTalk. This is not an issue, however, if you are connecting to the Internet, which is strictly TCP/IP-based.

  • SLIP generally requires that the host’s TCP/IP parameters be configured manually, while PPP can negotiate the parameters during session establishment. These parameters include the IP address of the host, the window size, and compression.

  • SLIP might require the user to write a script for automating the logon process, while PPP supports both the Password Authentication Protocol (PAP) and the Challenge Handshake Authentication Protocol (CHAP), which let you automatically forward your credentials to the PPP server for authentication.

Microsoft Windows NT and Windows 2000 can function as SLIP clients but not as SLIP servers. Windows NT Remote Access Service (RAS) and Windows 2000 Routing and Remote Access servers cannot accept connections from SLIP clients.

serial transmission

A form of signal transmission that sends information one bit at a time over a single data channel. Serial interfaces are generally used to connect data communications equipment (DCE) such as modems to data terminal equipment (DTE) such as computers and terminals and for connecting a DCE to a DTE. The term “interface” indicates that these specifications describe how to establish an electrical (pinning) and mechanical (connector) shared boundary between devices. An interface specifies a series of protocols, an arrangement of pins, special control signals, and other functions that enable devices to communicate with each other.

The common specifications for serial interfaces include the following:

  • RS-232:
    The most commonly used serial interface in ordinary network communication, which supports transmission over a range of 0 to 20 Kbps at distances of up to 50 feet (15.24 meters). RS-232 can use either DB9 or DB25 connectors.

  • RS-422:
    Specifies a balanced electrical interface but no specific mechanical interface for point-to-point serial communication. RS-422 typically uses either DB9 or DB37 connectors.

  • RS-423:
    Similar to RS-422, except that unbalanced lines are used instead of balanced ones.

  • RS-449:
    Specifies the mechanical interface for RS-422 and RS-423 and is used with these interfaces for high-speed serial communication with Channel Service Unit/Data Service Units (CSU/DSUs) and routers.

  • RS-485:
    Defines a balanced, multipoint interface using tristate drivers to reduce noise. The combined interface RS-422/485 allows you to daisy-chain up to 31 serial devices to a single serial port and is typically used for interfacing industrial sensors and measuring equipment to a computer.

  • RS-530:
    A successor to RS-232 and RS-449 that provides high-speed synchronous and asynchronous serial communication of up to 2 Mbps.

  • V.35:
    An International Telecommunication Union (ITU) standard for data transmission at 48 Kbps that is typically used for connecting CSU/DSUs and routers for wide area network (WAN) communication over digital data service (DDS) lines. V.35 uses a block-shaped 34-pin connector.

  • X.21:
    An ITU standard for synchronous communication between DTEs and DCEs on public X.25 packet-switched networks. X.21 typically uses a DB15 connector.

NOTE

Serial interfaces such as RS-232 are the most commonly used protocol for devices called line drivers, which enable terminals and hosts to be connected over phone lines and extend the distance over which the serial interface can function by regenerating the signal.

Related terminology includes

  • Serial cable:
    A cable used to connect pieces of DCE to pieces of DTE by using a serial interface

  • Serial port:
    A plug or connector on pieces of DTE that can use serial transmission to send and receive data

See also
parallel transmission, RS-232, V.35

Series Q protocols

See
Q-series protocols

server

A computer whose role in a network is to provide services and resources to users. Servers usually have one or more specific roles in a network:

  • Application servers are used as the back end in a client/server environment. An example of an application server is Microsoft Exchange Server, which functions as the back end of a client/server messaging system that includes Microsoft Outlook as the front-end user interface.

  • File and print servers provide users with centralized locations for storing files and accessing print devices. Microsoft Windows 2000 member servers and Windows 2000 servers running Internet Information Services (IIS) are examples of file servers.

  • Authentication servers or security servers validate users for logging on and accessing network resources. An example is a Windows 2000 domain controller.

  • Web servers can be used to host anything from static Hypertext Markup Language (HTML) pages to commercial Web applications such as online storefronts. IIS is an ideal platform for developing Web-based applications using Active Server Pages (ASP) technology.

server-based network

A network in which network security and storage are managed centrally by one or more servers.

How It Works

In a server-based network, special computers called servers handle network tasks such as authenticating users, storing files, managing printers, and running applications such as database and e-mail programs. Security is generally centralized in a security provider, which allows users to have one user account for logging on to any computer in the network. Because files are stored centrally, they can be easily secured and backed up.

Server-based networks are more costly and complex to set up and administer than peer-to-peer networks, and they often require the services of a full-time network administrator. They are ideal for businesses that are concerned about security and file integrity and have more than 10 computers.

Microsoft Windows NT and Windows 2000 are ideal operating systems for server-based networks. They offer centralized network administration, networking that is easy to set up and configure, NTFS file system security, file and print sharing, user profiles that allow multiple users to share one computer or allow one user to log on to many computers, Routing and Remote Access for supporting mobile users, and Internet Information Services (IIS) for establishing an intranet or Internet presence.

See also
peer-to-peer network

server certificate

A digital certificate obtained for a server application such as Microsoft Internet Information Services (IIS) that the server can use to digitally sign data that it transmits. The server certificate contains the server’s identification information and public key. The client (a Web browser, for example) that communicates with the server validates the identity of the server using the CA certificate of the certificate authority (CA) issuing digital certificates for the enterprise.

NOTE

Use server certificates when it is important for clients to validate the identity of your servers—for example, when you are running an online store built around a Web server and using the Secure Sockets Layer (SSL) protocol. You must obtain your server certificate from a public, third-party certificate authority that is already recognized by the client, such as VeriSign, Inc., or have the client first install the CA certificate of your own CA server, such as Microsoft Certificate Server.

See also
CA certificate, client certificate

Server Manager

A Microsoft Windows NT administrative tool for managing Windows NT domains and servers. You can use Server Manager to

  • Add a computer to a domain or remove it from a domain

  • View users connected to a server and disconnect them

  • Configure directory replication between servers

  • Start, stop, and pause services on servers

  • Synchronize domain controllers within a domain

  • Specify recipients of administrative alerts

  • View and manage directories that are shared

    Graphic S-5. Server Manager.
    Graphic S-5. Server Manager.
NOTE

The administrative functions of Server Manager in Windows NT are divided among several administrative consoles in Microsoft Windows 2000. For example,

  • To create a computer account or add a computer to a domain, use Active Directory Users and Computers.

  • To remotely manage services, shares, sessions, and open files, use Computer Management.

TIP

To use Server Manager to create a new share on a remote server, you must know the exact path to the folder you want to share. To determine the exact path, map a drive to the root administrative share on the appropriate drive of the remote server (for example, \\REMOTE_SERVER\C$) and browse the folder structure or create a new folder. Return to Server Manager and choose Shared Directories from the Computer menu, click the New Share button, and enter the share name and path.

Server Message Block (SMB)

A high-level file-sharing protocol jointly developed by Microsoft, IBM, and Intel for passing data between computers on a network. Microsoft Windows and OS/2 use Server Message Block (SMB). Many UNIX operating systems also support it.

How It Works

SMB is used between clients and servers to do the following:

  • Open and close connections between client redirectors and shared network resources

  • Locate, read, and write to files shared on a server

  • Locate and print to print queues that are shared on a server

SMB uses four types of messages:

  • Session control messages:
    Open or close a redirector connection to a shared resource on the server. The SMB redirector packages the requests sent to remote servers in an SMB-enabled network.

  • File messages:
    Used by the redirector to gain access to files on the server.

  • Printer messages:
    Used by the redirector to send data to a print queue and get status information about the queue.

  • Message messages:
    Let applications exchange messages with another computer.

server monitor

A component of Microsoft Exchange Server that you can use to verify that specific Microsoft Windows NT or Windows 2000 services are running on an Exchange server and to resynchronize clock times on the servers. If a server monitor detects a problem with a Windows NT or Windows 2000 service, it can send an alert, send an e-mail notification, or attempt to restart the service or reboot the server. One server monitor can monitor multiple servers, and you can define an escalation sequence of multiple actions when problems occur. Typical problems that trigger a server monitor to generate an alert include the following:

  • A downed server or one that rebooted for some reason

  • A service stopping unexpectedly on the Exchange server

  • A server whose network connectivity has failed

  • A server whose clock is off by a certain threshold amount

Graphic S-6. Server monitor.
Graphic S-6. Server monitor.
TIP

Once you create a new server monitor, you must start it using the Start Monitor command on the Tools menu of the Exchange Administrator program. You can also run it from the command prompt and configure it to start when the monitoring machine is rebooted.

server operating system

See
network operating system (NOS)

Server Operators built-in group

A built-in group in Microsoft Windows NT and Windows 2000 whose members have the rights to administer servers on the network. In Windows NT, Server Operators is a local group that exists on both domain controllers and member servers. In Windows 2000, Server Operators is a domain local group. The initial membership of the group is empty.

The Server Operators group has the following preassigned rights:

  • Log on locally to the server console

  • Change the system time

  • Back up files and directories

  • Restore files and directories

  • Shut down the system

  • Force shutdown from a remote system

Server Operators can also share and manage disk resources and printers on the network and lock the server.

See also
built-in group, built-in local group

server proxying

A feature supported by Microsoft Proxy Server that complements and supports reverse proxying. The proxy server uses server proxying to listen for incoming packets that are destined for computers connected to the internal network behind the proxy server. When the packets are received, the proxy server forwards them to the appropriate servers. This allows Microsoft Exchange Server, for example, to sit securely on an internal network behind a computer running Proxy Server. Server proxying is a circuit layer proxy service that supports a wide variety of protocols.

Server service

Also known as LanmanServer, a component of the Microsoft Windows NT and Windows 2000 operating systems that allows a server to share file and print resources with clients over the network. When a redirector on a client requests a shared resource from a server, the Server service on the server responds and routes the resource to the client.

How It Works

The Server service is implemented as a file system driver and resides above the transport driver interface (TDI) layer, which allows it to interact independently with any installed network transport protocols on the system. The Server service responds to requests just as any other file system driver does, allowing users to read and write data to and from remote network shares.

The Server service consists of two files:

  • Server (or SRV):
    A service that runs within the general Service Control Manager (services.exe) process

  • Srv.sys:
    A file system driver that operates in kernel mode and handles all low-level functions of the Server service, such as file reads and writes

If a remote network client makes a request to the Server service on the local computer, asking to read a file from the local file system, the request is received by the network interface card (NIC) driver and passed up the protocol stack to srv.sys, which forwards the read request to the appropriate local file system driver. The file system driver calls the disk subsystem driver to read the file, and the disk subsystem driver returns the file contents to the file system driver, which passes it back to srv.sys. Srv.sys passes the information back down the protocol stack to the NIC driver, which forwards it over the network to the requesting client.

Graphic S-7. Server service.
Graphic S-7. Server service.
TIP

If you cannot see a server’s shared folders and printers in Network Neighborhood, check to see whether the Server service is still running. Try stopping and starting the service by using the Windows 2000 Services snap-in or the Windows NT Services utility in Control Panel.

See also
Workstation service

service

A background process in an operating system that provides some specific functionality. Examples include the Server service in Microsoft Windows NT and Windows 2000 and File and Printer Sharing for Microsoft Networks in Microsoft Windows 95 and Windows 98, both of which enable sharing of resources over the network.

Services for Windows NT and Windows 2000 are RPC-enabled and can be called from remote computers over the network. In Windows NT, users can add and remove services by using the Network utility in Control Panel, and they can control and configure services by using the Services utility. In Windows 2000, users can add and remove services by using the Add/Remove Windows Components option in Add/Remove Programs. They can control and configure services by using the Services snap-in, accessible from Administrative Tools. The following tables list the default services available for typical Windows 2000 Server and Windows NT 4.0 Server installations and indicates which services are normally installed and started automatically.

Common Windows 2000 Services
Service | Normally Installed | Automatically Started
Alerter | x | x
Application Management | x |
Boot Information Negotiation Layer |  |
Certificate Services |  | x
ClipBook | x |
COM+ Event System | x |
Computer Browser | x | x
DHCP Client |  | x
DHCP Server |  | x
Distributed File System | x | x
Distributed Link Tracking Client | x | x
Distributed Link Tracking Server | x |
Distributed Transaction Coordinator | x | x
DNS Client | x | x
DNS Server |  | x
Event Log | x | x
Fax Service | x |
File Replication | x |
File Server for Macintosh |  | x
FTP Publishing Service |  | x
IIS Admin Service | x | x
Indexing Service |  | x
Internet Authentication Service |  | x
Internet Connection Sharing | x |
Intersite Messaging | x |
IPSEC Policy Agent | x | x
Kerberos Key Distribution Center | x |
License Logging Service | x | x
Logical Disk Manager | x | x
Logical Disk Manager Administrative Service | x |
Message Queuing |  | x
Messenger | x | x
Net Logon | x | x
NetMeeting Remote Desktop Sharing | x |
Network Connections | x |
Network DDE | x |
Network DDE DSDM | x |
Network News Transport Protocol (NNTP) |  | x
NT LM Security Support Provider | x |
On-line Presentation Broadcast |  |
Performance Logs and Alerts | x |
Plug and Play | x | x
Print Server for Macintosh |  | x
Print Spooler | x | x
Protected Storage | x | x
QoS Admission Control (RSVP) |  | x
QoS RSVP | x |
Remote Access Auto Connection Manager | x |
Remote Access Connection Manager | x |
Remote Procedure Call (RPC) | x | x
Remote Procedure Call (RPC) Locator | x |
Remote Registry Service | x | x
Remote Storage Engine |  | x
Remote Storage File |  | x
Remote Storage Media |  | x
Remote Storage Notification |  |
Removable Storage | x | x
Routing and Remote Access | x |
RunAs Service | x | x
Security Accounts Manager | x | x
Server | x | x
Simple Mail Transport Protocol (SMTP) | x | x
Simple TCP/IP Services |  | x
Single Instance Storage Groveler |  |
SiteServer ILS Service |  | x
Smart Card | x |
Smart Card Helper | x |
SNMP Service |  | x
SNMP Trap Service |  |
System Event Notification | x | x
Task Scheduler | x | x
TCP/IP NetBIOS Helper Service | x | x
TCP/IP Print Server |  | x
Telephony | x |
Telnet |  |
Terminal Services | x |
Terminal Services Licensing |  | x
Trivial FTP Daemon |  |
Uninterruptible Power Supply | x |
Utility Manager | x |
Windows Installer | x |
Windows Internet Name Service (WINS) |  | x
Windows Management Instrumentation | x |
Windows Management Instrumentation Driver Extensions | x |
Windows Media Monitor Service |  | x
Windows Media Program Service |  | x
Windows Media Station Service |  | x
Windows Media Unicast Service |  | x
Windows Time | x | x
Workstation | x | x
World Wide Web Publishing Service | x | x
Common Windows NT Services
Service | Normally Installed | Automatically Started
Alerter | x | x
ClipBook Server | x |
Computer Browser | x | x
DHCP Client |  | x
Directory Replicator | x |
EventLog | x | x
File Server for Macintosh |  | x
FTP Publishing Service |  | x
Gateway Service for NetWare |  | x
Gopher Publishing Service |  | x
License Logging Service | x | x
Messenger | x | x
Microsoft DHCP Server |  | x
Microsoft DNS Server |  | x
Net Logon | x | x
Network DDE | x |
Network DDE DSDM | x |
Network Monitor Agent |  |
NT LM Security Support Provider | x | x
Plug and Play | x | x
Print Server for Macintosh |  | x
Protected Storage | x | x
Remote Access Autodial Manager |  |
Remote Access Connection Manager |  |
Remote Access Server |  | x
Remoteboot Service |  |
RIP for Internet Protocol |  | x
Remote Procedure Call (RPC) Locator | x |
Remote Procedure Call (RPC) Service | x | x
SAP Agent |  | x
Schedule | x |
Server | x | x
Simple TCP/IP Services |  | x
SNMP |  | x
SNMP Trap Service |  |
Spooler | x | x
TCP/IP NetBIOS Helper |  |
TCP/IP Print Server |  |
Telephony Service | x |
UPS | x |
Windows Internet Name Service |  | x
Workstation | x | x
World Wide Web Publishing |  | x
See also
daemon

service account

A Microsoft Windows NT or Windows 2000 user account that an application uses as a security context in which to run services. Service accounts are used by products such as Microsoft Exchange Server, Microsoft SQL Server, Microsoft Systems Management Server, and Microsoft SNA Server.

To illustrate a service account, let’s consider the Exchange service account in Exchange Server 5.5. All Exchange servers in a given Exchange site must use the same service account. The servers use the service account to determine which other Exchange servers are part of the same site and have the right to use the messaging services on the server.

You should create the Exchange service account before you install the first Exchange server in a site. You can give it any name. You should not use it as an account for a user to log on to the network; instead, reserve it for use by Exchange and assign it a complex password for security reasons. Specify the service account during the installation process, and grant it the Service Account Admin role on the site object and its Configuration container within the Exchange Administrator directory hierarchy.

The Exchange service account is also granted the following system rights:

  • Act as part of the operating system

  • Log on as a service

  • Restore files and directories

TIP

You can change the password for an Exchange Server 5.5 service account in two places: the configuration container for the site object in the Exchange directory hierarchy (using the Exchange Administrator program) and in the Security Account Manager (SAM) database (using the administrative tool User Manager for Domains in Windows NT 4.0 or Computer Management in Windows 2000).

Service Advertising Protocol (SAP)

A Novell NetWare protocol that is used with Internetwork Packet Exchange (IPX) to enable file and print servers to advertise their availability to clients on a network.

How It Works

Service Advertising Protocol (SAP) periodically advertises the address of the server and the types of services it can provide to clients. It sends its advertisements by making frequent broadcasts to all machines on the local network. Routers generally forward the advertisements so that network services can be made available to machines throughout an IPX internetwork.

TIP

The use of SAP broadcasts on IPX internetworks creates effective limits on the size of a usable IPX internetwork. However, you can configure routers to reduce unnecessary SAP traffic by

  • Filtering unnecessary SAP broadcasts using access lists on routers

  • Using Cisco Systems IPX routers that allow SAP broadcasts to contain update information only, instead of the entire SAP table, and to forward SAP updates only when a change to the SAP table has occurred

See also
NetWare protocols

Service for NetWare Directory Services

A Microsoft Windows 98 networking component for interoperability with Novell NetWare 4 servers running Novell Directory Services (NDS). If a computer running Windows 98 is running Client for NetWare Networks only, in Network Neighborhood the computer can recognize only bindery-based NetWare servers on the network, such as NetWare 3 and earlier servers and NetWare 4 servers running in bindery-emulation mode. Computers running Microsoft Windows 95 and Windows 98 that are running File and Printer Sharing for NetWare Networks are also visible. If you install Service for NetWare Directory Services, the Windows 98 client can also view NDS objects in the current context in Network Neighborhood.

Service for NetWare Directory Services includes additional capabilities, including support for logon scripts on NDS servers. Administrators can also use the computer running Windows 98 to run NetWare 4 utilities that require NDS (such as the nwadmin tool or netadmin).

Use the Network utility in Control Panel to install Service for NetWare Directory Services on a computer running Windows 98.

service-level agreement (SLA)

A contractual agreement between a customer and a service provider that outlines what services will be provided and defines the acceptable range of performance and availability of those services. Service-level agreements (SLAs) also indicate the costs and penalties that will be incurred when performance and availability fall below acceptable levels. SLAs are typically used in contracts with telecommunications service providers who provide WAN links for wide area networks (WANs).

service pack

A collection of patches, fixes, and minor upgrades for a specific version of a product such as a Microsoft Windows operating system or a Microsoft BackOffice server product. A service pack is not the same as a decimal release, such as an upgrade from version 4.0 to version 4.01.

Service packs are typically identified with a number, such as Service Pack 2. Occasionally, interim releases of service packs are also issued, such as Service Pack 2a (SP2a) for Microsoft Transaction Server (MTS).

Service packs for each product are generally cumulative. For example, if you apply Service Pack 3 to a product, you normally don’t have to apply Service Packs 1 and 2 first, because Service Pack 3 includes the fixes and upgrades in Service Packs 1 and 2.

Service packs are included in Microsoft Developer Network (MSDN) TechNet subscriptions; they are also often available for download from the Microsoft Web site.

NOTE

Microsoft Office service packs are known as service releases and are numbered SR-n.

TIP

Check MSDN and TechNet for a list of current service packs and what they do for each product. Before you apply a service pack, read its documentation to determine whether you need to apply it. Occasionally, service packs must be applied in a specific order on a system that is running more than one BackOffice product. Check MSDN, TechNet, or the Microsoft Knowledge Base for information on this kind of situation.

Service packs often include new features or additional optional components for the product, in addition to bug fixes and patches. A common misconception about service packs is that while they are cumulative with respect to bug fixes and patches, they might not be cumulative with respect to new features or components. For example, Service Pack 4 for Windows NT 4.0 includes Microsoft Windows Media Player, but Service Pack 5 for Windows NT 4.0 does not include this new utility. So if you simply want to patch your product against bugs, you need only apply the most recent service pack for the product. But if you want to make use of product enhancements and new features, you might need to apply each of the service packs for the product in succession.

services file

A text file that assigns Transmission Control Protocol (TCP) and User Datagram Protocol (UDP) port numbers to TCP/IP protocols and services for a computer on a TCP/IP network. The entries in the services file are used for well-known service (WKS) records in Domain Name System (DNS) servers and other Windows Sockets applications. You can also use the file to quickly determine which well-known TCP or UDP port number is assigned to a specific network service or protocol.

How It Works

You will find the services file at the following location on a computer running Microsoft Windows:

  • Windows NT and Windows 2000:
    %SystemRoot%\System32\drivers\etc\services

  • Windows 95 and Windows 98:
    %WinDir%\Services

Each line in the services file contains the standard name for the service followed by the well-known port number as defined in Request for Comments (RFC) 1060, an alias, and an optional comment prefixed with a pound sign (#). The following example is a portion from the sample services file included with Windows:

# Format:
# <service name>  <port number>/<protocol>  [aliases...] [#<comment>]
  ...
ftp-data       20/tcp                  # FTP, data
ftp            21/tcp                  # FTP. control
telnet         23/tcp
smtp           25/tcp    mail          # Simple Mail Transfer Protocol
time           37/tcp    timeserver
time           37/udp    timeserver
TIP

You can change the default port number for a TCP/IP service by editing the services file—for example, if you need to run multiple Simple Network Management Protocol (SNMP) agents or if you want to change the default File Transfer Protocol (FTP) control port to make access more private.

See also
hosts file, lmhosts file, networks file, protocol file

Services for Macintosh

An optional set of services and protocols in Microsoft Windows NT and Windows 2000 that enables file and print resources to be shared between Macintosh computers and computers running Windows NT or Windows 2000. This simplifies the administration of resources on heterogeneous networks containing a mix of Macintosh and Windows servers and clients. On the Windows 2000 platform, these services and protocols are collectively known under the umbrella name AppleTalk network integration.

How It Works

Services for Macintosh (or AppleTalk network integration) consists of three optional components in Windows NT or Windows 2000:

  • The AppleTalk protocol:
    Apple’s proprietary network protocol for Macintosh computers.

  • File Server for Macintosh (MacFile):
    Lets you specify which volumes on your Windows NT–based or Windows 2000–based server you want to make available to Macintosh clients as Macintosh-accessible volumes, manages differences in permissions between the two platforms, and makes sure that Macintosh file names are legal NTFS file system names.

  • Print Server for Macintosh (MacPrint):
    Enables Macintosh clients to spool their print jobs to a Windows NT or Windows 2000 print server.

Macintosh client machines can access Windows NT servers running Services for Macintosh (or Windows 2000 servers with AppleTalk network integration installed) in the same way that they access file and print resources on an AppleShare server. Services for Macintosh supports an unlimited number of client connections using the AppleTalk Filing Protocol (AFP), Apple’s presentation-layer protocol for sharing files and applications over an AppleTalk network.

You can install Services for Macintosh on a server running Windows NT by using the Network utility in Control Panel. On servers running Windows 2000, you can install File Server for Macintosh or Print Server for Macintosh by using the Windows Components Wizard from Add/Remove Programs in Control Panel, which automatically installs the AppleTalk protocol as well. You can also separately install the AppleTalk protocol by using Network and Dial-Up Connections. Services for Macintosh requires an NTFS-formatted volume in order to operate. When Services for Macintosh is first installed, a Macintosh-accessible volume called Public Files is created on the server running Windows NT or Windows 2000. You can create other Macintosh-accessible volumes later using My Computer.

session layer

Layer 5 of the Open Systems Interconnection (OSI) reference model, which enables sessions between computers on a network to be established and terminated. The session layer does not concern itself with issues such as the reliability and efficiency of data transfer between stations because these functions are provided by the first four layers of the OSI reference model. The session layer is responsible for synchronizing data exchange between computers, structuring communication sessions, and other issues directly related to conversations between networked computers. The session layer is also responsible for name recognition functions at the level of logical network names and for assigning communication ports. For example, the NetBIOS protocol is considered to run at the session level.

The session layer of the OSI reference model is not widely implemented in common local area network (LAN) protocol suites such as TCP/IP and IPX/SPX. Instead, the top three layers of the OSI model—the application layer, presentation layer, and session layer—are often thought of best as a homogeneous whole subsumed within a generalized application layer.

Set Up Computer Wizard

A tool included with Microsoft BackOffice Small Business Server that automates the job of configuring Microsoft Windows–based client computers running in a Small Business Server network. The Set Up Computer Wizard creates a setup floppy disk that allows a user with a client computer to easily connect to the server. Once a user is connected to the server, the client computer can be configured and software can be installed. This frees the user from having to configure network settings, figure out how to join a domain, find out where the server is located, install client applications, configure the e-mail client, and so on.

How It Works

Setting up and configuring client computers involves two components:

  • Set Up Computer Wizard, which runs on the server

  • Client Installation Wizard, which runs on the client

To add a new client computer to the network, an administrator runs the Set Up Computer Wizard on the server. The administrator must perform the following functions when using the Set Up Computer Wizard:

  • Select the user who will be using the client computer. (The user must be set up to use a logon script.)

  • Specify a client computer name. (The Set Up Computer Wizard provides a suggested computer name.)

  • Specify the operating system for the client (Windows 95, Windows 98, or Windows NT Workstation 4.0).

  • Specify the applications to install on the client, which might include Microsoft Fax client, Microsoft Internet Explorer, Microsoft Modem Sharing client, Microsoft Proxy client, Microsoft Office 2000 (including Microsoft Outlook), and Outlook.

When the Set Up Computer Wizard completes, it creates the following items:

  • A user-specific floppy disk containing the user’s client configuration information

  • A logon script on the server for the specified user

  • A set of client configuration files on the server for the specified computer

  • A machine account on the server for the computer

To configure the client computer, the user inserts the disk in the computer and runs the setup program, and the following client network setup occurs:

  • Configuration of the client’s network settings, including installing TCP/IP

  • Configuration of the client so that the user can connect to the Small Business Server domain

Once the client network setup has been performed, the client computer will need to be restarted. After restarting, the user should be able to log on to the Small Business Server. When the user logs on to the server, the Client Installation Wizard starts automatically. The Client Installation Wizard will install and configure the selected client applications.

TIP

The Set Up Computer Wizard can be modified to support other client applications.

In many small businesses, a single computer might have more than one user. The Set Up Computer Wizard lets administrators easily configure a single computer for multiple users.

share

As a verb, to make resources on a computer available to other users on the network who have suitable permissions. Resources that can be shared include disk volumes, directories, and printers.

As a noun, a share is typically another name for a folder or directory that allows users on the network who have suitable permissions to access its contents. The name of a share does not have to be the same as the local name of the object. A share usually contains such items as public data, network applications, and users’ home folders.

In Microsoft Windows 95 and Windows 98, share access can take two forms:

  • Share-level security:
    Controls access to a share using a password that is the same for all users. For example, a user who wants to connect to a share on a peer server running Windows 95 or Windows 98 that uses share-level security must know only the password for the share in order to access it. Share-level security is commonly used in small workgroups.

  • User-level security:
    Controls access to a share via user credentials and group membership. For example, one group of users can be assigned read-only access to the share, another group can be assigned full access, and a third group can be assigned custom access. In order for user-level security to work, the network must have a security provider (such as a Microsoft Windows NT or Windows 2000 domain controller).

In Windows NT and Windows 2000, shares are always based on user-level security. A network user’s access to a shared folder on an NTFS volume is governed by a combination of NTFS permissions and shared folder permissions.

TIP

Share names that do not conform to the MS-DOS 8.3 naming convention cannot be accessed by MS-DOS-based workstations.

shared folder

See
share

shared folder permissions

In Microsoft Windows, a set of permissions that can be assigned to a shared folder to control access by users and groups on the network. Shared folder permissions can be applied only to the entire shared folder, not to its files and subfolders. If you want to control access to individual files and subfolders within a network share, you can use the more granular NTFS permissions on Windows NT and Windows 2000. In addition, shared folder permissions are effective only when a user accesses the folder over the network. If a user can log on locally to the console of the computer where the share is located, that user can always access the contents of the shared folder regardless of the shared folder permissions set (unless the folder is on an NTFS volume and the NTFS permissions restrict the user from accessing the resource). Finally, shared folder permissions are the only way to secure network resources that are stored on FAT volumes.

If a user belongs to two or more groups, and these groups have different permissions on a given share, the user’s ability to access the folder over the network can be calculated by two rules:

  • The effective permission is the least restrictive (most permissive) permission, as in this example:

    read + change = change permission

  • No access or deny access overrides all other permissions, as in this example:

    read + no access = no access

How It Works

Windows 95, Windows 98, Windows NT, and Windows 2000 each have different mechanisms for assigning shared folder permissions for users and groups. The following tables show the permissions for each of these operating systems and lists what the permissions allow users to perform.

Windows 95 and Windows 98 Shared Folder Permissions
Permission | What It Allows Users to Do
Read-Only Access Rights | List names of folders and files Browse hierarchies of folders Display the contents of folders and files Run executable files
Full Access Rights | Create and delete folders Add files to folders Create, modify, and delete files Change file attributes (Includes read permissions)
Custom Access Rights | Depending on the options specified, allows users to perform the following actions: Read files Write to files Create files and folders Delete files Change file attributes List files Change access control
Graphic S-8. The Change Access Rights dialog box in Windows 95 and Windows 98.
Graphic S-8. The Change Access Rights dialog box in Windows 95 and Windows 98.
Windows NT 4.0 Shared Folder Permissions
Permission | What It Allows Users to Do
No Access | Connect to a share without viewing its contents
Read | List names of folders and files Browse hierarchies of folders Display the contents of folders and files Run executable files
Change | Create and delete folders Create, modify, and delete files Change file attributes Includes read permissions
Full Control | Take ownership of files on NTFS volumes Change file permissions on NTFS volumes Includes read and change permissions
Graphic S-9. The Access Through Share Permissions dialog box in Windows NT 4.0.
Graphic S-9. The Access Through Share Permissions dialog box in Windows NT 4.0.
Windows 2000 Shared Folder Permissions
Permission | What It Allows Users to Do
Read | List names of folders and files Browse hierarchies of folders Display the contents of folders and files Run executable files
Change | Create and delete folders Add files to folders Create, modify, and delete files Change file attributes Includes read permissions
Full Control | Take ownership of files on NTFS volumes Change file permissions Includes read and change permissions
Graphic S-10. The Permissions dialog box in Windows 2000.
Graphic S-10. The Permissions dialog box in Windows 2000.
TIP

When you first share a folder in Windows NT and Windows 2000, the default permissions are Full Control for the Everyone group. You should remove this default permission and assign more appropriate permissions to the share, such as change permission for Domain Users and full control for Administrators.

When you assign permissions to shared folders, use group accounts instead of user accounts in order to simplify administration. Give users the most restrictive permissions that still enable them to perform the necessary tasks on the files in the share.

See also
NTFS permissions (Windows 2000), NTFS permissions (Windows NT), share

Shared Folders

An administrative snap-in for Microsoft Windows 2000 that lets you monitor and manage access to resources on the network. Shared Folders can be installed in a new console or accessed from the System Tools node in the Computer Management administrative tool.

How It Works

The function of Shared Folders is similar to that of the Server Manager administrative tool in Microsoft Windows NT. You can use Shared Folders to perform the following actions on either the local or the remote servers on the network:

  • View users currently connected to network resources and disconnect them from these resources

  • Send administrative messages to users before you disconnect them from network resources

  • View files currently opened by remote users and close them

  • Share folders on remote computers

  • Create, view, and configure permissions on network shares

  • Configure a Macintosh-accessible volume

    Graphic S-11. Shared Folders.
    Graphic S-11. Shared Folders.
NOTE

To use Shared Folders to manage all computers in a given domain, you must be a member of the Administrators or Server Operators group for that domain. If you want to manage only a specific member server, you must be a member of the Administrators or Power Users group for that member server.

TIP

Monitoring access to network resources with the Shared Folders administrative snap-in can help you do the following:

  • Plan for future system growth to satisfy current trends in resource usage

  • Monitor access to resources for security reasons

  • Notify users who will be disconnected from resources during scheduled or unscheduled system maintenance operations

There are several reasons why you might want to disconnect users from resources on the network:

  • The server needs to be shut down for maintenance or rebooted for some reason (such as a hardware or software upgrade).

  • Idle connections to the resource are preventing access by other users because the maximum number of connections to the resource has been reached.

  • Shared folder or NTFS permissions have been changed on the resource, and users must be disconnected so that the new permissions will apply to them.

  • Unauthorized users are accessing resources for which they have been accidentally granted permission.

shared SCSI bus

In Microsoft Cluster Services (MSCS), a shared storage bus that attaches one or more Small Computer System Interface (SCSI) disk drives containing data that can be used by applications running on the cluster. The shared SCSI bus logically represents the total interconnection between the cluster and the shared storage devices, but in practice this consists of a number of electrically separate SCSI bus segments. Each disk on a shared SCSI bus is owned by only one of the cluster’s nodes. If the disk group fails over, ownership of the disk switches from the failed node to the other node.

TIP

Remove the internal termination of the SCSI bus and use Y-cables or trilink connectors for terminating the external bus. In this way, you can remove the device if maintenance is required without affecting other devices on the bus.

share-level security

A mode of security on computers running Microsoft Windows 95 and Windows 98 that protects shared folders and printers using a password. All users use the same password to access the resource, and any user who knows the password has permission to use the resource.

How It Works

Security options for protecting a shared folder using share-level security include

  • Allowing read-only access, with or without a password

  • Allowing full access, with or without a password

  • Specifying one password for read-only access and another for full access

Share-level security is often used in peer-to-peer networks with computers running Windows 95 or Windows 98. Use the Network utility in Control Panel to enable share-level security.

Graphic S-12. The Sharing tab of a folder’s Properties dialog box.
Graphic S-12. The Sharing tab of a folder’s Properties dialog box.
See also
user-level security

shell

Another name for a user interface of an operating system. The term “shell” usually refers to the command-line interface (called the command interpreter) used by various flavors of the UNIX operating system, but on Microsoft Windows platforms the desktop graphical user interface (GUI) element can also be considered a type of shell.

How It Works

In a UNIX command-line shell, when a user types a command such as ls (list directory contents), the shell executes the associated program called ls. When the shell executes the command, it typically starts a new process for the command and goes into a sleep state until the command finishes executing, at which time the shell wakes up and issues a prompt to indicate that it is ready to receive another command. The output of shell commands is directed by default to Standard Output, which is the screen, but you can redirect command outputs to files and other applications. One advantage of using a command-line shell is that shell scripts can be written for batch execution of a series of shell commands.

Various shells are available for different UNIX platforms, each tailored to a different administration and programming environment. One commonly used shell is the Bourne Shell, which functions as both a command interpreter and a high-level programming language in which shell scripts can be used to automate groups of processes. Other UNIX shells include the C Shell of System V UNIX, which includes job control and command history mechanisms, and the Korn shell, which supports command-line editing.

NOTE

The command prompt in Windows provides similar functionality to UNIX shells, although scripting capabilities are more limited because they are based on the MS-DOS command language. The Windows Script Host (WSH) overcomes these limitations by supporting higher-level scripting languages such as Microsoft Visual Basic, Scripting Edition (VBScript), and JScript.

The term “shell” refers to the external user-accessible portion of an operating system, while the term “kernel” refers to the stuff under the hood that is normally hidden from the user.

UNIX shell scripts are called batch files in Windows programming environments. In an IBM mainframe environment, they are called EXECs.

shielded twisted-pair (STP) cabling

Twisted-pair cabling with additional shielding to reduce crosstalk and other forms of electromagnetic interference (EMI). The outer insulating jacket contains an inner braided copper mesh to shield the pairs of twisted cables, which themselves are wrapped in foil. Shielded twisted-pair (STP) cabling is more expensive than unshielded twisted-pair (UTP) cabling. It has an impedance of 150 ohms, has a maximum length of 90 meters, and is used primarily in networking environments with a high amount of EMI due to motors, air conditioners, power lines, or other noisy electrical components. STP cabling is the default type of cabling for IBM Token Ring networks.

STP cabling comes in various grades or categories defined by the EIA/TIA wiring standards, as shown in the following table.

STP Cabling Categories
Category | Description
IBM Type 1 | Token Ring transmissions on AWG #22 wire up to 20 Mbps
IBM Type 1A | Fiber Distributed Data Interface (FDDI), Copper Distributed Data Interface (CDDI), and Asynchronous Transfer Mode (ATM) transmission up to 300 Mbps
IBM Type 2A | Hybrid combination of STP data cable and CAT3 voice cable in one jacket
IBM Type 6A | AWG #26 patch cables
See also
unshielded twisted-pair (UTP) cabling

shielding

Metallic material added to cabling to reduce susceptibility to noise due to electromagnetic interference (EMI). Shielding usually takes one of two forms:

  • A braided copper or aluminum mesh enclosing the signal-carrying wires. This type of shielding offers superior performance and should be used in industrial areas where heavy machinery generates a lot of EMI.

  • An aluminum foil sleeve that encloses individual wires or the entire wire bundle. This kind of shielding is more suitable for office environments to shield against noise due to air conditioners, fans, and other motors.

For best performance, you can combine both kinds of shielding. An additional uninsulated drain wire is sometimes used to terminate the shield; it runs the length of the wire in contact with the foil sleeve or mesh. Shielded cabling is generally more expensive than unshielded cabling.

See also
coaxial cabling, shielded twisted-pair (STP) cabling

short

A condition that occurs when signal-carrying conductors make contact. The effect of a short is similar to having a break in the cable—network communication ceases. To find or isolate a short, use a cable tester or time domain reflectometer. Cable shorts can occur only in copper cables, not fiber-optic cables, although breaks can occur in fiber-optic cables.

Shortest Path First (SPF)

Also called the Dijkstra algorithm, a routing algorithm in which a router computes the shortest path between each pair of nodes in the network. The Open Shortest Path First (OSPF) Protocol is based on the Shortest Path First (SPF) algorithm.

How It Works

When an OSPF router is initialized, it sends a Hello message to determine whether it has any neighbors (routers that have an interface on the same network). Neighbors respond to the initiating router by using the same Hello packets. In fact, these Hello packets also serve to tell other routers that the transmitting router is still alive (keep-alive function). If more than two OSPF routers are on the internetwork, the Hello protocol causes one of the routers to be designated as the one to send out link state advertisements (LSAs) to all other routers on the network.

Neighbors then synchronize their topological databases with each other to become “adjacent” routers. Each router periodically floods the network with cost information for its adjacent nodes in the form of LSAs, allowing them to compile complete tables of network connections and calculate the path of least cost between any two nodes. Finally, each router analyzes its own database of network topology information and uses it to determine a shortest-path tree using itself as the root; from this tree, it derives a routing table for itself.

See also
Open Shortest Path First (OSPF) Protocol

Short Message Service (SMS)

A service for sending short text messages using the Global System for Mobile Communications (GSM) cellular telephone system. Short Message Service (SMS) can send short messages of up to 160 alphanumeric characters.

How It Works

SMS works as a store-and-forward service in which messages that are sent are stored at an SMS messaging center until the recipient can connect and receive them. SMS offers an advantage over paging systems in that it notifies the sender when the recipient has received the message. SMS allows messages to be sent or received simultaneously with voice, fax, or data transmission over GSM systems because it uses a separate signaling path instead of a dedicated channel. SMS thus works reliably even during peak usage periods of cellular systems.

Some SMS systems support compression to increase the amount of information that can be included in a message. You can also concatenate messages to create one message from several message fragments.

To use SMS, the user needs a subscription to a GSM bearer that supports SMS and a cell phone that supports SMS. The SMS function must be enabled for that user. (A subscription charge usually covers this.) SMS services are most widely deployed in Europe; more than 1 billion messages per month were sent in 1999.

S-HTTP

See
Secure Hypertext Transfer Protocol (S-HTTP)

shut down

To close a program or operating system in a way that ensures that no data is lost and that the system is not corrupted. To properly shut down a computer running Microsoft Windows 2000, choose Shut Down from the Start menu. Windows 2000 then performs the following actions:

  • Closes all open files

  • Saves operating system data

  • Prepares the system to be powered off

NOTE

If Windows 2000 is shut down improperly (through a power failure, for example), a utility called autochk.exe runs upon reboot to check and repair any volumes that are marked as dirty.

SID

See
security identifier (SID)

signal

An electrical transmission of alternating current (AC) on network cabling that is generated by a networking component such as a network interface card (NIC). Signals are purposeful transmissions, as opposed to noise, which is an undesirable transmission from other components or the environment.

In the networking environment, all electrical signals are digital except when the following devices are used:

  • Modems:
    Convert the digital signal from the serial port of a computer to an analog signal for transmission as audible sound waves over a phone line

  • Digital cellular phones:
    Convert the analog signal of sound waves produced by human speech into digital electrical pulses by sampling the sound wave at discrete intervals

Digital signals are essentially square waves, but they must also be encoded using line code, which represents binary information using discrete voltages.

signaling

In wide area network (WAN) technologies, the process of the components at either end of the WAN link communicating with each other to establish common timing and signal-flow settings. Signaling occurs before a communication session is established and before data is actually sent over the link. Signaling also refers to the period in which control information is exchanged during an established communication session.

Session-establishment signaling between telecommunications devices generally has a certain degree of latency. That is, it takes time for sessions to be negotiated and established before data can be sent. For example, analog modems typically take 15–30 seconds from dial-up until the connection is established, and Integrated Services Digital Network (ISDN) dial-up services sometimes take only 1–2 seconds to establish a connection.

Signaling between telecommunications devices generally takes place by one of two methods:

  • In-band signaling:
    The signaling information is sent in the same communication channel as the data itself.

  • Out-of-band signaling:
    The signaling happens on a separate channel, usually a separate pair of wires.

signal loss

The loss of strength of a signal as it propagates over a medium. Generally, the term refers to loss of signal strength in guided media such as copper cabling and fiber-optic cabling. Unguided media such as wireless networking technologies have signals that decrease in power per unit area primarily because of the inverse square law.

How It Works

A number of mechanisms can cause signal loss in a wire or cable:

  • Attenuation:
    Caused by resistive losses in the cable and affects only copper cabling

  • Absorption:
    Causes signal loss in fiber cabling because the glass core material is not perfectly transparent

  • Fractures:
    Can result in both attenuation and absorption of signal strength

  • Splices, connectors, and couplings:
    Involve dissimilar materials joined together and generally produce some loss

Signal loss is generally expressed in units of decibels (dB) per source of the loss. The following table shows typical signal loss values for fiber-optic cabling. These rough values are useful for estimating total signal loss, which you calculate by simply adding the loss for each element in the light path.

Signal Loss Values for Fiber-Optic Cabling
Source of Loss | Approximate Signal Loss
Connector loss | 3 dB/termination
Coupling loss | 2 dB/coupler
Intrinsic loss | 6 dB/1000 meters
Microbending loss | Increases with decreasing bend radius
Splice loss | 4 dB/splice
TIP

The total end-to-end signal loss of a light path through a fiber-optic cabling system is known as the optical power budget. If this value is greater than the power launch rating of your line driver, your system won’t work.

Simple Mail Transfer Protocol (SMTP)

A standard application-layer protocol for delivery of e-mail over a TCP/IP internetwork such as the Internet. The basics of Simple Mail Transfer Protocol (SMTP) are defined in Request for Comments (RFC) 821 and 822.

How It Works

SMTP defines the format for messages sent between TCP/IP hosts on the Internet. SMTP uses plain 7-bit ASCII text to send e-mail messages and to issue SMTP commands to receiving hosts. Multipurpose Internet Mail Extensions (MIME) is typically used to encode multipart binary files including attachments into a form that SMTP can handle.

SMTP provides a mechanism for forwarding e-mail from one TCP/IP host to another over the Internet. SMTP services running on a TCP/IP host first establish a connection to a remote host using Transmission Control Protocol (TCP) port 25. An SMTP session is then initiated by sending a helo command and receiving an OK response. The sending computer then uses the following commands to send messages:

  • Mail fr:
    Identifies the sending host to the receiving host

  • Rcpt to:
    Identifies the targeted message recipient to the receiving host by using the Domain Name System (DNS) format user@DNSdomain

  • Data:
    Initiates the sending of the message body as a series of lines of ASCII text, ending with a single period (.) alone on a line

  • Quit:
    Closes the SMTP connection

NOTE

SMTP provides message transport only from one SMTP host to another. Support for storing messages in mailboxes is provided by Post Office Protocol version 3 (POP3) and Internet Mail Access Protocol version 4 (IMAP4).

TIP

To implement SMTP on a Microsoft Exchange Server messaging network, install and configure the Internet Mail Service. To troubleshoot problems with remote SMTP servers, use Telnet to connect to port 25, try issuing various SMTP commands (such as the ones described in this entry), and examine the results. The SMTP service on Internet Information Server (IIS) version 4 functions only as an SMTP mail delivery agent (SMTP host) and does not have any provision for creating user mailboxes.

Simple Network Management Protocol (SNMP)

An Internet-standard application layer (layer 7) protocol for exchanging device management information between network devices on a TCP/IP network. Simple Network Management Protocol (SNMP) is most often used for collecting statistical and configuration information about network devices such as computers, hubs, switches, routers, and even network printers. The statistical information includes the number of packets or frames sent or received per second, the number of errors per second, and so on. The configuration information includes the IP address of an interface on the device, the version of the operating system running on the device, and so on. Management systems are used to monitor network health, trap errors, perform diagnostics, and generate reports. SNMP is the most popular network management protocol in use.

How It Works

A network configured to use SNMP version 1 essentially consists of two components that work together:

  • SNMP agents, which are programs that run on the network devices to be managed (called managed devices) and that collect TCP/IP-related configuration information and statistics about the operation of the device. Agents do not require heavy CPU usage to run. The types of information that an agent can collect are defined in a local database called a Management Information Base (MIB). MIB databases are hierarchical and contain managed objects that have uniquely assigned identifiers issued by the International Organization for Standardization (ISO). SNMP variables are specific instances of managed objects in MIBs. Agents running on managed devices monitor specific sets of SNMP variables and temporarily store this information until the agent is polled by a management system, whereupon the agent reports the values of the stored information to the management system. Most network devices have built-in SNMP agent software and associated MIBs.

  • SNMP Management Systems software (also called Network Management System, or NMS, software), which runs on an administrator workstation and can display data gathered from managed devices in a user-friendly form through a graphical user interface (GUI). SNMP Management Systems software can notify the administrator when certain conditions (such as errors) occur. Most SNMP management systems can also automatically determine the topology and components of a network with SNMP-enabled computers, routers, hubs, and switches and can display network topology, traffic, and conditions in graphical format. SNMP management systems regularly poll managed devices using SNMP messages for statistical and configuration information and then store this information in a central database, which can be used to present the information in a friendly way to users.

SNMP messages contain a header and a payload called the Protocol Data Unit (PDU). The header contains information about the community being referenced. A community is a subset of agents that will be monitored using a specific management system and institutes a primitive level of security. A community name is used for purposes of authentication, and SNMP communication is performed using User Datagram Protocol (UDP) port number 161.

SNMP messages come in four types, three of which are issued by management stations and one of which is executed by agents:

  • Get message:
    Issued by the management system to an agent on a managed device to read the value of a specific variable on the device.

  • Getnext message:
    Issued by the management system to determine which SNMP variables are supported by an agent running on a managed device and to traverse a series of variables to read their values sequentially.

  • Set message:
    Issued by the management system to an agent on a managed device to write a value for a specific variable on the device.

  • Trap message:
    Issued by an agent running on a managed device when an error or alert condition occurs. The trap message is sent to the management system to alert administrators of the situation.

The management station regularly sends get, getnext, and set messages to the SNMP agent on the managed device, in effect periodically polling the agent for the status of the device. The agent verifies the community name in the message, verifies the IP address or host name of the SNMP management system, processes the request, and sends the results to the management system.

Graphic S-13. Simple Network Management Protocol (SNMP).
Graphic S-13. Simple Network Management Protocol (SNMP).
NOTE

SNMP version 2 adds additional security features, can be applied to network architectures other than TCP/IP, and supports additional data types. It is only partially backward compatible with SNMP 1. SNMP 2 also defines two additional types of messages:

  • Getbulk message:
    Similar to getnext but allows the retrieval of greater amounts of information in one data block

  • Inform message:
    Allows management systems to send information to other management systems using a trap-like message

Microsoft’s implementation of TCP/IP on Microsoft Windows NT and Windows 2000 includes agents and MIBs for collecting information on TCP/IP conditions and statistics.

See also
Management Information Base (MIB)

simple volume

In Microsoft Windows 2000, a volume created using the Disk Management portion of the Computer Management tool that is made up of one or more contiguous blocks of free disk space on a single physical disk. You can extend simple volumes to include additional free disk space from the initial drive or from other drives, forming a spanned volume. You can create simple volumes only on dynamic volumes created using Disk Management. Simple volumes have no fault tolerance but can be mirrored to form mirrored volumes.

simplex

A form of communication in which signals are sent in only one direction. This is different from duplex transmission, in which signals can simultaneously be sent and received by a station, and from half-duplex transmission, in which signals can be sent or received but not both at the same time. Simplex transmission occurs in many common communication applications, the most obvious being broadcast and cable television. It is not used in true network communication because stations on a network generally need to communicate both ways. Some forms of network communication might seem to be simplex in nature, such as streaming audio or video, but the communication actually takes place using bidirectional network traffic, usually Transmission Control Protocol (TCP) traffic. Simplex communication is not included in the V series recommendations of the International Telecommunication Union (ITU).

See also
duplex, half-duplex

single domain model

A domain model used in small to mid-sized Microsoft Windows NT–based networks. In the single domain model, all global users and group accounts reside in a single domain and all network resources reside in the same domain. The single domain model is simple to implement and offers centralized administration of accounts and resources. The model works for as many as 40,000 accounts, although it performs poorly with large numbers of accounts.

TIP

When you upgrade a Windows NT–based network based on the single domain model to a Microsoft Windows 2000–based network, you usually end up with a single domain in Active Directory. You can then use Active Directory to create organizational units (OUs) to organize your network and assign administrative rights and permissions.

See also
complete trust model, master domain, multiple master domain model

single master domain model

A domain model used in enterprise-level Microsoft Windows NT–based networks. In the single master domain model, all global users and group accounts reside in a single Windows NT domain called the accounts domain. Network resources reside in other domains called resource domains. Each resource domain must have a trust relationship with the accounts domain. Users who log on to their accounts in the accounts domain can access shared network resources in any resource domain if they have the appropriate permissions. The advantages and disadvantages of using this model are shown in the following table.

Pros and Cons of the Single Master Domain Model
Pros | Cons
Not difficult to implement—one trust per resource domain | Poor performance when the number of accounts is large
Centralized administration of accounts | Local groups must be created in each resource domain
Resource domains manage their own resources |
Works for up to 40,000 accounts |
Graphic S-14. Single master domain model.
Graphic S-14. Single master domain model.
TIP

When you upgrade a Windows NT–based network based on the single master domain model to a Microsoft Windows 2000–based network, you usually perform the upgrade from the top down. You first upgrade the master domain to a Windows 2000 domain based on Active Directory. Then you upgrade resource domains to child domains within a directory tree whose root domain is the former master domain. You can move user accounts from the master domain to the domains where users actually work, because two-way transitive trusts enable users in any domain within the domain tree to access resources in any other domain.

Alternatively, companies with a centralized IT department can upgrade both the master domain and the resource domains to a single Windows 2000 domain. Organizational units (OUs) can then be created within Active Directory to mirror the administrative structure of the former master domain model. Administrative rights and permissions can be assigned to users and groups based on the new OUs. Here are the advantages of using this approach:

  • One domain to manage

  • No trust relationships to create or manage

  • Faster searching because all directory objects reside in a single domain

See also
complete trust model, multiple master domain model, single domain model

single-mode fiber-optic cabling

A type of fiber-optic cabling that can carry only one signal at a time. Single-mode fiber-optic cabling uses light generated by a laser-emitting diode to carry signals. Laser light is extremely stable and uniform and can be accurately focused, making it perfect for long-distance transmission. Single-mode fiber has extremely low signal attenuation and is typically used for long cable runs because it can generally carry signals up to 50 times farther than multimode fiber, which can carry many different signals simultaneously. Single-mode fiber typically has a core that is only 5 or 10 micrometers in diameter—much smaller than the core of multimode fiber, which needs room to carry many different light signals simultaneously.

TIP

Use single-mode fiber-optic cabling for long cable runs or where extra bandwidth is required. The bandwidth of single-mode fiber is typically double that of multimode fiber. Be aware, however, that installing single-mode fiber requires more care and expertise to avoid signal loss, especially if you terminate the cable with connectors. Single-mode fiber is also more expensive than multimode because multimode systems use transmitters that have cheaper light-emitting diodes, while single-mode systems use more expensive laser-emitting diodes in their transmitters. Also, when you use single-mode fiber-optic cabling, the ancillary devices such as line drivers cost more.

See also
fiber-optic cabling, multimode fiber-optic cabling

site administrator

In Microsoft Site Server, a user who is responsible for building and managing the Web site infrastructure and administering the overall Web publishing process. Site administrators ensure that content has been properly submitted by content authors and approved by site editors before it is deployed to destination Web servers.

Site administrators usually stage content on one or more staging servers so that it can be thoroughly tested before final deployment to one or many destination Web servers on the corporate intranet or the Internet.

Site Connector

A connector in Microsoft Exchange Server that is the simplest and most efficient way to connect Exchange sites and swap messages. The Site Connector enables Exchange servers in different sites to exchange e-mail messages in their native Exchange message format. No message conversion takes place, which saves time and processing power. Messages are sent using remote procedure calls (RPCs), and no connection schedule needs to be specified. Because Site Connectors use RPCs, sites must be connected with a dedicated connection that is always on, such as a local area network (LAN) connection or leased-line wide area network (WAN) link. The Site Connector also includes automatic features for enabling load balancing and fault tolerance.

Administrators who have the Permissions Admin role can configure Site Connectors at both ends of a LAN or WAN link. When you install a Site Connector, you can specify the following:

  • A bridgehead server in one or both sites that acts as a fixed endpoint of the messaging link between the sites and maintains connectivity between the sites

  • A list of target servers that specify which servers in the remote site can have messages routed to them by the Site Connector

site group

In Microsoft Systems Management Server (SMS), an alias for a set of sites. You use site groups to limit jobs to a specific set of sites. For example, if you want to distribute software to servers at all your sales sites, you can create a site group that contains all sales sites in your company and then use this group to limit the scope of the job to servers at only those sites. You can also use site groups to limit the scope of a query or an alert.

site in Microsoft Exchange Server

Two or more computers running Microsoft Exchange Server linked together by local area network (LAN) or high-speed wide area network (WAN) connections. The servers share the same directory information and work together to provide message routing and delivery services for all users in the site. Exchange sites are usually geographically determined by city, state, country, or continent, depending on the scope of the enterprise. In the Exchange directory hierarchy, the Site container contains the site Configuration container and the site Recipients container.

NOTE

The following conditions are necessary for Exchange servers to exist in the same site:

  • Servers in the same site must have permanent network connections between them with remote procedure call (RPC) connectivity.

  • Servers in the same site must run under the same service account. (They must have a common security context.)

  • Available network bandwidth must be sufficient for messaging and directory synchronization.

site in Microsoft Systems Management Server (SMS)

A collection of domains and computers that are managed together. A Microsoft Systems Management Server (SMS) system has one central site and a hierarchy of subsites under it. The central site can be used to manage all other sites.

There are six kinds of SMS sites in an SMS system:

  • Central site:
    A primary site at the top of the site hierarchy

  • Primary site:
    A site that locally stores system data for itself and for its subsites in a Microsoft SQL Server database

  • Secondary site:
    A site without a database that reports its information to a primary site

  • Parent site:
    Any site that includes other sites beneath it in the site hierarchy

  • Child site:
    Any site that reports its information to another site in the hierarchy

  • Subsite:
    Any site beneath another site in the site hierarchy, regardless of whether it has a parent/child relationship with that site

The central site for an SMS system is always a primary site. If you log on to an SMS database for any site to which you have network access and the appropriate permissions, you can administer that site and all its subsites. If you log on to the central site, you can administer your entire network using SMS.

site in Windows 2000

A collection of computers that are grouped together to optimize the performance of domain controllers. Sites are typically defined by geographical location and are connected by slower wide area network (WAN) links. At least one domain controller must be located at each site, thus ensuring that Active Directory runs at each site. Sites generally belong to one or more Internet Protocol (IP) subnets, and computers within a site are joined by high-speed networking connections.

How It Works

You define sites to manage and reduce Active Directory logon and directory replication traffic on the network. For example, when a user tries to log on to a Microsoft Windows 2000–based network, authentication is automatically attempted first by domain controllers in the site where the user is located. To optimize logon and replication traffic, sites should be groupings of servers connected by local area network (LAN) or high-speed permanent WAN links. You can create sites to control which domain controllers a group of workstations will use for network logons.

Sites contain two types of Active Directory objects: servers and connections. These objects are used to configure Active Directory replication. You can schedule replication traffic between sites to occur at off-hours to reduce network congestion. Replication traffic within a site (intrasite replication) uses remote procedure calls (RPCs) with dynamically assigned port numbers. Replication between sites (intersite replication) can use either TCP/IP or Simple Mail Transfer Protocol (SMTP) messages.

The topology of each site is stored in Active Directory. A site can contain domain controllers from several domains, and domain controllers from a particular domain might be located in several different sites. You can create sites by using Active Directory Sites and Services, a snap-in for Microsoft Management Console (MMC). A default site is created the first time the Active Directory Installation Wizard is run to create the first (root) domain controller of your enterprise.

To create additional sites, take the following steps:

  1. Create a new site by using Active Directory Sites and Services.

  2. Create a subnet (or use an existing one) and associate it with the site to indicate which portion of your network is associated with the site.

  3. Create a site link (or use an existing one) that represents a connection between your new site and existing sites. Configure the transport, sites, cost, and schedule attributes of the site link as desired.

  4. If desired, create a site link bridge to reduce the number of site links that you need to create for your new site.

  5. Create a connection object using the Knowledge Consistency Checker (KCC) across each site link between domain controllers in your new site and in linked sites.

  6. Place domain controllers and global catalog servers in your new site as desired.

NOTE

Sites are not part of the Domain Name System (DNS) namespace for an Active Directory implementation.

TIP

Try to limit the number of sites you use in your enterprise. Geographically separate locations of your company that do not need domain controllers should be part of larger sites instead of separate sites. There is no real advantage to defining multiple sites at a single physical location, and there are disadvantages to doing so. For example, if all domain controllers in one site become temporarily unavailable, workstations in that site will try to be authenticated from any other domain controller in the domain, even if the domain controller is in a remote site. Once a workstation finds a domain controller that responds to it, it will continue using that domain controller for all subsequent logons. This can cause unwanted WAN traffic because Windows 2000 does not keep track of which sites are “near” a given site in regard to network connectivity and speed.

Planning a site topology for your enterprise generally involves balancing good logon traffic with good replication traffic. Be sure to take into account the available bandwidth of physical network links between locations when you plan sites.

Site Server Express

See
Microsoft Site Server Express

SLA

See
service-level agreement (SLA)

SLIP

See
Serial Line Internet Protocol (SLIP)

Small Business Server

See
Microsoft BackOffice Small Business Server

Small Business Server Console

The primary administration tool for Microsoft BackOffice Small Business Server. The Small Business Server Console provides a consistent and unified wizard-based administration interface for integrated, day-to-day management of Small Business Server users, services, and resources. By deliberately hiding advanced Microsoft Windows NT concepts such as permissions and rights, the Small Business Server administrator can focus on day-to-day administration of server resources and doesn’t need to learn those new concepts.

The Small Business Server Console facilitates task-based administration that doesn’t rely on the use of applications. For example, to create a distribution list, you simply click the console button labeled Create New Distribution List instead of using the Exchange Administrator program. You use the Task page for frequently used management tasks; you use the More Tasks page for less commonly used tasks. Some tasks are also accessible from multiple pages in the console, with hyperlinks between related tasks. This eliminates flipping between console pages and speeds common administration tasks.

Wizards throughout the console guide you through the steps required to complete a selected task. For example, if you want to add a new user, a wizard leads you through the steps of creating and configuring the new account so that you do not have to use the User Manager for Domains administrative tool. By default, new users are granted access to common shared resources such as company folders, printers, faxes, the Internet, and dial-up networking.

Small Computer System Interface (SCSI)

A hardware bus specification for connecting peripherals to a computer using a parallel transmission interface. The Small Computer System Interface (SCSI) was developed by Apple and is widely used in the PC world for high-end storage solutions. Microsoft Cluster Server (MSCS) uses a shared SCSI bus to provide failover support for two computers on which Microsoft Windows NT Server, Enterprise Edition is installed.

How It Works

To implement SCSI on a system, you use a SCSI adapter to interface with the system bus, suitable SCSI devices such as SCSI hard drives, SCSI cables to daisy-chain the devices, and SCSI terminators for the ends of the bus. Each device on a SCSI bus must have a SCSI device ID number assigned to it, allowing SCSI to be used for daisy-chaining a number of devices together on a single parallel bus. You can change SCSI IDs by using dip switches or jumpers, or by using configuration software.

SCSI devices come in two basic types:

  • Single-ended devices:
    Use one data lead and one ground lead to establish single-ended signal transmission over the bus. This type of device is more prone to the effects of noise and is less forgiving of cable lengths beyond specifications.

  • Differential devices:
    Use two data leads, neither of which are at ground potential. These devices are generally more expensive but are resistant to the effects of noise and can often function over distances that exceed the SCSI specifications.

The SCSI interface comes in several varieties, including the following:

  • SCSI-1:
    The original 1986 SCSI standard that supports transmission rates of 5 Mbps over an 8-bit bus for up to seven daisy-chained devices. SCSI-1 cables typically use Centronics 50 or Telco 50 connectors. The chained bus length must not exceed 6 meters (20 feet).

  • SCSI-2:
    Sometimes referred to as Plain SCSI, which is a common SCSI standard that supports transmission rates of 5 Mbps over an 8-bit bus for up to seven daisy-chained devices. SCSI-2 cables typically use Micro DB50 connectors. Fast SCSI is a variant that supports 10-Mbps transmission rates, while Fast Wide SCSI uses a 16-bit bus and supports 20-Mbps rates. The chained bus length must not exceed 6 meters (20 feet) for regular SCSI-2, and 3 meters (10 feet) for Fast SCSI.

  • SCSI-3:
    Also called Ultra SCSI, which is a SCSI standard that supports transmission rates of 20 to 40 Mbps over an 8-bit or 16-bit bus for up to 15 daisy-chained devices. SCSI-3 cables typically use MicroD 68-pin or Mini 68 connectors.

  • SCSI-5:
    Also called Very High Density Connector Interface (VHDCI), which is a SCSI standard similar to SCSI-3 but uses a smaller 0.8 millimeter connector.

    Graphic S-15. Four varieties of SCSI interface.
    Graphic S-15. Four varieties of SCSI interface.
NOTE

Eight-bit SCSI data paths are referred to as “narrow” paths, and 16-bit data paths are called “wide” paths.

TIP

SCSI cables must always be properly terminated in order for devices to be properly recognized; they should also use high-quality active terminators. Diagnostic terminators that help identify problems in signal quality are also available.

Always use the shortest cable possible for SCSI connections, because longer cables cause signals to weaken and are more affected by noise due to electromagnetic interference (EMI). When you calculate the total length of the SCSI bus, add the lengths of all the SCSI cable segments plus any internal SCSI cabling.

Be sure that all devices on a SCSI bus are configured for either single-ended or differential transmission—do not mix these methods on a single bus. You can connect single-ended devices to differential transmission devices only by using a signal converter. If you don’t use a signal converter, your SCSI devices might be damaged by unexpected voltages.

smart host

A Simple Mail Transfer Protocol (SMTP) host through which a company routes all its outgoing messages. The SMTP service of Internet Information Services (IIS) on Microsoft Windows 2000 can forward all outbound messages to a specified smart host. You can also configure the Internet Mail Service on Microsoft Exchange Server to forward all outgoing SMTP mail to a specific SMTP host on the Internet. Exchange Server itself can also function as a smart host for other SMTP mail servers. By using a smart host, you can offload some of the SMTP mail processing functions of your corporate SMTP mail server.

SMB

See
Server Message Block (SMB)

SMDS

See
Switched Multimegabit Data Services (SMDS)

S/MIME

See
Secure/Multipurpose Internet Mail Extensions (S/MIME)

SMS

See
Microsoft Systems Management Server (SMS), Short Message Service (SMS)

SMS Service Manager

See
Systems Management Server Service Manager

SMTP

See
Simple Mail Transfer Protocol (SMTP)

SMTP service

A service installed when Internet Information Services (IIS) is installed on a computer running Microsoft Windows NT Server or Windows 2000 Server. The SMTP service is managed through a snap-in extension for the Microsoft Management Console (MMC) and is dedicated to the delivery of SMTP mail using the Simple Mail Transfer Protocol (SMTP). The SMTP service has no facility for creating user mailboxes, so it cannot function as a stand-alone mail server. One common use for this service is to enable Active Server Pages (ASP) applications to send SMTP mail in response to a form submission.

SNA

See
Systems Network Architecture (SNA)

SNADS

Stands for SNA Distribution Services, the e-mail messaging transport protocol for IBM’s Systems Network Architecture (SNA). SNADS is a mainframe host-based messaging system that is commonly used in SNA networking environments. Microsoft Exchange Server includes a connector for enabling messaging connectivity between SNADS mail systems and Exchange servers. You can use Microsoft SNA Server to provide the underlying network connectivity for this connector to function. The SNADS connector allows Exchange Server to leverage the functionality of existing host-based messaging systems such as AS/400 and System 3x during migration to a distributed client/server-based environment.

snap-in

A component that can be loaded into the Microsoft Management Console (MMC) to provide a specific management capability in Microsoft Windows 2000 or in a Microsoft BackOffice server application. Many snap-ins are available for administering computers running Windows 2000; these include third-party snap-ins for managing installable third-party applications and services. The following table shows some of the snap-ins that come with Windows 2000. Not all of them appear in the administrative tools program group that you access from the Start menu.

Windows 2000 Snap-Ins
Snap-In | Function
Active Directory Users and Computers | Configuring Active Directory, organizing a domain, creating user and group accounts, and configuring security for networking components
Active Directory Schema | Modifying the schema
Active Directory Sites and Services | Creating and managing sites
Active Directory Domains and Trusts | Administering a domain within a domain tree
Admission Control Services Manager | Configuring Admission Control Services
Certificate Manager | Managing digital certificates and keys
Computer Management | Managing a computer and creating access to other useful snap-ins such as Disk Management and Event Viewer
Device Manager | Managing resources used by system devices
DHCP Manager | Creating and configuring Dynamic Host Configuration Protocol (DHCP) servers
Disk Defragmenter | Defragmenting disks
Disk Management | Configuring disks and volumes
DFS Manager | Configuring the Distributed file system (Dfs) for centralized management of network resources
DNS Manager | Creating and configuring Domain Name System (DNS) servers
Event Viewer | Viewing system, application, security, and other logs on local and remote computers
File Service Management | Creating shares on local and remote computers and monitoring and configuring network connections
Group Policy Editor | Creating group policy objects (GPOs) for configuring groups of computers centrally
Index Manager | Configuring indexing of directories
Internet Authentication Service | Configuring Internet Authentication Service (IAS) service and clients
Internet Information Services (IIS) | Creating and configuring World Wide Web (WWW) and File Transfer Protocol (FTP) sites
IP Security Policy Management | Configuring Internet Protocol Security (IPSec)
Local User Manager | Managing user accounts in a workgroup
Microsoft System Information | Viewing system component details
Microsoft Transaction Server | Configuring Microsoft Transaction Server (MTS)
Network Management | Managing network services and policies
Removable Storage Management | Managing removable storage devices
Routing and Remote Access Management | Configuring Routing and Remote Access Service (RRAS)
Security Configuration Editor | Creating and modifying security policies
Security Configuration Manager | Managing security policies
System Monitor Log Manager | Managing System Monitor logs
System Service Management | Monitoring, starting, and stopping services
Telephony Manager | Managing Telephony API (TAPI) applications

Snap-ins come in two types:

  • Stand-alone snap-ins (or simply “snap-ins”), which provide an associated set of administrative functions

  • Extensions, which provide additional functionality to stand-alone snap-ins

SNMP

See
Simple Network Management Protocol (SNMP)

SNMP service

The service that enables Simple Network Management Protocol (SNMP) on a computer running Microsoft Windows NT Server or Windows 2000 Server. Features of the SNMP service include the following:

  • Support for the Windows Sockets application programming interface (API)

  • Extensibility (You can add Management Information Bases through third-party dynamic-link libraries.)

  • Use of standard User Datagram Protocol (UDP) port 161

NOTE

An additional service called the SNMP Trap Service enables Windows NT to trap SNMP events such as error conditions.

See also
Simple Network Management Protocol (SNMP)

SOA record

See
start of authority (SOA) record

socket

A logical endpoint for communication between two hosts on a TCP/IP network. A socket is also an application programming interface (API) for establishing, maintaining, and tearing down communication between TCP/IP hosts. Sockets were first developed for the Berkeley UNIX platform as a way of providing support for creating virtual connections between different processes.

How It Works

Sockets provide a mechanism for building distributed network applications such as client/server applications. Two sockets form a complete bidirectional communication path between processes on two different TCP/IP hosts. Network-aware applications and services can create and destroy sockets as needed.

As an endpoint for network communication between hosts, a socket is uniquely identified by three attributes:

  • The host’s IP address

  • The type of service needed—for example, a connectionless protocol such as User Datagram Protocol (UDP) or a connection-oriented protocol such as Transmission Control Protocol (TCP)

  • The port number used by the application or service running on the host

For example, the following identifier would represent a socket for the Simple Mail Transfer Protocol (SMTP) mail service running on a host with the specified IP address. (Port 25 is the well-known port number for the SMTP service on a TCP/IP host.)

172.16.8.55 (TCP port 25)
NOTE

In the Win32 programming environment, sockets are implemented using a programming interface called Windows Sockets. Windows Sockets on Microsoft Windows platforms supports most Internet protocols and services, such as Hypertext Transfer Protocol (HTTP), File Transfer Protocol (FTP), and Telnet.

See also
Windows Sockets

SOCKS v5

A circuit-layer proxy protocol used in client/server networking environments. SOCKS lets hosts on each side of a proxy server communicate with each other by establishing a relay connection between the internal and external networks.

SOCKS also provides authentication functions for controlling access between networks. SOCKS is widely implemented in both proxy server and firewall software, especially for allowing hosts on a private network to access the Internet while preventing distrusted hosts on the Internet from accessing the private network. SOCKS v5 is defined in Request for Comments (RFC) 1928, 1929, and 1961.

How It Works

When a host on one side of a proxy server wants to connect to a host on the other side to access network resources, SOCKS server software running on the proxy server authenticates the host’s request, creates a circuit-level proxy connection to the target host, requests the necessary data, and relays the information back to the requesting host.

Graphic S-16. SOCKS v5.
Graphic S-16. SOCKS v5.

The SOCKS client on the requesting host first negotiates an authentication method with the SOCKS server, and then sends the user’s credentials to the SOCKS server for authentication.

SOCKS v5 supports a number of authentication methods, including Challenge Handshake Authentication Protocol (CHAP) and digital certificates. Once the user is authenticated, the SOCKS client sends a request message using the SOCKS protocol to the SOCKS server (the daemon or SOCKS service running on the proxy server). This request message contains the address of the target host, such as a Web server on a corporate intranet. The SOCKS server then establishes a Transmission Control Protocol (TCP) connection with the target host that functions as a proxy circuit between the requesting and target hosts. Once this “virtual circuit” is established, the SOCKS server notifies the SOCKS client and communication can begin between the two hosts, with the SOCKS server relaying each packet sent between them.

SOCKS also supports public-key encryption for secure, encrypted transmission of data.

The previous version of the protocol, SOCKS v4, was more difficult to configure on the client side and had no support for authentication of users or encryption of data. It also did not support User Datagram Protocol (UDP) traffic. SOCKS v5 is easier to configure, supports various authentication methods and encryption algorithms, and supports connectionless UDP traffic.

NOTE

To use SOCKS, you must have SOCKS-enabled client software installed on the hosts that will be communicating over the proxy server. Using SOCKS, virtual circuits are set up and torn down between the two hosts on a session-by-session basis. SOCKS servers usually include comprehensive logging functionality to analyze the flow of traffic between the trusted and distrusted networks.

TIP

To access Microsoft NetShow servers through a firewall, you must upgrade from SOCKS v4 to SOCKS v5 because NetShow uses UDP connectionless communication. Microsoft Proxy Server supports the SOCKS protocol and can act as a secure circuit-level gateway between a private network and a distrusted public network such as the Internet.

solid conductor wire

Wire that has a single solid copper core surrounded by insulation, as opposed to stranded conductor wire, which consists of many fine strands of wire woven into a conducting bundle. Unshielded twisted-pair (UTP) cabling commonly comes in both solid and stranded forms. The following table compares the advantages of these types of wire.

Solid Conductor Wire vs. Stranded Conductor Wire
Solid Conductor | Stranded Conductor
Less attenuation | More flexible
Better conductivity | Less likely to break or fracture
Easier to terminate | Longer lasting
Cheaper |

Solid conductor wire is generally used for vertical backbone cabling between wiring closets on different floors and for horizontal runs from wiring closets to wall plates in work areas on each floor. Solid cabling is also used for permanently installed long cable runs inside and between buildings because it has less attenuation than stranded conductor wire and signals can travel farther without losing strength.

See also
stranded conductor wire

SONET

See
Synchronous Optical Network (SONET)

source address

The address from which a frame or packet of data originates on a network. The source address identifies the sending host to the receiving host and is used by the receiving host as a destination address for a response packet (such as an acknowledgment). Bridges also use the source address in building their internal routing tables of media access control (MAC) addresses for determining which packets should be forwarded to other network segments.

The source address refers to one of the following:

  • The physical address, such as the MAC address of an Ethernet frame

  • The logical address, such as the IP address of an Internet Protocol (IP) packet

Source addresses always identify the specific host that transmitted the packet or frame onto the network. This is in contrast to destination addresses, which sometimes direct packets to all hosts or to a specific group of hosts on the network.

TIP

You can see the source address of a packet or frame by using a network sniffer such as Network Monitor, a tool included with Microsoft Systems Management Server (SMS). Network Monitor displays source addresses in both ASCII and hexadecimal form.

See also
destination address

source files

Files that are needed to install software and are usually on the CD supplied by the software vendor. For example, the source files for Microsoft Windows NT on an x86-based system are on the Windows NT CD in the \I386 folder, the source files for Microsoft Windows 98 are on the Windows 98 CD in the \Win98 folder, and the source files for Microsoft Windows 2000 are on the Windows 2000 CD in the \I386 folder.

TIP

By copying source files from a CD to a folder on a network server and then sharing that folder, you can create a distribution server. A network client can then connect to the distribution server and install the application or operating system without having to use a local CD-ROM drive.

spam

Unsolicited e-mail such as chain letters and advertising for services or products. To avoid getting spam, you can do the following:

  • Avoid posting messages to Usenet newsgroups.

  • Never reply to junk mail.

  • Configure filters on your mail client to filter out mail containing certain keywords.

  • Ask your Internet service provider (ISP) to configure its mail servers to reject spam.

Spam is sometimes politely referred to as unsolicited commercial e-mail (UCE).

NOTE

To prevent abuse by spammers, the SMTP service of Internet Information Server (IIS) version 4 by default does not allow Simple Mail Transfer Protocol (SMTP) mail to be relayed through it to an outside e-mail address.

TIP

If your e-mail address somehow gets on the mailing lists of spammers, you can usually configure rules on your e-mail program’s Inbox to discard mail that comes from a specific address, uses words such as “sale” or “buy” in the subject header, or has specific words or phrases in the body of the message, but this is usually a tedious and losing game. A better solution is to use the Delete key. If the situation gets really bad, see whether your mail administrator or ISP can filter out spam.

spanned volume

In Microsoft Windows 2000, a volume created using the Disk Management portion of the Computer Management tool that is made up of free space from more than one physical disk. You can extend spanned volumes by adding additional free space from other physical disks. Spanned volumes must be created on dynamic disks. They are not fault tolerant and cannot be mirrored.

NOTE

The equivalent to spanned volumes in Microsoft Windows NT is volume sets.

See also
dynamic volume

spanning tree algorithm (STA)

An algorithm implemented on bridges and some Ethernet switches that detects redundant paths in an Ethernet network and prevents traffic from endlessly looping around the network. The spanning tree algorithm (STA) allows redundant paths to be used for backup links between bridged networks to provide fault tolerance in an internetwork.

TIP

Implementing the STA on Ethernet switches can sometimes prevent clients from renewing their Dynamic Host Configuration Protocol (DHCP) lease with a DHCP server. It might take 10 or 15 seconds for the STA to check the ports on the switch for loops, and if a computer running Microsoft Windows tries to obtain a DHCP lease during this time interval, the DHCPREQUEST packet is lost. You can work around this by disabling the STA on the switch or manually releasing and renewing the computer’s IP address using ipconfig (on Windows NT and Windows 2000) or winipcfg (on Windows 95 and Windows 98).

special identity

Also sometimes known as a system group, a special group account on a computer running Microsoft Windows NT or Windows 2000 that you can use to control security and access to NTFS volumes.

How It Works

Special identities are groups whose membership is controlled by the operating system itself, not by administrators or individual users. User accounts become “members” of these special groups based on the type of system activity they participate in; you cannot modify the “membership” of these groups directly.

Special identities on Windows NT systems include the following:

  • Creator Owner:
    Consists of users who will create files or subdirectories within the current directory on an NTFS volume.

  • Everyone:
    Consists of all network users, including guests and users from distrusted domains. Granting NTFS permissions to Everyone allows anyone to access the file or directory.

  • Interactive:
    Consists of all users who log on interactively to the console of the machine or who access the NTFS file system on the machine from a local console.

  • Network:
    Consists of all users who log on to the machine from over the network or who access the NTFS file system on the machine from over the network.

  • System:
    Consists of the local operating system. System is not normally used when assigning permissions to files and directories on NTFS volumes.

Additional special identities in Windows 2000 include the following:

  • Authenticated Users:
    Consists of all users with a valid user account in the local directory database or in Active Directory. The Authenticated Users identity was also added to Windows NT 4 in Service Pack 3.

  • Anonymous Logon:
    Consists of any user accounts that Windows 2000 did not authenticate.

  • Dialup:
    Consists of any users who currently have a dial-up connection.

SPF

See
Shortest Path First (SPF)

spoofing

The process of attempting to breach a network’s security by altering the source addresses of packets, making them appear as though they came from a trusted user within the network rather than from a distrusted outside user. Spoofing is one of the methods by which hackers attempt to compromise a network’s security and is of particular concern when a network is connected to the Internet.

Because of limitations in the design of the current Internet Protocol (IP) standard, IPv4, spoofing of IP packets cannot be prevented, only protected against. One way to protect your network against IP address spoofing is to use the packet-filtering features of a router or firewall. Configure your packet-filtering router so that the input filter on the external router interface discards any packet coming from the external network whose source address makes it look like it originated from your own internal network. Similarly, configure the output filter on your internal router interface to discard any outgoing packets that have a source address different from that of your internal network to protect against spoofing attacks from within your own network.

See also
packet filtering

spooling

The process of temporarily storing documents sent for printing on a hard disk and then sending them to the print device when it is ready (or when some other criterion has been met). The application software that performs this task is called a spooler. The spooler accepts and temporarily stores documents to be printed and then sends them to the printer according to predefined conditions such as print priority and schedule. Spooling of print jobs allows control to be returned more quickly to the application that generated the job. Spooling also allows jobs to be queued when the printer is unavailable so that the application doesn’t have to generate the jobs again.

NOTE

The term “spool” is actually an acronym for Simultaneous Peripheral Operation On Line.

spread spectrum

A wireless networking technology originally developed by the U.S. military for secure wireless communication.

How It Works

Unlike other forms of wireless communication, spread spectrum technologies take advantage of a large portion of the electromagnetic spectrum, making it difficult for distrusted users to “listen in” on private conversations. Two basic mechanisms can be used to implement spread spectrum wireless communication: direct sequence technology and frequency-hopping technology.

Direct sequence technology takes an individual binary bit from the transmission signal and converts it to a binary string. This string is then transmitted as a single wideband signal over an adjacent set of frequencies, with each bit in the string transmitted at a different frequency. The receiving station examines the bit pattern of the binary string and determines which single bit was originally transmitted by the sending station. This technology has built-in fault tolerance because electromagnetic interference (EMI) might degrade a portion of the binary string, but if the receiving station can recognize a different portion of the string, communication is assured. A typical example of direct sequencing technology might be to assign the string 10011011 to bit 1 and its inverse 01100100 to bit 0. Transmission of the bit sequence 110 would then consist of three transmitted strings: 10011011, 10011011, and 01100100.

Frequency-hopping technology uses a continually changing carrier frequency. The pattern by which the carrier frequency is changed is programmed according to an algorithm known to both the sending and receiving stations. For communication to take place, the two stations must remain synchronized throughout the session. One station is designated the master station and the other the slave station. If particular frequencies within the spread spectrum communication band contain interference from other radio sources, frequency-hopping technology can avoid these frequencies by using adaptive techniques. To further enhance security, either station can also dynamically change the pattern of frequency hopping.

Spread spectrum technologies can have a variety of uses in networking, including point-to-point links between networks, wireless local area networks (LANs), and cellular-based roving network communication. One common use in networking environments is for connecting stations to a LAN when it is impractical or impossible to lay cabling. Communication is currently limited to speeds of about 2 Mbps. Spread spectrum networking systems generally use very low power signals in the high radio or low microwave portion of the electromagnetic spectrum.

Spread spectrum communication can take place in three portions of the electromagnetic spectrum allocated by the Federal Communications Commission (FCC) without special licensing for wireless devices:

  • Industrial band:
    902 to 928 MHz

  • Scientific band:
    2400 to 2483.5 MHz

  • Medical band:
    5725 to 5850 MHz

TIP

You can also use spread spectrum wireless bridge technologies to establish point-to-point or multipoint communication between buildings on a campus. These devices usually support line-of-sight connections that function to distances of 30 kilometers or more, with speed decreasing as the distance increases. Spread spectrum devices for wireless LAN stations generally have a much shorter range, usually no more than about 200 meters.

SQL

See
Structured Query Language (SQL)

SQL Client Network utility

A tool in Microsoft SQL Server 7 for configuring clients for connectivity to a server running SQL Server. In version 6 of SQL Server, this tool is called Client Configuration utility. Clients in this context are applications that act as front ends for accessing the back-end services of a server running SQL Server.

You use SQL Client Network utility to

  • Define server alias names

  • Manage client Net-Libraries

  • Configure default options for DB-Library applications

NOTE

Client Network utility is rarely needed in SQL Server 7. Usually, a client needs to specify only the network name of the server running SQL Server in order to connect to the server.

See also
SQL Server tools

SQL Enterprise Manager

See
SQL Enterprise Manager

SQL Executive

See
SQL Server Agent

SQL Mail

A utility in Microsoft SQL Server 6 that can send messages through the built-in Messaging Application Programming Interface (MAPI) of Microsoft Windows NT.

SQL Mail messages can be

  • Short strings of text

  • The output of a query

  • An attached file

By using SQL Mail extended stored procedures, you can send messages in response to events such as the following:

  • SQL Server generates an alert.

  • A performance monitor threshold is exceeded.

  • A scheduled task succeeds or fails.

NOTE

SQL Server 7 uses two services for sending mail:

  • MSSQLServer Service:
    Processes mail for mail stored procedures

  • SQLServerAgent Service:
    Has its own mail capabilities that are separate from SQL Mail

SQL Security Manager

A tool in Microsoft SQL Server 6 for managing SQL Server user accounts when you run Integrated Security. You can use SQL Security Manager to automatically copy Microsoft Windows NT user accounts to a server running SQL Server—a simple, one-step process for implementing integrated security on the server running SQL Server. By using this tool, an administrator can grant or revoke SQL Server rights to Windows NT users and groups.

How It Works

SQL Server can validate connection attempts by using three different security modes:

  • Integrated security:
    Lets SQL Server use Windows NT authentication methods for validating all network connections. Connections made using integrated security are called trusted connections. Authentication information is stored in the Security Account Manager (SAM) database on Windows NT domain controllers.

  • Standard security:
    Lets SQL Server use its own logon validation process to validate all network connections. Connections made using standard security are called distrusted connections. Authentication information is stored in the syslogins table on the server running SQL Server.

  • Mixed security:
    Lets SQL Server use either integrated security or standard security.

See also
SQL Server tools

SQL Server Agent

A collection of managers for Microsoft SQL Server 7. Called SQL Executive in version 6 of SQL Server, SQL Server Agent handles repetitive tasks and exception conditions.

SQL Server Agent allows you to

  • Schedule and automate administrative tasks to run at specific times or time intervals.

  • Send alerts to administrators when error conditions arise, such as a database running out of space. You can use e-mail or pagers for alerting purposes, or you can trigger a job to run.

  • Perform replication tasks that have been specified by administrators.

See also
SQL Server tools

SQL Server Enterprise Manager

A tool for administering Microsoft SQL Server 7. Called SQL Enterprise Manager in version 6 of SQL Server, SQL Server Enterprise Manager simplifies the task of managing SQL Server and SQL Server objects across an enterprise.

You can use this tool to

  • Manage logons, users, and permissions

  • Create and manage databases and database objects such as tables, views, indexes, rules, stored procedures, and triggers

  • Create full-text indexes

  • Import and export data to files or other database management systems

  • Back up and restore SQL databases and their associated transaction logs

  • Configure alerts and e-mail notifications for events

  • Create scripts for automating tasks

  • Perform Web administration tasks

NOTE

SQL Server Enterprise Manager is installed with SQL Server by default as a server tool on computers running Microsoft Windows NT Server and Windows 2000 Server, and as a client tool on computers running Microsoft Windows 2000 Professional, Windows NT Workstation, Windows 98, and Windows 95. SQL Server Enterprise Manager is implemented as a snap-in for Microsoft Management Console (MMC).

See also
SQL Server tools

SQL Server Profiler

An administrative tool in Microsoft SQL Server 7. Called SQL Trace in version 6 of SQL Server, SQL Server Profiler can be used to track activity on a server running SQL Server. SQL Server Profiler captures information in the form of engine events that are saved in a trace file. You can then analyze the trace file or use it to replay a series of steps that led to a problem in order to troubleshoot the exact cause of the problem. You can save the trace data to a file or to a database table for further analysis.

You typically use SQL Server Profiler to do the following:

  • Troubleshoot a series of Structured Query Language (SQL) statements by replaying them on a test server

  • Diagnose what is causing a query to execute slowly

  • Debug stored procedures by stepping through them

  • Monitor SQL Server to tune workloads

See also
SQL Server tools

SQL Server Query Analyzer

A graphical user interface (GUI) for creating and testing Structured Query Language (SQL) statements and scripts in Microsoft SQL Server 7. This tool corresponds to the ISQL_w tool in version 6 of SQL Server.

How It Works

SQL Server Query Analyzer includes a free-form text editor that you can use to create SQL statements and scripts, with syntax-dependent color-coding to improve readability. You can display the results of executing a SQL query in a window as free-form text or as a grid. SQL Query Analyzer can also use SHOWPLAN to graphically display the flow of logic in a query. You can use the Index Tuning Wizard to determine whether adding more indexes will improve query performance. You can start SQL Server Query Analyzer from SQL Server Enterprise Manager.

See also
SQL Server tools

SQL Server Service Manager

An administrative tool in Microsoft SQL Server 7 that lets you start, stop, and pause the various components of a server running SQL Server. These components are implemented as Microsoft Windows NT or Windows 2000 services on a server running SQL Server. Called SQL Service Manager in version 6 of SQL Server, this tool manages several services.

  • Microsoft Search Service, a full-text search engine

  • MSDTC Service, which is used to manage distributed transactions

  • MSSQLServer Service, the database server for SQL Server

  • SQLServerAgent Service, which runs scheduled administrative tasks

TIP

SQL Server Service Manager runs as a taskbar application and displays an icon in the system tray. Double-click this icon to maximize the program. Clicking the Close button does not terminate the program—it returns it minimized to the system tray. To exit the program, right-click the icon in the system tray and choose Exit from the File menu.

See also
SQL Server tools

SQL Server tools

Tools in Microsoft SQL Server for administering SQL servers and databases. SQL Server 7 has replaced, renamed, or dropped some of the tools in previous versions and added new ones. The following table shows some of the most commonly used SQL Server 6 tools and their new names or replacement utilities in SQL Server 7.

SQL Server Tools
SQL Server 6 | SQL Server 7
ISQL_w | SQL Server Query Analyzer
MS Query | N/A
SQL Client Configuration | SQL Client Network utility
SQL Enterprise Manager | SQL Server Enterprise Manager
SQL Security Manager | N/A
SQL Trace | SQL Server Profiler
SQL Performance Monitor | Performance Monitor
SQL Service Manager | SQL Server Service Manager
SQL Setup | SQL Server Setup
NOTE

SQL Server 7 includes the same command-line tools as those in SQL Server 6. In addition, version 7 includes a large number of wizards that simplify common SQL Server and database administration tasks. Version 7 also uses the Microsoft Management Console (MMC), while version 6 does not. The console for SQL Server 7 is SQL Server Enterprise Manager.

SQL Service Manager

See
SQL Server Service Manager

SQL Trace

See
SQL Server Profiler

SSL

See
Secure Sockets Layer (SSL)

STA

See
spanning tree algorithm (STA)

stackable hubs

Hubs that can be placed above one another on a rack and connected using special short cables to effectively form a single hub with a number of ports. Other devices, such as Ethernet switches, can also be stackable. Different vendors use different methods of stacking hubs, but they generally use some form of ribbon cable. This is superior to the older way of cascading hubs together using the uplink port, which tends to produce crosstalk.

TIP

If you stack several hubs, the top and bottom hubs usually have a free connection that must be terminated in order to function properly.

Graphic S-17. Stackable hubs.
Graphic S-17. Stackable hubs.

stand-alone server

See
member server

standard Ethernet

See
10Base5

star bus topology

A networking topology in which hubs for workgroups or departmental local area networks (LANs) are connected by using a network bus to form a single network. Star bus topology is a combination of star topology superimposed on a backbone bus topology.

Graphic S-18. Star bus topology.
Graphic S-18. Star bus topology.

You can connect hubs by using one of the following:

  • Regular 10Base2 or 10BaseT cables with uplink ports on the hubs

  • Crossover cables for regular (host) ports on the hub

  • Special cables for stackable hubs

TIP

When you use this topology with standard Ethernet hubs, do not create an excessively large collision domain by adding too many stations. This will degrade network performance unless you segment the network by using bridges or routers.

See also
bus topology, star topology

start of authority (SOA) record

The first record in a zone file, which defines the general properties of the zone for a name server.

Here is an example of a start of authority (SOA) record:

@   IN  SOA     nameserver.place.dom.  postmaster.place.dom. (
                               1            ; serial number
                               3600         ; refresh   [1h]
                               600          ; retry     [10m]
                               86400        ; expire    [1d]
                               3600 )       ; min TTL   [1h]

This SOA record contains the following information:

  • The name of the subdomain over which a particular name server has authority (nameserver.place.dom)

  • The name of the host on which this zone file resides

  • The e-mail address of the person responsible for administering the subdomain (postmaster@nameserver.place.dom)

  • A serial number, which increases when the zone data is updated and which is used in zone transfers to determine whether the secondary name server needs a new version of the zone file

  • A refresh interval, in seconds, that informs the secondary name server how frequently it should check with the master name server to see whether its zone information is current

  • A retry interval, in seconds, that tells the secondary name server how often to contact the master name server if the initial contact is unsuccessful

  • An expiry interval, in seconds, that informs the secondary name server how long to keep trying to contact the master name server for a refresh of the zone data before the data expires and the secondary name server no longer responds to name queries

  • The Time to Live (TTL), which is a value returned by the name server to resolvers when a name is resolved, informing the resolver how long it can cache the resolved name and IP address

See also
Domain Name System (DNS), resource record

star topology

A networking topology in which the components are connected by individual cables to a central unit, usually a hub. When a computer or other networking component transmits a signal to the network, the signal travels to the hub, which forwards the signal simultaneously to all other components connected to the hub.

Star topology is used to

  • Connect computers in a workgroup or departmental local area network (LAN) using a hub.

  • Connect workgroup or departmental hubs using a master hub or switch. This is a special star topology called either cascading hubs or star-wired topology.

Star topology is the most popular way to connect computers in a workgroup or departmental LAN, but it is slightly more expensive than using bus topology. One advantage of star topology is that the failure of a single computer or cable doesn’t bring down the entire LAN. This topology also centralizes networking equipment, which can reduce costs in the long run by making network management much easier.

Graphic S-19. Star topology.
Graphic S-19. Star topology.
TIP

If no one on a star network can access network resources, the hub might be down or overloaded. Try resetting the hub by using the reset switch, or try powering it off and then on. If a hub frequently needs to be reset, you might have a hardware malfunction or network bandwidth might be reaching capacity (which means that you should upgrade your components).

See also
bus topology, mesh topology, ring topology, star bus topology

Startup menu

A boot menu that appears in Microsoft Windows 95 when you press the F8 function key while the screen displays the message “Starting Windows 95…” and in Microsoft Windows 98 when you hold down the Ctrl key while the system starts. The options on this menu are generally used for troubleshooting the Windows 95 or Windows 98 boot process.

The Startup menu usually offers the following options:

  • Normal start:
    Performs a normal startup of Windows.

  • Logged start:
    Creates a bootlog.txt file that logs the steps in the boot process.

  • Safe Mode:
    Bypasses the startup files and starts the system with generic mouse, keyboard, and VGA video drivers and no network support.

  • Safe Mode With Network Support:
    The same as Safe Mode but also includes network drivers and protocols.

  • Step-by-Step Confirmation:
    Allows you to confirm each step in the boot process before it is executed. This is useful if you have a problem in your configuration and want to step around that problem to test whether the system can still boot.

  • Command Prompt Only:
    Starts Windows 95 or Windows 98 but displays only a command prompt as the shell. The user can then start Windows manually by using the win.com command.

  • Safe Mode Command Prompt Only:
    Starts the system in Safe Mode but displays the command prompt as the shell.

  • Previous Version Of MS-DOS:
    Allows the user to boot to the previously installed operating system. (This option is visible only if a previously installed operating system exists.)

NOTE

A similar boot menu called the Advanced Options menu appears in Microsoft Windows 2000 when you press the F8 key at the boot prompt, “Please select the operating system to start.”

static address

An IP address that is manually assigned to a host on a TCP/IP internetwork. Computers running Microsoft Windows support both static Internet Protocol (IP) addressing and dynamic IP addressing through the Dynamic Host Configuration Protocol (DHCP).

Static IP addresses are usually used for

  • Small workgroups whose machine configurations will not change often. Peer-to-peer networks that use Windows 95 or Windows 98 don’t have a DHCP server to assign IP addresses to stations on the network.

  • Servers on a network, which should have an IP address that does not change. An alternative is to assign a DHCP reservation to these servers so that they receive their IP addresses automatically from a DHCP server but always receive the same reserved address.

  • Windows NT–based and Windows 2000–based servers that are running certain services, such as DHCP, Windows Internet Name Service (WINS), or Domain Name System (DNS). Servers running these services normally require static IP addresses.

static mapping

On a WINS server, a manually entered NetBIOS name to IP address mapping stored in the WINS database. WINS servers normally create mappings dynamically when a WINS client performs NetBIOS name registration upon client initialization. Non-WINS clients do not register their names, so administrators must manually create WINS database entries. Once they do this, other hosts on the network can perform NetBIOS name discovery queries to resolve the NetBIOS name of non-WINS clients into their IP addresses.

See also
Windows Internet Name Service (WINS)

static routing

A routing mechanism that is handled by the Internet Protocol (IP) and that depends on manually configured routing tables. Routers that use static routing are called static routers. Static routers are generally used in smaller networks that contain only a couple of routers or when security is an issue. Each static router must be configured and maintained separately because static routers do not exchange routing information with each other.

How It Works

For a static router to function properly, the routing table must contain a route for every network in the internetwork. Hosts on a network are configured so that their default gateway address matches the IP address of the local router interface. When a host needs to send a packet to another network, it forwards the packet to the local router, which checks its routing table and determines which route to use to forward the packet.

Static routers are more difficult to administer than dynamic routers, but they can be more secure because the administrator controls the configuration of the router. Static routers are generally immune from any attempt by hackers to spoof dynamic routing protocol packets to reconfigure the router and hijack network traffic.

NOTE

You can configure a multihomed server as a static router in Microsoft Windows NT and Windows 2000. In Windows NT, select Enable IP Forwarding on the Routing tab of the TCP/IP property sheet. In Windows 2000, click the Advanced button on the TCP/IP property sheet, select the Options tab, select TCP/IP Filtering and click Properties, then select Enable TCP/IP Filtering. You can then add static routers for each remote network by using the route command.

See also
dynamic routing, routing table

statistical multiplexing

A multiplexing technique that allows information from a number of channels to be combined for transmission over a single channel.

How It Works

Statistical multiplexing dynamically allocates bandwidth to each channel on an as-needed basis. This is in contrast to time-division multiplexing (TDM) techniques, in which quiet devices use up a portion of the multiplexed data stream, filling it with empty packets. Statistical multiplexing allocates bandwidth only to channels that are currently transmitting. It packages the data from the active channels into packets and dynamically feeds them into the output channel, usually on a FIFO (first in, first out) basis, but it’s also able to allocate extra bandwidth to specific input channels.

Statistical multiplexing devices usually support other features, such as the following:

  • Store-and-forward error detection and correction capability:
    Identifies which channel sent each packet of data and corrects errors that occur

  • Data compression:
    Increases the amount of data that can be sent per packet

Statistical multiplexing is sometimes referred to as statistical time-division multiplexing (STDM) or statistical packet multiplexing (SPM), but the shorter term is used more often.

NOTE

A multiplexer that is capable of statistically multiplexing several data streams together is sometimes called a statmux. If you have a statmux at each end of a digital line, the receiving statmux can identify the channel of each packet sent by the sending statmux and demultiplex the data stream into its original data channels.

ST connector

See
SC and ST connectors

Stop screen

A blue screen that appears when the Microsoft Windows NT or Windows 2000 operating system experiences a fatal problem and terminates itself. The most important part of a Stop screen is the bugcheck information in the first few lines, which gives a Stop code and parameters that can help identify the source of the problem to Microsoft support technicians.

A Stop screen includes the following information:

  • The top of the screen shows the bugcheck information—the error code and a list of up to four developer-defined parameters.

  • The middle portion of the screen lists all modules that have been successfully loaded and initialized by the operating system. This information is listed in three columns: preferred memory location, link time stamp, and driver name.

  • The bottom portion shows the build number of the kernel and a stack dump that indicates the address range in which the driver might have failed.

The following table shows some common bugcheck codes and how to interpret them.

Common Bugcheck Codes
Code | Description
0x9 | IRQL_NOT_GREATER_OR_EQUAL: An attempt was made to touch pageable memory at a process interrupt request level (IRQL) that was too high. This usually indicates that a driver is using improper addresses. A stack trace is usually helpful in debugging the problem.
0xA | IRQL_NOT_LESS_OR_EQUAL: Usually indicates a bad or corrupt pointer.
0x1E | KMODE_EXCEPTION_NOT_HANDLED: An exception (error) occurred with a driver or function. This is one of the most common bugcheck codes; you can often use the exception address to identify the driver or function involved.
0x20 | KERNEL_APC_PENDING_DURING_EXIT: This usually indicates a problem with a third-party file system driver, such as a third-party redirector. Check with the manufacturer for an updated redirector.
0x2E | DATA_BUS_ERROR: This usually indicates a parity error in system memory. Try installing new RAM. It can also be caused by a driver accessing an address that does not exist; if swapping memory does not solve the problem, try swapping other hardware cards or install updated drivers for them.
0x3E | MULTIPROCESSOR_CONFIGURATION_NOT_SUPPORTED: This indicates mismatched CPUs in a symmetric multiprocessing (SMP) system.
0x4C | FATAL_UNHANDLED_HARD_ERROR: An error prevented the Windows NT operating system from booting properly. Common causes are missing or corrupt registry hives, corrupt system dynamic-link library (DLL), corrupt device driver, or an I/O problem with the disk subsystem.
0x51 | REGISTRY_ERROR: This could mean corruption in the registry or an I/O problem with the disk subsystem that prevents it from properly reading registry information. This error might also occur on a domain controller in which no more allocated space is available for storing the registry files.
0x69 | IO1_INITIALIZATION_FAILED: This indicates a failure in initializing the disk subsystem and usually means that you made an incorrect configuration decision during setup or have reconfigured the disk system incorrectly.
0x73 | CONFIG_LIST_FAILED: This indicates corruption in the SAM, SOFTWARE, or SECURITY hive.
0x74 | BAD_SYSTEM_CONFIG_INFO: This might indicate a corrupt SYSTEM hive in the registry, or it might mean that some critical registry keys in the hive are not present. Try LastKnownGood; if that fails, try the emergency repair disk (ERD).
0x75 | CANNOT_WRITE_CONFIGURATION: This usually indicates that there are 0 bytes of free space on the system drive, so the SYSTEM hive of the registry cannot grow in size.
0x77 | KERNEL_STACK_INPAGE_ERROR: This is usually caused by a bad block in the paging file or a disk controller error. If the paging file is on a Small Computer System Interface (SCSI) drive, check the cabling and termination.
0x7B | INACCESSIBLE_BOOT_DEVICE: If this occurs right after setup, it might mean that your disk controller is not supported by Windows NT. You might have to check the Windows Driver Library for a new device driver and do a custom installation. This error can also occur when you repartition the disk that contains the system partition. The solution is to edit the ARC paths in the boot.ini file. Another reason for this error is a Master Boot Record (MBR) or boot sector virus.
0x8B | MBR_CHECKSUM_MISMATCH: This usually indicates the presence of a Master Boot Record virus.
0x98 | END_OF_NT_EVALUATION_PERIOD: Your evaluation copy of Windows NT has expired.
TIP

Sometimes you can compare the addresses of the parameters in the top portion of the Stop screen with the addresses of drivers in the stack dump at the bottom and identify which driver might have caused the crash, but this will not always work. For more information on bugcheck codes and how to interpret them, check Microsoft TechNet.

storage area network (SAN)

A general term for an architecture that uses external storage devices to provide network storage for applications running on an enterprise-level network. Typical applications that use a storage area network (SAN) are enterprise data warehousing and data mining applications, mail servers, and other high-availability applications. Using a SAN allows you to locate the mission-critical data externally and administer it separately from the applications that process that data. This type of architecture originated in mainframe computing environments.

How It Works

SANs are typically hardware/software storage arrays running on dedicated subnets that combine a variety of disk technologies, including magnetic and optical disk storage, RAID technologies such as disk mirroring and disk striping, and tape backup resources. SANs generally use high-speed Fibre Channel technologies for interconnections between the SAN and a group of computers running an application. Fibre Channel is a high-speed direct connection technology that supports data transfer rates of up to 1 Gbps. Data I/O is performed using block transfer methods and involves directly attaching the application to the storage system.

SANs are typically used to centralize storage of data in an enterprise, which simplifies administration and backup of the data. SANs are often located near legacy mainframe computing environments but are gaining importance in distributed client/server environments as well. SANs are also used as remote storage and archival facilities connected to networks by high-speed Synchronous Optical Network (SONET) or OC-3 connections.

Graphic S-20. Storage area network (SAN).
Graphic S-20. Storage area network (SAN).
NOTE

It is easy to get confused by the various buzzwords relating to external enterprise-level storage devices because standards in this area have not been developed and ratified by standards bodies. Here are two other related storage system concepts:

  • Network-attached storage (NAS):
    Involves data storage devices connected to computers using a standard network connection such as Ethernet. This is in contrast to SAN, in which a group of computers uses multipoint Fibre Channel technology. Another difference between NAS and SAN is that NAS involves the use of file servers similar to the Network File System (NFS) used in UNIX environments (from which the concept of NAS evolved), while SAN uses block-mode I/O for applications such as clustering and database access.

  • Direct-attached storage (DAS):
    Involves a storage system connected to only a single computer using either Small Computer System Interface (SCSI) or Fibre Channel technology. DAS is usually the only solution if your servers are at different geographical locations around your enterprise or if the application that uses them can support only this form of storage—for example, Windows Clustering, which requires a shared SCSI bus.

Growth of SAN technology in the enterprise has been driven by demand but is limited by the lack of agreed-upon standards. The main body pushing for standards in this area is the Storage Networking Industry Association (SNIA), which has submitted its Simple Network Management Protocol (SNMP) Management Information Base (MIB) for SAN to the Internet Engineering Task Force (IETF) for consideration. Other groups pushing their own management interface solutions for SAN technology include Microsoft, with its Common Information Model (CIM) standard, and Sun Microsystems, with its StoreX initiative.

TIP

Use a SAN if your data can be centrally located within your enterprise and if your application needs to access data directly using block transfers instead of using shared files. Use NAS if your data needs to be shared between different operating system platforms or for file-based applications such as Web servers.

On the Web
•
SNIA
: http://www.snia.org

stored procedure

A precompiled set of Structured Query Language (SQL) statements that can be executed on demand by Microsoft SQL Server. Stored procedures are stored in a database. They support features such as user-declared variables and conditional execution and can be run with a single call. They can accept parameters, and they can return parameters and status values. They can also call other stored procedures. You can create permanent stored procedures for global administrative tasks or temporary ones for a specific task.

How It Works

You create a stored procedure by using a series of SQL statements. SQL Server parses and analyzes the stored procedure and stores it in various system tables. When you execute it for the first time, it is loaded into memory and compiled, storing the execution plan in the procedure cache. By preparsing and prenormalizing a stored procedure, you can achieve significant performance gains compared to using a simple SQL query.

You can use stored procedures with SQL Server to

  • Create devices and databases

  • Access or update information in database tables

  • Perform other administrative or user actions

A trigger is a special type of stored procedure that you can use to enforce referential integrity in a database. Other types of stored procedures supported by SQL Server include the following:

  • Extended stored procedures:
    Dynamic-link libraries (DLLs) that can be loaded and run like stored procedures

  • Remote stored procedures:
    Run from a remote client

  • System stored procedures:
    Included with SQL Server to simplify common administrative tasks and to obtain information from system tables

  • User-defined stored procedures:
    Created by users for a specific database

  • User-defined system stored procedures:
    Created by users and runnable in any database

See also
Structured Query Language (SQL)

STP cabling

See
shielded twisted-pair (STP) cabling

straight tip connector

See
SC and ST connectors

stranded conductor wire

Wire that has a core composed of many thin copper strands woven together and surrounded by insulation. Stranded conductor wire is generally used for drop cables between computers and wall plates and for patch cables connecting patch panels with hubs and switches. Stranded conductor wire has more attenuation than solid conductor wire and should be used only for short cable runs. Stranded conductor wire is more durable and reliable than solid conductor wire because it can be bent numerous times without fracturing or breaking, and because damage to the wire has less impact on the surface area of the wire and hence on its capacity to carry alternating current.

Stranded wire comes in two basic configuration types:

  • Bunch-stranded wire:
    Uses a number of thin wires with the same diameter and twists them together in one direction.

  • Concentric-stranded wire:
    Uses several layers of thin wires wrapped in alternating directions. These wires are generally easier to splice and terminate than bunch-stranded wires.

streaming

A technology for receiving multimedia (audio and video) content as a steady continuous data flow called a stream.

How It Works

Streaming media can be used over corporate TCP/IP networks on the Internet to provide users with low-latency audio and video information. In contrast to the traditional method of downloading audio or video files and then playing them locally, streaming media needs only a short time to buffer the initial transmission, and then it plays continuously, depending on data flow. Data is streamed across the network to clients that render the data as they receive it. For example, if audio data is streamed over a network, clients receiving it can play the content as it arrives instead of storing it in a file and playing it after receiving the entire file.

In Microsoft NetShow terminology, a stream is any multimedia or file data stream transmitted using unicasting or multicasting methods over a network. NetShow supports several types of streams:

  • Advanced Streaming Format (ASF):
    Supports video, audio, images, Uniform Resource Locators (URLs), and scripts

  • Real-Time Transport Protocol (RTP) Live Audio:
    Streams audio fed into the server’s sound card

  • RTP WAV Audio:
    Streams audio recorded as .wav files

NOTE

NetShow also supports a file transfer method called streaming file transfer, which can be used to transfer directories and files over a network. The File Transfer Service (FTS) is the NetShow component that is used to transmit files over a network using multicasting. A NetShow FTS server transmits files over a network to a Microsoft ActiveX control on a client computer.

striped volume

In Microsoft Windows 2000, a volume created using the Disk Management portion of the Computer Management tool that stores its data across two or more physical disks in stripes. Striping allocates data alternately and evenly across multiple physical disks. Striped volumes must be created on dynamic disks. They are not fault tolerant and cannot be mirrored or extended. Stripe sets are the equivalent of striped volumes in Microsoft Windows NT.

See also
dynamic volume

stripe set

A single volume created using discontiguous free areas on two or more hard disks. Stripe sets are similar to volume sets but can give much faster read/write performance if segments reside on separately controlled drives. Use the Microsoft Windows NT administrative tool Disk Administrator to create stripe sets by combining 2–32 free areas on two or more disk drives.

NOTE

The Windows NT system partition and boot partition cannot be volume sets. Stripe sets also cannot be extended the way volume sets can.

stripe set with parity

A fault tolerance technology, whereby data is written simultaneously to two or more different disks. Parity information is distributed across the various disks so that if one disk drive fails, the lost data can be regenerated from the parity information. You can use the Microsoft Windows NT administrative tool Disk Administrator to create, delete, and regenerate stripe sets with parity. Stripe sets with parity are often used to provide fault tolerance for application and data volumes in Windows NT. In Microsoft Windows 2000, a stripe set with parity is known as a RAID-5 volume.

See also
RAID

Structured Query Language (SQL)

A standards-based language used by relational database management programs primarily for constructing queries. Structured Query Language (SQL) was originally developed by IBM for mainframe computing environments and is widely used in relational database management systems. The standard version of SQL is defined by the American National Standards Institute (ANSI), but many vendors have made enhancements to its syntax and command functions. The latest SQL standard is called SQL-92 but is more properly known as ANSI standard SQL X3.135-1992 or International Organization for Standardization (ISO) standard ISO/IEC 9075:1992.

How It Works

SQL includes a number of statements that can be used to perform different types of relational operations on the contents of a database, including creating databases and database objects, modifying these objects, and querying databases for information. The most basic SQL statement is the SELECT statement, which you can use to retrieve rows and columns of data from database tables and format the results set. The typical format of a SELECT statement is

SELECT <columns> FROM <tables> WHERE <rows>

where a group of columns are retrieved from a table or tables in which data values are restricted to a particular row or rows. To return all the columns from a table, you can use a wildcard (but this is generally inefficient and should be avoided):

SELECT * FROM <tables>
NOTE

Microsoft SQL Server conforms to the ANSI SQL-92 standard and enhances this standard with additional statements for certain types of applications, such as data warehousing and Internet/intranet applications.

TIP

If possible, include a WHERE clause in a SELECT statement to restrict the scope of your query and avoid unnecessary expenditure of system resources. The WHERE clause can include various comparison and logical operators, such as =, >, LIKE, BETWEEN, AND, and IS NULL.

subnet

See
subnetting

subnet mask

A 32-bit number that is used to partition IP addresses into a network ID and a host ID. Subnet masks are used by TCP/IP services and applications to determine whether a given IP address on an internetwork is a local network address or a remote network address.

How It Works

Subnet masks are represented as four-octet dotted-decimal numbers, just as IP addresses are, except that the most common values for an octet in a subnet mask are 0 and 255. In binary notation, decimal 0 represents the octet 00000000, and decimal 255 represents 11111111. A subnet mask consists of 32 binary digits, the first n of which are 1s and the remaining of which are 0s. When the subnet mask is logically ANDed with a 32-bit IP address of a TCP/IP host, the result is the network ID of the host—the portion of the host’s IP address that identifies which network the host is on. When the inverse of the subnet mask (for example, NOT mask) is logically ANDed with the IP address of the host, the result is the host ID of the host—the portion of the host’s IP address that uniquely identifies the host on its network.

For example, consider the IP address 207.61.16.119 and the subnet mask 255.255.255.0. Converting these two numbers to binary and ANDing them gives the host’s Network ID:

Host = 11001111 00111101 00010000 01110111
Mask = 11111111 11111111 11111111 00000000
AND  = 11001111 00111101 00010000 00000000
     = 207.61.16.0 = network ID

Taking the logical NOT of the subnet mask and ANDing it with the host’s IP address gives the host’s Host ID:

Host = 11001111 00111101 00010000 01110111
NOT Mask = 00000000 00000000 00000000 11111111
     AND = 00000000 00000000 00000000 01110111
         = 0.0.0.119 = host ID

Two types of subnet masks are used in TCP/IP networking:

  • Default subnet masks:
    Partition IP addresses into their network ID and host ID portions

  • Custom subnet masks:
    Further partition the network ID into a number of separate subnets by using a process called subnetting

NOTE

The default subnet masks for IP address classes A, B, and C are shown in the following table. The table also shows how these subnet masks would partition an IP address such as w.x.y.z into a network ID and a host ID portion.

Default Subnet Masks for IP Addresses
Class | Default Subnet Mask | Network ID | Host ID
A | 255.0.0.0 | w | x.y.z
B | 255.255.0.0 | w.z | y.z
C | 255.255.255.0 | w.x.y | z
TIP

Some TCP/IP configuration programs, such as those for Ascend routers, use a different notation for specifying subnet masks. They append a suffix of the form /n to the host’s IP address to indicate the subnet mask, in which n equals the number of binary 1s in the subnet mask. Thus, for example, 207.61.16.119/24 signifies 207.61.16.119/255.255.255.0.

subnetting

The process of partitioning a single TCP/IP network into a number of separate networks called subnets. These subnets are then joined using routers. Advantages of subnetting a network include the following:

  • Reducing network congestion by limiting the range of broadcasts using routers

  • Enabling different networking architectures to be joined

How It Works

To subnet a TCP/IP network, you take the assigned network ID and borrow bits from the host ID to establish a group of subnet IDs, one for each subnet. The more bits you borrow, the more subnets you produce, but the fewer the number of possible hosts for each subnet. The borrowing process also defines a unique custom subnet mask for the network.

For example, consider a class B network that uses the network ID 172.16.0.0. If this network needs to be subnetted into six subnets, you can accomplish this using a custom subnet mask of 255.255.224.0. Each subnet can be shown to support a maximum of 8190 hosts. The IP address blocks for the six subnets are as follows:

  • 172.16.32.1 to 172.16.63.254

  • 172.16.64.1 to 172.16.95.254

  • 172.16.96.1 to 172.16.127.254

  • 172.16.128.1 to 172.16.159.254

  • 172.16.160.1 to 172.16.191.254

  • 172.16.192.1 to 172.16.223.254

TIP

Manual calculation of custom subnet masks and subnet IDs is tedious. You can download numerous subnetting calculators from the Internet, some of them for free. To use these calculators to subnet your network, you must first determine how many subnets you need and the maximum number of hosts on each subnet.

subscriber connector

See
SC and ST connectors

subtree

A major logical section of the registry. Subtrees are the root keys of the registry, and all other registry keys are subkeys of these root keys. The following table summarizes the functions of the five subtrees of the Microsoft Windows NT and Windows 2000 registries.

Subtrees of the Windows NT and Windows 2000 Registries
Subtree | Function
HKEY_LOCAL_MACHINE | Contains configuration information for the local machine, including all hardware and software settings
HKEY_CLASSES_ROOT | Provides compatibility with Windows 3. x and points to the Classes subkey of HKEY_LOCAL_MACHINE
HKEY_CURRENT_CONFIG | Provides information about the active hardware profile
HKEY_CURRENT_USER | Contains the settings of the user who is currently logged on interactively and points to the SID_# of HKEY_USERS, in which SID_# is the security ID string of the current user
HKEY_USERS | Contains default system settings and the settings of the user who is currently logged on interactively, plus all previously logged on users
NOTE

In Microsoft Windows 95 and Windows 98, a sixth subtree called HKEY_DYN_DATA is generated dynamically and is used for performance measuring via System Monitor and plug and play configuration of devices. This subtree is also called the hardware tree.

TIP

Most Windows NT and Windows 2000 registry troubleshooting takes place in the HKEY_LOCAL_MACHINE\System\CurrentControlSet subkey.

supernetting

The process of combining multiple consecutive network IDs of the same IP address class into a single block. Supernetting, also known as classless interdomain routing (CIDR), is the reverse of subnetting.

How It Works

Supernetting is typically used to conserve class B addresses by combining contiguous groups of class C addresses. The class C addresses must have the same high-order bits, and the subnet mask is shortened by borrowing bits from the network ID and assigning them to the host ID portion to create a custom subnet mask. For example, if a company has 2000 hosts on its TCP/IP network, it can assign IP addresses by

  • Using a single class B address. This approach is wasteful.

  • Using eight different class C addresses, which can support 8 x 254 = 2032 hosts. This means poorer routing performance because each router requires eight entries in its routing table for each of the eight networks to which frames can be forwarded.

  • Using supernetting to collapse a block of eight class C addresses into a single routing table entry. The router must support CIDR for this to work.

surge protector

Also known as a surge suppressor, a device that protects sensitive data communications equipment (DCE) and data terminal equipment (DTE) from sudden rises in power line voltages called surges or spikes.

How It Works

Surges occur only with copper cabling such as twisted-pair cabling or coaxial cabling—they do not occur with fiber-optic cabling, which is one advantage of using this more expensive type of cabling for networking applications. Surge protectors use various technologies for absorbing or deflecting unwanted electrical current, including avalanche diodes, metal oxide varistors, and chokes or filters. One of the best electrical protection methods, especially for copper wiring runs between different buildings, is to use opto isolators, which convert electrical signals to light and then back again, thus providing true electrical isolation between the connected buildings. However, opto isolation in itself does not provide surge protection; this is the responsibility of the other components described, the most common component being the various types of diodes.

Surge protectors for computer networking come in two main types:

  • Data-line surge protectors:
    Connected to network cabling to prevent power surges from damaging networking components.

  • Alternating current (AC) outlet surge protectors:
    Connected to AC outlets that provide power for networking components. These surge protectors prevent AC power spikes from damaging networking components.

SVC

See
switched virtual circuit (SVC)

switch

Any device that can control the flow of electrical signals. A number of special-purpose switches are used in networking. For example, the following types of switches are used to control access to computers by printers, keyboards, and monitors:

  • Matrix switches:
    Have a keypad for mapping input ports to output ports and are typically used to connect several printers to several workstations

  • Code-operated switches:
    Use a data string sent by the PC to select the printer port to be used

  • Port-contention or scanning switches:
    Use several input ports but only one output port and monitor the input ports continually for data to route to the output port

  • KVM switches:
    Allow one keyboard/video-monitor/mouse to be used for several servers

NOTE

In the context of controlling data flow within a network, the term “switch” is also used to describe a data-link layer device that routes frames between connected networks. Data flow switches include

  • Local area network (LAN) switches:
    Used to route Ethernet frames over a TCP/IP internetwork; also called Ethernet switches

  • Asynchronous Transfer Mode (ATM) switches:
    Used to switch ATM cells at high speeds over an ATM network

In the context of high-speed Ethernet networks, the term “switch” usually refers to an Ethernet switch. Thus, the phrase “routers and switches” is understood to mean “routers and Ethernet switches.”

The term “switch” can also refer to a device used at a telco central office (CO) for establishing connections in circuit-switched services or for forwarding packets in packet-switched services.

switched 56

A digital switched-data communication technology that provides full-duplex dial-up connections at a speed of 56 Kbps. Switched 56 is essentially the dial-up version of digital data service (DDS) and is generally cheaper than leased-line services.

How It Works

A device called a data set, which is a type of Data Service Unit (DSU), provides switched 56 services to customer premises. For a typical local area network (LAN) connection, a router on the LAN is attached to the data set by using a V.35 serial interface. The data set is then connected over the customer’s local loop twisted-pair wiring to access equipment located at the telco’s central office (CO).

Switched 56 uses the same communication channels as DS0. You can establish circuits by manually entering the destination number on a numeric keypad or (more typically) by using in-band signaling when connecting bridges or routers to the service. Depending on the wiring at the customer premises and the equipment at the CO, you can use one of three configurations for this service:

  • Type I service:
    Uses a two-pair (4-wire) connection and is supported to up to 5500 meters from the CO over standard 26-gauge copper twisted-pair wiring.

  • Type II service:
    Uses a one-pair (2-wire) connection with in-band signaling. This type is not widely implemented.

  • Type III service:
    Uses a one-pair (2-wire) connection with out-of-band signaling and is supported to up to 5500 meters from the CO on 22-gauge or 24-gauge copper twisted-pair wiring and includes forward error correction for enhanced data transmission. Although Type III service appears to be full-duplex, in reality time-compression multiplexing (TCM) rapidly switches half-duplex communication at 160 Kbps to simulate full-duplex at 56 Kbps.

    Graphic S-21. Switched 56.
    Graphic S-21. Switched 56.
NOTE

Some carriers offer other higher speed versions of switched 56. For example, some carriers offer switched 56 as a 64-Kbps service under the name switched 64. Other higher dial-up services include switched 384 and switched 1536, although these are not widely offered anymore.

TIP

Switched 56 is a data-only service that is often available where Integrated Services Digital Network (ISDN) is not available. However, switched 56 does not support advanced ISDN features such as caller ID and has greater latency for establishing a connection. The cost is typically billed in the same way that ordinary telephone calls are—that is, local calls are free and long distance is billed by the minute.

Dial-up switched 56 can be a good service to use as a backup wide area network (WAN) link between two networks connected by expensive T1 lines. It is being phased out in most places in favor of ISDN.

See also
telecommunications services

Switched Multimegabit Data Services (SMDS)

A connectionless, packet-switched telecommunications service with speeds ranging from 56 Kbps to 34 Mbps. Switched Multimegabit Data Services (SMDS) was designed by Bellcore in the 1980s for high-speed wide area network (WAN) communication. It was the first high-speed broadband networking technology offered to subscribers and was a precursor to Asynchronous Transfer Mode (ATM) networking. Most carriers are now phasing out SMDS.

How It Works

SMDS is based on a packet-switching technology similar to frame relay networks. A subscriber’s local area network (LAN) typically connects to the SMDS service through a router using a RS-449 interface and a Channel Service Unit/Data Service Unit (CSU/DSU) using a copper DS1 connection (1.544 Mbps) for low-speed access or a fiber DS3 connection (44.736 Mbps) to achieve the highest possible transmission speeds. This point of connection between the subscriber’s LAN and the telco’s central office (CO) is called the Subscriber Network Interface (SNI). The CO provides a gateway to the SMDS packet-switching network, which consists of high-speed switches joined by trunk lines connecting different telco COs.

Graphic S-22. Switched Multimegabit Data Services (SMDS).
Graphic S-22. Switched Multimegabit Data Services (SMDS).

An SMDS packet consists of a header with the source address, destination address, and a payload of up to 9188 bytes. The SMDS payload is large so that SMDS can easily encapsulate Ethernet, Token Ring, and Fiber Distributed Data Interface (FDDI) frames for WAN transmission. The E.164 addressing scheme uses decimal numbers up to 15 digits long and includes a country code, area code, and subscriber ID number (similar to ordinary telephone numbers). Different address classes support different data transfer speeds. The serial protocol used for communication between the customer premises equipment and SMDS equipment at the telco’s CO is called the SMDS Interface Protocol (SIP), which is based on the IEEE 802.6 standard for metropolitan area networks (MANs). The primary function of SIP is to provide encapsulation of the LAN protocol. (Internet Protocol, Internetwork Packet Exchange, AppleTalk, and just about anything else is supported.) Higher-layer protocols support processes such as address resolution and source address screening.

NOTE

SMDS supports ATM communication and is suitable for use in high-capacity mesh topology WANs. SMDS is offered by long-distance carriers such as AT&T and by some Regional Bell Operating Companies (RBOCs). SMDS is not as widely supported as frame relay even though it uses similar packet-switching technology.

switched virtual circuit (SVC)

A form of telecommunications service that provides a path between two nodes in a packet-switched network. The path is set up and configured at the beginning of a session and is dismantled at the end. Each new session requires a switching path to be established, and this path differs during each session depending on the available switches.

A switched virtual circuit (SVC) provides a temporary, point-to-point connection between the two nodes. SVCs offer the advantage of bandwidth on demand but suffer from some latency in establishing a connection. They are cheaper than permanent virtual circuits (PVCs) because they use whatever telco resources are available at a given time; after the session, these resources are released for other purposes. Because the actual switching path varies with each session, SVCs also suffer from inconsistent connection quality.

TIP

SVCs are best used for WAN links that have low or irregular network traffic.

Symmetric Digital Subscriber Line (SDSL)

A type of Digital Subscriber Line (DSL) technology in which upstream and downstream speeds are equal. Symmetric Digital Subscriber Line (SDSL) technology can provide subscribers with permanent, high-speed data connections for Internet access and other uses much more cheaply than T1 lines can. SDSL is sometimes interpreted to stand for “Single-line DSL” instead of “Symmetric DSL” because it uses a single twisted-pair copper wire.

How It Works

SDSL is based on the same DSL technology that is used in High-bit-rate Digital Subscriber Line (HDSL) and Asymmetric Digital Subscriber Line (ADSL) implementations of DSL. SDSL can deliver data at speeds of up to 2 Mbps, which is comparable to speeds achieved by HDSL circuits, although typical SDSL speeds are equal to those of a T1 line (1.544 Mbps). While HDSL needs two pairs of copper wires (four wires), SDSL requires only one pair (two wires). And unlike ADSL technology, where downstream speed greatly exceeds upstream speed, SDSL transmission speeds are the same in both directions. However, this is true only if the length of the local loop connection does not exceed 3000 meters and the quality of the phone circuit is good. Also, while ADSL allows subscribers to connect both voice (phone) and data (computers) at their customer premises, SDSL allows only a data connection over a given pair of wires.

NOTE

SDSL uses the same line coding algorithm (2B1Q) that is used in HDSL and in Integrated Services Digital Network (ISDN) circuits.

SYN attack

Also called SYN flooding, a form of denial of service attack directed at TCP/IP networks connected to the Internet. A SYN attack is a protocol-level attack that can make a computer’s network services unavailable to other users.

How It Works

A malicious user initiates a SYN attack by sending a Transmission Control Protocol (TCP) connection request (SYN packet) to a targeted server in a network, usually a Web server. The attacker uses spoofing to alter the source IP address in the SYN packet. When the server receives the connection request, it allocates resources for handling and tracking the new connection and responds by sending a SYN-ACK packet to the nonexistent source address. Because there is no response to the SYN-ACK packet, the server continues to retransmit SYN-ACK several times (five times in Microsoft Windows NT) at increasingly longer time intervals. Finally, after the last retransmission, the server gives up and deallocates the resources previously allocated for the connection. For servers running Windows NT, the default time for this entire process is 189 seconds. The attacker configures software to automatically send large numbers of TCP SYNs in an attempt to tie up the server’s TCP resources and prevent other users from connecting to the server.

TIP

If you are running a Web server and your Web clients are receiving messages such as “The connection has been reset by the remote host,” you might be the target of a SYN attack. If you are running Internet Information Services (IIS) as your Web server, type netstat –n –p tcp at the command prompt to examine the number of TCP connections in a SYN_RECEIVED state. A large number of SYN_RECEIVED connections might indicate that your server is under attack.

SYN attacks against private networks are simple to prevent: you configure a firewall with access lists to accept only incoming IP addresses with known addresses. However, if you are running a Web server that needs to be accessible to anyone on the Internet, it is usually more difficult to defend the server against a SYN attack because if you configure an input filter, the attacker can simply modify the source IP address in the SYN packets. Ways to defend Web servers against SYN attacks include decreasing the time-out period for the TCP three-way handshake mechanism, increasing the size of the SYN-ACK queue, and applying various vendor-supplied patches to your Web server. For more information on configuring IIS servers to withstand SYN attacks, see the Microsoft Internet Information Server Resource Kit from Microsoft Press.

See also
TCP three-way handshake

sync

See
synchronous transmission

Synchronous Data Link Control (SDLC)

A data-link layer protocol developed in the 1970s by IBM for its Systems Network Architecture (SNA) networking environment. Synchronous Data Link Control (SDLC) is primarily used in wide area networks (WANs) that use leased lines to connect mainframe SNA hosts and remote terminals.

How It Works

SDLC was the first bit-oriented synchronous transmission protocol developed by IBM. It quickly displaced the older, less efficient, character-oriented synchronous protocols such as Bisync and DDCMP. In a serial SDLC link, data is sent as a synchronous bit stream divided into frames that contain addressing and control information in addition to the payload of data.

SDLC uses a master/slave architecture in which one station is designated as primary (master) and the remaining stations are secondary (slaves). The primary station establishes and tears down SDLC connections, manages these connections, and polls each secondary station in a specific order to determine whether any secondary station wants to transmit data. You can use SDLC in a variety of connection topologies, including direct point-to-point connections between a primary and a secondary station and multipoint connections between a primary and a group of secondary stations. Ring topologies are also possible in which a primary controls a ring of secondary stations and is itself part of the ring.

Graphic S-23. Synchronous Data Link Control (SDLC).
Graphic S-23. Synchronous Data Link Control (SDLC).
NOTE

A number of popular protocols have been derived from the SDLC protocol and standardized by various standards bodies. These include the following:

  • High-level Data Link Control (HDLC):
    Developed by the International Organization for Standardization (ISO) and used by Cisco Systems routers for serial communication over leased lines as an alternative to the Point-to-Point Protocol (PPP)

  • Link Access Procedure Balanced (LAPB):
    Part of the X.25 protocol stack

  • Logical Link Control (LLC) or IEEE 802.2:
    The most popular data link protocol for local area networks (LANs)

Synchronous Optical Network (SONET)

A physical layer specification for broadband synchronous transmission of voice, video, and data over long distances of fiber-optic cabling at speeds of more than 1 Gbps. Synchronous Optical Network (SONET) networks can carry voice, video, and data simultaneously and are often used by telecommunications providers to provide the underlying transport mechanism for Asynchronous Transfer Mode (ATM) networking in internal telco and long-distance carrier networks. SONET can also be used as the underlying transport for Fiber Distributed Data Interface (FDDI), Integrated Services Digital Network (ISDN), and Switched Multimegabit Data Services (SMDS) communication. SONET was developed by Bellcore in the mid-1980s and has been standardized by the American National Standards Institute (ANSI). A European version called Synchronous Digital Hierarchy (SDH), which has been standardized by the International Telecommunication Union (ITU), is essentially equivalent to SONET.

How It Works

SONET is built from multiplexed DS0, DS1, or DS3 digital signal channels using optical time-division multiplexing (TDM) to form a single Synchronous Transport Signal (STS) link for communication. The basic SONET transmission rate is 810 bytes transmitted every 125 microseconds, and frames are transmitted whether or not a payload (data) is present. A standard STS-1 SONET data path thus consists of 810 DS0 channels, of which 783 are used for data transmission and 27 are used for framing, error correction, format identification, and other forms of overhead.

SONET is usually implemented as a dual-ring topology to provide redundancy and fault tolerance. These rings are usually self-healing within 50 milliseconds of a break. SONET speeds are classified by one of the following:

  • Electrical signal speeds called Synchronous Transport Signal (STS)

  • Optical carrier line speeds called optical carrier (OC)

The following table shows the currently defined SONET speeds.

SONET Speeds
Electrical Signal | Optical Carrier | Speed
STS-1 | OC-1 | 51.48 Mbps
STS-3 | OC-3 | 155.52 Mbps
STS-12 | OC-12 | 622.08 Mbps
STS-24 | OC-24 | 1.24 Gbps
STS-48 | OC-48 | 2.48 Gbps
STS-192 | OC-192 | 9.95 Gbps

synchronous transmission

A mode of serial transmission for digital modems, ISDN terminal adapters, Channel Service Unit/Data Service Units (CSU/DSUs), and other telecommunications devices.

How It Works

Synchronous transmission uses clocking circuitry at both the transmitting station and the receiving station to ensure that communication is synchronized. This is in contrast to asynchronous transmission, in which start and stop bits are added to the beginning and end of each frame.

Devices that communicate with each other synchronously use either separate clocking channels to ensure synchronization between them or some kind of special signal code embedded in the signal for self-clocking purposes. Separate clocking lines are generally used when the distance between the data terminal equipment (DTE) and data communications equipment (DCE) is fairly short. Typically, the receiving station (such as a modem, a common form of DCE) provides the clocking signal to the transmitting station (usually a computer or a terminal).

The alternative is to use signal preamble, a special group of bytes (usually 8 bytes) called a SYNC signal that alerts the receiver that data is coming, synchronizes the clocks at the two devices, and starts the transmission. Special predefined voltage transition patterns familiar to both the transmitting and receiving stations are contained within the signal and are used to maintain synchronization between the devices. The receiver must extract this embedded information from the signal and use it to maintain synchronization between it and the transmitting station.

Synchronous transmission interfaces are generally about 20 percent faster and somewhat more reliable than comparable asynchronous interfaces.

See also
asynchronous transmission

system access control list (SACL)

A form of access control list (ACL) used by the Microsoft Windows 2000 and Windows NT operating systems for security control purposes. System access control lists (SACLs) are not to be confused with the more familiar discretionary access control lists (DACLs) used by Windows 2000 and Windows NT to control access to Active Directory and NTFS file system objects by users and groups. SACLs are used for establishing system-wide security policies for actions such as logging or auditing resource access. The SACL attached to a system, directory, or file object specifies

  • Which security principals (users, groups, computers) should be audited when accessing the object

  • Which access events should be audited for these principals

  • Whether a Success or Failure attribute is generated for an access event, depending on the permissions granted in the DACL for the object

TIP

In the Windows NT operating system, be sure to use the emergency repair disk (ERD) instead of the Restore utility if any system files are lost or damaged, since the Backup and Restore utilities do not copy the SACLs, but the ERD does.

See also
access control, access control list (ACL), discretionary access control list (DACL)

System Attendant

One of the four core components of Microsoft Exchange Server. You can use the System Attendant to do the following:

  • Collect information about all Exchange servers in a site

  • Maintain the Exchange routing table (GWART)

  • Create and maintain message-tracking log files for services and connectors

  • Automatically generate e-mail addresses for new recipients

  • Monitor links between sites

  • Perform diagnostic functions

The System Attendant is implemented as a Microsoft Windows NT or Windows 2000 service; it must be running for other Exchange services to run.

TIP

To stop all Exchange services on a computer, stop the System Attendant by using Services in Control Panel. To restart the services, you must restart each service individually, starting with the System Attendant.

System Configuration utility

A Microsoft Windows 98 utility that automates routine Windows troubleshooting tasks. The System Configuration utility (msconfig.exe) replaces the sysedit.exe program in earlier versions of Windows and has the added feature of allowing you to make backups of key system files. You can use the System Configuration utility to modify startup and initialization settings in files such as system.ini and config.sys by using Windows controls instead of a text editor such as Notepad.

The System Configuration utility lets you create a clean startup environment for troubleshooting purposes and determine the source of a boot problem by the process of elimination. You can select the items in your Startup group and in the Run and RunServices keys of your registry that you want to enable or disable. You can access the System Configuration utility from the Tools menu of the System Information utility in your System Tools program group.

System File Checker

A Microsoft Windows 98 utility for restoring missing, corrupt, or modified operating system files. The System File Checker (sfc.exe) tracks all modifications to Windows 98 operating system files. You can also configure it to monitor the files of other applications for changes. If the System File Checker determines that a file is missing, changed, or corrupt, it prompts you to insert the Windows 98 CD to restore these files to their correct state.

The System File Checker is useful because third-party applications occasionally replace original Windows 98 shared system files with versions that are incompatible with other installed applications. You can use the System File Checker to restore your Windows 98 operating system files to their original condition. You can start the System File Checker via the Tools menu of the System Information utility in your System Tools program group.

system group

See
special identity

System Information utility

A Microsoft Windows 98 utility that helps technical support personnel troubleshoot the system by gathering system configuration information on the installed hardware and software.

Graphic S-24. System Information utility.
Graphic S-24. System Information utility.
How It Works

The System Information utility gathers information from the registry, from initialization files, and from the operating system modules that are currently running. It displays the information in a hierarchical view, organized in three major categories:

  • Hardware Resources:
    Includes information about IRQ settings, I/O ports, and memory address ranges

  • Components:
    Includes information about the status of device drivers and networking and multimedia software

  • Software Environment:
    Shows a snapshot of all software currently loaded into memory, including drivers, operating system modules, running tasks, system hooks, and OLE registration information

system log

A Microsoft Windows NT and Windows 2000 log that records events generated by the operating system. Events logged in the system log mainly consist of information about services starting, stopping, or failing and about system device drivers that fail. Administrators cannot alter the type of information logged in the system log. You can view and manage the system log by using the administrative tool Event Viewer.

The following are three types of events that can be logged to the system log:

  • Errors:
    Identified by a white “X” in a red circle; indicates a significant problem that might have caused data loss or the loss of some aspect of system functionality (for example, a service failing to start properly)

  • Warnings:
    Identified by an exclamation mark in a yellow triangle; indicates a problem that might not be critical but might have an impact later (such as low disk space)

  • Information:
    Identified by a blue letter “i” in a speech balloon; indicates a significant but harmless event such as a service starting or device driver initializing

See also
application log, security log

System Monitor

A system tool in Microsoft Windows 95 and Windows 98 for monitoring the real-time performance of the Windows 95 or Windows 98 processor, memory, disk, and networking subsystems. System Monitor (sysmon.exe) can display information as a graph, a bar chart, or numeric values and can update information using a range of time intervals. The categories of information that you can monitor depend on which networking services are installed on your system, but they always include File System, Kernel, and Memory Manager. Other possible categories include Microsoft Network Client, Microsoft Network Server, and protocol categories. The following table shows some common troubleshooting uses for System Monitor.

Troubleshooting with System Monitor
Symptom or Problem | Category to Check
Memory leaks by applications | Kernel: Threads will increase steadily.
Excessive disk access | Memory Manager: Page Faults is large. This usually means that you should add more RAM.
Slow response | Kernel: Processor Usage (%) is high, which might indicate that a runaway application needs to be terminated with Ctrl+Alt+Delete.
NOTE

Microsoft Windows NT and Windows 2000 have a similar but more powerful tool. This is called System Monitor in Windows 2000 and Performance Monitor in Windows NT. For a fuller description, see the Performance Monitor entry elsewhere in this work.

TIP

You can use System Monitor to connect to and monitor a remote computer running Windows 95 or Windows 98 if the remote computer has the remote registry service installed, which itself requires that user-level security be enabled on the machine. This also means that a security provider such as a Windows NT domain controller must be available. Choose Connect from the File menu and type the name of the remote computer you want to monitor.

See also
Performance Monitor

system partition

The partition on which Microsoft Windows NT or Windows 2000 installs hardware-specific files that are needed to start the operating system. These files include the boot loader file (ntldr), the hardware detector file (ntdetect.com), and the boot.ini file. The system partition is different from the boot partition, which contains the actual Windows NT or Windows 2000 operating system files and supporting files. During the boot process, the code in the Master Boot Record (MBR) locates the system partition by scanning the partition table.

On x86-based computers, the system partition must be on the first physical hard disk of the machine and must be an active partition (and hence a primary partition). You can format the system partition by using the file allocation table (FAT) system of MS-DOS or the NTFS file system. On a RISC system, you must format the system partition using FAT, and the system partition can be on any physical disk. In a default Windows NT or Windows 2000 installation, both the system partition and boot partition are on the C drive.

See also
boot partition

system policy

A file that applies a set of rules to a computer or set of computers to restrict what users or groups of users can see and do on their workstations. System policies are included as an administrative feature on the Microsoft Windows NT operating system platform for helping administrators lock down the desktop configuration of Microsoft Windows NT Workstation, Windows 98, and Windows 95 clients. On the Microsoft Windows 2000 platform, a more advanced feature called Group Policy is implemented, which is integrated with Active Directory.

How It Works

System policies work by overwriting specific registry keys on the computers they are applied to. To apply a system policy to computers in a Windows NT domain, put the ntconfig.pol file in the NetLogon Share on the primary domain controller (PDC) and use the Directory Replicator Service to replicate the file to other domain controllers. When users log on to the network, the system policy file is downloaded and applied to their Windows NT workstations.

You can create system policy files for Windows NT Workstation clients by using the administrative tool System Policy Editor. A system policy file created this way is usually named ntconfig.pol.

NOTE

If users have Windows 95 or Windows 98 clients, use poledit.exe to create a config.pol file and place this in the NetLogon Share, as just described. System policy files created for Windows 95 and Windows 98 clients are usually named config.pol. If you have a mix of Windows NT, Windows 95, and Windows 98 clients on the network, you must create both an ntconfig.pol file and a config.pol file and store them in the NetLogon Share on the PDC.

See also
group policy, Group Policy

System Policy Editor

A Microsoft Windows NT administrative tool for creating and configuring system policies for Windows NT Workstation clients.

How It Works

System Policy Editor runs in two modes:

  • Policy mode:
    Creates system policies that can be saved in the NetLogon Share of domain controllers and applied to client computers when users log on. This is the normal way of using System Policy Editor.

  • Registry mode:
    Allows direct manipulation of a subset of entries in the Windows NT registry.

NOTE

Microsoft Windows 95 and Windows 98 also include a version of System Policy Editor called poledit.exe for configuring Windows 95 and Windows 98 system policy files.

TIP

System polices have been replaced with group policies on the Microsoft Windows 2000 platform, but System Policy Editor (poledit.exe) is still included on Windows 2000 Server as an optional tool for certain downlevel administration uses such as the following:

  • Creating and configuring ntconfig.pol files to lock down servers and workstations running Windows NT 4

  • Creating and configuring config.pol files to lock down client computers running Windows 98 and Windows 95

  • Locking down stand-alone computers running Windows 2000, since these exist outside of Active Directory and therefore cannot be managed by using group policies

Graphic S-25. System Policy Editor.
Graphic S-25. System Policy Editor.
See also
system policy

Systems Management Server (SMS)

See
Microsoft Systems Management Server (SMS)

Systems Management Server Administrator

The main tool for administering a deployment of Microsoft Systems Management Server (SMS) in an enterprise. The SMS Administrator program provides access to the Microsoft SQL Server database that stores SMS information such as packages, jobs, and events for different sites, servers, and clients. The program also lets you create, view, or modify these objects. Specifically, you can use the SMS Administrator program to

  • View a list of all computers in your site and sites beneath it in the SMS hierarchy and view the inventory for each individual computer

  • Provide direct support to computers using the remote troubleshooting utilities

  • Create, modify, and delete packages and program groups

  • Define inventory rules for packages to enable SMS to scan for these packages and report them to the inventory database

  • Configure site properties for your site and sites beneath it in the SMS hierarchy

  • Use Network Monitor to capture network traffic from a computer in the inventory

  • Configure SMS to receive Simple Network Management Protocol (SNMP) traps and store these traps in the database

  • Use Microsoft Windows NT administrative tools to manage Windows NT–based computers in the inventory

How It Works

You can install the SMS Administrator on any computer running Windows NT. You can use the SMS Administrator to log on to the SMS hierarchy and administer the objects and properties for your site and other sites beneath it in the hierarchy. You can access the Structured Query Language (SQL) database for any SMS system in which you have appropriate permissions. If you log on to the central SMS site, you can administer the entire SMS system.

The SMS Administrator program uses multiple windows for managing objects in the SMS database. Some of the more important windows include the following:

  • Sites window:
    Displays a complete view of all domains and computers for your current site and its subsites. The site that you log on to is the top site in your Sites window, regardless of whether any parent sites are above it. Use the Sites window to view the detailed hardware and software inventory of any computer that is displayed in the window and to launch the remote management and troubleshooting utilities for that computer.

  • Jobs window:
    Lets you create, modify, cancel, and delete jobs to manage the distribution, installation, and removal of software on your network. Jobs are stored in the SMS database. SMS automatically creates system jobs for maintaining the system. Before you create a job, first create a package and any machine groups, site groups, or queries you might need if you want to limit which computers receive the package.

  • Packages window:
    Lets you create, configure, and manage packages. Packages store information about software so that the software can be identified, distributed, installed on clients, or shared from servers.

  • Program Groups window:
    Lets you create SMS network applications that are delivered to users as program items within program groups.

  • Queries window:
    Lets you search for objects in the database. You use queries to select target computers for software distribution.

  • Event, Alert, and SNMP Trap windows:
    Provide information and tools for managing network assets.

TIP

The SMS Administrator windows are not automatically refreshed. Refresh the display for each Sites window to see changes to your system.

Systems Management Server Database Manager

A tool in Microsoft Systems Management Server (SMS) for managing and maintaining the SMS database. You can use the SMS Database Manager to

  • Delete duplicate, obsolete, or unused data from the database

  • Delete Group Classes, Collected Files, and Unused Records to reclaim wasted database space

  • Set preferences for groups shown in the Personal Computers Properties window

Systems Management Server MIF Form Generator

A tool in Microsoft Systems Management Server (SMS) for creating Management Information Format (MIF) forms for collecting custom data about computers in an SMS system. These MIF forms can be distributed to SMS client users, who can enter information about their computer by using the MIF Entry client tool. Information in the completed forms is returned to the SMS database.

Systems Management Server Security Manager

A tool in Microsoft Systems Management Server (SMS) for viewing and configuring access rights to specific features in the Systems Management Server Administrator program. When a user logs on to an SMS database using the SMS Administrator program, access is granted to sites, packages, queries, and jobs based on the rights previously configured for that user by the Systems Management Server Security Manager. When SMS is first installed, only the database owner (DBO) account possesses all rights to the SMS Administrator program. You use the SMS Security Manager to assign other users rights to the SMS Administrator program.

NOTE

Dependencies between security objects might restrict the sets of rights you can assign to them. For example, a user must have rights to Queries before you can assign any rights to Alerts for that user. The templates included with the SMS Security Manager, which consist of predefined sets of rights, make it easier to assign rights to SMS users.

TIP

Access permissions for objects affect how they appear in the SMS Administrator program. For example, if you have no access to the Packages window, this window will not even appear in the SMS Administrator program.

Systems Management Server Sender Manager

A tool in Microsoft Systems Management Server (SMS) for managing the properties of the SMS senders. You can use the Systems Management Server Sender Manager to control the following:

  • Sending bandwidth (maximum transfer rate per hour)

  • Number of threads and concurrent sessions for each sender

  • Sender retry interval

  • Sender address properties

Systems Management Server Service Manager

A tool in Microsoft Systems Management Server (SMS) for managing the SMS services and service components in an SMS site. You can use the Systems Management Server Service Manager to

  • Start and stop SMS services and components on the site server or on another server

  • Manage and configure tracing on SMS services and components of the SMS Executive

  • View the current run status and tracing status of components

Systems Network Architecture (SNA)

A set of IBM mainframe networking standards and protocols introduced in 1974. Systems Network Architecture (SNA) originally defined a centralized architecture with mainframe hosts controlling terminals, but it has also been adapted for peer-to-peer communication and distributed client/server computing environments. SNA includes services for configuring and managing system resources within an IBM mainframe networking environment.

How It Works

SNA has seven protocol layers and is similar but not identical to the Open Systems Interconnection (OSI) reference model, whose development it influenced. The SNA protocol suite includes the following:

  • Synchronous Data Link Control (SDLC) protocol:
    For data-link layer control of the flow of frames within an SNA network. SNA also supports IEEE 802.5 and 802.2 token passing with Logical Link Control (LLC).

  • Network Control Program (NCP):
    For routing, segmentation, and framing functions. NCP usually runs on the host or on the front-end processor.

  • Virtual Telecommunications Access Method (VTAM):
    For sequencing, flow control, error recovery, and session management functions. You use VTAM to implement Network Accessible Units (NAUs), which control the flow of data, in an SNA network.

  • Advanced Peer-to-Peer Networking (APPN):
    Enables SNA connections between two hosts, such as a PC host accessing an application running on a mainframe host using Advanced Program-to-Program Communications (APPC) sessions. You use APPN to implement Physical Units (PUs) and Logical Units (LUs), which are forms of NAUs that control communication processes for hosts and terminals. LUs represent SNA end nodes such as connections by users or applications, and two LUs communicate by using associated PUs, which are hardware devices or terminals. A number of types of LUs and PUs are used in an SNA networking environment.

  • NetView:
    A network management program for configuring, controlling, troubleshooting, and usage accounting of SNA networks.

Before data can be transferred over SNA, a session must be established between an LU on the client and an LU on the host. For example, a Microsoft Windows NT–based or Windows 2000–based server running Microsoft SNA Server can connect to a mainframe host by using SNA. SNA Server provides connectivity between Windows and SNA environments by providing an SNA gateway running on a Windows NT–based or Windows 2000–based server. Windows clients can then connect to the SNA mainframe host by going through the SNA Server gateway. By using LU 6.2, which is a peer-to-peer protocol, the Windows NT–based server running SNA Server or the mainframe host can initiate the user session. Clients on a Windows NT–based or Windows 2000–based network can then access data stored on the host, including data stored in structured or unstructured AS/400 or Virtual Storage Access Method (VSAM) files, DB2 database tables, and transaction processing monitors.

NOTE

Non-SNA architectures such as Token Ring networks can interface with SNA networks using Service Points (SPs).

SYSVOL share

A shared directory on a domain controller on Microsoft Windows 2000–based networks that contains the server’s copy of the domain public files, such as group policy objects and scripts for the current domain and the entire enterprise. The contents of this share are replicated to all domain controllers in the Windows 2000 domain. The default path for the SYSVOL share is \%System_Root%\Sysvol\SYSVOL.

NOTE

The SYSVOL share must be on an NTFS 5 volume because Active Directory uses the journaling function of NTFS 5 to track replication updates.


T

T1 channel bank

A type of customer premises equipment (CPE) that is used to terminate a T1 line and distribute its services across the organization. T1 channel banks allow T-carrier services to connect at the customer premises to

  • Data terminal equipment (DTE) such as routers or remote access servers that provide wide area network (WAN) data connections for corporate networks

  • Private Branch Exchange (PBX) units that provide integrated phone/fax services

How It Works

A typical T1 channel bank consists of a modular chassis unit to which you can add various expansion cards to provide digital communication services for CPEs. The modular chassis allows customers to add additional channels and upgrade fractional T1 services to full T1 or higher. It also allows customers to multiplex several channels together to provide higher bandwidth for high-speed data connections to routers, Web servers, and other DTEs. The chassis typically includes a built-in T1 Channel Service Unit (CSU) for terminating the T1 circuit at the customer premises, plus a variety of expansion cards for specific uses. Some chassis support up to four T1 lines, which can be configured for both active and backup purposes to provide redundant WAN connections.

Graphic T-1. T1 channel bank.
Graphic T-1. T1 channel bank.

Each expansion card typically services one or two DS0 channels, which means that different channels can supply different services (such as voice, fax, or data connections). Typical types of expansion cards include the following:

  • Data service cards:
    Usually have a dual channel format that supports two DS0 channels and use a serial interface such as RS-232, RS-530, or V.35 for directly connecting to bridges and routers with integrated Channel Service Unit/Data Service Units (CSU/DSUs)

  • High-speed data cards:
    Support up to 1.544 Mbps in 64-Kbps or 56-Kbps increments by selecting the number of DS0 channels to multiplex together

  • Voice cards:
    Used to connect to a PBX or even directly to a telephone using standard 4-wire connections

  • Modem cards:
    Turn your channel bank into a modem pool for remote access functionality

NOTE

Individual DS0 channels might have bandwidths of 56 Kbps or 65 Kbps, depending on the carrier.

T1 line

See
T-carrier

T.120 standard

An umbrella standard representing a suite of eight International Telecommunication Union (ITU) standards that define how real-time multipoint communication for tasks such as data conferencing and interactive game playing takes place over a network. The standards define such things as

  • Multipoint services for conferencing

  • Standard network services

  • Guidelines for defining data channels

  • Whiteboard methodologies

  • Application-sharing protocols

  • File transfer methodologies

T.120 is a multilevel standard that is tuned for reliable transmission within high-bandwidth enterprise environments running TCP/IP and other standard connection types. T.120 is the standard suite of protocols that makes possible collaboration and conferencing software such as Microsoft NetMeeting and is supported by many other telecommunications providers and application vendors.

How It Works

The architecture of the T.120 standard follows that defined by the Open Systems Interconnection (OSI) reference model for networking. The T.120 architecture can be divided into two parts:

  • Network-layer and transport-layer standards (T.122 through T.125):
    Allow data to be transmitted and received between conferencing nodes over a variety of supported network connections. These standards also provide platform independence and the capacity for simultaneously managing multiple participants running on different operating system platforms and conferencing software.

  • Application-layer standards (T.126 through T.128):
    Support multiuser conferencing functions such as whiteboarding, file transfer, and application sharing across different platforms and networks.

The following table shows the details of the various standards included under the T.120 umbrella.

T.120 Suite of Conferencing Standards
Standard | Description
T.121 | A required standard for T.120 applications that defines how conference nodes register themselves with a T.120 node controller. Also defines the generic application template (GAT) for building T.120 application protocols and management facilities.
T.122 | Defines multipoint communication services (MCS) over various topologies to enable multiple participants to send data as part of a conference. The MCS defined by T.122 are implemented by T.125.
T.123 | Defines flow control, error control, and sequencing mechanisms for connect, disconnect, send, and receive functions over different network connections.
T.124 | Defines how multipoint conferences are initiated and administered, and defines the generic conference control (GCC) that manages and monitors users, address lists, data flow, and MCS resources.
T.125 | Defines how data is transmitted during a conference, specifying the private and broadcast channels that transport conference data. T.125 implements the MCS defined by T.122.
T.126 | Defines mechanisms for transmitting and receiving whiteboard information between conference nodes and manages the multiuser whiteboard workspace.
T.127 | Defines mechanisms for file transfer between conference nodes in either broadcast or directed mode.
T.128 | Defines mechanisms for application sharing between conference nodes so that users can share their local programs with others for collaborative purposes.
NOTE

T.120 also forms the basis of the Remote Desktop Protocol (RDP), which is used in Microsoft Windows NT Server, Terminal Server Edition, and in Terminal Services of Microsoft Windows 2000 Advanced Server.

taking ownership

Assuming ownership of an object—usually a file or a folder—on an NTFS volume and thereby gaining the right to share the object and assign permissions to it. The user who creates a file or folder on an NTFS volume is the owner. To take ownership of a file or a folder that you do not own, you must have one of the following:

  • Membership in the Administrators local group

  • NTFS full control permission on the object

  • NTFS special permission O (taking ownership) on the object

  • NTFS special permission P (change permission) on the object, so that you can give yourself O permission

NOTE

Ownership can be taken, but it cannot be assigned.

See also
NTFS permissions (Windows 2000), NTFS permissions (Windows NT), NTFS special permissions (Windows 2000), NTFS special permissions (Windows NT)

tape backup

A general term for a class of devices for backing up data to a magnetic tape for disaster recovery planning and archiving purposes. A number of technologies with incompatible tape formats have been implemented in these devices. The following list describes some of the formats. Note that the capacity and speed of tape drives is rapidly improving. This list gives you an idea of the range of possibilities. Note also that the capacities mentioned in this list are for uncompressed data. With data compression, most of these formats can approximately double the amount of data they hold.

  • Digital audio tape (DAT):
    4-millimeter tape manufactured by a number of different vendors that has tape cartridge capacities of 4 GB and higher. DAT drives use the DDS-2 format for 4-GB tape cartridges, the DDS-3 format for 12-GB cartridges, and the DDS-4 format for 20-GB cartridges. Transfer speeds are typically 1.5 Mbps or higher. DAT cartridges are standardized with a 3.5-inch form factor.

  • Quarter-inch cartridge (QIC):
    Quarter-inch tape manufactured by Tandberg Data that can have tape cartridge capacities of 13 GB and higher. QIC generally uses 5.25-inch cartridges, but these are being replaced with 3.5-inch minicartridges. Transfer speeds are typically 1.5 Mbps or higher.

  • 8 millimeter:
    Can have tape cartridge capacities of 20 GB and higher. Transfer speeds are typically 3 Mbps or higher. 8-millimeter tapes have a form factor of 5.25 inches. Sony and Exabyte are two manufacturers of 8-millimeter tapes.

  • Digital linear tape (DLT):
    Uses technology developed by Digital Equipment Limited (which was acquired by Quantum in 1994). DLT can have tape cartridge capacities of 25 GB and higher. Transfer speeds are typically 5 Mbps or higher. DLT cartridges have a form factor of 5.25 inches. Quantum and Tandburg are two manufacturers of DLT.

See also
backup

TAPI

See
Telephony Application Programming Interface (TAPI)

Task Manager

A Microsoft Windows NT and Windows 2000 utility that you can invoke by clicking the Task Manager button in the Windows Security dialog box. You access the dialog box by pressing Ctrl+Alt+Del, the secure attention sequence (SAS) keystroke combination. You can use Task Manager to

  • Start, view, change the base priority of, and terminate processes

  • Display CPU and memory usage graphs and data

  • Terminate poorly behaving applications

  • Assign a process to a particular microprocessor on a multiprocessor system

    Graphic T-2. Task Manager.
    Graphic T-2. Task Manager.

Task Scheduler

A Microsoft Windows 2000 utility that lets you schedule when to run or open a script, program, or document. Task Scheduler is a useful tool for regularly running system maintenance. Task Scheduler is also the name of the Windows 2000 service that underlies the operation of this utility.

How It Works

You schedule a new task by using the Scheduled Tasks wizard, which you can access through the Scheduled Tasks folder in Control Panel. This wizard prompts you for the following information:

  • The script, program, or other file you want to run or open.

  • The schedule for the task. For example, you can configure a task to run daily, weekly, monthly, when you log on, when the system starts, or only a single time.

  • The credentials under which the task will run. You must specify credentials with sufficient privileges to run the script or program, or to open the file.

  • Advanced options, including how different power management conditions will affect the execution of the task, stopping the task if it runs for too long, or configuring the task to execute when the computer is idle for a specific period of time.

The result of scheduling a task is a task file, which has the extension .job. You can send these task files to and receive them from other users as attachments to e-mail messages. Users can then drag these files into their local Scheduled Tasks folder. Administrators can also view and modify tasks displayed in the Scheduled Tasks folder called \Winnt\Tasks on remote computers by using My Network Places.

Once a task has been scheduled, you can modify, delete, disable, or stop its execution. The service creates a log file of past scheduled tasks that can be viewed using the Advanced menu of the Scheduled Tasks folder.

NOTE

Task Scheduler provides a friendlier, GUI-based interface for scheduling system tasks than the at command used at the command prompt for scheduling tasks in Microsoft Windows NT. The at command is still available in Windows 2000, and tasks scheduled using this command appear in the Scheduled Tasks folder. However, if you use the GUI-based Task Scheduler to modify a task that was scheduled using the at command, you no longer will be able to use the at command to modify the task.

TIP

You can also schedule a task by dragging the icon for a script, program, or document from My Computer or Windows Explorer into the Scheduled Tasks folder.

If scheduled tasks do not run when expected, check the system date and time on your computer to see whether they are accurate.

If you have trouble using the at command to schedule a task, you might have accidentally changed the security context (credentials) under which the command runs. Check this using the Advanced menu of the Scheduled Tasks folder.

T-carrier

A series of digital communication services provided by telcos for high-speed permanent voice and data connections. T-carrier services were first developed by Bell in the 1960s for digital transmission of analog voice communication. Telcos typically use T1 lines to connect telephone exchange switching equipment within the telco’s central office (CO).

Common uses for T1 lines from a networking perspective include the following:

  • Building dedicated, high-speed wide area networks (WANs)

  • Providing corporate networks with high-speed access to the Internet

  • Connecting corporate intranet/extranet web servers to the Internet

  • Providing high-speed remote access solutions for companies with mobile users

  • Providing integrated voice/fax/data services to businesses

Graphic T-3. Uses for T1 routers.
Graphic T-3. Uses for T1 routers.
How It Works

The T-carrier system is based on the DS1 signaling standard defined by AT&T. A DS1 channel is formed from a combination of 24 DS0 (Digital Signal Zero) channels with 64 Kbps of bandwidth each, for a total bandwidth of 1.544 Mbps. This configuration is called a T1 circuit and is the base circuit from which other T-carrier circuits are derived. The 24 DS0 channels can either be used separately for voice and data or be combined by using a technique called time-division multiplexing (TDM), in which voice or data information from each channel is interleaved into a single bit stream. A DS1 frame is thus composed of 1 byte (8 bits) from each DS0 channel plus 1 bit of framing control. The transmission rate of frames is set at 8000 frames per second, which means that the total bandwidth of a T1 circuit or DS1 communication channel can be calculated using this formula:

T1 = 8000 frames/sec x ((24 x 8) + 1) bits/frame
   = 1544000 bits/sec
   = 1.544 Mbps

Because of the framing bit, the actual bandwidth of a T1 line for data transmission is slightly less than this, at 1.536 Mbps. Synchronization is maintained between T1 equipment at the customer premises and the telco CO by varying the framing bit using a predetermined algorithm. The most flexible T1 solution for customer premises is to use a T1 channel bank to interface local area networks (LANs), Private Branch Exchanges (PBXs), and telephone and fax equipment with a T1 circuit leased from a local telco.

Other special-purpose T1 equipment that you can buy or lease includes

  • T1 CSU/DSU, a Channel Service Unit/Data Service Unit for connecting bridges or routers to T1 circuits

  • T1 MUX, a multiplexer for aggregating T1 circuits for high-speed communication

  • T1 bridges and routers, with or without integrated T1 CSU/DSUs, for dedicated point-to-point or multipoint WAN connections for enterprise-level internetworks

  • T1 access routers for providing remote access services and allowing multiple, simultaneous remote access connections to be channeled through a single T1 line at the customer premises

Other T-carrier services provided by telecommunications carriers include the following:

  • Fractional T1 circuits, consisting of 4, 8, 12, or more DS0 channels multiplexed together

  • Multiples of T1, such as T2, T3, and T4, as shown in the following table

T-Carrier Services
T-Carrier Service | Number of DS0 Channels | Bandwidth
T1 | 24 | 1.544 Mbps
T2 | 4 x 24 = 96 | 6.312 Mbps
T3 | 18 x 24 = 432 | 44.736 Mbps
T4 | 168 x 24 = 4032 | 274.176 Mbps
NOTE

T-carrier services such as T1 lines are often used to provide networks with high-bandwidth, permanent WAN connections between sites. T1 is the preferred technology for combining voice, fax, and data transmissions over an enterprise-level internetwork. T1 lines can be expensive because, whether or not they are being used, they are always “on.” A cheaper solution is to lease a fractional T1 service such as 4 x DS0 = 256 Kbps and then upgrade it to higher speeds as necessary. Fractional T1 is usually cheaper than using individual DS0 circuits at the customer premises and multiplexing them together.

T1 cannot be run over Plain Old Telephone Service (POTS) lines. They must use specially conditioned two-pair copper lines. Two wires are used for transmission (TX interface) and two for receiving (RX interface) for full-duplex communication. A repeater is typically required every 915 meters or 3000 feet to regenerate the signal. T1 lines typically terminate at the customer premises using an RJ-48 jack, which looks like an RJ-45 jack but is pinned differently. T1 lines can use unshielded twisted-pair (UTP) cabling, coaxial cabling, or fiber-optic cabling.

T1 circuits use either AMI (Alternate Mark Inversion) or B8ZS line coding. AMI encodes zeros as 01 and ones alternately as 00 and 11. B8ZS substitutes a special byte if eight consecutive zero bits are detected in order to maintain a specific ones density to help maintain synchronization. (Ones density is a scheme that allows a CSU/DSU to recover the data clock reliably. The CSU/DSU derives the data clock from the data that passes through it. To recover the clock, the CSU/DSU hardware must receive at least one 1-bit value for every 8 bits of data that pass through it. Ones density is also called pulse density.)

TIP

To test T1 customer premises equipment (CPE) such as channel banks and CSU/DSUs, you can use a cable simulator, a passive device that simulates a standard 22-gauge twisted-pair T1 line that is 400 meters (1310 feet) long. Connect two cable simulators between your CPE and your T1 test equipment using the TX and RX interfaces to analyze the performance of your device. (Or use 400 meters of 22-gauge twisted-pair cabling instead!)

A “wet” T1 line carries a small DC current of about 140 mA (milliamperes) at several hundred volts for powering the CSU/DSU at the customer premises. “Dry” lines carry no current, so CSU/DSUs must be powered from the customer premises. Don’t touch a T1 line—a wet line can give you a serious shock!

See also
RJ connectors, T1 channel bank

TCP

See
Transmission Control Protocol (TCP)

TCP/IP

An abbreviation for Transmission Control Protocol/Internet Protocol, an industry-standard protocol suite for wide area networks (WANs) developed in the 1970s and 1980s by the U.S. Department of Defense (DoD). TCP/IP is a routable protocol that is suitable for connecting dissimilar systems (such as Microsoft Windows and UNIX) in heterogeneous networks, and it is the protocol of the worldwide network known as the Internet. Microsoft’s implementation of TCP/IP supports industry standards, and TCP/IP is implemented for all Windows operating systems.

Graphic T-4. TCP/IP.
Graphic T-4. TCP/IP.
How It Works

The architecture of the TCP/IP protocol suite has four layers that map loosely to the seven-layer Open Systems Interconnection (OSI) reference model (as shown in the diagram). The TCP/IP model is sometimes called the DoD model because TCP/IP was developed in connection with the ARPANET project of the U.S. Department of Defense. Each layer of the TCP/IP protocol suite has its associated component protocols, the most important of which are listed here:

  • Application layer protocols:
    Responsible for application-level access to TCP/IP networking services. These include Dynamic Host Configuration Protocol (DHCP), Domain Name System (DNS), Hypertext Transfer Protocol (HTTP), File Transfer Protocol (FTP), Telnet, Simple Mail Transfer Protocol (SMTP), and Simple Network Management Protocol (SNMP). In the Microsoft implementation of TCP/IP, application layer protocols interact with transport layer protocols by using either Windows Sockets or NetBIOS over TCP/IP (NetBT).

  • Transport layer protocols:
    Establish communication through connection-oriented sessions and connectionless broadcasts. Protocols at this layer include Transmission Control Protocol (TCP) and User Datagram Protocol (UDP).

  • Internet layer protocols:
    Responsible for routing and encapsulation into IP packets. Protocols at this layer include Internet Protocol (IP), Address Resolution Protocol (ARP), Internet Control Message Protocol (ICMP), and Internet Group Management Protocol (IGMP).

  • Network layer protocols:
    Place frames on the network. These protocols include the various local area network (LAN) architectures (such as Ethernet and Token Ring) and WAN telecommunication service technologies—such as Plain Old Telephone Service (POTS), Integrated Services Digital Network (ISDN), and Asynchronous Transfer Mode (ATM).

TCP/IP uses two naming schemes to identify hosts and networks on an internetwork:

  • IP addresses:
    Logical 32-bit (4-byte) numeric addresses of the form w.x.y.z. They are partitioned (using a subnet mask) into two segments, a network ID and a host ID. For example, the IP address 205.116.8.44 is partitioned using the subnet mask 255.255.255.0 into the network ID 25.116.8.0 and the host ID 44. IP addresses are the basic or primary way of identifying hosts and networks on an internetwork; they can be assigned to computers manually or by using DHCP.

  • Fully qualified domain names (FQDNs):
    Alphanumeric names of the form host_name.domain_name in which domain_name is part of DNS, a hierarchical worldwide naming system. For example, the FQDN server12.microsoft.com represents a host named server12 that belongs to a network whose domain name is microsoft, which belongs to the top-level domain named .com, which belongs to the root DNS domain named dot. FQDNs are friendly names. They are easier to remember than IP addresses and are resolved into IP addresses by using a DNS server or a local hosts file.

NOTE

TCP/IP is a constantly evolving protocol suite whose development is steered by such bodies as the Internet Society (ISOC), the Internet Architecture Board (IAB), and the Internet Engineering Task Force (IETF). The current version of TCP/IP is called IPv4 (Internet Protocol version 4); a new version called IPv6 is under development.

TCP/IP-32 for Windows for Workgroups

An add-on for Microsoft Windows for Workgroups that provides a 32-bit implementation of the TCP/IP protocol. This add-on includes features such as the following:

  • An industry-standard implementation of the TCP/IP protocol suite

  • Windows Sockets and NetBIOS programming interfaces

  • The TCP/IP client utilities File Transfer Protocol (FTP) and Telnet

  • The TCP/IP diagnostic utilities arp, ipconfig, nbtstat, netstat, ping, route, and tracert

  • Support for Dynamic Host Configuration Protocol (DHCP) and Windows Internet Naming Service (WINS)

  • Support for the User Datagram Protocol (UDP), Address Resolution Protocol (ARP), and Internet Control Message Protocol (ICMP)

NOTE

You can create installation disks for this software by using the Network Client Administrator tool in Microsoft Windows NT.

TCP three-way handshake

A method of initializing a Transmission Control Protocol (TCP) session between two hosts on a TCP/IP network. The handshake establishes a logical connection between the hosts by synchronizing the sending and receiving of packets and communicating TCP parameters between the hosts.

How It Works

All TCP communication is connection oriented. A TCP session must be established before the hosts in the connection exchange data. Packets that are transferred between hosts are accounted for by assigning a sequence number to each packet. An ACK, or acknowledgment, is sent after every packet is received. If no ACK is received for a packet, the packet is re-sent. The three-way handshake ensures that the initial request is acknowledged, that the data is sent, and that the data is acknowledged.

These are the three stages of a TCP three-way handshake:

  1. The initiating host sends a TCP packet requesting a new session. This packet contains the initiating host’s sequence number for the connection. The packet includes information such as a set SYN (synchronization) flag and data about the size of the window buffer on the initiating host.

    Graphic T-5. TCP three-way handshake.
    Graphic T-5. TCP three-way handshake.

  2. The target host sends a TCP packet with its own sequence number and an ACK of the initiating host’s sequence number.

  3. The initiating host sends an ACK containing the target sequence number that it received.

NOTE

A similar three-way process is used to terminate a TCP session between two hosts. Using the same type of handshake to end the connection ensures that the hosts have completed their transactions and that all data is accounted for.

TDI

See
Transport Driver Interface (TDI)

TDM

See
time-division multiplexing (TDM)

TDMA

See
Time Division Multiple Access (TDMA)

TDR

See
time domain reflectometry (TDR)

TechNet

See
Microsoft TechNet

telco

Stands for telephone company and can be one of the following:

  • A local provider of a Plain Old Telephone Service (POTS) connection through the local loop connection from its central office (CO)

  • Any telecommunications service provider (including long-distance carriers)

Telcos offer a variety of high-speed data transmission services, including Integrated Services Digital Network (ISDN), frame relay, T1 lines, and Asymmetric Digital Subscriber Line (ADSL). Networks connect their customer premises equipment (CPE) to similar equipment at telco COs for such purposes as

  • Point-to-point or multipoint connections for creating a wide area network (WAN) with other company locations

  • High-speed dedicated access to the Internet for corporate users

  • Dial-up remote access solutions using modems or ISDN

Telecommunications Industry Association (TIA)

A national trade organization representing all aspects of the telecommunications industry in the United States. Working in conjunction with its subsidiary, the MultiMedia Telecommunications Association (MMTA), and its industry peer organization, the Electronic Industries Alliance (EIA), the Telecommunications Industry Association (TIA) represents its members in activities such as establishing public policies and government regulatory issues, developing standards for communication and networking, and organizing trade shows and other events. The goal of the TIA is to provide member companies, which are drawn mostly from service providers and hardware vendors in the communication industry, with a forum for discussing industry issues and a voice for representing members’ interests on the national and international level.

Active in telecommunications standards development, the TIA is endorsed and accredited by the American National Standards Institute (ANSI). The Standards and Technology Department consists of five divisions expressed in over 70 groups responsible for formulating new standards. These five divisions are as follows:

  • Fiber Optics

  • User Premises Equipment

  • Network Equipment

  • Wireless Communications

  • Satellite Communications

On the Web
•
TIA Online
: http://www.tiaonline.org

telecommunications services

Internetworking services provided by telcos and long-distance carriers to businesses. To link geographically separated local area networks (LANs) into a metropolitan area network (MAN) or a wide area network (WAN), businesses must lease or purchase services from their local telco and long-distance carriers because these companies own the wires that make internetworking possible. In addition to the regular Public Switched Telephone Network (PSTN) service, most telecommunications companies offer additional services, including the following:

  • Leased lines, such as T1 lines for permanent, dedicated point-to-point WAN connections

  • Circuit-switched services, such as Integrated Services Digital Network (ISDN) for temporary or dial-up point-to-point WAN connections

  • Packet-switched services, such as X.25 services for permanent multipoint WAN connections

Various data communication technologies are used to provide these services, including the following:

  • Asynchronous Transfer Mode (ATM)

  • Digital data service (DDS)

  • Frame relay

  • ISDN

  • Switched 56

  • T1 and fractional T1

Telephony Application Programming Interface (TAPI)

A set of standard application programming interfaces (APIs) for accessing telephony services developed by Microsoft and Intel and implemented in Microsoft Windows.

Telephony Application Programming Interface (TAPI) receives requests from applications and forwards them to telephony devices such as modems, telephones, Integrated Services Digital Network (ISDN) equipment, or Private Branch Exchanges (PBXs). TAPI manages such functions as

  • Signal

  • Hold and transfer

  • Conference and call park

  • Other PBX functions

TIP

If you travel frequently and use a laptop, create a TAPI location for each geographical site that you commonly visit. A TAPI location is a set of information used by dial-up networking that specifies a country, area code, dial-out information, and calling card information. TAPI-aware applications such as dial-up networking use TAPI locations to correctly dial from a given location.

telnet

A standard TCP/IP protocol for running programs on remote hosts. The term “telnet” also refers to the software (client or server component) that implements this protocol on a particular platform or system. Telnet is defined in Request for Comments (RFC) 854.

How It Works

Telnet is a terminal emulation program, which is a command-line interface for issuing commands on a remote computer. A user running telnet client software can interactively run command-line applications on a remote host that is running the telnet service or daemon. The user enters information at the telnet client; this information is processed on the telnet server and its output is returned to the user. For example, if you use telnet to connect to a UNIX server, you can issue UNIX commands to remotely perform operations on that server.

NOTE

Microsoft Windows NT includes a telnet client implemented as a Microsoft Windows application, but does not include telnet server software. Windows 2000 includes both a telnet client implemented as a command-line utility and telnet server software that supports up to 63 simultaneous client connections but is licensed to only provide up to two simultaneous client connections. If you require support for additional client connections, you should obtain the Windows Services for UNIX add-on pack for Windows 2000 Server.

TIP

You can use a telnet client to connect to a Web server on port 80 or a Simple Mail Transfer Protocol (SMTP) mail server on port 25 and issue Hypertext Transfer Protocol (HTTP) or SMTP commands directly to the server for troubleshooting purposes.

terminal

Generally, any device that terminates a communication channel. In computer terminology, a terminal is an input/output (I/O) device, usually consisting of a keyboard and monitor, that acts as a front end for a mainframe, terminal server, or other back-end processing device. The earliest terminals were called teletypes (abbreviated TTY), which were essentially electric typewriters in which users would enter commands and data for a mainframe, and on which the mainframe would type the output returned to the user. A terminal that supports only text output is sometimes called an ASCII terminal.

How It Works

Terminals generally have little or no inherent data-processing power and rely entirely on the back-end system to do the processing. The terminal is responsible only for processing and queuing input from the keyboard (or other input device such as the mouse), transmitting this in a recognized format to the back-end host (mainframe or terminal server), and receiving output from the host and presenting it on the screen in suitable format for the user (ASCII text in older systems, graphical desktop environment in newer systems). This explains the origin of the term “dumb terminal,” which means that a terminal by itself is generally useless without connecting to the back-end system. However, there are also “smart” or “intelligent” terminals that have various degrees of inherent processing capability. The information the user enters on the keyboard is typically transmitted to a mainframe over an RS-232 or RS-423 asynchronous serial connection, but it is sometimes transmitted over an Ethernet or a Token Ring local area network (LAN) connection. The mainframe processes the input and returns the output to the terminal, which displays the output on the monitor. In other words, the application runs in one location (the mainframe), while the user interface is in a different location (the terminal).

Terminals originated in the mainframe environment, and a number of standards (terminal protocols) have evolved that govern their use. The VT-100 terminal originated by Digital Equipment Corporation was a popular ASCII-text-based terminal standard that is still used in places such as library online catalog systems, which remote users typically access by running a telnet client over a dial-up connection. IBM’s 3270 terminal protocol is still widely used in IBM mainframe environments, while 5250 is popular in AS/400 mid-range computing environments. Other terminal standards include ANSI, VT52, and VT220.

Terminals can be one of the following:

  • Local terminals that are directly connected to the back-end host via a serial or LAN connection

  • Remote terminals that are typically connected via a phone line with a modem at both ends

The popularity of terminals declined in the late 1980s and early 1990s with the advent of distributed client/server environments and the eclipse of mainframe computing environments. In a client/server environment, data processing is shared between the front-end client computer, usually a full-featured PC with a graphical user interface (GUI) such as Microsoft Windows, and the back-end server, which can be a Windows NT–based server, a Novell NetWare server, an AS/400, or some other system. In the late 1990s, the pendulum started to swing back toward terminals with the rising popularity of PC-based terminal emulators and terminal servers. A terminal emulator is hardware and/or software that runs on a stripped-down PC with no operating system and causes the PC to function as a terminal, while a terminal server is a back-end server that generates and delivers the user desktop environment to the terminals and performs all the processing. This arrangement allows for low-cost “thin clients” to be used and centralizes system administration at the back end, reducing deployment and management costs associated with a distributed client/server systems environment.

See also
terminal emulator, terminal server

terminal emulator

Hardware and/or software that allows a PC to operate as a terminal and connect to a back-end mainframe or terminal server. Terminal emulators can be designed to emulate specific terminal modes such as ANSI, VT52, VT100, VT220, TN3270, or TN5250. Microsoft HyperTerminal, included with 32-bit Microsoft Windows operating systems, supports a variety of different terminal emulation modes.

TIP

The emulation mode on the clients must match the terminal mode running on the back-end system in order for communication to work. If you are trying to connect to an unknown mainframe or other back-end system and your emulator cannot automatically detect the terminal mode needed, try using ANSI mode first. If that fails, try VT100 and other popular terminal modes.

See also
terminal

terminal server

Generally, a server that provides the back-end support needed for terminals to function. This can be a mainframe system, a UNIX host running X Windows, or a PC-based server running software such as Microsoft Windows NT Server, Terminal Server Edition, or Microsoft Windows 2000 Server. The terminal server generates the desktop environment presented to the user on the terminal and performs all processing of data submitted by the user. The main advantages of such a system are as follows:

  • Lower hardware costs:
    “Thin clients” (special devices or stripped-down PCs) can be used instead of full-featured desktop PCs. For example, Windows NT Server, Terminal Server Edition, can present a 32-bit Windows user environment on older PCs that lack the hardware requirements for running a local copy of the latest versions of Microsoft Windows operating systems.

  • Lower management costs:
    Operating systems and applications are installed and run only on the back-end terminal servers, which simplifies deployment and troubleshooting and makes administration more centralized. Windows NT Server, Terminal Server Edition, and Windows 2000 Server, for example, support running applications such as Microsoft Office from central servers instead of installing them on every desktop client in the enterprise.

  • Multiplatform support:
    Allows the same applications and desktop environments to be presented on a variety of client platforms, including Windows-based PCs, Macintosh computers, UNIX workstations, and other devices.

Some vendors produce rack-mountable terminal server devices with 8 or 16 RJ-45 ports that can be used to connect asynchronous terminals to an Ethernet local area network (LAN) running TCP/IP or some other network protocol. Such devices can be used to provide terminals (or PCs running terminal emulation software) with access to network file servers or dial-up access to the Internet. Windows-based management software allows these devices to be remotely managed from a PC for viewing and configuring port information. Built-in support for Password Authentication Protocol (PAP), Challenge Handshake Authentication Protocol (CHAP), and Remote Authentication Dial-In User Service (RADIUS) are often included to control user access. Users can dial in to the device, be authenticated, and select a desired host on the LAN they want to communicate with.

Single-port terminal servers are sometimes used in mainframe environments to allow users connected to different controllers to communicate over the corporate LAN without needing a dedicated point-to-point communication link. In a typical configuration, the controller is connected to a terminal server via an RS-232 serial connection, while the terminal server is linked to the LAN via an Ethernet interface.

See also
terminal, terminal emulator

Terminal Services

An optional component of Microsoft Windows 2000 Server that enables users to access the Windows 2000 desktop and run Microsoft Windows applications on remote computers and terminal devices. Terminal Services enables Windows 2000 Server to function as a terminal server and provide terminal emulation for a wide range of client computers. By moving all processing to the server, Terminal Services reduces total cost of ownership by

  • Simplifying system administration by centralizing the installation and management of all applications on the server and supporting full remote administration from a single desktop

  • Extending the life of legacy hardware by enabling client computers with minimal processing power and memory to run standard Windows applications

  • Extending the life of legacy operating systems by allowing applications designed for Windows 2000 to run on legacy versions of Windows

  • Increasing security by using encrypted sessions between clients and servers, by enabling administrators to fully monitor and control user operations by shadowing client sessions from another client computer, and by enabling administrators to input keyboard and mouse actions during client sessions for remote control purposes

How It Works

In order for Terminal Services to work on a network, you must implement three components:

  • Terminal server:
    A Windows 2000–based server that provides each client computer with its own Windows desktop, receives and processes all keystroke and mouse actions performed by clients, and sends the display output for the operating system and applications to the appropriate client.

  • Remote Desktop Protocol (RDP):
    A protocol suite based upon the T.120 standard from the International Telecommunication Union (ITU), which provides the basis for communication between the client and the terminal server.

    Graphic T-6. Terminal Services.
    Graphic T-6. Terminal Services.

  • Terminal Services client:
    A “thin client” that displays the Windows 2000 desktop and running applications within a window on the client computer. Terminal Services clients are provided for all versions of Windows, including 32-bit clients that can run on computers running Windows 2000, Windows NT 4.0, Windows NT 3.51, Windows 98, or Windows 95 on either Intel or Alpha platforms, and a 16-bit client for Windows for Workgroups 3.11. Special client software can also be embedded in devices such as Windows-based terminals and handheld PCs.

You can install Terminal Services during Setup or afterward using Add/Remove Programs in Control Panel. To use Terminal Services, you must install both Terminal Services and Terminal Services Licensing, and you need to specify the directory location of the licensing server database. Once the services are installed, you can configure the security of the terminal server to allow users to remotely run multiuser applications, configure user accounts to allow them to log on to the terminal server, create user profiles and home directories if desired, and install Terminal Services client software on client computers. You can install client software either by downloading it across the network or by creating client installation disks for manual installation.

NOTE

The implementation of RDP on Windows 2000 requires that TCP/IP be implemented as the underlying network transport.

TIP

By installing the Citrix MetaFrame add-on, non-Windows clients such as UNIX, Macintosh, and OS/2 Warp can also access a Windows 2000–based server running Terminal Services in order to run Windows 2000 applications.

A good rule of thumb is that a terminal server needs an additional 4 to 8 MB of RAM for each additional client it supports. Also, do not run legacy MS-DOS or 16-bit Windows on the terminal server, as this can significantly reduce the number of concurrent users that the server can support and increase the memory requirements for each connected client.

Install Terminal Services on a member server instead of a domain controller. Installation on a domain controller can affect the domain controller’s performance as a result of the additional load that Terminal Services places on server processor, memory, and network interface.

terminator

A device connected to one end of a bus or cable that absorbs signals. Terminators prevent signal reflection, which can produce interference that causes signal loss. Most communication systems such as networks and computer buses require some form of termination at the ends of the data path, although this is often provided internally by the devices at the ends of the data path.

How It Works

In a bus-based system, a single wire or series of wire segments connects network components in a chain formation. If the ends of the cable are not terminated, a signal placed on the wire by one component will bounce back and forth between the ends of the cable, hogging the cable and preventing other components from signaling. Terminators eliminate this signal bounce by absorbing the signal after each component has seen it once, allowing other components to place their signals on the cable.

Terminators can be passive (simple resistors) or active (more complex electronics) depending on the type of bus being terminated. By supplying a load equal to the impedance of the cable, the terminator prevents reflections or standing waves from developing on the cable. Passive terminators use resistors to provide this impedance matching, while active terminators generally use voltage regulators.

Terminator types include the following:

  • Coaxial cabling terminators:
    Passive terminators that come in various sizes and use BNC threading to terminate

    • RG-58 thinnet cabling for 10Base2 Ethernet networks with termination resistance of 50 ohms

    • RG-59 cable television terminators with resistance of 75 ohms

    • RG-62 ARCNET cabling terminators with resistance of 93 ohms

  • Small Computer System Interface (SCSI) terminators:
    The ends of a SCSI cable must always be terminated in a chain of SCSI devices. The internal termination is usually supplied by the SCSI adapter card, and the external termination is supplied by the last device in the chain. SCSI terminators can be passive, active, differential, or forced-perfect. Forced-perfect terminators compensate for the differences in impedance along the length of a SCSI bus. Diagnostic terminators analyze and display the condition of the data paths within a SCSI bus and are useful for high-availability uses such as clustering.

  • Free connectors:
    Connectors on the hubs at both ends of a series of stackable hubs. These terminators are specific to the type of hub sold by a vendor.

TIP

You can test the termination of a long 10Base2 network without having to hunt for the ends of the cable. Simply use an ohmmeter and test the resistance between the central conductor and the shield of any BNC T-connectors (after removing the cable from the network card it is attached to). If the reading is around 25 ohms, the cable is properly terminated; if the reading is around 50 ohms, one of the terminators is loose or missing. If the cable appears to be properly terminated but network problems persist, remove one of the terminators and use the ohmmeter to test the connection to the T-connector that you just exposed. If the result is less than 50 ohms, you probably have a short in the cable; if it is more than 56 ohms, there is probably a loose T-connector somewhere on the network.

Graphic T-7. A terminator can be used to test thinnet cabling.
Graphic T-7. A terminator can be used to test thinnet cabling.

Terrestrial Trunked Radio (Tetra)

An initiative from the European Telecommunications Standards Institute (ETSI) for a single standard for digital mobile radio services. Terrestrial Trunked Radio (Tetra) is defined in a memorandum of understanding between a number of different equipment vendors, service providers, testing bodies, and regulatory agencies that was laid out in 1994. Tetra consists of two complementary standards:

  • A standard Time Division Multiple Access (TDMA) cellular communication system for voice and data communication on 25-kHz channels

  • A Packet Data Optimized (PDO) protocol for packet-switched data-only transmission at 36 Kbps on 25-kHz channels

Tetra includes support for security features such as multilevel authentication and encryption, allows voice and data communication to be combined using the same equipment, and supports multiplexing of up to four channels to provide data rates of up to 144 Kbps. Tetra is complementary to the Global System for Mobile Communications (GSM) cellular communication standard: GSM can be considered an extension of the Integrated Services Digital Network (ISDN) to the wireless domain, while Tetra is an extension of ISDN Private Branch Exchange (PBX) systems to the same domain. Tetra thus provides additional communication functionality not built into GSM, such as direct mobile-to-mobile communication that bypasses the communication infrastructure, support for broadcast and group call features, fast call setup, priority call, and so on.

NOTE

Because of the recent growth of the Internet and wide demand for high-speed wireless mobile data services, a new high-speed wireless mobile packet-switching system called the Digital Advanced Wireless System (DAWS) is currently being developed by the ETSI to supersede the Tetra PDO standard.

On the Web
•
Tetra home page
: http://tetramou.com
See also
Digital Advanced Wireless System (DAWS)

test equipment

A general name for equipment used to configure, diagnose, and troubleshoot networking and telecommunications systems. Test equipment is invaluable to busy network administrators for troubleshooting local area network (LAN) or wide area network (WAN) connections, to system integrators who install networks and communication services at customer premises, and to wiring and cabling installation service people. You can buy test equipment for dedicated, single-use testing purposes, but multifunction test equipment is more cost effective.

Test equipment comes in all shapes and sizes, from rack-mounted equipment for enterprise troubleshooting, to hand-held scanners and packet sniffers, to laptops that run special software and use special PCMCIA-attached probes. Here are some examples:

  • Copper cable testers:
    Typically hand-held devices that can test installed copper cabling for compliance with EIA/TIA standards for cabling system performance. These are usually multifunction devices that support both coaxial cabling and twisted-pair cabling. Two-way testers enable you to test a cable from both ends.

  • Fiber-optic cable testers:
    Usually a separate category from coax/twisted-pair cable testers. These devices might support testing of single-mode fiber-optic cabling, multimode fiber-optic cabling, or both, and provide detailed measurements in decibels for optical link budget (OLB) calculations to ensure that a fiber installation will support the intended equipment layout. A typical fiber tester consists of two modules: a light source for injecting signals into the system at 850 or 1300 nanometers (depending on the type of fiber) and a power meter to measure what comes out the other end. Some devices include both functions and can be used to test fiber that is still on the spool.

  • Token Ring testers:
    Test for shorts, opens, and grounds on shielded twisted-pair (STP) cabling in Token Ring installations.

  • LAN analyzers (sniffers):
    For troubleshooting problems with LAN protocols at all levels of the Open Systems Interconnection (OSI) reference model protocol stack, from lower-level protocols such as Data Link Control (DLC), IPX/SPX, NetBEUI, and TCP/IP to higher-level protocols such as File Transfer Protocol (FTP), Hypertext Transfer Protocol (HTTP), NetBIOS, Server Message Block (SMB), and Simple Mail Transfer Protocol (SMTP). These devices basically capture LAN traffic and allow you to analyze and filter packets that use specific protocols, that are transmitted and received from specific computers, that are portions of a specific communication session between two computers, and so on. Microsoft Network Monitor, which is included with Microsoft Systems Management Server (SMS), Microsoft Windows 2000, and Microsoft Windows NT, is a software-based sniffer that runs on any PC with a network card and can capture and analyze most forms of LAN traffic.

  • SCSI testers:
    Test Small Computer Systems Interface (SCSI) buses for shorts, opens, or improper termination. These are usually dedicated to a specific type of SCSI interface.

  • ISDN and T1 test equipment:
    Includes continuity testers, channel testers, and line-quality analyzers for testing Integrated Services Digital Network (ISDN) and T-carrier circuits. They can sample frames to check for jitter and lack of synchronization.

  • WAN analyzers:
    Test serial transmission protocols such as RS-232 and V.35, which are used to connect WAN devices such as routers and bridges to Channel Service Unit/Data Service Units (CSU/DSUs). They are typically used to troubleshoot frame relay, High-level Data Link Control (HDLC), Point-to-Point Protocol (PPP), Synchronous Data Link Control (SDLC), Serial Line Internet Protocol (SLIP), Systems Network Architecture (SNA), and X.25 connections. You can connect a WAN analyzer to a serial connection by using a Y-shaped connector called a data tap, which lets you monitor communication without interfering with the data being transmitted.

TIP

Use a cable tester on a new enhanced category 5 cabling installation before you install and configure your Fast Ethernet network equipment. Good-quality cable testers typically test all four pairs of wires in unshielded twisted-pair (UTP) cabling over frequencies of up to 100 MHz or higher, checking cable integrity for shorts and opens, measuring cable segment lengths using time domain reflectometry (TDR), and allowing measurement of attenuation, near-end crosstalk (NEXT), and PowerSum NEXT to an accuracy of 0.1 decibels or better.

Cable testers can trace cables through walls, ceilings, and floors by measuring the length of a cable and telling you whether the cable is terminated, has an open end, is connected to a port on a hub, and so on. You can plug two-way cable testers into a wall plate and test the patch panel to find out which cable connects to the wall plate.

Tetra

See
Terrestrial Trunked Radio (Tetra)

text file

See
ASCII file

TFTP

An abbreviation for Trivial File Transfer Protocol, a TCP/IP file transfer protocol. TFTP differs from the popular File Transfer Protocol (FTP) in that it does not support any form of authentication. TFTP is defined in Request for Comments (RFC) 1350.

How It Works

TFTP copies files to and from remote hosts by using the User Datagram Protocol (UDP). The remote host must be running the TFTP service or daemon for the TFTP client to be able to communicate with it. In UNIX networks that use diskless workstations and the bootstrap protocol (BOOTP), TFTP is usually used to download the boot disk image from the BOOTP server to the workstation.

NOTE

Microsoft’s implementation of TCP/IP on Microsoft Windows NT does not include TFTP service but does include a command-prompt TFTP client. On the Microsoft Windows 2000 platform, in addition to the command-prompt TFTP client there is an optional TFTP service called the Trivial File Transfer Protocol Daemon (TFTPD), which is installed when the Remote Installation Services component of Windows 2000 Server is enabled.

thicknet

The coaxial cabling used in standard Ethernet or 10Base5 networking. Thicknet coaxial cabling is usually 3/8 inch in diameter. It is fairly rigid, has an impedance of 50 ohms, and can carry signals up to 500 meters (1640 feet)—hence the designation 10Base5 for “10-Mbps baseband transmission over 500 meters.”

How It Works

To connect a computer to a thicknet cable, you attach a vampire tap to the cable. The tap pierces the cable’s insulation layers and makes contact with the signal-carrying copper core. The tap is connected to a transceiver, and a drop cable connects the transceiver to an AUI connector on the computer’s network interface card (NIC).

NOTE

Thicknet was commonly used in the 1980s, primarily for Ethernet cabling. It has largely been superseded by twisted-pair and fiber-optic cabling.

See also
10Base5, coaxial cabling

thin coax

See
thinnet

thinnet

The thin coaxial cabling used for 10Base2 installations of Ethernet networking. Thinnet cabling is RG-58 coaxial cabling that is 3/16 inch in diameter and has an impedance of 50 ohms. Thinnet uses BNC connectors to connect cable segments, computers, and concentrators (hubs). Many older hubs, bridges, routers, and other networking devices have at least one thinnet port for connecting to 10Base2 networks. Thinnet was often used in the 1980s for workgroup or departmental local area networks (LANs); it has largely been replaced by unshielded twisted-pair (UTP) cabling.

TIP

Thinnet cables must be terminated at both ends. If communication is down, check the termination points, and then check for loose BNC T-connectors attached to the computers on the network. Thinnet cabling can become damaged if it is sharply bent or twisted, so handle it carefully. (It is not nearly as fragile as fiber-optic cabling, however.)

One place where thinnet is still useful is in electrically noisy environments such as shop floors in factories, where electromagnetic interference (EMI) caused by motors, generators, and other heavy equipment can disrupt communication over UTP. Coaxial cabling, with its internal shielding, can easily withstand the noise.

See also
10Base2, coaxial cabling

TIA

See
Telecommunications Industry Association (TIA)

ticket

A certificate issued by the Kerberos service running on a Microsoft Windows 2000–based network that approves an authenticated session. A ticket contains a session key, the name of the user to whom the session key was provided, the expiration time for the ticket, and additional information. The ticket’s expiration time is configured so that the session length doesn’t exceed the period specified by the domain security policy. If a ticket expires while a client and server have an active session open, the Kerberos service informs both the client and the server to refresh the ticket and generates a new session key for them.

Time Division Multiple Access (TDMA)

A cellular phone technology based on time-division multiplexing (TDM) techniques.

How It Works

Time Division Multiple Access (TDMA) is an analog cellular phone technology that evolved from the Advanced Mobile Phone Service (AMPS), which was developed in 1979. TDMA takes a cellular communication channel (frequency band) and slices it into a series of time segments, as in this example:

123123123...

Each cellular user is assigned the time slices with a given number and transmits information only for the duration of his or her time segments using the TDMA scheme. This means that voice communication must be buffered and transmitted as short bursts. The time segments are so small and the slicing frequency is so high that the user perceives a continuous communication channel. TDMA allows more communication sessions to be crammed onto a single cellular channel.

TDMA is used by both the 800-MHz frequency band of Digital Advanced Mobile Phone Service (D-AMPS) and the 1900-MHz frequency band of Personal Communications Services (PCS) technologies.

The first version of TDMA was developed in 1991 and was known as the IS-54 standard (developed by the EIA/TIA). It divided each 30-KHz channel into three multiplexed subchannels. A revised version using digital control channels was developed in 1994 and is known as the IS-136 standard or, more popularly, D-AMPS. Another cellular phone technology that is based on TDMA is the Global System for Mobile Communications (GSM), which multiplexes eight subchannels into a single 200-KHz channel.

See also
cellular phone technology

time-division multiplexing (TDM)

A multiplexing method for transmitting multiple data streams in a single communication path.

How It Works

In time-division multiplexing (TDM), the data from different input channels is divided into fixed-length segments and then combined in round-robin fashion into a single output data stream, which can then be transmitted over a single channel transmission system and demultiplexed at the destination location. The segments can be created by the multiplexer itself or can be inherent in the input channel signals, such as fixed-length frames. For example, if input streams A, B, and C are divided into segments as shown here

A    A1, A2, A3,...
B    B1, B2, B3,...
C    C1, C2, C3,...

the output stream will look like this:

MUX(ABC)    A1, B1, C1, A2, B2, C2, A3, B3, C3,...

One weakness in this mechanism is that if an input channel does not have anything important to carry for a time, empty segments are inserted into the output stream anyway. For example, if channel A is not transmitting data, one-third of the output channel is not being used. You can overcome this weakness by using a more sophisticated multiplexing technique called statistical multiplexing.

NOTE

TDM is used in T1 lines to enable them to simultaneously carry 24 data channels by interleaving data into portions of a single 193-bit frame. For example, bits 1 through 8 represent channel 1, bits 9 through 16 represent channel 2, and so on to bits 185 through 192 for channel 24, plus bit 193 for synchronization. This framing process occurs 8000 times per second, producing a total throughput of 1.544 Mbps.

See also
multiplexing

time domain reflectometry (TDR)

A cable testing technique for finding breaks or shorts in a cable.

How It Works

A time domain reflectometer is a device that sends a pulse onto a cable and measures the time that it takes for the reflection to return from a short or break in the cable. (This is analogous to the use of sonar to determine the depth of a sea.) The time interval between transmission and reception of the signal is called the signal delay; this delay can be used to determine the location of the short or break, typically within a few centimeters, even though the break might be hidden within the cable’s jacket and not visible. You can also use the reflectometer to determine the length of an undamaged cable and identify cables running through walls and false ceilings in a cabling installation.

Most high-quality cable testers can perform time domain reflectometry (TDR) tests in addition to their other functions. Time domain reflectometers are available for testing both copper cabling and fiber-optic cabling.

TN3270

A form of Telnet service that enables access to mainframe hosts over a TCP/IP network. By using Microsoft SNA Server, users running a TN3270 client can connect to mainframe computers using the TN3270 service included with SNA Server.

How It Works

TN3270 (Telnet 3270) was developed as an alternate to the regular Telnet service for accessing mainframe computers. TN3270 provides a better look and feel than standard Telnet, but its numeric field handling and keyboard interface are somewhat clumsy. TN3270 provides keyboard emulation and block-mode service at the client level, thus freeing the mainframe from translation functions. TN3270 provides workstation emulation only and does not include file-transfer or printer-emulation services.

You can also use TN3270 to connect to AS/400 systems, but the AS/400 systems must translate the 3270 data stream into 5250 format and provide keyboard mapping between the 3270 and 5250 key sequences, a process that consumes additional CPU resources on the AS/400.

TN5250

A form of Telnet service for letting users access AS/400 systems over a TCP/IP network using a TN5250 client terminal emulator.

How It Works

TN5250 (Telnet 5250) is to the AS/400 what TN3270 is to the mainframe. A TN5250 service included with Microsoft SNA Server lets TN5250 clients connect to AS/400 systems using SNA Server without installing TCP/IP on the AS/400. TN5250 offers full 5250 terminal emulation, including hot backup and security features similar to those included with the TN3270 service.

TN5250 provides 5250 workstation emulation that supports almost all the field attributes and keyboard sequences of a “real” SNA 5250 except text assist. TN5250 has a natural and intuitive look and feel; no conversion is required inside the AS/400. TN5250 provides workstation emulation only and does not include file-transfer or printer-emulation services.

Token Ring

A popular local area network (LAN) technology developed by IBM that still has a large installed base in many shops but has been greatly outpaced in recent years by different forms of Ethernet. Token Ring was standardized in the IEEE 802.5 specifications, which describe the implementation of a token-passing ring network configured as a physical star topology.

How It Works

In a Token Ring network, stations (computers) are wired in a star formation to a central wiring concentrating unit called a Multistation Access Unit (MAU). This unit concentrates wiring in a star topology but internally forms a logical ring topology over which network traffic can travel. Lobes connect the individual stations to the MAU. The maximum cable length for a lobe is 22.5 meters or 100 meters, depending on the cable type, but you can extend this distance up to 2.4 kilometers using repeaters designed for Token Ring networks. MAUs typically support 8 or 16 connections for attaching lobes. You can extend a Token Ring network by connecting MAUs to ring-out and ring-in ports to form larger rings that can support larger numbers of stations. Stackable MAUs simplify this process. You can connect up to 33 MAUs to form a network. Many MAUs support being connected by fiber-optic cabling to create networks that span a building or campus. Most MAUs also support in-band management by using Simple Network Management Protocol (SNMP) plus out-of-band management by using a serial interface.

Graphic T-8. Token Ring.
Graphic T-8. Token Ring.

Token Ring networks typically operate at speeds of 4 or 16 Mbps, although speeds of up to 100 Mbps are possible with equipment from some vendors. Token Ring networks come in two types, both of which can operate at 4 or 16 Mbps:

  • Type 1:
    Generally uses shielded twisted-pair (STP) cabling with a special data connector developed by IBM for Token Ring installations. However, 16-Mbps MAUs generally have ports for RJ-45 or DB9 connectors.

  • Type 3:
    This type uses standard unshielded twisted-pair (UTP) cabling with RJ-45 connectors.

Type 1 is often considered more reliable than Type 3, but the larger installed base of UTP cabling makes Type 3 a viable option for new Token Ring installations. Type 1 configurations support up to 260 stations per ring, while Type 3 can support up to 72 stations per ring.

Token Ring stations pass a single data packet called a token from one computer to the next rather than let each node transmit independently, as in a contention-based network such as Ethernet. Only one token can be on the network at a time, so collisions do not occur in Token Ring networks as they do in Ethernet networks. This process is analogous to sending messages to a group of people by passing a hat.

In order to pass a token in a Token Ring network, each station must know who its neighbors are and must perform a check to make sure that the circuit is unbroken. Messages containing this information are continually sent around the ring. The token circulates so long as this message is received. To generate the required information, the first station online in the ring assumes the role of Active Monitor Station. It creates the token and is responsible for taking action if the token is lost or damaged. The Active Monitor Station sends out an Active Monitor Present frame every seven seconds to the next node down the line. Each node in turn informs its downstream neighbor that it is its Nearest Active Upstream Neighbor. An error-detection process called beaconing occurs if the ring breaks and the token fails to circulate. If the Active Monitor Station fails, another station assumes its role of monitoring the status of the network and generating a new token if the existing one is lost.

If a station wants to transmit data over the network, it waits until the token comes by; if the token has not been claimed by another station, it claims the token and inverts the monitor setting bit to mark it “busy” so that no other station can claim the token for a predefined but variable amount of time. The originating station then removes the last byte from the token (called the delimiter byte), appends data to the token, and appends the delimiter byte to the end to form a frame of variable length (up to 8000 bytes). The token with data circulates around the ring in one direction from station to station. (Each station acts as a repeater to regenerate and forward the token.) When it returns to the originating station, the token and the data are removed and a new token is generated and placed onto the network.

NOTE

The term “Multistation Access Unit” is sometimes abbreviated as MSAU instead of MAU to distinguish it from “media attachment unit,” a term used in older Ethernet networking technologies.

Distances between MAUs and attached stations are specified as lobe lengths, which refer to round-trip signal paths. Thus, a station with a lobe length of 200 meters actually uses a cable 100 meters long.

TIP

STP cabling for Type 1 Token Ring comes in nine types, two of which are common now:

  • Type 1 cable:
    Uses two-pair 22-gauge shielded, grounded solid copper wire. Use this type for longer cable runs such as those between wiring closets and work areas. The maximum lobe length is 200 meters.

  • Type 6 cable:
    Uses two-pair 26-gauge stranded, shielded copper wire and is more flexible (and looks nicer!) than Type 1 cable. Use this type for work areas in which cables will be visible or where equipment will be moved around frequently, and especially for patch cables. The maximum lobe length is 45 meters.

You can get both types of cable in an adapter cable version (terminated at one end with an IBM data connector and at the other end with a DB9 male connector) or a patch panel version (terminated at both ends with data connectors). Use patch panel cables to connect MAUs, and use adapter cables to connect stations to MAUs.

You can also get baluns, which can convert Type 1 IBM cabling to UTP cabling to connect different Token Ring types, and you can get special adapters that allow data connectors to be connected to RJ-45 ports so that you can use installed UTP cabling with Type 1 MAUs.

TIP

Some network interface cards (NICs) for Token Ring networking support software-configurable physical layer addressing. All your NICs must have unique MAC addresses.

Most MAUs and NICs are dual-speed and can run at either 4 or 16 Mbps, but not both. However, you can use bridges or routers to connect 4-Mbps Token Ring networks to 16-Mbps Token Ring networks.

The following table provides suggestions for troubleshooting Token Ring network problems.

Troubleshooting Tips for Token Ring Networks
Problem | Suggestion
Mismatched ring speed | Be sure that all connected stations use 4 Mbps or that all use 16 Mbps. Do not mix stations of different speeds.
Stations cannot receive | Check cables and reset the MAU.
Conflicting MAC addresses | Use NIC configuration software to change the MAC address on one of the conflicting computers.
Traffic congestion on the network | Segment the network by using a bridge or a router.

top-level domain

Any domain that is directly under the root domain in the hierarchical Domain Name System (DNS). Top-level domains are few in number and are used to identify broad classes of Internet services. Except for country domains, the various top-level domains currently in existence are listed in the following table. A number of additional top-level domains are yet to be finalized and implemented.

Top-Level Domains
Domain | Description
.com | Commercial businesses and personal domains
.edu | Mostly U.S. universities and colleges
.org | Nonprofit organizations
.net | Networking and telecommunications companies
.gov | American government branches and agencies
.mil | U.S. military

In addition to the domains listed in the table, countries as well as states and provinces within countries are identified by two-letter country codes. For example, .uk is the top-level domain for the United Kingdom, .ca is the top-level domain for Canada, and mb.ca is the top-level domain for the province of Manitoba in Canada. Although the .com domain is by far the most popular one today due to the way it is marketed, many businesses are forced to use other domains such as .net or their country domain because of the shortage of commercial top-level domains.

NOTE

A special domain called in-addr.arpa is used for reverse DNS name lookups (resolving a host name given the host’s IP address).

See also
country code

topology

The physical layout of computers, cables, switches, routers, and other components of a network. This term can also refer to the underlying network architecture, such as Ethernet or Token Ring. The word “topology” comes from topos, which is Greek for “place.”

How It Works

When you design a network, your choice of topology will be determined by the size, architecture, cost, and management of the network. Basic network topologies include the following:

  • Bus topology:
    The stations are connected in a linear fashion. An example is the 10Base2 form of Ethernet.

  • Star topology:
    The stations are connected to a single concentrating device called a hub (Ethernet) or a Multistation Access Unit, or MAU (Token Ring physical topology).

  • Ring topology:
    The stations are connected in a ring. Examples are Fiber Distributed Data Interface, or FDDI (logical and physical ring), and Token Ring (logical ring and physical star).

  • Mesh topology:
    The stations are connected in a complex, redundant pattern. This topology is generally used only in wide area networks (WANs) in which different networks are connected using routers.

Variations of these basic topologies include the following:

  • Star bus topology:
    Consists of many star networks whose concentrators (hubs) are connected in a linear bus fashion

  • Star-wired topology or cascaded-star topology:
    Consists of star networks whose hubs are joined in star formation to other hubs, forming a kind of tree-shaped network with the main hub at the top

NOTE

The term “topology” can refer to either a network’s physical topology, which is the actual physical layout or pattern of the cabling, or its logical topology, which is the path that signals actually take around the network. This difference is most evident in Token Ring networks, whose cabling is physically arranged in a star but whose signal flows in a ring from one component to the next. The term “topology” without any further description is usually assumed to mean the physical layout.

tracert

A TCP/IP utility in Microsoft Windows for diagnosing and troubleshooting router connections in an internetwork such as the Internet. The term “tracert” stands for trace route. The tracert utility uses Internet Control Message Protocol (ICMP) echo packets that are similar to those used by the ping utility. These ICMP echo packets are assigned a steadily increasing Time to Live (TTL) to test network connectivity with routers and other hosts that are farther and farther along the network path until connectivity fails or the target host is finally contacted and successfully responds.

Example

If you run

tracert www.yahoo.com

from Winnipeg via a local Internet service provider (ISP), you might get a display similar to the following, depending on the route your packets take:

Tracing route to www.yahoo.com [204.71.177.75] over a maximum of 30 hops:

1   193 ms   188 ms   192 ms  tnt01.escape.ca [204.112.225.50]
2   195 ms   189 ms   199 ms  bb.escape.ca [204.112.225.4]
3   216 ms   575 ms   248 ms  escape.mbnet.mb.ca [204.112.54.194]
4   227 ms   239 ms   531 ms  e0.manitoba.mbnet.mb.ca [204.112.54.193]
5   211 ms   210 ms   358 ms  psp.mb.canet.ca [192.68.64.5]
6   269 ms   251 ms   244 ms  border1-atm1-0.quebec.canet.ca [205.207.238.45]
7   224 ms   240 ms   269 ms  psp.ny.canet.ca [205.207.238.154]
8   249 ms   274 ms   251 ms  borderx2-hssi2-0.Boston.mci.net [204.70.179.117]
9   238 ms   304 ms   258 ms  core2-fddi1-0.Boston.mci.net [204.70.179.65]
10   315 ms   310 ms   365 ms  bordercore2-loopback.Bloomington.mci.net [166.48.176.1]
11   701 ms   677 ms   360 ms  internet-connection.Bloomington.mci.net [166.48.177.254]
12   389 ms   384 ms   357 ms  www.yahoo.com [204.71.177.75]

Trace complete.

The destination host was reached after a distance of 12 hops. Note the gradually increasing response times.

NOTE

The UNIX version of this utility is typically called traceroute.

transaction

A method of coordinating a series of changes to a set of resources distributed over the network. Transactions are units of work that must succeed or fail as a whole—a transaction can never partially succeed. If a transaction fails while only partially completed, the transaction is rolled back to the beginning. An example is a credit card purchase: The store requests the purchase amount from the credit card company, the company distributes the funds to the store, and the company bills the purchaser. If any part of the transaction fails, the entire transaction must fail in order to prevent money from being lost.

Component Services on Microsoft Windows 2000 (or Microsoft Transaction Server on Microsoft Windows NT), a tool that provides the underlying support, or “plumbing,” for creating scalable, distributed, transactional Web applications, provides failure isolations and mechanisms for recovering failed transactions and can run components of transactions as isolated processes for additional crash protection. Component Services uses the Distributed Component Object Model (DCOM) programming architecture for communication between components on Microsoft Windows networks.

transaction log

A technology that provides fault tolerance and crash recovery for critical database files. Transaction logs are used in products such as the Microsoft Exchange Server directory services database and information store and Microsoft SQL Server.

How It Works

Using Exchange Server as an example, data is written to transaction log files before it is applied to the directory or information store databases. This improves the performance of write operations to the Exchange databases. Transaction logs also play an important role in providing fault tolerance and recoverability for databases. If a system crash corrupts the database files, you can use the transaction logs (if they are intact) to restore all changes to the database since the last backup. Transaction logs make online incremental and differential backups possible. Without transaction logs, you would be able to perform full backups only when backing up databases online.

NOTE

In Exchange, you might have several transaction logs in your database directory. When a database is backed up, the transaction logs are then purged.

TIP

Use the Microsoft Exchange Performance Optimizer tool to make sure that transaction logs are located on a stripe set for maximum performance.

transceiver

An electronic device for connecting a computer to a baseband transmission network so that the computer can transmit and receive signals on the network. In the 1980s, transceivers were often separate devices attached to thicknet cabling using vampire taps, but today most network interface cards (NICs) have onboard transceivers.

NOTE

Some Fast Ethernet NICs have a media independent interface (MII) to which an external transceiver can be connected to provide different kinds of 100-Mbps networking. This allows you greater flexibility in your networking options. For example, 100BaseTX transceivers have an RJ-45 port for connecting unshielded twisted-pair (UTP) cabling, and 100BaseFX transceivers have an SC-type port for connecting fiber-optic cabling.

transceiver cable

See
drop cable

Transmission Control Protocol (TCP)

A transport layer protocol that enables reliable, connection-oriented network communication.

How It Works

Transmission Control Protocol (TCP) is a connection-oriented protocol that guarantees data will be delivered intact to its destination. TCP first establishes a session by using a TCP three-way handshake with TCP ports on each host. It then transmits the data in packets, each with a sequence number. When packets are received at their destination, TCP generates an acknowledgment to the sending host. If a packet in a sequence is not received, TCP on the sending host retransmits the packet after a certain interval of time.

Microsoft’s implementation of TCP on Windows platforms includes advanced features such as self-tuning to ensure that data is sent at a speed optimal for the receiving host, dead gateway detection, and checksums for ensuring error-free delivery.

Transport Driver Interface (TDI)

A standard or specification for a common programming interface for developing Microsoft Windows NT and Windows 2000 file system drivers (server or redirector components) and for providing independence between transport layer protocols and file system drivers. The Transport Driver Interface (TDI) allows one file system driver to be bound to many protocols or one protocol to work with multiple file systems.

See also
I/O Manager

transport layer

Layer 4 of the Open Systems Interconnection (OSI) reference model. The transport layer is responsible for providing reliable transport services to the upper-layer protocols. These services include the following:

  • Flow control to ensure that the transmitting device does not send more data than the receiving device can handle

  • Packet sequencing for segmentation of data packets and remote reassembly

  • Error handling and acknowledgments to ensure that data is retransmitted when required

  • Multiplexing for combining data from several sources for transmission over one data path

  • Virtual circuits for establishing sessions between communicating stations

NOTE

The Transmission Control Protocol (TCP) of the TCP/IP protocol suite resides at the transport layer.

tree

See
domain tree

trunking

In switched Ethernet networking, any method of aggregating the physical network links into a single logical link. Trunking provides a way of overcoming the bandwidth limitations of a single physical link and is used in both switch-to-switch and switch-to-server connections to relieve traffic congestion. A number of vendors have implemented trunking hardware and/or software, and a standard called IEEE 802.3ad that ensures interoperability among the different vendor offerings should be approved soon.

How It Works

Trunking is essentially a form of inverse multiplexing and is often used to aggregate multiple wide area network (WAN) connections into a single connection. In the switched local area network (LAN) environment, trunking was originally used to reduce congestion in switch-to-switch connections. By aggregating several 100-Mbps links between Fast Ethernet switches, you can achieve data rates of 300 or 400 Mbps between the switches to accommodate network backbone traffic. In a full-duplex configuration, this means rates of 600 or 800 Mbps, which rivals the more expensive Gigabit Ethernet technology and gives new life to old switches.

You can also implement trunking in switch-to-server connections so that multiple connections to a single server can be aggregated. This form of trunking can be purely software based or can be implemented as a combination of both hardware and software. For example, trunking software installed on multiple network interface cards (NICs) in the server automatically handles load balancing across the various server interfaces and can remove an interface from the trunking group if the interface goes down. This provides increased bandwidth between the server and the switch and ensures fault-tolerant operation.

Graphic T-9. Trunking.
Graphic T-9. Trunking.

Trunking comes in two varieties:

  • Symmetrical trunking:
    Allows any port in a trunking group to transmit packets to any other port. Full-duplex connections are thus supported over all links in the group. For example, a server can both transmit and receive data at 400 Mbps in a trunked group of four interfaces and one switch.

  • Asymmetrical trunking:
    Allows any port in a trunking group to transmit packets but allows only one port (the port on the switch) to receive packets. The server can transmit data at 400 Mbps but can receive data at only 100 Mbps.

NOTE

Trunking by itself is limited to point-to-point connections between two switches or between a switch and a server. However, you can use the Multipoint Link Aggregation (MPLA) technology developed by 3Com to aggregate physical links connected to different switches into a single logical link. MPLA thus supports multipath trunking between multiple switches and servers, giving network administrators flexibility in configuring their hardware for optimal traffic servicing. Other vendors are working on similar multipath trunking technologies, but no standards have emerged yet.

Although the theoretical speed for quadruple-trunked full-duplex Fast Ethernet connections is 800 Mbps, in practice the maximum achievable rate is about 560 Mbps because of traffic overhead.

TIP

Software-based trunking adds overhead of up to 5 percent to the server’s CPU, depending on the software and the NIC used. Look for special NICs from trunking software vendors with on-board processors that can run the trunking software and thus reduce the load on the CPU. Also, don’t mix and match trunking software or hardware from different vendors in a single trunking group.

Switches must be intelligent if they are to properly support trunked connections. Check your switch documentation before you attempt to implement trunking on your network.

Not only is it often more economical to trunk Fast Ethernet lines than to upgrade to Gigabit Ethernet, but trunked Fast Ethernet cable runs can go farther than Gigabit Ethernet cable runs can. However, in certain situations trunking does not improve things. For example, trunking cannot speed up server-to-server backups.

trust

See
trust relationship

trust relationship

A secure communication channel between two domains in Microsoft Windows NT or Windows 2000. Trust relationships allow users in one domain to access resources in another domain. Trusts work by having one domain trust the authority of the other domain to authenticate its user accounts.

How It Works

In Windows NT, trusts are one-way—the trusting domain (or resource domain) trusts the trusted domain (or accounts domain). This means that global users in the trusted domain can be authenticated for accessing resources in the trusting domain. Global users from the trusted domain can log on to any computer in either domain and can access resources in either domain if they have the appropriate permissions.

If you want to establish a two-way trust between two domains, you must create two trusts, one in each direction. Administrators can set up trust relationships between domains by using the Policies menu in User Manager for Domains. The administrator on the accounts domain should permit the trust first, and then the administrator on the resource domain should complete the trust. Only global accounts (global users and global groups) can cross trusts.

Windows NT trusts are nontransitive. In other words, if domain A trusts domain B and domain B trusts domain C, it is not true that domain A trusts domain C.

By using trusts, you can join Windows NT domains into a variety of domain models, including the complete trust model, the master domain model, and the multiple master domain model. You can join domains to support 100,000 or more users for enterprise-level networks.

Windows NT trusts, which are based on the Windows NT Challenge/Response Authentication, are managed by the Windows NT Directory Services (NTDS).

Graphic T-10. Trust relationship.
Graphic T-10. Trust relationship.

In Windows 2000, trusts are always two-way. If domain A trusts domain B, users in either domain can access resources in the other domain if they have the appropriate permissions. Windows 2000 trusts are also transitive. In other words, if domain A trusts domain B and domain B trusts domain C, domain A also trusts domain C.

Windows 2000 trusts are much easier to manage than Windows NT trusts, primarily because there are far fewer trusts to manage. Windows 2000 domains are combined into hierarchical structures called domain trees. All users in a domain tree can access resources in any domain of the tree if they have suitable permissions. In Windows 2000, you can also use another type of trust called an explicit trust, which is a one-way trust similar to that implemented in Windows NT, to form a trust relationship between two domain forests.

Windows 2000 trusts are managed by Active Directory and are based on the Kerberos v5 security protocol.

TIP

If you are unable to establish a trust relationship between two domains, make sure that no sessions are open between the two primary domain controllers (PDCs) and that they are using common transport protocols.

T-SHARE

See
Remote Desktop Protocol (RDP)

tunneling

A technology for sending frames from one network to another. In tunneling, frames from the source network are encapsulated in the frame format of a different protocol and then sent over the link, called a tunnel. Frames are unencapsulated at the destination network and forwarded to their destination node.

Tunneling technologies include the following:

  • Internetwork Packet Exchange (IPX) tunneling over Internet Protocol (IP) internetworks, which allows IPX packets to be encapsulated in an IP packet and routed over the TCP/IP internetwork until they reach the destination local area network (LAN), where they are unwrapped into IPX packets. This process permits NetWare clients and servers using IPX to communicate over a TCP/IP internetwork.

  • Systems Network Architecture (SNA) tunneling over IP internetworks.

  • Point-to-Point Tunneling Protocol (PPTP).

  • Layer 2 Tunneling Protocol (L2TP).

twinax cabling

A form of coaxial cabling with twin central conducting cores. Twinax cabling typically uses 20 AWG stranded copper conductors, has an outside diameter of 1/3 inch, and comes with either a polyvinyl chloride or plenum jacket. Twinax cabling typically has an impedance of 80 to 100 ohms. Twinax cabling is used primarily for connecting IBM System 3X or AS/400 systems to 5250 terminals.

TIP

To extend a twinax connection over long distances, use a repeater. Twinax repeaters can typically transmit signals up to 1 mile over unshielded twisted-pair (UTP) cabling and over longer distances using duplex fiber-optic cabling. One repeater is required at both ends of the connection.

Use a multiport repeater (hub) to connect several terminals over a single connection to an AS/400 or System 3X host. You can use twinax-to-RJ-45 baluns to connect the terminals and mainframe host to the hub by using UTP cabling. Some repeaters have RJ-11 ports for extending twinax connections over standard telephone cabling. Twinax cabling is traditionally used in a daisy-chained topology, but if you use a multiport repeater, you can also use a star topology configuration.

twisted-pair cabling

A form of copper cabling that consists of one to four pairs of color-coded insulated stranded copper wires that are twisted together in pairs and enclosed in a protective outer sheath. Twisted-pair cabling is terminated with RJ-11 connectors and was originally developed for the telephone system. It is now also the cabling of choice for networking workgroups and departmental local area networks (LANs). Twisted-pair cabling for networking purposes has RJ-45 connectors at each end.

How It Works

In computer networking environments that use twisted-pair cabling, one pair of wires is typically used for transmitting data while another pair receives data. The twists in the cabling reduce the effects of crosstalk and make the cabling more resistant to electromagnetic interference (EMI), which helps maintain a high signal-to-noise ratio for reliable network communication. Twisted-pair cabling used in Ethernet networking is usually unshielded twisted-pair (UTP) cabling, while shielded twisted-pair (STP) cabling is typically used in Token Ring networks. UTP cabling comes in different grades for different purposes, the most common of which is category 5 cabling.

NOTE

In a telephone environment, one pair is sufficient for phone communication to take place. Most customer premises wiring established by telcos uses two-pair wiring in case a second phone line is later needed for fax or modem use.

two-way transitive trust

A trust relationship between two domains in Microsoft Windows 2000. By default, a Windows 2000 trust is two-way, meaning that each domain trusts the authority of the other domain for authentication. A Windows 2000 trust is also transitive—if domain A trusts domain B and domain B trusts domain C, domain A trusts domain C. Windows 2000 two-way transitive trusts are based on the Kerberos v5 security protocol.

Because of the two-way transitive nature of Windows 2000 trusts, all domains in a domain tree implicitly trust each other. This means that resources of one domain are available to users in all other domains in the domain tree if they have suitable permissions.

NOTE

You can also create one-way nontransitive trusts for Windows 2000–based networks. These one-way trusts are similar to the trust relationships formed by Microsoft Windows NT domain controllers. A one-way trust between a domain and a domain tree provides users of the domain with access only to the domain in the tree to which it is joined. One-way trusts can be useful when domains require a less permanent relationship—for example, when two companies take part in a joint venture. Only the resources needed by the other company are made available to the trusted domain; the entire domain tree is not exposed.

See also
Active Directory


U

UDF

See
Uniqueness Database File (UDF)

UDP

See
User Datagram Protocol (UDP)

ULS

See
Internet Locator Service (ILS)

UMTS

See
Universal Mobile Telecommunications System (UMTS)

unattended installation

A procedure for installing software without user intervention. Many Microsoft products, such as Microsoft Windows 2000 and Microsoft BackOffice, support unattended installation. Unattended installation allows network administrators to perform simultaneous installations of operating system and application software on networked computers. For example, an administrator can install Windows 2000 Professional on several desktop client computers simultaneously without having to remain at each desktop during the installation process.

How It Works

Unattended installations typically make use of a distribution server, which is simply a file server on the network that has the source files for the software you want to install stored on one of its shared folders. Client software can connect to the share point on the distribution server, download the necessary files, and run the software setup program.

You can create a file to provide a fixed set of responses to prompts for information (such as the computer name, the network protocol to employ, and optional components to install). In the Microsoft Windows version of unattended installation, this file is called an answer file; you use it by appending the filename to the /u switch when you run Setup from the command prompt. The Windows NT and Windows 2000 compact discs contain a sample answer file called unattend.txt. You can customize this file with a text editor such as Notepad, and then you can use the file to perform unattended installations of Windows.

NOTE

Windows NT and Windows 2000 include several installation tools for simplifying the deployment of servers and desktop computers in the enterprise. For example, as an alternative to manually creating answer files by using a text editor, Windows NT and Windows 2000 provide a wizard called Setup Manager that you can use to easily create answer files for unattended installations.

Another way to set up multiple computers running Windows for deployment on a network is to use disk-image duplication (or disk cloning) software such as Symantec’s Ghost or PowerQuest’s DriveImage software. In order to use disk cloning as an installation method, however, the master and target systems must have identical hardware configurations. To create a clone, you install and configure the operating system and applications on the master machine, and then use the disk imaging software to capture an exact bit-image of the master machine’s hard drive, which you then duplicate to the hard drives on the other computers, producing exact clones of the master machine. When you use disk-image duplication software, you must be careful that incompatibilities do not result. For example, if you clone a computer running Windows 2000, the cloned version will have the same security identifier (SID) as the original, which means that the two computers cannot coexist on the same network. Makers of disk-image duplication software can provide utilities for modifying SIDs to work around this problem. Note also that the master and target computers must be stand-alone member servers and not part of a Windows 2000 domain.

Finally, Windows 2000 Server includes Remote Installation Services (RIS), which you can use to install Windows 2000 Professional on client computers from a network share. An image of the fully configured operating system with any locally installed applications that will be required is created and stored on the network share, and a RIS boot disk is used to boot the client computers, connect to the RIS server, download the image, and install the operating system on the client computers. If the client computers have ROM that supports PXE (Pre-Boot eXecution Environment) architecture and have remote boot–enabled network adapter cards, a remote boot disk is not required for each client.

Microsoft also supports disk-image duplication of Windows 98 systems when the Windows 98 Image Preparation Tool is used to prepare the master disk image.

TIP

If you need to perform simultaneous installations of software on large numbers of networked computers, you might consider using systems management software such as Microsoft Systems Management Server (SMS). Unattended installation using answer files is practical only for smaller deployments and doesn’t offer the management and upgrade capabilities that systems management software does.

See also
answer file

unattend.txt

See
answer file

unbalanced line

An electrical cable in which the potential of the signal-carrying conductor is above ground while the return-path conductor is at ground potential. The two conductors thus have different electrical characteristics. This is different from a balanced line, in which both conductors carry a signal and have potentials that are equal in magnitude but 180 degrees out of phase.

In computer networking, an example of an unbalanced line is coaxial cabling, in which the electrical signal is carried solely by the central conductor while the ground path (the internal wire-braid or mesh shielding inside the cable jacket, which is connected to the earth at one termination point of the cable) provides the unbalanced signal return path. An example of a balanced line is twisted-pair cabling, which comes in the shielded twisted-pair (STP) or unshielded twisted-pair (UTP) variety. Because of its electrical characteristics, unbalanced coaxial cabling is more susceptible to electromagnetic interference (EMI) than balanced STP cabling, but coaxial cabling is capable of higher transmission rates over longer distances.

Graphic U-1. The return-path conductor of the unbalanced line is at ground potential. The return-path conductor of the balanced line carries a signal.
Graphic U-1. The return-path conductor of the unbalanced line is at ground potential. The return-path conductor of the balanced line carries a signal.
See also
balanced line

UNC

See
Universal Naming Convention (UNC)

unicasting

Two-way, point-to-point communication between stations on a network. This is in contrast to broadcasting, which is multipoint in nature and directs information to all accessible hosts on the network, and multicasting, which directs information only to hosts that request it. For a unicast packet to arrive at its destination host on the network, it must be configured with the specific destination address of that host, usually in the form of a logical address such as an IP address and a physical address, or MAC address.

Most user-initiated network traffic is unicast or directed traffic, while broadcast traffic is mostly for clients and services to announce themselves on the network and multicast traffic is for streaming multimedia communication. In the TCP/IP protocol suite, both the connection-oriented Transmission Control Protocol (TCP) and the connectionless User Datagram Protocol (UDP) support unicast transmission of Internet Protocol (IP) packets.

Graphic U-2. Comparison with multicasting and broadcasting.
Graphic U-2. Comparison with multicasting and broadcasting.
NOTE

Routers, which are network devices that can forward packets to other networks, are usually configured to forward unicast packets (packets directed to a specific host on a destination network) but not broadcast packets (packets directed to all users on a subnet, network, or internetwork). You can use a Microsoft Windows NT or Windows 2000 multihomed system for unicast IP routing by installing the Routing and Remote Access Service (RRAS), which turns the system into a dynamic router that supports both the Routing Information Protocol (RIP) and the Open Shortest Path First (OSPF) Protocol.

In addition to supporting streaming multicast traffic, Microsoft NetShow supports unicasting to transmit streaming audio and video over the Internet and corporate intranets directly from a NetShow server to a specific NetShow client.

Unicode

A character set that is capable of representing all written languages.

How It Works

The ANSI character set, which employs a single byte (8 bits) to represent each character, can represent up to 28 = 256 characters only. This is enough for Western languages, but it is insufficient for languages such as Chinese. In contrast, the Unicode character set employs two bytes (16 bits) per character, so it can represent a total of 216 = 65,536 characters—enough for every language in the world plus punctuation and standard mathematical symbols.

Unicode is the native character encoding for file and object names in Microsoft Windows NT and Windows 2000. The Win32 subsystem converts American National Standards Institute (ANSI) strings to Unicode before any string operations are performed on them. Filenames are represented in NTFS file system using Unicode.

TIP

If you create a logon script in Windows NT by using Notepad, do not select the Save As Unicode check box when you save the logon script, or it will fail to execute properly.

On the Web
•
Unicode Consortium
: http://www.unicode.org
See also
ASCII

Uniform Resource Locator (URL)

An addressing scheme that enables browsers such as Microsoft Internet Explorer and software such as File Transfer Protocol (FTP) clients to access various resources on the Internet. Uniform Resource Locators (URLs) are to the Internet what absolute paths are to file systems and what Universal Naming Convention (UNC) paths are to shared file and print resources on a Microsoft Windows network. In other words, URLs are a way of addressing resources on the Internet. By typing the URL of a resource into your browser, your browser can find and download the requested file at this address.

How It Works

A URL is a hierarchical, structured address based on the Domain Name System (DNS), although a URL can also use an IP address to locate its targets. A URL takes the following standard form:

[protocol:]//[domain or IP address][:port]/[path to target file]

The protocol is an optional address element that describes the application layer Internet protocol on the server that must be used in order for the client to access the resource. Examples are HTTP:, FTP:, and Telnet:.

The domain name or IP address, which represents the logical address of the server on which the resource resides, is required.

The port number is an optional element that represents the port on the server to which the client must connect in order to access the resource. If no port number is specified, the request is assumed to use the well-known port number for the protocol being used. For example, the well-known port number for Hypertext Transfer Protocol (HTTP) is port 80.

The path is required if the resource is not in the root of the server’s directory that is mapped to the specified domain name or IP address. This path is usually a virtual path that is mapped to a hierarchical series of directories on the server or on the server’s network.

The following are examples of URLs:

  • http://www.microsoft.com/train_cert/MCSE.htm

  • ftp://172.16.8.99:3355/usr/bin/frag.Z

  • http://b12.sales.expedia.com/Sales%20Department/Wigs/Colors/red.html

NOTE

The string “%20” in the third URL is an example of character encoding. Since certain ASCII characters (such as spaces) are not allowed in URLs, they must be encoded using the form %xx, in which xx is the hexadecimal code for the character using the International Organization for Standardization (ISO) Latin-1 character set. The string “%20” represents a space character.

uninterruptible power supply (UPS)

A device that can temporarily provide power to key components of a network if a general power failure happens. Uninterruptible power supply (UPS) devices generally use rechargeable batteries and perform operations such as the following:

  • Notifying users that a shutdown is imminent and that they should save their work

  • Pausing services on servers to prevent new connections from being established

  • Providing enough power to perform a soft shutdown of servers and other key network components

  • Performing other actions as specified in a batch file that runs automatically

  • Providing power line conditioning and smoothing out spikes and dips in the power flow

UPS units for computer networking equipment are available in both stand-alone and rack-mountable versions. UPS devices are generally rated according to two values:

  • Volt-amperes (VA) or kilovolt-amperes (kVA), which represents the overall ability of the UPS unit to support connected equipment. The larger the kVA value, the greater the number and power requirements of the connected equipment it can support. UPS units range from 1 or 2 kVA units for computer network server rooms to cabinet-sized 500-kVA units for hospitals. UPS units can also be rated in watts (W): 1 VA = 1 W, and 1 kVA = 1 kW.

  • The amount of time that the unit can sustain maximum power generation. Typical times for network UPS units are 5 to 15 minutes. You can use additional battery packs with some devices to extend available uptime.

NOTE

To configure a UPS to work with Microsoft Windows NT 4, use the UPS utility in Control Panel. (To configure a UPS to work with Microsoft Windows 2000, use the Power Options utility in Control Panel.) A serial cable with special pinouts is usually required to connect servers running Windows NT or Windows 2000 to the UPS devices.

TIP

Always test your UPS after installing it. Otherwise, you might be sorry when a power failure happens in your neighborhood!

TIP

The larger the load attached to a UPS unit, the shorter the time interval the unit can continue powering attached devices during a power outage. Be sure that your UPS unit can support your power needs for the time needed to properly shut down your system.

Uniqueness Database File (UDF)

A text file that supplements an answer file during unattended installations of Microsoft software such as Windows NT and Windows 2000. Uniqueness Database Files (UDFs) override the general answers that the answer file provides to prompts during unattended setup with information that is specific to a given computer or small group of computers.

How It Works

UDFs typically supply information such as computer name or username for each installed computer, while answer files specify more general setup options such as Typical setup or time zone, which are the same for all computers on the network. Thus, while you might need only one answer file for all the computers on which you are installing Windows NT in your local area network (LAN) or at your geographical locale, you need a separate UDF for each computer or small group of computers.

The UDF is merged into the answer file at the start of the graphical user interface (GUI) portion of setup, so you can use UDFs only to define setup parameters for the GUI portion of setup, not the text portion. During the text portion of setup, only the answer file can specify parameters to use in response to setup prompts.

See also
answer file, unattended installation

Universal DSL

See
G.Lite

universal group

One of three types of groups in Microsoft Windows 2000. Universal groups can include members from any domain and can be granted permissions for resources in any domain in the current forest. They can contain user accounts, global groups, and universal groups from any domain in the current forest. They cannot contain domain local groups. Like global groups, all trusted domains have access to universal groups in order to grant them permission to access resources on the network.

NOTE

You can create universal groups only when the domain is running in native mode, not when it is in mixed mode. In other words, you cannot use universal groups in a network that has a mixture of Windows 2000 and Microsoft Windows NT domain controllers. You can use them only in a network whose domain controllers are running Windows 2000.

TIP

You can use global groups nested inside universal groups to dramatically reduce network traffic due to global catalog replication in a Windows 2000–based network. Use universal groups only when their membership changes infrequently, since excessive replication traffic can occur in a domain tree if their membership changes frequently.

You can also use universal groups to grant users access to resources that are located in multiple domains. Simply add global groups from each domain to a universal group and assign permissions for the resource to the universal group. This use of universal groups is similar to that of domain local groups, except that you can use domain local groups only to assign permissions for resources in a single domain.

See also
group

Universal Mobile Telecommunications System (UMTS)

A standard from the European Telecommunications Standards Institute (ETSI) for 3G (third-generation) wireless communication networks. The Universal Mobile Telecommunications System (UMTS) is part of the International Mobile Telecommunications-2000 (IMT-2000) initiative from the International Telecommunication Union (ITU) and uses Wideband Code Division Multiple Access (W-CDMA) transmission technology to achieve higher transmission speeds than existing Code Division Multiple Access (CDMA) cellular telephone systems. UMTS uses a newly licensed portion of the 2-GHz band of the electromagnetic spectrum.

One cost involved in the UMTS upgrade process is that of replacing the circuit-switched core network that connects existing base stations with an IP-based backbone network, which can be used to interface between the wireless system and the Internet.

On the Web
•
UMTS Forum
: http://www.umts-forum.org

Universal Naming Convention (UNC)

A convention for naming shared network resources. The syntax for a Universal Naming Convention (UNC) path to a network resource is as follows:

\\server_name\share_name[\path]

where “share_name” is a shared folder, and “path” is the (optional) path to the file within the shared folder.

Example

The UNC path \\max\sales\1998\report.doc indicates that the document report.doc is located within the shared folder called sales on the file server called max. The document is in the 1998 subfolder of the sales shared folder.

universal serial bus (USB)

A serial interface standard for connecting peripherals to computers. Serial cards with universal serial bus (USB) ports are included on most computers sold today, and USB peripherals are becoming popular, especially in the consumer market. USB provides higher speeds than traditional RS-232 serial ports and can allow multiple stations to connect to a single port by using USB hubs. USB also supports “hot plugging” of peripheral devices, which is similar to that supported by PCMCIA cards in notebook computers.

Graphic U-3. Universal serial bus (USB).
Graphic U-3. Universal serial bus (USB).

USB makes it easier to connect peripherals to computers and eliminates the need to configure interrupt request (IRQ) settings or dual inline package (DIP) switches. USB peripherals include keyboards, mouse devices, joysticks, scanners, printers, monitors, and digital cameras. USB brings plug and play functionality to external peripheral devices and is fully supported by Microsoft Windows 98 and Windows 2000.

How It Works

USB uses a tiered star topology to connect up to 127 USB devices to a single USB port on a host. (A USB system can have only one USB host—the computer that has the USB port.) To set up this topology, you can arrange USB hubs into star and tiered star arrangements. You can physically daisy-chain some USB devices that have built-in USB hubs. Some monitors have this capability for greater flexibility of configuration. This is not true daisy-chaining; it’s simply an extension of the tiered USB topology. Whatever the arrangement, USB devices can be no more than 5 meters apart or 5 meters from a hub. The entire cabling arrangement is collectively referred to as the USB bus, even if the actual topology itself does not appear bus-like.

The USB controller on the host (the computer with a built-in USB port or a USB serial card) manages communication between the connected USB devices by using a mechanism called transfer queuing, whereby devices make a request to the controller, which queues the request and responds to it in a first in, first out (FIFO) manner. Requests made by USB devices are typically one of the following:

  • Requests for or reports of status information

  • Requests for reading data to or writing data from another device on the bus

All USB requests are handled by the host controller, which obtains and sends the necessary control information or data to the device.

USB cabling is 4-wire cabling that typically uses a 28-gauge twisted pair for data transmission and a 20-gauge untwisted pair for carrying power to the devices. Cabling is available in both shielded and unshielded forms. The following table shows the pinning types for USB cabling. USB supports two speeds, which depend on the type of media used to connect peripherals:

  • 1.5-Mbps transmission over unshielded USB cabling

  • 12-Mbps transmission over shielded USB cabling

Most USB hubs and serial cards are autosensing and can determine which transmission speed to use from the attached cabling.

Pinning Types for USB Cabling
Pin | Color | Function
1 | Red | +5 V power
2 | White | Data -
3 | Green | Data +
4 | Black | Ground
NOTE

You can prevent loops in a USB cabling configuration by using only USB cables with a Type A (flat) connector at one end and a Type B (square) connector at the other. The flat connector plugs into the USB port on the computer or into the device ports on the hub.

The USB 2.0 standard extends USB to higher transmission speeds of up to 400 Mbps.

TIP

When you use shielded USB cabling, connect the shield to ground only at the USB host (computer), not at the USB devices (peripherals).

You can connect an IEEE 1284–compliant printer that has a standard Centronics interface to a USB system by using a Centronics/USB adapter or patch cable.

Universal Wireless Communications (UWC-136)

A proposed standard from the Universal Wireless Communication Consortium (UWCC)—a consortium of more than 85 telecommunications carriers and wireless product vendors—for a 3G (third-generation) wireless communication system. Universal Wireless Communications (UWC-136) is part of the International Mobile Telecommunications-2000 (IMT-2000) initiative from the International Telecommunication Union (ITU). The UWCC promotes UWC-136 as a competing IMT-2000 standard.

UWC-136 is a pure Time Division Multiple Access (TDMA) technology that is designed to be backward compatible with the existing IS-136 TDMA digital cellular phone system defined by the ANSI-136 and IS-41 standards and still widely used in North America.

Implementation of UWC-136 is planned in phases by first upgrading existing IS-136 TDMA systems to IS-136+ to provide data rates of 43.2 Kbps over standard 30-kHz channels. Then IS-136+ will be upgraded to IS-136HS, which is the high-speed component of UWC-136. Eventually UWC-136 will provide packet-data services at speeds of up to 384 Kbps for wide-area coverage and up to 2 Mbps for in-building coverage. Voice communication on this system will be high-fidelity wireline quality, comparable to that of Integrated Services Digital Network (ISDN).

On the Web
•
UWCC home page
: http://www.uwcc.org
See also
Time Division Multiple Access (TDMA)

UNIX

An operating system developed at AT&T Bell Laboratories in 1969 and widely deployed today in the enterprise networking environment. UNIX was the first operating system written entirely in the C programming language and consequently has close ties to C. UNIX was designed as a time-sharing environment, in contrast to the batch environment of most computing systems of the time. Using UNIX, multiple users could simultaneously access the system and run their programs, communicating interactively with the system using remote terminals. Users could thus collaborate in real time on computing projects by sharing files and resources.

UNIX became widely available around 1975 and established strong roots in academic computing environments, where it is still used and taught today. UNIX has the stability and robustness of an operating system that has evolved over 25 years, but it has a reputation for being difficult to learn and administer. UNIX has evolved into a number of different “flavors” as vendors have adapted it to their own hardware platforms. These flavors include the following:

  • System V:
    Evolved from versions of UNIX developed by UNIX Systems Laboratories and AT&T

  • BSD:
    Developed at the University of California, Berkeley; the basis of the SunOS from Sun Microsystems

  • AIX:
    Developed by IBM for its mid-range computer systems

  • HP/UX:
    Developed by Hewlett-Packard

  • Solaris:
    Developed by Sun Microsystems for its SPARC systems

  • IRIX:
    Developed by Silicon Graphics for its high-end workstations

The original source code for System V UNIX is owned by Santa Cruz Operation (SCO), which licenses the code to other UNIX vendors and offers its own version called SCO UNIX for various hardware platforms. The actual trademark “UNIX” is now owned by The Open Group, a consortium of software and hardware manufacturers. A variety of open versions of UNIX also exist. These are highly popular machine-independent implementations of UNIX that have been compiled to run on multiple hardware platforms. Their source code is available with few restrictions. An example is FreeBSD, which evolved from BSD UNIX. Another example is Linux, a UNIX-like operating system that is rapidly growing in popularity.

Several attempts have been made to standardize the UNIX operating system. AT&T created a written standard called the System V Interface Definition (SVID) for its UNIX System V Release 4 (SVR4). In addition, an industry consortium has created a standard called Portable Operating System Interface for UNIX (POSIX).

NOTE

Microsoft Windows NT and Windows 2000 support interoperability with UNIX platforms in heterogeneous enterprise environments through protocols, services, and utilities such as the following:

  • Common support for industry-standard protocols such as TCP/IP, Dynamic Host Configuration Protocol (DHCP), Domain Name System (DNS), and remote procedure call (RPC) functionality

  • Support for File Transfer Protocol (FTP) and Hypertext Transfer Protocol (HTTP) for cross-platform file sharing

  • Support for UNIX printing through Line Printer Daemon (LPD), Line Printer Queue (LPQ), and Line Printer Remote (LPR) utilities

  • Support for remote terminal emulation using Telnet

  • Support for cross-platform database access through open database connectivity (ODBC)

  • Support for industry-standard network management through Simple Network Management Protocol (SNMP) and Remote Network Monitoring (RMON)

Third-party companies also offer Windows-compatible interoperability solutions such as the following:

  • X Windows clients for Windows-based PCs

  • Server Message Block (SMB) to Network File System (NFS) protocol conversion for file sharing between platforms

See also
POSIX, shell

UNIX commands

Commands for administering various aspects of the UNIX operating system. Most of these commands can be used in batch files to perform complex administrative tasks from a single command. You can create batch files with a text editor such as ed or vi and schedule their execution by using the cron command. The following table describes some commonly used UNIX commands. (They are listed in alphabetical order, not according to function.) Some commands have a simple syntax, such as the cd command for changing the current directory. Others are more complex and include scripting engines and even programming compilers, such as cc, the UNIX C compiler.

Most versions of UNIX support these commands, but there are subtle differences from system to system. To see the syntax for any UNIX command, use the man command, which provides access to the UNIX online command reference on most UNIX systems. For example, to see the syntax for the cd command, type man cd.

Common UNIX Commands
Command | Description
alias | Displays or sets aliases for long command strings
awk | Searches a file for a pattern and performs an action on the lines containing that pattern
bg | Moves a stopped process into the background and restarts it
cal | Displays a calendar
cat | Concatenates or displays files
cc | C language compiler
cd | Changes the current directory
chgrp | Changes group ownership of a file
chmod | Changes access permissions for a file
chown | Changes individual ownership of a file
chsh | Changes the default shell in a password file
clear | Clears the screen
cmp | Compares two files and returns the line numbers that differ
cp | Copies a file
csh | C shell command interpreter
date | Displays the date and time
df | Displays the amount of free disk space in a file system
diff | Displays differences between two files
du | Displays file system usage
echo | Echoes the text typed following the command to the screen; in a batch file, displays a line on the screen
ed | Text editor
elm | Text-based e-mail
emacs | Text editor
f77 | FORTRAN77 compiler
fg | Moves a stopped process to the foreground and restarts it
find | Finds a file with specified characteristics
ftp | File Transfer Protocol (FTP) client
grep | Searches a file for a text pattern
head | Displays the beginning of a file (by default, displays the first 10 lines)
help | Displays help
hostname | Displays the name of the current host system
kill | Ends a running process
ksh | Korn shell command interpreter
ln | Links files
lpq | Displays the print queue
lpr | Sends a print job to the spooler
ls | Lists files in a directory and displays the file statistics
mail | Sends e-mail
man | Accesses the online manual
mkdir | Creates a new directory
more | Displays a file one screen at a time
mv | Moves or renames a file
passwd | Changes your password
pico | Text editor
pine | Text-based e-mail program
ps | Displays the status of a process
pwd | Displays the name of the current directory
rm | Deletes a file
rmdir | Deletes a directory
sed | Stream line editor
sh | Bourne shell command interpreter
sleep | Pauses a process
sort | Sorts or merges files
split | Splits a file into multiple files
talk | Text-based chat
telnet | Terminal emulator
uucp | UNIX-to-UNIX system file copies
uudecode | Decodes a uuencoded file
uuencode | Encodes a binary file
vi | Text editor
who | Displays who else is logged on
whoami | Displays the name of the user currently logged on
whois | Finds remote users and sites
write | Sends a message to a user
See also
UNIX

unshielded twisted-pair (UTP) cabling

Twisted-pair cabling with no internal shielding. The outer insulating jacket protects the cable from physical stress or damage but does not shield the cable from electromagnetic interference (EMI). Unshielded twisted-pair (UTP) cabling is the most common form of network cabling for workgroups and departmental local area networks (LANs) because of its low cost, flexibility, and good performance.

UTP cabling has an impedance of approximately 100 ohms and comes in various grades or categories based on data transmission capabilities, as shown in the following table. Category 5 cabling is the most popular form of UTP cabling in 10/100-Mbps Ethernet workgroup or departmental LANs. No agreed standards exist above category 5, but many manufacturers offer UTP cabling certified for transmission rates up to 350 MHz or higher.

UTP Cabling Categories
Category | Use
Category 1 | Analog voice grade
Category 2 | Digital voice transmissions up to 4 Mbps
Category 3 | Digital transmissions up to 10 Mbps
Category 4 | Digital transmissions up to 16 Mbps
Category 5 | Digital transmissions up to 100 Mbps
TIP

To ensure that category 5 UTP cabling performs effectively, you should also use certified category 5 wall plates, connectors, and patch panels. The patch panel or wall plate connections should be untwisted no more than 0.5 inches; also try to keep cabling away from fluorescent lights, motors, and other sources of EMI. Do not bend the cable sharply—the radius of a bend should not be less than 10 times the diameter of the cable. Finally, avoid pulling cable wraps too tightly or crushing the cables in any way.

See also
shielded twisted-pair (STP) cabling

update sequence number (USN)

A type of identifier for controlling directory replication in Microsoft BackOffice products such as Microsoft Exchange Server and in Microsoft Windows 2000.

How It Works

As an example, we will consider how update sequence numbers (USNs) are used in directory replication between Windows 2000 domain controllers. When an object is changed in Active Directory, that change must be replicated to all other domain controllers. To do this, Active Directory assigns a USN to each changed object, incrementing the values with time. Each domain controller uses a table to keep track of its own current USN and the highest USN it has received from each of the other domain controllers on the network.

Graphic U-4. Update sequence number (USN).
Graphic U-4. Update sequence number (USN).

For example, if a domain controller called ABLE notifies a domain controller called BAKER of the updates it has for Active Directory, ABLE sends its own current USN number to BAKER, which compares the USN with the USN it recorded for ABLE in its internal table after the last directory update it received from ABLE. If the received USN is higher than the recorded USN, BAKER requests that ABLE send its updates for the directory. If the received USN is equal to or lower than the recorded one, BAKER knows that it has an up-to-date copy of ABLE’s directory and does not request any updates.

NOTE

USNs are more accurate than time stamps in controlling replication between domain controllers because time stamps depend on the clocks of domain controllers being exactly synchronized. However, time stamps are also employed if a tie-breaking mechanism is required for replication purposes. USNs also speed the recovery of Active Directory if a domain controller experiences a failure.

uplink port

A port on a hub that is used to connect the hub to another hub on an Ethernet network. Uplink ports allow hubs to be cascaded to form larger networks by using ordinary unshielded twisted-pair (UTP) patch cables and not using up any of the station ports on the hub that are used to connect computers. If you do not have an uplink port on your hub, you can still connect a station port on the hub to a station port on another hub by using a crossover cable. Hubs are typically connected in a cascaded star topology.

TIP

Be sure that the root or main hub of your cascaded star arrangement of hubs is a high-quality hub. Do not create collision domains larger than about 150 computers—network performance can seriously degrade due to too many collisions on the network. If hubs cannot meet your bandwidth requirements, consider replacing the main hub with an Ethernet switch.

UPS

See
uninterruptible power supply (UPS)

URL

See
Uniform Resource Locator (URL)

URL switching

A technology that allows companies to flexibly manage Web content by managing Hypertext Transfer Protocol (HTTP) request traffic based on the requested HTTP headers. URL switching is sometimes referred to as layer 7 content switching.

How It Works

URL switching allows HTTP requests from clients to be directed to Web servers and caches based on the value of substrings in the HTTP headers. For example, requests for static Web pages can be switched to a Web caching server, and requests for dynamic content can be switched to a Web application server. Other criteria that can be used to switch requests include the size of the file requested, whether the content is multimedia in form, and so on. Once the switch determines the best server to service the request, it binds the request to that server for the duration of the session. Cookies can also be used in Uniform Resource Locators (URLs) to switch requests to specific servers. URL switching also provides a way to load balance Web servers that is more flexible than the currently deployed Internet Protocol (IP) switching technologies. A leading vendor in URL switching devices is Alteon WebSystems.

Usage Import

A tool included with Microsoft Site Server and Microsoft Site Server Express for importing log files from a Web server. Usage Import can read various log file formats, which are Site Server, W3C Extended, Microsoft Internet Information Server (IIS), and NCSA Common. To use Usage Import, you select the desired log files and start the importing process. The importing process will import the log file data into the Site Server database. You can generate reports and analyze these imported logs by using Report Writer.

USB

See
universal serial bus (USB)

Usenet

A global network of servers that supports approximately 50,000 newsgroups on every imaginable topic. These servers are called news servers. Thousands of them around the world collectively function as a global bulletin board. Usenet is part of the Internet’s family of protocols and services and is typically used by individuals for such purposes as

  • Asking questions or requesting assistance on a particular issue

  • Distributing free information, including binary files such as images, sound clips, and multimedia files

  • Advertising products and services

  • Discussing issues of general, regional, local, or topical interest

How It Works

The Usenet system is based on the Network News Transfer Protocol (NNTP), a standard Internet protocol defined in Request for Comments (RFC) 977 that has two components:

  • A client/server portion that allows users running client software such as Microsoft Outlook Express to interact with news servers by downloading a list of available Usenet newsgroups on the server, reading existing messages in the newsgroups, replying to existing messages, or posting new messages.

  • A server/server portion that allows news servers to communicate with each other, primarily for the purpose of replicating messages from newsgroups. An example of software that can function as a Usenet server is Microsoft Exchange Server, which fully supports NNTP.

Graphic U-5. Usenet.
Graphic U-5. Usenet.

Users typically gain access to the Usenet system by dialing in to their local Internet service provider (ISP) and accessing a news server running at the ISP. Users typically must have an account and a password to connect to their ISP’s news server, although a number of free Usenet servers are also available on the Internet. Users employ NNTP client software such as Outlook Express to access newsgroups on the ISP’s server and post new messages to them. Periodically, the ISP’s news server replicates its newsgroup messages by pushing or pulling newsfeeds together with nearby Usenet servers on the Internet. As a result, within about 24 hours the messages posted by users are available on virtually every Usenet server in the world. A message typically remains on a news server for a few weeks or until enough new messages have been posted to the newsgroup to bump the old messages off the list.

As mentioned earlier, Usenet currently consists of around 50,000 newsgroups, although new groups are constantly being created as old ones die off. Most news servers do not carry the complete range of Usenet newsgroups because of the multigigabyte size of a full newsfeed. Other news servers exclude certain categories of groups, such as adult newsgroups. Some newsgroups are moderated, which means that new postings to the group must be approved by a moderator before they can appear in the newsgroup. This minimizes the “noise” or extraneous messages (mostly advertising).

The Usenet system of newsgroups is hierarchical in nature, similar to the Domain Name System (DNS). At the top level, Usenet consists of a number of top-level news hierarchies that identify either a range of topics (such as .rec for recreational topics) or a geographical location (such as .mn for Minnesota). The following table shows some of the popular top-level categories. Newsgroups are created hierarchically under these top-level categories, as in these examples:

  • forsale.mn

  • computers.forsale.mn

  • macintosh.computers.forsale.mn

Top-Level Usenet Categories
Category | Description
alt | Alternative, which is a collection of various topics
comp | Information on computer hardware, software, algorithms, and so on
misc | Miscellaneous information
news | Information about Usenet itself
rec | Recreational topics such as hobbies and travel
sci | Scientific issues
soc | Social issues
talk | General discussion topics such as politics and religion
TIP

If you don’t have an NNTP client program or if your company firewall will not allow you to access Usenet services using the well-known port number for NNTP (port 119), you can still access Usenet (if you can browse the Internet using a standard Web browser such as Microsoft Internet Explorer). Web sites such as Deja.com (www.deja.com) offer a Web interface for reading and posting to Usenet newsgroups. (Before you do this, make sure that your company does not have any policies forbidding employees to access Usenet.)

user

See
user account

user account

A type of account assigned to an individual user to allow that user to access network resources. These resources can include folders containing files, shared printers, mail services, or databases. The network administrator grants a user access to these resources by assigning the user a user account.

Two types of user accounts are available in Microsoft Windows NT and Windows 2000:

  • Domain user accounts:
    Created on domain controllers and exist domainwide on the network. You can log on to any computer on the network if you have a domain user account. Domain user accounts are often referred to simply as “user accounts.”

  • Local user accounts:
    Exist only within the directory database of a stand-alone member server or workstation that is not part of a domain. Users who have a local user account can log on only to the computer on which the account was created.

NOTE

A group account acts as a container for grouping user accounts. Group accounts simplify network administration by allowing multiple users to be granted or denied access to network resources in a single step—by granting or denying access for the group account to the resource.

See also
account, domain user account, local user account

User Datagram Protocol (UDP)

A TCP/IP transport layer protocol that supports unreliable, connectionless communication between hosts on a TCP/IP network.

How It Works

User Datagram Protocol (UDP) is a connectionless protocol that does not guarantee delivery of data packets between hosts. It differs from its companion transport layer protocol, the Transmission Control Protocol (TCP), which is a connection-oriented protocol for reliable packet delivery. UDP offers only “best-effort delivery” services and is used for both one-to-one and one-to-many communication in which small amounts of data are exchanged between hosts. UDP is used by applications and services that do not require acknowledgments. It can transmit only small portions of data at a time because it is not capable of segmenting and reassembling frames and does not implement sequence numbers.

UDP is typically used for services that perform broadcasts. These broadcasts can be directed to one of the following:

  • All hosts on the network—for example, to 255.255.255.255. All hosts will receive this packet unless they are prevented from doing so by a router along the way that is configured to drop such broadcasts instead of forwarding them.

  • Hosts on a specific (logical) network—for example, to 131.105.255.255 with subnet mask 255.255.0.0. All hosts with network ID 131.105 will receive this packet unless they are prevented from doing so by a router along the way.

  • Hosts on a specific (physical) subnet—for example, to 131.105.27.255 with subnet mask 255.255.255.0. All hosts on subnet 27 of network 131.105 will receive this packet.

UDP is used for the following services and functions in a Microsoft Windows networking environment:

  • NetBIOS name resolution using subnet UDP broadcasts sent to all hosts on a subnet or using unicast UDP packets sent directly to a Windows Internet Name Service (WINS) server

  • Domain Name System (DNS) host name resolution using UDP packets sent to name servers

  • Trivial File Transfer Protocol (TFTP) services

TIP

If a router is configured to allow 255.255.255.255 broadcasts, a broadcast storm can occur on the internetwork and bring network services to a halt. You should generally configure routers to allow only directed network traffic if possible.

user-level security

A mode of security on computers running Microsoft Windows 95 and Windows 98 that protects shared folders and printers by requiring that users be authenticated by the network’s security provider. The security provider can be a Microsoft Windows NT or Windows 2000 domain controller or a Novell NetWare server, depending on which network client the computer running Windows 95 or Windows 98 has installed.

How It Works

Windows 95 and Windows 98 use pass-through authentication for granting client requests for shared resources on the computer:

  1. A remote client attempts to access a share on the computer running Windows 95 or Windows 98, passing it the user’s credentials.

  2. The computer forwards the user’s credentials to the network security provider.

  3. The security provider verifies the credentials and informs the computer.

  4. The computer grants the user the specified level of access to the share, depending on the user’s account and group memberships.

NOTE

Use the Network utility in Control Panel to enable user-level security on a computer running Windows 95 or Windows 98.

See also
share-level security

User Locator Service (ULS)

See
Internet Locator Service (ILS)

User Manager for Domains

An administrative tool in Microsoft Windows NT for administering security on computers running Windows NT in a domain. You can use User Manager for Domains to

  • Create new users and groups

  • Edit the properties of users and groups

  • Set an account policy governing password restrictions

  • Set an audit policy for tracking resource usage

  • Configure trust relationships between domains

  • Assign rights to users and groups

    Graphic U-6. User Manager for Domains.
    Graphic U-6. User Manager for Domains.
NOTE

When Windows NT Server is installed as a member server, an administrator who logs on using a local user account can use the User Manager tool to administer the local security database on the computer. User Manager is the same tool as User Manager for Domains but has a different name on a member server or a computer running Windows NT Workstation.

When Microsoft Exchange Server is installed on a server running Windows NT, User Manager has a .dll extension and enables administrators to

  • Create an associated mailbox when they create a new user

  • View and modify the properties of a user’s mailbox

To create and manage users and groups in Microsoft Windows 2000, use Active Directory Users and Computers.

TIP

If you need to make the same modification to a series of user accounts (for example, if you need to set new restrictions on logon hours), hold down the Ctrl key and select the accounts, and then choose Properties from the User menu and make the modification.

user mode

A restricted mode of operation for processes in Microsoft Windows NT and Windows 2000. User mode processes have lower priority and fewer privileges than kernel mode processes. User mode processes include components of the operating system that directly support user applications and the applications that use those subsystems.

Graphic U-7. User mode.
Graphic U-7. User mode.

User mode subsystems include

  • Win32 subsystem, which supports Windows applications

  • OS/2 subsystem, which supports OS/2 applications

  • POSIX subsystem, which supports POSIX-compliant applications

  • Security subsystem, which handles logon validation

NOTE

User mode processes cannot access hardware directly in Windows NT; they must pass their access requests to the Windows NT executive.

See also
kernel mode, Windows NT executive

username

A unique identifier that enables a user to log on to a computer or network. A typical example is “jsmith” or “jeffs” for a user named Jeff Smith. Usernames are part of a user’s credentials, which include the username, password, and domain name. Each user on the network must have a unique username so that his or her personal folders can be protected against unauthorized access and for administrative purposes such as auditing.

NOTE

When a user requires access to a Microsoft Windows NT network, the administrator or account operator must first use the tool User Manager for Domains to create a user account for the user, specifying the username, password, domain, group memberships, and account restrictions. On a Microsoft Windows 2000–based network, the administrator or the account operator can use Active Directory Users and Computers to create and manage user accounts, and account restrictions can be created and managed using group policies.

See also
naming convention

user principal name

In Microsoft Windows 2000, the logon name of a user on the network. The user principal name consists of the associated name of the User object in Active Directory that is associated with the user, followed by an ampersand (&), and then typically followed by the Domain Name System (DNS) name of the container in Active Directory in which the User object resides. The user principal name must be unique for every User object in Active Directory.

Example

If the User object in Active Directory for user Jeff Smith has the name jsmith and if this User object resides in the container whose DNS name is sales.microsoft.com, the default form of Jeff Smith’s user principal name is as follows:

jsmith@sales.microsoft.com

An alternative form of the user principal name for Jeff Smith is

jsmith@microsoft.com

In other words, the suffix for the user principal name of a user can be either the name of the tree or the name of the domain that resides above the object named in the tree. Note the similarity between the user principal name for Jeff Smith and what you might expect his Simple Mail Transfer Protocol (SMTP) e-mail address to be. The difference is that the user principal name is merely a property that is assigned to the user and can be set to any value.

NOTE

The user principal name is one of three types of names by which objects in Active Directory can be known. The others are the distinguished name and the relative distinguished name.

user profile

In Microsoft Windows 95, Windows 98, Windows NT, and Windows 2000, user-definable information about a user’s work environment, including desktop settings, network connections, printer connections, and Start menu items.

In Windows NT, when a user logs on to a workstation, his or her profile is saved locally in a personal subfolder of the %SystemRoot%\profiles folder. You can also store user profiles on a network share to allow users to access their work environment from any workstation.

How It Works

A user’s profile is stored in a folder named after the username and consists of a registry hive and a series of subfolders whose functions are listed in the following table. If additional software is installed on the computer (such as Microsoft Internet Explorer), additional subfolders might exist within the user’s profile folder.

NOTE

In Windows 95 and Windows 98, ntuser.dat and ntuser.dat.log are replaced by user.dat and user.da0, which make Windows 95 and Windows 98 user profiles incompatible with Windows NT and Windows 2000 user profiles.

User Profile Subfolders and Registry Hives
Subfolder or hive | Contents
Application Data folder | Vendors’ application-specific data
Desktop folder | Files and shortcuts on the Desktop
Favorites folder | Favorite locations
NetHood folder | Shortcuts to Network Neighborhood items
Personal folder | Users’ personal documents
PrintHood folder | Shortcuts to Printer Folder items
Recent folder | Shortcuts to recently opened documents
SendTo folder | Shortcuts for the SendTo menu
Start Menu folder | Start menu shortcuts
Templates folder | Shortcuts to templates
ntuser.dat | Copy of the HKEY_CURRENT_USER hive
ntuser.dat.log | Transaction log for error recovery

Users group

A built-in group in Microsoft Windows NT and Windows 2000. The Users group is a local group that exists on all servers and workstations running Windows NT. In Windows 2000, however, the Users group is a domain local group on domain controllers and a local group on member servers, stand-alone servers, and computers running Windows 2000 Professional. The initial membership of the Users group is the domain users global group (all ordinary users on the network). The Users group has no preassigned rights or permissions and should be assigned permissions to network resources that ordinary users will normally require.

See also
built-in group

USN

See
update sequence number (USN)

UTP cabling

See
unshielded twisted-pair (UTP) cabling

UUCP

Stands for UNIX-to-UNIX Copy, a UNIX protocol and utility for copying (sending) files between two UNIX computers on a network. UUCP was originally intended for transferring files over an asynchronous serial transmission interface such as RS-232. With UUCP, you can transfer files via a direct cable connection between serial ports on two computers by using a null modem cable or over telephone lines by using modems connected to the serial ports of each computer. A version of UUCP has been developed for transferring files over Ethernet as well. UUCP was also used for transferring electronic mail messages (e-mail) between hosts in the early days of the Internet. A UNIX host used UUCP to transfer mail to a remote host simply by executing the MAIL program on the remote UNIX host and having it run on the local message file to be delivered.

UUCP uses the well-known port number 117 for its path service and number 540 for the UUCP daemon called UUCPD. UUCP has been eclipsed by File Transfer Protocol (FTP) as a general protocol for moving files between hosts and by Simple Mail Transfer Protocol (SMTP) for transferring e-mail messages.

NOTE

Third-party vendors have created UUCP gateway connectors for Microsoft Exchange Server to enable Exchange to send and receive UUCP mail over the Internet.

uuencoding

A method of encoding binary files into 7-bit ASCII text that was originally developed for UNIX platforms. Uuencoding enables you to attach binary files to e-mail messages and transmit them over the Internet using Simple Mail Transfer Protocol (SMTP). The sending program first “uuencodes” the attachments and sends them with the e-mail message, which the receiving program “uudecodes” into its original binary format.

Although still popular on some platforms, uuencoding has been largely superseded by Multipurpose Internet Mail Extensions (MIME), a more sophisticated scheme for encoding multipart e-mail messages. Uuencoding is still used in one context in Microsoft Windows, namely for Basic Authentication on Internet Information Services (IIS). Basic Authentication transmits the user’s credentials between the Web browser client and the IIS computer in uuencoded form. This method is commonly referred to as clear-text transmission, although if you were to capture authentication traffic by using a network sniffer such as Microsoft Network Monitor, you would be unable to read the user’s credentials without uudecoding the information. Uuencoding is not considered a cryptographic algorithm because it is extremely simple to crack.

NOTE

An encoding method similar to uuencoding that is implemented on Apple Macintosh systems is called BinHex.

TIP

You can tell that a binary file has been uuencoded into an ASCII text file if the text of the file starts with “begin 644….”

UWC-136

See
Universal Wireless Communications (UWC-136)


V

V.35

A serial transmission standard that defines a physical interface for synchronous communication between data terminal equipment (DTE) and data communications equipment (DCE). V.35 was part of the V series standards developed by the International Telecommunication Union (ITU).

V.35 supports transmissions of up to 1.544 Mbps at distances of up to 1200 meters by using balanced lines for signaling and unbalanced lines for control. The V.35 interface is typically used to connect high-speed routers to Channel Service Unit/Data Service Units (CSU/DSUs) for communication over leased lines such as T1 lines. V.35 uses a block-shaped 34-pin block connector for DTE-to-DCE connections.

Graphic V-1. V.35. A V.35 connector.
Graphic V-1. V.35. A V.35 connector.
TIP

You can sometimes use V.35-to-RS-232 gender changers to connect V.35 equipment using 25-pin (DB25) serial cables.

NOTE

Although the V.35 standard was replaced by the V10 and V11 standards in 1988, it remains one of the most popular DTE/DCE interfaces in use today for LAN/WAN connectivity.

V.90

A serial transmission standard for high-speed communication using modems. V.90, which is part of the V series standards developed by the International Telecommunication Union (ITU), evolved from the earlier x2 modem technology developed by U.S. Robotics (later bought by 3Com) and the K56flex modem technology developed by Rockwell. V.90 claims to support modem communication at a speed of 56 Kbps, but this is limited by several factors:

  • The top speed of 56 Kbps is achievable only for downstream traffic from the Internet service provider (ISP) via the telco central office (CO) to the customer premises. This downstream speed is achieved by using a pure digital downstream connection at the telco side, thus eliminating the quantization error that occurs during analog-to-digital conversion (ADC). The digital data path is actually 64 Kbps throughout the Public Switched Telephone Network (PSTN), but due to digital-to-analog conversion (DAC) at the CO where the digital PSTN backbone is switched to the analog local loop, information loss results, which reduces the possible speed to 56 Kbps.

  • The actual top downstream speed for V.90 is only 53 Kbps. This is because of Federal Communications Commission (FCC) regulations on communication over telephone lines, which mandate the maximum signal power that can be transmitted over the PSTN to prevent crosstalk from degrading signal quality.

  • The actual top downstream speed is less if line distances exceed 3.5 miles or if line conditions are poor. Typical downstream speeds are 40 to 50 Kbps. V.90 includes a mechanism whereby the client modem issues a request for a test tone during negotiation, which is used to gauge the line quality to determine the optimal downstream transmission speed.

  • Upstream speed for V.90 is limited to 33.6 Kbps and operates according to the older V.34b standard.

  • V.90 is possible only on telephone networks that have only one analog segment in the communication path (the local loop at the subscriber end) instead of two analog segments (at both the subscriber and ISP/CO ends).

value entry

A data entry in the Microsoft Windows registry. Value entries are contained in keys and are analogous to variables. They consist of three parts:

  • Name:
    The name of the value entry (for example, MaintainServerList)

  • Data type:
    The type of data stored in the value entry (for example, REG_SZ represents human-readable text)

  • Value:
    The actual data contained in the value entry (for example, the string “Auto”)

In Windows NT, five data types can be used in value entries. These are described in the table on the next page. Windows 2000 supports a few data types in addition to those shown in the table.

NOTE

The maximum size of a registry value in Windows NT is about 1 MB. Applications can define other data types, but the ones shown in the table are the only ones that you can display and modify using the registry editor (regedt32.exe).

Graphic V-2. 90. Digital and analog segments with V.90 modems and earlier modems.
Graphic V-2. 90. Digital and analog segments with V.90 modems and earlier modems.
Value Entry Data Types in Windows NT
Data Type | Description
REG_BINARY | Raw binary data, usually displayed in the registry editor in hexadecimal format
REG_DWORD | Data represented by a number that is 4 bytes long and is displayed in the registry editor in binary, hexadecimal, or decimal format
REG_EXPAND_SZ | An expandable data string (text that contains a variable that is replaced when called by an application)
REG_MULTI_SZ | A multiple string, typically used for lists that are in human-readable text with entries separated by NULL characters
REG_SZ | A sequence of characters in human-readable text, typically used for descriptive information
See also
key in Microsoft Windows registry, registry editor

VBScript

Stands for Visual Basic Scripting Edition, a scripting language developed by Microsoft and designed primarily for use in Web browsers such as Microsoft Internet Explorer. VBScript is a lightweight subset of the more powerful Visual Basic for Applications (VBA) programming language used in Microsoft Office and other Microsoft development platforms. VBScript omits features such as file I/O and direct access to the operating system to provide a secure scripting platform for developing Web-based applications using technologies such as Active Server Pages (ASP). Internet Explorer includes a scripting engine for interpreting and running scripts written in VBScript. VBScript can run on all versions of Microsoft Windows as well as on certain UNIX platforms.

How It Works

You cannot use VBScript to write stand-alone programs. Instead, you must embed script into standard Hypertext Markup Language (HTML) files. The script is executed when a Web browser opens the HTML file. Alternatively, ASP can use VBScript to generate client-side script on the fly.

Script within an HTML page is enclosed within <SCRIPT> … </SCRIPT> tags. For example, the following HTML segment displays a button that, when pressed, displays a message box that reads "Hello World!":

<INPUT TYPE=BUTTON VALUE="Click me"
NAME="BtnHello">
<SCRIPT LANGUAGE="VBScript">
    Sub BtnHello_OnClick
        MsgBox "Hello World!", 0, "An active document"
    End Sub
</SCRIPT>

In this code, the <INPUT> tag creates the command button and the <SCRIPT> tag contains the script for the event handler that handles the button click.

On the Web
•
Microsoft Windows Script Technologies home page
: http://msdn.microsoft.com/scripting/
See also
JavaScript, JScript

vCalendar

An Internet protocol for interoperability between scheduling programs running on different platforms. vCalendar allows Personal Data Interchange (PDI) programs to exchange scheduling information over the Internet to book meetings, schedule events, and so on. The vCalendar standards define the format by which scheduling information can be exchanged over the Internet. The basic units of scheduling information are the event, which consists of a scheduled activity and its time, date, and duration, and the to-do, a work item or assignment that is delegated to an individual. vCalendar is defined in Requests for Comments (RFCs) 2445 to 2447 and is broadly supported in the e-mail and groupware industry. The current version is vCalendar 1.0.

NOTE

Microsoft Outlook 98 and later can import and export information in vCalendar format.

On the Web
•
Internet Mail Consortium’s PDI page
: http://www.imc.org/pdi

vCard

An Internet protocol for exchanging business information. vCard enables users to exchange the kind of information found on business cards by using standard Internet applications such as e-mail clients and Web browsers. It can also be integrated into fax, cellular phone, pager, smart card, and other communication technologies. You can use vCard to electronically communicate information such as a user’s name, title, business, address, phone numbers, e-mail addresses, URLs (Uniform Resource Locators), company logo, photographic likeness, audio clip, and just about anything else. vCard specifies the format for encoding information for transmission over the Internet. vCard is defined in Requests for Comments (RFCs) 2425 and 2426. The current version is vCard 3.0.

NOTE

Microsoft Outlook 98 and later and Microsoft Outlook Express 5 support the vCard protocol.

On the Web
•
Internet Mail Consortium’s PDI page
: http://www.imc.org/pdi

virtual circuit

A logical path between nodes in a network, typically a telecommunications network. The path is made up of discrete segments of the network that are connected using switches. The nodes on the circuit communicate as if they were directly connected using physical wires, but the switches actually establish and tear down the virtual communication path. You can change the logical paths within the network by simply reconfiguring the switches to establish new paths and tear down old ones—you need not manually reconnect wires to create new circuits.

There are two types of virtual circuits:

  • Permanent virtual circuits (PVCs):
    The switches are set up manually by the communication management station (the telco’s central office) and offer performance comparable to dedicated lines. These circuits are always on and are generally used for high-speed connectivity. PVCs are a costly solution for wide area networks (WANs) because they require telco resources (switches) to be dedicated to a particular communication circuit, whether or not that circuit is being used.

  • Switched virtual circuits (SVCs):
    The switches are set up automatically when a communication session is established. SVCs are freed up when the session is finished and can be used for establishing other communication paths. Ordinary telephone communication functions in this fashion. SVCs are generally used in WANs where backups to dedicated leased lines are required and are charged by the amount of time or traffic.

One example of WAN technology that uses virtual circuits is frame relay, which enables PVCs to be established between nodes over a public or private carrier network. Another example is X.25 networking technology.

virtual directory

A directory that appears to Web browser users as a subdirectory of a Web site’s home directory but in fact might be located in a different folder, drive, or server. Virtual directories are supported by Internet Information Server (IIS) in Microsoft Windows NT and Internet Information Services (IIS) in Microsoft Windows 2000.

For example, consider a user accessing a Web site by using the following Uniform Resource Locator (URL):

http://www.microsoft.com/otherstuff/file.htm

The directory otherstuff appears to the user to be a real subdirectory of the home directory www.microsoft.com, while in fact it could be a virtual directory that is mapped to a share on a different server on the Web provider’s network.

The advantage of using virtual directories is that content does not need to be stored only on the Web server—it can be distributed on other servers throughout the Web provider’s network. These servers can be located at secure, strategic locations for easy access by Web content developers. The disadvantage is a slight performance hit due to data being transmitted over the network.

virtual hosting

See
reverse hosting

virtual LAN (VLAN)

A networking technology that allows networks to be segmented logically without having to be physically rewired.

How It Works

Traditional Ethernet networking devices such as hubs, bridges, and routers allow the creation of large internetworks that consist of physically separate “islands” of hosts. For example, each department in a building might have its own separate local area network (LAN) that was created using hubs, and these hubs might be interconnected to a main Ethernet switch in the main wiring room of the building. Using a switch instead of a hub as the main concentrator makes for a more efficient network because the network can be partitioned into several smaller collision domains. However, broadcasts sent by any host are still received by all hosts on the network, even if all of the hosts do not need to receive them. Also, if the organization of the departments changes, the hubs must be rewired to reflect the new topology of the network.

To overcome these problems, many Ethernet switches support virtual LAN (VLAN) technologies. By replacing all hubs with VLAN switches, the network administrator can create virtual network segments whose logical topology is independent of the physical topology of the wiring. Each station can be assigned a VLAN identification number (ID), and stations with the same VLAN ID (no matter what physical switch they are connected to) can act and function as though they are all on the same physical network segment. Broadcasts sent by one host are received only by hosts with the same VLAN ID. The assignment of VLAN IDs is done at the port level on the switches themselves and can be managed remotely using network management software. Moving a host to another department only requires the assignment of a different VLAN ID to the port on the switch to which the host is connected—no rewiring of patch cables is needed.

Graphic V-3. Example of a VLAN.
Graphic V-3. Example of a VLAN.

VLAN switches can function in different ways. They can be switched at the data-link layer (layer 2 of the Open Systems Interconnection reference model) or the network layer (layer 3), depending on the type of switching technology used. The main advantage of using VLAN technologies is that users can be grouped together according to their need for network communication, regardless of their actual physical locations. Membership in a VLAN segment (called a VLAN group) is controlled by the network management software, which allows users to be grouped according to their need for resource access and security privileges. The only disadvantage is that additional configuration is required to set up and establish the VLANs when implementing these switches.

NOTE

Many high-end Cisco Systems switches and routers support VLAN capability. A protocol called Inter-Switch Link (ISL) is used to carry traffic between switches and encapsulates Ethernet frames by adding a header of 30 bytes, which includes a 2-byte VLAN ID.

VLAN techniques are also typically used in Asynchronous Transfer Mode (ATM) networks to partition the network into smaller segments for LAN emulation (LANE).

virtual memory

A mechanism by which applications function as though the system has more RAM than it actually does. Virtual memory operates by paging unneeded code to a file on the hard drive called the swap file or page file.

How It Works

In Microsoft Windows 2000 and Windows NT, the Virtual Memory Manager maps the virtual addresses belonging to the address space of a running process to physical pages of memory in the computer. This ensures that each process has sufficient virtual memory to run efficiently and does not trespass on the memory of other processes. The Virtual Memory Manager handles paging between RAM and the page file, swapping pages by using a process called demand paging. The result is that each application has access to up to 4 GB of memory. A similar process in Microsoft Windows 95 and Windows 98 uses a comparable structure called the swap file. In Microsoft Windows 2000, you can use the System Properties property page to change the maximum size of the page file.

See also
working set

virtual private network (VPN)

Generally, a technology for connecting the components and resources of one network over another. In common usage, a virtual private network (VPN) is a private corporate network whose wide area network (WAN) connections are made over a shared public network, usually the Internet. A common telecommunications carrier provides connectivity that acts like dedicated lines, but the network backbone is actually shared between all users as in a public network. VPNs are usually more cost-effective for companies than providing traditional remote access services to remote employees by using modem pools, dedicated phones lines, and toll-free numbers.

How It Works

VPNs use tunneling technologies to allow users to access private network resources through the Internet or another public network. Users enjoy the same security and features formerly available only in their private networks. Tunneling solutions are typically based on Microsoft’s Point-to-Point Tunneling Protocol (PPTP) or Cisco Systems’ Layer 2 Tunneling Protocol (L2TP), depending on resources and requirements.

You can use Internet Connection Services for Microsoft Remote Access Service (RAS), which is included in the Microsoft Windows NT Option Pack, to build VPNs and provide employees with secure remote access to the corporate network over the Internet. Using Windows NT, with its built-in support for PPTP, network administrators must configure two computers on the corporate network:

  • A dedicated PPTP server for providing secure, encrypted tunneling of IP packets

  • An Internet Authentication Service (IAS) computer that automatically integrates with the company’s domain controller to remotely authenticate employees

The Internet service provider (ISP) that provides the far-end tunneling connection services for VPN customers can install a Remote Authentication Dial-In User Service (RADIUS) proxy server and configure it to recognize authentication requests from the customer’s remote employees and forward these requests to IAS on the customer’s private network. In this way, the VPN customer can keep control over remote access permissions for all of its employees.

The ISP can implement other tools from Internet Connection Services for RAS, including the following:

  • Connection Manager:
    By using the Connection Manager Administration Kit, ISPs can configure custom preconfigured dialers for their VPN customers’ employees. These dialers make the connection experience secure and simple for remote employees by supporting PPTP, including corporate and ISP support numbers, and including customized Help files. Employees only have to enter their username to use these dialers—the dialer does everything else.

  • Connection Point Services:
    This tool allows new corporate and ISP access numbers to be automatically transferred to each employee through the Connection Manager dialer, providing phone books that are always up to date.

Once everything is set up and configured on the corporate network and at the ISP, remote employees can establish secure, local connections to their private corporate networks from anywhere in the world by dialing local access numbers to their ISPs. The RADIUS proxy server at the ISP forwards their authentication requests to IAS on their corporate networks, which uses their corporate domain controllers to grant access to resources on the corporate network. With Microsoft Challenge Handshake Authentication Protocol (MS-CHAP), secure connections are established between remote employees and the PPTP server on the corporate network. The entire process is transparent to remote employees—as far as they are concerned, they appear to have a local area network (LAN) connection to the corporate network.

NOTE

Microsoft Windows 98 clients can also use PPTP to connect to VPNs. The Windows 98 client makes two connections to establish a VPN tunnel:

  • A physical connection to a network access server at an ISP using Dial-Up Networking and Point-to-Point Protocol (PPP). This type of connection is needed only if you use nondedicated dial-up connections.

  • A logical connection to the VPN tunnel server using PPTP control and data protocols. This is the only connection required if you have a dedicated connection to the ISP.

Microsoft Windows 2000 includes support for VPNs similar to that provided by Windows NT, along with the following enhancements:

  • L2TP, which, when used with Windows 2000 Internet Protocol Security (IPSec), provides an alternate method to PPTP for creating secure VPNs

  • Remote access policies to provide flexibility in configuring connection attributes and access permissions

  • The more secure version 2 of the MS-CHAP authentication protocol

  • Account lockout to help prevent against dictionary attacks

  • The new Extensible Authentication Protocol (EAP), which allows newer authentication methods such as smart cards to be integrated for VPN use

See also
Layer 2 Tunneling Protocol (L2TP), Point-to-Point Tunneling Protocol (PPTP)

virtual server

A technology that allows multiple independent Web sites to be hosted on a single Web server. A virtual server is sometimes referred to as a Web site.

Internet Information Services (IIS) supports virtual servers in three ways:

  • By binding multiple IP addresses to the server’s network interface card (NIC). Each virtual server can be assigned its own unique IP address. DNS servers can then resolve domain names into their respective IP addresses, allowing multiple companies to host their Web sites on a single IIS server. This is the preferred method if a large pool of available IP addresses exists for the server.

  • By using a single IP address but assigning a unique port number to each virtual server. Clients must know the exact port number to connect to the server instead of using the default Hypertext Transfer Protocol (HTTP) port number 80.

  • By enabling host headers on the IIS server. The server has only one IP address and uses the default HTTP port number 80. The client Web browser attempting to access a Web site on the IIS server must be HTTP 1.1–compliant to seamlessly access the site.

NOTE

The term “virtual server” is also used in Microsoft Cluster Server (MSCS), where it is a collection of services that appears to clients as a physical Microsoft Windows NT Server. The same terminology is also used in the Windows Clustering component of Microsoft Windows 2000 Server. A virtual server is usually a resource group that contains all the resources necessary for running an application, including the network name and IP address resources.

virus

Any piece of code that is deliberately written to cause damage or annoyance to computer users on a network. Tens of thousands of different “strains” of viruses have been detected over the years. The effects of these viruses range from harmless messages announcing the presence of an “infection” to malicious deletion of crucial system and data files. The first recorded PC virus was the Pakistani Brain virus detected in 1987.

Common categories of viruses include the following:

  • Boot-sector viruses:
    Viruses that infect the boot sector of a floppy or hard disk and execute when a system is booted, causing various kinds of damage, including totally disabling systems. Notorious boot viruses have included the Michelangelo virus and the Stoned virus.

  • File viruses:
    Viruses that reproduce by attaching themselves to executable (.exe) files. When the executable file is run, the virus code is executed, causing the virus to reproduce itself and (typically) damage user files in the process.

  • Polymorphic viruses:
    Viruses that evolve as they reproduce, causing their signature to change and making them difficult to detect unless the specific evolution algorithm is known.

  • Macro viruses:
    Increasingly popular viruses written in the form of macros for word processing and spreadsheet applications. When the macro is executed, the virus infects the system and typically results in loss of files.

NOTE

Related types of malicious programs that are not strictly viruses because they do not reproduce can have similar effects. These include the following:

  • Trojan horses:
    Programs that masquerade as other programs and are typically used to steal credentials or other information from a user

  • Worms:
    Programs that invade memory to destroy files but are not disk resident

  • Logic bombs:
    Programs that are triggered when a certain event or sequence of events occurs

Many malicious programs combine the properties of viruses with one or more of these programs and are not easy to categorize.

TIP

To keep viruses from proliferating on your network, you can take the following measures:

  • Install top-quality virus-scanning software on each computer in your network, and keep their virus information files up to date.

  • Be sure that your anti-virus software scans for viruses in Hypertext Markup Language (HTML) files and attachments to Simple Mail Transfer Protocol (SMTP) e-mail messages if you have Internet connectivity.

  • Regularly perform backups of all important servers and include periodic archives in your backup schedule, since many viruses do not activate for weeks or months after infection.

  • Scan new computers for infection before bringing them onto the network.

  • Issue a company policy prohibiting users from installing any personal programs on their desktop computers. You might even disable their floppy drives, because infection via floppy is a common route to virus infection.

On the Web
•
McAfee Virus Information Center
: http://www.mcafee.com/centers/anti-virus/

VLAN

See
virtual LAN (VLAN)

Voice over IP (VoIP)

An umbrella term for a set of technologies that allow voice traffic to be carried over Internet Protocol (IP) internetworks such as the Internet. The term “Voice over IP” was coined by the VoIP Forum, a consortium of companies dedicated to the development and extension of IP telephony technologies. Voice over IP (VoIP) is the prime example of “convergence” in the networking and telecommunications industry because it enables telephony and computer networking traffic to be combined into a single data stream of IP packets.

Various vendors have offered proprietary VoIP solutions, but most have recently moved toward standards-based solutions that implement the H.323 and T.120 communication protocols developed by the International Telecommunication Union (ITU). These include voice-encoding industry standards such as G.723 and G.729. One goal of these standards is to enable integration between IP telephony and global cellular telephony standards such as the Global System for Mobile Communications (GSM). However, the move toward standards has been slow, and only a few vendors offer end-to-end carrier-class VoIP services with acceptable levels of communication latency.

Vendors tout the following advantages of using VoIP technologies:

  • Lower long-distance costs:
    VoIP enables users to avoid long-distance charges by placing local calls to their Internet service provider (ISP) and having the encapsulated voice traffic move free of charge over the Internet. The problem with this approach is that transmission over the Internet is unpredictable and often has unacceptable levels of latency. One solution is for vendors to construct their own private IP internetworks for VoIP services, but this is an expensive prospect even for the largest carriers and has contributed to the slow progress in voice/data convergence. Some companies offer their own VoIP services to employees using the internal company network, but this approach is still costly and requires expertise to maintain.

  • New solutions for remote access by mobile users:
    VoIP solutions allow users to communicate with remote stations using both voice and data integrated into a single IP data stream. For example, a user can browse a Web site and talk to customer support at the site simultaneously by using a single modem connection.

voice profile for Internet mail (VPIM)

An Internet Engineering Task Force (IETF) specification that defines a unified way of transmitting voice mail and fax messages over the Internet. Voice profile for Internet mail (VPIM) uses e-mail systems that support Multipurpose Internet Mail Extensions (MIME) and Simple Mail Transfer Protocol Service Extensions (ESMTP) standards for Internet messaging. VPIM can also be deployed over corporate intranets for integrated business messaging solutions. VPIM includes a proposed directory service that enables lookup of routable addresses and includes a mapping specification to support interoperability with other voice messaging systems.

How It Works

VPIM defines the mechanisms by which voice mail and fax messages can be exchanged between Simple Mail Transfer Protocol (SMTP) mail servers on a TCP/IP internetwork. However, VPIM leaves open the way in which specific mail clients interface with these SMTP servers to send and receive voice and fax messages, which will initially be accomplished by implementing VPIM helper applications. VPIM is implemented as a MIME profile, which allows voice and fax information to be encoded using any SMTP mail server that supports MIME. You can implement VPIM by running additional VPIM software on existing SMTP mail servers or by installing VPIM-SMTP gateways on the TCP/IP internetwork. VPIM gateways support messaging between telephones, cell phones, fax machines, pagers, and computers. VPIM will be able to use Lightweight Directory Access Protocol (LDAP) or X.500-based directories for white pages lookup to address messages to users.

NOTE

VPIM is supported by the popular UNIX mail forwarder software called Sendmail; other vendors are also implementing VPIM. The current standard, VPIM v2, can be found in Request for Comments (RFC) 2421, and VPIM v3 is under development.

On the Web
•
VPIM information
: http://www.ema.org/vpimdir

VoIP

See
Voice over IP (VoIP)

VoIP gateway

A device that allows telephone calls to be transmitted over Internet Protocol (IP) backbone networks by converting voice signals into IP packets and transmitting them over the network. The reverse process takes place at the other end of the call.

How It Works

Most VoIP gateways are chassis-based units that have either digital or analog built-in Private Branch Exchange (PBX) interfaces. A gatekeeper keeps track of IP address to phone number mappings for routing calls between gateways. Built-in local area network (LAN) and/or wide area network (WAN) interfaces are included for connecting the gateway to the IP backbone. Some gateways also have built-in routing capabilities. The LAN interface is usually Ethernet, but some gateways support Token Ring. The WAN interface is typically T1 or E1, but smaller gateways designed for small office/home office (SOHO) environments support Integrated Services Digital Network (ISDN) interfaces. The number of voice interfaces per chassis typically ranges from 72 to 960, depending on the vendor. Voice interfaces are typically the digital signal cross-connect level (DSX-1) type, but some gateways also support the foreign exchange station (FXS) type interfaces for direct attachment of analog telephones.

TIP

When you shop for a VoIP gateway, you should consider the following:

  • Audio quality should be your primary consideration. The audio quality with low traffic congestion should be close to that of a digital PBX. With heavy traffic congestion, latency and jitter should remain low enough that voice quality is acceptable to average users. A packet loss of 15 percent or more results in transmission with borderline intelligibility; delays of over 700 milliseconds are unacceptable to most users.

  • Find out what extra features are supported by the gateway, such as dialed number identification service (DNIS) for call routing, automatic number identification (ANI) and caller ID for identifying the incoming caller, and interactive voice response (IVR) for creating telephone menus.

  • VoIP gateway technologies are still evolving, so equipment from different vendors might not interoperate, even if the vendors claim to support the H.323 standards of the International Telecommunication Union (ITU). You should therefore buy VoIP from a single vendor, especially if you have an enterprise implementation with many gateways.

  • If you are concerned about eavesdropping on voice conversations on IP networks such as the Internet, be sure that your gateways support the H.245 encryption standard. The alternative practice of using a virtual private network (VPN) gateway to encrypt VoIP traffic usually results in additional incompatibility problems. Also be aware that it is difficult to configure a VoIP gateway to operate across a firewall that hides network IP addresses using network address translation (NAT), especially if the traffic is encrypted.

Graphic V-4. VoIP gateway.
Graphic V-4. VoIP gateway.
See also
Voice over IP (VoIP)

volume

In MS-DOS and earlier Microsoft Windows platforms, a portion of a hard disk that can be formatted with a file system and can have a unique drive letter assigned to it. In Windows 2000, a volume is a logical storage entity composed of portions of one or more physical disks. Windows 2000 volumes can be formatted using the NTFS file system or file allocation table (FAT) and can be assigned a drive letter.

Windows 2000 supports two different types of disk storage:

  • Basic storage:
    Supported by Windows NT version 4 or earlier and can include primary partitions, extended partitions, logical drives, volume sets, mirror sets, stripe sets, or stripe sets with parity

  • Dynamic storage:
    Volumes created using the Windows 2000 Computer Management snap-in for the Microsoft Management Console (MMC) that can include simple volumes, spanned volumes, striped volumes, mirrored volumes, or RAID-5 volumes

volume set

A single volume created using discontiguous free areas on hard disks. By using the Microsoft Windows NT administrative tool Disk Administrator, you can create volume sets by combining between 2 and 32 free areas on your disk drives.

NOTE

Volume sets are called spanned volumes in Microsoft Windows 2000, and they are created using the Computer Management snap-in for the Microsoft Management Console (MMC).

TIP

The Windows NT system partition and boot partition cannot be volume sets.

You can extend a volume set formatted with the NTFS file system without having to reformat the entire volume.

See also
stripe set

VPIM

See
voice profile for Internet mail (VPIM)

VPN

See
virtual private network (VPN)

V series

A series of communication standards developed by the International Telecommunication Union (ITU). V series protocols define methodologies for exchanging data over the public telephone system by using telecommunications devices such as modems and multiplexers. Various V series protocols define interfaces between data terminal equipment (DTE) such as computers and data communications equipment (DCE) such as modems, or signaling methods for use over the public telephone system. Standards V.100 and above deal with internetworking the telephone system with other types of networks such as packet-switching networks, while standards below V.100 deal primarily with general DTE/DCE serial communication interfaces, analog modem technologies, flow control, and error control.

The following table describes some of the popular serial transmission standards relating to modem and other serial communication technologies.

Popular Serial Transmission Standards
V Standard | Description
V.22 | Early standard for full-duplex serial transmission over one pair of wires at 1200 bps (or 2400 bps for the V.22bis version).
V.24 | The ITU equivalent of the RS-232 serial interface.
V.32 | Industry standard for 9600-bps serial transmission (or 14.4 Kbps with V.32bis).
V.33 | Protocol for full-duplex synchronous serial communication over leased lines with two pairs of wires; supports speeds of up to 14.4 Kbps and is used primarily in IBM mainframe environments.
V.34 | Supports 28.8-Kbps serial transmission (or 33.6 Kbps with V.34bis) over dial-up (one wire pair) or leased (one or two wire pairs) lines.
V.35 | Protocol for synchronous serial communication at speeds of up to 48 Kbps; typically used for DTE/DCE communication between Channel Service Unit/Data Service Units (CSU/DSUs) and bridges/routers. Replaced by V.10/11 but still widely implemented.
V.42 | Standard for data compression and error control in serial communication; uses both the LAPM (link access procedures for modems) and MNP (Microcom Networking Protocol) series protocols.
V.90 | High-speed modem standard that supports asymmetric communication with a maximum downstream data rate of 56 Kbps and an upstream rate of 33.6 Kbps.
NOTE

Only two V series standards are covered in detail in this work: V.35 and V.90.


W

W3C

See
World Wide Web Consortium (W3C)

wall plate

A cabling fixture attached to a wall in a work area for connecting computers to the network. Also called a faceplate.

How It Works

Wall plates can have RJ-45 jacks for 10BaseT networks (which resemble household RJ-11 telephone wall jacks), BNC jacks for 10Base2 networks, or SC jacks for networks that use fiber-optic cabling. The back end of the connector joins a horizontal cable that runs inside the wall or through a false ceiling or floor to a patch panel in the wiring closet for that floor. Computers are then connected to the wall plate by a short unshielded twisted-pair (UTP) cable called a drop cable. Wall plates typically come in mono-port, dual-port, and quad-port configurations.

Wall plates are an important feature of a permanent networking installation because they enable stations to be easily disconnected and reconnected to the network and they protect cables from damage. Flush wall plates are flat, like AC outlets, but angled wall plates are often a better choice because they offer better protection from excessive bending and from contact with heavy or sharp-edged furniture.

Graphic W-1. A flush wall plate and an angled wall plate.
Graphic W-1. A flush wall plate and an angled wall plate.
NOTE

You can get special wall plates for serial interfaces that use DB connectors such as DB9 or DB25. These wall plates are used in mainframe computing environments in which dumb terminals are connected to mainframe hosts by using RS-232 serial lines.

TIP

Be sure to label or number wall plates so that you can easily identify the port on the patch panel to which they connect.

If you can’t run cabling inside walls and must instead tack cabling directly onto the interior wall surface, use surface-mount boxes instead of wall plates. These are box-shaped adapters that screw onto the wall and have side or face jacks for connecting cables.

See also
premise cabling

WAN

See
wide area network (WAN)

WAN link

A communication circuit that joins two or more local area networks (LANs) into a wide area network (WAN).

How It Works

Many types of WAN links are possible between networks, depending on the networking protocols and telecommunications carrier services used, but WAN links can be grouped into three broad categories:

  • Circuit-switched services:
    Dial-up connections that establish a temporary switched circuit through the carrier’s telecommunications system for the duration of the communication session. When the connection is terminated, the carrier’s switches are freed up for other uses. One problem with this type of service is that the quality of communication varies between sessions with the quality of the switches and connecting trunk lines used. For this reason, circuit-switched lines are often used as a temporary backup link in case the primary leased line goes down. Because circuit-switched lines cost much less than leased lines, they are also used in low-traffic WAN networking environments. These lines are typically point-to-point connections, but they allow users to dial any connection they choose instead of being confined to a single connection, as is the case with leased lines. Examples of circuit-switched WAN links are modems and dial-up Integrated Services Digital Network (ISDN) links.

  • Leased lines:
    Dedicated connections that establish a permanent switched circuit through the carrier’s system. They are always “on” and ready to carry network traffic. Leased lines are typically much more expensive than circuit-switched lines because the carrier’s switches are dedicated to the customer even when they are not in use. Leased lines are typically point-to-point connections. A typical example of a leased line is a T1 line or fractional T1 line.

  • Packet-switching:
    Can be either dedicated or dial-up connections to a public packet-switching network such as X.25, a public frame relay network, or even a virtual private network (VPN) that uses tunneling over the Internet. The switches for a communication session are not configured when the session is established; instead, switches send packets of data along the best route possible by using the logical address of the destination node, which is contained in the header of each packet. Packet-switching links can be either point-to-point or point-to-multipoint connections, depending on how they are configured.

TIP

Leased lines are best for dedicated high-traffic WAN links, but packet-switching connections are often more cost-effective when the traffic is intermittent. It’s a good idea to use circuit-switched connections as a backup link for leased lines.

WAP

See
Wireless Application Protocol (WAP)

wave division multiplexing (WDM)

See
dense wavelength division multiplexing (DWDM)

WBEM

See
Web-Based Enterprise Management (WBEM)

W-CDMA

See
Wideband Code Division Multiple Access (W-CDMA)

WDM

See
dense wavelength division multiplexing (DWDM)

Web

See
World Wide Web (WWW)

Web application

A collection of elements on a Web site that performs a task programmatically. Web applications are designed to run on Web servers (such as Internet Information Services) and use Web browsers such as Microsoft Internet Explorer as the user interface. Web applications are typically client/server applications. For example, the ordering mechanism on an electronic commerce site is a Web application. Web applications can be developed by using a variety of technologies, including the following:

  • Active Server Pages (ASP)

  • ActiveX components

  • Client-side scripting using Microsoft Visual Basic, Scripting Edition (VBScript) and JavaScript

  • Internet Server API (ISAPI)

  • Common Gateway Interface (CGI)

Web-Based Enterprise Management (WBEM)

A proposed set of standards that enable computers and other network devices to be managed using a standard Web browser such as Microsoft Internet Explorer. Web-Based Enterprise Management (WBEM) is an initiative of the Distributed Management Task Force (DMTF) and originated in 1996 as a joint initiative of companies headed by Microsoft, Intel, Cisco Systems, Compaq, and BMC Software.

How It Works

WBEM enables information such as the amount of RAM in a computer, the capacity of a hard disk, the type of process, and the version of the operating system or firmware to be extracted from computers, routers, switches, and other network devices. This information can be used for detection of potential problems before they occur, for remote management using products such as Microsoft Systems Management Server (SMS), and for planning and other decision-making purposes. WBEM is designed to work in heterogeneous enterprise networking environments to collect diagnostic and management data relating to hardware from multiple vendors, different operating systems, different network protocols, and distributed applications.

Currently, enterprise-level network management includes using Simple Network Management Protocol (SNMP) for managing routers and switches, Desktop Management Interface (DMI) for desktop systems management, proprietary management protocols and systems for managing vendor applications, and so on. WBEM simplifies management by providing a common model and data source that can be extended to function with existing protocols, networking components, and applications.

The framework for this standard is the Common Information Model (CIM), a set of schema for cross-platform network management also developed by the DMTF. Once information is collected, it can be shared across an enterprise and displayed using WBEM management systems.

Microsoft has built the WBEM architecture into Windows 98 and Windows 2000 and has made it available as an add-on for Windows NT 4. Windows Management Instrumentation (WMI) is Microsoft’s implementation of WBEM for Microsoft Windows platforms.

TIP

WBEM 1.1 is included in Windows NT Server 4.0 Service Pack 4; you install it by running wbemcore.exe. It is not included in Service Pack 5, but you can install it from Service Pack 4 after you apply Service Pack 5.

See also
Common Information Model (CIM)

Web browser

An application that supports the client side of the Hypertext Transfer Protocol (HTTP), the Internet protocol for the World Wide Web (WWW). You can use a Web browser, also called a “browser,” to access (browse) content published on a Web server. This content can be static, meaning it consists of ASCII text files formatted using Hypertext Markup Language (HTML), or the content can be dynamic, meaning it is generated on demand using client-side or server-side scripting in languages such as JavaScript or Microsoft Visual Basic, Scripting Edition (VBScript). Web browsers typically offer additional features to make browsing the Web easier and more profitable. These features include the following:

  • Toolbar buttons for navigating forward and backward through the tree of previously displayed pages, for stopping the download process, and for manually refreshing a page that loaded incompletely.

  • Lists of favorites or bookmarks that store Uniform Resource Locators (URLs) of frequently accessed sites as well as tools for organizing and accessing those URLs.

  • Options for specifying a default home page from which to begin browsing, a default search engine for searching the Web, and other default browsing options.

  • Security options for handling such concerns as whether to allow scripts, ActiveX components, or Java applets to run on the browser.

  • Facilities for displaying the underlying source code or HTML of a page, and even for editing and publishing Web content.

  • Integration with other Internet software such as mail, news, or chat applications. Some Web browsers are packaged as stand-alone applications, while others are part of an overall suite of Internet tools that are integrated at various levels.

The first graphical Web browser was developed in 1993 by a group of students headed by Marc Andreessen at the National Center for Supercomputing Applications (NCSA). This browser was known as Mosaic and was distributed free. In 1994, Andreessen left NCSA to help found Netscape Communications, which developed the Netscape Navigator browser. The popularity of this browser helped foster the explosive growth of the Internet in the mid-1990s. Microsoft soon entered the arena with its Internet Explorer browser, which has become the most widely used browser on the market. Starting with Windows 95, Microsoft began closely integrating Internet Explorer into its Windows operating systems, with the result that users running Windows can access Internet resources as easily as files on their own hard drives.

On the Web
•
Internet Explorer home page
: http://www.microsoft.com/windows/ie
•
Netscape browser home page
: http://home.netscape.com/browsers/index.html
•
Mosaic home page
: http://www.ncsa.uiuc.edu/SDG/Software/Mosaic/
See also
Hypertext Transfer Protocol (HTTP) , Web server

webcasting

Any technology that enables automatic delivery of information from Web sites on the Internet. For example, you might make use of webcasting to receive a weather report update every 10 minutes. An example of a technology that enables webcasting is the Channel Definition Format (CDF) technology included with Microsoft Internet Explorer versions 4.0 and later.

Webcasting in Internet Explorer 4 can be divided into three categories:

  • Basic webcasting:
    Any existing Web site can be enabled for webcasting without modification to the site format and content. Internet Explorer can be scheduled to “crawl” the site at scheduled time intervals, check for new or updated content, and notify the user of this content or download it for offline browsing. This process is called “subscribing” to the Web site.

  • Managed webcasting:
    An ordinary Web site is turned into an Active Channel Web site when you create a CDF file for the site by using any text editor. The author of the site can optimize and personalize the site and control how it is webcast to users. This is essentially a form of “smart pull” technology.

  • “True” webcasting: Uses Internet Protocol (IP) multicasting to push content to the browsers of users who belong to a multicast group. This is an example of true push technology.

NOTE

The term “webcasting” is sometimes used to refer to the broadcasting of radio programs over the Internet.

See also
Channel Definition Format (CDF)

Web hosting

Hosting of Web content for other businesses. Web hosting providers range from local Internet service providers (ISPs) who provide businesses with a few dozen megabytes of server space and access to Perl scripting engines to global-presence companies with server farms that offer dedicated servers, e-mail accounts, domain name holding, support for Web content development tools such as Microsoft FrontPage, support for Web application development platforms such as Microsoft Visual InterDev, open database connectivity (ODBC) support, domain name hosting and holding services, and so on. Some industry watchers estimate that about two-thirds of all corporate Web sites are hosted by Web hosting service providers.

NOTE

Web hosting became big business around 1998. Web hosting providers are rapidly being supplanted by “content hosting” providers that offer an even greater range of services, which can include back-end system integration, custom programming, security management, and site mirroring. However, the distinction between the terms “Web hosting” and “content hosting” is often blurred in this rapidly evolving market.

TIP

When you shop for a Web hosting or content hosting service provider, find out what degree of availability they guarantee. Some providers offer 100 percent availability with no downtime and give clients a refund if any downtime occurs, even a few minutes. They can ensure 100 percent availability by hosting sites on multiple redundant servers and scheduling maintenance so that one server is always online.

Also be sure that the provider offers the full range of services that you require (or might soon require), such as database access and site mirroring. Find out the size of the pipe connecting the provider with the Internet backbone and at which point of presence (POP) the provider is connected to the Internet. For business hosting purposes, a minimum dual OC3 connection with guaranteed 155-Mbps throughput is recommended. Decide whether you want dedicated or shared hosting—that is, whether you are willing to share a server and its network bandwidth with other companies or whether you require the stability, reliability, and throughput of your own dedicated Web server.

Web map

A graphic display generated by Content Analyzer (a tool included with Microsoft Site Server and Microsoft Site Server Express) that allows Web server administrators to view the structure and integrity of their Web sites. Web maps can display all or selected portions of a site, including Hypertext Markup Language (HTML) files, graphics files, Java applets, and any other type of object. Administrators can use the Web map to determine the properties of any object in the site, such as the date when the object was last modified or its file size.

Web maps can be displayed in two different views:

  • Tree view:
    Displays a hierarchical picture of the objects in the site. This view is similar to the left pane of Windows Explorer.

  • Hyperbolic view:
    Displays the objects in the site in a dynamic nonlinear form that you can drag and manipulate to change its size and shape.

Web page

A file of text information formatted using Hypertext Markup Language (HTML), and possibly including scripts and active content, that is sent by a Web server in response to a Web browser’s request. Web pages are generally of two types:

  • Static Web pages:
    Stored as files on the server in the same form that they are delivered to the client. These files usually have the extension .htm or .html.

  • Dynamic Web pages:
    Pages with included scripts, ActiveX components, Java applets, ActiveX Data Objects (ADO), open database connectivity (ODBC) technologies, Dynamic HTML, or any other type of active content. They can also be Web pages that don’t actually exist on the server until the client requests them, whereupon they are generated by the server using Active Server Pages (ASP) or some other server-side technology.

See also
Hypertext Markup Language (HTML), Web browser

Web server

An application that supports the server side of the Hypertext Transfer Protocol (HTTP), the Internet protocol for the World Wide Web (WWW). Web servers are used to publish content on corporate intranets and over the Internet. To access content on a Web server, you use a Web browser, which supports the client side of HTTP.

Web servers were originally developed on the UNIX platform and were designed for publishing static Web content consisting of ASCII text files formatted using Hypertext Markup Language (HTML). Dynamic content such as forms and search engines were soon added using the Common Gateway Interface (CGI) in scripts written in interpretive languages such as Perl. On Microsoft operating system platforms, Active Server Pages (ASP) and the Internet Server API (ISAPI) are two technologies that you can use to develop dynamic Web content.

An example of a Web server is Internet Information Server (IIS), Microsoft’s Web server for Windows NT Server 4.0. (In Windows 2000 Server, this component is called Internet Information Services.) IIS is a powerful Web application development platform that is managed through a graphical user interface called the Microsoft Management Console (MMC). In addition to supporting HTTP, IIS supports File Transfer Protocol (FTP), Simple Mail Transfer Protocol (SMTP), and Network News Transfer Protocol (NNTP), as well as the Secure Sockets Layer (SSL) and Secure/Multipurpose Internet Mail Extensions (S/MIME) security protocols. IIS also supports Microsoft FrontPage, which is a Web site development tool.

Another popular Web server is Apache, an open source application for UNIX platforms (which has been ported to other platforms as well). Apache was originally based on the National Center for Supercomputing Applications’ httpd Web server daemon, which is no longer being developed. Apache is popular with Internet service providers (ISPs) that were founded within the university environment from which the Internet originated.

Other popular Web servers include Netscape Enterprise Server and Netscape FastTrack Server from Netscape Communications and Lotus Domino, the Web server component of Lotus Notes.

On the Web
•
Apache home page
: http://www.apache.org
•
Windows NT Web services
: http://www.microsoft.com/ntserver/web/
See also
Hypertext Transfer Protocol (HTTP) , Web browser

well-known port numbers

Port numbers for Transmission Control Protocol (TCP) or User Datagram Protocol (UDP) that have been assigned to specific TCP/IP applications or services by the Internet Assigned Numbers Authority (IANA). Well-known port numbers are assigned within the range 0 through 1023 and are specified in Request for Comments (RFC) 1060. (The total range of possible port numbers is 0 through 65535.) The following table describes some of the well-known port numbers.

NOTE

“Registered ports” are port numbers that are not controlled by IANA but that IANA registers to indicate to the Internet community which vendor applications use them. Registered ports range from 1024 through 65535 and can be used by any process or program requesting it if the operating system has not already allocated it for a specific use. Programs and processes that communicate using remote procedure calls (RPCs) often randomly select a registered port for each RPC communication session.

Well-Known Port Numbers
Port Number | Keyword | Description
0/tcp, udp |  | Reserved
1/tcp, udp | tcpmux | TCP Port Service Multiplexer
2/tcp, udp | compressnet | Management Utility
3/tcp, udp | compressnet | Compression Process
4/tcp, udp |  | Unassigned
5/tcp, udp | rje | Remote Job Entry
6/tcp, udp |  | Unassigned
7/tcp, udp | echo | Echo
8/tcp, udp |  | Unassigned
9/tcp, udp | discard | Discard; alias = sink null
10/tcp, udp |  | Unassigned
11/tcp, udp | systat | Active Users; alias = users
12/tcp, udp |  | Unassigned
13/tcp, udp | daytime | Daytime
14/tcp, udp |  | Unassigned
15/tcp, udp |  | Unassigned (was netstat)
16/tcp, udp |  | Unassigned
17/tcp, udp | qotd | Quote of the Day; alias = quote
18/tcp, udp | msp | Message Send Protocol
19/tcp, udp | chargen | Character Generator; alias = ttytst source
20/tcp, udp | ftp-data | File Transfer (default data)
21/tcp, udp | ftp | File Transfer (control), connection dialog
22/tcp, udp |  | Unassigned
23/tcp, udp | telnet | Telnet
24/tcp, udp |  | Any private mail system
25/tcp, udp | smtp | Simple Mail Transfer; alias = mail
26/tcp, udp |  | Unassigned
27/tcp, udp | nsw-fe | NSW User System FE
28/tcp, udp |  | Unassigned
29/tcp, udp | msg-icp | MSG ICP
30/tcp, udp |  | Unassigned
31/tcp, udp | msg-auth | MSG Authentication
32/tcp, udp |  | Unassigned
33/tcp, udp | dsp | Display Support Protocol
34/tcp, udp |  | Unassigned
35/tcp, udp |  | Any private printer server
36/tcp, udp |  | Unassigned
37/tcp, udp | time | Time; alias = timeserver
38/tcp, udp |  | Unassigned
39/tcp, udp | rlp | Resource Location Protocol; alias = resource
40/tcp, udp |  | Unassigned
41/tcp, udp | graphics | Graphics
42/tcp, udp | nameserver | Host Name Server; alias = nameserver
43/tcp, udp | nicname | Who Is; alias = nicname
44/tcp, udp | mpm-flags | MPM FLAGS Protocol
45/tcp, udp | mpm | Message Processing Module
46/tcp, udp | mpm-snd | MPM (default send)
47/tcp, udp | ni-ftp | NI FTP
48/tcp, udp |  | Unassigned
49/tcp, udp | login | Login Host Protocol
50/tcp, udp | re-mail-ck | Remote Mail Checking Protocol
51/tcp, udp | la-maint | IMP Logical Address Maintenance
52/tcp, udp | xns-time | XNS Time Protocol
53/tcp, udp | domain | Domain Name Server
54/tcp, udp | xns-ch | XNS Clearinghouse
55/tcp, udp | isi-gl | ISI Graphics Language
56/tcp, udp | xns-auth | XNS Authentication
57/tcp, udp |  | Any private terminal access
58/tcp, udp | xns-mail | XNS Mail
59/tcp, udp |  | Any private file service
60/tcp, udp |  | Unassigned
61/tcp, udp | ni-mail | NI MAIL
62/tcp, udp | acas | ACA Services
63/tcp, udp | via-ftp | VIA Systems – FTP
64/tcp, udp | covia | Communications Integrator (CI)
65/tcp, udp | tacacs-ds | TACACS-Database Service
66/tcp, udp | sql*net | Oracle SQL*NET
67/tcp, udp | bootpc | DHCP/BOOTP Protocol Server
68/tcp, udp | bootpc | DHCP/BOOTP Protocol Server
69/tcp, udp | tftp | Trivial File Transfer
70/tcp, udp | gopher | Gopher
71/tcp, udp | netrjs-1 | Remote Job Service
72/tcp, udp | netrjs-2 | Remote Job Service
73/tcp, udp | netrjs-3 | Remote Job Service
74/tcp, udp | netrjs-4 | Remote Job Service
75/udp |  | Any private dial-out service
76/tcp, udp |  | Unassigned
77/tcp, udp |  | Any private RJE service
78/tcp, udp | vettcp | Vettcp
79/tcp, udp | finger | Finger
80/tcp, udp | www | World Wide Web HTTP
81/tcp, udp | hosts2-ns | HOSTS2 Name Server
82/tcp, udp | xfer | XFER Utility
83/tcp, udp | mit-ml-dev | MIT ML Device
84/tcp, udp | ctf | Common Trace Facility
85/tcp, udp | mit-ml-dev | MIT ML Device
86/tcp, udp | mfcobol | Micro Focus Cobol
87/tcp, udp |  | Any private terminal link; alias = ttylink
88/tcp, udp | kerberos | Kerberos
89/tcp, udp | su-mit-tg | SU/MIT Telnet Gateway
90/tcp, udp |  | DNSIX Security Attribute Token Map
91/tcp, udp | mit-dov | MIT Dover Spooler
92/tcp, udp | npp | Network Printing Protocol
93/tcp, udp | dcp | Device Control Protocol
94/tcp, udp | objcall | Tivoli Object Dispatcher
95/tcp, udp | supdup | SUPDUP
96/tcp, udp | dixie | DIXIE Protocol Specification
97/tcp, udp | swift-rvf | Swift Remote Virtual File Protocol
98/tcp, udp | tacnews | TAC News
99/tcp, udp | metagram | Metagram Relay
100/tcp | newacct | (unauthorized use)
101/tcp, udp | hostname | NIC Host Name Server; alias = hostname
102/tcp, udp | iso-tsap | ISO-TSAP
103/tcp, udp | gppitnp | Genesis Point-to-Point Trans Net; alias = webster
104/tcp, udp | acr-nema | ACR-NEMA Digital Imag. & Comm. 300
105/tcp, udp | csnet-ns | Mailbox Name Nameserver
106/tcp, udp | 3com-tsmux | 3COM-TSMUX
107/tcp, udp | rtelnet | Remote Telnet Service
108/tcp, udp | snagas | SNA Gateway Access Server
109/tcp, udp | pop2 | Post Office Protocol version 2 (POP2); alias = postoffice
110/tcp, udp | pop3 | Post Office Protocol version 3 (POP3); alias = postoffice
111/tcp, udp | sunrpc | SUN Remote Procedure Call
112/tcp, udp | mcidas | McIDAS Data Transmission Protocol
113/tcp, udp | auth | Authentication Service; alias = authentication
114/tcp, udp | audionews | Audio News Multicast
115/tcp, udp | sftp | Simple File Transfer Protocol
116/tcp, udp | ansanotify | ANSA REX Notify
117/tcp, udp | uucp-path | UUCP Path Service
118/tcp, udp | sqlserv | SQL Services
119/tcp, udp | nntp | Network News Transfer Protocol (NNTP); alias = usenet
120/tcp, udp | cfdptkt | CFDPTKT
121/tcp, udp | erpc | Encore Expedited Remote Pro. Call
122/tcp, udp | smakynet | SMAKYNET
123/tcp, udp | ntp | Network Time Protocol; alias = ntpd ntp
124/tcp, udp | ansatrader | ANSA REX Trader
125/tcp, udp | locus-map | Locus PC-Interface Net Map Server
126/tcp, udp | unitary | Unisys Unitary Login
127/tcp, udp | locus-con | Locus PC-Interface Conn Server
128/tcp, udp | gss-xlicen | GSS X License Verification
129/tcp, udp | pwdgen | Password Generator Protocol
130/tcp, udp | cisco-fna | Cisco FNATIVE
131/tcp, udp | cisco-tna | Cisco TNATIVE
132/tcp, udp | cisco-sys | Cisco SYSMAINT
133/tcp, udp | statsrv | Statistics Service
134/tcp, udp | ingres-net | INGRES-NET Service
135/tcp, udp | loc-srv | Location Service
136/tcp, udp | profile | PROFILE Naming System
137/tcp, udp | netbios-ns | NetBIOS Name Service
138/tcp, udp | netbios-dgm | NetBIOS Datagram Service
139/tcp, udp | netbios-ssn | NetBIOS Session Service
140/tcp, udp | emfis-data | EMFIS Data Service
141/tcp, udp | emfis-cntl | EMFIS Control Service
142/tcp, udp | bl-idm | Britton-Lee IDM
143/tcp, udp | imap2 | Interim Mail Access Protocol v2
144/tcp, udp | news | NewS; alias = news
145/tcp, udp | uaac | UAAC Protocol
146/tcp, udp | iso-ip0 | ISO-IP0
147/tcp, udp | iso-ip | ISO-IP
148/tcp, udp | cronus | CRONUS-SUPPORT
149/tcp, udp | aed-512 | AED 512 Emulation Service
150/tcp, udp | sql-net | SQL-NET
151/tcp, udp | hems | HEMS
152/tcp, udp | bftp | Background File Transfer Program
153/tcp, udp | sgmp | SGMP; alias = sgmp
154/tcp, udp | netsc-prod | Netscape
155/tcp, udp | netsc-dev | Netscape
156/tcp, udp | sqlsrv | SQL Service
157/tcp, udp | knet-cmp | KNET/VM Command/Message Protocol
158/tcp, udp | pcmail-srv | PCMail Server; alias = repository
159/tcp, udp | nss-routing | NSS-Routing
160/tcp, udp | sgmp-traps | SGMP-TRAPS
161/tcp, udp | snmp | SNMP; alias = snmp
162/tcp, udp | snmptrap | SNMPTRAP
163/tcp, udp | cmip-man | CMIP/TCP Manager
164/tcp, udp | cmip-agent | CMIP/TCP Agent
165/tcp, udp | xns-courier | Xerox
166/tcp, udp | s-net | Sirius Systems
167/tcp, udp | namp | NAMP
168/tcp, udp | rsvd | RSVD
169/tcp, udp | send | SEND
170/tcp, udp | print-srv | Network PostScript
171/tcp, udp | multiplex | Network Innovations Multiplex
172/tcp, udp | cl/1 | Network Innovations CL/1
173/tcp, udp | xyplex-mux | Xyplex
174/tcp, udp | mailq | MAILQ
175/tcp, udp | vmnet | VMNET
176/tcp, udp | genrad-mux | GENRAD-MUX
177/tcp, udp | xdmcp | X Display Manager Control Protocol
178/tcp, udp | nextstep | NextStep Window Server
179/tcp, udp | bgp | Border Gateway Protocol (BGP)
180/tcp, udp | ris | Intergraph
181/tcp, udp | unify | Unify
182/tcp, udp | audit | Unisys Audit SITP
183/tcp, udp | ocbinder | OCBinder
184/tcp, udp | ocserver | OCServer
185/tcp, udp | remote-kis | Remote-KIS
186/tcp, udp | kis | KIS Protocol
187/tcp, udp | aci | Application Communication Interface
188/tcp, udp | mumps | Plus Five’s MUMPS
189/tcp, udp | qft | Queued File Transport
190/tcp, udp | gacp | Gateway Access Control Protocol
191/tcp, udp | prospero | Prospero
192/tcp, udp | osu-nms | OSU Network Monitoring System
193/tcp, udp | srmp | Spider Remote Monitoring Protocol
194/tcp, udp | irc | Internet Relay Chat (IRC) Protocol
195/tcp, udp | dn6-nlm-aud | DNSIX Network Level Module Audit
196/tcp, udp | dn6-smm-red | DNSIX Session Mgt Module Audit Redir
197/tcp, udp | dls | Directory Location Service
198/tcp, udp | dls-mon | Directory Location Service Monitor
199/tcp, udp | smux | SMUX
200/tcp, udp | src | IBM System Resource Controller
201/tcp, udp | at-rtmp | AppleTalk Routing Maintenance
202/tcp, udp | at-nbp | AppleTalk Name Binding
203/tcp, udp | at-3 | AppleTalk Unused
204/tcp, udp | at-echo | AppleTalk Echo
205/tcp, udp | at-5 | AppleTalk Unused
206/tcp, udp | at-zis | AppleTalk Zone Information
207/tcp, udp | at-7 | AppleTalk Unused
208/tcp, udp | at-8 | AppleTalk Unused
209/tcp, udp | tam | Trivial Authenticated Mail Protocol
210/tcp, udp | z39.50 | ANSI Z39.50
211/tcp, udp | 914c/g | Texas Instruments 914C/G Terminal
212/tcp, udp | anet | ATEXSSTR
213/tcp, udp | ipx | Internetwork Packet Exchange (IPX)
214/tcp, udp | vmpwscs | VM PWSCS
215/tcp, udp | softpc | Insignia Solutions
216/tcp, udp | atls | Access Technology License Server
217/tcp, udp | dbase | dBASE UNIX
218/tcp, udp | mpp | Netix Message Posting Protocol
219/tcp, udp | uarps | Unisys ARPs
220/tcp, udp | imap3 | Interactive Mail Access Protocol v3
221/tcp, udp | fln-spx | Berkeley rlogind with SPX auth
222/tcp, udp | fsh-spx | Berkeley rshd with SPX auth
223/tcp, udp | cdc | Certificate Distribution Center
224–241 |  | Reserved
243/tcp, udp | sur-meas | Survey Measurement
245/tcp, udp | link | LINK
246/tcp, udp | dsp3270 | Display Systems Protocol
247–255 |  | Reserved
345/tcp, udp | pawserv | Perf Analysis Workbench
346/tcp, udp | zserv | Zebra server
347/tcp, udp | fatserv | Fatmen Server
371/tcp, udp | clearcase | Clearcase
372/tcp, udp | ulistserv | UNIX Listserv
373/tcp, udp | legent-1 | Legent Corporation
374/tcp, udp | legent-2 | Legent Corporation
512/tcp | print | Microsoft Windows NT Server and Windows NT Workstation 4 can send LPD client print jobs from any available reserved port between 512 and 1023; see also the description for ports 721 to 731
512/udp | biff | Used by the mail system to notify users of new mail received; currently receives messages only from processes on the same computer; alias = comsat
513/tcp | login | Remote logon such as Telnet; automatic authentication performed based on privileged port numbers and distributed databases that identify “authentication domains”
513/udp | who | Maintains databases showing who’s logged on to the computers on a local net and the load average of the computer; alias = whod
514/tcp | cmd | Like exec, but automatic authentication is performed as for logon server
514/udp | syslog |
515/tcp, udp | printer | Spooler; the print server LPD service listens on tcp port 515 for incoming connections; alias = spooler
517/tcp, udp | talk | Like tenex link, but across computers; unfortunately, doesn’t use link protocol (actually just a rendezvous port from which a TCP connection is established)
518/tcp, udp | ntalk |
519/tcp, udp | utime | Unixtime
520/tcp | efs | Extended filename server
520/udp | router | Local routing process (on site); uses variant of Xerox NS routing information protocol; alias = router routed
525/tcp, udp | timed | Timeserver
526/tcp, udp | tempo | Newdate
530/tcp, udp | courier | RPC
531/tcp | conference | Chat
531/udp | rvd-control | MIT disk
532/tcp, udp | netnews | Readnews
533/tcp, udp | netwall | For emergency broadcasts
540/tcp, udp | uucp | Uucpd
543/tcp, udp | klogin |
544/tcp, udp | kshell | Krcmd; alias = cmd
550/tcp, udp | new-rwho | New-who
555/tcp, udp | dsf |
556/tcp, udp | remotefs | Rfs server; alias = rfs_server rfs
560/tcp, udp | rmonitor | Rmonitord
561/tcp, udp | monitor |
562/tcp, udp | chshell | Chcmd
564/tcp, udp | 9pfs | Plan 9 file service
565/tcp, udp | whoami | Whoami
570/tcp, udp | meter | Demon
571/tcp, udp | meter | Udemon
600/tcp, udp | ipcserver | Sun IPC server
607/tcp, udp | nqs | Nqs
666/tcp, udp | doom | Reserved for Id software
704/tcp, udp | elcsd | Errlog copy/server daemon
721–731/tcp | printer | In Windows NT 3.5, all TCP/IP print jobs sent from a computer running Windows NT were sourced from TCP ports 721 through 731; Windows NT 4 and Windows 2000 source LPD client print jobs from any available reserved port between 512 and 1023
740/tcp, udp | netcp | NETscout Control Protocol
741/tcp, udp | netgw | NetGW
742/tcp, udp | netrcs | Network-based Rev. Cont. Sys.
744/tcp, udp | flexlm | Flexible License Manager
747/tcp, udp | fujitsu-dev | Fujitsu Device Control
748/tcp, udp | ris-cm | Russell Info Sci Calendar Manager
749/tcp, udp | kerberos-adm | Kerberos administration
750/tcp | rfile | Kerberos authentication; alias = kdc
750/udp | loadav |
751/tcp, udp | pump | Kerberos authentication
752/tcp, udp | qrh | Kerberos password server
753/tcp, udp | rrh | Kerberos userreg server
754/tcp, udp | tell | Send; Kerberos slave propagation
758/tcp, udp | nlogin |
759/tcp, udp | con |
760/tcp, udp | ns |
761/tcp, udp | rxe |
762/tcp, udp | quotad |
763/tcp, udp | cycleserv |
764/tcp, udp | omserv |
765/tcp, udp | webster |
767/tcp, udp | phonebook | Phone
769/tcp, udp | vid |
770/tcp, udp | cadlock |
771/tcp, udp | rtip |
772/tcp, udp | cycleserv2 |
773/tcp | submit |
773/udp | notify |
774/tcp | rpasswd |
774/udp | acmaint_dbd |
775/tcp | entomb |
775/udp | acmaint_transd |
776/tcp, udp | wpages |
780/tcp, udp | wpgs |
781/tcp, udp | hp-collector | HP performance data collector
782/tcp, udp | hp-managed-node | HP performance data managed node
783/tcp, udp | hp-alarm-mgr | HP performance data alarm manager
800/tcp, udp | mdbs_daemon |
801/tcp, udp | device |
888/tcp | erlogin | Logon and environment passing
996/tcp, udp | xtreelic | XTREE License Server
997/tcp, udp | maitrd |
998/tcp | busboy |
998/udp | puparp |
999/tcp | garcon |
999/udp | applix | Applix ac
999/tcp, udp | puprouter |
1000/tcp | cadlock |
1000/udp | ock |

wide area network (WAN)

A geographically distributed network composed of local area networks (LANs) joined into a single large network using services provided by common carriers. Wide area networks (WANS) are commonly implemented in enterprise networking environments in which company offices are in different cities, states, or countries or on different continents.

WAN technologies were previously limited to expensive leased lines such as T1 lines, slow packet-switching services such as X.25, cheap but low-bandwidth solutions such as modems, and dial-up Integrated Services Digital Network (ISDN) connections, but this has changed considerably in recent years. Frame relay services provide high-speed packet-switching services that offer more bandwidth than X.25, and virtual private networks (VPNs) created using Internet Protocol (IP) tunneling technologies enable companies to securely connect branch offices by using the Internet as a backbone service. Intranets and extranets provide remote and mobile users with access to company resources and applications and provide connectivity with business partners and resellers. Wireless networking technologies allow roaming users to access network resources by using cell-based technologies. Digital Subscriber Line (DSL) services provide T1 speeds at much lower costs than dedicated T1 circuits. These and other new technologies continue to evolve and proliferate, allowing enterprise network administrators to implement and administer a highly diverse range of WAN solutions.

See also
frame relay, Integrated Services Digital Network (ISDN), leased line, WAN link, X.25

Wideband Code Division Multiple Access (W-CDMA)

A wireless communication technology derived from Code Division Multiple Access (CDMA) cellular phone technology that is proposed for 3G (third-generation) wireless communication systems. Wideband Code Division Multiple Access (W-CDMA) uses wider frequency bands than CDMA, so it can achieve higher throughput for data transmission. The Universal Mobile Telecommunications System (UMTS) standard proposed by the European Telecommunications Standards Institute (ETSI) and incorporated into the International Mobile Telecommunications-2000 (IMT-2000) initiative of the International Telecommunication Union (ITU) is partly based on W-CDMA.

W-CDMA is not fully compatible with air and network interfaces of the proposed CDMA2000 standard, which is another part of the IMT-2000 initiative, and it is not compatible with the air interface of the existing Global System for Mobile Communications (GSM) cellular phone network. The CDMA2000 standard uses synchronous base station transmissions with 20-millisecond frames, while W-CDMA uses asynchronous base station transmissions with 10-millisecond frames.

Windows

See
Microsoft Windows

Windows 3.1

The GUI-based operating system from Microsoft that made personal computers easier and more fun to use. Microsoft Windows went through several earlier versions, but the first widely used version was Windows 3.0, which was released in 1990 and provided users with a graphical user interface (GUI) environment that was easier to learn and use than the command-line environment of the MS-DOS operating system. In 1992, Microsoft released Windows 3.1, which included additional enhancements and utilities. Windows 3.1 is now considered a legacy operating system and has largely been replaced by Windows 95, Windows 98, Windows NT, and Windows 2000 in homes and businesses.

Unique features of Windows 3.1 that distinguished it from earlier operating systems such as MS-DOS include the following:

  • A GUI that displays applications in separate windows that can be resized and arranged in any fashion

  • Virtual memory, a technique for swapping between RAM and disk space that increases the number of applications that can be run simultaneously

  • Customizable user interface elements, including the color scheme, fonts, arrangement of windows, and mouse settings

  • Data sharing by applications using Dynamic Data Exchange (DDE) and object linking and embedding (OLE)

  • TrueType fonts, which are displayed in WYSIWYG fashion and can be scaled to any size

  • Device independence, which makes it easier for manufacturers to write device drivers for their hardware

  • Network-aware File Manager and Print Manager utilities, which enable access to shared network drives and printers

    Graphic W-2. Windows 3.1 User interface.
    Graphic W-2. Windows 3.1 User interface.
How It Works

Windows 3.1 is a 16-bit cooperative multitasking graphical operating system that runs on top of MS-DOS and shares some architectural similarities with MS-DOS. Windows 3.1 uses a layered architecture (see the following figure) consisting of three main components:

  • A top-layer Windows application programming interface (API) that allows software developers to write 16-bit Windows programs without needing to understand the details of how the operating system routines work internally or how device drivers are implemented and communicate with underlying hardware.

  • A middle layer consisting of Windows core components and extensions. The core components make up the kernel of the operating system and consist of three subcomponents:

    • Krnl386.exe:
      Handles basic operating systems such as memory management, process and thread scheduling, and file input/output (I/O)

    • User.exe:
      Manages user I/O devices such as the keyboard and mouse, manages communication ports, and keeps track of Windows user interface elements such as windows, dialog boxes, icons, and menus

    • Gdi.exe:
      Manages drawing screen graphics and printing

    The middle layer also includes extensions to the core operating system components that are supplied in the form of dynamic-link libraries (DLLs) that add extra functionality to the Windows environment, such as multimedia support and DDE. Windows DLLs make the Windows operating system environment extensible, allowing software manufacturers to add basic functionality to Windows by creating their own custom DLLs. Windows optimizes memory usage by dynamically loading only the DLLs that it needs at a given time.

    Graphic W-3. Windows 3.1. Architecture.
    Graphic W-3. Windows 3.1. Architecture.

  • A bottom layer, consisting of Windows drivers, that provides device drivers for different hardware devices managed by Windows, such as the keyboard, mouse, video display, and communication ports.

Windows 3.1 has two modes of operation:

  • Standard Mode:
    Does not use virtual memory and cannot multitask with MS-DOS applications. In Standard Mode, MS-DOS applications can run only full-screen.

  • 386 Enhanced Mode:
    (See the following diagram.) Requires an Intel 386 or higher processor, uses virtual memory, and supports multitasking of MS-DOS applications in separate windows. This mode includes the Virtual Machine Manager (VMM), which creates and manages separate virtual machines (VMs) running on a single CPU. Each VM functions as though it has access to and control over the resources of the entire system. Windows 3.1 and all 16-bit Windows applications run in a single system VM, while each additional MS-DOS application runs in its own separate DOS VM. Virtual device drivers (VxDs) are 32-bit protected-mode DLLs that allow more than one process to share a system resource simultaneously in order to support multitasking. Windows applications are multitasked cooperatively—that is, they must be written to properly relinquish control to other applications to allow them to share system resources. Running win.com at the MS-DOS prompt invokes the 386 Enhanced Mode system loader (win386.exe).

Windows 3.1 stores its system and operating system configuration information in a series of text files accessed during the boot process. These include the following:

  • Config.sys and autoexec.bat, which have the same function as in MS-DOS

  • Win.ini, which configures the Windows desktop and working environment

  • System.ini, which stores the Windows system configuration, including device drivers and mode settings

  • Other INI files such as progman.ini, protocol.ini, control.ini, and lanman.ini

Graphic W-4. Windows 3.1. Virtual memory in 386 Enhanced Mode.
Graphic W-4. Windows 3.1. Virtual memory in 386 Enhanced Mode.
NOTE

Windows 3.1 includes a 32-bit file system technology called FastDisk, which filters Int 13H calls to the hard disk controller and uses 32-bit protected-mode device drivers or accesses the disk through the system BIOS, depending on how it is configured. However, this feature is disabled by default when Windows 3.1 is installed; you can turn it on by using the 386 Enhanced utility in Control Panel.

Windows 3.11

See
Windows for Workgroups 3.11

Windows 3. x

See
Windows 3.1, Windows for Workgroups 3.11

Windows 95

Microsoft’s popular 32-bit desktop operating system, which replaced the Windows 3.1 operating system. Windows 95 was designed as a desktop operating system for home, office, and business use that preserves full backward compatibility with applications for legacy 16-bit operating systems such as MS-DOS, Windows 3.1, and Windows for Workgroups.

Graphic W-5. Desktop.
Graphic W-5. Desktop.

Windows 95 includes the following features:

  • A redesigned graphical user interface (GUI) with such features as a configurable desktop, taskbar, Start button, and context menus

  • Compatibility with legacy hardware and with MS-DOS and 16-bit Windows applications

  • 32-bit virtual device drivers (VxDs) for protected-mode management of devices and services

  • Preemptive multitasking kernel that multitasks Win32 and MS-DOS-based applications, replacing the cooperative multitasking approach used by Windows 3.1

  • Fully integrated 32-bit disk, network, and print subsystems

  • Integrated built-in networking software for Microsoft Networks, Novell NetWare, and Banyan Vines

  • Support for long filenames

  • Support for plug and play automatic hardware installation and configuration

  • Advanced Power Management (APM) support for mobile users

  • Integrated Windows Messaging for e-mail

  • Integrated dial-up networking for Internet connectivity and for Remote Access Service (RAS) connectivity

  • Integrated support for multimedia sound and video applications

  • Microsoft Internet Explorer, an integrated Web browser

  • Support for advanced features for network administrators, including hardware profiles, user profiles, and system policies

How It Works

The Windows 95 architecture evolved from Windows 3.1 and Windows for Workgroups, but in contrast to these 16-bit versions of Windows, which ran on top of MS-DOS, Windows 95 is a 32-bit operating system with a 32-bit kernel, VxDs, and an Installable File System (IFS) manager and does not require that MS-DOS be loaded on the computer. However, Windows 95 does includes some 16-bit code and 16-bit components to ensure backward compatibility with MS-DOS, Windows 3.1, and Windows for Workgroups. Windows 95 also supports multithreaded operation and preemptive multitasking operation and manages system resources more effectively than earlier versions of Windows, allowing more and larger applications to be multitasked.

Graphic W-6. Architecture.
Graphic W-6. Architecture.

For added protection against application crashes, Windows 95 supports virtual machines (VMs). VMs in Windows 95 are similar to those implemented in Windows 3.1 except for two differences: in Windows 95, 32-bit Windows applications (Win32 apps) can run within their own protected memory address space within the system VM, and 16-bit Windows applications (Win16 apps) also run in the system VM but share their own address space (since they must be cooperatively multitasked). MS-DOS applications run in individual VMs of their own.

Another change in Windows 95 is that system configuration information that was formerly stored in boot files (config.sys and autoexec.bat) and INI files is stored in a database structure called the registry. The registry is the central repository for all hardware and software configuration information. Boot and INI files are still supported for backward compatibility with legacy hardware and software.

NOTE

Windows 95 went through several incremental releases, each with additional features and enhancements. To determine which version of Windows 95 you are using, run the System utility in Control Panel and look at the version number on the General tab. The incremental versions are described in the following table.

Windows 95 Incremental Releases
Version Number | Release
4.00.950 | Original full retail version and upgrade from Windows 3.1.
4.00.950A | Windows 95 with Service Pack 1, also called OEM Service Release 1 (OSR1).
4.00.950B | OEM Service Release 2 (OSR2) or OEM Service Release 2.1 (OSR2.1). If “USB Supplement to OSR2” shows up as an installed program when you use the Add/Remove Programs utility in Control Panel, you have OSR2.1 installed.
4.00.950C | OEM Service Release 2.5 (OSR2.5).
NOTE

If your 20-digit product ID number has “OEM” in it, you have an original equipment manufacturer (OEM) version of Windows 95 that was probably preinstalled on your computer.

See also
Windows 3.1

Windows 98

Microsoft’s upgrade for users of Windows 95 and earlier versions of Microsoft Windows operating systems. Windows 98 includes the following new features:

  • A Web-aware user interface that allows Web-like views of local resources and a single tool for browsing local, network, and Internet resources

  • Integrated Internet software including Microsoft Internet Explorer, Outlook Express, NetMeeting, Personal Web Server, FrontPad, and NetShow

  • Windows Update Manager for accessing the Internet to download enhancements and fixes to Windows 98

  • Improved networking support with a faster TCP/IP protocol stack, improved dial-up networking, and support for virtual private networking

  • Support for FAT32 drives and a FAT32 conversion utility

  • Maintenance Wizard for scheduling system maintenance utilities and other new utilities that simplify administration of computers running Windows 98, including the Microsoft System Information utility, System File Checker, Registry Checker, and Windows Scripting Host (for running administrative scripts from the desktop)

  • Support for digital versatile disc (DVD) and for multiple monitors on a single computer

  • Support for universal serial bus (USB), FireWire (IEEE 1394), and infrared wireless connectivity based on Infrared Data Association (IrDA) standards

  • Support for DirectX 5.0 and OnNow instant-on technology

  • Built-in Remote Access Service (RAS) for remote dial-up clients

  • HTML-based online help

  • Improved versions of many Windows 95 tools and utilities

NOTE

The Windows 98 system architecture and user interface are essentially the same as those of Windows 95 with Internet Explorer version 4.0 or later installed using the Active Desktop option.

TIP

When you plan an upgrade for your current desktop operating system, choose Windows 2000 over Windows 98 if you need such features as

  • Local desktop file security using the NTFS file system

  • Greater stability and protection for running applications

  • Scalability and portability to multiprocessor and RISC-based machines

  • C2 level security

On the other hand, you should choose Windows 98 over Windows 2000 if you need any of the following:

  • Full backward compatibility with MS-DOS and 16-bit Windows applications

  • Support for legacy hardware and lower overall hardware requirements

  • Advanced Power Management (APM) for mobile users

  • Support for games

See also
Windows 95

Windows 2000

The latest version of the Microsoft Windows operating system, which was designed as the successor to Windows NT and, to some extent, Windows 98. The Windows 2000 family has four members:

  • Windows 2000 Professional:
    A desktop operating system that replaces Windows NT Workstation 4 and builds on the ease-of-use of Windows 98 and the power and reliability of Windows NT. Windows 2000 Professional includes the following features:

    • Wizards for simplifying system configuration and common system maintenance tasks, and time-saving improvements for the user interface, including Microsoft Internet Explorer 5, an integrated Web browser

    • Features for mobile users, including Advanced Configuration and Power Interface (ACPI) support for laptop power management and offline files, and Synchronization Manager for remote use of network resources

    • Support for 4-GB RAM, two-way symmetric multiprocessing (SMP), universal serial bus (USB) and IEEE 1394 interfaces, Microsoft DirectX 7, OpenGL 1.2, video port extensions, and digital versatile disc (DVD) and smart card technologies

    • IntelliMirror client for deployment and maintenance in conjunction with Windows 2000 Server

    • Local data protection using the Encrypting File System (EFS)

    • Support for TCP/IP virtual private networking using Point-to-Point Tunneling Protocol (PPTP), Layer 2 Tunneling Protocol (L2TP), and Internet Protocol Security (IPSec)

    • Add-on Windows Services for UNIX components for interoperability with UNIX networking environments, including a Network File System (NFS) client and server, Telnet client and server, scripting tools, and password synchronization features

  • Windows 2000 Server, Standard Edition:
    A comprehensive application, file, print, and Internet services platform that replaces Windows NT Server 4 and provides increased reliability, scalability, management, and applications support. Its features include the following:

    • Active Directory, a directory service based on the X.500 directory specifications that simplifies centralized, one-point management of distributed network resources.

    • Windows Management Tools, which are snap-ins for the Microsoft Management Console (MMC). MMC provides a unified interface for managing enterprise-level network resources.

    • Enhanced Internet services, including Hypertext Transfer Protocol (HTTP), File Transfer Protocol (FTP), Simple Mail Transfer Protocol (SMTP), and Network News Transfer Protocol (NNTP) server support through Internet Information Services (IIS).

    • Windows Terminal Services for running terminal emulation on thin clients, replacing Windows NT Server, Terminal Server Edition.

    • Four-way SMP support.

    • Enhanced COM+ component services.

    • Support for Kerberos and public key infrastructure (PKI) security services.

  • Windows 2000 Advanced Server:
    A powerful server operating system that replaces Windows NT Server 4, Enterprise Edition, Windows 2000 Advanced Server is designed for enterprise-level networking environments that require high availability and scalability. Its features include all those in Windows 2000 Server, Standard Edition, plus the following:

    • Support for up to 64-GB RAM (through Intel’s Physical Address Extensions) and eight-way SMP

    • Network-based and component-based load balancing with failover clustering

    • High-performance sorting

  • Windows 2000 Datacenter Server:
    Designed to be the high end of the Windows 2000 Server family when it is released. It will support all features of Windows 2000 Advanced Server plus advanced clustering and 16-way SMP, with 32-way SMP available through original equipment manufacturers (OEMs)

    Graphic W-7. Desktop.
    Graphic W-7. Desktop.
NOTE

The architecture of Windows 2000 is similar to that of Windows NT. Some of the notable differences include the following:

  • The kernel is modified to include support for Terminal Services.

  • Kernel Mode includes two new modules: Plug and Play Manager and Power Manager.

  • I/O Manager includes additional drivers for Asynchronous Transfer Mode (ATM), quality of service (QoS), and so on.

TIP

If you are a Windows NT system administrator who is moving to the more powerful and scalable Windows 2000 operating system platform, you might be confused at first by the differences between administrative tools on the two platforms. The following table is designed to help you get up to speed quickly on Windows 2000 system administration by highlighting some of the differences between the basic administrative tools on the Windows NT and Windows 2000 platforms. Note that there is usually no one-to-one correspondence between tools on the two platforms; what can be done with one tool on Windows NT might require several on Windows 2000, and vice versa. The tools listed in the second column are therefore not exact equivalents of those in the first column. Unless otherwise indicated, all Windows 2000 tools referred to are in the Administrative Tools program group, which can be accessed either from the Start menu or from Control Panel.

Comparison of Administrative Tools in Windows 2000 and Windows NT
Windows NT Administrative Tool | Windows 2000 Equivalent(s)
Administrative Wizards | Configure Your Server (Various consoles also have integrated wizards.)
Backup | Backup (in System Tools in Accessories)
Disk Administrator | Computer Management
Event Viewer | Event Viewer
License Manager | Licensing
Network Client Administrator | No equivalent
Performance Monitor | Performance
Remote Access Admin | Routing and Remote Access
Server Manager | Computer Management
System Policy Editor | Active Directory Users and Computers Group Policy
User Manager for Domains | Active Directory Users and Computers Active Directory Domains and Trusts
Windows NT Diagnostics | Computer Management
See also
Windows NT

Windows 2000 command

See
Windows NT command

Windows Backup

A Microsoft Windows 2000 utility for backing up and restoring important data to tape. Windows Backup is accessed through the System Tools group in the Accessories group.

How It Works

With Windows Backup, you can either manually back up volumes or schedule unattended backup jobs to be performed automatically on a regular basis. Windows Backup lets you back up data either to a tape drive or to a file that can be stored on various media including hard disks, removable disks, writable CDs, or optical drives.

Graphic W-8. Windows Backup.
Graphic W-8. Windows Backup.

Backup and Restore are initiated and scheduled through a single dialog box (see screen capture). Wizard-based interfaces are used to simplify the backup and restore processes, and they allow you to back up all files on your system, specified files, or only critical system state data essential to the health of the system. You can use the Backup Wizard to perform a normal, copy, incremental, differential, or daily copy backup, and you can choose to either append the backup to the media specified or overwrite the existing backup file on the media. Backups can be run immediately or can be scheduled to run daily, weekly, monthly, at system startup, at logon, or when the system is idle.

In order to back up and restore any files regardless of the permissions they are assigned, users must be members of the Administrators, Backup Operators, or Server Operators group. Ordinary users can back up only their own files and folders, plus any files for which they have read permission. Similarly, ordinary users can restore only their own files and folders, plus any files for which they have write permission.

You must normally close files in order to back them up by using Windows Backup. Operating system files can be backed up even if they are open, however.

NOTE

The corresponding utility on the Microsoft Windows NT platform is called Windows NT Backup. The Windows NT Backup tool supports backup to tape drive only. It does not support volume recovery because it does not back up data at the sector level. The command-line version of this utility is called ntbackup.exe and includes a number of switches that allow you to run it from a batch file that you schedule using the Windows NT at command.

TIP

Prior to running Windows Backup, use the Send Console Message option in the Computer Management console to send an administrative message to all logged-on users instructing them to save their work and close their applications if they want their files to be backed up properly.

TIP

When Microsoft Exchange Server is installed on Windows NT Server, additional functionality is added to the Windows NT Backup tool to simplify backup of critical Exchange directories and files such as the information store.

Windows CE

A Microsoft Windows–compatible real-time operating system for a broad range of products including personal and handheld computers, terminals, and industrial controllers. Windows CE is primarily for embedded systems in which the operating system is hard-coded by a vendor into a device’s ROM and for handheld PCs that provide portable messaging and Internet capability.

How It Works

Windows CE is based on a subset of the standard Win32 API, which means that original equipment manufacturer (OEM) developers can use all of the standard Win32 development tools to create custom-based Windows CE solutions for their Windows CE–based products. Windows CE is a component-based operating system that you can use to create “mix-and-match” operating systems that provide only the functionality needed for an embedded system, thus minimizing the memory requirements of such a system. For example, a Windows CE–based industrial sensor might contain the Windows CE kernel and communication modules but not the graphical user interface (GUI). The available modules include the following:

  • Operating system kernel (32-bit, multitasking, multithreaded, executes in ROM), graphical device interface (GDI), and USER components

  • Device drivers (keyboard, touch panel, notification LED, display, audio, battery, PCMCIA, serial devices, and FAT/FAT32 volumes)

  • Communication components, including support for both wired and wireless local area network (LAN) connectivity, TCP/IP with Windows Sockets, Point-to-Point Protocol (PPP), Serial Line Internet Protocol (SLIP), Infrared Data Association (IrDA) standards, Telephony Application Programming Interface (TAPI), and so on

  • Windows CE Embedded Shell support, which allows developers to create custom shells for providing a user interface for their CE devices

  • Win32-like registry for storing configuration information

Windows CE is implemented on a specific hardware platform using a thin layer of code between the kernel and the hardware called the OEM adaptation layer (OAL), which isolates device-specific features of hardware from the operating system kernel, enabling developers to ignore specific hardware functionality.

The current version of Windows CE is 2.1; version 3 will soon be released.

Windows Clustering

A feature of Microsoft Windows 2000 Advanced Server that uses clustering technologies to provide high availability and scalability for enterprise-level applications. Clustering was first introduced in the Microsoft Windows platform in Windows NT Server 4, Enterprise Edition.

How It Works

A cluster is a collection of multiple independent servers (or nodes) that run a common set of applications but provide clients with the image of a single server. This redundancy enables clustered systems to provide load balancing and failover support, thus greatly increasing reliability and scalability over a single server system. Windows Clustering on Windows 2000 Advanced Server consists of two types of technologies: server clusters and network load balancing clusters.

Server clusters support the failover of resources for applications running on Windows 2000 so that applications and services can continue to function if a server fails or is down for maintenance. Server clusters are implemented through the Cluster service, which you can install using the Windows Components Wizard. If one node of a cluster becomes unavailable, the resources and applications running on the server smoothly migrate to an available node within the cluster with minimum interruption (a process called “failover”). When the failed node is restored, the resources and applications migrate back to the restored node (a process called “failback”). In this context, cluster resources include elements such as IP addresses and shared disk subsystems. Windows 2000 supports active/active clustering, in which every node in a cluster is available to do real work and to handle the resources of failed nodes when needed.

Network load balancing clusters allow up to 32 servers running Windows 2000 Advanced Server to be combined into a single cluster. Network load balancing provides high availability and scalability for TCP/IP-based services and applications by distributing client connections among the servers in a cluster. Each node monitors the status of the cluster by periodically exchanging multicast or broadcast messages with the cluster. If one node of a cluster fails or is taken offline for maintenance, the cluster automatically reconfigures itself and redistributes client connections accordingly to balance the load. This process is called convergence and results in the election of a new default host, which handles all network traffic that is not handled by port rules (filters that administrators can configure to specify the weighting factor for each node for load balancing purposes).

You use the administrative console called Cluster Administrator to manage clusters on Windows 2000. You can create cluster groups, initiate failover, monitor cluster health, and handle maintenance tasks. You can install Cluster Administrator on any computer running Windows 2000, not just those running Advanced Server. You can also use Cluster Administrator from Windows NT Server 4, Enterprise Edition, to manage a Windows 2000 cluster if Windows NT 4 Service Pack 3 or later is installed.

See also
clustering, Microsoft Cluster Server (MSCS)

Windows DNA

See
Microsoft Windows Distributed interNet Applications (DNA) Architecture

Windows Explorer

The primary tool for accessing file systems in Microsoft Windows NT, Windows 95, Windows 98, and Windows 2000. You can use Windows Explorer (or Windows NT Explorer, as it is called in the Windows NT operating system) to

  • Create, move, copy, open, edit, and delete files or folders

  • Search for files using complex queries

  • Map and disconnect network drives to shared folders on network servers

  • View and manipulate properties of files and other file system objects

  • Share folders and printers for use on the network

  • Configure NTFS permissions, auditing, and ownership (Windows NT and Windows 2000 only)

Windows Explorer displays a hierarchical window-based view of file system and network resources in two panes. The left pane shows a hierarchical view of all available file system resources, including the desktop, local drives, mapped network drives, printers, and Network Neighborhood (in Windows NT, Windows 95, and Windows 98) or My Network Places (in Windows 2000). In Windows 2000, the left pane can also show search tools or a history of recently accessed resources. The right pane shows the files and folders or other objects within the currently selected drive or folder in the left pane.

Graphic W-9. Windows Explorer.
Graphic W-9. Windows Explorer.
See also
My Computer, My Network Places, Network Neighborhood

Windows for Workgroups 3.11

A version of Microsoft Windows 3.1 released in 1994 that includes integrated networking components. Windows for Workgroups was first released as Windows for Workgroups 3.10; Windows for Workgroups 3.11 added high-performance 32-bit networking access. Windows for Workgroups was released as both a stand-alone product and as an add-on for Windows 3.1.

Windows for Workgroups uses the same graphical user interface (GUI) as Windows 3.1. It includes the following enhancements and features:

  • Low 4-KB footprint in conventional memory for use with 32-bit network drivers, enabling large MS-DOS applications to be multitasked in a Windows environment

  • Improved performance with 32-bit networking software that provides support for the network driver interface specification (NDIS) 3 standard, plus backward compatibility with the NDIS 2 standard of the 16-bit Windows 3.1 operating system

  • Compatibility with Microsoft Windows NT Advanced Server, Novell NetWare, and Banyan Vines

  • Autodetection of many network interface cards (NICs)

  • Support for IPX/SPX in addition to the earlier NetBEUI network protocols

  • Password-protected logon

  • Integrated mail and fax software

  • Workgroup version of Microsoft Mail for e-mail connectivity, and the Schedule+ utility for keeping track of appointments and tasks

  • Additional network utilities such as Chat, Net Watcher, WinPopup, and WinMeter

    Graphic W-10. Windows for Workgroups 3.11.
    Graphic W-10. Windows for Workgroups 3.11.
How It Works

The architecture of Windows for Workgroups is essentially the same as that of Windows 3.1 except for the networking subsystem, which supports the newer NDIS 3 standard. Windows for Workgroups also includes enhancements to 32-bit disk access, which is implemented as two Windows virtual device drivers (VxDs): VFAT, a 32-bit, protected-mode replacement for the MS-DOS file allocation table (FAT) file system, and VCACHE, which replaces the MS-DOS SmartDrive disk-caching utility and improves disk input/output (I/O). The network redirector (VREDIR) is implemented as a file system driver as well. The Installable File System (IFS) manager maintains a table that identifies which type of file system device is associated with each disk volume and forwards all I/O calls to the appropriate device.

NOTE

You can add support for advanced TCP/IP features such as Dynamic Host Configuration Protocol (DHCP), Telnet, and File Transfer Protocol (FTP) by using the Microsoft TCP/IP-32 for Windows for Workgroups add-on. You can create the installation disks for this add-on by using Network Client Administrator in Windows NT.

See also
Windows 3.1

Windows Internet Name Service (WINS)

A Microsoft Windows NT or Windows 2000 service that dynamically registers NetBIOS names of computers on the network. It also provides a central location for resolving these NetBIOS names into IP addresses. Windows Internet Name Service (WINS) is a popular name resolution service on Windows NT networks because it is dynamic, rather than static, making it easier to manage than the Domain Name System (DNS). On the Windows 2000 platform, however, DNS is the main name resolution method now used, while WINS is optionally available as a location service for supporting downlevel (Windows NT, Windows 98, Windows 95, and Windows for Workgroups) servers and clients on the network.

How It Works

In order for NetBIOS hosts (servers and clients running pre–Windows 2000 versions of Microsoft Windows) to communicate on a network, their NetBIOS names must first be resolved into IP addresses. WINS servers, which are servers running Windows NT or Windows 2000 with WINS installed, perform this task. Using WINS servers instead of broadcasts to perform NetBIOS name resolution has several advantages:

  • Directed traffic to WINS servers generates less network traffic than broadcasts.

  • WINS provides a mechanism for browsing network resources across multiple domains and subnets.

  • The WINS database of NetBIOS name to IP address mappings is dynamically maintained, eliminating the need for lmhosts files on clients.

WINS works by requiring each NetBIOS host to register its NetBIOS name to IP address mapping on the WINS server by using a process called name registration. These mappings are temporarily stored in a database called the WINS database and need to be renewed periodically by way of a process called registration renewal. If the IP address of the NetBIOS host changes, the WINS database is automatically updated accordingly. And when a NetBIOS host is shut down, a name release occurs, removing the host’s associated mapping from the WINS database.

If a client computer (typically a computer running Windows NT Workstation, Windows 98, Windows 95, or Windows for Workgroups) wants to connect to a file server running Windows 2000 or Windows NT, it queries a designated WINS server using a name query, providing it with the NetBIOS name of the file server it wants to connect to. The WINS server checks its database and responds to the client with the IP address of the desired file server, enabling the client to locate and connect to the file server.

On the Windows NT Server platform, you manage WINS by using the administrative tool called WINS Manager. This tool can be used for the following tasks:

  • Maintaining the WINS database of NetBIOS name to IP address mappings

  • Configuring WINS replication between primary and secondary WINS servers

  • Creating static mappings for non-WINS computers

On the Windows 2000 Server platform, you manage WINS using the WINS snap-in for the Microsoft Management Console (MMC).

TIP

A single WINS server can support up to about 5000 clients. However, it is a good idea to always use at least two WINS servers in order to provide fault tolerance for NetBIOS name resolution. WINS servers maintain their own separate WINS databases, but they can be configured to replicate their NetBIOS name to IP address mappings by way of a process called WINS database replication.

See also
NetBIOS name resolution

Windows Management Instrumentation (WMI)

Microsoft’s implementation of the Web-Based Enterprise Management (WBEM) architecture for enterprise-level network management. Administrators can use Windows Management Instrumentation (WMI) to track, monitor, and control computers, networking devices, and applications belonging to an enterprise network over the Internet by using a standard Web browser such as Microsoft Internet Explorer. WMI is WBEM-compliant and uses the Common Information Model (CIM) for describing manageable network objects. Support for WMI is built into Microsoft Windows 2000 and Windows 98 and is available as an add-on for Windows NT 4.

How It Works

WMI in Windows 2000 includes two main components:

  • An object repository that is compliant with the CIM standard and is used for storing information collected from WMI-manageable hardware and software

  • The CIM Object Manager, which collects information from WMI providers and stores it in the repository

WMI providers function as intermediaries between the network object being managed and WMI. For example, the registry provider allows information to be collected from the registry of remote computers and stored in the repository. Similarly, if Simple Network Management Protocol (SNMP) information needs to be collected from SNMP-manageable devices, the SNMP provider must translate this information into a format suitable for WMI.

Some components of Windows 2000 are WMI-enabled. These are accessible from the Computer Management snap-in, and they include

  • Logical drives, which you can use to manage local and mapped drives on local or remote computers in order to view drive properties, configure drive security settings, and handle other management tasks

  • System properties, which you can use to view and modify system properties on local or remote computers, modify virtual memory settings, view and modify computer and domain names, reboot systems, and perform other administrative tasks

  • System information, which you can collect and display for referencing as you troubleshoot system problems

  • The Dependencies component of Windows 2000 Services, which you can use to troubleshoot problems arising from service dependencies

You can use a console called the WMI Control to perform general WMI tasks such as enabling error logging, setting permissions for users or groups, and backing up the CIM object repository.

See also
Web-Based Enterprise Management (WBEM)

Windows Messaging Profile

A set of information required by Microsoft Windows messaging applications such as Microsoft Outlook. The Windows Messaging Profile identifies

  • What information services are used (such as Microsoft Exchange Server or the Internet)

  • How e-mail is delivered

  • Where incoming e-mail will be stored

When you install Outlook, a profile is automatically created consisting of the Outlook Address Book and Personal Folders store. You must specify additional information such as the information service to be used before you can use the profile.

NOTE

To facilitate deployment of Outlook in your Exchange organization, you can automatically generate profiles for your Exchange users by using the exchange.prf file from the Microsoft Office 97 Resource Kit and a custom outlook.prf file for each user.

Windows NT

Microsoft’s popular operating system for all types of networks ranging from workgroups to enterprise-level installations. Microsoft Windows NT, which provides a secure, scalable, reliable 32-bit operating system platform, is a component of Microsoft BackOffice and provides the foundation upon which all other BackOffice applications run.

Windows NT was first released in 1993 in two versions—a server version called Windows NT Advanced Server (formerly called LAN Manager for Windows NT) and an associated client version called Windows NT 3.1. In 1994, the product was enhanced and released as Windows NT Server 3.5 and Windows NT Workstation 3.5, which were both soon upgraded to Windows NT 3.51. Windows NT 3.51 includes such networking and security features as

  • NTFS file system for advanced local and remote file system security

  • Windows NT domains, which are implemented using domain controllers for secure logons in a networking environment

  • Trust relationships for building enterprise-level multidomain networks

  • Centralized storage of user profiles to support roaming users on the network

  • Remote Access Service (RAS) for supporting remote users

  • Support for both the server and client sides of Dynamic Host Configuration Protocol (DHCP) and Windows Internet Naming Service (WINS)

  • Support for the software implementation of RAID levels 0, 1, and 5

  • Integrated support for the TCP/IP protocol suite and associated utilities

  • Support for POSIX and OS/2 text-based applications

  • Services for Apple Macintosh

  • Support for Novell NetWare migration

In 1996, Windows NT was upgraded to version 4, with new features and enhancements that included the following:

  • An easy-to-use Microsoft Windows 95–style desktop interface

  • Administrative wizards

  • Integrated Internet services and tools, including Internet Information Server (IIS)

  • Administrative tools such as System Policy Editor, Network Monitor, and Task Manager

  • Support for both the server and client sides of the Domain Name System (DNS) protocol

  • Support for the Distributed Component Object Model (DCOM)

  • Improvements to the core operating system services and components

Graphic W-11. Windows NT 4 user interface.
Graphic W-11. Windows NT 4 user interface.

Windows NT now comes in four forms:

  • Windows NT Server 4:
    A fast 32-bit multitasking server operating system for networking environments. It can run as a file and print server, an application server, or an authentication and access control server (domain controller), and it can support as many concurrent connections as licenses purchased and up to 256 concurrent RAS sessions.

  • Windows NT Workstation 4:
    A fast 32-bit multitasking desktop operating system that supports up to 10 incoming concurrent sessions and one RAS session.

  • Windows NT Server 4, Enterprise Edition:
    Includes Microsoft Cluster Server (MSCS) for two-node clustering, Windows NT Load Balancing Service (WLBS) for load balancing up to 32 servers, eight-way symmetric multiprocessing (and support for up to 32 processors from selected vendors), 4-GB Memory Tuning (4GT), and additional tools and enhancements.

  • Windows NT Server 4, Terminal Server Edition:
    Uses terminal emulation to present the familiar 32-bit Windows user interface on Windows-based terminal-embedded devices and on all versions of Windows desktop operating systems, including those running on legacy hardware using the Remote Display Protocol (derived from the T.120 protocol of the International Telecommunication Union).

    Graphic W-12. Windows NT 4 architecture.
    Graphic W-12. Windows NT 4 architecture.
How It Works

Windows NT components run in one of two modes:

  • User mode:
    Contains applications and the various Windows NT subsystems that support them, including the following:

    • Win32 subsystem:
      Supports Win32 applications. (All other subsystems are dependent on this subsystem.)

    • Security subsystem:
      Responsible for authentication, access control, and implementing security and audit policies.

    • OS/2 subsystem:
      Responsible for running text-based OS/2 1.1 applications.

    • POSIX subsystem:
      Responsible for running POSIX-compliant UNIX applications.

    Windows NT processes that run in user mode are limited to an assigned portion of the system’s overall address space but can use virtual memory as needed. User mode processes run at a lower priority than kernel mode processes and have no direct access to system hardware functions. User mode processes must issue all hardware access requests to the Windows NT executive for fulfillment.

  • Kernel mode:
    Processes run at a higher priority than those in user mode and consist of the following:

    • Windows NT executive services:
      Implemented in various modules specific to operating system functions. All managers and device drivers are implemented at this level.

    • Microkernel:
      Handles core operating system functions such as thread scheduling and interrupt handling.

    • Hardware abstraction layer (HAL):
      Makes Windows NT more portable between platforms by isolating hardware-specific differences.

Windows NT Backup

See
Windows Backup

Windows NT Challenge/Response Authentication

An authentication scheme used in Microsoft Windows NT–based networks that enables users to be authenticated without the transmission of actual account information or passwords across the network. Windows NT Challenge/Response Authentication is one of three authentication schemes supported by Internet Information Services (IIS). It is also sometimes known as NTLM, which stands for Windows NT LAN Manager authentication. On the Microsoft Windows 2000 platform, this authentication scheme is now known as Integrated Windows Authentication.

How It Works

When a Web browser such as Microsoft Internet Explorer attempts to connect to an IIS server configured for Windows NT Challenge/Response Authentication, the IIS server challenges the browser to perform a complex mathematical calculation on the password of the logged-on user who is using the browser and to return the result of this calculation to the server. The server also performs the calculation on the user’s password obtained from a domain controller’s Security Account Manager (SAM) database. If the two calculations agree, the client is considered authenticated. If they differ, the user is prompted for a valid Windows NT username and password. If the user provides invalid credentials, the server sends a Hypertext Transfer Protocol (HTTP) status code to the client browser indicating that access is denied unless some other authentication scheme is enabled.

NOTE

Internet Explorer 2 and later are the only Web browsers that currently support Windows NT Challenge/Response Authentication.

TIP

You can configure IIS 4 so that basic authentication and Windows NT Challenge/Response Authentication are both available. When a browser that supports both methods makes a request to IIS 4 for authentication, Windows NT Challenge/Response Authentication takes precedence.

See also
anonymous access, Basic Authentication

Windows NT command

A command that can be typed at the Microsoft Windows NT command prompt, usually to perform an administrative action. You manage most Windows NT services by using GUI-based administrative tools, but some administrative tasks can also be performed at the command prompt. You can also save Windows NT commands in a text file and run them as a batch file.

Windows NT commands are grouped into several categories:

  • MS-DOS configuration commands:
    For configuring an MS-DOS environment to run MS-DOS applications. These commands include buffers, country, device, devichigh, dos, dosonly, driveparm, echoconfig, fcbs, files, install, lastdrive, ntcmdprompt, shell, stacks, and switches.

  • MS-DOS subsystem commands:
    For backward compatibility with MS-DOS applications. These commands include append, backup, debug, edit, edlin, exe2bin, expand, fastopen, graphics, loadfix, loadhigh, mem, nlsfunc, qbasic, setver, and share.

  • Windows commands:
    Include commands for administering and configuring aspects of the Windows NT operating system. Some of the more commonly used Windows commands are listed in this entry’s first table.

  • TCP/IP commands:
    Utilities associated with the TCP/IP protocol stack. These commands are listed in this entry’s second table.

  • OS/2 configuration commands:
    For configuring the operating system environment for applications that run using the OS/2 subsystem of Windows NT. These commands include codepage, devinfo, libpath, and protshell.

  • Net commands:
    For starting, stopping, and configuring networking services.

  • Batch commands:
    Used only within batch files for automating system tasks. These commands include call, echo, endlocal, for, goto, if, pause, rem, setlocal, and shift.

  • Filter commands:
    For sorting, viewing, and selecting portions of a command’s output. These commands include find, more, and sort.

  • Redirection symbols:
    For redirecting the input or output of a command to something other than standard input or output. These symbols include >, <, >>, and |.

  • Conditional processing symbols:
    Allow you to issue multiple commands from the same command prompt and to act based on the results of the commands’ execution. These symbols include &, &&, ||, ( ), and ^.

Windows Commands
Command | Description
assoc | Displays or modifies file extension associations
at | Schedules commands and programs to run on a system at a specified time and date
attrib | Displays or changes file attributes
cacls | Displays or modifies the access control lists (ACLs) of files
chdir (cd) | Displays the name of the current directory or changes the current directory
chkdsk | Displays a disk status report and corrects errors on the disk
cls | Clears the screen
cmd | Starts a new instance of the Windows NT command interpreter
compact | Displays and alters the compression of files or directories
convert | Converts file allocation table (FAT) volumes to NTFS
copy | Copies one or more files to another location
date | Displays the date or allows you to change the date
del (erase) | Deletes specified files
dir | Displays a list of a directory’s files and subdirectories
diskcopy | Copies a floppy disk
diskperf | Starts and stops system disk performance counters
doskey | Calls the doskey program, which recalls Windows NT commands, edits command lines, and creates macros
exit | Quits the command interpreter and returns to the program that started it
format | Formats a disk to accept Windows NT files
help | Provides online information about Windows NT commands
mkdir (md) | Creates a directory or subdirectory
move | Moves one or more files to a specified directory
ntbooks | Accesses online Windows NT manuals
prompt | Changes the Windows NT command prompt
rename (ren) | Changes the name of a file or files
rmdir (rd) | Deletes (removes) a directory
start | Opens a separate window to run a program or a command
time | Displays the system time or sets the computer’s internal clock
tree | Displays the directory structure of a path or disk
type | Displays the contents of a text file
ver | Displays the Windows NT version number
vol | Displays the disk volume label and serial number
winnt | Performs an installation or upgrade of Windows NT 4
winnt32 | Performs an installation or upgrade of Windows NT 4
xcopy | Copies files and directories, including subdirectories
TCP/IP Commands
Command | Description
arp | Displays or modifies the IP-to-MAC-address translation tables
finger | Displays user information on a system running the finger service
ftp | Transfers files to or from a File Transfer Protocol (FTP) server
hostname | Prints the name of the current computer (host)
ipconfig | Displays current TCP/IP network configuration values
lpq | Obtains status of a print queue of a Line Printer Daemon (LPD) server
lpr | Prints a file to an LPD server
nbtstat | Displays protocol statistics and current NetBEUI TCP/IP (NBT) connections
netstat | Displays TCP/IP protocol statistics and connections
nslookup | Displays information from Domain Name System (DNS) name servers
ping | Verifies connections to a remote computer
rcp | Copies files to or from a system running rshd
rexec | Runs commands on remote computers running rexec
route | Displays or modifies network routing tables
rsh | Runs commands on remote computers running rsh
tftp | Transfers files to or from a system running tftp
tracert | Displays the route taken to a remote host on an internetwork
NOTE

Microsoft Windows 2000 commands are essentially the same as those for Windows NT, with additional commands for services specific to Windows 2000.

TIP

To see a list of all Windows NT commands and view their syntax, choose Help from the Start menu, select the Index tab, type commands , select Windows NT, and click Display.

See also
net commands

Windows NT Diagnostics

A Microsoft Windows NT administrative tool useful for troubleshooting different aspects of system and network behavior. Windows NT Diagnostics can be used to display and print important configuration information for your computer running Windows NT Server. Windows NT Diagnostics can display

  • The operating system version and service packs applied

  • Processor and BIOS information

  • Display, drivers, and memory information

  • Installed services and their current states

  • Hardware settings such as interrupt request (IRQ), I/O port, and direct memory access (DMA) settings

  • System and user environment variables

  • Network interface card (NIC) settings, transports, and statistics

TIP

On the Microsoft Windows 2000 platform, the equivalent of Windows NT Diagnostics is the System Information node in Computer Management.

Windows NT Directory Services (NTDS)

The directory services used by Microsoft Windows NT to locate, manage, and organize network resources. Windows NT Directory Services (NTDS) uses domains, trusts, and directory synchronization to provide users of enterprise-level Windows NT networks with the following advanced capabilities:

  • Single-logon capability:
    Users can log on anywhere in the enterprise using only one account.

  • Centralized administration:
    Administrators can manage the entire network from a single location.

  • Universal resource access:
    Users can access resources anywhere in the enterprise if they have the appropriate permissions.

To build effective enterprise-level directory services using Windows NT domains, you should consider the following factors:

  • The number of domains needed (the domain model used)

  • The number of domain controllers needed to support the number of users

  • The placement of backup domain controllers (BDCs) to assure efficient directory synchronization of directory services

  • The placement of BDCs to assure effective logon and resource authentication over slow WAN links

Windows NT Distributed File System

See
Distributed file system (Dfs)

Windows NT executive

A set of modules within the Microsoft Windows NT operating system that run in kernel mode and provide process structure, memory and object management, thread scheduling, interrupt processing, security, and other key operating system functions. The modules included in Windows NT executive are as follows:

  • I/O Manager

  • Object Manager

  • Security Reference Monitor

  • Process Manager

  • Local Procedure Call Facility (LPC Facility)

  • Remote Procedure Call Facility (RPC Facility)

  • Virtual Memory Manager

  • Win32K Windows Manager and GDI

  • Hardware device drivers

See also
kernel mode

Windows NT Explorer

See
Windows Explorer

Windows NT LAN Manager Security Protocol

See
Windows NT Challenge/Response Authentication

Windows NT Option Pack

An add-on software package for Microsoft Windows NT that includes Internet Information Server (IIS) version 4 and a number of supporting Microsoft BackOffice applications and tools, including the following:

  • Internet Connection Services for Microsoft Remote Access Service (RAS)

  • Microsoft Certificate Server

  • Microsoft Data Access Components (MDAC) 1.5

  • Microsoft FrontPage Server Extensions

  • Microsoft Index Server 2.0

  • Microsoft Management Console (MMC)

  • Microsoft Message Queue (MSMQ) Server 1.0

  • Microsoft Script Debugger 1.0

  • Microsoft Site Server Express 2.0

  • Microsoft Transaction Server (MTS) 2.0

Windows NT Server

See
Windows NT

Windows NT Server, Enterprise Edition

An enhanced version of the Microsoft Windows NT Server operating system. Windows NT Server, Enterprise Edition, includes the following features:

  • Windows NT Server 4:
    An enterprise-level network operating system that provides highly scalable file and print services, standards-based communication features, robust application support, and comprehensive Internet as well as intranet functionality.

  • 4-GB RAM Tuning (4GT):
    An extension of the normal limit of addressable RAM available to applications in Windows NT Server. The 4 GB of RAM available in Windows NT Server are divided between applications and the kernel, each being allocated 2 GB. With 4GT, the potential RAM that can be allocated to the kernel is reduced to 1 GB, which leaves 3 GB for applications.

  • Eight-processor symmetric multiprocessing (SMP):
    Can be extended to up to 32 processors using original equipment manufacturer (OEM) versions of the product.

  • Microsoft Cluster Server (MSCS):
    Supports two-node cluster configurations that can automatically recover from application or server failures, allowing continuous availability of data and applications.

  • Microsoft Transaction Server (MTS):
    Provides an environment for developing and deploying scalable, enterprise-level Internet and intranet applications.

  • Microsoft Message Queue (MSMQ) Server:
    A service that enables applications to communicate asynchronously over heterogeneous networks.

TIP

After you install Windows NT Server, Enterprise Edition, you can enable 4GT by adding the switch /3GB to the boot.ini file:

multi(0)disk(0)rdisk(0)partition(2)\WINNT="Windows NT Server Version 4.00" /3GB

Windows NT Server, Terminal Server Edition

An extension of the Microsoft Windows NT Server operating system for delivering Microsoft Windows to diverse desktop systems through terminal emulation. Windows NT Server, Terminal Server Edition, supports a broad range of clients, including the following:

  • Dedicated Windows-based terminals

  • Existing computers running 32-bit Windows

  • Older computers running 16-bit Windows

  • MS-DOS

  • Apple Macintosh, UNIX workstations, and other non-Windows platforms (using third-party add-ons)

Terminal Server can reduce costs because it supports a new class of low-cost hardware called Windows-based terminals. These hardware platforms are marketed by hardware vendors and contain an embedded terminal emulation client. Terminal Server also works with existing Windows desktop operating systems running on PCs; it runs the terminal emulation client as a window on the local desktop. Terminal Server is compatible with Windows applications from Microsoft such as Office, Internet Explorer, Exchange, Outlook, and Project, as well as Microsoft Visual Basic–based applications and many other popular 32-bit Windows applications.

You can use Terminal Server to deploy a thin-client solution that eliminates the need to download applications from the server. The Terminal Server client has only minimal software for booting the client, connecting to the server, and displaying the Windows interface to the user. All operating system functions and applications run entirely from the server. Terminal Server provides a host-based computing environment in which administrators can manage all server resources on a per-user basis. It supports a multiuser environment in which a terminal emulator displays a Windows desktop and Windows-based applications that actually run completely off the server.

Terminal Server has four main components:

  • Terminal Server server software

  • Terminal Server Client software

  • Remote Desktop Protocol (RDP), which is based on the T.120 protocol developed by the International Telecommunication Union (ITU)

  • Administration Tools, including Terminal Server License Manager, Terminal Server Client Creator, Terminal Server Client Connection Configuration, and Terminal Server Administration tools

See also
Windows NT

Windows NT Workstation

See
Windows NT

Windows Script Host (WSH)

A language-independent scripting host included with Microsoft Windows 2000, Windows NT Option Pack, and Windows 98 that allows administrators to execute scripts for administrative tasks either from the command console (using cscript.exe) or by double-clicking on a desktop shortcut (using wscript.exe). Administrative scripts can be written in Microsoft Visual Basic, Scripting Edition (VBScript), or in Microsoft JScript and can be written to perform common or repetitive administrative tasks such as performing a backup, creating new users, and configuring clients. Windows Script Host (WSH) allows these scripts to be run without being embedded in a Hypertext Markup Language (HTML) document. You can also add support for other scripting languages, such as Perl or REXX.

TIP

You can configure how scripts are run by using .wsh files, which are created automatically when you access the properties of a VBScript or JScript file on a system with WSH installed. These .wsh files act like INI files, enabling you to configure settings such as how long a script should be allowed to run before being terminated. You can create a series of different .wsh files for a given script and use these in different situations. Double-click on a .wsh file to run the associated script.

Windows Sockets

Also called Winsock, an interprocess communication (IPC) mechanism that provides reliable, connection-oriented two-way communication or unreliable connectionless communication between processes on two computers. Windows Sockets is a Microsoft Windows implementation of the well-known Berkeley Sockets application programming interface (API) for accessing datagram and session services over TCP/IP. It provides guaranteed delivery of data between computers for distributed applications.

Windows Sockets can be used by TCP/IP, NWLink, and AppleTalk network protocols. Windows Sockets applications on Windows operating systems include File Transfer Protocol (FTP), Telnet, and Microsoft Internet Explorer. Windows Sockets is implemented as a dynamic-link library (DLL) for Windows operating systems. The current implementation of Windows Sockets on Windows platforms is version 2, which supports multicasting, provides better performance than previous versions, and supports wireless communication.

Windows Update

An Internet-based tool for locating and installing updates and enhancements to the Microsoft Windows 2000 and Windows 98 operating systems. Windows Update can be thought of as an online extension of Microsoft Windows, and is designed to help you get the most out of your computer.

How It Works

You need to establish an Internet connection in order to use Windows Update. You open Windows Update by selecting its shortcut from the Start menu. This action starts Microsoft Internet Explorer and takes you to a page on the Web site http://windowsupdate.microsoft.com. Note that you must be an administrator or a member of the Administrators group to access the Product Updates section of the Windows Update Web site. Once you have connected to the site, ActiveX controls scan your system for outdated system files and determine which new versions of these files should be installed. These system files can include drivers, patches, help files, or new Windows components you can download to keep your computer up-to-date.

TIP

You also have the option of restoring previous versions of system files that have been changed by Windows Update. To do this, start Windows Update, go to Product Updates, select Device Drivers, and click Restore.

winnt.exe

The Setup program for installing Microsoft Windows NT or Windows 2000 on computers with a non–Windows NT operating system such as MS-DOS, Microsoft Windows 95, or Microsoft Windows 98. Winnt.exe is in the \I386 directory on the Windows NT 4 Server CD or Windows 2000 Server CD. The following table describes three common switches for this program.

Common Switches for Winnt.exe
Switch | Description
/b | Installs Windows NT or Windows 2000 without using the three Windows NT boot floppies. Use this switch to install Windows NT on systems with a non–Windows NT operating system (such as Windows 95 or Windows 98).
/ox | Creates the three Windows NT boot floppies. Does not install Windows NT or Windows 2000.
/u | Performs unattended installation.
NOTE

The Setup program for installing Windows NT 4 or Windows 2000 on systems with a version of Windows NT already installed is winnt32.exe. You can use winnt32.exe to upgrade earlier versions of Windows NT to Windows NT 4 or Windows 2000, or to install a second copy of Windows NT 4 or Windows 2000 to a different system folder if you are attempting to recover from a system crash.

WINS

See
Windows Internet Name Service (WINS)

WINS client

A client operating system that can register its NetBIOS name with a WINS server. It’s also known as a WINS-enabled client. All Microsoft operating systems that are network-capable can be WINS clients. You can configure Microsoft Windows NT, Windows 2000, Windows 98, and Windows 95 clients by doing one of the following:

  • Manually configuring the IP address of the WINS servers by using the WINS Address tab of the TCP/IP property sheet (or Advanced TCP/IP Settings in Windows 2000).

  • Using the Dynamic Host Configuration Protocol (DHCP) with DHCP scope option 44 to configure DHCP clients as WINS clients. In Windows NT you do this by using the administrative tool called DHCP Manager, while in Windows 2000 you use the DHCP console.

NOTE

For non-WINS clients such as Macintosh computers, you can use the WINS proxy agent (provided with Windows NT and Windows 2000) to enable these clients to perform NetBIOS name resolution. You can also configure static mappings on the WINS server to enable these non-WINS clients to be resolved using NetBIOS name resolution.

See also
Windows Internet Name Service (WINS)

Winsock

See
Windows Sockets

WINS proxy agent

A computer on a network that enables non-WINS clients to perform NetBIOS name resolution using Windows Internet Name Service (WINS). In other words, a WINS proxy agent is a proxy for, and acts on behalf of, non-WINS clients. WINS proxy agents are typically only needed on networks that have client computers running legacy operating systems.

How It Works

WINS proxy agents are computers that have been configured to listen for NetBIOS name registration and NetBIOS name discovery broadcasts from non-WINS clients and then forward these broadcasts directly to a WINS server. These non-WINS clients are computers that cannot communicate directly using WINS and typically use broadcasts only (B-node) to perform NetBIOS name registration and resolution.

For example, if a non-WINS or B-node client wants to register its name on the network, it broadcasts a NetBIOS name registration request. The proxy agent detects this broadcast request and forwards it directly to the WINS server, which checks its WINS database to see whether the NetBIOS name is already being used on the network. If the name is in use, the WINS server responds to the proxy agent with a negative registration response, and the proxy server forwards this response back to the B-node client indicating that the name is already in use on the network.

You can configure computers running Microsoft Windows NT Server and Windows 2000 Server to operate as Windows proxy agents by making changes to their registries. Specifically, to enable a computer running Windows NT or Windows 2000 to act as a WINS proxy agent, use regedit to set the value EnableProxy equal to 1 for the following key:

HKEY_LOCAL_MACHINE
    \System
        \CurrentControlSet
            \Services
                \NetBT
                    \Parameters
NOTE

WINS proxy agents must be WINS clients but cannot be WINS servers.

TIP

WINS proxy agents are needed only on those subnets that have both of the following characteristics:

  • No WINS server

  • Include non-WINS clients that need to be able to resolve the names of NetBIOS computers on other subnets

WINS record

A resource record within a zone file that identifies a host on the network as a WINS server on the network. WINS records are used in Microsoft Windows NT–based networks to enable Domain Name System (DNS) servers to refer name lookups to WINS servers. On Windows NT–based networks, WINS uses a dynamically updated database, while the DNS database is static and needs to be manually configured. DNS is thus harder to manage than WINS on Windows NT. So by configuring DNS to use WINS wherever possible, you simplify administration of name resolution on the network.

WINS records are specific to Microsoft’s implementation of DNS on Windows NT and are not used with the new dynamic update of Windows 2000 or in non–Microsoft Windows networks such as those using BIND running on UNIX servers.

See also
Domain Name System (DNS), resource record

WINS server

A Microsoft Windows NT–based or Windows 2000–based server running the Windows Internet Name Service (WINS) that can accept NetBIOS name registrations and queries. WINS servers maintain a database of NetBIOS name to IP address mappings for WINS clients on the network and speed up NetBIOS name resolution by eliminating broadcasts.

How It Works

NetBIOS over TCP/IP clients configured as H-node clients register their names with a WINS server when they are initialized on the network. The WINS server maintains a database called the WINS database, which stores the NetBIOS name to IP address mappings for all hosts on the accessible network. Periodically, one of the hosts must renew its name registration for all its NetBIOS-enabled services. When a host is properly shut down or when a NetBIOS-related service is stopped on the host, the associated NetBIOS names are released from the WINS database. When a host tries to contact another host using NetBIOS over TCP/IP, a NetBIOS name query request is sent to the WINS server, which returns the IP address of the host and thus allows communication to take place.

WINS servers replicate the WINS database with other WINS servers to keep the database entries up-to-date. You can configure WINS servers for two replication roles:

  • Push partners send notices to their pull partners, notifying them of a certain threshold number of changes to their WINS database. You can configure this number on the push partners by using the Windows NT administrative tool WINS Manager or the WINS console in Windows 2000. The pull partners respond by requesting the changes, which the push partners then send.

  • Pull partners periodically send requests to their push partners, asking if any changes have been made to their WINS database. You can configure the time interval for sending these requests on the pull partner. The push partners respond by sending the changes.

NOTE

WINS servers should have static IP addresses assigned. You can create static mappings to allow non-WINS clients on the network to be resolved, and you can use WINS proxy agents to allow non-WINS clients to perform name resolution.

When you configure WINS replication, you should consider the following:

  • You can configure WINS servers to be both push and pull partners with other WINS servers.

  • WINS servers replicate only changes, not the full WINS database.

  • On Windows NT WINS servers, you can manually force WINS replication by clicking the Replicate Now button in WINS Manager. On Windows 2000 WINS servers, you use the Action menu in the WINS console.

TIP

For fault tolerance on large networks, you should consider using a second WINS server, with WINS replication configured between the primary WINS server and secondary WINS server. One primary and one secondary WINS server are recommended for every 10,000 WINS clients on the network.

Over local area network (LAN) or high-speed wide area network (WAN) links, you should configure all WINS servers as both push and pull partners to keep the WINS database up-to-date on all WINS servers. Over slow WAN links, however, you should configure WINS servers as pull partners only so that you can schedule replication when WAN traffic is light.

See also
NetBIOS name resolution, Windows Internet Name Service (WINS)

Wireless Application Protocol (WAP)

A set of technologies developed by a consortium of mobile telephony equipment vendors that is designed to bring Web content to wireless handheld communication devices such as Personal Digital Assistants (PDAs) and mobile phones. These devices are too small to easily display or allow users to interact with regular Web content. Wireless Application Protocol (WAP) enables them to receive simplified versions of regular Web pages. Typical uses for WAP-enabled devices might be to access stock market information, perform online banking, access inventory and sales information for sales quotes, and exchange information with business partners.

Graphic W-13. Wireless Application Protocol (WAP).
Graphic W-13. Wireless Application Protocol (WAP).

WAP is part of the Mobile Station Application Execution Environment (MExE) initiative from the European Telecommunications Standards Institute (ETSI) and is currently being tested by companies such as Alcatel, Nokia, and APiON.

How It Works

The WAP protocol stack lies within layers 4, 5, 6, and 7 of the Open Systems Interconnection (OSI) reference model for networking. For addressing and routing purposes, WAP uses the same layer 3 (network layer) protocol as TCP/IP, namely the Internet Protocol (IP). This allows WAP-enabled devices to request and receive Web content from the Internet by using the Hypertext Transfer Protocol (HTTP). However, instead of using the connection-oriented Transmission Control Protocol (TCP), WAP uses the connectionless User Datagram Protocol (UDP) for layer 4 (transport layer) session establishment because UDP has less overhead than TCP and is thus more suitable for the limited transmission capabilities of wireless handheld devices.

WAP uses the Wireless Transaction Protocol (WTP) instead of HTTP for its connectionless layer 7 (application layer) protocol. In addition, WAP-enabled devices can display only content that is formatted using Wireless Markup Language (WML), a simplified version of Hypertext Markup Language (HTML) for handheld wireless devices that includes limited display capabilities.

To request Web content from the Internet, a WAP-enabled device makes a WTP request to a WAP gateway, a device that stands between the WAP devices and Web sites. The WAP gateway services the WTP request in one of two ways:

  • The WAP gateway can itself host Web sites formatted in WML and return this content directly to the WAP device. The disadvantage of this method is that content providers must develop redundant versions of HTML-formatted Web sites in WML.

  • The WAP gateway can translate the WTP request that it received using UDP into an HTTP request contained in TCP packets and forward this HTTP request to a regular Web server on the Internet that hosts HTML-formatted Web content. The Web server returns the content to the WAP gateway using TCP, which translates the HTML into WML and sends it to the WAP device using UDP. This is the normal operation of a WAP gateway. Web content developers need only create one version of their site in HTML, although they must ensure that the page looks satisfactory when translated into WML.

WAP gateways can also be configured for other uses, such as collecting personal information from customers and recording traffic for billing purposes.

NOTE

WAP is designed primarily to enable Web content to be delivered over wireless communication systems, which are characterized by low speed and variable delays. Caching can be implemented on wireless handheld devices to minimize the amount of information that needs to be downloaded, but memory limitations currently prevent this from being very effective. You can use TCP header compression to reduce headers to only 3 or 4 bytes to speed up standard TCP/IP connections with these devices in order to boost performance a bit. You can adjust the TCP retransmission parameters to compensate for the typical round-trip time of 100 milliseconds to several seconds when users move through cells in wireless communication networks. But the TCP window size negotiation algorithm to optimize TCP transmission generally works poorly in situations where the typical delay varies so frequently and greatly. You can use middleware between the WAP device and the application server to simplify and streamline the data being transferred. Nevertheless, WAP has growing support in the cellular industry, especially because it shifts vendors toward the role of content hosting and development, which is a lucrative add-on in light of falling cellular line charges.

On the Web
•
WAP Forum
: http://www.wapforum.org

wireless networking

Networking that uses electromagnetic waves traveling through free space to connect stations on a network. Wireless transmission is said to use unguided media, as opposed to the guided media of copper cabling and fiber-optic cabling used in traditional wired networks. Wireless networking is typically used for

  • Communication with mobile stations, which precludes the use of fixed cabling, or for mobile users who roam over large distances, such as sales reps with laptops that have cellular modems.

  • Work areas in which it is impractical or expensive to run cabling, such as older buildings that are costly to renovate. In this case, two solutions are possible:

    • Create a wireless LAN (WLAN) that uses no cabling between stations.

    • Create a combination of traditional wired local area networks (LANs) and as many wireless stations as needed.

  • Networking buildings on a campus using a wireless bridge or router. You can typically use wireless bridges or routers over distances up to 25 miles. They might support point-to-point or multipoint connections and often support Internet Protocol (IP) or Internetwork Packet Exchange (IPX) routing using static routing or the Routing Information Protocol (RIP).

Wireless networking suffers somewhat from lower data transmission rates (the maximum is currently about 10 Mbps), greater susceptibility to electromagnetic interference (EMI), and greater risk of eavesdropping than transmission over guided media. You can largely solve the security issue by using secure network protocols, but you should be sure to isolate wireless stations from sources of EMI in the operating frequency range of the network. A microwave oven, for example, can degrade wireless communication that is based on the microwave portion of the electromagnetic spectrum.

How It Works

In the broadest sense, wireless networking is composed of all forms of network communication that use electromagnetic waves of any wavelength or frequency, which includes the following portions of the electromagnetic spectrum:

  • Infrared (IR):
    Ranges from frequencies of about 300 GHz to 200 THz and is used primarily in confined areas where line-of-sight communication is possible. IR cannot penetrate buildings or structures, but it can reflect off light-colored surfaces.

  • Microwave:
    Ranges from 2 GHz to 40 GHz and is used for both point-to-point terrestrial communication and satellite communication. Microwave suffers from signal degradation when weather conditions are poor (for example, in fog or rain).

  • Broadcast radio:
    Ranges from 30 MHz to 1 GHz, is less affected by poor atmospheric conditions than microwave, and can travel through most buildings and structures, but suffers from multipath interference over long distances.

To connect wireless stations to a traditional wired LAN, you need only two components:

  • One or more access points, which are transceivers connected to the wired LAN. They broadcast signals to and receive signals from the wireless stations on the LAN, forwarding signals between the wired network and the wireless stations as needed. The effective reception range from an access point defines a circular area called a cell, or more properly, a Basic Service Set. When more than one access point exists on a network and their cells overlap, the access point devices must also hand off communication as roaming stations move from one cell to another. The number of wireless stations that an access point can effectively handle is inversely proportional to the average traffic generated by each station. A typical wireless access point device might provide up to 3000 square meters of coverage in open areas (or less when obstacles are present) and support data transmission rates of 1 to 10 Mbps.

  • A WLAN adapter, which can be an external device called a station adapter that plugs into the RJ-45 port of a 10BaseT Ethernet card, an external device that connects to an RS-232 serial port, or a special PCMCIA card. Whatever configuration you use, the wireless adapter turns the computer in which it is installed into a wireless station on the network. A fixed or detachable antenna is generally included and gives the station better transmission and reception. For a small-scale WLAN, the typical power output for an adapter might be 100 mW, resulting in a coverage range of about 305 meters in open areas (or less when obstacles are present).

    Graphic W-14. Wireless networking.
    Graphic W-14. Wireless networking.

The existing standard for wireless networking is IEEE 802.11 of Project 802, which specifies the physical layer (PHY) and media access control (MAC) protocols and characteristics for wireless communication between networked stations. In particular, 802.11 covers low-power wireless microwave communication in the Industrial, Scientific, and Medial (ISM) communication band centering on 2.4 GHz that was set aside by the Federal Communications Commission (FCC) in the early 1980s for unlicensed wireless communication. 802.11 covers both common spread spectrum communication methods (direct sequencing and frequency hopping), includes an exportable encryption algorithm called wired equivalent privacy (WEP) to prevent eavesdropping, and specifies a maximum data transmission speed of either 1 or 2 Mbps. 802.11 also specifies standards for wireless communication using infrared light. 802.11 is currently being revised to support transmission speeds of up to 20 Mbps.

NOTE

Both direct sequencing spread spectrum (DSSS) and frequency hopping spread spectrum (FHSS) wireless technologies can operate in the unlicensed 2.4-GHz ISM band. DSSS equipment is also available for operation in a portion of the 900-MHz frequency band—the same part of the electromagnetic spectrum used by Cellular Digital Packet Data (CDPD) cellular telephone and Personal Communications Services (PCS) paging technologies—and is better able to penetrate buildings and structures than 2.4-GHz equipment. When you use a wireless bridge, 900 MHz is preferred for longer distances; 2.4 GHz works better over shorter distances and provides greater network throughput.

Most wireless systems use the Carrier Sense Multiple Access with Collision Avoidance (CSMA/CA) media access method, in contrast to the Carrier Sense Multiple Access with Collision Detection (CSMA/CD) method used in wired Ethernet networks. The primary reason for this is that it is difficult to detect collisions between unguided electromagnetic waves.

TIP

Use an omnidirectional antenna if your wireless bridge or router is being used for point-to-point communication.

wiring closet

Also called an equipment room or server room (and various other names), a room on the floor of a building that contains hubs, switches, and other network components for the floor that is connected through a vertical backbone cable to the main equipment room, which is usually in the basement of the building (in a multifloor building). The wiring closet for a floor is the termination point for horizontal cabling running from wall plates in work areas on that floor. This horizontal wiring typically terminates in a series of patch panels in the wiring closet. Patch cables are used to connect jacks on the patch panels to ports on hubs and switches to establish network connectivity between computers on the floor and with other floors. In a single-floor building, the wiring closet and the main equipment room are the same and are sometimes called the telecommunications closet because telecommunications services typically terminate in that room as well.

TIP

The EIA/TIA wiring standards recommend one wiring closet per floor, with a minimum size of 3 meters by 2 meters for up to 455 square meters of floor space. When stations must be located more than 91 meters from the wiring closet, additional wiring closets are recommended. Wiring closets should be well-lit and have adequate power supply. Equipment should be mounted on racks for greater security and efficiency. “Spaghetti” should be minimized—keep everything accurately labeled to save yourself hours of troubleshooting time when things go wrong. Keep access to the wiring closet clear and secure, and include fire protection devices.

See also
premise cabling

WMI

See
Windows Management Instrumentation (WMI)

word list

The result of the first stage of the indexing process in Microsoft Indexing Service. Word lists are temporary indexes stored in RAM in a relatively uncompressed state. They are a staging ground for the generation of more efficient indexes called persistent indexes. When the amount of word lists exceeds a specified number, they are merged together.

See also
Indexing Service

workgroup

A logical grouping of networked computers that can share resources with each other. These resources might include files, printers, and other devices. A workgroup is often called a peer-to-peer network because all computers in a workgroup are equally important. In other words, no single computer “runs the network,” as in a domain-based model.

How It Works

Each computer in a workgroup handles security separately using its own local security database, which tracks who can log on to the computer and what rights or permissions users have to resources on the computer. A user who wants to log on to a computer must have an account in that computer’s local security database. A user with an account on one computer doesn’t necessarily have any permissions or rights to resources on other computers.

If a computer in a workgroup is used to provide file, print, or other resources to other computers in the workgroup, that computer is generally called a peer server or a stand-alone server. Because security is local to each computer in a workgroup, a peer server can share resources using share-level security only, which uses passwords to protect access to each resource. Users who know this password can access the resources at the level of access with which it is shared (such as read-only access, full access, and so on).

Workgroups are simple to implement but hard to maintain. Administrators must create accounts on each computer for the users who need access to them. As a result, workgroups are generally used for small networks of 10 or fewer computers in which security and centralized administration are not an issue.

working set

The physical memory assigned to a process by the Microsoft Windows NT and Windows 2000 operating systems. The working set consists of pages, which are sections of code and application data that have recently been used by the process. If the process requires code or data that is not in its working set, it generates a page fault, causing the Virtual Memory Manager to swap new pages into the working set. If page faults become excessive, application performance can be slowed. Adding more RAM is one solution to this problem, while increasing the maximum working set size can also be helpful.

If memory becomes scarce, the Virtual Memory Manager moves the memory pages referenced less recently from the working sets in order to recover memory for the system. Older pages are also removed as new pages are added. Efficient applications use and store data in sequence, with the result that fewer memory pages are needed by the application, allowing a small working set.

Workstation service

Also known as LanmanWorkstation, a component of the Microsoft Windows NT and Windows 2000 operating systems that allows a client to request file and print resources from servers over the network.

How It Works

The Workstation service is a user mode service that works together with a kernel mode component called the redirector file system driver, or rdr.sys. This redirector is implemented as a standard file system driver and resides above the Transport Driver Interface (TDI) layer, which allows it to interact independently with any transport protocols.

The Workstation service on a client computer accepts an input/output (I/O) request for a remote file, named pipe, or mailslot; determines which service can best provide this resource; and redirects the request to the Server service on the server where the requested resource resides. The Server service provides the requested resource and routes it back to the client that requested it. The Server service also consists of two components, a user mode component called LanmanServer and a kernel mode component called the server file system driver, or srv.sys.

You can also install additional redirectors from third-party vendors that can coexist with the Workstation service on Windows NT and Windows 2000. An example of an additional redirector included with Windows NT and Windows 2000 is Gateway Service for NetWare (GSNW), which enables Microsoft Windows clients to gain access to files and printers on a Novell NetWare server.

See also
Server service

World Wide Web (WWW)

The most popular of Internet services, rapidly changing the way business is done around the world. The World Wide Web Consortium (W3C) defines the World Wide Web (WWW, or Web) as “the universe of network-accessible information, the embodiment of human knowledge.” The WWW began as a project for sharing hypertext information over a network that was developed by Tim Berners-Lee at CERN, a physics research center in Geneva, Switzerland.

How It Works

The Web consists of all client and server applications that communicate over the Internet using the client/server protocol Hypertext Transfer Protocol (HTTP), as well as the resources that reside on those servers and are accessed by those clients. These resources are generally referred to as “Web sites” and consist mainly of text files formatted in Hypertext Markup Language (HTML) and associated image, sound, multimedia, script, and other files. Each HTML file is called a Web page (or page), and pages in a site are generally linked in a hierarchical fashion, starting with the home or top page, using anchor tags. Web sites are stored on Web servers, which run software that handles the server side of HTTP, such as Internet Information Services (IIS) for Microsoft Windows 2000. Users access Web sites on the Internet by using client software, typically called a Web browser (such as Microsoft Internet Explorer).

See also
Hypertext Transfer Protocol (HTTP)

World Wide Web Consortium (W3C)

A vendor-neutral organization created in 1994 that develops common, interoperable protocols for the World Wide Web (WWW). Represented by the Massachusetts Institute of Technology (MIT) in the United States and a number of international research centers, the World Wide Web Consortium (W3C) provides a variety of services to its member organizations, including the following:

  • Discussion groups and meetings on issues relating to the evolution of the WWW

  • Repositories of information, reference documents, and code relating to WWW protocols, services, and applications

  • The creation and testing of applications that demonstrate new types of WWW technologies

The director of the W3C is Tim Berners-Lee, the creator of the WWW. Membership in the W3C is tailored to organizations, but individuals can become affiliate members for an annual fee. For additional information about the WWW, you can subscribe to the World Wide Web Journal, produced by O’Reilly & Associates.

On the Web
•
W3C home page
: http://www.w3c.org
•
World Wide Web Journal
: http://www.w3j.com

World Wide Web Publishing Service

A component of Internet Information Services (IIS) on Microsoft Windows 2000 and of Internet Information Server (IIS) on Microsoft Windows NT. The World Wide Web Publishing Service provides support on Windows 2000 and Windows NT for communication using the Hypertext Transfer Protocol (HTTP). This protocol allows users to publish Web content on IIS for use on the Internet or on corporate intranets. Published Web content can then be accessed and displayed on client computers by using a standard Web browser such as Microsoft Internet Explorer. The World Wide Web Publishing Service is also central to third-party applications that facilitate remote administration of computers running Windows 2000 and Windows NT using Web browsers as their standard administrative interface.

See also
Hypertext Transfer Protocol (HTTP), Internet Information Services (IIS)

WOW

Stands for “Win16 on Win32,” a component of the Microsoft Windows NT operating system that enables 16-bit Microsoft Windows applications (such as those designed to run on Windows 3.1 and Windows for Workgroups 3.11) to run properly on Windows NT’s 32-bit operating system.

How It Works

Like MS-DOS applications, 16-bit Windows applications (Win16 applications) also run on Windows NT within the context of a Windows NT Virtual DOS Machine (NTVDM), which simulates the 16-bit environment necessary for these applications to run. However, while MS-DOS applications each require their own separate NTVDMs in which to run, Win16 applications run within a single NTVDM called WOW, which corresponds to the system process wowexec.exe. And while NTVDMs hosting MS-DOS applications are single-threaded, WOW is a multithreaded NTVDM in which each Win16 application runs as a separate thread using the same shared address space. WOW also simulates the cooperative multitasking environment for which applications written for Windows 3.1 and Windows for Workgroups 3.11 are designed. WOW will allow only one Win16 application to run at a time, blocking the threads of all other Win16 applications until the running application relinquishes control. If the Windows NT kernel needs to preempt the Win16 application (by preempting WOW), it always resumes with the same Win16 application.

WOW also handles the translation of 16-bit Windows application programming interfaces (APIs) and messages to their corresponding 32-bit APIs and messages, enabling interoperability and data sharing between 16-bit and 32-bit Windows applications on the Windows NT platform.

NOTE

WOW starts automatically when the first Win16 application is started on the Windows NT system.

TIP

Windows NT also includes an option for running Win16 applications in their own separate NTVDMs, which enables Win16 applications to function as a process within Windows NT’s preemptive, multitasking environment. You can run a Win16 application in a separate NTVDM by opening the Run box from the Start menu, typing the path to the Win16 executable, and selecting the Run In Separate Memory Space check box. Note that doing this can have negative effects on Win16 applications that need to share data with each other by using legacy data-sharing mechanisms such as Dynamic Data Exchange (DDE).

WSH

See
Windows Script Host (WSH)

WWW

See
World Wide Web (WWW)


X

X.25

A packet-switching protocol for wide area network (WAN) connectivity that uses a public data network (PDN) that parallels the voice network of the Public Switched Telephone Network (PSTN). The current X.25 standard supports synchronous, full-duplex communication at speeds up to 2 Mbps over two pairs of wires, but most implementations are 64-Kbps connections via a standard DS0 link.

X.25 was developed by common carriers in the early 1970s and approved in 1976 by the CCITT, the precursor of the International Telecommunication Union (ITU), and was designed as a global standard for a packet-switching network. X.25 was originally designed to connect remote character-based terminals to mainframe hosts. The original X.25 standard operated only at 19.2 Kbps, but this was generally sufficient for character-based communication between mainframes and terminals.

Because X.25 was designed when analog telephone transmission over copper wire was the norm, X.25 packets have a relatively large overhead of error-correction information, resulting in comparatively low overall bandwidth. Newer WAN technologies such as frame relay, Integrated Services Digital Network (ISDN), and T-carrier services are now generally preferred over X.25. However, X.25 networks still have applications in areas such as credit card verification, automatic teller machine transactions, and other dedicated business and financial uses.

Graphic X-1. X.25. An X.25 network.
Graphic X-1. X.25. An X.25 network.
How It Works

The X.25 standard corresponds in functionality to the first three layers of the Open Systems Interconnection (OSI) reference model for networking. Specifically, X.25 defines the following:

  • The physical layer interface for connecting data terminal equipment (DTE), such as computers and terminals at the customer premises, with the data communications equipment (DCE), such as X.25 packet switches at the X.25 carrier’s facilities. The physical layer interface of X.25 is called X.21bis and was derived from the RS-232 interface for serial transmission.

  • The data-link layer protocol called Link Access Procedure, Balanced (LAPB), which defines encapsulation (framing) and error-correction methods. LAPB also enables the DTE or the DCE to initiate or terminate a communication session or initiate data transfer. LAPB is derived from the High-level Data Link Control (HDLC) protocol.

  • The network layer protocol called the Packet Layer Protocol (PLP), which defines how to address and deliver X.25 packets between end nodes and switches on an X.25 network using permanent virtual circuits (PVCs) or switched virtual circuits (SVCs). This layer is responsible for call setup and termination and for managing transfer of packets.

An X.25 network consists of a backbone of X.25 switches that are called packet switching exchanges (PSEs). These switches provide packet-switching services that connect DCEs at the local facilities of X.25 carriers. DTEs at customer premises connect to DCEs at X.25 carrier facilities by using a device called a packet assembler/disassembler (PAD). You can connect several DTEs to a single DCE by using the multiplexing methods inherent in the X.25 protocol. Similarly, a single X.25 end node can establish several virtual circuits simultaneously with remote nodes.

An end node (DTE) can initiate a communication session with another end node by dialing its X.121 address and establishing a virtual circuit that can be either permanent or switched, depending on the level of service required. Packets are routed through the X.25 backbone network by using the ID number of the virtual circuit established for the particular communication session. This ID number is called the logical channel identifier (LCI) and is a 12-bit address that identifies the virtual circuit. Packets are generally up to 128 bytes in size, although maximum packet sizes range from 64 to 4096 bytes, depending on the system.

NOTE

Related protocols include X.3, which defines the parameters for configuring a PAD; X.28, which defines the data transmission interface between the DTE and the PAD; and X.29, which defines a control protocol between the DTE and the PAD.

The Remote Access Service (RAS) for Microsoft Windows NT and the Routing and Remote Access feature of Microsoft Windows 2000 support X.25 PADs for dial-up clients and smart cards for direct connection to the X.25 network of remote access servers and clients.

TIP

X.25 is efficient for file transfer but not for interactive communication such as Telnet sessions, in which TCP/IP is run over X.25. If you often use Telnet from your X.25 terminal, you can improve efficiency by employing VanJacobsen TCP/IP Header Compression to reduce the overhead of the TCP/IP packet header from 40 bytes to 5 bytes (if your TCP/IP stack supports this feature).

Another reason that X.25 is inefficient for interactive communication is the typical half-second latency in communication due to the store-and-forward nature of the packet-switching network. Frame relay does not use store-and-forward packet switching and hence has much less latency.

TIP

The X.25 standard is updated every four years. Versions after 1984 are backward compatible with the 1984 version. However, if a network using the 1980 version of X.25 needs to communicate with a DTE on a network based on a later version, you must properly configure the routers connecting these networks to ensure effective communication.

x86 platform

A computer platform whose processor is based on the Intel 386 architecture microprocessor. The x86, or Intel, platform is one of the two processor platforms supported by Microsoft Windows NT (the other being the Alpha platform) and the only processor platform supported by Microsoft Windows 2000. Intel-based systems have essentially caught up with Alpha in terms of speed and functionality and are used for everything from mobile laptop computers to desktop workstations to high-performance symmetric multiprocessing (SMP) servers.

The x86 family is based on the 386 processor and includes the 486, Pentium, Pentium Pro, Pentium II, and Pentium III processors. Intel processors are based on the CISC (complex instruction set computing) architecture, which uses a large set of basic processor instructions to simplify code compilation. The CISC architecture differs from the RISC (reduced instruction set computing) architecture of the Alpha platform, which uses fewer processor instructions and offers better performance.

X.121 address

Also called an international data number (IDN), an address of an end node (computer or terminal) that is connected to an X.25 public data network.

How It Works

X.121 addresses are similar to long-distance telephone numbers and are used by X.25 end nodes to call each other to set up communication sessions. X.121 addresses are used during the call setup phase of X.25 communication and are used to establish a virtual circuit between the source node and destination node on the network.

X.121 addresses can be up to 14 decimal digits in length (if that many digits are required to uniquely determine the address of the destination node being called). The first four digits form the data network identification code (DNIC), with the first three digits indicating the country and the fourth digit indicating the carrier that owns the common packet-switching network being used to make the call. The last 8 to10 digits form the national terminal number (NTN) and identify the end node being called. An additional 1-byte header indicates the number of digits of both the source and destination nodes.

Once a communication session is established, a 12-bit logical channel identifier (LCI) is assigned to the two hosts as the identification number of the virtual circuit that is established between them. The X.25 network uses the LCI in the headers of the X.25 packets for routing data between the nodes. The X.121 address is used only at call setup to establish the virtual circuit.

X.400

A set of standards defined in 1984 and 1988 by the International Telecommunication Union (ITU) for computer-based handling of e-mail. The X.400 standard is based on the Open Systems Interconnection (OSI) reference model and other protocols developed by the International Organization for Standardization (ISO). X.400 provides global standards that enable users to send e-mail between any X.400-compliant messaging systems. X.400 is widely considered to be the standard framework for global messaging, although the Simple Mail Transfer Protocol (SMTP) for Internet e-mail might have an even better claim to the title. X.400 is widely implemented in Europe by most post, telephone, and telegraph (PTT) authorities. Microsoft Exchange Server supports messaging connectivity with X.400 mail systems through the X.400 Connector, an optional component available with the Enterprise Edition of Exchange Server 5.5.

How It Works

X.400 defines a global Message Handling System (MHS) that consists of a number of messaging components. From an administrative point of view, the building blocks of the MHS are management domains (MDs). (MDs are not the same as DNS domains—the Domain Name System [DNS] is used for SMTP mail, not X.400 messaging services.) A management domain is a collection of messaging systems with at least one Message Transfer Agent (MTA) managed by a specific organization. X.400 management domains come in two varieties:

  • Administrative Management Domains (ADMDs):
    Messaging systems managed by an administrator or a registered private agency. These are the top-level management domains that handle third-party messaging traffic. An example is a telephone carrier service company such as AT&T.

  • Private Management Domains (PRMDs):
    Unique subscriptions to an ADMD, such as telephone numbers of users. PRMDs can send or receive messages from an ADMD, but PRMDs cannot communicate directly with each other.

An X.400 MHS consists of the following five kinds of messaging components:

  • Message Transfer Systems (MTS’s):
    Collections of one or more MTAs that function together to provide message forwarding services for a particular X.400 domain.

  • Message Transfer Agents (MTAs):
    Route and deliver transport messages to and from User Agents (UAs) and with other MTAs. An MTA corresponds to a mail server in a typical LAN–based messaging system. MTAs maintain a database of all UAs registered in their domain and routing tables that indicate how messages should be forwarded to other domains.

  • Messages Stores (MS’s):
    Temporarily store messages that an MTA has received until they can be processed and forwarded for delivery. X.400 thus uses a store-and-forward method of message delivery.

  • User Agents (UAs):
    Provide messaging functionality directly to users. From a practical point of view, a UA can be identified as the e-mail client software that a user is running; from an abstract point of view, a UA is a domain belonging to a user and consisting of additional subcomponents. The goal of an X.400 MHS is to facilitate exchange of messages between different UAs.

  • Access Units (AUs):
    Gateways between an X.400 MHS and another messaging system such as a telex or fax system.

    Graphic X-2. X.400. The X.400 Message Handling System.
    Graphic X-2. X.400. The X.400 Message Handling System.

Each UA in an X.400 MTS is identified by a special X.400 address called an Originator/Recipient (O/R) address. The O/R address is the e-mail address of the X.400 user and can be quite complex compared to an SMTP e-mail address. (This is one reason that SMTP is overtaking X.400 in popularity.) An O/R address consists of a series of VALUE=ATTRIBUTE pairs separated by semicolons. Not all fields need to be complete—only those that uniquely identify the recipient are required. Here is an example of an X.400 address:

C=US;A=MCI;P=MICROSOFT;O=SALES;S=SMITH;G=JEFF;

The individual address fields are as follows:

  • Country (C) is United States

  • ADMD (A) is MCI

  • PRMD (P) is Microsoft (company name)

  • Organization (O) is Sales Department of Microsoft

  • Surname (S) is Smith

  • Given name (G) is Jeff

An X.400 message consists of a P1 envelope and its P2/22 message contents. The envelope contains the e-mail address information needed for routing the message to its destination. The X.400 protocol for a message envelope includes support for message tracking and delivery priority features. The X.400 protocol for the message content includes a header and body part for the message.

What typically happens in the message transfer process is that a UA sends a message addressed to another UA in the MHS. The message is forwarded to an MTA in the local MTS, which either delivers the message locally or forwards it to a remote MTA for handling, depending on where the destination UA is located. The message is passed from MTA to MTA until it reaches the MTS of the destination UA, whereupon it is either delivered if the destination UA is connected or stored in an MS until the UA can retrieve it.

See also
P-series protocols

X.400 Connector

A type of connector that is available as an optional component of Microsoft Exchange Server. The X.400 Connector can be used in several ways:

  • To link two different sites in an Exchange organization for messaging connectivity and directory replication. One advantage of using the X.400 Connector for this purpose instead of the Site Connector is that you can use the X.400 Connector to control both the size of the messages and the schedule for routing them.

  • To link two different sites in an Exchange organization by using a public or private X.400 messaging network as the messaging backbone.

  • To provide messaging connectivity between an Exchange organization and a foreign X.400 messaging system.

The X.400 Connector works with several different network transports, including these:

  • TP0/X.25 for X.25 packet-switched networks

  • TP4/CLNP for connecting to host-based systems

  • TCP/IP

TIP

Use the X.400 Connector instead of the Site Connector to link sites that are connected by dedicated or leased lines with a bandwidth of 64 Kbps or less, because the X.400 Connector uses about 30 percent less bandwidth than the Site Connector for communication overhead.

X.500

A recommendation from the International Telecommunication Union (ITU) that specifies a global, hierarchical directory service. Features of X.500 include the following:

  • A standards-based directory service for those applications that require directory information

  • A single, global, hierarchical namespace of objects and their attributes

  • Data management functions for viewing, adding, modifying, and deleting directory objects

  • Search capabilities for customizing complete data queries

How It Works

X.500 defines a global directory service that consists of several components. From an administrative point of view, the building blocks of the X.500 directory service are Directory Management Domains (DMDs). An X.500 DMD is a collection of X.500 components that includes at least one Directory System Agent (DSA) and is managed by a Domain Management Organization (DMO). There are two types of DMDs:

  • Administrative Directory Management Domains (ADDMDs):
    Directory services managed by a registered private agency that provide public directory services. Examples of ADDMDs are Four11 and Bigfoot, which provide public X.500 directory services over the Internet.

  • Private Directory Management Domains (PRDMDs):
    Directory services that provide private directory access. An example is a domain controller hosting Active Directory on a network running Microsoft Windows 2000.

Three main components are involved in maintaining and accessing X.500 directory services:

  • Directory Information Base (DIB):
    The actual hierarchical database that contains all the information in the directory. X.500 uses a distributed directory hierarchy in which different subsets of the DIB are found on different servers at different locations. From the user’s point of view, however, the entire global X.500 directory appears to be accessible from the local directory server that the Directory User Agent (DUA) connects to. A schema is used to define the various classes of objects and their attributes, which can be stored in the directory. The Directory Information Tree (DIT) is the naming hierarchy that describes the hierarchical structure of the DIB.

  • Directory System Agent (DSA):
    A particular server that maintains a subset of the DIB and provides an access point to the directory for DUAs to connect. Each DSA is responsible for a subset of the DIB and includes a set of naming contexts that define objects that are near each other in the DIT. DSAs also communicate with each other for directory replication purposes to ensure that each DSA’s subset of the DIB is current and complete and to maintain the integrity of the whole X.500 directory system.

  • Directory User Agents (DUAs):
    The client software that accesses the X.500 directory on behalf of the user. DUAs can perform such actions as searching, reading, updating, and deleting information in the directory, depending on the level of functionality of the client and the level of access granted to the user. The functionality of a DUA can be built into any type of software, including e-mail clients, Web browsers, or even the operating system itself.

    Graphic X-3. X.500. The X.500 directory service.
    Graphic X-3. X.500. The X.500 directory service.

To access information in the directory, a DUA connects to a local DSA and queries the directory by using the Directory Access Protocol (DAP), the standard X.500 protocol for locating, accessing, and modifying information in an X.500 directory. Various attribute-based search methods are possible using X.500-based directory services, including the following:

  • White pages searches, for name-to-address lookups

  • Yellow pages searches, for looking up a category

  • Browsing, for listings related to a given attribute

When a DUA issues a query, the query travels through a chain of DSAs and a result set travels back along the same chain. These queries use DAP, while DSAs communicate with each other using the Directory System Protocol (DSP).

NOTE

X.500 forms the basis of Active Directory in Windows 2000, the directory service of Microsoft Exchange Server, and Novell Directory Services (NDS).

A simplified version of DAP called the Lightweight Directory Access Protocol (LDAP) is more widely implemented than the feature-heavy DAP. LDAP was developed by the University of Michigan for use on TCP/IP networks such as the Internet and is widely implemented in Simple Mail Transfer Protocol (SMTP) client software such as Microsoft Outlook Express for querying online directories about SMTP users.

X.509 digital certificate

See
digital certificate

Xerox Network Systems (XNS)

A suite of networking protocols developed by Xerox Corporation’s Palo Alto Research Center (PARC) in the early 1980s. Xerox Network Systems (XNS) is little used today, but it was important in the evolution of other networking protocols, such as IPX/SPX and TCP/IP.

How It Works

XNS is based on a five-layer model, in contrast to the seven-layer Open Systems Interconnection (OSI) reference model for networking. The layers of the XNS protocol stack are as follows:

  • Level 0 (media access layer):
    Maps to the OSI physical layer and data-link layer and performs similar functions. XNS does not tie into any one media access protocol and supports the Ethernet, Token Ring, High-level Data Link Control (HDLC), and X.25 protocols, among others.

  • Level 1 (network layer):
    Maps to the OSI network layer and defines the Internet Datagram Protocol (IDP). IDP functions similarly to the Internet Protocol (IP) of TCP/IP and uses a logical addressing scheme that requires four-byte network numbers, four-byte host numbers, and two-byte socket numbers for both source and destination addresses. IDP is responsible for delivering datagrams by using unicast, multicast, and broadcast methods. Level 1 also defines the Routing Information Protocol (RIP), which handles dynamic routing and has evolved into later versions for use in IPX/SPX and TCP/IP networks.

  • Level 2 (transport layer):
    Maps to the OSI transport layer and defines the Sequenced Packet Protocol (SPP). SPP functions similarly to the Transmission Control Protocol (TCP) of TCP/IP and is responsible for providing reliable transmission of IDP packets, including sequence numbers and acknowledgments. Level 2 also defines the Packet Exchange Protocol (PEP), which functions similarly to the User Datagram Protocol (UDP) of TCP/IP. For troubleshooting purposes, the Echo Protocol (EP) functions similarly to the ping utility of TCP/IP.

  • Level 3:
    Maps to the OSI presentation layer and includes the Filing Protocol (FP), Clearinghouse Protocol (CP), Printing Protocol (PP), and others.

  • Level 4:
    Maps to the OSI application layer.

XNS has no level that maps to the OSI session layer.

XHTML

Stands for Extensible Hypertext Markup Language, a proposed version of Hypertext Markup Language (HTML) from the World Wide Web Consortium (W3C). XHTML 1 is basically a reformulation of HTML 4 in Extensible Markup Language (XML) and can smooth the migration from HTML to XML by allowing developers to create HTML documents that contain XML functions.

The advantages of using XHTML instead of HTML for Web content development include the following:

  • Easier portability to nonstandard user interfaces

  • The ability to create new document type definitions (DTDs)

Web sites can already be migrated to XHTML because XHTML conforms to existing Hypertext Transfer Protocol (HTTP) user agents (Web browsers). Migrating ensures that content is XML-conforming, which is advantageous because XML is the future Web content paradigm.

On the Web
•
W3C XHTML information
: http://www.w3.org/TR/xhtml1/

XML

Stands for Extensible Markup Language, a family of standards for the exchange of structured information that was developed by the World Wide Web Consortium (W3C). XML is viewed as the successor to Hypertext Markup Language (HTML), which is still commonly used for creating Web sites on the Internet and for publishing corporate intranet content. XML and its various components allow richly formatted and structured information to be delivered over the Web, and XML promises to be widely used in electronic commerce and electronic business applications.

How It Works

Like HTML, XML uses embedded tags to mark up documents for formatting purposes and to create relationships between documents (that is, to create hypertext). In fact, XML is a restricted subset of Standard Generalized Markup Language (SGML), which has existed for years but is unsuitable for implementation on the Web.

Unlike HTML, with its fixed syntax of tags, XML allows users to declare and use their own tags by using document type definitions (DTDs), which define the syntax, structure, and meaning of their tags. In other words, XML does not specify the set of available tags or their syntax, but instead functions as a meta-language for creating and describing other markup languages.

Various DTDs have been created for different subject areas, such as science, commerce, and documentation. XML also extends the idea of a “document” to include not only text files but also e-commerce transactions, server application programming interfaces (APIs), vector graphics, and many other forms. As a result, XML is far more universal than HTML.

XML also uses Extensible Stylesheet Language (XSL), in which you can define classes of XML documents and how they are formatted. You can use the XML Linking Language (XLL) to create links in XML documents to external objects such as multimedia objects, and use the XML Pointer Language (XPointer) to define link addresses in an XML document. These two languages go beyond the simple anchor tag (<A>) of HTML and provide ways to create one-to-many links, bidirectional links, read-only links, and other complex structural interactions between XML documents. Other components of the XML system include namespaces, query languages, and schema languages, many of which are still under development.

Here is a simple example of an XML document:

<?XML VERSION="1.0">
<HUMOR>
<BOB><QUOTE>Knock knock.</QUOTE>
<SALLY><QUOTE>Who's there?</QUOTE>
<LAUGHTER/>
</HUMOR>

This example illustrates two of the XML markup types:

  • Processing instructions:
    Supply necessary information to the application parsing the XML document, such as <?XML VERSION="1.0">, which tells the application that the document being parsed is written in XML.

  • Elements:
    Surround content with start and end tags, as in <QUOTE>…</QUOTE>. Elements of the form <…/>, such as <LAUGHTER/>, are called empty elements.

Other types of XML markup include the following:

  • Attributes, which are name-value pairs that extend the definition of a start tag.

  • Comments, which are represented by <!--…-->, as in HTML.

  • CDATA sections, such as <![CDATA[…]]>, which indicate to the parser in the application reading the document that the enclosed section is to be read unparsed. This might be used for computer code, for example.

  • Entity references, which specify reserved and special characters. For example, &LT; represents the less than symbol (<) that indicates the beginning of an element’s start tag.

XML also includes declarations that enable the XML document to communicate various types of meta-information to the application parsing the document. These include declarations for new elements, lists of attributes, and new entities. In the preceding sample XML document, for example, the elements <HUMOR>, <BOB>, <SALLY>, <LAUGHTER/>, and <QUOTE> would all need to be declared using <!ELEMENT…> declaration statements.

NOTE

Microsoft’s Channel Definition Format (CDF) was one of the earliest uses for XML in Internet environments.

On the Web
•
W3C’s XML site
: http://www.w3.org/XML

XNS

See
Xerox Network Systems (XNS)

X-series protocols

A series of standards and recommendations developed by the International Telecommunication Union (ITU) relating to data communication over networking and telecommunication services. These standards and recommendations include the following:

  • X.25:
    Defines a protocol for a global packet-switching network for wide area network (WAN) connectivity. Related X-series protocols include X.3, X.28, X.29, X.92, X.96, X.110, and X.121.

  • X.400:
    Defines a standard for a global message handling system for e-mail. Related protocols include X.402, X.403, X.407 (ANS.1), X.408, X.411, X.413, X.420, and the P-series protocols.

  • X.500:
    Defines a recommendation for a global directory service. Related protocols include X.501, X.509, X.511, and X.518 through X.521.

See also
X.25, X.400, X.500

X Window System

A client/server system for running a graphical user interface (GUI) that uses windows in a UNIX environment. The X Window System, also known as “X,” was developed jointly by the Massachusetts Institute of Technology (MIT), Stanford, and IBM starting in 1984, and its implementation is standardized by The Open Group. The X Window System is device-independent and provides a multitasking windowing environment for client computers.

The X Window System runs on network-attached workstations and terminals that access UNIX servers or mainframe computers. Elements of the X Window System include the following:

  • X servers, which form the server portion of the X Window System. These are typically UNIX servers but can also be mainframe computers running UNIX.

  • X clients, which are UNIX desktop workstations running the X Window System client software. The client software enables the workstations to display a windowed GUI in the X Window System environment. An alternative to using workstations is using X terminals, which are dumb terminals that have no operating system and use a ROM routine to implement X client software. X terminal machines must be connected to X servers by using local area network (LAN) connections, in contrast to character-based dumb terminals, which usually use serial connections such as RS-232 or X.21.

  • X protocol, the standard protocol for transmitting requests for windows functionality between X clients and X servers.

  • An X window manager, such as OSF/Motif, which implements windows features such as menus, toolbars, and gadgets that provide the look and feel of a windows GUI environment and allows X applications to run.


Y

Y2K

Also called the year 2000 problem or the millennium bug (even though it is not actually a bug), a computer problem that was expected to affect older hardware and software on January 1, 2000. Similar problems were expected to arise on related dates, particularly September 9, 1999, and February 28, 2000.

How It Works

The Y2K problem had the potential to affect hardware, operating systems, applications, run-time libraries, date-sensitive documents, data interfaces, and almost all other aspects of the computing environment. Potential Y2K problems arose from three primary sources:

  • Until recently, most software (and the BIOS on most PCs manufactured before about 1996) had been written to store date information in a format that uses only the last two digits of a year to represent the year. For example, the year 1960 is internally represented as 60. This date representation issue is most commonly identified as the year 2000 problem because the year 2000 is represented internally as 00, which is the same as for 1900. Most older software does, in fact, interpret the internal date 00 as 1900 instead of 2000. The problem arises when calculations are performed using dates. For example, financial software might calculate that an employee born in 1954 is actually 00 - 54 = -54 years old in the year 2000, and this negative age could lead to such problems as missed paychecks or pension contributions. On a large scale, such problems could have disastrous social consequences.

  • The year 2000 is a leap year because it is divisible by 4000, but some older software applications and hardware BIOS programs do not recognize this fact and, as a result, produce dates that are off by one day after February 28, 2000.

  • Many older software applications use special dates to represent special situations. For example, many older COBOL applications give the date 9/9/99 a special meaning such as “this item is to be saved forever” or “this item is to be deleted after 30 days.” Such applications had the potential to produce unpredictable results after September 9 , 1999.

In the early days of programming, system and disk memory were expensive and had to be carefully optimized. Saving 2 bytes by representing the date 1954 internally as the two-digit number 54 yielded significant savings on a system with limited RAM. This type of “good programming practice” continued even into the mid-1990s. And even though early programmers were probably aware of potential Y2K problems, no one expected programs developed in the 1970s and 1980s to continue being used into the next millennium.

An estimated 180 billion lines of COBOL code have been written for mainframe environments in business, industry, and government, and much if not most of this code had the potential to be affected by the Y2K problem. The problem was not limited to the mainframe arena—it also affected server and desktop operating systems and applications on UNIX, Macintosh, and Microsoft Windows platforms, affecting hardware BIOS programming, operating systems, application software, custom code, macros, and data files. The problem was enormous in scope and well publicized. Government and public agencies, enterprise-level businesses, and software and hardware vendors have devoted extensive resources in recent years to ensure that systems functioned properly on and after January 1, 2000.

NOTE

The most common PC hardware-related issues associated with Y2K related to the real-time clock (RTC) chip, which in most PCs uses only two digits to represent a year, and the BIOS routing, which is stored in flash ROM. If the BIOS did not contain code to roll over the century from 19xx to 20xx on January 1, 2000, the operating system would see the date 1900 when the user first turned on his or her PC in the year 2000. In some systems, this problem could be fixed with a BIOS upgrade, while other systems have had to be replaced with Y2K-compliant hardware.

TIP

Some experts might have advised you to test a system’s hardware compliance for Y2K by setting the date to 11:59 p.m. on December 31, 1999, and observing what happened when the date rolled over. This approach might have been acceptable for testing certain kinds of desktop systems, but it could be extremely dangerous on a network server. For example, on a server that incorrectly rolled over its date, date-licensed software might have expired or administrators might have been locked out of the system.

Y-connector

A type of adapter that can be used to connect a single device or cable to two devices or cables. Examples of Y-connectors include the following:

  • RJ-11 Y-connector:
    Allows two or more telephone devices to be plugged into a single RJ-11 wall plate. Some vendors call these adapters modular coupler splitters. This arrangement allows only one of the devices to work at any given time.

  • SCSI Y-connector:
    Allows a Small Computer Systems Interface (SCSI) device to be added to the middle of a chain of SCSI devices. A typical SCSI Y-connector has one 50-pin Centronics male connector and two 50-pin Centronics female connectors. One use for a SCSI Y-connector is the connection of a single RAID-5 SCSI array to two nodes of a cluster when Microsoft Cluster Server (MSCS), which is included in Microsoft Windows NT Server 4, Enterprise Edition, is used.

    Graphic Y-1. A SCSI Y-connector.
    Graphic Y-1. A SCSI Y-connector.
See also
Y-splitter

Y-splitter

Also called a Y-cable, a type of cable adapter that is arranged in a Y-shaped formation and is used to connect one device to a pair of other devices. Examples of Y-splitters include the following:

  • PS/2 Y-splitter:
    Typically used to connect an external keyboard and mouse to a single PS/2 port on a laptop such as the IBM ThinkPad. This type of splitter typically has cables that are about 1 foot long.

  • Internal power Y-splitter:
    An adapter used inside a PC to connect additional internal drives to the internal power supply of the PC. This type of splitter comes in various arrangements for connecting different combinations of hard drive, CD-ROM, and floppy drive.

    • Graphic Y-2. A PS/2 Y-splitter and an internal power Y-splitter.
    Graphic Y-2. A PS/2 Y-splitter and an internal power Y-splitter.

  • External power Y-splitter:
    An adapter commonly used with high-end Ethernet switches to connect them to two redundant external power supplies. If one power supply fails, the other immediately takes over the load, and the failed power supply can be hot-swapped with a replacement.

  • RS-366 Y-splitter:
    Used for some videoconferencing systems running in dual port mode over Integrated Services Digital Network (ISDN) connections.

TIP

PS/2 Y-splitters should use shielded cabling for best operation in noisy electrical environments.

See also
Y-connector


Z

ZAK

See
Zero Administration Kit (ZAK)

Zero Administration Kit (ZAK)

A collection of tools, methodologies, and guidelines for Microsoft Windows NT Workstation 4 that network administrators can use to implement policy-based management of Windows NT–based networks. You can use the Zero Administration Kit (ZAK) to

  • Manage the configuration of users’ desktops from a central location without having to visit each computer. You can specify exactly which applications the user can run, the appearance of the desktop, and where user data will be saved.

  • Restrict local access to users’ desktops. You can lock down the desktops to prevent users from performing actions that can result in costly help-desk calls, such as installing unapproved applications or modifying critical system files.

  • Configure applications and data to be stored on network servers. You can achieve improved security by downloading applications from the network, and you can use local hard drives for caching to ensure good performance. This facilitates upgrading of applications and centralized backup.

How It Works

The Zero Administration Kit uses the security of the NTFS file system along with system policies and user profiles. You can use the predefined set of system policies to override the local default settings, and you can use standard user profiles to configure and manage users’ desktops from a central location. The Zero Administration Kit includes the two following preconfigured modes of operation. (Advanced administrators can create other custom network configurations.)

  • TaskStation Mode:
    A desktop configuration for a “task-oriented” user such as a bank teller or a data entry person. This mode is ideal for users who require access to only one line-of-business application. TaskStation Mode completely locks down users’ desktops and boots directly into Microsoft Internet Explorer or a specified application. The user has no access to the Microsoft Windows Start button, taskbar, Task Manager, Control Panel, file system, or context menus.

  • AppStation Mode:
    A desktop configuration for typical “knowledge workers” who use three or four business applications every day but lack the knowledge and experience to configure or troubleshoot the system or install other applications. This mode provides users with only the applications they need for their jobs via a constrained Windows interface. The user has no access to Task Manager, Control Panel, the file system, or context menus.

TIP

Microsoft TechNet includes a self-paced Hypertext Markup Language (HTML) course called “Implementing the MS Zero Administration Kit for Windows NT Workstation 4.0” (course 979), which is a great resource for learning about how to implement and deploy the Zero Administration Kit.

On the Web
•
Zero Administration Kit home page
: http://www.microsoft.com/windows/zak

zone

Also called a zone of authority, a subset of the Domain Name System (DNS) namespace that is managed by a name server. This administrative unit can consist of a single domain, or it can be a domain combined with a number of subdomains. The concepts of a zone and a DNS domain are related: each zone is anchored in a specific domain known as the zone’s root domain.

How It Works

The name server must have a zone file, which contains the mappings between IP addresses and host names for the zone. A name server can manage one or more zones, depending on how it is configured. For example, a name server might have one zone for the domain microsoft.com and another zone for the domain adventure.expedia.com. Depending on how the zone file is configured, a name server might be responsible for

  • A single domain and all of its subdomains (if any). In this case, the particular name server is said to be authoritative over its entire root domain.

  • A single domain and a portion of the tree of subdomains beneath it. In this case, other name servers are authoritative over the remaining portion of the tree of subdomains beneath the root domain. You might want to divide a domain into several zones managed by several name servers in order to assign the management of each zone to a different group or to make zone transfers more efficient.

Typically, at least two name servers are responsible for a given zone—a primary name server, which manages the actual zone file, and one or more secondary name servers for redundancy. The primary name server manages a standard primary zone, which is represented by a text file called a zone file. (You can modify this file by using a text editor such as Notepad or by using the Microsoft Windows NT administrative tool called DNS Manager.) Each secondary name server manages a standard secondary zone, which is represented by a read-only zone file that you obtain by copying the primary zone file from the primary name server via a process called zone transfer.

Graphic Z-1. Zones and domains in DNS.
Graphic Z-1. Zones and domains in DNS.
NOTE

In Microsoft Windows 2000–based networks, a zone can take yet a third form, called an Active Directory integrated zone. In this type of zone, the zone information is stored and integrated into Active Directory of Windows 2000 for security purposes and is replicated by using the standard directory replication method used by Windows 2000 domain controllers. DNS in Windows 2000 supports dynamic update to ease the administrative burden of manually maintaining zone files.

See also
Domain Name System (DNS)

zone file

A file on a name server that contains information that defines the zone that the name server manages. The zone file is a text file consisting of a series of resource records that form the Domain Name System (DNS) database of the name server. These records identify which name server is responsible for a given zone, timing parameters for zone transfers between name servers, IP address to host name mappings for hosts within the domains over which the zone file is authoritative, and so on.

A typical zone file might look something like this:

; Database file microsoft.com.dns for microsoft.com.
zone.
@             IN    SOA    dns1.microsoft.com.  admin.microsoft.com.(
              12    ; serial number
              3600    ; refresh
              600    ; retry
              86400    ; expire
              3600    ) ; minimum TTL
; Zone NS records
@              IN    NS    dns1
@              IN    NS    dns2
; Zone A records
dns1        IN    A    192.250.100.10
dns2        IN    A    192.250.100.11
proxy1        IN    A    192.250.100.101
fred        IN    A    192.250.100.102
wilma        IN    A    192.250.100.103
localhost    IN     A    127.0.0.1
www             IN    CNAME    fred
ftp             IN    CNAME    wilma
NOTE

On Microsoft Windows NT–based and Windows 2000–based servers running the DNS Server services (and hence configured to operate as name servers for the network), the names of the zone files are similar to the names of the domains over which they have authority, but they have the .dns extension appended to them. For example, the zone file for the domain microsoft.com would be microsoft.com.dns and would be located in the directory \%SystemRoot%\System32\Dns.

A typical DNS server has at least three zone files:

  • <root_domain>.dns:
    The forward lookup zone file that is used to resolve host names into IP addresses for TCP/IP hosts over which the name server has authority. In the preceding example, the root domain is microsoft.com, so the zone file is microsoft.com.dns.

  • z.y.x.w.in-addr.arpa:
    The reverse lookup zone file for the forward lookup zone, which is used to resolve IP addresses into host names for TCP/IP hosts over which the name server has authority. In the preceding example, the network ID is 192.250.100.0, so the reverse lookup zone file is 100.250.192.in-addr.arpa.dns.

  • cache.dns:
    A standard file that exists on all name servers and contains the host names and IP addresses of name servers on the Internet that maintain the root domain of the entire DNS namespace.

TIP

Windows 2000 gives you the option of integrating DNS with Active Directory. This results in zone data being stored in Active Directory, which has advantages over traditional implementations of DNS in which zone data is stored in text files:

  • It provides a more efficient mechanism for zone transfers through the domain replication process of Active Directory. This eliminates the chore of manually configuring zone transfers between primary and secondary DNS servers.

  • It provides additional fault tolerance for the DNS information because all Active Directory integrated zones are primary zones and therefore contain a copy of the zone data.

You should generally use the Windows NT administrative tool called DNS Manager to make changes to zone files on a DNS server running on Windows NT rather than modify these files directly by using a text editor such as Notepad. This will prevent errors from finding their way into the DNS database. Similarly, use the DNS console in Windows 2000 to administer the zone files instead of editing them directly.

See also
Domain Name System (DNS) , resource record

zone of authority

See
zone

zone transfer

The process of transferring information in the zone file on a primary name server to a secondary name server. You would do this in the following situations:

  • If the primary name server goes down, so that the secondary name server has a complete, up-to-date copy of the zone file and can handle name resolution requests by Domain Name System (DNS) clients on the network.

  • If a large number of DNS clients on the local network are making name resolution requests, so that you can load balance these requests between the primary name server and its secondary name servers.

  • If the primary name server is located on the other side of a slow wide area network (WAN) link, so that you can reduce network traffic over the link by allowing name resolution requests to be handled locally. The only network traffic created by DNS is occasional zone transfers over the link.

How It Works

In Microsoft’s implementation of DNS on Microsoft Windows NT, zone transfers occur in three circumstances:

  • When the Microsoft DNS Server Service is started on the secondary name server.

  • When the refresh interval for the secondary name server expires—as defined in the start of authority (SOA) record at the beginning of the zone file on the primary name server.

  • When changes have been made to the zone file on the primary name server and there is a notify list. The primary name server immediately notifies the secondary name server that the zone file has been modified and instructs it to initiate a zone transfer without waiting for the refresh interval to expire. The notify list is a list of IP addresses that specify which secondary name servers are allowed to access zone information on the primary name server for purposes of zone transfer.

A zone transfer is always initiated by the secondary name server. Typically, the secondary name server periodically contacts the primary name server to determine whether any changes have been made to the primary name server’s zone file. If so, it initiates a request for zone transfer. Specifically, when the refresh interval expires on the secondary name server, the following occurs:

  1. The secondary name server requests and receives the SOA record from the primary name server.

  2. The secondary name server compares the version number in the primary name server’s SOA record with its own current version number. If they differ, the secondary name server requests a zone transfer from the primary name server.

  3. In standard DNS operation, the entire zone file is transferred during this process.

    Graphic Z-2. Zone transfer in standard DNS on Windows NT.
    Graphic Z-2. Zone transfer in standard DNS on Windows NT.
NOTE

The dynamic update standard supported by Microsoft Windows 2000 allows zone information to be transferred by using updates. The entire contents of the zone file are not sent when a change is made to a resource record in the file. This method is called incremental zone transfer and is defined in Request for Comments (RFC) 1995.

See also
Domain Name System (DNS) , zone


 [Previous] [Next]

About the Author

Mitch Tulloch is a Microsoft Certified Trainer (MCT) and Microsoft Certified Systems Engineer (MCSE) based in Winnipeg, Canada. He is president of MTIT Enterprises (http://www.mtit.com) and the author of five books on Microsoft BackOffice products, including the best-selling Administering IIS4 from McGraw-Hill Professional Publishers and Microsoft Exchange Server in a Nutshell from O’Reilly and Associates. The Microsoft Encyclopedia of Networking is his first book with Microsoft Press. Mitch is also the Microsoft Windows NT and Windows 2000 section lead for Swynk (http://www.swynk.com/windows), a popular site for administrators who work with Microsoft BackOffice products.

Mitch has almost 20 years of experience teaching and training in technical subjects. His background is in physics, and his involvement with computers goes back to his student days in the early seventies, when he wrote programs on a PDP-11 to determine nuclear decay lifetimes for the cyclotron laboratory in the Physics Department at the University of Manitoba. He describes himself as “one of Microsoft’s biggest fans” and a “well-balanced nerd.”


About This Electronic Book

This electronic book was originally created—and still may be purchased—as a print book. For simplicity, the electronic version of this book has been modified as little as possible from its original form. For instance, there may be occasional references to sample files that come with the book. These files are available with the print version, but are not provided in this electronic edition.

“Expanding” Graphics

Many of the graphics shown in this book are quite large. To improve the readability of the book, reduced versions of these graphics are shown in the text. To see a full-size version, click on the reduced graphic.


About Microsoft Press

Microsoft Press is a division of Microsoft Corporation and the leading source of comprehensive self-paced learning, training, evaluation, and support resources to help everyone from developers to IT professionals to end users get the most from Microsoft® technology. Choose from more than 250 current titles in print, multimedia, and network-ready formats—learning solutions made by Microsoft, with the most timely and accurate information available. For more information, visit http://mspress.microsoft.com/.


INDEX

Numbers and Symbols

Sysadmin
Commands
>
Sysadmin
Commands
|
Sysadmin
Commands
%SystemRoot%
Sysadmin
WAN
3.1 kHz bearer service
Sysadmin
LAN
5-4-3 rule
Sysadmin
Legacy
MicrosoftSoftware
OS
8.3 filename
Sysadmin
LAN
Standards
10Base2
Sysadmin
LAN
Standards
10Base5
Sysadmin
LAN
Standards
10BaseF
Sysadmin
LAN
Standards
10BaseT
WebMaster
Jargon
24 x 7
Sysadmin
LAN
Standards
100BaseFX
Sysadmin
LAN
Standards
100BaseT4
Sysadmin
LAN
Standards
100BaseTX
Sysadmin
LAN
Standards
100VG-AnyLan
Sysadmin
LAN
Standards
1000BaseCX
Sysadmin
LAN
Standards
1000BaseLX
Sysadmin
LAN
Standards
1000BaseSX
Sysadmin
LAN
Standards
1000BaseT
Sysadmin
Mainframe
3270

A

Sysadmin
Commands
absolute path
Sysadmin
Exchange
Protocols
Abstract Syntax Notation One (ASN.1)
Sysadmin
Security
access control
Sysadmin
Security
access control entry (ACE)
Sysadmin
Security
Unix
Win2000
WinNT
access control list (ACL)
Sysadmin
Security
access token
End-User
Security
account
Sysadmin
Security
WinNT
account domain
End-User
Security
Win2000
WinNT
account lockout
Sysadmin
Security
Win2000
WinNT
Account policy
Sysadmin
Security
Win2000
Active Directory
Sysadmin
Security
Win2000
Active Directory schema
Sysadmin
AdminTools
Security
Win2000
Active Directory Schema
Programmer
Programming
Security
Win2000
Active Directory Service Interfaces (ADSI)
Sysadmin
AdminTools
Security
Win2000
Active Directory Users and Computers
Programmer
Internet
MicrosoftSoftware
Programming
Active Platform
WebMaster
Internet
Programming
Active Server Pages (ASP)
Programmer
Internet
MicrosoftSoftware
Programming
ActiveX
Programmer
Internet
MicrosoftSoftware
Programming
SQL
ActiveX Data Objects (ADO)
Sysadmin
Telephony
Adaptive Differential Pulse-Code Modulation (ADPCM)
WebMaster
Internet
address record
Sysadmin
Internet
Protocols
TCP/IP
Address Resolution Protocol (ARP)
Sysadmin
Exchange
Administrative Management Domain (ADMD)
Sysadmin
AdminTools
Win2000
administrative tools (Windows 2000)
Sysadmin
AdminTools
WinNT
administrative tools (Windows NT)
Sysadmin
Security
Win2000
WinNT
Administrators group
Sysadmin
Hardware
Win2000
Advanced Configuration and Power Interface (ACPI)
Sysadmin
LAN
Protocols
Advanced Infrared (AIr)
Sysadmin
Telephony
Advanced Mobile Phone Service (AMPS)
Sysadmin
Mainframe
Protocols
Advanced Peer-to-Peer Networking (APPN)
Sysadmin
Mainframe
Protocols
Advanced Program-to-Program Communications (APPC) protocol
Sysadmin
BackOffice
Internet
Advanced Streaming Format (ASF)
Sysadmin
Security
WinNT
AGLP
Sysadmin
Other
Standards
American National Standards Institute (ANSI)
WebMaster
Internet
Standards
American Registry for Internet Numbers (ARIN)
Sysadmin
Dial-Up
Hardware
analog modem
Sysadmin
Hardware
analog-to-digital converter (ADC)
Sysadmin
Other
analog transmission
WebMaster
Security
WinNT
anonymous access
Sysadmin
Win2000
WinNT
answer file
Sysadmin
Mainframe
Protocols
APPC File Transfer Protocol (AFTP)
Sysadmin
Mac
Protocols
Apple Open Transport
Sysadmin
Mac
Protocols
AppleShare
Sysadmin
Mac
Protocols
TCP/IP
AppleShare IP
Sysadmin
Mac
Protocols
AppleTalk
Sysadmin
Protocols
Standards
application layer
WebMaster
Internet
Security
application layer proxy
Sysadmin
Security
Win2000
WinNT
application log
Programmer
Programming
application programming interface (API)
WebMaster
Internet
application service provider (ASP)
Sysadmin
TCP/IP
WinNT
arp command
Sysadmin
Standards
ASCII
Sysadmin
Other
ASCII file
Sysadmin
Other
Association for Computing Machinery (ACM)
WebMaster
Internet
Other
Association of Online Professionals (AOP)
Sysadmin
Protocols
Telephony
WAN
Asymmetric Digital Subscriber Line (ADSL)
Sysadmin
Hardware
Win2000
WinNT
asymmetric multiprocessing (AMP)
Sysadmin
LAN
WAN
Asynchronous Transfer Mode (ATM)
Sysadmin
Other
asynchronous transmission
Sysadmin
Security
Win2000
WinNT
auditing
Sysadmin
Security
Win2000
WinNT
Audit policy
Sysadmin
WinNT
automatic logon
Sysadmin
Win95/98
Automatic Skip Driver Agent (ASD)
Sysadmin
IE
Automatic Version Synchronization (AVS)
Programmer
MicrosoftSoftware
Programming
Automation
Programmer
MicrosoftSoftware
Programming
Automation controller
Programmer
MicrosoftSoftware
Programming
Automation server
Sysadmin
Internet
TCP/IP
WAN
autonomous system (AS)

B

Sysadmin
Hardware
LAN
backbone
Sysadmin
Hardware
Internet
backbone router
Sysadmin
Exchange
backboning
Sysadmin
Win2000
WinNT
background program
Sysadmin
Management
backup
Sysadmin
Management
Win95/98
backup agent
Sysadmin
WinNT
backup browser
Sysadmin
Management
WinNT
backup catalog
Sysadmin
Security
Win2000
WinNT
backup domain controller (BDC)
Sysadmin
Security
Win2000
WinNT
Backup Operator
Sysadmin
Security
Win2000
WinNT
Backup Operators built-in group
Sysadmin
Management
Win2000
WinNT
backup set
Sysadmin
BackOffice
backup site controller (BSC)
Sysadmin
Management
backup strategy
Sysadmin
Management
Win2000
WinNT
backup type
Sysadmin
Management
Win2000
Backup Wizard
Sysadmin
Engineering
balanced line
Sysadmin
Hardware
balun
Sysadmin
Engineering
bandwidth
Sysadmin
PPP/PPTP
Protocols
Win2000
Bandwidth Allocation Protocol (BAP)
Sysadmin
Telecommunications
bandwidth on demand
WebMaster
Internet
Management
bandwidth throttling
Sysadmin
LAN
NonMicrosoftSoftware
Protocols
Banyan VINES
Sysadmin
Engineering
baseband transmission
Sysadmin
Management
Win2000
WinNT
baseline
WebMaster
Internet
Security
Unix
Win2000
WinNT
Basic Authentication
Sysadmin
Win2000
basic disk
Sysadmin
Telecommunications
WAN
Basic Rate Interface ISDN (BRI-ISDN)
Sysadmin
Win2000
basic volume
Sysadmin
Commands
Management
Win2000
batch commands
Sysadmin
Commands
Legacy
Management
Win2000
Win95/98
WinNT
batch file
Sysadmin
Telecommunications
WAN
B channel
Sysadmin
SQL
bcp utility
Sysadmin
Engineering
LAN
beaconing
Sysadmin
NonMicrosoftSoftware
OS
BeOS
WebMaster
Internet
Protocols
TCP/IP
BIND
Sysadmin
NonMicrosoftSoftware
OS
bindery
Sysadmin
Protocols
Win2000
Win95/98
WinNT
binding
Sysadmin
Engineering
bits per second (bps)
Sysadmin
WAN
black hole
Sysadmin
Win95/98
WinNT
blue screen
Sysadmin
LAN
Standards
Bluetooth
Sysadmin
Hardware
BNC connector
Sysadmin
WinNT
B-node
Sysadmin
Protocols
Telecommunications
bonding
Sysadmin
OS
boot
Sysadmin
Legacy
Win95/98
WinNT
boot files
Sysadmin
Win2000
WinNT
boot.ini
Sysadmin
WinNT
boot loader menu
Sysadmin
WinNT
boot partition
Sysadmin
WinNT
bootsect.dos
Sysadmin
WinNT
boot sequence
Sysadmin
TCP/IP
bootstrap protocol (BOOTP)
Sysadmin
Win2000
boot volume
WebMaster
Internet
Protocols
TCP/IP
Border Gateway Protocol (BGP)
Sysadmin
Win2000
WinNT
bottleneck
Sysadmin
Engineering
LAN
bounce
Sysadmin
Hardware
breakout box
Sysadmin
Hardware
LAN
WAN
bridge
Sysadmin
Exchange
bridgehead server
End-User
Win2000
Win95/98
WinNT
Briefcase
Sysadmin
Telecommunications
WAN
broadband ISDN (B-ISDN)
Sysadmin
Engineering
broadband transmission
Sysadmin
LAN
broadcast
Sysadmin
LAN
broadcast frame
Sysadmin
LAN
TCP/IP
broadcast packet
Sysadmin
LAN
broadcast storm
Sysadmin
Hardware
brouter
Sysadmin
Win2000
WinNT
browse list
Sysadmin
Win2000
WinNT
browser election
Sysadmin
Win2000
WinNT
browsing
Sysadmin
OS
Unix
BSD UNIX
Sysadmin
Security
Win2000
WinNT
built-in account
Sysadmin
Security
Win2000
WinNT
built-in global group
Sysadmin
Security
Win2000
WinNT
built-in group
Sysadmin
Security
Win2000
WinNT
built-in identities
Sysadmin
Security
Win2000
WinNT
built-in local group
Sysadmin
Engineering
burst
Sysadmin
Hardware
bus
Programmer
Programming
business logic
Sysadmin
LAN
bus topology

C

Sysadmin
Hardware
cabinet
Sysadmin
Hardware
cabling
WebMaster
Security
CA certificate
WebMaster
Other
caching
WebMaster
Internet
Protocols
Caching Array Routing Protocol (CARP)
Sysadmin
Internet
Protocols
caching-only name server
Sysadmin
Internet
caching service provider (CSP)
Sysadmin
Internet
Protocols
WAN
Callback Control Protocol (CBCP)
Sysadmin
AdminTools
LAN
Security
Win2000
WinNT
capture window
Sysadmin
Engineering
carrierless amplitude and phase modulation (CAP)
Sysadmin
Engineering
LAN
Protocols
Carrier Sense Multiple Access with Collision Avoidance (CSMA/CA)
Sysadmin
Engineering
LAN
Protocols
Carrier Sense Multiple Access with Collision Detection (CSMA/CD)
WebMaster
Internet
Programming
cascading style sheets (CSS)
Sysadmin
Engineering
LAN
category 5 cabling
Sysadmin
Standards
CD file system (CDFS)
Sysadmin
Telephony
CDMA2000
End-User
Telecommunications
Telephony
Cellular Digital Packet Data (CDPD)
Sysadmin
Telecommunications
Telephony
cellular phone technology
Sysadmin
Telecommunications
Telephony
central office (CO)
WebMaster
Internet
Security
Win2000
WinNT
Certificate Administration Log Utility
WebMaster
Internet
Security
Win2000
WinNT
Certificate Administration Queue Utility
WebMaster
Internet
Security
certificate authority (CA)
WebMaster
Internet
Security
certificate revocation list (CRL)
WebMaster
Other
Programming
Certified Technical Education Center (CTEC)
WebMaster
Internet
Protocols
Security
WAN
Challenge Handshake Authentication Protocol (CHAP)
WebMaster
Internet
Standards
Channel Definition Format (CDF)
Sysadmin
Hardware
WAN
Channel Service Unit (CSU)
Sysadmin
Hardware
WAN
Channel Service Unit/Data Service Unit (CSU/DSU)
Sysadmin
Telecommunications
WAN
circuit-switched services
Sysadmin
Internet
Protocols
WAN
classless interdomain routing (CIDR)
Sysadmin
Other
client access license (CAL)
WebMaster
Internet
Security
client certificate
Sysadmin
NonMicrosoftSoftware
Win2000
WinNT
Client Services for NetWare (CSNW)
Sysadmin
Other
clustering
Sysadmin
Hardware
coaxial cabling
Sysadmin
Telecommunications
Telephony
Code Division Multiple Access (CDMA)
Programmer
Internet
Programming
Collaboration Data Objects (CDO)
Sysadmin
Hardware
LAN
collapsed backbone
WebMaster
Internet
MicrosoftSoftware
Programming
COM component
Sysadmin
Management
command prompt
WebMaster
Internet
commercial service provider (CSP)
Sysadmin
NonMicrosoftSoftware
Common Desktop Environment (CDE)
WebMaster
Internet
Programming
Standards
Common Gateway Interface (CGI)
Sysadmin
Management
Standards
Common Information Model (CIM)
WebMaster
Internet
Management
Protocols
Common Internet File System (CIFS)
Sysadmin
Programming
Standards
Common Object Request Broker Architecture (CORBA)
Programmer
MicrosoftSoftware
Programming
COM object
Sysadmin
Security
WinNT
complete trust model
Programmer
MicrosoftSoftware
Programming
Component Object Model (COM)
Sysadmin
Management
Win2000
WinNT
Computer Browser service
Sysadmin
Standards
Telephony
computer-telephony integration (CTI)
Sysadmin
Standards
Computing Technology Industry Association (CompTIA)
Sysadmin
BackOffice
COM Transaction Integrator (COMTI)
Sysadmin
BackOffice
Programming
connected network (CN)
Sysadmin
Protocols
TCP/IP
connectionless protocol
WebMaster
MicrosoftSoftware
Connection Manager Administration Kit (CMAK)
Sysadmin
Protocols
TCP/IP
connection-oriented protocol
WebMaster
MicrosoftSoftware
Connection Point Services (CPS)
Sysadmin
Hardware
connector (device)
Sysadmin
Engineering
Hardware
copper cabling
Sysadmin
LAN
Protocols
WAN
Copper Distributed Data Interface (CDDI)
Sysadmin
Win2000
WinNT
copying files
WebMaster
Internet
Standards
country code
Programmer
Programming
Security
CryptoAPI
Sysadmin
Telecommunications
customer premises equipment (CPE)
Sysadmin
Other
Protocols
cyclical redundancy check (CRC)

D

Sysadmin
Unix
daemon
Programmer
Programming
SQL
Data Access Objects (DAO)
Sysadmin
SQL
database owner (DBO)
Sysadmin
Engineering
data communications equipment (DCE)
WebMaster
Security
Data Encryption Standard (DES)
Sysadmin
Protocols
Data Link Control (DLC)
Sysadmin
Protocols
Standards
data-link layer
Sysadmin
Hardware
WAN
Data Service Unit (DSU)
Sysadmin
SQL
data source name (DSN)
Sysadmin
Engineering
data terminal equipment (DTE)
Sysadmin
Telecommunications
WAN
dedicated line
Sysadmin
Exchange
Defense Messaging System (DMS)
Sysadmin
Win2000
delegation
Sysadmin
Protocols
Standards
demand priority
Sysadmin
Engineering
dense wavelength division multiplexing (DWDM)
Sysadmin
Management
Standards
Desktop Management Interface (DMI)
Sysadmin
Protocols
destination address
Sysadmin
Internet
Protocols
TCP/IP
Win2000
Win95/98
WinNT
DHCP client
Sysadmin
Internet
Protocols
TCP/IP
Win2000
DHCP console
Sysadmin
Internet
Protocols
TCP/IP
WinNT
DHCP Manager
Sysadmin
Internet
Protocols
TCP/IP
Win2000
WinNT
DHCP scope
Sysadmin
Internet
Protocols
TCP/IP
WinNT
DHCP server
Sysadmin
Internet
Protocols
TCP/IP
Win2000
WinNT
DHCP Server service
Sysadmin
Telecommunications
WAN
dial-up line
Sysadmin
Management
differential backup
Sysadmin
Telephony
Digital Advanced Mobile Phone Service (D-AMPS)
Sysadmin
Telephony
Digital Advanced Wireless System (DAWS)
WebMaster
Internet
Security
Standards
digital certificate
Sysadmin
Telecommunications
digital data service (DDS)
Sysadmin
Hardware
digital modem
WebMaster
Internet
Security
Standards
digital signature
Sysadmin
Telecommunications
Digital Subscriber Line (DSL)
Sysadmin
Engineering
digital transmission
Sysadmin
LAN
TCP/IP
directed packet
Sysadmin
Telephony
direct inward dialing (DID)
Sysadmin
Protocols
Security
Directory Access Protocol (DAP)
Sysadmin
Security
Win2000
WinNT
directory database
Sysadmin
WinNT
directory export
Sysadmin
WinNT
directory import
Sysadmin
Security
Win2000
directory replication in Windows 2000
Sysadmin
Win2000
WinNT
Directory Replicator Service
Sysadmin
Security
Win2000
WinNT
directory service
Sysadmin
WinNT
Directory Service Manager for NetWare (DSMN)
Sysadmin
Internet
Protocols
Directory Service Markup Language (DSML)
Sysadmin
Security
Win2000
WinNT
discretionary access control list (DACL)
Sysadmin
Protocols
distance vector routing algorithm
Sysadmin
Exchange
Win2000
distinguished name
Programmer
MicrosoftSoftware
Distributed Component Object Model (DCOM)
Sysadmin
Win2000
WinNT
Distributed file system (Dfs)
Sysadmin
Security
Win2000
distribution group
Sysadmin
AdminTools
Internet
Protocols
WinNT
DNS Manager
Sysadmin
Internet
Protocols
DNS namespace
Sysadmin
Internet
Protocols
DNS query
Sysadmin
Internet
Protocols
DNS server
Sysadmin
Security
Win2000
WinNT
domain controller
Sysadmin
Security
Win2000
domain forest
Sysadmin
Security
Win2000
WinNT
domain in Windows NT and Windows 2000
Sysadmin
Win2000
WinNT
domain master browser
Sysadmin
Security
Win2000
domain modes
Sysadmin
Internet
Protocols
Domain Name System (DNS)
Sysadmin
Security
Win2000
domain tree
Sysadmin
Security
Win2000
domain user account
Sysadmin
Hardware
LAN
drop cable
Sysadmin
Telecommunications
DS0
Sysadmin
Telephony
Dual Tone Multiple Frequency (DTMF)
Sysadmin
Engineering
duplex
Sysadmin
Win2000
dynamic disk
Sysadmin
Internet
Protocols
TCP/IP
Win2000
WinNT
Dynamic Host Configuration Protocol (DHCP)
Programmer
MicrosoftSoftware
Programming
dynamic-link library (DLL)
Sysadmin
LAN
Protocols
WAN
dynamic routing
Sysadmin
Win2000
dynamic volume

E

Sysadmin
Engineering
electromagnetic interference (EMI)
WebMaster
Standards
electronic data interchange (EDI)
Sysadmin
Standards
Electronic Industries Alliance (EIA)
Sysadmin
Management
Win2000
WinNT
emergency repair disk (ERD)
Sysadmin
Security
Win2000
Encrypting File System (EFS)
WebMaster
Security
encryption
Sysadmin
Other
End-User License Agreement (EULA)
Sysadmin
Hardware
LAN
enhanced category 5 cabling
Sysadmin
Telephony
Enhanced Data Rates for Global Evolution (EDGE)
Sysadmin
Other
enterprise resource planning (ERP)
Sysadmin
LAN
Standards
Ethernet
Sysadmin
Hardware
LAN
Ethernet switch
Sysadmin
Management
Security
Win2000
WinNT
Event Viewer
Sysadmin
Exchange
Exchange Administrator
Sysadmin
Exchange
Exchange directory service
Sysadmin
Exchange
Security
Exchange permissions
Sysadmin
Win2000
WinNT
extended partition
Sysadmin
Internet
Protocols
Exterior Gateway Protocol (EGP)

F

Sysadmin
Management
Win2000
WinNT
failover
Sysadmin
LAN
Fast Ethernet
Sysadmin
Security
Win2000
Win95/98
FAT32
Sysadmin
Management
fault tolerance
Sysadmin
Standards
Federal Communications Commission (FCC)
Sysadmin
LAN
Fiber Distributed Data Interface (FDDI)
Sysadmin
Engineering
Hardware
fiber-optic cabling
Sysadmin
Security
Win2000
Win95/98
WinNT
file allocation table (FAT)
Sysadmin
Mac
Win2000
File and Print Services for Macintosh (FSM)
Sysadmin
Win2000
WinNT
File and Print Services for NetWare (FPNW)
Sysadmin
Security
Win2000
file permissions (Windows 2000)
Sysadmin
OS
file system
Sysadmin
Protocols
File-Transfer Access and Management (FTAM)
Sysadmin
Internet
Protocols
File Transfer Protocol (FTP)
Sysadmin
Security
firewall
Sysadmin
Standards
FireWire
Sysadmin
Engineering
flow control
Sysadmin
Security
Win2000
folder permissions (Windows 2000)
Sysadmin
Telecommunications
WAN
frame relay
Sysadmin
Hardware
WAN
frame relay access device (FRAD)
Sysadmin
Telephony
Frequency Division Multiple Access (FDMA)
Sysadmin
Engineering
frequency-division multiplexing (FDM)
End-User
Other
frequently asked questions (FAQ)
Sysadmin
Engineering
full-duplex
Sysadmin
Internet
Protocols
fully qualified domain name (FQDN)

G

Sysadmin
Win2000
WinNT
Gateway Service for NetWare (GSNW)
Sysadmin
Telephony
General Packet Radio Service (GPRS)
Sysadmin
LAN
Gigabit Ethernet
Sysadmin
Standards
Telecommunications
G.Lite
Sysadmin
Exchange
Global Address List (GAL)
Sysadmin
Win2000
global catalog
Sysadmin
Win2000
global catalog server
Sysadmin
Security
Win2000
WinNT
global group
Sysadmin
BackOffice
Programming
Win2000
globally unique identifier (GUID)
Sysadmin
Telephony
Global System for Mobile Communications (GSM)
Sysadmin
Security
Win2000
WinNT
global user account
Sysadmin
Engineering
ground loop
Sysadmin
Security
Win2000
WinNT
group
Sysadmin
Security
Win2000
group policy
Sysadmin
Security
Win2000
Group Policy
Sysadmin
Security
Win2000
WinNT
Guests group

H

Sysadmin
Standards
Telecommunications
H.323
Sysadmin
Telecommunications
Telephony
H.323 gateway
Sysadmin
Security
hacking
Sysadmin
Engineering
half-duplex
WebMaster
Internet
Protocols
Handheld Device Markup Language (HDML)
Sysadmin
Engineering
handshaking
Sysadmin
Win2000
WinNT
hardware abstraction layer (HAL)
Sysadmin
Win2000
Win95/98
WinNT
Hardware Compatibility List (HCL)
End-User
Win2000
Win95/98
WinNT
hardware profile
WebMaster
Security
hashing algorithm
Sysadmin
Telecommunications
H channel
Sysadmin
Protocols
header
Sysadmin
BackOffice
heartbeat
End-User
MicrosoftSoftware
Help
Sysadmin
BackOffice
helper server
Sysadmin
LAN
WAN
heterogeneous network
Sysadmin
Win2000
Win95/98
WinNT
hidden share
Sysadmin
Telecommunications
WAN
High-bit-rate Digital Subscriber Line (HDSL)
Sysadmin
Protocols
WAN
High-level Data Link Control (HDLC)
Sysadmin
Standards
High Performance File System (HPFS)
Sysadmin
Telephony
High Speed Circuit Switched Data (HSCSD)
Sysadmin
IE
History
Sysadmin
Win2000
WinNT
hive
Sysadmin
Win2000
WinNT
H-node
End-User
LAN
home area network (HAN)
Sysadmin
Win2000
WinNT
home folder
Sysadmin
Exchange
home server
Sysadmin
LAN
WAN
homogeneous network
Sysadmin
Hardware
hood
Sysadmin
LAN
WAN
hop
Sysadmin
Hardware
horizontal cabling
Sysadmin
TCP/IP
host
Programmer
SQL
Host Data Replicator
Sysadmin
IE
Internet
host header names
Sysadmin
TCP/IP
host ID
Sysadmin
TCP/IP
host name
Sysadmin
TCP/IP
host name resolution
Sysadmin
LAN
WAN
host routing
Sysadmin
TCP/IP
hosts file
Sysadmin
Jargon
hot
Sysadmin
Management
Win2000
WinNT
HTML-based administration (HTMLA)
WebMaster
Programming
Win2000
WinNT
HTML Extension (HTX)
WebMaster
Internet
TCP/IP
HTTP Keep-Alives
WebMaster
Internet
Protocols
Security
TCP/IP
HTTPS
WebMaster
Internet
TCP/IP
HTTP status codes
Sysadmin
Hardware
LAN
hub
Sysadmin
Win2000
Win95/98
WinNT
HyperTerminal
WebMaster
Internet
Programming
TCP/IP
Hypertext Markup Language (HTML)
WebMaster
Internet
Protocols
TCP/IP
Hypertext Transfer Protocol (HTTP)

I

Sysadmin
Management
incremental backup
Sysadmin
Standards
WinNT
Independent Computing Architecture (ICA)
WebMaster
Win2000
WinNT
Indexing Service
Sysadmin
SQL
Index Tuning Wizard
Sysadmin
Exchange
information store
Sysadmin
Standards
Infrared Data Association (IrDA)
Sysadmin
Engineering
Protocols
Standards
infrared transmission
Sysadmin
Standards
Institute of Electrical and Electronics Engineers (IEEE)
WebMaster
Internet
integrated communications provider (ICP)
Sysadmin
Telecommunications
WAN
Integrated Services Digital Network (ISDN)
Sysadmin
Hardware
Standards
Intelligent Input/Output (I 2 O)
Sysadmin
Security
Win2000
WinNT
interactive logon
Sysadmin
Telecommunications
Telephony
inter-exchange carrier (IXC)
Sysadmin
Internet
Protocols
Interior Gateway Protocol (IGP)
Sysadmin
Standards
Telephony
International Mobile Telecommunications-2000 (IMT-2000)
Sysadmin
Standards
International Organization for Standardization (ISO)
Sysadmin
Standards
International Telecommunication Union (ITU)
WebMaster
Internet
Standards
Internet Architecture Board (IAB)
WebMaster
Internet
Standards
Internet Assigned Numbers Authority (IANA)
WebMaster
WAN
WinNT
Internet Authentication Service (IAS)
WebMaster
Internet
Protocol
Internet Cache Protocol (ICP)
Sysadmin
Internet
Protocols
TCP/IP
Internet Control Message Protocol (ICMP)
WebMaster
Internet
Standards
Internet Corporation for Assigned Names and Numbers (ICANN)
WebMaster
Internet
Programming
WinNT
Internet Database Connector (IDC)
WebMaster
Internet
Programming
WinNT
Internet Data Query (IDQ)
WebMaster
Internet
Standards
Internet Engineering Task Force (IETF)
Sysadmin
IE
Internet
Management
Internet Explorer Administration Kit (IEAK)
Sysadmin
Internet
Protocols
TCP/IP
Internet Group Management Protocol (IGMP)
WebMaster
Internet
Win2000
WinNT
Internet Information Services (IIS)
WebMaster
Internet
MicrosoftSoftware
Internet Locator Service (ILS)
Sysadmin
Internet
Mail
Protocols
Internet Mail Access Protocol version 4 (IMAP4)
WebMaster
Internet
Standards
Internet Network Information Center (InterNIC)
Sysadmin
Internet
Protocols
TCP/IP
Internet Protocol (IP)
Sysadmin
Internet
Protocols
TCP/IP
Internet Protocol Security (IPSec)
Sysadmin
Internet
Protocols
TCP/IP
Internet Relay Chat (IRC)
WebMaster
Internet
Standards
Internet Research Task Force (IRTF)
WebMaster
Internet
Programming
Win2000
WinNT
Internet Server API (ISAPI)
WebMaster
Internet
Internet service provider (ISP)
WebMaster
Internet
Standards
Internet Society (ISOC)
Sysadmin
OS
Internetwork Operating System (IOS)
Sysadmin
LAN
Legacy
Protocols
Internetwork Packet Exchange (IPX)
Sysadmin
Programming
interprocess communication (IPC)
Sysadmin
Hardware
Telecommunications
inverse multiplexer (IMUX)
Sysadmin
Engineering
inverse multiplexing
WebMaster
Internet
Protocols
inverse query
Sysadmin
WinNT
I/O Manager
Sysadmin
Internet
Protocols
TCP/IP
IP address
Sysadmin
Internet
Protocols
TCP/IP
IPv6
Sysadmin
LAN
Protocols
IrDA Control
Sysadmin
LAN
Protocols
IrDA Data
Sysadmin
Internet
Protocols
iterative query
WebMaster
Internet
Security
Win2000
WinNT
IUSR_ComputerName

J

Programmer
Internet
NonMicrosoftSoftware
Programming
Java
Programmer
Internet
Programming
SQL
Java Database Connectivity (JDBC)
WebMaster
Internet
Programming
JavaScript
Sysadmin
Programming
Jet
WebMaster
IE
Internet
Programming
JScript

K

Sysadmin
OS
Win2000
WinNT
kernel
Sysadmin
Programming
Win2000
WinNT
kernel mode
Sysadmin
Win2000
Win95/98
WinNT
key in Microsoft Windows registry
Sysadmin
Exchange
Security
Key Management Server (KMS)
Sysadmin
Exchange
Knowledge Consistency Checker (KCC)

L

Sysadmin
LAN
Protocols
LAN emulation (LANE)
Sysadmin
Protocols
WAN
Layer 2 Forwarding (L2F)
Sysadmin
Protocols
WAN
Layer 2 Tunneling Protocol (L2TP)
Sysadmin
Telecommunications
WAN
leased line
Sysadmin
BackOffice
license
Sysadmin
WinNT
License Manager
Sysadmin
WinNT
licensing mode
Sysadmin
Internet
Protocols
Lightweight Directory Access Protocol (LDAP)
Sysadmin
Unix
Win2000
WinNT
Line Printer Daemon (LPD)
Sysadmin
Unix
Win2000
WinNT
Line Printer Queue (LPQ)
Sysadmin
Unix
Win2000
WinNT
Line Printer Remote (LPR)
Sysadmin
Protocols
WAN
Link Control Protocol (LCP)
Sysadmin
Protocols
link state routing algorithm
Sysadmin
Win2000
Win95/98
WinNT
lmhosts file
Sysadmin
BackOffice
Security
Local Address Table (LAT)
Sysadmin
Telecommunications
Local Area Data Channel (LADC)
Sysadmin
LAN
local area network (LAN)
Sysadmin
Telecommunications
Telephony
local exchange carrier (LEC)
Sysadmin
Win2000
WinNT
local group
Sysadmin
WinNT
Local Procedure Call Facility (LPC Facility)
Sysadmin
WinNT
Local Security Authority (LSA)
Sysadmin
Win2000
WinNT
local user account
Sysadmin
WinNT
local user profile
Sysadmin
Protocols
logical link control (LLC) layer
Sysadmin
LAN
Security
logon
Sysadmin
Win2000
Win95/98
WinNT
long filename (LFN)
Sysadmin
TCP/IP
loopback address

M

Sysadmin
Hardware
LAN
Protocols
MAC address
Sysadmin
BackOffice
machine group
Sysadmin
Hardware
NonMicrosoftSoftware
OS
Macintosh
Sysadmin
Exchange
mailbox
Sysadmin
Mail
mail client
Programmer
Programming
WinNT
mailslot
Sysadmin
Mail
mail system
Sysadmin
Hardware
mainframe
Sysadmin
AdminTools
Win95/98
Maintenance Wizard
Programmer
Programming
SQL
makepipe
Sysadmin
Internet
Protocols
Security
Management Information Base (MIB)
Sysadmin
Standards
Management Information Format (MIF)
Sysadmin
Engineering
LAN
Manchester coding
Sysadmin
Win2000
WinNT
mandatory user profile
Sysadmin
Hardware
LAN
manual switch
Sysadmin
Win2000
Win95/98
WinNT
mapped network drive
Sysadmin
Win2000
WinNT
master browser
Sysadmin
SQL
master database
Sysadmin
Security
WinNT
master domain
Sysadmin
Win2000
WinNT
master index
Sysadmin
Internet
Protocols
master name server
Sysadmin
Mainframe
master station
Sysadmin
Hardware
matrix switch
Sysadmin
Internet
MBone
Sysadmin
Hardware
LAN
media
Sysadmin
Protocols
media access control (MAC) layer
Sysadmin
LAN
Protocols
media access control method
Sysadmin
Hardware
LAN
media converter
Sysadmin
Hardware
LAN
media-dependent adapter (MDA)
Sysadmin
Win2000
WinNT
member server
Sysadmin
Win2000
WinNT
memory.dmp
Sysadmin
Win2000
WinNT
merge
Sysadmin
LAN
mesh topology
Sysadmin
Mail
message
Sysadmin
Security
message digest (MD) algorithms
Sysadmin
Exchange
Message Tracking Center
Sysadmin
Exchange
Message Transfer Agent (MTA)
Programmer
Mail
MicrosoftSoftware
Messaging Application Programming Interface (MAPI)
Sysadmin
Win2000
WinNT
Messenger service
Sysadmin
WinNT
metabase
Sysadmin
WAN
metropolitan area network (MAN)
Sysadmin
Win2000
WinNT
Microsoft BackOffice
Sysadmin
BackOffice
Microsoft BackOffice Server
Sysadmin
BackOffice
Microsoft BackOffice Small Business Server
End-User
Win95/98
Microsoft Backup
Sysadmin
BackOffice
Microsoft Certificate Server
Sysadmin
Certification
Microsoft Certified Database Administrator (MCDBA)
Sysadmin
Certification
Microsoft Certified Professional (MCP)
Programmer
Certification
Microsoft Certified Solution Developer (MCSD)
Programmer
Certification
Programming
Microsoft Certified Solution Provider (MCSP)
Sysadmin
Certification
Microsoft Certified Systems Engineer (MCSE)
Sysadmin
Certification
Microsoft Certified Trainer (MCT)
Sysadmin
Protocols
Security
Microsoft Challenge Handshake Authentication Protocol (MS-CHAP)
Sysadmin
WinNT
Microsoft Cluster Server (MSCS)
Sysadmin
Internet
MicrosoftSoftware
Microsoft Commercial Internet System (MCIS)
Sysadmin
MicrosoftSoftware
Microsoft Connection Manager (CM)
Programmer
Programming
SQL
Microsoft Data Access Components (MDAC)
Programmer
Programming
Microsoft Developer Network (MSDN)
Sysadmin
Management
Microsoft Direct Access (MSDA)
Sysadmin
Win2000
WinNT
Microsoft DNS Service
Sysadmin
BackOffice
Microsoft Exchange Server
Sysadmin
BackOffice
Microsoft Fax Service
Programmer
Programming
Microsoft Foundation Classes (MFC)
WebMaster
Internet
Programming
Microsoft FrontPage
Sysadmin
IE
Microsoft Internet Explorer
End-User
Win2000
Win95/98
Microsoft Magnifier
Sysadmin
Mail
MicrosoftSoftware
Microsoft Mail
Sysadmin
Exchange
Microsoft Mail Connector
Sysadmin
AdminTools
Win2000
WinNT
Microsoft Management Console (MMC)
Sysadmin
Win2000
WinNT
Microsoft Message Queue (MSMQ) Server
Sysadmin
BackOffice
Microsoft Modem Sharing Server
Sysadmin
MicrosoftSoftware
Microsoft NetMeeting
Sysadmin
MicrosoftSoftware
Microsoft NetShow
Sysadmin
MicrosoftSoftware
Microsoft NetShow Server
End-User
Certification
MicrosoftSoftware
Microsoft Office User Specialist (MOUS)
WebMaster
Certification
Microsoft Official Curriculum (MOC)
Sysadmin
MicrosoftSoftware
Microsoft Open License Program (MOLP)
Sysadmin
Exchange
MicrosoftSoftware
Microsoft Outlook
End-User
Internet
Mail
MicrosoftSoftware
Microsoft Outlook Express
Sysadmin
WinNT
Microsoft Personal Web Server (PWS)
Sysadmin
BackOffice
Internet
Security
Microsoft Proxy Server
Sysadmin
Legacy
WinNT
Microsoft RAS Protocol
Sysadmin
Certification
Microsoft Sales Specialist
Sysadmin
Legacy
Mail
Microsoft Schedule+
Sysadmin
Exchange
Microsoft Schedule+ Free/Busy Connector
WebMaster
Internet
Programming
Win2000
WinNT
Microsoft Script Debugger
WebMaster
MicrosoftSoftware
Microsoft Seminar Online
Sysadmin
MicrosoftSoftware
Microsoft Site Server
Sysadmin
MicrosoftSoftware
Microsoft Site Server, Commerce Edition
Sysadmin
WinNT
Microsoft Site Server Express
Sysadmin
BackOffice
Mainframe
Microsoft SNA Server
Sysadmin
BackOffice
SQL
Microsoft SQL Server
Sysadmin
BackOffice
Microsoft Systems Management Server (SMS)
Sysadmin
MicrosoftSoftware
Resource
Microsoft TechNet
Sysadmin
Win2000
WinNT
Microsoft Transaction Server (MTS)
Sysadmin
MicrosoftSoftware
OS
Microsoft Windows
Programmer
MicrosoftSoftware
Microsoft Windows Distributed interNet Applications (DNA) Architecture
Sysadmin
Exchange
Migration Wizard
Sysadmin
Win2000
mirrored volume
Sysadmin
Security
WinNT
mirror set
Sysadmin
Win2000
mixed mode
Sysadmin
AdminTools
Win2000
WinNT
MMC console
Sysadmin
WinNT
M-node
Sysadmin
Telephony
Mobile Broadband System (MBS)
Sysadmin
Hardware
Telecommunications
modem
Sysadmin
Hardware
modem eliminator
Sysadmin
Engineering
modulation
Sysadmin
Win2000
WinNT
moving files
Sysadmin
Legacy
MicrosoftSoftware
OS
MS-DOS
End-User
Win95/98
MS-DOS mode
Sysadmin
Win2000
WinNT
MSMQ Enterprise
Sysadmin
WinNT
MSMQ Information Store (MQIS)
Programmer
Win2000
WinNT
MSMQ Routing Server
Sysadmin
Win2000
WinNT
MSMQ site
Sysadmin
Exchange
mtacheck
Sysadmin
Internet
Protocols
multicast DHCP (MDHCP)
Sysadmin
TCP/IP
multicasting
Sysadmin
LAN
multihoming
Sysadmin
Protocols
WAN
Multilink Point-to-Point Protocol (MPPP)
Sysadmin
Win2000
multimaster replication
Sysadmin
Hardware
multimode fiber-optic cabling
Sysadmin
Win2000
WinNT
multiple master domain model
Sysadmin
WinNT
multiple provider router (MPR)
Sysadmin
WinNT
Multiple UNC Provider (MUP)
Sysadmin
Mainframe
Multiple Virtual Storage (MVS)
Sysadmin
Hardware
multiplexer (MUX)
Sysadmin
Engineering
multiplexing
Sysadmin
Internet
Protocols
TCP/IP
Multiprotocol Label Switching (MPLS)
Sysadmin
Internet
Protocols
Multipurpose Internet Mail Extensions (MIME)
Sysadmin
Hardware
LAN
Multistation Access Unit (MAU)
Sysadmin
OS
multitasking
Sysadmin
Internet
Protocols
MX record
End-User
Win2000
Win95/98
WinNT
My Computer
End-User
Win2000
Win95/98
My Documents
End-User
SysAdmin
Win2000
My Network Places

N

Sysadmin
Internet
Protocols
TCP/IP
name lookup
Sysadmin
Internet
Protocols
TCP/IP
name server
Sysadmin
Internet
Protocols
TCP/IP
name server (NS) record
Sysadmin
Security
naming convention
Sysadmin
Standards
National Electric Code (NEC)
Sysadmin
Standards
National Institute of Standards and Technology (NIST)
Sysadmin
Engineering
LAN
near-end crosstalk (NEXT)
Sysadmin
LAN
Protocols
NetBEUI
Sysadmin
LAN
Protocols
WinNT
NetBEUI Frame (NBF)
Sysadmin
Protocols
NetBIOS
Sysadmin
Protocols
NetBIOS name
Sysadmin
Protocols
NetBIOS name resolution
Sysadmin
Protocols
Win2000
WinNT
NetBIOS Name Server (NBNS)
Sysadmin
Protocols
TCP/IP
NetBIOS over TCP/IP (NetBT)
Sysadmin
Protocols
TCP/IP
NetBIOS over TCP/IP node types
Sysadmin
Win2000
WinNT
net commands
Sysadmin
Protocols
NetWare protocols
WebMaster
Internet
Network Access Point (NAP)
WebMaster
Internet
network access server (NAS)
Sysadmin
Security
network address translation (NAT)
Sysadmin
WAN
Win2000
Win95/98
WinNT
Network and Dial-up Connections
Sysadmin
Protocols
Standards
network driver interface specification (NDIS)
Sysadmin
Unix
Network File System (NFS)
Sysadmin
Protocols
network ID
Sysadmin
Unix
Network Information System (NIS)
Sysadmin
Hardware
LAN
network interface card (NIC)
Sysadmin
Protocols
network layer
Sysadmin
Win2000
WinNT
Network Monitor
Sysadmin
Win95/98
WinNT
Network Neighborhood
Sysadmin
Internet
Protocols
Network News Transfer Protocol (NNTP)
Sysadmin
OS
network operating system (NOS)
Sysadmin
TCP/IP
networks file
Sysadmin
Hardware
Telecommunications
Network Termination Unit (NTU)
Sysadmin
Hardware
Standards
Next Generation I/O (NGIO)
Sysadmin
Security
normal backup
Sysadmin
NonMicrosoftSoftware
OS
Novell Directory Services (NDS)
Sysadmin
Security
Win2000
WinNT
NTFS file system
Sysadmin
Security
Win2000
NTFS permissions (Windows 2000)
Sysadmin
Security
WinNT
NTFS permissions (Windows NT)
Sysadmin
Security
Win2000
NTFS special permissions (Windows 2000)
Sysadmin
Security
WinNT
NTFS special permissions (Windows NT)
Sysadmin
WinNT
NT Virtual DOS Machine (NTVDM)
Sysadmin
Protocols
WinNT
NWLink IPX/SPX-Compatible Transport

O

Sysadmin
Security
Win2000
object in Active Directory
Sysadmin
Win2000
WinNT
object in Windows NT and Windows 2000
Programmer
MicrosoftSoftware
Programming
object linking and embedding (OLE)
Programmer
MicrosoftSoftware
Programming
OLE
Programmer
Programming
online analytical processing (OLAP)
Programmer
MicrosoftSoftware
Programming
open database connectivity (ODBC)
Sysadmin
Hardware
NonMicrosoftSoftware
Standards
Open Data-link Interface (ODI)
Sysadmin
Protocols
TCP/IP
Open Shortest Path First (OSPF) Protocol
Sysadmin
Protocols
Standards
Open Systems Interconnection (OSI) reference model
Sysadmin
Engineering
optical carrier (OC-x) levels
Sysadmin
Security
Win2000
organizational unit (OU)
Sysadmin
WAN
out-of-band management (OBM)
Sysadmin
Security
Win2000
WinNT
owner

P

Sysadmin
Hardware
Telecommunications
packet assembler/disassembler (PAD)
Sysadmin
LAN
Security
WAN
packet filtering
Sysadmin
LAN
WAN
packet-switching services
Sysadmin
Win2000
WinNT
paging file
Sysadmin
Engineering
parallel transmission
Sysadmin
Hardware
partition of a disk
Sysadmin
Security
WinNT
passfilt.dll
Sysadmin
Protocols
WAN
Password Authentication Protocol (PAP)
Sysadmin
Hardware
LAN
patch panel
Sysadmin
LAN
Win95/98
peer-to-peer network
Sysadmin
Win2000
WinNT
Performance Monitor
Sysadmin
Engineering
Telecommunications
WAN
permanent virtual circuit (PVC)
Sysadmin
Security
Win2000
WinNT
permissions
Sysadmin
BackOffice
Per Seat licensing
Sysadmin
BackOffice
Per Server licensing
Sysadmin
Telephony
Personal Communications Services (PCS)
Sysadmin
Hardware
Personal Digital Assistant (PDA)
Sysadmin
Protocols
physical layer
Sysadmin
Security
Standards
PKCS
Sysadmin
Security
Standards
PKCS #7
Sysadmin
Security
Standards
PKCS #12
Sysadmin
Telephony
Plain Old Telephone Service (POTS)
Sysadmin
Hardware
LAN
plenum cabling
Sysadmin
WinNT
P-node
Sysadmin
Internet
Protocols
pointer (PTR) record
WebMaster
Internet
point of presence (POP)
Sysadmin
Engineering
point-to-multipoint
Sysadmin
Engineering
point-to-point
Sysadmin
Protocols
WAN
Point-to-Point Protocol (PPP)
Sysadmin
Protocols
WAN
Point-to-Point Tunneling Protocol (PPTP)
Sysadmin
Hardware
LAN
polyvinyl chloride (PVC) cabling
Sysadmin
Unix
POSIX
Sysadmin
Internet
Protocols
Post Office Protocol version 3 (POP3)
Sysadmin
WinNT
potential browser
Sysadmin
Hardware
power-on self test (POST)
Sysadmin
Hardware
LAN
premise cabling
Sysadmin
Protocols
presentation layer
Sysadmin
Internet
Protocols
Security
Pretty Good Privacy (PGP)
Sysadmin
Security
WinNT
primary domain controller (PDC)
Sysadmin
BackOffice
primary enterprise controller (PEC)
Sysadmin
Internet
Protocols
primary name server
Sysadmin
Telecommunications
WAN
Primary Rate Interface ISDN (PRI-ISDN)
Sysadmin
LAN
primary ring
Sysadmin
BackOffice
primary site controller (PSC)
Sysadmin
MicrosoftSoftware
printing terminology
Sysadmin
Hardware
Telephony
Private Branch Exchange (PBX)
Sysadmin
LAN
Standards
WAN
Project 802
Sysadmin
Engineering
protocol
Sysadmin
TCP/IP
Win2000
WinNT
protocol file
Sysadmin
Internet
Protocols
Provider Architecture for Differentiated Services and Traffic Engineering (PASTE)
Sysadmin
LAN
Security
proxy server
Sysadmin
Protocols
Standards
P-series protocols
Sysadmin
Security
Standards
public key cryptography
Sysadmin
Security
public key infrastructure (PKI)
Sysadmin
Telephony
Public Switched Telephone Network (PSTN)
Sysadmin
Engineering
pulse code modulation (PCM)

Q

Sysadmin
Security
TCP/IP
Win2000
QoS Admission Control Service (QoS ACS)
Sysadmin
Protocols
Standards
Q-series protocols
Sysadmin
Protocols
quality of service (QoS)

R

Sysadmin
Hardware
rack
Sysadmin
Hardware
RAID
WebMaster
Standards
Recreational Software Advisory Council (RSAC)
Sysadmin
Internet
Protocols
recursive query
Sysadmin
Telecommunications
Regional Bell Operating Company (RBOC)
Sysadmin
Internet
Security
registration authority (RA)
Sysadmin
Win2000
Win95/98
WinNT
registry editor
End-User
Commands
Win2000
relative path
Sysadmin
Management
remote access
Sysadmin
WinNT
Remote Access Service (RAS)
Sysadmin
Protocols
Security
Remote Authentication Dial-In User Service (RADIUS)
Sysadmin
Hardware
LAN
WAN
remote bridge
Sysadmin
Security
remote client impersonation
Sysadmin
Protocols
Win2000
WinNT
Remote Desktop Protocol (RDP)
Sysadmin
Management
Protocols
Remote Network Monitoring (RMON)
Sysadmin
Programming
Win2000
WinNT
remote procedure call (RPC)
Sysadmin
Standards
Request for Comments (RFC)
Sysadmin
Security
WinNT
resource domain
Sysadmin
Other
resource on a network
Sysadmin
Internet
Protocols
resource record
Sysadmin
BackOffice
Security
reverse hosting
Sysadmin
Security
WinNT
rights
Sysadmin
LAN
ring topology
Sysadmin
Hardware
RJ connectors
Sysadmin
Win2000
WinNT
roaming user profile
Sysadmin
Hardware
LAN
WAN
router
Sysadmin
LAN
WAN
routing
Sysadmin
Engineering
LAN
WAN
routing algorithm
Sysadmin
Win2000
Routing and Remote Access
Sysadmin
WinNT
Routing and Remote Access Service (RRAS)
Sysadmin
Protocols
Routing Information Protocol (RIP)
Sysadmin
Protocols
routing protocol
Sysadmin
Hardware
Protocols
routing table
Sysadmin
Hardware
Standards
RS-232

S

Sysadmin
Hardware
SC and ST connectors
Sysadmin
Internet
Protocols
secondary name server
Sysadmin
LAN
secondary ring
Sysadmin
Win2000
WinNT
secure attention sequence (SAS)
Sysadmin
Internet
Protocols
Secure Hypertext Transfer Protocol (S-HTTP)
Sysadmin
Internet
Protocols
Secure/Multipurpose Internet Mail Extensions (S/MIME)
Sysadmin
Internet
Protocols
Secure Sockets Layer (SSL)
Sysadmin
Security
WinNT
Security Account Manager (SAM) database
Sysadmin
Security
Unix
Security Administrator Tool for Analyzing Networks (SATAN)
Sysadmin
Security
Win2000
WinNT
security identifier (SID)
Sysadmin
Security
Win2000
WinNT
security log
Sysadmin
Security
Win2000
WinNT
security subsystem
Sysadmin
Protocols
WAN
Serial Line Internet Protocol (SLIP)
Sysadmin
Engineering
serial transmission
Sysadmin
LAN
server-based network
Sysadmin
Security
server certificate
Sysadmin
Protocols
Server Message Block (SMB)
Sysadmin
Win2000
WinNT
Server service
Sysadmin
LAN
Protocols
Service Advertising Protocol (SAP)
Sysadmin
Other
service-level agreement (SLA)
Sysadmin
Win2000
WinNT
services file
Sysadmin
Protocols
session layer
Sysadmin
LAN
share
Sysadmin
Security
Win2000
Win95/98
WinNT
shared folder permissions
Sysadmin
Security
Win95/98
share-level security
Sysadmin
OS
Unix
shell
Sysadmin
Hardware
LAN
shielded twisted-pair (STP) cabling
Sysadmin
Engineering
Protocols
Shortest Path First (SPF)
Sysadmin
Telephony
Short Message Service (SMS)
Sysadmin
Engineering
signal
Sysadmin
Internet
Protocols
Simple Mail Transfer Protocol (SMTP)
Sysadmin
Protocols
TCP/IP
Simple Network Management Protocol (SNMP)
Sysadmin
Engineering
simplex
Sysadmin
Win2000
WinNT
single domain model
Sysadmin
Win2000
WinNT
single master domain model
Sysadmin
Hardware
Small Computer System Interface (SCSI)
Sysadmin
LAN
source address
Sysadmin
Engineering
LAN
spanning tree algorithm (STA)
Sysadmin
Security
Win2000
WinNT
special identity
Sysadmin
Engineering
spread spectrum
Sysadmin
SQL
SQL Security Manager
Sysadmin
SQL
SQL Server Agent
Sysadmin
SQL
SQL Server Profiler
Sysadmin
SQL
SQL Server Service Manager
Sysadmin
SQL
SQL Server tools
Sysadmin
LAN
star bus topology
Sysadmin
Internet
start of authority (SOA) record
Sysadmin
LAN
star topology
Sysadmin
Protocols
static routing
Sysadmin
Other
storage area network (SAN)
Sysadmin
Engineering
stranded conductor wire
Sysadmin
WinNT
stripe set
Programmer
SQL
Structured Query Language (SQL)
Sysadmin
TCP/IP
subnetting
Sysadmin
Hardware
switch
Sysadmin
Telecommunications
WAN
Switched Multimegabit Data Services (SMDS)
Sysadmin
Engineering
Telecommunications
WAN
switched virtual circuit (SVC)
Sysadmin
Telecommunications
Symmetric Digital Subscriber Line (SDSL)
Sysadmin
Mainframe
Protocols
Synchronous Data Link Control (SDLC)
Sysadmin
Telecommunications
WAN
Synchronous Optical Network (SONET)
Sysadmin
Engineering
synchronous transmission
Sysadmin
Security
Win2000
WinNT
system access control list (SACL)
Sysadmin
Exchange
System Attendant
Sysadmin
Security
Win2000
WinNT
system log
Sysadmin
Win95/98
System Monitor
Sysadmin
Win2000
WinNT
system partition
Sysadmin
WinNT
system policy
Sysadmin
BackOffice
Systems Management Server Database Manager
Sysadmin
BackOffice
Systems Management Server MIF Form Generator
Sysadmin
BackOffice
Systems Management Server Service Manager
Sysadmin
Mainframe
Protocols
Systems Network Architecture (SNA)

T

Sysadmin
Hardware
WAN
T1 channel bank
Sysadmin
Standards
T.120 standard
Sysadmin
Win2000
WinNT
taking ownership
End-User
Hardware
tape backup
Sysadmin
Win2000
WinNT
Task Manager
Sysadmin
Win2000
Task Scheduler
Sysadmin
Standards
Telecommunications
WAN
T-carrier
Sysadmin
LAN
Protocols
TCP/IP
TCP/IP
Sysadmin
Legacy
MicrosoftSoftware
TCP/IP-32 for Windows for Workgroups
Sysadmin
TCP/IP
TCP three-way handshake
Sysadmin
Telecommunications
Telephony
telco
Sysadmin
Standards
Telecommunications Industry Association (TIA)
Sysadmin
Telecommunications
telecommunications services
Sysadmin
MicrosoftSoftware
Standards
Telephony Application Programming Interface (TAPI)
Sysadmin
TCP/IP
telnet
Sysadmin
Mainframe
terminal
Sysadmin
Mainframe
MicrosoftSoftware
terminal emulator
Sysadmin
Mainframe
Unix
Win2000
terminal server
Sysadmin
Win2000
Terminal Services
Sysadmin
Hardware
terminator
Sysadmin
Telephony
Terrestrial Trunked Radio (Tetra)
Sysadmin
Hardware
test equipment
Sysadmin
TCP/IP
TFTP
Sysadmin
Hardware
LAN
thicknet
Sysadmin
Hardware
LAN
thinnet
Sysadmin
Security
Win2000
ticket
Sysadmin
Telephony
Time Division Multiple Access (TDMA)
Sysadmin
Engineering
time-division multiplexing (TDM)
Sysadmin
Engineering
time domain reflectometry (TDR)
Sysadmin
Mainframe
TN3270
Sysadmin
Mainframe
TN5250
Sysadmin
LAN
Token Ring
Sysadmin
Internet
Protocols
top-level domain
Sysadmin
LAN
WAN
topology
Sysadmin
TCP/IP
tracert
WebMaster
Programming
Win2000
WinNT
transaction
Sysadmin
Exchange
transaction log
Sysadmin
Hardware
transceiver
Sysadmin
Protocols
TCP/IP
Transmission Control Protocol (TCP)
Sysadmin
MicrosoftSoftware
Standards
Transport Driver Interface (TDI)
Sysadmin
Protocols
Standards
transport layer
Sysadmin
LAN
trunking
Sysadmin
Security
Win2000
WinNT
trust relationship
Sysadmin
Protocols
tunneling
Sysadmin
Hardware
Mainframe
twinax cabling
Sysadmin
Hardware
twisted-pair cabling
Sysadmin
Security
Win2000
two-way transitive trust

U

Sysadmin
Management
Win2000
WinNT
unattended installation
Sysadmin
Engineering
unbalanced line
WebMaster
Internet
Uniform Resource Locator (URL)
Sysadmin
Hardware
uninterruptible power supply (UPS)
Sysadmin
Management
Win2000
WinNT
Uniqueness Database File (UDF)
Sysadmin
Security
Win2000
universal group
Sysadmin
Standards
Telephony
Universal Mobile Telecommunications System (UMTS)
Sysadmin
Standards
Universal Naming Convention (UNC)
Sysadmin
Hardware
Standards
universal serial bus (USB)
Sysadmin
Standards
Telephony
Universal Wireless Communications (UWC-136)
Sysadmin
OS
Unix
UNIX
Sysadmin
Hardware
unshielded twisted-pair (UTP) cabling
Sysadmin
Win2000
update sequence number (USN)
WebMaster
Internet
Usenet
Sysadmin
Security
Win2000
WinNT
user account
Sysadmin
Protocols
TCP/IP
User Datagram Protocol (UDP)
Sysadmin
Security
Win95/98
user-level security
Sysadmin
Security
WinNT
User Manager for Domains
Sysadmin
Win2000
WinNT
user mode
Sysadmin
LAN
Security
WAN
username
Sysadmin
Security
Win2000
Win95/98
WinNT
user profile

V

Sysadmin
Standards
V.35
Sysadmin
Engineering
Telecommunications
virtual circuit
Sysadmin
LAN
virtual LAN (VLAN)
Sysadmin
Win2000
Win95/98
WinNT
virtual memory
Sysadmin
WAN
virtual private network (VPN)
Sysadmin
TCP/IP
Telephony
Voice over IP (VoIP)
Sysadmin
Internet
Protocols
voice profile for Internet mail (VPIM)
Sysadmin
Standards
V series

W

Sysadmin
WAN
WAN link
Sysadmin
Standards
Web-Based Enterprise Management (WBEM)
WebMaster
Internet
Web browser
WebMaster
Internet
MicrosoftSoftware
NonMicrosoftSoftware
Web server
Sysadmin
TCP/IP
well-known port numbers
Sysadmin
WAN
wide area network (WAN)
Sysadmin
Telephony
Wideband Code Division Multiple Access (W-CDMA)
Sysadmin
Legacy
MicrosoftSoftware
OS
Windows 3.1
Sysadmin
MicrosoftSoftware
OS
Win95/98
Windows 95
Sysadmin
Win2000
WinNT
Windows Backup
Sysadmin
Win2000
Windows Clustering
Sysadmin
Win2000
Win95/98
WinNT
Windows Explorer
Sysadmin
Legacy
MicrosoftSoftware
OS
Windows for Workgroups 3.11
Sysadmin
Win2000
WinNT
Windows Internet Name Service (WINS)
Sysadmin
Standards
Windows Management Instrumentation (WMI)
Sysadmin
MicrosoftSoftware
OS
WinNT
Windows NT
Sysadmin
Security
Win2000
WinNT
Windows NT Challenge/Response Authentication
Sysadmin
Commands
WinNT
Windows NT command
Sysadmin
WinNT
Windows NT executive
Sysadmin
AdminTools
Win2000
Win95/98
WinNT
Windows Script Host (WSH)
Sysadmin
Protocols
Windows Sockets
WebMaster
Internet
Protocols
WINS server
Sysadmin
Protocols
Telephony
Wireless Application Protocol (WAP)
Sysadmin
LAN
WAN
wireless networking
Sysadmin
LAN
workgroup
Sysadmin
Win2000
WinNT
working set
Sysadmin
Win2000
WinNT
Workstation service
WebMaster
Internet
World Wide Web (WWW)
Sysadmin
Internet
Standards
World Wide Web Consortium (W3C)

X

Sysadmin
Protocols
Telecommunications
WAN
X.25
Sysadmin
Hardware
x 86 platform
Sysadmin
Protocols
Telecommunications
WAN
X.121 address
Sysadmin
Mail
Standards
X.400
Sysadmin
Exchange
X.400 Connector
Sysadmin
Standards
X.500
Sysadmin
LAN
Protocols
Xerox Network Systems (XNS)
WebMaster
Internet
Protocols
XHTML
Programmer
Programming
XML
Sysadmin
Standards
X-series protocols
Sysadmin
Unix
X Window System

Y

Sysadmin
Hardware
Y-connector
Sysadmin
Hardware
Y-splitter

Z

Sysadmin
WinNT
Zero Administration Kit (ZAK)
Sysadmin
Internet
Protocols
zone


CHECKFRAME

Select Audience
End-User
Systems Administrator
Web Master
Programmer

Select Topics
AdminTools
BackOffice
Certification
Commands
Dial-Up
Engineering
Exchange
Hardware
Internet
IE
Jargon
LAN
Legacy
Mac
Mail
Mainframe
Management
MicrosoftSoftware
NonMicrosoftSoftware
OS
Other
PPP/PPTP
Protocols
Programming
Resource
Security
SQL
Standards
TCP/IP
Telecommunications
Telephony
Unix
WAN
Win2000
Win98/95
WinNT