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Introduction

Thank you for purchasing metaPackager from HiSoftware

PRIVATE ForeHelp xParaStyle ID=1418Welcome to metaPackager Professional by HiSoftware

PRIVATE ForeHelp xParaStyle ID=1417This program is designed to wrap files in XML (eXtensible Markup Language) metadata.  These electronic files can then be indexed, managed and archived much more easily, whether the goal is short term or long term record management.  The program also creates objects meeting the VERS (Victorian Electronic Records Strategy) specification PROS 99/007.  The VERS specification can be found at PRIVATE ForeHelp xCharStyle ID=1416http://www.prov.vic.gov.au/vers/welcome.htm.

PRIVATE ForeHelp xParaStyle ID=1415One great advantage of metaPackager and wrapping the file in metadata is that the file's metadata travels with the document, wherever the document is stored.  This eliminates cases where the file was indexed, but then was moved somewhere else and the index was never updated.  

PRIVATE ForeHelp xParaStyle ID=1414Another advantage to wrapping files in metadata is that it allows you to add metadata to files that natively do not support metadata.  Web developers and archivists have been adding metadata to HTML documents for years, but if you have thousands oPRIVATE ForeHelp Scaps value=-1f sound, video, executable, drawing or graphic files that do not support metadata, then indexing them becomes much easier if you can wrap the file in metadata, without destroying the original integrity of the document.

metaPackager is the industry’s first metadata software that allows you to use common practices such as rich metadata to catalog and archive files that do not have the ability to embed metadata; or where it is not advisable to do so because of frequent changes in standards.  metaPackager decreases Total Cost of Ownership (TCO) of your indexing and/or archiving systems by having document independence during the catalog and retrieval stages
PRIVATE ForeHelp xParaStyle ID=1413
PRIVATE ForeHelp xParaStyle ID=1412What you can do with metaPackager

PRIVATE ForeHelp xParaStyle ID=1362

PRIVATE ForeHelp xHotspot ID=16777630Create XML Packages where files are wrapped in XMLCreating_the_XML_Package
PRIVATE ForeHelp xParaStyle ID=1361

PRIVATE ForeHelp xHotspot ID=16777629Create XML Templates for package creationXML_Templates
PRIVATE ForeHelp xParaStyle ID=498

PRIVATE ForeHelp xHotspot ID=16777336Create multiple XML Packages in batch modeBatch_Processing
PRIVATE ForeHelp xParaStyle ID=1360

PRIVATE ForeHelp xHotspot ID=16777628Create VERS Encapsulated Object RecordsCreating_a_new_VERS_Encapsulated_Object_Package
PRIVATE ForeHelp xParaStyle ID=1359

PRIVATE ForeHelp xHotspot ID=16777627Create VERS Encapsulated Object FilesCreating_a_new_VERS_VEO_File
PRIVATE ForeHelp xParaStyle ID=1358

PRIVATE ForeHelp xHotspot ID=16777626Create Templates for VERS Encapsulated ObjectsCreating_an_New_VERS_Template
PRIVATE ForeHelp xParaStyle ID=1357

PRIVATE ForeHelp xHotspot ID=16777625Extract the files from the XML and VERS Packages

 

Easily Create Metadata 

· Using the metaPackagerTM wizard interface, you add page properties, site properties, and all other search related metadata.   

· The metaPackagerTM  allows you to add custom metadata schemas.

· You can wrap 1 or 100 pages in seconds with the click of a button. 

· Batch processing is supported for all metadata elements

· Update documents with intellectual property specific elements.  Select your entire web site document collection and apply information like publisher, author, company, and copyright statement, as well as copyright tag.

· Update documents with site-specific default elements.  Select your entire document collection and apply information like expiration, archive, reply-to, and/or other controlled vocabulary.

Add Customized Metadata and Properties

· With metaPackager, you can add customized metadata schemas for specific search engines / document management systems, schemas for your corporate intranet or schemas for your web site.  The custom metadata schema generator allows you to easily create metadata element groupings or to derive a new group from an existing group. 

· The program includes the standard recognized schemas: GILS, WAGILS, Dublin Core, Publish, aGils, and IMS.

· metaPackager includes a base template from which you can derive new schemas.

· The grid base (similar to Microsoft® Excel® Spreadsheet) stores element names and allows you to set up system default values for the elements.

· The end user can create the custom schema and then protect the names of the elements from being overwritten while allowing the values to be edited.

· The value cells automatically grow as needed during data entry so you can see everything that you are typing in.

· The end user can use the Special Controlled Vocabulary Tree View Builder to build custom Tree based controlled vocabularies.

· Unlimited custom support to meet all of your metadata needs 

Extract_Files
HiSoftware Product Support

Hiawatha Island Software Company is committed to providing the best possible technical support for all of our products.  To get you the fastest and most complete support we ask that you follow the support guidelines.

The HiSoftware web site, http://www.hisoftware.com, is the fastest and most efficient way to find information.  The site contains product information, technical support questions and answers (FAQ’s), maintenance files, and contact information.

The HiSoftware web server is always available 24 hours a day, 7 days a week, 365 days a year.  In addition, the site provides you with many different ways to correspond with us directly.  If you need additional support, please send your questions to support@hisoftware.com.

Registering Your Software

Completion of the HiSoftware product registration form ensures you are eligible for the benefits available to registered users, such as special offers, updates, and exclusive HiSoftware product information.  By registering, you can also access via e-mail our superior technical support staff free for thirty days to help you will any installation issues and for as long as you are using the product.

· You can register via the Internet by visiting http://www.hisoftware.com/register.htm
· You can fill out the registration form included with your product and fax it to Hiawatha Island Software Company, (603) 223-9741.

· Remember - Registering your software lets us know where to send your maintenance releases and other important information. 

Necessary Information for Technical Support
The technical support department at HiSoftware likes to provide detailed and accurate answers to all of your questions.  To do so, our representatives will need the following information:

· Your full name and the name of the registered user, if different,

· Your street address, phone and fax number, and email address,

· The product number of your software,

· The software version number,  (This can be found in the About box, which you can quickly open by running the program and clicking the About selection from the Help menu.)

· The system information of the computer you are using,  (Make and model of the machine, video driver, operating system, amount of memory and system resources, and any relevant devices you are using.)

· A detailed description of the problem  (Describe any error messages exactly as they appear.  Please list also the steps and conditions that led to the problem.)

For your convenience and to give you the quickest and best technical support, we have included an online technical support request form you can use quickly to organize the information we need.  To access it, go to http://www.hisoftware.com/supreq.htm.  If you cannot access the HiSoftware web site, you can email all of the necessary information previously listed to support@hisoftware.com.

The Best Ways to Contact Technical Support

Because of the amount of information our technical support department needs, and because finding answers may require some research on our part, calling is often the least effective method of getting technical support.  We recommend the following methods as the quickest and best ways to get the answers you need:

1. Product Documentation

Before you spend the time gathering information, contacting HiSoftware, and waiting for a response, make sure that the answer to your question is not in the product documentation.  Take advantage of our help files.  Documentation can be found at http://www.hisoftware.com/doccentral/doccentral.htm.

2. Internet

Keep informed of all the late breaking information relating to your product by consulting the HiSoftware Web site at http://www.hisoftware.com.  This area is constantly updated with news and notes.  If you have questions about your product, you might save yourself time by checking the HiSoftware web site for the answer.

The product FAQ's contain the answers to many of the commonly asked question that users like you have.  The FAQ's is the site where any new information regarding the use of your product that does not appear in the printed documentation will appear.  The information you need to continue is instantly accessible, 24 hours a day. The FAQ's are located in the technical support area of the HiSoftware web site.

3. Email

Once you have determined that neither the product documentation nor the HiSoftware web site contains the answer you need, the best way to contact the technical support department is through email.  Our address is support@hisoftware.com.

4. Fax

Faxing is the next most efficient means of contacting us.  Our technical support fax number is (603) 223-9741.

Contacting Hiawatha Island Software Company
	Support via Internet or Email


	HiSoftware WWW Site
	http://www.hisoftware.com

	Technical Support via email
	support@hisoftware.com

	Suggestions for future improvements
	http://www.hisoftware.com/register.htm


	Technical Support


	Email
	support@hisoftware.com

	Fax requests for technical support
	(603) 223-9741

	Mail requests for technical support
	HiSoftware

6 Chenell Drive

Concord, NH 03301


	Sales, Marketing and Licensing


	Call either number to order or request information about all HiSoftware products
	Phone     (888) 272-2484

               (603) 229-3055
FAX        (603) 223-9741

Email      info@hisoftware.com
Address  HiSoftware

               6 Chenell Drive

               Concord, NH 03301, USA


Installation

This installation section will walk you through the systematic installation of the HiSoftware metaPackager™.

System Requirements

Please check that the system on which you will be installing the HiSoftware metaPackager™ meets the following requirements:

	Computer
	IBM or Compatible 486 or Higher

(Intel Pentium II or compatible recommended)


	Operating System
	Windows 95, Windows 98 or Windows Millennium, Windows NT 4.0, (Service Pack three or later) or Windows 2000


	RAM
	At least 8 megabytes above the minimum amount required by the operating system.


	Hard Disk Drive
	20 Megabytes for installation




How We Install…

· The HiSoftware metaPackager™ runs a responsible installation on your windows system.  This means that the installation complies with Microsoft standards relating to the addition and removal of files.   

· HiSoftware uses the Windows Installer from Microsoft to install the software.

· HiSoftware will not remove any core system files upon which Windows depends 

· HiSoftware will not remove or update a system file with an older version

· HiSoftware will not remove data created by the program when performing an Uninstall

· HiSoftware will provide an uninstall program via the Control Panel Add/Remove Programs feature.

Directory Structure

The default directory for installation is Program Files\HISC\metaPackager.  For most users, the Program Files folder is located on the C: drive.  The software is installed into this directory and subdirectories of it:

	Directory
	Files

	HISC\metaPackager
	Application files, Help files, readme for metaPackager

	HISC\metaPackager\data
	Controlled vocabulary files

	HISC\metaPackager\list temp
	Location for temporary files

	HISC\metaPackager \Lists
	Location of stored lists used in Step 2

	HISC\metaPackager\Profiles
	Location of the metaPackager profile files

	HISC\metaPackager \Save
	Location for saved keyword and description files

	HISC\metaPackager \ Schemas
	Location of schemas


Install Check List

Please make sure that you have checked all items available from the list below before starting your install.

· Installation license code is available (Not required for CD Install)

· If on Windows NT or Windows 2000, Administrator’s rights

· Close all other programs that are running (Highly Recommended)

· Uninstall any previous versions of metaPackager™.

Performing Installation for File Downloaded from the Web

1. On the Web, find the web page for downloading the HiSoftware product you selected.  Use the site indicated by your order receipt.  At the site, click the link you require to download the product you are looking for.

2. In the File Download dialog box, click Save this program to disk and save the file on your hard drive.

3. On your hard drive, find the file you downloaded.  Double-click on the application file you downloaded. 
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4. If you are not installing the trial, you will need to enter your password in the next step and then select the Next button.
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5. Click on the Next button in the Welcome window.
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6. You will now be prompted for a destination directory for the installation files (not the actual installation program).  Since these are your installation files, HiSoftware recommends that you back them up just as you would any other important files on your system.

7. Click on the Finish button to accept the default or click on the Browse button to change the directory and then click the Finish Button.   

You are now ready to install the product.

Installation Steps from CD-ROM or Extracted Web File:

1. If installing from a CD-ROM, run the Setup.exe program located on the root of the CD-ROM.  This will start automatically when you insert the CD-ROM into a running computer.

The first step the installation program does is check if the Windows Installer is present on the system.  If the Windows Installer is not present on the system, or if the existing version is older, then the newer version (version 1.1) will be installed on the system.  The Windows Installer is a new program from Microsoft that handles program installation.  It is included as part of Windows 2000, and is offered as an add-in pack for Windows 95/98/NT4.  HiSoftware installs now include the Windows Installer for those users who do not have it.  This installation transparently handles the installation of the Windows Installer in addition to the program.

A small number of users may be prompted for a reboot during installation.  This occurs because the installation program detected an older version of the Windows Installer and is performing an upgrade of that service, or some files the Windows Installer needs were in use at the time.  For those systems requiring a reboot, the HiSoftware product installation will continue after the system reboots.  For more information on the Windows Installer, please visit http://www.hisoftware.com/windowsinstaller.htm
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The above screenshot represents one of the screens visible while the Windows Installer prepares to install.

2. After the Windows Installer has performed its pre-setup tasks, it presents you with the Welcome screen.  Click on the Next button to continue.
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3. The installation presents the license agreement next.
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4. Carefully read the license agreement.  If you accept the terms of the License Agreement, select the I accept the terms in the license agreement option then click Next.  If you do not accept the terms of the License Agreement, select I do not accept the terms in the license agreement option, then click Next to exit the installation program. 

5. Next, the customer information screen is displayed.  Enter your name and organization and select the Next button.
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6. The Setup Type screen then appears.

Either select Default to install the program accepting the default installation path chosen by the Windows Installer or select Custom to modify this path.  

When done, select the Next button.
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7. If you selected Custom, the screen below will appear.  The default installation path will be shown in the lower left corner.  To modify the path, select the Change button in the lower right corner.
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8. The installation is now waiting for user confirmation prior to installing.  Select the Install button to begin installation.
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9. When the installation has completed, select the Finish button.
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Starting metaPackager

To start metaPackager, select the HiSoftware metaPackager program group from the Windows Start menu.  From there, select the metaPackager Pro shortcut.  metaPackager now opens to the Normal tab.
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PRIVATE ForeHelp xParaStyle ID=1355About the User Interface

PRIVATE ForeHelp xParaStyle ID=1354The metaPackager Graphical User Interface should be familiar to most Windows Users.

PRIVATE ForeHelp xParaStyle ID=1353At the top of the interface is a menu system common to almost all Windows programs.  

PRIVATE ForeHelp xParaStyle ID=1352Below the menu is a toolbar where many commonly used commands are available by selecting the button on the toolbar.  Placing the mouse over each button reveals a hint with the button name.

PRIVATE ForeHelp xParaStyle ID=1447There is a tab control at the lower left corner of the program.  These tabs control access to the five main screens.  

· PRIVATE ForeHelp xParaStyle ID=1596The Normal tab is used when PRIVATE ForeHelp xHotspot ID=16777624creating XML PackagesCreating_the_XML_Package.

· PRIVATE ForeHelp xParaStyle ID=1597The Structure tab is a standard XML tree view used for creating the VERS packages.  This can also be used for creating the XML Packages.

· PRIVATE ForeHelp xParaStyle ID=1533The Source tab shows the XML data that will wrap or enclose the files that you are packaging.  This tab is for reference use only.

· PRIVATE ForeHelp xParaStyle ID=1514The DTD tag is used to show the Document Type Definition for the package that was created.  This tab is for reference use only.  It describes the rules that the package was created using.   metaPackager comes with two DTDs, the HiSoftware DTD and the VERS DTD.

· PRIVATE ForeHelp xParaStyle ID=1624The Processing tab is used when processing packagesBatch_Processing to give a report of the files processed.  This tab is for reference too.

Preferences – Setting General Preferences

To modify program preferences, select Preferences from the File menu.  The following screen appears.
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PRIVATE ForeHelp xParaStyle ID=1764
PRIVATE ForeHelp xParaStyle ID=488

PRIVATE ForeHelp Scaps value=0The General tab allows the end user to set the file paths where the packages will be created and extracted to.

PRIVATE ForeHelp xParaStyle ID=479Package Build Path
PRIVATE ForeHelp xParaStyle ID=480The Package Build Path sets the location where packages created with metaPackager will be placed.   The default setting is a subdirectory of the metaPackager installation called xmlexport.   This path can easily be changed by selecting the directory chooser control to the right of this field and navigating through your local and networked drives in the Select a Folder window to choose a suitable folder.  When you have selected a folder, click on the OK button.   If you are selecting a networked drive to create your packages to, make sure you have WRITE access to that location.  If you do not have permissions to write to the folder or directory on the network, the program will not create packages to it.  If you are unsure about your access permissions to the network, please contact your network administrator.

PRIVATE ForeHelp xParaStyle ID=481
PRIVATE ForeHelp xParaStyle ID=483Package File Extraction
PRIVATE ForeHelp xParaStyle ID=484The Package File Extraction sets the location where packages extracted with metaPackager will be placed.   The default setting here is a subdirectory of the metaPackager installation called extract.   This path can easily be changed by selecting the directory chooser control to the right of this field and navigating through your local and networked drives in the Select a Folder window to choose a suitable folder.  When you have selected a folder, click on the OK button.   Selecting the Show File Selection dialog when extracting files checkbox allows you to see which files are in the package you are extracting.  You can then add or remove files from the extraction at that time.  If you are selecting a networked drive to extract your packages to, make sure you have WRITE access to that location.  If you do not have permissions to write to the folder or directory on the network, the program will not create packages to it.  If you are unsure about your access permissions to the network, please contact your network administrator.

PRIVATE ForeHelp xParaStyle ID=1389
Use folder names when extracting

Selecting the Use folder names when extracting checkbox uses the original folder location to the files and appends this information to the extract path for the files.

For example:  You make a package with two files.  One file is located at C:\temp and is named readme.txt.  The second file is named histats.exe and is located at C:\Program Files\HISC\histats.  You extract these files from your XML Package to the C:\temp2 directory on your system.  If you select the Use folder names when extracting checkbox, upon extracting, you will have the following files: C:\temp2\temp\readme.txt and C:\temp2\Program Files\HISC\histats\histats.exe  If you did not have the Use folder names when extracting checkbox selected, you would have these two files: C:\temp2\readme.txt and C:\temp2\histats.exe.

Selecting the Use folder names when extracting checkbox is recommended when you may duplicate file names in a package.  For example, adding multiple directories to a package where each directory might have a readme.txt file in it.

Preferences___VERS_Encapsulated_Object
PRIVATE ForeHelp xParaStyle ID=422

PRIVATE ForeHelp xTopic ID=33554473Preferences – Setting XML Packages Preferences
PRIVATE ForeHelp xParaStyle ID=475
PRIVATE ForeHelp xParaStyle ID=527

PRIVATE ForeHelp Scaps value=0The XML Packages tab in the preferences window allows the user to set options related to the creation of the XML Packages.  These settings do not apply to users creating VERS Encapsulated Objects.

To modify program preferences, select Preferences from the File menu.  Select the XML Packages tab.  The following screen appears.
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PRIVATE ForeHelp xParaStyle ID=474
PRIVATE ForeHelp xParaStyle ID=473Default Template File

PRIVATE ForeHelp xParaStyle ID=472The Default Template File is used as a template for creating new packages.  The default selection is the template provided by HiSoftware called xmlpkg.xmlt.  Templates are normally stored in the templates subfolder of the metaPackager installation.  This path can easily be changed by selecting the directory chooser control to the right of this field and navigating through your local and networked drives in the Select a Folder window to choose a suitable folder.  When you have selected a folder, click on the OK button.

PRIVATE ForeHelp xParaStyle ID=471You can also create your own templates.  Please see the help topic for creating new templates.

PRIVATE ForeHelp xParaStyle ID=470
PRIVATE ForeHelp xParaStyle ID=469Special meta tag settings

PRIVATE ForeHelp xParaStyle ID=456The Custom Subject Meta Name field allows the user to change the name of the Custom Subject meta tag.  This tag is located at the top of the Normal tab when the program is opened.  By default, the Custom Subject meta tag will place a tag in the package such as follows:
PRIVATE ForeHelp xParaStyle ID=512<meta name = “subject” content = “your tag value or content goes here”/>

PRIVATE ForeHelp xParaStyle ID=513By changing the Custom Subject meta name, you could make the tag say:

PRIVATE ForeHelp xParaStyle ID=514<meta name = “mynewsubject” content = “your tag value or content goes here”/>

PRIVATE ForeHelp xParaStyle ID=515
PRIVATE ForeHelp xParaStyle ID=516Change display name to meta name
PRIVATE ForeHelp xParaStyle ID=517By selecting the Change display name to meta name, you can not only change the meta tag value that is added to the package, but you can change the name of the value that appears in the Graphical User Interface.  You may not want to select this checkbox if you have a very long name for the meta name aPRIVATE ForeHelp Scaps value=-1s this distorts the value presented in the Graphical User Interface of metaPackager.

PRIVATE ForeHelp xParaStyle ID=518

PRIVATE ForeHelp xParaStyle ID=519
PRIVATE ForeHelp xParaStyle ID=520Conversion of packages created with a previous version of metaPackager

PRIVATE ForeHelp xParaStyle ID=521This section of the Preferences is for users of previous versions of metaPackager (versions 1.0 and 1.1)

PRIVATE ForeHelp xParaStyle ID=522Automatically convert old packagers when opening  

PRIVATE ForeHelp xParaStyle ID=523By selecting this checkbox, you do not receive messages regarding metaPackager converting the old packages to the new format.

PRIVATE ForeHelp xParaStyle ID=524
PRIVATE ForeHelp xParaStyle ID=525Keep backup copy of the original package

PRIVATE ForeHelp xParaStyle ID=526Selecting this checkbox keeps a backup copy of the packages created with a previous version of metaPackager.
PRIVATE ForeHelp xParaStyle ID=425PRIVATE ForeHelp xTopic ID=33554475Preferences – Setting VERS Encapsulated Object Preferences
PRIVATE ForeHelp xParaStyle ID=528
PRIVATE ForeHelp xParaStyle ID=510

PRIVATE ForeHelp Scaps value=0The VERS Encapsulated Object tab in the preferences window allows the user to set options related to the creation of the VERS Encapsulated Object.  These settings do not apply to users creating XML Packages.

PRIVATE ForeHelp xParaStyle ID=501The VERS specification can be found at PRIVATE ForeHelp xCharStyle ID=500http://www.prov.vic.gov.au/vers/welcome.htm.

To modify program preferences, select Preferences from the File menu.  Select the VERS Encapsulated Object tab.  The following screen appears.
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PRIVATE ForeHelp xParaStyle ID=499

PRIVATE ForeHelp Scaps value=-1
PRIVATE ForeHelp xParaStyle ID=508

PRIVATE ForeHelp Scaps value=0Default Template File

PRIVATE ForeHelp xParaStyle ID=1607The Default Template File is used as a template for creating new packages.  The default selection is the template provided by HiSoftware for VERS is called versrec.xmlt.  Templates are normally stored in the templates subfolder of the metaPackager installation.  This path can easily be changed by selecting the directory chooser control to the right of this field and navigating through your local and networked drives in the Select a Folder window to choose a suitable folder.  When you have selected a folder, click on the OK button.
PRIVATE ForeHelp xParaStyle ID=1608You can also create your own templates.  Please see the help topic for creating new templates.

PRIVATE ForeHelp xParaStyle ID=1609
PRIVATE ForeHelp xParaStyle ID=1610XML Namespace Attribute Values

· PRIVATE ForeHelp xParaStyle ID=1735xmlns:vers
  Enter a value for the XML Namespace conforming to VERS (Victorian Electronic Records Strategy)

· PRIVATE ForeHelp xParaStyle ID=1661xmlns:naa
  Enter a value for the XML Namespace conforming to the NAA (National Archives of Australia) format 

PRIVATE ForeHelp xParaStyle ID=1613
PRIVATE ForeHelp xParaStyle ID=1614
PRIVATE ForeHelp xParaStyle ID=1615DTD  (Document Type Definition)

PRIVATE ForeHelp xParaStyle ID=1616Enter the URIs for the Public and System Identifiers

· PRIVATE ForeHelp xParaStyle ID=1662Public Identifier URI

· PRIVATE ForeHelp xParaStyle ID=1663System Identifier URI

Creating XML Packages

PRIVATE ForeHelp xParaStyle ID=842
PRIVATE ForeHelp xParaStyle ID=630PRIVATE ForeHelp Scaps value=0metaPackager allows you to create XML Packages, (files wrapped with XML data).  Creating the package consists of three parts:  Creating the package, adding files to the package and then building the package.
PRIVATE ForeHelp xParaStyle ID=695PRIVATE ForeHelp Scaps value=-1
1. PRIVATE ForeHelp xParaStyle ID=1519From the File menu, select New and then select XML Package.  The Create New File window appears.  Make sure that the Create Package option is selected and not the Create Template option.
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2. PRIVATE ForeHelp xParaStyle ID=799Confirm that the template file displayed in the Template File path is the template you want to use.  Unless you have created a new template file to meet your specific needs, the default template will be fine.

3. PRIVATE ForeHelp xParaStyle ID=800Select the OK button.  You have now created the base for your package.  

PRIVATE ForeHelp xParaStyle ID=759
PRIVATE ForeHelp xParaStyle ID=760
PRIVATE ForeHelp xParaStyle ID=761

PRIVATE ForeHelp xTarget ID=33554629Adding metadata to the XML Package using the Custom Subject feature

There are two ways to add metadata to the XML Package.  One is through the Custom Subject tag, and the other is through the Package Meta tags grid.
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PRIVATE ForeHelp xParaStyle ID=1727Custom Subject Tag

PRIVATE ForeHelp xParaStyle ID=1685The Custom Subject tag is a tag that is integrated into the controlled vocabulary feature of metaPackager.  This tag uses a tree style controlled vocabulary.  PRIVATE ForeHelp xParaStyle ID=1674The Custom Subject tag is essentially a Meta tag whose name can be changed and whose Meta tag values are obtained from a HiSoftware Tree File, or another custom tree file of your choice.
PRIVATE ForeHelp xParaStyle ID=1673
PRIVATE ForeHelp xParaStyle ID=1672To change the Meta tag name of the Custom Subject Tag, select Preferences from the File menu of metaPackager.  Select the XML Packages tab.  Enter a new name in the Custom Subject Meta Name field.  Select the OK button when done.

PRIVATE ForeHelp xParaStyle ID=1671
PRIVATE ForeHelp xParaStyle ID=1670Using the Custom Subjects tag

PRIVATE ForeHelp xParaStyle ID=1669To enter a Meta tag value for the Custom Subject tag, enter a value in the field for that tag.
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PRIVATE ForeHelp xParaStyle ID=1668You may also click the Select Subjects button to the right of the field to select a value from a controlled vocabulary.
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PRIVATE ForeHelp xParaStyle ID=1667When the Select Subjects button appears, select a controlled vocabulary list using the top menu and then navigate though the tree view to the value you wish.
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PRIVATE ForeHelp xParaStyle ID=1666Double click on the value and then select the Add button.

PRIVATE ForeHelp xParaStyle ID=1665
The value selected from the tree now appears in the Custom Subject field.
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Note:  By default, the Custom Subject tag uses the meta tag name subject.  I.E.  meta name = “subject” content = “your content goes here”

This meta name can be changed in the program preferences to be a name other than subject.  Please see the help previous to the section regarding changing of program preferences.

PRIVATE ForeHelp xParaStyle ID=1762
PRIVATE ForeHelp xParaStyle ID=1728Adding metadata using the Package Meta tags and schemas

 In the main screen of metaPackager when the normal tab is selected, there is a grid.  In this grid are meta tag properties that can be added.  The meta tag name represents the name of the meta tag while the meta tag value represents the value for these tags that you are entering.
PRIVATE ForeHelp xParaStyle ID=763Most meta tags can be grouped into schemas (collections of tags).   metaPackager comes with several PRIVATE ForeHelp xHotspot ID=16777419schemasSchemas with collections of meta tags from different document management groups and organizations.  You can switch between the schemas by selecting the Select Schema drop down menu and choose a different schema.
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PRIVATE ForeHelp xParaStyle ID=764To add metadata to your package:

1. PRIVATE ForeHelp xParaStyle ID=803Pick a schema using the Select Schema menu option located at the top right of the Normal tab.

2. PRIVATE ForeHelp xParaStyle ID=802Enter content for the meta tags that you want to have values in your schema.

3. PRIVATE ForeHelp xParaStyle ID=808Select the Apply Changes button.PRIVATE ForeHelp Scaps value=0

PRIVATE ForeHelp Scaps value=-1
PRIVATE ForeHelp xParaStyle ID=1681
PRIVATE ForeHelp xParaStyle ID=1766Using Package Metatags
PRIVATE ForeHelp xParaStyle ID=1767The names of your meta tags are entered in the Meta Tag Name columns, while the values of your tags are entered in the Meta Tag values columns.
PRIVATE ForeHelp xParaStyle ID=1768For example, if you wanted to Meta tag name to be “State” and your value to be “New Hampshire”, you would enter State in the Meta Tag name column and New Hampshire in the Meta Tag Value column.  The resulting tag placed in the package would look like the one below.

PRIVATE ForeHelp xParaStyle ID=1769<meta name = “state” content = “New Hampshire”/>

PRIVATE ForeHelp xParaStyle ID=1770
PRIVATE ForeHelp xParaStyle ID=1771Navigation:

PRIVATE ForeHelp xParaStyle ID=1772Use your TAB key on the keyboard to traverse through the values and names in the table.  To add additional rows, select the cell located in the last row of the Meta Tag Value column.  Use the + and – buttons to add and delete rows.
PRIVATE ForeHelp xParaStyle ID=1773

PRIVATE ForeHelp xParaStyle ID=1774To create a new Meta data element schema (Set of tags):

1. PRIVATE ForeHelp xParaStyle ID=1775Select BASE in the Select Schema menu.

2. PRIVATE ForeHelp xParaStyle ID=1776Add values as required by pressing the + button in the middle of the window while the cursor is placed in the last row in the Values column.

3. PRIVATE ForeHelp xParaStyle ID=1777When you have completed your list of Meta Tag Names type over the schema name value in the drop down box and click on the Save button.  The new schema is now selectable in the drop down list.

PRIVATE ForeHelp xParaStyle ID=1778
PRIVATE ForeHelp xParaStyle ID=1779To delete a blank row from a schema

1. PRIVATE ForeHelp xParaStyle ID=1805Clear the name and column values for that row
2. PRIVATE ForeHelp xParaStyle ID=1807Click on the Save button.
PRIVATE ForeHelp xParaStyle ID=1782
PRIVATE ForeHelp xParaStyle ID=1783Protecting the Meta Tag name:
PRIVATE ForeHelp xParaStyle ID=1784Select the Protect Name checkbox to make the name field READ ONLY.  This prevents the user from accidentally deleting or changing a name.

PRIVATE ForeHelp xParaStyle ID=1785
PRIVATE ForeHelp xParaStyle ID=1786Viewing the fields MULTI Line:
PRIVATE ForeHelp xParaStyle ID=1787Selecting the Multi-Line checkbox will dynamically adjust the size of the individual rows.  

PRIVATE ForeHelp xParaStyle ID=1788
PRIVATE ForeHelp xParaStyle ID=1789Auto Sizing Columns
PRIVATE ForeHelp xParaStyle ID=1790Selecting the Auto Size checkbox will dynamically adjust the width of the columns to match the width of the content.  It will also add a horizontal scrollbar if needed.

PRIVATE ForeHelp xParaStyle ID=1791
PRIVATE ForeHelp xParaStyle ID=1792Renaming a schema

1. PRIVATE ForeHelp xParaStyle ID=1751Select the schema you want to rename in the Select Schema menu at the top right corner of the step.

2. PRIVATE ForeHelp xParaStyle ID=1750Type over the existing text in the Select Schema menu, replacing the existing name with the new name.

3. PRIVATE ForeHelp xParaStyle ID=1745Select the Save button in the toolbar at the bottom of the screen.

PRIVATE ForeHelp xParaStyle ID=1747
PRIVATE ForeHelp xParaStyle ID=1796Making the Meta Tag Value column use a listing of values

PRIVATE ForeHelp xParaStyle ID=1797You can make the Meta Tag Value column use a listing of values from a drop down menu or a calendar control.  Please see the section of the Custom Field Editor.

PRIVATE ForeHelp xParaStyle ID=1798
PRIVATE ForeHelp xParaStyle ID=1799Deleting values for the schemes

PRIVATE ForeHelp xParaStyle ID=1800There is a button above the schema to the right of the + and - buttons that looks like a pencil eraser.  This Clear All button has a menu that allows you to either clear the cell value currently selected or to clear all values currently selected.

PRIVATE ForeHelp xParaStyle ID=1801Clearing values created with the PRIVATE ForeHelp xHotspot ID=16777667Custom Field EditorCustom_Field_Editor:  When you have created custom values with the Custom Field Editor, you may have some difficulty deleting a date created with the calendar control using the Clear All Values button in the Normal Tab.  If this happens, you need to click to the Meta tag name column to the left of the calendar control value and then select the Clear All Values or Clear Current Value option to remove it.  If you have clicked in the cell for that has the calendar control, you need to click out of that cell and into another in order to delete the calendar control from it. 

PRIVATE ForeHelp xParaStyle ID=771
PRIVATE ForeHelp xParaStyle ID=772
PRIVATE ForeHelp xParaStyle ID=773Adding Files to the XML Package
PRIVATE ForeHelp xParaStyle ID=774Once the XML Package has been created, you need to add files (documents) to the package.  These files can be text files, images, multi-media, etc.   You can add more than one file to the package.
Depending on your application, you may want to add several files to one package, or make a separate file or each file.  This choice is left up to the end user.  One example of when you may want to add several files one package is if you are working on a project where there are two written documents, six images and one sound clip.  With these, you always want the files to stay together and therefore want them to stay in the same package.

PRIVATE ForeHelp xParaStyle ID=775To add a file or grouping files:

1. PRIVATE ForeHelp xParaStyle ID=805Select Add File(s) from the File menu.  A standard Windows Open dialog box appears. 
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2. PRIVATE ForeHelp xParaStyle ID=806Navigate through your local or networked file system and select the files that you want to add.  You can select more than one file at once by holding the CTRL key down on the keyboard while selecting files with the left mouse button.  You can select a sequence of files by selecting the first file in the sequence, holding the SHIFT key down on the keyboard and then selecting the last file in the sequence.

3. PRIVATE ForeHelp xParaStyle ID=809You can add all files within a directory, but you cannot add the directory itself.  If you want to then add files from a second directory, repeat the previous step, this time selecting the files from the second directory.

4. PRIVATE ForeHelp xParaStyle ID=810The list of files selected appears in the screen below the main meta tag grid.  This screen can be hidden and made visible by clicking on the hot bar.  The hot bar appears similar to a window shade.  Clicking on the hot bar control opens and closes the Included Files window at the bottom of the normal tab.
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5. PRIVATE ForeHelp xParaStyle ID=811If you wish to remove a file from a package, select the Remove File option from the File menu.

PRIVATE ForeHelp xParaStyle ID=780
PRIVATE ForeHelp xParaStyle ID=781Adding metadata to the individual files in the XML Package 

metaPackager allows you to not just add metadata to the package, but to also add metadata to the files in the package.  This metadata for the files can be the same as or different then the package itself.  If the files do not have metadata, it is assumed that they share the same metadata as the package itself.

PRIVATE ForeHelp xParaStyle ID=782To add metadata to the files:

1. PRIVATE ForeHelp xParaStyle ID=812Select the file in the Included Files window.

2. PRIVATE ForeHelp xParaStyle ID=813Either double click with the left mouse button or right click and select the Edit File Metadata option to open the Document Metadata manager.

3. PRIVATE ForeHelp xParaStyle ID=814Edit the metadata for the file that you selected.  You can refer to the section above about adding metadata and refer to the help topic on schemas.

4. PRIVATE ForeHelp xParaStyle ID=815When you have completed adding the metadata to the document, select the OK button.  Repeat for every file that you want to add metadata to.

5. PRIVATE ForeHelp xParaStyle ID=816Select the Apply Changes button.

PRIVATE ForeHelp xParaStyle ID=788
PRIVATE ForeHelp xParaStyle ID=789
PRIVATE ForeHelp xParaStyle ID=790Building the XML Package

PRIVATE ForeHelp xParaStyle ID=791Once you have: created the package, added metadata to the package, added files to the package, and optionally added metadata to the files within the package, you can now build the package.

The Build Package screen is used to set package build options such as: File name and build path, Compression and Encryption

File Name:  This is where you pick a name for your package.

Either enter a file name and build path for in this by directly typing in the field such as C:\mypackage.xmlp or use the directory chooser button to the right of the edit field to navigate through your drives and folders to select a directory.  Then, enter a file name followed by the ,XMLP extension and select the Save button.  Note:  If you are typing in a field in the File Name field, make sure the path you enter is correct.  If a directory that you specify does not exist, the program will not create it for you on save.

Refresh Files in Package:  Selecting this checkbox refreshes the files in the package.  This is used when opening up a previously created package and you want the package update the files within it with later versions of these files that may exist on your system or network.  If this checkbox is not selected, any later versions of these files will not be refreshed when a package has been reopened and their previous versions will remain in the package.

Package Compression Options:

You have the option to not compress, compress or compress with password individual files in your project.  In placing files in XML Packages, the files must be converted to BASE64 format in order to meet the XML 1.0 Specification.  Converting a file to BASE64 format adds about 33 percent to the file size.  Because of this, compression is strongly recommended.

When building a package, metaPackager first takes any files listed for compression and compresses them.  If the files also have the password attribute set, then the passwords are added to those files (see password section below for more details).  Then the files are converted to BASE64 and input into the package.  Some files such as text files may compress up to 20 times prior to the BASE64 conversion.  The 33 percent BASE 64 conversion overhead when converting to a file that is only 5 percent of the original size is not bothersome.  Other files such as MP3 or other highly compressed file formats will see no real gain on the compression, but will then increase in size about 30-40 percent once converted to BASE64.  Your results will vary depending on the file type.  Understanding how the compression works explains why some files can be larger in size once placed in the package.

The same passwords are applied to all files in the package with one exception. This exception relates to the Refresh Files in Package checkbox.  If you open a existing package with password protected files, these passwords will be over-written with the new password if the Refresh Files in Package checkbox is selected.  If the Refresh Files in Package checkbox is not selected, the passwords of those files in the existing package will not be modified.  

A files needs to be compressed in order to be password protected.  You cannot have password protection on non-compressed files.
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Building the Package

1. PRIVATE ForeHelp xParaStyle ID=824Make sure you have clicked on the Apply Changes button, if you have not already done so in the previous step.

2. PRIVATE ForeHelp xParaStyle ID=1680From the File menu, select Build Package.

3. In the File Path field, enter a file path and name for your package.  Make sure the package named ends in .XMLP.

4. Select which files in the package are to be compressed.  HiSoftware recommends that all files be compressed.  Select files for compression by clicking in the checkbox beside each file or by using the Compress All and Compress None buttons.  You can also right click with the mouse in the file list to open a pop-up menu with options.

5. If you wish to use password protection, select the Password button and enter a password in both fields.  The mask password checkbox allows you to either see the password you are entering or see a masked value instead (******) .

6. Select which files to place passwords on.  Right click on each file with the mouse in the file list to open a pop-up menu and select Encrypt.  You can also use the Encryption menu button on the toolbar to Encrypt All or Encrypt None.

7. When ready to build, select the Build button.

Creating XML TemplatesPRIVATE ForeHelp Scaps value=0
PRIVATE ForeHelp xParaStyle ID=756metaPackager allows you to create XML templates that are then in turn used to create XML Packages.  In order to create packages from a template, you need to PRIVATE ForeHelp xHotspot ID=16777420change the default template XML_Packageswhen creating a package.

Creating a template allows you to set common meta tags names and values, and have the new packages use these values instead of needing to enter them separately.

PRIVATE ForeHelp xParaStyle ID=755
PRIVATE ForeHelp xParaStyle ID=754To create an XML Template:
1. PRIVATE ForeHelp xParaStyle ID=1523From the File menu, select New and then select XML Package.  The Create New File window appears.  Make sure that the Create Template option is selected and not the Create Package option.
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2. PRIVATE ForeHelp xParaStyle ID=745Select the OK button.  You have now created the base for your template. 

3. PRIVATE ForeHelp xParaStyle ID=744Make changes to the default metadata as required.

4. PRIVATE ForeHelp xParaStyle ID=743When done, select Save As from the File menu and save your template.   Note the Save In value at the top of the Save As dialog box.  This represents the directory where the packages will be stored.  By default, this location is the templates directory of the metaPackager installation.  The recommended location for storing templates is in the templates subdirectory of the metaPackager installation.

PRIVATE ForeHelp xParaStyle ID=749When creating new packages in the future, you can then select this new template files you just created.  This new template file can also be set as the default template file.

PRIVATE ForeHelp xParaStyle ID=748Note:  When saving templates, the document encoding elements are removed from the saved template.

Creating Multiple XML Packages in Batch mode
PRIVATE ForeHelp xParaStyle ID=1364

PRIVATE ForeHelp Scaps value=0Batch Processing is used to create multiple XML Packages in Batch mode.  With this method, there will be one file or document per XML Package.PRIVATE ForeHelp Scaps value=-1
PRIVATE ForeHelp xParaStyle ID=1605

PRIVATE ForeHelp Scaps value=0To use this feature:

1. PRIVATE ForeHelp xParaStyle ID=1536In the Normal tab, PRIVATE ForeHelp xHotspot ID=16777639enter the metadata for the package_Adding_metadata_to_the_XML_Package. Please see the previous sections for information on entering metadata for the packages.

2. PRIVATE ForeHelp xParaStyle ID=1517From the Special menu, select the Batch Package Build button.  The Batch Package Build window appears.
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3. PRIVATE ForeHelp xParaStyle ID=798Select the Add Files button to add files to the batch list. A standard Windows Open dialog box appears. 

4. PRIVATE ForeHelp xParaStyle ID=503Navigate through your local or networked file system and select the files that you want to add.  You can select more than one file at once by holding the CTRL key down on the keyboard while selecting files with the left mouse button.  You can select a sequence of files by selecting the first file in the sequence, holding the SHIFT key down on the keyboard and then selecting the last file in the sequence.

5. PRIVATE ForeHelp xParaStyle ID=1537You can add all files within a directory, but you cannot add the directory itself.  If you want to then add files from a second directory, repeat the previous step, this time selecting the files from the second directory..

6. Select which files in the package are to be compressed.  HiSoftware recommends that all files be compressed.  Select files for compression by clicking in the checkbox beside each file or by using the Compress All and Compress None buttons.  You can also right click with the mouse in the file list to open a pop-up menu with options.

7. If you wish to use password protection, select the Password button and enter a password in both fields.  The mask password checkbox allows you to either see the password you are entering or see a masked value instead (******) .

8. Select which files to place passwords on.  Right click on each file with the mouse in the file list to open a pop-up menu and select Encrypt.  You can also use the Encryption menu button on the toolbar to Encrypt All or Encrypt None.

9. If you want the batch process to overwrite any existing packages of the same name, select the Overwrite existing packages checkbox.

10. If you want the batch process to stop if for some reason the batch process fails, select the Stop process if package build fails checkbox.

· If you want to remove a file from the batch list, select the file name in the list and then select the - Files button found in the Batch Package Build window.

11. When you are ready to run the batch, select the Batch button.

12. A report of the processing of the batch update appears in the last tab in the tab control, the Processing tab.PRIVATE ForeHelp Scaps value=-1
Extracting Packages

1. From the File menu, select Extract Files.  The Select which files to extract from package window appears (unless this option was disabled in the preferences).

2. In the Files Available for Extract list, select one, several or all of the files that you want to extract.  All files are selected by default.

3. If you want this screen to appear every time you extract, leave the Show this dialog when extracting files checkbox selected.

4. Note the Extract Directory location and modify that if you choose.  If you modify it and wish for the modified path to be the new default, select the Save Directory as Default checkbox.

5. Select the Ok button to complete the extraction.  The files will be extracted to the selected extract directory.
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About the Schemas

PRIVATE ForeHelp xParaStyle ID=736
PRIVATE ForeHelp xParaStyle ID=602

PRIVATE ForeHelp Scaps value=0HiSoftware allows the user to either create custom schemas or use some of the predefined schemas.

PRIVATE ForeHelp xParaStyle ID=735The predefined schemas provided are:

· PRIVATE ForeHelp xParaStyle ID=734The A-CORE schema is an Australian schema based partly on the Dublin Core schema.

· PRIVATE ForeHelp xParaStyle ID=733The AGLS schema is for the PRIVATE ForeHelp Underline value=1

PRIVATE ForeHelp Scaps value=-1

PRIVATE ForeHelp xCharStyle ID=732Australian Government Locator ServicePRIVATE ForeHelp Underline value=1PRIVATE ForeHelp xCharStyle ID=732 PRIVATE ForeHelp Underline value=0 located at PRIVATE ForeHelp Scaps value=0

PRIVATE ForeHelp Scaps value=-1

PRIVATE ForeHelp xCharStyle ID=1612http://www.naa.gov.au/govserv/agls/ PRIVATE ForeHelp Underline value=0 The AGLS metadata standard is a set of 19 descriptive elements which government departments and agencies can use to improve the visibility and accessibility of their services and information over the Internet.

· PRIVATE ForeHelp xParaStyle ID=731The Publish schema is a publisher’s style set of Meta elements.

· PRIVATE ForeHelp xParaStyle ID=730The Dublin Core element set is a schema intended to be used by non-catalogers as well as resource description specialist.  Visit the PRIVATE ForeHelp Underline value=1

PRIVATE ForeHelp xCharStyle ID=729Dublin CorePRIVATE ForeHelp Underline value=0 web site @ PRIVATE ForeHelp xCharStyle ID=1611http://purl.orgPRIVATE ForeHelp Underline value=0 for more info.

· PRIVATE ForeHelp xParaStyle ID=728The Base schema is where a user can create a custom schema.

· PRIVATE ForeHelp xParaStyle ID=727GILS is Global Information Locator Service.  metaPackager offers custom Meta properties meeting requirements for GILS.  For more information, visit PRIVATE ForeHelp xCharStyle ID=1617http://PRIVATE ForeHelp xCharStyle ID=1617www.gils.netPRIVATE ForeHelp Underline value=1PRIVATE ForeHelp Underline value=0
· PRIVATE ForeHelp xParaStyle ID=723The IMS schema is also supported.  Please see the PRIVATE ForeHelp Underline value=1

PRIVATE ForeHelp xCharStyle ID=718IMS ProjectPRIVATE ForeHelp Underline value=0 website @ PRIVATE ForeHelp Scaps value=0 PRIVATE ForeHelp Scaps value=-1

PRIVATE ForeHelp xCharStyle ID=1736http://www.imsproject.org/index.htmlPRIVATE ForeHelp Underline value=0PRIVATE ForeHelp Underline value=0 for more information on this project and how its members are trying to define learning on the Internet.

· PRIVATE ForeHelp xParaStyle ID=717The MS Extended schema is a schema from Microsoft Corporation.

· PRIVATE ForeHelp xParaStyle ID=715The WAGILS schema uses enhanced Meta data attributes to identify documents.  Used by Washington State Government Information Locator Service.  Additional information may be found at the PRIVATE ForeHelp Underline value=1

PRIVATE ForeHelp xCharStyle ID=714Washington State LibraryPRIVATE ForeHelp Underline value=0 at PRIVATE ForeHelp Underline value=1http://www.statelib.wa.gov/info_rscrs/dbs_tools/find-it/gils.htmPRIVATE ForeHelp Underline value=0.

Custom Field Editor

PRIVATE ForeHelp xParaStyle ID=610
PRIVATE ForeHelp xParaStyle ID=668

PRIVATE ForeHelp Scaps value=0The Custom Field Editor is designed for users of controlled vocabularies.   A controlled vocabulary is a predefined hierarchical listing of terms used by enterprise size organizations to focus and control searching and input of data.  The Custom Field Editor allows users to create controlled vocabularies using lists, or dates, instead of using the tree style in the Custom Subject PRIVATE ForeHelp Scaps value=-1Selector.   Sometimes, lists of values in text form are easier to use than a subject tree.

PRIVATE ForeHelp xParaStyle ID=667
PRIVATE ForeHelp xParaStyle ID=666For example, if your team was entering metatags in various documents and one of the metatags was related to color, you could use the controlled vocabulary to enforce the use of certain colors such as Red, Blue, Green or Yellow.  This would prevent the users from selecting other colors such as magenta, turquoise, teal or tan.

PRIVATE ForeHelp xParaStyle ID=665
PRIVATE ForeHelp xParaStyle ID=664In the Normal tab of metaPackager, you could have a particular schema for your organization, and in that, have certain meta tags that allowed for either normal editing, selecting from a drop down menu, or selecting a date from a calendar control.   Using the example above, the users would then choose the colors Red, Blue, Green or Yellow from a custom drop down menu that you created.   

PRIVATE ForeHelp xParaStyle ID=663
PRIVATE ForeHelp xParaStyle ID=662Getting to the Custom Field Editor
PRIVATE ForeHelp xParaStyle ID=661Choose the Special menu and select Custom Field Editor.
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PRIVATE ForeHelp xParaStyle ID=660
PRIVATE ForeHelp xParaStyle ID=659Parts of the Screen

PRIVATE ForeHelp xParaStyle ID=658To create a new file, select the Create New Schema button with the new page icon on the toolbar or select New from the File menu.

PRIVATE ForeHelp xParaStyle ID=657To open a file, select the Open Existing Schema button with the open folder icon on the toolbar or select Open from the File menu.

PRIVATE ForeHelp xParaStyle ID=656To save a file, select the Save Current Schema button with the floppy disk icon on the toolbar or select Save from the File menu.
PRIVATE ForeHelp xParaStyle ID=655To add rows and delete rows in the grid, select the Add Row button with the (+) icon or Del Row with the (–) icon button from the toolbar.

PRIVATE ForeHelp xParaStyle ID=654To exit the Editor, select the Exit button with the door icon from the toolbar or select Exit from the File menu.

PRIVATE ForeHelp xParaStyle ID=653For help, select the Help button with the book icon from the toolbar.

PRIVATE ForeHelp xParaStyle ID=652
PRIVATE ForeHelp xParaStyle ID=651Creating Controlled Vocabularies in the Custom Field Editor

1. PRIVATE ForeHelp xParaStyle ID=650Choose the File menu and select New to open a new file or Open to open an existing file.  You can also select the New button with the new page icon or the Open button with the open folder icon.

2. PRIVATE ForeHelp xParaStyle ID=649Enter a Name for the controlled field.

3. PRIVATE ForeHelp xParaStyle ID=648Choose a Type from the drop down menu: Drop Down, Date and Normal.  Drop Down describes the type of data values where the user will select from among the choices provided in the drop down menu. Date describes a control where when the user is entering data values from the meta tags in the schema, the user selects a calendar control to choose a date, instead of typing in a values as would be done with the normal scheme, or drop down where the user selects from a list of options.  Normal describes a meta tag where the user will enter values for the tag when running the program.  Normal style values are not available in a list as are the drop down values.  NOTE:  If you enter Date or Normal as your type in the Type Column, move your cursor to a new record to save the Type.

4. PRIVATE ForeHelp xParaStyle ID=647Enter value(s) in the Edit column for Drop Down menus using the Custom Field Data Editor.  If you chose your type to be Normal or Date, do not enter any values in the Edit field. 
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PRIVATE ForeHelp xParaStyle ID=646
PRIVATE ForeHelp xParaStyle ID=645Saving Controlled Vocabularies in the Custom Field Editor

PRIVATE ForeHelp xParaStyle ID=632To use the file with a particular schema, choose the File menu and select Save As.  Then, save the file with the same name as the schema.   For example, if you want to create a custom field file to use with the WAGILS schema, you will need to save this custom field file as WAGILS.  The program will automatically append the .sbf file extension to the file name for you.

PRIVATE ForeHelp xParaStyle ID=643
PRIVATE ForeHelp xParaStyle ID=642Using the Controlled Vocabularies with Schemas in the Custom/Subject Tab

1. PRIVATE ForeHelp xParaStyle ID=641In the main window of metaPackager, select the Normal tab.

2. PRIVATE ForeHelp xParaStyle ID=640At the right side of the tab, choose the Schema drop down box to select a schema.

3. PRIVATE ForeHelp xParaStyle ID=639Add a row to the schema by selecting the button with the + icon.
4. PRIVATE ForeHelp xParaStyle ID=638Type in the Meta Name column the name of the custom field created in the Custom Field Editor.

5. PRIVATE ForeHelp xParaStyle ID=691In the Meta Value column, select the value you would like for that controlled vocabulary field.

PRIVATE ForeHelp xParaStyle ID=692
Subject Tree Manager

PRIVATE ForeHelp xParaStyle ID=553

PRIVATE ForeHelp Scaps value=0
PRIVATE ForeHelp xParaStyle ID=552The HiSoftware Subject Tree Manager is a utility for easily creating the tree files (.HSTF) used with controlled vocabularies.  This feature will mostly be used by Enterprise level organizations employing controlled vocabularies.
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PRIVATE ForeHelp xParaStyle ID=551
PRIVATE ForeHelp xParaStyle ID=550An easy way to understand this feature is to select Open from the File menu and select the default.hstf file provided.  This file PRIVATE ForeHelp Scaps value=-1should appear in the Open tree file dialog box.  Tree files are normally stored in the Lists subdirectory of metaPackager.  This file contains a schema populated with a large number of Meta tag values in a tree format.

PRIVATE ForeHelp xParaStyle ID=549
PRIVATE ForeHelp xParaStyle ID=548Creating a tree file
1. PRIVATE ForeHelp xParaStyle ID=482To create your own file, select New from the File menu.  Enter a branch for the tree in the tree view control. 

2. PRIVATE ForeHelp xParaStyle ID=489To add more branches, select the Item button on the toolbar and add more items.

3. PRIVATE ForeHelp xParaStyle ID=490To add sub-items, select the item or branch were you want to add the item and the select the Sub Item button.

4. PRIVATE ForeHelp xParaStyle ID=491To delete an item or sub-item, select the item and the select the Delete button.

5. PRIVATE ForeHelp xParaStyle ID=492To rename an item, select the item and the click the Rename button.  The program will highlight the text to be renamed.  Enter in the new text and then select the ENTER key to accept changed.

6. PRIVATE ForeHelp xParaStyle ID=573When done, select the Save or Save As keys to save your files.  These files are stored by default to the lists subdirectory of the metaPackager installation.  These lists can later be shared with other members of your enterprise.

VERS Packages and Files

PRIVATE ForeHelp xParaStyle ID=765PRIVATE ForeHelp xParaStyle ID=835

PRIVATE ForeHelp xParaStyle ID=834

PRIVATE ForeHelp xParaStyle ID=777
PRIVATE ForeHelp xParaStyle ID=860PRIVATE ForeHelp Scaps value=0

PRIVATE ForeHelp xTarget ID=33554592Creating a new VERS Encapsulated Object Package
PRIVATE ForeHelp xParaStyle ID=861metaPackager allows the user to create packages meeting the VERS specification.

PRIVATE ForeHelp xParaStyle ID=864To create a VERS Encapsulated Object Package:

1. PRIVATE ForeHelp xParaStyle ID=1368From the File menu, select New and then select VERS Encapsulated Object.  The Create New File window appears.  Make sure that the Create Package (VEO Record) option is selected and not the Create Template or Create VEO File option.
2. PRIVATE ForeHelp xParaStyle ID=924Confirm that the template file displayed in the Template File path is the template you want to use.  Unless you have created a new template file to meet your specific needs, the default template will be fine.

3. PRIVATE ForeHelp xParaStyle ID=923Select the OK button.  You have now created the base for your package.  At this point, the Normal tab of metaPackager will disappear, as this is not used with VERS.

PRIVATE ForeHelp xParaStyle ID=868
PRIVATE ForeHelp xParaStyle ID=869

PRIVATE ForeHelp xTarget ID=33554658Adding metadata to the VERS Encapsulated Object Package
PRIVATE ForeHelp xParaStyle ID=870Adding metadata to the VERS Encapsulated Object Package is done in the Structure tab, not in the Normal tab as is done with the XML Packages.
1. PRIVATE ForeHelp xParaStyle ID=1602Expand the tree to find vers:RecordMetadata
2. PRIVATE ForeHelp xParaStyle ID=937This is found in the tree under: 

PRIVATE ForeHelp xParaStyle ID=936      vers:VERSEncapsulatedObject
PRIVATE ForeHelp xParaStyle ID=942        vers:SignedObject

PRIVATE ForeHelp xParaStyle ID=941          vers:ObjectContent

PRIVATE ForeHelp xParaStyle ID=939            vers:Record

PRIVATE ForeHelp xParaStyle ID=927              vers:RecordMetadataPRIVATE ForeHelp xParaStyle ID=931
3. PRIVATE ForeHelp xParaStyle ID=945You can also select the Search button on the toolbar or select Search from the Edit menu, enter vers:RecordMetadata in the search dialog and select Ok to find the metadata section.

4. PRIVATE ForeHelp xParaStyle ID=946Below this node in the tree are the metadata properties available to you.  Expand out the items and enter metadata properties in the TEXT fields that appear below each node.

5. PRIVATE ForeHelp xParaStyle ID=947Double click on the TEXT node to open a text editor where values for the metadata can be added.  Click on the OK button when done.  If the node does not have a TEXT sub-node, double clicking on the node will create the TEXT sub-node.
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PRIVATE ForeHelp xParaStyle ID=952
PRIVATE ForeHelp xParaStyle ID=883
PRIVATE ForeHelp xParaStyle ID=884Adding files to the VERS Encapsulated Object Package

1. PRIVATE ForeHelp xParaStyle ID=885To add files to the VERS Encapsulated Object Package, select Add File(s) from the File menu.  The files are now added to the structure.

2. PRIVATE ForeHelp xParaStyle ID=886To view the file in the structure, navigate the tree to find vers:FileIdentifer
      PRIVATE ForeHelp xParaStyle ID=887This is found in the tree under: 

      PRIVATE ForeHelp xParaStyle ID=888vers:VERSEncapsulatedObject
PRIVATE ForeHelp xParaStyle ID=889        vers:SignedObject

PRIVATE ForeHelp xParaStyle ID=890          vers:ObjectContent

PRIVATE ForeHelp xParaStyle ID=891            vers:Record

PRIVATE ForeHelp xParaStyle ID=892              vers:Document

PRIVATE ForeHelp xParaStyle ID=893                vers:Encoding

PRIVATE ForeHelp xParaStyle ID=894                  vers:EncodingMetadata

PRIVATE ForeHelp xParaStyle ID=895                    vers:FileIdentifier

PRIVATE ForeHelp xParaStyle ID=896                      vers:Text

PRIVATE ForeHelp xParaStyle ID=897
PRIVATE ForeHelp xParaStyle ID=898If you have selected more than one file, you will have more than one node titled vers:Encoding.  There is one of these for each file.
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PRIVATE ForeHelp xParaStyle ID=899
PRIVATE ForeHelp xParaStyle ID=900Adding metadata to the VERS Encapsulated Object Package’s documents

1. PRIVATE ForeHelp xParaStyle ID=901To add metadata to the files in the VERS Encapsulated Object Packages, you must navigate to the vers:DocumentMetadata node of the tree.

PRIVATE ForeHelp xParaStyle ID=902The vers:DocumentMetadata node if found under:

      PRIVATE ForeHelp xParaStyle ID=903vers:VERSEncapsulatedObject

PRIVATE ForeHelp xParaStyle ID=904        vers:SignedObject

PRIVATE ForeHelp xParaStyle ID=905          vers:ObjectContent

PRIVATE ForeHelp xParaStyle ID=906            vers:Record

PRIVATE ForeHelp xParaStyle ID=907              vers:Document

PRIVATE ForeHelp xParaStyle ID=908                vers:DocumentMetadata

2. PRIVATE ForeHelp xParaStyle ID=909Below the vers:DocumentMetadata node are various sub-nodes for the different metadata values available.  The various sub nodes in the tree represent the various meta tags available under VERS.

3. PRIVATE ForeHelp xParaStyle ID=910Under each specific metadata value that is represented by a node, locate the vers:Text sub node and double click on it.  This opens an Enter Text Form dialog box that is used to enter the text for the metadata value.

4. PRIVATE ForeHelp xParaStyle ID=911Enter the metadata values in the Enter Text Form dialog box and then select the Ok button.

5. PRIVATE ForeHelp xParaStyle ID=912Repeat this for each file that you want to add metadata.  If you have selected more than one file for your package, you will have more than one node titled vers:Encoding.  Therefore, the metadata for each file will be found in under the particular nodes for that file, as found under the appropriate vers:Encoding node.
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PRIVATE ForeHelp xParaStyle ID=913
PRIVATE ForeHelp xParaStyle ID=914Building the VERS Encapsulated Object Packages

PRIVATE ForeHelp xParaStyle ID=915Once you have: created the package, added metadata to the package, added files to the package, and optionally added metadata to the files within the package you can now build the package.

PRIVATE ForeHelp xParaStyle ID=791Once you have: created the package, added metadata to the package, added files to the package, and optionally added metadata to the files within the package, you can now build the package.

The Build Package screen is used to set package build options such as: File name and build path, Compression and Encryption

File Name:  This is where you pick a name for your package.

Either enter a file name and build path for in this by directly typing in the field such as C:\mypackage.xmlp or use the directory chooser button to the right of the edit field to navigate through your drives and folders to select a directory.  Then, enter a file name followed by the ,XMLP extension and select the Save button.  Note:  If you are typing in a field in the File Name field, make sure the path you enter is correct.  If a directory that you specify does not exist, the program will not create it for you on save.

Refresh Files in Package:  Selecting this checkbox refreshes the files in the package.  This is used when opening up a previously created package and you want the package update the files within it with later versions of these files that may exist on your system or network.  If this checkbox is not selected, any later versions of these files will not be refreshed when a package has been reopened and their previous versions will remain in the package.

Package Compression Options:

You have the option to not compress, compress or compress with password individual files in your project.  In placing files in XML Packages, the files must be converted to BASE64 format in order to meet the XML 1.0 Specification.  Converting a file to BASE64 format adds about 33 percent to the file size.  Because of this, compression is strongly recommended.

When building a package, metaPackager first takes any files listed for compression and compresses them.  If the files also have the password attribute set, then the passwords are added to those files (see password section below for more details).  Then the files are converted to BASE64 and input into the package.  Some files such as text files may compress up to 20 times prior to the BASE64 conversion.  The 33 percent BASE 64 conversion overhead when converting to a file that is only 5 percent of the original size is not bothersome.  Other files such as MP3 or other highly compressed file formats will see no real gain on the compression, but will then increase in size about 30-40 percent once converted to BASE64.  Your results will vary depending on the file type.  Understanding how the compression works explains why some files can be larger in size once placed in the package.

The same passwords are applied to all files in the package with one exception. This exception relates to the Refresh Files in Package checkbox.  If you open a existing package with password protected files, these passwords will be over-written with the new password if the Refresh Files in Package checkbox is selected.  If the Refresh Files in Package checkbox is not selected, the passwords of those files in the existing package will not be modified.  

A files needs to be compressed in order to be password protected.  You cannot have password protection on non-compressed files.
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1. From the File menu, select Build Package.

2. In the File Path field, enter a file path and name for your package.  Make sure the package named ends in .XMLP.

3. Select which files in the package are to be compressed.  HiSoftware recommends that all files be compressed.  Select files for compression by clicking in the checkbox beside each file or by using the Compress All and Compress None buttons.  You can also right click with the mouse in the file list to open a pop-up menu with options.

4. If you wish to use password protection, select the Password button and enter a password in both fields.  The mask password checkbox allows you to either see the password you are entering or see a masked value instead (******) .

5. Select which files to place passwords on.  Right click on each file with the mouse in the file list to open a pop-up menu and select Encrypt.  You can also use the Encryption menu button on the toolbar to Encrypt All or Encrypt None.

6. When ready to build, select the Build button. 
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PRIVATE ForeHelp xParaStyle ID=951

PRIVATE ForeHelp xParaStyle ID=934
PRIVATE ForeHelp xParaStyle ID=858

PRIVATE ForeHelp xTarget ID=33554591Creating an New VERS Template

PRIVATE ForeHelp xParaStyle ID=856metaPackager allows you to create VERS templates that are then in turn used to create VERS Packages.

PRIVATE ForeHelp xParaStyle ID=854To create an VERS Template:
1. PRIVATE ForeHelp xParaStyle ID=846From the File menu, select New and then select VERS Encapsulated Object.  The Create New File window appears.  Make sure that the Create Template option is selected and not the Create Package or Create VEO option.
2. PRIVATE ForeHelp xParaStyle ID=845Select the correct option for the template you are creating in the Template Type field.  The two choices are Record and File.

3. PRIVATE ForeHelp xParaStyle ID=560Select the OK button.  You have now created the base for your template. 

4. PRIVATE ForeHelp xParaStyle ID=565Make modifications to the structure of the VERS object as desired, by using the Structure tab.

5. PRIVATE ForeHelp xParaStyle ID=676When done, select Save As from the File menu and save your template.   Note the Save In value at the top of the Save As dialog box.  This represents the directory where the packages will be stored.  By default, this location is the templates directory of the metaPackager installation.  The recommended location for storing templates is in the templates subdirectory of the metaPackager installation.

PRIVATE ForeHelp xParaStyle ID=848When creating new packages in the future, you can then select this new template files you just created.  This new template file can also be set as the default template file.

PRIVATE ForeHelp xParaStyle ID=847Note:  When saving templates, the VERS encoding elements are removed from the saved template.PRIVATE ForeHelp Scaps value=-1
PRIVATE ForeHelp xParaStyle ID=955
PRIVATE ForeHelp xParaStyle ID=871
PRIVATE ForeHelp xParaStyle ID=867
PRIVATE ForeHelp xParaStyle ID=866

PRIVATE ForeHelp Scaps value=0

PRIVATE ForeHelp Scaps value=-1
PRIVATE ForeHelp xParaStyle ID=875

PRIVATE ForeHelp xTarget ID=33554590Creating a new VERS VEO File

PRIVATE ForeHelp xParaStyle ID=874metaPackager allows the user to create packages meeting the VERS specification.
PRIVATE ForeHelp xParaStyle ID=872To create a VERS VEO File:
1. PRIVATE ForeHelp xParaStyle ID=783From the File menu, select New and then select VERS Encapsulated Object.  The Create New File window appears.  Make sure that the Create VEO File option is selected and not the Create Template or Create Package (VEO Option) option.
2. PRIVATE ForeHelp xParaStyle ID=779Confirm that the template file displayed in the Template File path is the template you want to use.  Unless you have created a new template file to meet your specific needs, the default template will be fine.

3. PRIVATE ForeHelp xParaStyle ID=767Select the OK button.  You have now created the base for your package.  At this point, the Normal tab of metaPackager will disappear, as this is not used with VERS.

PRIVATE ForeHelp xParaStyle ID=865
PRIVATE ForeHelp xParaStyle ID=862Adding metadata to the VERS VEO File
PRIVATE ForeHelp xParaStyle ID=863Adding metadata to the VERS VEO File is done in the Structure tab, not in the Normal tab as is done with the XML Packages.
PRIVATE ForeHelp xParaStyle ID=738Expand the tree to find vers:RecordMetadata:
PRIVATE ForeHelp xParaStyle ID=739This is found in the tree under 

PRIVATE ForeHelp xParaStyle ID=740vers:VERSEncapsulatedObject
PRIVATE ForeHelp xParaStyle ID=741vers:SignedObject

PRIVATE ForeHelp xParaStyle ID=742vers:ObjectContent

PRIVATE ForeHelp xParaStyle ID=750vers:Record

PRIVATE ForeHelp xParaStyle ID=751vers:RecordMetadata

PRIVATE ForeHelp xParaStyle ID=752
PRIVATE ForeHelp xParaStyle ID=753You can also select the Search button on the toolbar or select Search from the Edit menu, enter vers:RecordMetadata in the search dialog and select Ok to find the metadata section.

PRIVATE ForeHelp xParaStyle ID=797Below this node in the tree are the metadata properties available to you.  Expand out the items and enter metadata properties in the TEXT fields that appear below each node.

PRIVATE ForeHelp xParaStyle ID=796Double click on the TEXT node to open a text editor where values for the metadata can be added.  Click on the OK button when done.  If the node does not have a TEXT sub-node, double clicking on the node will create the TEXT sub-node.

PRIVATE ForeHelp xParaStyle ID=222
PRIVATE ForeHelp xParaStyle ID=227HiSoftware MP Package Find

PRIVATE ForeHelp xParaStyle ID=228The HiSoftware MP Package Find allows for fielded searching of metadata in files wrapped with the HiSoftware metaPackager.

To open HiSoftware MP Package Find, select the Find Metadata Packages from the HiSoftware metaPackager shortcut on the Windows Start menu.
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PRIVATE ForeHelp xParaStyle ID=229
PRIVATE ForeHelp xParaStyle ID=230 MP Package Find Search tab – parts of the screen

· PRIVATE ForeHelp xParaStyle ID=231Files of Type: In this menu, select the type of file to search for.  This includes XMLPPRIVATE ForeHelp Underline value=0

PRIVATE ForeHelp Blink value=0

PRIVATE ForeHelp Scaps value=-1 files.

· PRIVATE ForeHelp xParaStyle ID=232Located in: Enter the path in which to search for these files.

· PRIVATE ForeHelp xParaStyle ID=233Search Profile:  You can select a search profile created with the HiSoftware Profile Builder.  The Profile Builder is located in the Windows Start menu.

· PRIVATE ForeHelp xParaStyle ID=234Property Name:  In the property name field, enter the name of the meta property you are searching for.  For example, enter keywords or description.

· PRIVATE ForeHelp xParaStyle ID=235Property Value:  Enter the value for the search property in the table.

· PRIVATE ForeHelp xParaStyle ID=236Include subfolders:  Include subfolders in the search

· PRIVATE ForeHelp xParaStyle ID=237Exact matches only:  Selecting this checkbox limits the search to exact matches only.

PRIVATE ForeHelp xParaStyle ID=238  

PRIVATE ForeHelp xParaStyle ID=239 

MP Package Find toolbar

· PRIVATE ForeHelp xParaStyle ID=240Help:  Provides help for this screen
· PRIVATE ForeHelp xParaStyle ID=241Save:  Saves the results

· PRIVATE ForeHelp xParaStyle ID=242New Search: Clears the current search and prepares for a new search

· PRIVATE ForeHelp xParaStyle ID=243Stop:  Stops a search in progress

· PRIVATE ForeHelp xParaStyle ID=244Find Now:  Starts the search

PRIVATE ForeHelp xParaStyle ID=245
PRIVATE ForeHelp xParaStyle ID=246 MP Package Find Files Found tab – parts of the screen
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· PRIVATE ForeHelp xParaStyle ID=249Open:  Selecting the Open button opens the meta-wrapped file.

If you have metaPackager on your system, you can open the packaged file in metaPackager.  If you do not have metaPackager on your system, you can view the file in Internet Explorer or another XML capable web browser.

PRIVATE ForeHelp xParaStyle ID=250
Thank you for working with HiSoftware metaPackager™.  Visit the HiSoftware web site for more knowledge management and web site promotion products.
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