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Designing Reports for Character-Mode Output

Introduction/Abstract
Developer/2000 is the most powerful and versatile forms, graphics and reporting tool available
for Windows, Macintosh and Motif/UNIX today. With Developer/2000 you can create reports
designed for both character and bitmapped output.  Character mode reports are often needed in
environments where users need to send their report output to bulletin boards, spreadsheets or to
character-only printers.

This paper discusses the benefits of producing character mode reports using Developer/2000.
We will discuss how to design a report for character mode output, and review how to produce a
character mode report for  Windows, Motif and Macintosh environments.

Character Mode Reports

Character mode reports provide a number of advantages to the user:
1) Portability: Character reports can be printed or exported anywhere, because they are strictly
ASCII or EBCDIC files.
2) Preserve Investment in Old Printers: No investment in new printers are necessary. Character
mode reports require no special formatting, unlike complicated postscript output.  Also, character
printers can survive in harsh industrial/factory environments.
3) Printer Code Support.  Developer/2000 provides support for Printer escape codes, which
enable users to exploit printer-specific features at runtime.
By sending printer escape codes to the printer, you can:
• switch printer paper trays dynamically during report execution
• switch paper orientation dynamically during report execution.
• support other printer-specific features in your printed reports, such as alternate fonts,

background fill patterns and so forth.

With Developer/2000, specific printer escape codes can be associated with all layout objects,
such as fields, boilerplate and group frames.  Printer escape sequences can be sent both before
and after formatting of a layout object.  When executing the same report in bitmap mode,
Developer/2000 ignores printer codes.
4) Performance:  Character mode reports run much faster than an equivalent bitmap report, as
only the 132x66 ASCII character grid needs to be formatted.  Bitmapped output, on the other
hand require more formatting time and have larger (Postscript, PCL5) output files.

Limitations

As one might expect, character mode output is plain looking when compared to a bitmapped
report, as report output is limited to ASCII characters.  For example, reports displayed in
character
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mode can display lines and boxes, but not ellipses, colors, bitmap patterns or drill-down buttons.
See the chart below for specifics.

Character Support Bitmap Only
Boxes
Horizontal lines
Vertical lines
ASCII text
Boldface text
Underlines

Images
Colors
Drawings
Ellipses
Drill-down buttons
Italicized Text
Bitmap Patterns
Diagonal Lines
Multimedia Support

Designing a Character Mode Report

With Developer/2000, designing a character mode report is a straightforward process.  The most
important design issue to keep in mind is the requirements of your output destination.  For
instance, if you intend to send your report output to a printer that has 15” x 8” physical pages, set
your physical page size accordingly in the Report Global Properties sheet.  If you are sending
your report to a bulletin board or other online application, the standard 8.5” x 11” page size may
be best. After determining the appropriate page size for your output, set your report width and
height in character units.  You should also set up your Reports Designer to use character mode
settings.  For more specific instructions, please see Appendix A.

When designing the layout of your character mode report, you should make sure that the height
and width of text or graphic objects in your layout is at least half the height and width of a
character cell, otherwise your object may be mapped to a zero size, resulting in an error in your
report.

Before creating or editing your character-mode report in the Layout editor, be sure to set the
following parameter:

Use Character Units in Designer: Always have this option selected if you plan to design a
character report.  See Appendix A for more information.

Layout Design Considerations
When you generate a default layout for a character-mode report, you may notice that fields and
enclosing frames in your layout overlay each other.  This is because all report objects are being
mapped to the character grid.
Use the Object Navigator and make use of the color palettes to identify and manipulate report
objects in your layout.
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For example,  the field F_EMPNO has been highlighted in the figure above in dark gray.
Coloring neighboring objects with a different fill color from the tool palette can help you to
identify each object.  Concurrently displaying the Object Navigator in an adjoining window will
also help you identify the currently selected object.  See Appendix B for more hints.

While you are developing your character mode report, make use of the Reports Previewer which
can display your report in character mode onscreen.  Just set MODE=character  in the runtime
parameter form.  See the following section “Previewing your Dual-mode report” on how to set
this up.

Designing a Report for Both Bitmap and Character Output

As mentioned earlier, with Developer/2000, you can create a report for both character and
bitmap output.  As far as Developer/2000 is concerned, the execution of a report as either
bitmapped or character simply depends upon a system parameter called MODE , which can be set
dynamically at runtime.

To design a report for both character and bitmap output, just follow the steps in Appendix A, and
once you are satisfied with your report output in character mode, you can then apply bitmap-
specific enhancements to your report.  Bitmap-specific features can include graphics, postscript
fonts,  interactive PL/SQL buttons, multimedia support, etc.

When changing fonts in a dual-mode report, try to maintain the same font sizes and field sizes
as were originally set in your character-mode layout.  Keeping the same field and font sizes will
help maintain the positioning of the other objects in your report.

The following are design time settings to choose before editing your dual-mode report in
character mode.  You can access these settings through your report’s Global Property Sheet
under the Character Mode tab.

Convert Bitmapped Objects to Boxes:
When this is selected, bitmap objects in your report such as ellipses are converted to
rectangles and boxes upon display in character mode.  Default behavior is to display a blank
region in lieu of a bitmap object in character mode.
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Convert Borders: If your report objects have borders and Convert Borders is selected, a box
comprised of ASCII characters will appear around the object in question.  Otherwise, bitmap
borders will not appear around your layout objects.

Previewing Your Dual-Mode Report

One of the great strengths of Developer/2000 is its ability to preview your dual-mode report
onscreen as you develop it. When you preview your report, all you have to do to choose either
MODE=Character or MODE=Bitmap to toggle between the two output formats.

To enable this, simply create a default parameter form before you run your report with the
following system parameters selected: DESTYPE, MODE and DESNAME.  Use Tools->Default
Parameter Form  to create a default parameter form.

For an example of a dual-mode bitmap and character report, see the sample report trades.rdf
included in your Developer/2000 software in the <orawin>/report25/demo/reqfiles
subdirectory.   This report can also be viewed in bitmap mode from the Developer/2000 Reports
Demo by entering the form, selecting the Interactive Reporting button, and drilling down from the
Interactive Reporting report.

Converting a Bitmap Report to a Character-mode Report

Due to precise bitmap formatting and the wide range of object sizes in a bitmap report, it is a bit
more of a challenge  to convert a bitmap report for character output. Because of the difficulty, we
prefer that users build a character report and then add in bitmap enhancements if they are
interested in creating a dual-mode report.  However, if you must convert a bitmap report for
character output, the most straightforward way is to use the reports conversion utility accessible
by choosing File->Admin->Convert in the Developer/2000 Reports Designer.  See Appendix C
for more information.

Common Problems after Conversion

After converting your bitmap report to character coordinates, you may find that many of your
fields and text objects will need to be resized.  Graphical objects such as ellipses will also not be
included in your newly converted report.

For more specifics, see Appendix B for manipulation of layout objects in character mode.
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Running Character Mode Reports

Not only can you preview your report in the Reports designer, but you can run your report using
Developer/2000’s reports runtime executable, r25run.  The runtime executable is lighter on
resource usage so that you can deploy on smaller production machines to run your reports.
During execution, r25run and the Reports designer both make use of printer definition (.prt ) files
to take advantage of printer features such as bolding, page orientation, print compression,
underlining and graphics.

The following are a few examples of how to run character mode reports on different platforms.

Windows:
The Reports runtime executable on Windows can produce both bitmap and character output.

Example:
r25run report=dept.rdf mode=character batch=yes destype=file
desname=dept.lis

Note that we have set batch=yes  in order to suppress the report’s parameter form from
appearing for the report.

If you are sending your output to a printer or file, you will need to choose a printer definition file,
or Developer/2000 will just use the dflt.prt  file if desformat  is not specified.

Example:
r25run report=dept.rdf mode=character batch=yes destype=printer
desformat=dec.prt

Of course, these long command lines can be automated by creating a program item in your
program manager that your users can just double-click to invoke the report.  If you exceed the
DOS limit of 128 characters with your program item, use the cmdfile=<filename>  option for
r25run.

Motif:
For Motif/UNIX or Motif/VMS environments, two runtime executables are provided - one for
character (r25run) and one for bitmap (r25runm) output.

Character Example:
r25run report=dept.rdf
userid=joe/user@t:hostname:server
destype=printer
desname=<localprinter>
desformat=hplwide.prt

Bitmap example:
r25runm mode=bitmap
report=dept.rdf
userid=joe/user@t:hostname:server
destype=printer
desname=<localprinter>

In the bitmap example above, note that DESFORMAT  is not specified in the commandline.
DESFORMAT  (and .prt files) are only valid for character mode output.

Macintosh:  
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With the upcoming release of Developer/2000 Release 1 on the Macintosh, there is a Reports
runtime executable that will produce both bitmap and character mode output.

For Reports 2.0, there is a Reports <Text> Runtime which will produce character mode output.
For details on how to run the Reports <Text> Runtime, consult the Release Notes for the
Macintosh or bulletin #108082.256 from Oracle Worldwide Support.

Printer Definition (.prt ) Files

As mentioned earlier, Developer/2000 uses printer definition files on character-mode reports to
invoke printer-specific features such as boldface, underlining, page orientation and so forth.

Developer/2000 is shipped with several printer definition files (.prt files), any of which can be
easily modified to suit your particular model printer if necessary.

You designate which .prt file you wish to use with the DESFORMAT  parameter.  For example, to
run a character mode report with the hpl.prt printer file,  you issue the following command:

r25run report=dept.rdf userid=joe/user destype=file desname=dept.lis
desformat=hpl.prt paramform=no

If the DESFORMAT  parameter is not specified, then the dflt.prt  file is used by default.

You may also create your own versions of .prt files if you have specific needs.
See Appendix B of the Oracle Reports Reference Manual for more details.

Running Bitmap Reports in Character Mode Environments

Bitmap reports can be invoked from character mode environments using the r25run executable.
This feature is especially useful where bitmap PCs or Workstations are not suitable or
unavailable.  With Reports, users just need to set batch=yes  in the r25run command line to
invoke their bitmap report for output on a Postscript printer or other Postscript-capable output
device for their bitmap report.  Batch mode must be set to batch=yes , as Parameter Forms
cannot be displayed on character-mode display terminals when mode=bitmap .

Example:
r25run report=dept.rdf destype=printer batch=yes
mode=bitmap
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Appendix A: Steps to Build a Character-mode Report

1. In the Object Navigator, double-click on the property icon  of your report to access the
global property sheet.

2. In the report global properties sheet, set the following properties:
a. On the Report page, set Page Width and Height appropriately. Examples:

11 in. x 8.5 in. for landscape reports with dimensions of 132 x 66.
15 in. x 8.5 in. for landscape reports with dimensions of 180 x 66.
8.5 in. x 11 in. for portrait reports with dimensions of 102x85.
8.5 in. x 15 in. for portrait reports with dimensions of 102x116.

b. Click the Character Mode  tab and change pagesize.  Example:
for landscape reports, change width to 132 or 180, and height to 66.

c. Click the Use Character Units in Designer  checkbox.

d. If you are converting your report from an existing bitmap report, click Convert
Bitmapped Objects to Boxes  if you want to display rectangles in place of
bitmapped objects in your report.

e. Optionally, click Convert Borders , if you are converting a bitmap report and would
like to have large ASCII borders around bitmapped objects that display borders in bitmap
mode.
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2.  In the Object Navigator, double-click the MODE system parameter icon (under the Data
Model node).  In the MODE property sheet, set the Initial Value to Character.  This will ensure
that your report will always be run in character mode by default.

3. In the Layout Editor’s View menu, alter the following settings:
a. Switch Grid Snap on.  This will allow you to align new objects precisely with the
character cell grid in your layout.

b. Choose View->Options->Rulers to display Ruler Settings, and alter the Number of
Snap Points per Grid Spacing  to one.
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Appendix B: Tips and Techniques in Character-mode Design

As mentioned earlier, character mode reports tend to have objects that are harder to manipulate
since most objects are being mapped to the character grid. In this section, we will show you how
to manipulate objects in a character mode report.

This example illustrates how to add an additional data column (“manager”) into an existing
character mode report.

1) To create room for the new column, turn Flex mode ‘On’. Click the Flex button  in the

toolbar to toggle the mode until the icon looks like .

2) In your old layout, select the field F_HIREDATE and drag it to the right to create extra room
for your new column.

3) Select the column header HIREDATE, and the underline under HIREDATE and drag both to
the right as well.  [Hint: to select both of those objects, use shift-select, and be careful not to
select the surrounding group frames as well].

4) To turn Flex Mode “Off”,  click once on the flex icon  again until it looks like .

5) Duplicate the field F_JOB by clicking of F_JOB, then choose Edit->Duplicate.
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6) Doubleclick on the newly-created F_JOB1 and change it’s name to F_Manager, and its
source to MGR.  Click OK.

7) Drag the F_Manager field into the empty space in your old layout.  Make sure that it is aligned
with the repeating frame around it.

8) Run your report.
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Appendix C: Converting a Bitmap Report for Character Output
If you must convert a bitmap report to character output, try the following steps:

1) In the Reports designer, select File->Admin->Convert to display the following window:

2) As Source type, select RDF File.

3) As Destination Type, select RDF File.

4) For the Source field: click Browse to select a report, or type in the name of the report that you
would like to convert to bitmap.

5) Into the destination field, enter in the new name of your character report.  Note that this
process will create a new character mode report using your original bitmap report.  Your original
bitmap report will remain unchanged.
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5) Click on the Options Tab to display the following:

6) As your Destination Unit, select .  This will ensure that objects in your bitmap
report will be converted to character mode.

7) Click OK to create a new character report from your bitmap report.

8) Open your new character report in the Reports designer and run it.

9) After running your character report for the first time,  you may need to resize layout objects in
order to have them display properly in character mode.  Resize objects and rerun your report as
necessary until your report output looks satisfactory.
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Appendix D: Common Errors in Designing Character Mode Reports

REP-1219:  <object name> has not size -- length or width is zero:  The object that you have
converted to character mode is less than half the height or width of a character cell.  As a result,
Reports has mapped its size to zero during formatting.

Also, objects that are large, but are less than “halfway” between two grids will be shrunk to the
nearest grid coordinate during formatting.  This is often the cause of zero-sized or truncated
objects.

Example:

The boilerplate text “Sale” above will cause a REP-1219 error.

To remedy this problem, you can do one or both of the following:
a) increase the size of your object to be greater than half the height and width of a
character cell.
b) Move your object (horizontally/vertically) to correspond to the character grid.

“Cannot run character report in bitmapped designer “:  To fix this, just enter the Object
Navigator, open the MODE system parameter property sheet, and set the initial value to
character.  Run your report again.

Fields in your report output appear with “*******”: The field is currently too short in width to
accommodate your format mask.  Lengthen your field to fix this.
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Appendix E: Where to Look for More information

Developer/2000 Reports 2.5 Reference Manual (A32489-1)
Appendix A - pages. A-2 through A-3
Character Mode Output - page 1-31
Performance Advantages - page 17-17
Printer Codes Tab - pages 8-26 thru 8-27
Printer Definition Files - Appendix B

Developer/2000 Reports 2.5 Building Reports Manual (A32488-1)
Create Character Mode Reports pages 8-18 thru 8-20
Run and Print Character Mode Reports page 8-22

Oracle Worldwide Support Bulletins
Bulletin No. 108368.237 - (V2.0/2.5) Creating ASCII Text output in Oracle Reports
Bulletin No. 107332.325 - (V2) Oracle*Reports Character Mode and PRT files
Bulletin No. 108368.269 - (V2.5) Using the Oracle Reports ASCII Driver
Bulletin No. 108082.256 - Apple: Calling Reports Text Runtime from Forms


